QsUI Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AttributeTable | Classe che descrive il datasource bindato alla griglia.
Classe pubblica | AttributeTableRow | Classe che descrive una riga del datasource.
Classe pubblica | AttributeValueList | Classe che descrive una lista di valori collegata a un attributo.
Classe pubblica | AttributeValueListItem | Classe che descrive una riga della lista di valori.
Classe pubblica | AttrNameFromPromptEventArgs | EventArgs dell'evento AttrNameFromPromptEvent.
Classe pubblica | BrowseForFolderResult |
Classe pubblica | Cascade | Classe che descrive una cascata come lista di combinazioni.
Classe pubblica | CascadeDependency | Classe che descrive una combinazione di valori in una cascata.
Classe pubblica | CascadeValue | Cascata che descrive un valore figlio in una cascata.
Classe pubblica | ClassListFillEventArgs | EventArgs dell'evento ClassListFillEvent.
Classe pubblica | ClassListItemClickedEventArgs | EventArgs dell'evento ClassListItemClickedEvent.
Classe pubblica | ColumnOptions | Classe che descrive le opzioni aggiuntive che posso essere modificate per ogni colonna
Classe pubblica | DataSourceInitEventArgs | EventArgs dell'evento DataSourceInitEvent.
Classe pubblica | DlgCancOpForm | Classe per visualizzare una progress bar di avanzamento. Costruire il form e poi chiamare i vari metodi ( ci pensa lui a visualizzarsi e chiudersi quando parte e termina )
Classe pubblica | EditAttrControlBase | Controllo per visualizzare l'anagrafica
Classe pubblica | EditList |
Classe pubblica | EditListResult | Classe di risultato del dialogo EditList.
Classe pubblica | ElaborationReport |
Classe pubblica | ElaborationReportResultDescriptor | Oggetto descrittore del risultato dell'elaborazione
Classe pubblica | FilterEventArgs | Argomenti dell'evento FilterEvent.
Classe pubblica | FormAbout |
Classe pubblica | FormBarProg | Classe per visualizzare una progress bar di avanzamento. Costruire il form e poi chiamare i vari metodi ( ci pensa lui a visualizzarsi e chiudersi quando parte e termina )
Classe pubblica | FormException | Finestra di dialogo per visualizzare le eccezioni nel codice.
Classe pubblica | GetFileNameInResult |
Classe pubblica | GetFileNameOutResult |
Classe pubblica | InputBox | The InputBox class is used to show a prompt in a dialog box using the static method Show().
Classe pubblica | InputBoxResult | Class used to store the result of an InputBox.Show message.
Classe pubblica | InputBoxValidatingArgs | EventArgs used to Validate an InputBox
Classe pubblica | IsDirtyEventArgs | EventArgs dell'evento IsDirtyEvent.
Classe pubblica | LabelTextSetEventArgs | EventArgs dell'evento LabelTextSetEvent.
Classe pubblica | ListChoice | Classe che permette di visualizzare un form per scegliere gli elementi da una lista.
Classe pubblica | LolEditor |
Classe pubblica | LolEditorEditValueEventArgs | Fornisce dati relativi all'evento di editazione di una cella.
Classe pubblica | LolEditorRowColorEventArgs | Fornisce dati relativi all'evento di colorazione di una cella.
Classe pubblica | LolEditorSelectedRowChangedEventArgs | Fornisce dati relativi all'evento di cambio di selezione di una riga.
Classe pubblica | LuaExecuteForm |
Classe pubblica | LuaValidatingEventArgs | EventArgs dell'evento LuaValidatingEvent.
Classe pubblica | MessageBoxResult |
Classe pubblica | MyGridControl | Griglia custom che implementa l'override di OnPaint.
Classe pubblica | OkCancelControl | Classe che implementa il controllo di due bottoni ( ok , cancel )
Classe pubblica | OperationChoice |
Classe pubblica | OrderTabPagesEventArgs | EventArgs dell'evento OrderTabPagesEvent.
Classe pubblica | OverrideCustomDrawCellEventArgs | EventArgs dell'evento OverrideCustomDrawCellEvent.
Classe pubblica | OverrideImpostaStatoPulsantiEventArgs | EventArgs dell'evento OverrideImpostaStatoPulsantiEvent.
Classe pubblica | OverrideRowCellStyleEventArgs | EventArgs dell'evento OverrideRowCellStyleEvent.
Classe pubblica | OverrideValidatingEditorEventArgs | EventArgs dell'evento OverrideValidatingEditorEvent.
Classe pubblica | QsBaseForm |
Classe pubblica | QsException | Classe base per la gestione delle eccezioni.
Classe pubblica | QsExceptionList | Eccezione contenente una lista di eccezioni.
Classe pubblica | QsFileSelection |
Classe pubblica | QsUI |
Classe pubblica | QuestionForm | Finestra per mostrare un form con la possibilità di scegliere tra [Si-Si Tutti-No-No Tutti].
Classe pubblica | RepositoryBindEventArgs | EventArgs dell'evento RepositoryBindEvent.
Classe pubblica | RulesImagesChangeEventArgs | EventArgs dell'evento RulesImageChangeEvent.
Classe pubblica | SetAttrValueEventArgs | EventArgs dell'evento SetAttrValueEvent.
Classe pubblica | ThumbnailControl | Classe usata per ricavare l'anteprima di un file.
Classe pubblica | TreeListChoice |
Classe pubblica | TreeListChoiceCheckNodeEventArgs | Argomento contenente le informazioni relative al comando in esecuzione.
Classe pubblica | ValidateAttrEventArgs | EventArgs dell'evento ValidateAttrEvent.
Classe pubblica | WantDialogMessages |
Classe pubblica | WindowsThumbnailProvider |
Classe pubblica | WinToggles |
Classe pubblica | WinTogglesResult |
Strutture
 | Struttura | Descrizione
Struttura pubblica | WindowsThumbnailProviderRGBQUAD |
Delegate
 | Delegate | Descrizione
Delegate pubblico | ElaborationReportBoundDataOperationDelegate | Delegate per la personalizzazione del comportamento del form
Delegate pubblico | ElaborationReportExecuteOperationDelegate |
Delegate pubblico | ElaborationReportGetIdObjectDelegate |
Delegate pubblico | InputBoxValidatingHandler | Delegate used to Validate an InputBox
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DialogOperation | Operazione di aggiunta file. Specifica che tipo ti operazione è stata effettuata per aggiungere il file alla lista.
Enumerazione pubblica | ElaborationReportOperationStatus | Enumerazione dei possibili stati del risultato
Enumerazione pubblica | OperationChoiceOperationChoiceEnum | Enumerazione descrivente le operazione scelte da eseguire
Enumerazione pubblica | OperationChoiceQuestionButtonSet | Enumerazione dei pulsanti da visualizzare all'utente.
Enumerazione pubblica | QuestionFormQuestionButtonSet | Enumerazione dei pulsanti da visualizzare all'utente.
Enumerazione pubblica | QuestionFormQuestionResult | Enumerazione per la gestione dei risultati multipli.
Enumerazione pubblica | ThumbnailOptions |
Enumerazione pubblica | WantDialogMessagesFlags |
Enumerazione pubblica | WantDialogMessagesWindowsMessage |

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe AttributeTable
Classe che descrive il datasource bindato alla griglia.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList AttributeTableRow
QsUIAttributeTable

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AttributeTable : List<AttributeTableRow>
Public Class AttributeTable
    Inherits List(Of AttributeTableRow)
public ref class AttributeTable : public List<AttributeTableRow^>
type AttributeTable =
    class
        inherit List<AttributeTableRow>
    end

Il tipo AttributeTable espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeTable | Inizializza una nuova istanza della classe AttributeTable.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasDedAttr |
Proprietà pubblica | HasTopAttr | Restituisce se la collezione di attributi ne contiene almeno uno del TOP.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetRowFromName | Restituisce l'oggetto AttributeTableRow corrispondente al nome dell'attributo passato.
Metodo pubblico | GetValoriAttrPadri | Restituisce un dizionario che contiene le accoppiate Nome-Valore degli attributi padre dell'attributo passato.
Metodo pubblico | ValuePadreChanged | Metodo chiamato quando cambia il valore di un attributo. Controlla se l'attributo modificato fa parte di una cascata come padre, e in tal caso ricarica le tendine dei figli sulla base dei valori padre.
Torna su
Vedi anche

Documentazione

Namespace QsUI


Costruttore AttributeTable
Inizializza una nuova istanza della classe AttributeTable.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTable()
Public Sub New
public:
AttributeTable()
new : unit -> AttributeTable
Vedi anche

Documentazione

Classe AttributeTable


Proprietà di AttributeTable

Il tipo AttributeTable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasDedAttr |
Proprietà pubblica | HasTopAttr | Restituisce se la collezione di attributi ne contiene almeno uno del TOP.
Torna su
Vedi anche

Documentazione

Classe AttributeTable


Proprietà AttributeTable.HasDedAttr

Libreria interfaccie

Proprietà AttributeTableHasDedAttr

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDedAttr { get; }
Public ReadOnly Property HasDedAttr As Boolean
    Get
public:
property bool HasDedAttr {
    bool get ();
}
member HasDedAttr : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTable


Proprietà AttributeTable.HasTopAttr

Proprietà AttributeTableHasTopAttr
Restituisce se la collezione di attributi ne contiene almeno uno del TOP.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasTopAttr { get; }
Public ReadOnly Property HasTopAttr As Boolean
    Get
public:
property bool HasTopAttr {
    bool get ();
}
member HasTopAttr : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTable


Metodi di AttributeTable

Il tipo AttributeTable espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetRowFromName | Restituisce l'oggetto AttributeTableRow corrispondente al nome dell'attributo passato.
Metodo pubblico | GetValoriAttrPadri | Restituisce un dizionario che contiene le accoppiate Nome-Valore degli attributi padre dell'attributo passato.
Metodo pubblico | ValuePadreChanged | Metodo chiamato quando cambia il valore di un attributo. Controlla se l'attributo modificato fa parte di una cascata come padre, e in tal caso ricarica le tendine dei figli sulla base dei valori padre.
Torna su
Vedi anche

Documentazione

Classe AttributeTable


Metodo AttributeTable.GetRowFromName

Metodo AttributeTableGetRowFromName
Restituisce l'oggetto AttributeTableRow corrispondente al nome dell'attributo passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow GetRowFromName(
    string name
)
Public Function GetRowFromName (
    name As String
) As AttributeTableRow
public:
AttributeTableRow^ GetRowFromName(
    String^ name
)
member GetRowFromName :
        name : string -> AttributeTableRow

Parametri

name String
Nome dell'attributo.

Valore di ritorno

AttributeTableRow
Vedi anche

Documentazione

Classe AttributeTable


Metodo AttributeTable.GetValoriAttrPadri

Metodo AttributeTableGetValoriAttrPadri
Restituisce un dizionario che contiene le accoppiate Nome-Valore degli attributi padre dell'attributo passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> GetValoriAttrPadri(
    AttributeTableRow row
)
Public Function GetValoriAttrPadri (
    row As AttributeTableRow
) As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ GetValoriAttrPadri(
    AttributeTableRow^ row
)
member GetValoriAttrPadri :
        row : AttributeTableRow -> Dictionary<string, Object>

Parametri

row AttributeTableRow
Attributo di cui trovare i valori padre.

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe AttributeTable


Metodo AttributeTable.ValuePadreChanged

Metodo AttributeTableValuePadreChanged
Metodo chiamato quando cambia il valore di un attributo. Controlla se l'attributo modificato fa parte di una cascata come padre, e in tal caso ricarica le tendine dei figli sulla base dei valori padre.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ValuePadreChanged(
    AttributeTableRow changed
)
Public Sub ValuePadreChanged (
    changed As AttributeTableRow
)
public:
void ValuePadreChanged(
    AttributeTableRow^ changed
)
member ValuePadreChanged :
        changed : AttributeTableRow -> unit

Parametri

changed AttributeTableRow
Vedi anche

Documentazione

Classe AttributeTable


Classe AttributeTableRow
Classe che descrive una riga del datasource.
Gerarchia di ereditarietà
SystemObject
QsUIAttributeTableRow

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AttributeTableRow
Public Class AttributeTableRow
public ref class AttributeTableRow
type AttributeTableRow = class end

Il tipo AttributeTableRow espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeTableRow | Costruttore unico.
Metodo pubblico | AttributeTableRow(String, String, Object, Object, Type, Boolean) | Inizializza una nuova istanza della classe AttributeTableRow.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor | Colore di sfondo.
Proprietà pubblica | Cascade | Oggetto che descrive la cascata.
Proprietà pubblica | CascadeDisabled | Indica se disabilitare la gestione della cascata per questo attributo.
Proprietà pubblica | Category | Categoria.
Proprietà pubblica | DataType | Tipo del valore.
Proprietà pubblica | Font | Font da applicare alla cella valore dell'attributo.
Proprietà pubblica | ForeColor | Colore del testo.
Proprietà pubblica | Group | Gruppo dell'attributo.
Proprietà pubblica | HasValueList | Ritorna true se l'attributo ha una ValueList con almeno un elemento.
Proprietà pubblica | IsDedAttr |
Proprietà pubblica | IsLinkValue | Indica se il testo è un link.
Proprietà pubblica | IsTranslation | Indica se è una traduzione.
Proprietà pubblica | IsValid | Indica se l'attributo è valido (controllando il parametro Required e il valore dell'attributo).
Proprietà pubblica | ListType | Tipo di lista (facoltativa, obbligatoria, multiselezione).
Proprietà pubblica | MaxLen | Indica la lunghezza massima dell'attributo.
Proprietà pubblica | Multiline | Indica se il testo deve essere multilinea.
Proprietà pubblica | Nome | Nome interno dell'attributo.
Proprietà pubblica | Parent | Collezione a cui appartiene questo oggetto.
Proprietà pubblica | Prompt | Prompt dell'attributo.
Proprietà pubblica | ReadOnly | Indica se l'attributo è readonly.
Proprietà pubblica | Required | Indica se questo attributo è obbligatorio.
Proprietà pubblica | Tag |
Proprietà pubblica | Tooltip | Testo del tooltip.
Proprietà pubblica | TranslatedPrompt | Eventuale traduzione da visualizzare del prompt dell'attributo.
Proprietà pubblica | TranslationCode | Codice della traduzione.
Proprietà pubblica | Valore | Valore dell'attributo. NOTA : Da settare dopo aver impostato il campo DataType.
Proprietà pubblica | ValueList | Lista di valori collegata all'attributo.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AttributeTableRow
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AttributeTableRow | Costruttore unico.
Metodo pubblico | AttributeTableRow(String, String, Object, Object, Type, Boolean) | Inizializza una nuova istanza della classe AttributeTableRow.
Torna su
Vedi anche

Documentazione

Classe AttributeTableRow


Costruttore AttributeTableRow
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow()
Public Sub New
public:
AttributeTableRow()
new : unit -> AttributeTableRow
Vedi anche

Documentazione

Classe AttributeTableRow
Overload di AttributeTableRow


Costruttore AttributeTableRow(String, String, Object, Object, Type, Boolean)
Inizializza una nuova istanza della classe AttributeTableRow.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow(
    string name,
    string prompt,
    Object value,
    Object tag,
    Type type,
    bool isDedAttr
)
Public Sub New (
    name As String,
    prompt As String,
    value As Object,
    tag As Object,
    type As Type,
    isDedAttr As Boolean
)
public:
AttributeTableRow(
    String^ name,
    String^ prompt,
    Object^ value,
    Object^ tag,
    Type^ type,
    bool isDedAttr
)
new :
        name : string *
        prompt : string *
        value : Object *
        tag : Object *
        type : Type *
        isDedAttr : bool -> AttributeTableRow

Parametri

name String
prompt String
value Object
tag Object
type Type
isDedAttr Boolean
Vedi anche

Documentazione

Classe AttributeTableRow
Overload di AttributeTableRow


Proprietà di AttributeTableRow

Il tipo AttributeTableRow espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor | Colore di sfondo.
Proprietà pubblica | Cascade | Oggetto che descrive la cascata.
Proprietà pubblica | CascadeDisabled | Indica se disabilitare la gestione della cascata per questo attributo.
Proprietà pubblica | Category | Categoria.
Proprietà pubblica | DataType | Tipo del valore.
Proprietà pubblica | Font | Font da applicare alla cella valore dell'attributo.
Proprietà pubblica | ForeColor | Colore del testo.
Proprietà pubblica | Group | Gruppo dell'attributo.
Proprietà pubblica | HasValueList | Ritorna true se l'attributo ha una ValueList con almeno un elemento.
Proprietà pubblica | IsDedAttr |
Proprietà pubblica | IsLinkValue | Indica se il testo è un link.
Proprietà pubblica | IsTranslation | Indica se è una traduzione.
Proprietà pubblica | IsValid | Indica se l'attributo è valido (controllando il parametro Required e il valore dell'attributo).
Proprietà pubblica | ListType | Tipo di lista (facoltativa, obbligatoria, multiselezione).
Proprietà pubblica | MaxLen | Indica la lunghezza massima dell'attributo.
Proprietà pubblica | Multiline | Indica se il testo deve essere multilinea.
Proprietà pubblica | Nome | Nome interno dell'attributo.
Proprietà pubblica | Parent | Collezione a cui appartiene questo oggetto.
Proprietà pubblica | Prompt | Prompt dell'attributo.
Proprietà pubblica | ReadOnly | Indica se l'attributo è readonly.
Proprietà pubblica | Required | Indica se questo attributo è obbligatorio.
Proprietà pubblica | Tag |
Proprietà pubblica | Tooltip | Testo del tooltip.
Proprietà pubblica | TranslatedPrompt | Eventuale traduzione da visualizzare del prompt dell'attributo.
Proprietà pubblica | TranslationCode | Codice della traduzione.
Proprietà pubblica | Valore | Valore dell'attributo. NOTA : Da settare dopo aver impostato il campo DataType.
Proprietà pubblica | ValueList | Lista di valori collegata all'attributo.
Torna su
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.BackColor

Proprietà AttributeTableRowBackColor
Colore di sfondo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Cascade

Proprietà AttributeTableRowCascade
Oggetto che descrive la cascata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Cascade Cascade { get; set; }
Public Property Cascade As Cascade
    Get
    Set
public:
property Cascade^ Cascade {
    Cascade^ get ();
    void set (Cascade^ value);
}
member Cascade : Cascade with get, set

Valore della proprietà

Cascade
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.CascadeDisabled

Proprietà AttributeTableRowCascadeDisabled
Indica se disabilitare la gestione della cascata per questo attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CascadeDisabled { get; set; }
Public Property CascadeDisabled As Boolean
    Get
    Set
public:
property bool CascadeDisabled {
    bool get ();
    void set (bool value);
}
member CascadeDisabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Category

Proprietà AttributeTableRowCategory
Categoria.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.DataType

Proprietà AttributeTableRowDataType
Tipo del valore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Type DataType { get; set; }
Public Property DataType As Type
    Get
    Set
public:
property Type^ DataType {
    Type^ get ();
    void set (Type^ value);
}
member DataType : Type with get, set

Valore della proprietà

Type
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Font

Proprietà AttributeTableRowFont
Font da applicare alla cella valore dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set

Valore della proprietà

Font
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.ForeColor

Proprietà AttributeTableRowForeColor
Colore del testo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Group

Proprietà AttributeTableRowGroup
Gruppo dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.HasValueList

Proprietà AttributeTableRowHasValueList
Ritorna true se l'attributo ha una ValueList con almeno un elemento.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasValueList { get; }
Public ReadOnly Property HasValueList As Boolean
    Get
public:
property bool HasValueList {
    bool get ();
}
member HasValueList : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.IsDedAttr

Proprietà AttributeTableRowIsDedAttr

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDedAttr { get; set; }
Public Property IsDedAttr As Boolean
    Get
    Set
public:
property bool IsDedAttr {
    bool get ();
    void set (bool value);
}
member IsDedAttr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.IsLinkValue

Proprietà AttributeTableRowIsLinkValue
Indica se il testo è un link.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLinkValue { get; set; }
Public Property IsLinkValue As Boolean
    Get
    Set
public:
property bool IsLinkValue {
    bool get ();
    void set (bool value);
}
member IsLinkValue : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.IsTranslation

Proprietà AttributeTableRowIsTranslation
Indica se è una traduzione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTranslation { get; set; }
Public Property IsTranslation As Boolean
    Get
    Set
public:
property bool IsTranslation {
    bool get ();
    void set (bool value);
}
member IsTranslation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.IsValid

Proprietà AttributeTableRowIsValid
Indica se l'attributo è valido (controllando il parametro Required e il valore dell'attributo).

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.ListType

Proprietà AttributeTableRowListType
Tipo di lista (facoltativa, obbligatoria, multiselezione).

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ListType { get; set; }
Public Property ListType As String
    Get
    Set
public:
property String^ ListType {
    String^ get ();
    void set (String^ value);
}
member ListType : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.MaxLen

Proprietà AttributeTableRowMaxLen
Indica la lunghezza massima dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int MaxLen { get; set; }
Public Property MaxLen As Integer
    Get
    Set
public:
property int MaxLen {
    int get ();
    void set (int value);
}
member MaxLen : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Multiline

Proprietà AttributeTableRowMultiline
Indica se il testo deve essere multilinea.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multiline { get; set; }
Public Property Multiline As Boolean
    Get
    Set
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}
member Multiline : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Nome

Proprietà AttributeTableRowNome
Nome interno dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Parent

Proprietà AttributeTableRowParent
Collezione a cui appartiene questo oggetto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTable Parent { get; set; }
Public Property Parent As AttributeTable
    Get
    Set
public:
property AttributeTable^ Parent {
    AttributeTable^ get ();
    void set (AttributeTable^ value);
}
member Parent : AttributeTable with get, set

Valore della proprietà

AttributeTable
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Prompt

Proprietà AttributeTableRowPrompt
Prompt dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.ReadOnly

Proprietà AttributeTableRowReadOnly
Indica se l'attributo è readonly.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Required

Proprietà AttributeTableRowRequired
Indica se questo attributo è obbligatorio.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Required { get; set; }
Public Property Required As Boolean
    Get
    Set
public:
property bool Required {
    bool get ();
    void set (bool value);
}
member Required : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Tag

Proprietà AttributeTableRowTag

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
member Tag : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Tooltip

Proprietà AttributeTableRowTooltip
Testo del tooltip.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.TranslatedPrompt

Proprietà AttributeTableRowTranslatedPrompt
Eventuale traduzione da visualizzare del prompt dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string TranslatedPrompt { get; set; }
Public Property TranslatedPrompt As String
    Get
    Set
public:
property String^ TranslatedPrompt {
    String^ get ();
    void set (String^ value);
}
member TranslatedPrompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.TranslationCode

Proprietà AttributeTableRowTranslationCode
Codice della traduzione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string TranslationCode { get; set; }
Public Property TranslationCode As String
    Get
    Set
public:
property String^ TranslationCode {
    String^ get ();
    void set (String^ value);
}
member TranslationCode : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.Valore

Proprietà AttributeTableRowValore
Valore dell'attributo. NOTA : Da settare dopo aver impostato il campo DataType.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; set; }
Public Property Valore As Object
    Get
    Set
public:
property Object^ Valore {
    Object^ get ();
    void set (Object^ value);
}
member Valore : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe AttributeTableRow


Proprietà AttributeTableRow.ValueList

Proprietà AttributeTableRowValueList
Lista di valori collegata all'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeValueList ValueList { get; set; }
Public Property ValueList As AttributeValueList
    Get
    Set
public:
property AttributeValueList^ ValueList {
    AttributeValueList^ get ();
    void set (AttributeValueList^ value);
}
member ValueList : AttributeValueList with get, set

Valore della proprietà

AttributeValueList
Vedi anche

Documentazione

Classe AttributeTableRow


Classe AttributeValueList
Classe che descrive una lista di valori collegata a un attributo.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList AttributeValueListItem
QsUIAttributeValueList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AttributeValueList : List<AttributeValueListItem>
Public Class AttributeValueList
    Inherits List(Of AttributeValueListItem)
public ref class AttributeValueList : public List<AttributeValueListItem^>
type AttributeValueList =
    class
        inherit List<AttributeValueListItem>
    end

Il tipo AttributeValueList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeValueList | Costruttore unico.
Metodo pubblico | AttributeValueList(Boolean) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsCascade | Indica se è una lista temporanea creata per una cascata.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsValue | Ritorna True se la lista di valori contiene il valore passato.
Metodo pubblico | HasDescription | Restituisce True se almeno uno degli item della lista ha una descrizione.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AttributeValueList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AttributeValueList | Costruttore unico.
Metodo pubblico | AttributeValueList(Boolean) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe AttributeValueList


Costruttore AttributeValueList
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeValueList()
Public Sub New
public:
AttributeValueList()
new : unit -> AttributeValueList
Vedi anche

Documentazione

Classe AttributeValueList
Overload di AttributeValueList


Costruttore AttributeValueList(Boolean)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeValueList(
    bool isCascade
)
Public Sub New (
    isCascade As Boolean
)
public:
AttributeValueList(
    bool isCascade
)
new :
        isCascade : bool -> AttributeValueList

Parametri

isCascade Boolean
Indica se è una lista temporanea creata per una cascata.
Vedi anche

Documentazione

Classe AttributeValueList
Overload di AttributeValueList


Proprietà di AttributeValueList

Il tipo AttributeValueList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsCascade | Indica se è una lista temporanea creata per una cascata.
Torna su
Vedi anche

Documentazione

Classe AttributeValueList


Proprietà AttributeValueList.IsCascade

Proprietà AttributeValueListIsCascade
Indica se è una lista temporanea creata per una cascata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCascade { get; set; }
Public Property IsCascade As Boolean
    Get
    Set
public:
property bool IsCascade {
    bool get ();
    void set (bool value);
}
member IsCascade : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AttributeValueList


Metodi di AttributeValueList

Il tipo AttributeValueList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsValue | Ritorna True se la lista di valori contiene il valore passato.
Metodo pubblico | HasDescription | Restituisce True se almeno uno degli item della lista ha una descrizione.
Torna su
Vedi anche

Documentazione

Classe AttributeValueList


Metodo AttributeValueList.ContainsValue

Metodo AttributeValueListContainsValue
Ritorna True se la lista di valori contiene il valore passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsValue(
    Object value
)
Public Function ContainsValue (
    value As Object
) As Boolean
public:
bool ContainsValue(
    Object^ value
)
member ContainsValue :
        value : Object -> bool

Parametri

value Object
Valore da controllare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AttributeValueList


Metodo AttributeValueList.HasDescription

Metodo AttributeValueListHasDescription
Restituisce True se almeno uno degli item della lista ha una descrizione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDescription()
Public Function HasDescription As Boolean
public:
bool HasDescription()
member HasDescription : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AttributeValueList


Classe AttributeValueListItem
Classe che descrive una riga della lista di valori.
Gerarchia di ereditarietà
SystemObject
QsUIAttributeValueListItem

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AttributeValueListItem
Public Class AttributeValueListItem
public ref class AttributeValueListItem
type AttributeValueListItem = class end

Il tipo AttributeValueListItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeValueListItem(String) | Costruttore unico.
Metodo pubblico | AttributeValueListItem(String, String) | Costruttore unico.
Metodo pubblico | AttributeValueListItem(String, String, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AltValue | Valore alternativo.
Proprietà pubblica | Descrizione | Descrizione del valore.
Proprietà pubblica | Valore | Valore.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AttributeValueListItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AttributeValueListItem(String) | Costruttore unico.
Metodo pubblico | AttributeValueListItem(String, String) | Costruttore unico.
Metodo pubblico | AttributeValueListItem(String, String, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe AttributeValueListItem


Costruttore AttributeValueListItem(String)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeValueListItem(
    string value
)
Public Sub New (
    value As String
)
public:
AttributeValueListItem(
    String^ value
)
new :
        value : string -> AttributeValueListItem

Parametri

value String
Valore.
Vedi anche

Documentazione

Classe AttributeValueListItem
Overload di AttributeValueListItem


Costruttore AttributeValueListItem(String, String)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeValueListItem(
    string value,
    string description
)
Public Sub New (
    value As String,
    description As String
)
public:
AttributeValueListItem(
    String^ value,
    String^ description
)
new :
        value : string *
        description : string -> AttributeValueListItem

Parametri

value String
Valore.
description String
Descrizione del valore.
Vedi anche

Documentazione

Classe AttributeValueListItem
Overload di AttributeValueListItem


Costruttore AttributeValueListItem(String, String, String)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeValueListItem(
    string value,
    string description,
    string altvalue
)
Public Sub New (
    value As String,
    description As String,
    altvalue As String
)
public:
AttributeValueListItem(
    String^ value,
    String^ description,
    String^ altvalue
)
new :
        value : string *
        description : string *
        altvalue : string -> AttributeValueListItem

Parametri

value String
Valore.
description String
Descrizione del valore.
altvalue String
Valore alternativo.
Vedi anche

Documentazione

Classe AttributeValueListItem
Overload di AttributeValueListItem


Proprietà di AttributeValueListItem

Il tipo AttributeValueListItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AltValue | Valore alternativo.
Proprietà pubblica | Descrizione | Descrizione del valore.
Proprietà pubblica | Valore | Valore.
Torna su
Vedi anche

Documentazione

Classe AttributeValueListItem


Proprietà AttributeValueListItem.AltValue

Proprietà AttributeValueListItemAltValue
Valore alternativo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string AltValue { get; }
Public ReadOnly Property AltValue As String
    Get
public:
property String^ AltValue {
    String^ get ();
}
member AltValue : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeValueListItem


Proprietà AttributeValueListItem.Descrizione

Proprietà AttributeValueListItemDescrizione
Descrizione del valore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; }
Public ReadOnly Property Descrizione As String
    Get
public:
property String^ Descrizione {
    String^ get ();
}
member Descrizione : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeValueListItem


Proprietà AttributeValueListItem.Valore

Proprietà AttributeValueListItemValore
Valore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Valore { get; }
Public ReadOnly Property Valore As String
    Get
public:
property String^ Valore {
    String^ get ();
}
member Valore : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeValueListItem


Classe AttrNameFromPromptEventArgs
EventArgs dell'evento AttrNameFromPromptEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIAttrNameFromPromptEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AttrNameFromPromptEventArgs : EventArgs
Public Class AttrNameFromPromptEventArgs
    Inherits EventArgs
public ref class AttrNameFromPromptEventArgs : public EventArgs
type AttrNameFromPromptEventArgs =
    class
        inherit EventArgs
    end

Il tipo AttrNameFromPromptEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttrNameFromPromptEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name | Name dell'attributo
Proprietà pubblica | Prompt | Prompt dell'attributo da ricercare
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AttrNameFromPromptEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttrNameFromPromptEventArgs(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
AttrNameFromPromptEventArgs(
    String^ prompt
)
new :
        prompt : string -> AttrNameFromPromptEventArgs

Parametri

prompt String
Vedi anche

Documentazione

Classe AttrNameFromPromptEventArgs


Proprietà di AttrNameFromPromptEventArgs

Il tipo AttrNameFromPromptEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name | Name dell'attributo
Proprietà pubblica | Prompt | Prompt dell'attributo da ricercare
Torna su
Vedi anche

Documentazione

Classe AttrNameFromPromptEventArgs


Proprietà AttrNameFromPromptEventArgs.Name

Proprietà AttrNameFromPromptEventArgsName
Name dell'attributo

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttrNameFromPromptEventArgs


Proprietà AttrNameFromPromptEventArgs.Prompt

Proprietà AttrNameFromPromptEventArgsPrompt
Prompt dell'attributo da ricercare

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttrNameFromPromptEventArgs


Classe BrowseForFolderResult
Gerarchia di ereditarietà
SystemObject
QsUIBrowseForFolderResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class BrowseForFolderResult
Public Class BrowseForFolderResult
public ref class BrowseForFolderResult
type BrowseForFolderResult = class end

Il tipo BrowseForFolderResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BrowseForFolderResult | Inizializza una nuova istanza della classe BrowseForFolderResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | Name |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore BrowseForFolderResult
Inizializza una nuova istanza della classe BrowseForFolderResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public BrowseForFolderResult()
Public Sub New
public:
BrowseForFolderResult()
new : unit -> BrowseForFolderResult
Vedi anche

Documentazione

Classe BrowseForFolderResult


Campi di BrowseForFolderResult

Il tipo BrowseForFolderResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Name |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Classe BrowseForFolderResult


Campo BrowseForFolderResult.Name

Campo BrowseForFolderResultName

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Valore del campo

String
Vedi anche

Documentazione

Classe BrowseForFolderResult


Campo BrowseForFolderResult.OK

Campo BrowseForFolderResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe BrowseForFolderResult


Classe Cascade
Classe che descrive una cascata come lista di combinazioni.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList CascadeDependency
QsUICascade

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Cascade : List<CascadeDependency>
Public Class Cascade
    Inherits List(Of CascadeDependency)
public ref class Cascade : public List<CascadeDependency^>
type Cascade =
    class
        inherit List<CascadeDependency>
    end

Il tipo Cascade espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Cascade | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Figlio | Restituisce o imposta il nome del figlio.
Proprietà pubblica | Padri | Restituisce o imposta la lista (ordinata) dei nomi dei padri.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetMatchingValues | Restituisce tutti i valori che corrispondono ai padri passati.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore Cascade
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Cascade(
    List<string> padri,
    string figlio
)
Public Sub New (
    padri As List(Of String),
    figlio As String
)
public:
Cascade(
    List<String^>^ padri,
    String^ figlio
)
new :
        padri : List<string> *
        figlio : string -> Cascade

Parametri

padri List String
Nomi dei padri.
figlio String
Nome del figlio.
Vedi anche

Documentazione

Classe Cascade


Proprietà di Cascade

Il tipo Cascade espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Figlio | Restituisce o imposta il nome del figlio.
Proprietà pubblica | Padri | Restituisce o imposta la lista (ordinata) dei nomi dei padri.
Torna su
Vedi anche

Documentazione

Classe Cascade


Proprietà Cascade.Figlio

Proprietà CascadeFiglio
Restituisce o imposta il nome del figlio.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Figlio { get; set; }
Public Property Figlio As String
    Get
    Set
public:
property String^ Figlio {
    String^ get ();
    void set (String^ value);
}
member Figlio : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Cascade


Proprietà Cascade.Padri

Proprietà CascadePadri
Restituisce o imposta la lista (ordinata) dei nomi dei padri.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Padri { get; set; }
Public Property Padri As List(Of String)
    Get
    Set
public:
property List<String^>^ Padri {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Padri : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe Cascade


Metodi di Cascade

Il tipo Cascade espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetMatchingValues | Restituisce tutti i valori che corrispondono ai padri passati.
Torna su
Vedi anche

Documentazione

Classe Cascade


Metodo Cascade.GetMatchingValues

Metodo CascadeGetMatchingValues
Restituisce tutti i valori che corrispondono ai padri passati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<CascadeValue> GetMatchingValues(
    Dictionary<string, Object> padri,
    string anyValChar = "*",
    bool checkAnyValChar = false
)
Public Function GetMatchingValues (
    padri As Dictionary(Of String, Object),
    Optional anyValChar As String = "*",
    Optional checkAnyValChar As Boolean = false
) As List(Of CascadeValue)
public:
List<CascadeValue^>^ GetMatchingValues(
    Dictionary<String^, Object^>^ padri,
    String^ anyValChar = L"*",
    bool checkAnyValChar = false
)
member GetMatchingValues :
        padri : Dictionary<string, Object> *
        ?anyValChar : string *
        ?checkAnyValChar : bool
(* Defaults:
        let _anyValChar = defaultArg anyValChar "*"
        let _checkAnyValChar = defaultArg checkAnyValChar false
*)
-> List<CascadeValue>

Parametri

padri Dictionary String, Object
Dizionario che contiene le accoppiate NomePadre-Valore.
anyValChar String (Optional)
Carattere jolly.
checkAnyValChar Boolean (Optional)
Indica se controllare la presenza di valori con il carattere jolly.

Valore di ritorno

List CascadeValue
Vedi anche

Documentazione

Classe Cascade


Classe CascadeDependency
Classe che descrive una combinazione di valori in una cascata.
Gerarchia di ereditarietà
SystemObject
QsUICascadeDependency

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CascadeDependency
Public Class CascadeDependency
public ref class CascadeDependency
type CascadeDependency = class end

Il tipo CascadeDependency espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CascadeDependency | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Multival | Restituisce o imposta il flag multivalore.
Proprietà pubblica | Valfiglio | Restituisce o imposta il valore dell'attributo figlio.
Proprietà pubblica | Valpadre | Restituisce o imposta il valore degli attributi padre.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore CascadeDependency
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeDependency(
    Object valpadre,
    CascadeValue valfiglio
)
Public Sub New (
    valpadre As Object,
    valfiglio As CascadeValue
)
public:
CascadeDependency(
    Object^ valpadre,
    CascadeValue^ valfiglio
)
new :
        valpadre : Object *
        valfiglio : CascadeValue -> CascadeDependency

Parametri

valpadre Object
Valore padre.
valfiglio CascadeValue
Valore figlio.
Vedi anche

Documentazione

Classe CascadeDependency


Proprietà di CascadeDependency

Il tipo CascadeDependency espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Multival | Restituisce o imposta il flag multivalore.
Proprietà pubblica | Valfiglio | Restituisce o imposta il valore dell'attributo figlio.
Proprietà pubblica | Valpadre | Restituisce o imposta il valore degli attributi padre.
Torna su
Vedi anche

Documentazione

Classe CascadeDependency


Proprietà CascadeDependency.Multival

Proprietà CascadeDependencyMultival
Restituisce o imposta il flag multivalore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multival { get; set; }
Public Property Multival As Boolean
    Get
    Set
public:
property bool Multival {
    bool get ();
    void set (bool value);
}
member Multival : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CascadeDependency


Proprietà CascadeDependency.Valfiglio

Proprietà CascadeDependencyValfiglio
Restituisce o imposta il valore dell'attributo figlio.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeValue Valfiglio { get; set; }
Public Property Valfiglio As CascadeValue
    Get
    Set
public:
property CascadeValue^ Valfiglio {
    CascadeValue^ get ();
    void set (CascadeValue^ value);
}
member Valfiglio : CascadeValue with get, set

Valore della proprietà

CascadeValue
Vedi anche

Documentazione

Classe CascadeDependency


Proprietà CascadeDependency.Valpadre

Proprietà CascadeDependencyValpadre
Restituisce o imposta il valore degli attributi padre.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valpadre { get; set; }
Public Property Valpadre As Object
    Get
    Set
public:
property Object^ Valpadre {
    Object^ get ();
    void set (Object^ value);
}
member Valpadre : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe CascadeDependency


Classe CascadeValue
Cascata che descrive un valore figlio in una cascata.
Gerarchia di ereditarietà
SystemObject
QsUICascadeValue

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CascadeValue
Public Class CascadeValue
public ref class CascadeValue
type CascadeValue = class end

Il tipo CascadeValue espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CascadeValue | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Restituisce o imposta la descrizione del valore.
Proprietà pubblica | Valore | Restituisce o imposta il valore.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore CascadeValue
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeValue(
    Object value,
    string description
)
Public Sub New (
    value As Object,
    description As String
)
public:
CascadeValue(
    Object^ value,
    String^ description
)
new :
        value : Object *
        description : string -> CascadeValue

Parametri

value Object
Valore.
description String
Descrizione.
Vedi anche

Documentazione

Classe CascadeValue


Proprietà di CascadeValue

Il tipo CascadeValue espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Restituisce o imposta la descrizione del valore.
Proprietà pubblica | Valore | Restituisce o imposta il valore.
Torna su
Vedi anche

Documentazione

Classe CascadeValue


Proprietà CascadeValue.Descrizione

Proprietà CascadeValueDescrizione
Restituisce o imposta la descrizione del valore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CascadeValue


Proprietà CascadeValue.Valore

Proprietà CascadeValueValore
Restituisce o imposta il valore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; set; }
Public Property Valore As Object
    Get
    Set
public:
property Object^ Valore {
    Object^ get ();
    void set (Object^ value);
}
member Valore : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe CascadeValue


Classe ClassListFillEventArgs
EventArgs dell'evento ClassListFillEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIClassListFillEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ClassListFillEventArgs : EventArgs
Public Class ClassListFillEventArgs
    Inherits EventArgs
public ref class ClassListFillEventArgs : public EventArgs
type ClassListFillEventArgs =
    class
        inherit EventArgs
    end

Il tipo ClassListFillEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ClassListFillEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Menu | Menu contestuale.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ClassListFillEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ClassListFillEventArgs(
    GridViewMenu menu,
    Object attr
)
Public Sub New (
    menu As GridViewMenu,
    attr As Object
)
public:
ClassListFillEventArgs(
    GridViewMenu^ menu,
    Object^ attr
)
new :
        menu : GridViewMenu *
        attr : Object -> ClassListFillEventArgs

Parametri

menu GridViewMenu
Menu contestuale.
attr Object
Attributo.
Vedi anche

Documentazione

Classe ClassListFillEventArgs


Proprietà di ClassListFillEventArgs

Il tipo ClassListFillEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Menu | Menu contestuale.
Torna su
Vedi anche

Documentazione

Classe ClassListFillEventArgs


Proprietà ClassListFillEventArgs.Attr

Proprietà ClassListFillEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ClassListFillEventArgs


Proprietà ClassListFillEventArgs.Menu

Proprietà ClassListFillEventArgsMenu
Menu contestuale.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridViewMenu Menu { get; set; }
Public Property Menu As GridViewMenu
    Get
    Set
public:
property GridViewMenu^ Menu {
    GridViewMenu^ get ();
    void set (GridViewMenu^ value);
}
member Menu : GridViewMenu with get, set

Valore della proprietà

GridViewMenu
Vedi anche

Documentazione

Classe ClassListFillEventArgs


Classe ClassListItemClickedEventArgs
EventArgs dell'evento ClassListItemClickedEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIClassListItemClickedEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ClassListItemClickedEventArgs : EventArgs
Public Class ClassListItemClickedEventArgs
    Inherits EventArgs
public ref class ClassListItemClickedEventArgs : public EventArgs
type ClassListItemClickedEventArgs =
    class
        inherit EventArgs
    end

Il tipo ClassListItemClickedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ClassListItemClickedEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Item | Elemento selezionato.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ClassListItemClickedEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ClassListItemClickedEventArgs(
    DXMenuItem item
)
Public Sub New (
    item As DXMenuItem
)
public:
ClassListItemClickedEventArgs(
    DXMenuItem^ item
)
new :
        item : DXMenuItem -> ClassListItemClickedEventArgs

Parametri

item DXMenuItem
Elemento selezionato.
Vedi anche

Documentazione

Classe ClassListItemClickedEventArgs


Proprietà di ClassListItemClickedEventArgs

Il tipo ClassListItemClickedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Item | Elemento selezionato.
Torna su
Vedi anche

Documentazione

Classe ClassListItemClickedEventArgs


Proprietà ClassListItemClickedEventArgs.Item

Proprietà ClassListItemClickedEventArgsItem
Elemento selezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public DXMenuItem Item { get; }
Public ReadOnly Property Item As DXMenuItem
    Get
public:
property DXMenuItem^ Item {
    DXMenuItem^ get ();
}
member Item : DXMenuItem with get

Valore della proprietà

DXMenuItem
Vedi anche

Documentazione

Classe ClassListItemClickedEventArgs


Classe ColumnOptions
Classe che descrive le opzioni aggiuntive che posso essere modificate per ogni colonna
Gerarchia di ereditarietà
SystemObject
QsUIColumnOptions

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ColumnOptions
Public Class ColumnOptions
public ref class ColumnOptions
type ColumnOptions = class end

Il tipo ColumnOptions espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ColumnOptions | Inizializza una nuova istanza della classe ColumnOptions.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Editable | Imposta se le celle della colonna debbano essere editabili (true) oppure no (false)
Proprietà pubblica | Name | Nome della colonna
Proprietà pubblica | Tooltip | Testo che il tooltip deve mostrare
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ColumnOptions
Inizializza una nuova istanza della classe ColumnOptions.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ColumnOptions()
Public Sub New
public:
ColumnOptions()
new : unit -> ColumnOptions
Vedi anche

Documentazione

Classe ColumnOptions


Proprietà di ColumnOptions

Il tipo ColumnOptions espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Editable | Imposta se le celle della colonna debbano essere editabili (true) oppure no (false)
Proprietà pubblica | Name | Nome della colonna
Proprietà pubblica | Tooltip | Testo che il tooltip deve mostrare
Torna su
Vedi anche

Documentazione

Classe ColumnOptions


Proprietà ColumnOptions.Editable

Proprietà ColumnOptionsEditable
Imposta se le celle della colonna debbano essere editabili (true) oppure no (false)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ColumnOptions


Proprietà ColumnOptions.Name

Proprietà ColumnOptionsName
Nome della colonna

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ColumnOptions


Proprietà ColumnOptions.Tooltip

Proprietà ColumnOptionsTooltip
Testo che il tooltip deve mostrare

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ColumnOptions


Classe DataSourceInitEventArgs
EventArgs dell'evento DataSourceInitEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
QsUIDataSourceInitEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DataSourceInitEventArgs : HandledEventArgs
Public Class DataSourceInitEventArgs
    Inherits HandledEventArgs
public ref class DataSourceInitEventArgs : public HandledEventArgs
type DataSourceInitEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo DataSourceInitEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DataSourceInitEventArgs | Costruttore unico.
Metodo pubblico | DataSourceInitEventArgs(AttributeTable) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataSource | Datasource bindata alla griglia.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DataSourceInitEventArgs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DataSourceInitEventArgs | Costruttore unico.
Metodo pubblico | DataSourceInitEventArgs(AttributeTable) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe DataSourceInitEventArgs


Costruttore DataSourceInitEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public DataSourceInitEventArgs()
Public Sub New
public:
DataSourceInitEventArgs()
new : unit -> DataSourceInitEventArgs
Vedi anche

Documentazione

Classe DataSourceInitEventArgs
Overload di DataSourceInitEventArgs


Costruttore DataSourceInitEventArgs(AttributeTable)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public DataSourceInitEventArgs(
    AttributeTable ds
)
Public Sub New (
    ds As AttributeTable
)
public:
DataSourceInitEventArgs(
    AttributeTable^ ds
)
new :
        ds : AttributeTable -> DataSourceInitEventArgs

Parametri

ds AttributeTable
Oggetto datasource.
Vedi anche

Documentazione

Classe DataSourceInitEventArgs
Overload di DataSourceInitEventArgs


Proprietà di DataSourceInitEventArgs

Il tipo DataSourceInitEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataSource | Datasource bindata alla griglia.
Torna su
Vedi anche

Documentazione

Classe DataSourceInitEventArgs


Proprietà DataSourceInitEventArgs.DataSource

Proprietà DataSourceInitEventArgsDataSource
Datasource bindata alla griglia.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTable DataSource { get; set; }
Public Property DataSource As AttributeTable
    Get
    Set
public:
property AttributeTable^ DataSource {
    AttributeTable^ get ();
    void set (AttributeTable^ value);
}
member DataSource : AttributeTable with get, set

Valore della proprietà

AttributeTable
Vedi anche

Documentazione

Classe DataSourceInitEventArgs


Enumerazione DialogOperation
Operazione di aggiunta file. Specifica che tipo ti operazione è stata effettuata per aggiungere il file alla lista.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum DialogOperation
Public Enumeration DialogOperation
public enum class DialogOperation
type DialogOperation
Membri
Nome | Valore | Descrizione
Drop | 0 |
Init | 1 |
AddFolder | 2 |
AddFile | 3 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe DlgCancOpForm
Classe per visualizzare una progress bar di avanzamento. Costruire il form e poi chiamare i vari metodi ( ci pensa lui a visualizzarsi e chiudersi quando parte e termina )
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIDlgCancOpForm

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DlgCancOpForm : QsBaseForm
Public Class DlgCancOpForm
    Inherits QsBaseForm
public ref class DlgCancOpForm : public QsBaseForm
type DlgCancOpForm =
    class
        inherit QsBaseForm
    end

Il tipo DlgCancOpForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DlgCancOpForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Counter | Contatore del numero di step effettuati.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà pubblica | HasProg | Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | Max | Imposta o restituisce il limite massimo della progressbar.
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StepValue | Imposta o restituisce il valore dello step utilizzato dal metodo ProgressBarControl.PerformStep() per incrementare l'avanzamento.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | Close | Metodo richiamabile da Lua. Chiude la finestra di dialogo.
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | EnforceRefresh | Metodo richiamabile da Lua. Forza un refresh della finestra.
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo pubblico | isOpen | Metodo richiamabile da Lua. Indica se il dialogo non è stato annullato.
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo pubblico | Message | Metodo richiamabile da Lua. Permette di modificare il testo visualizzato dal dialogo.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo pubblico | Open | Metodo richiamabile da Lua. Apre la finestra che consente all'utente di interrompere l'operazione.
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo pubblico | Step | Metodo richiamabile da Lua. Manda avanti il progresso della barra di uno step.
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DlgCancOpForm
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public DlgCancOpForm()
Public Sub New
public:
DlgCancOpForm()
new : unit -> DlgCancOpForm
Vedi anche

Documentazione

Classe DlgCancOpForm


Proprietà di DlgCancOpForm

Il tipo DlgCancOpForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Counter | Contatore del numero di step effettuati.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà pubblica | HasProg | Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | Max | Imposta o restituisce il limite massimo della progressbar.
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StepValue | Imposta o restituisce il valore dello step utilizzato dal metodo ProgressBarControl.PerformStep() per incrementare l'avanzamento.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DlgCancOpForm


Proprietà DlgCancOpForm.Counter

Proprietà DlgCancOpFormCounter
Contatore del numero di step effettuati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Counter { get; set; }
Public Property Counter As Integer
    Get
    Set
public:
property int Counter {
    int get ();
    void set (int value);
}
member Counter : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DlgCancOpForm


Proprietà DlgCancOpForm.HasProg

Proprietà DlgCancOpFormHasProg
Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasProg { get; set; }
Public Property HasProg As Boolean
    Get
    Set
public:
property bool HasProg {
    bool get ();
    void set (bool value);
}
member HasProg : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DlgCancOpForm


Proprietà DlgCancOpForm.Max

Proprietà DlgCancOpFormMax
Imposta o restituisce il limite massimo della progressbar.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set
public:
property int Max {
    int get ();
    void set (int value);
}
member Max : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DlgCancOpForm


Proprietà DlgCancOpForm.StepValue

Proprietà DlgCancOpFormStepValue
Imposta o restituisce il valore dello step utilizzato dal metodo ProgressBarControl.PerformStep() per incrementare l'avanzamento.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int StepValue { get; set; }
Public Property StepValue As Integer
    Get
    Set
public:
property int StepValue {
    int get ();
    void set (int value);
}
member StepValue : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodi di DlgCancOpForm

Il tipo DlgCancOpForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | Close | Metodo richiamabile da Lua. Chiude la finestra di dialogo.
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | EnforceRefresh | Metodo richiamabile da Lua. Forza un refresh della finestra.
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo pubblico | isOpen | Metodo richiamabile da Lua. Indica se il dialogo non è stato annullato.
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo pubblico | Message | Metodo richiamabile da Lua. Permette di modificare il testo visualizzato dal dialogo.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo pubblico | Open | Metodo richiamabile da Lua. Apre la finestra che consente all'utente di interrompere l'operazione.
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo pubblico | Step | Metodo richiamabile da Lua. Manda avanti il progresso della barra di uno step.
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.Close

Metodo DlgCancOpFormClose
Metodo richiamabile da Lua. Chiude la finestra di dialogo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.Dispose

Metodo DlgCancOpFormDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.EnforceRefresh

Metodo DlgCancOpFormEnforceRefresh
Metodo richiamabile da Lua. Forza un refresh della finestra.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void EnforceRefresh()
Public Sub EnforceRefresh
public:
void EnforceRefresh()
member EnforceRefresh : unit -> unit
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.isOpen

Metodo DlgCancOpFormisOpen
Metodo richiamabile da Lua. Indica se il dialogo non è stato annullato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool? isOpen()
Public Function isOpen As Boolean?
public:
Nullable<bool> isOpen()
member isOpen : unit -> Nullable<bool>

Valore di ritorno

Nullable Boolean
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.Message

Metodo DlgCancOpFormMessage
Metodo richiamabile da Lua. Permette di modificare il testo visualizzato dal dialogo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Message(
    string msg = null
)
Public Sub Message (
    Optional msg As String = Nothing
)
public:
void Message(
    String^ msg = nullptr
)
member Message :
        ?msg : string
(* Defaults:
        let _msg = defaultArg msg null
*)
-> unit

Parametri

msg String (Optional)
Messaggio da visualizzare.
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.Open

Metodo DlgCancOpFormOpen
Metodo richiamabile da Lua. Apre la finestra che consente all'utente di interrompere l'operazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Open(
    bool topMostWindow = false,
    bool disableCancButton = false,
    string message = ""
)
Public Sub Open (
    Optional topMostWindow As Boolean = false,
    Optional disableCancButton As Boolean = false,
    Optional message As String = ""
)
public:
void Open(
    bool topMostWindow = false,
    bool disableCancButton = false,
    String^ message = L""
)
member Open :
        ?topMostWindow : bool *
        ?disableCancButton : bool *
        ?message : string
(* Defaults:
        let _topMostWindow = defaultArg topMostWindow false
        let _disableCancButton = defaultArg disableCancButton false
        let _message = defaultArg message ""
*)
-> unit

Parametri

topMostWindow Boolean (Optional)
Indica se è in primo piano o no.
disableCancButton Boolean (Optional)
Indica se visualizzare il pulsante di annulla o no.
message String (Optional)
Messaggio da mostrare.
Vedi anche

Documentazione

Classe DlgCancOpForm


Metodo DlgCancOpForm.Step

Metodo DlgCancOpFormStep
Metodo richiamabile da Lua. Manda avanti il progresso della barra di uno step.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Step(
    string msg = null
)
Public Sub Step (
    Optional msg As String = Nothing
)
public:
void Step(
    String^ msg = nullptr
)
member Step :
        ?msg : string
(* Defaults:
        let _msg = defaultArg msg null
*)
-> unit

Parametri

msg String (Optional)
Se non null, indica il messaggio da visualizzare.
Vedi anche

Documentazione

Classe DlgCancOpForm


Eventi di DlgCancOpForm

Il tipo DlgCancOpForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DlgCancOpForm


Campi di DlgCancOpForm

Il tipo DlgCancOpForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DlgCancOpForm


Classe EditAttrControlBase
Controllo per visualizzare l'anagrafica
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
QsUIEditAttrControlBase

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class EditAttrControlBase : XtraUserControl
Public Class EditAttrControlBase
    Inherits XtraUserControl
public ref class EditAttrControlBase : public XtraUserControl
type EditAttrControlBase =
    class
        inherit XtraUserControl
    end

Il tipo EditAttrControlBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EditAttrControlBase | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnyValChar | Imposta o restituisce il carattere che corrisponde a 'qualunque valore non presente nella cascata'. Quando tra i valori della cascata viene trovato questo carattere, viene escluso dalla lista e gestito nel caso in cui venga assegnato all'attributo un valore non gestito.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CascadeAutocomplete | Indica se autocompilare la tendina di un attributo associato a una cascata nel caso in cui la tendina contenga un solo valore.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ColumnNome | Restituisce la colonna Nome della griglia.
Proprietà pubblica | CtrTab | Ritorna l'XtraTabControl delle categorie.
Proprietà pubblica | DataSource | Lista bindata al controllo.
Proprietà pubblica | DbPathPicture | Restituisce il PictureEdit che mostra se ci sono regole collegate all'attributo selezionato.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | Editable | Proprietà per settare l'editabilità del controllo
Proprietà pubblica | EditAllConfButtonDefintion | Restituisce la definizione del pulsante Tutte le configurazioni.
Proprietà pubblica | EditAllConfButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Tutte le configurazioni.
Proprietà pubblica | EditAllConfButtonVisible | Restituisce o imposta la visibilità del pulsante Tutte le configurazioni.
Proprietà pubblica | EditAttrUpperize | Restituisce se forzare in maiuscolo i caratteri digitati nell'edita attributi. Di default è false.
Proprietà pubblica | EditButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Edita.
Proprietà pubblica | EditButtonVisible | Restituisce o imposta la visibilità del pulsante Edita.
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Grid | Restituisce l'albero/griglia.
Proprietà pubblica | GroupAttribute | Indica se raggruppare gli attributi in base al loro ambiente (utilizza la proprietà Env del datasource).
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsInitDataInEditMode | Proprietà che indica se l'InitData è stato chiamato in una fase di editazione attributi.
Proprietà pubblica | IsValid | Indica se è presente un errore negli attributi.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | NumCharMemo | Numero di caratteri oltre il quale usare un memoEdit.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PanelVisible | Restituisce o imposta la visibilità del pannello contenente i pulsanti.
Proprietà pubblica | PopupMenu | Restituisce il menù contestuale.
Proprietà pubblica | RefreshButtonDefintion | Restituisce o imposta la definizione del pulsante Refresh.
Proprietà pubblica | RefreshButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Refresh.
Proprietà pubblica | RefreshButtonVisible | Restituisce o imposta la visibilità del pulsante Aggiorna.
Proprietà pubblica | RegistryBaseDir | Radice della chiave delle impostazioni di registro.
Proprietà pubblica | ReloadButtonDefintion | Restituisce la definizione del pulsante Reload.
Proprietà pubblica | ReloadButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Reload.
Proprietà pubblica | ReloadButtonVisible | Restituisce o imposta la visibilità del pulsante Reload.
Proprietà pubblica | RepItems | Restituisce o imposta il dizionario contenente i repository dei vari attributi.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | ValidateAttr | Imposta se validare gli attributi compilati.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttrNameFromPrompt | Nome dell'attributo ricercato per prompt.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CategoryHasError | Ritorna se ci sono errori tra gli attributi della categoria passata.
Metodo protetto | classListItemClick | Evento chiamato sul click di un elemento del class List
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | DataSourceInit | Inizializza il controllo.
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
 | GetReadOnlyBackColor | Ritorna il colore 'ReadOnly' a seconda dello skin attualmente impostato.
Metodo pubblico | GetValue | Permette di leggere il valore di uno specifico attributo. Restituisce null se si specifica un attributo non esistente.
Metodo pubblico | HasError | Controlla se ci sono errori nella compilazione degli attibuti e visualizza un messaggio di errore in base all'opzione passata.
Metodo pubblico | ImpostaStatoPulsanti | Verifica ed imposta lo stato dei pulsanti in base alle proprietà del controllo.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo pubblico | IsDirty |
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnAttrNameFromPromptEvent | Fa scattare l'evento AttrNameFromPromptEvent
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnButtonCancelClick |
Metodo protetto | OnButtonEditClick |
Metodo protetto | OnButtonOkClick |
Metodo protetto | OnClassListFill | Fa scattare l'evento ClassListFillEvent.
Metodo protetto | OnClassListItemClicked | Fa scattare l'evento ClassListItemClickedEvent.
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDataInitDone | Fa scattare l'evento DataInitDoneEvent.
Metodo protetto | OnDataSourceInit | Fa scattare l'evento DataSourceInitEvent.
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnIsDirty | Fa scattare l'evento IsDirtyEvent.
Metodo protetto | OnLabelTextSet | Fa scattare l'evento LabelTextSetEvent.
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnLuaValidating | Fa scattare l'evento LuaValidatingEvent.
Metodo protetto | OnOrderTabPages | Fa scattare l'evento OrderTabPagesEvent.
Metodo protetto | OnOverrideCellValueChanged | Fa scattare l'evento OverrideCellValueChangedEvent.
Metodo protetto | OnOverrideCustomDrawCell | Fa scattare l'evento OverrideCustomDrawCellEvent.
Metodo protetto | OnOverrideImpostaStatoPulsanti | Fa scattare l'evento OverrideImpostaStatoPulsantiEvent.
Metodo protetto | OnOverrideRowCellStyle | Fa scattare l'evento OverrideRowCellStyleEvent.
Metodo protetto | OnOverrideValidatingEditor | Fa scattare l'evento OverrideValidatingEditorEvent.
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPopupOpening | Fa scattare l'evento PopupOpeningEvent.
Metodo protetto | OnPostButtonCancelClick |
Metodo protetto | OnPostButtonOkClick |
Metodo protetto | OnRepositoryBind | Fa scattare l'evento RepositoryBindEvent.
Metodo protetto | OnRulesImageChange | Fa scattare l'evento RulesImageChangeEvent.
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSetAttrValue | Fa scattare l'evento SetAttreValueEvent.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnValidateAttr | Fa scattare l'evento ValidateAttrEvent.
Metodo protetto | OnValueChanged |
Metodo pubblico | OverrideLabelTextCursor | Metodo che permette l'override del testo inserito in base al contenuto del controllo.
Metodo pubblico | PerformCancelClick |
Metodo pubblico | PerformEditClick |
Metodo pubblico | PerformOkClick |
Metodo pubblico | PerformPostCancelClick |
Metodo pubblico | PerformPostOkClick |
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetValue | Permette di impostare un valore di uno specifico attributo. Valida il valore prima di assegnarlo alla cella ed all'anagrafica.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | UpdateGridDataSource | Ricarica il datasource nella griglia per mostrare eventuali modifiche alla collezione.
Metodo pubblico | ValidateLuaEvent | Esegue evento lua per validare gli attributi. Restituisce true se sono validi altrimenti false.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AttrNameFromPromptEvent | Evento per sapere il nome dell'attributo cercato per prompt
Evento pubblico | ButtonCancelClick | Evento sul click del bottone Cancel.
Evento pubblico | ButtonEditClick | Evento sul click del bottone Edita.
Evento pubblico | ButtonOkClick | Evento sul click del bottone Ok.
Evento pubblico | ClassListFillEvent |
Evento pubblico | ClassListItemClickedEvent | Evento di click su un elemento del classlist.
Evento pubblico | DataInitDoneEvent | Evento di fine inizializzazione del datasource.
Evento pubblico | DataSourceInitEvent | Evento di inizializzazione del datasource.
Evento pubblico | IsDirtyEvent | Evento per sapere se il controllo è dirty.
Evento pubblico | LabelTextSetEvent | Evento di modifica del testo della Label di info.
Evento pubblico | LuaValidatingEvent | Evento di validazione tramite Lua.
Evento pubblico | OrderTabPagesEvent | Evento per riordinare le tab delle categorie.
Evento pubblico | OverrideCellValueChangedEvent | Evento di override dell'evento CellValueChanged.
Evento pubblico | OverrideCustomDrawCellEvent | Evento di override dell'evento CustomDrawCell
Evento pubblico | OverrideImpostaStatoPulsantiEvent | Evento di override del metodo ImpostaStatoPulsanti.
Evento pubblico | OverrideRowCellStyleEvent | Evento di override dell'evento RowCellStyle
Evento pubblico | OverrideValidatingEditorEvent | Evento di override dell'evento ValidatingEditor.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | PopupOpeningEvent | Evento di apertura del menù contestuale.
Evento pubblico | PostButtonCancelClick | Evento sul click del bottone Cancel.
Evento pubblico | PostButtonOkClick | Evento sul post click del bottone Ok (parte dopo ButtonOkClick) per gestire DED+TOP.
Evento pubblico | RepositoryBindEvent | Evento di binding del repository alla cella.
Evento pubblico | RulesImageChangeEvent | Evento di modifica dell'immagine dlle regole attributo.
Evento pubblico | SetAttrValueEvent | Evento di modifica del valore di un attributo.
Evento pubblico | ValidateAttrEvent | Evento di validazione di un attributo.
Evento pubblico | ValueChanged | Evento su avvenuta modifica del valore di un attributo.
Torna su
Campi
Nome | Descrizione
LISTTYPE_FACOLTATIVA |
LISTTYPE_MULTI |
LISTTYPE_OBBLIGATORIA |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore EditAttrControlBase
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public EditAttrControlBase()
Public Sub New
public:
EditAttrControlBase()
new : unit -> EditAttrControlBase
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà di EditAttrControlBase

Il tipo EditAttrControlBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnyValChar | Imposta o restituisce il carattere che corrisponde a 'qualunque valore non presente nella cascata'. Quando tra i valori della cascata viene trovato questo carattere, viene escluso dalla lista e gestito nel caso in cui venga assegnato all'attributo un valore non gestito.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CascadeAutocomplete | Indica se autocompilare la tendina di un attributo associato a una cascata nel caso in cui la tendina contenga un solo valore.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ColumnNome | Restituisce la colonna Nome della griglia.
Proprietà pubblica | CtrTab | Ritorna l'XtraTabControl delle categorie.
Proprietà pubblica | DataSource | Lista bindata al controllo.
Proprietà pubblica | DbPathPicture | Restituisce il PictureEdit che mostra se ci sono regole collegate all'attributo selezionato.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | Editable | Proprietà per settare l'editabilità del controllo
Proprietà pubblica | EditAllConfButtonDefintion | Restituisce la definizione del pulsante Tutte le configurazioni.
Proprietà pubblica | EditAllConfButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Tutte le configurazioni.
Proprietà pubblica | EditAllConfButtonVisible | Restituisce o imposta la visibilità del pulsante Tutte le configurazioni.
Proprietà pubblica | EditAttrUpperize | Restituisce se forzare in maiuscolo i caratteri digitati nell'edita attributi. Di default è false.
Proprietà pubblica | EditButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Edita.
Proprietà pubblica | EditButtonVisible | Restituisce o imposta la visibilità del pulsante Edita.
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Grid | Restituisce l'albero/griglia.
Proprietà pubblica | GroupAttribute | Indica se raggruppare gli attributi in base al loro ambiente (utilizza la proprietà Env del datasource).
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsInitDataInEditMode | Proprietà che indica se l'InitData è stato chiamato in una fase di editazione attributi.
Proprietà pubblica | IsValid | Indica se è presente un errore negli attributi.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | NumCharMemo | Numero di caratteri oltre il quale usare un memoEdit.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PanelVisible | Restituisce o imposta la visibilità del pannello contenente i pulsanti.
Proprietà pubblica | PopupMenu | Restituisce il menù contestuale.
Proprietà pubblica | RefreshButtonDefintion | Restituisce o imposta la definizione del pulsante Refresh.
Proprietà pubblica | RefreshButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Refresh.
Proprietà pubblica | RefreshButtonVisible | Restituisce o imposta la visibilità del pulsante Aggiorna.
Proprietà pubblica | RegistryBaseDir | Radice della chiave delle impostazioni di registro.
Proprietà pubblica | ReloadButtonDefintion | Restituisce la definizione del pulsante Reload.
Proprietà pubblica | ReloadButtonEnabled | Restituisce o imposta l'abilitazione del pulsante Reload.
Proprietà pubblica | ReloadButtonVisible | Restituisce o imposta la visibilità del pulsante Reload.
Proprietà pubblica | RepItems | Restituisce o imposta il dizionario contenente i repository dei vari attributi.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | ValidateAttr | Imposta se validare gli attributi compilati.
Torna su
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.AnyValChar

Proprietà EditAttrControlBaseAnyValChar
Imposta o restituisce il carattere che corrisponde a 'qualunque valore non presente nella cascata'. Quando tra i valori della cascata viene trovato questo carattere, viene escluso dalla lista e gestito nel caso in cui venga assegnato all'attributo un valore non gestito.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string AnyValChar { get; }
Public ReadOnly Property AnyValChar As String
    Get
public:
property String^ AnyValChar {
    String^ get ();
}
member AnyValChar : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.CascadeAutocomplete

Proprietà EditAttrControlBaseCascadeAutocomplete
Indica se autocompilare la tendina di un attributo associato a una cascata nel caso in cui la tendina contenga un solo valore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CascadeAutocomplete { get; set; }
Public Property CascadeAutocomplete As Boolean
    Get
    Set
public:
property bool CascadeAutocomplete {
    bool get ();
    void set (bool value);
}
member CascadeAutocomplete : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.ColumnNome

Proprietà EditAttrControlBaseColumnNome
Restituisce la colonna Nome della griglia.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridColumn ColumnNome { get; }
Public ReadOnly Property ColumnNome As GridColumn
    Get
public:
property GridColumn^ ColumnNome {
    GridColumn^ get ();
}
member ColumnNome : GridColumn with get

Valore della proprietà

GridColumn
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.CtrTab

Proprietà EditAttrControlBaseCtrTab
Ritorna l'XtraTabControl delle categorie.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public XtraTabControl CtrTab { get; }
Public ReadOnly Property CtrTab As XtraTabControl
    Get
public:
property XtraTabControl^ CtrTab {
    XtraTabControl^ get ();
}
member CtrTab : XtraTabControl with get

Valore della proprietà

XtraTabControl
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.DataSource

Proprietà EditAttrControlBaseDataSource
Lista bindata al controllo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTable DataSource { get; }
Public ReadOnly Property DataSource As AttributeTable
    Get
public:
property AttributeTable^ DataSource {
    AttributeTable^ get ();
}
member DataSource : AttributeTable with get

Valore della proprietà

AttributeTable
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.DbPathPicture

Proprietà EditAttrControlBaseDbPathPicture
Restituisce il PictureEdit che mostra se ci sono regole collegate all'attributo selezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public PictureEdit DbPathPicture { get; set; }
Public Property DbPathPicture As PictureEdit
    Get
    Set
public:
property PictureEdit^ DbPathPicture {
    PictureEdit^ get ();
    void set (PictureEdit^ value);
}
member DbPathPicture : PictureEdit with get, set

Valore della proprietà

PictureEdit
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.Editable

Proprietà EditAttrControlBaseEditable
Proprietà per settare l'editabilità del controllo

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.EditAllConfButtonDefintion

Proprietà EditAttrControlBaseEditAllConfButtonDefintion
Restituisce la definizione del pulsante Tutte le configurazioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CheckButton EditAllConfButtonDefintion { get; }
Public ReadOnly Property EditAllConfButtonDefintion As CheckButton
    Get
public:
property CheckButton^ EditAllConfButtonDefintion {
    CheckButton^ get ();
}
member EditAllConfButtonDefintion : CheckButton with get

Valore della proprietà

CheckButton
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.EditAllConfButtonEnabled

Proprietà EditAttrControlBaseEditAllConfButtonEnabled
Restituisce o imposta l'abilitazione del pulsante Tutte le configurazioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditAllConfButtonEnabled { get; set; }
Public Property EditAllConfButtonEnabled As Boolean
    Get
    Set
public:
property bool EditAllConfButtonEnabled {
    bool get ();
    void set (bool value);
}
member EditAllConfButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.EditAllConfButtonVisible

Proprietà EditAttrControlBaseEditAllConfButtonVisible
Restituisce o imposta la visibilità del pulsante Tutte le configurazioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditAllConfButtonVisible { get; set; }
Public Property EditAllConfButtonVisible As Boolean
    Get
    Set
public:
property bool EditAllConfButtonVisible {
    bool get ();
    void set (bool value);
}
member EditAllConfButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.EditAttrUpperize

Proprietà EditAttrControlBaseEditAttrUpperize
Restituisce se forzare in maiuscolo i caratteri digitati nell'edita attributi. Di default è false.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditAttrUpperize { get; set; }
Public Property EditAttrUpperize As Boolean
    Get
    Set
public:
property bool EditAttrUpperize {
    bool get ();
    void set (bool value);
}
member EditAttrUpperize : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.EditButtonEnabled

Proprietà EditAttrControlBaseEditButtonEnabled
Restituisce o imposta l'abilitazione del pulsante Edita.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditButtonEnabled { get; set; }
Public Property EditButtonEnabled As Boolean
    Get
    Set
public:
property bool EditButtonEnabled {
    bool get ();
    void set (bool value);
}
member EditButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.EditButtonVisible

Proprietà EditAttrControlBaseEditButtonVisible
Restituisce o imposta la visibilità del pulsante Edita.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditButtonVisible { get; set; }
Public Property EditButtonVisible As Boolean
    Get
    Set
public:
property bool EditButtonVisible {
    bool get ();
    void set (bool value);
}
member EditButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.Grid

Proprietà EditAttrControlBaseGrid
Restituisce l'albero/griglia.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl Grid { get; }
Public ReadOnly Property Grid As GridControl
    Get
public:
property GridControl^ Grid {
    GridControl^ get ();
}
member Grid : GridControl with get

Valore della proprietà

GridControl
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.GroupAttribute

Proprietà EditAttrControlBaseGroupAttribute
Indica se raggruppare gli attributi in base al loro ambiente (utilizza la proprietà Env del datasource).

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool GroupAttribute { get; set; }
Public Property GroupAttribute As Boolean
    Get
    Set
public:
property bool GroupAttribute {
    bool get ();
    void set (bool value);
}
member GroupAttribute : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.IsInitDataInEditMode

Proprietà EditAttrControlBaseIsInitDataInEditMode
Proprietà che indica se l'InitData è stato chiamato in una fase di editazione attributi.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInitDataInEditMode { get; set; }
Public Property IsInitDataInEditMode As Boolean
    Get
    Set
public:
property bool IsInitDataInEditMode {
    bool get ();
    void set (bool value);
}
member IsInitDataInEditMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.IsValid

Proprietà EditAttrControlBaseIsValid
Indica se è presente un errore negli attributi.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.NumCharMemo

Proprietà EditAttrControlBaseNumCharMemo
Numero di caratteri oltre il quale usare un memoEdit.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int NumCharMemo { get; set; }
Public Property NumCharMemo As Integer
    Get
    Set
public:
property int NumCharMemo {
    int get ();
    void set (int value);
}
member NumCharMemo : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.PanelVisible

Proprietà EditAttrControlBasePanelVisible
Restituisce o imposta la visibilità del pannello contenente i pulsanti.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool PanelVisible { get; set; }
Public Property PanelVisible As Boolean
    Get
    Set
public:
property bool PanelVisible {
    bool get ();
    void set (bool value);
}
member PanelVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.PopupMenu

Proprietà EditAttrControlBasePopupMenu
Restituisce il menù contestuale.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public PopupMenu PopupMenu { get; set; }
Public Property PopupMenu As PopupMenu
    Get
    Set
public:
property PopupMenu^ PopupMenu {
    PopupMenu^ get ();
    void set (PopupMenu^ value);
}
member PopupMenu : PopupMenu with get, set

Valore della proprietà

PopupMenu
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.RefreshButtonDefintion

Proprietà EditAttrControlBaseRefreshButtonDefintion
Restituisce o imposta la definizione del pulsante Refresh.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton RefreshButtonDefintion { get; }
Public ReadOnly Property RefreshButtonDefintion As SimpleButton
    Get
public:
property SimpleButton^ RefreshButtonDefintion {
    SimpleButton^ get ();
}
member RefreshButtonDefintion : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.RefreshButtonEnabled

Proprietà EditAttrControlBaseRefreshButtonEnabled
Restituisce o imposta l'abilitazione del pulsante Refresh.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshButtonEnabled { get; set; }
Public Property RefreshButtonEnabled As Boolean
    Get
    Set
public:
property bool RefreshButtonEnabled {
    bool get ();
    void set (bool value);
}
member RefreshButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.RefreshButtonVisible

Proprietà EditAttrControlBaseRefreshButtonVisible
Restituisce o imposta la visibilità del pulsante Aggiorna.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshButtonVisible { get; set; }
Public Property RefreshButtonVisible As Boolean
    Get
    Set
public:
property bool RefreshButtonVisible {
    bool get ();
    void set (bool value);
}
member RefreshButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.RegistryBaseDir

Proprietà EditAttrControlBaseRegistryBaseDir
Radice della chiave delle impostazioni di registro.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseDir { get; set; }
Public Property RegistryBaseDir As String
    Get
    Set
public:
property String^ RegistryBaseDir {
    String^ get ();
    void set (String^ value);
}
member RegistryBaseDir : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.ReloadButtonDefintion

Proprietà EditAttrControlBaseReloadButtonDefintion
Restituisce la definizione del pulsante Reload.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton ReloadButtonDefintion { get; }
Public ReadOnly Property ReloadButtonDefintion As SimpleButton
    Get
public:
property SimpleButton^ ReloadButtonDefintion {
    SimpleButton^ get ();
}
member ReloadButtonDefintion : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.ReloadButtonEnabled

Proprietà EditAttrControlBaseReloadButtonEnabled
Restituisce o imposta l'abilitazione del pulsante Reload.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReloadButtonEnabled { get; set; }
Public Property ReloadButtonEnabled As Boolean
    Get
    Set
public:
property bool ReloadButtonEnabled {
    bool get ();
    void set (bool value);
}
member ReloadButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.ReloadButtonVisible

Proprietà EditAttrControlBaseReloadButtonVisible
Restituisce o imposta la visibilità del pulsante Reload.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReloadButtonVisible { get; set; }
Public Property ReloadButtonVisible As Boolean
    Get
    Set
public:
property bool ReloadButtonVisible {
    bool get ();
    void set (bool value);
}
member ReloadButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.RepItems

Proprietà EditAttrControlBaseRepItems
Restituisce o imposta il dizionario contenente i repository dei vari attributi.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<Object, RepositoryItem> RepItems { get; set; }
Public Property RepItems As Dictionary(Of Object, RepositoryItem)
    Get
    Set
public:
property Dictionary<Object^, RepositoryItem^>^ RepItems {
    Dictionary<Object^, RepositoryItem^>^ get ();
    void set (Dictionary<Object^, RepositoryItem^>^ value);
}
member RepItems : Dictionary<Object, RepositoryItem> with get, set

Valore della proprietà

Dictionary Object, RepositoryItem
Vedi anche

Documentazione

Classe EditAttrControlBase


Proprietà EditAttrControlBase.ValidateAttr

Proprietà EditAttrControlBaseValidateAttr
Imposta se validare gli attributi compilati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateAttr { get; set; }
Public Property ValidateAttr As Boolean
    Get
    Set
public:
property bool ValidateAttr {
    bool get ();
    void set (bool value);
}
member ValidateAttr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodi di EditAttrControlBase

Il tipo EditAttrControlBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttrNameFromPrompt | Nome dell'attributo ricercato per prompt.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CategoryHasError | Ritorna se ci sono errori tra gli attributi della categoria passata.
Metodo protetto | classListItemClick | Evento chiamato sul click di un elemento del class List
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | DataSourceInit | Inizializza il controllo.
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
 | GetReadOnlyBackColor | Ritorna il colore 'ReadOnly' a seconda dello skin attualmente impostato.
Metodo pubblico | GetValue | Permette di leggere il valore di uno specifico attributo. Restituisce null se si specifica un attributo non esistente.
Metodo pubblico | HasError | Controlla se ci sono errori nella compilazione degli attibuti e visualizza un messaggio di errore in base all'opzione passata.
Metodo pubblico | ImpostaStatoPulsanti | Verifica ed imposta lo stato dei pulsanti in base alle proprietà del controllo.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo pubblico | IsDirty |
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnAttrNameFromPromptEvent | Fa scattare l'evento AttrNameFromPromptEvent
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnButtonCancelClick |
Metodo protetto | OnButtonEditClick |
Metodo protetto | OnButtonOkClick |
Metodo protetto | OnClassListFill | Fa scattare l'evento ClassListFillEvent.
Metodo protetto | OnClassListItemClicked | Fa scattare l'evento ClassListItemClickedEvent.
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDataInitDone | Fa scattare l'evento DataInitDoneEvent.
Metodo protetto | OnDataSourceInit | Fa scattare l'evento DataSourceInitEvent.
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnIsDirty | Fa scattare l'evento IsDirtyEvent.
Metodo protetto | OnLabelTextSet | Fa scattare l'evento LabelTextSetEvent.
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnLuaValidating | Fa scattare l'evento LuaValidatingEvent.
Metodo protetto | OnOrderTabPages | Fa scattare l'evento OrderTabPagesEvent.
Metodo protetto | OnOverrideCellValueChanged | Fa scattare l'evento OverrideCellValueChangedEvent.
Metodo protetto | OnOverrideCustomDrawCell | Fa scattare l'evento OverrideCustomDrawCellEvent.
Metodo protetto | OnOverrideImpostaStatoPulsanti | Fa scattare l'evento OverrideImpostaStatoPulsantiEvent.
Metodo protetto | OnOverrideRowCellStyle | Fa scattare l'evento OverrideRowCellStyleEvent.
Metodo protetto | OnOverrideValidatingEditor | Fa scattare l'evento OverrideValidatingEditorEvent.
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPopupOpening | Fa scattare l'evento PopupOpeningEvent.
Metodo protetto | OnPostButtonCancelClick |
Metodo protetto | OnPostButtonOkClick |
Metodo protetto | OnRepositoryBind | Fa scattare l'evento RepositoryBindEvent.
Metodo protetto | OnRulesImageChange | Fa scattare l'evento RulesImageChangeEvent.
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSetAttrValue | Fa scattare l'evento SetAttreValueEvent.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnValidateAttr | Fa scattare l'evento ValidateAttrEvent.
Metodo protetto | OnValueChanged |
Metodo pubblico | OverrideLabelTextCursor | Metodo che permette l'override del testo inserito in base al contenuto del controllo.
Metodo pubblico | PerformCancelClick |
Metodo pubblico | PerformEditClick |
Metodo pubblico | PerformOkClick |
Metodo pubblico | PerformPostCancelClick |
Metodo pubblico | PerformPostOkClick |
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetValue | Permette di impostare un valore di uno specifico attributo. Valida il valore prima di assegnarlo alla cella ed all'anagrafica.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | UpdateGridDataSource | Ricarica il datasource nella griglia per mostrare eventuali modifiche alla collezione.
Metodo pubblico | ValidateLuaEvent | Esegue evento lua per validare gli attributi. Restituisce true se sono validi altrimenti false.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.AttrNameFromPrompt

Metodo EditAttrControlBaseAttrNameFromPrompt
Nome dell'attributo ricercato per prompt.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string AttrNameFromPrompt(
    string prompt
)
Public Function AttrNameFromPrompt (
    prompt As String
) As String
public:
String^ AttrNameFromPrompt(
    String^ prompt
)
member AttrNameFromPrompt :
        prompt : string -> string

Parametri

prompt String

Valore di ritorno

String
Name dell'attributo
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.CategoryHasError

Metodo EditAttrControlBaseCategoryHasError
Ritorna se ci sono errori tra gli attributi della categoria passata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CategoryHasError(
    string category
)
Public Function CategoryHasError (
    category As String
) As Boolean
public:
bool CategoryHasError(
    String^ category
)
member CategoryHasError :
        category : string -> bool

Parametri

category String
Categoria da controllare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.classListItemClick

Metodo EditAttrControlBaseclassListItemClick
Evento chiamato sul click di un elemento del class List

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void classListItemClick(
    Object sender,
    EventArgs e
)
Protected Sub classListItemClick (
    sender As Object,
    e As EventArgs
)
protected:
void classListItemClick(
    Object^ sender,
    EventArgs^ e
)
member classListItemClick :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.DataSourceInit

Metodo EditAttrControlBaseDataSourceInit
Inizializza il controllo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void DataSourceInit()
Public Sub DataSourceInit
public:
void DataSourceInit()
member DataSourceInit : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.Dispose

Metodo EditAttrControlBaseDispose
Liberare le risorse in uso.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.GetReadOnlyBackColor

Metodo EditAttrControlBaseGetReadOnlyBackColor
Ritorna il colore 'ReadOnly' a seconda dello skin attualmente impostato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Color GetReadOnlyBackColor(
    ISupportLookAndFeel ctrl
)
Public Shared Function GetReadOnlyBackColor (
    ctrl As ISupportLookAndFeel
) As Color
public:
static Color GetReadOnlyBackColor(
    ISupportLookAndFeel^ ctrl
)
static member GetReadOnlyBackColor :
        ctrl : ISupportLookAndFeel -> Color

Parametri

ctrl ISupportLookAndFeel

Valore di ritorno

Color
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.GetValue

Metodo EditAttrControlBaseGetValue
Permette di leggere il valore di uno specifico attributo. Restituisce null se si specifica un attributo non esistente.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string attrName
)
Public Function GetValue (
    attrName As String
) As Object
public:
Object^ GetValue(
    String^ attrName
)
member GetValue :
        attrName : string -> Object

Parametri

attrName String
Nome dell'attributo del quale restituire il valore.

Valore di ritorno

Object
Valore dell'attributo.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.HasError

Metodo EditAttrControlBaseHasError
Controlla se ci sono errori nella compilazione degli attibuti e visualizza un messaggio di errore in base all'opzione passata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasError(
    bool silent
)
Public Function HasError (
    silent As Boolean
) As Boolean
public:
bool HasError(
    bool silent
)
member HasError :
        silent : bool -> bool

Parametri

silent Boolean
Indica se mostrare il messaggio di errore.

Valore di ritorno

Boolean
False se non sono presenti errori, altrimenti True.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.ImpostaStatoPulsanti

Metodo EditAttrControlBaseImpostaStatoPulsanti
Verifica ed imposta lo stato dei pulsanti in base alle proprietà del controllo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ImpostaStatoPulsanti()
Public Sub ImpostaStatoPulsanti
public:
void ImpostaStatoPulsanti()
member ImpostaStatoPulsanti : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.IsDirty

Metodo EditAttrControlBaseIsDirty

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty()
Public Function IsDirty As Boolean
public:
bool IsDirty()
member IsDirty : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnAttrNameFromPromptEvent

Metodo EditAttrControlBaseOnAttrNameFromPromptEvent
Fa scattare l'evento AttrNameFromPromptEvent

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAttrNameFromPromptEvent(
    Object sender,
    AttrNameFromPromptEventArgs e
)
Protected Friend Sub OnAttrNameFromPromptEvent (
    sender As Object,
    e As AttrNameFromPromptEventArgs
)
protected public:
void OnAttrNameFromPromptEvent(
    Object^ sender,
    AttrNameFromPromptEventArgs^ e
)
member OnAttrNameFromPromptEvent :
        sender : Object *
        e : AttrNameFromPromptEventArgs -> unit

Parametri

sender Object
e AttrNameFromPromptEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnButtonCancelClick

Metodo EditAttrControlBaseOnButtonCancelClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonCancelClick()
Protected Sub OnButtonCancelClick
protected:
void OnButtonCancelClick()
member OnButtonCancelClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnButtonEditClick

Metodo EditAttrControlBaseOnButtonEditClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonEditClick()
Protected Sub OnButtonEditClick
protected:
void OnButtonEditClick()
member OnButtonEditClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnButtonOkClick

Metodo EditAttrControlBaseOnButtonOkClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonOkClick()
Protected Sub OnButtonOkClick
protected:
void OnButtonOkClick()
member OnButtonOkClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnClassListFill

Metodo EditAttrControlBaseOnClassListFill
Fa scattare l'evento ClassListFillEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnClassListFill(
    Object sender,
    ClassListFillEventArgs e
)
Protected Friend Sub OnClassListFill (
    sender As Object,
    e As ClassListFillEventArgs
)
protected public:
void OnClassListFill(
    Object^ sender,
    ClassListFillEventArgs^ e
)
member OnClassListFill :
        sender : Object *
        e : ClassListFillEventArgs -> unit

Parametri

sender Object
e ClassListFillEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnClassListItemClicked

Metodo EditAttrControlBaseOnClassListItemClicked
Fa scattare l'evento ClassListItemClickedEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnClassListItemClicked(
    Object sender,
    ClassListItemClickedEventArgs e
)
Protected Friend Sub OnClassListItemClicked (
    sender As Object,
    e As ClassListItemClickedEventArgs
)
protected public:
void OnClassListItemClicked(
    Object^ sender,
    ClassListItemClickedEventArgs^ e
)
member OnClassListItemClicked :
        sender : Object *
        e : ClassListItemClickedEventArgs -> unit

Parametri

sender Object
e ClassListItemClickedEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnDataInitDone

Metodo EditAttrControlBaseOnDataInitDone
Fa scattare l'evento DataInitDoneEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDataInitDone(
    Object sender,
    EventArgs e
)
Protected Friend Sub OnDataInitDone (
    sender As Object,
    e As EventArgs
)
protected public:
void OnDataInitDone(
    Object^ sender,
    EventArgs^ e
)
member OnDataInitDone :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnDataSourceInit

Metodo EditAttrControlBaseOnDataSourceInit
Fa scattare l'evento DataSourceInitEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDataSourceInit(
    Object sender,
    DataSourceInitEventArgs e
)
Protected Friend Sub OnDataSourceInit (
    sender As Object,
    e As DataSourceInitEventArgs
)
protected public:
void OnDataSourceInit(
    Object^ sender,
    DataSourceInitEventArgs^ e
)
member OnDataSourceInit :
        sender : Object *
        e : DataSourceInitEventArgs -> unit

Parametri

sender Object
e DataSourceInitEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnIsDirty

Metodo EditAttrControlBaseOnIsDirty
Fa scattare l'evento IsDirtyEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnIsDirty(
    Object sender,
    IsDirtyEventArgs e
)
Protected Friend Sub OnIsDirty (
    sender As Object,
    e As IsDirtyEventArgs
)
protected public:
void OnIsDirty(
    Object^ sender,
    IsDirtyEventArgs^ e
)
member OnIsDirty :
        sender : Object *
        e : IsDirtyEventArgs -> unit

Parametri

sender Object
e IsDirtyEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnLabelTextSet

Metodo EditAttrControlBaseOnLabelTextSet
Fa scattare l'evento LabelTextSetEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnLabelTextSet(
    Object sender,
    LabelTextSetEventArgs e
)
Protected Friend Sub OnLabelTextSet (
    sender As Object,
    e As LabelTextSetEventArgs
)
protected public:
void OnLabelTextSet(
    Object^ sender,
    LabelTextSetEventArgs^ e
)
member OnLabelTextSet :
        sender : Object *
        e : LabelTextSetEventArgs -> unit

Parametri

sender Object
e LabelTextSetEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnLuaValidating

Metodo EditAttrControlBaseOnLuaValidating
Fa scattare l'evento LuaValidatingEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnLuaValidating(
    Object sender,
    LuaValidatingEventArgs e
)
Protected Friend Sub OnLuaValidating (
    sender As Object,
    e As LuaValidatingEventArgs
)
protected public:
void OnLuaValidating(
    Object^ sender,
    LuaValidatingEventArgs^ e
)
member OnLuaValidating :
        sender : Object *
        e : LuaValidatingEventArgs -> unit

Parametri

sender Object
e LuaValidatingEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnOrderTabPages

Metodo EditAttrControlBaseOnOrderTabPages
Fa scattare l'evento OrderTabPagesEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOrderTabPages(
    Object sender,
    OrderTabPagesEventArgs e
)
Protected Friend Sub OnOrderTabPages (
    sender As Object,
    e As OrderTabPagesEventArgs
)
protected public:
void OnOrderTabPages(
    Object^ sender,
    OrderTabPagesEventArgs^ e
)
member OnOrderTabPages :
        sender : Object *
        e : OrderTabPagesEventArgs -> unit

Parametri

sender Object
e OrderTabPagesEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnOverrideCellValueChanged

Metodo EditAttrControlBaseOnOverrideCellValueChanged
Fa scattare l'evento OverrideCellValueChangedEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideCellValueChanged(
    Object sender,
    CellValueChangedEventArgs e
)
Protected Friend Sub OnOverrideCellValueChanged (
    sender As Object,
    e As CellValueChangedEventArgs
)
protected public:
void OnOverrideCellValueChanged(
    Object^ sender,
    CellValueChangedEventArgs^ e
)
member OnOverrideCellValueChanged :
        sender : Object *
        e : CellValueChangedEventArgs -> unit

Parametri

sender Object
e CellValueChangedEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnOverrideCustomDrawCell

Metodo EditAttrControlBaseOnOverrideCustomDrawCell
Fa scattare l'evento OverrideCustomDrawCellEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideCustomDrawCell(
    Object sender,
    OverrideCustomDrawCellEventArgs e
)
Protected Friend Sub OnOverrideCustomDrawCell (
    sender As Object,
    e As OverrideCustomDrawCellEventArgs
)
protected public:
void OnOverrideCustomDrawCell(
    Object^ sender,
    OverrideCustomDrawCellEventArgs^ e
)
member OnOverrideCustomDrawCell :
        sender : Object *
        e : OverrideCustomDrawCellEventArgs -> unit

Parametri

sender Object
e OverrideCustomDrawCellEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnOverrideImpostaStatoPulsanti

Metodo EditAttrControlBaseOnOverrideImpostaStatoPulsanti
Fa scattare l'evento OverrideImpostaStatoPulsantiEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideImpostaStatoPulsanti(
    Object sender,
    OverrideImpostaStatoPulsantiEventArgs e
)
Protected Friend Sub OnOverrideImpostaStatoPulsanti (
    sender As Object,
    e As OverrideImpostaStatoPulsantiEventArgs
)
protected public:
void OnOverrideImpostaStatoPulsanti(
    Object^ sender,
    OverrideImpostaStatoPulsantiEventArgs^ e
)
member OnOverrideImpostaStatoPulsanti :
        sender : Object *
        e : OverrideImpostaStatoPulsantiEventArgs -> unit

Parametri

sender Object
e OverrideImpostaStatoPulsantiEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnOverrideRowCellStyle

Metodo EditAttrControlBaseOnOverrideRowCellStyle
Fa scattare l'evento OverrideRowCellStyleEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideRowCellStyle(
    Object sender,
    OverrideRowCellStyleEventArgs e
)
Protected Friend Sub OnOverrideRowCellStyle (
    sender As Object,
    e As OverrideRowCellStyleEventArgs
)
protected public:
void OnOverrideRowCellStyle(
    Object^ sender,
    OverrideRowCellStyleEventArgs^ e
)
member OnOverrideRowCellStyle :
        sender : Object *
        e : OverrideRowCellStyleEventArgs -> unit

Parametri

sender Object
e OverrideRowCellStyleEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnOverrideValidatingEditor

Metodo EditAttrControlBaseOnOverrideValidatingEditor
Fa scattare l'evento OverrideValidatingEditorEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideValidatingEditor(
    Object sender,
    OverrideValidatingEditorEventArgs e
)
Protected Friend Sub OnOverrideValidatingEditor (
    sender As Object,
    e As OverrideValidatingEditorEventArgs
)
protected public:
void OnOverrideValidatingEditor(
    Object^ sender,
    OverrideValidatingEditorEventArgs^ e
)
member OnOverrideValidatingEditor :
        sender : Object *
        e : OverrideValidatingEditorEventArgs -> unit

Parametri

sender Object
e OverrideValidatingEditorEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnPopupOpening

Metodo EditAttrControlBaseOnPopupOpening
Fa scattare l'evento PopupOpeningEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnPopupOpening(
    Object sender,
    CancelEventArgs e
)
Protected Friend Sub OnPopupOpening (
    sender As Object,
    e As CancelEventArgs
)
protected public:
void OnPopupOpening(
    Object^ sender,
    CancelEventArgs^ e
)
member OnPopupOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnPostButtonCancelClick

Metodo EditAttrControlBaseOnPostButtonCancelClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnPostButtonCancelClick()
Protected Sub OnPostButtonCancelClick
protected:
void OnPostButtonCancelClick()
member OnPostButtonCancelClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnPostButtonOkClick

Metodo EditAttrControlBaseOnPostButtonOkClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnPostButtonOkClick()
Protected Sub OnPostButtonOkClick
protected:
void OnPostButtonOkClick()
member OnPostButtonOkClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnRepositoryBind

Metodo EditAttrControlBaseOnRepositoryBind
Fa scattare l'evento RepositoryBindEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRepositoryBind(
    Object sender,
    RepositoryBindEventArgs e
)
Protected Friend Sub OnRepositoryBind (
    sender As Object,
    e As RepositoryBindEventArgs
)
protected public:
void OnRepositoryBind(
    Object^ sender,
    RepositoryBindEventArgs^ e
)
member OnRepositoryBind :
        sender : Object *
        e : RepositoryBindEventArgs -> unit

Parametri

sender Object
e RepositoryBindEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnRulesImageChange

Metodo EditAttrControlBaseOnRulesImageChange
Fa scattare l'evento RulesImageChangeEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRulesImageChange(
    Object sender,
    RulesImagesChangeEventArgs e
)
Protected Friend Sub OnRulesImageChange (
    sender As Object,
    e As RulesImagesChangeEventArgs
)
protected public:
void OnRulesImageChange(
    Object^ sender,
    RulesImagesChangeEventArgs^ e
)
member OnRulesImageChange :
        sender : Object *
        e : RulesImagesChangeEventArgs -> unit

Parametri

sender Object
e RulesImagesChangeEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnSetAttrValue

Metodo EditAttrControlBaseOnSetAttrValue
Fa scattare l'evento SetAttreValueEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnSetAttrValue(
    Object sender,
    SetAttrValueEventArgs e
)
Protected Friend Sub OnSetAttrValue (
    sender As Object,
    e As SetAttrValueEventArgs
)
protected public:
void OnSetAttrValue(
    Object^ sender,
    SetAttrValueEventArgs^ e
)
member OnSetAttrValue :
        sender : Object *
        e : SetAttrValueEventArgs -> unit

Parametri

sender Object
e SetAttrValueEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnValidateAttr

Metodo EditAttrControlBaseOnValidateAttr
Fa scattare l'evento ValidateAttrEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnValidateAttr(
    Object sender,
    ValidateAttrEventArgs e
)
Protected Friend Sub OnValidateAttr (
    sender As Object,
    e As ValidateAttrEventArgs
)
protected public:
void OnValidateAttr(
    Object^ sender,
    ValidateAttrEventArgs^ e
)
member OnValidateAttr :
        sender : Object *
        e : ValidateAttrEventArgs -> unit

Parametri

sender Object
e ValidateAttrEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OnValueChanged

Metodo EditAttrControlBaseOnValueChanged

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnValueChanged()
Protected Sub OnValueChanged
protected:
void OnValueChanged()
member OnValueChanged : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.OverrideLabelTextCursor

Metodo EditAttrControlBaseOverrideLabelTextCursor
Metodo che permette l'override del testo inserito in base al contenuto del controllo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void OverrideLabelTextCursor(
    string infoTxt
)
Public Sub OverrideLabelTextCursor (
    infoTxt As String
)
public:
void OverrideLabelTextCursor(
    String^ infoTxt
)
member OverrideLabelTextCursor :
        infoTxt : string -> unit

Parametri

infoTxt String
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.PerformCancelClick

Metodo EditAttrControlBasePerformCancelClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformCancelClick()
Public Sub PerformCancelClick
public:
void PerformCancelClick()
member PerformCancelClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.PerformEditClick

Metodo EditAttrControlBasePerformEditClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformEditClick()
Public Sub PerformEditClick
public:
void PerformEditClick()
member PerformEditClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.PerformOkClick

Metodo EditAttrControlBasePerformOkClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformOkClick()
Public Sub PerformOkClick
public:
void PerformOkClick()
member PerformOkClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.PerformPostCancelClick

Metodo EditAttrControlBasePerformPostCancelClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformPostCancelClick()
Public Sub PerformPostCancelClick
public:
void PerformPostCancelClick()
member PerformPostCancelClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.PerformPostOkClick

Metodo EditAttrControlBasePerformPostOkClick

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformPostOkClick()
Public Sub PerformPostOkClick
public:
void PerformPostOkClick()
member PerformPostOkClick : unit -> unit
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.RestoreLayoutFromRegistry

Metodo EditAttrControlBaseRestoreLayoutFromRegistry
Ripristina il layout del controllo leggendolo dal registro di sistema.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey String
Path della chiave da cui leggere il layout.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.SaveLayoutToRegistry

Metodo EditAttrControlBaseSaveLayoutToRegistry
Salva il layout del controllo nel registro di sistema.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey String
Path della chiave dove salvare il layout.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.SetValue

Metodo EditAttrControlBaseSetValue
Permette di impostare un valore di uno specifico attributo. Valida il valore prima di assegnarlo alla cella ed all'anagrafica.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool SetValue(
    string attrName,
    Object value
)
Public Function SetValue (
    attrName As String,
    value As Object
) As Boolean
public:
bool SetValue(
    String^ attrName,
    Object^ value
)
member SetValue :
        attrName : string *
        value : Object -> bool

Parametri

attrName String
Nome dell'attributo del quale modificare il valore.
value Object
Valore da impostare.

Valore di ritorno

Boolean
Restituisce True se risesce ad impostare il valore, altrimenti False.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.UpdateGridDataSource

Metodo EditAttrControlBaseUpdateGridDataSource
Ricarica il datasource nella griglia per mostrare eventuali modifiche alla collezione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void UpdateGridDataSource(
    AttributeTable collection
)
Protected Friend Sub UpdateGridDataSource (
    collection As AttributeTable
)
protected public:
void UpdateGridDataSource(
    AttributeTable^ collection
)
member UpdateGridDataSource :
        collection : AttributeTable -> unit

Parametri

collection AttributeTable
Collezione da bindare alla griglia.
Vedi anche

Documentazione

Classe EditAttrControlBase


Metodo EditAttrControlBase.ValidateLuaEvent

Metodo EditAttrControlBaseValidateLuaEvent
Esegue evento lua per validare gli attributi. Restituisce true se sono validi altrimenti false.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateLuaEvent(
    bool silent
)
Public Function ValidateLuaEvent (
    silent As Boolean
) As Boolean
public:
bool ValidateLuaEvent(
    bool silent
)
member ValidateLuaEvent :
        silent : bool -> bool

Parametri

silent Boolean

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditAttrControlBase


Eventi di EditAttrControlBase

Il tipo EditAttrControlBase espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AttrNameFromPromptEvent | Evento per sapere il nome dell'attributo cercato per prompt
Evento pubblico | ButtonCancelClick | Evento sul click del bottone Cancel.
Evento pubblico | ButtonEditClick | Evento sul click del bottone Edita.
Evento pubblico | ButtonOkClick | Evento sul click del bottone Ok.
Evento pubblico | ClassListFillEvent |
Evento pubblico | ClassListItemClickedEvent | Evento di click su un elemento del classlist.
Evento pubblico | DataInitDoneEvent | Evento di fine inizializzazione del datasource.
Evento pubblico | DataSourceInitEvent | Evento di inizializzazione del datasource.
Evento pubblico | IsDirtyEvent | Evento per sapere se il controllo è dirty.
Evento pubblico | LabelTextSetEvent | Evento di modifica del testo della Label di info.
Evento pubblico | LuaValidatingEvent | Evento di validazione tramite Lua.
Evento pubblico | OrderTabPagesEvent | Evento per riordinare le tab delle categorie.
Evento pubblico | OverrideCellValueChangedEvent | Evento di override dell'evento CellValueChanged.
Evento pubblico | OverrideCustomDrawCellEvent | Evento di override dell'evento CustomDrawCell
Evento pubblico | OverrideImpostaStatoPulsantiEvent | Evento di override del metodo ImpostaStatoPulsanti.
Evento pubblico | OverrideRowCellStyleEvent | Evento di override dell'evento RowCellStyle
Evento pubblico | OverrideValidatingEditorEvent | Evento di override dell'evento ValidatingEditor.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | PopupOpeningEvent | Evento di apertura del menù contestuale.
Evento pubblico | PostButtonCancelClick | Evento sul click del bottone Cancel.
Evento pubblico | PostButtonOkClick | Evento sul post click del bottone Ok (parte dopo ButtonOkClick) per gestire DED+TOP.
Evento pubblico | RepositoryBindEvent | Evento di binding del repository alla cella.
Evento pubblico | RulesImageChangeEvent | Evento di modifica dell'immagine dlle regole attributo.
Evento pubblico | SetAttrValueEvent | Evento di modifica del valore di un attributo.
Evento pubblico | ValidateAttrEvent | Evento di validazione di un attributo.
Evento pubblico | ValueChanged | Evento su avvenuta modifica del valore di un attributo.
Torna su
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.AttrNameFromPromptEvent

Evento EditAttrControlBaseAttrNameFromPromptEvent
Evento per sapere il nome dell'attributo cercato per prompt

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<AttrNameFromPromptEventArgs> AttrNameFromPromptEvent
Public Event AttrNameFromPromptEvent As EventHandler(Of AttrNameFromPromptEventArgs)
public:
 event EventHandler<AttrNameFromPromptEventArgs^>^ AttrNameFromPromptEvent {
    void add (EventHandler<AttrNameFromPromptEventArgs^>^ value);
    void remove (EventHandler<AttrNameFromPromptEventArgs^>^ value);
}
member AttrNameFromPromptEvent : IEvent<EventHandler<AttrNameFromPromptEventArgs>,
    AttrNameFromPromptEventArgs>

Valore

EventHandler AttrNameFromPromptEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ButtonCancelClick

Evento EditAttrControlBaseButtonCancelClick
Evento sul click del bottone Cancel.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ButtonCancelClick
Public Event ButtonCancelClick As EventHandler
public:
 event EventHandler^ ButtonCancelClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ButtonCancelClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ButtonEditClick

Evento EditAttrControlBaseButtonEditClick
Evento sul click del bottone Edita.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ButtonEditClick
Public Event ButtonEditClick As EventHandler
public:
 event EventHandler^ ButtonEditClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ButtonEditClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ButtonOkClick

Evento EditAttrControlBaseButtonOkClick
Evento sul click del bottone Ok.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ButtonOkClick
Public Event ButtonOkClick As EventHandler
public:
 event EventHandler^ ButtonOkClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ButtonOkClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ClassListFillEvent

Evento EditAttrControlBaseClassListFillEvent

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ClassListFillEventArgs> ClassListFillEvent
Public Event ClassListFillEvent As EventHandler(Of ClassListFillEventArgs)
public:
 event EventHandler<ClassListFillEventArgs^>^ ClassListFillEvent {
    void add (EventHandler<ClassListFillEventArgs^>^ value);
    void remove (EventHandler<ClassListFillEventArgs^>^ value);
}
member ClassListFillEvent : IEvent<EventHandler<ClassListFillEventArgs>,
    ClassListFillEventArgs>

Valore

EventHandler ClassListFillEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ClassListItemClickedEvent

Evento EditAttrControlBaseClassListItemClickedEvent
Evento di click su un elemento del classlist.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ClassListItemClickedEventArgs> ClassListItemClickedEvent
Public Event ClassListItemClickedEvent As EventHandler(Of ClassListItemClickedEventArgs)
public:
 event EventHandler<ClassListItemClickedEventArgs^>^ ClassListItemClickedEvent {
    void add (EventHandler<ClassListItemClickedEventArgs^>^ value);
    void remove (EventHandler<ClassListItemClickedEventArgs^>^ value);
}
member ClassListItemClickedEvent : IEvent<EventHandler<ClassListItemClickedEventArgs>,
    ClassListItemClickedEventArgs>

Valore

EventHandler ClassListItemClickedEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.DataInitDoneEvent

Evento EditAttrControlBaseDataInitDoneEvent
Evento di fine inizializzazione del datasource.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler DataInitDoneEvent
Public Event DataInitDoneEvent As EventHandler
public:
 event EventHandler^ DataInitDoneEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DataInitDoneEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.DataSourceInitEvent

Evento EditAttrControlBaseDataSourceInitEvent
Evento di inizializzazione del datasource.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DataSourceInitEventArgs> DataSourceInitEvent
Public Event DataSourceInitEvent As EventHandler(Of DataSourceInitEventArgs)
public:
 event EventHandler<DataSourceInitEventArgs^>^ DataSourceInitEvent {
    void add (EventHandler<DataSourceInitEventArgs^>^ value);
    void remove (EventHandler<DataSourceInitEventArgs^>^ value);
}
member DataSourceInitEvent : IEvent<EventHandler<DataSourceInitEventArgs>,
    DataSourceInitEventArgs>

Valore

EventHandler DataSourceInitEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.IsDirtyEvent

Evento EditAttrControlBaseIsDirtyEvent
Evento per sapere se il controllo è dirty.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<IsDirtyEventArgs> IsDirtyEvent
Public Event IsDirtyEvent As EventHandler(Of IsDirtyEventArgs)
public:
 event EventHandler<IsDirtyEventArgs^>^ IsDirtyEvent {
    void add (EventHandler<IsDirtyEventArgs^>^ value);
    void remove (EventHandler<IsDirtyEventArgs^>^ value);
}
member IsDirtyEvent : IEvent<EventHandler<IsDirtyEventArgs>,
    IsDirtyEventArgs>

Valore

EventHandler IsDirtyEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.LabelTextSetEvent

Evento EditAttrControlBaseLabelTextSetEvent
Evento di modifica del testo della Label di info.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<LabelTextSetEventArgs> LabelTextSetEvent
Public Event LabelTextSetEvent As EventHandler(Of LabelTextSetEventArgs)
public:
 event EventHandler<LabelTextSetEventArgs^>^ LabelTextSetEvent {
    void add (EventHandler<LabelTextSetEventArgs^>^ value);
    void remove (EventHandler<LabelTextSetEventArgs^>^ value);
}
member LabelTextSetEvent : IEvent<EventHandler<LabelTextSetEventArgs>,
    LabelTextSetEventArgs>

Valore

EventHandler LabelTextSetEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.LuaValidatingEvent

Evento EditAttrControlBaseLuaValidatingEvent
Evento di validazione tramite Lua.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<LuaValidatingEventArgs> LuaValidatingEvent
Public Event LuaValidatingEvent As EventHandler(Of LuaValidatingEventArgs)
public:
 event EventHandler<LuaValidatingEventArgs^>^ LuaValidatingEvent {
    void add (EventHandler<LuaValidatingEventArgs^>^ value);
    void remove (EventHandler<LuaValidatingEventArgs^>^ value);
}
member LuaValidatingEvent : IEvent<EventHandler<LuaValidatingEventArgs>,
    LuaValidatingEventArgs>

Valore

EventHandler LuaValidatingEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.OrderTabPagesEvent

Evento EditAttrControlBaseOrderTabPagesEvent
Evento per riordinare le tab delle categorie.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OrderTabPagesEventArgs> OrderTabPagesEvent
Public Event OrderTabPagesEvent As EventHandler(Of OrderTabPagesEventArgs)
public:
 event EventHandler<OrderTabPagesEventArgs^>^ OrderTabPagesEvent {
    void add (EventHandler<OrderTabPagesEventArgs^>^ value);
    void remove (EventHandler<OrderTabPagesEventArgs^>^ value);
}
member OrderTabPagesEvent : IEvent<EventHandler<OrderTabPagesEventArgs>,
    OrderTabPagesEventArgs>

Valore

EventHandler OrderTabPagesEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.OverrideCellValueChangedEvent

Evento EditAttrControlBaseOverrideCellValueChangedEvent
Evento di override dell'evento CellValueChanged.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CellValueChangedEventArgs> OverrideCellValueChangedEvent
Public Event OverrideCellValueChangedEvent As EventHandler(Of CellValueChangedEventArgs)
public:
 event EventHandler<CellValueChangedEventArgs^>^ OverrideCellValueChangedEvent {
    void add (EventHandler<CellValueChangedEventArgs^>^ value);
    void remove (EventHandler<CellValueChangedEventArgs^>^ value);
}
member OverrideCellValueChangedEvent : IEvent<EventHandler<CellValueChangedEventArgs>,
    CellValueChangedEventArgs>

Valore

EventHandler CellValueChangedEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.OverrideCustomDrawCellEvent

Evento EditAttrControlBaseOverrideCustomDrawCellEvent
Evento di override dell'evento CustomDrawCell

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideCustomDrawCellEventArgs> OverrideCustomDrawCellEvent
Public Event OverrideCustomDrawCellEvent As EventHandler(Of OverrideCustomDrawCellEventArgs)
public:
 event EventHandler<OverrideCustomDrawCellEventArgs^>^ OverrideCustomDrawCellEvent {
    void add (EventHandler<OverrideCustomDrawCellEventArgs^>^ value);
    void remove (EventHandler<OverrideCustomDrawCellEventArgs^>^ value);
}
member OverrideCustomDrawCellEvent : IEvent<EventHandler<OverrideCustomDrawCellEventArgs>,
    OverrideCustomDrawCellEventArgs>

Valore

EventHandler OverrideCustomDrawCellEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.OverrideImpostaStatoPulsantiEvent

Evento EditAttrControlBaseOverrideImpostaStatoPulsantiEvent
Evento di override del metodo ImpostaStatoPulsanti.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideImpostaStatoPulsantiEventArgs> OverrideImpostaStatoPulsantiEvent
Public Event OverrideImpostaStatoPulsantiEvent As EventHandler(Of OverrideImpostaStatoPulsantiEventArgs)
public:
 event EventHandler<OverrideImpostaStatoPulsantiEventArgs^>^ OverrideImpostaStatoPulsantiEvent {
    void add (EventHandler<OverrideImpostaStatoPulsantiEventArgs^>^ value);
    void remove (EventHandler<OverrideImpostaStatoPulsantiEventArgs^>^ value);
}
member OverrideImpostaStatoPulsantiEvent : IEvent<EventHandler<OverrideImpostaStatoPulsantiEventArgs>,
    OverrideImpostaStatoPulsantiEventArgs>

Valore

EventHandler OverrideImpostaStatoPulsantiEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.OverrideRowCellStyleEvent

Evento EditAttrControlBaseOverrideRowCellStyleEvent
Evento di override dell'evento RowCellStyle

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideRowCellStyleEventArgs> OverrideRowCellStyleEvent
Public Event OverrideRowCellStyleEvent As EventHandler(Of OverrideRowCellStyleEventArgs)
public:
 event EventHandler<OverrideRowCellStyleEventArgs^>^ OverrideRowCellStyleEvent {
    void add (EventHandler<OverrideRowCellStyleEventArgs^>^ value);
    void remove (EventHandler<OverrideRowCellStyleEventArgs^>^ value);
}
member OverrideRowCellStyleEvent : IEvent<EventHandler<OverrideRowCellStyleEventArgs>,
    OverrideRowCellStyleEventArgs>

Valore

EventHandler OverrideRowCellStyleEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.OverrideValidatingEditorEvent

Evento EditAttrControlBaseOverrideValidatingEditorEvent
Evento di override dell'evento ValidatingEditor.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideValidatingEditorEventArgs> OverrideValidatingEditorEvent
Public Event OverrideValidatingEditorEvent As EventHandler(Of OverrideValidatingEditorEventArgs)
public:
 event EventHandler<OverrideValidatingEditorEventArgs^>^ OverrideValidatingEditorEvent {
    void add (EventHandler<OverrideValidatingEditorEventArgs^>^ value);
    void remove (EventHandler<OverrideValidatingEditorEventArgs^>^ value);
}
member OverrideValidatingEditorEvent : IEvent<EventHandler<OverrideValidatingEditorEventArgs>,
    OverrideValidatingEditorEventArgs>

Valore

EventHandler OverrideValidatingEditorEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.PopupOpeningEvent

Evento EditAttrControlBasePopupOpeningEvent
Evento di apertura del menù contestuale.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CancelEventArgs> PopupOpeningEvent
Public Event PopupOpeningEvent As EventHandler(Of CancelEventArgs)
public:
 event EventHandler<CancelEventArgs^>^ PopupOpeningEvent {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}
member PopupOpeningEvent : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

Valore

EventHandler CancelEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.PostButtonCancelClick

Evento EditAttrControlBasePostButtonCancelClick
Evento sul click del bottone Cancel.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler PostButtonCancelClick
Public Event PostButtonCancelClick As EventHandler
public:
 event EventHandler^ PostButtonCancelClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member PostButtonCancelClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.PostButtonOkClick

Evento EditAttrControlBasePostButtonOkClick
Evento sul post click del bottone Ok (parte dopo ButtonOkClick) per gestire DED+TOP.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler PostButtonOkClick
Public Event PostButtonOkClick As EventHandler
public:
 event EventHandler^ PostButtonOkClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member PostButtonOkClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.RepositoryBindEvent

Evento EditAttrControlBaseRepositoryBindEvent
Evento di binding del repository alla cella.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RepositoryBindEventArgs> RepositoryBindEvent
Public Event RepositoryBindEvent As EventHandler(Of RepositoryBindEventArgs)
public:
 event EventHandler<RepositoryBindEventArgs^>^ RepositoryBindEvent {
    void add (EventHandler<RepositoryBindEventArgs^>^ value);
    void remove (EventHandler<RepositoryBindEventArgs^>^ value);
}
member RepositoryBindEvent : IEvent<EventHandler<RepositoryBindEventArgs>,
    RepositoryBindEventArgs>

Valore

EventHandler RepositoryBindEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.RulesImageChangeEvent

Evento EditAttrControlBaseRulesImageChangeEvent
Evento di modifica dell'immagine dlle regole attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RulesImagesChangeEventArgs> RulesImageChangeEvent
Public Event RulesImageChangeEvent As EventHandler(Of RulesImagesChangeEventArgs)
public:
 event EventHandler<RulesImagesChangeEventArgs^>^ RulesImageChangeEvent {
    void add (EventHandler<RulesImagesChangeEventArgs^>^ value);
    void remove (EventHandler<RulesImagesChangeEventArgs^>^ value);
}
member RulesImageChangeEvent : IEvent<EventHandler<RulesImagesChangeEventArgs>,
    RulesImagesChangeEventArgs>

Valore

EventHandler RulesImagesChangeEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.SetAttrValueEvent

Evento EditAttrControlBaseSetAttrValueEvent
Evento di modifica del valore di un attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<SetAttrValueEventArgs> SetAttrValueEvent
Public Event SetAttrValueEvent As EventHandler(Of SetAttrValueEventArgs)
public:
 event EventHandler<SetAttrValueEventArgs^>^ SetAttrValueEvent {
    void add (EventHandler<SetAttrValueEventArgs^>^ value);
    void remove (EventHandler<SetAttrValueEventArgs^>^ value);
}
member SetAttrValueEvent : IEvent<EventHandler<SetAttrValueEventArgs>,
    SetAttrValueEventArgs>

Valore

EventHandler SetAttrValueEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ValidateAttrEvent

Evento EditAttrControlBaseValidateAttrEvent
Evento di validazione di un attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ValidateAttrEventArgs> ValidateAttrEvent
Public Event ValidateAttrEvent As EventHandler(Of ValidateAttrEventArgs)
public:
 event EventHandler<ValidateAttrEventArgs^>^ ValidateAttrEvent {
    void add (EventHandler<ValidateAttrEventArgs^>^ value);
    void remove (EventHandler<ValidateAttrEventArgs^>^ value);
}
member ValidateAttrEvent : IEvent<EventHandler<ValidateAttrEventArgs>,
    ValidateAttrEventArgs>

Valore

EventHandler ValidateAttrEventArgs
Vedi anche

Documentazione

Classe EditAttrControlBase


Evento EditAttrControlBase.ValueChanged

Evento EditAttrControlBaseValueChanged
Evento su avvenuta modifica del valore di un attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ValueChanged : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe EditAttrControlBase


Campi di EditAttrControlBase

Il tipo EditAttrControlBase espone i seguenti membri.

Campi
Nome | Descrizione
LISTTYPE_FACOLTATIVA |
LISTTYPE_MULTI |
LISTTYPE_OBBLIGATORIA |
Torna su
Vedi anche

Documentazione

Classe EditAttrControlBase


Campo EditAttrControlBase.LISTTYPE_FACOLTATIVA

Campo EditAttrControlBaseLISTTYPE_FACOLTATIVA

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string LISTTYPE_FACOLTATIVA = "Combo"
Public Const LISTTYPE_FACOLTATIVA As String = "Combo"
public:
literal String^ LISTTYPE_FACOLTATIVA = "Combo"
static val mutable LISTTYPE_FACOLTATIVA: string

Valore del campo

String
Vedi anche

Documentazione

Classe EditAttrControlBase


Campo EditAttrControlBase.LISTTYPE_MULTI

Campo EditAttrControlBaseLISTTYPE_MULTI

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string LISTTYPE_MULTI = "MultiCheck"
Public Const LISTTYPE_MULTI As String = "MultiCheck"
public:
literal String^ LISTTYPE_MULTI = "MultiCheck"
static val mutable LISTTYPE_MULTI: string

Valore del campo

String
Vedi anche

Documentazione

Classe EditAttrControlBase


Campo EditAttrControlBase.LISTTYPE_OBBLIGATORIA

Campo EditAttrControlBaseLISTTYPE_OBBLIGATORIA

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string LISTTYPE_OBBLIGATORIA = "ComboList"
Public Const LISTTYPE_OBBLIGATORIA As String = "ComboList"
public:
literal String^ LISTTYPE_OBBLIGATORIA = "ComboList"
static val mutable LISTTYPE_OBBLIGATORIA: string

Valore del campo

String
Vedi anche

Documentazione

Classe EditAttrControlBase


Classe EditList
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIEditList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class EditList : QsBaseForm
Public Class EditList
    Inherits QsBaseForm
public ref class EditList : public QsBaseForm
type EditList =
    class
        inherit QsBaseForm
    end

Il tipo EditList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EditList | Inizializza una nuova istanza della classe EditList.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | ListCodes |
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore EditList
Inizializza una nuova istanza della classe EditList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public EditList(
    string path
)
Public Sub New (
    path As String
)
public:
EditList(
    String^ path
)
new :
        path : string -> EditList

Parametri

path String
Vedi anche

Documentazione

Classe EditList


Proprietà di EditList

Il tipo EditList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | ListCodes |
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe EditList


Proprietà EditList.ListCodes

Proprietà EditListListCodes

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string[] ListCodes { get; }
Public ReadOnly Property ListCodes As String()
    Get
public:
property array<String^>^ ListCodes {
    array<String^>^ get ();
}
member ListCodes : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe EditList


Metodi di EditList

Il tipo EditList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe EditList


Metodo EditList.Dispose

Metodo EditListDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe EditList


Eventi di EditList

Il tipo EditList espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe EditList


Campi di EditList

Il tipo EditList espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe EditList


Classe EditListResult
Classe di risultato del dialogo EditList.
Gerarchia di ereditarietà
SystemObject
QsUIEditListResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class EditListResult
Public Class EditListResult
public ref class EditListResult
type EditListResult = class end

Il tipo EditListResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EditListResult | Inizializza una nuova istanza della classe EditListResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | ListCodes |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore EditListResult
Inizializza una nuova istanza della classe EditListResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public EditListResult()
Public Sub New
public:
EditListResult()
new : unit -> EditListResult
Vedi anche

Documentazione

Classe EditListResult


Campi di EditListResult

Il tipo EditListResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | ListCodes |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Classe EditListResult


Campo EditListResult.ListCodes

Campo EditListResultListCodes

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string[] ListCodes
Public ListCodes As String()
public:
array<String^>^ ListCodes
val mutable ListCodes: string[]

Valore del campo

String
Vedi anche

Documentazione

Classe EditListResult


Campo EditListResult.OK

Campo EditListResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe EditListResult


Classe ElaborationReport
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIElaborationReport

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ElaborationReport : QsBaseForm
Public Class ElaborationReport
    Inherits QsBaseForm
public ref class ElaborationReport : public QsBaseForm
type ElaborationReport =
    class
        inherit QsBaseForm
    end

Il tipo ElaborationReport espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ElaborationReport | Costruttore pubblico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowCancel | Se attivo permette l'annullamento dell'operazione attivando il tasto con la x rossa
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AutoClose | Determina se chiudere automaticamente il dialogo al termine dell'elaborazione
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundWorkingMode | Determina se deve girare in modalità background working. ATTENZIONE! Fondamentale settarlo a false per l'utilizzo in ambiente lua.
Proprietà pubblica | BoundDataDelegate | Delegate binding dei dati nelle colonne
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomFields | Dizionario dei campi custom
Proprietà pubblica | CustomFieldsType | Tipi dei campi custom. Default String. Altra possibilità "Image"
Proprietà pubblica | CustomFieldsWidth | Larghezza dei campi custom. Default 50
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | ElaborationExceptions | Lista eccezioni di elaborazione
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | ExecutorDelegate | Delegate di esecuzione
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GetIdDelegate | Delegate per l'identificazione dell'oggetto
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ObjList | Lista di oggetti ai quali aplicare l'elaborazione
Proprietà pubblica | RunOnLoad | Determina se l'elaborazione deve scattare all'avvio
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ElaborationReport
Costruttore pubblico

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReport()
Public Sub New
public:
ElaborationReport()
new : unit -> ElaborationReport
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowCancel | Se attivo permette l'annullamento dell'operazione attivando il tasto con la x rossa
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AutoClose | Determina se chiudere automaticamente il dialogo al termine dell'elaborazione
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundWorkingMode | Determina se deve girare in modalità background working. ATTENZIONE! Fondamentale settarlo a false per l'utilizzo in ambiente lua.
Proprietà pubblica | BoundDataDelegate | Delegate binding dei dati nelle colonne
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomFields | Dizionario dei campi custom
Proprietà pubblica | CustomFieldsType | Tipi dei campi custom. Default String. Altra possibilità "Image"
Proprietà pubblica | CustomFieldsWidth | Larghezza dei campi custom. Default 50
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | ElaborationExceptions | Lista eccezioni di elaborazione
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | ExecutorDelegate | Delegate di esecuzione
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GetIdDelegate | Delegate per l'identificazione dell'oggetto
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ObjList | Lista di oggetti ai quali aplicare l'elaborazione
Proprietà pubblica | RunOnLoad | Determina se l'elaborazione deve scattare all'avvio
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.AllowCancel

Proprietà ElaborationReportAllowCancel
Se attivo permette l'annullamento dell'operazione attivando il tasto con la x rossa

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowCancel { get; set; }
Public Property AllowCancel As Boolean
    Get
    Set
public:
property bool AllowCancel {
    bool get ();
    void set (bool value);
}
member AllowCancel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.AutoClose

Proprietà ElaborationReportAutoClose
Determina se chiudere automaticamente il dialogo al termine dell'elaborazione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoClose { get; set; }
Public Property AutoClose As Boolean
    Get
    Set
public:
property bool AutoClose {
    bool get ();
    void set (bool value);
}
member AutoClose : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.BackgroundWorkingMode

Proprietà ElaborationReportBackgroundWorkingMode
Determina se deve girare in modalità background working. ATTENZIONE! Fondamentale settarlo a false per l'utilizzo in ambiente lua.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool BackgroundWorkingMode { get; set; }
Public Property BackgroundWorkingMode As Boolean
    Get
    Set
public:
property bool BackgroundWorkingMode {
    bool get ();
    void set (bool value);
}
member BackgroundWorkingMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.BoundDataDelegate

Proprietà ElaborationReportBoundDataDelegate
Delegate binding dei dati nelle colonne

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportBoundDataOperationDelegate BoundDataDelegate { get; set; }
Public Property BoundDataDelegate As ElaborationReportBoundDataOperationDelegate
    Get
    Set
public:
property ElaborationReportBoundDataOperationDelegate^ BoundDataDelegate {
    ElaborationReportBoundDataOperationDelegate^ get ();
    void set (ElaborationReportBoundDataOperationDelegate^ value);
}
member BoundDataDelegate : ElaborationReportBoundDataOperationDelegate with get, set

Valore della proprietà

ElaborationReportBoundDataOperationDelegate
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.CustomFields

Proprietà ElaborationReportCustomFields
Dizionario dei campi custom

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> CustomFields { get; set; }
Public Property CustomFields As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ CustomFields {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
member CustomFields : Dictionary<string, string> with get, set

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.CustomFieldsType

Proprietà ElaborationReportCustomFieldsType
Tipi dei campi custom. Default String. Altra possibilità "Image"

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> CustomFieldsType { get; set; }
Public Property CustomFieldsType As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ CustomFieldsType {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
member CustomFieldsType : Dictionary<string, string> with get, set

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.CustomFieldsWidth

Proprietà ElaborationReportCustomFieldsWidth
Larghezza dei campi custom. Default 50

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, int> CustomFieldsWidth { get; set; }
Public Property CustomFieldsWidth As Dictionary(Of String, Integer)
    Get
    Set
public:
property Dictionary<String^, int>^ CustomFieldsWidth {
    Dictionary<String^, int>^ get ();
    void set (Dictionary<String^, int>^ value);
}
member CustomFieldsWidth : Dictionary<string, int> with get, set

Valore della proprietà

Dictionary String, Int32
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.ElaborationExceptions

Proprietà ElaborationReportElaborationExceptions
Lista eccezioni di elaborazione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> ElaborationExceptions { get; }
Public ReadOnly Property ElaborationExceptions As List(Of Exception)
    Get
public:
property List<Exception^>^ ElaborationExceptions {
    List<Exception^>^ get ();
}
member ElaborationExceptions : List<Exception> with get

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.ExecutorDelegate

Proprietà ElaborationReportExecutorDelegate
Delegate di esecuzione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportExecuteOperationDelegate ExecutorDelegate { get; set; }
Public Property ExecutorDelegate As ElaborationReportExecuteOperationDelegate
    Get
    Set
public:
property ElaborationReportExecuteOperationDelegate^ ExecutorDelegate {
    ElaborationReportExecuteOperationDelegate^ get ();
    void set (ElaborationReportExecuteOperationDelegate^ value);
}
member ExecutorDelegate : ElaborationReportExecuteOperationDelegate with get, set

Valore della proprietà

ElaborationReportExecuteOperationDelegate
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.GetIdDelegate

Proprietà ElaborationReportGetIdDelegate
Delegate per l'identificazione dell'oggetto

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportGetIdObjectDelegate GetIdDelegate { get; set; }
Public Property GetIdDelegate As ElaborationReportGetIdObjectDelegate
    Get
    Set
public:
property ElaborationReportGetIdObjectDelegate^ GetIdDelegate {
    ElaborationReportGetIdObjectDelegate^ get ();
    void set (ElaborationReportGetIdObjectDelegate^ value);
}
member GetIdDelegate : ElaborationReportGetIdObjectDelegate with get, set

Valore della proprietà

ElaborationReportGetIdObjectDelegate
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.ObjList

Proprietà ElaborationReportObjList
Lista di oggetti ai quali aplicare l'elaborazione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable ObjList { get; set; }
Public Property ObjList As IEnumerable
    Get
    Set
public:
property IEnumerable^ ObjList {
    IEnumerable^ get ();
    void set (IEnumerable^ value);
}
member ObjList : IEnumerable with get, set

Valore della proprietà

IEnumerable
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.RunOnLoad

Proprietà ElaborationReportRunOnLoad
Determina se l'elaborazione deve scattare all'avvio

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool RunOnLoad { get; set; }
Public Property RunOnLoad As Boolean
    Get
    Set
public:
property bool RunOnLoad {
    bool get ();
    void set (bool value);
}
member RunOnLoad : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Metodi di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Metodo ElaborationReport.Dispose

Metodo ElaborationReportDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ElaborationReport


Eventi di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Campi di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Delegate ElaborationReport.BoundDataOperationDelegate

Delegate ElaborationReportBoundDataOperationDelegate
Delegate per la personalizzazione del comportamento del form

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public delegate Object BoundDataOperationDelegate(
    string fieldname,
    Object argument
)
Public Delegate Function BoundDataOperationDelegate (
    fieldname As String,
    argument As Object
) As Object
public delegate Object^ BoundDataOperationDelegate(
    String^ fieldname,
    Object^ argument
)
type BoundDataOperationDelegate =
    delegate of
        fieldname : string *
        argument : Object -> Object

Parametri

fieldname String
argument Object

Valore di ritorno

Object
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Delegate ElaborationReport.ExecuteOperationDelegate

Delegate ElaborationReportExecuteOperationDelegate

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public delegate ElaborationReportResultDescriptor ExecuteOperationDelegate(
    Object argument
)
Public Delegate Function ExecuteOperationDelegate (
    argument As Object
) As ElaborationReportResultDescriptor
public delegate ElaborationReportResultDescriptor^ ExecuteOperationDelegate(
    Object^ argument
)
type ExecuteOperationDelegate =
    delegate of
        argument : Object -> ElaborationReportResultDescriptor

Parametri

argument Object

Valore di ritorno

ElaborationReportResultDescriptor
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Delegate ElaborationReport.GetIdObjectDelegate

Delegate ElaborationReportGetIdObjectDelegate

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public delegate Object GetIdObjectDelegate(
    Object argument
)
Public Delegate Function GetIdObjectDelegate (
    argument As Object
) As Object
public delegate Object^ GetIdObjectDelegate(
    Object^ argument
)
type GetIdObjectDelegate =
    delegate of
        argument : Object -> Object

Parametri

argument Object

Valore di ritorno

Object
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione ElaborationReport.OperationStatus

Enumerazione ElaborationReportOperationStatus
Enumerazione dei possibili stati del risultato

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum OperationStatus
Public Enumeration OperationStatus
public enum class OperationStatus
type OperationStatus
Membri
Nome | Valore | Descrizione
ok | 0 |
warning | 1 |
error | 2 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ElaborationReport.ResultDescriptor

Classe ElaborationReportResultDescriptor
Oggetto descrittore del risultato dell'elaborazione
Gerarchia di ereditarietà
SystemObject
QsUIElaborationReportResultDescriptor

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ResultDescriptor
Public Class ResultDescriptor
public ref class ResultDescriptor
type ResultDescriptor = class end

Il tipo ElaborationReportResultDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ElaborationReportResultDescriptor | Inizializza una nuova istanza della classe ElaborationReportResultDescriptor.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | message |
Campo pubblico | status |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ElaborationReport.ResultDescriptor

Costruttore ElaborationReportResultDescriptor
Inizializza una nuova istanza della classe ElaborationReportResultDescriptor.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ResultDescriptor(
    ElaborationReportOperationStatus isOk,
    Object msg
)
Public Sub New (
    isOk As ElaborationReportOperationStatus,
    msg As Object
)
public:
ResultDescriptor(
    ElaborationReportOperationStatus isOk,
    Object^ msg
)
new :
        isOk : ElaborationReportOperationStatus *
        msg : Object -> ResultDescriptor

Parametri

isOk ElaborationReportOperationStatus
msg Object
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Campi di ResultDescriptor

Il tipo ElaborationReportResultDescriptor espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | message |
Campo pubblico | status |
Torna su
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Campo ElaborationReport.ResultDescriptor.message

Campo ElaborationReportResultDescriptormessage

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object message
Public message As Object
public:
Object^ message
val mutable message: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Campo ElaborationReport.ResultDescriptor.status

Campo ElaborationReportResultDescriptorstatus

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportOperationStatus status
Public status As ElaborationReportOperationStatus
public:
ElaborationReportOperationStatus status
val mutable status: ElaborationReportOperationStatus

Valore del campo

ElaborationReportOperationStatus
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Classe FilterEventArgs
Argomenti dell'evento FilterEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIFilterEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FilterEventArgs : EventArgs
Public Class FilterEventArgs
    Inherits EventArgs
public ref class FilterEventArgs : public EventArgs
type FilterEventArgs =
    class
        inherit EventArgs
    end

Il tipo FilterEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FilterEventArgs | Inizializza una nuova istanza della classe FilterEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FilePath | Path del file.
Proprietà pubblica | Operation | Tipo di operazione cha ha scatenato l'evento.
Proprietà pubblica | Valid | Flag booleano per decidere se il file è valido.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FilterEventArgs
Inizializza una nuova istanza della classe FilterEventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FilterEventArgs()
Public Sub New
public:
FilterEventArgs()
new : unit -> FilterEventArgs
Vedi anche

Documentazione

Classe FilterEventArgs


Proprietà di FilterEventArgs

Il tipo FilterEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FilePath | Path del file.
Proprietà pubblica | Operation | Tipo di operazione cha ha scatenato l'evento.
Proprietà pubblica | Valid | Flag booleano per decidere se il file è valido.
Torna su
Vedi anche

Documentazione

Classe FilterEventArgs


Proprietà FilterEventArgs.FilePath

Proprietà FilterEventArgsFilePath
Path del file.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
member FilePath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FilterEventArgs


Proprietà FilterEventArgs.Operation

Proprietà FilterEventArgsOperation
Tipo di operazione cha ha scatenato l'evento.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public DialogOperation Operation { get; set; }
Public Property Operation As DialogOperation
    Get
    Set
public:
property DialogOperation Operation {
    DialogOperation get ();
    void set (DialogOperation value);
}
member Operation : DialogOperation with get, set

Valore della proprietà

DialogOperation
Vedi anche

Documentazione

Classe FilterEventArgs


Proprietà FilterEventArgs.Valid

Proprietà FilterEventArgsValid
Flag booleano per decidere se il file è valido.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set
public:
property bool Valid {
    bool get ();
    void set (bool value);
}
member Valid : bool with get, set

Valore della proprietà

Boolean
Note
Impostare a true per aggiungere il file, altrimenti impostare a false.
Vedi anche

Documentazione

Classe FilterEventArgs


Classe FormAbout
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIFormAbout

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FormAbout : QsBaseForm
Public Class FormAbout
    Inherits QsBaseForm
public ref class FormAbout : public QsBaseForm
type FormAbout =
    class
        inherit QsBaseForm
    end

Il tipo FormAbout espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FormAbout | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AssemblyVersion |
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | IniPath |
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | QsProductDescription | Imposta la textbox che visualizza la descrizione del prodotto.
Proprietà pubblica | QsProductImage | Imposta l'immagine del prodotto visualizzata a lato.
Proprietà pubblica | QsProductName | Imposta la label che visualizza il nome del prodotto.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FormAbout
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormAbout()
Public Sub New
public:
FormAbout()
new : unit -> FormAbout
Vedi anche

Documentazione

Classe FormAbout


Proprietà di FormAbout

Il tipo FormAbout espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AssemblyVersion |
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | IniPath |
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | QsProductDescription | Imposta la textbox che visualizza la descrizione del prodotto.
Proprietà pubblica | QsProductImage | Imposta l'immagine del prodotto visualizzata a lato.
Proprietà pubblica | QsProductName | Imposta la label che visualizza il nome del prodotto.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormAbout


Proprietà FormAbout.AssemblyVersion

Proprietà FormAboutAssemblyVersion

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string AssemblyVersion { get; }
Public ReadOnly Property AssemblyVersion As String
    Get
public:
property String^ AssemblyVersion {
    String^ get ();
}
member AssemblyVersion : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FormAbout


Proprietà FormAbout.IniPath

Proprietà FormAboutIniPath

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string IniPath { get; set; }
Public Property IniPath As String
    Get
    Set
public:
property String^ IniPath {
    String^ get ();
    void set (String^ value);
}
member IniPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FormAbout


Proprietà FormAbout.QsProductDescription

Proprietà FormAboutQsProductDescription
Imposta la textbox che visualizza la descrizione del prodotto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string QsProductDescription { set; }
Public WriteOnly Property QsProductDescription As String
    Set
public:
property String^ QsProductDescription {
    void set (String^ value);
}
member QsProductDescription : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FormAbout


Proprietà FormAbout.QsProductImage

Proprietà FormAboutQsProductImage
Imposta l'immagine del prodotto visualizzata a lato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image QsProductImage { set; }
Public WriteOnly Property QsProductImage As Image
    Set
public:
property Image^ QsProductImage {
    void set (Image^ value);
}
member QsProductImage : Image with set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe FormAbout


Proprietà FormAbout.QsProductName

Proprietà FormAboutQsProductName
Imposta la label che visualizza il nome del prodotto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string QsProductName { set; }
Public WriteOnly Property QsProductName As String
    Set
public:
property String^ QsProductName {
    void set (String^ value);
}
member QsProductName : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FormAbout


Metodi di FormAbout

Il tipo FormAbout espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormAbout


Metodo FormAbout.Dispose

Metodo FormAboutDispose
Liberare le risorse in uso.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
True per rilasciare sia le risorse managed che quelle unmanaged; false per rilasciare solo quelle unmanaged.
Vedi anche

Documentazione

Classe FormAbout


Eventi di FormAbout

Il tipo FormAbout espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormAbout


Campi di FormAbout

Il tipo FormAbout espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormAbout


Classe FormBarProg
Classe per visualizzare una progress bar di avanzamento. Costruire il form e poi chiamare i vari metodi ( ci pensa lui a visualizzarsi e chiudersi quando parte e termina )
Gerarchia di ereditarietà
SystemObject
QsUIFormBarProg

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FormBarProg
Public Class FormBarProg
public ref class FormBarProg
type FormBarProg = class end

Il tipo FormBarProg espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FormBarProg | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DisableCanButton | Indica se mostrare o nascondere il bottone "Cancel".
Proprietà pubblica | HasProg | Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.
Proprietà pubblica | Location | Imposta la posizione del form
Proprietà pubblica | Size | Ritorna la dimensione del form
Proprietà pubblica | Text | Imposta il titolo del form.
Proprietà pubblica | UserCancOp | Flag che indica se è stato premuto il bottone "Cancel".
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Close | Chiusura Form.
Metodo pubblico | Decrement | Decrementa la progress bar con il valore passato.
Metodo pubblico | EnforceRefresh | Forza un refresh grafico del dialogo. Usare con parsimonia perchè utilizza un "Application.DoEvents".
Metodo pubblico | Finished | Indica se il processo di avanzamento è giunto al termine (True) o meno (False). Usare con molta attenzione perchè verifica lo stato di avanzamento della barra che in alcuni casi potrebbe essere falsato rispetto a quello del ciclo in cui è utilizzato.
Metodo pubblico | Increment | Incrementa la progress bar con il valore passato.
Metodo pubblico | IncrementStep | Incermenta la progress bar del valore dello step.
Metodo pubblico | IsOpen | Ritorna True se il form è visibile, False altrimenti.
Metodo pubblico | SetMax | Reimposta il valore massimo della progressbar. Attenzione però! dopo che il valore massimo è stato reimpostato, lo step della progressbar viene impostato a 1 e l'indicatore di avanzamento viene resettato a 0.
Metodo pubblico | SetMessage | Imposta il testo del form.
Metodo pubblico | SetStep | Decrementa la progress bar con il valore passato.
Metodo pubblico | SetText | Imposta il testo del form.
Metodo pubblico | Show | Visualizza il Form.
Metodo pubblico | ShowDialog | Visualizza il Form.
Metodo pubblico | StepMessage | Aggiorna il testo visualizzato nel dialogo e incrementa lo step della progressbar.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FormBarProg
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormBarProg(
    int minValue,
    int maxValue,
    int stepValue,
    bool autoShow = true,
    bool autoClose = true,
    bool topMost = true,
    bool disableCancelButton = true,
    bool hasProgr = true
)
Public Sub New (
    minValue As Integer,
    maxValue As Integer,
    stepValue As Integer,
    Optional autoShow As Boolean = true,
    Optional autoClose As Boolean = true,
    Optional topMost As Boolean = true,
    Optional disableCancelButton As Boolean = true,
    Optional hasProgr As Boolean = true
)
public:
FormBarProg(
    int minValue,
    int maxValue,
    int stepValue,
    bool autoShow = true,
    bool autoClose = true,
    bool topMost = true,
    bool disableCancelButton = true,
    bool hasProgr = true
)
new :
        minValue : int *
        maxValue : int *
        stepValue : int *
        ?autoShow : bool *
        ?autoClose : bool *
        ?topMost : bool *
        ?disableCancelButton : bool *
        ?hasProgr : bool
(* Defaults:
        let _autoShow = defaultArg autoShow true
        let _autoClose = defaultArg autoClose true
        let _topMost = defaultArg topMost true
        let _disableCancelButton = defaultArg disableCancelButton true
        let _hasProgr = defaultArg hasProgr true
*)
-> FormBarProg

Parametri

minValue Int32
Valore di partenza.
maxValue Int32
Valore di arrivo.
stepValue Int32
Valore di incremento.
autoShow Boolean (Optional)
Indica se mostrare il form in automatico (nel caso di marquee deve per forza essere visualizzato dall'utente)
autoClose Boolean (Optional)
Indica se chiudere il form in automatico (nel caso di marquee deve per forza essere chiuso dall'utente)
topMost Boolean (Optional)
Indica se il form deve essere in primo piano
disableCancelButton Boolean (Optional)
Indica se disabilitare il pulsante di cancel
hasProgr Boolean (Optional)
Indica se mostrare la barra di progressione o se è marquee
Vedi anche

Documentazione

Classe FormBarProg


Proprietà di FormBarProg

Il tipo FormBarProg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DisableCanButton | Indica se mostrare o nascondere il bottone "Cancel".
Proprietà pubblica | HasProg | Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.
Proprietà pubblica | Location | Imposta la posizione del form
Proprietà pubblica | Size | Ritorna la dimensione del form
Proprietà pubblica | Text | Imposta il titolo del form.
Proprietà pubblica | UserCancOp | Flag che indica se è stato premuto il bottone "Cancel".
Torna su
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.DisableCanButton

Proprietà FormBarProgDisableCanButton
Indica se mostrare o nascondere il bottone "Cancel".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableCanButton { set; }
Public WriteOnly Property DisableCanButton As Boolean
    Set
public:
property bool DisableCanButton {
    void set (bool value);
}
member DisableCanButton : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.HasProg

Proprietà FormBarProgHasProg
Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasProg { set; }
Public WriteOnly Property HasProg As Boolean
    Set
public:
property bool HasProg {
    void set (bool value);
}
member HasProg : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.Location

Proprietà FormBarProgLocation
Imposta la posizione del form

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Point Location { set; }
Public WriteOnly Property Location As Point
    Set
public:
property Point Location {
    void set (Point value);
}
member Location : Point with set

Valore della proprietà

Point
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.Size

Proprietà FormBarProgSize
Ritorna la dimensione del form

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
public:
property Size Size {
    Size get ();
}
member Size : Size with get

Valore della proprietà

Size
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.Text

Proprietà FormBarProgText
Imposta il titolo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Text { set; }
Public WriteOnly Property Text As String
    Set
public:
property String^ Text {
    void set (String^ value);
}
member Text : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.UserCancOp

Proprietà FormBarProgUserCancOp
Flag che indica se è stato premuto il bottone "Cancel".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCancOp { get; }
Public ReadOnly Property UserCancOp As Boolean
    Get
public:
property bool UserCancOp {
    bool get ();
}
member UserCancOp : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FormBarProg


Metodi di FormBarProg

Il tipo FormBarProg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Close | Chiusura Form.
Metodo pubblico | Decrement | Decrementa la progress bar con il valore passato.
Metodo pubblico | EnforceRefresh | Forza un refresh grafico del dialogo. Usare con parsimonia perchè utilizza un "Application.DoEvents".
Metodo pubblico | Finished | Indica se il processo di avanzamento è giunto al termine (True) o meno (False). Usare con molta attenzione perchè verifica lo stato di avanzamento della barra che in alcuni casi potrebbe essere falsato rispetto a quello del ciclo in cui è utilizzato.
Metodo pubblico | Increment | Incrementa la progress bar con il valore passato.
Metodo pubblico | IncrementStep | Incermenta la progress bar del valore dello step.
Metodo pubblico | IsOpen | Ritorna True se il form è visibile, False altrimenti.
Metodo pubblico | SetMax | Reimposta il valore massimo della progressbar. Attenzione però! dopo che il valore massimo è stato reimpostato, lo step della progressbar viene impostato a 1 e l'indicatore di avanzamento viene resettato a 0.
Metodo pubblico | SetMessage | Imposta il testo del form.
Metodo pubblico | SetStep | Decrementa la progress bar con il valore passato.
Metodo pubblico | SetText | Imposta il testo del form.
Metodo pubblico | Show | Visualizza il Form.
Metodo pubblico | ShowDialog | Visualizza il Form.
Metodo pubblico | StepMessage | Aggiorna il testo visualizzato nel dialogo e incrementa lo step della progressbar.
Torna su
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Close

Metodo FormBarProgClose
Chiusura Form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Decrement

Metodo FormBarProgDecrement
Decrementa la progress bar con il valore passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Decrement(
    int value
)
Public Sub Decrement (
    value As Integer
)
public:
void Decrement(
    int value
)
member Decrement :
        value : int -> unit

Parametri

value Int32
Valore di decremento della progress bar.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.EnforceRefresh

Metodo FormBarProgEnforceRefresh
Forza un refresh grafico del dialogo. Usare con parsimonia perchè utilizza un "Application.DoEvents".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void EnforceRefresh()
Public Sub EnforceRefresh
public:
void EnforceRefresh()
member EnforceRefresh : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Finished

Metodo FormBarProgFinished
Indica se il processo di avanzamento è giunto al termine (True) o meno (False). Usare con molta attenzione perchè verifica lo stato di avanzamento della barra che in alcuni casi potrebbe essere falsato rispetto a quello del ciclo in cui è utilizzato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Finished()
Public Function Finished As Boolean
public:
bool Finished()
member Finished : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Increment

Metodo FormBarProgIncrement
Incrementa la progress bar con il valore passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Increment(
    int value
)
Public Sub Increment (
    value As Integer
)
public:
void Increment(
    int value
)
member Increment :
        value : int -> unit

Parametri

value Int32
Valore di incremento della progress bar.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.IncrementStep

Metodo FormBarProgIncrementStep
Incermenta la progress bar del valore dello step.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void IncrementStep()
Public Sub IncrementStep
public:
void IncrementStep()
member IncrementStep : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.IsOpen

Metodo FormBarProgIsOpen
Ritorna True se il form è visibile, False altrimenti.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsOpen()
Public Function IsOpen As Boolean
public:
bool IsOpen()
member IsOpen : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetMax

Metodo FormBarProgSetMax
Reimposta il valore massimo della progressbar. Attenzione però! dopo che il valore massimo è stato reimpostato, lo step della progressbar viene impostato a 1 e l'indicatore di avanzamento viene resettato a 0.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetMax(
    int value
)
Public Sub SetMax (
    value As Integer
)
public:
void SetMax(
    int value
)
member SetMax :
        value : int -> unit

Parametri

value Int32
Nuovo valore massimo che la progressbar può raggiungere.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetMessage

Metodo FormBarProgSetMessage
Imposta il testo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetMessage(
    string message
)
Public Sub SetMessage (
    message As String
)
public:
void SetMessage(
    String^ message
)
member SetMessage :
        message : string -> unit

Parametri

message String
Testo da visualizzare.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetStep

Metodo FormBarProgSetStep
Decrementa la progress bar con il valore passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetStep(
    int value
)
Public Sub SetStep (
    value As Integer
)
public:
void SetStep(
    int value
)
member SetStep :
        value : int -> unit

Parametri

value Int32
Valore di decremento della progress bar.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetText

Metodo FormBarProgSetText
Imposta il testo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetText(
    string text
)
Public Sub SetText (
    text As String
)
public:
void SetText(
    String^ text
)
member SetText :
        text : string -> unit

Parametri

text String
Testo da visualizzare.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Show

Metodo FormBarProgShow
Visualizza il Form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Show()
Public Sub Show
public:
void Show()
member Show : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.ShowDialog

Metodo FormBarProgShowDialog
Visualizza il Form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDialog()
Public Sub ShowDialog
public:
void ShowDialog()
member ShowDialog : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.StepMessage

Metodo FormBarProgStepMessage
Aggiorna il testo visualizzato nel dialogo e incrementa lo step della progressbar.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void StepMessage(
    string txt
)
Public Sub StepMessage (
    txt As String
)
public:
void StepMessage(
    String^ txt
)
member StepMessage :
        txt : string -> unit

Parametri

txt String
Testo da visualizzare.
Vedi anche

Documentazione

Classe FormBarProg


Classe FormException
Finestra di dialogo per visualizzare le eccezioni nel codice.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIFormException

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FormException : QsBaseForm
Public Class FormException
    Inherits QsBaseForm
public ref class FormException : public QsBaseForm
type FormException =
    class
        inherit QsBaseForm
    end

Il tipo FormException espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FormException | Costruttore di con tutti i valori di default.
Metodo pubblico | FormException(Exception, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(ListException, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, ListException) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, Exception) | Cotruttore della classe.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Exceptions | Permette di impostare l'eccezione da visualizzare
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | NotShowAgain | Indica se la spunta "Non mostrare più" è nascosta o meno.
Proprietà pubblica | RowImage | Permette di impostare l'icona della finestra
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | Title | Restituisce o imposta il titolo della finestra.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FormException
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FormException | Costruttore di con tutti i valori di default.
Metodo pubblico | FormException(Exception, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(ListException, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, ListException) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, Exception) | Cotruttore della classe.
Torna su
Vedi anche

Documentazione

Classe FormException


Costruttore FormException
Costruttore di con tutti i valori di default.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormException()
Public Sub New
public:
FormException()
new : unit -> FormException
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException(Exception, Boolean)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    Exception exception,
    bool notShowAgain = false
)
Public Sub New (
    exception As Exception,
    Optional notShowAgain As Boolean = false
)
public:
FormException(
    Exception^ exception,
    bool notShowAgain = false
)
new :
        exception : Exception *
        ?notShowAgain : bool
(* Defaults:
        let _notShowAgain = defaultArg notShowAgain false
*)
-> FormException

Parametri

exception Exception
Eccezione da visualizzare.
notShowAgain Boolean (Optional)
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException(List<Exception>, Boolean)

Costruttore FormException(ListException, Boolean)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    List<Exception> exceptions,
    bool notShowAgain = false
)
Public Sub New (
    exceptions As List(Of Exception),
    Optional notShowAgain As Boolean = false
)
public:
FormException(
    List<Exception^>^ exceptions,
    bool notShowAgain = false
)
new :
        exceptions : List<Exception> *
        ?notShowAgain : bool
(* Defaults:
        let _notShowAgain = defaultArg notShowAgain false
*)
-> FormException

Parametri

exceptions List Exception
Lista di eccezioni da visulaizzare
notShowAgain Boolean (Optional)
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException(Image, String, List<Exception>)

Costruttore FormException(Image, String, ListException)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    Image image,
    string text,
    List<Exception> exceptions
)
Public Sub New (
    image As Image,
    text As String,
    exceptions As List(Of Exception)
)
public:
FormException(
    Image^ image,
    String^ text,
    List<Exception^>^ exceptions
)
new :
        image : Image *
        text : string *
        exceptions : List<Exception> -> FormException

Parametri

image Image
Icona da visualizzare nel form e nei vari nodi.
text String
Titolo del form (se null imposta quello di default: "Errore")
exceptions List Exception
Lista di eccezioni da visulaizzare
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException(Image, String, Exception)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    Image image,
    string text,
    Exception exception
)
Public Sub New (
    image As Image,
    text As String,
    exception As Exception
)
public:
FormException(
    Image^ image,
    String^ text,
    Exception^ exception
)
new :
        image : Image *
        text : string *
        exception : Exception -> FormException

Parametri

image Image
Icona da visualizzare nel form e nei vari nodi.
text String
Titolo del form (se null imposta quello di default: "Errore").
exception Exception
Eccezione da visualizzare.
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Proprietà di FormException

Il tipo FormException espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Exceptions | Permette di impostare l'eccezione da visualizzare
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | NotShowAgain | Indica se la spunta "Non mostrare più" è nascosta o meno.
Proprietà pubblica | RowImage | Permette di impostare l'icona della finestra
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | Title | Restituisce o imposta il titolo della finestra.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.Exceptions

Proprietà FormExceptionExceptions
Permette di impostare l'eccezione da visualizzare

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> Exceptions { set; }
Public WriteOnly Property Exceptions As List(Of Exception)
    Set
public:
property List<Exception^>^ Exceptions {
    void set (List<Exception^>^ value);
}
member Exceptions : List<Exception> with set

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.NotShowAgain

Proprietà FormExceptionNotShowAgain
Indica se la spunta "Non mostrare più" è nascosta o meno.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotShowAgain { get; }
Public ReadOnly Property NotShowAgain As Boolean
    Get
public:
property bool NotShowAgain {
    bool get ();
}
member NotShowAgain : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.RowImage

Proprietà FormExceptionRowImage
Permette di impostare l'icona della finestra

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image RowImage { set; }
Public WriteOnly Property RowImage As Image
    Set
public:
property Image^ RowImage {
    void set (Image^ value);
}
member RowImage : Image with set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.Title

Proprietà FormExceptionTitle
Restituisce o imposta il titolo della finestra.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FormException


Metodi di FormException

Il tipo FormException espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormException


Metodo FormException.Dispose

Metodo FormExceptionDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe FormException


Eventi di FormException

Il tipo FormException espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormException


Campi di FormException

Il tipo FormException espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe FormException


Classe GetFileNameInResult
Gerarchia di ereditarietà
SystemObject
QsUIGetFileNameInResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class GetFileNameInResult
Public Class GetFileNameInResult
public ref class GetFileNameInResult
type GetFileNameInResult = class end

Il tipo GetFileNameInResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GetFileNameInResult | Inizializza una nuova istanza della classe GetFileNameInResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | FileNames |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore GetFileNameInResult
Inizializza una nuova istanza della classe GetFileNameInResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GetFileNameInResult()
Public Sub New
public:
GetFileNameInResult()
new : unit -> GetFileNameInResult
Vedi anche

Documentazione

Classe GetFileNameInResult


Campi di GetFileNameInResult

Il tipo GetFileNameInResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | FileNames |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Classe GetFileNameInResult


Campo GetFileNameInResult.FileNames

Campo GetFileNameInResultFileNames

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object FileNames
Public FileNames As Object
public:
Object^ FileNames
val mutable FileNames: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe GetFileNameInResult


Campo GetFileNameInResult.OK

Campo GetFileNameInResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe GetFileNameInResult


Classe GetFileNameOutResult
Gerarchia di ereditarietà
SystemObject
QsUIGetFileNameOutResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class GetFileNameOutResult
Public Class GetFileNameOutResult
public ref class GetFileNameOutResult
type GetFileNameOutResult = class end

Il tipo GetFileNameOutResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GetFileNameOutResult | Inizializza una nuova istanza della classe GetFileNameOutResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | FileName |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore GetFileNameOutResult
Inizializza una nuova istanza della classe GetFileNameOutResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GetFileNameOutResult()
Public Sub New
public:
GetFileNameOutResult()
new : unit -> GetFileNameOutResult
Vedi anche

Documentazione

Classe GetFileNameOutResult


Campi di GetFileNameOutResult

Il tipo GetFileNameOutResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | FileName |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Classe GetFileNameOutResult


Campo GetFileNameOutResult.FileName

Campo GetFileNameOutResultFileName

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FileName
Public FileName As String
public:
String^ FileName
val mutable FileName: string

Valore del campo

String
Vedi anche

Documentazione

Classe GetFileNameOutResult


Campo GetFileNameOutResult.OK

Campo GetFileNameOutResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe GetFileNameOutResult


Classe InputBox
The InputBox class is used to show a prompt in a dialog box using the static method Show().
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIInputBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InputBox : QsBaseForm
Public Class InputBox
    Inherits QsBaseForm
public ref class InputBox : public QsBaseForm
type InputBox =
    class
        inherit QsBaseForm
    end

Il tipo InputBox espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InputBox | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | ComboBox |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DedOkCancelControl |
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | LabelPrompt |
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà pubblica | TableLayout |
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextBoxText |
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | TxtMemoEdit |
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | Validator | Restituisce o imposta il validatore dei dati.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore InputBox
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InputBox()
Public Sub New
public:
InputBox()
new : unit -> InputBox
Vedi anche

Documentazione

Classe InputBox


Proprietà di InputBox

Il tipo InputBox espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | ComboBox |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DedOkCancelControl |
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | LabelPrompt |
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà pubblica | TableLayout |
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextBoxText |
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | TxtMemoEdit |
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | Validator | Restituisce o imposta il validatore dei dati.
Torna su
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.ComboBox

Proprietà InputBoxComboBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ComboBoxEdit ComboBox { get; set; }
Public Property ComboBox As ComboBoxEdit
    Get
    Set
public:
property ComboBoxEdit^ ComboBox {
    ComboBoxEdit^ get ();
    void set (ComboBoxEdit^ value);
}
member ComboBox : ComboBoxEdit with get, set

Valore della proprietà

ComboBoxEdit
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.DedOkCancelControl

Proprietà InputBoxDedOkCancelControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OkCancelControl DedOkCancelControl { get; set; }
Public Property DedOkCancelControl As OkCancelControl
    Get
    Set
public:
property OkCancelControl^ DedOkCancelControl {
    OkCancelControl^ get ();
    void set (OkCancelControl^ value);
}
member DedOkCancelControl : OkCancelControl with get, set

Valore della proprietà

OkCancelControl
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.LabelPrompt

Proprietà InputBoxLabelPrompt

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public LabelControl LabelPrompt { get; set; }
Public Property LabelPrompt As LabelControl
    Get
    Set
public:
property LabelControl^ LabelPrompt {
    LabelControl^ get ();
    void set (LabelControl^ value);
}
member LabelPrompt : LabelControl with get, set

Valore della proprietà

LabelControl
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.TableLayout

Proprietà InputBoxTableLayout

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public TableLayoutPanel TableLayout { get; set; }
Public Property TableLayout As TableLayoutPanel
    Get
    Set
public:
property TableLayoutPanel^ TableLayout {
    TableLayoutPanel^ get ();
    void set (TableLayoutPanel^ value);
}
member TableLayout : TableLayoutPanel with get, set

Valore della proprietà

TableLayoutPanel
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.TextBoxText

Proprietà InputBoxTextBoxText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public TextEdit TextBoxText { get; set; }
Public Property TextBoxText As TextEdit
    Get
    Set
public:
property TextEdit^ TextBoxText {
    TextEdit^ get ();
    void set (TextEdit^ value);
}
member TextBoxText : TextEdit with get, set

Valore della proprietà

TextEdit
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.TxtMemoEdit

Proprietà InputBoxTxtMemoEdit

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public MemoEdit TxtMemoEdit { get; set; }
Public Property TxtMemoEdit As MemoEdit
    Get
    Set
public:
property MemoEdit^ TxtMemoEdit {
    MemoEdit^ get ();
    void set (MemoEdit^ value);
}
member TxtMemoEdit : MemoEdit with get, set

Valore della proprietà

MemoEdit
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.Validator

Proprietà InputBoxValidator
Restituisce o imposta il validatore dei dati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InputBoxValidatingHandler Validator { get; set; }
Public Property Validator As InputBoxValidatingHandler
    Get
    Set
public:
property InputBoxValidatingHandler^ Validator {
    InputBoxValidatingHandler^ get ();
    void set (InputBoxValidatingHandler^ value);
}
member Validator : InputBoxValidatingHandler with get, set

Valore della proprietà

InputBoxValidatingHandler
Vedi anche

Documentazione

Classe InputBox


Metodi di InputBox

Il tipo InputBox espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InputBox


Metodo InputBox.Dispose

Metodo InputBoxDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
True per rilasciare sia le risorse managed che quelle unmanaged; false per rilasciare solo quelle unmanaged.
Vedi anche

Documentazione

Classe InputBox


Eventi di InputBox

Il tipo InputBox espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InputBox


Campi di InputBox

Il tipo InputBox espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InputBox


Classe InputBoxResult
Class used to store the result of an InputBox.Show message.
Gerarchia di ereditarietà
SystemObject
QsUIInputBoxResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InputBoxResult
Public Class InputBoxResult
public ref class InputBoxResult
type InputBoxResult = class end

Il tipo InputBoxResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InputBoxResult | Inizializza una nuova istanza della classe InputBoxResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | OK |
Campo pubblico | Text |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore InputBoxResult
Inizializza una nuova istanza della classe InputBoxResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InputBoxResult()
Public Sub New
public:
InputBoxResult()
new : unit -> InputBoxResult
Vedi anche

Documentazione

Classe InputBoxResult


Campi di InputBoxResult

Il tipo InputBoxResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | OK |
Campo pubblico | Text |
Torna su
Vedi anche

Documentazione

Classe InputBoxResult


Campo InputBoxResult.OK

Campo InputBoxResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe InputBoxResult


Campo InputBoxResult.Text

Campo InputBoxResultText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Text
Public Text As String
public:
String^ Text
val mutable Text: string

Valore del campo

String
Vedi anche

Documentazione

Classe InputBoxResult


Classe InputBoxValidatingArgs
EventArgs used to Validate an InputBox
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIInputBoxValidatingArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InputBoxValidatingArgs : EventArgs
Public Class InputBoxValidatingArgs
    Inherits EventArgs
public ref class InputBoxValidatingArgs : public EventArgs
type InputBoxValidatingArgs =
    class
        inherit EventArgs
    end

Il tipo InputBoxValidatingArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InputBoxValidatingArgs | Inizializza una nuova istanza della classe InputBoxValidatingArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel |
Proprietà pubblica | Message |
Proprietà pubblica | Text |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _cancel |
Campo pubblico | _message |
Campo pubblico | _text |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore InputBoxValidatingArgs
Inizializza una nuova istanza della classe InputBoxValidatingArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InputBoxValidatingArgs()
Public Sub New
public:
InputBoxValidatingArgs()
new : unit -> InputBoxValidatingArgs
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà di InputBoxValidatingArgs

Il tipo InputBoxValidatingArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel |
Proprietà pubblica | Message |
Proprietà pubblica | Text |
Torna su
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà InputBoxValidatingArgs.Cancel

Proprietà InputBoxValidatingArgsCancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà InputBoxValidatingArgs.Message

Proprietà InputBoxValidatingArgsMessage

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà InputBoxValidatingArgs.Text

Proprietà InputBoxValidatingArgsText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campi di InputBoxValidatingArgs

Il tipo InputBoxValidatingArgs espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _cancel |
Campo pubblico | _message |
Campo pubblico | _text |
Torna su
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campo InputBoxValidatingArgs._cancel

Campo InputBoxValidatingArgs_cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool _cancel
Public _cancel As Boolean
public:
bool _cancel
val mutable _cancel: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campo InputBoxValidatingArgs._message

Campo InputBoxValidatingArgs_message

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string _message
Public _message As String
public:
String^ _message
val mutable _message: string

Valore del campo

String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campo InputBoxValidatingArgs._text

Campo InputBoxValidatingArgs_text

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string _text
Public _text As String
public:
String^ _text
val mutable _text: string

Valore del campo

String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Delegate InputBoxValidatingHandler
Delegate used to Validate an InputBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void InputBoxValidatingHandler(
    Object sender,
    InputBoxValidatingArgs e
)
Public Delegate Sub InputBoxValidatingHandler (
    sender As Object,
    e As InputBoxValidatingArgs
)
public delegate void InputBoxValidatingHandler(
    Object^ sender,
    InputBoxValidatingArgs^ e
)
type InputBoxValidatingHandler =
    delegate of
        sender : Object *
        e : InputBoxValidatingArgs -> unit

Parametri

sender Object
e InputBoxValidatingArgs
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe IsDirtyEventArgs
EventArgs dell'evento IsDirtyEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIIsDirtyEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class IsDirtyEventArgs : EventArgs
Public Class IsDirtyEventArgs
    Inherits EventArgs
public ref class IsDirtyEventArgs : public EventArgs
type IsDirtyEventArgs =
    class
        inherit EventArgs
    end

Il tipo IsDirtyEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | IsDirtyEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsDirty | Inidca se il controllo è dirty
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore IsDirtyEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public IsDirtyEventArgs(
    bool isDirty
)
Public Sub New (
    isDirty As Boolean
)
public:
IsDirtyEventArgs(
    bool isDirty
)
new :
        isDirty : bool -> IsDirtyEventArgs

Parametri

isDirty Boolean
Valore da impostare
Vedi anche

Documentazione

Classe IsDirtyEventArgs


Proprietà di IsDirtyEventArgs

Il tipo IsDirtyEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsDirty | Inidca se il controllo è dirty
Torna su
Vedi anche

Documentazione

Classe IsDirtyEventArgs


Proprietà IsDirtyEventArgs.IsDirty

Proprietà IsDirtyEventArgsIsDirty
Inidca se il controllo è dirty

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty { get; set; }
Public Property IsDirty As Boolean
    Get
    Set
public:
property bool IsDirty {
    bool get ();
    void set (bool value);
}
member IsDirty : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe IsDirtyEventArgs


Classe LabelTextSetEventArgs
EventArgs dell'evento LabelTextSetEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUILabelTextSetEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class LabelTextSetEventArgs : EventArgs
Public Class LabelTextSetEventArgs
    Inherits EventArgs
public ref class LabelTextSetEventArgs : public EventArgs
type LabelTextSetEventArgs =
    class
        inherit EventArgs
    end

Il tipo LabelTextSetEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LabelTextSetEventArgs | Cotruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | LabelText | Testo da impostare nella label.
Proprietà pubblica | SelLength | Lunghezza della selezione.
Proprietà pubblica | SelStart | Posizione di inizio della selezione.
Proprietà pubblica | TextLength | Lunghezza del testo.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LabelTextSetEventArgs
Cotruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public LabelTextSetEventArgs(
    int textLength,
    int selLength,
    int selStart,
    Object attr
)
Public Sub New (
    textLength As Integer,
    selLength As Integer,
    selStart As Integer,
    attr As Object
)
public:
LabelTextSetEventArgs(
    int textLength,
    int selLength,
    int selStart,
    Object^ attr
)
new :
        textLength : int *
        selLength : int *
        selStart : int *
        attr : Object -> LabelTextSetEventArgs

Parametri

textLength Int32
Lunghezza del testo.
selLength Int32
Lunghezza della selezione
selStart Int32
Posizione di inizio dell aselezione
attr Object
Attributo.
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Proprietà di LabelTextSetEventArgs

Il tipo LabelTextSetEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | LabelText | Testo da impostare nella label.
Proprietà pubblica | SelLength | Lunghezza della selezione.
Proprietà pubblica | SelStart | Posizione di inizio della selezione.
Proprietà pubblica | TextLength | Lunghezza del testo.
Torna su
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Proprietà LabelTextSetEventArgs.Attr

Proprietà LabelTextSetEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Proprietà LabelTextSetEventArgs.LabelText

Proprietà LabelTextSetEventArgsLabelText
Testo da impostare nella label.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string LabelText { get; set; }
Public Property LabelText As String
    Get
    Set
public:
property String^ LabelText {
    String^ get ();
    void set (String^ value);
}
member LabelText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Proprietà LabelTextSetEventArgs.SelLength

Proprietà LabelTextSetEventArgsSelLength
Lunghezza della selezione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int SelLength { get; }
Public ReadOnly Property SelLength As Integer
    Get
public:
property int SelLength {
    int get ();
}
member SelLength : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Proprietà LabelTextSetEventArgs.SelStart

Proprietà LabelTextSetEventArgsSelStart
Posizione di inizio della selezione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int SelStart { get; }
Public ReadOnly Property SelStart As Integer
    Get
public:
property int SelStart {
    int get ();
}
member SelStart : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Proprietà LabelTextSetEventArgs.TextLength

Proprietà LabelTextSetEventArgsTextLength
Lunghezza del testo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int TextLength { get; }
Public ReadOnly Property TextLength As Integer
    Get
public:
property int TextLength {
    int get ();
}
member TextLength : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe LabelTextSetEventArgs


Classe ListChoice
Classe che permette di visualizzare un form per scegliere gli elementi da una lista.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIListChoice

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ListChoice : QsBaseForm
Public Class ListChoice
    Inherits QsBaseForm
public ref class ListChoice : public QsBaseForm
type ListChoice =
    class
        inherit QsBaseForm
    end

Il tipo ListChoice espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ListChoice(String, Object) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32) | Costruttore.
Metodo pubblico | ListChoice(String, Object, String) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, String) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32, Int32) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32, String) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32, Int32, String) | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | Selected | Restiutisce l'oggetto selezionato.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ListChoice
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ListChoice(String, Object) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32) | Costruttore.
Metodo pubblico | ListChoice(String, Object, String) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, String) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32, Int32) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32, String) | Costruttore.
Metodo pubblico | ListChoice(String, Object, Int32, Int32, Int32, String) | Costruttore.
Torna su
Vedi anche

Documentazione

Classe ListChoice


Costruttore ListChoice(String, Object)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource
)
Public Sub New (
    title As String,
    datasource As Object
)
public:
ListChoice(
    String^ title,
    Object^ datasource
)
new :
        title : string *
        datasource : Object -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, Int32)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width
)
Public Sub New (
    title As String,
    datasource As Object,
    width As Integer
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width
)
new :
        title : string *
        datasource : Object *
        width : int -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
width Int32
Larghezza della finestra (passare -1 in caso si voglia ignorare).
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, String)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    string alignment
)
Public Sub New (
    title As String,
    datasource As Object,
    alignment As String
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    String^ alignment
)
new :
        title : string *
        datasource : Object *
        alignment : string -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
alignment String
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, Int32, Int32)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width,
    int height
)
Public Sub New (
    title As String,
    datasource As Object,
    width As Integer,
    height As Integer
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width,
    int height
)
new :
        title : string *
        datasource : Object *
        width : int *
        height : int -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
width Int32
Larghezza della finestra (passare -1 in caso si voglia ignorare).
height Int32
Altezza della finestra (passare -1 in caso si voglia ignorare).
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, Int32, String)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width,
    string alignment
)
Public Sub New (
    title As String,
    datasource As Object,
    width As Integer,
    alignment As String
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width,
    String^ alignment
)
new :
        title : string *
        datasource : Object *
        width : int *
        alignment : string -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
width Int32
Larghezza della finestra (passare -1 in caso si voglia ignorare).
alignment String
Allineamento del testo nella tabella.
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, Int32, Int32, Int32)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width,
    int height,
    int sel
)
Public Sub New (
    title As String,
    datasource As Object,
    width As Integer,
    height As Integer,
    sel As Integer
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width,
    int height,
    int sel
)
new :
        title : string *
        datasource : Object *
        width : int *
        height : int *
        sel : int -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
width Int32
Larghezza della finestra (passare -1 in caso si voglia ignorare).
height Int32
Altezza della finestra (passare -1 in caso si voglia ignorare).
sel Int32
Indice dell'elemento selezionato inizialmente.
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, Int32, Int32, String)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width,
    int height,
    string alignment
)
Public Sub New (
    title As String,
    datasource As Object,
    width As Integer,
    height As Integer,
    alignment As String
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width,
    int height,
    String^ alignment
)
new :
        title : string *
        datasource : Object *
        width : int *
        height : int *
        alignment : string -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
width Int32
Larghezza della finestra (passare -1 in caso si voglia ignorare).
height Int32
Altezza della finestra (passare -1 in caso si voglia ignorare).
alignment String
Allineamento del testo nella tabella.
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Costruttore ListChoice(String, Object, Int32, Int32, Int32, String)
Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width,
    int height,
    int sel,
    string alignment
)
Public Sub New (
    title As String,
    datasource As Object,
    width As Integer,
    height As Integer,
    sel As Integer,
    alignment As String
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width,
    int height,
    int sel,
    String^ alignment
)
new :
        title : string *
        datasource : Object *
        width : int *
        height : int *
        sel : int *
        alignment : string -> ListChoice

Parametri

title String
Titolo della finestra.
datasource Object
Lista da bindare alla griglia.
width Int32
Larghezza della finestra (passare -1 in caso si voglia ignorare).
height Int32
Altezza della finestra (passare -1 in caso si voglia ignorare).
sel Int32
Indice dell'elemento selezionato inizialmente.
alignment String
Allineamento del testo nella tabella.
Vedi anche

Documentazione

Classe ListChoice
Overload di ListChoice


Proprietà di ListChoice

Il tipo ListChoice espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | Selected | Restiutisce l'oggetto selezionato.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Proprietà ListChoice.Selected

Proprietà ListChoiceSelected
Restiutisce l'oggetto selezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Selected { get; set; }
Public Property Selected As Object
    Get
    Set
public:
property Object^ Selected {
    Object^ get ();
    void set (Object^ value);
}
member Selected : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ListChoice


Metodi di ListChoice

Il tipo ListChoice espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Metodo ListChoice.Dispose

Metodo ListChoiceDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ListChoice


Eventi di ListChoice

Il tipo ListChoice espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Campi di ListChoice

Il tipo ListChoice espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Classe LolEditor
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUILolEditor

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class LolEditor : QsBaseForm
Public Class LolEditor
    Inherits QsBaseForm
public ref class LolEditor : public QsBaseForm
type LolEditor =
    class
        inherit QsBaseForm
    end

Il tipo LolEditor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LolEditor | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GridView |
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | Selected |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo pubblico | InitializeGrid(ColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(ListColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32, ListString, ColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32, ListString, ListColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnEditValueEvent | Lancia l'evento EditValueEvent.
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnRowColorEvent | Lancia l'evento RowColorEvent.
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnSelectionChanged | Lancia l'evento SelectionChangedEvent.
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | EditValueEvent | Evento che permette il controllo sull'editazione di una cella da lua.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | RowColorEvent | Evento che permette la colorazione delle celle da lua.
Evento pubblico | SelectedRowChangedEvent | Evento che permette il controllo sulla selezione di una riga da lua.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LolEditor
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public LolEditor(
    List<List<string>> datasource
)
Public Sub New (
    datasource As List(Of List(Of String))
)
public:
LolEditor(
    List<List<String^>^>^ datasource
)
new :
        datasource : List<List<string>> -> LolEditor

Parametri

datasource List List String
Lista dei dati da mostrare nella griglia.
Vedi anche

Documentazione

Classe LolEditor


Proprietà di LolEditor

Il tipo LolEditor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GridView |
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | Selected |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LolEditor


Proprietà LolEditor.GridView

Proprietà LolEditorGridView

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridView GridView { get; set; }
Public Property GridView As GridView
    Get
    Set
public:
property GridView^ GridView {
    GridView^ get ();
    void set (GridView^ value);
}
member GridView : GridView with get, set

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe LolEditor


Proprietà LolEditor.Selected

Proprietà LolEditorSelected

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Selected { get; set; }
Public Property Selected As Object
    Get
    Set
public:
property Object^ Selected {
    Object^ get ();
    void set (Object^ value);
}
member Selected : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe LolEditor


Metodi di LolEditor

Il tipo LolEditor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo pubblico | InitializeGrid(ColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(ListColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32, ListString, ColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32, ListString, ListColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnEditValueEvent | Lancia l'evento EditValueEvent.
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnRowColorEvent | Lancia l'evento RowColorEvent.
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnSelectionChanged | Lancia l'evento SelectionChangedEvent.
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LolEditor


Metodo LolEditor.Dispose

Metodo LolEditorDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe LolEditor


Metodo LolEditor.InitializeGrid

Metodo LolEditorInitializeGrid
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | InitializeGrid(ColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(ListColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32, ListString, ColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Metodo pubblico | InitializeGrid(Int32, ListString, ListColumnOptions) | Permette l'inizializzazione della griglia creando colonne e righe.
Torna su
Vedi anche

Documentazione

Classe LolEditor


Metodo LolEditor.InitializeGrid(ColumnOptions)

Metodo LolEditorInitializeGrid(ColumnOptions)
Permette l'inizializzazione della griglia creando colonne e righe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int InitializeGrid(
    ColumnOptions columnOptions
)
Public Function InitializeGrid (
    columnOptions As ColumnOptions
) As Integer
public:
int InitializeGrid(
    ColumnOptions^ columnOptions
)
member InitializeGrid :
        columnOptions : ColumnOptions -> int

Parametri

columnOptions ColumnOptions
Opzioni aggiuntive per una singola colonna.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe LolEditor
Overload di InitializeGrid


Metodo LolEditor.InitializeGrid(Int32)

Metodo LolEditorInitializeGrid(Int32)
Permette l'inizializzazione della griglia creando colonne e righe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int InitializeGrid(
    int checkbox
)
Public Function InitializeGrid (
    checkbox As Integer
) As Integer
public:
int InitializeGrid(
    int checkbox
)
member InitializeGrid :
        checkbox : int -> int

Parametri

checkbox Int32
Imposta il tipo di selezione. 1 se deve essere attivata la multiselezione attraverso checkbox, 0 per la selezione singola.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe LolEditor
Overload di InitializeGrid


Metodo LolEditor.InitializeGrid(List<ColumnOptions>)

Metodo LolEditorInitializeGrid(ListColumnOptions)
Permette l'inizializzazione della griglia creando colonne e righe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int InitializeGrid(
    List<ColumnOptions> columnOptions
)
Public Function InitializeGrid (
    columnOptions As List(Of ColumnOptions)
) As Integer
public:
int InitializeGrid(
    List<ColumnOptions^>^ columnOptions
)
member InitializeGrid :
        columnOptions : List<ColumnOptions> -> int

Parametri

columnOptions List ColumnOptions
Lista di opzioni aggiuntive per le colonne.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe LolEditor
Overload di InitializeGrid


Metodo LolEditor.InitializeGrid(Int32, List<String>, ColumnOptions)

Metodo LolEditorInitializeGrid(Int32, ListString, ColumnOptions)
Permette l'inizializzazione della griglia creando colonne e righe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int InitializeGrid(
    int checkbox,
    List<string> hiddencolumns,
    ColumnOptions columnOptions
)
Public Function InitializeGrid (
    checkbox As Integer,
    hiddencolumns As List(Of String),
    columnOptions As ColumnOptions
) As Integer
public:
int InitializeGrid(
    int checkbox,
    List<String^>^ hiddencolumns,
    ColumnOptions^ columnOptions
)
member InitializeGrid :
        checkbox : int *
        hiddencolumns : List<string> *
        columnOptions : ColumnOptions -> int

Parametri

checkbox Int32
Imposta il tipo di selezione. 1 se deve essere attivata la multiselezione attraverso checkbox, 0 per la selezione singola.
hiddencolumns List String
Lista di intestazioni delle colonne da nascondere.
columnOptions ColumnOptions
Opzioni aggiuntive per una singola colonna.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe LolEditor
Overload di InitializeGrid


Metodo LolEditor.InitializeGrid(Int32, List<String>, List<ColumnOptions>)

Metodo LolEditorInitializeGrid(Int32, ListString, ListColumnOptions)
Permette l'inizializzazione della griglia creando colonne e righe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int InitializeGrid(
    int checkbox,
    List<string> hiddencolumns,
    List<ColumnOptions> columnOptions
)
Public Function InitializeGrid (
    checkbox As Integer,
    hiddencolumns As List(Of String),
    columnOptions As List(Of ColumnOptions)
) As Integer
public:
int InitializeGrid(
    int checkbox,
    List<String^>^ hiddencolumns,
    List<ColumnOptions^>^ columnOptions
)
member InitializeGrid :
        checkbox : int *
        hiddencolumns : List<string> *
        columnOptions : List<ColumnOptions> -> int

Parametri

checkbox Int32
Imposta il tipo di selezione. 1 se deve essere attivata la multiselezione attraverso checkbox, 0 per la selezione singola.
hiddencolumns List String
Lista di intestazioni delle colonne da nascondere.
columnOptions List ColumnOptions
Lista di opzioni aggiuntive per le colonne.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe LolEditor
Overload di InitializeGrid


Metodo LolEditor.OnEditValueEvent

Metodo LolEditorOnEditValueEvent
Lancia l'evento EditValueEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnEditValueEvent(
    Object sender,
    LolEditorEditValueEventArgs e
)
Protected Friend Sub OnEditValueEvent (
    sender As Object,
    e As LolEditorEditValueEventArgs
)
protected public:
void OnEditValueEvent(
    Object^ sender,
    LolEditorEditValueEventArgs^ e
)
member OnEditValueEvent :
        sender : Object *
        e : LolEditorEditValueEventArgs -> unit

Parametri

sender Object
e LolEditorEditValueEventArgs
Vedi anche

Documentazione

Classe LolEditor


Metodo LolEditor.OnRowColorEvent

Metodo LolEditorOnRowColorEvent
Lancia l'evento RowColorEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRowColorEvent(
    LolEditorRowColorEventArgs e
)
Protected Friend Sub OnRowColorEvent (
    e As LolEditorRowColorEventArgs
)
protected public:
void OnRowColorEvent(
    LolEditorRowColorEventArgs^ e
)
member OnRowColorEvent :
        e : LolEditorRowColorEventArgs -> unit

Parametri

e LolEditorRowColorEventArgs
Vedi anche

Documentazione

Classe LolEditor


Metodo LolEditor.OnSelectionChanged

Metodo LolEditorOnSelectionChanged
Lancia l'evento SelectionChangedEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnSelectionChanged(
    Object sender,
    LolEditorSelectedRowChangedEventArgs e
)
Protected Friend Sub OnSelectionChanged (
    sender As Object,
    e As LolEditorSelectedRowChangedEventArgs
)
protected public:
void OnSelectionChanged(
    Object^ sender,
    LolEditorSelectedRowChangedEventArgs^ e
)
member OnSelectionChanged :
        sender : Object *
        e : LolEditorSelectedRowChangedEventArgs -> unit

Parametri

sender Object
e LolEditorSelectedRowChangedEventArgs
Vedi anche

Documentazione

Classe LolEditor


Eventi di LolEditor

Il tipo LolEditor espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | EditValueEvent | Evento che permette il controllo sull'editazione di una cella da lua.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | RowColorEvent | Evento che permette la colorazione delle celle da lua.
Evento pubblico | SelectedRowChangedEvent | Evento che permette il controllo sulla selezione di una riga da lua.
Torna su
Vedi anche

Documentazione

Classe LolEditor


Evento LolEditor.EditValueEvent

Evento LolEditorEditValueEvent
Evento che permette il controllo sull'editazione di una cella da lua.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<LolEditorEditValueEventArgs> EditValueEvent
Public Event EditValueEvent As EventHandler(Of LolEditorEditValueEventArgs)
public:
 event EventHandler<LolEditorEditValueEventArgs^>^ EditValueEvent {
    void add (EventHandler<LolEditorEditValueEventArgs^>^ value);
    void remove (EventHandler<LolEditorEditValueEventArgs^>^ value);
}
member EditValueEvent : IEvent<EventHandler<LolEditorEditValueEventArgs>,
    LolEditorEditValueEventArgs>

Valore

EventHandler LolEditorEditValueEventArgs
Vedi anche

Documentazione

Classe LolEditor


Evento LolEditor.RowColorEvent

Evento LolEditorRowColorEvent
Evento che permette la colorazione delle celle da lua.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<LolEditorRowColorEventArgs> RowColorEvent
Public Event RowColorEvent As EventHandler(Of LolEditorRowColorEventArgs)
public:
 event EventHandler<LolEditorRowColorEventArgs^>^ RowColorEvent {
    void add (EventHandler<LolEditorRowColorEventArgs^>^ value);
    void remove (EventHandler<LolEditorRowColorEventArgs^>^ value);
}
member RowColorEvent : IEvent<EventHandler<LolEditorRowColorEventArgs>,
    LolEditorRowColorEventArgs>

Valore

EventHandler LolEditorRowColorEventArgs
Vedi anche

Documentazione

Classe LolEditor


Evento LolEditor.SelectedRowChangedEvent

Evento LolEditorSelectedRowChangedEvent
Evento che permette il controllo sulla selezione di una riga da lua.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<LolEditorSelectedRowChangedEventArgs> SelectedRowChangedEvent
Public Event SelectedRowChangedEvent As EventHandler(Of LolEditorSelectedRowChangedEventArgs)
public:
 event EventHandler<LolEditorSelectedRowChangedEventArgs^>^ SelectedRowChangedEvent {
    void add (EventHandler<LolEditorSelectedRowChangedEventArgs^>^ value);
    void remove (EventHandler<LolEditorSelectedRowChangedEventArgs^>^ value);
}
member SelectedRowChangedEvent : IEvent<EventHandler<LolEditorSelectedRowChangedEventArgs>,
    LolEditorSelectedRowChangedEventArgs>

Valore

EventHandler LolEditorSelectedRowChangedEventArgs
Vedi anche

Documentazione

Classe LolEditor


Campi di LolEditor

Il tipo LolEditor espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LolEditor


Classe LolEditor.EditValueEventArgs

Classe LolEditorEditValueEventArgs
Fornisce dati relativi all'evento di editazione di una cella.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
QsUILolEditorEditValueEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class EditValueEventArgs : CancelEventArgs
Public Class EditValueEventArgs
    Inherits CancelEventArgs
public ref class EditValueEventArgs : public CancelEventArgs
type EditValueEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo LolEditorEditValueEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LolEditorEditValueEventArgs | Inizializza una nuova istanza della classe LolEditorEditValueEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ColName | Nome della colonna a cui appartiene la cella modificata.
Proprietà pubblica | ErrorText | Messaggio di errore in caso di cancellazione.
Proprietà pubblica | Grid | Griglia che ha fatto scattare l'evento.
Proprietà pubblica | RowHandle | Indice della riga a cui appartiene la cella modificata.
Proprietà pubblica | Value | Valore contenuto nella cella modificata.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LolEditor.EditValueEventArgs

Costruttore LolEditorEditValueEventArgs
Inizializza una nuova istanza della classe LolEditorEditValueEventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public EditValueEventArgs()
Public Sub New
public:
EditValueEventArgs()
new : unit -> EditValueEventArgs
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Proprietà di EditValueEventArgs

Il tipo LolEditorEditValueEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ColName | Nome della colonna a cui appartiene la cella modificata.
Proprietà pubblica | ErrorText | Messaggio di errore in caso di cancellazione.
Proprietà pubblica | Grid | Griglia che ha fatto scattare l'evento.
Proprietà pubblica | RowHandle | Indice della riga a cui appartiene la cella modificata.
Proprietà pubblica | Value | Valore contenuto nella cella modificata.
Torna su
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Proprietà LolEditor.EditValueEventArgs.ColName

Proprietà LolEditorEditValueEventArgsColName
Nome della colonna a cui appartiene la cella modificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; protected internal set; }
Public Property ColName As String
    Get
    Protected Friend Set
public:
property String^ ColName {
    String^ get ();
    protected public: void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Proprietà LolEditor.EditValueEventArgs.ErrorText

Proprietà LolEditorEditValueEventArgsErrorText
Messaggio di errore in caso di cancellazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
member ErrorText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Proprietà LolEditor.EditValueEventArgs.Grid

Proprietà LolEditorEditValueEventArgsGrid
Griglia che ha fatto scattare l'evento.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridView Grid { get; set; }
Public Property Grid As GridView
    Get
    Set
public:
property GridView^ Grid {
    GridView^ get ();
    void set (GridView^ value);
}
member Grid : GridView with get, set

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Proprietà LolEditor.EditValueEventArgs.RowHandle

Proprietà LolEditorEditValueEventArgsRowHandle
Indice della riga a cui appartiene la cella modificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int RowHandle { get; protected internal set; }
Public Property RowHandle As Integer
    Get
    Protected Friend Set
public:
property int RowHandle {
    int get ();
    protected public: void set (int value);
}
member RowHandle : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Proprietà LolEditor.EditValueEventArgs.Value

Proprietà LolEditorEditValueEventArgsValue
Valore contenuto nella cella modificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; protected internal set; }
Public Property Value As Object
    Get
    Protected Friend Set
public:
property Object^ Value {
    Object^ get ();
    protected public: void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe LolEditorEditValueEventArgs


Classe LolEditor.RowColorEventArgs

Classe LolEditorRowColorEventArgs
Fornisce dati relativi all'evento di colorazione di una cella.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
QsUILolEditorRowColorEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class RowColorEventArgs : HandledEventArgs
Public Class RowColorEventArgs
    Inherits HandledEventArgs
public ref class RowColorEventArgs : public HandledEventArgs
type RowColorEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo LolEditorRowColorEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LolEditorRowColorEventArgs | Inizializza una nuova istanza della classe LolEditorRowColorEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor | Colore di sfondo della cella.
Proprietà pubblica | CellValue | Valore contenuto nella cella.
Proprietà pubblica | ColName | Nome della colonna a cui appartiene la cella.
Proprietà pubblica | ForeColor | Colore del testo della cella.
Proprietà pubblica | Grid | Griglia che ha fatto scattare l'evento.
Proprietà pubblica | RowHandle | Indice della riga a cui appartiene la cella.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LolEditor.RowColorEventArgs

Costruttore LolEditorRowColorEventArgs
Inizializza una nuova istanza della classe LolEditorRowColorEventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RowColorEventArgs()
Public Sub New
public:
RowColorEventArgs()
new : unit -> RowColorEventArgs
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà di RowColorEventArgs

Il tipo LolEditorRowColorEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor | Colore di sfondo della cella.
Proprietà pubblica | CellValue | Valore contenuto nella cella.
Proprietà pubblica | ColName | Nome della colonna a cui appartiene la cella.
Proprietà pubblica | ForeColor | Colore del testo della cella.
Proprietà pubblica | Grid | Griglia che ha fatto scattare l'evento.
Proprietà pubblica | RowHandle | Indice della riga a cui appartiene la cella.
Torna su
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà LolEditor.RowColorEventArgs.BackColor

Proprietà LolEditorRowColorEventArgsBackColor
Colore di sfondo della cella.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà LolEditor.RowColorEventArgs.CellValue

Proprietà LolEditorRowColorEventArgsCellValue
Valore contenuto nella cella.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object CellValue { get; protected internal set; }
Public Property CellValue As Object
    Get
    Protected Friend Set
public:
property Object^ CellValue {
    Object^ get ();
    protected public: void set (Object^ value);
}
member CellValue : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà LolEditor.RowColorEventArgs.ColName

Proprietà LolEditorRowColorEventArgsColName
Nome della colonna a cui appartiene la cella.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; protected internal set; }
Public Property ColName As String
    Get
    Protected Friend Set
public:
property String^ ColName {
    String^ get ();
    protected public: void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà LolEditor.RowColorEventArgs.ForeColor

Proprietà LolEditorRowColorEventArgsForeColor
Colore del testo della cella.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà LolEditor.RowColorEventArgs.Grid

Proprietà LolEditorRowColorEventArgsGrid
Griglia che ha fatto scattare l'evento.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridView Grid { get; set; }
Public Property Grid As GridView
    Get
    Set
public:
property GridView^ Grid {
    GridView^ get ();
    void set (GridView^ value);
}
member Grid : GridView with get, set

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Proprietà LolEditor.RowColorEventArgs.RowHandle

Proprietà LolEditorRowColorEventArgsRowHandle
Indice della riga a cui appartiene la cella.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int RowHandle { get; protected internal set; }
Public Property RowHandle As Integer
    Get
    Protected Friend Set
public:
property int RowHandle {
    int get ();
    protected public: void set (int value);
}
member RowHandle : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe LolEditorRowColorEventArgs


Classe LolEditor.SelectedRowChangedEventArgs

Classe LolEditorSelectedRowChangedEventArgs
Fornisce dati relativi all'evento di cambio di selezione di una riga.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
QsUILolEditorSelectedRowChangedEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SelectedRowChangedEventArgs : CancelEventArgs
Public Class SelectedRowChangedEventArgs
    Inherits CancelEventArgs
public ref class SelectedRowChangedEventArgs : public CancelEventArgs
type SelectedRowChangedEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo LolEditorSelectedRowChangedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LolEditorSelectedRowChangedEventArgs | Inizializza una nuova istanza della classe LolEditorSelectedRowChangedEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CheckState | Stato della checkbox. True se è checkata, altrimenti False.
Proprietà pubblica | Grid | Griglia che ha fatto scattare l'evento.
Proprietà pubblica | RowHandle | Indice della riga selezionata.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LolEditor.SelectedRowChangedEventArgs

Costruttore LolEditorSelectedRowChangedEventArgs
Inizializza una nuova istanza della classe LolEditorSelectedRowChangedEventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SelectedRowChangedEventArgs()
Public Sub New
public:
SelectedRowChangedEventArgs()
new : unit -> SelectedRowChangedEventArgs
Vedi anche

Documentazione

Classe LolEditorSelectedRowChangedEventArgs


Proprietà di SelectedRowChangedEventArgs

Il tipo LolEditorSelectedRowChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CheckState | Stato della checkbox. True se è checkata, altrimenti False.
Proprietà pubblica | Grid | Griglia che ha fatto scattare l'evento.
Proprietà pubblica | RowHandle | Indice della riga selezionata.
Torna su
Vedi anche

Documentazione

Classe LolEditorSelectedRowChangedEventArgs


Proprietà LolEditor.SelectedRowChangedEventArgs.CheckState

Proprietà LolEditorSelectedRowChangedEventArgsCheckState
Stato della checkbox. True se è checkata, altrimenti False.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckState { get; protected internal set; }
Public Property CheckState As Boolean
    Get
    Protected Friend Set
public:
property bool CheckState {
    bool get ();
    protected public: void set (bool value);
}
member CheckState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LolEditorSelectedRowChangedEventArgs


Proprietà LolEditor.SelectedRowChangedEventArgs.Grid

Proprietà LolEditorSelectedRowChangedEventArgsGrid
Griglia che ha fatto scattare l'evento.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridView Grid { get; set; }
Public Property Grid As GridView
    Get
    Set
public:
property GridView^ Grid {
    GridView^ get ();
    void set (GridView^ value);
}
member Grid : GridView with get, set

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe LolEditorSelectedRowChangedEventArgs


Proprietà LolEditor.SelectedRowChangedEventArgs.RowHandle

Proprietà LolEditorSelectedRowChangedEventArgsRowHandle
Indice della riga selezionata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int RowHandle { get; protected internal set; }
Public Property RowHandle As Integer
    Get
    Protected Friend Set
public:
property int RowHandle {
    int get ();
    protected public: void set (int value);
}
member RowHandle : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe LolEditorSelectedRowChangedEventArgs


Classe LuaExecuteForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUILuaExecuteForm

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class LuaExecuteForm : QsBaseForm
Public Class LuaExecuteForm
    Inherits QsBaseForm
public ref class LuaExecuteForm : public QsBaseForm
type LuaExecuteForm =
    class
        inherit QsBaseForm
    end

Il tipo LuaExecuteForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LuaExecuteForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadRecentFiles |
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveRecentFiles |
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateRecentFiles |
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LuaExecuteForm
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public LuaExecuteForm()
Public Sub New
public:
LuaExecuteForm()
new : unit -> LuaExecuteForm
Vedi anche

Documentazione

Classe LuaExecuteForm


Proprietà di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodi di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadRecentFiles |
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveRecentFiles |
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateRecentFiles |
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodo LuaExecuteForm.Dispose

Metodo LuaExecuteFormDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodo LuaExecuteForm.LoadRecentFiles

Metodo LuaExecuteFormLoadRecentFiles

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void LoadRecentFiles()
Protected Sub LoadRecentFiles
protected:
void LoadRecentFiles()
member LoadRecentFiles : unit -> unit
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodo LuaExecuteForm.SaveRecentFiles

Metodo LuaExecuteFormSaveRecentFiles

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void SaveRecentFiles()
Protected Sub SaveRecentFiles
protected:
void SaveRecentFiles()
member SaveRecentFiles : unit -> unit
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodo LuaExecuteForm.UpdateRecentFiles

Metodo LuaExecuteFormUpdateRecentFiles

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void UpdateRecentFiles(
    string file
)
Protected Sub UpdateRecentFiles (
    file As String
)
protected:
void UpdateRecentFiles(
    String^ file
)
member UpdateRecentFiles :
        file : string -> unit

Parametri

file String
Vedi anche

Documentazione

Classe LuaExecuteForm


Eventi di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Campi di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Classe LuaValidatingEventArgs
EventArgs dell'evento LuaValidatingEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUILuaValidatingEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class LuaValidatingEventArgs : EventArgs
Public Class LuaValidatingEventArgs
    Inherits EventArgs
public ref class LuaValidatingEventArgs : public EventArgs
type LuaValidatingEventArgs =
    class
        inherit EventArgs
    end

Il tipo LuaValidatingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LuaValidatingEventArgs | Costruttore unico.
Metodo pubblico | LuaValidatingEventArgs(Boolean) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Silent | Indica se la validazione deve essere silent.
Proprietà pubblica | Valid | Indica il risultato della validazione.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LuaValidatingEventArgs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | LuaValidatingEventArgs | Costruttore unico.
Metodo pubblico | LuaValidatingEventArgs(Boolean) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe LuaValidatingEventArgs


Costruttore LuaValidatingEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public LuaValidatingEventArgs()
Public Sub New
public:
LuaValidatingEventArgs()
new : unit -> LuaValidatingEventArgs
Vedi anche

Documentazione

Classe LuaValidatingEventArgs
Overload di LuaValidatingEventArgs


Costruttore LuaValidatingEventArgs(Boolean)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public LuaValidatingEventArgs(
    bool silent
)
Public Sub New (
    silent As Boolean
)
public:
LuaValidatingEventArgs(
    bool silent
)
new :
        silent : bool -> LuaValidatingEventArgs

Parametri

silent Boolean
Indica se deve essere silent
Vedi anche

Documentazione

Classe LuaValidatingEventArgs
Overload di LuaValidatingEventArgs


Proprietà di LuaValidatingEventArgs

Il tipo LuaValidatingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Silent | Indica se la validazione deve essere silent.
Proprietà pubblica | Valid | Indica il risultato della validazione.
Torna su
Vedi anche

Documentazione

Classe LuaValidatingEventArgs


Proprietà LuaValidatingEventArgs.Silent

Proprietà LuaValidatingEventArgsSilent
Indica se la validazione deve essere silent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Silent { get; }
Public ReadOnly Property Silent As Boolean
    Get
public:
property bool Silent {
    bool get ();
}
member Silent : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LuaValidatingEventArgs


Proprietà LuaValidatingEventArgs.Valid

Proprietà LuaValidatingEventArgsValid
Indica il risultato della validazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set
public:
property bool Valid {
    bool get ();
    void set (bool value);
}
member Valid : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LuaValidatingEventArgs


Classe MessageBoxResult
Gerarchia di ereditarietà
SystemObject
QsUIMessageBoxResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class MessageBoxResult
Public Class MessageBoxResult
public ref class MessageBoxResult
type MessageBoxResult = class end

Il tipo MessageBoxResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MessageBoxResult | Inizializza una nuova istanza della classe MessageBoxResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | Choice |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore MessageBoxResult
Inizializza una nuova istanza della classe MessageBoxResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public MessageBoxResult()
Public Sub New
public:
MessageBoxResult()
new : unit -> MessageBoxResult
Vedi anche

Documentazione

Classe MessageBoxResult


Campi di MessageBoxResult

Il tipo MessageBoxResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Choice |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Classe MessageBoxResult


Campo MessageBoxResult.Choice

Campo MessageBoxResultChoice

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Choice
Public Choice As Integer
public:
int Choice
val mutable Choice: int

Valore del campo

Int32
Vedi anche

Documentazione

Classe MessageBoxResult


Campo MessageBoxResult.OK

Campo MessageBoxResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe MessageBoxResult


Classe MyGridControl
Griglia custom che implementa l'override di OnPaint.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
GridControl
QsUIMyGridControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class MyGridControl : GridControl
Public Class MyGridControl
    Inherits GridControl
public ref class MyGridControl : public GridControl
type MyGridControl =
    class
        inherit GridControl
    end

Il tipo MyGridControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyGridControl | Inizializza una nuova istanza della classe MyGridControl.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | AllowLayoutEvent | (Ereditato da GridControl)
Proprietà pubblica | AllowRestoreSelectionAndFocusedRow | (Ereditato da GridControl)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà pubblica | AvailableViews | (Ereditato da GridControl)
Proprietà pubblica | BackColor | (Ereditato da GridControl)
Proprietà pubblica | BindingContext | (Ereditato da GridControl)
Proprietà pubblica | ContextMenuStrip | (Ereditato da GridControl)
Proprietà pubblica | Controls | (Ereditato da GridControl)
Proprietà pubblica | Cursor | (Ereditato da GridControl)
Proprietà pubblica | DataMember | (Ereditato da GridControl)
Proprietà pubblica | DataSource | (Ereditato da GridControl)
Proprietà protetta | DefaultSize | (Ereditato da GridControl)
Proprietà pubblica | DefaultView | (Ereditato da GridControl)
Proprietà protetta | DirectXProvider | (Ereditato da GridControl)
Proprietà protetta | DirectXScroller | (Ereditato da GridControl)
Proprietà pubblica | Dock | (Ereditato da GridControl)
Proprietà protetta | DragController | (Ereditato da GridControl)
Proprietà protetta | EditorHelper | (Ereditato da GridControl)
Proprietà pubblica | EmbeddedNavigator | (Ereditato da GridControl)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da GridControl)
Proprietà protetta | ExceptionThrown | (Ereditato da GridControl)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da GridControl)
Proprietà pubblica | FocusedView | (Ereditato da GridControl)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormsUseDefaultLookAndFeel | (Ereditato da GridControl)
Proprietà pubblica | GridDisposing | (Ereditato da GridControl)
Proprietà pubblica | IsAttachedToSearchControl | (Ereditato da GridControl)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà pubblica | IsFocused | (Ereditato da GridControl)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsInPrintMessage | (Ereditato da GridControl)
Proprietà pubblica | IsLoaded | (Ereditato da GridControl)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockUpdate | (Ereditato da GridControl)
Proprietà protetta | IsPrinterExist | (Ereditato da GridControl)
Proprietà pubblica | IsPrinting | (Ereditato da GridControl)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da GridControl)
Proprietà protetta | IsPrintWrapperValid | (Ereditato da GridControl)
Proprietà protetta | IsRightToLeft | (Ereditato da GridControl)
Proprietà pubblica | IsSplitGrid | (Ereditato da GridControl)
Proprietà pubblica | KeyboardFocusView | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | LevelTree | (Ereditato da GridControl)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpOwner | (Ereditato da GridControl)
Proprietà pubblica | MainView | (Ereditato da GridControl)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MouseCaptureOwner | (Ereditato da GridControl)
Proprietà protetta | NavigatableHelper | (Ereditato da GridControl)
Proprietà protetta | NavView | (Ereditato da GridControl)
Proprietà protetta | Printer | (Ereditato da GridControl)
Proprietà protetta | PrintWrapper | (Ereditato da GridControl)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | Scroller | (Ereditato da GridControl)
Proprietà pubblica | ServerMode | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | ShowOnlyPredefinedDetails | (Ereditato da GridControl)
Proprietà protetta | SplitContainer | (Ereditato da GridControl)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TouchClient | (Ereditato da GridControl)
Proprietà pubblica | UseDirectXPaint | (Ereditato da GridControl)
Proprietà protetta | UseDirectXPaintCore | (Ereditato da GridControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da GridControl)
Proprietà pubblica | UseEmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | ViewCollection | (Ereditato da GridControl)
Proprietà protetta | ViewRepository | (Ereditato da GridControl)
Proprietà pubblica | Views | (Ereditato da GridControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da GridControl)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32) | (Ereditato da GridControl)
Metodo protetto | ActivateDataSource | (Ereditato da GridControl)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo pubblico | BeginInit | (Ereditato da GridControl)
Metodo pubblico | BeginUpdate | (Ereditato da GridControl)
Metodo protetto | CancelUpdate | (Ereditato da GridControl)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CheckMousePos | (Ereditato da GridControl)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckPrintWrapper | (Ereditato da GridControl)
Metodo protetto | CheckProcessMsg | (Ereditato da GridControl)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da GridControl)
Metodo protetto | CreateComponentPrinter | (Ereditato da GridControl)
Metodo protetto | CreateDefaultView | (Ereditato da GridControl)
Metodo protetto | CreateEmbeddedNavigator | (Ereditato da GridControl)
Metodo pubblico | CreateGraphicsCache | (Ereditato da GridControl)
Metodo protetto | CreateHelper | (Ereditato da GridControl)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateMainView | (Ereditato da GridControl)
Metodo pubblico | CreateSplitContainer | (Ereditato da GridControl)
Metodo pubblico | CreateView | (Ereditato da GridControl)
Metodo protetto | CreateViewPrintWrapper | (Ereditato da GridControl)
Metodo protetto | DestroyAvailableViews | (Ereditato da GridControl)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyPrinting | (Ereditato da GridControl)
Metodo protetto | Dispose | (Ereditato da GridControl)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da GridControl)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndUpdate | (Ereditato da GridControl)
Metodo protetto | EndUpdate(Boolean) | (Ereditato da GridControl)
Metodo protetto | EnforceValidDataMember | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToExcelOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtmlOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToTextOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | FireChanged | (Ereditato da GridControl)
Metodo protetto | FireChanged(Object) | (Ereditato da GridControl)
Metodo protetto | FocusViewByMouse | (Ereditato da GridControl)
Metodo pubblico | ForceInitialize | (Ereditato da GridControl)
Metodo protetto | ForceViewInitialize | (Ereditato da GridControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da GridControl)
Metodo protetto | GetComponentSelected | (Ereditato da GridControl)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da GridControl)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetMouseViews | (Ereditato da GridControl)
Metodo protetto | GetSelectedObjects | (Ereditato da GridControl)
Metodo protetto | GetSelectionService | (Ereditato da GridControl)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da GridControl)
Metodo pubblico | GetViewAt | (Ereditato da GridControl)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo pubblico | InternalGetService | (Ereditato da GridControl)
Metodo protetto | IsControlPressed | (Ereditato da GridControl)
Metodo protetto | IsInputChar | (Ereditato da GridControl)
Metodo protetto | IsInputKey | (Ereditato da GridControl)
Metodo protetto | IsNeededKey | (Ereditato da GridControl)
Metodo protetto | IsPaintAnimateItems | (Ereditato da GridControl)
Metodo protetto | IsShiftPressed | (Ereditato da GridControl)
Metodo protetto | IsTabPressed | (Ereditato da GridControl)
Metodo protetto | IsValidDataSource | (Ereditato da GridControl)
Metodo pubblico | IsVisibleView | (Ereditato da GridControl)
Metodo pubblico | LockFireChanged | (Ereditato da GridControl)
Metodo protetto | NormalView | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageChanged | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageLayoutChanged | (Ereditato da GridControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da GridControl)
Metodo protetto | OnClick | (Ereditato da GridControl)
Metodo protetto | OnContainerEnter | (Ereditato da GridControl)
Metodo protetto | OnContainerLeave | (Ereditato da GridControl)
Metodo protetto | OnContextMenuKey | (Ereditato da GridControl)
Metodo protetto | OnCreateControl | (Ereditato da GridControl)
Metodo protetto | OnCursorChanged | (Ereditato da GridControl)
Metodo protetto | OnDataSourceChanging | (Ereditato da GridControl)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da EditorContainer)
Metodo protetto | OnDoubleClick | (Ereditato da GridControl)
Metodo protetto | OnDragDrop | (Ereditato da GridControl)
Metodo protetto | OnDragOver | (Ereditato da GridControl)
Metodo protetto | OnEmbeddedNavigator_SizeChanged | (Ereditato da GridControl)
Metodo protetto | OnEnabledChanged | (Ereditato da GridControl)
Metodo protetto | OnEndInit | (Ereditato da GridControl)
Metodo protetto | OnEnter | (Ereditato da GridControl)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da GridControl)
Metodo protetto | OnHandleCreated | (Ereditato da GridControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da GridControl)
Metodo protetto | OnKeyDown | (Ereditato da GridControl)
Metodo protetto | OnKeyPress | (Ereditato da GridControl)
Metodo protetto | OnKeyUp | (Ereditato da GridControl)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da GridControl)
Metodo protetto | OnLostFocus | (Ereditato da GridControl)
Metodo protetto | OnMouseCaptureChanged | (Ereditato da GridControl)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da GridControl)
Metodo protetto | OnMouseEnter | (Ereditato da GridControl)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da GridControl)
Metodo protetto | OnMouseMove | (Ereditato da GridControl)
Metodo protetto | OnMouseUp | (Ereditato da GridControl)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da GridControl)
Metodo protetto | OnPaint | Implementazione dell'override di OnPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form e logga comunque call stack ed eccezione. (Sovrascrive GridControl.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da GridControl)
Metodo protetto | OnParentChanged | (Ereditato da GridControl)
Metodo protetto | OnResize | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da GridControl)
Metodo protetto | OnVisibleChanged | (Ereditato da GridControl)
Metodo pubblico | Print | (Ereditato da GridControl)
Metodo pubblico | PrintDialog | (Ereditato da GridControl)
Metodo protetto | ProcessControlTab | (Ereditato da GridControl)
Metodo protetto | ProcessDialogKey | (Ereditato da GridControl)
Metodo protetto | ProcessDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ProcessGridKeys | (Ereditato da GridControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseLoad | (Ereditato da GridControl)
Metodo protetto | RaiseOnDefaultViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnFocusedViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnRegisterView | (Ereditato da GridControl)
Metodo protetto | RaiseOnRemoveView | (Ereditato da GridControl)
Metodo protetto | RaisePaintEx | (Ereditato da GridControl)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseViewGridLoadComplete | (Ereditato da GridControl)
Metodo pubblico | RefreshDataSource | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViews | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViewsCore | (Ereditato da GridControl)
Metodo protetto | RegisterBorders | (Ereditato da GridControl)
Metodo protetto | RegisterView | (Ereditato da GridControl)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | RemoveSplitContainer | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView) | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView, Boolean) | (Ereditato da GridControl)
Metodo pubblico | RenderToBitmap | (Ereditato da GridControl)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | SetComponentsSelected | (Ereditato da GridControl)
Metodo protetto | SetDataSourceCore | (Ereditato da GridControl)
Metodo protetto | SetDefaultView | (Ereditato da GridControl)
Metodo protetto | SetupLookUp | (Ereditato da GridControl)
Metodo protetto | SetUseDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowPreview | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ShowPrintPreview | (Ereditato da GridControl)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da GridControl)
Metodo protetto | StopScroller | (Ereditato da GridControl)
Metodo pubblico | SwitchPaintStyle | (Ereditato da GridControl)
Metodo pubblico | UnlockFireChanged | (Ereditato da GridControl)
Metodo protetto | UpdateNavigator | (Ereditato da GridControl)
Metodo protetto | UpdateRepositoryOwner | (Ereditato da GridControl)
Metodo protetto | UpdateViewCollection | (Ereditato da GridControl)
Metodo protetto | UpdateViewStyles | (Ereditato da GridControl)
Metodo protetto | ViewByPoint | (Ereditato da GridControl)
Metodo protetto | WndProc | (Ereditato da GridControl)
Metodo protetto | ZoomView | (Ereditato da GridControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | DataSourceChanged | (Ereditato da GridControl)
Evento pubblico | DefaultViewChanged | (Ereditato da GridControl)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | FocusedViewChanged | (Ereditato da GridControl)
Evento pubblico | KeyboardFocusViewChanged | Obsoleto. (Ereditato da GridControl)
Evento pubblico | Load | (Ereditato da GridControl)
Evento pubblico | Paint | (Ereditato da GridControl)
Evento pubblico | PaintEx | (Ereditato da GridControl)
Evento pubblico | ProcessGridKey | (Ereditato da GridControl)
Evento pubblico | ViewRegistered | (Ereditato da GridControl)
Evento pubblico | ViewRemoved | (Ereditato da GridControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore MyGridControl
Inizializza una nuova istanza della classe MyGridControl.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public MyGridControl()
Public Sub New
public:
MyGridControl()
new : unit -> MyGridControl
Vedi anche

Documentazione

Classe MyGridControl


Proprietà di MyGridControl

Il tipo MyGridControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | AllowLayoutEvent | (Ereditato da GridControl)
Proprietà pubblica | AllowRestoreSelectionAndFocusedRow | (Ereditato da GridControl)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà pubblica | AvailableViews | (Ereditato da GridControl)
Proprietà pubblica | BackColor | (Ereditato da GridControl)
Proprietà pubblica | BindingContext | (Ereditato da GridControl)
Proprietà pubblica | ContextMenuStrip | (Ereditato da GridControl)
Proprietà pubblica | Controls | (Ereditato da GridControl)
Proprietà pubblica | Cursor | (Ereditato da GridControl)
Proprietà pubblica | DataMember | (Ereditato da GridControl)
Proprietà pubblica | DataSource | (Ereditato da GridControl)
Proprietà protetta | DefaultSize | (Ereditato da GridControl)
Proprietà pubblica | DefaultView | (Ereditato da GridControl)
Proprietà protetta | DirectXProvider | (Ereditato da GridControl)
Proprietà protetta | DirectXScroller | (Ereditato da GridControl)
Proprietà pubblica | Dock | (Ereditato da GridControl)
Proprietà protetta | DragController | (Ereditato da GridControl)
Proprietà protetta | EditorHelper | (Ereditato da GridControl)
Proprietà pubblica | EmbeddedNavigator | (Ereditato da GridControl)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da GridControl)
Proprietà protetta | ExceptionThrown | (Ereditato da GridControl)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da GridControl)
Proprietà pubblica | FocusedView | (Ereditato da GridControl)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormsUseDefaultLookAndFeel | (Ereditato da GridControl)
Proprietà pubblica | GridDisposing | (Ereditato da GridControl)
Proprietà pubblica | IsAttachedToSearchControl | (Ereditato da GridControl)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà pubblica | IsFocused | (Ereditato da GridControl)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsInPrintMessage | (Ereditato da GridControl)
Proprietà pubblica | IsLoaded | (Ereditato da GridControl)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockUpdate | (Ereditato da GridControl)
Proprietà protetta | IsPrinterExist | (Ereditato da GridControl)
Proprietà pubblica | IsPrinting | (Ereditato da GridControl)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da GridControl)
Proprietà protetta | IsPrintWrapperValid | (Ereditato da GridControl)
Proprietà protetta | IsRightToLeft | (Ereditato da GridControl)
Proprietà pubblica | IsSplitGrid | (Ereditato da GridControl)
Proprietà pubblica | KeyboardFocusView | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | LevelTree | (Ereditato da GridControl)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpOwner | (Ereditato da GridControl)
Proprietà pubblica | MainView | (Ereditato da GridControl)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MouseCaptureOwner | (Ereditato da GridControl)
Proprietà protetta | NavigatableHelper | (Ereditato da GridControl)
Proprietà protetta | NavView | (Ereditato da GridControl)
Proprietà protetta | Printer | (Ereditato da GridControl)
Proprietà protetta | PrintWrapper | (Ereditato da GridControl)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | Scroller | (Ereditato da GridControl)
Proprietà pubblica | ServerMode | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | ShowOnlyPredefinedDetails | (Ereditato da GridControl)
Proprietà protetta | SplitContainer | (Ereditato da GridControl)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TouchClient | (Ereditato da GridControl)
Proprietà pubblica | UseDirectXPaint | (Ereditato da GridControl)
Proprietà protetta | UseDirectXPaintCore | (Ereditato da GridControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da GridControl)
Proprietà pubblica | UseEmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | ViewCollection | (Ereditato da GridControl)
Proprietà protetta | ViewRepository | (Ereditato da GridControl)
Proprietà pubblica | Views | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe MyGridControl


Metodi di MyGridControl

Il tipo MyGridControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da GridControl)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32) | (Ereditato da GridControl)
Metodo protetto | ActivateDataSource | (Ereditato da GridControl)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo pubblico | BeginInit | (Ereditato da GridControl)
Metodo pubblico | BeginUpdate | (Ereditato da GridControl)
Metodo protetto | CancelUpdate | (Ereditato da GridControl)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CheckMousePos | (Ereditato da GridControl)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckPrintWrapper | (Ereditato da GridControl)
Metodo protetto | CheckProcessMsg | (Ereditato da GridControl)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da GridControl)
Metodo protetto | CreateComponentPrinter | (Ereditato da GridControl)
Metodo protetto | CreateDefaultView | (Ereditato da GridControl)
Metodo protetto | CreateEmbeddedNavigator | (Ereditato da GridControl)
Metodo pubblico | CreateGraphicsCache | (Ereditato da GridControl)
Metodo protetto | CreateHelper | (Ereditato da GridControl)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateMainView | (Ereditato da GridControl)
Metodo pubblico | CreateSplitContainer | (Ereditato da GridControl)
Metodo pubblico | CreateView | (Ereditato da GridControl)
Metodo protetto | CreateViewPrintWrapper | (Ereditato da GridControl)
Metodo protetto | DestroyAvailableViews | (Ereditato da GridControl)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyPrinting | (Ereditato da GridControl)
Metodo protetto | Dispose | (Ereditato da GridControl)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da GridControl)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndUpdate | (Ereditato da GridControl)
Metodo protetto | EndUpdate(Boolean) | (Ereditato da GridControl)
Metodo protetto | EnforceValidDataMember | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToExcelOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtmlOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToTextOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | FireChanged | (Ereditato da GridControl)
Metodo protetto | FireChanged(Object) | (Ereditato da GridControl)
Metodo protetto | FocusViewByMouse | (Ereditato da GridControl)
Metodo pubblico | ForceInitialize | (Ereditato da GridControl)
Metodo protetto | ForceViewInitialize | (Ereditato da GridControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da GridControl)
Metodo protetto | GetComponentSelected | (Ereditato da GridControl)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da GridControl)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetMouseViews | (Ereditato da GridControl)
Metodo protetto | GetSelectedObjects | (Ereditato da GridControl)
Metodo protetto | GetSelectionService | (Ereditato da GridControl)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da GridControl)
Metodo pubblico | GetViewAt | (Ereditato da GridControl)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo pubblico | InternalGetService | (Ereditato da GridControl)
Metodo protetto | IsControlPressed | (Ereditato da GridControl)
Metodo protetto | IsInputChar | (Ereditato da GridControl)
Metodo protetto | IsInputKey | (Ereditato da GridControl)
Metodo protetto | IsNeededKey | (Ereditato da GridControl)
Metodo protetto | IsPaintAnimateItems | (Ereditato da GridControl)
Metodo protetto | IsShiftPressed | (Ereditato da GridControl)
Metodo protetto | IsTabPressed | (Ereditato da GridControl)
Metodo protetto | IsValidDataSource | (Ereditato da GridControl)
Metodo pubblico | IsVisibleView | (Ereditato da GridControl)
Metodo pubblico | LockFireChanged | (Ereditato da GridControl)
Metodo protetto | NormalView | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageChanged | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageLayoutChanged | (Ereditato da GridControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da GridControl)
Metodo protetto | OnClick | (Ereditato da GridControl)
Metodo protetto | OnContainerEnter | (Ereditato da GridControl)
Metodo protetto | OnContainerLeave | (Ereditato da GridControl)
Metodo protetto | OnContextMenuKey | (Ereditato da GridControl)
Metodo protetto | OnCreateControl | (Ereditato da GridControl)
Metodo protetto | OnCursorChanged | (Ereditato da GridControl)
Metodo protetto | OnDataSourceChanging | (Ereditato da GridControl)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da EditorContainer)
Metodo protetto | OnDoubleClick | (Ereditato da GridControl)
Metodo protetto | OnDragDrop | (Ereditato da GridControl)
Metodo protetto | OnDragOver | (Ereditato da GridControl)
Metodo protetto | OnEmbeddedNavigator_SizeChanged | (Ereditato da GridControl)
Metodo protetto | OnEnabledChanged | (Ereditato da GridControl)
Metodo protetto | OnEndInit | (Ereditato da GridControl)
Metodo protetto | OnEnter | (Ereditato da GridControl)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da GridControl)
Metodo protetto | OnHandleCreated | (Ereditato da GridControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da GridControl)
Metodo protetto | OnKeyDown | (Ereditato da GridControl)
Metodo protetto | OnKeyPress | (Ereditato da GridControl)
Metodo protetto | OnKeyUp | (Ereditato da GridControl)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da GridControl)
Metodo protetto | OnLostFocus | (Ereditato da GridControl)
Metodo protetto | OnMouseCaptureChanged | (Ereditato da GridControl)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da GridControl)
Metodo protetto | OnMouseEnter | (Ereditato da GridControl)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da GridControl)
Metodo protetto | OnMouseMove | (Ereditato da GridControl)
Metodo protetto | OnMouseUp | (Ereditato da GridControl)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da GridControl)
Metodo protetto | OnPaint | Implementazione dell'override di OnPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form e logga comunque call stack ed eccezione. (Sovrascrive GridControl.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da GridControl)
Metodo protetto | OnParentChanged | (Ereditato da GridControl)
Metodo protetto | OnResize | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da GridControl)
Metodo protetto | OnVisibleChanged | (Ereditato da GridControl)
Metodo pubblico | Print | (Ereditato da GridControl)
Metodo pubblico | PrintDialog | (Ereditato da GridControl)
Metodo protetto | ProcessControlTab | (Ereditato da GridControl)
Metodo protetto | ProcessDialogKey | (Ereditato da GridControl)
Metodo protetto | ProcessDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ProcessGridKeys | (Ereditato da GridControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseLoad | (Ereditato da GridControl)
Metodo protetto | RaiseOnDefaultViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnFocusedViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnRegisterView | (Ereditato da GridControl)
Metodo protetto | RaiseOnRemoveView | (Ereditato da GridControl)
Metodo protetto | RaisePaintEx | (Ereditato da GridControl)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseViewGridLoadComplete | (Ereditato da GridControl)
Metodo pubblico | RefreshDataSource | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViews | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViewsCore | (Ereditato da GridControl)
Metodo protetto | RegisterBorders | (Ereditato da GridControl)
Metodo protetto | RegisterView | (Ereditato da GridControl)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | RemoveSplitContainer | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView) | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView, Boolean) | (Ereditato da GridControl)
Metodo pubblico | RenderToBitmap | (Ereditato da GridControl)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | SetComponentsSelected | (Ereditato da GridControl)
Metodo protetto | SetDataSourceCore | (Ereditato da GridControl)
Metodo protetto | SetDefaultView | (Ereditato da GridControl)
Metodo protetto | SetupLookUp | (Ereditato da GridControl)
Metodo protetto | SetUseDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowPreview | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ShowPrintPreview | (Ereditato da GridControl)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da GridControl)
Metodo protetto | StopScroller | (Ereditato da GridControl)
Metodo pubblico | SwitchPaintStyle | (Ereditato da GridControl)
Metodo pubblico | UnlockFireChanged | (Ereditato da GridControl)
Metodo protetto | UpdateNavigator | (Ereditato da GridControl)
Metodo protetto | UpdateRepositoryOwner | (Ereditato da GridControl)
Metodo protetto | UpdateViewCollection | (Ereditato da GridControl)
Metodo protetto | UpdateViewStyles | (Ereditato da GridControl)
Metodo protetto | ViewByPoint | (Ereditato da GridControl)
Metodo protetto | WndProc | (Ereditato da GridControl)
Metodo protetto | ZoomView | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe MyGridControl


Metodo MyGridControl.OnPaint

Metodo MyGridControlOnPaint
Implementazione dell'override di OnPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form e logga comunque call stack ed eccezione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parametri

e PaintEventArgs
Vedi anche

Documentazione

Classe MyGridControl


Eventi di MyGridControl

Il tipo MyGridControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | DataSourceChanged | (Ereditato da GridControl)
Evento pubblico | DefaultViewChanged | (Ereditato da GridControl)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | FocusedViewChanged | (Ereditato da GridControl)
Evento pubblico | KeyboardFocusViewChanged | Obsoleto. (Ereditato da GridControl)
Evento pubblico | Load | (Ereditato da GridControl)
Evento pubblico | Paint | (Ereditato da GridControl)
Evento pubblico | PaintEx | (Ereditato da GridControl)
Evento pubblico | ProcessGridKey | (Ereditato da GridControl)
Evento pubblico | ViewRegistered | (Ereditato da GridControl)
Evento pubblico | ViewRemoved | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe MyGridControl


Campi di MyGridControl

Il tipo MyGridControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Torna su
Vedi anche

Documentazione

Classe MyGridControl


Classe OkCancelControl
Classe che implementa il controllo di due bottoni ( ok , cancel )
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
QsUIOkCancelControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OkCancelControl : XtraUserControl
Public Class OkCancelControl
    Inherits XtraUserControl
public ref class OkCancelControl : public XtraUserControl
type OkCancelControl =
    class
        inherit XtraUserControl
    end

Il tipo OkCancelControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OkCancelControl | Costruttore della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CancelButton | Ritorna il bottone Cancel
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | OkButton | Ritorna il bottone Ok
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | onClickCancel |
Metodo protetto | onClickOk |
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UseOnlyOkButton | Sposta il bottone 'Ok' nella posizione del bottone 'Cancel' in modo tale da coprirlo. Internamente sposta il bottone 'Ok' e imposta la proprietà 'Visible' del bottone 'Cancel'.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CancelClick | Evento associato al click del bottone Cancel
Evento pubblico | OKClick | Evento associato al click del bottone Ok
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OkCancelControl
Costruttore della classe

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OkCancelControl()
Public Sub New
public:
OkCancelControl()
new : unit -> OkCancelControl
Vedi anche

Documentazione

Classe OkCancelControl


Proprietà di OkCancelControl

Il tipo OkCancelControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CancelButton | Ritorna il bottone Cancel
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | OkButton | Ritorna il bottone Ok
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe OkCancelControl


Proprietà OkCancelControl.CancelButton

Proprietà OkCancelControlCancelButton
Ritorna il bottone Cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton CancelButton { get; }
Public ReadOnly Property CancelButton As SimpleButton
    Get
public:
property SimpleButton^ CancelButton {
    SimpleButton^ get ();
}
member CancelButton : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe OkCancelControl


Proprietà OkCancelControl.OkButton

Proprietà OkCancelControlOkButton
Ritorna il bottone Ok

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton OkButton { get; }
Public ReadOnly Property OkButton As SimpleButton
    Get
public:
property SimpleButton^ OkButton {
    SimpleButton^ get ();
}
member OkButton : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe OkCancelControl


Metodi di OkCancelControl

Il tipo OkCancelControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | onClickCancel |
Metodo protetto | onClickOk |
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UseOnlyOkButton | Sposta il bottone 'Ok' nella posizione del bottone 'Cancel' in modo tale da coprirlo. Internamente sposta il bottone 'Ok' e imposta la proprietà 'Visible' del bottone 'Cancel'.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.Dispose

Metodo OkCancelControlDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.onClickCancel

Metodo OkCancelControlonClickCancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void onClickCancel(
    Object sender,
    EventArgs e
)
Protected Sub onClickCancel (
    sender As Object,
    e As EventArgs
)
protected:
void onClickCancel(
    Object^ sender,
    EventArgs^ e
)
member onClickCancel :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.onClickOk

Metodo OkCancelControlonClickOk

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void onClickOk(
    Object sender,
    EventArgs e
)
Protected Sub onClickOk (
    sender As Object,
    e As EventArgs
)
protected:
void onClickOk(
    Object^ sender,
    EventArgs^ e
)
member onClickOk :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.UseOnlyOkButton

Metodo OkCancelControlUseOnlyOkButton
Sposta il bottone 'Ok' nella posizione del bottone 'Cancel' in modo tale da coprirlo. Internamente sposta il bottone 'Ok' e imposta la proprietà 'Visible' del bottone 'Cancel'.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UseOnlyOkButton()
Public Sub UseOnlyOkButton
public:
void UseOnlyOkButton()
member UseOnlyOkButton : unit -> unit
Vedi anche

Documentazione

Classe OkCancelControl


Eventi di OkCancelControl

Il tipo OkCancelControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CancelClick | Evento associato al click del bottone Cancel
Evento pubblico | OKClick | Evento associato al click del bottone Ok
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe OkCancelControl


Evento OkCancelControl.CancelClick

Evento OkCancelControlCancelClick
Evento associato al click del bottone Cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler CancelClick
Public Event CancelClick As EventHandler
public:
 event EventHandler^ CancelClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CancelClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe OkCancelControl


Evento OkCancelControl.OKClick

Evento OkCancelControlOKClick
Evento associato al click del bottone Ok

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler OKClick
Public Event OKClick As EventHandler
public:
 event EventHandler^ OKClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OKClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe OkCancelControl


Classe OperationChoice
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIOperationChoice

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OperationChoice : QsBaseForm
Public Class OperationChoice
    Inherits QsBaseForm
public ref class OperationChoice : public QsBaseForm
type OperationChoice =
    class
        inherit QsBaseForm
    end

Il tipo OperationChoice espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OperationChoice | Costruttore
Metodo pubblico | OperationChoice(String, OperationChoiceQuestionButtonSet) | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | ApplyToEveryone | Check se attivo applica l'operazione scelta su tutti i file
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OperationChoiceEnu | Operazione scelta
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OperationChoice
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OperationChoice | Costruttore
Metodo pubblico | OperationChoice(String, OperationChoiceQuestionButtonSet) | Costruttore
Torna su
Vedi anche

Documentazione

Classe OperationChoice


Costruttore OperationChoice
Costruttore

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OperationChoice()
Public Sub New
public:
OperationChoice()
new : unit -> OperationChoice
Vedi anche

Documentazione

Classe OperationChoice
Overload di OperationChoice


Costruttore OperationChoice(String, OperationChoice.QuestionButtonSet)

Costruttore OperationChoice(String, OperationChoiceQuestionButtonSet)
Costruttore

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OperationChoice(
    string text,
    OperationChoiceQuestionButtonSet buttonSet
)
Public Sub New (
    text As String,
    buttonSet As OperationChoiceQuestionButtonSet
)
public:
OperationChoice(
    String^ text,
    OperationChoiceQuestionButtonSet buttonSet
)
new :
        text : string *
        buttonSet : OperationChoiceQuestionButtonSet -> OperationChoice

Parametri

text String
Messaggio da visualizzare all'interno del form
buttonSet OperationChoiceQuestionButtonSet
Vedi anche

Documentazione

Classe OperationChoice
Overload di OperationChoice


Proprietà di OperationChoice

Il tipo OperationChoice espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | ApplyToEveryone | Check se attivo applica l'operazione scelta su tutti i file
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OperationChoiceEnu | Operazione scelta
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OperationChoice


Proprietà OperationChoice.ApplyToEveryone

Proprietà OperationChoiceApplyToEveryone
Check se attivo applica l'operazione scelta su tutti i file

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyToEveryone { get; set; }
Public Property ApplyToEveryone As Boolean
    Get
    Set
public:
property bool ApplyToEveryone {
    bool get ();
    void set (bool value);
}
member ApplyToEveryone : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OperationChoice


Proprietà OperationChoice.OperationChoiceEnu

Proprietà OperationChoiceOperationChoiceEnu
Operazione scelta

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OperationChoiceOperationChoiceEnum OperationChoiceEnu { get; set; }
Public Property OperationChoiceEnu As OperationChoiceOperationChoiceEnum
    Get
    Set
public:
property OperationChoiceOperationChoiceEnum OperationChoiceEnu {
    OperationChoiceOperationChoiceEnum get ();
    void set (OperationChoiceOperationChoiceEnum value);
}
member OperationChoiceEnu : OperationChoiceOperationChoiceEnum with get, set

Valore della proprietà

OperationChoiceOperationChoiceEnum
Vedi anche

Documentazione

Classe OperationChoice


Metodi di OperationChoice

Il tipo OperationChoice espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OperationChoice


Metodo OperationChoice.Dispose

Metodo OperationChoiceDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe OperationChoice


Eventi di OperationChoice

Il tipo OperationChoice espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OperationChoice


Campi di OperationChoice

Il tipo OperationChoice espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OperationChoice


Enumerazione OperationChoice.OperationChoiceEnum

Enumerazione OperationChoiceOperationChoiceEnum
Enumerazione descrivente le operazione scelte da eseguire

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum OperationChoiceEnum
Public Enumeration OperationChoiceEnum
public enum class OperationChoiceEnum
type OperationChoiceEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuna operazione
Ignore | 1 | Da ignorare
Replace | 2 | Sostituzione
Both | 3 | Mantenere entrambi i file
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione OperationChoice.QuestionButtonSet

Enumerazione OperationChoiceQuestionButtonSet
Enumerazione dei pulsanti da visualizzare all'utente.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum QuestionButtonSet
Public Enumeration QuestionButtonSet
public enum class QuestionButtonSet
type QuestionButtonSet
Membri
Nome | Valore | Descrizione
ReplaceIgnore | 0 | Sostituisci, Ignora
ReplaceIgnoreBoth | 1 | Sostituisci, Ignora, Mantenere
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe OrderTabPagesEventArgs
EventArgs dell'evento OrderTabPagesEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIOrderTabPagesEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OrderTabPagesEventArgs : EventArgs
Public Class OrderTabPagesEventArgs
    Inherits EventArgs
public ref class OrderTabPagesEventArgs : public EventArgs
type OrderTabPagesEventArgs =
    class
        inherit EventArgs
    end

Il tipo OrderTabPagesEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OrderTabPagesEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Pages | Lista dei nomi delle pagine da creare.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OrderTabPagesEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OrderTabPagesEventArgs(
    List<string> pages
)
Public Sub New (
    pages As List(Of String)
)
public:
OrderTabPagesEventArgs(
    List<String^>^ pages
)
new :
        pages : List<string> -> OrderTabPagesEventArgs

Parametri

pages List String
Lista dei nomi delle pagine da creare.
Vedi anche

Documentazione

Classe OrderTabPagesEventArgs


Proprietà di OrderTabPagesEventArgs

Il tipo OrderTabPagesEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Pages | Lista dei nomi delle pagine da creare.
Torna su
Vedi anche

Documentazione

Classe OrderTabPagesEventArgs


Proprietà OrderTabPagesEventArgs.Pages

Proprietà OrderTabPagesEventArgsPages
Lista dei nomi delle pagine da creare.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Pages { get; set; }
Public Property Pages As List(Of String)
    Get
    Set
public:
property List<String^>^ Pages {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Pages : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe OrderTabPagesEventArgs


Classe OverrideCustomDrawCellEventArgs
EventArgs dell'evento OverrideCustomDrawCellEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
QsUIOverrideCustomDrawCellEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideCustomDrawCellEventArgs : HandledEventArgs
Public Class OverrideCustomDrawCellEventArgs
    Inherits HandledEventArgs
public ref class OverrideCustomDrawCellEventArgs : public HandledEventArgs
type OverrideCustomDrawCellEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo OverrideCustomDrawCellEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideCustomDrawCellEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | EventArgs | EventArgs.
Proprietà pubblica | RowAttr | Riga che descrive l'attributo.
Proprietà pubblica | View | Vista attualmente mostrata.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OverrideCustomDrawCellEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideCustomDrawCellEventArgs(
    Object attr,
    GridView view,
    AttributeTableRow rowAttr,
    RowCellCustomDrawEventArgs e
)
Public Sub New (
    attr As Object,
    view As GridView,
    rowAttr As AttributeTableRow,
    e As RowCellCustomDrawEventArgs
)
public:
OverrideCustomDrawCellEventArgs(
    Object^ attr,
    GridView^ view,
    AttributeTableRow^ rowAttr,
    RowCellCustomDrawEventArgs^ e
)
new :
        attr : Object *
        view : GridView *
        rowAttr : AttributeTableRow *
        e : RowCellCustomDrawEventArgs -> OverrideCustomDrawCellEventArgs

Parametri

attr Object
Attributo.
view GridView
Vista.
rowAttr AttributeTableRow
Riga dell'attributo.
e RowCellCustomDrawEventArgs
EventArgs.
Vedi anche

Documentazione

Classe OverrideCustomDrawCellEventArgs


Proprietà di OverrideCustomDrawCellEventArgs

Il tipo OverrideCustomDrawCellEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | EventArgs | EventArgs.
Proprietà pubblica | RowAttr | Riga che descrive l'attributo.
Proprietà pubblica | View | Vista attualmente mostrata.
Torna su
Vedi anche

Documentazione

Classe OverrideCustomDrawCellEventArgs


Proprietà OverrideCustomDrawCellEventArgs.Attr

Proprietà OverrideCustomDrawCellEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe OverrideCustomDrawCellEventArgs


Proprietà OverrideCustomDrawCellEventArgs.EventArgs

Proprietà OverrideCustomDrawCellEventArgsEventArgs
EventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RowCellCustomDrawEventArgs EventArgs { get; set; }
Public Property EventArgs As RowCellCustomDrawEventArgs
    Get
    Set
public:
property RowCellCustomDrawEventArgs^ EventArgs {
    RowCellCustomDrawEventArgs^ get ();
    void set (RowCellCustomDrawEventArgs^ value);
}
member EventArgs : RowCellCustomDrawEventArgs with get, set

Valore della proprietà

RowCellCustomDrawEventArgs
Vedi anche

Documentazione

Classe OverrideCustomDrawCellEventArgs


Proprietà OverrideCustomDrawCellEventArgs.RowAttr

Proprietà OverrideCustomDrawCellEventArgsRowAttr
Riga che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow RowAttr { get; }
Public ReadOnly Property RowAttr As AttributeTableRow
    Get
public:
property AttributeTableRow^ RowAttr {
    AttributeTableRow^ get ();
}
member RowAttr : AttributeTableRow with get

Valore della proprietà

AttributeTableRow
Vedi anche

Documentazione

Classe OverrideCustomDrawCellEventArgs


Proprietà OverrideCustomDrawCellEventArgs.View

Proprietà OverrideCustomDrawCellEventArgsView
Vista attualmente mostrata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridView View { get; set; }
Public Property View As GridView
    Get
    Set
public:
property GridView^ View {
    GridView^ get ();
    void set (GridView^ value);
}
member View : GridView with get, set

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe OverrideCustomDrawCellEventArgs


Classe OverrideImpostaStatoPulsantiEventArgs
EventArgs dell'evento OverrideImpostaStatoPulsantiEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
QsUIOverrideImpostaStatoPulsantiEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideImpostaStatoPulsantiEventArgs : HandledEventArgs
Public Class OverrideImpostaStatoPulsantiEventArgs
    Inherits HandledEventArgs
public ref class OverrideImpostaStatoPulsantiEventArgs : public HandledEventArgs
type OverrideImpostaStatoPulsantiEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo OverrideImpostaStatoPulsantiEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideImpostaStatoPulsantiEventArgs | Costruttore unico.
Metodo pubblico | OverrideImpostaStatoPulsantiEventArgs(Boolean, Boolean) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CancelButtonEnabled | Indica se il pulsante Cancel è abilitato.
Proprietà pubblica | OkButtonEnabled | Indica se il pulsante Ok è abilitato.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OverrideImpostaStatoPulsantiEventArgs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OverrideImpostaStatoPulsantiEventArgs | Costruttore unico.
Metodo pubblico | OverrideImpostaStatoPulsantiEventArgs(Boolean, Boolean) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe OverrideImpostaStatoPulsantiEventArgs


Costruttore OverrideImpostaStatoPulsantiEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideImpostaStatoPulsantiEventArgs()
Public Sub New
public:
OverrideImpostaStatoPulsantiEventArgs()
new : unit -> OverrideImpostaStatoPulsantiEventArgs
Vedi anche

Documentazione

Classe OverrideImpostaStatoPulsantiEventArgs
Overload di OverrideImpostaStatoPulsantiEventArgs


Costruttore OverrideImpostaStatoPulsantiEventArgs(Boolean, Boolean)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideImpostaStatoPulsantiEventArgs(
    bool okBtnEnabled,
    bool cancelBtnEnabled
)
Public Sub New (
    okBtnEnabled As Boolean,
    cancelBtnEnabled As Boolean
)
public:
OverrideImpostaStatoPulsantiEventArgs(
    bool okBtnEnabled,
    bool cancelBtnEnabled
)
new :
        okBtnEnabled : bool *
        cancelBtnEnabled : bool -> OverrideImpostaStatoPulsantiEventArgs

Parametri

okBtnEnabled Boolean
Abilitazione del pulsante Ok.
cancelBtnEnabled Boolean
Abilitazione del pulsante Cancel.
Vedi anche

Documentazione

Classe OverrideImpostaStatoPulsantiEventArgs
Overload di OverrideImpostaStatoPulsantiEventArgs


Proprietà di OverrideImpostaStatoPulsantiEventArgs

Il tipo OverrideImpostaStatoPulsantiEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CancelButtonEnabled | Indica se il pulsante Cancel è abilitato.
Proprietà pubblica | OkButtonEnabled | Indica se il pulsante Ok è abilitato.
Torna su
Vedi anche

Documentazione

Classe OverrideImpostaStatoPulsantiEventArgs


Proprietà OverrideImpostaStatoPulsantiEventArgs.CancelButtonEnabled

Proprietà OverrideImpostaStatoPulsantiEventArgsCancelButtonEnabled
Indica se il pulsante Cancel è abilitato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CancelButtonEnabled { get; set; }
Public Property CancelButtonEnabled As Boolean
    Get
    Set
public:
property bool CancelButtonEnabled {
    bool get ();
    void set (bool value);
}
member CancelButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OverrideImpostaStatoPulsantiEventArgs


Proprietà OverrideImpostaStatoPulsantiEventArgs.OkButtonEnabled

Proprietà OverrideImpostaStatoPulsantiEventArgsOkButtonEnabled
Indica se il pulsante Ok è abilitato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OkButtonEnabled { get; set; }
Public Property OkButtonEnabled As Boolean
    Get
    Set
public:
property bool OkButtonEnabled {
    bool get ();
    void set (bool value);
}
member OkButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OverrideImpostaStatoPulsantiEventArgs


Classe OverrideRowCellStyleEventArgs
EventArgs dell'evento OverrideRowCellStyleEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
QsUIOverrideRowCellStyleEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideRowCellStyleEventArgs : HandledEventArgs
Public Class OverrideRowCellStyleEventArgs
    Inherits HandledEventArgs
public ref class OverrideRowCellStyleEventArgs : public HandledEventArgs
type OverrideRowCellStyleEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo OverrideRowCellStyleEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideRowCellStyleEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | EventArgs | EventArgs.
Proprietà pubblica | RowAttr | Riga dell'attributo.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OverrideRowCellStyleEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideRowCellStyleEventArgs(
    Object attr,
    AttributeTableRow rowAttr,
    RowCellStyleEventArgs e
)
Public Sub New (
    attr As Object,
    rowAttr As AttributeTableRow,
    e As RowCellStyleEventArgs
)
public:
OverrideRowCellStyleEventArgs(
    Object^ attr,
    AttributeTableRow^ rowAttr,
    RowCellStyleEventArgs^ e
)
new :
        attr : Object *
        rowAttr : AttributeTableRow *
        e : RowCellStyleEventArgs -> OverrideRowCellStyleEventArgs

Parametri

attr Object
Attributo.
rowAttr AttributeTableRow
Riga dell'attributo.
e RowCellStyleEventArgs
EventArgs
Vedi anche

Documentazione

Classe OverrideRowCellStyleEventArgs


Proprietà di OverrideRowCellStyleEventArgs

Il tipo OverrideRowCellStyleEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | EventArgs | EventArgs.
Proprietà pubblica | RowAttr | Riga dell'attributo.
Torna su
Vedi anche

Documentazione

Classe OverrideRowCellStyleEventArgs


Proprietà OverrideRowCellStyleEventArgs.Attr

Proprietà OverrideRowCellStyleEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe OverrideRowCellStyleEventArgs


Proprietà OverrideRowCellStyleEventArgs.EventArgs

Proprietà OverrideRowCellStyleEventArgsEventArgs
EventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RowCellStyleEventArgs EventArgs { get; set; }
Public Property EventArgs As RowCellStyleEventArgs
    Get
    Set
public:
property RowCellStyleEventArgs^ EventArgs {
    RowCellStyleEventArgs^ get ();
    void set (RowCellStyleEventArgs^ value);
}
member EventArgs : RowCellStyleEventArgs with get, set

Valore della proprietà

RowCellStyleEventArgs
Vedi anche

Documentazione

Classe OverrideRowCellStyleEventArgs


Proprietà OverrideRowCellStyleEventArgs.RowAttr

Proprietà OverrideRowCellStyleEventArgsRowAttr
Riga dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow RowAttr { get; }
Public ReadOnly Property RowAttr As AttributeTableRow
    Get
public:
property AttributeTableRow^ RowAttr {
    AttributeTableRow^ get ();
}
member RowAttr : AttributeTableRow with get

Valore della proprietà

AttributeTableRow
Vedi anche

Documentazione

Classe OverrideRowCellStyleEventArgs


Classe OverrideValidatingEditorEventArgs
EventArgs dell'evento OverrideValidatingEditorEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIOverrideValidatingEditorEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideValidatingEditorEventArgs : EventArgs
Public Class OverrideValidatingEditorEventArgs
    Inherits EventArgs
public ref class OverrideValidatingEditorEventArgs : public EventArgs
type OverrideValidatingEditorEventArgs =
    class
        inherit EventArgs
    end

Il tipo OverrideValidatingEditorEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideValidatingEditorEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | EventArgs | EventArgs.
Proprietà pubblica | Valid | Indica se è valido.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OverrideValidatingEditorEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideValidatingEditorEventArgs(
    Object attr,
    BaseContainerValidateEditorEventArgs e
)
Public Sub New (
    attr As Object,
    e As BaseContainerValidateEditorEventArgs
)
public:
OverrideValidatingEditorEventArgs(
    Object^ attr,
    BaseContainerValidateEditorEventArgs^ e
)
new :
        attr : Object *
        e : BaseContainerValidateEditorEventArgs -> OverrideValidatingEditorEventArgs

Parametri

attr Object
Attributo.
e BaseContainerValidateEditorEventArgs
EventArgs.
Vedi anche

Documentazione

Classe OverrideValidatingEditorEventArgs


Proprietà di OverrideValidatingEditorEventArgs

Il tipo OverrideValidatingEditorEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | EventArgs | EventArgs.
Proprietà pubblica | Valid | Indica se è valido.
Torna su
Vedi anche

Documentazione

Classe OverrideValidatingEditorEventArgs


Proprietà OverrideValidatingEditorEventArgs.Attr

Proprietà OverrideValidatingEditorEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe OverrideValidatingEditorEventArgs


Proprietà OverrideValidatingEditorEventArgs.EventArgs

Proprietà OverrideValidatingEditorEventArgsEventArgs
EventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public BaseContainerValidateEditorEventArgs EventArgs { get; set; }
Public Property EventArgs As BaseContainerValidateEditorEventArgs
    Get
    Set
public:
property BaseContainerValidateEditorEventArgs^ EventArgs {
    BaseContainerValidateEditorEventArgs^ get ();
    void set (BaseContainerValidateEditorEventArgs^ value);
}
member EventArgs : BaseContainerValidateEditorEventArgs with get, set

Valore della proprietà

BaseContainerValidateEditorEventArgs
Vedi anche

Documentazione

Classe OverrideValidatingEditorEventArgs


Proprietà OverrideValidatingEditorEventArgs.Valid

Proprietà OverrideValidatingEditorEventArgsValid
Indica se è valido.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set
public:
property bool Valid {
    bool get ();
    void set (bool value);
}
member Valid : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OverrideValidatingEditorEventArgs


Classe QsBaseForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
Altro

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsBaseForm : XtraForm
Public Class QsBaseForm
    Inherits XtraForm
public ref class QsBaseForm : public XtraForm
type QsBaseForm =
    class
        inherit XtraForm
    end

Il tipo QsBaseForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsBaseForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver;
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIDlgCancOpForm
QsUIEditList
QsUIElaborationReport
QsUIFormAbout
QsUIFormException
QsUIInputBox
QsUIListChoice
QsUILolEditor
QsUILuaExecuteForm
QsUIOperationChoice
QsUIQsFileSelection
QsUIQuestionForm
QsUIWinToggles


Costruttore QsBaseForm
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsBaseForm()
Public Sub New
public:
QsBaseForm()
new : unit -> QsBaseForm
Vedi anche

Documentazione

Classe QsBaseForm


Proprietà di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver;
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Proprietà QsBaseForm.LoadSize

Proprietà QsBaseFormLoadSize
Indica se ripristinare la dimensione della sessione precedente. (Default True.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadSize { get; set; }
Public Property LoadSize As Boolean
    Get
    Set
public:
property bool LoadSize {
    bool get ();
    void set (bool value);
}
member LoadSize : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QsBaseForm


Proprietà QsBaseForm.MainRegistryKey

Proprietà QsBaseFormMainRegistryKey
Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver;

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string MainRegistryKey { get; }
Public ReadOnly Property MainRegistryKey As String
    Get
public:
property String^ MainRegistryKey {
    String^ get ();
}
member MainRegistryKey : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsBaseForm


Metodi di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.Dispose

Metodo QsBaseFormDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.GetPixelSizeForCurrentDpiSettings

Metodo QsBaseFormGetPixelSizeForCurrentDpiSettings
Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected int GetPixelSizeForCurrentDpiSettings(
    int pixel
)
Protected Function GetPixelSizeForCurrentDpiSettings (
    pixel As Integer
) As Integer
protected:
int GetPixelSizeForCurrentDpiSettings(
    int pixel
)
member GetPixelSizeForCurrentDpiSettings :
        pixel : int -> int

Parametri

pixel Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.LoadSizeAndPosition

Metodo QsBaseFormLoadSizeAndPosition
Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void LoadSizeAndPosition()
Protected Sub LoadSizeAndPosition
protected:
void LoadSizeAndPosition()
member LoadSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.SaveSizeAndPosition

Metodo QsBaseFormSaveSizeAndPosition
Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void SaveSizeAndPosition()
Protected Sub SaveSizeAndPosition
protected:
void SaveSizeAndPosition()
member SaveSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe QsBaseForm


Eventi di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Campi di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Campo QsBaseForm.DpiBasedMinimumSize

Campo QsBaseFormDpiBasedMinimumSize
Dimensioni minime calcolate sull'impostazione dei dpi correnti

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected Size DpiBasedMinimumSize
Protected DpiBasedMinimumSize As Size
protected:
Size DpiBasedMinimumSize
val mutable DpiBasedMinimumSize: Size

Valore del campo

Size
Vedi anche

Documentazione

Classe QsBaseForm


Classe QsException
Classe base per la gestione delle eccezioni.
Gerarchia di ereditarietà
SystemObject
SystemException
SystemApplicationException
QsUIQsException
QsUIQsExceptionList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsException : ApplicationException
Public Class QsException
    Inherits ApplicationException
public ref class QsException : public ApplicationException
type QsException =
    class
        inherit ApplicationException
    end

Il tipo QsException espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsException | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String, Exception) | Inizializza una nuova istanza della classe QsException.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsException
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | QsException | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String, Exception) | Inizializza una nuova istanza della classe QsException.
Torna su
Vedi anche

Documentazione

Classe QsException


Costruttore QsException
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsException()
Public Sub New
public:
QsException()
new : unit -> QsException
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Costruttore QsException(String)
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsException(
    string message
)
Public Sub New (
    message As String
)
public:
QsException(
    String^ message
)
new :
        message : string -> QsException

Parametri

message String
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Costruttore QsException(SerializationInfo, StreamingContext)
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
QsException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> QsException

Parametri

info SerializationInfo
context StreamingContext
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Costruttore QsException(String, Exception)
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
QsException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> QsException

Parametri

message String
innerException Exception
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Classe QsExceptionList
Eccezione contenente una lista di eccezioni.
Gerarchia di ereditarietà
SystemObject
SystemException
SystemApplicationException
QsUIQsException
QsUIQsExceptionList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsExceptionList : QsException
Public Class QsExceptionList
    Inherits QsException
public ref class QsExceptionList : public QsException
type QsExceptionList =
    class
        inherit QsException
    end

Il tipo QsExceptionList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsExceptionList(ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, Exception, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExceptionList | Restituisce la lista delle eccezioni.
Proprietà pubblica | MessageList | Restituisce la lista dei messaggi concatenati con "\r\n".
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsExceptionList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | QsExceptionList(ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, Exception, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Torna su
Vedi anche

Documentazione

Classe QsExceptionList


Costruttore QsExceptionList(List<Exception>)

Costruttore QsExceptionList(ListException)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    List<Exception> exceptionList
)
Public Sub New (
    exceptionList As List(Of Exception)
)
public:
QsExceptionList(
    List<Exception^>^ exceptionList
)
new :
        exceptionList : List<Exception> -> QsExceptionList

Parametri

exceptionList List Exception
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Costruttore QsExceptionList(SerializationInfo, StreamingContext)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
QsExceptionList(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> QsExceptionList

Parametri

info SerializationInfo
context StreamingContext
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Costruttore QsExceptionList(String, List<Exception>)

Costruttore QsExceptionList(String, ListException)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    string msg,
    List<Exception> exceptionList
)
Public Sub New (
    msg As String,
    exceptionList As List(Of Exception)
)
public:
QsExceptionList(
    String^ msg,
    List<Exception^>^ exceptionList
)
new :
        msg : string *
        exceptionList : List<Exception> -> QsExceptionList

Parametri

msg String
exceptionList List Exception
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Costruttore QsExceptionList(String, Exception, List<Exception>)

Costruttore QsExceptionList(String, Exception, ListException)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    string msg,
    Exception ex,
    List<Exception> exceptionList
)
Public Sub New (
    msg As String,
    ex As Exception,
    exceptionList As List(Of Exception)
)
public:
QsExceptionList(
    String^ msg,
    Exception^ ex,
    List<Exception^>^ exceptionList
)
new :
        msg : string *
        ex : Exception *
        exceptionList : List<Exception> -> QsExceptionList

Parametri

msg String
ex Exception
exceptionList List Exception
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Proprietà di QsExceptionList

Il tipo QsExceptionList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExceptionList | Restituisce la lista delle eccezioni.
Proprietà pubblica | MessageList | Restituisce la lista dei messaggi concatenati con "\r\n".
Torna su
Vedi anche

Documentazione

Classe QsExceptionList


Proprietà QsExceptionList.ExceptionList

Proprietà QsExceptionListExceptionList
Restituisce la lista delle eccezioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> ExceptionList { get; }
Public ReadOnly Property ExceptionList As List(Of Exception)
    Get
public:
property List<Exception^>^ ExceptionList {
    List<Exception^>^ get ();
}
member ExceptionList : List<Exception> with get

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe QsExceptionList


Proprietà QsExceptionList.MessageList

Proprietà QsExceptionListMessageList
Restituisce la lista dei messaggi concatenati con "\r\n".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string MessageList { get; }
Public ReadOnly Property MessageList As String
    Get
public:
property String^ MessageList {
    String^ get ();
}
member MessageList : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsExceptionList


Classe QsFileSelection
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIQsFileSelection

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsFileSelection : QsBaseForm
Public Class QsFileSelection
    Inherits QsBaseForm
public ref class QsFileSelection : public QsBaseForm
type QsFileSelection =
    class
        inherit QsBaseForm
    end

Il tipo QsFileSelection espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsFileSelection | Inizializza una nuova istanza della classe QsFileSelection.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Files | Lista dei file.
Proprietà pubblica | Filter | Il filtro come testo. Il testo deve rispettare il formato "File di testo (*.txt)|*.txt|Tutti i file (*.*)|*.*".
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddInitialValues | Imposta i valori iniziali per la lista.
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFilterEvent |
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo pubblico | RefreshTitle |
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FilterEvent | Il filtro come evento. Serve nel caso si voglia filtrare tramite una funzione personalizzata (tipicamente utilizzato dal lua).
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsFileSelection
Inizializza una nuova istanza della classe QsFileSelection.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsFileSelection()
Public Sub New
public:
QsFileSelection()
new : unit -> QsFileSelection
Vedi anche

Documentazione

Classe QsFileSelection


Proprietà di QsFileSelection

Il tipo QsFileSelection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Files | Lista dei file.
Proprietà pubblica | Filter | Il filtro come testo. Il testo deve rispettare il formato "File di testo (*.txt)|*.txt|Tutti i file (*.*)|*.*".
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsFileSelection


Proprietà QsFileSelection.Files

Proprietà QsFileSelectionFiles
Lista dei file.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string[] Files { get; }
Public ReadOnly Property Files As String()
    Get
public:
property array<String^>^ Files {
    array<String^>^ get ();
}
member Files : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsFileSelection


Proprietà QsFileSelection.Filter

Proprietà QsFileSelectionFilter
Il filtro come testo. Il testo deve rispettare il formato "File di testo (*.txt)|*.txt|Tutti i file (*.*)|*.*".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}
member Filter : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsFileSelection


Metodi di QsFileSelection

Il tipo QsFileSelection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddInitialValues | Imposta i valori iniziali per la lista.
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFilterEvent |
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo pubblico | RefreshTitle |
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsFileSelection


Metodo QsFileSelection.AddInitialValues

Metodo QsFileSelectionAddInitialValues
Imposta i valori iniziali per la lista.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddInitialValues(
    List<string> files
)
Public Sub AddInitialValues (
    files As List(Of String)
)
public:
void AddInitialValues(
    List<String^>^ files
)
member AddInitialValues :
        files : List<string> -> unit

Parametri

files List String
Elenco dei valori iniziali.
Vedi anche

Documentazione

Classe QsFileSelection


Metodo QsFileSelection.Dispose

Metodo QsFileSelectionDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe QsFileSelection


Metodo QsFileSelection.OnFilterEvent

Metodo QsFileSelectionOnFilterEvent

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnFilterEvent(
    FilterEventArgs e
)
Protected Overridable Sub OnFilterEvent (
    e As FilterEventArgs
)
protected:
virtual void OnFilterEvent(
    FilterEventArgs^ e
)
abstract OnFilterEvent :
        e : FilterEventArgs -> unit
override OnFilterEvent :
        e : FilterEventArgs -> unit

Parametri

e FilterEventArgs
Vedi anche

Documentazione

Classe QsFileSelection


Metodo QsFileSelection.RefreshTitle

Metodo QsFileSelectionRefreshTitle

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshTitle()
Public Sub RefreshTitle
public:
void RefreshTitle()
member RefreshTitle : unit -> unit
Vedi anche

Documentazione

Classe QsFileSelection


Eventi di QsFileSelection

Il tipo QsFileSelection espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FilterEvent | Il filtro come evento. Serve nel caso si voglia filtrare tramite una funzione personalizzata (tipicamente utilizzato dal lua).
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsFileSelection


Evento QsFileSelection.FilterEvent

Evento QsFileSelectionFilterEvent
Il filtro come evento. Serve nel caso si voglia filtrare tramite una funzione personalizzata (tipicamente utilizzato dal lua).

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FilterEventArgs> FilterEvent
Public Event FilterEvent As EventHandler(Of FilterEventArgs)
public:
 event EventHandler<FilterEventArgs^>^ FilterEvent {
    void add (EventHandler<FilterEventArgs^>^ value);
    void remove (EventHandler<FilterEventArgs^>^ value);
}
member FilterEvent : IEvent<EventHandler<FilterEventArgs>,
    FilterEventArgs>

Valore

EventHandler FilterEventArgs
Vedi anche

Documentazione

Classe QsFileSelection


Campi di QsFileSelection

Il tipo QsFileSelection espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QsFileSelection


Classe QsUI
Gerarchia di ereditarietà
SystemObject
QsUIQsUI

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class QsUI
Public NotInheritable Class QsUI
public ref class QsUI abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QsUI = class end

Il tipo QsUI espone i seguenti membri.

Metodi
Nome | Descrizione
Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Log(String) | Registra il messaggio nei file di Log.
Log(String, String) | Registra il messaggio nei file di Log.
LogInfo | Registra il messaggio nei file di Log.
OnEditAttrControlInit | Fa scattare l'evento EditAttrControlInitEvent.
ShowBrowseForFolder(String, String) |
ShowBrowseForFolder(String, String, Boolean) |
ShowBrowseForFolder(String, String, Boolean, Boolean) |
ShowBrowseForFolder(String, String, Boolean, Boolean, Boolean) |
ShowEditList | Visualizza il dialogo di selezione di una lista di codici, caricati dal file passato. SE la variabile checkPath viene impostata a TRUE: - Passando il nome di un file, questo viene utilizzato come sorgente per inizializzare la lista mostrata dalla finestra di dialogo. - Se viene passata una directory, viene chiesto all'utente di selezionare un file partendo da quella directory. - Se non viene passato nulla, viene chiesto all'utente se desidera selezionare un file di lista codici.
ShowFormAbout(String, String) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, Image) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, String) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, String, Image) | Mostra il form di informazioni sul prodotto.
ShowGetFileNameIn(String, String) |
ShowGetFileNameIn(String, String, Int32) |
ShowGetFileNameIn(String, String, String) |
ShowGetFileNameIn(String, String, String, Int32) |
ShowGetFileNameIn(String, String, String, String) |
ShowGetFileNameIn(String, String, String, String, Int32) |
ShowGetFileNameOut |
ShowInputBox(String, String, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowListChoice | Visualizza il form per selezionare un elmento da una lista.
ShowLolEditor | Shows the LolEditor dialog
ShowMessageBox |
ShowOperationChoice | Visualizza il form per selezionare l'operazione da eseguire
ShowText |
ShowWinToggles(CheckedListBoxItem) |
ShowWinToggles(CheckedListBoxItem, String) |
ShowWinToggles(String, CheckedListBoxItem) |
ShowWinToggles(String, CheckedListBoxItem, String) | Displays a number of CheckBoxes in a dialog, then creates a List containing the Value of every CHECKED item.
VisMsg(IWin32Window, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, ListException, Boolean) | Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, String, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Eventi
Nome | Descrizione
EditAttrControlInitEvent | Evento di inizializzazione del controllo EditAttrControl. Permette di registrarsi agli eventi del controllo.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di QsUI

Il tipo QsUI espone i seguenti membri.

Metodi
Nome | Descrizione
Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Log(String) | Registra il messaggio nei file di Log.
Log(String, String) | Registra il messaggio nei file di Log.
LogInfo | Registra il messaggio nei file di Log.
OnEditAttrControlInit | Fa scattare l'evento EditAttrControlInitEvent.
ShowBrowseForFolder(String, String) |
ShowBrowseForFolder(String, String, Boolean) |
ShowBrowseForFolder(String, String, Boolean, Boolean) |
ShowBrowseForFolder(String, String, Boolean, Boolean, Boolean) |
ShowEditList | Visualizza il dialogo di selezione di una lista di codici, caricati dal file passato. SE la variabile checkPath viene impostata a TRUE: - Passando il nome di un file, questo viene utilizzato come sorgente per inizializzare la lista mostrata dalla finestra di dialogo. - Se viene passata una directory, viene chiesto all'utente di selezionare un file partendo da quella directory. - Se non viene passato nulla, viene chiesto all'utente se desidera selezionare un file di lista codici.
ShowFormAbout(String, String) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, Image) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, String) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, String, Image) | Mostra il form di informazioni sul prodotto.
ShowGetFileNameIn(String, String) |
ShowGetFileNameIn(String, String, Int32) |
ShowGetFileNameIn(String, String, String) |
ShowGetFileNameIn(String, String, String, Int32) |
ShowGetFileNameIn(String, String, String, String) |
ShowGetFileNameIn(String, String, String, String, Int32) |
ShowGetFileNameOut |
ShowInputBox(String, String, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowListChoice | Visualizza il form per selezionare un elmento da una lista.
ShowLolEditor | Shows the LolEditor dialog
ShowMessageBox |
ShowOperationChoice | Visualizza il form per selezionare l'operazione da eseguire
ShowText |
ShowWinToggles(CheckedListBoxItem) |
ShowWinToggles(CheckedListBoxItem, String) |
ShowWinToggles(String, CheckedListBoxItem) |
ShowWinToggles(String, CheckedListBoxItem, String) | Displays a number of CheckBoxes in a dialog, then creates a List containing the Value of every CHECKED item.
VisMsg(IWin32Window, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, ListException, Boolean) | Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, String, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.Log

Metodo QsUILog
Lista degli overload
Nome | Descrizione
Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Log(String) | Registra il messaggio nei file di Log.
Log(String, String) | Registra il messaggio nei file di Log.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.Log(Exception)

Metodo QsUILog(Exception)
Registra il messaggio nel file di Log dell'applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex
)
Public Shared Sub Log (
    ex As Exception
)
public:
static void Log(
    Exception^ ex
)
static member Log :
        ex : Exception -> unit

Parametri

ex Exception
Eccezione da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI
Overload di Log


Metodo QsUI.Log(String)

Metodo QsUILog(String)
Registra il messaggio nei file di Log.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    string message
)
Public Shared Sub Log (
    message As String
)
public:
static void Log(
    String^ message
)
static member Log :
        message : string -> unit

Parametri

message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI
Overload di Log


Metodo QsUI.Log(String, String)

Metodo QsUILog(String, String)
Registra il messaggio nei file di Log.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    string modulename,
    string message
)
Public Shared Sub Log (
    modulename As String,
    message As String
)
public:
static void Log(
    String^ modulename,
    String^ message
)
static member Log :
        modulename : string *
        message : string -> unit

Parametri

modulename String
Nome del modulo dal quale proviene la registrazione.
message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI
Overload di Log


Metodo QsUI.LogInfo

Metodo QsUILogInfo
Registra il messaggio nei file di Log.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void LogInfo(
    string message
)
Public Shared Sub LogInfo (
    message As String
)
public:
static void LogInfo(
    String^ message
)
static member LogInfo :
        message : string -> unit

Parametri

message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.OnEditAttrControlInit

Metodo QsUIOnEditAttrControlInit
Fa scattare l'evento EditAttrControlInitEvent.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnEditAttrControlInit(
    Object sender,
    EventArgs e
)
Public Shared Sub OnEditAttrControlInit (
    sender As Object,
    e As EventArgs
)
public:
static void OnEditAttrControlInit(
    Object^ sender,
    EventArgs^ e
)
static member OnEditAttrControlInit :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowBrowseForFolder

Metodo QsUIShowBrowseForFolder
Lista degli overload
Nome | Descrizione
ShowBrowseForFolder(String, String) |
ShowBrowseForFolder(String, String, Boolean) |
ShowBrowseForFolder(String, String, Boolean, Boolean) |
ShowBrowseForFolder(String, String, Boolean, Boolean, Boolean) |
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowBrowseForFolder(String, String)

Metodo QsUIShowBrowseForFolder(String, String)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static BrowseForFolderResult ShowBrowseForFolder(
    string title,
    string initPath
)
Public Shared Function ShowBrowseForFolder (
    title As String,
    initPath As String
) As BrowseForFolderResult
public:
static BrowseForFolderResult^ ShowBrowseForFolder(
    String^ title,
    String^ initPath
)
static member ShowBrowseForFolder :
        title : string *
        initPath : string -> BrowseForFolderResult

Parametri

title String
initPath String

Valore di ritorno

BrowseForFolderResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowBrowseForFolder


Metodo QsUI.ShowBrowseForFolder(String, String, Boolean)

Metodo QsUIShowBrowseForFolder(String, String, Boolean)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static BrowseForFolderResult ShowBrowseForFolder(
    string title,
    string initPath,
    bool nonewbutton
)
Public Shared Function ShowBrowseForFolder (
    title As String,
    initPath As String,
    nonewbutton As Boolean
) As BrowseForFolderResult
public:
static BrowseForFolderResult^ ShowBrowseForFolder(
    String^ title,
    String^ initPath,
    bool nonewbutton
)
static member ShowBrowseForFolder :
        title : string *
        initPath : string *
        nonewbutton : bool -> BrowseForFolderResult

Parametri

title String
initPath String
nonewbutton Boolean

Valore di ritorno

BrowseForFolderResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowBrowseForFolder


Metodo QsUI.ShowBrowseForFolder(String, String, Boolean, Boolean)

Metodo QsUIShowBrowseForFolder(String, String, Boolean, Boolean)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static BrowseForFolderResult ShowBrowseForFolder(
    string title,
    string initPath,
    bool nonewbutton,
    bool noedit
)
Public Shared Function ShowBrowseForFolder (
    title As String,
    initPath As String,
    nonewbutton As Boolean,
    noedit As Boolean
) As BrowseForFolderResult
public:
static BrowseForFolderResult^ ShowBrowseForFolder(
    String^ title,
    String^ initPath,
    bool nonewbutton,
    bool noedit
)
static member ShowBrowseForFolder :
        title : string *
        initPath : string *
        nonewbutton : bool *
        noedit : bool -> BrowseForFolderResult

Parametri

title String
initPath String
nonewbutton Boolean
noedit Boolean

Valore di ritorno

BrowseForFolderResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowBrowseForFolder


Metodo QsUI.ShowBrowseForFolder(String, String, Boolean, Boolean, Boolean)

Metodo QsUIShowBrowseForFolder(String, String, Boolean, Boolean, Boolean)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static BrowseForFolderResult ShowBrowseForFolder(
    string title,
    string initPath,
    bool nonewbutton,
    bool newstyle,
    bool noedit
)
Public Shared Function ShowBrowseForFolder (
    title As String,
    initPath As String,
    nonewbutton As Boolean,
    newstyle As Boolean,
    noedit As Boolean
) As BrowseForFolderResult
public:
static BrowseForFolderResult^ ShowBrowseForFolder(
    String^ title,
    String^ initPath,
    bool nonewbutton,
    bool newstyle,
    bool noedit
)
static member ShowBrowseForFolder :
        title : string *
        initPath : string *
        nonewbutton : bool *
        newstyle : bool *
        noedit : bool -> BrowseForFolderResult

Parametri

title String
initPath String
nonewbutton Boolean
newstyle Boolean
noedit Boolean

Valore di ritorno

BrowseForFolderResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowBrowseForFolder


Metodo QsUI.ShowEditList

Metodo QsUIShowEditList
Visualizza il dialogo di selezione di una lista di codici, caricati dal file passato. SE la variabile checkPath viene impostata a TRUE: - Passando il nome di un file, questo viene utilizzato come sorgente per inizializzare la lista mostrata dalla finestra di dialogo. - Se viene passata una directory, viene chiesto all'utente di selezionare un file partendo da quella directory. - Se non viene passato nulla, viene chiesto all'utente se desidera selezionare un file di lista codici.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static EditListResult ShowEditList(
    string filePath,
    bool checkPath = false
)
Public Shared Function ShowEditList (
    filePath As String,
    Optional checkPath As Boolean = false
) As EditListResult
public:
static EditListResult^ ShowEditList(
    String^ filePath,
    bool checkPath = false
)
static member ShowEditList :
        filePath : string *
        ?checkPath : bool
(* Defaults:
        let _checkPath = defaultArg checkPath false
*)
-> EditListResult

Parametri

filePath String
Percorso del file da cui caricare la lista di codici.
checkPath Boolean (Optional)
Indica se controllare o meno la validità del percorso passato.

Valore di ritorno

EditListResult
Un oggetto EditListResult che descrive il risultato della finestra di dialogo.
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowFormAbout

Metodo QsUIShowFormAbout
Lista degli overload
Nome | Descrizione
ShowFormAbout(String, String) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, Image) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, String) | Mostra il form di informazioni sul prodotto.
ShowFormAbout(String, String, String, Image) | Mostra il form di informazioni sul prodotto.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowFormAbout(String, String)

Metodo QsUIShowFormAbout(String, String)
Mostra il form di informazioni sul prodotto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowFormAbout(
    string name,
    string description
)
Public Shared Sub ShowFormAbout (
    name As String,
    description As String
)
public:
static void ShowFormAbout(
    String^ name,
    String^ description
)
static member ShowFormAbout :
        name : string *
        description : string -> unit

Parametri

name String
Nome del prodotto.
description String
Descrizione del prodotto.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowFormAbout


Metodo QsUI.ShowFormAbout(String, String, Image)

Metodo QsUIShowFormAbout(String, String, Image)
Mostra il form di informazioni sul prodotto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowFormAbout(
    string name,
    string description,
    Image image
)
Public Shared Sub ShowFormAbout (
    name As String,
    description As String,
    image As Image
)
public:
static void ShowFormAbout(
    String^ name,
    String^ description,
    Image^ image
)
static member ShowFormAbout :
        name : string *
        description : string *
        image : Image -> unit

Parametri

name String
Nome del prodotto.
description String
Descrizione del prodotto.
image Image
Immagine da visualizzare a lato.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowFormAbout


Metodo QsUI.ShowFormAbout(String, String, String)

Metodo QsUIShowFormAbout(String, String, String)
Mostra il form di informazioni sul prodotto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowFormAbout(
    string name,
    string description,
    string inipath
)
Public Shared Sub ShowFormAbout (
    name As String,
    description As String,
    inipath As String
)
public:
static void ShowFormAbout(
    String^ name,
    String^ description,
    String^ inipath
)
static member ShowFormAbout :
        name : string *
        description : string *
        inipath : string -> unit

Parametri

name String
Nome del prodotto.
description String
Descrizione del prodotto.
inipath String
Percorso del file "Hotfix.ini".
Vedi anche

Documentazione

Classe QsUI
Overload di ShowFormAbout


Metodo QsUI.ShowFormAbout(String, String, String, Image)

Metodo QsUIShowFormAbout(String, String, String, Image)
Mostra il form di informazioni sul prodotto.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowFormAbout(
    string name,
    string description,
    string inipath,
    Image image
)
Public Shared Sub ShowFormAbout (
    name As String,
    description As String,
    inipath As String,
    image As Image
)
public:
static void ShowFormAbout(
    String^ name,
    String^ description,
    String^ inipath,
    Image^ image
)
static member ShowFormAbout :
        name : string *
        description : string *
        inipath : string *
        image : Image -> unit

Parametri

name String
Nome del prodotto.
description String
Descrizione del prodotto.
inipath String
Percorso del file "Hotfix.ini".
image Image
Immagine da visualizzare a lato.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowFormAbout


Metodo QsUI.ShowGetFileNameIn

Metodo QsUIShowGetFileNameIn
Lista degli overload
Nome | Descrizione
ShowGetFileNameIn(String, String) |
ShowGetFileNameIn(String, String, Int32) |
ShowGetFileNameIn(String, String, String) |
ShowGetFileNameIn(String, String, String, Int32) |
ShowGetFileNameIn(String, String, String, String) |
ShowGetFileNameIn(String, String, String, String, Int32) |
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowGetFileNameIn(String, String)

Metodo QsUIShowGetFileNameIn(String, String)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameInResult ShowGetFileNameIn(
    string filter,
    string title
)
Public Shared Function ShowGetFileNameIn (
    filter As String,
    title As String
) As GetFileNameInResult
public:
static GetFileNameInResult^ ShowGetFileNameIn(
    String^ filter,
    String^ title
)
static member ShowGetFileNameIn :
        filter : string *
        title : string -> GetFileNameInResult

Parametri

filter String
title String

Valore di ritorno

GetFileNameInResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowGetFileNameIn


Metodo QsUI.ShowGetFileNameIn(String, String, Int32)

Metodo QsUIShowGetFileNameIn(String, String, Int32)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameInResult ShowGetFileNameIn(
    string filter,
    string title,
    int multisel
)
Public Shared Function ShowGetFileNameIn (
    filter As String,
    title As String,
    multisel As Integer
) As GetFileNameInResult
public:
static GetFileNameInResult^ ShowGetFileNameIn(
    String^ filter,
    String^ title,
    int multisel
)
static member ShowGetFileNameIn :
        filter : string *
        title : string *
        multisel : int -> GetFileNameInResult

Parametri

filter String
title String
multisel Int32

Valore di ritorno

GetFileNameInResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowGetFileNameIn


Metodo QsUI.ShowGetFileNameIn(String, String, String)

Metodo QsUIShowGetFileNameIn(String, String, String)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameInResult ShowGetFileNameIn(
    string dir,
    string filter,
    string title
)
Public Shared Function ShowGetFileNameIn (
    dir As String,
    filter As String,
    title As String
) As GetFileNameInResult
public:
static GetFileNameInResult^ ShowGetFileNameIn(
    String^ dir,
    String^ filter,
    String^ title
)
static member ShowGetFileNameIn :
        dir : string *
        filter : string *
        title : string -> GetFileNameInResult

Parametri

dir String
filter String
title String

Valore di ritorno

GetFileNameInResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowGetFileNameIn


Metodo QsUI.ShowGetFileNameIn(String, String, String, Int32)

Metodo QsUIShowGetFileNameIn(String, String, String, Int32)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameInResult ShowGetFileNameIn(
    string dir,
    string filter,
    string title,
    int multisel
)
Public Shared Function ShowGetFileNameIn (
    dir As String,
    filter As String,
    title As String,
    multisel As Integer
) As GetFileNameInResult
public:
static GetFileNameInResult^ ShowGetFileNameIn(
    String^ dir,
    String^ filter,
    String^ title,
    int multisel
)
static member ShowGetFileNameIn :
        dir : string *
        filter : string *
        title : string *
        multisel : int -> GetFileNameInResult

Parametri

dir String
filter String
title String
multisel Int32

Valore di ritorno

GetFileNameInResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowGetFileNameIn


Metodo QsUI.ShowGetFileNameIn(String, String, String, String)

Metodo QsUIShowGetFileNameIn(String, String, String, String)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameInResult ShowGetFileNameIn(
    string dir,
    string filter,
    string name,
    string title
)
Public Shared Function ShowGetFileNameIn (
    dir As String,
    filter As String,
    name As String,
    title As String
) As GetFileNameInResult
public:
static GetFileNameInResult^ ShowGetFileNameIn(
    String^ dir,
    String^ filter,
    String^ name,
    String^ title
)
static member ShowGetFileNameIn :
        dir : string *
        filter : string *
        name : string *
        title : string -> GetFileNameInResult

Parametri

dir String
filter String
name String
title String

Valore di ritorno

GetFileNameInResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowGetFileNameIn


Metodo QsUI.ShowGetFileNameIn(String, String, String, String, Int32)

Metodo QsUIShowGetFileNameIn(String, String, String, String, Int32)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameInResult ShowGetFileNameIn(
    string dir,
    string filter,
    string name,
    string title,
    int multisel
)
Public Shared Function ShowGetFileNameIn (
    dir As String,
    filter As String,
    name As String,
    title As String,
    multisel As Integer
) As GetFileNameInResult
public:
static GetFileNameInResult^ ShowGetFileNameIn(
    String^ dir,
    String^ filter,
    String^ name,
    String^ title,
    int multisel
)
static member ShowGetFileNameIn :
        dir : string *
        filter : string *
        name : string *
        title : string *
        multisel : int -> GetFileNameInResult

Parametri

dir String
filter String
name String
title String
multisel Int32

Valore di ritorno

GetFileNameInResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowGetFileNameIn


Metodo QsUI.ShowGetFileNameOut

Metodo QsUIShowGetFileNameOut

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static GetFileNameOutResult ShowGetFileNameOut(
    string dir,
    string filter,
    string name,
    string title,
    string defext
)
Public Shared Function ShowGetFileNameOut (
    dir As String,
    filter As String,
    name As String,
    title As String,
    defext As String
) As GetFileNameOutResult
public:
static GetFileNameOutResult^ ShowGetFileNameOut(
    String^ dir,
    String^ filter,
    String^ name,
    String^ title,
    String^ defext
)
static member ShowGetFileNameOut :
        dir : string *
        filter : string *
        name : string *
        title : string *
        defext : string -> GetFileNameOutResult

Parametri

dir String
filter String
name String
title String
defext String

Valore di ritorno

GetFileNameOutResult
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowInputBox

Metodo QsUIShowInputBox
Lista degli overload
Nome | Descrizione
ShowInputBox(String, String, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowInputBox(String, String, String)

Metodo QsUIShowInputBox(String, String, String)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String)

Metodo QsUIShowInputBox(String, String, ListString, String)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, String, InputBoxValidatingHandler)

Metodo QsUIShowInputBox(String, String, String, InputBoxValidatingHandler)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, String, Int32)

Metodo QsUIShowInputBox(String, String, String, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    int pwd
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    pwd As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    int pwd
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        pwd : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
pwd Int32
Numeric expression that specifies whether the text in the TextBox is shown as a password or not

Valore di ritorno

InputBoxResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String, InputBoxValidatingHandler)

Metodo QsUIShowInputBox(String, String, ListString, String, InputBoxValidatingHandler)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    InputBoxValidatingHandler validator
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    validator As InputBoxValidatingHandler
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    InputBoxValidatingHandler^ validator
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        validator : InputBoxValidatingHandler -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String
validator InputBoxValidatingHandler
Delegate used to validate the text

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, String, Int32, Int32)

Metodo QsUIShowInputBox(String, String, String, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    int pwd,
    int maxLenght
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    pwd As Integer,
    maxLenght As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    int pwd,
    int maxLenght
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        pwd : int *
        maxLenght : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
pwd Int32
Numeric expression that specifies whether the text in the TextBox is shown as a password or not
maxLenght Int32
Limit number of characters

Valore di ritorno

InputBoxResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String, Boolean, InputBoxValidatingHandler)

Metodo QsUIShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    bool disableEdit,
    InputBoxValidatingHandler validator
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    disableEdit As Boolean,
    validator As InputBoxValidatingHandler
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    bool disableEdit,
    InputBoxValidatingHandler^ validator
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        disableEdit : bool *
        validator : InputBoxValidatingHandler -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String
disableEdit Boolean
Boolean used to express if the user should be able to write custom values (true) or not (false).
validator InputBoxValidatingHandler
Delegate used to validate the text

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32)

Metodo QsUIShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
xpos Int32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos Int32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String, InputBoxValidatingHandler, Int32, Int32)

Metodo QsUIShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    InputBoxValidatingHandler validator,
    int width,
    int height
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    validator As InputBoxValidatingHandler,
    width As Integer,
    height As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    InputBoxValidatingHandler^ validator,
    int width,
    int height
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        validator : InputBoxValidatingHandler *
        width : int *
        height : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String
validator InputBoxValidatingHandler
Delegate used to validate the text
width Int32
height Int32

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32)

Metodo QsUIShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int pwd
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    pwd As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int pwd
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        pwd : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
xpos Int32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos Int32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen
pwd Int32

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String, Boolean, InputBoxValidatingHandler, Int32, Int32)

Metodo QsUIShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    bool disableEdit,
    InputBoxValidatingHandler validator,
    int width,
    int height
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    disableEdit As Boolean,
    validator As InputBoxValidatingHandler,
    width As Integer,
    height As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    bool disableEdit,
    InputBoxValidatingHandler^ validator,
    int width,
    int height
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        disableEdit : bool *
        validator : InputBoxValidatingHandler *
        width : int *
        height : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String
disableEdit Boolean
Boolean used to express if the user should be able to write custom values (true) or not (false).
validator InputBoxValidatingHandler
Delegate used to validate the text
width Int32
height Int32

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)

Metodo QsUIShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int pwd,
    int maxLenght
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    pwd As Integer,
    maxLenght As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int pwd,
    int maxLenght
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        pwd : int *
        maxLenght : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
xpos Int32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos Int32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen
pwd Int32
Numeric expression that specifies whether the text in the TextBox is shown as a password or not
maxLenght Int32
Limit number of characters

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)

Metodo QsUIShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int width,
    int height
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    width As Integer,
    height As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int width,
    int height
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        width : int *
        height : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String
validator InputBoxValidatingHandler
Delegate used to validate the text
xpos Int32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos Int32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen
width Int32
Width of the form
height Int32
Height of the form

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox(String, String, List<String>, String, Boolean, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)

Metodo QsUIShowInputBox(String, String, ListString, String, Boolean, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    bool disableEdit,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int width,
    int height
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    disableEdit As Boolean,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    width As Integer,
    height As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    bool disableEdit,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int width,
    int height
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        disableEdit : bool *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        width : int *
        height : int -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse List String
String expression displayed in the text box as the default response
selectedText String
disableEdit Boolean
Boolean used to express if the user should be able to write custom values (true) or not (false).
validator InputBoxValidatingHandler
Delegate used to validate the text
xpos Int32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos Int32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen
width Int32
Width of the form
height Int32
Height of the form

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBoxAsMultiLine

Metodo QsUIShowInputBoxAsMultiLine
Lista degli overload
Nome | Descrizione
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32, Boolean) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler)

Metodo QsUIShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler -> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Boolean)

Metodo QsUIShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Boolean)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    bool useOnlyOkButton = false
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    Optional useOnlyOkButton As Boolean = false
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    bool useOnlyOkButton = false
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        ?useOnlyOkButton : bool
(* Defaults:
        let _useOnlyOkButton = defaultArg useOnlyOkButton false
*)
-> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
useOnlyOkButton Boolean (Optional)
Indicates whether to use only Ok button

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Boolean)

Metodo QsUIShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Boolean)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int maxLenght = 0,
    bool useOnlyOkButton = false
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    Optional maxLenght As Integer = 0,
    Optional useOnlyOkButton As Boolean = false
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int maxLenght = 0,
    bool useOnlyOkButton = false
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        ?maxLenght : int *
        ?useOnlyOkButton : bool
(* Defaults:
        let _maxLenght = defaultArg maxLenght 0
        let _useOnlyOkButton = defaultArg useOnlyOkButton false
*)
-> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
maxLenght Int32 (Optional)
Limit number of characters.
useOnlyOkButton Boolean (Optional)
Indicates whether to use only Ok button

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Boolean)

Metodo QsUIShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Boolean)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int width,
    int height,
    int maxLenght = 0,
    bool useOnlyOkButton = false
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    width As Integer,
    height As Integer,
    Optional maxLenght As Integer = 0,
    Optional useOnlyOkButton As Boolean = false
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int width,
    int height,
    int maxLenght = 0,
    bool useOnlyOkButton = false
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        width : int *
        height : int *
        ?maxLenght : int *
        ?useOnlyOkButton : bool
(* Defaults:
        let _maxLenght = defaultArg maxLenght 0
        let _useOnlyOkButton = defaultArg useOnlyOkButton false
*)
-> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
width Int32
Larghezza della finestra (-1) default
height Int32
Altezza della finestra (-1) default
maxLenght Int32 (Optional)
Limit number of characters.
useOnlyOkButton Boolean (Optional)
Indicates whether to use only Ok button

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32, Boolean)

Metodo QsUIShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32, Boolean)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int width,
    int height,
    int maxLenght = 0,
    bool useOnlyOkButton = false
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    width As Integer,
    height As Integer,
    Optional maxLenght As Integer = 0,
    Optional useOnlyOkButton As Boolean = false
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int width,
    int height,
    int maxLenght = 0,
    bool useOnlyOkButton = false
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        width : int *
        height : int *
        ?maxLenght : int *
        ?useOnlyOkButton : bool
(* Defaults:
        let _maxLenght = defaultArg maxLenght 0
        let _useOnlyOkButton = defaultArg useOnlyOkButton false
*)
-> InputBoxResult

Parametri

prompt String
String expression displayed as the message in the dialog box
title String
String expression displayed in the title bar of the dialog box
defaultResponse String
String expression displayed in the text box as the default response
validator InputBoxValidatingHandler
Delegate used to validate the text
xpos Int32
ypos Int32
width Int32
Width of the form
height Int32
Height of the form
maxLenght Int32 (Optional)
Limit number of characters
useOnlyOkButton Boolean (Optional)
Indicates whether to use only Ok button

Valore di ritorno

InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowListChoice

Metodo QsUIShowListChoice
Visualizza il form per selezionare un elmento da una lista.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Object ShowListChoice(
    string title,
    Object datasource,
    int width = 193,
    int height = 305,
    int sel = -1,
    string alignment = "c"
)
Public Shared Function ShowListChoice (
    title As String,
    datasource As Object,
    Optional width As Integer = 193,
    Optional height As Integer = 305,
    Optional sel As Integer = -1,
    Optional alignment As String = "c"
) As Object
public:
static Object^ ShowListChoice(
    String^ title,
    Object^ datasource,
    int width = 193,
    int height = 305,
    int sel = -1,
    String^ alignment = L"c"
)
static member ShowListChoice :
        title : string *
        datasource : Object *
        ?width : int *
        ?height : int *
        ?sel : int *
        ?alignment : string
(* Defaults:
        let _width = defaultArg width 193
        let _height = defaultArg height 305
        let _sel = defaultArg sel -1
        let _alignment = defaultArg alignment "c"
*)
-> Object

Parametri

title String
Titolo del form
datasource Object
Lista da visualizzare
width Int32 (Optional)
larghezza finestra (193 default) (passare -1 in caso si voglia ignorare)
height Int32 (Optional)
altezza finestra (305 default) (passare -1 in caso si voglia ignorare)
sel Int32 (Optional)
Indica qual è l'elemento selezionato inizialmente
alignment String (Optional)
Indica l'allineamento del testo nella griglia.

Valore di ritorno

Object
L'indice dell'elemento selezionato se la selezione avviene correttamente, altrimenti -1
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowLolEditor

Metodo QsUIShowLolEditor
Shows the LolEditor dialog

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Object ShowLolEditor(
    Object datasource,
    string title,
    int checkbox,
    List<string> hiddencolumns,
    List<ColumnOptions> options
)
Public Shared Function ShowLolEditor (
    datasource As Object,
    title As String,
    checkbox As Integer,
    hiddencolumns As List(Of String),
    options As List(Of ColumnOptions)
) As Object
public:
static Object^ ShowLolEditor(
    Object^ datasource,
    String^ title,
    int checkbox,
    List<String^>^ hiddencolumns,
    List<ColumnOptions^>^ options
)
static member ShowLolEditor :
        datasource : Object *
        title : string *
        checkbox : int *
        hiddencolumns : List<string> *
        options : List<ColumnOptions> -> Object

Parametri

datasource Object
The data that composes the grid
title String
checkbox Int32
Flag used to decide whether you want to show a Checkbox column
hiddencolumns List String
The list of hidden columns
options List ColumnOptions
A list of options for columns

Valore di ritorno

Object
An object that contains the selected row(s)
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowMessageBox

Metodo QsUIShowMessageBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static MessageBoxResult ShowMessageBox(
    string flags,
    string text,
    string title
)
Public Shared Function ShowMessageBox (
    flags As String,
    text As String,
    title As String
) As MessageBoxResult
public:
static MessageBoxResult^ ShowMessageBox(
    String^ flags,
    String^ text,
    String^ title
)
static member ShowMessageBox :
        flags : string *
        text : string *
        title : string -> MessageBoxResult

Parametri

flags String
text String
title String

Valore di ritorno

MessageBoxResult
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowOperationChoice

Metodo QsUIShowOperationChoice
Visualizza il form per selezionare l'operazione da eseguire

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static OperationChoice ShowOperationChoice(
    string text,
    OperationChoiceQuestionButtonSet buttonSet
)
Public Shared Function ShowOperationChoice (
    text As String,
    buttonSet As OperationChoiceQuestionButtonSet
) As OperationChoice
public:
static OperationChoice^ ShowOperationChoice(
    String^ text,
    OperationChoiceQuestionButtonSet buttonSet
)
static member ShowOperationChoice :
        text : string *
        buttonSet : OperationChoiceQuestionButtonSet -> OperationChoice

Parametri

text String
buttonSet OperationChoiceQuestionButtonSet

Valore di ritorno

OperationChoice
Ritorna un oggetto che identifica l'operazione scelta
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowText

Metodo QsUIShowText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowText(
    string text,
    string title
)
Public Shared Sub ShowText (
    text As String,
    title As String
)
public:
static void ShowText(
    String^ text,
    String^ title
)
static member ShowText :
        text : string *
        title : string -> unit

Parametri

text String
title String
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowWinToggles

Metodo QsUIShowWinToggles
Lista degli overload
Nome | Descrizione
ShowWinToggles(CheckedListBoxItem) |
ShowWinToggles(CheckedListBoxItem, String) |
ShowWinToggles(String, CheckedListBoxItem) |
ShowWinToggles(String, CheckedListBoxItem, String) | Displays a number of CheckBoxes in a dialog, then creates a List containing the Value of every CHECKED item.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowWinToggles(CheckedListBoxItem[])

Metodo QsUIShowWinToggles(CheckedListBoxItem)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static WinTogglesResult ShowWinToggles(
    CheckedListBoxItem[] items
)
Public Shared Function ShowWinToggles (
    items As CheckedListBoxItem()
) As WinTogglesResult
public:
static WinTogglesResult^ ShowWinToggles(
    array<CheckedListBoxItem^>^ items
)
static member ShowWinToggles :
        items : CheckedListBoxItem[] -> WinTogglesResult

Parametri

items CheckedListBoxItem

Valore di ritorno

WinTogglesResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowWinToggles


Metodo QsUI.ShowWinToggles(CheckedListBoxItem[], String)

Metodo QsUIShowWinToggles(CheckedListBoxItem, String)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static WinTogglesResult ShowWinToggles(
    CheckedListBoxItem[] items,
    string coltitle
)
Public Shared Function ShowWinToggles (
    items As CheckedListBoxItem(),
    coltitle As String
) As WinTogglesResult
public:
static WinTogglesResult^ ShowWinToggles(
    array<CheckedListBoxItem^>^ items,
    String^ coltitle
)
static member ShowWinToggles :
        items : CheckedListBoxItem[] *
        coltitle : string -> WinTogglesResult

Parametri

items CheckedListBoxItem
coltitle String

Valore di ritorno

WinTogglesResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowWinToggles


Metodo QsUI.ShowWinToggles(String, CheckedListBoxItem[])

Metodo QsUIShowWinToggles(String, CheckedListBoxItem)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static WinTogglesResult ShowWinToggles(
    string title,
    CheckedListBoxItem[] items
)
Public Shared Function ShowWinToggles (
    title As String,
    items As CheckedListBoxItem()
) As WinTogglesResult
public:
static WinTogglesResult^ ShowWinToggles(
    String^ title,
    array<CheckedListBoxItem^>^ items
)
static member ShowWinToggles :
        title : string *
        items : CheckedListBoxItem[] -> WinTogglesResult

Parametri

title String
items CheckedListBoxItem

Valore di ritorno

WinTogglesResult
Vedi anche

Documentazione

Classe QsUI
Overload di ShowWinToggles


Metodo QsUI.ShowWinToggles(String, CheckedListBoxItem[], String)

Metodo QsUIShowWinToggles(String, CheckedListBoxItem, String)
Displays a number of CheckBoxes in a dialog, then creates a List containing the Value of every CHECKED item.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static WinTogglesResult ShowWinToggles(
    string title,
    CheckedListBoxItem[] items,
    string coltitle
)
Public Shared Function ShowWinToggles (
    title As String,
    items As CheckedListBoxItem(),
    coltitle As String
) As WinTogglesResult
public:
static WinTogglesResult^ ShowWinToggles(
    String^ title,
    array<CheckedListBoxItem^>^ items,
    String^ coltitle
)
static member ShowWinToggles :
        title : string *
        items : CheckedListBoxItem[] *
        coltitle : string -> WinTogglesResult

Parametri

title String
String expression displayed in the title bar of the dialog box
items CheckedListBoxItem
Collection of CheckedListBoxItem objects. It contains the CheckBox values the user wants to display
coltitle String
String expression displayed in the title bar of the column

Valore di ritorno

WinTogglesResult
A WinTogglesResult object containing the result of the dialog and a List of CheckBoxItem values
Vedi anche

Documentazione

Classe QsUI
Overload di ShowWinToggles


Metodo QsUI.VisMsg

Metodo QsUIVisMsg
Lista degli overload
Nome | Descrizione
VisMsg(IWin32Window, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, ListException, Boolean) | Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, String, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.VisMsg(IWin32Window, List<Exception>)

Metodo QsUIVisMsg(IWin32Window, ListException)
Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    List<Exception> exList
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    exList As List(Of Exception)
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    List<Exception^>^ exList
)
static member VisMsg :
        ownerForm : IWin32Window *
        exList : List<Exception> -> unit

Parametri

ownerForm IWin32Window
Parent Form.
exList List Exception
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, Exception)

Metodo QsUIVisMsg(IWin32Window, Exception)
Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    Exception ex
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    ex As Exception
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    Exception^ ex
)
static member VisMsg :
        ownerForm : IWin32Window *
        ex : Exception -> unit

Parametri

ownerForm IWin32Window
Parent Form.
ex Exception
Eccezione da visualizzare.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, String)

Metodo QsUIVisMsg(IWin32Window, String)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string msg
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    msg As String
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ msg
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string -> unit

Parametri

ownerForm IWin32Window
Parent Form.
msg String
Stringa da visualizzare.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, List<Exception>, Boolean)

Metodo QsUIVisMsg(IWin32Window, ListException, Boolean)
Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    List<Exception> exList,
    out bool notShowAgain
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    exList As List(Of Exception),
    <OutAttribute> ByRef notShowAgain As Boolean
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    List<Exception^>^ exList,
    [OutAttribute] bool% notShowAgain
)
static member VisMsg :
        ownerForm : IWin32Window *
        exList : List<Exception> *
        notShowAgain : bool byref -> unit

Parametri

ownerForm IWin32Window
Parent Form.
exList List Exception
notShowAgain Boolean
Indica se alla chiusura del dialogo la checkbox "non mostrare più" è stata spuntata o meno.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, Exception, Boolean)

Metodo QsUIVisMsg(IWin32Window, Exception, Boolean)
Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    Exception ex,
    out bool notShowAgain
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    ex As Exception,
    <OutAttribute> ByRef notShowAgain As Boolean
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    Exception^ ex,
    [OutAttribute] bool% notShowAgain
)
static member VisMsg :
        ownerForm : IWin32Window *
        ex : Exception *
        notShowAgain : bool byref -> unit

Parametri

ownerForm IWin32Window
Parent Form.
ex Exception
Eccezione da visualizzare.
notShowAgain Boolean
Indica se alla chiusura del dialogo la checkbox "non mostrare più" è stata spuntata o meno.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, String, String)

Metodo QsUIVisMsg(IWin32Window, String, String)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string -> unit

Parametri

ownerForm IWin32Window
Parent Form.
title String
Titolo del form.
msg String
Stringa da visualizzare.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, String, MessageBoxIcon)

Metodo QsUIVisMsg(IWin32Window, String, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string msg,
    MessageBoxIcon iconType
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    msg As String,
    iconType As MessageBoxIcon
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ msg,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string *
        iconType : MessageBoxIcon -> unit

Parametri

ownerForm IWin32Window
Parent Form.
msg String
Stringa da visualizzare.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, String, String, MessageBoxIcon)

Metodo QsUIVisMsg(IWin32Window, String, String, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg,
    MessageBoxIcon iconType
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String,
    iconType As MessageBoxIcon
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string *
        iconType : MessageBoxIcon -> unit

Parametri

ownerForm IWin32Window
Parent Form.
title String
Titolo della finestra.
msg String
Stringa da visualizzare.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon)

Metodo QsUIVisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DialogResult VisMsg(
    IWin32Window ownerForm,
    string msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
Public Shared Function VisMsg (
    ownerForm As IWin32Window,
    msg As String,
    buttons As MessageBoxButtons,
    iconType As MessageBoxIcon
) As DialogResult
public:
static DialogResult VisMsg(
    IWin32Window^ ownerForm,
    String^ msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string *
        buttons : MessageBoxButtons *
        iconType : MessageBoxIcon -> DialogResult

Parametri

ownerForm IWin32Window
Parent Form.
msg String
Stringa da visualizzare.
buttons MessageBoxButtons
Bottoni da visualizzare nel messaggio.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.

Valore di ritorno

DialogResult
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)

Metodo QsUIVisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DialogResult VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
Public Shared Function VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String,
    buttons As MessageBoxButtons,
    iconType As MessageBoxIcon
) As DialogResult
public:
static DialogResult VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string *
        buttons : MessageBoxButtons *
        iconType : MessageBoxIcon -> DialogResult

Parametri

ownerForm IWin32Window
Parent Form.
title String
Titolo della finestra.
msg String
Stringa da visualizzare.
buttons MessageBoxButtons
Bottoni da visualizzare nel messaggio.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.

Valore di ritorno

DialogResult
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Eventi di QsUI

Il tipo QsUI espone i seguenti membri.

Eventi
Nome | Descrizione
EditAttrControlInitEvent | Evento di inizializzazione del controllo EditAttrControl. Permette di registrarsi agli eventi del controllo.
Torna su
Vedi anche

Documentazione

Classe QsUI


Evento QsUI.EditAttrControlInitEvent

Evento QsUIEditAttrControlInitEvent
Evento di inizializzazione del controllo EditAttrControl. Permette di registrarsi agli eventi del controllo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler EditAttrControlInitEvent
Public Shared Event EditAttrControlInitEvent As EventHandler
public:
static  event EventHandler^ EditAttrControlInitEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EditAttrControlInitEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe QsUI


Classe QuestionForm
Finestra per mostrare un form con la possibilità di scegliere tra [Si-Si Tutti-No-No Tutti].
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIQuestionForm

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QuestionForm : QsBaseForm
Public Class QuestionForm
    Inherits QsBaseForm
public ref class QuestionForm : public QsBaseForm
type QuestionForm =
    class
        inherit QsBaseForm
    end

Il tipo QuestionForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | ButtonSet | Restituisce i pulsanti visualizzati.
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà pubblica | DefaultButton | Restituisce il pulsante di default preselezionato.
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Result | Restituisce la scelta effettuata dall'utente oppure None se non ha effettuato scelte.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
 | Show(String, String) | Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.
 | Show(String, String, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon) | Visualizza il Form passando tutte le opzioni.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | ButtonSet | Restituisce i pulsanti visualizzati.
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà pubblica | DefaultButton | Restituisce il pulsante di default preselezionato.
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Result | Restituisce la scelta effettuata dall'utente oppure None se non ha effettuato scelte.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Proprietà QuestionForm.ButtonSet

Proprietà QuestionFormButtonSet
Restituisce i pulsanti visualizzati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QuestionFormQuestionButtonSet ButtonSet { get; }
Public ReadOnly Property ButtonSet As QuestionFormQuestionButtonSet
    Get
public:
property QuestionFormQuestionButtonSet ButtonSet {
    QuestionFormQuestionButtonSet get ();
}
member ButtonSet : QuestionFormQuestionButtonSet with get

Valore della proprietà

QuestionFormQuestionButtonSet
Vedi anche

Documentazione

Classe QuestionForm


Proprietà QuestionForm.DefaultButton

Proprietà QuestionFormDefaultButton
Restituisce il pulsante di default preselezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QuestionFormQuestionResult DefaultButton { get; }
Public ReadOnly Property DefaultButton As QuestionFormQuestionResult
    Get
public:
property QuestionFormQuestionResult DefaultButton {
    QuestionFormQuestionResult get ();
}
member DefaultButton : QuestionFormQuestionResult with get

Valore della proprietà

QuestionFormQuestionResult
Vedi anche

Documentazione

Classe QuestionForm


Proprietà QuestionForm.Result

Proprietà QuestionFormResult
Restituisce la scelta effettuata dall'utente oppure None se non ha effettuato scelte.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QuestionFormQuestionResult Result { get; }
Public ReadOnly Property Result As QuestionFormQuestionResult
    Get
public:
property QuestionFormQuestionResult Result {
    QuestionFormQuestionResult get ();
}
member Result : QuestionFormQuestionResult with get

Valore della proprietà

QuestionFormQuestionResult
Vedi anche

Documentazione

Classe QuestionForm


Metodi di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
 | Show(String, String) | Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.
 | Show(String, String, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon) | Visualizza il Form passando tutte le opzioni.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Metodo QuestionForm.Dispose

Metodo QuestionFormDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe QuestionForm


Metodo QuestionForm.Show

Metodo QuestionFormShow
Lista degli overload
Nome | Descrizione
Show(String, String) | Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.
Show(String, String, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.
Show(IWin32Window, String, String, QuestionFormQuestionResult) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon) | Visualizza il Form passando tutte le opzioni.
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Metodo QuestionForm.Show(String, String)

Metodo QuestionFormShow(String, String)
Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    string title,
    string message
)
Public Shared Function Show (
    title As String,
    message As String
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    String^ title,
    String^ message
)
static member Show :
        title : string *
        message : string -> QuestionFormQuestionResult

Parametri

title String
Titolo della finestra.
message String
Messaggio da visualizzare.

Valore di ritorno

QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show(String, String, QuestionForm.QuestionButtonSet)

Metodo QuestionFormShow(String, String, QuestionFormQuestionButtonSet)
Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    string title,
    string message,
    QuestionFormQuestionButtonSet buttonSet
)
Public Shared Function Show (
    title As String,
    message As String,
    buttonSet As QuestionFormQuestionButtonSet
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    String^ title,
    String^ message,
    QuestionFormQuestionButtonSet buttonSet
)
static member Show :
        title : string *
        message : string *
        buttonSet : QuestionFormQuestionButtonSet -> QuestionFormQuestionResult

Parametri

title String
Titolo della finestra
message String
Messaggio da visualizzare
buttonSet QuestionFormQuestionButtonSet

Valore di ritorno

QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show(IWin32Window, String, String, QuestionForm.QuestionResult)

Metodo QuestionFormShow(IWin32Window, String, String, QuestionFormQuestionResult)
Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    IWin32Window owner,
    string title,
    string message,
    QuestionFormQuestionResult defaultButton
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    message As String,
    defaultButton As QuestionFormQuestionResult
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    IWin32Window^ owner,
    String^ title,
    String^ message,
    QuestionFormQuestionResult defaultButton
)
static member Show :
        owner : IWin32Window *
        title : string *
        message : string *
        defaultButton : QuestionFormQuestionResult -> QuestionFormQuestionResult

Parametri

owner IWin32Window
Finestra genitore.
title String
Titolo della finestra.
message String
Messaggio da visualizzare.
defaultButton QuestionFormQuestionResult
Imposta il bottone usato di default.

Valore di ritorno

QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show(IWin32Window, String, String, QuestionForm.QuestionResult, QuestionForm.QuestionButtonSet)

Metodo QuestionFormShow(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet)
Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    IWin32Window owner,
    string title,
    string message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    message As String,
    defaultButton As QuestionFormQuestionResult,
    buttonSet As QuestionFormQuestionButtonSet
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    IWin32Window^ owner,
    String^ title,
    String^ message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet
)
static member Show :
        owner : IWin32Window *
        title : string *
        message : string *
        defaultButton : QuestionFormQuestionResult *
        buttonSet : QuestionFormQuestionButtonSet -> QuestionFormQuestionResult

Parametri

owner IWin32Window
Finestra genitore.
title String
Titolo della finestra.
message String
Messaggio da visualizzare.
defaultButton QuestionFormQuestionResult
Imposta il bottone usato di default.
buttonSet QuestionFormQuestionButtonSet

Valore di ritorno

QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show(IWin32Window, String, String, QuestionForm.QuestionResult, QuestionForm.QuestionButtonSet, MessageBoxIcon)

Metodo QuestionFormShow(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon)
Visualizza il Form passando tutte le opzioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    IWin32Window owner,
    string title,
    string message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet,
    MessageBoxIcon iconType
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    message As String,
    defaultButton As QuestionFormQuestionResult,
    buttonSet As QuestionFormQuestionButtonSet,
    iconType As MessageBoxIcon
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    IWin32Window^ owner,
    String^ title,
    String^ message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet,
    MessageBoxIcon iconType
)
static member Show :
        owner : IWin32Window *
        title : string *
        message : string *
        defaultButton : QuestionFormQuestionResult *
        buttonSet : QuestionFormQuestionButtonSet *
        iconType : MessageBoxIcon -> QuestionFormQuestionResult

Parametri

owner IWin32Window
Finestra genitore.
title String
Titolo della finestra.
message String
Messaggio da visualizzare.
defaultButton QuestionFormQuestionResult
Imposta il bottone usato di default.
buttonSet QuestionFormQuestionButtonSet
Indica i pulsanti da visualizzare.
iconType MessageBoxIcon
Icona da visualizzare.

Valore di ritorno

QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Eventi di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Campi di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Enumerazione QuestionForm.QuestionButtonSet

Enumerazione QuestionFormQuestionButtonSet
Enumerazione dei pulsanti da visualizzare all'utente.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum QuestionButtonSet
Public Enumeration QuestionButtonSet
public enum class QuestionButtonSet
type QuestionButtonSet
Membri
Nome | Valore | Descrizione
Ok | 0 | Solo il pulsante ok.
YesNo | 1 | Sì/No.
YesNoAll | 2 | Sì, No, Sì tutti, No tutti
YesNoCancel | 3 | Sì, No, Annulla.
OkCancel | 4 | Ok, Annulla
RetryCancel | 5 | Riprova, Cancella
AbortRetryIgnore | 6 | Cancella, Riprova, Ignora
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione QuestionForm.QuestionResult

Enumerazione QuestionFormQuestionResult
Enumerazione per la gestione dei risultati multipli.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum QuestionResult
Public Enumeration QuestionResult
public enum class QuestionResult
type QuestionResult
Membri
Nome | Valore | Descrizione
None | 0 |
Yes | 1 |
YesAll | 2 |
No | 3 |
NoAll | 4 |
Ok | 5 |
Cancel | 6 |
Retry | 7 |
Abort | 8 |
Ignore | 9 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe RepositoryBindEventArgs
EventArgs dell'evento RepositoryBindEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIRepositoryBindEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class RepositoryBindEventArgs : EventArgs
Public Class RepositoryBindEventArgs
    Inherits EventArgs
public ref class RepositoryBindEventArgs : public EventArgs
type RepositoryBindEventArgs =
    class
        inherit EventArgs
    end

Il tipo RepositoryBindEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RepositoryBindEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Item | Oggetto repository.
Proprietà pubblica | RowAttr | Riga a cui bindare il repository.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore RepositoryBindEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryBindEventArgs(
    RepositoryItem item,
    Object attr,
    AttributeTableRow rowAttr
)
Public Sub New (
    item As RepositoryItem,
    attr As Object,
    rowAttr As AttributeTableRow
)
public:
RepositoryBindEventArgs(
    RepositoryItem^ item,
    Object^ attr,
    AttributeTableRow^ rowAttr
)
new :
        item : RepositoryItem *
        attr : Object *
        rowAttr : AttributeTableRow -> RepositoryBindEventArgs

Parametri

item RepositoryItem
Repository.
attr Object
Attributo.
rowAttr AttributeTableRow
Riga del datasource.
Vedi anche

Documentazione

Classe RepositoryBindEventArgs


Proprietà di RepositoryBindEventArgs

Il tipo RepositoryBindEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Item | Oggetto repository.
Proprietà pubblica | RowAttr | Riga a cui bindare il repository.
Torna su
Vedi anche

Documentazione

Classe RepositoryBindEventArgs


Proprietà RepositoryBindEventArgs.Attr

Proprietà RepositoryBindEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe RepositoryBindEventArgs


Proprietà RepositoryBindEventArgs.Item

Proprietà RepositoryBindEventArgsItem
Oggetto repository.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItem Item { get; set; }
Public Property Item As RepositoryItem
    Get
    Set
public:
property RepositoryItem^ Item {
    RepositoryItem^ get ();
    void set (RepositoryItem^ value);
}
member Item : RepositoryItem with get, set

Valore della proprietà

RepositoryItem
Vedi anche

Documentazione

Classe RepositoryBindEventArgs


Proprietà RepositoryBindEventArgs.RowAttr

Proprietà RepositoryBindEventArgsRowAttr
Riga a cui bindare il repository.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow RowAttr { get; }
Public ReadOnly Property RowAttr As AttributeTableRow
    Get
public:
property AttributeTableRow^ RowAttr {
    AttributeTableRow^ get ();
}
member RowAttr : AttributeTableRow with get

Valore della proprietà

AttributeTableRow
Vedi anche

Documentazione

Classe RepositoryBindEventArgs


Classe RulesImagesChangeEventArgs
EventArgs dell'evento RulesImageChangeEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIRulesImagesChangeEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class RulesImagesChangeEventArgs : EventArgs
Public Class RulesImagesChangeEventArgs
    Inherits EventArgs
public ref class RulesImagesChangeEventArgs : public EventArgs
type RulesImagesChangeEventArgs =
    class
        inherit EventArgs
    end

Il tipo RulesImagesChangeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RulesImagesChangeEventArgs(Object) | Costruttore unico.
Metodo pubblico | RulesImagesChangeEventArgs(Image, String, Object) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Image | Immagine da impostare.
Proprietà pubblica | ToolTip | Testo del tooltip.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore RulesImagesChangeEventArgs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RulesImagesChangeEventArgs(Object) | Costruttore unico.
Metodo pubblico | RulesImagesChangeEventArgs(Image, String, Object) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs


Costruttore RulesImagesChangeEventArgs(Object)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RulesImagesChangeEventArgs(
    Object attr
)
Public Sub New (
    attr As Object
)
public:
RulesImagesChangeEventArgs(
    Object^ attr
)
new :
        attr : Object -> RulesImagesChangeEventArgs

Parametri

attr Object
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs
Overload di RulesImagesChangeEventArgs


Costruttore RulesImagesChangeEventArgs(Image, String, Object)
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public RulesImagesChangeEventArgs(
    Image image,
    string tooltip,
    Object attr
)
Public Sub New (
    image As Image,
    tooltip As String,
    attr As Object
)
public:
RulesImagesChangeEventArgs(
    Image^ image,
    String^ tooltip,
    Object^ attr
)
new :
        image : Image *
        tooltip : string *
        attr : Object -> RulesImagesChangeEventArgs

Parametri

image Image
Immagine da impostare.
tooltip String
Testo del tooltip.
attr Object
Attributo.
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs
Overload di RulesImagesChangeEventArgs


Proprietà di RulesImagesChangeEventArgs

Il tipo RulesImagesChangeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Image | Immagine da impostare.
Proprietà pubblica | ToolTip | Testo del tooltip.
Torna su
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs


Proprietà RulesImagesChangeEventArgs.Attr

Proprietà RulesImagesChangeEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs


Proprietà RulesImagesChangeEventArgs.Image

Proprietà RulesImagesChangeEventArgsImage
Immagine da impostare.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs


Proprietà RulesImagesChangeEventArgs.ToolTip

Proprietà RulesImagesChangeEventArgsToolTip
Testo del tooltip.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
member ToolTip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RulesImagesChangeEventArgs


Classe SetAttrValueEventArgs
EventArgs dell'evento SetAttrValueEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
QsUISetAttrValueEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SetAttrValueEventArgs : HandledEventArgs
Public Class SetAttrValueEventArgs
    Inherits HandledEventArgs
public ref class SetAttrValueEventArgs : public HandledEventArgs
type SetAttrValueEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo SetAttrValueEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SetAttrValueEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Name | Nome dell'attributo.
Proprietà pubblica | Value | Nuovo valore dell'attributo.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore SetAttrValueEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SetAttrValueEventArgs(
    Object attr,
    Object value,
    string name
)
Public Sub New (
    attr As Object,
    value As Object,
    name As String
)
public:
SetAttrValueEventArgs(
    Object^ attr,
    Object^ value,
    String^ name
)
new :
        attr : Object *
        value : Object *
        name : string -> SetAttrValueEventArgs

Parametri

attr Object
Attributo.
value Object
Nuovo valore.
name String
Nome dell'attributo.
Vedi anche

Documentazione

Classe SetAttrValueEventArgs


Proprietà di SetAttrValueEventArgs

Il tipo SetAttrValueEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | Name | Nome dell'attributo.
Proprietà pubblica | Value | Nuovo valore dell'attributo.
Torna su
Vedi anche

Documentazione

Classe SetAttrValueEventArgs


Proprietà SetAttrValueEventArgs.Attr

Proprietà SetAttrValueEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe SetAttrValueEventArgs


Proprietà SetAttrValueEventArgs.Name

Proprietà SetAttrValueEventArgsName
Nome dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe SetAttrValueEventArgs


Proprietà SetAttrValueEventArgs.Value

Proprietà SetAttrValueEventArgsValue
Nuovo valore dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}
member Value : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe SetAttrValueEventArgs


Classe ThumbnailControl
Classe usata per ricavare l'anteprima di un file.
Gerarchia di ereditarietà
SystemObject
QsUIThumbnailControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ThumbnailControl
Public Class ThumbnailControl
public ref class ThumbnailControl
type ThumbnailControl = class end

Il tipo ThumbnailControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ThumbnailControl | Costruttore. Copyright 2017 QsInformatica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Thumb | Ritorna un clone dell'immagine rappresentante l'anterpima del file.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ThumbnailControl
Costruttore. Copyright 2017 QsInformatica.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ThumbnailControl(
    string file,
    int width,
    int height
)
Public Sub New (
    file As String,
    width As Integer,
    height As Integer
)
public:
ThumbnailControl(
    String^ file,
    int width,
    int height
)
new :
        file : string *
        width : int *
        height : int -> ThumbnailControl

Parametri

file String
File di cui ricavare l'anteprima.
width Int32
Larghezza desiderata del preview.
height Int32
Altezza desiderata del preview.
Vedi anche

Documentazione

Classe ThumbnailControl


Proprietà di ThumbnailControl

Il tipo ThumbnailControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Thumb | Ritorna un clone dell'immagine rappresentante l'anterpima del file.
Torna su
Vedi anche

Documentazione

Classe ThumbnailControl


Proprietà ThumbnailControl.Thumb

Proprietà ThumbnailControlThumb
Ritorna un clone dell'immagine rappresentante l'anterpima del file.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Bitmap Thumb { get; }
Public ReadOnly Property Thumb As Bitmap
    Get
public:
property Bitmap^ Thumb {
    Bitmap^ get ();
}
member Thumb : Bitmap with get

Valore della proprietà

Bitmap
Vedi anche

Documentazione

Classe ThumbnailControl


Enumerazione ThumbnailOptions

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ThumbnailOptions
<FlagsAttribute>
Public Enumeration ThumbnailOptions
[FlagsAttribute]
public enum class ThumbnailOptions
[<FlagsAttribute>]
type ThumbnailOptions
Membri
Nome | Valore | Descrizione
None | 0 |
BiggerSizeOk | 1 |
InMemoryOnly | 2 |
IconOnly | 4 |
ThumbnailOnly | 8 |
InCacheOnly | 16 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe TreeListChoice
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUITreeListChoice

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class TreeListChoice : XtraForm
Public Class TreeListChoice
    Inherits XtraForm
public ref class TreeListChoice : public XtraForm
type TreeListChoice =
    class
        inherit XtraForm
    end

Il tipo TreeListChoice espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TreeListChoice | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FieldNameColumnFullFileName | FielName della colonna che contiene il fullfilename del file. (Create tale colonna tramite metodo AddColumn)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FormTitle | Imposta il titolo del form.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Multilev | Indica se la visualizzazione di default deve essere multilivello.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OkCancelControl | Restituisce il controllo ok cancel
Proprietà pubblica | Res | Restituisce se è stao premuto ok o cancel
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedNodes | Restiruisce la lista dei nodi selezionati.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowBtnStructure | Indica se visualizzare o meno il pannello con i pulsanti per il multilivello.
Proprietà pubblica | ShowFileIcon | Indica se visualizzare o meno l'icona dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowOptions | Indica se visualizzare o meno il pannello con le opzioni personalizzate
Proprietà pubblica | ShowPreview | Indica se visualizzare o meno l'anteprima dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StateImageList | Lista di immagini da usare per disegnare icona.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | TreeList | Restituiece l'albero.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddColumn(String, String, Boolean) | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | AddColumn(String, String, Boolean, Boolean) | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | AddNode | Aggiunge un nodo all'albero (è bene fare TreeList.BeginUnboundLoad prima di inserire la primo e TreeList.EndUnboundLoad dopo aver inserito l'ultimo)
Metodo pubblico | AddOption | Aggiunge oggetto custom al pannello opzioni
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnCheckNode | Chiama l'evento ShowSaveForm.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetOptionsTitle | Imposta il titolo del gruppo di controlli opzioni
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | Show | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CheckNodeEvent | Evento chiamato alla fine dell'inizializzazione dell'applicazione.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore TreeListChoice
Costruttore

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListChoice()
Public Sub New
public:
TreeListChoice()
new : unit -> TreeListChoice
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FieldNameColumnFullFileName | FielName della colonna che contiene il fullfilename del file. (Create tale colonna tramite metodo AddColumn)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FormTitle | Imposta il titolo del form.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Multilev | Indica se la visualizzazione di default deve essere multilivello.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OkCancelControl | Restituisce il controllo ok cancel
Proprietà pubblica | Res | Restituisce se è stao premuto ok o cancel
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedNodes | Restiruisce la lista dei nodi selezionati.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowBtnStructure | Indica se visualizzare o meno il pannello con i pulsanti per il multilivello.
Proprietà pubblica | ShowFileIcon | Indica se visualizzare o meno l'icona dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowOptions | Indica se visualizzare o meno il pannello con le opzioni personalizzate
Proprietà pubblica | ShowPreview | Indica se visualizzare o meno l'anteprima dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StateImageList | Lista di immagini da usare per disegnare icona.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | TreeList | Restituiece l'albero.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.FieldNameColumnFullFileName

Proprietà TreeListChoiceFieldNameColumnFullFileName
FielName della colonna che contiene il fullfilename del file. (Create tale colonna tramite metodo AddColumn)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldNameColumnFullFileName { get; set; }
Public Property FieldNameColumnFullFileName As String
    Get
    Set
public:
property String^ FieldNameColumnFullFileName {
    String^ get ();
    void set (String^ value);
}
member FieldNameColumnFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.FormTitle

Proprietà TreeListChoiceFormTitle
Imposta il titolo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FormTitle { set; }
Public WriteOnly Property FormTitle As String
    Set
public:
property String^ FormTitle {
    void set (String^ value);
}
member FormTitle : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.Multilev

Proprietà TreeListChoiceMultilev
Indica se la visualizzazione di default deve essere multilivello.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multilev { get; set; }
Public Property Multilev As Boolean
    Get
    Set
public:
property bool Multilev {
    bool get ();
    void set (bool value);
}
member Multilev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.OkCancelControl

Proprietà TreeListChoiceOkCancelControl
Restituisce il controllo ok cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public OkCancelControl OkCancelControl { get; }
Public ReadOnly Property OkCancelControl As OkCancelControl
    Get
public:
property OkCancelControl^ OkCancelControl {
    OkCancelControl^ get ();
}
member OkCancelControl : OkCancelControl with get

Valore della proprietà

OkCancelControl
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.Res

Proprietà TreeListChoiceRes
Restituisce se è stao premuto ok o cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult Res { get; }
Public ReadOnly Property Res As DialogResult
    Get
public:
property DialogResult Res {
    DialogResult get ();
}
member Res : DialogResult with get

Valore della proprietà

DialogResult
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.SelectedNodes

Proprietà TreeListChoiceSelectedNodes
Restiruisce la lista dei nodi selezionati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<TreeListNode> SelectedNodes { get; }
Public ReadOnly Property SelectedNodes As List(Of TreeListNode)
    Get
public:
property List<TreeListNode^>^ SelectedNodes {
    List<TreeListNode^>^ get ();
}
member SelectedNodes : List<TreeListNode> with get

Valore della proprietà

List TreeListNode
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.ShowBtnStructure

Proprietà TreeListChoiceShowBtnStructure
Indica se visualizzare o meno il pannello con i pulsanti per il multilivello.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowBtnStructure { get; set; }
Public Property ShowBtnStructure As Boolean
    Get
    Set
public:
property bool ShowBtnStructure {
    bool get ();
    void set (bool value);
}
member ShowBtnStructure : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.ShowFileIcon

Proprietà TreeListChoiceShowFileIcon
Indica se visualizzare o meno l'icona dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFileIcon { get; set; }
Public Property ShowFileIcon As Boolean
    Get
    Set
public:
property bool ShowFileIcon {
    bool get ();
    void set (bool value);
}
member ShowFileIcon : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.ShowOptions

Proprietà TreeListChoiceShowOptions
Indica se visualizzare o meno il pannello con le opzioni personalizzate

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOptions { get; set; }
Public Property ShowOptions As Boolean
    Get
    Set
public:
property bool ShowOptions {
    bool get ();
    void set (bool value);
}
member ShowOptions : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.ShowPreview

Proprietà TreeListChoiceShowPreview
Indica se visualizzare o meno l'anteprima dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { get; set; }
Public Property ShowPreview As Boolean
    Get
    Set
public:
property bool ShowPreview {
    bool get ();
    void set (bool value);
}
member ShowPreview : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.StateImageList

Proprietà TreeListChoiceStateImageList
Lista di immagini da usare per disegnare icona.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ImageCollection StateImageList { get; set; }
Public Property StateImageList As ImageCollection
    Get
    Set
public:
property ImageCollection^ StateImageList {
    ImageCollection^ get ();
    void set (ImageCollection^ value);
}
member StateImageList : ImageCollection with get, set

Valore della proprietà

ImageCollection
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.TreeList

Proprietà TreeListChoiceTreeList
Restituiece l'albero.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList TreeList { get; }
Public ReadOnly Property TreeList As TreeList
    Get
public:
property TreeList^ TreeList {
    TreeList^ get ();
}
member TreeList : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe TreeListChoice


Metodi di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddColumn(String, String, Boolean) | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | AddColumn(String, String, Boolean, Boolean) | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | AddNode | Aggiunge un nodo all'albero (è bene fare TreeList.BeginUnboundLoad prima di inserire la primo e TreeList.EndUnboundLoad dopo aver inserito l'ultimo)
Metodo pubblico | AddOption | Aggiunge oggetto custom al pannello opzioni
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnCheckNode | Chiama l'evento ShowSaveForm.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetOptionsTitle | Imposta il titolo del gruppo di controlli opzioni
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | Show | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.AddColumn

Metodo TreeListChoiceAddColumn
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddColumn(String, String, Boolean) | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | AddColumn(String, String, Boolean, Boolean) | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.AddColumn(String, String, Boolean)

Metodo TreeListChoiceAddColumn(String, String, Boolean)
Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddColumn(
    string caption,
    string fieldname,
    bool visible
)
Public Sub AddColumn (
    caption As String,
    fieldname As String,
    visible As Boolean
)
public:
void AddColumn(
    String^ caption,
    String^ fieldname,
    bool visible
)
member AddColumn :
        caption : string *
        fieldname : string *
        visible : bool -> unit

Parametri

caption String
Caption della colonna
fieldname String
Nome interno della colonna
visible Boolean
Indica se la colonna deve essere visibile o meno
Vedi anche

Documentazione

Classe TreeListChoice
Overload di AddColumn


Metodo TreeListChoice.AddColumn(String, String, Boolean, Boolean)

Metodo TreeListChoiceAddColumn(String, String, Boolean, Boolean)
Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddColumn(
    string caption,
    string fieldname,
    bool visible,
    bool editable
)
Public Sub AddColumn (
    caption As String,
    fieldname As String,
    visible As Boolean,
    editable As Boolean
)
public:
void AddColumn(
    String^ caption,
    String^ fieldname,
    bool visible,
    bool editable
)
member AddColumn :
        caption : string *
        fieldname : string *
        visible : bool *
        editable : bool -> unit

Parametri

caption String
Caption della colonna
fieldname String
Nome interno della colonna
visible Boolean
Indica se la colonna deve essere visibile o meno
editable Boolean
Vedi anche

Documentazione

Classe TreeListChoice
Overload di AddColumn


Metodo TreeListChoice.AddNode

Metodo TreeListChoiceAddNode
Aggiunge un nodo all'albero (è bene fare TreeList.BeginUnboundLoad prima di inserire la primo e TreeList.EndUnboundLoad dopo aver inserito l'ultimo)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode AddNode(
    List<Object> values,
    bool checkNode,
    TreeListNode parentNode
)
Public Function AddNode (
    values As List(Of Object),
    checkNode As Boolean,
    parentNode As TreeListNode
) As TreeListNode
public:
TreeListNode^ AddNode(
    List<Object^>^ values,
    bool checkNode,
    TreeListNode^ parentNode
)
member AddNode :
        values : List<Object> *
        checkNode : bool *
        parentNode : TreeListNode -> TreeListNode

Parametri

values List Object
Array di oggetti che rappresentano il contenuto delle varie colonne create.
checkNode Boolean
Indica se selezionare il nodo di default
parentNode TreeListNode
Nodo genitore (null se deve essere un nodo di testa)

Valore di ritorno

TreeListNode
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.AddOption

Metodo TreeListChoiceAddOption
Aggiunge oggetto custom al pannello opzioni

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddOption(
    Control item
)
Public Sub AddOption (
    item As Control
)
public:
void AddOption(
    Control^ item
)
member AddOption :
        item : Control -> unit

Parametri

item Control
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.Dispose

Metodo TreeListChoiceDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.OnCheckNode

Metodo TreeListChoiceOnCheckNode
Chiama l'evento ShowSaveForm.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCheckNode(
    TreeListChoiceCheckNodeEventArgs ev
)
Protected Friend Sub OnCheckNode (
    ev As TreeListChoiceCheckNodeEventArgs
)
protected public:
void OnCheckNode(
    TreeListChoiceCheckNodeEventArgs^ ev
)
member OnCheckNode :
        ev : TreeListChoiceCheckNodeEventArgs -> unit

Parametri

ev TreeListChoiceCheckNodeEventArgs
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.SetOptionsTitle

Metodo TreeListChoiceSetOptionsTitle
Imposta il titolo del gruppo di controlli opzioni

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetOptionsTitle(
    string groupTitle
)
Public Sub SetOptionsTitle (
    groupTitle As String
)
public:
void SetOptionsTitle(
    String^ groupTitle
)
member SetOptionsTitle :
        groupTitle : string -> unit

Parametri

groupTitle String
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.Show

Metodo TreeListChoiceShow
Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Show(
    string fileName
)
Public Sub Show (
    fileName As String
)
public:
void Show(
    String^ fileName
)
member Show :
        fileName : string -> unit

Parametri

fileName String
Percorso del file da visualizzare.
Vedi anche

Documentazione

Classe TreeListChoice


Eventi di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CheckNodeEvent | Evento chiamato alla fine dell'inizializzazione dell'applicazione.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Evento TreeListChoice.CheckNodeEvent

Evento TreeListChoiceCheckNodeEvent
Evento chiamato alla fine dell'inizializzazione dell'applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<TreeListChoiceCheckNodeEventArgs> CheckNodeEvent
Public Event CheckNodeEvent As EventHandler(Of TreeListChoiceCheckNodeEventArgs)
public:
 event EventHandler<TreeListChoiceCheckNodeEventArgs^>^ CheckNodeEvent {
    void add (EventHandler<TreeListChoiceCheckNodeEventArgs^>^ value);
    void remove (EventHandler<TreeListChoiceCheckNodeEventArgs^>^ value);
}
member CheckNodeEvent : IEvent<EventHandler<TreeListChoiceCheckNodeEventArgs>,
    TreeListChoiceCheckNodeEventArgs>

Valore

EventHandler TreeListChoiceCheckNodeEventArgs
Vedi anche

Documentazione

Classe TreeListChoice


Campi di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Classe TreeListChoice.CheckNodeEventArgs

Classe TreeListChoiceCheckNodeEventArgs
Argomento contenente le informazioni relative al comando in esecuzione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUITreeListChoiceCheckNodeEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckNodeEventArgs : EventArgs
Public Class CheckNodeEventArgs
    Inherits EventArgs
public ref class CheckNodeEventArgs : public EventArgs
type CheckNodeEventArgs =
    class
        inherit EventArgs
    end

Il tipo TreeListChoiceCheckNodeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TreeListChoiceCheckNodeEventArgs | Inizializza una nuova istanza della classe TreeListChoiceCheckNodeEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanCheck |
Proprietà pubblica | Node | Restituisce il comando in esecuzione.
Proprietà pubblica | PrevState |
Proprietà pubblica | State |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore TreeListChoice.CheckNodeEventArgs

Costruttore TreeListChoiceCheckNodeEventArgs
Inizializza una nuova istanza della classe TreeListChoiceCheckNodeEventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CheckNodeEventArgs()
Public Sub New
public:
CheckNodeEventArgs()
new : unit -> CheckNodeEventArgs
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà di CheckNodeEventArgs

Il tipo TreeListChoiceCheckNodeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanCheck |
Proprietà pubblica | Node | Restituisce il comando in esecuzione.
Proprietà pubblica | PrevState |
Proprietà pubblica | State |
Torna su
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà TreeListChoice.CheckNodeEventArgs.CanCheck

Proprietà TreeListChoiceCheckNodeEventArgsCanCheck

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanCheck { get; set; }
Public Property CanCheck As Boolean
    Get
    Set
public:
property bool CanCheck {
    bool get ();
    void set (bool value);
}
member CanCheck : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà TreeListChoice.CheckNodeEventArgs.Node

Proprietà TreeListChoiceCheckNodeEventArgsNode
Restituisce il comando in esecuzione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; }
Public ReadOnly Property Node As TreeListNode
    Get
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
}
member Node : TreeListNode with get

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà TreeListChoice.CheckNodeEventArgs.PrevState

Proprietà TreeListChoiceCheckNodeEventArgsPrevState

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CheckState PrevState { get; set; }
Public Property PrevState As CheckState
    Get
    Set
public:
property CheckState PrevState {
    CheckState get ();
    void set (CheckState value);
}
member PrevState : CheckState with get, set

Valore della proprietà

CheckState
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà TreeListChoice.CheckNodeEventArgs.State

Proprietà TreeListChoiceCheckNodeEventArgsState

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CheckState State { get; set; }
Public Property State As CheckState
    Get
    Set
public:
property CheckState State {
    CheckState get ();
    void set (CheckState value);
}
member State : CheckState with get, set

Valore della proprietà

CheckState
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Classe ValidateAttrEventArgs
EventArgs dell'evento ValidateAttrEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIValidateAttrEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ValidateAttrEventArgs : EventArgs
Public Class ValidateAttrEventArgs
    Inherits EventArgs
public ref class ValidateAttrEventArgs : public EventArgs
type ValidateAttrEventArgs =
    class
        inherit EventArgs
    end

Il tipo ValidateAttrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ValidateAttrEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | RowAttr |
Proprietà pubblica | Valid | Indica se il valore è valido.
Proprietà pubblica | Value | Nuovo valore dell'attributo.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ValidateAttrEventArgs
Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ValidateAttrEventArgs(
    Object attr,
    Object value,
    AttributeTableRow rowAttr
)
Public Sub New (
    attr As Object,
    value As Object,
    rowAttr As AttributeTableRow
)
public:
ValidateAttrEventArgs(
    Object^ attr,
    Object^ value,
    AttributeTableRow^ rowAttr
)
new :
        attr : Object *
        value : Object *
        rowAttr : AttributeTableRow -> ValidateAttrEventArgs

Parametri

attr Object
Attributo.
value Object
Nuovo valore.
rowAttr AttributeTableRow
Vedi anche

Documentazione

Classe ValidateAttrEventArgs


Proprietà di ValidateAttrEventArgs

Il tipo ValidateAttrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Oggetto che descrive l'attributo.
Proprietà pubblica | RowAttr |
Proprietà pubblica | Valid | Indica se il valore è valido.
Proprietà pubblica | Value | Nuovo valore dell'attributo.
Torna su
Vedi anche

Documentazione

Classe ValidateAttrEventArgs


Proprietà ValidateAttrEventArgs.Attr

Proprietà ValidateAttrEventArgsAttr
Oggetto che descrive l'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Attr { get; }
Public ReadOnly Property Attr As Object
    Get
public:
property Object^ Attr {
    Object^ get ();
}
member Attr : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ValidateAttrEventArgs


Proprietà ValidateAttrEventArgs.RowAttr

Proprietà ValidateAttrEventArgsRowAttr

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeTableRow RowAttr { get; }
Public ReadOnly Property RowAttr As AttributeTableRow
    Get
public:
property AttributeTableRow^ RowAttr {
    AttributeTableRow^ get ();
}
member RowAttr : AttributeTableRow with get

Valore della proprietà

AttributeTableRow
Vedi anche

Documentazione

Classe ValidateAttrEventArgs


Proprietà ValidateAttrEventArgs.Valid

Proprietà ValidateAttrEventArgsValid
Indica se il valore è valido.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set
public:
property bool Valid {
    bool get ();
    void set (bool value);
}
member Valid : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ValidateAttrEventArgs


Proprietà ValidateAttrEventArgs.Value

Proprietà ValidateAttrEventArgsValue
Nuovo valore dell'attributo.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}
member Value : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ValidateAttrEventArgs


Classe WantDialogMessages
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.Windows.FormsNativeWindow
QsUIWantDialogMessages

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class WantDialogMessages : NativeWindow
Public Class WantDialogMessages
    Inherits NativeWindow
public ref class WantDialogMessages : public NativeWindow
type WantDialogMessages =
    class
        inherit NativeWindow
    end

Il tipo WantDialogMessages espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | WantDialogMessages | Inizializza una nuova istanza della classe WantDialogMessages.
Torna su
Metodi
 | Nome | Descrizione
 | ProcessMessage |
Metodo protetto | WndProc | (Sovrascrive NativeWindowWndProc(Message))
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore WantDialogMessages
Inizializza una nuova istanza della classe WantDialogMessages.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public WantDialogMessages(
    Control control,
    WantDialogMessagesFlags flags
)
Public Sub New (
    control As Control,
    flags As WantDialogMessagesFlags
)
public:
WantDialogMessages(
    Control^ control,
    WantDialogMessagesFlags flags
)
new :
        control : Control *
        flags : WantDialogMessagesFlags -> WantDialogMessages

Parametri

control Control
flags WantDialogMessagesFlags
Vedi anche

Documentazione

Classe WantDialogMessages


Metodi di WantDialogMessages

Il tipo WantDialogMessages espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | ProcessMessage |
Metodo protetto | WndProc | (Sovrascrive NativeWindowWndProc(Message))
Torna su
Vedi anche

Documentazione

Classe WantDialogMessages


Metodo WantDialogMessages.ProcessMessage

Metodo WantDialogMessagesProcessMessage

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ProcessMessage(
    ref Message msg,
    WantDialogMessagesFlags flags
)
Public Shared Sub ProcessMessage (
    ByRef msg As Message,
    flags As WantDialogMessagesFlags
)
public:
static void ProcessMessage(
    Message% msg,
    WantDialogMessagesFlags flags
)
static member ProcessMessage :
        msg : Message byref *
        flags : WantDialogMessagesFlags -> unit

Parametri

msg Message
flags WantDialogMessagesFlags
Vedi anche

Documentazione

Classe WantDialogMessages


Metodo WantDialogMessages.WndProc

Metodo WantDialogMessagesWndProc

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void WndProc(
    ref Message msg
)
Protected Overrides Sub WndProc (
    ByRef msg As Message
)
protected:
virtual void WndProc(
    Message% msg
) override
abstract WndProc :
        msg : Message byref -> unit
override WndProc :
        msg : Message byref -> unit

Parametri

msg Message
Vedi anche

Documentazione

Classe WantDialogMessages


Enumerazione WantDialogMessages.Flags

Enumerazione WantDialogMessagesFlags

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum Flags
Public Enumeration Flags
public enum class Flags
type Flags
Membri
Nome | Valore | Descrizione
WantEscEnter | 1 |
WantArrows | 2 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione WantDialogMessages.WindowsMessage

Enumerazione WantDialogMessagesWindowsMessage

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum WindowsMessage
Public Enumeration WindowsMessage
public enum class WindowsMessage
type WindowsMessage
Membri
Nome | Valore | Descrizione
WM_NULL | 0 |
WM_CREATE | 1 |
WM_DESTROY | 2 |
WM_GETDLGCODE | 135 |
WM_KEYDOWN | 256 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe WindowsThumbnailProvider
Gerarchia di ereditarietà
SystemObject
QsUIWindowsThumbnailProvider

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class WindowsThumbnailProvider
Public Class WindowsThumbnailProvider
public ref class WindowsThumbnailProvider
type WindowsThumbnailProvider = class end

Il tipo WindowsThumbnailProvider espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | WindowsThumbnailProvider | Inizializza una nuova istanza della classe WindowsThumbnailProvider.
Torna su
Metodi
Nome | Descrizione
CreateAlphaBitmap |
GetBitmapFromHBitmap |
GetThumbnail |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore WindowsThumbnailProvider
Inizializza una nuova istanza della classe WindowsThumbnailProvider.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public WindowsThumbnailProvider()
Public Sub New
public:
WindowsThumbnailProvider()
new : unit -> WindowsThumbnailProvider
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodi di WindowsThumbnailProvider

Il tipo WindowsThumbnailProvider espone i seguenti membri.

Metodi
Nome | Descrizione
CreateAlphaBitmap |
GetBitmapFromHBitmap |
GetThumbnail |
Torna su
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodo WindowsThumbnailProvider.CreateAlphaBitmap

Metodo WindowsThumbnailProviderCreateAlphaBitmap

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap CreateAlphaBitmap(
    Bitmap srcBitmap,
    PixelFormat targetPixelFormat
)
Public Shared Function CreateAlphaBitmap (
    srcBitmap As Bitmap,
    targetPixelFormat As PixelFormat
) As Bitmap
public:
static Bitmap^ CreateAlphaBitmap(
    Bitmap^ srcBitmap,
    PixelFormat targetPixelFormat
)
static member CreateAlphaBitmap :
        srcBitmap : Bitmap *
        targetPixelFormat : PixelFormat -> Bitmap

Parametri

srcBitmap Bitmap
targetPixelFormat PixelFormat

Valore di ritorno

Bitmap
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodo WindowsThumbnailProvider.GetBitmapFromHBitmap

Metodo WindowsThumbnailProviderGetBitmapFromHBitmap

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap GetBitmapFromHBitmap(
    IntPtr nativeHBitmap
)
Public Shared Function GetBitmapFromHBitmap (
    nativeHBitmap As IntPtr
) As Bitmap
public:
static Bitmap^ GetBitmapFromHBitmap(
    IntPtr nativeHBitmap
)
static member GetBitmapFromHBitmap :
        nativeHBitmap : IntPtr -> Bitmap

Parametri

nativeHBitmap IntPtr

Valore di ritorno

Bitmap
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodo WindowsThumbnailProvider.GetThumbnail

Metodo WindowsThumbnailProviderGetThumbnail

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap GetThumbnail(
    string fileName,
    int width,
    int height,
    ThumbnailOptions options
)
Public Shared Function GetThumbnail (
    fileName As String,
    width As Integer,
    height As Integer,
    options As ThumbnailOptions
) As Bitmap
public:
static Bitmap^ GetThumbnail(
    String^ fileName,
    int width,
    int height,
    ThumbnailOptions options
)
static member GetThumbnail :
        fileName : string *
        width : int *
        height : int *
        options : ThumbnailOptions -> Bitmap

Parametri

fileName String
width Int32
height Int32
options ThumbnailOptions

Valore di ritorno

Bitmap
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Struttura WindowsThumbnailProvider.RGBQUAD

Struttura WindowsThumbnailProviderRGBQUAD
Gerarchia di ereditarietà
SystemObject
SystemValueType
QsUIWindowsThumbnailProviderRGBQUAD

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public struct RGBQUAD
Public Structure RGBQUAD
public value class RGBQUAD
[<SealedAttribute>]
type RGBQUAD =
    struct
        inherit ValueType
    end

Il tipo WindowsThumbnailProviderRGBQUAD espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | rgbBlue |
Campo pubblico | rgbGreen |
Campo pubblico | rgbRed |
Campo pubblico | rgbReserved |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Campi di RGBQUAD

Il tipo WindowsThumbnailProviderRGBQUAD espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | rgbBlue |
Campo pubblico | rgbGreen |
Campo pubblico | rgbRed |
Campo pubblico | rgbReserved |
Torna su
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbBlue

Campo WindowsThumbnailProviderRGBQUADrgbBlue

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public byte rgbBlue
Public rgbBlue As Byte
public:
unsigned char rgbBlue
val mutable rgbBlue: byte

Valore del campo

Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbGreen

Campo WindowsThumbnailProviderRGBQUADrgbGreen

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public byte rgbGreen
Public rgbGreen As Byte
public:
unsigned char rgbGreen
val mutable rgbGreen: byte

Valore del campo

Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbRed

Campo WindowsThumbnailProviderRGBQUADrgbRed

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public byte rgbRed
Public rgbRed As Byte
public:
unsigned char rgbRed
val mutable rgbRed: byte

Valore del campo

Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbReserved

Campo WindowsThumbnailProviderRGBQUADrgbReserved

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public byte rgbReserved
Public rgbReserved As Byte
public:
unsigned char rgbReserved
val mutable rgbReserved: byte

Valore del campo

Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Classe WinToggles
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIWinToggles

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class WinToggles : QsBaseForm
Public Class WinToggles
    Inherits QsBaseForm
public ref class WinToggles : public QsBaseForm
type WinToggles =
    class
        inherit QsBaseForm
    end

Il tipo WinToggles espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | WinToggles | Inizializza una nuova istanza della classe WinToggles.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | ButtonCancel |
Proprietà pubblica | ButtonOk |
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | CheckedListBox |
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GroupControl |
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore WinToggles
Inizializza una nuova istanza della classe WinToggles.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public WinToggles()
Public Sub New
public:
WinToggles()
new : unit -> WinToggles
Vedi anche

Documentazione

Classe WinToggles


Proprietà di WinToggles

Il tipo WinToggles espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | ButtonCancel |
Proprietà pubblica | ButtonOk |
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | CheckedListBox |
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GroupControl |
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe WinToggles


Proprietà WinToggles.ButtonCancel

Proprietà WinTogglesButtonCancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton ButtonCancel { get; set; }
Public Property ButtonCancel As SimpleButton
    Get
    Set
public:
property SimpleButton^ ButtonCancel {
    SimpleButton^ get ();
    void set (SimpleButton^ value);
}
member ButtonCancel : SimpleButton with get, set

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe WinToggles


Proprietà WinToggles.ButtonOk

Proprietà WinTogglesButtonOk

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton ButtonOk { get; set; }
Public Property ButtonOk As SimpleButton
    Get
    Set
public:
property SimpleButton^ ButtonOk {
    SimpleButton^ get ();
    void set (SimpleButton^ value);
}
member ButtonOk : SimpleButton with get, set

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe WinToggles


Proprietà WinToggles.CheckedListBox

Proprietà WinTogglesCheckedListBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public CheckedListBoxControl CheckedListBox { get; set; }
Public Property CheckedListBox As CheckedListBoxControl
    Get
    Set
public:
property CheckedListBoxControl^ CheckedListBox {
    CheckedListBoxControl^ get ();
    void set (CheckedListBoxControl^ value);
}
member CheckedListBox : CheckedListBoxControl with get, set

Valore della proprietà

CheckedListBoxControl
Vedi anche

Documentazione

Classe WinToggles


Proprietà WinToggles.GroupControl

Proprietà WinTogglesGroupControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GroupControl GroupControl { get; set; }
Public Property GroupControl As GroupControl
    Get
    Set
public:
property GroupControl^ GroupControl {
    GroupControl^ get ();
    void set (GroupControl^ value);
}
member GroupControl : GroupControl with get, set

Valore della proprietà

GroupControl
Vedi anche

Documentazione

Classe WinToggles


Metodi di WinToggles

Il tipo WinToggles espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe WinToggles


Metodo WinToggles.Dispose

Metodo WinTogglesDispose
Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe WinToggles


Eventi di WinToggles

Il tipo WinToggles espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe WinToggles


Campi di WinToggles

Il tipo WinToggles espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe WinToggles


Classe WinTogglesResult
Gerarchia di ereditarietà
SystemObject
QsUIWinTogglesResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class WinTogglesResult
Public Class WinTogglesResult
public ref class WinTogglesResult
type WinTogglesResult = class end

Il tipo WinTogglesResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | WinTogglesResult | Inizializza una nuova istanza della classe WinTogglesResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | List |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore WinTogglesResult
Inizializza una nuova istanza della classe WinTogglesResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public WinTogglesResult()
Public Sub New
public:
WinTogglesResult()
new : unit -> WinTogglesResult
Vedi anche

Documentazione

Classe WinTogglesResult


Campi di WinTogglesResult

Il tipo WinTogglesResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | List |
Campo pubblico | OK |
Torna su
Vedi anche

Documentazione

Classe WinTogglesResult


Campo WinTogglesResult.List

Campo WinTogglesResultList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> List
Public List As List(Of Object)
public:
List<Object^>^ List
val mutable List: List<Object>

Valore del campo

List Object
Vedi anche

Documentazione

Classe WinTogglesResult


Campo WinTogglesResult.OK

Campo WinTogglesResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe WinTogglesResult


QsUI.form Namespace
Classi
 | Classe | Descrizione
Classe pubblica | ShowText |


Classe ShowText
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUI.formShowText

Namespace: QsUI.form
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowText : XtraForm
Public Class ShowText
    Inherits XtraForm
public ref class ShowText : public XtraForm
type ShowText =
    class
        inherit XtraForm
    end

Il tipo ShowText espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ShowText | Inizializza una nuova istanza della classe ShowText.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace QsUI.form


Costruttore ShowText
Inizializza una nuova istanza della classe ShowText.

Namespace: QsUI.form
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ShowText(
    string text,
    string title
)
Public Sub New (
    text As String,
    title As String
)
public:
ShowText(
    String^ text,
    String^ title
)
new :
        text : string *
        title : string -> ShowText

Parametri

text String
title String
Vedi anche

Documentazione

Classe ShowText
Namespace QsUI.form


Proprietà di ShowText

Il tipo ShowText espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ShowText
Namespace QsUI.form


Metodi di ShowText

Il tipo ShowText espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ShowText
Namespace QsUI.form


Metodo ShowText.Dispose

Metodo ShowTextDispose
Clean up any resources being used.

Namespace: QsUI.form
Assembly: QsUI (in QsUI.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ShowText
Namespace QsUI.form


Eventi di ShowText

Il tipo ShowText espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ShowText
Namespace QsUI.form


Campi di ShowText

Il tipo ShowText espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ShowText
Namespace QsUI.form