QsInformatica.Utils

QsInformatica.Utils mette a disposizione dell'utente una serie di API atte ad adempiere i più svariati compiti. Sarà infatti possibile interagire con file .ini e .xml, mandare mail tramite servizio SMTP e molto altro ancora.


QsInformatica.AutoCAD.Runtime Namespace

[Missing <summary> documentation for "N:QsInformatica.AutoCAD.Runtime"]

Classes
 | Class | Description
Public class | QsCommandClassAttribute |
Public class | QsCommandMethodAttribute |
Public class | QsExtensionApplicationAttribute |
Interfaces
 | Interface | Description
Public interface | IExtensionApplication | Interfaccia che la classe di inizializzazione deve implementare.
Enumerations
 | Enumeration | Description
Public enumeration | QsCommandFlags | Flags usati nella definizione dei comandi di AutoCAD


IExtensionApplication Interface

Interfaccia che la classe di inizializzazione deve implementare.

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public interface IExtensionApplication
Public Interface IExtensionApplication
public interface class IExtensionApplication
type IExtensionApplication = interface end

The IExtensionApplication type exposes the following members.

Methods
 | Name | Description
Public method | Initialize |
Public method | Terminate |
Top
See Also

Reference

QsInformatica.AutoCAD.Runtime Namespace


IExtensionApplication Methods

The IExtensionApplication type exposes the following members.

Methods
 | Name | Description
Public method | Initialize |
Public method | Terminate |
Top
See Also

Reference

IExtensionApplication Interface
QsInformatica.AutoCAD.Runtime Namespace


IExtensionApplication.Initialize Method

A Sandcastle Documented Class Library

IExtensionApplicationInitialize Method

[Missing <summary> documentation for "M:QsInformatica.AutoCAD.Runtime.IExtensionApplication.Initialize"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void Initialize()
Sub Initialize
void Initialize()
abstract Initialize : unit -> unit
See Also

Reference

IExtensionApplication Interface
QsInformatica.AutoCAD.Runtime Namespace


IExtensionApplication.Terminate Method

IExtensionApplicationTerminate Method

[Missing <summary> documentation for "M:QsInformatica.AutoCAD.Runtime.IExtensionApplication.Terminate"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void Terminate()
Sub Terminate
void Terminate()
abstract Terminate : unit -> unit
See Also

Reference

IExtensionApplication Interface
QsInformatica.AutoCAD.Runtime Namespace


QsCommandClassAttribute Class

[Missing <summary> documentation for "T:QsInformatica.AutoCAD.Runtime.QsCommandClassAttribute"]

Inheritance Hierarchy
SystemObject
SystemAttribute
QsInformatica.AutoCAD.RuntimeQsCommandClassAttribute

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class QsCommandClassAttribute : Attribute
Public NotInheritable Class QsCommandClassAttribute
    Inherits Attribute
public ref class QsCommandClassAttribute sealed : public Attribute
[<SealedAttribute>]
type QsCommandClassAttribute =
    class
        inherit Attribute
    end

The QsCommandClassAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | QsCommandClassAttribute | Initializes a new instance of the QsCommandClassAttribute class
Top
Properties
 | Name | Description
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.AutoCAD.Runtime Namespace


QsCommandClassAttribute Constructor

Initializes a new instance of the QsCommandClassAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandClassAttribute(
    Type name
)
Public Sub New (
    name As Type
)
public:
QsCommandClassAttribute(
    Type^ name
)
new :
        name : Type -> QsCommandClassAttribute

Parameters

name Type

[Missing <param name="name"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandClassAttribute.#ctor(System.Type)"]

See Also

Reference

QsCommandClassAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandClassAttribute Properties

The QsCommandClassAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

QsCommandClassAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandClassAttribute.Type Property

QsCommandClassAttributeType Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandClassAttribute.Type"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type
See Also

Reference

QsCommandClassAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandClassAttribute Methods

The QsCommandClassAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsCommandClassAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandFlags Enumeration

Flags usati nella definizione dei comandi di AutoCAD

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum QsCommandFlags
<FlagsAttribute>
Public Enumeration QsCommandFlags
[FlagsAttribute]
public enum class QsCommandFlags
[<FlagsAttribute>]
type QsCommandFlags
Members
Member name | Value | Description
Modal | 0 |
Transparent | 1 |
UsePickSet | 2 |
Redraw | 4 |
NoPerspective | 8 |
NoMultiple | 16 |
NoTileMode | 32 |
NoPaperSpace | 64 |
NoOem | 256 |
Undefined | 512 |
InProgress | 1,024 |
Defun | 2,048 |
NoNewStack | 65,536 |
NoInternalLock | 131,072 |
DocReadLock | 524,288 |
DocExclusiveLock | 1,048,576 |
Session | 2,097,152 |
Interruptible | 4,194,304 |
NoHistory | 8,388,608 |
NoUndoMarker | 16,777,216 |
NoBlockEditor | 33,554,432 |
NoActionRecording | 67,108,864 |
ActionMacro | 134,217,728 |
NoInferConstraint | 1,073,741,824 |
TempShowDynDimension | -2,147,483,648 |
See Also

Reference

QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute Class

[Missing <summary> documentation for "T:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute"]

Inheritance Hierarchy
SystemObject
SystemAttribute
QsInformatica.AutoCAD.RuntimeQsCommandMethodAttribute

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class QsCommandMethodAttribute : Attribute
Public NotInheritable Class QsCommandMethodAttribute
    Inherits Attribute
public ref class QsCommandMethodAttribute sealed : public Attribute
[<SealedAttribute>]
type QsCommandMethodAttribute =
    class
        inherit Attribute
    end

The QsCommandMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | QsCommandMethodAttribute(String) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, QsCommandFlags) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, QsCommandFlags) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags, String) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags, Type) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags, Type, String, String) | Initializes a new instance of the QsCommandMethodAttribute class
Top
Properties
 | Name | Description
Public property | ContextMenuExtensionType |
Public property | Flags |
Public property | GlobalName |
Public property | GroupName |
Public property | HelpFileName |
Public property | HelpTopic |
Public property | LocalizedNameId |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute Constructor

Overload List
 | Name | Description
Public method | QsCommandMethodAttribute(String) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, QsCommandFlags) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, QsCommandFlags) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags, String) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags, Type) | Initializes a new instance of the QsCommandMethodAttribute class
Public method | QsCommandMethodAttribute(String, String, String, QsCommandFlags, Type, String, String) | Initializes a new instance of the QsCommandMethodAttribute class
Top
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string globalName
)
Public Sub New (
    globalName As String
)
public:
QsCommandMethodAttribute(
    String^ globalName
)
new :
        globalName : string -> QsCommandMethodAttribute

Parameters

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String, QsCommandFlags) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string globalName,
    QsCommandFlags flags
)
Public Sub New (
    globalName As String,
    flags As QsCommandFlags
)
public:
QsCommandMethodAttribute(
    String^ globalName,
    QsCommandFlags flags
)
new :
        globalName : string *
        flags : QsCommandFlags -> QsCommandMethodAttribute

Parameters

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

flags QsCommandFlags

[Missing <param name="flags"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String, String, QsCommandFlags) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string groupName,
    string globalName,
    QsCommandFlags flags
)
Public Sub New (
    groupName As String,
    globalName As String,
    flags As QsCommandFlags
)
public:
QsCommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    QsCommandFlags flags
)
new :
        groupName : string *
        globalName : string *
        flags : QsCommandFlags -> QsCommandMethodAttribute

Parameters

groupName String

[Missing <param name="groupName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

flags QsCommandFlags

[Missing <param name="flags"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String, String, String, QsCommandFlags) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    QsCommandFlags flags
)
Public Sub New (
    groupName As String,
    globalName As String,
    localizedNameId As String,
    flags As QsCommandFlags
)
public:
QsCommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    QsCommandFlags flags
)
new :
        groupName : string *
        globalName : string *
        localizedNameId : string *
        flags : QsCommandFlags -> QsCommandMethodAttribute

Parameters

groupName String

[Missing <param name="groupName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

localizedNameId String

[Missing <param name="localizedNameId"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

flags QsCommandFlags

[Missing <param name="flags"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String, String, String, QsCommandFlags, String) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    QsCommandFlags flags,
    string helpTopic
)
Public Sub New (
    groupName As String,
    globalName As String,
    localizedNameId As String,
    flags As QsCommandFlags,
    helpTopic As String
)
public:
QsCommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    QsCommandFlags flags,
    String^ helpTopic
)
new :
        groupName : string *
        globalName : string *
        localizedNameId : string *
        flags : QsCommandFlags *
        helpTopic : string -> QsCommandMethodAttribute

Parameters

groupName String

[Missing <param name="groupName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.String)"]

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.String)"]

localizedNameId String

[Missing <param name="localizedNameId"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.String)"]

flags QsCommandFlags

[Missing <param name="flags"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.String)"]

helpTopic String

[Missing <param name="helpTopic"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.String)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String, String, String, QsCommandFlags, Type) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    QsCommandFlags flags,
    Type contextMenuExtensionType
)
Public Sub New (
    groupName As String,
    globalName As String,
    localizedNameId As String,
    flags As QsCommandFlags,
    contextMenuExtensionType As Type
)
public:
QsCommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    QsCommandFlags flags,
    Type^ contextMenuExtensionType
)
new :
        groupName : string *
        globalName : string *
        localizedNameId : string *
        flags : QsCommandFlags *
        contextMenuExtensionType : Type -> QsCommandMethodAttribute

Parameters

groupName String

[Missing <param name="groupName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type)"]

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type)"]

localizedNameId String

[Missing <param name="localizedNameId"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type)"]

flags QsCommandFlags

[Missing <param name="flags"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type)"]

contextMenuExtensionType Type

[Missing <param name="contextMenuExtensionType"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute(String, String, String, QsCommandFlags, Type, String, String) Constructor

Initializes a new instance of the QsCommandMethodAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    QsCommandFlags flags,
    Type contextMenuExtensionType,
    string helpFileName,
    string helpTopic
)
Public Sub New (
    groupName As String,
    globalName As String,
    localizedNameId As String,
    flags As QsCommandFlags,
    contextMenuExtensionType As Type,
    helpFileName As String,
    helpTopic As String
)
public:
QsCommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    QsCommandFlags flags,
    Type^ contextMenuExtensionType,
    String^ helpFileName,
    String^ helpTopic
)
new :
        groupName : string *
        globalName : string *
        localizedNameId : string *
        flags : QsCommandFlags *
        contextMenuExtensionType : Type *
        helpFileName : string *
        helpTopic : string -> QsCommandMethodAttribute

Parameters

groupName String

[Missing <param name="groupName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

globalName String

[Missing <param name="globalName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

localizedNameId String

[Missing <param name="localizedNameId"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

flags QsCommandFlags

[Missing <param name="flags"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

contextMenuExtensionType Type

[Missing <param name="contextMenuExtensionType"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

helpFileName String

[Missing <param name="helpFileName"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

helpTopic String

[Missing <param name="helpTopic"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.#ctor(System.String,System.String,System.String,QsInformatica.AutoCAD.Runtime.QsCommandFlags,System.Type,System.String,System.String)"]

See Also

Reference

QsCommandMethodAttribute Class
QsCommandMethodAttribute Overload
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute Properties

The QsCommandMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ContextMenuExtensionType |
Public property | Flags |
Public property | GlobalName |
Public property | GroupName |
Public property | HelpFileName |
Public property | HelpTopic |
Public property | LocalizedNameId |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.ContextMenuExtensionType Property

QsCommandMethodAttributeContextMenuExtensionType Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.ContextMenuExtensionType"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Type ContextMenuExtensionType { get; }
Public ReadOnly Property ContextMenuExtensionType As Type
    Get
public:
property Type^ ContextMenuExtensionType {
    Type^ get ();
}
member ContextMenuExtensionType : Type with get

Property Value

Type
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.Flags Property

QsCommandMethodAttributeFlags Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.Flags"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsCommandFlags Flags { get; }
Public ReadOnly Property Flags As QsCommandFlags
    Get
public:
property QsCommandFlags Flags {
    QsCommandFlags get ();
}
member Flags : QsCommandFlags with get

Property Value

QsCommandFlags
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.GlobalName Property

QsCommandMethodAttributeGlobalName Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.GlobalName"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string GlobalName { get; }
Public ReadOnly Property GlobalName As String
    Get
public:
property String^ GlobalName {
    String^ get ();
}
member GlobalName : string with get

Property Value

String
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.GroupName Property

QsCommandMethodAttributeGroupName Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.GroupName"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string GroupName { get; }
Public ReadOnly Property GroupName As String
    Get
public:
property String^ GroupName {
    String^ get ();
}
member GroupName : string with get

Property Value

String
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.HelpFileName Property

QsCommandMethodAttributeHelpFileName Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.HelpFileName"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string HelpFileName { get; }
Public ReadOnly Property HelpFileName As String
    Get
public:
property String^ HelpFileName {
    String^ get ();
}
member HelpFileName : string with get

Property Value

String
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.HelpTopic Property

QsCommandMethodAttributeHelpTopic Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.HelpTopic"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string HelpTopic { get; }
Public ReadOnly Property HelpTopic As String
    Get
public:
property String^ HelpTopic {
    String^ get ();
}
member HelpTopic : string with get

Property Value

String
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute.LocalizedNameId Property

QsCommandMethodAttributeLocalizedNameId Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsCommandMethodAttribute.LocalizedNameId"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string LocalizedNameId { get; }
Public ReadOnly Property LocalizedNameId As String
    Get
public:
property String^ LocalizedNameId {
    String^ get ();
}
member LocalizedNameId : string with get

Property Value

String
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsCommandMethodAttribute Methods

The QsCommandMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsCommandMethodAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsExtensionApplicationAttribute Class

[Missing <summary> documentation for "T:QsInformatica.AutoCAD.Runtime.QsExtensionApplicationAttribute"]

Inheritance Hierarchy
SystemObject
SystemAttribute
QsInformatica.AutoCAD.RuntimeQsExtensionApplicationAttribute

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class QsExtensionApplicationAttribute : Attribute
Public NotInheritable Class QsExtensionApplicationAttribute
    Inherits Attribute
public ref class QsExtensionApplicationAttribute sealed : public Attribute
[<SealedAttribute>]
type QsExtensionApplicationAttribute =
    class
        inherit Attribute
    end

The QsExtensionApplicationAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | QsExtensionApplicationAttribute | Initializes a new instance of the QsExtensionApplicationAttribute class
Top
Properties
 | Name | Description
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.AutoCAD.Runtime Namespace


QsExtensionApplicationAttribute Constructor

Initializes a new instance of the QsExtensionApplicationAttribute class

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsExtensionApplicationAttribute(
    Type entryPointType
)
Public Sub New (
    entryPointType As Type
)
public:
QsExtensionApplicationAttribute(
    Type^ entryPointType
)
new :
        entryPointType : Type -> QsExtensionApplicationAttribute

Parameters

entryPointType Type

[Missing <param name="entryPointType"/> documentation for "M:QsInformatica.AutoCAD.Runtime.QsExtensionApplicationAttribute.#ctor(System.Type)"]

See Also

Reference

QsExtensionApplicationAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsExtensionApplicationAttribute Properties

The QsExtensionApplicationAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

QsExtensionApplicationAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsExtensionApplicationAttribute.Type Property

QsExtensionApplicationAttributeType Property

[Missing <summary> documentation for "P:QsInformatica.AutoCAD.Runtime.QsExtensionApplicationAttribute.Type"]

Namespace: QsInformatica.AutoCAD.Runtime
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type
See Also

Reference

QsExtensionApplicationAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsExtensionApplicationAttribute Methods

The QsExtensionApplicationAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsExtensionApplicationAttribute Class
QsInformatica.AutoCAD.Runtime Namespace


QsInformatica.Utils Namespace

[Missing <summary> documentation for "N:QsInformatica.Utils"]

Classes
 | Class | Description
Public class | Arguments | Arguments class
Public class | EMail | Classe che espone alcune funzionalità per l'invio delle e-mail.
Public class | EnumExtension |
Public class | FolderBrowserDialogEx |
Public class | HelpManager |
Public class | HostProduct |
Public class | INIFile | Classe per la gestione dei file di inizializzazione.
Public class | MapiMailMessage | Represents an email message to be sent through MAPI.
Public class | ProductVersionManager |
Public class | ProductVersionManagerHotfixIniData |
Public class | PrsReader | Class PrsReader.
Public class | PrsReaderException | The PrsReader class exceptions.
Public class | QsLicMan |
Public class | QsLog | Base class to work with QS Informatica log files.
Public class | QsLogAsync | "Async" logger class evolved to use a cache. The main goal is to reduce the number of I/O operations and improve performance. Instead of writing to the file system every time a message is logged, the logger writes to a buffer. Then a timer flushes the buffer to a file at regular intervals.
Public class | QsPath |
Public class | QsProduct |
Public class | QsResources | Class QsResources. Manages the resources for the viewer menu.
Public class | Recipient | Represents a Recipient for a MapiMailMessage.
Public class | RecipientCollection | Represents a colleciton of recipients for a mail message.
Public class | RegisterUtility | Classe utilizzata per creare/leggere le chiavi nel/dal registro di sistema CURRENT USER.
Public class | TopBomIniHelper |
Public class | TopBomIniHelperAttributeQs | Oggetto Attribute
Public class | TopBomIniHelperBomQs | ''' Classe che getisce il file INI '''
Public class | TopBomIniHelperDistinta | Classe Distinta
Public class | TopBomIniHelperManagementINI |
Public class | Util |
Public class | UtilMarshalHelper |
Public class | UtilThumbnail | Classe usata per ricavare l'anteprima di un file.
Public class | XMX | Modulo per la lettura dei file xmx per la localizzazione delle stringhe.
Interfaces
 | Interface | Description
Public interface | IQsLog | Interfaccia contenente i metodi, le proprietà e le operazioni disponibili su ogni oggetto Log.
Enumerations
 | Enumeration | Description
Public enumeration | LicModeEnum | Stato della licenza.
Public enumeration | LogFileTypeEnum | Enumerazione contenente i tipi di file Log disponibili.
Public enumeration | LogMessageTypeEnum | Enumerazione dei tipi di messaggi registrabili all'interno del file di Log.
Public enumeration | MapiMailMessageRecipientType | Specifies the valid RecipientTypes for a Recipient.
Public enumeration | QsResourcesResourceType |


Arguments Class

Arguments class
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsArguments

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class Arguments
Public Class Arguments
public ref class Arguments
type Arguments = class end

The Arguments type exposes the following members.

Constructors
 | Name | Description
Public method | Arguments | Initializes a new instance of the Arguments class
Top
Properties
 | Name | Description
Public property | Item |
Public property | Parameters |
Public property | SequentialParameters |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


Arguments Constructor

Initializes a new instance of the Arguments class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Arguments(
    IEnumerable<string> args,
    bool ignorecase
)
Public Sub New (
    args As IEnumerable(Of String),
    ignorecase As Boolean
)
public:
Arguments(
    IEnumerable<String^>^ args,
    bool ignorecase
)
new :
        args : IEnumerable<string> *
        ignorecase : bool -> Arguments

Parameters

args IEnumerable String

[Missing <param name="args"/> documentation for "M:QsInformatica.Utils.Arguments.#ctor(System.Collections.Generic.IEnumerable{System.String},System.Boolean)"]

ignorecase Boolean

[Missing <param name="ignorecase"/> documentation for "M:QsInformatica.Utils.Arguments.#ctor(System.Collections.Generic.IEnumerable{System.String},System.Boolean)"]

See Also

Reference

Arguments Class


Arguments Properties

The Arguments type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Public property | Parameters |
Public property | SequentialParameters |
Top
See Also

Reference

Arguments Class


Arguments.Item Property

ArgumentsItem Property

[Missing <summary> documentation for "P:QsInformatica.Utils.Arguments.Item(System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string this[
    string param
] { get; }
Public ReadOnly Default Property Item (
    param As String
) As String
    Get
public:
property String^ default[String^ param] {
    String^ get (String^ param);
}
member Item : string with get

Parameters

param String

Property Value

String
See Also

Reference

Arguments Class


Arguments.Parameters Property

ArgumentsParameters Property

[Missing <summary> documentation for "P:QsInformatica.Utils.Arguments.Parameters"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> Parameters { get; }
Public ReadOnly Property Parameters As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ Parameters {
    Dictionary<String^, String^>^ get ();
}
member Parameters : Dictionary<string, string> with get

Property Value

Dictionary String, String
See Also

Reference

Arguments Class


Arguments.SequentialParameters Property

ArgumentsSequentialParameters Property

[Missing <summary> documentation for "P:QsInformatica.Utils.Arguments.SequentialParameters"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> SequentialParameters { get; }
Public ReadOnly Property SequentialParameters As List(Of String)
    Get
public:
property List<String^>^ SequentialParameters {
    List<String^>^ get ();
}
member SequentialParameters : List<string> with get

Property Value

List String
See Also

Reference

Arguments Class


Arguments Methods

The Arguments type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Arguments Class


EMail Class

Classe che espone alcune funzionalità per l'invio delle e-mail.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsEMail

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class EMail
Public NotInheritable Class EMail
public ref class EMail abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EMail = class end

The EMail type exposes the following members.

Methods
Name | Description
SendMessage | Mostra all'utente la finestra di dialogo per inviare un messaggio, con il programma di posta predefinito ed utilizzando l'account predefinito di posta, se ne esiste uno.
SilentSendMessage | Invia un messaggio, con il programma di posta predefinito ed utilizzando l'account predefinito di posta, se ne esiste uno. Non visualizza alcune finestra all'utente.
Top
See Also

Reference

QsInformatica.Utils Namespace


EMail Methods

The EMail type exposes the following members.

Methods
Name | Description
SendMessage | Mostra all'utente la finestra di dialogo per inviare un messaggio, con il programma di posta predefinito ed utilizzando l'account predefinito di posta, se ne esiste uno.
SilentSendMessage | Invia un messaggio, con il programma di posta predefinito ed utilizzando l'account predefinito di posta, se ne esiste uno. Non visualizza alcune finestra all'utente.
Top
See Also

Reference

EMail Class


EMail.SendMessage Method

EMailSendMessage Method

Mostra all'utente la finestra di dialogo per inviare un messaggio, con il programma di posta predefinito ed utilizzando l'account predefinito di posta, se ne esiste uno.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static bool SendMessage(
    string Subject,
    string ToMailAddress,
    string ToMailName,
    string Body,
    string AttachFile,
    string AttachName
)
Public Shared Function SendMessage (
    Subject As String,
    ToMailAddress As String,
    ToMailName As String,
    Body As String,
    AttachFile As String,
    AttachName As String
) As Boolean
public:
static bool SendMessage(
    String^ Subject,
    String^ ToMailAddress,
    String^ ToMailName,
    String^ Body,
    String^ AttachFile,
    String^ AttachName
)
static member SendMessage :
        Subject : string *
        ToMailAddress : string *
        ToMailName : string *
        Body : string *
        AttachFile : string *
        AttachName : string -> bool

Parameters

Subject String
Oggetto del messaggio (può essere null).
ToMailAddress String
Indirizzo e-mail del destinatario (può essere null).
ToMailName String
Nome visualizzato del destinatario (può essere null). Viene ignorato se ToMailAddress non è presente.
Body String
Corpo del messaggio (può essere null).
AttachFile String
Percorso e nome del file da allegare al messaggio (può essere null).
AttachName String
Nome del file che verrà utilizzato per l'allegato (può essere null). Viene ignorato se AttachFile non è presente.

Return Value

Boolean
Restituisce True se l'operazione avviene con successo.
Remarks
Per mostrare all'utente una finestra di dialogo completamente vuota, chiamare il metodo nel seguente modo: EMail.SendMessage("", "", "", "", "", "")
See Also

Reference

EMail Class


EMail.SilentSendMessage Method

EMailSilentSendMessage Method

Invia un messaggio, con il programma di posta predefinito ed utilizzando l'account predefinito di posta, se ne esiste uno. Non visualizza alcune finestra all'utente.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static bool SilentSendMessage(
    string Subject,
    string ToMailAddress,
    string ToMailName,
    string Body,
    string AttachFile,
    string AttachName
)
Public Shared Function SilentSendMessage (
    Subject As String,
    ToMailAddress As String,
    ToMailName As String,
    Body As String,
    AttachFile As String,
    AttachName As String
) As Boolean
public:
static bool SilentSendMessage(
    String^ Subject,
    String^ ToMailAddress,
    String^ ToMailName,
    String^ Body,
    String^ AttachFile,
    String^ AttachName
)
static member SilentSendMessage :
        Subject : string *
        ToMailAddress : string *
        ToMailName : string *
        Body : string *
        AttachFile : string *
        AttachName : string -> bool

Parameters

Subject String
Oggetto del messaggio (può essere null).
ToMailAddress String
Indirizzo e-mail del destinatario (può essere null).
ToMailName String
Nome visualizzato del destinatario (può essere null). Viene ignorato se ToMailAddress non è presente.
Body String
Corpo del messaggio (può essere null).
AttachFile String
Percorso e nome del file da allegare al messaggio (può essere null).
AttachName String
Nome del file che verrà utilizzato per l'allegato (può essere null). Viene ignorato se AttachFile non è presente.

Return Value

Boolean
Restituisce True se l'operazione avviene con successo.
Remarks
Per mostrare all'utente una finestra di dialogo completamente vuota, chiamare il metodo nel seguente modo: EMail.SendMessage("", "", "", "", "", "")
See Also

Reference

EMail Class


EnumExtension Class

[Missing <summary> documentation for "T:QsInformatica.Utils.EnumExtension"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsEnumExtension

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class EnumExtension
<ExtensionAttribute>
Public NotInheritable Class EnumExtension
[ExtensionAttribute]
public ref class EnumExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type EnumExtension = class end

The EnumExtension type exposes the following members.

Methods
 | Name | Description
Public Extension Method | GetAttributeTAttribute | This method retrieves a specific attribute (TAttribute) associated with the given enum value. It returns the attribute instance if found, or null if the attribute is not present.
Public Extension Method | GetDescriptionTEnum | This method retrieves the description attribute value associated with the given enum value. If a description attribute is defined for the enum value, it returns the description value. Otherwise, it returns the string representation of the enum value.
 | GetEnumValueFromDescriptionTEnum | This method searches for an enum value that has a description attribute matching the provided descriptionValue. It iterates through all values of the specified enum type and compares their descriptions. If a match is found, it returns the corresponding enum value. If no matching value is found, it throws an ArgumentException indicating that no enum value matches the given description attribute value.
Top
See Also

Reference

QsInformatica.Utils Namespace


EnumExtension Methods

The EnumExtension type exposes the following members.

Methods
 | Name | Description
Public Extension Method | GetAttributeTAttribute | This method retrieves a specific attribute (TAttribute) associated with the given enum value. It returns the attribute instance if found, or null if the attribute is not present.
Public Extension Method | GetDescriptionTEnum | This method retrieves the description attribute value associated with the given enum value. If a description attribute is defined for the enum value, it returns the description value. Otherwise, it returns the string representation of the enum value.
 | GetEnumValueFromDescriptionTEnum | This method searches for an enum value that has a description attribute matching the provided descriptionValue. It iterates through all values of the specified enum type and compares their descriptions. If a match is found, it returns the corresponding enum value. If no matching value is found, it throws an ArgumentException indicating that no enum value matches the given description attribute value.
Top
See Also

Reference

EnumExtension Class


EnumExtension.GetAttribute<TAttribute> Method

EnumExtensionGetAttributeTAttribute Method

This method retrieves a specific attribute (TAttribute) associated with the given enum value. It returns the attribute instance if found, or null if the attribute is not present.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static TAttribute GetAttribute<TAttribute>(
    this Enum value
)
where TAttribute : Attribute

<ExtensionAttribute>
Public Shared Function GetAttribute(Of TAttribute As Attribute) (
    value As Enum
) As TAttribute
public:
[ExtensionAttribute]
generic<typename TAttribute>
where TAttribute : Attribute
static TAttribute GetAttribute(
    Enum^ value
)
[<ExtensionAttribute>]
static member GetAttribute :
        value : Enum -> 'TAttribute  when 'TAttribute : Attribute

Parameters

value Enum

[Missing <param name="value"/> documentation for "M:QsInformatica.Utils.EnumExtension.GetAttribute``1(System.Enum)"]

Type Parameters

TAttribute

[Missing <typeparam name="TAttribute"/> documentation for "M:QsInformatica.Utils.EnumExtension.GetAttribute``1(System.Enum)"]

Return Value

TAttribute

[Missing <returns> documentation for "M:QsInformatica.Utils.EnumExtension.GetAttribute``1(System.Enum)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Enum. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtension Class


EnumExtension.GetDescription<TEnum> Method

EnumExtensionGetDescriptionTEnum Method

This method retrieves the description attribute value associated with the given enum value. If a description attribute is defined for the enum value, it returns the description value. Otherwise, it returns the string representation of the enum value.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription<TEnum>(
    this TEnum value
)

<ExtensionAttribute>
Public Shared Function GetDescription(Of TEnum) (
    value As TEnum
) As String
public:
[ExtensionAttribute]
generic<typename TEnum>
static String^ GetDescription(
    TEnum value
)
[<ExtensionAttribute>]
static member GetDescription :
        value : 'TEnum -> string

Parameters

value TEnum

[Missing <param name="value"/> documentation for "M:QsInformatica.Utils.EnumExtension.GetDescription``1(``0)"]

Type Parameters

TEnum

[Missing <typeparam name="TEnum"/> documentation for "M:QsInformatica.Utils.EnumExtension.GetDescription``1(``0)"]

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.EnumExtension.GetDescription``1(``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type TEnum. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtension Class


EnumExtension.GetEnumValueFromDescription<TEnum> Method

EnumExtensionGetEnumValueFromDescriptionTEnum Method

This method searches for an enum value that has a description attribute matching the provided descriptionValue. It iterates through all values of the specified enum type and compares their descriptions. If a match is found, it returns the corresponding enum value. If no matching value is found, it throws an ArgumentException indicating that no enum value matches the given description attribute value.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static TEnum GetEnumValueFromDescription<TEnum>(
    string descriptionValue
)

Public Shared Function GetEnumValueFromDescription(Of TEnum) (
    descriptionValue As String
) As TEnum
public:
generic<typename TEnum>
static TEnum GetEnumValueFromDescription(
    String^ descriptionValue
)
static member GetEnumValueFromDescription :
        descriptionValue : string -> 'TEnum

Parameters

descriptionValue String

[Missing <param name="descriptionValue"/> documentation for "M:QsInformatica.Utils.EnumExtension.GetEnumValueFromDescription``1(System.String)"]

Type Parameters

TEnum

[Missing <typeparam name="TEnum"/> documentation for "M:QsInformatica.Utils.EnumExtension.GetEnumValueFromDescription``1(System.String)"]

Return Value

TEnum

[Missing <returns> documentation for "M:QsInformatica.Utils.EnumExtension.GetEnumValueFromDescription``1(System.String)"]

Exceptions
Exception | Condition
ArgumentException |
See Also

Reference

EnumExtension Class


FolderBrowserDialogEx Class

[Missing <summary> documentation for "T:QsInformatica.Utils.FolderBrowserDialogEx"]

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsCommonDialog
QsInformatica.UtilsFolderBrowserDialogEx

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class FolderBrowserDialogEx : CommonDialog
Public Class FolderBrowserDialogEx
    Inherits CommonDialog
public ref class FolderBrowserDialogEx : public CommonDialog
type FolderBrowserDialogEx =
    class
        inherit CommonDialog
    end

The FolderBrowserDialogEx type exposes the following members.

Constructors
 | Name | Description
Public method | FolderBrowserDialogEx | Initializes a new instance of the FolderBrowserDialogEx class
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | Description | This description appears near the top of the dialog box, providing direction to the user.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component)
Public property | DontIncludeNetworkFoldersBelowDomainLevel |
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component)
Public property | NewStyle | Set whether to use the New Folder Browser dialog style.
Public property | RootFolder |
Public property | SelectedPath | Set or get the selected path.
Public property | ShowBothFilesAndFolders |
Public property | ShowEditBox | Show an "edit box" in the folder browser.
Public property | ShowFullPathInEditBox | Show the full path in the edit box as the user selects it.
Public property | ShowNewFolderButton | Enable or disable the "New Folder" button in the browser dialog.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component)
Public property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Top
Methods
 | Name | Description
 | ComputerBrowser |
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Obsolete. Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | HookProc | Defines the common dialog box hook procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog)
Public method | InitializeLifetimeService | Obsolete. Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject)
Protected method | OnHelpRequest | Raises the HelpRequest event. (Inherited from CommonDialog)
Protected method | OwnerWndProc | Defines the owner window procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog)
 | PrinterBrowser |
Public method | Reset | (Overrides CommonDialogReset)
Protected method | RunDialog | (Overrides CommonDialogRunDialog(IntPtr))
Public method | ShowDialog | Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public method | ShowDialog(IWin32Window) | Runs a common dialog box with the specified owner. (Inherited from CommonDialog)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | HelpRequest |
Top
See Also

Reference

QsInformatica.Utils Namespace


FolderBrowserDialogEx Constructor

Initializes a new instance of the FolderBrowserDialogEx class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public FolderBrowserDialogEx()
Public Sub New
public:
FolderBrowserDialogEx()
new : unit -> FolderBrowserDialogEx
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx Properties

The FolderBrowserDialogEx type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | Description | This description appears near the top of the dialog box, providing direction to the user.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component)
Public property | DontIncludeNetworkFoldersBelowDomainLevel |
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component)
Public property | NewStyle | Set whether to use the New Folder Browser dialog style.
Public property | RootFolder |
Public property | SelectedPath | Set or get the selected path.
Public property | ShowBothFilesAndFolders |
Public property | ShowEditBox | Show an "edit box" in the folder browser.
Public property | ShowFullPathInEditBox | Show the full path in the edit box as the user selects it.
Public property | ShowNewFolderButton | Enable or disable the "New Folder" button in the browser dialog.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component)
Public property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Top
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.Description Property

FolderBrowserDialogExDescription Property

This description appears near the top of the dialog box, providing direction to the user.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.DontIncludeNetworkFoldersBelowDomainLevel Property

FolderBrowserDialogExDontIncludeNetworkFoldersBelowDomainLevel Property

[Missing <summary> documentation for "P:QsInformatica.Utils.FolderBrowserDialogEx.DontIncludeNetworkFoldersBelowDomainLevel"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool DontIncludeNetworkFoldersBelowDomainLevel { get; set; }
Public Property DontIncludeNetworkFoldersBelowDomainLevel As Boolean
    Get
    Set
public:
property bool DontIncludeNetworkFoldersBelowDomainLevel {
    bool get ();
    void set (bool value);
}
member DontIncludeNetworkFoldersBelowDomainLevel : bool with get, set

Property Value

Boolean
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.NewStyle Property

FolderBrowserDialogExNewStyle Property

Set whether to use the New Folder Browser dialog style.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool NewStyle { get; set; }
Public Property NewStyle As Boolean
    Get
    Set
public:
property bool NewStyle {
    bool get ();
    void set (bool value);
}
member NewStyle : bool with get, set

Property Value

Boolean
Remarks
The new style is resizable and includes a "New Folder" button.
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.RootFolder Property

FolderBrowserDialogExRootFolder Property

[Missing <summary> documentation for "P:QsInformatica.Utils.FolderBrowserDialogEx.RootFolder"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public EnvironmentSpecialFolder RootFolder { get; set; }
Public Property RootFolder As EnvironmentSpecialFolder
    Get
    Set
public:
property EnvironmentSpecialFolder RootFolder {
    EnvironmentSpecialFolder get ();
    void set (EnvironmentSpecialFolder value);
}
member RootFolder : EnvironmentSpecialFolder with get, set

Property Value

EnvironmentSpecialFolder
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.SelectedPath Property

FolderBrowserDialogExSelectedPath Property

Set or get the selected path.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string SelectedPath { get; set; }
Public Property SelectedPath As String
    Get
    Set
public:
property String^ SelectedPath {
    String^ get ();
    void set (String^ value);
}
member SelectedPath : string with get, set

Property Value

String
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.ShowBothFilesAndFolders Property

FolderBrowserDialogExShowBothFilesAndFolders Property

[Missing <summary> documentation for "P:QsInformatica.Utils.FolderBrowserDialogEx.ShowBothFilesAndFolders"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowBothFilesAndFolders { get; set; }
Public Property ShowBothFilesAndFolders As Boolean
    Get
    Set
public:
property bool ShowBothFilesAndFolders {
    bool get ();
    void set (bool value);
}
member ShowBothFilesAndFolders : bool with get, set

Property Value

Boolean
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.ShowEditBox Property

FolderBrowserDialogExShowEditBox Property

Show an "edit box" in the folder browser.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowEditBox { get; set; }
Public Property ShowEditBox As Boolean
    Get
    Set
public:
property bool ShowEditBox {
    bool get ();
    void set (bool value);
}
member ShowEditBox : bool with get, set

Property Value

Boolean
Remarks
The "edit box" normally shows the name of the selected folder. The user may also type a pathname directly into the edit box.
See Also

Reference

FolderBrowserDialogEx Class
QsInformatica.Utils Namespace
ShowFullPathInEditBox


FolderBrowserDialogEx.ShowFullPathInEditBox Property

FolderBrowserDialogExShowFullPathInEditBox Property

Show the full path in the edit box as the user selects it.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowFullPathInEditBox { get; set; }
Public Property ShowFullPathInEditBox As Boolean
    Get
    Set
public:
property bool ShowFullPathInEditBox {
    bool get ();
    void set (bool value);
}
member ShowFullPathInEditBox : bool with get, set

Property Value

Boolean
Remarks
This works only if ShowEditBox is also set to true.
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.ShowNewFolderButton Property

FolderBrowserDialogExShowNewFolderButton Property

Enable or disable the "New Folder" button in the browser dialog.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowNewFolderButton { get; set; }
Public Property ShowNewFolderButton As Boolean
    Get
    Set
public:
property bool ShowNewFolderButton {
    bool get ();
    void set (bool value);
}
member ShowNewFolderButton : bool with get, set

Property Value

Boolean
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx Methods

The FolderBrowserDialogEx type exposes the following members.

Methods
 | Name | Description
 | ComputerBrowser |
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Obsolete. Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | HookProc | Defines the common dialog box hook procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog)
Public method | InitializeLifetimeService | Obsolete. Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject)
Protected method | OnHelpRequest | Raises the HelpRequest event. (Inherited from CommonDialog)
Protected method | OwnerWndProc | Defines the owner window procedure that is overridden to add specific functionality to a common dialog box. (Inherited from CommonDialog)
 | PrinterBrowser |
Public method | Reset | (Overrides CommonDialogReset)
Protected method | RunDialog | (Overrides CommonDialogRunDialog(IntPtr))
Public method | ShowDialog | Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public method | ShowDialog(IWin32Window) | Runs a common dialog box with the specified owner. (Inherited from CommonDialog)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component)
Top
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.ComputerBrowser Method

FolderBrowserDialogExComputerBrowser Method

[Missing <summary> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.ComputerBrowser"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static FolderBrowserDialogEx ComputerBrowser()
Public Shared Function ComputerBrowser As FolderBrowserDialogEx
public:
static FolderBrowserDialogEx^ ComputerBrowser()
static member ComputerBrowser : unit -> FolderBrowserDialogEx

Return Value

FolderBrowserDialogEx

[Missing <returns> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.ComputerBrowser"]

See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.PrinterBrowser Method

FolderBrowserDialogExPrinterBrowser Method

[Missing <summary> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.PrinterBrowser"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static FolderBrowserDialogEx PrinterBrowser()
Public Shared Function PrinterBrowser As FolderBrowserDialogEx
public:
static FolderBrowserDialogEx^ PrinterBrowser()
static member PrinterBrowser : unit -> FolderBrowserDialogEx

Return Value

FolderBrowserDialogEx

[Missing <returns> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.PrinterBrowser"]

See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.Reset Method

FolderBrowserDialogExReset Method

[Missing <summary> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.Reset"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.RunDialog Method

FolderBrowserDialogExRunDialog Method

[Missing <summary> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.RunDialog(System.IntPtr)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
protected override bool RunDialog(
    IntPtr hWndOwner
)
Protected Overrides Function RunDialog (
    hWndOwner As IntPtr
) As Boolean
protected:
virtual bool RunDialog(
    IntPtr hWndOwner
) override
abstract RunDialog :
        hWndOwner : IntPtr -> bool
override RunDialog :
        hWndOwner : IntPtr -> bool

Parameters

hWndOwner IntPtr

[Missing <param name="hWndOwner"/> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.RunDialog(System.IntPtr)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.FolderBrowserDialogEx.RunDialog(System.IntPtr)"]

See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx Events

The FolderBrowserDialogEx type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | HelpRequest |
Top
See Also

Reference

FolderBrowserDialogEx Class


FolderBrowserDialogEx.HelpRequest Event

FolderBrowserDialogExHelpRequest Event

[Missing <summary> documentation for "E:QsInformatica.Utils.FolderBrowserDialogEx.HelpRequest"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public event EventHandler HelpRequest
Public Event HelpRequest As EventHandler
public:
 event EventHandler^ HelpRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member HelpRequest : IEvent<EventHandler,
    EventArgs>

Value

EventHandler
See Also

Reference

FolderBrowserDialogEx Class


HelpManager Class

[Missing <summary> documentation for "T:QsInformatica.Utils.HelpManager"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsHelpManager

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class HelpManager
Public NotInheritable Class HelpManager
public ref class HelpManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HelpManager = class end

The HelpManager type exposes the following members.

Methods
Name | Description
GetRadixUrlHelp | Ritorna la radice dell'indirizzo web riguardante i manuali dei vari applicativi QS.
Top
See Also

Reference

QsInformatica.Utils Namespace


HelpManager Methods

The HelpManager type exposes the following members.

Methods
Name | Description
GetRadixUrlHelp | Ritorna la radice dell'indirizzo web riguardante i manuali dei vari applicativi QS.
Top
See Also

Reference

HelpManager Class


HelpManager.GetRadixUrlHelp Method

HelpManagerGetRadixUrlHelp Method

Ritorna la radice dell'indirizzo web riguardante i manuali dei vari applicativi QS.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetRadixUrlHelp()
Public Shared Function GetRadixUrlHelp As String
public:
static String^ GetRadixUrlHelp()
static member GetRadixUrlHelp : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.HelpManager.GetRadixUrlHelp"]

See Also

Reference

HelpManager Class


HostProduct Class

[Missing <summary> documentation for "T:QsInformatica.Utils.HostProduct"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsHostProduct

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class HostProduct
Public Class HostProduct
public ref class HostProduct
type HostProduct = class end

The HostProduct type exposes the following members.

Constructors
 | Name | Description
Public method | HostProduct | Initializes a new instance of the HostProduct class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Ver |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


HostProduct Constructor

Initializes a new instance of the HostProduct class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public HostProduct()
Public Sub New
public:
HostProduct()
new : unit -> HostProduct
See Also

Reference

HostProduct Class


HostProduct Properties

The HostProduct type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Ver |
Top
See Also

Reference

HostProduct Class


HostProduct.Name Property

HostProductName Property

[Missing <summary> documentation for "P:QsInformatica.Utils.HostProduct.Name"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

HostProduct Class


HostProduct.Ver Property

HostProductVer Property

[Missing <summary> documentation for "P:QsInformatica.Utils.HostProduct.Ver"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Ver { get; set; }
Public Property Ver As String
    Get
    Set
public:
property String^ Ver {
    String^ get ();
    void set (String^ value);
}
member Ver : string with get, set

Property Value

String
See Also

Reference

HostProduct Class


HostProduct Methods

The HostProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HostProduct Class


INIFile Class

Classe per la gestione dei file di inizializzazione.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsINIFile

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class INIFile
Public Class INIFile
public ref class INIFile
type INIFile = class end

The INIFile type exposes the following members.

Constructors
 | Name | Description
Public method | INIFile | Costruttore senza parametri.
Public method | INIFile(String) | Costruttore con argomento per inizializzare il nome file.
Top
Properties
 | Name | Description
Public property | Dirty | Indica se la struttura è stata modificata e quindi necessita di essere scritta su file.
Public property | FileName | Imposta o restituisce il nome del file contenente le impostazioni.
Public property | Loaded | Indica se il file di impostazione è stato letto e caricato in memoria correttamente.
Public property | Sections | Restituisce una collezione di sola lettura contenente tutte le Sezioni presenti nel file.
Top
Methods
 | Name | Description
Public method | DeleteKey | Elimina la chiave da una specifica sezione. Se la chiave o la sezione non esiste non viene sollevata alcuna eccezione.
Public method | DeleteSection | Elimina l'intera sezione con tutte le chiavi contenute. Se la sezione non esiste non viene sollevata alcuna eccezione.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawLines | Gets the raw lines (skip comments)
Public method | GetSectionKeys | Restituisce la collezione delle chiavi presenti attualmente in una sezione.
Public method | GetSectionRawLines | Gets the section lines. The raw text of the section. Skip comments.
Public method | GetString | Restituisce il valore presente nella sezione ed alla chiave specificata. Se una delle due non esiste viene restituito il valore di default.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Read | Carica in memoria la struttura dati contenuta nel file di impostazione.
Public method | Read(String) | Carica in memoria la struttura dati contenuta nel file di impostazioni passato come argomento.
Public method | SetString | Imposta il valore nella sezione ed alla chiave specificata.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TryWrite | Scrive su file le impostazioni presenti in memoria senza lanciare eccezioni ma restituendo se è riuscito o meno.
Public method | Write | Scrive su file le impostazioni presenti in memoria.
Top
See Also

Reference

QsInformatica.Utils Namespace


INIFile Constructor

Overload List
 | Name | Description
Public method | INIFile | Costruttore senza parametri.
Public method | INIFile(String) | Costruttore con argomento per inizializzare il nome file.
Top
See Also

Reference

INIFile Class


INIFile Constructor

Costruttore senza parametri.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public INIFile()
Public Sub New
public:
INIFile()
new : unit -> INIFile
Remarks
Utilizzando questo costruttore sarà necessario impostare il nome file da utilizzare attraverso la proprietà FileName oppure chiamando il metodo di caricamento Read(String FileName) che riceve il nome del file da utilizzare.
See Also

Reference

INIFile Class
INIFile Overload


INIFile(String) Constructor

Costruttore con argomento per inizializzare il nome file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public INIFile(
    string FileName
)
Public Sub New (
    FileName As String
)
public:
INIFile(
    String^ FileName
)
new :
        FileName : string -> INIFile

Parameters

FileName String
Nome completo di percorso da utilizzare come file .ini
Remarks
Il file di imipostazione non viene letto. Sarà caricato in memoria chiamando l'apposito metodo Read().
See Also

Reference

INIFile Class
INIFile Overload


INIFile Properties

The INIFile type exposes the following members.

Properties
 | Name | Description
Public property | Dirty | Indica se la struttura è stata modificata e quindi necessita di essere scritta su file.
Public property | FileName | Imposta o restituisce il nome del file contenente le impostazioni.
Public property | Loaded | Indica se il file di impostazione è stato letto e caricato in memoria correttamente.
Public property | Sections | Restituisce una collezione di sola lettura contenente tutte le Sezioni presenti nel file.
Top
See Also

Reference

INIFile Class


INIFile.Dirty Property

INIFileDirty Property

Indica se la struttura è stata modificata e quindi necessita di essere scritta su file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Property Value

Boolean
See Also

Reference

INIFile Class


INIFile.FileName Property

INIFileFileName Property

Imposta o restituisce il nome del file contenente le impostazioni.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

String
See Also

Reference

INIFile Class


INIFile.Loaded Property

INIFileLoaded Property

Indica se il file di impostazione è stato letto e caricato in memoria correttamente.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Loaded { get; }
Public ReadOnly Property Loaded As Boolean
    Get
public:
property bool Loaded {
    bool get ();
}
member Loaded : bool with get

Property Value

Boolean
See Also

Reference

INIFile Class


INIFile.Sections Property

INIFileSections Property

Restituisce una collezione di sola lettura contenente tutte le Sezioni presenti nel file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> Sections { get; }
Public ReadOnly Property Sections As IList(Of String)
    Get
public:
property IList<String^>^ Sections {
    IList<String^>^ get ();
}
member Sections : IList<string> with get

Property Value

IList String
See Also

Reference

INIFile Class


INIFile Methods

The INIFile type exposes the following members.

Methods
 | Name | Description
Public method | DeleteKey | Elimina la chiave da una specifica sezione. Se la chiave o la sezione non esiste non viene sollevata alcuna eccezione.
Public method | DeleteSection | Elimina l'intera sezione con tutte le chiavi contenute. Se la sezione non esiste non viene sollevata alcuna eccezione.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawLines | Gets the raw lines (skip comments)
Public method | GetSectionKeys | Restituisce la collezione delle chiavi presenti attualmente in una sezione.
Public method | GetSectionRawLines | Gets the section lines. The raw text of the section. Skip comments.
Public method | GetString | Restituisce il valore presente nella sezione ed alla chiave specificata. Se una delle due non esiste viene restituito il valore di default.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Read | Carica in memoria la struttura dati contenuta nel file di impostazione.
Public method | Read(String) | Carica in memoria la struttura dati contenuta nel file di impostazioni passato come argomento.
Public method | SetString | Imposta il valore nella sezione ed alla chiave specificata.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TryWrite | Scrive su file le impostazioni presenti in memoria senza lanciare eccezioni ma restituendo se è riuscito o meno.
Public method | Write | Scrive su file le impostazioni presenti in memoria.
Top
See Also

Reference

INIFile Class


INIFile.DeleteKey Method

INIFileDeleteKey Method

Elimina la chiave da una specifica sezione. Se la chiave o la sezione non esiste non viene sollevata alcuna eccezione.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void DeleteKey(
    string Section,
    string Key
)
Public Sub DeleteKey (
    Section As String,
    Key As String
)
public:
void DeleteKey(
    String^ Section,
    String^ Key
)
member DeleteKey :
        Section : string *
        Key : string -> unit

Parameters

Section String
Nome della sezione dalla quale eliminare la chiave specificata.
Key String
Nome della chiave da eliminare.
See Also

Reference

INIFile Class


INIFile.DeleteSection Method

INIFileDeleteSection Method

Elimina l'intera sezione con tutte le chiavi contenute. Se la sezione non esiste non viene sollevata alcuna eccezione.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void DeleteSection(
    string Section
)
Public Sub DeleteSection (
    Section As String
)
public:
void DeleteSection(
    String^ Section
)
member DeleteSection :
        Section : string -> unit

Parameters

Section String
Nome della sezione da eliminare.
See Also

Reference

INIFile Class


INIFile.GetRawLines Method

INIFileGetRawLines Method

Gets the raw lines (skip comments)

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetRawLines()
Public Function GetRawLines As IList(Of String)
public:
IList<String^>^ GetRawLines()
member GetRawLines : unit -> IList<string>

Return Value

IList String
IList<System.String>.
See Also

Reference

INIFile Class


INIFile.GetSectionKeys Method

INIFileGetSectionKeys Method

Restituisce la collezione delle chiavi presenti attualmente in una sezione.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetSectionKeys(
    string Section
)
Public Function GetSectionKeys (
    Section As String
) As IList(Of String)
public:
IList<String^>^ GetSectionKeys(
    String^ Section
)
member GetSectionKeys :
        Section : string -> IList<string>

Parameters

Section String
Nome della sezione della quale enumerare le chiavi.

Return Value

IList String
Restituisce una collezione in sola lettura delle chiavi presenti attualmente sotto una data sezione.
Exceptions
Exception | Condition
ArgumentNullException | La Section è null o stringa vuota"".
See Also

Reference

INIFile Class


INIFile.GetSectionRawLines Method

INIFileGetSectionRawLines Method

Gets the section lines. The raw text of the section. Skip comments.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetSectionRawLines(
    string section
)
Public Function GetSectionRawLines (
    section As String
) As IList(Of String)
public:
IList<String^>^ GetSectionRawLines(
    String^ section
)
member GetSectionRawLines :
        section : string -> IList<string>

Parameters

section String
The section.

Return Value

IList String
IList<System.String>.
Exceptions
Exception | Condition
ArgumentNullException | Section
See Also

Reference

INIFile Class


INIFile.GetString Method

INIFileGetString Method

Restituisce il valore presente nella sezione ed alla chiave specificata. Se una delle due non esiste viene restituito il valore di default.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string GetString(
    string Section,
    string Key,
    string DefaultValue
)
Public Function GetString (
    Section As String,
    Key As String,
    DefaultValue As String
) As String
public:
String^ GetString(
    String^ Section,
    String^ Key,
    String^ DefaultValue
)
member GetString :
        Section : string *
        Key : string *
        DefaultValue : string -> string

Parameters

Section String
Sezione nella quale leggere l'impostazione.
Key String
Chiave nella quale leggere l'impostazione.
DefaultValue String
Valore di default restituito nel caso in cui la sezione o la chiave non esistessero.

Return Value

String
Restituisce il valore letto dal file di inizializzazione oppure il valore di default passato come argomento.
Exceptions
Exception | Condition
ArgumentNullException | La Section o la Key sono null o stringa vuota"".
See Also

Reference

INIFile Class


INIFile.Read Method

INIFileRead Method

Overload List
 | Name | Description
Public method | Read | Carica in memoria la struttura dati contenuta nel file di impostazione.
Public method | Read(String) | Carica in memoria la struttura dati contenuta nel file di impostazioni passato come argomento.
Top
See Also

Reference

INIFile Class


INIFile.Read Method

INIFileRead Method

Carica in memoria la struttura dati contenuta nel file di impostazione.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Read()
Public Function Read As Boolean
public:
bool Read()
member Read : unit -> bool

Return Value

Boolean
Restituisce True se l'operazione è avvenuta con successo.
Exceptions
Exception | Condition
InvalidOperationException | Uno dei metodi Read() è già stato chiamato in precedenza oppure il nome del file di impostazioni non è stato inizializzato.
FileNotFoundException | Il file di impostazione non è accessibile o non è stato trovato.
See Also

Reference

INIFile Class
Read Overload


INIFile.Read(String) Method

INIFileRead(String) Method

Carica in memoria la struttura dati contenuta nel file di impostazioni passato come argomento.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Read(
    string FileName
)
Public Function Read (
    FileName As String
) As Boolean
public:
bool Read(
    String^ FileName
)
member Read :
        FileName : string -> bool

Parameters

FileName String
File dal quale leggere le impostazioni.

Return Value

Boolean
Restituisce True se l'operazione è avvenuta con successo.
Exceptions
Exception | Condition
InvalidOperationException | Uno dei metodo Read() è già stato chiamato in precedenza oppure il nome del file di impostazioni non è stato inizializzato.
FileNotFoundException | Il file di impostazione non è accessibile o non è stato trovato.
See Also

Reference

INIFile Class
Read Overload


INIFile.SetString Method

INIFileSetString Method

Imposta il valore nella sezione ed alla chiave specificata.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void SetString(
    string Section,
    string Key,
    string Value
)
Public Sub SetString (
    Section As String,
    Key As String,
    Value As String
)
public:
void SetString(
    String^ Section,
    String^ Key,
    String^ Value
)
member SetString :
        Section : string *
        Key : string *
        Value : string -> unit

Parameters

Section String
Sezione del file di inizializzazione.
Key String
Chiave del file di inizializzazione.
Value String
Valore da inserire.
Exceptions
Exception | Condition
ArgumentNullException | Se la Section o la Key sono null o stringa vuota"" oppure l'argomento Value è null.
See Also

Reference

INIFile Class


INIFile.TryWrite Method

INIFileTryWrite Method

Scrive su file le impostazioni presenti in memoria senza lanciare eccezioni ma restituendo se è riuscito o meno.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryWrite()
Public Function TryWrite As Boolean
public:
bool TryWrite()
member TryWrite : unit -> bool

Return Value

Boolean
Restituisce true se riesce altrimenti false.
See Also

Reference

INIFile Class


INIFile.Write Method

INIFileWrite Method

Scrive su file le impostazioni presenti in memoria.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Write()
Public Sub Write
public:
void Write()
member Write : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Non è stato ancora caricato in memoria il file di inizializzazione attraverso uno dei metodi Read() oppure il nome del file di impostazioni non è stato inizializzato.
IOException | Errore nella creazione del file o nell'accesso al percorso.
See Also

Reference

INIFile Class


IQsLog Interface

Interfaccia contenente i metodi, le proprietà e le operazioni disponibili su ogni oggetto Log.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public interface IQsLog
Public Interface IQsLog
public interface class IQsLog
type IQsLog = interface end

The IQsLog type exposes the following members.

Properties
 | Name | Description
Public property | BackupModeEnabled | Attiva o disattiva il sistema di backup e cancellazione sul distruttore del logger.
Public property | DeleteOnExit | True se cancellare il log in uscita
Public property | FullLogFileName | Restituisce il nome del file di Log completo di percorso.
Public property | LogType | Restituisce il tipo di file di Log in uso.
Public property | Name | Stringa rappresentante il nome del file di Log (che coincide anche con il nome fisico del file).
Public property | PutAppDomainName | Imposta o restituisce se la registrazione dei messaggi deve anteporre il nome dell'eseguibile al quale appartiene il processo chiamante.
Public property | PutCategory | Imposta o restituisce se la registrazione dei messaggi deve anteporre la categoria di quello specifico messaggio.
Public property | PutMessageType | Imposta o restituisce se la registrazione dei messaggi deve anteporre una stringa descrivente il tipo di messaggio registrato.
Public property | PutTimeStamp | Imposta o restituisce se la registrazione dei messaggi deve anteporre la data e l'ora della registrazione.
Public property | WornigMessageText | Imposta o restituisce il testo di default visualizzato dal metodo ShowMessageWarning().
Top
Methods
 | Name | Description
Public method | Close | Chiude il file di Log e rilascia ogni risorsa. Questa operazione permette l'editazione del file da un altro processo.
Public method | Close(Boolean) | Chiude il file di Log, rilascia ogni risorsa e poi cancella il file.
Public method | GetEntriesCount | Restituisce il conteggio dei messaggi registrati di uno specifico tipo.
Public method | ShowLog | Apre direttamente il file di Log utilizzando l'applicazione predefinita di windows.
Public method | ShowLogDialog | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.
Public method | ShowLogDialog(IWin32Window) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.
Public method | ShowLogDialog(String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String, String, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowMessageWarning | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(String) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, String) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(String, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, String, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | Write(String) | Registra un messaggio nel file di Log.
Public method | Write(String, LogMessageTypeEnum) | Registra un messaggio nel file di Log.
Public method | Write(String, String) | Registra un messaggio nel file di Log.
Public method | Write(String, String, LogMessageTypeEnum) | Registra un messaggio nel file di Log.
Top
See Also

Reference

QsInformatica.Utils Namespace


IQsLog Properties

The IQsLog type exposes the following members.

Properties
 | Name | Description
Public property | BackupModeEnabled | Attiva o disattiva il sistema di backup e cancellazione sul distruttore del logger.
Public property | DeleteOnExit | True se cancellare il log in uscita
Public property | FullLogFileName | Restituisce il nome del file di Log completo di percorso.
Public property | LogType | Restituisce il tipo di file di Log in uso.
Public property | Name | Stringa rappresentante il nome del file di Log (che coincide anche con il nome fisico del file).
Public property | PutAppDomainName | Imposta o restituisce se la registrazione dei messaggi deve anteporre il nome dell'eseguibile al quale appartiene il processo chiamante.
Public property | PutCategory | Imposta o restituisce se la registrazione dei messaggi deve anteporre la categoria di quello specifico messaggio.
Public property | PutMessageType | Imposta o restituisce se la registrazione dei messaggi deve anteporre una stringa descrivente il tipo di messaggio registrato.
Public property | PutTimeStamp | Imposta o restituisce se la registrazione dei messaggi deve anteporre la data e l'ora della registrazione.
Public property | WornigMessageText | Imposta o restituisce il testo di default visualizzato dal metodo ShowMessageWarning().
Top
See Also

Reference

IQsLog Interface


IQsLog.BackupModeEnabled Property

IQsLogBackupModeEnabled Property

Attiva o disattiva il sistema di backup e cancellazione sul distruttore del logger.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool BackupModeEnabled { get; set; }
Property BackupModeEnabled As Boolean
    Get
    Set
property bool BackupModeEnabled {
    bool get ();
    void set (bool value);
}
abstract BackupModeEnabled : bool with get, set

Property Value

Boolean
See Also

Reference

IQsLog Interface


IQsLog.DeleteOnExit Property

IQsLogDeleteOnExit Property

True se cancellare il log in uscita

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool DeleteOnExit { get; set; }
Property DeleteOnExit As Boolean
    Get
    Set
property bool DeleteOnExit {
    bool get ();
    void set (bool value);
}
abstract DeleteOnExit : bool with get, set

Property Value

Boolean
See Also

Reference

IQsLog Interface


IQsLog.FullLogFileName Property

IQsLogFullLogFileName Property

Restituisce il nome del file di Log completo di percorso.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
string FullLogFileName { get; }
ReadOnly Property FullLogFileName As String
    Get
property String^ FullLogFileName {
    String^ get ();
}
abstract FullLogFileName : string with get

Property Value

String
See Also

Reference

IQsLog Interface


IQsLog.LogType Property

IQsLogLogType Property

Restituisce il tipo di file di Log in uso.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
LogFileTypeEnum LogType { get; }
ReadOnly Property LogType As LogFileTypeEnum
    Get
property LogFileTypeEnum LogType {
    LogFileTypeEnum get ();
}
abstract LogType : LogFileTypeEnum with get

Property Value

LogFileTypeEnum
See Also

Reference

IQsLog Interface


IQsLog.Name Property

IQsLogName Property

Stringa rappresentante il nome del file di Log (che coincide anche con il nome fisico del file).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

String
See Also

Reference

IQsLog Interface


IQsLog.PutAppDomainName Property

IQsLogPutAppDomainName Property

Imposta o restituisce se la registrazione dei messaggi deve anteporre il nome dell'eseguibile al quale appartiene il processo chiamante.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool PutAppDomainName { get; set; }
Property PutAppDomainName As Boolean
    Get
    Set
property bool PutAppDomainName {
    bool get ();
    void set (bool value);
}
abstract PutAppDomainName : bool with get, set

Property Value

Boolean
See Also

Reference

IQsLog Interface


IQsLog.PutCategory Property

IQsLogPutCategory Property

Imposta o restituisce se la registrazione dei messaggi deve anteporre la categoria di quello specifico messaggio.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool PutCategory { get; set; }
Property PutCategory As Boolean
    Get
    Set
property bool PutCategory {
    bool get ();
    void set (bool value);
}
abstract PutCategory : bool with get, set

Property Value

Boolean
See Also

Reference

IQsLog Interface


IQsLog.PutMessageType Property

IQsLogPutMessageType Property

Imposta o restituisce se la registrazione dei messaggi deve anteporre una stringa descrivente il tipo di messaggio registrato.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool PutMessageType { get; set; }
Property PutMessageType As Boolean
    Get
    Set
property bool PutMessageType {
    bool get ();
    void set (bool value);
}
abstract PutMessageType : bool with get, set

Property Value

Boolean
See Also

Reference

IQsLog Interface


IQsLog.PutTimeStamp Property

IQsLogPutTimeStamp Property

Imposta o restituisce se la registrazione dei messaggi deve anteporre la data e l'ora della registrazione.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool PutTimeStamp { get; set; }
Property PutTimeStamp As Boolean
    Get
    Set
property bool PutTimeStamp {
    bool get ();
    void set (bool value);
}
abstract PutTimeStamp : bool with get, set

Property Value

Boolean
See Also

Reference

IQsLog Interface


IQsLog.WornigMessageText Property

IQsLogWornigMessageText Property

Imposta o restituisce il testo di default visualizzato dal metodo ShowMessageWarning().

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
string WornigMessageText { get; set; }
Property WornigMessageText As String
    Get
    Set
property String^ WornigMessageText {
    String^ get ();
    void set (String^ value);
}
abstract WornigMessageText : string with get, set

Property Value

String
See Also

Reference

IQsLog Interface


IQsLog Methods

The IQsLog type exposes the following members.

Methods
 | Name | Description
Public method | Close | Chiude il file di Log e rilascia ogni risorsa. Questa operazione permette l'editazione del file da un altro processo.
Public method | Close(Boolean) | Chiude il file di Log, rilascia ogni risorsa e poi cancella il file.
Public method | GetEntriesCount | Restituisce il conteggio dei messaggi registrati di uno specifico tipo.
Public method | ShowLog | Apre direttamente il file di Log utilizzando l'applicazione predefinita di windows.
Public method | ShowLogDialog | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.
Public method | ShowLogDialog(IWin32Window) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.
Public method | ShowLogDialog(String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String, String, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowMessageWarning | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(String) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, String) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(String, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, String, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | Write(String) | Registra un messaggio nel file di Log.
Public method | Write(String, LogMessageTypeEnum) | Registra un messaggio nel file di Log.
Public method | Write(String, String) | Registra un messaggio nel file di Log.
Public method | Write(String, String, LogMessageTypeEnum) | Registra un messaggio nel file di Log.
Top
See Also

Reference

IQsLog Interface


IQsLog.Close Method

IQsLogClose Method

Overload List
 | Name | Description
Public method | Close | Chiude il file di Log e rilascia ogni risorsa. Questa operazione permette l'editazione del file da un altro processo.
Public method | Close(Boolean) | Chiude il file di Log, rilascia ogni risorsa e poi cancella il file.
Top
See Also

Reference

IQsLog Interface


IQsLog.Close Method

IQsLogClose Method

Chiude il file di Log e rilascia ogni risorsa. Questa operazione permette l'editazione del file da un altro processo.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool Close()
Function Close As Boolean
bool Close()
abstract Close : unit -> bool

Return Value

Boolean
Restituisce True se l'operazione riesce.
Remarks
Dopo aver chiamato questo metodo il file di log è ancora utilizzabile. La successiva chiamata ad un metodo Write() rimetterrà in apertura esclusiva il file di Log.
See Also

Reference

IQsLog Interface
Close Overload


IQsLog.Close(Boolean) Method

IQsLogClose(Boolean) Method

Chiude il file di Log, rilascia ogni risorsa e poi cancella il file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool Close(
    bool delete
)
Function Close (
    delete As Boolean
) As Boolean
bool Close(
    bool delete
)
abstract Close :
        delete : bool -> bool

Parameters

delete Boolean
Se True cancella il file dopo averlo chiuso.

Return Value

Boolean
Restituisce True se l'operazione riesce.
Remarks
Dopo aver chiamato questo metodo il file di log è ancora utilizzabile. La successiva chiamata ad un metodo Write() rimetterrà in apertura esclusiva il file di Log ricreandolo nuovamente.
See Also

Reference

IQsLog Interface
Close Overload


IQsLog.GetEntriesCount Method

IQsLogGetEntriesCount Method

Restituisce il conteggio dei messaggi registrati di uno specifico tipo.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
int GetEntriesCount(
    LogMessageTypeEnum logMessageType
)
Function GetEntriesCount (
    logMessageType As LogMessageTypeEnum
) As Integer
int GetEntriesCount(
    LogMessageTypeEnum logMessageType
)
abstract GetEntriesCount :
        logMessageType : LogMessageTypeEnum -> int

Parameters

logMessageType LogMessageTypeEnum
Elemento dell'enumerazione LogMessageTypeEnum del quale si desidera avere il numero di registrazioni.

Return Value

Int32
Il numero di messaggi che sono stati registrati con la caratteristica specificata.
See Also

Reference

IQsLog Interface


IQsLog.ShowLog Method

IQsLogShowLog Method

Apre direttamente il file di Log utilizzando l'applicazione predefinita di windows.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLog()
Sub ShowLog
void ShowLog()
abstract ShowLog : unit -> unit
See Also

Reference

IQsLog Interface


IQsLog.ShowLogDialog Method

IQsLogShowLogDialog Method

Overload List
 | Name | Description
Public method | ShowLogDialog | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.
Public method | ShowLogDialog(IWin32Window) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.
Public method | ShowLogDialog(String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Public method | ShowLogDialog(IWin32Window, String, String, String, String, String) | Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.
Top
See Also

Reference

IQsLog Interface


IQsLog.ShowLogDialog Method

IQsLogShowLogDialog Method

Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLogDialog()
Sub ShowLogDialog
void ShowLogDialog()
abstract ShowLogDialog : unit -> unit
See Also

Reference

IQsLog Interface
ShowLogDialog Overload


IQsLog.ShowLogDialog(IWin32Window) Method

IQsLogShowLogDialog(IWin32Window) Method

Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLogDialog(
    IWin32Window owner
)
Sub ShowLogDialog (
    owner As IWin32Window
)
void ShowLogDialog(
    IWin32Window^ owner
)
abstract ShowLogDialog :
        owner : IWin32Window -> unit

Parameters

owner IWin32Window
IWin32Window Finestra genitore. Può essere null (Nothing in Visual Basic).
See Also

Reference

IQsLog Interface
ShowLogDialog Overload


IQsLog.ShowLogDialog(String, String) Method

IQsLogShowLogDialog(String, String) Method

Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLogDialog(
    string mailAddress,
    string mailName
)
Sub ShowLogDialog (
    mailAddress As String,
    mailName As String
)
void ShowLogDialog(
    String^ mailAddress,
    String^ mailName
)
abstract ShowLogDialog :
        mailAddress : string *
        mailName : string -> unit

Parameters

mailAddress String
Indirizzo e-mail al quale inviare le informazioni registrate nel file di Log.
mailName String
Nome visualizzato del destinatario.
See Also

Reference

IQsLog Interface
ShowLogDialog Overload


IQsLog.ShowLogDialog(IWin32Window, String, String) Method

IQsLogShowLogDialog(IWin32Window, String, String) Method

Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLogDialog(
    IWin32Window owner,
    string mailAddress,
    string mailName
)
Sub ShowLogDialog (
    owner As IWin32Window,
    mailAddress As String,
    mailName As String
)
void ShowLogDialog(
    IWin32Window^ owner,
    String^ mailAddress,
    String^ mailName
)
abstract ShowLogDialog :
        owner : IWin32Window *
        mailAddress : string *
        mailName : string -> unit

Parameters

owner IWin32Window
IWin32Window Finestra genitore.
mailAddress String
Indirizzo e-mail al quale inviare le informazioni registrate nel file di Log.
mailName String
Nome visualizzato del destinatario.
See Also

Reference

IQsLog Interface
ShowLogDialog Overload


IQsLog.ShowLogDialog(IWin32Window, String, String, String) Method

IQsLogShowLogDialog(IWin32Window, String, String, String) Method

Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLogDialog(
    IWin32Window owner,
    string title,
    string mailAddress,
    string mailName
)
Sub ShowLogDialog (
    owner As IWin32Window,
    title As String,
    mailAddress As String,
    mailName As String
)
void ShowLogDialog(
    IWin32Window^ owner,
    String^ title,
    String^ mailAddress,
    String^ mailName
)
abstract ShowLogDialog :
        owner : IWin32Window *
        title : string *
        mailAddress : string *
        mailName : string -> unit

Parameters

owner IWin32Window
IWin32Window Finestra genitore. Può essere null (Nothing in Visual Basic).
title String
Titolo della finestra (di default "QS Informatica").
mailAddress String
Indirizzo e-mail al quale inviare le informazioni registrate nel file di Log.
mailName String
Nome visualizzato del destinatario.
See Also

Reference

IQsLog Interface
ShowLogDialog Overload


IQsLog.ShowLogDialog(IWin32Window, String, String, String, String, String) Method

IQsLogShowLogDialog(IWin32Window, String, String, String, String, String) Method

Visualizza la finestra di dialogo contenente il file Log da mostrare all'utente. Questo overload mostra anche un pulsante che consente di inviare via e-mail le informazioni registrate nel file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void ShowLogDialog(
    IWin32Window owner,
    string title,
    string mailAddress,
    string mailName,
    string subject,
    string body
)
Sub ShowLogDialog (
    owner As IWin32Window,
    title As String,
    mailAddress As String,
    mailName As String,
    subject As String,
    body As String
)
void ShowLogDialog(
    IWin32Window^ owner,
    String^ title,
    String^ mailAddress,
    String^ mailName,
    String^ subject,
    String^ body
)
abstract ShowLogDialog :
        owner : IWin32Window *
        title : string *
        mailAddress : string *
        mailName : string *
        subject : string *
        body : string -> unit

Parameters

owner IWin32Window
IWin32Window Finestra genitore.
title String
Titolo della finestra (di default "QS Informatica").
mailAddress String
Indirizzo e-mail al quale inviare le informazioni registrate nel file di Log.
mailName String
Nome visualizzato del destinatario.
subject String
Oggetto dell'e-mail.
body String
Corpo del messaggio dll'e-mail.
See Also

Reference

IQsLog Interface
ShowLogDialog Overload


IQsLog.ShowMessageWarning Method

IQsLogShowMessageWarning Method

Overload List
 | Name | Description
Public method | ShowMessageWarning | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(String) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, String) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(String, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Public method | ShowMessageWarning(IWin32Window, String, MessageBoxIcon) | Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.
Top
See Also

Reference

IQsLog Interface


IQsLog.ShowMessageWarning Method

IQsLogShowMessageWarning Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning()
Function ShowMessageWarning As Boolean
bool ShowMessageWarning()
abstract ShowMessageWarning : unit -> bool

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.ShowMessageWarning(IWin32Window) Method

IQsLogShowMessageWarning(IWin32Window) Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning(
    IWin32Window owner
)
Function ShowMessageWarning (
    owner As IWin32Window
) As Boolean
bool ShowMessageWarning(
    IWin32Window^ owner
)
abstract ShowMessageWarning :
        owner : IWin32Window -> bool

Parameters

owner IWin32Window
IWin32Window Finestra genitore. Può essere null (Nothing in Visual Basic).

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.ShowMessageWarning(String) Method

IQsLogShowMessageWarning(String) Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning(
    string title
)
Function ShowMessageWarning (
    title As String
) As Boolean
bool ShowMessageWarning(
    String^ title
)
abstract ShowMessageWarning :
        title : string -> bool

Parameters

title String
Titolo del MessageBox (di default è "QS Informatica").

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.ShowMessageWarning(IWin32Window, String) Method

IQsLogShowMessageWarning(IWin32Window, String) Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning(
    IWin32Window owner,
    string title
)
Function ShowMessageWarning (
    owner As IWin32Window,
    title As String
) As Boolean
bool ShowMessageWarning(
    IWin32Window^ owner,
    String^ title
)
abstract ShowMessageWarning :
        owner : IWin32Window *
        title : string -> bool

Parameters

owner IWin32Window
IWin32Window Finestra genitore. Può essere null (Nothing in Visual Basic).
title String
Titolo del MessageBox (di default è "QS Informatica").

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.ShowMessageWarning(IWin32Window, MessageBoxIcon) Method

IQsLogShowMessageWarning(IWin32Window, MessageBoxIcon) Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning(
    IWin32Window owner,
    MessageBoxIcon icon
)
Function ShowMessageWarning (
    owner As IWin32Window,
    icon As MessageBoxIcon
) As Boolean
bool ShowMessageWarning(
    IWin32Window^ owner,
    MessageBoxIcon icon
)
abstract ShowMessageWarning :
        owner : IWin32Window *
        icon : MessageBoxIcon -> bool

Parameters

owner IWin32Window
IWin32Window Finestra genitore. Può essere null (Nothing in Visual Basic).
icon MessageBoxIcon
Tipo di icona MessageBoxIcon da visualizzare all'utente (il default è Information).

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.ShowMessageWarning(String, MessageBoxIcon) Method

IQsLogShowMessageWarning(String, MessageBoxIcon) Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning(
    string title,
    MessageBoxIcon icon
)
Function ShowMessageWarning (
    title As String,
    icon As MessageBoxIcon
) As Boolean
bool ShowMessageWarning(
    String^ title,
    MessageBoxIcon icon
)
abstract ShowMessageWarning :
        title : string *
        icon : MessageBoxIcon -> bool

Parameters

title String
Titolo del MessageBox (di default è "QS Informatica").
icon MessageBoxIcon
Tipo di icona MessageBoxIcon da visualizzare all'utente (il default è Information).

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.ShowMessageWarning(IWin32Window, String, MessageBoxIcon) Method

IQsLogShowMessageWarning(IWin32Window, String, MessageBoxIcon) Method

Visualizza un MessageBox che avverte l'utente che sono stati registrati degli errori e gli chiede se desidera visualizzare il file di Log contenente i dettagli.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowMessageWarning(
    IWin32Window owner,
    string title,
    MessageBoxIcon icon
)
Function ShowMessageWarning (
    owner As IWin32Window,
    title As String,
    icon As MessageBoxIcon
) As Boolean
bool ShowMessageWarning(
    IWin32Window^ owner,
    String^ title,
    MessageBoxIcon icon
)
abstract ShowMessageWarning :
        owner : IWin32Window *
        title : string *
        icon : MessageBoxIcon -> bool

Parameters

owner IWin32Window
IWin32Window Finestra genitore. Può essere null (Nothing in Visual Basic).
title String
Titolo del MessageBox (di default è "QS Informatica").
icon MessageBoxIcon
Tipo di icona MessageBoxIcon da visualizzare all'utente (il default è Information).

Return Value

Boolean
Restituisce True se l'utente ha selezionato Sì, altrimenti False
Remarks
Per modificare il messaggio di default utilizzare la proprietà WornigMessageText.
See Also

Reference

IQsLog Interface
ShowMessageWarning Overload


IQsLog.Write Method

IQsLogWrite Method

Overload List
 | Name | Description
Public method | Write(String) | Registra un messaggio nel file di Log.
Public method | Write(String, LogMessageTypeEnum) | Registra un messaggio nel file di Log.
Public method | Write(String, String) | Registra un messaggio nel file di Log.
Public method | Write(String, String, LogMessageTypeEnum) | Registra un messaggio nel file di Log.
Top
See Also

Reference

IQsLog Interface


IQsLog.Write(String) Method

IQsLogWrite(String) Method

Registra un messaggio nel file di Log.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void Write(
    string message
)
Sub Write (
    message As String
)
void Write(
    String^ message
)
abstract Write :
        message : string -> unit

Parameters

message String
Messaggio da scrivere.
See Also

Reference

IQsLog Interface
Write Overload


IQsLog.Write(String, LogMessageTypeEnum) Method

IQsLogWrite(String, LogMessageTypeEnum) Method

Registra un messaggio nel file di Log.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void Write(
    string message,
    LogMessageTypeEnum logMessageType
)
Sub Write (
    message As String,
    logMessageType As LogMessageTypeEnum
)
void Write(
    String^ message,
    LogMessageTypeEnum logMessageType
)
abstract Write :
        message : string *
        logMessageType : LogMessageTypeEnum -> unit

Parameters

message String
Messaggio da scrivere.
logMessageType LogMessageTypeEnum
Elemento dell'enumerazione LogMessageTypeEnum descrivente il tipo di messaggio che si sta registrando.
See Also

Reference

IQsLog Interface
Write Overload


IQsLog.Write(String, String) Method

IQsLogWrite(String, String) Method

Registra un messaggio nel file di Log.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void Write(
    string message,
    string category
)
Sub Write (
    message As String,
    category As String
)
void Write(
    String^ message,
    String^ category
)
abstract Write :
        message : string *
        category : string -> unit

Parameters

message String
Messaggio da scrivere.
category String
Stringa posta prima del messaggio per identificare una categoria di registrazione particolare. Risulta utile nella scrittura su Log condivisi da altri processi o da altri applicativi, per meglio identificare e quindi poi riconoscere la provenienza della registrazione.
See Also

Reference

IQsLog Interface
Write Overload


IQsLog.Write(String, String, LogMessageTypeEnum) Method

IQsLogWrite(String, String, LogMessageTypeEnum) Method

Registra un messaggio nel file di Log.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
void Write(
    string message,
    string category,
    LogMessageTypeEnum logMessageType
)
Sub Write (
    message As String,
    category As String,
    logMessageType As LogMessageTypeEnum
)
void Write(
    String^ message,
    String^ category,
    LogMessageTypeEnum logMessageType
)
abstract Write :
        message : string *
        category : string *
        logMessageType : LogMessageTypeEnum -> unit

Parameters

message String
Messaggio da scrivere.
category String
Stringa posta prima del messaggio per identificare una categoria di registrazione particolare. Risulta utile nella scrittura su Log condivisi da altri processi o da altri applicativi, per meglio identificare e quindi poi riconoscere la provenienza della registrazione.
logMessageType LogMessageTypeEnum
Elemento dell'enumerazione LogMessageTypeEnum descrivente il tipo di messaggio che si sta registrando.
See Also

Reference

IQsLog Interface
Write Overload


LicModeEnum Enumeration

Stato della licenza.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public enum LicModeEnum
Public Enumeration LicModeEnum
public enum class LicModeEnum
type LicModeEnum
Members
Member name | Value | Description
licOk | 0 |
licError | 1 |
licFatal | 2 |
licDemo | 3 |
licDemoExpired | 4 |
See Also

Reference

QsInformatica.Utils Namespace


LogFileTypeEnum Enumeration

Enumerazione contenente i tipi di file Log disponibili.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum LogFileTypeEnum
<FlagsAttribute>
Public Enumeration LogFileTypeEnum
[FlagsAttribute]
public enum class LogFileTypeEnum
[<FlagsAttribute>]
type LogFileTypeEnum
Members
Member name | Value | Description
Global | 1 | File di Log globale, condiviso da tutte le applicazioni QS Informatica.
Application | 2 | File di Log comune a tutti gli add-in QS Informatica di una stessa applicazione (Autocad, Invantor).
Custom | 4 | File di Log personalizzato nel nome e nel percorso, disponibile per una specifica applicazione o add-in QS Informatica.
See Also

Reference

QsInformatica.Utils Namespace


LogMessageTypeEnum Enumeration

Enumerazione dei tipi di messaggi registrabili all'interno del file di Log.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public enum LogMessageTypeEnum
Public Enumeration LogMessageTypeEnum
public enum class LogMessageTypeEnum
type LogMessageTypeEnum
Members
Member name | Value | Description
Information | 0 | Informational message.
Warning | 1 | Warning message.
Error | 2 | Error message.
See Also

Reference

QsInformatica.Utils Namespace


MapiMailMessage Class

Represents an email message to be sent through MAPI.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsMapiMailMessage

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class MapiMailMessage
Public Class MapiMailMessage
public ref class MapiMailMessage
type MapiMailMessage = class end

The MapiMailMessage type exposes the following members.

Constructors
 | Name | Description
Public method | MapiMailMessage | Creates a blank mail message.
Public method | MapiMailMessage(String) | Creates a new mail message with the specified subject.
Public method | MapiMailMessage(String, String) | Creates a new mail message with the specified subject and body.
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body of this mail message.
Public property | DeleteFilesAfterSend | Gets or sets if delete the attachments after send mail.
Public property | Files | Gets the file list for this mail message.
Public property | Recipients | Gets the recipient list for this mail message.
Public property | Subject | Gets or sets the subject of this mail message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Show | Displays the mail message dialog synchronously.
Public method | ShowDialog | Displays the mail message dialog asynchronously.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


MapiMailMessage Constructor

Overload List
 | Name | Description
Public method | MapiMailMessage | Creates a blank mail message.
Public method | MapiMailMessage(String) | Creates a new mail message with the specified subject.
Public method | MapiMailMessage(String, String) | Creates a new mail message with the specified subject and body.
Top
See Also

Reference

MapiMailMessage Class


MapiMailMessage Constructor

Creates a blank mail message.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public MapiMailMessage()
Public Sub New
public:
MapiMailMessage()
new : unit -> MapiMailMessage
See Also

Reference

MapiMailMessage Class
MapiMailMessage Overload


MapiMailMessage(String) Constructor

Creates a new mail message with the specified subject.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public MapiMailMessage(
    string subject
)
Public Sub New (
    subject As String
)
public:
MapiMailMessage(
    String^ subject
)
new :
        subject : string -> MapiMailMessage

Parameters

subject String

[Missing <param name="subject"/> documentation for "M:QsInformatica.Utils.MapiMailMessage.#ctor(System.String)"]

See Also

Reference

MapiMailMessage Class
MapiMailMessage Overload


MapiMailMessage(String, String) Constructor

Creates a new mail message with the specified subject and body.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public MapiMailMessage(
    string subject,
    string body
)
Public Sub New (
    subject As String,
    body As String
)
public:
MapiMailMessage(
    String^ subject,
    String^ body
)
new :
        subject : string *
        body : string -> MapiMailMessage

Parameters

subject String

[Missing <param name="subject"/> documentation for "M:QsInformatica.Utils.MapiMailMessage.#ctor(System.String,System.String)"]

body String

[Missing <param name="body"/> documentation for "M:QsInformatica.Utils.MapiMailMessage.#ctor(System.String,System.String)"]

See Also

Reference

MapiMailMessage Class
MapiMailMessage Overload


MapiMailMessage Properties

The MapiMailMessage type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body of this mail message.
Public property | DeleteFilesAfterSend | Gets or sets if delete the attachments after send mail.
Public property | Files | Gets the file list for this mail message.
Public property | Recipients | Gets the recipient list for this mail message.
Public property | Subject | Gets or sets the subject of this mail message.
Top
See Also

Reference

MapiMailMessage Class


MapiMailMessage.Body Property

MapiMailMessageBody Property

Gets or sets the body of this mail message.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Body { get; set; }
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
member Body : string with get, set

Property Value

String
See Also

Reference

MapiMailMessage Class


MapiMailMessage.DeleteFilesAfterSend Property

MapiMailMessageDeleteFilesAfterSend Property

Gets or sets if delete the attachments after send mail.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool DeleteFilesAfterSend { get; set; }
Public Property DeleteFilesAfterSend As Boolean
    Get
    Set
public:
property bool DeleteFilesAfterSend {
    bool get ();
    void set (bool value);
}
member DeleteFilesAfterSend : bool with get, set

Property Value

Boolean
See Also

Reference

MapiMailMessage Class


MapiMailMessage.Files Property

MapiMailMessageFiles Property

Gets the file list for this mail message.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList Files { get; }
Public ReadOnly Property Files As ArrayList
    Get
public:
property ArrayList^ Files {
    ArrayList^ get ();
}
member Files : ArrayList with get

Property Value

ArrayList
See Also

Reference

MapiMailMessage Class


MapiMailMessage.Recipients Property

MapiMailMessageRecipients Property

Gets the recipient list for this mail message.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public RecipientCollection Recipients { get; }
Public ReadOnly Property Recipients As RecipientCollection
    Get
public:
property RecipientCollection^ Recipients {
    RecipientCollection^ get ();
}
member Recipients : RecipientCollection with get

Property Value

RecipientCollection
See Also

Reference

MapiMailMessage Class


MapiMailMessage.Subject Property

MapiMailMessageSubject Property

Gets or sets the subject of this mail message.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
member Subject : string with get, set

Property Value

String
See Also

Reference

MapiMailMessage Class


MapiMailMessage Methods

The MapiMailMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Show | Displays the mail message dialog synchronously.
Public method | ShowDialog | Displays the mail message dialog asynchronously.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MapiMailMessage Class


MapiMailMessage.Show Method

MapiMailMessageShow Method

Displays the mail message dialog synchronously.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Show()
Public Sub Show
public:
void Show()
member Show : unit -> unit
See Also

Reference

MapiMailMessage Class


MapiMailMessage.ShowDialog Method

MapiMailMessageShowDialog Method

Displays the mail message dialog asynchronously.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowDialog()
Public Sub ShowDialog
public:
void ShowDialog()
member ShowDialog : unit -> unit
See Also

Reference

MapiMailMessage Class


MapiMailMessage.RecipientType Enumeration

MapiMailMessageRecipientType Enumeration

Specifies the valid RecipientTypes for a Recipient.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public enum RecipientType
Public Enumeration RecipientType
public enum class RecipientType
type RecipientType
Members
Member name | Value | Description
To | 1 | Recipient will be in the TO list.
CC | 2 | Recipient will be in the CC list.
BCC | 3 | Recipient will be in the BCC list.
See Also

Reference

QsInformatica.Utils Namespace


ProductVersionManager Class

[Missing <summary> documentation for "T:QsInformatica.Utils.ProductVersionManager"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsProductVersionManager

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class ProductVersionManager
Public NotInheritable Class ProductVersionManager
public ref class ProductVersionManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProductVersionManager = class end

The ProductVersionManager type exposes the following members.

Methods
Name | Description
GetQsCommonFilesVersion |
GetQsProductVersion | Ritorna la versione del prodotto installato nel formato X.X.X.X Major version, major update version, minor update version, hotfix version.
WriteQsProductVersion | Aggiorna i valori della versione relativi al prodotto qsSoftwarePath e opzionalmente a quelli del prodotto ospitante hostProductPair
Top
See Also

Reference

QsInformatica.Utils Namespace


ProductVersionManager Methods

The ProductVersionManager type exposes the following members.

Methods
Name | Description
GetQsCommonFilesVersion |
GetQsProductVersion | Ritorna la versione del prodotto installato nel formato X.X.X.X Major version, major update version, minor update version, hotfix version.
WriteQsProductVersion | Aggiorna i valori della versione relativi al prodotto qsSoftwarePath e opzionalmente a quelli del prodotto ospitante hostProductPair
Top
See Also

Reference

ProductVersionManager Class


ProductVersionManager.GetQsCommonFilesVersion Method

ProductVersionManagerGetQsCommonFilesVersion Method

[Missing <summary> documentation for "M:QsInformatica.Utils.ProductVersionManager.GetQsCommonFilesVersion"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static ProductVersionManagerHotfixIniData GetQsCommonFilesVersion()
Public Shared Function GetQsCommonFilesVersion As ProductVersionManagerHotfixIniData
public:
static ProductVersionManagerHotfixIniData^ GetQsCommonFilesVersion()
static member GetQsCommonFilesVersion : unit -> ProductVersionManagerHotfixIniData

Return Value

ProductVersionManagerHotfixIniData

[Missing <returns> documentation for "M:QsInformatica.Utils.ProductVersionManager.GetQsCommonFilesVersion"]

See Also

Reference

ProductVersionManager Class


ProductVersionManager.GetQsProductVersion Method

ProductVersionManagerGetQsProductVersion Method

Ritorna la versione del prodotto installato nel formato X.X.X.X Major version, major update version, minor update version, hotfix version.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsProductVersion(
    string qsSoftwarePath
)
Public Shared Function GetQsProductVersion (
    qsSoftwarePath As String
) As String
public:
static String^ GetQsProductVersion(
    String^ qsSoftwarePath
)
static member GetQsProductVersion :
        qsSoftwarePath : string -> string

Parameters

qsSoftwarePath String
Percorso di un prodotto QS dove è presente il file Hotfix.ini

Return Value

String
La versione del prodotto nel formato indicato, null se non è presente l'hotfix.ini
See Also

Reference

ProductVersionManager Class


ProductVersionManager.WriteQsProductVersion Method

ProductVersionManagerWriteQsProductVersion Method

Aggiorna i valori della versione relativi al prodotto qsSoftwarePath e opzionalmente a quelli del prodotto ospitante hostProductPair

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void WriteQsProductVersion(
    string qsSoftwarePath,
    Tuple<string, string> hostProductPair = null
)
Public Shared Sub WriteQsProductVersion (
    qsSoftwarePath As String,
    Optional hostProductPair As Tuple(Of String, String) = Nothing
)
public:
static void WriteQsProductVersion(
    String^ qsSoftwarePath,
    Tuple<String^, String^>^ hostProductPair = nullptr
)
static member WriteQsProductVersion :
        qsSoftwarePath : string *
        ?hostProductPair : Tuple<string, string>
(* Defaults:
        let _hostProductPair = defaultArg hostProductPair null
*)
-> unit

Parameters

qsSoftwarePath String
Il percorso di installazione del prodotto QS
hostProductPair Tuple String, String (Optional)
I dati relativi al prodotto ospitante
See Also

Reference

ProductVersionManager Class


ProductVersionManager.HotfixIniData Class

ProductVersionManagerHotfixIniData Class

[Missing <summary> documentation for "T:QsInformatica.Utils.ProductVersionManager.HotfixIniData"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsProductVersionManagerHotfixIniData

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class HotfixIniData
Public Class HotfixIniData
public ref class HotfixIniData
type HotfixIniData = class end

The ProductVersionManagerHotfixIniData type exposes the following members.

Constructors
 | Name | Description
Public method | ProductVersionManagerHotfixIniData | Initializes a new instance of the ProductVersionManagerHotfixIniData class
Top
Properties
 | Name | Description
Public property | CurrentVersion |
Public property | InstalledHotfix |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

QsInformatica.Utils Namespace


ProductVersionManager.HotfixIniData Constructor

ProductVersionManagerHotfixIniData Constructor

Initializes a new instance of the ProductVersionManagerHotfixIniData class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public HotfixIniData()
Public Sub New
public:
HotfixIniData()
new : unit -> HotfixIniData
See Also

Reference

ProductVersionManagerHotfixIniData Class


HotfixIniData Properties

The ProductVersionManagerHotfixIniData type exposes the following members.

Properties
 | Name | Description
Public property | CurrentVersion |
Public property | InstalledHotfix |
Top
See Also

Reference

ProductVersionManagerHotfixIniData Class


ProductVersionManager.HotfixIniData.CurrentVersion Property

ProductVersionManagerHotfixIniDataCurrentVersion Property

[Missing <summary> documentation for "P:QsInformatica.Utils.ProductVersionManager.HotfixIniData.CurrentVersion"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string CurrentVersion { get; set; }
Public Property CurrentVersion As String
    Get
    Set
public:
property String^ CurrentVersion {
    String^ get ();
    void set (String^ value);
}
member CurrentVersion : string with get, set

Property Value

String
See Also

Reference

ProductVersionManagerHotfixIniData Class


ProductVersionManager.HotfixIniData.InstalledHotfix Property

ProductVersionManagerHotfixIniDataInstalledHotfix Property

[Missing <summary> documentation for "P:QsInformatica.Utils.ProductVersionManager.HotfixIniData.InstalledHotfix"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string InstalledHotfix { get; set; }
Public Property InstalledHotfix As String
    Get
    Set
public:
property String^ InstalledHotfix {
    String^ get ();
    void set (String^ value);
}
member InstalledHotfix : string with get, set

Property Value

String
See Also

Reference

ProductVersionManagerHotfixIniData Class


HotfixIniData Methods

The ProductVersionManagerHotfixIniData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ProductVersionManagerHotfixIniData Class


ProductVersionManager.HotfixIniData.ToString Method

ProductVersionManagerHotfixIniDataToString Method

[Missing <summary> documentation for "M:QsInformatica.Utils.ProductVersionManager.HotfixIniData.ToString"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.ProductVersionManager.HotfixIniData.ToString"]

See Also

Reference

ProductVersionManagerHotfixIniData Class


PrsReader Class

Class PrsReader.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsPrsReader

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class PrsReader
Public Class PrsReader
public ref class PrsReader
type PrsReader = class end

The PrsReader type exposes the following members.

Constructors
 | Name | Description
Public method | PrsReader(String) | Creates a new instance of the PrsReader class.
Public method | PrsReader(String, Boolean) | Creates a new instance of the PrsReader class.
Top
Properties
 | Name | Description
Public property | FilePath | The file path.
Public property | Name | The file name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSectionKeys | Gets all section entries.
Public method | GetSectionRawLines | Gets the section raw lines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadBoolean | Reads a bool from the file.
Public method | ReadDouble | Reads a double from the file.
Public method | ReadInteger | Reads a integer from the file.
Public method | ReadString | Reads a string from the file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteBoolean | Writes the bool.
Public method | WriteDouble | Writes the double.
Public method | WriteInteger | Writes the integer.
Public method | WriteString | Writes the string.
Top
See Also

Reference

QsInformatica.Utils Namespace


PrsReader Constructor

Overload List
 | Name | Description
Public method | PrsReader(String) | Creates a new instance of the PrsReader class.
Public method | PrsReader(String, Boolean) | Creates a new instance of the PrsReader class.
Top
See Also

Reference

PrsReader Class


PrsReader(String) Constructor

Creates a new instance of the PrsReader class.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public PrsReader(
    string filePath
)
Public Sub New (
    filePath As String
)
public:
PrsReader(
    String^ filePath
)
new :
        filePath : string -> PrsReader

Parameters

filePath String
The file path.
See Also

Reference

PrsReader Class
PrsReader Overload


PrsReader(String, Boolean) Constructor

Creates a new instance of the PrsReader class.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public PrsReader(
    string filePath,
    bool forceCreation
)
Public Sub New (
    filePath As String,
    forceCreation As Boolean
)
public:
PrsReader(
    String^ filePath,
    bool forceCreation
)
new :
        filePath : string *
        forceCreation : bool -> PrsReader

Parameters

filePath String
The file path.
forceCreation Boolean
If true creates the file in case it does not already exist.
See Also

Reference

PrsReader Class
PrsReader Overload


PrsReader Properties

The PrsReader type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | The file path.
Public property | Name | The file name.
Top
See Also

Reference

PrsReader Class


PrsReader.FilePath Property

PrsReaderFilePath Property

The file path.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}
member FilePath : string with get

Property Value

String
See Also

Reference

PrsReader Class


PrsReader.Name Property

PrsReaderName Property

The file name.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

PrsReader Class


PrsReader Methods

The PrsReader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSectionKeys | Gets all section entries.
Public method | GetSectionRawLines | Gets the section raw lines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadBoolean | Reads a bool from the file.
Public method | ReadDouble | Reads a double from the file.
Public method | ReadInteger | Reads a integer from the file.
Public method | ReadString | Reads a string from the file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteBoolean | Writes the bool.
Public method | WriteDouble | Writes the double.
Public method | WriteInteger | Writes the integer.
Public method | WriteString | Writes the string.
Top
See Also

Reference

PrsReader Class


PrsReader.GetSectionKeys Method

PrsReaderGetSectionKeys Method

Gets all section entries.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetSectionKeys(
    string section
)
Public Function GetSectionKeys (
    section As String
) As IList(Of String)
public:
IList<String^>^ GetSectionKeys(
    String^ section
)
member GetSectionKeys :
        section : string -> IList<string>

Parameters

section String
The section.

Return Value

IList String
An IListT of String objects containing all the section entries.
Exceptions
Exception | Condition
PrsReaderException |
See Also

Reference

PrsReader Class


PrsReader.GetSectionRawLines Method

PrsReaderGetSectionRawLines Method

Gets the section raw lines.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetSectionRawLines(
    string section
)
Public Function GetSectionRawLines (
    section As String
) As IList(Of String)
public:
IList<String^>^ GetSectionRawLines(
    String^ section
)
member GetSectionRawLines :
        section : string -> IList<string>

Parameters

section String
The section.

Return Value

IList String
An IListT of String objects containing all the section raw lines.
Exceptions
Exception | Condition
PrsReaderException |
See Also

Reference

PrsReader Class


PrsReader.ReadBoolean Method

PrsReaderReadBoolean Method

Reads a bool from the file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ReadBoolean(
    string section,
    string key,
    out bool value,
    bool defaultValue
)
Public Function ReadBoolean (
    section As String,
    key As String,
    <OutAttribute> ByRef value As Boolean,
    defaultValue As Boolean
) As Boolean
public:
bool ReadBoolean(
    String^ section,
    String^ key,
    [OutAttribute] bool% value,
    bool defaultValue
)
member ReadBoolean :
        section : string *
        key : string *
        value : bool byref *
        defaultValue : bool -> bool

Parameters

section String
The section.
key String
The key.
value Boolean
The value.
defaultValue Boolean
The default value.

Return Value

Boolean
True if successful, false otherwise.
See Also

Reference

PrsReader Class


PrsReader.ReadDouble Method

PrsReaderReadDouble Method

Reads a double from the file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ReadDouble(
    string section,
    string key,
    out double value,
    double defaultValue
)
Public Function ReadDouble (
    section As String,
    key As String,
    <OutAttribute> ByRef value As Double,
    defaultValue As Double
) As Boolean
public:
bool ReadDouble(
    String^ section,
    String^ key,
    [OutAttribute] double% value,
    double defaultValue
)
member ReadDouble :
        section : string *
        key : string *
        value : float byref *
        defaultValue : float -> bool

Parameters

section String
The section.
key String
The key.
value Double
The value.
defaultValue Double
The default value.

Return Value

Boolean
True if successful, false otherwise.
See Also

Reference

PrsReader Class


PrsReader.ReadInteger Method

PrsReaderReadInteger Method

Reads a integer from the file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ReadInteger(
    string section,
    string key,
    out int value,
    int defaultValue
)
Public Function ReadInteger (
    section As String,
    key As String,
    <OutAttribute> ByRef value As Integer,
    defaultValue As Integer
) As Boolean
public:
bool ReadInteger(
    String^ section,
    String^ key,
    [OutAttribute] int% value,
    int defaultValue
)
member ReadInteger :
        section : string *
        key : string *
        value : int byref *
        defaultValue : int -> bool

Parameters

section String
The section.
key String
The key.
value Int32
The value.
defaultValue Int32
The default value.

Return Value

Boolean
True if successful, false otherwise.
See Also

Reference

PrsReader Class


PrsReader.ReadString Method

PrsReaderReadString Method

Reads a string from the file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ReadString(
    string section,
    string key,
    out string value,
    string defaultValue,
    bool trim = true
)
Public Function ReadString (
    section As String,
    key As String,
    <OutAttribute> ByRef value As String,
    defaultValue As String,
    Optional trim As Boolean = true
) As Boolean
public:
bool ReadString(
    String^ section,
    String^ key,
    [OutAttribute] String^% value,
    String^ defaultValue,
    bool trim = true
)
member ReadString :
        section : string *
        key : string *
        value : string byref *
        defaultValue : string *
        ?trim : bool
(* Defaults:
        let _trim = defaultArg trim true
*)
-> bool

Parameters

section String
The section.
key String
The key.
value String
The value.
defaultValue String
The default value.
trim Boolean (Optional)
If true trims the string.

Return Value

Boolean
True if successful, false otherwise.
See Also

Reference

PrsReader Class


PrsReader.WriteBoolean Method

PrsReaderWriteBoolean Method

Writes the bool.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void WriteBoolean(
    string section,
    string key,
    bool val
)
Public Sub WriteBoolean (
    section As String,
    key As String,
    val As Boolean
)
public:
void WriteBoolean(
    String^ section,
    String^ key,
    bool val
)
member WriteBoolean :
        section : string *
        key : string *
        val : bool -> unit

Parameters

section String
The section.
key String
The key.
val Boolean
The value.
See Also

Reference

PrsReader Class


PrsReader.WriteDouble Method

PrsReaderWriteDouble Method

Writes the double.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void WriteDouble(
    string section,
    string key,
    double val,
    int precision = 3,
    bool forcePointSeparator = true
)
Public Sub WriteDouble (
    section As String,
    key As String,
    val As Double,
    Optional precision As Integer = 3,
    Optional forcePointSeparator As Boolean = true
)
public:
void WriteDouble(
    String^ section,
    String^ key,
    double val,
    int precision = 3,
    bool forcePointSeparator = true
)
member WriteDouble :
        section : string *
        key : string *
        val : float *
        ?precision : int *
        ?forcePointSeparator : bool
(* Defaults:
        let _precision = defaultArg precision 3
        let _forcePointSeparator = defaultArg forcePointSeparator true
*)
-> unit

Parameters

section String
The section.
key String
The key.
val Double
The value.
precision Int32 (Optional)
The precision.
forcePointSeparator Boolean (Optional)
If set to true [force point separator].
Exceptions
Exception | Condition
PrsReaderException |
See Also

Reference

PrsReader Class


PrsReader.WriteInteger Method

PrsReaderWriteInteger Method

Writes the integer.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void WriteInteger(
    string section,
    string key,
    int val
)
Public Sub WriteInteger (
    section As String,
    key As String,
    val As Integer
)
public:
void WriteInteger(
    String^ section,
    String^ key,
    int val
)
member WriteInteger :
        section : string *
        key : string *
        val : int -> unit

Parameters

section String
The section.
key String
The key.
val Int32
The value.
See Also

Reference

PrsReader Class


PrsReader.WriteString Method

PrsReaderWriteString Method

Writes the string.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void WriteString(
    string section,
    string key,
    string val
)
Public Sub WriteString (
    section As String,
    key As String,
    val As String
)
public:
void WriteString(
    String^ section,
    String^ key,
    String^ val
)
member WriteString :
        section : string *
        key : string *
        val : string -> unit

Parameters

section String
The section.
key String
The key.
val String
The value.
Exceptions
Exception | Condition
PrsReaderException |
See Also

Reference

PrsReader Class


PrsReaderException Class

The PrsReader class exceptions.
Inheritance Hierarchy
SystemObject
SystemException
QsInformatica.UtilsPrsReaderException

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class PrsReaderException : Exception
Public Class PrsReaderException
    Inherits Exception
public ref class PrsReaderException : public Exception
type PrsReaderException =
    class
        inherit Exception
    end

The PrsReaderException type exposes the following members.

Constructors
 | Name | Description
Public method | PrsReaderException(String) | Creates a new instance of the PrsReaderException class.
Public method | PrsReaderException(String, String) | Creates a new instance of the PrsReaderException class.
Protected method | PrsReaderException(SerializationInfo, StreamingContext, String) | Creates a new instance of the PrsReaderException class.
Public method | PrsReaderException(String, Exception, String) | Creates a new instance of the PrsReaderException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Obsolete. Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

QsInformatica.Utils Namespace


PrsReaderException Constructor

Overload List
 | Name | Description
Public method | PrsReaderException(String) | Creates a new instance of the PrsReaderException class.
Public method | PrsReaderException(String, String) | Creates a new instance of the PrsReaderException class.
Protected method | PrsReaderException(SerializationInfo, StreamingContext, String) | Creates a new instance of the PrsReaderException class.
Public method | PrsReaderException(String, Exception, String) | Creates a new instance of the PrsReaderException class.
Top
See Also

Reference

PrsReaderException Class


PrsReaderException(String) Constructor

Creates a new instance of the PrsReaderException class.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public PrsReaderException(
    string prsFileName
)
Public Sub New (
    prsFileName As String
)
public:
PrsReaderException(
    String^ prsFileName
)
new :
        prsFileName : string -> PrsReaderException

Parameters

prsFileName String
The file name.
See Also

Reference

PrsReaderException Class
PrsReaderException Overload


PrsReaderException(String, String) Constructor

Creates a new instance of the PrsReaderException class.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public PrsReaderException(
    string message,
    string prsFileName
)
Public Sub New (
    message As String,
    prsFileName As String
)
public:
PrsReaderException(
    String^ message,
    String^ prsFileName
)
new :
        message : string *
        prsFileName : string -> PrsReaderException

Parameters

message String
The exception message.
prsFileName String
The file name.
See Also

Reference

PrsReaderException Class
PrsReaderException Overload


PrsReaderException(SerializationInfo, StreamingContext, String) Constructor

Creates a new instance of the PrsReaderException class.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
protected PrsReaderException(
    SerializationInfo info,
    StreamingContext context,
    string prsFileName
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext,
    prsFileName As String
)
protected:
PrsReaderException(
    SerializationInfo^ info,
    StreamingContext context,
    String^ prsFileName
)
new :
        info : SerializationInfo *
        context : StreamingContext *
        prsFileName : string -> PrsReaderException

Parameters

info SerializationInfo
The infos.
context StreamingContext
The context.
prsFileName String
The file name.
See Also

Reference

PrsReaderException Class
PrsReaderException Overload


PrsReaderException(String, Exception, String) Constructor

Creates a new instance of the PrsReaderException class.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public PrsReaderException(
    string message,
    Exception innerException,
    string prsFileName
)
Public Sub New (
    message As String,
    innerException As Exception,
    prsFileName As String
)
public:
PrsReaderException(
    String^ message,
    Exception^ innerException,
    String^ prsFileName
)
new :
        message : string *
        innerException : Exception *
        prsFileName : string -> PrsReaderException

Parameters

message String
The exception message.
innerException Exception
The inner exception.
prsFileName String
The file name.
See Also

Reference

PrsReaderException Class
PrsReaderException Overload


PrsReaderException Properties

The PrsReaderException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

PrsReaderException Class


PrsReaderException Methods

The PrsReaderException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

PrsReaderException Class


PrsReaderException Events

The PrsReaderException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Obsolete. Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

PrsReaderException Class


QsLicMan Class

[Missing <summary> documentation for "T:QsInformatica.Utils.QsLicMan"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsQsLicMan

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class QsLicMan
Public NotInheritable Class QsLicMan
public ref class QsLicMan abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QsLicMan = class end

The QsLicMan type exposes the following members.

Methods
Name | Description
checkProt |
Top
See Also

Reference

QsInformatica.Utils Namespace


QsLicMan Methods

The QsLicMan type exposes the following members.

Methods
Name | Description
checkProt |
Top
See Also

Reference

QsLicMan Class


QsLicMan.checkProt Method

QsLicMancheckProt Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLicMan.checkProt(System.String,System.Boolean,System.Boolean,QsInformatica.Utils.XMX)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static LicModeEnum checkProt(
    string descApp,
    bool DemoAllowed,
    bool ShowMessages,
    XMX MsgDiz
)
Public Shared Function checkProt (
    descApp As String,
    DemoAllowed As Boolean,
    ShowMessages As Boolean,
    MsgDiz As XMX
) As LicModeEnum
public:
static LicModeEnum checkProt(
    String^ descApp,
    bool DemoAllowed,
    bool ShowMessages,
    XMX^ MsgDiz
)
static member checkProt :
        descApp : string *
        DemoAllowed : bool *
        ShowMessages : bool *
        MsgDiz : XMX -> LicModeEnum

Parameters

descApp String

[Missing <param name="descApp"/> documentation for "M:QsInformatica.Utils.QsLicMan.checkProt(System.String,System.Boolean,System.Boolean,QsInformatica.Utils.XMX)"]

DemoAllowed Boolean

[Missing <param name="DemoAllowed"/> documentation for "M:QsInformatica.Utils.QsLicMan.checkProt(System.String,System.Boolean,System.Boolean,QsInformatica.Utils.XMX)"]

ShowMessages Boolean

[Missing <param name="ShowMessages"/> documentation for "M:QsInformatica.Utils.QsLicMan.checkProt(System.String,System.Boolean,System.Boolean,QsInformatica.Utils.XMX)"]

MsgDiz XMX

[Missing <param name="MsgDiz"/> documentation for "M:QsInformatica.Utils.QsLicMan.checkProt(System.String,System.Boolean,System.Boolean,QsInformatica.Utils.XMX)"]

Return Value

LicModeEnum

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLicMan.checkProt(System.String,System.Boolean,System.Boolean,QsInformatica.Utils.XMX)"]

See Also

Reference

QsLicMan Class


QsLog Class

Base class to work with QS Informatica log files.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsQsLog

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class QsLog
Public NotInheritable Class QsLog
public ref class QsLog abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QsLog = class end

The QsLog type exposes the following members.

Methods
Name | Description
EndLogs | Restituisce l'oggetto di Log riservato e personalizzato, richiesto da una specifica applicazione o add-in.
GetApplicationLog | Restituisce l'oggetto di Log utilizzato da tutti gli add-in QS Informatica di una specifica applicazione (AutoCAD o Inventor).
GetApplicationLog2 | Restituisce l'oggetto di Log, in versione "async", utilizzato da tutti gli add-in QS Informatica di una specifica applicazione (AutoCAD o Inventor).
GetCustomLog | Restituisce l'oggetto di Log riservato e personalizzato, richiesto da una specifica applicazione o add-in.
GetCustomLog2 | Restituisce l'oggetto di Log, in versione "async", riservato e personalizzato, richiesto da una specifica applicazione o add-in.
GetGlobalLog | Restituisce l'oggetto di log comune, utilizzato da tutte le applicazioni QS Informatica.
GetGlobalLog2 | Restituisce l'oggetto di log comune, in versione "async", utilizzato da tutte le applicazioni QS Informatica.
Top
See Also

Reference

QsInformatica.Utils Namespace


QsLog Methods

The QsLog type exposes the following members.

Methods
Name | Description
EndLogs | Restituisce l'oggetto di Log riservato e personalizzato, richiesto da una specifica applicazione o add-in.
GetApplicationLog | Restituisce l'oggetto di Log utilizzato da tutti gli add-in QS Informatica di una specifica applicazione (AutoCAD o Inventor).
GetApplicationLog2 | Restituisce l'oggetto di Log, in versione "async", utilizzato da tutti gli add-in QS Informatica di una specifica applicazione (AutoCAD o Inventor).
GetCustomLog | Restituisce l'oggetto di Log riservato e personalizzato, richiesto da una specifica applicazione o add-in.
GetCustomLog2 | Restituisce l'oggetto di Log, in versione "async", riservato e personalizzato, richiesto da una specifica applicazione o add-in.
GetGlobalLog | Restituisce l'oggetto di log comune, utilizzato da tutte le applicazioni QS Informatica.
GetGlobalLog2 | Restituisce l'oggetto di log comune, in versione "async", utilizzato da tutte le applicazioni QS Informatica.
Top
See Also

Reference

QsLog Class


QsLog.EndLogs Method

QsLogEndLogs Method

Restituisce l'oggetto di Log riservato e personalizzato, richiesto da una specifica applicazione o add-in.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void EndLogs()
Public Shared Sub EndLogs
public:
static void EndLogs()
static member EndLogs : unit -> unit

Return Value

Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLog.GetApplicationLog Method

QsLogGetApplicationLog Method

Restituisce l'oggetto di Log utilizzato da tutti gli add-in QS Informatica di una specifica applicazione (AutoCAD o Inventor).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static IQsLog GetApplicationLog()
Public Shared Function GetApplicationLog As IQsLog
public:
static IQsLog^ GetApplicationLog()
static member GetApplicationLog : unit -> IQsLog

Return Value

IQsLog
Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLog.GetApplicationLog2 Method

QsLogGetApplicationLog2 Method

Restituisce l'oggetto di Log, in versione "async", utilizzato da tutti gli add-in QS Informatica di una specifica applicazione (AutoCAD o Inventor).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static IQsLog GetApplicationLog2()
Public Shared Function GetApplicationLog2 As IQsLog
public:
static IQsLog^ GetApplicationLog2()
static member GetApplicationLog2 : unit -> IQsLog

Return Value

IQsLog
Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLog.GetCustomLog Method

QsLogGetCustomLog Method

Restituisce l'oggetto di Log riservato e personalizzato, richiesto da una specifica applicazione o add-in.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static IQsLog GetCustomLog(
    string customTag,
    bool deleteIfExists
)
Public Shared Function GetCustomLog (
    customTag As String,
    deleteIfExists As Boolean
) As IQsLog
public:
static IQsLog^ GetCustomLog(
    String^ customTag,
    bool deleteIfExists
)
static member GetCustomLog :
        customTag : string *
        deleteIfExists : bool -> IQsLog

Parameters

customTag String

[Missing <param name="customTag"/> documentation for "M:QsInformatica.Utils.QsLog.GetCustomLog(System.String,System.Boolean)"]

deleteIfExists Boolean

[Missing <param name="deleteIfExists"/> documentation for "M:QsInformatica.Utils.QsLog.GetCustomLog(System.String,System.Boolean)"]

Return Value

IQsLog
Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLog.GetCustomLog2 Method

QsLogGetCustomLog2 Method

Restituisce l'oggetto di Log, in versione "async", riservato e personalizzato, richiesto da una specifica applicazione o add-in.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static IQsLog GetCustomLog2(
    string customTag,
    bool deleteIfExists
)
Public Shared Function GetCustomLog2 (
    customTag As String,
    deleteIfExists As Boolean
) As IQsLog
public:
static IQsLog^ GetCustomLog2(
    String^ customTag,
    bool deleteIfExists
)
static member GetCustomLog2 :
        customTag : string *
        deleteIfExists : bool -> IQsLog

Parameters

customTag String

[Missing <param name="customTag"/> documentation for "M:QsInformatica.Utils.QsLog.GetCustomLog2(System.String,System.Boolean)"]

deleteIfExists Boolean

[Missing <param name="deleteIfExists"/> documentation for "M:QsInformatica.Utils.QsLog.GetCustomLog2(System.String,System.Boolean)"]

Return Value

IQsLog
Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLog.GetGlobalLog Method

QsLogGetGlobalLog Method

Restituisce l'oggetto di log comune, utilizzato da tutte le applicazioni QS Informatica.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static IQsLog GetGlobalLog()
Public Shared Function GetGlobalLog As IQsLog
public:
static IQsLog^ GetGlobalLog()
static member GetGlobalLog : unit -> IQsLog

Return Value

IQsLog
Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLog.GetGlobalLog2 Method

QsLogGetGlobalLog2 Method

Restituisce l'oggetto di log comune, in versione "async", utilizzato da tutte le applicazioni QS Informatica.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static IQsLog GetGlobalLog2()
Public Shared Function GetGlobalLog2 As IQsLog
public:
static IQsLog^ GetGlobalLog2()
static member GetGlobalLog2 : unit -> IQsLog

Return Value

IQsLog
Un oggetto che implementa l'interfaccia IQsLog oppure null (Nothing in VisualBasic) se avvengono errori.
See Also

Reference

QsLog Class


QsLogAsync Class

"Async" logger class evolved to use a cache. The main goal is to reduce the number of I/O operations and improve performance. Instead of writing to the file system every time a message is logged, the logger writes to a buffer. Then a timer flushes the buffer to a file at regular intervals.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsQsLogAsync

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class QsLogAsync : IQsLog
Public NotInheritable Class QsLogAsync
    Implements IQsLog
public ref class QsLogAsync sealed : IQsLog
[<SealedAttribute>]
type QsLogAsync =
    class
        interface IQsLog
    end

The QsLogAsync type exposes the following members.

Properties
 | Name | Description
Public property | BackupModeEnabled | Delete/backup the log file on
Public property | DeleteOnExit |
Public property | FullLogFileName | Log file full path.
Public property | LogType | The log type.
Public property | Name |
Public property | PutAppDomainName |
Public property | PutCategory |
Public property | PutMessageType |
Public property | PutTimeStamp |
Public property | WornigMessageText |
Top
Methods
 | Name | Description
Public method | Close |
Public method | Close(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEntriesCount |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ShowLog |
Public method | ShowLogDialog |
Public method | ShowLogDialog(IWin32Window) |
Public method | ShowLogDialog(String, String) |
Public method | ShowLogDialog(IWin32Window, String, String) |
Public method | ShowLogDialog(String, String, String) |
Public method | ShowLogDialog(IWin32Window, String, String, String) |
Public method | ShowLogDialog(IWin32Window, String, String, String, String, String) |
Public method | ShowMessageWarning |
Public method | ShowMessageWarning(IWin32Window) |
Public method | ShowMessageWarning(String) |
Public method | ShowMessageWarning(IWin32Window, String) |
Public method | ShowMessageWarning(IWin32Window, MessageBoxIcon) |
Public method | ShowMessageWarning(String, MessageBoxIcon) |
Public method | ShowMessageWarning(IWin32Window, String, MessageBoxIcon) |
Public method | ShutDown |
Public method | Start |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Write(String) | Writes the specified message to the log file. It uses default category and log type.
Public method | Write(String, LogMessageTypeEnum) | Writes the specified message to the log file. It uses default category.
Public method | Write(String, String) | Writes the specified message to the log file. It uses default log type.
Public method | Write(String, String, LogMessageTypeEnum) | Writes the specified message to the log file.
Top
Fields
Name | Description
BatchInterval | Logging time interval (default 1 sec)
LogToConsole | Add an extra log to the Trace
Top
See Also

Reference

QsInformatica.Utils Namespace


QsLogAsync Properties

The QsLogAsync type exposes the following members.

Properties
 | Name | Description
Public property | BackupModeEnabled | Delete/backup the log file on
Public property | DeleteOnExit |
Public property | FullLogFileName | Log file full path.
Public property | LogType | The log type.
Public property | Name |
Public property | PutAppDomainName |
Public property | PutCategory |
Public property | PutMessageType |
Public property | PutTimeStamp |
Public property | WornigMessageText |
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.BackupModeEnabled Property

QsLogAsyncBackupModeEnabled Property

Delete/backup the log file on

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool BackupModeEnabled { get; set; }
Public Property BackupModeEnabled As Boolean
    Get
    Set
public:
virtual property bool BackupModeEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract BackupModeEnabled : bool with get, set
override BackupModeEnabled : bool with get, set

Property Value

Boolean

Implements

IQsLogBackupModeEnabled
See Also

Reference

QsLogAsync Class


QsLogAsync.DeleteOnExit Property

QsLogAsyncDeleteOnExit Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.DeleteOnExit"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool DeleteOnExit { get; set; }
Public Property DeleteOnExit As Boolean
    Get
    Set
public:
virtual property bool DeleteOnExit {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract DeleteOnExit : bool with get, set
override DeleteOnExit : bool with get, set

Property Value

Boolean

Implements

IQsLogDeleteOnExit
See Also

Reference

QsLogAsync Class


QsLogAsync.FullLogFileName Property

QsLogAsyncFullLogFileName Property

Log file full path.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string FullLogFileName { get; }
Public ReadOnly Property FullLogFileName As String
    Get
public:
virtual property String^ FullLogFileName {
    String^ get () sealed;
}
abstract FullLogFileName : string with get
override FullLogFileName : string with get

Property Value

String

Implements

IQsLogFullLogFileName
See Also

Reference

QsLogAsync Class


QsLogAsync.LogType Property

QsLogAsyncLogType Property

The log type.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public LogFileTypeEnum LogType { get; }
Public ReadOnly Property LogType As LogFileTypeEnum
    Get
public:
virtual property LogFileTypeEnum LogType {
    LogFileTypeEnum get () sealed;
}
abstract LogType : LogFileTypeEnum with get
override LogType : LogFileTypeEnum with get

Property Value

LogFileTypeEnum

Implements

IQsLogLogType
See Also

Reference

QsLogAsync Class


QsLogAsync.Name Property

QsLogAsyncName Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.Name"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

String

Implements

IQsLogName
See Also

Reference

QsLogAsync Class


QsLogAsync.PutAppDomainName Property

QsLogAsyncPutAppDomainName Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.PutAppDomainName"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool PutAppDomainName { get; set; }
Public Property PutAppDomainName As Boolean
    Get
    Set
public:
virtual property bool PutAppDomainName {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PutAppDomainName : bool with get, set
override PutAppDomainName : bool with get, set

Property Value

Boolean

Implements

IQsLogPutAppDomainName
See Also

Reference

QsLogAsync Class


QsLogAsync.PutCategory Property

QsLogAsyncPutCategory Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.PutCategory"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool PutCategory { get; set; }
Public Property PutCategory As Boolean
    Get
    Set
public:
virtual property bool PutCategory {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PutCategory : bool with get, set
override PutCategory : bool with get, set

Property Value

Boolean

Implements

IQsLogPutCategory
See Also

Reference

QsLogAsync Class


QsLogAsync.PutMessageType Property

QsLogAsyncPutMessageType Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.PutMessageType"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool PutMessageType { get; set; }
Public Property PutMessageType As Boolean
    Get
    Set
public:
virtual property bool PutMessageType {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PutMessageType : bool with get, set
override PutMessageType : bool with get, set

Property Value

Boolean

Implements

IQsLogPutMessageType
See Also

Reference

QsLogAsync Class


QsLogAsync.PutTimeStamp Property

QsLogAsyncPutTimeStamp Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.PutTimeStamp"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool PutTimeStamp { get; set; }
Public Property PutTimeStamp As Boolean
    Get
    Set
public:
virtual property bool PutTimeStamp {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PutTimeStamp : bool with get, set
override PutTimeStamp : bool with get, set

Property Value

Boolean

Implements

IQsLogPutTimeStamp
See Also

Reference

QsLogAsync Class


QsLogAsync.WornigMessageText Property

QsLogAsyncWornigMessageText Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsLogAsync.WornigMessageText"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string WornigMessageText { get; set; }
Public Property WornigMessageText As String
    Get
    Set
public:
virtual property String^ WornigMessageText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract WornigMessageText : string with get, set
override WornigMessageText : string with get, set

Property Value

String

Implements

IQsLogWornigMessageText
See Also

Reference

QsLogAsync Class


QsLogAsync Methods

The QsLogAsync type exposes the following members.

Methods
 | Name | Description
Public method | Close |
Public method | Close(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEntriesCount |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ShowLog |
Public method | ShowLogDialog |
Public method | ShowLogDialog(IWin32Window) |
Public method | ShowLogDialog(String, String) |
Public method | ShowLogDialog(IWin32Window, String, String) |
Public method | ShowLogDialog(String, String, String) |
Public method | ShowLogDialog(IWin32Window, String, String, String) |
Public method | ShowLogDialog(IWin32Window, String, String, String, String, String) |
Public method | ShowMessageWarning |
Public method | ShowMessageWarning(IWin32Window) |
Public method | ShowMessageWarning(String) |
Public method | ShowMessageWarning(IWin32Window, String) |
Public method | ShowMessageWarning(IWin32Window, MessageBoxIcon) |
Public method | ShowMessageWarning(String, MessageBoxIcon) |
Public method | ShowMessageWarning(IWin32Window, String, MessageBoxIcon) |
Public method | ShutDown |
Public method | Start |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Write(String) | Writes the specified message to the log file. It uses default category and log type.
Public method | Write(String, LogMessageTypeEnum) | Writes the specified message to the log file. It uses default category.
Public method | Write(String, String) | Writes the specified message to the log file. It uses default log type.
Public method | Write(String, String, LogMessageTypeEnum) | Writes the specified message to the log file.
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.Close Method

QsLogAsyncClose Method

Overload List
 | Name | Description
Public method | Close |
Public method | Close(Boolean) |
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.Close Method

QsLogAsyncClose Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.Close"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Close()
Public Function Close As Boolean
public:
virtual bool Close() sealed
abstract Close : unit -> bool
override Close : unit -> bool

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.Close"]

Implements

IQsLogClose
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

QsLogAsync Class
Close Overload


QsLogAsync.Close(Boolean) Method

QsLogAsyncClose(Boolean) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.Close(System.Boolean)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Close(
    bool delete
)
Public Function Close (
    delete As Boolean
) As Boolean
public:
virtual bool Close(
    bool delete
) sealed
abstract Close :
        delete : bool -> bool
override Close :
        delete : bool -> bool

Parameters

delete Boolean

[Missing <param name="delete"/> documentation for "M:QsInformatica.Utils.QsLogAsync.Close(System.Boolean)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.Close(System.Boolean)"]

Implements

IQsLogClose(Boolean)
See Also

Reference

QsLogAsync Class
Close Overload


QsLogAsync.GetEntriesCount Method

QsLogAsyncGetEntriesCount Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.GetEntriesCount(QsInformatica.Utils.LogMessageTypeEnum)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public int GetEntriesCount(
    LogMessageTypeEnum logMessageType
)
Public Function GetEntriesCount (
    logMessageType As LogMessageTypeEnum
) As Integer
public:
virtual int GetEntriesCount(
    LogMessageTypeEnum logMessageType
) sealed
abstract GetEntriesCount :
        logMessageType : LogMessageTypeEnum -> int
override GetEntriesCount :
        logMessageType : LogMessageTypeEnum -> int

Parameters

logMessageType LogMessageTypeEnum

[Missing <param name="logMessageType"/> documentation for "M:QsInformatica.Utils.QsLogAsync.GetEntriesCount(QsInformatica.Utils.LogMessageTypeEnum)"]

Return Value

Int32

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.GetEntriesCount(QsInformatica.Utils.LogMessageTypeEnum)"]

Implements

IQsLogGetEntriesCount(LogMessageTypeEnum)
See Also

Reference

QsLogAsync Class


QsLogAsync.ShowLog Method

QsLogAsyncShowLog Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLog"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLog()
Public Sub ShowLog
public:
virtual void ShowLog() sealed
abstract ShowLog : unit -> unit
override ShowLog : unit -> unit

Implements

IQsLogShowLog
See Also

Reference

QsLogAsync Class


QsLogAsync.ShowLogDialog Method

QsLogAsyncShowLogDialog Method

Overload List
 | Name | Description
Public method | ShowLogDialog |
Public method | ShowLogDialog(IWin32Window) |
Public method | ShowLogDialog(String, String) |
Public method | ShowLogDialog(IWin32Window, String, String) |
Public method | ShowLogDialog(String, String, String) |
Public method | ShowLogDialog(IWin32Window, String, String, String) |
Public method | ShowLogDialog(IWin32Window, String, String, String, String, String) |
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.ShowLogDialog Method

QsLogAsyncShowLogDialog Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog()
Public Sub ShowLogDialog
public:
virtual void ShowLogDialog() sealed
abstract ShowLogDialog : unit -> unit
override ShowLogDialog : unit -> unit

Implements

IQsLogShowLogDialog
See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowLogDialog(IWin32Window) Method

QsLogAsyncShowLogDialog(IWin32Window) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog(
    IWin32Window owner
)
Public Sub ShowLogDialog (
    owner As IWin32Window
)
public:
virtual void ShowLogDialog(
    IWin32Window^ owner
) sealed
abstract ShowLogDialog :
        owner : IWin32Window -> unit
override ShowLogDialog :
        owner : IWin32Window -> unit

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window)"]

Implements

IQsLogShowLogDialog(IWin32Window)
See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowLogDialog(String, String) Method

QsLogAsyncShowLogDialog(String, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog(
    string mailAddress,
    string mailName
)
Public Sub ShowLogDialog (
    mailAddress As String,
    mailName As String
)
public:
virtual void ShowLogDialog(
    String^ mailAddress,
    String^ mailName
) sealed
abstract ShowLogDialog :
        mailAddress : string *
        mailName : string -> unit
override ShowLogDialog :
        mailAddress : string *
        mailName : string -> unit

Parameters

mailAddress String

[Missing <param name="mailAddress"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String)"]

mailName String

[Missing <param name="mailName"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String)"]

Implements

IQsLogShowLogDialog(String, String)
See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowLogDialog(IWin32Window, String, String) Method

QsLogAsyncShowLogDialog(IWin32Window, String, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog(
    IWin32Window owner,
    string mailAddress,
    string mailName
)
Public Sub ShowLogDialog (
    owner As IWin32Window,
    mailAddress As String,
    mailName As String
)
public:
virtual void ShowLogDialog(
    IWin32Window^ owner,
    String^ mailAddress,
    String^ mailName
) sealed
abstract ShowLogDialog :
        owner : IWin32Window *
        mailAddress : string *
        mailName : string -> unit
override ShowLogDialog :
        owner : IWin32Window *
        mailAddress : string *
        mailName : string -> unit

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String)"]

mailAddress String

[Missing <param name="mailAddress"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String)"]

mailName String

[Missing <param name="mailName"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String)"]

Implements

IQsLogShowLogDialog(IWin32Window, String, String)
See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowLogDialog(String, String, String) Method

QsLogAsyncShowLogDialog(String, String, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog(
    string title,
    string mailAddress,
    string mailName
)
Public Sub ShowLogDialog (
    title As String,
    mailAddress As String,
    mailName As String
)
public:
void ShowLogDialog(
    String^ title,
    String^ mailAddress,
    String^ mailName
)
member ShowLogDialog :
        title : string *
        mailAddress : string *
        mailName : string -> unit

Parameters

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String,System.String)"]

mailAddress String

[Missing <param name="mailAddress"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String,System.String)"]

mailName String

[Missing <param name="mailName"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.String,System.String,System.String)"]

See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowLogDialog(IWin32Window, String, String, String) Method

QsLogAsyncShowLogDialog(IWin32Window, String, String, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog(
    IWin32Window owner,
    string title,
    string mailAddress,
    string mailName
)
Public Sub ShowLogDialog (
    owner As IWin32Window,
    title As String,
    mailAddress As String,
    mailName As String
)
public:
virtual void ShowLogDialog(
    IWin32Window^ owner,
    String^ title,
    String^ mailAddress,
    String^ mailName
) sealed
abstract ShowLogDialog :
        owner : IWin32Window *
        title : string *
        mailAddress : string *
        mailName : string -> unit
override ShowLogDialog :
        owner : IWin32Window *
        title : string *
        mailAddress : string *
        mailName : string -> unit

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String)"]

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String)"]

mailAddress String

[Missing <param name="mailAddress"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String)"]

mailName String

[Missing <param name="mailName"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String)"]

Implements

IQsLogShowLogDialog(IWin32Window, String, String, String)
See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowLogDialog(IWin32Window, String, String, String, String, String) Method

QsLogAsyncShowLogDialog(IWin32Window, String, String, String, String, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowLogDialog(
    IWin32Window owner,
    string title,
    string mailAddress,
    string mailName,
    string subject,
    string body
)
Public Sub ShowLogDialog (
    owner As IWin32Window,
    title As String,
    mailAddress As String,
    mailName As String,
    subject As String,
    body As String
)
public:
virtual void ShowLogDialog(
    IWin32Window^ owner,
    String^ title,
    String^ mailAddress,
    String^ mailName,
    String^ subject,
    String^ body
) sealed
abstract ShowLogDialog :
        owner : IWin32Window *
        title : string *
        mailAddress : string *
        mailName : string *
        subject : string *
        body : string -> unit
override ShowLogDialog :
        owner : IWin32Window *
        title : string *
        mailAddress : string *
        mailName : string *
        subject : string *
        body : string -> unit

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

mailAddress String

[Missing <param name="mailAddress"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

mailName String

[Missing <param name="mailName"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

subject String

[Missing <param name="subject"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

body String

[Missing <param name="body"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowLogDialog(System.Windows.Forms.IWin32Window,System.String,System.String,System.String,System.String,System.String)"]

Implements

IQsLogShowLogDialog(IWin32Window, String, String, String, String, String)
See Also

Reference

QsLogAsync Class
ShowLogDialog Overload


QsLogAsync.ShowMessageWarning Method

QsLogAsyncShowMessageWarning Method

Overload List
 | Name | Description
Public method | ShowMessageWarning |
Public method | ShowMessageWarning(IWin32Window) |
Public method | ShowMessageWarning(String) |
Public method | ShowMessageWarning(IWin32Window, String) |
Public method | ShowMessageWarning(IWin32Window, MessageBoxIcon) |
Public method | ShowMessageWarning(String, MessageBoxIcon) |
Public method | ShowMessageWarning(IWin32Window, String, MessageBoxIcon) |
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.ShowMessageWarning Method

QsLogAsyncShowMessageWarning Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning()
Public Function ShowMessageWarning As Boolean
public:
virtual bool ShowMessageWarning() sealed
abstract ShowMessageWarning : unit -> bool
override ShowMessageWarning : unit -> bool

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning"]

Implements

IQsLogShowMessageWarning
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShowMessageWarning(IWin32Window) Method

QsLogAsyncShowMessageWarning(IWin32Window) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning(
    IWin32Window owner
)
Public Function ShowMessageWarning (
    owner As IWin32Window
) As Boolean
public:
virtual bool ShowMessageWarning(
    IWin32Window^ owner
) sealed
abstract ShowMessageWarning :
        owner : IWin32Window -> bool
override ShowMessageWarning :
        owner : IWin32Window -> bool

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window)"]

Implements

IQsLogShowMessageWarning(IWin32Window)
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShowMessageWarning(String) Method

QsLogAsyncShowMessageWarning(String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning(
    string title
)
Public Function ShowMessageWarning (
    title As String
) As Boolean
public:
virtual bool ShowMessageWarning(
    String^ title
) sealed
abstract ShowMessageWarning :
        title : string -> bool
override ShowMessageWarning :
        title : string -> bool

Parameters

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String)"]

Implements

IQsLogShowMessageWarning(String)
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShowMessageWarning(IWin32Window, String) Method

QsLogAsyncShowMessageWarning(IWin32Window, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning(
    IWin32Window owner,
    string title
)
Public Function ShowMessageWarning (
    owner As IWin32Window,
    title As String
) As Boolean
public:
virtual bool ShowMessageWarning(
    IWin32Window^ owner,
    String^ title
) sealed
abstract ShowMessageWarning :
        owner : IWin32Window *
        title : string -> bool
override ShowMessageWarning :
        owner : IWin32Window *
        title : string -> bool

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String)"]

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String)"]

Implements

IQsLogShowMessageWarning(IWin32Window, String)
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShowMessageWarning(IWin32Window, MessageBoxIcon) Method

QsLogAsyncShowMessageWarning(IWin32Window, MessageBoxIcon) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.Windows.Forms.MessageBoxIcon)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning(
    IWin32Window owner,
    MessageBoxIcon icon
)
Public Function ShowMessageWarning (
    owner As IWin32Window,
    icon As MessageBoxIcon
) As Boolean
public:
virtual bool ShowMessageWarning(
    IWin32Window^ owner,
    MessageBoxIcon icon
) sealed
abstract ShowMessageWarning :
        owner : IWin32Window *
        icon : MessageBoxIcon -> bool
override ShowMessageWarning :
        owner : IWin32Window *
        icon : MessageBoxIcon -> bool

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.Windows.Forms.MessageBoxIcon)"]

icon MessageBoxIcon

[Missing <param name="icon"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.Windows.Forms.MessageBoxIcon)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.Windows.Forms.MessageBoxIcon)"]

Implements

IQsLogShowMessageWarning(IWin32Window, MessageBoxIcon)
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShowMessageWarning(String, MessageBoxIcon) Method

QsLogAsyncShowMessageWarning(String, MessageBoxIcon) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String,System.Windows.Forms.MessageBoxIcon)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning(
    string title,
    MessageBoxIcon icon
)
Public Function ShowMessageWarning (
    title As String,
    icon As MessageBoxIcon
) As Boolean
public:
virtual bool ShowMessageWarning(
    String^ title,
    MessageBoxIcon icon
) sealed
abstract ShowMessageWarning :
        title : string *
        icon : MessageBoxIcon -> bool
override ShowMessageWarning :
        title : string *
        icon : MessageBoxIcon -> bool

Parameters

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String,System.Windows.Forms.MessageBoxIcon)"]

icon MessageBoxIcon

[Missing <param name="icon"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String,System.Windows.Forms.MessageBoxIcon)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.String,System.Windows.Forms.MessageBoxIcon)"]

Implements

IQsLogShowMessageWarning(String, MessageBoxIcon)
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShowMessageWarning(IWin32Window, String, MessageBoxIcon) Method

QsLogAsyncShowMessageWarning(IWin32Window, String, MessageBoxIcon) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String,System.Windows.Forms.MessageBoxIcon)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageWarning(
    IWin32Window owner,
    string title,
    MessageBoxIcon icon
)
Public Function ShowMessageWarning (
    owner As IWin32Window,
    title As String,
    icon As MessageBoxIcon
) As Boolean
public:
virtual bool ShowMessageWarning(
    IWin32Window^ owner,
    String^ title,
    MessageBoxIcon icon
) sealed
abstract ShowMessageWarning :
        owner : IWin32Window *
        title : string *
        icon : MessageBoxIcon -> bool
override ShowMessageWarning :
        owner : IWin32Window *
        title : string *
        icon : MessageBoxIcon -> bool

Parameters

owner IWin32Window

[Missing <param name="owner"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String,System.Windows.Forms.MessageBoxIcon)"]

title String

[Missing <param name="title"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String,System.Windows.Forms.MessageBoxIcon)"]

icon MessageBoxIcon

[Missing <param name="icon"/> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String,System.Windows.Forms.MessageBoxIcon)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsLogAsync.ShowMessageWarning(System.Windows.Forms.IWin32Window,System.String,System.Windows.Forms.MessageBoxIcon)"]

Implements

IQsLogShowMessageWarning(IWin32Window, String, MessageBoxIcon)
See Also

Reference

QsLogAsync Class
ShowMessageWarning Overload


QsLogAsync.ShutDown Method

QsLogAsyncShutDown Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.ShutDown"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void ShutDown()
Public Sub ShutDown
public:
void ShutDown()
member ShutDown : unit -> unit
See Also

Reference

QsLogAsync Class


QsLogAsync.Start Method

QsLogAsyncStart Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsLogAsync.Start"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
See Also

Reference

QsLogAsync Class


QsLogAsync.Write Method

QsLogAsyncWrite Method

Overload List
 | Name | Description
Public method | Write(String) | Writes the specified message to the log file. It uses default category and log type.
Public method | Write(String, LogMessageTypeEnum) | Writes the specified message to the log file. It uses default category.
Public method | Write(String, String) | Writes the specified message to the log file. It uses default log type.
Public method | Write(String, String, LogMessageTypeEnum) | Writes the specified message to the log file.
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.Write(String) Method

QsLogAsyncWrite(String) Method

Writes the specified message to the log file. It uses default category and log type.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string message
)
Public Sub Write (
    message As String
)
public:
virtual void Write(
    String^ message
) sealed
abstract Write :
        message : string -> unit
override Write :
        message : string -> unit

Parameters

message String
The message to log.

Implements

IQsLogWrite(String)
See Also

Reference

QsLogAsync Class
Write Overload


QsLogAsync.Write(String, LogMessageTypeEnum) Method

QsLogAsyncWrite(String, LogMessageTypeEnum) Method

Writes the specified message to the log file. It uses default category.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string message,
    LogMessageTypeEnum logMessageType
)
Public Sub Write (
    message As String,
    logMessageType As LogMessageTypeEnum
)
public:
virtual void Write(
    String^ message,
    LogMessageTypeEnum logMessageType
) sealed
abstract Write :
        message : string *
        logMessageType : LogMessageTypeEnum -> unit
override Write :
        message : string *
        logMessageType : LogMessageTypeEnum -> unit

Parameters

message String
The message to log.
logMessageType LogMessageTypeEnum
The message type.

Implements

IQsLogWrite(String, LogMessageTypeEnum)
See Also

Reference

QsLogAsync Class
Write Overload


QsLogAsync.Write(String, String) Method

QsLogAsyncWrite(String, String) Method

Writes the specified message to the log file. It uses default log type.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string message,
    string category
)
Public Sub Write (
    message As String,
    category As String
)
public:
virtual void Write(
    String^ message,
    String^ category
) sealed
abstract Write :
        message : string *
        category : string -> unit
override Write :
        message : string *
        category : string -> unit

Parameters

message String
The message to log.
category String
The message category.

Implements

IQsLogWrite(String, String)
See Also

Reference

QsLogAsync Class
Write Overload


QsLogAsync.Write(String, String, LogMessageTypeEnum) Method

QsLogAsyncWrite(String, String, LogMessageTypeEnum) Method

Writes the specified message to the log file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string message,
    string category,
    LogMessageTypeEnum logMessageType
)
Public Sub Write (
    message As String,
    category As String,
    logMessageType As LogMessageTypeEnum
)
public:
virtual void Write(
    String^ message,
    String^ category,
    LogMessageTypeEnum logMessageType
) sealed
abstract Write :
        message : string *
        category : string *
        logMessageType : LogMessageTypeEnum -> unit
override Write :
        message : string *
        category : string *
        logMessageType : LogMessageTypeEnum -> unit

Parameters

message String
The message to log.
category String
The message category.
logMessageType LogMessageTypeEnum
The message type.

Implements

IQsLogWrite(String, String, LogMessageTypeEnum)
See Also

Reference

QsLogAsync Class
Write Overload


QsLogAsync Fields

The QsLogAsync type exposes the following members.

Fields
Name | Description
BatchInterval | Logging time interval (default 1 sec)
LogToConsole | Add an extra log to the Trace
Top
See Also

Reference

QsLogAsync Class


QsLogAsync.BatchInterval Field

QsLogAsyncBatchInterval Field

Logging time interval (default 1 sec)

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static int BatchInterval
Public Shared BatchInterval As Integer
public:
static int BatchInterval
static val mutable BatchInterval: int

Field Value

Int32
See Also

Reference

QsLogAsync Class


QsLogAsync.LogToConsole Field

QsLogAsyncLogToConsole Field

Add an extra log to the Trace

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static bool LogToConsole
Public Shared LogToConsole As Boolean
public:
static bool LogToConsole
static val mutable LogToConsole: bool

Field Value

Boolean
See Also

Reference

QsLogAsync Class


QsPath Class

[Missing <summary> documentation for "T:QsInformatica.Utils.QsPath"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsQsPath

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class QsPath
Public NotInheritable Class QsPath
public ref class QsPath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QsPath = class end

The QsPath type exposes the following members.

Methods
Name | Description
GetQsCommonFilesFolderPath | Ritorna il percorso alla cartella common filex QS
GetQsCommonFilesX86FolderPath | Ritorna il percorso alla cartella common filex x86 QS
GetQsLogFolderPath | Ritorna il percorso alla cartella dei LOG
GetQsProgramDataFolderPath | Ritorna il percorso alla cartella Program data QS
GetQsProgramFilesFolderPath | Ritorna il percorso alla cartella programmi QS
GetQsPublicDocumentsFolderPath | Ritorna il percorso della cartella Documenti Pubblici QS
GetQsRetePath | Ritorna il percorso del QS_RETE leggendolo dal file LUA. Se non è impostato ritorna una stringa vuota.
GetQsUserDataFolderPath | Ritorna il percorso alla cartella userdata QS
Top
See Also

Reference

QsInformatica.Utils Namespace


QsPath Methods

The QsPath type exposes the following members.

Methods
Name | Description
GetQsCommonFilesFolderPath | Ritorna il percorso alla cartella common filex QS
GetQsCommonFilesX86FolderPath | Ritorna il percorso alla cartella common filex x86 QS
GetQsLogFolderPath | Ritorna il percorso alla cartella dei LOG
GetQsProgramDataFolderPath | Ritorna il percorso alla cartella Program data QS
GetQsProgramFilesFolderPath | Ritorna il percorso alla cartella programmi QS
GetQsPublicDocumentsFolderPath | Ritorna il percorso della cartella Documenti Pubblici QS
GetQsRetePath | Ritorna il percorso del QS_RETE leggendolo dal file LUA. Se non è impostato ritorna una stringa vuota.
GetQsUserDataFolderPath | Ritorna il percorso alla cartella userdata QS
Top
See Also

Reference

QsPath Class


QsPath.GetQsCommonFilesFolderPath Method

QsPathGetQsCommonFilesFolderPath Method

Ritorna il percorso alla cartella common filex QS

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsCommonFilesFolderPath()
Public Shared Function GetQsCommonFilesFolderPath As String
public:
static String^ GetQsCommonFilesFolderPath()
static member GetQsCommonFilesFolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsCommonFilesFolderPath"]

See Also

Reference

QsPath Class


QsPath.GetQsCommonFilesX86FolderPath Method

QsPathGetQsCommonFilesX86FolderPath Method

Ritorna il percorso alla cartella common filex x86 QS

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsCommonFilesX86FolderPath()
Public Shared Function GetQsCommonFilesX86FolderPath As String
public:
static String^ GetQsCommonFilesX86FolderPath()
static member GetQsCommonFilesX86FolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsCommonFilesX86FolderPath"]

See Also

Reference

QsPath Class


QsPath.GetQsLogFolderPath Method

QsPathGetQsLogFolderPath Method

Ritorna il percorso alla cartella dei LOG

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsLogFolderPath()
Public Shared Function GetQsLogFolderPath As String
public:
static String^ GetQsLogFolderPath()
static member GetQsLogFolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsLogFolderPath"]

See Also

Reference

QsPath Class


QsPath.GetQsProgramDataFolderPath Method

QsPathGetQsProgramDataFolderPath Method

Ritorna il percorso alla cartella Program data QS

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsProgramDataFolderPath()
Public Shared Function GetQsProgramDataFolderPath As String
public:
static String^ GetQsProgramDataFolderPath()
static member GetQsProgramDataFolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsProgramDataFolderPath"]

See Also

Reference

QsPath Class


QsPath.GetQsProgramFilesFolderPath Method

QsPathGetQsProgramFilesFolderPath Method

Ritorna il percorso alla cartella programmi QS

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsProgramFilesFolderPath()
Public Shared Function GetQsProgramFilesFolderPath As String
public:
static String^ GetQsProgramFilesFolderPath()
static member GetQsProgramFilesFolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsProgramFilesFolderPath"]

See Also

Reference

QsPath Class


QsPath.GetQsPublicDocumentsFolderPath Method

QsPathGetQsPublicDocumentsFolderPath Method

Ritorna il percorso della cartella Documenti Pubblici QS

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsPublicDocumentsFolderPath()
Public Shared Function GetQsPublicDocumentsFolderPath As String
public:
static String^ GetQsPublicDocumentsFolderPath()
static member GetQsPublicDocumentsFolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsPublicDocumentsFolderPath"]

See Also

Reference

QsPath Class


QsPath.GetQsRetePath Method

QsPathGetQsRetePath Method

Ritorna il percorso del QS_RETE leggendolo dal file LUA. Se non è impostato ritorna una stringa vuota.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsRetePath()
Public Shared Function GetQsRetePath As String
public:
static String^ GetQsRetePath()
static member GetQsRetePath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsRetePath"]

See Also

Reference

QsPath Class


QsPath.GetQsUserDataFolderPath Method

QsPathGetQsUserDataFolderPath Method

Ritorna il percorso alla cartella userdata QS

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetQsUserDataFolderPath()
Public Shared Function GetQsUserDataFolderPath As String
public:
static String^ GetQsUserDataFolderPath()
static member GetQsUserDataFolderPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsPath.GetQsUserDataFolderPath"]

See Also

Reference

QsPath Class


QsProduct Class

[Missing <summary> documentation for "T:QsInformatica.Utils.QsProduct"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsQsProduct

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class QsProduct
Public Class QsProduct
public ref class QsProduct
type QsProduct = class end

The QsProduct type exposes the following members.

Constructors
 | Name | Description
Public method | QsProduct | Initializes a new instance of the QsProduct class
Top
Properties
 | Name | Description
Public property | HostProduct |
Public property | Name |
Public property | Ver |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


QsProduct Constructor

Initializes a new instance of the QsProduct class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsProduct()
Public Sub New
public:
QsProduct()
new : unit -> QsProduct
See Also

Reference

QsProduct Class


QsProduct Properties

The QsProduct type exposes the following members.

Properties
 | Name | Description
Public property | HostProduct |
Public property | Name |
Public property | Ver |
Top
See Also

Reference

QsProduct Class


QsProduct.HostProduct Property

QsProductHostProduct Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsProduct.HostProduct"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public HostProduct HostProduct { get; set; }
Public Property HostProduct As HostProduct
    Get
    Set
public:
property HostProduct^ HostProduct {
    HostProduct^ get ();
    void set (HostProduct^ value);
}
member HostProduct : HostProduct with get, set

Property Value

HostProduct
See Also

Reference

QsProduct Class


QsProduct.Name Property

QsProductName Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsProduct.Name"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

QsProduct Class


QsProduct.Ver Property

QsProductVer Property

[Missing <summary> documentation for "P:QsInformatica.Utils.QsProduct.Ver"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Ver { get; set; }
Public Property Ver As String
    Get
    Set
public:
property String^ Ver {
    String^ get ();
    void set (String^ value);
}
member Ver : string with get, set

Property Value

String
See Also

Reference

QsProduct Class


QsProduct Methods

The QsProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsProduct Class


QsResources Class

Class QsResources. Manages the resources for the viewer menu.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsQsResources

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class QsResources
Public Class QsResources
public ref class QsResources
type QsResources = class end

The QsResources type exposes the following members.

Constructors
 | Name | Description
Public method | QsResources | Initializes a new instance of the QsResources class
Top
Methods
 | Name | Description
Public method | AddIcon(String, Icon) |
Public method | AddIcon(String, String) |
Public method | AddImage(String, Image) | Add an image resource
Public method | AddImage(String, String) | Add an image resource
Public method | AddSvgImage | Add the SvgImage object. Pass the "SvgImage.FromFile" as file reader
 | DetectResourceType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIcon | Get a resource icon given the name (normally with the extension)
Public method | GetImage | Get a resource image given the name (normally with the extension)
Public method | GetResource | Get a resource given the name (normally with the extension)
Public method | GetResourcesNames | Returns all the resource names
Public method | GetSvgImage | Get a resource svgimage as object given the name (normally with the extension) pass the DevExpress "SvgImage.FromStream" method and cast to SvgImage
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResource | Check for resource existence
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadResourceFile | Reads a resource file. The resource file is just a zip file. Normmaly we use .mnx and .rsx extensions.
Public method | RemoveResource | Remove the entry form the resources
Public method | RenameResource | Rename an entry.Do not change the extension!
 | Sample | for testing only
Public method | SaveAs | Save the archive
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


QsResources Constructor

Initializes a new instance of the QsResources class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public QsResources()
Public Sub New
public:
QsResources()
new : unit -> QsResources
See Also

Reference

QsResources Class


QsResources Methods

The QsResources type exposes the following members.

Methods
 | Name | Description
Public method | AddIcon(String, Icon) |
Public method | AddIcon(String, String) |
Public method | AddImage(String, Image) | Add an image resource
Public method | AddImage(String, String) | Add an image resource
Public method | AddSvgImage | Add the SvgImage object. Pass the "SvgImage.FromFile" as file reader
 | DetectResourceType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIcon | Get a resource icon given the name (normally with the extension)
Public method | GetImage | Get a resource image given the name (normally with the extension)
Public method | GetResource | Get a resource given the name (normally with the extension)
Public method | GetResourcesNames | Returns all the resource names
Public method | GetSvgImage | Get a resource svgimage as object given the name (normally with the extension) pass the DevExpress "SvgImage.FromStream" method and cast to SvgImage
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResource | Check for resource existence
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadResourceFile | Reads a resource file. The resource file is just a zip file. Normmaly we use .mnx and .rsx extensions.
Public method | RemoveResource | Remove the entry form the resources
Public method | RenameResource | Rename an entry.Do not change the extension!
 | Sample | for testing only
Public method | SaveAs | Save the archive
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsResources Class


QsResources.AddIcon Method

QsResourcesAddIcon Method

Overload List
 | Name | Description
Public method | AddIcon(String, Icon) |
Public method | AddIcon(String, String) |
Top
See Also

Reference

QsResources Class


QsResources.AddIcon(String, Icon) Method

QsResourcesAddIcon(String, Icon) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.Drawing.Icon)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool AddIcon(
    string name,
    Icon ico
)
Public Function AddIcon (
    name As String,
    ico As Icon
) As Boolean
public:
bool AddIcon(
    String^ name,
    Icon^ ico
)
member AddIcon :
        name : string *
        ico : Icon -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.Drawing.Icon)"]

ico Icon

[Missing <param name="ico"/> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.Drawing.Icon)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.Drawing.Icon)"]

See Also

Reference

QsResources Class
AddIcon Overload


QsResources.AddIcon(String, String) Method

QsResourcesAddIcon(String, String) Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool AddIcon(
    string name,
    string icoPath
)
Public Function AddIcon (
    name As String,
    icoPath As String
) As Boolean
public:
bool AddIcon(
    String^ name,
    String^ icoPath
)
member AddIcon :
        name : string *
        icoPath : string -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.String)"]

icoPath String

[Missing <param name="icoPath"/> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.AddIcon(System.String,System.String)"]

See Also

Reference

QsResources Class
AddIcon Overload


QsResources.AddImage Method

QsResourcesAddImage Method

Overload List
 | Name | Description
Public method | AddImage(String, Image) | Add an image resource
Public method | AddImage(String, String) | Add an image resource
Top
See Also

Reference

QsResources Class


QsResources.AddImage(String, Image) Method

QsResourcesAddImage(String, Image) Method

Add an image resource

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool AddImage(
    string name,
    Image img
)
Public Function AddImage (
    name As String,
    img As Image
) As Boolean
public:
bool AddImage(
    String^ name,
    Image^ img
)
member AddImage :
        name : string *
        img : Image -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.AddImage(System.String,System.Drawing.Image)"]

img Image

[Missing <param name="img"/> documentation for "M:QsInformatica.Utils.QsResources.AddImage(System.String,System.Drawing.Image)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.AddImage(System.String,System.Drawing.Image)"]

See Also

Reference

QsResources Class
AddImage Overload


QsResources.AddImage(String, String) Method

QsResourcesAddImage(String, String) Method

Add an image resource

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool AddImage(
    string name,
    string imgPath
)
Public Function AddImage (
    name As String,
    imgPath As String
) As Boolean
public:
bool AddImage(
    String^ name,
    String^ imgPath
)
member AddImage :
        name : string *
        imgPath : string -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.AddImage(System.String,System.String)"]

imgPath String

[Missing <param name="imgPath"/> documentation for "M:QsInformatica.Utils.QsResources.AddImage(System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.AddImage(System.String,System.String)"]

See Also

Reference

QsResources Class
AddImage Overload


QsResources.AddSvgImage Method

QsResourcesAddSvgImage Method

Add the SvgImage object. Pass the "SvgImage.FromFile" as file reader

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool AddSvgImage(
    string name,
    string svgFilePath
)
Public Function AddSvgImage (
    name As String,
    svgFilePath As String
) As Boolean
public:
bool AddSvgImage(
    String^ name,
    String^ svgFilePath
)
member AddSvgImage :
        name : string *
        svgFilePath : string -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.AddSvgImage(System.String,System.String)"]

svgFilePath String

[Missing <param name="svgFilePath"/> documentation for "M:QsInformatica.Utils.QsResources.AddSvgImage(System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.AddSvgImage(System.String,System.String)"]

See Also

Reference

QsResources Class


QsResources.DetectResourceType Method

QsResourcesDetectResourceType Method

[Missing <summary> documentation for "M:QsInformatica.Utils.QsResources.DetectResourceType(System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static QsResourcesResourceType DetectResourceType(
    string entryname
)
Public Shared Function DetectResourceType (
    entryname As String
) As QsResourcesResourceType
public:
static QsResourcesResourceType DetectResourceType(
    String^ entryname
)
static member DetectResourceType :
        entryname : string -> QsResourcesResourceType

Parameters

entryname String

[Missing <param name="entryname"/> documentation for "M:QsInformatica.Utils.QsResources.DetectResourceType(System.String)"]

Return Value

QsResourcesResourceType

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.DetectResourceType(System.String)"]

See Also

Reference

QsResources Class


QsResources.GetIcon Method

QsResourcesGetIcon Method

Get a resource icon given the name (normally with the extension)

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Icon GetIcon(
    string name
)
Public Function GetIcon (
    name As String
) As Icon
public:
Icon^ GetIcon(
    String^ name
)
member GetIcon :
        name : string -> Icon

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.GetIcon(System.String)"]

Return Value

Icon

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.GetIcon(System.String)"]

See Also

Reference

QsResources Class


QsResources.GetImage Method

QsResourcesGetImage Method

Get a resource image given the name (normally with the extension)

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Image GetImage(
    string name
)
Public Function GetImage (
    name As String
) As Image
public:
Image^ GetImage(
    String^ name
)
member GetImage :
        name : string -> Image

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.GetImage(System.String)"]

Return Value

Image

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.GetImage(System.String)"]

See Also

Reference

QsResources Class


QsResources.GetResource Method

QsResourcesGetResource Method

Get a resource given the name (normally with the extension)

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Object GetResource(
    string name
)
Public Function GetResource (
    name As String
) As Object
public:
Object^ GetResource(
    String^ name
)
member GetResource :
        name : string -> Object

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.GetResource(System.String)"]

Return Value

Object

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.GetResource(System.String)"]

See Also

Reference

QsResources Class


QsResources.GetResourcesNames Method

QsResourcesGetResourcesNames Method

Returns all the resource names

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> GetResourcesNames()
Public Function GetResourcesNames As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetResourcesNames()
member GetResourcesNames : unit -> IEnumerable<string>

Return Value

IEnumerable String

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.GetResourcesNames"]

See Also

Reference

QsResources Class


QsResources.GetSvgImage Method

QsResourcesGetSvgImage Method

Get a resource svgimage as object given the name (normally with the extension) pass the DevExpress "SvgImage.FromStream" method and cast to SvgImage

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Object GetSvgImage(
    string name,
    Func<Stream, Object> streamReader
)
Public Function GetSvgImage (
    name As String,
    streamReader As Func(Of Stream, Object)
) As Object
public:
Object^ GetSvgImage(
    String^ name,
    Func<Stream^, Object^>^ streamReader
)
member GetSvgImage :
        name : string *
        streamReader : Func<Stream, Object> -> Object

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.GetSvgImage(System.String,System.Func{System.IO.Stream,System.Object})"]

streamReader Func Stream, Object

[Missing <param name="streamReader"/> documentation for "M:QsInformatica.Utils.QsResources.GetSvgImage(System.String,System.Func{System.IO.Stream,System.Object})"]

Return Value

Object

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.GetSvgImage(System.String,System.Func{System.IO.Stream,System.Object})"]

See Also

Reference

QsResources Class


QsResources.HasResource Method

QsResourcesHasResource Method

Check for resource existence

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool HasResource(
    string name
)
Public Function HasResource (
    name As String
) As Boolean
public:
bool HasResource(
    String^ name
)
member HasResource :
        name : string -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.HasResource(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.HasResource(System.String)"]

See Also

Reference

QsResources Class


QsResources.ReadResourceFile Method

QsResourcesReadResourceFile Method

Reads a resource file. The resource file is just a zip file. Normmaly we use .mnx and .rsx extensions.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public int ReadResourceFile(
    string resfile,
    bool addPrefix
)
Public Function ReadResourceFile (
    resfile As String,
    addPrefix As Boolean
) As Integer
public:
int ReadResourceFile(
    String^ resfile,
    bool addPrefix
)
member ReadResourceFile :
        resfile : string *
        addPrefix : bool -> int

Parameters

resfile String
The resfile.
addPrefix Boolean
if set to true [add prefix].

Return Value

Int32

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.ReadResourceFile(System.String,System.Boolean)"]

See Also

Reference

QsResources Class


QsResources.RemoveResource Method

QsResourcesRemoveResource Method

Remove the entry form the resources

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool RemoveResource(
    string name
)
Public Function RemoveResource (
    name As String
) As Boolean
public:
bool RemoveResource(
    String^ name
)
member RemoveResource :
        name : string -> bool

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.QsResources.RemoveResource(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.RemoveResource(System.String)"]

See Also

Reference

QsResources Class


QsResources.RenameResource Method

QsResourcesRenameResource Method

Rename an entry.Do not change the extension!

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool RenameResource(
    string oldName,
    string newName
)
Public Function RenameResource (
    oldName As String,
    newName As String
) As Boolean
public:
bool RenameResource(
    String^ oldName,
    String^ newName
)
member RenameResource :
        oldName : string *
        newName : string -> bool

Parameters

oldName String

[Missing <param name="oldName"/> documentation for "M:QsInformatica.Utils.QsResources.RenameResource(System.String,System.String)"]

newName String

[Missing <param name="newName"/> documentation for "M:QsInformatica.Utils.QsResources.RenameResource(System.String,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.QsResources.RenameResource(System.String,System.String)"]

See Also

Reference

QsResources Class


QsResources.Sample Method

QsResourcesSample Method

for testing only

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void Sample()
Public Shared Sub Sample
public:
static void Sample()
static member Sample : unit -> unit
See Also

Reference

QsResources Class


QsResources.SaveAs Method

QsResourcesSaveAs Method

Save the archive

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    string resFile
)
Public Sub SaveAs (
    resFile As String
)
public:
void SaveAs(
    String^ resFile
)
member SaveAs :
        resFile : string -> unit

Parameters

resFile String

[Missing <param name="resFile"/> documentation for "M:QsInformatica.Utils.QsResources.SaveAs(System.String)"]

See Also

Reference

QsResources Class


QsResources.ResourceType Enumeration

QsResourcesResourceType Enumeration

[Missing <summary> documentation for "T:QsInformatica.Utils.QsResources.ResourceType"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public enum ResourceType
Public Enumeration ResourceType
public enum class ResourceType
type ResourceType
Members
Member name | Value | Description
Unknown | 0 |
Icon | 1 |
Image | 2 |
SvgImage | 3 |
See Also

Reference

QsInformatica.Utils Namespace


Recipient Class

Represents a Recipient for a MapiMailMessage.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsRecipient

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class Recipient
Public Class Recipient
public ref class Recipient
type Recipient = class end

The Recipient type exposes the following members.

Constructors
 | Name | Description
Public method | Recipient(String) | Creates a new recipient with the specified address.
Public method | Recipient(String, MapiMailMessageRecipientType) | Creates a new recipient with the specified address and recipient type.
Public method | Recipient(String, String) | Creates a new recipient with the specified address and display name.
Public method | Recipient(String, String, MapiMailMessageRecipientType) | Creates a new recipient with the specified address, display name and recipient type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
 | Name | Description
Public field | Address | The email address of this recipient.
Public field | DisplayName | The display name of this recipient.
Public field | RecipientType | How the recipient will receive this message (To, CC, BCC).
Top
See Also

Reference

QsInformatica.Utils Namespace


Recipient Constructor

Overload List
 | Name | Description
Public method | Recipient(String) | Creates a new recipient with the specified address.
Public method | Recipient(String, MapiMailMessageRecipientType) | Creates a new recipient with the specified address and recipient type.
Public method | Recipient(String, String) | Creates a new recipient with the specified address and display name.
Public method | Recipient(String, String, MapiMailMessageRecipientType) | Creates a new recipient with the specified address, display name and recipient type.
Top
See Also

Reference

Recipient Class


Recipient(String) Constructor

Creates a new recipient with the specified address.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Recipient(
    string address
)
Public Sub New (
    address As String
)
public:
Recipient(
    String^ address
)
new :
        address : string -> Recipient

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String)"]

See Also

Reference

Recipient Class
Recipient Overload


Recipient(String, MapiMailMessage.RecipientType) Constructor

Recipient(String, MapiMailMessageRecipientType) Constructor

Creates a new recipient with the specified address and recipient type.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Recipient(
    string address,
    MapiMailMessageRecipientType recipientType
)
Public Sub New (
    address As String,
    recipientType As MapiMailMessageRecipientType
)
public:
Recipient(
    String^ address,
    MapiMailMessageRecipientType recipientType
)
new :
        address : string *
        recipientType : MapiMailMessageRecipientType -> Recipient

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

recipientType MapiMailMessageRecipientType

[Missing <param name="recipientType"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

See Also

Reference

Recipient Class
Recipient Overload


Recipient(String, String) Constructor

Creates a new recipient with the specified address and display name.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Recipient(
    string address,
    string displayName
)
Public Sub New (
    address As String,
    displayName As String
)
public:
Recipient(
    String^ address,
    String^ displayName
)
new :
        address : string *
        displayName : string -> Recipient

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,System.String)"]

displayName String

[Missing <param name="displayName"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,System.String)"]

See Also

Reference

Recipient Class
Recipient Overload


Recipient(String, String, MapiMailMessage.RecipientType) Constructor

Recipient(String, String, MapiMailMessageRecipientType) Constructor

Creates a new recipient with the specified address, display name and recipient type.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Recipient(
    string address,
    string displayName,
    MapiMailMessageRecipientType recipientType
)
Public Sub New (
    address As String,
    displayName As String,
    recipientType As MapiMailMessageRecipientType
)
public:
Recipient(
    String^ address,
    String^ displayName,
    MapiMailMessageRecipientType recipientType
)
new :
        address : string *
        displayName : string *
        recipientType : MapiMailMessageRecipientType -> Recipient

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

displayName String

[Missing <param name="displayName"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

recipientType MapiMailMessageRecipientType

[Missing <param name="recipientType"/> documentation for "M:QsInformatica.Utils.Recipient.#ctor(System.String,System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

See Also

Reference

Recipient Class
Recipient Overload


Recipient Methods

The Recipient type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Recipient Class


Recipient Fields

The Recipient type exposes the following members.

Fields
 | Name | Description
Public field | Address | The email address of this recipient.
Public field | DisplayName | The display name of this recipient.
Public field | RecipientType | How the recipient will receive this message (To, CC, BCC).
Top
See Also

Reference

Recipient Class


Recipient.Address Field

RecipientAddress Field

The email address of this recipient.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Address
Public Address As String
public:
String^ Address
val mutable Address: string

Field Value

String
See Also

Reference

Recipient Class


Recipient.DisplayName Field

RecipientDisplayName Field

The display name of this recipient.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string DisplayName
Public DisplayName As String
public:
String^ DisplayName
val mutable DisplayName: string

Field Value

String
See Also

Reference

Recipient Class


Recipient.RecipientType Field

RecipientRecipientType Field

How the recipient will receive this message (To, CC, BCC).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public MapiMailMessageRecipientType RecipientType
Public RecipientType As MapiMailMessageRecipientType
public:
MapiMailMessageRecipientType RecipientType
val mutable RecipientType: MapiMailMessageRecipientType

Field Value

MapiMailMessageRecipientType
See Also

Reference

Recipient Class


RecipientCollection Class

Represents a colleciton of recipients for a mail message.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
QsInformatica.UtilsRecipientCollection

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class RecipientCollection : CollectionBase
Public Class RecipientCollection
    Inherits CollectionBase
public ref class RecipientCollection : public CollectionBase
type RecipientCollection =
    class
        inherit CollectionBase
    end

The RecipientCollection type exposes the following members.

Constructors
 | Name | Description
Public method | RecipientCollection | Initializes a new instance of the RecipientCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase)
Public property | Item | Returns the recipient stored in this collection at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase)
Top
Methods
 | Name | Description
Public method | Add(Recipient) | Adds the specified recipient to this collection.
Public method | Add(String) | Adds a new recipient with the specified address to this collection.
Public method | Add(String, MapiMailMessageRecipientType) | Adds a new recipient with the specified address and recipient type to this collection.
Public method | Add(String, String) | Adds a new recipient with the specified address and display name to this collection.
Public method | Add(String, String, MapiMailMessageRecipientType) | Adds a new recipient with the specified address, display name and recipient type to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


RecipientCollection Constructor

Initializes a new instance of the RecipientCollection class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public RecipientCollection()
Public Sub New
public:
RecipientCollection()
new : unit -> RecipientCollection
See Also

Reference

RecipientCollection Class


RecipientCollection Properties

The RecipientCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase)
Public property | Item | Returns the recipient stored in this collection at the specified index.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase)
Top
See Also

Reference

RecipientCollection Class


RecipientCollection.Item Property

RecipientCollectionItem Property

Returns the recipient stored in this collection at the specified index.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Recipient this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Recipient
    Get
public:
property Recipient^ default[int index] {
    Recipient^ get (int index);
}
member Item : Recipient with get

Parameters

index Int32

Property Value

Recipient
See Also

Reference

RecipientCollection Class


RecipientCollection Methods

The RecipientCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(Recipient) | Adds the specified recipient to this collection.
Public method | Add(String) | Adds a new recipient with the specified address to this collection.
Public method | Add(String, MapiMailMessageRecipientType) | Adds a new recipient with the specified address and recipient type to this collection.
Public method | Add(String, String) | Adds a new recipient with the specified address and display name to this collection.
Public method | Add(String, String, MapiMailMessageRecipientType) | Adds a new recipient with the specified address, display name and recipient type to this collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RecipientCollection Class


RecipientCollection.Add Method

RecipientCollectionAdd Method

Overload List
 | Name | Description
Public method | Add(Recipient) | Adds the specified recipient to this collection.
Public method | Add(String) | Adds a new recipient with the specified address to this collection.
Public method | Add(String, MapiMailMessageRecipientType) | Adds a new recipient with the specified address and recipient type to this collection.
Public method | Add(String, String) | Adds a new recipient with the specified address and display name to this collection.
Public method | Add(String, String, MapiMailMessageRecipientType) | Adds a new recipient with the specified address, display name and recipient type to this collection.
Top
See Also

Reference

RecipientCollection Class


RecipientCollection.Add(Recipient) Method

RecipientCollectionAdd(Recipient) Method

Adds the specified recipient to this collection.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Recipient value
)
Public Sub Add (
    value As Recipient
)
public:
void Add(
    Recipient^ value
)
member Add :
        value : Recipient -> unit

Parameters

value Recipient

[Missing <param name="value"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(QsInformatica.Utils.Recipient)"]

See Also

Reference

RecipientCollection Class
Add Overload


RecipientCollection.Add(String) Method

RecipientCollectionAdd(String) Method

Adds a new recipient with the specified address to this collection.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string address
)
Public Sub Add (
    address As String
)
public:
void Add(
    String^ address
)
member Add :
        address : string -> unit

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String)"]

See Also

Reference

RecipientCollection Class
Add Overload


RecipientCollection.Add(String, MapiMailMessage.RecipientType) Method

RecipientCollectionAdd(String, MapiMailMessageRecipientType) Method

Adds a new recipient with the specified address and recipient type to this collection.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string address,
    MapiMailMessageRecipientType recipientType
)
Public Sub Add (
    address As String,
    recipientType As MapiMailMessageRecipientType
)
public:
void Add(
    String^ address,
    MapiMailMessageRecipientType recipientType
)
member Add :
        address : string *
        recipientType : MapiMailMessageRecipientType -> unit

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

recipientType MapiMailMessageRecipientType

[Missing <param name="recipientType"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

See Also

Reference

RecipientCollection Class
Add Overload


RecipientCollection.Add(String, String) Method

RecipientCollectionAdd(String, String) Method

Adds a new recipient with the specified address and display name to this collection.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string address,
    string displayName
)
Public Sub Add (
    address As String,
    displayName As String
)
public:
void Add(
    String^ address,
    String^ displayName
)
member Add :
        address : string *
        displayName : string -> unit

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,System.String)"]

displayName String

[Missing <param name="displayName"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,System.String)"]

See Also

Reference

RecipientCollection Class
Add Overload


RecipientCollection.Add(String, String, MapiMailMessage.RecipientType) Method

RecipientCollectionAdd(String, String, MapiMailMessageRecipientType) Method

Adds a new recipient with the specified address, display name and recipient type to this collection.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string address,
    string displayName,
    MapiMailMessageRecipientType recipientType
)
Public Sub Add (
    address As String,
    displayName As String,
    recipientType As MapiMailMessageRecipientType
)
public:
void Add(
    String^ address,
    String^ displayName,
    MapiMailMessageRecipientType recipientType
)
member Add :
        address : string *
        displayName : string *
        recipientType : MapiMailMessageRecipientType -> unit

Parameters

address String

[Missing <param name="address"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

displayName String

[Missing <param name="displayName"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

recipientType MapiMailMessageRecipientType

[Missing <param name="recipientType"/> documentation for "M:QsInformatica.Utils.RecipientCollection.Add(System.String,System.String,QsInformatica.Utils.MapiMailMessage.RecipientType)"]

See Also

Reference

RecipientCollection Class
Add Overload


RegisterUtility Class

Classe utilizzata per creare/leggere le chiavi nel/dal registro di sistema CURRENT USER.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsRegisterUtility

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class RegisterUtility
Public NotInheritable Class RegisterUtility
public ref class RegisterUtility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RegisterUtility = class end

The RegisterUtility type exposes the following members.

Methods
Name | Description
CreateSubKeys | Crea una chiave, nel caso non esistono i genitori li crea. Esempio: Software\QsInformatica\Prova (crea tutte le chiavi necessarie).
GetValueInSubKey | Restituisce il valore di una variabile all'interno di una chiave.
GetValuesInSubKeyWithSeparator | Restituisce tutti gli elementi presenti in una variabile.
RemoveValueBySubKey | Rimuove un valore da un chiave.
RemoveValuesInSubKeyWithSeparator | Rimuove un elemento da una lista di elementi presenti in una varibile.
SetValueInSubKey | Imposta il valore di una variabile all'interno di una chiave.
SetValuesInSubKeyWithSeparator | Aggiunge un elemento agli elementi già presenti in una varibile.
SetValuesInSubKeyWithSeparatorUpdatingPosition | Aggiunge l'elemento specificato alla lista presente nella chiave di registro. Se l'elemento è già presente, viene spostato in ultima posizione (la più recente).
Top
See Also

Reference

QsInformatica.Utils Namespace


RegisterUtility Methods

The RegisterUtility type exposes the following members.

Methods
Name | Description
CreateSubKeys | Crea una chiave, nel caso non esistono i genitori li crea. Esempio: Software\QsInformatica\Prova (crea tutte le chiavi necessarie).
GetValueInSubKey | Restituisce il valore di una variabile all'interno di una chiave.
GetValuesInSubKeyWithSeparator | Restituisce tutti gli elementi presenti in una variabile.
RemoveValueBySubKey | Rimuove un valore da un chiave.
RemoveValuesInSubKeyWithSeparator | Rimuove un elemento da una lista di elementi presenti in una varibile.
SetValueInSubKey | Imposta il valore di una variabile all'interno di una chiave.
SetValuesInSubKeyWithSeparator | Aggiunge un elemento agli elementi già presenti in una varibile.
SetValuesInSubKeyWithSeparatorUpdatingPosition | Aggiunge l'elemento specificato alla lista presente nella chiave di registro. Se l'elemento è già presente, viene spostato in ultima posizione (la più recente).
Top
See Also

Reference

RegisterUtility Class


RegisterUtility.CreateSubKeys Method

RegisterUtilityCreateSubKeys Method

Crea una chiave, nel caso non esistono i genitori li crea. Esempio: Software\QsInformatica\Prova (crea tutte le chiavi necessarie).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void CreateSubKeys(
    string subkey
)
Public Shared Sub CreateSubKeys (
    subkey As String
)
public:
static void CreateSubKeys(
    String^ subkey
)
static member CreateSubKeys :
        subkey : string -> unit

Parameters

subkey String
Stringa con la chiave da creare.
See Also

Reference

RegisterUtility Class


RegisterUtility.GetValueInSubKey Method

RegisterUtilityGetValueInSubKey Method

Restituisce il valore di una variabile all'interno di una chiave.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static Object GetValueInSubKey(
    string key,
    string name,
    Object defval
)
Public Shared Function GetValueInSubKey (
    key As String,
    name As String,
    defval As Object
) As Object
public:
static Object^ GetValueInSubKey(
    String^ key,
    String^ name,
    Object^ defval
)
static member GetValueInSubKey :
        key : string *
        name : string *
        defval : Object -> Object

Parameters

key String
Stringa con la chiave.
name String
Nome della variabile.
defval Object
Valore da restituire di default nel caso non sia presente.

Return Value

Object

[Missing <returns> documentation for "M:QsInformatica.Utils.RegisterUtility.GetValueInSubKey(System.String,System.String,System.Object)"]

See Also

Reference

RegisterUtility Class


RegisterUtility.GetValuesInSubKeyWithSeparator Method

RegisterUtilityGetValuesInSubKeyWithSeparator Method

Restituisce tutti gli elementi presenti in una variabile.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string[] GetValuesInSubKeyWithSeparator(
    string key,
    string name,
    Object[] defval,
    char separator
)
Public Shared Function GetValuesInSubKeyWithSeparator (
    key As String,
    name As String,
    defval As Object(),
    separator As Char
) As String()
public:
static array<String^>^ GetValuesInSubKeyWithSeparator(
    String^ key,
    String^ name,
    array<Object^>^ defval,
    wchar_t separator
)
static member GetValuesInSubKeyWithSeparator :
        key : string *
        name : string *
        defval : Object[] *
        separator : char -> string[]

Parameters

key String
Stringa con la chiave.
name String
Nome della variabile.
defval Object
Valore da restituire di default nel caso non sia presente.
separator Char
Carattere separatore tra i vari elementi all'interno della varibile.

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.RegisterUtility.GetValuesInSubKeyWithSeparator(System.String,System.String,System.Object[],System.Char)"]

See Also

Reference

RegisterUtility Class


RegisterUtility.RemoveValueBySubKey Method

RegisterUtilityRemoveValueBySubKey Method

Rimuove un valore da un chiave.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void RemoveValueBySubKey(
    string key,
    string name
)
Public Shared Sub RemoveValueBySubKey (
    key As String,
    name As String
)
public:
static void RemoveValueBySubKey(
    String^ key,
    String^ name
)
static member RemoveValueBySubKey :
        key : string *
        name : string -> unit

Parameters

key String
Stringa con la chiave.
name String
Nome del valore da rimuovere dalla chiave.
See Also

Reference

RegisterUtility Class


RegisterUtility.RemoveValuesInSubKeyWithSeparator Method

RegisterUtilityRemoveValuesInSubKeyWithSeparator Method

Rimuove un elemento da una lista di elementi presenti in una varibile.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void RemoveValuesInSubKeyWithSeparator(
    string key,
    string name,
    string valore,
    char separator
)
Public Shared Sub RemoveValuesInSubKeyWithSeparator (
    key As String,
    name As String,
    valore As String,
    separator As Char
)
public:
static void RemoveValuesInSubKeyWithSeparator(
    String^ key,
    String^ name,
    String^ valore,
    wchar_t separator
)
static member RemoveValuesInSubKeyWithSeparator :
        key : string *
        name : string *
        valore : string *
        separator : char -> unit

Parameters

key String
Stringa con la chiave.
name String
Nome della variabile.
valore String
VValore da rimuovere.
separator Char
Carattere separatore tra i vari elementi all'interno della varibile.

Return Value

See Also

Reference

RegisterUtility Class


RegisterUtility.SetValueInSubKey Method

RegisterUtilitySetValueInSubKey Method

Imposta il valore di una variabile all'interno di una chiave.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void SetValueInSubKey(
    string key,
    string name,
    Object value
)
Public Shared Sub SetValueInSubKey (
    key As String,
    name As String,
    value As Object
)
public:
static void SetValueInSubKey(
    String^ key,
    String^ name,
    Object^ value
)
static member SetValueInSubKey :
        key : string *
        name : string *
        value : Object -> unit

Parameters

key String
Stringa con la chiave.
name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.RegisterUtility.SetValueInSubKey(System.String,System.String,System.Object)"]

value Object
Valore della variabile.
See Also

Reference

RegisterUtility Class


RegisterUtility.SetValuesInSubKeyWithSeparator Method

RegisterUtilitySetValuesInSubKeyWithSeparator Method

Aggiunge un elemento agli elementi già presenti in una varibile.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void SetValuesInSubKeyWithSeparator(
    string key,
    string name,
    Object value,
    char separator,
    int maxElements,
    bool allowDuplicate
)
Public Shared Sub SetValuesInSubKeyWithSeparator (
    key As String,
    name As String,
    value As Object,
    separator As Char,
    maxElements As Integer,
    allowDuplicate As Boolean
)
public:
static void SetValuesInSubKeyWithSeparator(
    String^ key,
    String^ name,
    Object^ value,
    wchar_t separator,
    int maxElements,
    bool allowDuplicate
)
static member SetValuesInSubKeyWithSeparator :
        key : string *
        name : string *
        value : Object *
        separator : char *
        maxElements : int *
        allowDuplicate : bool -> unit

Parameters

key String
Stringa con la chiave.
name String
Nome della variabile.
value Object
Valore da aggiungere.
separator Char
Carattere separatore tra i vari elementi all'interno della varibile.
maxElements Int32
Massimo numero di elementi permessi nella variabile, nel caso sfori viene cancellato l'elemento più vecchio.
allowDuplicate Boolean
Indica se ci possono essere valori duplicati all'interno della stessa chiave.
See Also

Reference

RegisterUtility Class


RegisterUtility.SetValuesInSubKeyWithSeparatorUpdatingPosition Method

RegisterUtilitySetValuesInSubKeyWithSeparatorUpdatingPosition Method

Aggiunge l'elemento specificato alla lista presente nella chiave di registro. Se l'elemento è già presente, viene spostato in ultima posizione (la più recente).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void SetValuesInSubKeyWithSeparatorUpdatingPosition(
    string regKey,
    string nameRegKey,
    string valToAdd,
    char separator,
    int maxElements
)
Public Shared Sub SetValuesInSubKeyWithSeparatorUpdatingPosition (
    regKey As String,
    nameRegKey As String,
    valToAdd As String,
    separator As Char,
    maxElements As Integer
)
public:
static void SetValuesInSubKeyWithSeparatorUpdatingPosition(
    String^ regKey,
    String^ nameRegKey,
    String^ valToAdd,
    wchar_t separator,
    int maxElements
)
static member SetValuesInSubKeyWithSeparatorUpdatingPosition :
        regKey : string *
        nameRegKey : string *
        valToAdd : string *
        separator : char *
        maxElements : int -> unit

Parameters

regKey String
Path della chaive di registro.
nameRegKey String
Nome della chiave di registro.
valToAdd String
Valore da aggiungere.
separator Char
Separatore.
maxElements Int32
Numero massimo di elementi.
See Also

Reference

RegisterUtility Class


TopBomIniHelper Class

[Missing <summary> documentation for "T:QsInformatica.Utils.TopBomIniHelper"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsTopBomIniHelper

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class TopBomIniHelper
Public NotInheritable Class TopBomIniHelper
public ref class TopBomIniHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TopBomIniHelper = class end
See Also

Reference

QsInformatica.Utils Namespace


TopBomIniHelper.AttributeQs Class

TopBomIniHelperAttributeQs Class

Oggetto Attribute
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsTopBomIniHelperAttributeQs

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class AttributeQs
Public Class AttributeQs
public ref class AttributeQs
type AttributeQs = class end

The TopBomIniHelperAttributeQs type exposes the following members.

Constructors
 | Name | Description
Public method | TopBomIniHelperAttributeQs(String) | Initializes a new instance of the TopBomIniHelperAttributeQs class
Public method | TopBomIniHelperAttributeQs(String, String) | Initializes a new instance of the TopBomIniHelperAttributeQs class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Parameters |
Public property | Val |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | getAttrVal | Restituisce il valore del parametro passato alla funzione
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | getStringParameters | Restituisce la stringa con i parametri dell'attributo "-name nome -indent ..."
Public method | getStringVals | Restituisce la stringa con i valori dell'attributo separati da ,
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


TopBomIniHelper.AttributeQs Constructor

TopBomIniHelperAttributeQs Constructor

Overload List
 | Name | Description
Public method | TopBomIniHelperAttributeQs(String) | Initializes a new instance of the TopBomIniHelperAttributeQs class
Public method | TopBomIniHelperAttributeQs(String, String) | Initializes a new instance of the TopBomIniHelperAttributeQs class
Top
See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs(String) Constructor

TopBomIniHelperAttributeQs(String) Constructor

Initializes a new instance of the TopBomIniHelperAttributeQs class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public AttributeQs(
    string name
)
Public Sub New (
    name As String
)
public:
AttributeQs(
    String^ name
)
new :
        name : string -> AttributeQs

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.#ctor(System.String)"]

See Also

Reference

TopBomIniHelperAttributeQs Class
TopBomIniHelperAttributeQs Overload


TopBomIniHelper.AttributeQs(String, String) Constructor

TopBomIniHelperAttributeQs(String, String) Constructor

Initializes a new instance of the TopBomIniHelperAttributeQs class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public AttributeQs(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
AttributeQs(
    String^ name,
    String^ value
)
new :
        name : string *
        value : string -> AttributeQs

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.#ctor(System.String,System.String)"]

value String

[Missing <param name="value"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.#ctor(System.String,System.String)"]

See Also

Reference

TopBomIniHelperAttributeQs Class
TopBomIniHelperAttributeQs Overload


AttributeQs Properties

The TopBomIniHelperAttributeQs type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Parameters |
Public property | Val |
Top
See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs.Name Property

TopBomIniHelperAttributeQsName Property

[Missing <summary> documentation for "P:QsInformatica.Utils.TopBomIniHelper.AttributeQs.Name"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs.Parameters Property

TopBomIniHelperAttributeQsParameters Property

[Missing <summary> documentation for "P:QsInformatica.Utils.TopBomIniHelper.AttributeQs.Parameters"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> Parameters { get; set; }
Public Property Parameters As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ Parameters {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
member Parameters : Dictionary<string, string> with get, set

Property Value

Dictionary String, String
See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs.Val Property

TopBomIniHelperAttributeQsVal Property

[Missing <summary> documentation for "P:QsInformatica.Utils.TopBomIniHelper.AttributeQs.Val"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> Val { get; set; }
Public Property Val As List(Of String)
    Get
    Set
public:
property List<String^>^ Val {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Val : List<string> with get, set

Property Value

List String
See Also

Reference

TopBomIniHelperAttributeQs Class


AttributeQs Methods

The TopBomIniHelperAttributeQs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | getAttrVal | Restituisce il valore del parametro passato alla funzione
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | getStringParameters | Restituisce la stringa con i parametri dell'attributo "-name nome -indent ..."
Public method | getStringVals | Restituisce la stringa con i valori dell'attributo separati da ,
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs.getAttrVal Method

TopBomIniHelperAttributeQsgetAttrVal Method

Restituisce il valore del parametro passato alla funzione

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string getAttrVal(
    string val
)
Public Function getAttrVal (
    val As String
) As String
public:
String^ getAttrVal(
    String^ val
)
member getAttrVal :
        val : string -> string

Parameters

val String

[Missing <param name="val"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.getAttrVal(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.getAttrVal(System.String)"]

See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs.getStringParameters Method

TopBomIniHelperAttributeQsgetStringParameters Method

Restituisce la stringa con i parametri dell'attributo "-name nome -indent ..."

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string getStringParameters()
Public Function getStringParameters As String
public:
String^ getStringParameters()
member getStringParameters : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.getStringParameters"]

See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.AttributeQs.getStringVals Method

TopBomIniHelperAttributeQsgetStringVals Method

Restituisce la stringa con i valori dell'attributo separati da ,

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string getStringVals()
Public Function getStringVals As String
public:
String^ getStringVals()
member getStringVals : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.AttributeQs.getStringVals"]

See Also

Reference

TopBomIniHelperAttributeQs Class


TopBomIniHelper.BomQs Class

TopBomIniHelperBomQs Class

''' Classe che getisce il file INI '''
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsTopBomIniHelperBomQs

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class BomQs
Public Class BomQs
public ref class BomQs
type BomQs = class end

The TopBomIniHelperBomQs type exposes the following members.

Constructors
 | Name | Description
Public method | TopBomIniHelperBomQs | Initializes a new instance of the TopBomIniHelperBomQs class
Top
Methods
 | Name | Description
Public method | addBom | Aggiunge una distinta alla lista delle distinte e tutti i suoi parametri
Public method | addFilters | Aggiunge i filtri al dizionario
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExistDistintaBom |
Public method | ExistDistintaName |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | getAllDistinte |
Public method | getAllFilters |
Public method | getDistinte |
Public method | getFilters |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | getPath |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | setDistinte |
Public method | setFilters |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | writeFileINI | Scrittura del file INI
Top
See Also

Reference

QsInformatica.Utils Namespace


TopBomIniHelper.BomQs Constructor

TopBomIniHelperBomQs Constructor

Initializes a new instance of the TopBomIniHelperBomQs class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public BomQs(
    TopBomIniHelperManagementINI ini
)
Public Sub New (
    ini As TopBomIniHelperManagementINI
)
public:
BomQs(
    TopBomIniHelperManagementINI^ ini
)
new :
        ini : TopBomIniHelperManagementINI -> BomQs

Parameters

ini TopBomIniHelperManagementINI

[Missing <param name="ini"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.#ctor(QsInformatica.Utils.TopBomIniHelper.ManagementINI)"]

See Also

Reference

TopBomIniHelperBomQs Class


BomQs Methods

The TopBomIniHelperBomQs type exposes the following members.

Methods
 | Name | Description
Public method | addBom | Aggiunge una distinta alla lista delle distinte e tutti i suoi parametri
Public method | addFilters | Aggiunge i filtri al dizionario
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExistDistintaBom |
Public method | ExistDistintaName |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | getAllDistinte |
Public method | getAllFilters |
Public method | getDistinte |
Public method | getFilters |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | getPath |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | setDistinte |
Public method | setFilters |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | writeFileINI | Scrittura del file INI
Top
See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.addBom Method

TopBomIniHelperBomQsaddBom Method

Aggiunge una distinta alla lista delle distinte e tutti i suoi parametri

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void addBom(
    string section
)
Public Sub addBom (
    section As String
)
public:
void addBom(
    String^ section
)
member addBom :
        section : string -> unit

Parameters

section String
sezione relativa alla distinta nel file INI
See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.addFilters Method

TopBomIniHelperBomQsaddFilters Method

Aggiunge i filtri al dizionario

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void addFilters(
    string section
)
Public Sub addFilters (
    section As String
)
public:
void addFilters(
    String^ section
)
member addFilters :
        section : string -> unit

Parameters

section String
sezione relativa ai filtri nel file INI
See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.ExistDistintaBom Method

TopBomIniHelperBomQsExistDistintaBom Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaBom(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ExistDistintaBom(
    TopBomIniHelperDistinta dist,
    string bom
)
Public Function ExistDistintaBom (
    dist As TopBomIniHelperDistinta,
    bom As String
) As Boolean
public:
bool ExistDistintaBom(
    TopBomIniHelperDistinta^ dist,
    String^ bom
)
member ExistDistintaBom :
        dist : TopBomIniHelperDistinta *
        bom : string -> bool

Parameters

dist TopBomIniHelperDistinta

[Missing <param name="dist"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaBom(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

bom String

[Missing <param name="bom"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaBom(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaBom(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.ExistDistintaName Method

TopBomIniHelperBomQsExistDistintaName Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaName(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool ExistDistintaName(
    TopBomIniHelperDistinta dist,
    string name
)
Public Function ExistDistintaName (
    dist As TopBomIniHelperDistinta,
    name As String
) As Boolean
public:
bool ExistDistintaName(
    TopBomIniHelperDistinta^ dist,
    String^ name
)
member ExistDistintaName :
        dist : TopBomIniHelperDistinta *
        name : string -> bool

Parameters

dist TopBomIniHelperDistinta

[Missing <param name="dist"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaName(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaName(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.ExistDistintaName(QsInformatica.Utils.TopBomIniHelper.Distinta,System.String)"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.getAllDistinte Method

TopBomIniHelperBomQsgetAllDistinte Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getAllDistinte"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<TopBomIniHelperDistinta> getAllDistinte()
Public Function getAllDistinte As List(Of TopBomIniHelperDistinta)
public:
List<TopBomIniHelperDistinta^>^ getAllDistinte()
member getAllDistinte : unit -> List<TopBomIniHelperDistinta>

Return Value

List TopBomIniHelperDistinta

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getAllDistinte"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.getAllFilters Method

TopBomIniHelperBomQsgetAllFilters Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getAllFilters"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> getAllFilters()
Public Function getAllFilters As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ getAllFilters()
member getAllFilters : unit -> Dictionary<string, string>

Return Value

Dictionary String, String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getAllFilters"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.getDistinte Method

TopBomIniHelperBomQsgetDistinte Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getDistinte"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<TopBomIniHelperDistinta> getDistinte()
Public Function getDistinte As List(Of TopBomIniHelperDistinta)
public:
List<TopBomIniHelperDistinta^>^ getDistinte()
member getDistinte : unit -> List<TopBomIniHelperDistinta>

Return Value

List TopBomIniHelperDistinta

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getDistinte"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.getFilters Method

TopBomIniHelperBomQsgetFilters Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getFilters"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> getFilters()
Public Function getFilters As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ getFilters()
member getFilters : unit -> Dictionary<string, string>

Return Value

Dictionary String, String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getFilters"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.getPath Method

TopBomIniHelperBomQsgetPath Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getPath"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string getPath()
Public Function getPath As String
public:
String^ getPath()
member getPath : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.getPath"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.setDistinte Method

TopBomIniHelperBomQssetDistinte Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.setDistinte(System.Collections.Generic.List{QsInformatica.Utils.TopBomIniHelper.Distinta})"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void setDistinte(
    List<TopBomIniHelperDistinta> lst
)
Public Sub setDistinte (
    lst As List(Of TopBomIniHelperDistinta)
)
public:
void setDistinte(
    List<TopBomIniHelperDistinta^>^ lst
)
member setDistinte :
        lst : List<TopBomIniHelperDistinta> -> unit

Parameters

lst List TopBomIniHelperDistinta

[Missing <param name="lst"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.setDistinte(System.Collections.Generic.List{QsInformatica.Utils.TopBomIniHelper.Distinta})"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.setFilters Method

TopBomIniHelperBomQssetFilters Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.setFilters(System.Collections.Generic.Dictionary{System.String,System.String})"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void setFilters(
    Dictionary<string, string> dict
)
Public Sub setFilters (
    dict As Dictionary(Of String, String)
)
public:
void setFilters(
    Dictionary<String^, String^>^ dict
)
member setFilters :
        dict : Dictionary<string, string> -> unit

Parameters

dict Dictionary String, String

[Missing <param name="dict"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.BomQs.setFilters(System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.BomQs.writeFileINI Method

TopBomIniHelperBomQswriteFileINI Method

Scrittura del file INI

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void writeFileINI(
    TopBomIniHelperBomQs bomToWrite
)
Public Sub writeFileINI (
    bomToWrite As TopBomIniHelperBomQs
)
public:
void writeFileINI(
    TopBomIniHelperBomQs^ bomToWrite
)
member writeFileINI :
        bomToWrite : TopBomIniHelperBomQs -> unit

Parameters

bomToWrite TopBomIniHelperBomQs
Oggetto Bom da scrivere sul file
See Also

Reference

TopBomIniHelperBomQs Class


TopBomIniHelper.Distinta Class

TopBomIniHelperDistinta Class

Classe Distinta
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsTopBomIniHelperDistinta

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class Distinta
Public Class Distinta
public ref class Distinta
type Distinta = class end

The TopBomIniHelperDistinta type exposes the following members.

Constructors
 | Name | Description
Public method | TopBomIniHelperDistinta | Initializes a new instance of the TopBomIniHelperDistinta class
Top
Properties
 | Name | Description
Public property | Attributes |
Public property | Bom |
Public property | Name |
Top
Methods
 | Name | Description
Public method | addAttribute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | getAllAttributeName | Ottiente una lista con tutti gli oggetti Attribute che hanno attrib
Public method | getAttributeValsByName | Ottiene la lista di valori dell'Attribute con nome "name"
Public method | getAttributeWithName | Ottiene l'oggetto Attribute dal suo nome
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | getIndexOfAttributeWithAttribName | Ottiene l'indice del parametro attrib con nome "name"
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


TopBomIniHelper.Distinta Constructor

TopBomIniHelperDistinta Constructor

Initializes a new instance of the TopBomIniHelperDistinta class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Distinta(
    string bom,
    string name
)
Public Sub New (
    bom As String,
    name As String
)
public:
Distinta(
    String^ bom,
    String^ name
)
new :
        bom : string *
        name : string -> Distinta

Parameters

bom String

[Missing <param name="bom"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.#ctor(System.String,System.String)"]

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.#ctor(System.String,System.String)"]

See Also

Reference

TopBomIniHelperDistinta Class


Distinta Properties

The TopBomIniHelperDistinta type exposes the following members.

Properties
 | Name | Description
Public property | Attributes |
Public property | Bom |
Public property | Name |
Top
See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.Attributes Property

TopBomIniHelperDistintaAttributes Property

[Missing <summary> documentation for "P:QsInformatica.Utils.TopBomIniHelper.Distinta.Attributes"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<TopBomIniHelperAttributeQs> Attributes { get; set; }
Public Property Attributes As List(Of TopBomIniHelperAttributeQs)
    Get
    Set
public:
property List<TopBomIniHelperAttributeQs^>^ Attributes {
    List<TopBomIniHelperAttributeQs^>^ get ();
    void set (List<TopBomIniHelperAttributeQs^>^ value);
}
member Attributes : List<TopBomIniHelperAttributeQs> with get, set

Property Value

List TopBomIniHelperAttributeQs
See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.Bom Property

TopBomIniHelperDistintaBom Property

[Missing <summary> documentation for "P:QsInformatica.Utils.TopBomIniHelper.Distinta.Bom"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Bom { get; set; }
Public Property Bom As String
    Get
    Set
public:
property String^ Bom {
    String^ get ();
    void set (String^ value);
}
member Bom : string with get, set

Property Value

String
See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.Name Property

TopBomIniHelperDistintaName Property

[Missing <summary> documentation for "P:QsInformatica.Utils.TopBomIniHelper.Distinta.Name"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
See Also

Reference

TopBomIniHelperDistinta Class


Distinta Methods

The TopBomIniHelperDistinta type exposes the following members.

Methods
 | Name | Description
Public method | addAttribute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | getAllAttributeName | Ottiente una lista con tutti gli oggetti Attribute che hanno attrib
Public method | getAttributeValsByName | Ottiene la lista di valori dell'Attribute con nome "name"
Public method | getAttributeWithName | Ottiene l'oggetto Attribute dal suo nome
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | getIndexOfAttributeWithAttribName | Ottiene l'indice del parametro attrib con nome "name"
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.addAttribute Method

TopBomIniHelperDistintaaddAttribute Method

[Missing <summary> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.addAttribute(QsInformatica.Utils.TopBomIniHelper.AttributeQs)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public void addAttribute(
    TopBomIniHelperAttributeQs att
)
Public Sub addAttribute (
    att As TopBomIniHelperAttributeQs
)
public:
void addAttribute(
    TopBomIniHelperAttributeQs^ att
)
member addAttribute :
        att : TopBomIniHelperAttributeQs -> unit

Parameters

att TopBomIniHelperAttributeQs

[Missing <param name="att"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.addAttribute(QsInformatica.Utils.TopBomIniHelper.AttributeQs)"]

See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.getAllAttributeName Method

TopBomIniHelperDistintagetAllAttributeName Method

Ottiente una lista con tutti gli oggetti Attribute che hanno attrib

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<TopBomIniHelperAttributeQs> getAllAttributeName()
Public Function getAllAttributeName As List(Of TopBomIniHelperAttributeQs)
public:
List<TopBomIniHelperAttributeQs^>^ getAllAttributeName()
member getAllAttributeName : unit -> List<TopBomIniHelperAttributeQs>

Return Value

List TopBomIniHelperAttributeQs

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getAllAttributeName"]

See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.getAttributeValsByName Method

TopBomIniHelperDistintagetAttributeValsByName Method

Ottiene la lista di valori dell'Attribute con nome "name"

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> getAttributeValsByName(
    string name
)
Public Function getAttributeValsByName (
    name As String
) As List(Of String)
public:
List<String^>^ getAttributeValsByName(
    String^ name
)
member getAttributeValsByName :
        name : string -> List<string>

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getAttributeValsByName(System.String)"]

Return Value

List String

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getAttributeValsByName(System.String)"]

See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.getAttributeWithName Method

TopBomIniHelperDistintagetAttributeWithName Method

Ottiene l'oggetto Attribute dal suo nome

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public TopBomIniHelperAttributeQs getAttributeWithName(
    string name
)
Public Function getAttributeWithName (
    name As String
) As TopBomIniHelperAttributeQs
public:
TopBomIniHelperAttributeQs^ getAttributeWithName(
    String^ name
)
member getAttributeWithName :
        name : string -> TopBomIniHelperAttributeQs

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getAttributeWithName(System.String)"]

Return Value

TopBomIniHelperAttributeQs

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getAttributeWithName(System.String)"]

See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.Distinta.getIndexOfAttributeWithAttribName Method

TopBomIniHelperDistintagetIndexOfAttributeWithAttribName Method

Ottiene l'indice del parametro attrib con nome "name"

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public int getIndexOfAttributeWithAttribName(
    string name
)
Public Function getIndexOfAttributeWithAttribName (
    name As String
) As Integer
public:
int getIndexOfAttributeWithAttribName(
    String^ name
)
member getIndexOfAttributeWithAttribName :
        name : string -> int

Parameters

name String

[Missing <param name="name"/> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getIndexOfAttributeWithAttribName(System.String)"]

Return Value

Int32

[Missing <returns> documentation for "M:QsInformatica.Utils.TopBomIniHelper.Distinta.getIndexOfAttributeWithAttribName(System.String)"]

See Also

Reference

TopBomIniHelperDistinta Class


TopBomIniHelper.ManagementINI Class

TopBomIniHelperManagementINI Class

[Missing <summary> documentation for "T:QsInformatica.Utils.TopBomIniHelper.ManagementINI"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsTopBomIniHelperManagementINI

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class ManagementINI
Public Class ManagementINI
public ref class ManagementINI
type ManagementINI = class end

The TopBomIniHelperManagementINI type exposes the following members.

Constructors
 | Name | Description
Public method | TopBomIniHelperManagementINI | Costruttore
Top
Properties
 | Name | Description
Public property | Path | Ottiene o imposta la path del file INI
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBomsDefined | Ritorna un dizionario chiave valore della sezione "bom.idx" Un elemento è della forma: (bom_n_, Nome_Distinta)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Estrapola il nome da una chiave key passata come parametro
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadAllSection | Legge tutte le sezioni del file ini
Public method | ReadKey | Legge dal file il valore della chiave specificiata
Public method | ReadSection | Legge tutte le chiavi e i valori di una sezione del file
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteFile | Scrive sul file INI
Top
See Also

Reference

QsInformatica.Utils Namespace


TopBomIniHelper.ManagementINI Constructor

TopBomIniHelperManagementINI Constructor

Costruttore

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public ManagementINI(
    string PathFile
)
Public Sub New (
    PathFile As String
)
public:
ManagementINI(
    String^ PathFile
)
new :
        PathFile : string -> ManagementINI

Parameters

PathFile String
Percoso dove si trova l'INI
See Also

Reference

TopBomIniHelperManagementINI Class


ManagementINI Properties

The TopBomIniHelperManagementINI type exposes the following members.

Properties
 | Name | Description
Public property | Path | Ottiene o imposta la path del file INI
Top
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.Path Property

TopBomIniHelperManagementINIPath Property

Ottiene o imposta la path del file INI

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

String
See Also

Reference

TopBomIniHelperManagementINI Class


ManagementINI Methods

The TopBomIniHelperManagementINI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBomsDefined | Ritorna un dizionario chiave valore della sezione "bom.idx" Un elemento è della forma: (bom_n_, Nome_Distinta)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Estrapola il nome da una chiave key passata come parametro
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadAllSection | Legge tutte le sezioni del file ini
Public method | ReadKey | Legge dal file il valore della chiave specificiata
Public method | ReadSection | Legge tutte le chiavi e i valori di una sezione del file
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteFile | Scrive sul file INI
Top
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.GetBomsDefined Method

TopBomIniHelperManagementINIGetBomsDefined Method

Ritorna un dizionario chiave valore della sezione "bom.idx" Un elemento è della forma: (bom_n_, Nome_Distinta)

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetBomsDefined()
Public Function GetBomsDefined As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetBomsDefined()
member GetBomsDefined : unit -> Dictionary<string, string>

Return Value

Dictionary String, String
On error returns nothing
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.GetName Method

TopBomIniHelperManagementINIGetName Method

Estrapola il nome da una chiave key passata come parametro

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string GetName(
    string Key
)
Public Function GetName (
    Key As String
) As String
public:
String^ GetName(
    String^ Key
)
member GetName :
        Key : string -> string

Parameters

Key String
Chiave da cui estrapolare il nome

Return Value

String
Ritorna il nome della chiave passata come parametro (es. Nome=Valore) torna nome
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.ReadAllSection Method

TopBomIniHelperManagementINIReadAllSection Method

Legge tutte le sezioni del file ini

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList ReadAllSection()
Public Function ReadAllSection As ArrayList
public:
ArrayList^ ReadAllSection()
member ReadAllSection : unit -> ArrayList

Return Value

ArrayList
Ritorna un arraylist con tutte le sezioni contenute nel file
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.ReadKey Method

TopBomIniHelperManagementINIReadKey Method

Legge dal file il valore della chiave specificiata

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string ReadKey(
    string Section,
    string Key
)
Public Function ReadKey (
    Section As String,
    Key As String
) As String
public:
String^ ReadKey(
    String^ Section,
    String^ Key
)
member ReadKey :
        Section : string *
        Key : string -> string

Parameters

Section String
Sezione su cui leggere
Key String
Chiave da leggere

Return Value

String
Il buffer letto
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.ReadSection Method

TopBomIniHelperManagementINIReadSection Method

Legge tutte le chiavi e i valori di una sezione del file

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public ArrayList ReadSection(
    string Section
)
Public Function ReadSection (
    Section As String
) As ArrayList
public:
ArrayList^ ReadSection(
    String^ Section
)
member ReadSection :
        Section : string -> ArrayList

Parameters

Section String
Sezione da leggere

Return Value

ArrayList
Restituisce un arraylist contenente il tutto le chiavi e i valori della sezione
See Also

Reference

TopBomIniHelperManagementINI Class


TopBomIniHelper.ManagementINI.WriteFile Method

TopBomIniHelperManagementINIWriteFile Method

Scrive sul file INI

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool WriteFile(
    string Section,
    string Key,
    string Value
)
Public Function WriteFile (
    Section As String,
    Key As String,
    Value As String
) As Boolean
public:
bool WriteFile(
    String^ Section,
    String^ Key,
    String^ Value
)
member WriteFile :
        Section : string *
        Key : string *
        Value : string -> bool

Parameters

Section String
Sezione su cui scrivere (se non esiste viene creata)
Key String
Chiave da scrivere (se non esiste viene creata (altrimenti sovrascritta))
Value String
Valore da inserire

Return Value

Boolean
True in caso di successo, False altrimenti
See Also

Reference

TopBomIniHelperManagementINI Class


Util Class

[Missing <summary> documentation for "T:QsInformatica.Utils.Util"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsUtil

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class Util
Public NotInheritable Class Util
public ref class Util abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Util = class end

The Util type exposes the following members.

Methods
Name | Description
CheckForInternetConnection | Ritorna True se c'è connessione a internet, False altrimenti. Per verificare la connessione si basa che la pagina "http://google.com" sia raggiungibile.
DwmIsCompositionEnabled | Metodo per leggere se è attivo il tema aero.
FilesAreEquals | Normalizza il nome dei file e li confronta.
GetEncoding | Determines a text file's encoding by analyzing its byte order mark (BOM). Defaults to ASCII when detection of the text file's endianness fails.
SendDumpQs | Funzione che crea i file e invia il dump alla qs.
TranslateText | Traduce il testo utilizzando 'Microsoft Translator'. Genera eccezione nel caso in cui non ci sia connessione a internet.
UncNormalize | Risolve un percorso file prendendo i primi 2 caratteri (cioè l'unità del drive) con il corrispondente percorso di rete. Se non riesce restituisce lo stesso percorso ricevuto come parametro.
WNetGetConnection |
Top
See Also

Reference

QsInformatica.Utils Namespace


Util Methods

The Util type exposes the following members.

Methods
Name | Description
CheckForInternetConnection | Ritorna True se c'è connessione a internet, False altrimenti. Per verificare la connessione si basa che la pagina "http://google.com" sia raggiungibile.
DwmIsCompositionEnabled | Metodo per leggere se è attivo il tema aero.
FilesAreEquals | Normalizza il nome dei file e li confronta.
GetEncoding | Determines a text file's encoding by analyzing its byte order mark (BOM). Defaults to ASCII when detection of the text file's endianness fails.
SendDumpQs | Funzione che crea i file e invia il dump alla qs.
TranslateText | Traduce il testo utilizzando 'Microsoft Translator'. Genera eccezione nel caso in cui non ci sia connessione a internet.
UncNormalize | Risolve un percorso file prendendo i primi 2 caratteri (cioè l'unità del drive) con il corrispondente percorso di rete. Se non riesce restituisce lo stesso percorso ricevuto come parametro.
WNetGetConnection |
Top
See Also

Reference

Util Class


Util.CheckForInternetConnection Method

UtilCheckForInternetConnection Method

Ritorna True se c'è connessione a internet, False altrimenti. Per verificare la connessione si basa che la pagina "http://google.com" sia raggiungibile.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static bool CheckForInternetConnection()
Public Shared Function CheckForInternetConnection As Boolean
public:
static bool CheckForInternetConnection()
static member CheckForInternetConnection : unit -> bool

Return Value

Boolean

[Missing <returns> documentation for "M:QsInformatica.Utils.Util.CheckForInternetConnection"]

See Also

Reference

Util Class


Util.DwmIsCompositionEnabled Method

UtilDwmIsCompositionEnabled Method

Metodo per leggere se è attivo il tema aero.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static int DwmIsCompositionEnabled(
    out bool enabled
)
Public Shared Function DwmIsCompositionEnabled (
    <OutAttribute> ByRef enabled As Boolean
) As Integer
public:
static int DwmIsCompositionEnabled(
    [OutAttribute] bool% enabled
)
static member DwmIsCompositionEnabled :
        enabled : bool byref -> int

Parameters

enabled Boolean

[Missing <param name="enabled"/> documentation for "M:QsInformatica.Utils.Util.DwmIsCompositionEnabled(System.Boolean@)"]

Return Value

Int32

[Missing <returns> documentation for "M:QsInformatica.Utils.Util.DwmIsCompositionEnabled(System.Boolean@)"]

See Also

Reference

Util Class


Util.FilesAreEquals Method

UtilFilesAreEquals Method

Normalizza il nome dei file e li confronta.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static bool FilesAreEquals(
    string fileA,
    string fileB
)
Public Shared Function FilesAreEquals (
    fileA As String,
    fileB As String
) As Boolean
public:
static bool FilesAreEquals(
    String^ fileA,
    String^ fileB
)
static member FilesAreEquals :
        fileA : string *
        fileB : string -> bool

Parameters

fileA String
Primo file da comparare.
fileB String
Secondo file da comparare.

Return Value

Boolean
Restitusice true se sono uguali altrimenti false.
See Also

Reference

Util Class


Util.GetEncoding Method

UtilGetEncoding Method

Determines a text file's encoding by analyzing its byte order mark (BOM). Defaults to ASCII when detection of the text file's endianness fails.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static Encoding GetEncoding(
    string filename
)
Public Shared Function GetEncoding (
    filename As String
) As Encoding
public:
static Encoding^ GetEncoding(
    String^ filename
)
static member GetEncoding :
        filename : string -> Encoding

Parameters

filename String
The text file to analyze.

Return Value

Encoding
The detected encoding.
See Also

Reference

Util Class


Util.SendDumpQs Method

UtilSendDumpQs Method

Funzione che crea i file e invia il dump alla qs.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void SendDumpQs(
    UnhandledExceptionEventArgs e,
    bool silent
)
Public Shared Sub SendDumpQs (
    e As UnhandledExceptionEventArgs,
    silent As Boolean
)
public:
static void SendDumpQs(
    UnhandledExceptionEventArgs^ e,
    bool silent
)
static member SendDumpQs :
        e : UnhandledExceptionEventArgs *
        silent : bool -> unit

Parameters

e UnhandledExceptionEventArgs
Eccezione che ha causato il crash dell'applicativo.
silent Boolean
Indica se la mail viene mandata in modo silent o con interazione utente.
See Also

Reference

Util Class


Util.TranslateText Method

UtilTranslateText Method

Traduce il testo utilizzando 'Microsoft Translator'. Genera eccezione nel caso in cui non ci sia connessione a internet.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string TranslateText(
    string inputText,
    string fromLanguage,
    string toLanguage
)
Public Shared Function TranslateText (
    inputText As String,
    fromLanguage As String,
    toLanguage As String
) As String
public:
static String^ TranslateText(
    String^ inputText,
    String^ fromLanguage,
    String^ toLanguage
)
static member TranslateText :
        inputText : string *
        fromLanguage : string *
        toLanguage : string -> string

Parameters

inputText String
Testo da tradurre.
fromLanguage String
Codice della lingua di partenza ('it', 'it-it', ecc..).
toLanguage String
Codice della lingua di destinazione ('en, 'de', ecc..).

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.Util.TranslateText(System.String,System.String,System.String)"]

See Also

Reference

Util Class


Util.UncNormalize Method

UtilUncNormalize Method

Risolve un percorso file prendendo i primi 2 caratteri (cioè l'unità del drive) con il corrispondente percorso di rete. Se non riesce restituisce lo stesso percorso ricevuto come parametro.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string UncNormalize(
    string fileName
)
Public Shared Function UncNormalize (
    fileName As String
) As String
public:
static String^ UncNormalize(
    String^ fileName
)
static member UncNormalize :
        fileName : string -> string

Parameters

fileName String
Nome file completo di unità di rete.

Return Value

String
Restituisce il nome file completo normalizzato.
See Also

Reference

Util Class


Util.WNetGetConnection Method

UtilWNetGetConnection Method

[Missing <summary> documentation for "M:QsInformatica.Utils.Util.WNetGetConnection(System.String,System.Text.StringBuilder,System.Int32@)"]

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static int WNetGetConnection(
    string localName,
    StringBuilder remoteName,
    ref int length
)
Public Shared Function WNetGetConnection (
    localName As String,
    remoteName As StringBuilder,
    ByRef length As Integer
) As Integer
public:
static int WNetGetConnection(
    String^ localName,
    StringBuilder^ remoteName,
    int% length
)
static member WNetGetConnection :
        localName : string *
        remoteName : StringBuilder *
        length : int byref -> int

Parameters

localName String

[Missing <param name="localName"/> documentation for "M:QsInformatica.Utils.Util.WNetGetConnection(System.String,System.Text.StringBuilder,System.Int32@)"]

remoteName StringBuilder

[Missing <param name="remoteName"/> documentation for "M:QsInformatica.Utils.Util.WNetGetConnection(System.String,System.Text.StringBuilder,System.Int32@)"]

length Int32

[Missing <param name="length"/> documentation for "M:QsInformatica.Utils.Util.WNetGetConnection(System.String,System.Text.StringBuilder,System.Int32@)"]

Return Value

Int32

[Missing <returns> documentation for "M:QsInformatica.Utils.Util.WNetGetConnection(System.String,System.Text.StringBuilder,System.Int32@)"]

See Also

Reference

Util Class


Util.MarshalHelper Class

UtilMarshalHelper Class

[Missing <summary> documentation for "T:QsInformatica.Utils.Util.MarshalHelper"]

Inheritance Hierarchy
SystemObject
QsInformatica.UtilsUtilMarshalHelper

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class MarshalHelper
Public Class MarshalHelper
public ref class MarshalHelper
type MarshalHelper = class end

The UtilMarshalHelper type exposes the following members.

Constructors
 | Name | Description
Public method | UtilMarshalHelper | Initializes a new instance of the UtilMarshalHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | GetActiveObject | Obtains a running instance of the specified object from the running object table (ROT).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsInformatica.Utils Namespace


Util.MarshalHelper Constructor

UtilMarshalHelper Constructor

Initializes a new instance of the UtilMarshalHelper class

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public MarshalHelper()
Public Sub New
public:
MarshalHelper()
new : unit -> MarshalHelper
See Also

Reference

UtilMarshalHelper Class


MarshalHelper Methods

The UtilMarshalHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | GetActiveObject | Obtains a running instance of the specified object from the running object table (ROT).
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UtilMarshalHelper Class


Util.MarshalHelper.GetActiveObject Method

UtilMarshalHelperGetActiveObject Method

Obtains a running instance of the specified object from the running object table (ROT).

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static Object GetActiveObject(
    string progId,
    bool throwOnError = false
)
Public Shared Function GetActiveObject (
    progId As String,
    Optional throwOnError As Boolean = false
) As Object
public:
static Object^ GetActiveObject(
    String^ progId,
    bool throwOnError = false
)
static member GetActiveObject :
        progId : string *
        ?throwOnError : bool
(* Defaults:
        let _throwOnError = defaultArg throwOnError false
*)
-> Object

Parameters

progId String
The programmatic identifier (ProgID) of the object that was requested.
throwOnError Boolean (Optional)

[Missing <param name="throwOnError"/> documentation for "M:QsInformatica.Utils.Util.MarshalHelper.GetActiveObject(System.String,System.Boolean)"]

Return Value

Object
The object that was requested; otherwise null.
Exceptions
Exception | Condition
ArgumentNullException |
Remarks
Implementation of [Marshal.GetActiveObject](https://learn.microsoft.com/it-it/dotnet/api/system.runtime.interopservices.marshal.getactiveobject?view=netframework-4.8#system-runtime-interopservices-marshal-getactiveobject(system-string)) that works for .NET core 3.1+ on Windows. Source: https://stackoverflow.com/a/64826127
See Also

Reference

UtilMarshalHelper Class


Util.Thumbnail Class

UtilThumbnail Class

Classe usata per ricavare l'anteprima di un file.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsUtilThumbnail

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class Thumbnail
Public NotInheritable Class Thumbnail
public ref class Thumbnail abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Thumbnail = class end

The UtilThumbnail type exposes the following members.

Methods
Name | Description
GetThumbnail | Costruttore.
ResizeImage | Ridimensiona l'immagine passata secondo la larghezza e l'altezza specificate.
Top
See Also

Reference

QsInformatica.Utils Namespace


Thumbnail Methods

The UtilThumbnail type exposes the following members.

Methods
Name | Description
GetThumbnail | Costruttore.
ResizeImage | Ridimensiona l'immagine passata secondo la larghezza e l'altezza specificate.
Top
See Also

Reference

UtilThumbnail Class


Util.Thumbnail.GetThumbnail Method

UtilThumbnailGetThumbnail Method

Costruttore.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static Image GetThumbnail(
    string file,
    int width,
    int height,
    bool throwEx
)
Public Shared Function GetThumbnail (
    file As String,
    width As Integer,
    height As Integer,
    throwEx As Boolean
) As Image
public:
static Image^ GetThumbnail(
    String^ file,
    int width,
    int height,
    bool throwEx
)
static member GetThumbnail :
        file : string *
        width : int *
        height : int *
        throwEx : bool -> Image

Parameters

file String
File di cui ricavare l'anteprima.
width Int32
Larghezza desiderata del preview (solo file inventor).
height Int32
Altezza desiderata del preview (solo file inventor).
throwEx Boolean
Indica se rilanciare l'eccezione o loggarla e basta

Return Value

Image

[Missing <returns> documentation for "M:QsInformatica.Utils.Util.Thumbnail.GetThumbnail(System.String,System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

UtilThumbnail Class


Util.Thumbnail.ResizeImage Method

UtilThumbnailResizeImage Method

Ridimensiona l'immagine passata secondo la larghezza e l'altezza specificate.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static Image ResizeImage(
    Image imgPhoto,
    int width,
    int height
)
Public Shared Function ResizeImage (
    imgPhoto As Image,
    width As Integer,
    height As Integer
) As Image
public:
static Image^ ResizeImage(
    Image^ imgPhoto,
    int width,
    int height
)
static member ResizeImage :
        imgPhoto : Image *
        width : int *
        height : int -> Image

Parameters

imgPhoto Image
L'immagine sorgente.
width Int32
La larghezza da impostare.
height Int32
L'altezza da impostare.

Return Value

Image
L'oggetto Image modificato secondo i parametri passati.
See Also

Reference

UtilThumbnail Class


XMX Class

Modulo per la lettura dei file xmx per la localizzazione delle stringhe.
Inheritance Hierarchy
SystemObject
QsInformatica.UtilsXMX

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public class XMX
Public Class XMX
public ref class XMX
type XMX = class end

The XMX type exposes the following members.

Constructors
 | Name | Description
Public method | XMX | Costruttore senza argomenti.
Public method | XMX(String) | Costruttore con nome file.
Public method | XMX(String, String) | Costruttore con nome file completo di percorso.
Top
Properties
 | Name | Description
Public property | Dizionario | Restituisce il dizionario delle stringhe indicizzate.
Public property | FileName | Restituisce il nome del file .xmx utilizzato per il caricamento delle stringhe localizzate.
Public property | FullFileName | Restituisce il nome del file xmx, completo di percorso, utilizzato per il caricamento delle stringhe localizzate.
Public property | Path | Restituisce il percorso nel quale è stato caricato il file xmx utilizzato per il caricamento delle stringhe localizzate.
Top
Methods
 | Name | Description
 | CheckSum | Funzione per il calcolo dell'hash della stringa
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLastError | Restituisce la stringa descrivente l'ultimo errore avvenuto. Può essere una stringa vuota "".
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IMSG | Restituisce il messaggio localizzato.
Public method | Load | Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto. Per la trasformazione da array di byte a stringa viene utilizzato l'encoding 1252.
Public method | Load(Encoding) | Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto, utilizzando un particolare Encoding.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Usare la funzione IMSG, all'interno dei sorgenti, per racchiudere le costanti stringa che devono essere tradotte.
See Also

Reference

QsInformatica.Utils Namespace


XMX Constructor

Overload List
 | Name | Description
Public method | XMX | Costruttore senza argomenti.
Public method | XMX(String) | Costruttore con nome file.
Public method | XMX(String, String) | Costruttore con nome file completo di percorso.
Top
See Also

Reference

XMX Class


XMX Constructor

Costruttore senza argomenti.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public XMX()
Public Sub New
public:
XMX()
new : unit -> XMX
Remarks
Cerca un file con nome 'messages.xmx' affianco all'assembly chiamante (eseguibile o modulo che sia), poi nei percorsi dei file comuni (\File comuni\qs\messages.xmx), ed inizializza il dizionario interno con tale file. Se il file non esiste non viene sollevata alcuna eccezione, sarà il metodo Load() ad effettuare i controlli ed eventualmente restituire Fase.
See Also

Reference

XMX Class
XMX Overload


XMX(String) Constructor

Costruttore con nome file.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public XMX(
    string FileName
)
Public Sub New (
    FileName As String
)
public:
XMX(
    String^ FileName
)
new :
        FileName : string -> XMX

Parameters

FileName String
Nome file, avente estensione .xmx, da utilizzare per il caricamento.
Remarks
Il file viene prima cercato affianco all'assembly (eseguibile o modulo che sia), poi nella cartella dei file comuni (\File comuni\qs\'FileName'). Se il file non esiste non viene sollevata alcuna eccezione, sarà il metodo Load() ad effettuare i controlli ed eventualmente restituire Fase.
See Also

Reference

XMX Class
XMX Overload


XMX(String, String) Constructor

Costruttore con nome file completo di percorso.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public XMX(
    string FilePath,
    string FileName
)
Public Sub New (
    FilePath As String,
    FileName As String
)
public:
XMX(
    String^ FilePath,
    String^ FileName
)
new :
        FilePath : string *
        FileName : string -> XMX

Parameters

FilePath String
Percorso nel quale caricare il file xmx.
FileName String
Nome file, avente estensione .xmx, da utilizzare per il caricamento.
Remarks
Se il file non esiste non viene sollevata alcuna eccezione, sarà il metodo Load() ad effettuare i controlli ed eventualmente restituire Fase.
See Also

Reference

XMX Class
XMX Overload


XMX Properties

The XMX type exposes the following members.

Properties
 | Name | Description
Public property | Dizionario | Restituisce il dizionario delle stringhe indicizzate.
Public property | FileName | Restituisce il nome del file .xmx utilizzato per il caricamento delle stringhe localizzate.
Public property | FullFileName | Restituisce il nome del file xmx, completo di percorso, utilizzato per il caricamento delle stringhe localizzate.
Public property | Path | Restituisce il percorso nel quale è stato caricato il file xmx utilizzato per il caricamento delle stringhe localizzate.
Top
See Also

Reference

XMX Class


XMX.Dizionario Property

XMXDizionario Property

Restituisce il dizionario delle stringhe indicizzate.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<uint, string> Dizionario { get; }
Public ReadOnly Property Dizionario As Dictionary(Of UInteger, String)
    Get
public:
property Dictionary<unsigned int, String^>^ Dizionario {
    Dictionary<unsigned int, String^>^ get ();
}
member Dizionario : Dictionary<uint32, string> with get

Property Value

Dictionary UInt32, String
See Also

Reference

XMX Class


XMX.FileName Property

XMXFileName Property

Restituisce il nome del file .xmx utilizzato per il caricamento delle stringhe localizzate.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

String
See Also

Reference

XMX Class


XMX.FullFileName Property

XMXFullFileName Property

Restituisce il nome del file xmx, completo di percorso, utilizzato per il caricamento delle stringhe localizzate.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Property Value

String
See Also

Reference

XMX Class


XMX.Path Property

XMXPath Property

Restituisce il percorso nel quale è stato caricato il file xmx utilizzato per il caricamento delle stringhe localizzate.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

String
See Also

Reference

XMX Class


XMX Methods

The XMX type exposes the following members.

Methods
 | Name | Description
 | CheckSum | Funzione per il calcolo dell'hash della stringa
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLastError | Restituisce la stringa descrivente l'ultimo errore avvenuto. Può essere una stringa vuota "".
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IMSG | Restituisce il messaggio localizzato.
Public method | Load | Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto. Per la trasformazione da array di byte a stringa viene utilizzato l'encoding 1252.
Public method | Load(Encoding) | Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto, utilizzando un particolare Encoding.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

XMX Class


XMX.CheckSum Method

XMXCheckSum Method

Funzione per il calcolo dell'hash della stringa

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static uint CheckSum(
    string str
)
Public Shared Function CheckSum (
    str As String
) As UInteger
public:
static unsigned int CheckSum(
    String^ str
)
static member CheckSum :
        str : string -> uint32

Parameters

str String

[Missing <param name="str"/> documentation for "M:QsInformatica.Utils.XMX.CheckSum(System.String)"]

Return Value

UInt32

[Missing <returns> documentation for "M:QsInformatica.Utils.XMX.CheckSum(System.String)"]

See Also

Reference

XMX Class


XMX.GetLastError Method

XMXGetLastError Method

Restituisce la stringa descrivente l'ultimo errore avvenuto. Può essere una stringa vuota "".

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string GetLastError()
Public Function GetLastError As String
public:
String^ GetLastError()
member GetLastError : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.XMX.GetLastError"]

See Also

Reference

XMX Class


XMX.IMSG Method

XMXIMSG Method

Restituisce il messaggio localizzato.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public string IMSG(
    string strMessage
)
Public Function IMSG (
    strMessage As String
) As String
public:
String^ IMSG(
    String^ strMessage
)
member IMSG :
        strMessage : string -> string

Parameters

strMessage String
Stringa in italiano, che deve essere tradotta.

Return Value

String

[Missing <returns> documentation for "M:QsInformatica.Utils.XMX.IMSG(System.String)"]

See Also

Reference

XMX Class


XMX.Load Method

XMXLoad Method

Overload List
 | Name | Description
Public method | Load | Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto. Per la trasformazione da array di byte a stringa viene utilizzato l'encoding 1252.
Public method | Load(Encoding) | Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto, utilizzando un particolare Encoding.
Top
See Also

Reference

XMX Class


XMX.Load Method

XMXLoad Method

Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto. Per la trasformazione da array di byte a stringa viene utilizzato l'encoding 1252.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Load()
Public Function Load As Boolean
public:
bool Load()
member Load : unit -> bool

Return Value

Boolean
Restituisce True se la lettura del file avviene correttamente. Se viene restituito False, per ottenere le informazioni di errore, chiamare il metodo GetLastError().
See Also

Reference

XMX Class
Load Overload


XMX.Load(Encoding) Method

XMXLoad(Encoding) Method

Carica in memoria i messaggi presenti nel file .xmx con il quale si è inizializzato l'oggetto, utilizzando un particolare Encoding.

Namespace: QsInformatica.Utils
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public bool Load(
    Encoding encoding
)
Public Function Load (
    encoding As Encoding
) As Boolean
public:
bool Load(
    Encoding^ encoding
)
member Load :
        encoding : Encoding -> bool

Parameters

encoding Encoding
Oggetto System.Text.Encoding da utilizzare per la lettura del file .xmx contenente i messaggi tradotti.

Return Value

Boolean
Restituisce True se la lettura del file avviene correttamente. Se viene restituito False, per ottenere le informazioni di errore, chiamare il metodo GetLastError().
See Also

Reference

XMX Class
Load Overload


QsInformatica.Utils.src Namespace

[Missing <summary> documentation for "N:QsInformatica.Utils.src"]

Classes
 | Class | Description
Public class | StartupHelper | Improve applications startup time (require Framework > 4.5)


StartupHelper Class

Improve applications startup time (require Framework > 4.5)
Inheritance Hierarchy
SystemObject
QsInformatica.Utils.srcStartupHelper

Namespace: QsInformatica.Utils.src
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static class StartupHelper
Public NotInheritable Class StartupHelper
public ref class StartupHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StartupHelper = class end

The StartupHelper type exposes the following members.

Properties
Name | Description
ApplicationDataPath | Gets the application data path.
Top
Methods
Name | Description
ActivateMultiCoreJit | Activates the multi core JIT introduced in .NET 4.5. The profile is stored in the AppCache sub folder of the assembly location. For more information see .
GetApplicationDataPath | Gets the application data path.
Top
See Also

Reference

QsInformatica.Utils.src Namespace


StartupHelper Properties

The StartupHelper type exposes the following members.

Properties
Name | Description
ApplicationDataPath | Gets the application data path.
Top
See Also

Reference

StartupHelper Class
QsInformatica.Utils.src Namespace


StartupHelper.ApplicationDataPath Property

StartupHelperApplicationDataPath Property

Gets the application data path.

Namespace: QsInformatica.Utils.src
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string ApplicationDataPath { get; }
Public Shared ReadOnly Property ApplicationDataPath As String
    Get
public:
static property String^ ApplicationDataPath {
    String^ get ();
}
static member ApplicationDataPath : string with get

Property Value

String
The application data path.
See Also

Reference

StartupHelper Class
QsInformatica.Utils.src Namespace


StartupHelper Methods

The StartupHelper type exposes the following members.

Methods
Name | Description
ActivateMultiCoreJit | Activates the multi core JIT introduced in .NET 4.5. The profile is stored in the AppCache sub folder of the assembly location. For more information see .
GetApplicationDataPath | Gets the application data path.
Top
See Also

Reference

StartupHelper Class
QsInformatica.Utils.src Namespace


StartupHelper.ActivateMultiCoreJit Method

StartupHelperActivateMultiCoreJit Method

Activates the multi core JIT introduced in .NET 4.5. The profile is stored in the AppCache sub folder of the assembly location. For more information see .

Namespace: QsInformatica.Utils.src
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static void ActivateMultiCoreJit(
    string profileName
)
Public Shared Sub ActivateMultiCoreJit (
    profileName As String
)
public:
static void ActivateMultiCoreJit(
    String^ profileName
)
static member ActivateMultiCoreJit :
        profileName : string -> unit

Parameters

profileName String

[Missing <param name="profileName"/> documentation for "M:QsInformatica.Utils.src.StartupHelper.ActivateMultiCoreJit(System.String)"]

See Also

Reference

StartupHelper Class
QsInformatica.Utils.src Namespace
[!:http://blogs.msdn.com/b/dotnet/archive/2012/10/18/an-easy-solution-for-improving-app-launch-performance.aspx]


StartupHelper.GetApplicationDataPath Method

StartupHelperGetApplicationDataPath Method

Gets the application data path.

Namespace: QsInformatica.Utils.src
Assembly: QsInformatica.Utils (in QsInformatica.Utils.dll) Version: 27.1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetApplicationDataPath(
    string subPath
)
Public Shared Function GetApplicationDataPath (
    subPath As String
) As String
public:
static String^ GetApplicationDataPath(
    String^ subPath
)
static member GetApplicationDataPath :
        subPath : string -> string

Parameters

subPath String

[Missing <param name="subPath"/> documentation for "M:QsInformatica.Utils.src.StartupHelper.GetApplicationDataPath(System.String)"]

Return Value

String
System.String.
See Also

Reference

StartupHelper Class
QsInformatica.Utils.src Namespace