InitPrtFast Namespace
Classi
 | Classe | Descrizione
Classe pubblica | ButtonClickedEventArgs |
Classe pubblica | ConnectionLoader |
Classe pubblica | ConnectionProviderManager | Connections manager. Load and initialize all providers
Classe pubblica | ConnectionsEditorControl |
Classe pubblica | InitPrtFast | Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.
Classe pubblica | InitPrtFastElement | Classe che rappreseneta l'oggetto cella.
Classe pubblica | InitPrtFastInitPrtFastCtxMenuCommand | Classe per gestire i comandi personalizzati sul tasto dx.
Classe pubblica | InitPrtFastInitPrtFastCtxMenuCommandList | Lista di oggetti InitPrtFastCtxMenuCommand.
Classe pubblica | InitPrtFastInitPrtFastCtxMenuItemClickEventArgs | Argomento utilizzato durante il click su un menu constestuale personalizzato.
Classe pubblica | InitPrtFastPrtInitSelectionEventArgs | Classe contenente le informazioni per l'evento SelectionChanged.
Classe pubblica | InitPrtFastRow |
Classe pubblica | InitPrtFastRows |
Classe pubblica | InitPrtFastSearchControlCreatedEventArgs | Classe contenente le informazioni per l'evento SearchControlCreated.
Classe pubblica | InitPrtFastConfigForm |
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Classe pubblica | ResetPanelControl | Classe per creare un pannello che contiene [ label + combo ]
Classe pubblica | SearchPanelControl | Classe per creare un pannello che contiene [ label + combo ]
Classe pubblica | Utils |
Classe pubblica | UtilsEncodingConverter | Custom JsonConverter for Encoding
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | InitPrtFastSelectionVisibility | Definizione possibili azioni su oggetti importazione

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ButtonClickedEventArgs

[Manca la documentazione <summary> per "T:InitPrtFast.ButtonClickedEventArgs"]

Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastButtonClickedEventArgs

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ButtonClickedEventArgs : EventArgs
Public Class ButtonClickedEventArgs
    Inherits EventArgs
public ref class ButtonClickedEventArgs : public EventArgs
type ButtonClickedEventArgs =
    class
        inherit EventArgs
    end

Il tipo ButtonClickedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ButtonClickedEventArgs | Inizializza una nuova istanza della classe ButtonClickedEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore ButtonClickedEventArgs
Inizializza una nuova istanza della classe ButtonClickedEventArgs.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ButtonClickedEventArgs(
    IConnection connection
)
Public Sub New (
    connection As IConnection
)
public:
ButtonClickedEventArgs(
    IConnection^ connection
)
new :
        connection : IConnection -> ButtonClickedEventArgs

Parametri

connection IConnection
Vedi anche

Documentazione

Classe ButtonClickedEventArgs
Namespace InitPrtFast


Proprietà di ButtonClickedEventArgs

Il tipo ButtonClickedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection |
Torna su
Vedi anche

Documentazione

Classe ButtonClickedEventArgs
Namespace InitPrtFast


Proprietà ButtonClickedEventArgs.Connection

Libreria query DedNet

Proprietà ButtonClickedEventArgsConnection

[Manca la documentazione <summary> per "P:InitPrtFast.ButtonClickedEventArgs.Connection"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Connection { get; }
Public ReadOnly Property Connection As IConnection
    Get
public:
property IConnection^ Connection {
    IConnection^ get ();
}
member Connection : IConnection with get

Valore della proprietà

IConnection
Vedi anche

Documentazione

Classe ButtonClickedEventArgs
Namespace InitPrtFast


Classe ConnectionLoader

[Manca la documentazione <summary> per "T:InitPrtFast.ConnectionLoader"]

Gerarchia di ereditarietà
SystemObject
InitPrtFastConnectionLoader

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnectionLoader
Public Class ConnectionLoader
public ref class ConnectionLoader
type ConnectionLoader = class end

Il tipo ConnectionLoader espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnectionLoader | Inizializza una nuova istanza della classe ConnectionLoader.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddConnection |
Metodo pubblico | Clear |
Metodo pubblico | CloseConnections |
Metodo pubblico | GetConnection(Int32) |
Metodo pubblico | GetConnection(String) |
Metodo pubblico | GetConnectionDefinitions |
Metodo pubblico | GetConnections |
Metodo pubblico | GetLoadableConnections |
Metodo pubblico | IsLoadableConnection | Check if a connection is loadable or not
Metodo pubblico | LoadConnection | Load a data source connection
Metodo pubblico | RemoveConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore ConnectionLoader
Inizializza una nuova istanza della classe ConnectionLoader.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnectionLoader()
Public Sub New
public:
ConnectionLoader()
new : unit -> ConnectionLoader
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodi di ConnectionLoader

Il tipo ConnectionLoader espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddConnection |
Metodo pubblico | Clear |
Metodo pubblico | CloseConnections |
Metodo pubblico | GetConnection(Int32) |
Metodo pubblico | GetConnection(String) |
Metodo pubblico | GetConnectionDefinitions |
Metodo pubblico | GetConnections |
Metodo pubblico | GetLoadableConnections |
Metodo pubblico | IsLoadableConnection | Check if a connection is loadable or not
Metodo pubblico | LoadConnection | Load a data source connection
Metodo pubblico | RemoveConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Torna su
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.AddConnection

Metodo ConnectionLoaderAddConnection

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.AddConnection(InitPrtFastCommon.Interfaces.IConnection,System.String)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddConnection(
    IConnection connection,
    string path
)
Public Sub AddConnection (
    connection As IConnection,
    path As String
)
public:
void AddConnection(
    IConnection^ connection,
    String^ path
)
member AddConnection :
        connection : IConnection *
        path : string -> unit

Parametri

connection IConnection
path String
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.Clear

Metodo ConnectionLoaderClear

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.Clear"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.CloseConnections

Metodo ConnectionLoaderCloseConnections

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.CloseConnections"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void CloseConnections()
Public Sub CloseConnections
public:
void CloseConnections()
member CloseConnections : unit -> unit
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.GetConnection

Metodo ConnectionLoaderGetConnection
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetConnection(Int32) |
Metodo pubblico | GetConnection(String) |
Torna su
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.GetConnection(Int32)

Metodo ConnectionLoaderGetConnection(Int32)

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.GetConnection(System.Int32)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection GetConnection(
    int idx
)
Public Function GetConnection (
    idx As Integer
) As IConnection
public:
IConnection^ GetConnection(
    int idx
)
member GetConnection :
        idx : int -> IConnection

Parametri

idx Int32

Valore di ritorno

IConnection
Vedi anche

Documentazione

Classe ConnectionLoader
Overload di GetConnection
Namespace InitPrtFast


Metodo ConnectionLoader.GetConnection(String)

Metodo ConnectionLoaderGetConnection(String)

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.GetConnection(System.String)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection GetConnection(
    string name
)
Public Function GetConnection (
    name As String
) As IConnection
public:
IConnection^ GetConnection(
    String^ name
)
member GetConnection :
        name : string -> IConnection

Parametri

name String

Valore di ritorno

IConnection
Vedi anche

Documentazione

Classe ConnectionLoader
Overload di GetConnection
Namespace InitPrtFast


Metodo ConnectionLoader.GetConnectionDefinitions

Metodo ConnectionLoaderGetConnectionDefinitions

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.GetConnectionDefinitions"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable<ConnectionDefinition> GetConnectionDefinitions()
Public Function GetConnectionDefinitions As IEnumerable(Of ConnectionDefinition)
public:
IEnumerable<ConnectionDefinition^>^ GetConnectionDefinitions()
member GetConnectionDefinitions : unit -> IEnumerable<ConnectionDefinition>

Valore di ritorno

IEnumerable ConnectionDefinition
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.GetConnections

Metodo ConnectionLoaderGetConnections

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.GetConnections"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<IConnection> GetConnections()
Public Function GetConnections As List(Of IConnection)
public:
List<IConnection^>^ GetConnections()
member GetConnections : unit -> List<IConnection>

Valore di ritorno

List IConnection
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.GetLoadableConnections

Metodo ConnectionLoaderGetLoadableConnections

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.GetLoadableConnections(System.Collections.Generic.List{InitPrtFastCommon.Interfaces.IConnection},System.String)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<IConnection> GetLoadableConnections(
    List<IConnection> connections,
    string caller
)
Public Function GetLoadableConnections (
    connections As List(Of IConnection),
    caller As String
) As List(Of IConnection)
public:
List<IConnection^>^ GetLoadableConnections(
    List<IConnection^>^ connections,
    String^ caller
)
member GetLoadableConnections :
        connections : List<IConnection> *
        caller : string -> List<IConnection>

Parametri

connections List IConnection
caller String

Valore di ritorno

List IConnection
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.IsLoadableConnection

Metodo ConnectionLoaderIsLoadableConnection
Check if a connection is loadable or not

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLoadableConnection(
    IConnection connection,
    string caller
)
Public Function IsLoadableConnection (
    connection As IConnection,
    caller As String
) As Boolean
public:
bool IsLoadableConnection(
    IConnection^ connection,
    String^ caller
)
member IsLoadableConnection :
        connection : IConnection *
        caller : string -> bool

Parametri

connection IConnection
caller String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.LoadConnection

Metodo ConnectionLoaderLoadConnection
Load a data source connection

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection LoadConnection(
    string sourcePath
)
Public Function LoadConnection (
    sourcePath As String
) As IConnection
public:
IConnection^ LoadConnection(
    String^ sourcePath
)
member LoadConnection :
        sourcePath : string -> IConnection

Parametri

sourcePath String

Valore di ritorno

IConnection
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.RemoveConnection

Metodo ConnectionLoaderRemoveConnection

[Manca la documentazione <summary> per "M:InitPrtFast.ConnectionLoader.RemoveConnection(InitPrtFastCommon.Interfaces.IConnection)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveConnection(
    IConnection connection
)
Public Sub RemoveConnection (
    connection As IConnection
)
public:
void RemoveConnection(
    IConnection^ connection
)
member RemoveConnection :
        connection : IConnection -> unit

Parametri

connection IConnection
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Metodo ConnectionLoader.ResolveAssembly

Metodo ConnectionLoaderResolveAssembly
Assembly resolution

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Assembly ResolveAssembly(
    ResolveEventArgs args
)
Public Function ResolveAssembly (
    args As ResolveEventArgs
) As Assembly
public:
Assembly^ ResolveAssembly(
    ResolveEventArgs^ args
)
member ResolveAssembly :
        args : ResolveEventArgs -> Assembly

Parametri

args ResolveEventArgs

Valore di ritorno

Assembly
Vedi anche

Documentazione

Classe ConnectionLoader
Namespace InitPrtFast


Classe ConnectionProviderManager
Connections manager. Load and initialize all providers
Gerarchia di ereditarietà
SystemObject
InitPrtFastConnectionProviderManager

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnectionProviderManager
Public Class ConnectionProviderManager
public ref class ConnectionProviderManager
type ConnectionProviderManager = class end

Il tipo ConnectionProviderManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnectionProviderManager | Inizializza una nuova istanza della classe ConnectionProviderManager.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Providers |
Proprietà pubblica | TargetAttributes |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | EditConnection | Edit a connection
Metodo pubblico | EditData | Edit the connection data
Metodo pubblico | InitializeProviders | Initialize the connection providers
Metodo pubblico | LoadConnectionFile | Load a connection from a serialized file
Metodo pubblico | LoadProviders | Load all connection providers. Scans the current folder looking for InitPrtFast*.dll. Then look inside for connection providers.
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | SaveConnectionFile | Save a connection file
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore ConnectionProviderManager
Inizializza una nuova istanza della classe ConnectionProviderManager.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnectionProviderManager(
    string repositoryPath
)
Public Sub New (
    repositoryPath As String
)
public:
ConnectionProviderManager(
    String^ repositoryPath
)
new :
        repositoryPath : string -> ConnectionProviderManager

Parametri

repositoryPath String
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Proprietà di ConnectionProviderManager

Il tipo ConnectionProviderManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Providers |
Proprietà pubblica | TargetAttributes |
Torna su
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Proprietà ConnectionProviderManager.Providers

Proprietà ConnectionProviderManagerProviders

[Manca la documentazione <summary> per "P:InitPrtFast.ConnectionProviderManager.Providers"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<IConnectionProvider> Providers { get; }
Public ReadOnly Property Providers As List(Of IConnectionProvider)
    Get
public:
property List<IConnectionProvider^>^ Providers {
    List<IConnectionProvider^>^ get ();
}
member Providers : List<IConnectionProvider> with get

Valore della proprietà

List IConnectionProvider
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Proprietà ConnectionProviderManager.TargetAttributes

Proprietà ConnectionProviderManagerTargetAttributes

[Manca la documentazione <summary> per "P:InitPrtFast.ConnectionProviderManager.TargetAttributes"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> TargetAttributes { get; set; }
Public Property TargetAttributes As List(Of String)
    Get
    Set
public:
property List<String^>^ TargetAttributes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member TargetAttributes : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodi di ConnectionProviderManager

Il tipo ConnectionProviderManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | EditConnection | Edit a connection
Metodo pubblico | EditData | Edit the connection data
Metodo pubblico | InitializeProviders | Initialize the connection providers
Metodo pubblico | LoadConnectionFile | Load a connection from a serialized file
Metodo pubblico | LoadProviders | Load all connection providers. Scans the current folder looking for InitPrtFast*.dll. Then look inside for connection providers.
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | SaveConnectionFile | Save a connection file
Torna su
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.EditConnection

Metodo ConnectionProviderManagerEditConnection
Edit a connection

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void EditConnection(
    IConnection currentConnection,
    ConnectionEditorOptions options
)
Public Sub EditConnection (
    currentConnection As IConnection,
    options As ConnectionEditorOptions
)
public:
void EditConnection(
    IConnection^ currentConnection,
    ConnectionEditorOptions^ options
)
member EditConnection :
        currentConnection : IConnection *
        options : ConnectionEditorOptions -> unit

Parametri

currentConnection IConnection
options ConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.EditData

Metodo ConnectionProviderManagerEditData
Edit the connection data

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void EditData(
    IConnection currentConnection
)
Public Sub EditData (
    currentConnection As IConnection
)
public:
void EditData(
    IConnection^ currentConnection
)
member EditData :
        currentConnection : IConnection -> unit

Parametri

currentConnection IConnection
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.InitializeProviders

Metodo ConnectionProviderManagerInitializeProviders
Initialize the connection providers

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void InitializeProviders()
Public Sub InitializeProviders
public:
void InitializeProviders()
member InitializeProviders : unit -> unit
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.LoadConnectionFile

Metodo ConnectionProviderManagerLoadConnectionFile
Load a connection from a serialized file

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection LoadConnectionFile(
    string filePath
)
Public Function LoadConnectionFile (
    filePath As String
) As IConnection
public:
IConnection^ LoadConnectionFile(
    String^ filePath
)
member LoadConnectionFile :
        filePath : string -> IConnection

Parametri

filePath String

Valore di ritorno

IConnection
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.LoadProviders

Metodo ConnectionProviderManagerLoadProviders
Load all connection providers. Scans the current folder looking for InitPrtFast*.dll. Then look inside for connection providers.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadProviders()
Public Sub LoadProviders
public:
void LoadProviders()
member LoadProviders : unit -> unit
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.ResolveAssembly

Metodo ConnectionProviderManagerResolveAssembly
Assembly resolution

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Assembly ResolveAssembly(
    ResolveEventArgs args
)
Public Function ResolveAssembly (
    args As ResolveEventArgs
) As Assembly
public:
Assembly^ ResolveAssembly(
    ResolveEventArgs^ args
)
member ResolveAssembly :
        args : ResolveEventArgs -> Assembly

Parametri

args ResolveEventArgs

Valore di ritorno

Assembly
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Metodo ConnectionProviderManager.SaveConnectionFile

Metodo ConnectionProviderManagerSaveConnectionFile
Save a connection file

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveConnectionFile(
    IConnection currentConnection,
    string filePath
)
Public Sub SaveConnectionFile (
    currentConnection As IConnection,
    filePath As String
)
public:
void SaveConnectionFile(
    IConnection^ currentConnection,
    String^ filePath
)
member SaveConnectionFile :
        currentConnection : IConnection *
        filePath : string -> unit

Parametri

currentConnection IConnection
filePath String
Eccezioni
Eccezione | Condizione
NotImplementedException |
Vedi anche

Documentazione

Classe ConnectionProviderManager
Namespace InitPrtFast


Classe ConnectionsEditorControl

[Manca la documentazione <summary> per "T:InitPrtFast.ConnectionsEditorControl"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
InitPrtFastConnectionsEditorControl

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnectionsEditorControl : UserControl
Public Class ConnectionsEditorControl
    Inherits UserControl
public ref class ConnectionsEditorControl : public UserControl
type ConnectionsEditorControl =
    class
        inherit UserControl
    end

Il tipo ConnectionsEditorControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnectionsEditorControl | Inizializza una nuova istanza della classe ConnectionsEditorControl.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConnectionsFolder |
Proprietà pubblica | CurrentConnection |
Proprietà pubblica | ShowTestConnectionButton |
Proprietà pubblica | TargetAttributes |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AppendConnection | Add the connection
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive ContainerControlDispose(Boolean))
Metodo pubblico | LoadConnectionFromFile | Load a connectin from file
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | TestButtonClicked |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore ConnectionsEditorControl
Inizializza una nuova istanza della classe ConnectionsEditorControl.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnectionsEditorControl()
Public Sub New
public:
ConnectionsEditorControl()
new : unit -> ConnectionsEditorControl
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Proprietà di ConnectionsEditorControl

Il tipo ConnectionsEditorControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConnectionsFolder |
Proprietà pubblica | CurrentConnection |
Proprietà pubblica | ShowTestConnectionButton |
Proprietà pubblica | TargetAttributes |
Torna su
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Proprietà ConnectionsEditorControl.ConnectionsFolder

Proprietà ConnectionsEditorControlConnectionsFolder

[Manca la documentazione <summary> per "P:InitPrtFast.ConnectionsEditorControl.ConnectionsFolder"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ConnectionsFolder { get; set; }
Public Property ConnectionsFolder As String
    Get
    Set
public:
property String^ ConnectionsFolder {
    String^ get ();
    void set (String^ value);
}
member ConnectionsFolder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Proprietà ConnectionsEditorControl.CurrentConnection

Proprietà ConnectionsEditorControlCurrentConnection

[Manca la documentazione <summary> per "P:InitPrtFast.ConnectionsEditorControl.CurrentConnection"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection CurrentConnection { get; }
Public ReadOnly Property CurrentConnection As IConnection
    Get
public:
property IConnection^ CurrentConnection {
    IConnection^ get ();
}
member CurrentConnection : IConnection with get

Valore della proprietà

IConnection
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Proprietà ConnectionsEditorControl.ShowTestConnectionButton

Proprietà ConnectionsEditorControlShowTestConnectionButton

[Manca la documentazione <summary> per "P:InitPrtFast.ConnectionsEditorControl.ShowTestConnectionButton"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowTestConnectionButton { get; set; }
Public Property ShowTestConnectionButton As Boolean
    Get
    Set
public:
property bool ShowTestConnectionButton {
    bool get ();
    void set (bool value);
}
member ShowTestConnectionButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Proprietà ConnectionsEditorControl.TargetAttributes

Proprietà ConnectionsEditorControlTargetAttributes

[Manca la documentazione <summary> per "P:InitPrtFast.ConnectionsEditorControl.TargetAttributes"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> TargetAttributes { get; set; }
Public Property TargetAttributes As List(Of String)
    Get
    Set
public:
property List<String^>^ TargetAttributes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member TargetAttributes : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Metodi di ConnectionsEditorControl

Il tipo ConnectionsEditorControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AppendConnection | Add the connection
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive ContainerControlDispose(Boolean))
Metodo pubblico | LoadConnectionFromFile | Load a connectin from file
Torna su
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Metodo ConnectionsEditorControl.AppendConnection

Metodo ConnectionsEditorControlAppendConnection
Add the connection

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AppendConnection(
    IConnection connection,
    string filePath
)
Public Sub AppendConnection (
    connection As IConnection,
    filePath As String
)
public:
void AppendConnection(
    IConnection^ connection,
    String^ filePath
)
member AppendConnection :
        connection : IConnection *
        filePath : string -> unit

Parametri

connection IConnection
filePath String
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Metodo ConnectionsEditorControl.Dispose

Metodo ConnectionsEditorControlDispose
Clean up any resources being used.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Metodo ConnectionsEditorControl.LoadConnectionFromFile

Metodo ConnectionsEditorControlLoadConnectionFromFile
Load a connectin from file

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadConnectionFromFile(
    string connFile
)
Public Function LoadConnectionFromFile (
    connFile As String
) As Boolean
public:
bool LoadConnectionFromFile(
    String^ connFile
)
member LoadConnectionFromFile :
        connFile : string -> bool

Parametri

connFile String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Eventi di ConnectionsEditorControl

Il tipo ConnectionsEditorControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | TestButtonClicked |
Torna su
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Evento ConnectionsEditorControl.TestButtonClicked

Evento ConnectionsEditorControlTestButtonClicked

[Manca la documentazione <summary> per "E:InitPrtFast.ConnectionsEditorControl.TestButtonClicked"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ButtonClickedEventArgs> TestButtonClicked
Public Event TestButtonClicked As EventHandler(Of ButtonClickedEventArgs)
public:
 event EventHandler<ButtonClickedEventArgs^>^ TestButtonClicked {
    void add (EventHandler<ButtonClickedEventArgs^>^ value);
    void remove (EventHandler<ButtonClickedEventArgs^>^ value);
}
member TestButtonClicked : IEvent<EventHandler<ButtonClickedEventArgs>,
    ButtonClickedEventArgs>

Valore

EventHandler ButtonClickedEventArgs
Vedi anche

Documentazione

Classe ConnectionsEditorControl
Namespace InitPrtFast


Classe InitPrtFast
Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
InitPrtFastInitPrtFast

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFast : XtraUserControl
Public Class InitPrtFast
    Inherits XtraUserControl
public ref class InitPrtFast : public XtraUserControl
type InitPrtFast =
    class
        inherit XtraUserControl
    end

Il tipo InitPrtFast espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFast | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Caller | Definisce il contesto di utilizzo del modulo. Serve nei lua per capire da dove si è chiamati. Viene usato anche per filtrare le connessioni caricabili
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà pubblica | DefaultDataSource |
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InitPrtFastMenuCommandList | Lista dei comandi custom del menu constestuale.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedConnection | Connessione attualmente selezionata.
Proprietà pubblica | SelectedRows | Contiene le righe attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AdjustControlFocus |
Metodo pubblico | AllowDragAndDrop |
Metodo pubblico | AppendDataSource | Add a data source
Metodo pubblico | AppendDataSources(ListConnBase) | aggiunge le connessioni alla lista
Metodo pubblico | AppendDataSources(ListIConnection) | aggiunge le connessioni alla lista
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | ClearDataSources | Clear the datasources
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Liberare le risorse in uso. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | GetIRoundedBorderProvider | (Ereditato da XtraUserControl)
Metodo pubblico | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
Metodo pubblico | InizializeInitPrtFast(String) | Per compatibilità col passato
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadDataSource | Load a data source connection
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnInitPrtFastCtxMenuItemClick | Lancia l'evento InitPrtFastCtxMenuItemClick.
Metodo protetto | OnInitPrtFastGridViewDoubleClick |
Metodo protetto | OnInitPrtFastSelectionChanged |
Metodo protetto | OnInitPrtFastSelectionConfirmed |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResolveAssembly |
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le impostazioni della griglia.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetBoundsCore | (Ereditato da XtraUserControl)
Metodo pubblico | SetDataSources(IListConnBase) | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt. WARNING: Required for compatibility with existing LUA code.
Metodo pubblico | SetDataSources(IListIConnection) | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
Metodo pubblico | SetPictureRowHeight | Set the row height in case of pictures
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | ShowResetButton | show hide the reset
Metodo pubblico | StopThread | Funzione per bloccate l'esecuzione del thread.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | InitPrtFastCtxMenuItemClick | Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.
Evento pubblico | InitPrtFastGridViewDoubleClick |
Evento pubblico | OnSearchControlCreated | Evento sulla creazione del controllo di ricerca
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento su modifica della selezione.
Evento pubblico | SelectionConfirmed |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast
Costruttore unico.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFast()
Public Sub New
public:
InitPrtFast()
new : unit -> InitPrtFast
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà di InitPrtFast

Il tipo InitPrtFast espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Caller | Definisce il contesto di utilizzo del modulo. Serve nei lua per capire da dove si è chiamati. Viene usato anche per filtrare le connessioni caricabili
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà pubblica | DefaultDataSource |
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InitPrtFastMenuCommandList | Lista dei comandi custom del menu constestuale.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedConnection | Connessione attualmente selezionata.
Proprietà pubblica | SelectedRows | Contiene le righe attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.Caller

Proprietà InitPrtFastCaller
Definisce il contesto di utilizzo del modulo. Serve nei lua per capire da dove si è chiamati. Viene usato anche per filtrare le connessioni caricabili

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Caller { get; set; }
Public Property Caller As String
    Get
    Set
public:
property String^ Caller {
    String^ get ();
    void set (String^ value);
}
member Caller : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.DefaultDataSource

Proprietà InitPrtFastDefaultDataSource

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.DefaultDataSource"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultDataSource { get; set; }
Public Property DefaultDataSource As String
    Get
    Set
public:
property String^ DefaultDataSource {
    String^ get ();
    void set (String^ value);
}
member DefaultDataSource : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastMenuCommandList

Proprietà InitPrtFastInitPrtFastMenuCommandList
Lista dei comandi custom del menu constestuale.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastInitPrtFastCtxMenuCommandList InitPrtFastMenuCommandList { get; }
Public ReadOnly Property InitPrtFastMenuCommandList As InitPrtFastInitPrtFastCtxMenuCommandList
    Get
public:
property InitPrtFastInitPrtFastCtxMenuCommandList^ InitPrtFastMenuCommandList {
    InitPrtFastInitPrtFastCtxMenuCommandList^ get ();
}
member InitPrtFastMenuCommandList : InitPrtFastInitPrtFastCtxMenuCommandList with get

Valore della proprietà

InitPrtFastInitPrtFastCtxMenuCommandList
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.SelectedConnection

Proprietà InitPrtFastSelectedConnection
Connessione attualmente selezionata.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection SelectedConnection { get; }
Public ReadOnly Property SelectedConnection As IConnection
    Get
public:
property IConnection^ SelectedConnection {
    IConnection^ get ();
}
member SelectedConnection : IConnection with get

Valore della proprietà

IConnection
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.SelectedRows

Proprietà InitPrtFastSelectedRows
Contiene le righe attualmente selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows SelectedRows { get; set; }
Public Property SelectedRows As InitPrtFastRows
    Get
    Set
public:
property InitPrtFastRows^ SelectedRows {
    InitPrtFastRows^ get ();
    void set (InitPrtFastRows^ value);
}
member SelectedRows : InitPrtFastRows with get, set

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodi di InitPrtFast

Il tipo InitPrtFast espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AdjustControlFocus |
Metodo pubblico | AllowDragAndDrop |
Metodo pubblico | AppendDataSource | Add a data source
Metodo pubblico | AppendDataSources(ListConnBase) | aggiunge le connessioni alla lista
Metodo pubblico | AppendDataSources(ListIConnection) | aggiunge le connessioni alla lista
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | ClearDataSources | Clear the datasources
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Liberare le risorse in uso. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | GetIRoundedBorderProvider | (Ereditato da XtraUserControl)
Metodo pubblico | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
Metodo pubblico | InizializeInitPrtFast(String) | Per compatibilità col passato
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadDataSource | Load a data source connection
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnInitPrtFastCtxMenuItemClick | Lancia l'evento InitPrtFastCtxMenuItemClick.
Metodo protetto | OnInitPrtFastGridViewDoubleClick |
Metodo protetto | OnInitPrtFastSelectionChanged |
Metodo protetto | OnInitPrtFastSelectionConfirmed |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResolveAssembly |
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le impostazioni della griglia.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetBoundsCore | (Ereditato da XtraUserControl)
Metodo pubblico | SetDataSources(IListConnBase) | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt. WARNING: Required for compatibility with existing LUA code.
Metodo pubblico | SetDataSources(IListIConnection) | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
Metodo pubblico | SetPictureRowHeight | Set the row height in case of pictures
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | ShowResetButton | show hide the reset
Metodo pubblico | StopThread | Funzione per bloccate l'esecuzione del thread.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AdjustControlFocus

Metodo InitPrtFastAdjustControlFocus

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.AdjustControlFocus"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AdjustControlFocus()
Public Sub AdjustControlFocus
public:
void AdjustControlFocus()
member AdjustControlFocus : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AllowDragAndDrop

Metodo InitPrtFastAllowDragAndDrop

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.AllowDragAndDrop(System.Boolean)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AllowDragAndDrop(
    bool allowDrop
)
Public Sub AllowDragAndDrop (
    allowDrop As Boolean
)
public:
void AllowDragAndDrop(
    bool allowDrop
)
member AllowDragAndDrop :
        allowDrop : bool -> unit

Parametri

allowDrop Boolean
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AppendDataSource

Metodo InitPrtFastAppendDataSource
Add a data source

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AppendDataSource(
    IConnection source
)
Public Function AppendDataSource (
    source As IConnection
) As Boolean
public:
bool AppendDataSource(
    IConnection^ source
)
member AppendDataSource :
        source : IConnection -> bool

Parametri

source IConnection

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AppendDataSources

Metodo InitPrtFastAppendDataSources
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AppendDataSources(ListConnBase) | aggiunge le connessioni alla lista
Metodo pubblico | AppendDataSources(ListIConnection) | aggiunge le connessioni alla lista
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AppendDataSources(List<ConnBase>)

Metodo InitPrtFastAppendDataSources(ListConnBase)
aggiunge le connessioni alla lista

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AppendDataSources(
    List<ConnBase> sources
)
Public Sub AppendDataSources (
    sources As List(Of ConnBase)
)
public:
void AppendDataSources(
    List<ConnBase^>^ sources
)
member AppendDataSources :
        sources : List<ConnBase> -> unit

Parametri

sources List ConnBase
Vedi anche

Documentazione

Classe InitPrtFast
Overload di AppendDataSources
Namespace InitPrtFast


Metodo InitPrtFast.AppendDataSources(List<IConnection>)

Metodo InitPrtFastAppendDataSources(ListIConnection)
aggiunge le connessioni alla lista

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AppendDataSources(
    List<IConnection> sources
)
Public Sub AppendDataSources (
    sources As List(Of IConnection)
)
public:
void AppendDataSources(
    List<IConnection^>^ sources
)
member AppendDataSources :
        sources : List<IConnection> -> unit

Parametri

sources List IConnection
Vedi anche

Documentazione

Classe InitPrtFast
Overload di AppendDataSources
Namespace InitPrtFast


Metodo InitPrtFast.ClearDataSources

Metodo InitPrtFastClearDataSources
Clear the datasources

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearDataSources()
Public Sub ClearDataSources
public:
void ClearDataSources()
member ClearDataSources : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.Dispose

Metodo InitPrtFastDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Liberare le risorse in uso.
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.Dispose

Metodo InitPrtFastDispose
Esegue il dispose dei controlli utente particolarmente dispendiosi

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Overload di Dispose
Namespace InitPrtFast


Metodo InitPrtFast.Dispose(Boolean)

Metodo InitPrtFastDispose(Boolean)
Liberare le risorse in uso.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe InitPrtFast
Overload di Dispose
Namespace InitPrtFast


Metodo InitPrtFast.InizializeInitPrtFast

Metodo InitPrtFastInizializeInitPrtFast
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
Metodo pubblico | InizializeInitPrtFast(String) | Per compatibilità col passato
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.InizializeInitPrtFast

Metodo InitPrtFastInizializeInitPrtFast
Chiama la funzione InizializeInitPrt definita nei lua comuni.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void InizializeInitPrtFast()
Public Sub InizializeInitPrtFast
public:
void InizializeInitPrtFast()
member InizializeInitPrtFast : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Overload di InizializeInitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.InizializeInitPrtFast(String)

Metodo InitPrtFastInizializeInitPrtFast(String)
Per compatibilità col passato

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void InizializeInitPrtFast(
    string caller
)
Public Sub InizializeInitPrtFast (
    caller As String
)
public:
void InizializeInitPrtFast(
    String^ caller
)
member InizializeInitPrtFast :
        caller : string -> unit

Parametri

caller String
Vedi anche

Documentazione

Classe InitPrtFast
Overload di InizializeInitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.LoadDataSource

Metodo InitPrtFastLoadDataSource
Load a data source connection

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection LoadDataSource(
    string sourcePath
)
Public Function LoadDataSource (
    sourcePath As String
) As IConnection
public:
IConnection^ LoadDataSource(
    String^ sourcePath
)
member LoadDataSource :
        sourcePath : string -> IConnection

Parametri

sourcePath String

Valore di ritorno

IConnection
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastCtxMenuItemClick

Metodo InitPrtFastOnInitPrtFastCtxMenuItemClick
Lancia l'evento InitPrtFastCtxMenuItemClick.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnInitPrtFastCtxMenuItemClick(
    Object sender,
    InitPrtFastInitPrtFastCtxMenuItemClickEventArgs e
)
Protected Friend Sub OnInitPrtFastCtxMenuItemClick (
    sender As Object,
    e As InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
)
protected public:
void OnInitPrtFastCtxMenuItemClick(
    Object^ sender,
    InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^ e
)
member OnInitPrtFastCtxMenuItemClick :
        sender : Object *
        e : InitPrtFastInitPrtFastCtxMenuItemClickEventArgs -> unit

Parametri

sender Object
e InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastGridViewDoubleClick

Metodo InitPrtFastOnInitPrtFastGridViewDoubleClick

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.OnInitPrtFastGridViewDoubleClick(System.Object,System.EventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnInitPrtFastGridViewDoubleClick(
    Object sender,
    EventArgs e
)
Protected Friend Sub OnInitPrtFastGridViewDoubleClick (
    sender As Object,
    e As EventArgs
)
protected public:
void OnInitPrtFastGridViewDoubleClick(
    Object^ sender,
    EventArgs^ e
)
member OnInitPrtFastGridViewDoubleClick :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastSelectionChanged

Metodo InitPrtFastOnInitPrtFastSelectionChanged

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.OnInitPrtFastSelectionChanged(System.Object,InitPrtFast.InitPrtFast.PrtInitSelectionEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnInitPrtFastSelectionChanged(
    Object sender,
    InitPrtFastPrtInitSelectionEventArgs ev
)
Protected Sub OnInitPrtFastSelectionChanged (
    sender As Object,
    ev As InitPrtFastPrtInitSelectionEventArgs
)
protected:
void OnInitPrtFastSelectionChanged(
    Object^ sender,
    InitPrtFastPrtInitSelectionEventArgs^ ev
)
member OnInitPrtFastSelectionChanged :
        sender : Object *
        ev : InitPrtFastPrtInitSelectionEventArgs -> unit

Parametri

sender Object
ev InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastSelectionConfirmed

Metodo InitPrtFastOnInitPrtFastSelectionConfirmed

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.OnInitPrtFastSelectionConfirmed(System.Object,InitPrtFast.InitPrtFast.PrtInitSelectionEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnInitPrtFastSelectionConfirmed(
    Object sender,
    InitPrtFastPrtInitSelectionEventArgs ev
)
Protected Sub OnInitPrtFastSelectionConfirmed (
    sender As Object,
    ev As InitPrtFastPrtInitSelectionEventArgs
)
protected:
void OnInitPrtFastSelectionConfirmed(
    Object^ sender,
    InitPrtFastPrtInitSelectionEventArgs^ ev
)
member OnInitPrtFastSelectionConfirmed :
        sender : Object *
        ev : InitPrtFastPrtInitSelectionEventArgs -> unit

Parametri

sender Object
ev InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.ResolveAssembly

Metodo InitPrtFastResolveAssembly

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.ResolveAssembly(System.ResolveEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Assembly ResolveAssembly(
    ResolveEventArgs args
)
Public Function ResolveAssembly (
    args As ResolveEventArgs
) As Assembly
public:
Assembly^ ResolveAssembly(
    ResolveEventArgs^ args
)
member ResolveAssembly :
        args : ResolveEventArgs -> Assembly

Parametri

args ResolveEventArgs

Valore di ritorno

Assembly
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.SaveRegistrySettings

Metodo InitPrtFastSaveRegistrySettings
Salva nel registro le impostazioni della griglia.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.SetDataSources

Metodo InitPrtFastSetDataSources
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetDataSources(IListConnBase) | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt. WARNING: Required for compatibility with existing LUA code.
Metodo pubblico | SetDataSources(IListIConnection) | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.SetDataSources(IList<ConnBase>)

Metodo InitPrtFastSetDataSources(IListConnBase)
Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt. WARNING: Required for compatibility with existing LUA code.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDataSources(
    IList<ConnBase> sources
)
Public Sub SetDataSources (
    sources As IList(Of ConnBase)
)
public:
void SetDataSources(
    IList<ConnBase^>^ sources
)
member SetDataSources :
        sources : IList<ConnBase> -> unit

Parametri

sources IList ConnBase
Vedi anche

Documentazione

Classe InitPrtFast
Overload di SetDataSources
Namespace InitPrtFast


Metodo InitPrtFast.SetDataSources(IList<IConnection>)

Metodo InitPrtFastSetDataSources(IListIConnection)
Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDataSources(
    IList<IConnection> sources
)
Public Sub SetDataSources (
    sources As IList(Of IConnection)
)
public:
void SetDataSources(
    IList<IConnection^>^ sources
)
member SetDataSources :
        sources : IList<IConnection> -> unit

Parametri

sources IList IConnection
Vedi anche

Documentazione

Classe InitPrtFast
Overload di SetDataSources
Namespace InitPrtFast


Metodo InitPrtFast.SetPictureRowHeight

Metodo InitPrtFastSetPictureRowHeight
Set the row height in case of pictures

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetPictureRowHeight(
    int height
)
Public Sub SetPictureRowHeight (
    height As Integer
)
public:
void SetPictureRowHeight(
    int height
)
member SetPictureRowHeight :
        height : int -> unit

Parametri

height Int32
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.ShowResetButton

Metodo InitPrtFastShowResetButton
show hide the reset

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowResetButton(
    bool show
)
Public Sub ShowResetButton (
    show As Boolean
)
public:
void ShowResetButton(
    bool show
)
member ShowResetButton :
        show : bool -> unit

Parametri

show Boolean
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.StopThread

Metodo InitPrtFastStopThread
Funzione per bloccate l'esecuzione del thread.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void StopThread()
Public Sub StopThread
public:
void StopThread()
member StopThread : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Eventi di InitPrtFast

Il tipo InitPrtFast espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | InitPrtFastCtxMenuItemClick | Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.
Evento pubblico | InitPrtFastGridViewDoubleClick |
Evento pubblico | OnSearchControlCreated | Evento sulla creazione del controllo di ricerca
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento su modifica della selezione.
Evento pubblico | SelectionConfirmed |
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.InitPrtFastCtxMenuItemClick

Evento InitPrtFastInitPrtFastCtxMenuItemClick
Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs> InitPrtFastCtxMenuItemClick
Public Event InitPrtFastCtxMenuItemClick As EventHandler(Of InitPrtFastInitPrtFastCtxMenuItemClickEventArgs)
public:
 event EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^>^ InitPrtFastCtxMenuItemClick {
    void add (EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^>^ value);
}
member InitPrtFastCtxMenuItemClick : IEvent<EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs>,
    InitPrtFastInitPrtFastCtxMenuItemClickEventArgs>

Valore

EventHandler InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.InitPrtFastGridViewDoubleClick

Evento InitPrtFastInitPrtFastGridViewDoubleClick

[Manca la documentazione <summary> per "E:InitPrtFast.InitPrtFast.InitPrtFastGridViewDoubleClick"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler InitPrtFastGridViewDoubleClick
Public Event InitPrtFastGridViewDoubleClick As EventHandler
public:
 event EventHandler^ InitPrtFastGridViewDoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member InitPrtFastGridViewDoubleClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.OnSearchControlCreated

Evento InitPrtFastOnSearchControlCreated
Evento sulla creazione del controllo di ricerca

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastSearchControlCreatedEventArgs> OnSearchControlCreated
Public Event OnSearchControlCreated As EventHandler(Of InitPrtFastSearchControlCreatedEventArgs)
public:
 event EventHandler<InitPrtFastSearchControlCreatedEventArgs^>^ OnSearchControlCreated {
    void add (EventHandler<InitPrtFastSearchControlCreatedEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastSearchControlCreatedEventArgs^>^ value);
}
member OnSearchControlCreated : IEvent<EventHandler<InitPrtFastSearchControlCreatedEventArgs>,
    InitPrtFastSearchControlCreatedEventArgs>

Valore

EventHandler InitPrtFastSearchControlCreatedEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.SelectionChanged

Evento InitPrtFastSelectionChanged
Evento su modifica della selezione.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastPrtInitSelectionEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of InitPrtFastPrtInitSelectionEventArgs)
public:
 event EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ SelectionChanged {
    void add (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<InitPrtFastPrtInitSelectionEventArgs>,
    InitPrtFastPrtInitSelectionEventArgs>

Valore

EventHandler InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.SelectionConfirmed

Evento InitPrtFastSelectionConfirmed

[Manca la documentazione <summary> per "E:InitPrtFast.InitPrtFast.SelectionConfirmed"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastPrtInitSelectionEventArgs> SelectionConfirmed
Public Event SelectionConfirmed As EventHandler(Of InitPrtFastPrtInitSelectionEventArgs)
public:
 event EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ SelectionConfirmed {
    void add (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
}
member SelectionConfirmed : IEvent<EventHandler<InitPrtFastPrtInitSelectionEventArgs>,
    InitPrtFastPrtInitSelectionEventArgs>

Valore

EventHandler InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Classe InitPrtFast.Element

Classe InitPrtFastElement
Classe che rappreseneta l'oggetto cella.
Gerarchia di ereditarietà
SystemObject
InitPrtFastInitPrtFastElement

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Element
Public Class Element
public ref class Element
type Element = class end

Il tipo InitPrtFastElement espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastElement(String, IField, Object) | Inizializza una nuova istanza della classe InitPrtFastElement.
Metodo pubblico | InitPrtFastElement(String, String, Object) | Inizializza una nuova istanza della classe InitPrtFastElement.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Il campo DedLink del Field associato alla colonna
Proprietà pubblica | Field | Corrisponde alla Caption della colonna Di conseguenza può corrispondere al Prompt o alla Translation del Field associato alla colonna
Proprietà pubblica | SourceField | The original source field
Proprietà pubblica | Value | Valore della cella
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.Element

Costruttore InitPrtFastElement
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | InitPrtFastElement(String, IField, Object) | Inizializza una nuova istanza della classe InitPrtFastElement.
Metodo pubblico | InitPrtFastElement(String, String, Object) | Inizializza una nuova istanza della classe InitPrtFastElement.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Costruttore InitPrtFast.Element(String, IField, Object)

Costruttore InitPrtFastElement(String, IField, Object)
Inizializza una nuova istanza della classe InitPrtFastElement.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Element(
    string field,
    IField sourceField,
    Object cellValue
)
Public Sub New (
    field As String,
    sourceField As IField,
    cellValue As Object
)
public:
Element(
    String^ field,
    IField^ sourceField,
    Object^ cellValue
)
new :
        field : string *
        sourceField : IField *
        cellValue : Object -> Element

Parametri

field String
sourceField IField
cellValue Object
Vedi anche

Documentazione

Classe InitPrtFastElement
Overload di InitPrtFastElement
Namespace InitPrtFast


Costruttore InitPrtFast.Element(String, String, Object)

Costruttore InitPrtFastElement(String, String, Object)
Inizializza una nuova istanza della classe InitPrtFastElement.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Element(
    string field,
    string dedlink,
    Object cellValue
)
Public Sub New (
    field As String,
    dedlink As String,
    cellValue As Object
)
public:
Element(
    String^ field,
    String^ dedlink,
    Object^ cellValue
)
new :
        field : string *
        dedlink : string *
        cellValue : Object -> Element

Parametri

field String
dedlink String
cellValue Object
Vedi anche

Documentazione

Classe InitPrtFastElement
Overload di InitPrtFastElement
Namespace InitPrtFast


Proprietà di Element

Il tipo InitPrtFastElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Il campo DedLink del Field associato alla colonna
Proprietà pubblica | Field | Corrisponde alla Caption della colonna Di conseguenza può corrispondere al Prompt o alla Translation del Field associato alla colonna
Proprietà pubblica | SourceField | The original source field
Proprietà pubblica | Value | Valore della cella
Torna su
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.DedLink

Proprietà InitPrtFastElementDedLink
Il campo DedLink del Field associato alla colonna

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DedLink { get; set; }
Public Property DedLink As String
    Get
    Set
public:
property String^ DedLink {
    String^ get ();
    void set (String^ value);
}
member DedLink : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.Field

Proprietà InitPrtFastElementField
Corrisponde alla Caption della colonna Di conseguenza può corrispondere al Prompt o alla Translation del Field associato alla colonna

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Field { get; set; }
Public Property Field As String
    Get
    Set
public:
property String^ Field {
    String^ get ();
    void set (String^ value);
}
member Field : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.SourceField

Proprietà InitPrtFastElementSourceField
The original source field

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IField SourceField { get; set; }
Public Property SourceField As IField
    Get
    Set
public:
property IField^ SourceField {
    IField^ get ();
    void set (IField^ value);
}
member SourceField : IField with get, set

Valore della proprietà

IField
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.Value

Proprietà InitPrtFastElementValue
Valore della cella

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Classe InitPrtFast.InitPrtFastCtxMenuCommand

Classe InitPrtFastInitPrtFastCtxMenuCommand
Classe per gestire i comandi personalizzati sul tasto dx.
Gerarchia di ereditarietà
SystemObject
InitPrtFastInitPrtFastInitPrtFastCtxMenuCommand

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastCtxMenuCommand
Public Class InitPrtFastCtxMenuCommand
public ref class InitPrtFastCtxMenuCommand
type InitPrtFastCtxMenuCommand = class end

Il tipo InitPrtFastInitPrtFastCtxMenuCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommand(String, String, String, Image, Boolean, InitPrtFastSelectionVisibility) | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommand(String, String, String, String, Boolean, InitPrtFastSelectionVisibility) | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeginGroup |
Proprietà pubblica | ImagePath |
Proprietà pubblica | Img |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | SelectionVisibility |
Proprietà pubblica | ToolStripItem |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuCommand

Costruttore InitPrtFastInitPrtFastCtxMenuCommand
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommand(String, String, String, Image, Boolean, InitPrtFastSelectionVisibility) | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommand(String, String, String, String, Boolean, InitPrtFastSelectionVisibility) | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuCommand(String, String, String, Image, Boolean, InitPrtFast.SelectionVisibility)

Costruttore InitPrtFastInitPrtFastCtxMenuCommand(String, String, String, Image, Boolean, InitPrtFastSelectionVisibility)
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuCommand(
    string name,
    string prompt,
    string tooltip,
    Image image,
    bool beginGroup,
    InitPrtFastSelectionVisibility selectionVisibility
)
Public Sub New (
    name As String,
    prompt As String,
    tooltip As String,
    image As Image,
    beginGroup As Boolean,
    selectionVisibility As InitPrtFastSelectionVisibility
)
public:
InitPrtFastCtxMenuCommand(
    String^ name,
    String^ prompt,
    String^ tooltip,
    Image^ image,
    bool beginGroup,
    InitPrtFastSelectionVisibility selectionVisibility
)
new :
        name : string *
        prompt : string *
        tooltip : string *
        image : Image *
        beginGroup : bool *
        selectionVisibility : InitPrtFastSelectionVisibility -> InitPrtFastCtxMenuCommand

Parametri

name String
prompt String
tooltip String
image Image
beginGroup Boolean
selectionVisibility InitPrtFastSelectionVisibility
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Overload di InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuCommand(String, String, String, String, Boolean, InitPrtFast.SelectionVisibility)

Costruttore InitPrtFastInitPrtFastCtxMenuCommand(String, String, String, String, Boolean, InitPrtFastSelectionVisibility)
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuCommand(
    string name,
    string prompt,
    string tooltip,
    string imagePath,
    bool beginGroup,
    InitPrtFastSelectionVisibility selectionVisibility
)
Public Sub New (
    name As String,
    prompt As String,
    tooltip As String,
    imagePath As String,
    beginGroup As Boolean,
    selectionVisibility As InitPrtFastSelectionVisibility
)
public:
InitPrtFastCtxMenuCommand(
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath,
    bool beginGroup,
    InitPrtFastSelectionVisibility selectionVisibility
)
new :
        name : string *
        prompt : string *
        tooltip : string *
        imagePath : string *
        beginGroup : bool *
        selectionVisibility : InitPrtFastSelectionVisibility -> InitPrtFastCtxMenuCommand

Parametri

name String
prompt String
tooltip String
imagePath String
beginGroup Boolean
selectionVisibility InitPrtFastSelectionVisibility
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Overload di InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà di InitPrtFastCtxMenuCommand

Il tipo InitPrtFastInitPrtFastCtxMenuCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeginGroup |
Proprietà pubblica | ImagePath |
Proprietà pubblica | Img |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | SelectionVisibility |
Proprietà pubblica | ToolStripItem |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.BeginGroup

Proprietà InitPrtFastInitPrtFastCtxMenuCommandBeginGroup

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.BeginGroup"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool BeginGroup { get; set; }
Public Property BeginGroup As Boolean
    Get
    Set
public:
property bool BeginGroup {
    bool get ();
    void set (bool value);
}
member BeginGroup : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.ImagePath

Proprietà InitPrtFastInitPrtFastCtxMenuCommandImagePath

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.ImagePath"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ImagePath { get; set; }
Public Property ImagePath As String
    Get
    Set
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}
member ImagePath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Img

Proprietà InitPrtFastInitPrtFastCtxMenuCommandImg

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Img"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image Img { get; set; }
Public Property Img As Image
    Get
    Set
public:
property Image^ Img {
    Image^ get ();
    void set (Image^ value);
}
member Img : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Name

Proprietà InitPrtFastInitPrtFastCtxMenuCommandName

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Name"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Prompt

Proprietà InitPrtFastInitPrtFastCtxMenuCommandPrompt

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Prompt"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.SelectionVisibility

Proprietà InitPrtFastInitPrtFastCtxMenuCommandSelectionVisibility

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.SelectionVisibility"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastSelectionVisibility SelectionVisibility { get; set; }
Public Property SelectionVisibility As InitPrtFastSelectionVisibility
    Get
    Set
public:
property InitPrtFastSelectionVisibility SelectionVisibility {
    InitPrtFastSelectionVisibility get ();
    void set (InitPrtFastSelectionVisibility value);
}
member SelectionVisibility : InitPrtFastSelectionVisibility with get, set

Valore della proprietà

InitPrtFastSelectionVisibility
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.ToolStripItem

Proprietà InitPrtFastInitPrtFastCtxMenuCommandToolStripItem

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.ToolStripItem"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public BarItem ToolStripItem { get; }
Public ReadOnly Property ToolStripItem As BarItem
    Get
public:
property BarItem^ ToolStripItem {
    BarItem^ get ();
}
member ToolStripItem : BarItem with get

Valore della proprietà

BarItem
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Tooltip

Proprietà InitPrtFastInitPrtFastCtxMenuCommandTooltip

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Tooltip"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Classe InitPrtFast.InitPrtFastCtxMenuCommandList

Classe InitPrtFastInitPrtFastCtxMenuCommandList
Lista di oggetti InitPrtFastCtxMenuCommand.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList InitPrtFastInitPrtFastCtxMenuCommand
InitPrtFastInitPrtFastInitPrtFastCtxMenuCommandList

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastCtxMenuCommandList : List<InitPrtFastInitPrtFastCtxMenuCommand>
Public Class InitPrtFastCtxMenuCommandList
    Inherits List(Of InitPrtFastInitPrtFastCtxMenuCommand)
public ref class InitPrtFastCtxMenuCommandList : public List<InitPrtFastInitPrtFastCtxMenuCommand^>
type InitPrtFastCtxMenuCommandList =
    class
        inherit List<InitPrtFastInitPrtFastCtxMenuCommand>
    end

Il tipo InitPrtFastInitPrtFastCtxMenuCommandList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommandList | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommandList.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuCommandList

Costruttore InitPrtFastInitPrtFastCtxMenuCommandList
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommandList.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuCommandList()
Public Sub New
public:
InitPrtFastCtxMenuCommandList()
new : unit -> InitPrtFastCtxMenuCommandList
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommandList
Namespace InitPrtFast


Classe InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Argomento utilizzato durante il click su un menu constestuale personalizzato.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastInitPrtFastInitPrtFastCtxMenuItemClickEventArgs

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastCtxMenuItemClickEventArgs : EventArgs
Public Class InitPrtFastCtxMenuItemClickEventArgs
    Inherits EventArgs
public ref class InitPrtFastCtxMenuItemClickEventArgs : public EventArgs
type InitPrtFastCtxMenuItemClickEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastInitPrtFastCtxMenuItemClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuItemClickEventArgs | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CtrlGrid | Restituisce il controllo griglia.
Proprietà pubblica | CtrlInitPrtFast | Restituisce il controllo InitPrtFast
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | MainForm | Form che contiente il controllo.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | SelectedConnection | Restiruisce la connessione selezionata
Proprietà pubblica | SelectedRows | Restituisce le righe selezionate.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs

Costruttore InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuItemClickEventArgs()
Public Sub New
public:
InitPrtFastCtxMenuItemClickEventArgs()
new : unit -> InitPrtFastCtxMenuItemClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà di InitPrtFastCtxMenuItemClickEventArgs

Il tipo InitPrtFastInitPrtFastCtxMenuItemClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CtrlGrid | Restituisce il controllo griglia.
Proprietà pubblica | CtrlInitPrtFast | Restituisce il controllo InitPrtFast
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | MainForm | Form che contiente il controllo.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | SelectedConnection | Restiruisce la connessione selezionata
Proprietà pubblica | SelectedRows | Restituisce le righe selezionate.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.CtrlGrid

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsCtrlGrid
Restituisce il controllo griglia.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl CtrlGrid { get; }
Public ReadOnly Property CtrlGrid As GridControl
    Get
public:
property GridControl^ CtrlGrid {
    GridControl^ get ();
}
member CtrlGrid : GridControl with get

Valore della proprietà

GridControl
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.CtrlInitPrtFast

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsCtrlInitPrtFast
Restituisce il controllo InitPrtFast

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFast CtrlInitPrtFast { get; set; }
Public Property CtrlInitPrtFast As InitPrtFast
    Get
    Set
public:
property InitPrtFast^ CtrlInitPrtFast {
    InitPrtFast^ get ();
    void set (InitPrtFast^ value);
}
member CtrlInitPrtFast : InitPrtFast with get, set

Valore della proprietà

InitPrtFast
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.ItemClicked

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsItemClicked
Restuisce l'elemento cliccato.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public BarButtonItem ItemClicked { get; }
Public ReadOnly Property ItemClicked As BarButtonItem
    Get
public:
property BarButtonItem^ ItemClicked {
    BarButtonItem^ get ();
}
member ItemClicked : BarButtonItem with get

Valore della proprietà

BarButtonItem
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.MainForm

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsMainForm
Form che contiente il controllo.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Form MainForm { get; set; }
Public Property MainForm As Form
    Get
    Set
public:
property Form^ MainForm {
    Form^ get ();
    void set (Form^ value);
}
member MainForm : Form with get, set

Valore della proprietà

Form
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.NeedRefresh

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsNeedRefresh
Indica se è necessario un refresh dopo il comando.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRefresh { get; set; }
Public Property NeedRefresh As Boolean
    Get
    Set
public:
property bool NeedRefresh {
    bool get ();
    void set (bool value);
}
member NeedRefresh : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.SelectedConnection

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsSelectedConnection
Restiruisce la connessione selezionata

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection SelectedConnection { get; }
Public ReadOnly Property SelectedConnection As IConnection
    Get
public:
property IConnection^ SelectedConnection {
    IConnection^ get ();
}
member SelectedConnection : IConnection with get

Valore della proprietà

IConnection
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.SelectedRows

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsSelectedRows
Restituisce le righe selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows SelectedRows { get; }
Public ReadOnly Property SelectedRows As InitPrtFastRows
    Get
public:
property InitPrtFastRows^ SelectedRows {
    InitPrtFastRows^ get ();
}
member SelectedRows : InitPrtFastRows with get

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Classe InitPrtFast.PrtInitSelectionEventArgs

Classe InitPrtFastPrtInitSelectionEventArgs
Classe contenente le informazioni per l'evento SelectionChanged.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastInitPrtFastPrtInitSelectionEventArgs

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PrtInitSelectionEventArgs : EventArgs
Public Class PrtInitSelectionEventArgs
    Inherits EventArgs
public ref class PrtInitSelectionEventArgs : public EventArgs
type PrtInitSelectionEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastPrtInitSelectionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastPrtInitSelectionEventArgs | Inizializza una nuova istanza della classe InitPrtFastPrtInitSelectionEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Rows | Lista delle righe selezionate.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.PrtInitSelectionEventArgs

Costruttore InitPrtFastPrtInitSelectionEventArgs
Inizializza una nuova istanza della classe InitPrtFastPrtInitSelectionEventArgs.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public PrtInitSelectionEventArgs()
Public Sub New
public:
PrtInitSelectionEventArgs()
new : unit -> PrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFastPrtInitSelectionEventArgs
Namespace InitPrtFast


Proprietà di PrtInitSelectionEventArgs

Il tipo InitPrtFastPrtInitSelectionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Rows | Lista delle righe selezionate.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastPrtInitSelectionEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.PrtInitSelectionEventArgs.Rows

Proprietà InitPrtFastPrtInitSelectionEventArgsRows
Lista delle righe selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows Rows { get; }
Public ReadOnly Property Rows As InitPrtFastRows
    Get
public:
property InitPrtFastRows^ Rows {
    InitPrtFastRows^ get ();
}
member Rows : InitPrtFastRows with get

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFastPrtInitSelectionEventArgs
Namespace InitPrtFast


Classe InitPrtFast.Row

Classe InitPrtFastRow

[Manca la documentazione <summary> per "T:InitPrtFast.InitPrtFast.Row"]

Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList InitPrtFastElement
InitPrtFastInitPrtFastRow

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Row : List<InitPrtFastElement>
Public Class Row
    Inherits List(Of InitPrtFastElement)
public ref class Row : public List<InitPrtFastElement^>
type Row =
    class
        inherit List<InitPrtFastElement>
    end

Il tipo InitPrtFastRow espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastRow | Inizializza una nuova istanza della classe InitPrtFastRow.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.Row

Costruttore InitPrtFastRow
Inizializza una nuova istanza della classe InitPrtFastRow.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Row()
Public Sub New
public:
Row()
new : unit -> Row
Vedi anche

Documentazione

Classe InitPrtFastRow
Namespace InitPrtFast


Classe InitPrtFast.Rows

Classe InitPrtFastRows

[Manca la documentazione <summary> per "T:InitPrtFast.InitPrtFast.Rows"]

Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList InitPrtFastRow
InitPrtFastInitPrtFastRows

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Rows : List<InitPrtFastRow>
Public Class Rows
    Inherits List(Of InitPrtFastRow)
public ref class Rows : public List<InitPrtFastRow^>
type Rows =
    class
        inherit List<InitPrtFastRow>
    end

Il tipo InitPrtFastRows espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastRows | Inizializza una nuova istanza della classe InitPrtFastRows.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.Rows

Costruttore InitPrtFastRows
Inizializza una nuova istanza della classe InitPrtFastRows.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Rows()
Public Sub New
public:
Rows()
new : unit -> Rows
Vedi anche

Documentazione

Classe InitPrtFastRows
Namespace InitPrtFast


Classe InitPrtFast.SearchControlCreatedEventArgs

Classe InitPrtFastSearchControlCreatedEventArgs
Classe contenente le informazioni per l'evento SearchControlCreated.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastInitPrtFastSearchControlCreatedEventArgs

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SearchControlCreatedEventArgs : EventArgs
Public Class SearchControlCreatedEventArgs
    Inherits EventArgs
public ref class SearchControlCreatedEventArgs : public EventArgs
type SearchControlCreatedEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastSearchControlCreatedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastSearchControlCreatedEventArgs | Inizializza una nuova istanza della classe InitPrtFastSearchControlCreatedEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Connessione attiva
Proprietà pubblica | Control | Controllo di ricerca
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.SearchControlCreatedEventArgs

Costruttore InitPrtFastSearchControlCreatedEventArgs
Inizializza una nuova istanza della classe InitPrtFastSearchControlCreatedEventArgs.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchControlCreatedEventArgs(
    SearchPanelControl ctrl,
    IConnection connection
)
Public Sub New (
    ctrl As SearchPanelControl,
    connection As IConnection
)
public:
SearchControlCreatedEventArgs(
    SearchPanelControl^ ctrl,
    IConnection^ connection
)
new :
        ctrl : SearchPanelControl *
        connection : IConnection -> SearchControlCreatedEventArgs

Parametri

ctrl SearchPanelControl
connection IConnection
Vedi anche

Documentazione

Classe InitPrtFastSearchControlCreatedEventArgs
Namespace InitPrtFast


Proprietà di SearchControlCreatedEventArgs

Il tipo InitPrtFastSearchControlCreatedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Connessione attiva
Proprietà pubblica | Control | Controllo di ricerca
Torna su
Vedi anche

Documentazione

Classe InitPrtFastSearchControlCreatedEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.SearchControlCreatedEventArgs.Connection

Proprietà InitPrtFastSearchControlCreatedEventArgsConnection
Connessione attiva

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Connection { get; set; }
Public Property Connection As IConnection
    Get
    Set
public:
property IConnection^ Connection {
    IConnection^ get ();
    void set (IConnection^ value);
}
member Connection : IConnection with get, set

Valore della proprietà

IConnection
Vedi anche

Documentazione

Classe InitPrtFastSearchControlCreatedEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.SearchControlCreatedEventArgs.Control

Proprietà InitPrtFastSearchControlCreatedEventArgsControl
Controllo di ricerca

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchPanelControl Control { get; set; }
Public Property Control As SearchPanelControl
    Get
    Set
public:
property SearchPanelControl^ Control {
    SearchPanelControl^ get ();
    void set (SearchPanelControl^ value);
}
member Control : SearchPanelControl with get, set

Valore della proprietà

SearchPanelControl
Vedi anche

Documentazione

Classe InitPrtFastSearchControlCreatedEventArgs
Namespace InitPrtFast


Enumerazione InitPrtFast.SelectionVisibility

Enumerazione InitPrtFastSelectionVisibility
Definizione possibili azioni su oggetti importazione

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum SelectionVisibility
Public Enumeration SelectionVisibility
public enum class SelectionVisibility
type SelectionVisibility
Membri
Nome | Valore | Descrizione
Single | 0 |
Multiple | 1 |
SingleAndMultiple | 2 |
None | 3 |
Always | 4 |
Vedi anche

Documentazione

Namespace InitPrtFast


Classe InitPrtFastConfigForm

[Manca la documentazione <summary> per "T:InitPrtFast.InitPrtFastConfigForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
InitPrtFastInitPrtFastConfigForm

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastConfigForm : XtraForm
Public Class InitPrtFastConfigForm
    Inherits XtraForm
public ref class InitPrtFastConfigForm : public XtraForm
type InitPrtFastConfigForm =
    class
        inherit XtraForm
    end

Il tipo InitPrtFastConfigForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastConfigForm | Inizializza una nuova istanza della classe InitPrtFastConfigForm.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowTestConnectionButton | Show the test button
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddDataSource | Add the datasource
Metodo pubblico | AddTargetAttribute | Add a target attribute
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | ClearDataSources | Clear the datasources
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadDataSource | Load the datasource
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetConnectionsFolder | Save the connections folder
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFastConfigForm
Inizializza una nuova istanza della classe InitPrtFastConfigForm.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastConfigForm()
Public Sub New
public:
InitPrtFastConfigForm()
new : unit -> InitPrtFastConfigForm
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Proprietà di InitPrtFastConfigForm

Il tipo InitPrtFastConfigForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowTestConnectionButton | Show the test button
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Proprietà InitPrtFastConfigForm.ShowTestConnectionButton

Proprietà InitPrtFastConfigFormShowTestConnectionButton
Show the test button

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowTestConnectionButton { get; set; }
Public Property ShowTestConnectionButton As Boolean
    Get
    Set
public:
property bool ShowTestConnectionButton {
    bool get ();
    void set (bool value);
}
member ShowTestConnectionButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodi di InitPrtFastConfigForm

Il tipo InitPrtFastConfigForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddDataSource | Add the datasource
Metodo pubblico | AddTargetAttribute | Add a target attribute
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | ClearDataSources | Clear the datasources
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadDataSource | Load the datasource
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetConnectionsFolder | Save the connections folder
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodo InitPrtFastConfigForm.AddDataSource

Metodo InitPrtFastConfigFormAddDataSource
Add the datasource

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddDataSource(
    IConnection connection
)
Public Sub AddDataSource (
    connection As IConnection
)
public:
void AddDataSource(
    IConnection^ connection
)
member AddDataSource :
        connection : IConnection -> unit

Parametri

connection IConnection
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodo InitPrtFastConfigForm.AddTargetAttribute

Metodo InitPrtFastConfigFormAddTargetAttribute
Add a target attribute

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddTargetAttribute(
    string attrName
)
Public Sub AddTargetAttribute (
    attrName As String
)
public:
void AddTargetAttribute(
    String^ attrName
)
member AddTargetAttribute :
        attrName : string -> unit

Parametri

attrName String
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodo InitPrtFastConfigForm.ClearDataSources

Metodo InitPrtFastConfigFormClearDataSources
Clear the datasources

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearDataSources()
Public Sub ClearDataSources
public:
void ClearDataSources()
member ClearDataSources : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodo InitPrtFastConfigForm.Dispose

Metodo InitPrtFastConfigFormDispose
Clean up any resources being used.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodo InitPrtFastConfigForm.LoadDataSource

Metodo InitPrtFastConfigFormLoadDataSource
Load the datasource

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadDataSource(
    string path
)
Public Sub LoadDataSource (
    path As String
)
public:
void LoadDataSource(
    String^ path
)
member LoadDataSource :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Metodo InitPrtFastConfigForm.SetConnectionsFolder

Metodo InitPrtFastConfigFormSetConnectionsFolder
Save the connections folder

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetConnectionsFolder(
    string folder
)
Public Sub SetConnectionsFolder (
    folder As String
)
public:
void SetConnectionsFolder(
    String^ folder
)
member SetConnectionsFolder :
        folder : string -> unit

Parametri

folder String
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Eventi di InitPrtFastConfigForm

Il tipo InitPrtFastConfigForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Campi di InitPrtFastConfigForm

Il tipo InitPrtFastConfigForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastConfigForm
Namespace InitPrtFast


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
InitPrtFastQsResources

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources | Inizializza una nuova istanza della classe QsResources.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore QsResources
Inizializza una nuova istanza della classe QsResources.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s String
a Assembly
Vedi anche

Documentazione

Classe QsResources
Namespace InitPrtFast


Metodi di QsResources

Il tipo QsResources espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace InitPrtFast


Metodo QsResources.GetString

Metodo QsResourcesGetString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace InitPrtFast


Metodo QsResources.GetString(String)

Metodo QsResourcesGetString(String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace InitPrtFast


Metodo QsResources.GetString(String, CultureInfo)

Metodo QsResourcesGetString(String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name String
culture CultureInfo

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace InitPrtFast


Classe ResetPanelControl
Classe per creare un pannello che contiene [ label + combo ]
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
InitPrtFastResetPanelControl

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ResetPanelControl : XtraUserControl
Public Class ResetPanelControl
    Inherits XtraUserControl
public ref class ResetPanelControl : public XtraUserControl
type ResetPanelControl =
    class
        inherit XtraUserControl
    end

Il tipo ResetPanelControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ResetPanelControl | Inizializza una nuova istanza della classe ResetPanelControl.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Button |
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | Label |
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Panel |
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | GetIRoundedBorderProvider | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetBoundsCore | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore ResetPanelControl
Inizializza una nuova istanza della classe ResetPanelControl.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ResetPanelControl()
Public Sub New
public:
ResetPanelControl()
new : unit -> ResetPanelControl
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Proprietà di ResetPanelControl

Il tipo ResetPanelControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Button |
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | Label |
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Panel |
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Proprietà ResetPanelControl.Button

Proprietà ResetPanelControlButton

[Manca la documentazione <summary> per "P:InitPrtFast.ResetPanelControl.Button"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton Button { get; }
Public ReadOnly Property Button As SimpleButton
    Get
public:
property SimpleButton^ Button {
    SimpleButton^ get ();
}
member Button : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Proprietà ResetPanelControl.Label

Proprietà ResetPanelControlLabel

[Manca la documentazione <summary> per "P:InitPrtFast.ResetPanelControl.Label"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public LabelControl Label { get; }
Public ReadOnly Property Label As LabelControl
    Get
public:
property LabelControl^ Label {
    LabelControl^ get ();
}
member Label : LabelControl with get

Valore della proprietà

LabelControl
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Proprietà ResetPanelControl.Panel

Proprietà ResetPanelControlPanel

[Manca la documentazione <summary> per "P:InitPrtFast.ResetPanelControl.Panel"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public PanelControl Panel { get; }
Public ReadOnly Property Panel As PanelControl
    Get
public:
property PanelControl^ Panel {
    PanelControl^ get ();
}
member Panel : PanelControl with get

Valore della proprietà

PanelControl
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Metodi di ResetPanelControl

Il tipo ResetPanelControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | GetIRoundedBorderProvider | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetBoundsCore | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Metodo ResetPanelControl.Dispose

Metodo ResetPanelControlDispose
Clean up any resources being used.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Eventi di ResetPanelControl

Il tipo ResetPanelControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ResetPanelControl
Namespace InitPrtFast


Classe SearchPanelControl
Classe per creare un pannello che contiene [ label + combo ]
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
InitPrtFastSearchPanelControl

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SearchPanelControl : XtraUserControl
Public Class SearchPanelControl
    Inherits XtraUserControl
public ref class SearchPanelControl : public XtraUserControl
type SearchPanelControl =
    class
        inherit XtraUserControl
    end

Il tipo SearchPanelControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SearchPanelControl | Inizializza una nuova istanza della classe SearchPanelControl.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | Combo |
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Field | The field associated to the control
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | Label |
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Panel |
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | GetIRoundedBorderProvider | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetBoundsCore | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore SearchPanelControl
Inizializza una nuova istanza della classe SearchPanelControl.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchPanelControl()
Public Sub New
public:
SearchPanelControl()
new : unit -> SearchPanelControl
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Proprietà di SearchPanelControl

Il tipo SearchPanelControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | Combo |
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Field | The field associated to the control
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | Label |
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Panel |
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Proprietà SearchPanelControl.Combo

Proprietà SearchPanelControlCombo

[Manca la documentazione <summary> per "P:InitPrtFast.SearchPanelControl.Combo"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ComboBoxEdit Combo { get; }
Public ReadOnly Property Combo As ComboBoxEdit
    Get
public:
property ComboBoxEdit^ Combo {
    ComboBoxEdit^ get ();
}
member Combo : ComboBoxEdit with get

Valore della proprietà

ComboBoxEdit
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Proprietà SearchPanelControl.Field

Proprietà SearchPanelControlField
The field associated to the control

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IField Field { get; set; }
Public Property Field As IField
    Get
    Set
public:
property IField^ Field {
    IField^ get ();
    void set (IField^ value);
}
member Field : IField with get, set

Valore della proprietà

IField
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Proprietà SearchPanelControl.Label

Proprietà SearchPanelControlLabel

[Manca la documentazione <summary> per "P:InitPrtFast.SearchPanelControl.Label"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public LabelControl Label { get; }
Public ReadOnly Property Label As LabelControl
    Get
public:
property LabelControl^ Label {
    LabelControl^ get ();
}
member Label : LabelControl with get

Valore della proprietà

LabelControl
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Proprietà SearchPanelControl.Panel

Proprietà SearchPanelControlPanel

[Manca la documentazione <summary> per "P:InitPrtFast.SearchPanelControl.Panel"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public PanelControl Panel { get; }
Public ReadOnly Property Panel As PanelControl
    Get
public:
property PanelControl^ Panel {
    PanelControl^ get ();
}
member Panel : PanelControl with get

Valore della proprietà

PanelControl
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Metodi di SearchPanelControl

Il tipo SearchPanelControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | GetIRoundedBorderProvider | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetBoundsCore | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Metodo SearchPanelControl.Dispose

Metodo SearchPanelControlDispose
Clean up any resources being used.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Eventi di SearchPanelControl

Il tipo SearchPanelControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe SearchPanelControl
Namespace InitPrtFast


Classe Utils

[Manca la documentazione <summary> per "T:InitPrtFast.Utils"]

Gerarchia di ereditarietà
SystemObject
InitPrtFastUtils

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class Utils
Public NotInheritable Class Utils
public ref class Utils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utils = class end

Il tipo Utils espone i seguenti membri.

Metodi
Nome | Descrizione
Array2String |
BuildEncodingsList | Get the available encodings
DetectTextFileEncoding | Detect the encoding of the text file
Log(Exception) | Utilità di logging delle Eccezionii
Log(String) | Utilità di logging degli errori
Log(Exception, LogMessageTypeEnum) | Utilità di logging delle Eccezionii
Log(String, LogMessageTypeEnum) | Utilità di logging degli errori
MoveItemT | Moves an item in a generic list forward or backward.
String2Array |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Metodi di Utils

Il tipo Utils espone i seguenti membri.

Metodi
Nome | Descrizione
Array2String |
BuildEncodingsList | Get the available encodings
DetectTextFileEncoding | Detect the encoding of the text file
Log(Exception) | Utilità di logging delle Eccezionii
Log(String) | Utilità di logging degli errori
Log(Exception, LogMessageTypeEnum) | Utilità di logging delle Eccezionii
Log(String, LogMessageTypeEnum) | Utilità di logging degli errori
MoveItemT | Moves an item in a generic list forward or backward.
String2Array |
Torna su
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Metodo Utils.Array2String

Metodo UtilsArray2String

[Manca la documentazione <summary> per "M:InitPrtFast.Utils.Array2String(System.String[])"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string Array2String(
    string[] values
)
Public Shared Function Array2String (
    values As String()
) As String
public:
static String^ Array2String(
    array<String^>^ values
)
static member Array2String :
        values : string[] -> string

Parametri

values String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Metodo Utils.BuildEncodingsList

Metodo UtilsBuildEncodingsList
Get the available encodings

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void BuildEncodingsList(
    out List<Encoding> encodings
)
Public Shared Sub BuildEncodingsList (
    <OutAttribute> ByRef encodings As List(Of Encoding)
)
public:
static void BuildEncodingsList(
    [OutAttribute] List<Encoding^>^% encodings
)
static member BuildEncodingsList :
        encodings : List<Encoding> byref -> unit

Parametri

encodings List Encoding
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Metodo Utils.DetectTextFileEncoding

Metodo UtilsDetectTextFileEncoding
Detect the encoding of the text file

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Encoding DetectTextFileEncoding(
    string filePath
)
Public Shared Function DetectTextFileEncoding (
    filePath As String
) As Encoding
public:
static Encoding^ DetectTextFileEncoding(
    String^ filePath
)
static member DetectTextFileEncoding :
        filePath : string -> Encoding

Parametri

filePath String

Valore di ritorno

Encoding
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Metodo Utils.Log

Metodo UtilsLog
Lista degli overload
Nome | Descrizione
Log(Exception) | Utilità di logging delle Eccezionii
Log(String) | Utilità di logging degli errori
Log(Exception, LogMessageTypeEnum) | Utilità di logging delle Eccezionii
Log(String, LogMessageTypeEnum) | Utilità di logging degli errori
Torna su
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Metodo Utils.Log(Exception)

Metodo UtilsLog(Exception)
Utilità di logging delle Eccezionii

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex
)
Public Shared Sub Log (
    ex As Exception
)
public:
static void Log(
    Exception^ ex
)
static member Log :
        ex : Exception -> unit

Parametri

ex Exception
Vedi anche

Documentazione

Classe Utils
Overload di Log
Namespace InitPrtFast


Metodo Utils.Log(String)

Metodo UtilsLog(String)
Utilità di logging degli errori

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    string msg
)
Public Shared Sub Log (
    msg As String
)
public:
static void Log(
    String^ msg
)
static member Log :
        msg : string -> unit

Parametri

msg String
Vedi anche

Documentazione

Classe Utils
Overload di Log
Namespace InitPrtFast


Metodo Utils.Log(Exception, LogMessageTypeEnum)

Metodo UtilsLog(Exception, LogMessageTypeEnum)
Utilità di logging delle Eccezionii

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex,
    LogMessageTypeEnum errType
)
Public Shared Sub Log (
    ex As Exception,
    errType As LogMessageTypeEnum
)
public:
static void Log(
    Exception^ ex,
    LogMessageTypeEnum errType
)
static member Log :
        ex : Exception *
        errType : LogMessageTypeEnum -> unit

Parametri

ex Exception
errType LogMessageTypeEnum
Vedi anche

Documentazione

Classe Utils
Overload di Log
Namespace InitPrtFast


Metodo Utils.Log(String, LogMessageTypeEnum)

Metodo UtilsLog(String, LogMessageTypeEnum)
Utilità di logging degli errori

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    string msg,
    LogMessageTypeEnum errType
)
Public Shared Sub Log (
    msg As String,
    errType As LogMessageTypeEnum
)
public:
static void Log(
    String^ msg,
    LogMessageTypeEnum errType
)
static member Log :
        msg : string *
        errType : LogMessageTypeEnum -> unit

Parametri

msg String
errType LogMessageTypeEnum
Vedi anche

Documentazione

Classe Utils
Overload di Log
Namespace InitPrtFast


Metodo Utils.MoveItem<T>

Metodo UtilsMoveItemT
Moves an item in a generic list forward or backward.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool MoveItem<T>(
    List<T> list,
    int idx,
    bool moveForward
)

Public Shared Function MoveItem(Of T) (
    list As List(Of T),
    idx As Integer,
    moveForward As Boolean
) As Boolean
public:
generic<typename T>
static bool MoveItem(
    List<T>^ list,
    int idx,
    bool moveForward
)
static member MoveItem :
        list : List<'T> *
        idx : int *
        moveForward : bool -> bool

Parametri

list List T
The list to modify.
idx Int32
The index of the item to move.
moveForward Boolean
True to move the item forward (to next position), false to move backward (to previous position).

Parametri di tipo

T
The type of elements in the list.

Valore di ritorno

Boolean
True if the move was successful, false if the index is out of range or the item cannot be moved in the specified direction.
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Metodo Utils.String2Array

Metodo UtilsString2Array

[Manca la documentazione <summary> per "M:InitPrtFast.Utils.String2Array(System.String)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] String2Array(
    string s
)
Public Shared Function String2Array (
    s As String
) As String()
public:
static array<String^>^ String2Array(
    String^ s
)
static member String2Array :
        s : string -> string[]

Parametri

s String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utils
Namespace InitPrtFast


Classe Utils.EncodingConverter

Classe UtilsEncodingConverter
Custom JsonConverter for Encoding
Gerarchia di ereditarietà
SystemObject
JsonConverter
InitPrtFastUtilsEncodingConverter

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class EncodingConverter : JsonConverter
Public Class EncodingConverter
    Inherits JsonConverter
public ref class EncodingConverter : public JsonConverter
type EncodingConverter =
    class
        inherit JsonConverter
    end

Il tipo UtilsEncodingConverter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilsEncodingConverter | Inizializza una nuova istanza della classe UtilsEncodingConverter.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore Utils.EncodingConverter

Costruttore UtilsEncodingConverter
Inizializza una nuova istanza della classe UtilsEncodingConverter.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public EncodingConverter()
Public Sub New
public:
EncodingConverter()
new : unit -> EncodingConverter
Vedi anche

Documentazione

Classe UtilsEncodingConverter
Namespace InitPrtFast


Proprietà di EncodingConverter

Il tipo UtilsEncodingConverter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Vedi anche

Documentazione

Classe UtilsEncodingConverter
Namespace InitPrtFast


Metodi di EncodingConverter

Il tipo UtilsEncodingConverter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Classe UtilsEncodingConverter
Namespace InitPrtFast


Metodo Utils.EncodingConverter.CanConvert

Metodo UtilsEncodingConverterCanConvert

[Manca la documentazione <summary> per "M:InitPrtFast.Utils.EncodingConverter.CanConvert(System.Type)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool CanConvert(
    Type objectType
)
Public Overrides Function CanConvert (
    objectType As Type
) As Boolean
public:
virtual bool CanConvert(
    Type^ objectType
) override
abstract CanConvert :
        objectType : Type -> bool
override CanConvert :
        objectType : Type -> bool

Parametri

objectType Type

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilsEncodingConverter
Namespace InitPrtFast


Metodo Utils.EncodingConverter.ReadJson

Metodo UtilsEncodingConverterReadJson

[Manca la documentazione <summary> per "M:InitPrtFast.Utils.EncodingConverter.ReadJson(Newtonsoft.Json.JsonReader,System.Type,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
Public Overrides Function ReadJson (
    reader As JsonReader,
    objectType As Type,
    existingValue As Object,
    serializer As JsonSerializer
) As Object
public:
virtual Object^ ReadJson(
    JsonReader^ reader,
    Type^ objectType,
    Object^ existingValue,
    JsonSerializer^ serializer
) override
abstract ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object
override ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object

Parametri

reader JsonReader
objectType Type
existingValue Object
serializer JsonSerializer

Valore di ritorno

Object
Vedi anche

Documentazione

Classe UtilsEncodingConverter
Namespace InitPrtFast


Metodo Utils.EncodingConverter.WriteJson

Metodo UtilsEncodingConverterWriteJson

[Manca la documentazione <summary> per "M:InitPrtFast.Utils.EncodingConverter.WriteJson(Newtonsoft.Json.JsonWriter,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Public Overrides Sub WriteJson (
    writer As JsonWriter,
    value As Object,
    serializer As JsonSerializer
)
public:
virtual void WriteJson(
    JsonWriter^ writer,
    Object^ value,
    JsonSerializer^ serializer
) override
abstract WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit
override WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit

Parametri

writer JsonWriter
value Object
serializer JsonSerializer
Vedi anche

Documentazione

Classe UtilsEncodingConverter
Namespace InitPrtFast


InitPrtFast.ConnType Namespace
Classi
 | Classe | Descrizione
Classe pubblica | ConnBase | Definisce i metodi di accesso all'oggetto della connessione. Impostare i campi su cui effettuare la query tramite la proprietà FieldList.
Classe pubblica | ConnDB | Classe che rappresenta la connessione a un DB.
Classe pubblica | ConnDBConnectionProvider |
Classe pubblica | ConnDBForm |
Classe pubblica | ConnFileFixedLenght | Classe che rappresenta la connessione a un file con elementi a spaziatura fissa. NON CORREGGERE IL NOME! USATO IN LUA.
Classe pubblica | ConnFileFixedLengthConnectionProvider | Provider for Fixed length data files
Classe pubblica | ConnFileFixedLengthForm |
Classe pubblica | ConnFileSeparator | Classe che rappresenta la connessione a un file con elementi separati con separatore.
Classe pubblica | ConnFileSeparatorConnectionProvider |
Classe pubblica | ConnFileSeparatorForm |
Classe pubblica | Field | Classe che rappresenta un campo generico.
Classe pubblica | FieldFileFixedLenght | Classe che rappresenta un campo a lunghezza fissa.
Classe pubblica | FieldFileFixedLengthListConverter | Required to deserialize Interfaces
Classe pubblica | FieldFileSeparator | Classe che rappresenta un campo con separatore.
Classe pubblica | FieldFileSeparatorListConverter | Required to deserialize Interfaces
Classe pubblica | FieldList | The list of fields
Classe pubblica | FieldListConverter | Required to deserialize Interfaces
Classe pubblica | SearchRule | Classe che rappresenta un singolo criterio di ricerca
Classe pubblica | SearchRules | Insieme di criteri di ricerca


Classe ConnBase
Definisce i metodi di accesso all'oggetto della connessione. Impostare i campi su cui effettuare la query tramite la proprietà FieldList.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnDB
InitPrtFast.ConnTypeConnFileFixedLenght

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class ConnBase : IConnection
Public MustInherit Class ConnBase
    Implements IConnection
public ref class ConnBase abstract : IConnection
[<AbstractClassAttribute>]
type ConnBase =
    class
        interface IConnection
    end

Il tipo ConnBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnBase | Costruttore della classe base.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato)
Proprietà pubblica | DataSource | The datasource to be connected to the grid
Proprietà pubblica | Description | A detailed description of the connection
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter
Proprietà pubblica | Ds | Data source
Proprietà pubblica | Editable | Is the connection source editable?
Proprietà pubblica | Fields |
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto
Proprietà pubblica | Id |
Proprietà pubblica | MultiSelect | Decide if multiselection is allowed or not
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio.
Proprietà pubblica | Prompt | Prompt della connessione.
Proprietà pubblica | RegistryBaseDir |
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio.
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearDataSource |
Metodo pubblico | Close | Called when disposing
Metodo pubblico | GetConnectionId |
Metodo pubblico | Run | Metodo per effettuare la query.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnBase
Costruttore della classe base.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnBase(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnBase(
    String^ prompt
)
new :
        prompt : string -> ConnBase

Parametri

prompt String
Prompt della connessione.
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà di ConnBase

Il tipo ConnBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato)
Proprietà pubblica | DataSource | The datasource to be connected to the grid
Proprietà pubblica | Description | A detailed description of the connection
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter
Proprietà pubblica | Ds | Data source
Proprietà pubblica | Editable | Is the connection source editable?
Proprietà pubblica | Fields |
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto
Proprietà pubblica | Id |
Proprietà pubblica | MultiSelect | Decide if multiselection is allowed or not
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio.
Proprietà pubblica | Prompt | Prompt della connessione.
Proprietà pubblica | RegistryBaseDir |
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio.
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded
Torna su
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.AutoComplete

Proprietà ConnBaseAutoComplete
Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato)

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoComplete { get; set; }
Public Property AutoComplete As Boolean
    Get
    Set
public:
virtual property bool AutoComplete {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutoComplete : bool with get, set
override AutoComplete : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.AutoComplete
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.DataSource

Proprietà ConnBaseDataSource
The datasource to be connected to the grid

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual Object DataSource { get; }
Public Overridable ReadOnly Property DataSource As Object
    Get
public:
virtual property Object^ DataSource {
    Object^ get ();
}
abstract DataSource : Object with get
override DataSource : Object with get

Valore della proprietà

Object

Implementa

IConnection.DataSource
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Description

Proprietà ConnBaseDescription
A detailed description of the connection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Description : string with get, set
override Description : string with get, set

Valore della proprietà

String

Implementa

IConnection.Description
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.DisableUpdateResultsOnLoad

Proprietà ConnBaseDisableUpdateResultsOnLoad
Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableUpdateResultsOnLoad { get; set; }
Public Property DisableUpdateResultsOnLoad As Boolean
    Get
    Set
public:
virtual property bool DisableUpdateResultsOnLoad {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract DisableUpdateResultsOnLoad : bool with get, set
override DisableUpdateResultsOnLoad : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.DisableUpdateResultsOnLoad
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Ds

Proprietà ConnBaseDs
Data source

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Ds { get; set; }
Public Property Ds As Object
    Get
    Set
public:
property Object^ Ds {
    Object^ get ();
    void set (Object^ value);
}
member Ds : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Editable

Proprietà ConnBaseEditable
Is the connection source editable?

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
virtual property bool Editable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Editable : bool with get, set
override Editable : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.Editable
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Fields

Proprietà ConnBaseFields

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.Fields"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IFieldList Fields { get; set; }
Public Property Fields As IFieldList
    Get
    Set
public:
virtual property IFieldList^ Fields {
    IFieldList^ get () sealed;
    void set (IFieldList^ value) sealed;
}
abstract Fields : IFieldList with get, set
override Fields : IFieldList with get, set

Valore della proprietà

IFieldList

Implementa

IConnection.Fields
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.FitColumnsOnSearch

Proprietà ConnBaseFitColumnsOnSearch
Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool FitColumnsOnSearch { get; set; }
Public Property FitColumnsOnSearch As Boolean
    Get
    Set
public:
virtual property bool FitColumnsOnSearch {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FitColumnsOnSearch : bool with get, set
override FitColumnsOnSearch : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.FitColumnsOnSearch
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Id

Proprietà ConnBaseId

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.Id"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string Id { get; }
Public Overridable ReadOnly Property Id As String
    Get
public:
virtual property String^ Id {
    String^ get ();
}
abstract Id : string with get
override Id : string with get

Valore della proprietà

String

Implementa

IConnection.Id
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.MultiSelect

Proprietà ConnBaseMultiSelect
Decide if multiselection is allowed or not

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool MultiSelect { get; set; }
Public Overridable Property MultiSelect As Boolean
    Get
    Set
public:
virtual property bool MultiSelect {
    bool get ();
    void set (bool value);
}
abstract MultiSelect : bool with get, set
override MultiSelect : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.MultiSelect
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Posname

Proprietà ConnBasePosname
Imposta/Restituice l'indice del campo che da il nome alla parte

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Posname { get; set; }
Public Property Posname As Integer
    Get
    Set
public:
virtual property int Posname {
    int get () sealed;
    void set (int value) sealed;
}
abstract Posname : int with get, set
override Posname : int with get, set

Valore della proprietà

Int32

Implementa

IConnection.Posname
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.PrecompileLastSearch

Proprietà ConnBasePrecompileLastSearch
Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrecompileLastSearch { get; set; }
Public Property PrecompileLastSearch As Boolean
    Get
    Set
public:
virtual property bool PrecompileLastSearch {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PrecompileLastSearch : bool with get, set
override PrecompileLastSearch : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.PrecompileLastSearch
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Prompt

Proprietà ConnBasePrompt
Prompt della connessione.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
virtual property String^ Prompt {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Prompt : string with get, set
override Prompt : string with get, set

Valore della proprietà

String

Implementa

IConnection.Prompt
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.RegistryBaseDir

Proprietà ConnBaseRegistryBaseDir

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.RegistryBaseDir"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseDir { get; }
Public ReadOnly Property RegistryBaseDir As String
    Get
public:
virtual property String^ RegistryBaseDir {
    String^ get () sealed;
}
abstract RegistryBaseDir : string with get
override RegistryBaseDir : string with get

Valore della proprietà

String

Implementa

IConnection.RegistryBaseDir
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.SearchOnEnter

Proprietà ConnBaseSearchOnEnter
Indica se la ricerca parte alla pressione del tasto invio.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool SearchOnEnter { get; set; }
Public Property SearchOnEnter As Boolean
    Get
    Set
public:
virtual property bool SearchOnEnter {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SearchOnEnter : bool with get, set
override SearchOnEnter : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.SearchOnEnter
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.SkipCallers

Proprietà ConnBaseSkipCallers
List of callers where the connection will not be loaded

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual List<string> SkipCallers { get; set; }
Public Overridable Property SkipCallers As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ SkipCallers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
abstract SkipCallers : List<string> with get, set
override SkipCallers : List<string> with get, set

Valore della proprietà

List String

Implementa

IConnection.SkipCallers
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodi di ConnBase

Il tipo ConnBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearDataSource |
Metodo pubblico | Close | Called when disposing
Metodo pubblico | GetConnectionId |
Metodo pubblico | Run | Metodo per effettuare la query.
Torna su
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodo ConnBase.ClearDataSource

Metodo ConnBaseClearDataSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnBase.ClearDataSource"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearDataSource()
Public Sub ClearDataSource
public:
virtual void ClearDataSource() sealed
abstract ClearDataSource : unit -> unit
override ClearDataSource : unit -> unit

Implementa

IConnection.ClearDataSource
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodo ConnBase.Close

Metodo ConnBaseClose
Called when disposing

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Close()
Public Overridable Sub Close
public:
virtual void Close()
abstract Close : unit -> unit
override Close : unit -> unit

Implementa

IConnection.Close
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodo ConnBase.GetConnectionId

Metodo ConnBaseGetConnectionId

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnBase.GetConnectionId"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string GetConnectionId()
Public MustOverride Function GetConnectionId As String
public:
virtual String^ GetConnectionId() abstract
abstract GetConnectionId : unit -> string

Valore di ritorno

String

Implementa

IConnection.GetConnectionId
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodo ConnBase.Run

Metodo ConnBaseRun
Metodo per effettuare la query.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void Run(
    ISearchRules search,
    Action onCompleted
)
Public MustOverride Sub Run (
    search As ISearchRules,
    onCompleted As Action
)
public:
virtual void Run(
    ISearchRules^ search,
    Action^ onCompleted
) abstract
abstract Run :
        search : ISearchRules *
        onCompleted : Action -> unit

Parametri

search ISearchRules
Criteri di ricerca scelti.
onCompleted Action

Implementa

IConnection.Run(ISearchRules, Action)
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Classe ConnDB
Classe che rappresenta la connessione a un DB.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnDB

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnDB : ConnBase, IConnection
Public Class ConnDB
    Inherits ConnBase
    Implements IConnection
public ref class ConnDB : public ConnBase,
    IConnection
type ConnDB =
    class
        inherit ConnBase
        interface IConnection
    end

Il tipo ConnDB espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnDB | Construttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato) (Ereditato da ConnBase)
Proprietà pubblica | Connection | Oggetto che gestisce la connessione al DB.
Proprietà pubblica | ConnectionString | Database connection string
Proprietà pubblica | DataSource | The datasource (Sovrascrive ConnBaseDataSource)
Proprietà pubblica | Description | A detailed description of the connection (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter (Ereditato da ConnBase)
Proprietà pubblica | Ds | Data source (Ereditato da ConnBase)
Proprietà pubblica | Editable | Is the connection source editable? (Ereditato da ConnBase)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto (Ereditato da ConnBase)
Proprietà pubblica | Id | (Sovrascrive ConnBaseId)
Proprietà pubblica | MultiSelect | Enable multi selection (Sovrascrive ConnBaseMultiSelect)
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio. (Ereditato da ConnBase)
Proprietà pubblica | Prompt | Prompt della connessione. (Ereditato da ConnBase)
Proprietà pubblica | ProviderName | Database provider name
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio. (Ereditato da ConnBase)
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded (Sovrascrive ConnBaseSkipCallers)
Proprietà pubblica | Table | Nome della tabella da cui leggere le anagrafiche.
Proprietà pubblica | WhereClause | Eventuale clausola where da aggiungere alla fine.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhere | Add the where clause
Metodo pubblico | ClearDataSource |
Metodo pubblico | Close | Close the connection (dispose) (Sovrascrive ConnBaseClose)
Metodo pubblico | GetConnectionId | Required in serialization/deserialization (Sovrascrive ConnBaseGetConnectionId)
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(ISearchRules, Action))
Torna su
Campi
Nome | Descrizione
InternalId | The ID if the connection
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnDB
Construttore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnDB(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnDB(
    String^ prompt
)
new :
        prompt : string -> ConnDB

Parametri

prompt String
Nome della connessione.
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà di ConnDB

Il tipo ConnDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato) (Ereditato da ConnBase)
Proprietà pubblica | Connection | Oggetto che gestisce la connessione al DB.
Proprietà pubblica | ConnectionString | Database connection string
Proprietà pubblica | DataSource | The datasource (Sovrascrive ConnBaseDataSource)
Proprietà pubblica | Description | A detailed description of the connection (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter (Ereditato da ConnBase)
Proprietà pubblica | Ds | Data source (Ereditato da ConnBase)
Proprietà pubblica | Editable | Is the connection source editable? (Ereditato da ConnBase)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto (Ereditato da ConnBase)
Proprietà pubblica | Id | (Sovrascrive ConnBaseId)
Proprietà pubblica | MultiSelect | Enable multi selection (Sovrascrive ConnBaseMultiSelect)
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio. (Ereditato da ConnBase)
Proprietà pubblica | Prompt | Prompt della connessione. (Ereditato da ConnBase)
Proprietà pubblica | ProviderName | Database provider name
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio. (Ereditato da ConnBase)
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded (Sovrascrive ConnBaseSkipCallers)
Proprietà pubblica | Table | Nome della tabella da cui leggere le anagrafiche.
Proprietà pubblica | WhereClause | Eventuale clausola where da aggiungere alla fine.
Torna su
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.Connection

Proprietà ConnDBConnection
Oggetto che gestisce la connessione al DB.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; set; }
Public Property Connection As QSConnection
    Get
    Set
public:
property QSConnection^ Connection {
    QSConnection^ get ();
    void set (QSConnection^ value);
}
member Connection : QSConnection with get, set

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.ConnectionString

Proprietà ConnDBConnectionString
Database connection string

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
member ConnectionString : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.DataSource

Proprietà ConnDBDataSource
The datasource

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object DataSource { get; }
Public Overrides ReadOnly Property DataSource As Object
    Get
public:
virtual property Object^ DataSource {
    Object^ get () override;
}
abstract DataSource : Object with get
override DataSource : Object with get

Valore della proprietà

Object

Implementa

IConnection.DataSource
IConnection.DataSource
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.Id

Proprietà ConnDBId

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnDB.Id"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string Id { get; }
Public Overrides ReadOnly Property Id As String
    Get
public:
virtual property String^ Id {
    String^ get () override;
}
abstract Id : string with get
override Id : string with get

Valore della proprietà

String

Implementa

IConnection.Id
IConnection.Id
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.MultiSelect

Proprietà ConnDBMultiSelect
Enable multi selection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool MultiSelect { get; set; }
Public Overrides Property MultiSelect As Boolean
    Get
    Set
public:
virtual property bool MultiSelect {
    bool get () override;
    void set (bool value) override;
}
abstract MultiSelect : bool with get, set
override MultiSelect : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.MultiSelect
IConnection.MultiSelect
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.ProviderName

Proprietà ConnDBProviderName
Database provider name

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
member ProviderName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.SkipCallers

Proprietà ConnDBSkipCallers
List of callers where the connection will not be loaded

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override List<string> SkipCallers { get; set; }
Public Overrides Property SkipCallers As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ SkipCallers {
    List<String^>^ get () override;
    void set (List<String^>^ value) override;
}
abstract SkipCallers : List<string> with get, set
override SkipCallers : List<string> with get, set

Valore della proprietà

List String

Implementa

IConnection.SkipCallers
IConnection.SkipCallers
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.Table

Proprietà ConnDBTable
Nome della tabella da cui leggere le anagrafiche.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Table { get; set; }
Public Property Table As String
    Get
    Set
public:
property String^ Table {
    String^ get ();
    void set (String^ value);
}
member Table : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.WhereClause

Proprietà ConnDBWhereClause
Eventuale clausola where da aggiungere alla fine.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string WhereClause { get; set; }
Public Property WhereClause As String
    Get
    Set
public:
property String^ WhereClause {
    String^ get ();
    void set (String^ value);
}
member WhereClause : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodi di ConnDB

Il tipo ConnDB espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhere | Add the where clause
Metodo pubblico | ClearDataSource |
Metodo pubblico | Close | Close the connection (dispose) (Sovrascrive ConnBaseClose)
Metodo pubblico | GetConnectionId | Required in serialization/deserialization (Sovrascrive ConnBaseGetConnectionId)
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(ISearchRules, Action))
Torna su
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.AddWhere

Metodo ConnDBAddWhere
Add the where clause

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhere(
    string wstr
)
Public Sub AddWhere (
    wstr As String
)
public:
void AddWhere(
    String^ wstr
)
member AddWhere :
        wstr : string -> unit

Parametri

wstr String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.ClearDataSource

Metodo ConnDBClearDataSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnDB.ClearDataSource"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearDataSource()
Public Sub ClearDataSource
public:
virtual void ClearDataSource() sealed
abstract ClearDataSource : unit -> unit
override ClearDataSource : unit -> unit

Implementa

IConnection.ClearDataSource
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.Close

Metodo ConnDBClose
Close the connection (dispose)

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit

Implementa

IConnection.Close
IConnection.Close
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.GetConnectionId

Metodo ConnDBGetConnectionId
Required in serialization/deserialization

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetConnectionId()
Public Overrides Function GetConnectionId As String
public:
virtual String^ GetConnectionId() override
abstract GetConnectionId : unit -> string
override GetConnectionId : unit -> string

Valore di ritorno

String

Implementa

IConnection.GetConnectionId
IConnection.GetConnectionId
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.Run

Metodo ConnDBRun
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Run(
    ISearchRules searchRules,
    Action onCompleted
)
Public Overrides Sub Run (
    searchRules As ISearchRules,
    onCompleted As Action
)
public:
virtual void Run(
    ISearchRules^ searchRules,
    Action^ onCompleted
) override
abstract Run :
        searchRules : ISearchRules *
        onCompleted : Action -> unit
override Run :
        searchRules : ISearchRules *
        onCompleted : Action -> unit

Parametri

searchRules ISearchRules
Regole per eseguire la ricerca
onCompleted Action

Valore di ritorno

Implementa

IConnection.Run(ISearchRules, Action)
IConnection.Run(ISearchRules, Action)
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Campi di ConnDB

Il tipo ConnDB espone i seguenti membri.

Campi
Nome | Descrizione
InternalId | The ID if the connection
Torna su
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Campo ConnDB.InternalId

Campo ConnDBInternalId
The ID if the connection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string InternalId
Public Shared InternalId As String
public:
static String^ InternalId
static val mutable InternalId: string

Valore del campo

String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Classe ConnDBConnectionProvider

[Manca la documentazione <summary> per "T:InitPrtFast.ConnType.ConnDBConnectionProvider"]

Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnDBConnectionProvider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnDBConnectionProvider : IConnectionProvider
Public Class ConnDBConnectionProvider
    Implements IConnectionProvider
public ref class ConnDBConnectionProvider : IConnectionProvider
type ConnDBConnectionProvider =
    class
        interface IConnectionProvider
    end

Il tipo ConnDBConnectionProvider espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnDBConnectionProvider | Inizializza una nuova istanza della classe ConnDBConnectionProvider.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | Description of the connection
Proprietà pubblica | HasConnectionEditor |
Proprietà pubblica | Name | The name of the connection
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Deserialize |
Metodo pubblico | EditConnection | Edit the conenction
Metodo pubblico | EditConnectionSource |
Metodo pubblico | Initialize | Initialize the provider
Metodo pubblico | IsAvailable | The enable/disable the provider
Metodo pubblico | NewConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | Serialize | Serialize the configuration to a file
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnDBConnectionProvider
Inizializza una nuova istanza della classe ConnDBConnectionProvider.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnDBConnectionProvider()
Public Sub New
public:
ConnDBConnectionProvider()
new : unit -> ConnDBConnectionProvider
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà di ConnDBConnectionProvider

Il tipo ConnDBConnectionProvider espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | Description of the connection
Proprietà pubblica | HasConnectionEditor |
Proprietà pubblica | Name | The name of the connection
Torna su
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnDBConnectionProvider.Description

Proprietà ConnDBConnectionProviderDescription
Description of the connection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Valore della proprietà

String

Implementa

IConnectionProvider.Description
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnDBConnectionProvider.HasConnectionEditor

Proprietà ConnDBConnectionProviderHasConnectionEditor

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnDBConnectionProvider.HasConnectionEditor"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasConnectionEditor { get; }
Public ReadOnly Property HasConnectionEditor As Boolean
    Get
public:
virtual property bool HasConnectionEditor {
    bool get () sealed;
}
abstract HasConnectionEditor : bool with get
override HasConnectionEditor : bool with get

Valore della proprietà

Boolean

Implementa

IConnectionProvider.HasConnectionEditor
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnDBConnectionProvider.Name

Proprietà ConnDBConnectionProviderName
The name of the connection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String

Implementa

IConnectionProvider.Name
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodi di ConnDBConnectionProvider

Il tipo ConnDBConnectionProvider espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Deserialize |
Metodo pubblico | EditConnection | Edit the conenction
Metodo pubblico | EditConnectionSource |
Metodo pubblico | Initialize | Initialize the provider
Metodo pubblico | IsAvailable | The enable/disable the provider
Metodo pubblico | NewConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | Serialize | Serialize the configuration to a file
Torna su
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.Deserialize

Metodo ConnDBConnectionProviderDeserialize

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnDBConnectionProvider.Deserialize(System.String,System.String)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Deserialize(
    string connectionId,
    string json
)
Public Function Deserialize (
    connectionId As String,
    json As String
) As IConnection
public:
virtual IConnection^ Deserialize(
    String^ connectionId,
    String^ json
) sealed
abstract Deserialize :
        connectionId : string *
        json : string -> IConnection
override Deserialize :
        connectionId : string *
        json : string -> IConnection

Parametri

connectionId String
json String

Valore di ritorno

IConnection

Implementa

IConnectionProvider.Deserialize(String, String)
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.EditConnection

Metodo ConnDBConnectionProviderEditConnection
Edit the conenction

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditConnection(
    IConnection connection,
    IConnectionEditorOptions options
)
Public Function EditConnection (
    connection As IConnection,
    options As IConnectionEditorOptions
) As Boolean
public:
virtual bool EditConnection(
    IConnection^ connection,
    IConnectionEditorOptions^ options
) sealed
abstract EditConnection :
        connection : IConnection *
        options : IConnectionEditorOptions -> bool
override EditConnection :
        connection : IConnection *
        options : IConnectionEditorOptions -> bool

Parametri

connection IConnection
options IConnectionEditorOptions

Valore di ritorno

Boolean

Implementa

IConnectionProvider.EditConnection(IConnection, IConnectionEditorOptions)
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.EditConnectionSource

Metodo ConnDBConnectionProviderEditConnectionSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnDBConnectionProvider.EditConnectionSource(InitPrtFastCommon.Interfaces.IConnection)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditConnectionSource(
    IConnection currConnection
)
Public Function EditConnectionSource (
    currConnection As IConnection
) As Boolean
public:
virtual bool EditConnectionSource(
    IConnection^ currConnection
) sealed
abstract EditConnectionSource :
        currConnection : IConnection -> bool
override EditConnectionSource :
        currConnection : IConnection -> bool

Parametri

currConnection IConnection

Valore di ritorno

Boolean

Implementa

IConnectionProvider.EditConnectionSource(IConnection)
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.Initialize

Metodo ConnDBConnectionProviderInitialize
Initialize the provider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
virtual void Initialize() sealed
abstract Initialize : unit -> unit
override Initialize : unit -> unit

Implementa

IConnectionProvider.Initialize
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.IsAvailable

Metodo ConnDBConnectionProviderIsAvailable
The enable/disable the provider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsAvailable()
Public Function IsAvailable As Boolean
public:
virtual bool IsAvailable() sealed
abstract IsAvailable : unit -> bool
override IsAvailable : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionProvider.IsAvailable
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.NewConnection

Metodo ConnDBConnectionProviderNewConnection

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnDBConnectionProvider.NewConnection(InitPrtFastCommon.Interfaces.IConnectionEditorOptions)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection NewConnection(
    IConnectionEditorOptions options
)
Public Function NewConnection (
    options As IConnectionEditorOptions
) As IConnection
public:
virtual IConnection^ NewConnection(
    IConnectionEditorOptions^ options
) sealed
abstract NewConnection :
        options : IConnectionEditorOptions -> IConnection
override NewConnection :
        options : IConnectionEditorOptions -> IConnection

Parametri

options IConnectionEditorOptions

Valore di ritorno

IConnection

Implementa

IConnectionProvider.NewConnection(IConnectionEditorOptions)
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.ResolveAssembly

Metodo ConnDBConnectionProviderResolveAssembly
Assembly resolution

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Assembly ResolveAssembly(
    ResolveEventArgs args
)
Public Function ResolveAssembly (
    args As ResolveEventArgs
) As Assembly
public:
virtual Assembly^ ResolveAssembly(
    ResolveEventArgs^ args
) sealed
abstract ResolveAssembly :
        args : ResolveEventArgs -> Assembly
override ResolveAssembly :
        args : ResolveEventArgs -> Assembly

Parametri

args ResolveEventArgs

Valore di ritorno

Assembly

Implementa

IConnectionProvider.ResolveAssembly(ResolveEventArgs)
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnDBConnectionProvider.Serialize

Metodo ConnDBConnectionProviderSerialize
Serialize the configuration to a file

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Serialize(
    IConnection newConnection,
    string path
)
Public Function Serialize (
    newConnection As IConnection,
    path As String
) As Boolean
public:
virtual bool Serialize(
    IConnection^ newConnection,
    String^ path
) sealed
abstract Serialize :
        newConnection : IConnection *
        path : string -> bool
override Serialize :
        newConnection : IConnection *
        path : string -> bool

Parametri

newConnection IConnection
path String

Valore di ritorno

Boolean

Implementa

IConnectionProvider.Serialize(IConnection, String)
Vedi anche

Documentazione

Classe ConnDBConnectionProvider
Namespace InitPrtFast.ConnType


Classe ConnDBForm

[Manca la documentazione <summary> per "T:InitPrtFast.ConnType.ConnDBForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
InitPrtFast.ConnTypeConnDBForm

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnDBForm : XtraForm, IConnectionEditorForm
Public Class ConnDBForm
    Inherits XtraForm
    Implements IConnectionEditorForm
public ref class ConnDBForm : public XtraForm,
    IConnectionEditorForm
type ConnDBForm =
    class
        inherit XtraForm
        interface IConnectionEditorForm
    end

Il tipo ConnDBForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnDBForm(IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnDBForm.
Metodo pubblico | ConnDBForm(IConnection, IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnDBForm.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Connection |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddField | Add the field
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
 | GetSQLiteTables | Required for SQLite connections
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsValidSourceConnectionData | Quick check for connection data
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo pubblico | UpdateDataPreview | Update the dta preview
Metodo pubblico | UpdateForm | Refresh the form from the data
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | ValidateConnection | Validate the conenction
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnDBForm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ConnDBForm(IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnDBForm.
Metodo pubblico | ConnDBForm(IConnection, IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnDBForm.
Torna su
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Costruttore ConnDBForm(IConnectionEditorOptions)
Inizializza una nuova istanza della classe ConnDBForm.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnDBForm(
    IConnectionEditorOptions options
)
Public Sub New (
    options As IConnectionEditorOptions
)
public:
ConnDBForm(
    IConnectionEditorOptions^ options
)
new :
        options : IConnectionEditorOptions -> ConnDBForm

Parametri

options IConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnDBForm
Overload di ConnDBForm
Namespace InitPrtFast.ConnType


Costruttore ConnDBForm(IConnection, IConnectionEditorOptions)
Inizializza una nuova istanza della classe ConnDBForm.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnDBForm(
    IConnection connection,
    IConnectionEditorOptions options
)
Public Sub New (
    connection As IConnection,
    options As IConnectionEditorOptions
)
public:
ConnDBForm(
    IConnection^ connection,
    IConnectionEditorOptions^ options
)
new :
        connection : IConnection *
        options : IConnectionEditorOptions -> ConnDBForm

Parametri

connection IConnection
options IConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnDBForm
Overload di ConnDBForm
Namespace InitPrtFast.ConnType


Proprietà di ConnDBForm

Il tipo ConnDBForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Connection |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Proprietà ConnDBForm.Connection

Proprietà ConnDBFormConnection

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnDBForm.Connection"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Connection { get; set; }
Public Property Connection As IConnection
    Get
    Set
public:
virtual property IConnection^ Connection {
    IConnection^ get () sealed;
    void set (IConnection^ value) sealed;
}
abstract Connection : IConnection with get, set
override Connection : IConnection with get, set

Valore della proprietà

IConnection

Implementa

IConnectionEditorForm.Connection
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodi di ConnDBForm

Il tipo ConnDBForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddField | Add the field
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
 | GetSQLiteTables | Required for SQLite connections
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsValidSourceConnectionData | Quick check for connection data
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo pubblico | UpdateDataPreview | Update the dta preview
Metodo pubblico | UpdateForm | Refresh the form from the data
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | ValidateConnection | Validate the conenction
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.AddField

Metodo ConnDBFormAddField
Add the field

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    int index
)
Public Sub AddField (
    fieldName As String,
    index As Integer
)
public:
virtual void AddField(
    String^ fieldName,
    int index
) sealed
abstract AddField :
        fieldName : string *
        index : int -> unit
override AddField :
        fieldName : string *
        index : int -> unit

Parametri

fieldName String
index Int32

Implementa

IConnectionEditorForm.AddField(String, Int32)
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.Dispose

Metodo ConnDBFormDispose
Clean up any resources being used.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.GetSQLiteTables

Metodo ConnDBFormGetSQLiteTables
Required for SQLite connections

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetSQLiteTables(
    QSConnection conn
)
Public Shared Function GetSQLiteTables (
    conn As QSConnection
) As List(Of String)
public:
static List<String^>^ GetSQLiteTables(
    QSConnection^ conn
)
static member GetSQLiteTables :
        conn : QSConnection -> List<string>

Parametri

conn QSConnection

Valore di ritorno

List String
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.IsValidSourceConnectionData

Metodo ConnDBFormIsValidSourceConnectionData
Quick check for connection data

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValidSourceConnectionData()
Public Function IsValidSourceConnectionData As Boolean
public:
virtual bool IsValidSourceConnectionData() sealed
abstract IsValidSourceConnectionData : unit -> bool
override IsValidSourceConnectionData : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionEditorForm.IsValidSourceConnectionData
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.UpdateDataPreview

Metodo ConnDBFormUpdateDataPreview
Update the dta preview

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateDataPreview()
Public Sub UpdateDataPreview
public:
virtual void UpdateDataPreview() sealed
abstract UpdateDataPreview : unit -> unit
override UpdateDataPreview : unit -> unit

Implementa

IConnectionEditorForm.UpdateDataPreview
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.UpdateForm

Metodo ConnDBFormUpdateForm
Refresh the form from the data

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateForm(
    bool updatePreview
)
Public Sub UpdateForm (
    updatePreview As Boolean
)
public:
virtual void UpdateForm(
    bool updatePreview
) sealed
abstract UpdateForm :
        updatePreview : bool -> unit
override UpdateForm :
        updatePreview : bool -> unit

Parametri

updatePreview Boolean

Implementa

IConnectionEditorForm.UpdateForm(Boolean)
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Metodo ConnDBForm.ValidateConnection

Metodo ConnDBFormValidateConnection
Validate the conenction

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateConnection()
Public Function ValidateConnection As Boolean
public:
virtual bool ValidateConnection() sealed
abstract ValidateConnection : unit -> bool
override ValidateConnection : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionEditorForm.ValidateConnection
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Eventi di ConnDBForm

Il tipo ConnDBForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Campi di ConnDBForm

Il tipo ConnDBForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnDBForm
Namespace InitPrtFast.ConnType


Classe ConnFileFixedLenght
Classe che rappresenta la connessione a un file con elementi a spaziatura fissa. NON CORREGGERE IL NOME! USATO IN LUA.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnFileFixedLenght
InitPrtFast.ConnTypeConnFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileFixedLenght : ConnBase
Public Class ConnFileFixedLenght
    Inherits ConnBase
public ref class ConnFileFixedLenght : public ConnBase
type ConnFileFixedLenght =
    class
        inherit ConnBase
    end

Il tipo ConnFileFixedLenght espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileFixedLenght | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato) (Ereditato da ConnBase)
Proprietà pubblica | DataSource | Expose the datasource (Sovrascrive ConnBaseDataSource)
Proprietà pubblica | Description | A detailed description of the connection (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter (Ereditato da ConnBase)
Proprietà pubblica | Ds | Data source (Ereditato da ConnBase)
Proprietà pubblica | Editable | Is the connection source editable? (Ereditato da ConnBase)
Proprietà pubblica | Encoding | Indica il tipo di codifica del file.
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData | Percorso del file contenente le anagrafiche.
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto (Ereditato da ConnBase)
Proprietà pubblica | Id | (Sovrascrive ConnBaseId)
Proprietà pubblica | MultiSelect | Enable multi selection (Sovrascrive ConnBaseMultiSelect)
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio. (Ereditato da ConnBase)
Proprietà pubblica | Prompt | Prompt della connessione. (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio. (Ereditato da ConnBase)
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded (Sovrascrive ConnBaseSkipCallers)
Proprietà pubblica | SkipHeaders | Skip the first row (headers)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearDataSource |
Metodo pubblico | Close | Called when disposing (Ereditato da ConnBase)
Metodo pubblico | GetConnectionId | Required in serialization/deserialization (Sovrascrive ConnBaseGetConnectionId)
Metodo protetto | ReadLine | Legge la linea del file.
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(ISearchRules, Action))
Torna su
Campi
Nome | Descrizione
InternalId | The ID if the connection
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileFixedLenght
Costruttore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileFixedLenght(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnFileFixedLenght(
    String^ prompt
)
new :
        prompt : string -> ConnFileFixedLenght

Parametri

prompt String
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà di ConnFileFixedLenght

Il tipo ConnFileFixedLenght espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato) (Ereditato da ConnBase)
Proprietà pubblica | DataSource | Expose the datasource (Sovrascrive ConnBaseDataSource)
Proprietà pubblica | Description | A detailed description of the connection (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter (Ereditato da ConnBase)
Proprietà pubblica | Ds | Data source (Ereditato da ConnBase)
Proprietà pubblica | Editable | Is the connection source editable? (Ereditato da ConnBase)
Proprietà pubblica | Encoding | Indica il tipo di codifica del file.
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData | Percorso del file contenente le anagrafiche.
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto (Ereditato da ConnBase)
Proprietà pubblica | Id | (Sovrascrive ConnBaseId)
Proprietà pubblica | MultiSelect | Enable multi selection (Sovrascrive ConnBaseMultiSelect)
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio. (Ereditato da ConnBase)
Proprietà pubblica | Prompt | Prompt della connessione. (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio. (Ereditato da ConnBase)
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded (Sovrascrive ConnBaseSkipCallers)
Proprietà pubblica | SkipHeaders | Skip the first row (headers)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.DataSource

Proprietà ConnFileFixedLenghtDataSource
Expose the datasource

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object DataSource { get; }
Public Overrides ReadOnly Property DataSource As Object
    Get
public:
virtual property Object^ DataSource {
    Object^ get () override;
}
abstract DataSource : Object with get
override DataSource : Object with get

Valore della proprietà

Object

Implementa

IConnection.DataSource
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.Encoding

Proprietà ConnFileFixedLenghtEncoding
Indica il tipo di codifica del file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Valore della proprietà

Encoding
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.FileData

Proprietà ConnFileFixedLenghtFileData
Percorso del file contenente le anagrafiche.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FileData { get; set; }
Public Property FileData As String
    Get
    Set
public:
property String^ FileData {
    String^ get ();
    void set (String^ value);
}
member FileData : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.Id

Proprietà ConnFileFixedLenghtId

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileFixedLenght.Id"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string Id { get; }
Public Overrides ReadOnly Property Id As String
    Get
public:
virtual property String^ Id {
    String^ get () override;
}
abstract Id : string with get
override Id : string with get

Valore della proprietà

String

Implementa

IConnection.Id
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.MultiSelect

Proprietà ConnFileFixedLenghtMultiSelect
Enable multi selection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool MultiSelect { get; set; }
Public Overrides Property MultiSelect As Boolean
    Get
    Set
public:
virtual property bool MultiSelect {
    bool get () override;
    void set (bool value) override;
}
abstract MultiSelect : bool with get, set
override MultiSelect : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.MultiSelect
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.SkipCallers

Proprietà ConnFileFixedLenghtSkipCallers
List of callers where the connection will not be loaded

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override List<string> SkipCallers { get; set; }
Public Overrides Property SkipCallers As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ SkipCallers {
    List<String^>^ get () override;
    void set (List<String^>^ value) override;
}
abstract SkipCallers : List<string> with get, set
override SkipCallers : List<string> with get, set

Valore della proprietà

List String

Implementa

IConnection.SkipCallers
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.SkipHeaders

Proprietà ConnFileFixedLenghtSkipHeaders
Skip the first row (headers)

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool SkipHeaders { get; set; }
Public Overridable Property SkipHeaders As Boolean
    Get
    Set
public:
virtual property bool SkipHeaders {
    bool get ();
    void set (bool value);
}
abstract SkipHeaders : bool with get, set
override SkipHeaders : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodi di ConnFileFixedLenght

Il tipo ConnFileFixedLenght espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearDataSource |
Metodo pubblico | Close | Called when disposing (Ereditato da ConnBase)
Metodo pubblico | GetConnectionId | Required in serialization/deserialization (Sovrascrive ConnBaseGetConnectionId)
Metodo protetto | ReadLine | Legge la linea del file.
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(ISearchRules, Action))
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.ClearDataSource

Metodo ConnFileFixedLenghtClearDataSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLenght.ClearDataSource"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void ClearDataSource()
Public Overridable Sub ClearDataSource
public:
virtual void ClearDataSource()
abstract ClearDataSource : unit -> unit
override ClearDataSource : unit -> unit
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.GetConnectionId

Metodo ConnFileFixedLenghtGetConnectionId
Required in serialization/deserialization

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetConnectionId()
Public Overrides Function GetConnectionId As String
public:
virtual String^ GetConnectionId() override
abstract GetConnectionId : unit -> string
override GetConnectionId : unit -> string

Valore di ritorno

String

Implementa

IConnection.GetConnectionId
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.ReadLine

Metodo ConnFileFixedLenghtReadLine
Legge la linea del file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void ReadLine(
    DataTable t,
    string line
)
Protected Overridable Sub ReadLine (
    t As DataTable,
    line As String
)
protected:
virtual void ReadLine(
    DataTable^ t,
    String^ line
)
abstract ReadLine :
        t : DataTable *
        line : string -> unit
override ReadLine :
        t : DataTable *
        line : string -> unit

Parametri

t DataTable
Data table da riempire con i valori della linea.
line String
Linea da valutare.
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.Run

Metodo ConnFileFixedLenghtRun
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Run(
    ISearchRules search,
    Action onCompleted
)
Public Overrides Sub Run (
    search As ISearchRules,
    onCompleted As Action
)
public:
virtual void Run(
    ISearchRules^ search,
    Action^ onCompleted
) override
abstract Run :
        search : ISearchRules *
        onCompleted : Action -> unit
override Run :
        search : ISearchRules *
        onCompleted : Action -> unit

Parametri

search ISearchRules
Dizionario contenente le coppie colonna - valore da cercare
onCompleted Action

Valore di ritorno

Implementa

IConnection.Run(ISearchRules, Action)
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Campi di ConnFileFixedLenght

Il tipo ConnFileFixedLenght espone i seguenti membri.

Campi
Nome | Descrizione
InternalId | The ID if the connection
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Campo ConnFileFixedLenght.InternalId

Campo ConnFileFixedLenghtInternalId
The ID if the connection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string InternalId
Public Shared InternalId As String
public:
static String^ InternalId
static val mutable InternalId: string

Valore del campo

String
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Classe ConnFileFixedLengthConnectionProvider
Provider for Fixed length data files
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnFileFixedLengthConnectionProvider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileFixedLengthConnectionProvider : IConnectionProvider
Public Class ConnFileFixedLengthConnectionProvider
    Implements IConnectionProvider
public ref class ConnFileFixedLengthConnectionProvider : IConnectionProvider
type ConnFileFixedLengthConnectionProvider =
    class
        interface IConnectionProvider
    end

Il tipo ConnFileFixedLengthConnectionProvider espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileFixedLengthConnectionProvider | Inizializza una nuova istanza della classe ConnFileFixedLengthConnectionProvider.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description |
Proprietà pubblica | HasConnectionEditor | no editor for now
Proprietà pubblica | Name |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Deserialize |
Metodo pubblico | EditConnection | Edit the conenction
Metodo pubblico | EditConnectionSource |
Metodo pubblico | Initialize | Initialize the provider
Metodo pubblico | IsAvailable | The enable/disable the provider
Metodo pubblico | NewConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | Serialize | Serialize the connection to a file
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileFixedLengthConnectionProvider
Inizializza una nuova istanza della classe ConnFileFixedLengthConnectionProvider.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileFixedLengthConnectionProvider()
Public Sub New
public:
ConnFileFixedLengthConnectionProvider()
new : unit -> ConnFileFixedLengthConnectionProvider
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà di ConnFileFixedLengthConnectionProvider

Il tipo ConnFileFixedLengthConnectionProvider espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description |
Proprietà pubblica | HasConnectionEditor | no editor for now
Proprietà pubblica | Name |
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLengthConnectionProvider.Description

Proprietà ConnFileFixedLengthConnectionProviderDescription

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileFixedLengthConnectionProvider.Description"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Valore della proprietà

String

Implementa

IConnectionProvider.Description
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLengthConnectionProvider.HasConnectionEditor

Proprietà ConnFileFixedLengthConnectionProviderHasConnectionEditor
no editor for now

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasConnectionEditor { get; }
Public ReadOnly Property HasConnectionEditor As Boolean
    Get
public:
virtual property bool HasConnectionEditor {
    bool get () sealed;
}
abstract HasConnectionEditor : bool with get
override HasConnectionEditor : bool with get

Valore della proprietà

Boolean

Implementa

IConnectionProvider.HasConnectionEditor
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLengthConnectionProvider.Name

Proprietà ConnFileFixedLengthConnectionProviderName

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileFixedLengthConnectionProvider.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String

Implementa

IConnectionProvider.Name
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodi di ConnFileFixedLengthConnectionProvider

Il tipo ConnFileFixedLengthConnectionProvider espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Deserialize |
Metodo pubblico | EditConnection | Edit the conenction
Metodo pubblico | EditConnectionSource |
Metodo pubblico | Initialize | Initialize the provider
Metodo pubblico | IsAvailable | The enable/disable the provider
Metodo pubblico | NewConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | Serialize | Serialize the connection to a file
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.Deserialize

Metodo ConnFileFixedLengthConnectionProviderDeserialize

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthConnectionProvider.Deserialize(System.String,System.String)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Deserialize(
    string connectionId,
    string json
)
Public Function Deserialize (
    connectionId As String,
    json As String
) As IConnection
public:
virtual IConnection^ Deserialize(
    String^ connectionId,
    String^ json
) sealed
abstract Deserialize :
        connectionId : string *
        json : string -> IConnection
override Deserialize :
        connectionId : string *
        json : string -> IConnection

Parametri

connectionId String
json String

Valore di ritorno

IConnection

Implementa

IConnectionProvider.Deserialize(String, String)
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.EditConnection

Metodo ConnFileFixedLengthConnectionProviderEditConnection
Edit the conenction

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditConnection(
    IConnection connection,
    IConnectionEditorOptions options
)
Public Function EditConnection (
    connection As IConnection,
    options As IConnectionEditorOptions
) As Boolean
public:
virtual bool EditConnection(
    IConnection^ connection,
    IConnectionEditorOptions^ options
) sealed
abstract EditConnection :
        connection : IConnection *
        options : IConnectionEditorOptions -> bool
override EditConnection :
        connection : IConnection *
        options : IConnectionEditorOptions -> bool

Parametri

connection IConnection
options IConnectionEditorOptions

Valore di ritorno

Boolean

Implementa

IConnectionProvider.EditConnection(IConnection, IConnectionEditorOptions)
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.EditConnectionSource

Metodo ConnFileFixedLengthConnectionProviderEditConnectionSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthConnectionProvider.EditConnectionSource(InitPrtFastCommon.Interfaces.IConnection)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditConnectionSource(
    IConnection currConnection
)
Public Function EditConnectionSource (
    currConnection As IConnection
) As Boolean
public:
virtual bool EditConnectionSource(
    IConnection^ currConnection
) sealed
abstract EditConnectionSource :
        currConnection : IConnection -> bool
override EditConnectionSource :
        currConnection : IConnection -> bool

Parametri

currConnection IConnection

Valore di ritorno

Boolean

Implementa

IConnectionProvider.EditConnectionSource(IConnection)
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.Initialize

Metodo ConnFileFixedLengthConnectionProviderInitialize
Initialize the provider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
virtual void Initialize() sealed
abstract Initialize : unit -> unit
override Initialize : unit -> unit

Implementa

IConnectionProvider.Initialize
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.IsAvailable

Metodo ConnFileFixedLengthConnectionProviderIsAvailable
The enable/disable the provider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsAvailable()
Public Function IsAvailable As Boolean
public:
virtual bool IsAvailable() sealed
abstract IsAvailable : unit -> bool
override IsAvailable : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionProvider.IsAvailable
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.NewConnection

Metodo ConnFileFixedLengthConnectionProviderNewConnection

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthConnectionProvider.NewConnection(InitPrtFastCommon.Interfaces.IConnectionEditorOptions)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection NewConnection(
    IConnectionEditorOptions options
)
Public Function NewConnection (
    options As IConnectionEditorOptions
) As IConnection
public:
virtual IConnection^ NewConnection(
    IConnectionEditorOptions^ options
) sealed
abstract NewConnection :
        options : IConnectionEditorOptions -> IConnection
override NewConnection :
        options : IConnectionEditorOptions -> IConnection

Parametri

options IConnectionEditorOptions

Valore di ritorno

IConnection

Implementa

IConnectionProvider.NewConnection(IConnectionEditorOptions)
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.ResolveAssembly

Metodo ConnFileFixedLengthConnectionProviderResolveAssembly
Assembly resolution

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Assembly ResolveAssembly(
    ResolveEventArgs args
)
Public Function ResolveAssembly (
    args As ResolveEventArgs
) As Assembly
public:
virtual Assembly^ ResolveAssembly(
    ResolveEventArgs^ args
) sealed
abstract ResolveAssembly :
        args : ResolveEventArgs -> Assembly
override ResolveAssembly :
        args : ResolveEventArgs -> Assembly

Parametri

args ResolveEventArgs

Valore di ritorno

Assembly

Implementa

IConnectionProvider.ResolveAssembly(ResolveEventArgs)
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthConnectionProvider.Serialize

Metodo ConnFileFixedLengthConnectionProviderSerialize
Serialize the connection to a file

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Serialize(
    IConnection newConnection,
    string path
)
Public Function Serialize (
    newConnection As IConnection,
    path As String
) As Boolean
public:
virtual bool Serialize(
    IConnection^ newConnection,
    String^ path
) sealed
abstract Serialize :
        newConnection : IConnection *
        path : string -> bool
override Serialize :
        newConnection : IConnection *
        path : string -> bool

Parametri

newConnection IConnection
path String

Valore di ritorno

Boolean

Implementa

IConnectionProvider.Serialize(IConnection, String)
Vedi anche

Documentazione

Classe ConnFileFixedLengthConnectionProvider
Namespace InitPrtFast.ConnType


Classe ConnFileFixedLengthForm

[Manca la documentazione <summary> per "T:InitPrtFast.ConnType.ConnFileFixedLengthForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
InitPrtFast.ConnTypeConnFileFixedLengthForm

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileFixedLengthForm : XtraForm,
    IConnectionEditorForm
Public Class ConnFileFixedLengthForm
    Inherits XtraForm
    Implements IConnectionEditorForm
public ref class ConnFileFixedLengthForm : public XtraForm,
    IConnectionEditorForm
type ConnFileFixedLengthForm =
    class
        inherit XtraForm
        interface IConnectionEditorForm
    end

Il tipo ConnFileFixedLengthForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileFixedLengthForm(IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileFixedLengthForm.
Metodo pubblico | ConnFileFixedLengthForm(IConnection, IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileFixedLengthForm.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Connection |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddField |
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsValidSourceConnectionData | Make sure we have a valid connection data
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo pubblico | UpdateDataPreview |
Metodo pubblico | UpdateForm |
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | ValidateConnection |
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileFixedLengthForm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ConnFileFixedLengthForm(IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileFixedLengthForm.
Metodo pubblico | ConnFileFixedLengthForm(IConnection, IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileFixedLengthForm.
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Costruttore ConnFileFixedLengthForm(IConnectionEditorOptions)
Inizializza una nuova istanza della classe ConnFileFixedLengthForm.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileFixedLengthForm(
    IConnectionEditorOptions options
)
Public Sub New (
    options As IConnectionEditorOptions
)
public:
ConnFileFixedLengthForm(
    IConnectionEditorOptions^ options
)
new :
        options : IConnectionEditorOptions -> ConnFileFixedLengthForm

Parametri

options IConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Overload di ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Costruttore ConnFileFixedLengthForm(IConnection, IConnectionEditorOptions)
Inizializza una nuova istanza della classe ConnFileFixedLengthForm.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileFixedLengthForm(
    IConnection connection,
    IConnectionEditorOptions options
)
Public Sub New (
    connection As IConnection,
    options As IConnectionEditorOptions
)
public:
ConnFileFixedLengthForm(
    IConnection^ connection,
    IConnectionEditorOptions^ options
)
new :
        connection : IConnection *
        options : IConnectionEditorOptions -> ConnFileFixedLengthForm

Parametri

connection IConnection
options IConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Overload di ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Proprietà di ConnFileFixedLengthForm

Il tipo ConnFileFixedLengthForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Connection |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLengthForm.Connection

Proprietà ConnFileFixedLengthFormConnection

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileFixedLengthForm.Connection"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Connection { get; set; }
Public Property Connection As IConnection
    Get
    Set
public:
virtual property IConnection^ Connection {
    IConnection^ get () sealed;
    void set (IConnection^ value) sealed;
}
abstract Connection : IConnection with get, set
override Connection : IConnection with get, set

Valore della proprietà

IConnection

Implementa

IConnectionEditorForm.Connection
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodi di ConnFileFixedLengthForm

Il tipo ConnFileFixedLengthForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddField |
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsValidSourceConnectionData | Make sure we have a valid connection data
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo pubblico | UpdateDataPreview |
Metodo pubblico | UpdateForm |
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | ValidateConnection |
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthForm.AddField

Metodo ConnFileFixedLengthFormAddField

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthForm.AddField(System.String,System.Int32)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    int index
)
Public Sub AddField (
    fieldName As String,
    index As Integer
)
public:
virtual void AddField(
    String^ fieldName,
    int index
) sealed
abstract AddField :
        fieldName : string *
        index : int -> unit
override AddField :
        fieldName : string *
        index : int -> unit

Parametri

fieldName String
index Int32

Implementa

IConnectionEditorForm.AddField(String, Int32)
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthForm.Dispose

Metodo ConnFileFixedLengthFormDispose
Clean up any resources being used.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthForm.IsValidSourceConnectionData

Metodo ConnFileFixedLengthFormIsValidSourceConnectionData
Make sure we have a valid connection data

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValidSourceConnectionData()
Public Function IsValidSourceConnectionData As Boolean
public:
virtual bool IsValidSourceConnectionData() sealed
abstract IsValidSourceConnectionData : unit -> bool
override IsValidSourceConnectionData : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionEditorForm.IsValidSourceConnectionData
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthForm.UpdateDataPreview

Metodo ConnFileFixedLengthFormUpdateDataPreview

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthForm.UpdateDataPreview"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateDataPreview()
Public Sub UpdateDataPreview
public:
virtual void UpdateDataPreview() sealed
abstract UpdateDataPreview : unit -> unit
override UpdateDataPreview : unit -> unit

Implementa

IConnectionEditorForm.UpdateDataPreview
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthForm.UpdateForm

Metodo ConnFileFixedLengthFormUpdateForm

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthForm.UpdateForm(System.Boolean)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateForm(
    bool updatePreview
)
Public Sub UpdateForm (
    updatePreview As Boolean
)
public:
virtual void UpdateForm(
    bool updatePreview
) sealed
abstract UpdateForm :
        updatePreview : bool -> unit
override UpdateForm :
        updatePreview : bool -> unit

Parametri

updatePreview Boolean

Implementa

IConnectionEditorForm.UpdateForm(Boolean)
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLengthForm.ValidateConnection

Metodo ConnFileFixedLengthFormValidateConnection

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileFixedLengthForm.ValidateConnection"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateConnection()
Public Function ValidateConnection As Boolean
public:
virtual bool ValidateConnection() sealed
abstract ValidateConnection : unit -> bool
override ValidateConnection : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionEditorForm.ValidateConnection
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Eventi di ConnFileFixedLengthForm

Il tipo ConnFileFixedLengthForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Campi di ConnFileFixedLengthForm

Il tipo ConnFileFixedLengthForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLengthForm
Namespace InitPrtFast.ConnType


Classe ConnFileSeparator
Classe che rappresenta la connessione a un file con elementi separati con separatore.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnFileFixedLenght
InitPrtFast.ConnTypeConnFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileSeparator : ConnFileFixedLenght
Public Class ConnFileSeparator
    Inherits ConnFileFixedLenght
public ref class ConnFileSeparator : public ConnFileFixedLenght
type ConnFileSeparator =
    class
        inherit ConnFileFixedLenght
    end

Il tipo ConnFileSeparator espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileSeparator | Inizializza una nuova istanza della classe ConnFileSeparator.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato) (Ereditato da ConnBase)
Proprietà pubblica | DataSource | The datasource (Sovrascrive ConnFileFixedLenghtDataSource)
Proprietà pubblica | Description | A detailed description of the connection (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter (Ereditato da ConnBase)
Proprietà pubblica | Ds | Data source (Ereditato da ConnBase)
Proprietà pubblica | Editable | Is the connection source editable? (Ereditato da ConnBase)
Proprietà pubblica | Encoding | Indica il tipo di codifica del file. (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData | Percorso del file contenente le anagrafiche. (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto (Ereditato da ConnBase)
Proprietà pubblica | Id | (Sovrascrive ConnFileFixedLenghtId)
Proprietà pubblica | MultiSelect | Enable multi selection (Sovrascrive ConnFileFixedLenghtMultiSelect)
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio. (Ereditato da ConnBase)
Proprietà pubblica | Prompt | Prompt della connessione. (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio. (Ereditato da ConnBase)
Proprietà pubblica | Separator | the fields separator
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded (Sovrascrive ConnFileFixedLenghtSkipCallers)
Proprietà pubblica | SkipHeaders | Skip the first row (headers) (Sovrascrive ConnFileFixedLenghtSkipHeaders)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearDataSource | (Sovrascrive ConnFileFixedLenghtClearDataSource)
Metodo pubblico | Close | Called when disposing (Ereditato da ConnBase)
Metodo pubblico | GetConnectionId | Required in serialization/deserialization (Sovrascrive ConnFileFixedLenghtGetConnectionId)
Metodo protetto | ReadLine | Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable. (Sovrascrive ConnFileFixedLenghtReadLine(DataTable, String))
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnFileFixedLenghtRun(ISearchRules, Action))
Torna su
Campi
Nome | Descrizione
InternalId | The ID if the connection
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileSeparator
Inizializza una nuova istanza della classe ConnFileSeparator.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileSeparator(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnFileSeparator(
    String^ prompt
)
new :
        prompt : string -> ConnFileSeparator

Parametri

prompt String
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà di ConnFileSeparator

Il tipo ConnFileSeparator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | Indica se disabilitare l'auto-completamento del combobox mentre sto digitando. Di default è True (cioè abilitato) (Ereditato da ConnBase)
Proprietà pubblica | DataSource | The datasource (Sovrascrive ConnFileFixedLenghtDataSource)
Proprietà pubblica | Description | A detailed description of the connection (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | Indica se disabilitare l'update automatico dei risulta all'avvio in modalità SearchOnEnter (Ereditato da ConnBase)
Proprietà pubblica | Ds | Data source (Ereditato da ConnBase)
Proprietà pubblica | Editable | Is the connection source editable? (Ereditato da ConnBase)
Proprietà pubblica | Encoding | Indica il tipo di codifica del file. (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData | Percorso del file contenente le anagrafiche. (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | FitColumnsOnSearch | Indica se ad ogni ricerca le colonne devono adattarsi in base al contenuto (Ereditato da ConnBase)
Proprietà pubblica | Id | (Sovrascrive ConnFileFixedLenghtId)
Proprietà pubblica | MultiSelect | Enable multi selection (Sovrascrive ConnFileFixedLenghtMultiSelect)
Proprietà pubblica | Posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | Indica se precompilare i filtri con l'ulitma ricerca effettuate nel caso di ricerca su Invio. (Ereditato da ConnBase)
Proprietà pubblica | Prompt | Prompt della connessione. (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | Indica se la ricerca parte alla pressione del tasto invio. (Ereditato da ConnBase)
Proprietà pubblica | Separator | the fields separator
Proprietà pubblica | SkipCallers | List of callers where the connection will not be loaded (Sovrascrive ConnFileFixedLenghtSkipCallers)
Proprietà pubblica | SkipHeaders | Skip the first row (headers) (Sovrascrive ConnFileFixedLenghtSkipHeaders)
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.DataSource

Proprietà ConnFileSeparatorDataSource
The datasource

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object DataSource { get; }
Public Overrides ReadOnly Property DataSource As Object
    Get
public:
virtual property Object^ DataSource {
    Object^ get () override;
}
abstract DataSource : Object with get
override DataSource : Object with get

Valore della proprietà

Object

Implementa

IConnection.DataSource
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.Id

Proprietà ConnFileSeparatorId

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileSeparator.Id"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string Id { get; }
Public Overrides ReadOnly Property Id As String
    Get
public:
virtual property String^ Id {
    String^ get () override;
}
abstract Id : string with get
override Id : string with get

Valore della proprietà

String

Implementa

IConnection.Id
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.MultiSelect

Proprietà ConnFileSeparatorMultiSelect
Enable multi selection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool MultiSelect { get; set; }
Public Overrides Property MultiSelect As Boolean
    Get
    Set
public:
virtual property bool MultiSelect {
    bool get () override;
    void set (bool value) override;
}
abstract MultiSelect : bool with get, set
override MultiSelect : bool with get, set

Valore della proprietà

Boolean

Implementa

IConnection.MultiSelect
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.Separator

Proprietà ConnFileSeparatorSeparator
the fields separator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public char Separator { get; set; }
Public Property Separator As Char
    Get
    Set
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}
member Separator : char with get, set

Valore della proprietà

Char
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.SkipCallers

Proprietà ConnFileSeparatorSkipCallers
List of callers where the connection will not be loaded

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override List<string> SkipCallers { get; set; }
Public Overrides Property SkipCallers As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ SkipCallers {
    List<String^>^ get () override;
    void set (List<String^>^ value) override;
}
abstract SkipCallers : List<string> with get, set
override SkipCallers : List<string> with get, set

Valore della proprietà

List String

Implementa

IConnection.SkipCallers
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.SkipHeaders

Proprietà ConnFileSeparatorSkipHeaders
Skip the first row (headers)

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SkipHeaders { get; set; }
Public Overrides Property SkipHeaders As Boolean
    Get
    Set
public:
virtual property bool SkipHeaders {
    bool get () override;
    void set (bool value) override;
}
abstract SkipHeaders : bool with get, set
override SkipHeaders : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodi di ConnFileSeparator

Il tipo ConnFileSeparator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearDataSource | (Sovrascrive ConnFileFixedLenghtClearDataSource)
Metodo pubblico | Close | Called when disposing (Ereditato da ConnBase)
Metodo pubblico | GetConnectionId | Required in serialization/deserialization (Sovrascrive ConnFileFixedLenghtGetConnectionId)
Metodo protetto | ReadLine | Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable. (Sovrascrive ConnFileFixedLenghtReadLine(DataTable, String))
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnFileFixedLenghtRun(ISearchRules, Action))
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparator.ClearDataSource

Metodo ConnFileSeparatorClearDataSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparator.ClearDataSource"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearDataSource()
Public Overrides Sub ClearDataSource
public:
virtual void ClearDataSource() override
abstract ClearDataSource : unit -> unit
override ClearDataSource : unit -> unit
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparator.GetConnectionId

Metodo ConnFileSeparatorGetConnectionId
Required in serialization/deserialization

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetConnectionId()
Public Overrides Function GetConnectionId As String
public:
virtual String^ GetConnectionId() override
abstract GetConnectionId : unit -> string
override GetConnectionId : unit -> string

Valore di ritorno

String

Implementa

IConnection.GetConnectionId
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparator.ReadLine

Metodo ConnFileSeparatorReadLine
Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void ReadLine(
    DataTable t,
    string line
)
Protected Overrides Sub ReadLine (
    t As DataTable,
    line As String
)
protected:
virtual void ReadLine(
    DataTable^ t,
    String^ line
) override
abstract ReadLine :
        t : DataTable *
        line : string -> unit
override ReadLine :
        t : DataTable *
        line : string -> unit

Parametri

t DataTable
DataTable
line String
Linea da analizzare.
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparator.Run

Metodo ConnFileSeparatorRun
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Run(
    ISearchRules search,
    Action onCompleted
)
Public Overrides Sub Run (
    search As ISearchRules,
    onCompleted As Action
)
public:
virtual void Run(
    ISearchRules^ search,
    Action^ onCompleted
) override
abstract Run :
        search : ISearchRules *
        onCompleted : Action -> unit
override Run :
        search : ISearchRules *
        onCompleted : Action -> unit

Parametri

search ISearchRules
onCompleted Action

Valore di ritorno

Implementa

IConnection.Run(ISearchRules, Action)
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Campi di ConnFileSeparator

Il tipo ConnFileSeparator espone i seguenti membri.

Campi
Nome | Descrizione
InternalId | The ID if the connection
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Campo ConnFileSeparator.InternalId

Campo ConnFileSeparatorInternalId
The ID if the connection

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string InternalId
Public Shared InternalId As String
public:
static String^ InternalId
static val mutable InternalId: string

Valore del campo

String
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Classe ConnFileSeparatorConnectionProvider

[Manca la documentazione <summary> per "T:InitPrtFast.ConnType.ConnFileSeparatorConnectionProvider"]

Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnFileSeparatorConnectionProvider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileSeparatorConnectionProvider : IConnectionProvider
Public Class ConnFileSeparatorConnectionProvider
    Implements IConnectionProvider
public ref class ConnFileSeparatorConnectionProvider : IConnectionProvider
type ConnFileSeparatorConnectionProvider =
    class
        interface IConnectionProvider
    end

Il tipo ConnFileSeparatorConnectionProvider espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileSeparatorConnectionProvider | Inizializza una nuova istanza della classe ConnFileSeparatorConnectionProvider.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description |
Proprietà pubblica | HasConnectionEditor | no editor for now
Proprietà pubblica | Name |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Deserialize |
Metodo pubblico | EditConnection | Edit the conenction
Metodo pubblico | EditConnectionSource |
Metodo pubblico | Initialize | Initialize the provider
Metodo pubblico | IsAvailable | The enable/disable the provider
Metodo pubblico | NewConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | Serialize | Serialize the connection to a file
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileSeparatorConnectionProvider
Inizializza una nuova istanza della classe ConnFileSeparatorConnectionProvider.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileSeparatorConnectionProvider()
Public Sub New
public:
ConnFileSeparatorConnectionProvider()
new : unit -> ConnFileSeparatorConnectionProvider
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà di ConnFileSeparatorConnectionProvider

Il tipo ConnFileSeparatorConnectionProvider espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description |
Proprietà pubblica | HasConnectionEditor | no editor for now
Proprietà pubblica | Name |
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparatorConnectionProvider.Description

Proprietà ConnFileSeparatorConnectionProviderDescription

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileSeparatorConnectionProvider.Description"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Valore della proprietà

String

Implementa

IConnectionProvider.Description
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparatorConnectionProvider.HasConnectionEditor

Proprietà ConnFileSeparatorConnectionProviderHasConnectionEditor
no editor for now

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasConnectionEditor { get; }
Public ReadOnly Property HasConnectionEditor As Boolean
    Get
public:
virtual property bool HasConnectionEditor {
    bool get () sealed;
}
abstract HasConnectionEditor : bool with get
override HasConnectionEditor : bool with get

Valore della proprietà

Boolean

Implementa

IConnectionProvider.HasConnectionEditor
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparatorConnectionProvider.Name

Proprietà ConnFileSeparatorConnectionProviderName

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileSeparatorConnectionProvider.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String

Implementa

IConnectionProvider.Name
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodi di ConnFileSeparatorConnectionProvider

Il tipo ConnFileSeparatorConnectionProvider espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Deserialize |
Metodo pubblico | EditConnection | Edit the conenction
Metodo pubblico | EditConnectionSource |
Metodo pubblico | Initialize | Initialize the provider
Metodo pubblico | IsAvailable | The enable/disable the provider
Metodo pubblico | NewConnection |
Metodo pubblico | ResolveAssembly | Assembly resolution
Metodo pubblico | Serialize | Serialize the connection to a file
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.Deserialize

Metodo ConnFileSeparatorConnectionProviderDeserialize

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparatorConnectionProvider.Deserialize(System.String,System.String)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Deserialize(
    string connectionId,
    string json
)
Public Function Deserialize (
    connectionId As String,
    json As String
) As IConnection
public:
virtual IConnection^ Deserialize(
    String^ connectionId,
    String^ json
) sealed
abstract Deserialize :
        connectionId : string *
        json : string -> IConnection
override Deserialize :
        connectionId : string *
        json : string -> IConnection

Parametri

connectionId String
json String

Valore di ritorno

IConnection

Implementa

IConnectionProvider.Deserialize(String, String)
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.EditConnection

Metodo ConnFileSeparatorConnectionProviderEditConnection
Edit the conenction

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditConnection(
    IConnection connection,
    IConnectionEditorOptions options
)
Public Function EditConnection (
    connection As IConnection,
    options As IConnectionEditorOptions
) As Boolean
public:
virtual bool EditConnection(
    IConnection^ connection,
    IConnectionEditorOptions^ options
) sealed
abstract EditConnection :
        connection : IConnection *
        options : IConnectionEditorOptions -> bool
override EditConnection :
        connection : IConnection *
        options : IConnectionEditorOptions -> bool

Parametri

connection IConnection
options IConnectionEditorOptions

Valore di ritorno

Boolean

Implementa

IConnectionProvider.EditConnection(IConnection, IConnectionEditorOptions)
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.EditConnectionSource

Metodo ConnFileSeparatorConnectionProviderEditConnectionSource

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparatorConnectionProvider.EditConnectionSource(InitPrtFastCommon.Interfaces.IConnection)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditConnectionSource(
    IConnection currConnection
)
Public Function EditConnectionSource (
    currConnection As IConnection
) As Boolean
public:
virtual bool EditConnectionSource(
    IConnection^ currConnection
) sealed
abstract EditConnectionSource :
        currConnection : IConnection -> bool
override EditConnectionSource :
        currConnection : IConnection -> bool

Parametri

currConnection IConnection

Valore di ritorno

Boolean

Implementa

IConnectionProvider.EditConnectionSource(IConnection)
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.Initialize

Metodo ConnFileSeparatorConnectionProviderInitialize
Initialize the provider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
virtual void Initialize() sealed
abstract Initialize : unit -> unit
override Initialize : unit -> unit

Implementa

IConnectionProvider.Initialize
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.IsAvailable

Metodo ConnFileSeparatorConnectionProviderIsAvailable
The enable/disable the provider

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsAvailable()
Public Function IsAvailable As Boolean
public:
virtual bool IsAvailable() sealed
abstract IsAvailable : unit -> bool
override IsAvailable : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionProvider.IsAvailable
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.NewConnection

Metodo ConnFileSeparatorConnectionProviderNewConnection

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparatorConnectionProvider.NewConnection(InitPrtFastCommon.Interfaces.IConnectionEditorOptions)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection NewConnection(
    IConnectionEditorOptions options
)
Public Function NewConnection (
    options As IConnectionEditorOptions
) As IConnection
public:
virtual IConnection^ NewConnection(
    IConnectionEditorOptions^ options
) sealed
abstract NewConnection :
        options : IConnectionEditorOptions -> IConnection
override NewConnection :
        options : IConnectionEditorOptions -> IConnection

Parametri

options IConnectionEditorOptions

Valore di ritorno

IConnection

Implementa

IConnectionProvider.NewConnection(IConnectionEditorOptions)
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.ResolveAssembly

Metodo ConnFileSeparatorConnectionProviderResolveAssembly
Assembly resolution

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Assembly ResolveAssembly(
    ResolveEventArgs args
)
Public Function ResolveAssembly (
    args As ResolveEventArgs
) As Assembly
public:
virtual Assembly^ ResolveAssembly(
    ResolveEventArgs^ args
) sealed
abstract ResolveAssembly :
        args : ResolveEventArgs -> Assembly
override ResolveAssembly :
        args : ResolveEventArgs -> Assembly

Parametri

args ResolveEventArgs

Valore di ritorno

Assembly

Implementa

IConnectionProvider.ResolveAssembly(ResolveEventArgs)
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorConnectionProvider.Serialize

Metodo ConnFileSeparatorConnectionProviderSerialize
Serialize the connection to a file

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Serialize(
    IConnection newConnection,
    string path
)
Public Function Serialize (
    newConnection As IConnection,
    path As String
) As Boolean
public:
virtual bool Serialize(
    IConnection^ newConnection,
    String^ path
) sealed
abstract Serialize :
        newConnection : IConnection *
        path : string -> bool
override Serialize :
        newConnection : IConnection *
        path : string -> bool

Parametri

newConnection IConnection
path String

Valore di ritorno

Boolean

Implementa

IConnectionProvider.Serialize(IConnection, String)
Vedi anche

Documentazione

Classe ConnFileSeparatorConnectionProvider
Namespace InitPrtFast.ConnType


Classe ConnFileSeparatorForm

[Manca la documentazione <summary> per "T:InitPrtFast.ConnType.ConnFileSeparatorForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
InitPrtFast.ConnTypeConnFileSeparatorForm

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileSeparatorForm : XtraForm,
    IConnectionEditorForm
Public Class ConnFileSeparatorForm
    Inherits XtraForm
    Implements IConnectionEditorForm
public ref class ConnFileSeparatorForm : public XtraForm,
    IConnectionEditorForm
type ConnFileSeparatorForm =
    class
        inherit XtraForm
        interface IConnectionEditorForm
    end

Il tipo ConnFileSeparatorForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileSeparatorForm(IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileSeparatorForm.
Metodo pubblico | ConnFileSeparatorForm(IConnection, IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileSeparatorForm.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Connection |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddField |
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsValidSourceConnectionData | Make sure we have a valid connection data
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo pubblico | UpdateDataPreview |
Metodo pubblico | UpdateForm |
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | ValidateConnection | connection validation
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileSeparatorForm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ConnFileSeparatorForm(IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileSeparatorForm.
Metodo pubblico | ConnFileSeparatorForm(IConnection, IConnectionEditorOptions) | Inizializza una nuova istanza della classe ConnFileSeparatorForm.
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Costruttore ConnFileSeparatorForm(IConnectionEditorOptions)
Inizializza una nuova istanza della classe ConnFileSeparatorForm.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileSeparatorForm(
    IConnectionEditorOptions options
)
Public Sub New (
    options As IConnectionEditorOptions
)
public:
ConnFileSeparatorForm(
    IConnectionEditorOptions^ options
)
new :
        options : IConnectionEditorOptions -> ConnFileSeparatorForm

Parametri

options IConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Overload di ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Costruttore ConnFileSeparatorForm(IConnection, IConnectionEditorOptions)
Inizializza una nuova istanza della classe ConnFileSeparatorForm.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileSeparatorForm(
    IConnection connection,
    IConnectionEditorOptions options
)
Public Sub New (
    connection As IConnection,
    options As IConnectionEditorOptions
)
public:
ConnFileSeparatorForm(
    IConnection^ connection,
    IConnectionEditorOptions^ options
)
new :
        connection : IConnection *
        options : IConnectionEditorOptions -> ConnFileSeparatorForm

Parametri

connection IConnection
options IConnectionEditorOptions
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Overload di ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Proprietà di ConnFileSeparatorForm

Il tipo ConnFileSeparatorForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Connection |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparatorForm.Connection

Proprietà ConnFileSeparatorFormConnection

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileSeparatorForm.Connection"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection Connection { get; set; }
Public Property Connection As IConnection
    Get
    Set
public:
virtual property IConnection^ Connection {
    IConnection^ get () sealed;
    void set (IConnection^ value) sealed;
}
abstract Connection : IConnection with get, set
override Connection : IConnection with get, set

Valore della proprietà

IConnection

Implementa

IConnectionEditorForm.Connection
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodi di ConnFileSeparatorForm

Il tipo ConnFileSeparatorForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddField |
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsValidSourceConnectionData | Make sure we have a valid connection data
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo pubblico | UpdateDataPreview |
Metodo pubblico | UpdateForm |
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | ValidateConnection | connection validation
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorForm.AddField

Metodo ConnFileSeparatorFormAddField

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparatorForm.AddField(System.String,System.Int32)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    int index
)
Public Sub AddField (
    fieldName As String,
    index As Integer
)
public:
virtual void AddField(
    String^ fieldName,
    int index
) sealed
abstract AddField :
        fieldName : string *
        index : int -> unit
override AddField :
        fieldName : string *
        index : int -> unit

Parametri

fieldName String
index Int32

Implementa

IConnectionEditorForm.AddField(String, Int32)
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorForm.Dispose

Metodo ConnFileSeparatorFormDispose
Clean up any resources being used.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorForm.IsValidSourceConnectionData

Metodo ConnFileSeparatorFormIsValidSourceConnectionData
Make sure we have a valid connection data

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValidSourceConnectionData()
Public Function IsValidSourceConnectionData As Boolean
public:
virtual bool IsValidSourceConnectionData() sealed
abstract IsValidSourceConnectionData : unit -> bool
override IsValidSourceConnectionData : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionEditorForm.IsValidSourceConnectionData
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorForm.UpdateDataPreview

Metodo ConnFileSeparatorFormUpdateDataPreview

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparatorForm.UpdateDataPreview"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateDataPreview()
Public Sub UpdateDataPreview
public:
virtual void UpdateDataPreview() sealed
abstract UpdateDataPreview : unit -> unit
override UpdateDataPreview : unit -> unit

Implementa

IConnectionEditorForm.UpdateDataPreview
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorForm.UpdateForm

Metodo ConnFileSeparatorFormUpdateForm

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnFileSeparatorForm.UpdateForm(System.Boolean)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateForm(
    bool updatePreview
)
Public Sub UpdateForm (
    updatePreview As Boolean
)
public:
virtual void UpdateForm(
    bool updatePreview
) sealed
abstract UpdateForm :
        updatePreview : bool -> unit
override UpdateForm :
        updatePreview : bool -> unit

Parametri

updatePreview Boolean

Implementa

IConnectionEditorForm.UpdateForm(Boolean)
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparatorForm.ValidateConnection

Metodo ConnFileSeparatorFormValidateConnection
connection validation

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateConnection()
Public Function ValidateConnection As Boolean
public:
virtual bool ValidateConnection() sealed
abstract ValidateConnection : unit -> bool
override ValidateConnection : unit -> bool

Valore di ritorno

Boolean

Implementa

IConnectionEditorForm.ValidateConnection
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Eventi di ConnFileSeparatorForm

Il tipo ConnFileSeparatorForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Campi di ConnFileSeparatorForm

Il tipo ConnFileSeparatorForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparatorForm
Namespace InitPrtFast.ConnType


Classe Field
Classe che rappresenta un campo generico.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeField
InitPrtFast.ConnTypeFieldFileFixedLenght
InitPrtFast.ConnTypeFieldFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Field : IField
Public Class Field
    Implements IField
public ref class Field : IField
type Field =
    class
        interface IField
    end

Il tipo Field espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Field | Inizializza una nuova istanza della classe Field.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, Boolean, String, String, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Nome del campo ded collegato
Proprietà pubblica | FieldType |
Proprietà pubblica | Format | Formattazione del campo.
Proprietà pubblica | IsInitializable | Indica se il campo può essere precompilato.
Proprietà pubblica | IsResult | Indica se è un campo da visualizzare nel risultato.
Proprietà pubblica | IsReturn | Inidca se è un campo di cui fare tornare il valore.
Proprietà pubblica | IsSearch | Indica se è un campo di ricerca.
Proprietà pubblica | List |
Proprietà pubblica | Name | Nome del campo.
Proprietà pubblica | Prompt | Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata.
Proprietà pubblica | Translation | Traduzione del prompt del campo.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore Field
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Field | Inizializza una nuova istanza della classe Field.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, Boolean, String, String, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Costruttore Field
Inizializza una nuova istanza della classe Field.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field()
Public Sub New
public:
Field()
new : unit -> Field
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String[])

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String()
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String[], String)

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    string format
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    format As String
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    String^ format
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        format : string -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
format String
Formattazione del campo
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String[], String, String)

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String, String, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    string format,
    string translation
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    format As String,
    translation As String
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    String^ format,
    String^ translation
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        format : string *
        translation : string -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
format String
Formattazione del campo
translation String
Traduzione prompt del campo
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, Boolean, String[], String, String)

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, Boolean, String, String, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    bool isInitializable,
    string[] attList,
    string format,
    string translation
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    isInitializable As Boolean,
    attList As String(),
    format As String,
    translation As String
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    bool isInitializable,
    array<String^>^ attList,
    String^ format,
    String^ translation
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        isInitializable : bool *
        attList : string[] *
        format : string *
        translation : string -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
isInitializable Boolean
attList String
Valori da mostrare nel menù a tendina
format String
Formattazione del campo
translation String
Traduzione prompt del campo
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Proprietà di Field

Il tipo Field espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Nome del campo ded collegato
Proprietà pubblica | FieldType |
Proprietà pubblica | Format | Formattazione del campo.
Proprietà pubblica | IsInitializable | Indica se il campo può essere precompilato.
Proprietà pubblica | IsResult | Indica se è un campo da visualizzare nel risultato.
Proprietà pubblica | IsReturn | Inidca se è un campo di cui fare tornare il valore.
Proprietà pubblica | IsSearch | Indica se è un campo di ricerca.
Proprietà pubblica | List |
Proprietà pubblica | Name | Nome del campo.
Proprietà pubblica | Prompt | Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata.
Proprietà pubblica | Translation | Traduzione del prompt del campo.
Torna su
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.DedLink

Proprietà FieldDedLink
Nome del campo ded collegato

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DedLink { get; set; }
Public Property DedLink As String
    Get
    Set
public:
virtual property String^ DedLink {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DedLink : string with get, set
override DedLink : string with get, set

Valore della proprietà

String

Implementa

IField.DedLink
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.FieldType

Proprietà FieldFieldType

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.FieldType"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldType FieldType { get; set; }
Public Property FieldType As FieldType
    Get
    Set
public:
virtual property FieldType FieldType {
    FieldType get () sealed;
    void set (FieldType value) sealed;
}
abstract FieldType : FieldType with get, set
override FieldType : FieldType with get, set

Valore della proprietà

FieldType

Implementa

IField.FieldType
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Format

Proprietà FieldFormat
Formattazione del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
virtual property String^ Format {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Format : string with get, set
override Format : string with get, set

Valore della proprietà

String

Implementa

IField.Format
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsInitializable

Proprietà FieldIsInitializable
Indica se il campo può essere precompilato.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInitializable { get; set; }
Public Property IsInitializable As Boolean
    Get
    Set
public:
virtual property bool IsInitializable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsInitializable : bool with get, set
override IsInitializable : bool with get, set

Valore della proprietà

Boolean

Implementa

IField.IsInitializable
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsResult

Proprietà FieldIsResult
Indica se è un campo da visualizzare nel risultato.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsResult { get; set; }
Public Property IsResult As Boolean
    Get
    Set
public:
virtual property bool IsResult {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsResult : bool with get, set
override IsResult : bool with get, set

Valore della proprietà

Boolean

Implementa

IField.IsResult
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsReturn

Proprietà FieldIsReturn
Inidca se è un campo di cui fare tornare il valore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReturn { get; set; }
Public Property IsReturn As Boolean
    Get
    Set
public:
virtual property bool IsReturn {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsReturn : bool with get, set
override IsReturn : bool with get, set

Valore della proprietà

Boolean

Implementa

IField.IsReturn
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsSearch

Proprietà FieldIsSearch
Indica se è un campo di ricerca.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSearch { get; set; }
Public Property IsSearch As Boolean
    Get
    Set
public:
virtual property bool IsSearch {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsSearch : bool with get, set
override IsSearch : bool with get, set

Valore della proprietà

Boolean

Implementa

IField.IsSearch
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.List

Proprietà FieldList

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.List"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string[] List { get; set; }
Public Property List As String()
    Get
    Set
public:
virtual property array<String^>^ List {
    array<String^>^ get () sealed;
    void set (array<String^>^ value) sealed;
}
abstract List : string[] with get, set
override List : string[] with get, set

Valore della proprietà

String

Implementa

IField.List
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Name

Proprietà FieldName
Nome del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set

Valore della proprietà

String

Implementa

IField.Name
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Prompt

Proprietà FieldPrompt
Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
virtual property String^ Prompt {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Prompt : string with get, set
override Prompt : string with get, set

Valore della proprietà

String

Implementa

IField.Prompt
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Translation

Proprietà FieldTranslation
Traduzione del prompt del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Translation { get; set; }
Public Property Translation As String
    Get
    Set
public:
virtual property String^ Translation {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Translation : string with get, set
override Translation : string with get, set

Valore della proprietà

String

Implementa

IField.Translation
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Classe FieldFileFixedLenght
Classe che rappresenta un campo a lunghezza fissa.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeField
InitPrtFast.ConnTypeFieldFileFixedLenght

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldFileFixedLenght : Field
Public Class FieldFileFixedLenght
    Inherits Field
public ref class FieldFileFixedLenght : public Field
type FieldFileFixedLenght =
    class
        inherit Field
    end

Il tipo FieldFileFixedLenght espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldFileFixedLenght | Required for json deserialization
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32) | Costruttore unico.
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32, String) | Costruttore unico.
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, Boolean, String, Int32, Int32, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Nome del campo ded collegato (Ereditato da Field)
Proprietà pubblica | FieldType | (Ereditato da Field)
Proprietà pubblica | Format | Formattazione del campo. (Ereditato da Field)
Proprietà pubblica | IsInitializable | Indica se il campo può essere precompilato. (Ereditato da Field)
Proprietà pubblica | IsResult | Indica se è un campo da visualizzare nel risultato. (Ereditato da Field)
Proprietà pubblica | IsReturn | Inidca se è un campo di cui fare tornare il valore. (Ereditato da Field)
Proprietà pubblica | IsSearch | Indica se è un campo di ricerca. (Ereditato da Field)
Proprietà pubblica | Lenght | Indica la lunghezza del campo.
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | Nome del campo. (Ereditato da Field)
Proprietà pubblica | Prompt | Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata. (Ereditato da Field)
Proprietà pubblica | StartIndex | Indica l'indice di partenza del campo.
Proprietà pubblica | Translation | Traduzione del prompt del campo. (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FieldFileFixedLenght | Required for json deserialization
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32) | Costruttore unico.
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32, String) | Costruttore unico.
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, Boolean, String, Int32, Int32, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght
Required for json deserialization

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLenght()
Public Sub New
public:
FieldFileFixedLenght()
new : unit -> FieldFileFixedLenght
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Overload di FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String[], Int32, Int32)

Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLenght(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int startIndex,
    int lenght
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    startIndex As Integer,
    lenght As Integer
)
public:
FieldFileFixedLenght(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int startIndex,
    int lenght
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        startIndex : int *
        lenght : int -> FieldFileFixedLenght

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
startIndex Int32
Indica l'indice del carattere di partenza del campo.
lenght Int32
Indica la lunghezza del campo ( in caratteri )
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Overload di FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String[], Int32, Int32, String)

Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLenght(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int startIndex,
    int lenght,
    string format
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    startIndex As Integer,
    lenght As Integer,
    format As String
)
public:
FieldFileFixedLenght(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int startIndex,
    int lenght,
    String^ format
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        startIndex : int *
        lenght : int *
        format : string -> FieldFileFixedLenght

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
startIndex Int32
Indica l'indice del carattere di partenza del campo.
lenght Int32
Indica la lunghezza del campo ( in caratteri )
format String
Formattazione del campo
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Overload di FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, Boolean, String[], Int32, Int32, String)

Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, Boolean, String, Int32, Int32, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLenght(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    bool isInitializable,
    string[] attList,
    int startIndex,
    int lenght,
    string format
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    isInitializable As Boolean,
    attList As String(),
    startIndex As Integer,
    lenght As Integer,
    format As String
)
public:
FieldFileFixedLenght(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    bool isInitializable,
    array<String^>^ attList,
    int startIndex,
    int lenght,
    String^ format
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        isInitializable : bool *
        attList : string[] *
        startIndex : int *
        lenght : int *
        format : string -> FieldFileFixedLenght

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
isInitializable Boolean
attList String
Valori da mostrare nel menù a tendina
startIndex Int32
Indica l'indice del carattere di partenza del campo.
lenght Int32
Indica la lunghezza del campo ( in caratteri )
format String
Formattazione del campo
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Overload di FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà di FieldFileFixedLenght

Il tipo FieldFileFixedLenght espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Nome del campo ded collegato (Ereditato da Field)
Proprietà pubblica | FieldType | (Ereditato da Field)
Proprietà pubblica | Format | Formattazione del campo. (Ereditato da Field)
Proprietà pubblica | IsInitializable | Indica se il campo può essere precompilato. (Ereditato da Field)
Proprietà pubblica | IsResult | Indica se è un campo da visualizzare nel risultato. (Ereditato da Field)
Proprietà pubblica | IsReturn | Inidca se è un campo di cui fare tornare il valore. (Ereditato da Field)
Proprietà pubblica | IsSearch | Indica se è un campo di ricerca. (Ereditato da Field)
Proprietà pubblica | Lenght | Indica la lunghezza del campo.
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | Nome del campo. (Ereditato da Field)
Proprietà pubblica | Prompt | Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata. (Ereditato da Field)
Proprietà pubblica | StartIndex | Indica l'indice di partenza del campo.
Proprietà pubblica | Translation | Traduzione del prompt del campo. (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà FieldFileFixedLenght.Lenght

Proprietà FieldFileFixedLenghtLenght
Indica la lunghezza del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Lenght { get; set; }
Public Property Lenght As Integer
    Get
    Set
public:
property int Lenght {
    int get ();
    void set (int value);
}
member Lenght : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà FieldFileFixedLenght.StartIndex

Proprietà FieldFileFixedLenghtStartIndex
Indica l'indice di partenza del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public int StartIndex { get; set; }
Public Property StartIndex As Integer
    Get
    Set
public:
property int StartIndex {
    int get ();
    void set (int value);
}
member StartIndex : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Classe FieldFileFixedLengthListConverter
Required to deserialize Interfaces
Gerarchia di ereditarietà
SystemObject
JsonConverter
InitPrtFast.ConnTypeFieldFileFixedLengthListConverter

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldFileFixedLengthListConverter : JsonConverter
Public Class FieldFileFixedLengthListConverter
    Inherits JsonConverter
public ref class FieldFileFixedLengthListConverter : public JsonConverter
type FieldFileFixedLengthListConverter =
    class
        inherit JsonConverter
    end

Il tipo FieldFileFixedLengthListConverter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldFileFixedLengthListConverter | Inizializza una nuova istanza della classe FieldFileFixedLengthListConverter.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLengthListConverter
Inizializza una nuova istanza della classe FieldFileFixedLengthListConverter.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLengthListConverter()
Public Sub New
public:
FieldFileFixedLengthListConverter()
new : unit -> FieldFileFixedLengthListConverter
Vedi anche

Documentazione

Classe FieldFileFixedLengthListConverter
Namespace InitPrtFast.ConnType


Proprietà di FieldFileFixedLengthListConverter

Il tipo FieldFileFixedLengthListConverter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Vedi anche

Documentazione

Classe FieldFileFixedLengthListConverter
Namespace InitPrtFast.ConnType


Metodi di FieldFileFixedLengthListConverter

Il tipo FieldFileFixedLengthListConverter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Classe FieldFileFixedLengthListConverter
Namespace InitPrtFast.ConnType


Metodo FieldFileFixedLengthListConverter.CanConvert

Metodo FieldFileFixedLengthListConverterCanConvert

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldFileFixedLengthListConverter.CanConvert(System.Type)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool CanConvert(
    Type objectType
)
Public Overrides Function CanConvert (
    objectType As Type
) As Boolean
public:
virtual bool CanConvert(
    Type^ objectType
) override
abstract CanConvert :
        objectType : Type -> bool
override CanConvert :
        objectType : Type -> bool

Parametri

objectType Type

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FieldFileFixedLengthListConverter
Namespace InitPrtFast.ConnType


Metodo FieldFileFixedLengthListConverter.ReadJson

Metodo FieldFileFixedLengthListConverterReadJson

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldFileFixedLengthListConverter.ReadJson(Newtonsoft.Json.JsonReader,System.Type,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
Public Overrides Function ReadJson (
    reader As JsonReader,
    objectType As Type,
    existingValue As Object,
    serializer As JsonSerializer
) As Object
public:
virtual Object^ ReadJson(
    JsonReader^ reader,
    Type^ objectType,
    Object^ existingValue,
    JsonSerializer^ serializer
) override
abstract ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object
override ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object

Parametri

reader JsonReader
objectType Type
existingValue Object
serializer JsonSerializer

Valore di ritorno

Object
Vedi anche

Documentazione

Classe FieldFileFixedLengthListConverter
Namespace InitPrtFast.ConnType


Metodo FieldFileFixedLengthListConverter.WriteJson

Metodo FieldFileFixedLengthListConverterWriteJson

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldFileFixedLengthListConverter.WriteJson(Newtonsoft.Json.JsonWriter,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Public Overrides Sub WriteJson (
    writer As JsonWriter,
    value As Object,
    serializer As JsonSerializer
)
public:
virtual void WriteJson(
    JsonWriter^ writer,
    Object^ value,
    JsonSerializer^ serializer
) override
abstract WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit
override WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit

Parametri

writer JsonWriter
value Object
serializer JsonSerializer
Vedi anche

Documentazione

Classe FieldFileFixedLengthListConverter
Namespace InitPrtFast.ConnType


Classe FieldFileSeparator
Classe che rappresenta un campo con separatore.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeField
InitPrtFast.ConnTypeFieldFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldFileSeparator : Field
Public Class FieldFileSeparator
    Inherits Field
public ref class FieldFileSeparator : public Field
type FieldFileSeparator =
    class
        inherit Field
    end

Il tipo FieldFileSeparator espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldFileSeparator | Required for json deserialization
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32) | Costruttore unico.
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32, String) | Costruttore unico.
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, Boolean, String, Int32, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Nome del campo ded collegato (Ereditato da Field)
Proprietà pubblica | FieldType | (Ereditato da Field)
Proprietà pubblica | Format | Formattazione del campo. (Ereditato da Field)
Proprietà pubblica | Index | Indica l'indice del campo.
Proprietà pubblica | IsInitializable | Indica se il campo può essere precompilato. (Ereditato da Field)
Proprietà pubblica | IsResult | Indica se è un campo da visualizzare nel risultato. (Ereditato da Field)
Proprietà pubblica | IsReturn | Inidca se è un campo di cui fare tornare il valore. (Ereditato da Field)
Proprietà pubblica | IsSearch | Indica se è un campo di ricerca. (Ereditato da Field)
Proprietà pubblica | Lenght | Indica la lunghezza del campo.
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | Nome del campo. (Ereditato da Field)
Proprietà pubblica | Prompt | Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata. (Ereditato da Field)
Proprietà pubblica | Translation | Traduzione del prompt del campo. (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FieldFileSeparator | Required for json deserialization
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32) | Costruttore unico.
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32, String) | Costruttore unico.
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, Boolean, String, Int32, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator
Required for json deserialization

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparator()
Public Sub New
public:
FieldFileSeparator()
new : unit -> FieldFileSeparator
Vedi anche

Documentazione

Classe FieldFileSeparator
Overload di FieldFileSeparator
Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String[], Int32)

Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparator(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int index
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    index As Integer
)
public:
FieldFileSeparator(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int index
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        index : int -> FieldFileSeparator

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
index Int32
Indica la posizione del campo ( zero-based )
Vedi anche

Documentazione

Classe FieldFileSeparator
Overload di FieldFileSeparator
Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String[], Int32, String)

Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparator(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int index,
    string format = null
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    index As Integer,
    Optional format As String = Nothing
)
public:
FieldFileSeparator(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int index,
    String^ format = nullptr
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        index : int *
        ?format : string
(* Defaults:
        let _format = defaultArg format null
*)
-> FieldFileSeparator

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
index Int32
Indica la posizione del campo ( zero-based )
format String (Optional)
Formattazione del campo
Vedi anche

Documentazione

Classe FieldFileSeparator
Overload di FieldFileSeparator
Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, Boolean, String[], Int32, String)

Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, Boolean, String, Int32, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparator(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    bool isInitializable,
    string[] attList,
    int index,
    string format = null
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    isInitializable As Boolean,
    attList As String(),
    index As Integer,
    Optional format As String = Nothing
)
public:
FieldFileSeparator(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    bool isInitializable,
    array<String^>^ attList,
    int index,
    String^ format = nullptr
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        isInitializable : bool *
        attList : string[] *
        index : int *
        ?format : string
(* Defaults:
        let _format = defaultArg format null
*)
-> FieldFileSeparator

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
isInitializable Boolean
attList String
Valori da mostrare nel menù a tendina
index Int32
Indica la posizione del campo ( zero-based )
format String (Optional)
Formattazione del campo
Vedi anche

Documentazione

Classe FieldFileSeparator
Overload di FieldFileSeparator
Namespace InitPrtFast.ConnType


Proprietà di FieldFileSeparator

Il tipo FieldFileSeparator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | Nome del campo ded collegato (Ereditato da Field)
Proprietà pubblica | FieldType | (Ereditato da Field)
Proprietà pubblica | Format | Formattazione del campo. (Ereditato da Field)
Proprietà pubblica | Index | Indica l'indice del campo.
Proprietà pubblica | IsInitializable | Indica se il campo può essere precompilato. (Ereditato da Field)
Proprietà pubblica | IsResult | Indica se è un campo da visualizzare nel risultato. (Ereditato da Field)
Proprietà pubblica | IsReturn | Inidca se è un campo di cui fare tornare il valore. (Ereditato da Field)
Proprietà pubblica | IsSearch | Indica se è un campo di ricerca. (Ereditato da Field)
Proprietà pubblica | Lenght | Indica la lunghezza del campo.
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | Nome del campo. (Ereditato da Field)
Proprietà pubblica | Prompt | Prompt del campo. Viene usato come caption della colonna e ritornato come Field del risultato nella riga selezionata. (Ereditato da Field)
Proprietà pubblica | Translation | Traduzione del prompt del campo. (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Proprietà FieldFileSeparator.Index

Proprietà FieldFileSeparatorIndex
Indica l'indice del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Proprietà FieldFileSeparator.Lenght

Proprietà FieldFileSeparatorLenght
Indica la lunghezza del campo.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Lenght { get; set; }
Public Property Lenght As Integer
    Get
    Set
public:
property int Lenght {
    int get ();
    void set (int value);
}
member Lenght : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Classe FieldFileSeparatorListConverter
Required to deserialize Interfaces
Gerarchia di ereditarietà
SystemObject
JsonConverter
InitPrtFast.ConnTypeFieldFileSeparatorListConverter

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldFileSeparatorListConverter : JsonConverter
Public Class FieldFileSeparatorListConverter
    Inherits JsonConverter
public ref class FieldFileSeparatorListConverter : public JsonConverter
type FieldFileSeparatorListConverter =
    class
        inherit JsonConverter
    end

Il tipo FieldFileSeparatorListConverter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldFileSeparatorListConverter | Inizializza una nuova istanza della classe FieldFileSeparatorListConverter.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparatorListConverter
Inizializza una nuova istanza della classe FieldFileSeparatorListConverter.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparatorListConverter()
Public Sub New
public:
FieldFileSeparatorListConverter()
new : unit -> FieldFileSeparatorListConverter
Vedi anche

Documentazione

Classe FieldFileSeparatorListConverter
Namespace InitPrtFast.ConnType


Proprietà di FieldFileSeparatorListConverter

Il tipo FieldFileSeparatorListConverter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Vedi anche

Documentazione

Classe FieldFileSeparatorListConverter
Namespace InitPrtFast.ConnType


Metodi di FieldFileSeparatorListConverter

Il tipo FieldFileSeparatorListConverter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Classe FieldFileSeparatorListConverter
Namespace InitPrtFast.ConnType


Metodo FieldFileSeparatorListConverter.CanConvert

Metodo FieldFileSeparatorListConverterCanConvert

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldFileSeparatorListConverter.CanConvert(System.Type)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool CanConvert(
    Type objectType
)
Public Overrides Function CanConvert (
    objectType As Type
) As Boolean
public:
virtual bool CanConvert(
    Type^ objectType
) override
abstract CanConvert :
        objectType : Type -> bool
override CanConvert :
        objectType : Type -> bool

Parametri

objectType Type

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FieldFileSeparatorListConverter
Namespace InitPrtFast.ConnType


Metodo FieldFileSeparatorListConverter.ReadJson

Metodo FieldFileSeparatorListConverterReadJson

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldFileSeparatorListConverter.ReadJson(Newtonsoft.Json.JsonReader,System.Type,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
Public Overrides Function ReadJson (
    reader As JsonReader,
    objectType As Type,
    existingValue As Object,
    serializer As JsonSerializer
) As Object
public:
virtual Object^ ReadJson(
    JsonReader^ reader,
    Type^ objectType,
    Object^ existingValue,
    JsonSerializer^ serializer
) override
abstract ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object
override ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object

Parametri

reader JsonReader
objectType Type
existingValue Object
serializer JsonSerializer

Valore di ritorno

Object
Vedi anche

Documentazione

Classe FieldFileSeparatorListConverter
Namespace InitPrtFast.ConnType


Metodo FieldFileSeparatorListConverter.WriteJson

Metodo FieldFileSeparatorListConverterWriteJson

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldFileSeparatorListConverter.WriteJson(Newtonsoft.Json.JsonWriter,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Public Overrides Sub WriteJson (
    writer As JsonWriter,
    value As Object,
    serializer As JsonSerializer
)
public:
virtual void WriteJson(
    JsonWriter^ writer,
    Object^ value,
    JsonSerializer^ serializer
) override
abstract WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit
override WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit

Parametri

writer JsonWriter
value Object
serializer JsonSerializer
Vedi anche

Documentazione

Classe FieldFileSeparatorListConverter
Namespace InitPrtFast.ConnType


Classe FieldList
The list of fields
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList IField
InitPrtFast.ConnTypeFieldList

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldList : List<IField>,
    IFieldList, IList<IField>, ICollection<IField>,
    IEnumerable<IField>, IEnumerable
Public Class FieldList
    Inherits List(Of IField)
    Implements IFieldList, IList(Of IField),
    ICollection(Of IField), IEnumerable(Of IField), IEnumerable
public ref class FieldList : public List<IField^>,
    IFieldList, IList<IField^>, ICollection<IField^>,
    IEnumerable<IField^>, IEnumerable
type FieldList =
    class
        inherit List<IField>
        interface IFieldList
        interface IList<IField>
        interface ICollection<IField>
        interface IEnumerable<IField>
        interface IEnumerable
    end

Il tipo FieldList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldList | Inizializza una nuova istanza della classe FieldList.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldList
Inizializza una nuova istanza della classe FieldList.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldList()
Public Sub New
public:
FieldList()
new : unit -> FieldList
Vedi anche

Documentazione

Classe FieldList
Namespace InitPrtFast.ConnType


Classe FieldListConverter
Required to deserialize Interfaces
Gerarchia di ereditarietà
SystemObject
JsonConverter
InitPrtFast.ConnTypeFieldListConverter

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldListConverter : JsonConverter
Public Class FieldListConverter
    Inherits JsonConverter
public ref class FieldListConverter : public JsonConverter
type FieldListConverter =
    class
        inherit JsonConverter
    end

Il tipo FieldListConverter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldListConverter | Inizializza una nuova istanza della classe FieldListConverter.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldListConverter
Inizializza una nuova istanza della classe FieldListConverter.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldListConverter()
Public Sub New
public:
FieldListConverter()
new : unit -> FieldListConverter
Vedi anche

Documentazione

Classe FieldListConverter
Namespace InitPrtFast.ConnType


Proprietà di FieldListConverter

Il tipo FieldListConverter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanRead | (Ereditato da JsonConverter)
Proprietà pubblica | CanWrite | (Ereditato da JsonConverter)
Torna su
Vedi anche

Documentazione

Classe FieldListConverter
Namespace InitPrtFast.ConnType


Metodi di FieldListConverter

Il tipo FieldListConverter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanConvert | (Sovrascrive JsonConverter.CanConvert(Type))
Metodo pubblico | ReadJson | (Sovrascrive JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer))
Metodo pubblico | WriteJson | (Sovrascrive JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer))
Torna su
Vedi anche

Documentazione

Classe FieldListConverter
Namespace InitPrtFast.ConnType


Metodo FieldListConverter.CanConvert

Metodo FieldListConverterCanConvert

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldListConverter.CanConvert(System.Type)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool CanConvert(
    Type objectType
)
Public Overrides Function CanConvert (
    objectType As Type
) As Boolean
public:
virtual bool CanConvert(
    Type^ objectType
) override
abstract CanConvert :
        objectType : Type -> bool
override CanConvert :
        objectType : Type -> bool

Parametri

objectType Type

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FieldListConverter
Namespace InitPrtFast.ConnType


Metodo FieldListConverter.ReadJson

Metodo FieldListConverterReadJson

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldListConverter.ReadJson(Newtonsoft.Json.JsonReader,System.Type,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override Object ReadJson(
    JsonReader reader,
    Type objectType,
    Object existingValue,
    JsonSerializer serializer
)
Public Overrides Function ReadJson (
    reader As JsonReader,
    objectType As Type,
    existingValue As Object,
    serializer As JsonSerializer
) As Object
public:
virtual Object^ ReadJson(
    JsonReader^ reader,
    Type^ objectType,
    Object^ existingValue,
    JsonSerializer^ serializer
) override
abstract ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object
override ReadJson :
        reader : JsonReader *
        objectType : Type *
        existingValue : Object *
        serializer : JsonSerializer -> Object

Parametri

reader JsonReader
objectType Type
existingValue Object
serializer JsonSerializer

Valore di ritorno

Object
Vedi anche

Documentazione

Classe FieldListConverter
Namespace InitPrtFast.ConnType


Metodo FieldListConverter.WriteJson

Metodo FieldListConverterWriteJson

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.FieldListConverter.WriteJson(Newtonsoft.Json.JsonWriter,System.Object,Newtonsoft.Json.JsonSerializer)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Public Overrides Sub WriteJson (
    writer As JsonWriter,
    value As Object,
    serializer As JsonSerializer
)
public:
virtual void WriteJson(
    JsonWriter^ writer,
    Object^ value,
    JsonSerializer^ serializer
) override
abstract WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit
override WriteJson :
        writer : JsonWriter *
        value : Object *
        serializer : JsonSerializer -> unit

Parametri

writer JsonWriter
value Object
serializer JsonSerializer
Vedi anche

Documentazione

Classe FieldListConverter
Namespace InitPrtFast.ConnType


Classe SearchRule
Classe che rappresenta un singolo criterio di ricerca
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeSearchRule

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SearchRule : ISearchRule
Public Class SearchRule
    Implements ISearchRule
public ref class SearchRule : ISearchRule
type SearchRule =
    class
        interface ISearchRule
    end

Il tipo SearchRule espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SearchRule | Inizializza una nuova istanza della classe SearchRule.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore SearchRule
Inizializza una nuova istanza della classe SearchRule.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchRule()
Public Sub New
public:
SearchRule()
new : unit -> SearchRule
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Proprietà di SearchRule

Il tipo SearchRule espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Proprietà SearchRule.Name

Proprietà SearchRuleName

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.SearchRule.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set

Valore della proprietà

String

Implementa

ISearchRule.Name
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Proprietà SearchRule.Value

Proprietà SearchRuleValue

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.SearchRule.Value"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Value : string with get, set
override Value : string with get, set

Valore della proprietà

String

Implementa

ISearchRule.Value
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Classe SearchRules
Insieme di criteri di ricerca
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, ISearchRule
InitPrtFast.ConnTypeSearchRules

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SearchRules : Dictionary<string, ISearchRule>,
    ISearchRules, IDictionary<string, ISearchRule>, ICollection<KeyValuePair<string, ISearchRule>>,
    IEnumerable<KeyValuePair<string, ISearchRule>>, IEnumerable
Public Class SearchRules
    Inherits Dictionary(Of String, ISearchRule)
    Implements ISearchRules, IDictionary(Of String, ISearchRule),
    ICollection(Of KeyValuePair(Of String, ISearchRule)), IEnumerable(Of KeyValuePair(Of String, ISearchRule)),
    IEnumerable
public ref class SearchRules : public Dictionary<String^, ISearchRule^>,
    ISearchRules, IDictionary<String^, ISearchRule^>, ICollection<KeyValuePair<String^, ISearchRule^>>,
    IEnumerable<KeyValuePair<String^, ISearchRule^>>, IEnumerable
type SearchRules =
    class
        inherit Dictionary<string, ISearchRule>
        interface ISearchRules
        interface IDictionary<string, ISearchRule>
        interface ICollection<KeyValuePair<string, ISearchRule>>
        interface IEnumerable<KeyValuePair<string, ISearchRule>>
        interface IEnumerable
    end

Il tipo SearchRules espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SearchRules | Inizializza una nuova istanza della classe SearchRules.
Metodo pubblico | SearchRules(SearchRules) | Inizializza una nuova istanza della classe SearchRules.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore SearchRules
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SearchRules | Inizializza una nuova istanza della classe SearchRules.
Metodo pubblico | SearchRules(SearchRules) | Inizializza una nuova istanza della classe SearchRules.
Torna su
Vedi anche

Documentazione

Classe SearchRules
Namespace InitPrtFast.ConnType


Costruttore SearchRules
Inizializza una nuova istanza della classe SearchRules.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchRules()
Public Sub New
public:
SearchRules()
new : unit -> SearchRules
Vedi anche

Documentazione

Classe SearchRules
Overload di SearchRules
Namespace InitPrtFast.ConnType


Costruttore SearchRules(SearchRules)
Inizializza una nuova istanza della classe SearchRules.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchRules(
    SearchRules from
)
Public Sub New (
    from As SearchRules
)
public:
SearchRules(
    SearchRules^ from
)
new :
        from : SearchRules -> SearchRules

Parametri

from SearchRules
Vedi anche

Documentazione

Classe SearchRules
Overload di SearchRules
Namespace InitPrtFast.ConnType


InitPrtFastForm Namespace
Classi
 | Classe | Descrizione
Classe pubblica | InitPrtFastForm |
Classe pubblica | InitPrtFastFormBtnClickEventArgs | Classe contenente le informazioni per l'evento BtnClick.


Classe InitPrtFastForm

[Manca la documentazione <summary> per "T:InitPrtFastForm.InitPrtFastForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
InitPrtFastFormInitPrtFastForm

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastForm : XtraForm
Public Class InitPrtFastForm
    Inherits XtraForm
public ref class InitPrtFastForm : public XtraForm
type InitPrtFastForm =
    class
        inherit XtraForm
    end

Il tipo InitPrtFastForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | ctrInitPrtFast | Restituisce il controllo dell'inizia parte veloce.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FormTitle | Imposta il titolo della finestra.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | InizializeInitPrtFast | Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedConnection | Connessione attualmente selezionata.
Proprietà pubblica | SelectedRow | Restituisce l'insieme delle righe attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowResetButton | Show the reset button
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo pubblico | AppendDataSource | Aggiunge una data source alla lista.
Metodo pubblico | AppendDataSources(ListConnBase) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | AppendDataSources(ListIConnection) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | ClearDataSources | Clear the datasources
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | FindButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadDataSource | Aggiunge una data source alla lista caricandola da file
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBtnClick |
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnRowDoubleClick |
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnSearchControlCreated |
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetDataSources(ListConnBase) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDataSources(ListIConnection) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDefaultDataSource | Imposta la sorgente dati da pre-selezionare di default.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetPictureRowHeight | set the row height in case of pictures
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BtnClick | Evento sul click del bottone.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | RowDoubleClick | Evento sul doppio click sulla riga.
Evento pubblico | SearchControlCreated | Evento sulla creazione del controllo di ricerca
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFastForm


Costruttore InitPrtFastForm
Costruttore unico.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastForm()
Public Sub New
public:
InitPrtFastForm()
new : unit -> InitPrtFastForm
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | ctrInitPrtFast | Restituisce il controllo dell'inizia parte veloce.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FormTitle | Imposta il titolo della finestra.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | InizializeInitPrtFast | Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedConnection | Connessione attualmente selezionata.
Proprietà pubblica | SelectedRow | Restituisce l'insieme delle righe attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowResetButton | Show the reset button
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.ctrInitPrtFast

Proprietà InitPrtFastFormctrInitPrtFast
Restituisce il controllo dell'inizia parte veloce.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFast ctrInitPrtFast { get; }
Public ReadOnly Property ctrInitPrtFast As InitPrtFast
    Get
public:
property InitPrtFast^ ctrInitPrtFast {
    InitPrtFast^ get ();
}
member ctrInitPrtFast : InitPrtFast with get

Valore della proprietà

InitPrtFast
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.FormTitle

Proprietà InitPrtFastFormFormTitle
Imposta il titolo della finestra.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FormTitle { set; }
Public WriteOnly Property FormTitle As String
    Set
public:
property String^ FormTitle {
    void set (String^ value);
}
member FormTitle : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.InizializeInitPrtFast

Proprietà InitPrtFastFormInizializeInitPrtFast
Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string InizializeInitPrtFast { set; }
Public WriteOnly Property InizializeInitPrtFast As String
    Set
public:
property String^ InizializeInitPrtFast {
    void set (String^ value);
}
member InizializeInitPrtFast : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.SelectedConnection

Proprietà InitPrtFastFormSelectedConnection
Connessione attualmente selezionata.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public IConnection SelectedConnection { get; }
Public ReadOnly Property SelectedConnection As IConnection
    Get
public:
property IConnection^ SelectedConnection {
    IConnection^ get ();
}
member SelectedConnection : IConnection with get

Valore della proprietà

IConnection
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.SelectedRow

Proprietà InitPrtFastFormSelectedRow
Restituisce l'insieme delle righe attualmente selezionate.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows SelectedRow { get; }
Public ReadOnly Property SelectedRow As InitPrtFastRows
    Get
public:
property InitPrtFastRows^ SelectedRow {
    InitPrtFastRows^ get ();
}
member SelectedRow : InitPrtFastRows with get

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.ShowResetButton

Proprietà InitPrtFastFormShowResetButton
Show the reset button

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowResetButton { set; }
Public WriteOnly Property ShowResetButton As Boolean
    Set
public:
property bool ShowResetButton {
    void set (bool value);
}
member ShowResetButton : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodi di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo pubblico | AppendDataSource | Aggiunge una data source alla lista.
Metodo pubblico | AppendDataSources(ListConnBase) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | AppendDataSources(ListIConnection) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | ClearDataSources | Clear the datasources
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | FindButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadDataSource | Aggiunge una data source alla lista caricandola da file
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBtnClick |
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnRowDoubleClick |
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnSearchControlCreated |
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetDataSources(ListConnBase) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDataSources(ListIConnection) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDefaultDataSource | Imposta la sorgente dati da pre-selezionare di default.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetPictureRowHeight | set the row height in case of pictures
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.AddButton

Metodo InitPrtFastFormAddButton
Metodo che permette di aggiungere un bottone ( da destra a sinistra ).

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddButton(
    string text,
    string tagText
)
Public Sub AddButton (
    text As String,
    tagText As String
)
public:
void AddButton(
    String^ text,
    String^ tagText
)
member AddButton :
        text : string *
        tagText : string -> unit

Parametri

text String
Testo da visualizzare sul bottone.
tagText String
Testo usato come tag del bottone.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.AppendDataSource

Metodo InitPrtFastFormAppendDataSource
Aggiunge una data source alla lista.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AppendDataSource(
    IConnection source
)
Public Sub AppendDataSource (
    source As IConnection
)
public:
void AppendDataSource(
    IConnection^ source
)
member AppendDataSource :
        source : IConnection -> unit

Parametri

source IConnection
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.AppendDataSources

Metodo InitPrtFastFormAppendDataSources
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AppendDataSources(ListConnBase) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | AppendDataSources(ListIConnection) | Imposta le sorgenti dati da visualizzare.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.AppendDataSources(List<ConnBase>)

Metodo InitPrtFastFormAppendDataSources(ListConnBase)
Imposta le sorgenti dati da visualizzare.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AppendDataSources(
    List<ConnBase> sources
)
Public Sub AppendDataSources (
    sources As List(Of ConnBase)
)
public:
void AppendDataSources(
    List<ConnBase^>^ sources
)
member AppendDataSources :
        sources : List<ConnBase> -> unit

Parametri

sources List ConnBase
Vedi anche

Documentazione

Classe InitPrtFastForm
Overload di AppendDataSources
Namespace InitPrtFastForm


Metodo InitPrtFastForm.AppendDataSources(List<IConnection>)

Metodo InitPrtFastFormAppendDataSources(ListIConnection)
Imposta le sorgenti dati da visualizzare.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AppendDataSources(
    List<IConnection> sources
)
Public Sub AppendDataSources (
    sources As List(Of IConnection)
)
public:
void AppendDataSources(
    List<IConnection^>^ sources
)
member AppendDataSources :
        sources : List<IConnection> -> unit

Parametri

sources List IConnection
Lista di sorgenti dati.
Vedi anche

Documentazione

Classe InitPrtFastForm
Overload di AppendDataSources
Namespace InitPrtFastForm


Metodo InitPrtFastForm.ClearDataSources

Metodo InitPrtFastFormClearDataSources
Clear the datasources

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearDataSources()
Public Sub ClearDataSources
public:
void ClearDataSources()
member ClearDataSources : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.Dispose

Metodo InitPrtFastFormDispose
Liberare le risorse in uso.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.FindButton

Metodo InitPrtFastFormFindButton
Metodo che permette di aggiungere un bottone ( da destra a sinistra ).

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public BaseButton FindButton(
    string text
)
Public Function FindButton (
    text As String
) As BaseButton
public:
BaseButton^ FindButton(
    String^ text
)
member FindButton :
        text : string -> BaseButton

Parametri

text String
Testo visualizzato sul bottone.

Valore di ritorno

BaseButton
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.LoadDataSource

Metodo InitPrtFastFormLoadDataSource
Aggiunge una data source alla lista caricandola da file

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadDataSource(
    string sourcePath
)
Public Function LoadDataSource (
    sourcePath As String
) As Boolean
public:
bool LoadDataSource(
    String^ sourcePath
)
member LoadDataSource :
        sourcePath : string -> bool

Parametri

sourcePath String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.LoadSizeAndPosition

Metodo InitPrtFastFormLoadSizeAndPosition
Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void LoadSizeAndPosition()
Protected Sub LoadSizeAndPosition
protected:
void LoadSizeAndPosition()
member LoadSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.OnBtnClick

Metodo InitPrtFastFormOnBtnClick

[Manca la documentazione <summary> per "M:InitPrtFastForm.InitPrtFastForm.OnBtnClick(System.Object,InitPrtFastForm.InitPrtFastForm.BtnClickEventArgs)"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnBtnClick(
    Object sender,
    InitPrtFastFormBtnClickEventArgs ev
)
Protected Sub OnBtnClick (
    sender As Object,
    ev As InitPrtFastFormBtnClickEventArgs
)
protected:
void OnBtnClick(
    Object^ sender,
    InitPrtFastFormBtnClickEventArgs^ ev
)
member OnBtnClick :
        sender : Object *
        ev : InitPrtFastFormBtnClickEventArgs -> unit

Parametri

sender Object
ev InitPrtFastFormBtnClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.OnRowDoubleClick

Metodo InitPrtFastFormOnRowDoubleClick

[Manca la documentazione <summary> per "M:InitPrtFastForm.InitPrtFastForm.OnRowDoubleClick(System.Object,System.EventArgs)"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnRowDoubleClick(
    Object sender,
    EventArgs ev
)
Protected Sub OnRowDoubleClick (
    sender As Object,
    ev As EventArgs
)
protected:
void OnRowDoubleClick(
    Object^ sender,
    EventArgs^ ev
)
member OnRowDoubleClick :
        sender : Object *
        ev : EventArgs -> unit

Parametri

sender Object
ev EventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.OnSearchControlCreated

Metodo InitPrtFastFormOnSearchControlCreated

[Manca la documentazione <summary> per "M:InitPrtFastForm.InitPrtFastForm.OnSearchControlCreated(System.Object,InitPrtFast.InitPrtFast.SearchControlCreatedEventArgs)"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSearchControlCreated(
    Object sender,
    InitPrtFastSearchControlCreatedEventArgs ev
)
Protected Sub OnSearchControlCreated (
    sender As Object,
    ev As InitPrtFastSearchControlCreatedEventArgs
)
protected:
void OnSearchControlCreated(
    Object^ sender,
    InitPrtFastSearchControlCreatedEventArgs^ ev
)
member OnSearchControlCreated :
        sender : Object *
        ev : InitPrtFastSearchControlCreatedEventArgs -> unit

Parametri

sender Object
ev InitPrtFastSearchControlCreatedEventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SaveSizeAndPosition

Metodo InitPrtFastFormSaveSizeAndPosition
Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void SaveSizeAndPosition()
Protected Sub SaveSizeAndPosition
protected:
void SaveSizeAndPosition()
member SaveSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetDataSources

Metodo InitPrtFastFormSetDataSources
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetDataSources(ListConnBase) | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDataSources(ListIConnection) | Imposta le sorgenti dati da visualizzare.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetDataSources(List<ConnBase>)

Metodo InitPrtFastFormSetDataSources(ListConnBase)
Imposta le sorgenti dati da visualizzare.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDataSources(
    List<ConnBase> sources
)
Public Sub SetDataSources (
    sources As List(Of ConnBase)
)
public:
void SetDataSources(
    List<ConnBase^>^ sources
)
member SetDataSources :
        sources : List<ConnBase> -> unit

Parametri

sources List ConnBase
Vedi anche

Documentazione

Classe InitPrtFastForm
Overload di SetDataSources
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetDataSources(List<IConnection>)

Metodo InitPrtFastFormSetDataSources(ListIConnection)
Imposta le sorgenti dati da visualizzare.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDataSources(
    List<IConnection> sources
)
Public Sub SetDataSources (
    sources As List(Of IConnection)
)
public:
void SetDataSources(
    List<IConnection^>^ sources
)
member SetDataSources :
        sources : List<IConnection> -> unit

Parametri

sources List IConnection
Lista di sorgenti dati.
Vedi anche

Documentazione

Classe InitPrtFastForm
Overload di SetDataSources
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetDefaultDataSource

Metodo InitPrtFastFormSetDefaultDataSource
Imposta la sorgente dati da pre-selezionare di default.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDefaultDataSource(
    string sourceName
)
Public Sub SetDefaultDataSource (
    sourceName As String
)
public:
void SetDefaultDataSource(
    String^ sourceName
)
member SetDefaultDataSource :
        sourceName : string -> unit

Parametri

sourceName String
Nome della sorgente dati da pre-selezionare.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetPictureRowHeight

Metodo InitPrtFastFormSetPictureRowHeight
set the row height in case of pictures

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetPictureRowHeight(
    int height
)
Public Sub SetPictureRowHeight (
    height As Integer
)
public:
void SetPictureRowHeight(
    int height
)
member SetPictureRowHeight :
        height : int -> unit

Parametri

height Int32
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Eventi di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BtnClick | Evento sul click del bottone.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | RowDoubleClick | Evento sul doppio click sulla riga.
Evento pubblico | SearchControlCreated | Evento sulla creazione del controllo di ricerca
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Evento InitPrtFastForm.BtnClick

Evento InitPrtFastFormBtnClick
Evento sul click del bottone.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastFormBtnClickEventArgs> BtnClick
Public Event BtnClick As EventHandler(Of InitPrtFastFormBtnClickEventArgs)
public:
 event EventHandler<InitPrtFastFormBtnClickEventArgs^>^ BtnClick {
    void add (EventHandler<InitPrtFastFormBtnClickEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastFormBtnClickEventArgs^>^ value);
}
member BtnClick : IEvent<EventHandler<InitPrtFastFormBtnClickEventArgs>,
    InitPrtFastFormBtnClickEventArgs>

Valore

EventHandler InitPrtFastFormBtnClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Evento InitPrtFastForm.RowDoubleClick

Evento InitPrtFastFormRowDoubleClick
Evento sul doppio click sulla riga.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> RowDoubleClick
Public Event RowDoubleClick As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ RowDoubleClick {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member RowDoubleClick : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Evento InitPrtFastForm.SearchControlCreated

Evento InitPrtFastFormSearchControlCreated
Evento sulla creazione del controllo di ricerca

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastSearchControlCreatedEventArgs> SearchControlCreated
Public Event SearchControlCreated As EventHandler(Of InitPrtFastSearchControlCreatedEventArgs)
public:
 event EventHandler<InitPrtFastSearchControlCreatedEventArgs^>^ SearchControlCreated {
    void add (EventHandler<InitPrtFastSearchControlCreatedEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastSearchControlCreatedEventArgs^>^ value);
}
member SearchControlCreated : IEvent<EventHandler<InitPrtFastSearchControlCreatedEventArgs>,
    InitPrtFastSearchControlCreatedEventArgs>

Valore

EventHandler InitPrtFastSearchControlCreatedEventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Campi di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Classe InitPrtFastForm.BtnClickEventArgs

Classe InitPrtFastFormBtnClickEventArgs
Classe contenente le informazioni per l'evento BtnClick.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastFormInitPrtFastFormBtnClickEventArgs

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public class BtnClickEventArgs : EventArgs
Public Class BtnClickEventArgs
    Inherits EventArgs
public ref class BtnClickEventArgs : public EventArgs
type BtnClickEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastFormBtnClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastFormBtnClickEventArgs | Inizializza una nuova istanza della classe InitPrtFastFormBtnClickEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BtnTag |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFastForm


Costruttore InitPrtFastForm.BtnClickEventArgs

Costruttore InitPrtFastFormBtnClickEventArgs
Inizializza una nuova istanza della classe InitPrtFastFormBtnClickEventArgs.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public BtnClickEventArgs(
    string text
)
Public Sub New (
    text As String
)
public:
BtnClickEventArgs(
    String^ text
)
new :
        text : string -> BtnClickEventArgs

Parametri

text String
Vedi anche

Documentazione

Classe InitPrtFastFormBtnClickEventArgs
Namespace InitPrtFastForm


Proprietà di BtnClickEventArgs

Il tipo InitPrtFastFormBtnClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BtnTag |
Torna su
Vedi anche

Documentazione

Classe InitPrtFastFormBtnClickEventArgs
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.BtnClickEventArgs.BtnTag

Proprietà InitPrtFastFormBtnClickEventArgsBtnTag

[Manca la documentazione <summary> per "P:InitPrtFastForm.InitPrtFastForm.BtnClickEventArgs.BtnTag"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 29.0.0
Sintassi
C#
VB
C++
F#
Copy
public string BtnTag { get; }
Public ReadOnly Property BtnTag As String
    Get
public:
property String^ BtnTag {
    String^ get ();
}
member BtnTag : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastFormBtnClickEventArgs
Namespace InitPrtFastForm