DedNetAcad Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AcadCommandBase | Classe base per la gestione dei comandi di AutoCAD, in particolare per quanto riguarda i comandi che vanno a lavorare (anche) sugli XREF.
Classe pubblica | AcadDocStructInfo |
Classe pubblica | AcadDocStructInfoEventHandlers | Classe gestione eventi client del DoscStructInfo
Classe pubblica | ApriFileAssociati | Apre il file associato se ne esiste soltanto uno altrimenti visualizza la finestra WhereUsed (in modalità appropriata) per far selezionare all'utente i documenti da aprire.
Classe pubblica | ApriInNuovaFinestra | Apre la finestra per l'apertura in lettura di un documento.
Classe pubblica | ArchiviaXref | Comando Archivia per Xref. Permette di archiviare il file e poi sostituisce i riferimenti impostando il nuovo file all'interno del documento attivo.
Classe pubblica | AssociaCommXref | Comando Associa a commessa per Xref. Permette di associare il file ad una commessa e poi, se è stato effettuato un copia, sostituisce i riferimenti impostando il nuovo file all'interno del documento attivo.
Classe pubblica | AssociatoA | Comando per visualizzare all'interno di quali anagrafiche è usato un determinato documento
Classe pubblica | AssociaXref | Comando Associa per Xref. Permette di associare il file a un'anagrafica e poi, se è stato effettuato un copia, sostituisce i riferimenti impostando il nuovo file all'interno del documento attivo.
Classe pubblica | CaricaParte | Comando che effettua il carica parte di un DWG, sotto una data parte.
Classe pubblica | ChangeStateXref | Comando di cambio stato per gli Xref. Può essere lanciato in modalità singola o multipla. In caso di modalità multipla utilizza solamente il primo file inserito nella lista di elaborazione in quanto il rilascio multiplo funziona monoselezione.
Classe pubblica | CheckIn | Mette in check-in il documento correntemente attivo se è attivo il flag WorkOnActiveDoc, altrimenti lavora su una lista di file.
Classe pubblica | CheckOut | Mette in check-out il documento correntemente attivo se attivo il flag WorkOnActiveDoc, altrimenti lavora su una lista di file.
Classe pubblica | CompilaParteDaAnagrafica | Compila gli attributi della parte correntemente attiva con l'anagrafica selezionata nella finestra di Ricerca.
Classe pubblica | CreateSparePartsDrawing | Comando che, partendo dal disegno correntemente aperto, crea il documento tecnico dei ricambi da inserire nel manuale.
Classe pubblica | DedAcadArchiviaDwg | Archivia il documento corrente in una root specifica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | DedAcadAssociaDwg | Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | DedAcadChangeState | Comando che effettua il rilascio dell'anagrafica associata
Classe pubblica | DedAcadCommandContext | Classe per il contesto di esecuzione comando all'interno dell'addin. Contiene le informazioni necessarie per l'esecuzione di un comando .
Classe pubblica | DedAcadCreaAnagrafica | Effettua il salvataggio del documento corrente o della parte selezionata nel Database con un nuovo codice. Da utilizzare anche nelle procedure personalizzate. Per personalizzare la creazione dell'anagrafica, impostare nella proprietà SaveCommand un comando inizializzato con già tutte le informazioni preimpostate. Diversamente il comando sarà inizializzato in base agli attributi del documento corrente.
Classe pubblica | DedAcadCreaRev | Effettua il Salva Revisione del documento attivo. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | DedAcadForceMarkerAlingment | Comando che permette di forzare la allineamento del documento con quella presente nel Database.
Classe pubblica | DedAcadMarkerInfo | Comando che permette di controllare lo stato di allineamento del documento.
Classe pubblica | DedAcadSaveDist | Salvataggio distinta
Classe pubblica | DedApiAcad | NOTA : Da Lua usare DEDACADAPI per accedere ai metodi.
Classe pubblica | DedNetAcadApp | Classe principale dell'add-in per Autocad di DedNet. Viene pubblicata l'istanza di questo oggetto attraverso la variabile globale LUA DEDACAD.
Classe pubblica | DedNetAcadAppAcadRilPublishEventArgs | Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Classe pubblica | DedNetAcadAppImportPackAndGoAfterLoadEventArgs | Argomento usato per effettuare modifiche al form dopo caricamento nodi.
Classe pubblica | DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs | Argomento usato per gestire la comparazione degli attributi nelle azioni che lo richiedono
Classe pubblica | DedNetAcadAppImportPackAndGoMappingRootEventArgs |
Classe pubblica | DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs |
Classe pubblica | DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs |
Classe pubblica | DedNetAcadAppResolutionEventArgs | Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Classe pubblica | DedNetAcadAppSkipLayoutOnPrintingEventArgs | Argomento usato per decidere quali layou skippare in fase di stampa.
Classe pubblica | DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs | Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Classe pubblica | DedNetAcadAppUpdateCartOnOpenEventArgs | Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Classe pubblica | DedNetAcadCommands | Classe di definizione dei comandi.
Classe pubblica | DedNetAcadFileResolution |
Classe pubblica | DedNetAcadFileResolutionOnFileResolutionSostItem |
Classe pubblica | DedNetAcadFileResolutionOnFileResolutionSostItemList |
Classe pubblica | FileStateElement | Oggetto descrivente un singolo documento ed il suo stato. Funge da ponte tra chi sa determinare lo stato del documento e deve decidere cosa fare nelle varie situazioni e chi deve visualizzare lo stato del documento e le sue dipendenze.
Classe pubblica | FileStateElementList | Lista di elementi di tipo FileStateElement.
Classe pubblica | FileStateManager | Gestisce lo stato di tutti i documenti presenti in Inventor aperti in modo visibile o meno. Centralizza le funzionalità necessarie al Check-in/out o al riservarsi o meno i documenti. Attraverso l'implementazione di una stessa interfaccia rende possibile avere un albero di documenti con la gestione integrata del loro stato, fruibile sia nel DedPlus che nel Ded tradizionale. Pensa questa classe a registrarsi agli eventi e visualizzare il browser con lo stato dei documenti. Chiama i metodi dell'interfaccia, necessari al check-out/riservo dei documenti.
Classe pubblica | FindInRicerca | Apre la finestra della ricerca con preselezionata l'anagrafica interessata.
Classe pubblica | ForzaAllineamento | Comando per forzare l'allineamento di un documento registrato nel DB.
Classe pubblica | Lua | Utilizzata per chiamare direttamente, in modo trasparente al .NET, funzioni LUA definite sia dai vari file lua del DedNetAcad che native di Top/Top_prt.
Classe pubblica | PackAndGoExport | Esportazione packAndgo Autocad
Classe pubblica | PackAndGoImport | Esportazione packAndgo Autocad
Classe pubblica | PackAndGoImportingStructureInfo | Oggetto di servizio per l'impostazione delle informazioni di descrittore e operazione
Classe pubblica | PackAndGoNodeDescriptor | Descrittore singolo nodo di struttura
Classe pubblica | PackAndGoNodeDescriptors | Classe gestione lista nodi di struttura
Classe pubblica | PackAndGoNodeWrapper | Classe rappresentante l'oggetto nodo nel controllo treeList del form
Classe pubblica | PackAndGoStructureDescriptor | Descrittore di tutta la struttura che viene serializzato. Contiene informazioni sul database e sulla struttura esportata
Classe pubblica | PartInfo | Classe utilizzata per ottenere informazioni, chiamando metodi, sulla parte correntemente selezionata, sulla parte Top del disegno oppure su di una parte utilizzata nella creazione dell'oggetto.
Classe pubblica | PartInfoLoadPartData |
Classe pubblica | PartInfoArray | Classe utilizzata per ottenere informazioni su di un oggetto PrtArray LUA. Chiama i metodi dell'oggetto via LUA come l'oggetto PartInfo. Questo oggetto è creabile solo via LUA.
Classe pubblica | PrtArraySelectStatusInfo | Classe che verifica lo stato di un array di parti e restituisce informazioni utili per la disponibilità e l'esecuzione dei comandi.
Classe pubblica | Pubblica | Comando di pubblicazione.
Classe pubblica | Pubblish |
Classe pubblica | PublishSparePartsDrawing | Comando che pubblica una tavola tecnica ricambi in formato pdf.
Classe pubblica | QsDocument |
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Classe pubblica | Registra | Comando di registrazione di un nuovo documento.
Classe pubblica | Resolver | Classe di inizializzazione add-in. Viene utilizzata per registrare l'evento di risuluzione assembly in modo che nell'inizializzazione vera e propria dell'oggetto DedNetAcadApp si possa liberamente dichiarare i vari tipi di dato senza compromettere il caricamento dell'add-in.
Classe pubblica | SalvaRevXref | Comando Salva Revisione per Xref. Permette di codificare il file e poi sostituisce i riferimenti impostando il nuovo codificato all'interno del documento attivo.
Classe pubblica | SalvaXref | Comando Salva per Xref. Permette di codificare il file e poi sostituisce i riferimenti impostando il nuovo codificato all'interno del documento attivo.
Classe pubblica | SelezionaRiferimento | Comando di selezione di un riferimento nell'interfaccia grafica.
Classe pubblica | SostituisciRiferimenti | Comando di sostituzione dei riferimenti di un xref sul documento attivo. Il comando lavora SEMPRE e SOLO sul documento attivo, per cui gli unici riferimenti sostituibili sono quelli di primo livello.
Classe pubblica | StatoAllineamento | Comando che visualizza il dialogo di stato dell'allineamento di un documento.
Classe pubblica | UpdateOldRev | Aggiorna i riferimenti degli xref superati all'interno del documento attivo.
Classe pubblica | UsatoIn | Comando per visualizzare all'interno di quali documenti è usato un determinato documento
Classe pubblica | Util | Utility con gli assert e varie altre funzioni di utilizzo frequente.
Classe pubblica | UtilCommandHelper |
Classe pubblica | XrefDescriptor | Classe che descrive le informazioni di un riferimento in lettura.
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | IFileStateInformer |
Delegate
 | Delegate | Descrizione
Delegate pubblico | FileStateManagerActivateEventHandler | Elemento che si verifica quando un elemento è stato aggiunto.
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | CaricaParteLoadMode |
Enumerazione pubblica | DedNetAcadFileResolutionRispostaUtenteSost |
Enumerazione pubblica | PackAndGoContext | Definizione possibili contesti
Enumerazione pubblica | PackAndGoImportAttrStatus | Stato attributi in validazione importazione
Enumerazione pubblica | PackAndGoImportDedCases | Possibili casi del database in fase di importazione
Enumerazione pubblica | PackAndGoImportOperation | Definizione possibili azioni su oggetti importazione
Enumerazione pubblica | PackAndGoImportOperationStatus | Stato di validazione dell'operazione ( per ora non usata sempre Ok )
Enumerazione pubblica | PubblishTypeLayoutExp |
Enumerazione pubblica | UtilDxfReferenceType | Enum che contiene le varie tipologie di file da cercare tramite dxf.
Enumerazione pubblica | UtilXrefPathType | Enum che descrive il tipo di percorso nell'inserimento di un xref.

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe AcadCommandBase
Classe base per la gestione dei comandi di AutoCAD, in particolare per quanto riguarda i comandi che vanno a lavorare (anche) sugli XREF.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
Altro

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class AcadCommandBase : DedCommand
Public MustInherit Class AcadCommandBase
    Inherits DedCommand
public ref class AcadCommandBase abstract : public DedCommand
[<AbstractClassAttribute>]
type AcadCommandBase =
    class
        inherit DedCommand
    end

Il tipo AcadCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando sia abilitato in base al contesto di Inventor attuale.
Metodo pubblico | AcadSetContext | Inizializza il comando con il context di Inventor e restituisce true se riesce altrimenti false.
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadApriFileAssociati
DedNetAcadApriInNuovaFinestra
DedNetAcadArchiviaXref
DedNetAcadAssociaCommXref
DedNetAcadAssociatoA
DedNetAcadAssociaXref
DedNetAcadChangeStateXref
DedNetAcadCheckIn
DedNetAcadCheckOut
DedNetAcadFindInRicerca
DedNetAcadForzaAllineamento
DedNetAcadPubblica
DedNetAcadRegistra
DedNetAcadSalvaRevXref
DedNetAcadSalvaXref
DedNetAcadSelezionaRiferimento
DedNetAcadSostituisciRiferimenti
DedNetAcadStatoAllineamento
DedNetAcadUpdateOldRev
DedNetAcadUsatoIn


Proprietà di AcadCommandBase

Il tipo AcadCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo.
Torna su
Vedi anche

Documentazione

Classe AcadCommandBase
Namespace DedNetAcad


Proprietà AcadCommandBase.AddToolbar

Libreria DedNetAcad

Proprietà AcadCommandBaseAddToolbar
Indica se il comando deve essere aggiunto alla toolbar.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddToolbar { get; set; }
Public Property AddToolbar As Boolean
    Get
    Set
public:
property bool AddToolbar {
    bool get ();
    void set (bool value);
}
member AddToolbar : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Proprietà AcadCommandBase.NeedParameters

Proprietà AcadCommandBaseNeedParameters
Restituisce se il comando ha bisogno di parametri. Restituisce sempre false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Proprietà AcadCommandBase.RequireStatePanelRefresh

Proprietà AcadCommandBaseRequireStatePanelRefresh
Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool RequireStatePanelRefresh { get; }
Public Overridable ReadOnly Property RequireStatePanelRefresh As Boolean
    Get
public:
virtual property bool RequireStatePanelRefresh {
    bool get ();
}
abstract RequireStatePanelRefresh : bool with get
override RequireStatePanelRefresh : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Proprietà AcadCommandBase.Struttura

Proprietà AcadCommandBaseStruttura
Restituisce la lista di documenti inventor da elaborare

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Proprietà AcadCommandBase.WorkOnActiveDoc

Proprietà AcadCommandBaseWorkOnActiveDoc
Indica se il comando va a lavorare sul documento attualmente aperto e attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool WorkOnActiveDoc { get; set; }
Public Property WorkOnActiveDoc As Boolean
    Get
    Set
public:
property bool WorkOnActiveDoc {
    bool get ();
    void set (bool value);
}
member WorkOnActiveDoc : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Metodi di AcadCommandBase

Il tipo AcadCommandBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando sia abilitato in base al contesto di Inventor attuale.
Metodo pubblico | AcadSetContext | Inizializza il comando con il context di Inventor e restituisce true se riesce altrimenti false.
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AcadCommandBase


Metodo AcadCommandBase.AcadEnabled

Metodo AcadCommandBaseAcadEnabled
Restituisce se il comando sia abilitato in base al contesto di Inventor attuale.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool AcadEnabled(
    DedAcadCommandContext invCmdCtx
)
Public MustOverride Function AcadEnabled (
    invCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ invCmdCtx
) abstract
abstract AcadEnabled :
        invCmdCtx : DedAcadCommandContext -> bool

Parametri

invCmdCtx DedAcadCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Metodo AcadCommandBase.AcadSetContext

Metodo AcadCommandBaseAcadSetContext
Inizializza il comando con il context di Inventor e restituisce true se riesce altrimenti false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool AcadSetContext(
    DedAcadCommandContext invCmdCtx
)
Public MustOverride Function AcadSetContext (
    invCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ invCmdCtx
) abstract
abstract AcadSetContext :
        invCmdCtx : DedAcadCommandContext -> bool

Parametri

invCmdCtx DedAcadCommandContext
Selezione attuale presente in Inventor.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Metodo AcadCommandBase.ClearCommand

Metodo AcadCommandBaseClearCommand
Azzera il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AcadCommandBase


Metodo AcadCommandBase.Enabled

Metodo AcadCommandBaseEnabled
Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Metodo AcadCommandBase.ExecuteCommand

Metodo AcadCommandBaseExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCmdResult ExecuteCommand()
Protected MustOverride Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() abstract override
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AcadCommandBase


Metodo AcadCommandBase.SetContext

Metodo AcadCommandBaseSetContext
Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AcadCommandBase


Classe AcadDocStructInfo
Gerarchia di ereditarietà
SystemObject
DocStructInfo
DedNetAcadAcadDocStructInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AcadDocStructInfo : DocStructInfo
Public Class AcadDocStructInfo
    Inherits DocStructInfo
public ref class AcadDocStructInfo : public DocStructInfo
type AcadDocStructInfo =
    class
        inherit DocStructInfo
    end

Il tipo AcadDocStructInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | AcadDocStructInfo | Passa la costruzione alla classe base.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DocStructInfo)
Proprietà pubblica | CfgDescr | (Ereditato da DocStructInfo)
Proprietà pubblica | ChildrenMade | (Ereditato da DocStructInfo)
Proprietà pubblica | CloneFullName | (Ereditato da DocStructInfo)
Proprietà pubblica | Config | (Ereditato da DocStructInfo)
Proprietà pubblica | Data | Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.
Proprietà pubblica | DataUpdated | (Ereditato da DocStructInfo)
Proprietà pubblica | DelToMake | (Ereditato da DocStructInfo)
Proprietà pubblica | DepType | (Ereditato da DocStructInfo)
Proprietà pubblica | Description | (Ereditato da DocStructInfo)
Proprietà pubblica | DocRowVer | (Ereditato da DocStructInfo)
Proprietà pubblica | DoNotMoveOrDelete | (Ereditato da DocStructInfo)
Proprietà pubblica | FileDescriptor | (Ereditato da DocStructInfo)
Proprietà pubblica | FileOperationExecuted | (Ereditato da DocStructInfo)
Proprietà pubblica | FirstOperation | (Ereditato da DocStructInfo)
Proprietà pubblica | Folder | (Ereditato da DocStructInfo)
Proprietà pubblica | FullFileName | (Ereditato da DocStructInfo)
Proprietà pubblica | HasChildren | (Ereditato da DocStructInfo)
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo)
Proprietà pubblica | HasSubstitutes | (Ereditato da DocStructInfo)
Proprietà pubblica | InternalName | (Ereditato da DocStructInfo)
Proprietà pubblica | IsElaborated | (Ereditato da DocStructInfo)
Proprietà pubblica | IsiModelMember | (Ereditato da DocStructInfo)
Proprietà pubblica | IsInRootCopy | (Ereditato da DocStructInfo)
Proprietà pubblica | IsLayoutAsset | (Ereditato da DocStructInfo)
Proprietà pubblica | IsParentSubstitute | (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructContainer | (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructElement | (Ereditato da DocStructInfo)
Proprietà pubblica | IsSubstitute | (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperation | (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperationEnum | (Ereditato da DocStructInfo)
Proprietà pubblica | MakeChildrenOutOfMemory | (Ereditato da DocStructInfo)
Proprietà pubblica | MoveInsteadOfCopy | (Ereditato da DocStructInfo)
Proprietà pubblica | OperationList | (Ereditato da DocStructInfo)
Proprietà pubblica | OpListHierarchy | (Ereditato da DocStructInfo)
Proprietà pubblica | Parent | (Ereditato da DocStructInfo)
Proprietà pubblica | ReferenceUpdated | (Ereditato da DocStructInfo)
Proprietà pubblica | RelocateInfo | (Ereditato da DocStructInfo)
Proprietà pubblica | SavingTypeDoc | (Ereditato da DocStructInfo)
Proprietà pubblica | SkipReferenceUpdate | (Ereditato da DocStructInfo)
Proprietà pubblica | Ties | (Ereditato da DocStructInfo)
Proprietà pubblica | ToClone | (Ereditato da DocStructInfo)
Proprietà pubblica | UserData | (Ereditato da DocStructInfo)
Proprietà pubblica | WasInDb | (Ereditato da DocStructInfo)
Proprietà pubblica | WasInLibraryPath | (Ereditato da DocStructInfo)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation(String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedComm) | (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedData) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingStrutturaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedComm) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedEco) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaStrutturaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedComm) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRemovingOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddSbloccaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddUpdatingOperation | (Ereditato da DocStructInfo)
Metodo pubblico | BottomUpCall | (Ereditato da DocStructInfo)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | CreateDocStructInfo(String) | (Ereditato da DocStructInfo)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo))
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | EnforcedMakeChildrenAuto | La logica è la stessa del MakeChildrenAuto solo che legge le dipendenze in base alla varibile di Autocad (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String))
Metodo pubblico | Equals | (Ereditato da DocStructInfo)
Metodo pubblico | FileNameAreEquals | (Ereditato da DocStructInfo)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo)
Metodo pubblico | GetAllSpecialChildren | (Ereditato da DocStructInfo)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetLastQueuedOperation | (Ereditato da DocStructInfo)
Metodo pubblico | GetOperation | (Ereditato da DocStructInfo)
Metodo pubblico | GetOperationHierarchy | (Ereditato da DocStructInfo)
Metodo pubblico | HasOperation | (Ereditato da DocStructInfo)
Metodo pubblico | HasOperationHierarchy | (Ereditato da DocStructInfo)
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | (Ereditato da DocStructInfo)
Metodo pubblico | MakeChildrenAutoByDocDep | (Ereditato da DocStructInfo)
 | MakeFromFileList | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo)
Metodo pubblico | Rebuild | (Ereditato da DocStructInfo)
Metodo pubblico | Reinit | (Ereditato da DocStructInfo)
Metodo pubblico | SetNotToClone | (Ereditato da DocStructInfo)
Metodo pubblico | SetToClone | (Ereditato da DocStructInfo)
Metodo pubblico | ToString | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateData | Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true (Sovrascrive DocStructInfo.UpdateData(Boolean))
Metodo pubblico | UpdateDocumentData | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateParentReferences | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true. (Sovrascrive DocStructInfo.UpdateReferences)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Elements | (Ereditato da DocStructInfo)
Campo pubblico | IgnoreCheckParentCollection | (Ereditato da DocStructInfo)
Campo protetto | Operations | (Ereditato da DocStructInfo)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AcadDocStructInfo
Passa la costruzione alla classe base.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected AcadDocStructInfo(
    DedNetApplication app,
    DocStructInfoCollection parent,
    DocStructInfoDictionary elements,
    DocStructInfoOperationListDictionary operations,
    DocStructInfoFileDescriptor fileDescr,
    DocDepEnum depType
)
Protected Sub New (
    app As DedNetApplication,
    parent As DocStructInfoCollection,
    elements As DocStructInfoDictionary,
    operations As DocStructInfoOperationListDictionary,
    fileDescr As DocStructInfoFileDescriptor,
    depType As DocDepEnum
)
protected:
AcadDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoCollection^ parent,
    DocStructInfoDictionary^ elements,
    DocStructInfoOperationListDictionary^ operations,
    DocStructInfoFileDescriptor^ fileDescr,
    DocDepEnum depType
)
new :
        app : DedNetApplication *
        parent : DocStructInfoCollection *
        elements : DocStructInfoDictionary *
        operations : DocStructInfoOperationListDictionary *
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> AcadDocStructInfo

Parametri

app DedNetApplication
parent DocStructInfoCollection
elements DocStructInfoDictionary
operations DocStructInfoOperationListDictionary
fileDescr DocStructInfoFileDescriptor
depType DocDepEnum
Vedi anche

Documentazione

Classe AcadDocStructInfo


Proprietà di AcadDocStructInfo

Il tipo AcadDocStructInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DocStructInfo)
Proprietà pubblica | CfgDescr | (Ereditato da DocStructInfo)
Proprietà pubblica | ChildrenMade | (Ereditato da DocStructInfo)
Proprietà pubblica | CloneFullName | (Ereditato da DocStructInfo)
Proprietà pubblica | Config | (Ereditato da DocStructInfo)
Proprietà pubblica | Data | Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.
Proprietà pubblica | DataUpdated | (Ereditato da DocStructInfo)
Proprietà pubblica | DelToMake | (Ereditato da DocStructInfo)
Proprietà pubblica | DepType | (Ereditato da DocStructInfo)
Proprietà pubblica | Description | (Ereditato da DocStructInfo)
Proprietà pubblica | DocRowVer | (Ereditato da DocStructInfo)
Proprietà pubblica | DoNotMoveOrDelete | (Ereditato da DocStructInfo)
Proprietà pubblica | FileDescriptor | (Ereditato da DocStructInfo)
Proprietà pubblica | FileOperationExecuted | (Ereditato da DocStructInfo)
Proprietà pubblica | FirstOperation | (Ereditato da DocStructInfo)
Proprietà pubblica | Folder | (Ereditato da DocStructInfo)
Proprietà pubblica | FullFileName | (Ereditato da DocStructInfo)
Proprietà pubblica | HasChildren | (Ereditato da DocStructInfo)
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo)
Proprietà pubblica | HasSubstitutes | (Ereditato da DocStructInfo)
Proprietà pubblica | InternalName | (Ereditato da DocStructInfo)
Proprietà pubblica | IsElaborated | (Ereditato da DocStructInfo)
Proprietà pubblica | IsiModelMember | (Ereditato da DocStructInfo)
Proprietà pubblica | IsInRootCopy | (Ereditato da DocStructInfo)
Proprietà pubblica | IsLayoutAsset | (Ereditato da DocStructInfo)
Proprietà pubblica | IsParentSubstitute | (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructContainer | (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructElement | (Ereditato da DocStructInfo)
Proprietà pubblica | IsSubstitute | (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperation | (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperationEnum | (Ereditato da DocStructInfo)
Proprietà pubblica | MakeChildrenOutOfMemory | (Ereditato da DocStructInfo)
Proprietà pubblica | MoveInsteadOfCopy | (Ereditato da DocStructInfo)
Proprietà pubblica | OperationList | (Ereditato da DocStructInfo)
Proprietà pubblica | OpListHierarchy | (Ereditato da DocStructInfo)
Proprietà pubblica | Parent | (Ereditato da DocStructInfo)
Proprietà pubblica | ReferenceUpdated | (Ereditato da DocStructInfo)
Proprietà pubblica | RelocateInfo | (Ereditato da DocStructInfo)
Proprietà pubblica | SavingTypeDoc | (Ereditato da DocStructInfo)
Proprietà pubblica | SkipReferenceUpdate | (Ereditato da DocStructInfo)
Proprietà pubblica | Ties | (Ereditato da DocStructInfo)
Proprietà pubblica | ToClone | (Ereditato da DocStructInfo)
Proprietà pubblica | UserData | (Ereditato da DocStructInfo)
Proprietà pubblica | WasInDb | (Ereditato da DocStructInfo)
Proprietà pubblica | WasInLibraryPath | (Ereditato da DocStructInfo)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Proprietà AcadDocStructInfo.Data

Proprietà AcadDocStructInfoData
Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodi di AcadDocStructInfo

Il tipo AcadDocStructInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation(String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedComm) | (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedData) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingStrutturaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedComm) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedEco) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaStrutturaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedComm) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddRemovingOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddSbloccaOperation | (Ereditato da DocStructInfo)
Metodo pubblico | AddUpdatingOperation | (Ereditato da DocStructInfo)
Metodo pubblico | BottomUpCall | (Ereditato da DocStructInfo)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | CreateDocStructInfo(String) | (Ereditato da DocStructInfo)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo))
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | (Ereditato da DocStructInfo)
Metodo pubblico | EnforcedMakeChildrenAuto | La logica è la stessa del MakeChildrenAuto solo che legge le dipendenze in base alla varibile di Autocad (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String))
Metodo pubblico | Equals | (Ereditato da DocStructInfo)
Metodo pubblico | FileNameAreEquals | (Ereditato da DocStructInfo)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo)
Metodo pubblico | GetAllSpecialChildren | (Ereditato da DocStructInfo)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetLastQueuedOperation | (Ereditato da DocStructInfo)
Metodo pubblico | GetOperation | (Ereditato da DocStructInfo)
Metodo pubblico | GetOperationHierarchy | (Ereditato da DocStructInfo)
Metodo pubblico | HasOperation | (Ereditato da DocStructInfo)
Metodo pubblico | HasOperationHierarchy | (Ereditato da DocStructInfo)
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | (Ereditato da DocStructInfo)
Metodo pubblico | MakeChildrenAutoByDocDep | (Ereditato da DocStructInfo)
 | MakeFromFileList | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo)
Metodo pubblico | Rebuild | (Ereditato da DocStructInfo)
Metodo pubblico | Reinit | (Ereditato da DocStructInfo)
Metodo pubblico | SetNotToClone | (Ereditato da DocStructInfo)
Metodo pubblico | SetToClone | (Ereditato da DocStructInfo)
Metodo pubblico | ToString | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateData | Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true (Sovrascrive DocStructInfo.UpdateData(Boolean))
Metodo pubblico | UpdateDocumentData | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateParentReferences | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true. (Sovrascrive DocStructInfo.UpdateReferences)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.CreateDocStructInfo

Metodo AcadDocStructInfoCreateDocStructInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) |
Metodo pubblico | CreateDocStructInfo(String) |
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) |
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor)

Metodo AcadDocStructInfoCreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor)
Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static AcadDocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    DocStructInfoFileDescriptor fileDescr
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileDescr As DocStructInfoFileDescriptor
) As AcadDocStructInfo
public:
static AcadDocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoFileDescriptor^ fileDescr
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileDescr : DocStructInfoFileDescriptor -> AcadDocStructInfo

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileDescr DocStructInfoFileDescriptor
File del quale ricavere le informazioni.

Valore di ritorno

AcadDocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe AcadDocStructInfo
Overload di CreateDocStructInfo


Metodo AcadDocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo)

Metodo AcadDocStructInfoCreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr,
    DocStructInfo parent
)
Public Overrides Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor,
    parent As DocStructInfo
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr,
    DocStructInfo^ parent
) override
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo

Parametri

fileDescr DocStructInfoFileDescriptor
Descrittore file del quale ricavere le informazioni
parent DocStructInfo
Padre dell'elemento.

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe AcadDocStructInfo
Overload di CreateDocStructInfo


Metodo AcadDocStructInfo.EnforcedMakeChildrenAuto

Metodo AcadDocStructInfoEnforcedMakeChildrenAuto
La logica è la stessa del MakeChildrenAuto solo che legge le dipendenze in base alla varibile di Autocad

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void EnforcedMakeChildrenAuto(
    string fileName
)
Public Overrides Sub EnforcedMakeChildrenAuto (
    fileName As String
)
public:
virtual void EnforcedMakeChildrenAuto(
    String^ fileName
) override
abstract EnforcedMakeChildrenAuto :
        fileName : string -> unit
override EnforcedMakeChildrenAuto :
        fileName : string -> unit

Parametri

fileName String
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.MakeChildrenAuto

Metodo AcadDocStructInfoMakeChildrenAuto
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria.
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) |
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.MakeChildrenAuto

Metodo AcadDocStructInfoMakeChildrenAuto
Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void MakeChildrenAuto()
Public Overrides Sub MakeChildrenAuto
public:
virtual void MakeChildrenAuto() override
abstract MakeChildrenAuto : unit -> unit
override MakeChildrenAuto : unit -> unit
Vedi anche

Documentazione

Classe AcadDocStructInfo
Overload di MakeChildrenAuto


Metodo AcadDocStructInfo.MakeFromFileList

Metodo AcadDocStructInfoMakeFromFileList
Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileList(
    DedNetApplication app,
    string[] fileList
)
Public Shared Function MakeFromFileList (
    app As DedNetApplication,
    fileList As String()
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileList(
    DedNetApplication^ app,
    array<String^>^ fileList
)
static member MakeFromFileList :
        app : DedNetApplication *
        fileList : string[] -> DocStructInfoList

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileList String
Lista di file da elaborare.

Valore di ritorno

DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.UpdateData

Metodo AcadDocStructInfoUpdateData
Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateData(
    bool updateRowVer = true
)
Public Overrides Sub UpdateData (
    Optional updateRowVer As Boolean = true
)
public:
virtual void UpdateData(
    bool updateRowVer = true
) override
abstract UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit
override UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit

Parametri

updateRowVer Boolean (Optional)
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.UpdateReferences

Metodo AcadDocStructInfoUpdateReferences
Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateReferences()
Public Overrides Sub UpdateReferences
public:
virtual void UpdateReferences() override
abstract UpdateReferences : unit -> unit
override UpdateReferences : unit -> unit
Vedi anche

Documentazione

Classe AcadDocStructInfo


Campi di AcadDocStructInfo

Il tipo AcadDocStructInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Elements | (Ereditato da DocStructInfo)
Campo pubblico | IgnoreCheckParentCollection | (Ereditato da DocStructInfo)
Campo protetto | Operations | (Ereditato da DocStructInfo)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Classe AcadDocStructInfoEventHandlers
Classe gestione eventi client del DoscStructInfo
Gerarchia di ereditarietà
SystemObject
DedNetAcadAcadDocStructInfoEventHandlers

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AcadDocStructInfoEventHandlers
Public Class AcadDocStructInfoEventHandlers
public ref class AcadDocStructInfoEventHandlers
type AcadDocStructInfoEventHandlers = class end

Il tipo AcadDocStructInfoEventHandlers espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AcadDocStructInfoEventHandlers |
Torna su
Metodi
Nome | Descrizione
InitializeDocStructInfoEvents | Metodo che inizializza gli eventi
OnDocStructInfoCreated | Evento chiamato al termine della creazione di un nuovo struct info
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AcadDocStructInfoEventHandlers

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public AcadDocStructInfoEventHandlers()
Public Sub New
public:
AcadDocStructInfoEventHandlers()
new : unit -> AcadDocStructInfoEventHandlers
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Metodi di AcadDocStructInfoEventHandlers

Il tipo AcadDocStructInfoEventHandlers espone i seguenti membri.

Metodi
Nome | Descrizione
InitializeDocStructInfoEvents | Metodo che inizializza gli eventi
OnDocStructInfoCreated | Evento chiamato al termine della creazione di un nuovo struct info
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Metodo AcadDocStructInfoEventHandlers.InitializeDocStructInfoEvents

Metodo AcadDocStructInfoEventHandlersInitializeDocStructInfoEvents
Metodo che inizializza gli eventi

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void InitializeDocStructInfoEvents()
Public Shared Sub InitializeDocStructInfoEvents
public:
static void InitializeDocStructInfoEvents()
static member InitializeDocStructInfoEvents : unit -> unit
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Metodo AcadDocStructInfoEventHandlers.OnDocStructInfoCreated

Metodo AcadDocStructInfoEventHandlersOnDocStructInfoCreated
Evento chiamato al termine della creazione di un nuovo struct info

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnDocStructInfoCreated(
    Object sender,
    ResolveDocStructInfoEventArgs args
)
Public Shared Sub OnDocStructInfoCreated (
    sender As Object,
    args As ResolveDocStructInfoEventArgs
)
public:
static void OnDocStructInfoCreated(
    Object^ sender,
    ResolveDocStructInfoEventArgs^ args
)
static member OnDocStructInfoCreated :
        sender : Object *
        args : ResolveDocStructInfoEventArgs -> unit

Parametri

sender Object
args ResolveDocStructInfoEventArgs
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Classe ApriFileAssociati
Apre il file associato se ne esiste soltanto uno altrimenti visualizza la finestra WhereUsed (in modalità appropriata) per far selezionare all'utente i documenti da aprire.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadApriFileAssociati

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ApriFileAssociati : AcadCommandBase
Public Class ApriFileAssociati
    Inherits AcadCommandBase
public ref class ApriFileAssociati : public AcadCommandBase
type ApriFileAssociati =
    class
        inherit AcadCommandBase
    end

Il tipo ApriFileAssociati espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Attachments | Imposta o ritorna se il comando deve lavorare sugli allegati (True) o sugli associati (False).
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di ApriFileAssociati

Il tipo ApriFileAssociati espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Attachments | Imposta o ritorna se il comando deve lavorare sugli allegati (True) o sugli associati (False).
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe ApriFileAssociati


Proprietà ApriFileAssociati.Attachments

Proprietà ApriFileAssociatiAttachments
Imposta o ritorna se il comando deve lavorare sugli allegati (True) o sugli associati (False).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Attachments { get; set; }
Public Property Attachments As Boolean
    Get
    Set
public:
property bool Attachments {
    bool get ();
    void set (bool value);
}
member Attachments : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati


Proprietà ApriFileAssociati.NeedParameters

Proprietà ApriFileAssociatiNeedParameters
Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati


Metodi di ApriFileAssociati

Il tipo ApriFileAssociati espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriFileAssociati


Metodo ApriFileAssociati.AcadEnabled

Metodo ApriFileAssociatiAcadEnabled
Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati


Metodo ApriFileAssociati.AcadSetContext

Metodo ApriFileAssociatiAcadSetContext
Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati


Metodo ApriFileAssociati.ClearCommand

Metodo ApriFileAssociatiClearCommand
Azzera e rigenera il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriFileAssociati


Metodo ApriFileAssociati.ExecuteCommand

Metodo ApriFileAssociatiExecuteCommand
Lancia il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriFileAssociati


Classe ApriInNuovaFinestra
Apre la finestra per l'apertura in lettura di un documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadApriInNuovaFinestra

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ApriInNuovaFinestra : AcadCommandBase
Public Class ApriInNuovaFinestra
    Inherits AcadCommandBase
public ref class ApriInNuovaFinestra : public AcadCommandBase
type ApriInNuovaFinestra =
    class
        inherit AcadCommandBase
    end

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da AcadCommandBase)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzeramento campi del comando (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in lettura. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di ApriInNuovaFinestra

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da AcadCommandBase)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe ApriInNuovaFinestra


Metodi di ApriInNuovaFinestra

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzeramento campi del comando (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in lettura. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInNuovaFinestra


Metodo ApriInNuovaFinestra.AcadEnabled

Metodo ApriInNuovaFinestraAcadEnabled
Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInNuovaFinestra


Metodo ApriInNuovaFinestra.AcadSetContext

Metodo ApriInNuovaFinestraAcadSetContext
Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInNuovaFinestra


Metodo ApriInNuovaFinestra.ClearCommand

Metodo ApriInNuovaFinestraClearCommand
Azzeramento campi del comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriInNuovaFinestra


Metodo ApriInNuovaFinestra.ExecuteCommand

Metodo ApriInNuovaFinestraExecuteCommand
Lancia il comando di apertura in lettura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriInNuovaFinestra


Classe ArchiviaXref
Comando Archivia per Xref. Permette di archiviare il file e poi sostituisce i riferimenti impostando il nuovo file all'interno del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadArchiviaXref

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ArchiviaXref : AcadCommandBase
Public Class ArchiviaXref
    Inherits AcadCommandBase
public ref class ArchiviaXref : public AcadCommandBase
type ArchiviaXref =
    class
        inherit AcadCommandBase
    end

Il tipo ArchiviaXref espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ArchiviaXref | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ArchiviaXref
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ArchiviaXref(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
ArchiviaXref(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> ArchiviaXref

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe ArchiviaXref


Proprietà di ArchiviaXref

Il tipo ArchiviaXref espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Vedi anche

Documentazione

Classe ArchiviaXref


Proprietà ArchiviaXref.CreazioneVariante

Proprietà ArchiviaXrefCreazioneVariante
Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ArchiviaXref


Proprietà ArchiviaXref.NeedParameters

Proprietà ArchiviaXrefNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ArchiviaXref


Proprietà ArchiviaXref.XrefFileName

Proprietà ArchiviaXrefXrefFileName
Restituisce o imposta il filename dell'xref di partenza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string XrefFileName { get; set; }
Public Property XrefFileName As String
    Get
    Set
public:
property String^ XrefFileName {
    String^ get ();
    void set (String^ value);
}
member XrefFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ArchiviaXref


Metodi di ArchiviaXref

Il tipo ArchiviaXref espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ArchiviaXref


Metodo ArchiviaXref.AcadEnabled

Metodo ArchiviaXrefAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ArchiviaXref


Metodo ArchiviaXref.AcadSetContext

Metodo ArchiviaXrefAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ArchiviaXref


Metodo ArchiviaXref.ClearCommand

Metodo ArchiviaXrefClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ArchiviaXref


Metodo ArchiviaXref.ExecuteCommand

Metodo ArchiviaXrefExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ArchiviaXref


Classe AssociaCommXref
Comando Associa a commessa per Xref. Permette di associare il file ad una commessa e poi, se è stato effettuato un copia, sostituisce i riferimenti impostando il nuovo file all'interno del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadAssociaCommXref

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AssociaCommXref : AcadCommandBase
Public Class AssociaCommXref
    Inherits AcadCommandBase
public ref class AssociaCommXref : public AcadCommandBase
type AssociaCommXref =
    class
        inherit AcadCommandBase
    end

Il tipo AssociaCommXref espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AssociaCommXref | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AssociaCommXref
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public AssociaCommXref(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
AssociaCommXref(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> AssociaCommXref

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe AssociaCommXref


Proprietà di AssociaCommXref

Il tipo AssociaCommXref espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Vedi anche

Documentazione

Classe AssociaCommXref


Proprietà AssociaCommXref.LinkNotCopy

Proprietà AssociaCommXrefLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaCommXref


Proprietà AssociaCommXref.NeedParameters

Proprietà AssociaCommXrefNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaCommXref


Proprietà AssociaCommXref.XrefFileName

Proprietà AssociaCommXrefXrefFileName
Restituisce o imposta il filename dell'xref di partenza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string XrefFileName { get; set; }
Public Property XrefFileName As String
    Get
    Set
public:
property String^ XrefFileName {
    String^ get ();
    void set (String^ value);
}
member XrefFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AssociaCommXref


Metodi di AssociaCommXref

Il tipo AssociaCommXref espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociaCommXref


Metodo AssociaCommXref.AcadEnabled

Metodo AssociaCommXrefAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssociaCommXref


Metodo AssociaCommXref.AcadSetContext

Metodo AssociaCommXrefAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe AssociaCommXref


Metodo AssociaCommXref.ClearCommand

Metodo AssociaCommXrefClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociaCommXref


Metodo AssociaCommXref.ExecuteCommand

Metodo AssociaCommXrefExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe AssociaCommXref


Classe AssociatoA
Comando per visualizzare all'interno di quali anagrafiche è usato un determinato documento
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadAssociatoA

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AssociatoA : AcadCommandBase
Public Class AssociatoA
    Inherits AcadCommandBase
public ref class AssociatoA : public AcadCommandBase
type AssociatoA =
    class
        inherit AcadCommandBase
    end

Il tipo AssociatoA espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Imposta il comando in base alla selezione. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di AssociatoA

Il tipo AssociatoA espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe AssociatoA


Proprietà AssociatoA.NeedParameters

Proprietà AssociatoANeedParameters
Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociatoA


Metodi di AssociatoA

Il tipo AssociatoA espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Imposta il comando in base alla selezione. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociatoA


Metodo AssociatoA.AcadEnabled

Metodo AssociatoAAcadEnabled
Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociatoA


Metodo AssociatoA.AcadSetContext

Metodo AssociatoAAcadSetContext
Imposta il comando in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociatoA


Metodo AssociatoA.ClearCommand

Metodo AssociatoAClearCommand
Azzera il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociatoA


Metodo AssociatoA.ExecuteCommand

Metodo AssociatoAExecuteCommand
Lancia il comando di "Usato in".

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AssociatoA


Classe AssociaXref
Comando Associa per Xref. Permette di associare il file a un'anagrafica e poi, se è stato effettuato un copia, sostituisce i riferimenti impostando il nuovo file all'interno del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadAssociaXref

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AssociaXref : AcadCommandBase
Public Class AssociaXref
    Inherits AcadCommandBase
public ref class AssociaXref : public AcadCommandBase
type AssociaXref =
    class
        inherit AcadCommandBase
    end

Il tipo AssociaXref espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AssociaXref | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | Mdres | Informazioni sul risultato del move dei documenti
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AssociaXref
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public AssociaXref(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
AssociaXref(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> AssociaXref

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe AssociaXref


Proprietà di AssociaXref

Il tipo AssociaXref espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | Mdres | Informazioni sul risultato del move dei documenti
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.Data

Proprietà AssociaXrefData
Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.EnforceOverWriteMode

Proprietà AssociaXrefEnforceOverWriteMode
Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.LinkNotCopy

Proprietà AssociaXrefLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.Mdres

Proprietà AssociaXrefMdres
Informazioni sul risultato del move dei documenti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.NeedParameters

Proprietà AssociaXrefNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.PrimaryContext

Proprietà AssociaXrefPrimaryContext
Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.SparePartsContext

Proprietà AssociaXrefSparePartsContext
Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.UseDocValues

Proprietà AssociaXrefUseDocValues
Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaXref


Proprietà AssociaXref.XrefFileName

Proprietà AssociaXrefXrefFileName
Restituisce o imposta il filename dell'xref di partenza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string XrefFileName { get; set; }
Public Property XrefFileName As String
    Get
    Set
public:
property String^ XrefFileName {
    String^ get ();
    void set (String^ value);
}
member XrefFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AssociaXref


Metodi di AssociaXref

Il tipo AssociaXref espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociaXref


Metodo AssociaXref.AcadEnabled

Metodo AssociaXrefAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssociaXref


Metodo AssociaXref.AcadSetContext

Metodo AssociaXrefAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe AssociaXref


Metodo AssociaXref.ClearCommand

Metodo AssociaXrefClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociaXref


Metodo AssociaXref.ExecuteCommand

Metodo AssociaXrefExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe AssociaXref


Classe CaricaParte
Comando che effettua il carica parte di un DWG, sotto una data parte.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCaricaParte

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CaricaParte : DedCommand
Public Class CaricaParte
    Inherits DedCommand
public ref class CaricaParte : public DedCommand
type CaricaParte =
    class
        inherit DedCommand
    end

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è true.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LoadAsBlock | Restituisce o imposta se bisogna inserire il documento come blocco o meno.
Proprietà pubblica | LoadAsPrtExt | Restituisce o imposta se bisogna utilizzare il comando "Carica parte esterna".
Proprietà pubblica | LoadAsXref | Restituisce o imposta se bisogna inserire il documento come xRef o meno.
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrtNew | Restituisce la parte caricata. Disponibile solo alla fine del comando. Non è detto che il comando riesca a reperire la parte, soprattutto se lanciato dalla ricerca in modo asincrono.
Proprietà pubblica | PrtPadre | Restituisce o imposta la parte sotto la quale caricare il documento. Se non specificata viene utilizzata la parte correntemente attiva.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è true.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LoadAsBlock | Restituisce o imposta se bisogna inserire il documento come blocco o meno.
Proprietà pubblica | LoadAsPrtExt | Restituisce o imposta se bisogna utilizzare il comando "Carica parte esterna".
Proprietà pubblica | LoadAsXref | Restituisce o imposta se bisogna inserire il documento come xRef o meno.
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrtNew | Restituisce la parte caricata. Disponibile solo alla fine del comando. Non è detto che il comando riesca a reperire la parte, soprattutto se lanciato dalla ricerca in modo asincrono.
Proprietà pubblica | PrtPadre | Restituisce o imposta la parte sotto la quale caricare il documento. Se non specificata viene utilizzata la parte correntemente attiva.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.Asynch

Proprietà CaricaParteAsynch
Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è true.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.DocInfo

Proprietà CaricaParteDocInfo
Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.DocInfos

Proprietà CaricaParteDocInfos
Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommandDocAnagrInfo> DocInfos { get; set; }
Public Property DocInfos As List(Of DedCommandDocAnagrInfo)
    Get
    Set
public:
property List<DedCommandDocAnagrInfo^>^ DocInfos {
    List<DedCommandDocAnagrInfo^>^ get ();
    void set (List<DedCommandDocAnagrInfo^>^ value);
}
member DocInfos : List<DedCommandDocAnagrInfo> with get, set

Valore della proprietà

List DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.LoadAsBlock

Proprietà CaricaParteLoadAsBlock
Restituisce o imposta se bisogna inserire il documento come blocco o meno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadAsBlock { get; set; }
Public Property LoadAsBlock As Boolean
    Get
    Set
public:
property bool LoadAsBlock {
    bool get ();
    void set (bool value);
}
member LoadAsBlock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.LoadAsPrtExt

Proprietà CaricaParteLoadAsPrtExt
Restituisce o imposta se bisogna utilizzare il comando "Carica parte esterna".

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadAsPrtExt { get; set; }
Public Property LoadAsPrtExt As Boolean
    Get
    Set
public:
property bool LoadAsPrtExt {
    bool get ();
    void set (bool value);
}
member LoadAsPrtExt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.LoadAsXref

Proprietà CaricaParteLoadAsXref
Restituisce o imposta se bisogna inserire il documento come xRef o meno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadAsXref { get; set; }
Public Property LoadAsXref As Boolean
    Get
    Set
public:
property bool LoadAsXref {
    bool get ();
    void set (bool value);
}
member LoadAsXref : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.NeedParameters

Proprietà CaricaParteNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.PrtNew

Proprietà CaricaPartePrtNew
Restituisce la parte caricata. Disponibile solo alla fine del comando. Non è detto che il comando riesca a reperire la parte, soprattutto se lanciato dalla ricerca in modo asincrono.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtNew { get; }
Public ReadOnly Property PrtNew As PartInfo
    Get
public:
property PartInfo^ PrtNew {
    PartInfo^ get ();
}
member PrtNew : PartInfo with get

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.PrtPadre

Proprietà CaricaPartePrtPadre
Restituisce o imposta la parte sotto la quale caricare il documento. Se non specificata viene utilizzata la parte correntemente attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtPadre { get; set; }
Public Property PrtPadre As PartInfo
    Get
    Set
public:
property PartInfo^ PrtPadre {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtPadre : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe CaricaParte


Metodi di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.ClearCommand

Metodo CaricaParteClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.Enabled

Metodo CaricaParteEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.ExecuteCommand

Metodo CaricaParteExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.SetContext

Metodo CaricaParteSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CaricaParte


Enumerazione CaricaParteLoadMode

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum CaricaParteLoadMode
Public Enumeration CaricaParteLoadMode
public enum class CaricaParteLoadMode
type CaricaParteLoadMode
Membri
Nome | Valore | Descrizione
AsPart | 0 |
AsPartExternal | 1 |
AsBlock | 2 |
AsXRef | 3 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ChangeStateXref
Comando di cambio stato per gli Xref. Può essere lanciato in modalità singola o multipla. In caso di modalità multipla utilizza solamente il primo file inserito nella lista di elaborazione in quanto il rilascio multiplo funziona monoselezione.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadChangeStateXref

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ChangeStateXref : AcadCommandBase
Public Class ChangeStateXref
    Inherits AcadCommandBase
public ref class ChangeStateXref : public AcadCommandBase
type ChangeStateXref =
    class
        inherit AcadCommandBase
    end

Il tipo ChangeStateXref espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ChangeStateXref | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce o imposta la lista di file su cui lavorare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Multiple | Restituisce o imposta il flag che indica se va eseguito un cambio stato multiplo.
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | TargetState | Restituisce o imposta lo stato anagrafico di destinazione.
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | SingleChangeState | Metodo delegate usato per l'operazione di cambio stato.
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ChangeStateXref
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeStateXref(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
ChangeStateXref(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> ChangeStateXref

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe ChangeStateXref


Proprietà di ChangeStateXref

Il tipo ChangeStateXref espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce o imposta la lista di file su cui lavorare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Multiple | Restituisce o imposta il flag che indica se va eseguito un cambio stato multiplo.
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | TargetState | Restituisce o imposta lo stato anagrafico di destinazione.
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe ChangeStateXref


Proprietà ChangeStateXref.FileList

Proprietà ChangeStateXrefFileList
Restituisce o imposta la lista di file su cui lavorare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FileList { get; set; }
Public Property FileList As List(Of String)
    Get
    Set
public:
property List<String^>^ FileList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FileList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe ChangeStateXref


Proprietà ChangeStateXref.Multiple

Proprietà ChangeStateXrefMultiple
Restituisce o imposta il flag che indica se va eseguito un cambio stato multiplo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multiple { get; set; }
Public Property Multiple As Boolean
    Get
    Set
public:
property bool Multiple {
    bool get ();
    void set (bool value);
}
member Multiple : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChangeStateXref


Proprietà ChangeStateXref.NeedParameters

Proprietà ChangeStateXrefNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChangeStateXref


Proprietà ChangeStateXref.TargetState

Proprietà ChangeStateXrefTargetState
Restituisce o imposta lo stato anagrafico di destinazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedState TargetState { get; set; }
Public Property TargetState As DedState
    Get
    Set
public:
property DedState^ TargetState {
    DedState^ get ();
    void set (DedState^ value);
}
member TargetState : DedState with get, set

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe ChangeStateXref


Metodi di ChangeStateXref

Il tipo ChangeStateXref espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | SingleChangeState | Metodo delegate usato per l'operazione di cambio stato.
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangeStateXref


Metodo ChangeStateXref.AcadEnabled

Metodo ChangeStateXrefAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ChangeStateXref


Metodo ChangeStateXref.AcadSetContext

Metodo ChangeStateXrefAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ChangeStateXref


Metodo ChangeStateXref.ClearCommand

Metodo ChangeStateXrefClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ChangeStateXref


Metodo ChangeStateXref.ExecuteCommand

Metodo ChangeStateXrefExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ChangeStateXref


Metodo ChangeStateXref.SingleChangeState

Metodo ChangeStateXrefSingleChangeState
Metodo delegate usato per l'operazione di cambio stato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult SingleChangeState(
    DedState targetState,
    string changeNote,
    MultipleStateOperationPartInfoDoc docInfo,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Function SingleChangeState (
    targetState As DedState,
    changeNote As String,
    docInfo As MultipleStateOperationPartInfoDoc,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public:
DedCmdResult SingleChangeState(
    DedState^ targetState,
    String^ changeNote,
    MultipleStateOperationPartInfoDoc^ docInfo,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
member SingleChangeState :
        targetState : DedState *
        changeNote : string *
        docInfo : MultipleStateOperationPartInfoDoc *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState DedState
Stato di destinazione.
changeNote String
Note da visualizzare nel cambio stato.
docInfo MultipleStateOperationPartInfoDoc
Oggetto descrittore del cambio stato.
multiplo Boolean
Indica se è un cambio stato multiplo.
message String
Messaggio da visualizzare all'interno del dialogo.
pubExtList List Exception
Lista di eccezioni.

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ChangeStateXref


Classe CheckIn
Mette in check-in il documento correntemente attivo se è attivo il flag WorkOnActiveDoc, altrimenti lavora su una lista di file.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadCheckIn

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckIn : AcadCommandBase
Public Class CheckIn
    Inherits AcadCommandBase
public ref class CheckIn : public AcadCommandBase
type CheckIn =
    class
        inherit AcadCommandBase
    end

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | AssociatedFiles | Indica se il comando deve lavorare anche sui file associati.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se eliminare il documento dall'area locale. Di default è false.
Proprietà pubblica | FnList | Lista di file da porre in c/i.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo. (Sovrascrive AcadCommandBaseRequireStatePanelRefresh)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CheckIn

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | AssociatedFiles | Indica se il comando deve lavorare anche sui file associati.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se eliminare il documento dall'area locale. Di default è false.
Proprietà pubblica | FnList | Lista di file da porre in c/i.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo. (Sovrascrive AcadCommandBaseRequireStatePanelRefresh)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.AssociatedFiles

Proprietà CheckInAssociatedFiles
Indica se il comando deve lavorare anche sui file associati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AssociatedFiles { get; set; }
Public Property AssociatedFiles As Boolean
    Get
    Set
public:
property bool AssociatedFiles {
    bool get ();
    void set (bool value);
}
member AssociatedFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.EraseFromPws

Proprietà CheckInEraseFromPws
Restituisce o imposta se eliminare il documento dall'area locale. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EraseFromPws { get; set; }
Public Property EraseFromPws As Boolean
    Get
    Set
public:
property bool EraseFromPws {
    bool get ();
    void set (bool value);
}
member EraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.FnList

Proprietà CheckInFnList
Lista di file da porre in c/i.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FnList { get; set; }
Public Property FnList As List(Of String)
    Get
    Set
public:
property List<String^>^ FnList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FnList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.NeedParameters

Proprietà CheckInNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.RequireStatePanelRefresh

Proprietà CheckInRequireStatePanelRefresh
Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool RequireStatePanelRefresh { get; }
Public Overrides ReadOnly Property RequireStatePanelRefresh As Boolean
    Get
public:
virtual property bool RequireStatePanelRefresh {
    bool get () override;
}
abstract RequireStatePanelRefresh : bool with get
override RequireStatePanelRefresh : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckIn


Metodi di CheckIn

Il tipo CheckIn espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.AcadEnabled

Metodo CheckInAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.AcadSetContext

Metodo CheckInAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.ClearCommand

Metodo CheckInClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.ExecuteCommand

Metodo CheckInExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CheckIn


Classe CheckOut
Mette in check-out il documento correntemente attivo se attivo il flag WorkOnActiveDoc, altrimenti lavora su una lista di file.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadCheckOut

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckOut : AcadCommandBase
Public Class CheckOut
    Inherits AcadCommandBase
public ref class CheckOut : public AcadCommandBase
type CheckOut =
    class
        inherit AcadCommandBase
    end

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | AssociatedFiles | Indica se il comando deve lavorare anche sui file associati.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FnList | Lista di file da porre in c/o.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo. (Sovrascrive AcadCommandBaseRequireStatePanelRefresh)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CheckOut

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | AssociatedFiles | Indica se il comando deve lavorare anche sui file associati.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FnList | Lista di file da porre in c/o.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo. (Sovrascrive AcadCommandBaseRequireStatePanelRefresh)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe CheckOut


Proprietà CheckOut.AssociatedFiles

Proprietà CheckOutAssociatedFiles
Indica se il comando deve lavorare anche sui file associati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AssociatedFiles { get; set; }
Public Property AssociatedFiles As Boolean
    Get
    Set
public:
property bool AssociatedFiles {
    bool get ();
    void set (bool value);
}
member AssociatedFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOut


Proprietà CheckOut.FnList

Proprietà CheckOutFnList
Lista di file da porre in c/o.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FnList { get; set; }
Public Property FnList As List(Of String)
    Get
    Set
public:
property List<String^>^ FnList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FnList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CheckOut


Proprietà CheckOut.NeedParameters

Proprietà CheckOutNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOut


Proprietà CheckOut.RequireStatePanelRefresh

Proprietà CheckOutRequireStatePanelRefresh
Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool RequireStatePanelRefresh { get; }
Public Overrides ReadOnly Property RequireStatePanelRefresh As Boolean
    Get
public:
virtual property bool RequireStatePanelRefresh {
    bool get () override;
}
abstract RequireStatePanelRefresh : bool with get
override RequireStatePanelRefresh : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOut


Metodi di CheckOut

Il tipo CheckOut espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.AcadEnabled

Metodo CheckOutAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.AcadSetContext

Metodo CheckOutAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.ClearCommand

Metodo CheckOutClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.ExecuteCommand

Metodo CheckOutExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CheckOut


Classe CompilaParteDaAnagrafica
Compila gli attributi della parte correntemente attiva con l'anagrafica selezionata nella finestra di Ricerca.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCompilaParteDaAnagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CompilaParteDaAnagrafica : DedCommand
Public Class CompilaParteDaAnagrafica
    Inherits DedCommand
public ref class CompilaParteDaAnagrafica : public DedCommand
type CompilaParteDaAnagrafica =
    class
        inherit DedCommand
    end

Il tipo CompilaParteDaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica da compilare nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere sia l'anagrafica che la parte attiva. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Prt | Restitusice o imposta la parte da compilare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CompilaParteDaAnagrafica

Il tipo CompilaParteDaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica da compilare nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere sia l'anagrafica che la parte attiva. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Prt | Restitusice o imposta la parte da compilare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Proprietà CompilaParteDaAnagrafica.Data

Proprietà CompilaParteDaAnagraficaData
Restituisce o imposta l'anagrafica da compilare nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Proprietà CompilaParteDaAnagrafica.NeedParameters

Proprietà CompilaParteDaAnagraficaNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere sia l'anagrafica che la parte attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Proprietà CompilaParteDaAnagrafica.Prt

Proprietà CompilaParteDaAnagraficaPrt
Restitusice o imposta la parte da compilare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; set; }
Public Property Prt As PartInfo
    Get
    Set
public:
property PartInfo^ Prt {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member Prt : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodi di CompilaParteDaAnagrafica

Il tipo CompilaParteDaAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.ClearCommand

Metodo CompilaParteDaAnagraficaClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.Enabled

Metodo CompilaParteDaAnagraficaEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.ExecuteCommand

Metodo CompilaParteDaAnagraficaExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.SetContext

Metodo CompilaParteDaAnagraficaSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Classe CreateSparePartsDrawing
Comando che, partendo dal disegno correntemente aperto, crea il documento tecnico dei ricambi da inserire nel manuale.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCreateSparePartsDrawing

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateSparePartsDrawing : DedCommand
Public Class CreateSparePartsDrawing
    Inherits DedCommand
public ref class CreateSparePartsDrawing : public DedCommand
type CreateSparePartsDrawing =
    class
        inherit DedCommand
    end

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Proprietà CreateSparePartsDrawing.NeedParameters

Proprietà CreateSparePartsDrawingNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodi di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.ClearCommand

Metodo CreateSparePartsDrawingClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.Enabled

Metodo CreateSparePartsDrawingEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.ExecuteCommand

Metodo CreateSparePartsDrawingExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.SetContext

Metodo CreateSparePartsDrawingSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Classe DedAcadArchiviaDwg
Archivia il documento corrente in una root specifica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadArchiviaDwg

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadArchiviaDwg : DedCommand
Public Class DedAcadArchiviaDwg
    Inherits DedCommand
public ref class DedAcadArchiviaDwg : public DedCommand
type DedAcadArchiviaDwg =
    class
        inherit DedCommand
    end

Il tipo DedAcadArchiviaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadArchiviaDwg

Il tipo DedAcadArchiviaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.AcadDoc

Proprietà DedAcadArchiviaDwgAcadDoc
Restitusice il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

QsDocument
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.AlsoSubParts

Proprietà DedAcadArchiviaDwgAlsoSubParts
Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.Data

Proprietà DedAcadArchiviaDwgData
Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.EnforceOverWriteMode

Proprietà DedAcadArchiviaDwgEnforceOverWriteMode
Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.InfoItem

Proprietà DedAcadArchiviaDwgInfoItem
Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
property DocStructInfo^ InfoItem {
    DocStructInfo^ get ();
}
member InfoItem : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.IsSavePrt

Proprietà DedAcadArchiviaDwgIsSavePrt
Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.LinkNotCopy

Proprietà DedAcadArchiviaDwgLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.NeedParameters

Proprietà DedAcadArchiviaDwgNeedParameters
Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.PrimaryContext

Proprietà DedAcadArchiviaDwgPrimaryContext
Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.Prt

Proprietà DedAcadArchiviaDwgPrt
Restituisce la parte da associare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; set; }
Public Property Prt As PartInfo
    Get
    Set
public:
property PartInfo^ Prt {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member Prt : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.UseDocValues

Proprietà DedAcadArchiviaDwgUseDocValues
Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodi di DedAcadArchiviaDwg

Il tipo DedAcadArchiviaDwg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.ClearCommand

Metodo DedAcadArchiviaDwgClearCommand
Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.Enabled

Metodo DedAcadArchiviaDwgEnabled
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.ExecuteCommand

Metodo DedAcadArchiviaDwgExecuteCommand
Esegue il comando di associazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.SetContext

Metodo DedAcadArchiviaDwgSetContext
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Classe DedAcadAssociaDwg
Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadAssociaDwg

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadAssociaDwg : DedCommand
Public Class DedAcadAssociaDwg
    Inherits DedCommand
public ref class DedAcadAssociaDwg : public DedCommand
type DedAcadAssociaDwg =
    class
        inherit DedCommand
    end

Il tipo DedAcadAssociaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | Mdres | Informazioni sul risultato del move dei documenti
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadAssociaDwg

Il tipo DedAcadAssociaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | Mdres | Informazioni sul risultato del move dei documenti
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.AcadDoc

Proprietà DedAcadAssociaDwgAcadDoc
Restitusice il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

QsDocument
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.AlsoSubParts

Proprietà DedAcadAssociaDwgAlsoSubParts
Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.Data

Proprietà DedAcadAssociaDwgData
Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.EnforceOverWriteMode

Proprietà DedAcadAssociaDwgEnforceOverWriteMode
Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.InfoItem

Proprietà DedAcadAssociaDwgInfoItem
Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
property DocStructInfo^ InfoItem {
    DocStructInfo^ get ();
}
member InfoItem : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.IsSavePrt

Proprietà DedAcadAssociaDwgIsSavePrt
Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.LinkNotCopy

Proprietà DedAcadAssociaDwgLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.Mdres

Proprietà DedAcadAssociaDwgMdres
Informazioni sul risultato del move dei documenti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.NeedParameters

Proprietà DedAcadAssociaDwgNeedParameters
Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.PrimaryContext

Proprietà DedAcadAssociaDwgPrimaryContext
Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.Prt

Proprietà DedAcadAssociaDwgPrt
Restituisce la parte da associare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; set; }
Public Property Prt As PartInfo
    Get
    Set
public:
property PartInfo^ Prt {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member Prt : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.SparePartsContext

Proprietà DedAcadAssociaDwgSparePartsContext
Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.UseDocValues

Proprietà DedAcadAssociaDwgUseDocValues
Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodi di DedAcadAssociaDwg

Il tipo DedAcadAssociaDwg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.ClearCommand

Metodo DedAcadAssociaDwgClearCommand
Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.Enabled

Metodo DedAcadAssociaDwgEnabled
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.ExecuteCommand

Metodo DedAcadAssociaDwgExecuteCommand
Esegue il comando di associazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.SetContext

Metodo DedAcadAssociaDwgSetContext
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Classe DedAcadChangeState
Comando che effettua il rilascio dell'anagrafica associata
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadChangeState

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadChangeState : DedCommand
Public Class DedAcadChangeState
    Inherits DedCommand
public ref class DedAcadChangeState : public DedCommand
type DedAcadChangeState =
    class
        inherit DedCommand
    end

Il tipo DedAcadChangeState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non i parametri non sono sufficienti (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | MultipleChangeState | Operazione di rilascio multiplo. Visualizza il form di selezione dei codici e quindi esegue ciclicamente le operazioni.
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | SingleChangeState |
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadChangeState

Il tipo DedAcadChangeState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non i parametri non sono sufficienti (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadChangeState


Proprietà DedAcadChangeState.NeedParameters

Proprietà DedAcadChangeStateNeedParameters
Restituisce true se non i parametri non sono sufficienti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodi di DedAcadChangeState

Il tipo DedAcadChangeState espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | MultipleChangeState | Operazione di rilascio multiplo. Visualizza il form di selezione dei codici e quindi esegue ciclicamente le operazioni.
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | SingleChangeState |
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.ClearCommand

Metodo DedAcadChangeStateClearCommand
Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.Enabled

Metodo DedAcadChangeStateEnabled
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.ExecuteCommand

Metodo DedAcadChangeStateExecuteCommand
Esegue il comando di associazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.MultipleChangeState

Metodo DedAcadChangeStateMultipleChangeState
Operazione di rilascio multiplo. Visualizza il form di selezione dei codici e quindi esegue ciclicamente le operazioni.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult MultipleChangeState(
    AcadDocStructInfo acadDsInfo
)
Public Function MultipleChangeState (
    acadDsInfo As AcadDocStructInfo
) As DedCmdResult
public:
DedCmdResult MultipleChangeState(
    AcadDocStructInfo^ acadDsInfo
)
member MultipleChangeState :
        acadDsInfo : AcadDocStructInfo -> DedCmdResult

Parametri

acadDsInfo AcadDocStructInfo
DocStructInfo di Inventor di partenza. Rappresenta il topDocument in questo caso.

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.SetContext

Metodo DedAcadChangeStateSetContext
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.SingleChangeState

Metodo DedAcadChangeStateSingleChangeState

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult SingleChangeState(
    DedState targetState,
    string changeNote,
    MultipleStateOperationPartInfoDoc docInfo,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Function SingleChangeState (
    targetState As DedState,
    changeNote As String,
    docInfo As MultipleStateOperationPartInfoDoc,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public:
DedCmdResult SingleChangeState(
    DedState^ targetState,
    String^ changeNote,
    MultipleStateOperationPartInfoDoc^ docInfo,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
member SingleChangeState :
        targetState : DedState *
        changeNote : string *
        docInfo : MultipleStateOperationPartInfoDoc *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState DedState
changeNote String
docInfo MultipleStateOperationPartInfoDoc
multiplo Boolean
message String
pubExtList List Exception

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadChangeState


Classe DedAcadCommandContext
Classe per il contesto di esecuzione comando all'interno dell'addin. Contiene le informazioni necessarie per l'esecuzione di un comando .
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedAcadCommandContext

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadCommandContext
Public Class DedAcadCommandContext
public ref class DedAcadCommandContext
type DedAcadCommandContext = class end

Il tipo DedAcadCommandContext espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAcadCommandContext | Costruttore unico.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | ElementList | Lista di FileStateElement facenti parte del contesto.
Campo pubblico | FileList | Lista di FileName facenti parte del contesto.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedAcadCommandContext
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAcadCommandContext()
Public Sub New
public:
DedAcadCommandContext()
new : unit -> DedAcadCommandContext
Vedi anche

Documentazione

Classe DedAcadCommandContext


Campi di DedAcadCommandContext

Il tipo DedAcadCommandContext espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | ElementList | Lista di FileStateElement facenti parte del contesto.
Campo pubblico | FileList | Lista di FileName facenti parte del contesto.
Torna su
Vedi anche

Documentazione

Classe DedAcadCommandContext


Campo DedAcadCommandContext.ElementList

Campo DedAcadCommandContextElementList
Lista di FileStateElement facenti parte del contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList ElementList
Public ElementList As FileStateElementList
public:
FileStateElementList^ ElementList
val mutable ElementList: FileStateElementList

Valore del campo

FileStateElementList
Vedi anche

Documentazione

Classe DedAcadCommandContext


Campo DedAcadCommandContext.FileList

Campo DedAcadCommandContextFileList
Lista di FileName facenti parte del contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FileList
Public FileList As List(Of String)
public:
List<String^>^ FileList
val mutable FileList: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe DedAcadCommandContext


Classe DedAcadCreaAnagrafica
Effettua il salvataggio del documento corrente o della parte selezionata nel Database con un nuovo codice. Da utilizzare anche nelle procedure personalizzate. Per personalizzare la creazione dell'anagrafica, impostare nella proprietà SaveCommand un comando inizializzato con già tutte le informazioni preimpostate. Diversamente il comando sarà inizializzato in base agli attributi del documento corrente.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadCreaAnagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadCreaAnagrafica : DedCommand
Public Class DedAcadCreaAnagrafica
    Inherits DedCommand
public ref class DedAcadCreaAnagrafica : public DedCommand
type DedAcadCreaAnagrafica =
    class
        inherit DedCommand
    end

Il tipo DedAcadCreaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nel salva parte.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Asynch | Restituisce o imposta se il salva parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è false.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire il salva parte e non il salva documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da salvare nel Database.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento corrente.
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo protetto | ExecuteCommand | Esegue il comando di salvataggio del documento nel Database. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadCreaAnagrafica

Il tipo DedAcadCreaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nel salva parte.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Asynch | Restituisce o imposta se il salva parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è false.
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire il salva parte e non il salva documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da salvare nel Database.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento corrente.
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.AcadDoc

Proprietà DedAcadCreaAnagraficaAcadDoc
Restitusice il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

QsDocument
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.AlsoSubParts

Proprietà DedAcadCreaAnagraficaAlsoSubParts
Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nel salva parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.Asynch

Proprietà DedAcadCreaAnagraficaAsynch
Restituisce o imposta se il salva parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.CreazioneVariante

Proprietà DedAcadCreaAnagraficaCreazioneVariante
Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.IsSavePrt

Proprietà DedAcadCreaAnagraficaIsSavePrt
Restituisce o imposta se sia da eseguire il salva parte e non il salva documento. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.NeedParameters

Proprietà DedAcadCreaAnagraficaNeedParameters
Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.Prt

Proprietà DedAcadCreaAnagraficaPrt
Restituisce la parte Top del documento attivo che è da salvare nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; }
Public ReadOnly Property Prt As PartInfo
    Get
public:
property PartInfo^ Prt {
    PartInfo^ get ();
}
member Prt : PartInfo with get

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.SaveCommand

Proprietà DedAcadCreaAnagraficaSaveCommand
Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

SaveCommand
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodi di DedAcadCreaAnagrafica

Il tipo DedAcadCreaAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo protetto | ExecuteCommand | Esegue il comando di salvataggio del documento nel Database. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.ClearCommand

Metodo DedAcadCreaAnagraficaClearCommand
Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.Enabled

Metodo DedAcadCreaAnagraficaEnabled
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.Equals

Metodo DedAcadCreaAnagraficaEquals

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.ExecuteCommand

Metodo DedAcadCreaAnagraficaExecuteCommand
Esegue il comando di salvataggio del documento nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.GetHashCode

Metodo DedAcadCreaAnagraficaGetHashCode

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.SetContext

Metodo DedAcadCreaAnagraficaSetContext
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.ToString

Metodo DedAcadCreaAnagraficaToString

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Classe DedAcadCreaRev
Effettua il Salva Revisione del documento attivo. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadCreaRev

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadCreaRev : DedCommand
Public Class DedAcadCreaRev
    Inherits DedCommand
public ref class DedAcadCreaRev : public DedCommand
type DedAcadCreaRev =
    class
        inherit DedCommand
    end

Il tipo DedAcadCreaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento appena salvato.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CurData | Restituisce l'anagrafica di partenza del documento in salvataggio.
Proprietà pubblica | CurDoc | Restituisce il documento di partenza in salvataggio.
Proprietà pubblica | FullFileName | Restituisce il nome completo del file correntemente attivo e da Revisionare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NewData | Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.
Proprietà pubblica | NewDoc | Restituisce il documento associato alla nuova revisione.
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da Revisionare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di salva revisione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadCreaRev

Il tipo DedAcadCreaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento appena salvato.
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CurData | Restituisce l'anagrafica di partenza del documento in salvataggio.
Proprietà pubblica | CurDoc | Restituisce il documento di partenza in salvataggio.
Proprietà pubblica | FullFileName | Restituisce il nome completo del file correntemente attivo e da Revisionare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NewData | Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.
Proprietà pubblica | NewDoc | Restituisce il documento associato alla nuova revisione.
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da Revisionare.
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.AcadDoc

Proprietà DedAcadCreaRevAcadDoc
Restitusice il documento appena salvato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

QsDocument
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.CurData

Proprietà DedAcadCreaRevCurData
Restituisce l'anagrafica di partenza del documento in salvataggio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData CurData { get; }
Public ReadOnly Property CurData As DedData
    Get
public:
property DedData^ CurData {
    DedData^ get ();
}
member CurData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.CurDoc

Proprietà DedAcadCreaRevCurDoc
Restituisce il documento di partenza in salvataggio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc CurDoc { get; }
Public ReadOnly Property CurDoc As DedDoc
    Get
public:
property DedDoc^ CurDoc {
    DedDoc^ get ();
}
member CurDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.FullFileName

Proprietà DedAcadCreaRevFullFileName
Restituisce il nome completo del file correntemente attivo e da Revisionare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.NeedParameters

Proprietà DedAcadCreaRevNeedParameters
Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.NewData

Proprietà DedAcadCreaRevNewData
Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.NewDoc

Proprietà DedAcadCreaRevNewDoc
Restituisce il documento associato alla nuova revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc NewDoc { get; }
Public ReadOnly Property NewDoc As DedDoc
    Get
public:
property DedDoc^ NewDoc {
    DedDoc^ get ();
}
member NewDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.Prt

Proprietà DedAcadCreaRevPrt
Restituisce la parte Top del documento attivo che è da Revisionare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; }
Public ReadOnly Property Prt As PartInfo
    Get
public:
property PartInfo^ Prt {
    PartInfo^ get ();
}
member Prt : PartInfo with get

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodi di DedAcadCreaRev

Il tipo DedAcadCreaRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando di salva revisione. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.ClearCommand

Metodo DedAcadCreaRevClearCommand
Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.Enabled

Metodo DedAcadCreaRevEnabled
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.ExecuteCommand

Metodo DedAcadCreaRevExecuteCommand
Esegue il comando di salva revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.SetContext

Metodo DedAcadCreaRevSetContext
Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadCreaRev


Classe DedAcadForceMarkerAlingment
Comando che permette di forzare la allineamento del documento con quella presente nel Database.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadForceMarkerAlingment

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadForceMarkerAlingment : DedCommand
Public Class DedAcadForceMarkerAlingment
    Inherits DedCommand
public ref class DedAcadForceMarkerAlingment : public DedCommand
type DedAcadForceMarkerAlingment =
    class
        inherit DedCommand
    end

Il tipo DedAcadForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadForceMarkerAlingment

Il tipo DedAcadForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Proprietà DedAcadForceMarkerAlingment.NeedParameters

Proprietà DedAcadForceMarkerAlingmentNeedParameters
Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodi di DedAcadForceMarkerAlingment

Il tipo DedAcadForceMarkerAlingment espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.ClearCommand

Metodo DedAcadForceMarkerAlingmentClearCommand
Pulizia del comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.Enabled

Metodo DedAcadForceMarkerAlingmentEnabled
Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext invCmdCtx
)
Public Overrides Function Enabled (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ invCmdCtx
) override
abstract Enabled :
        invCmdCtx : DedCommandContext -> bool
override Enabled :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.ExecuteCommand

Metodo DedAcadForceMarkerAlingmentExecuteCommand
Lancia il comando di salva nel db.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.SetContext

Metodo DedAcadForceMarkerAlingmentSetContext
Imposta il comando in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext invCmdCtx
)
Public Overrides Function SetContext (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ invCmdCtx
) override
abstract SetContext :
        invCmdCtx : DedCommandContext -> bool
override SetContext :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Classe DedAcadMarkerInfo
Comando che permette di controllare lo stato di allineamento del documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadMarkerInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadMarkerInfo : DedCommand
Public Class DedAcadMarkerInfo
    Inherits DedCommand
public ref class DedAcadMarkerInfo : public DedCommand
type DedAcadMarkerInfo =
    class
        inherit DedCommand
    end

Il tipo DedAcadMarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadMarkerInfo

Il tipo DedAcadMarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Proprietà DedAcadMarkerInfo.NeedParameters

Proprietà DedAcadMarkerInfoNeedParameters
Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodi di DedAcadMarkerInfo

Il tipo DedAcadMarkerInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.ClearCommand

Metodo DedAcadMarkerInfoClearCommand
Pulizia del comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.Enabled

Metodo DedAcadMarkerInfoEnabled
Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext invCmdCtx
)
Public Overrides Function Enabled (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ invCmdCtx
) override
abstract Enabled :
        invCmdCtx : DedCommandContext -> bool
override Enabled :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.ExecuteCommand

Metodo DedAcadMarkerInfoExecuteCommand
Lancia il comando di salva nel db.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.SetContext

Metodo DedAcadMarkerInfoSetContext
Imposta il comando in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext invCmdCtx
)
Public Overrides Function SetContext (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ invCmdCtx
) override
abstract SetContext :
        invCmdCtx : DedCommandContext -> bool
override SetContext :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Classe DedAcadSaveDist
Salvataggio distinta
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadSaveDist

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadSaveDist : DedCommand
Public Class DedAcadSaveDist
    Inherits DedCommand
public ref class DedAcadSaveDist : public DedCommand
type DedAcadSaveDist =
    class
        inherit DedCommand
    end

Il tipo DedAcadSaveDist espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAcadSaveDist | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Args | Table di argomenti impostati esternamente
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedAcadSaveDist
Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAcadSaveDist(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
DedAcadSaveDist(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> DedAcadSaveDist

Parametri

app DedNetApplication
internalName String
name String
Vedi anche

Documentazione

Classe DedAcadSaveDist


Proprietà di DedAcadSaveDist

Il tipo DedAcadSaveDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Args | Table di argomenti impostati esternamente
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadSaveDist


Proprietà DedAcadSaveDist.Args

Proprietà DedAcadSaveDistArgs
Table di argomenti impostati esternamente

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public LuaTable Args { get; set; }
Public Property Args As LuaTable
    Get
    Set
public:
property LuaTable^ Args {
    LuaTable^ get ();
    void set (LuaTable^ value);
}
member Args : LuaTable with get, set

Valore della proprietà

LuaTable
Vedi anche

Documentazione

Classe DedAcadSaveDist


Proprietà DedAcadSaveDist.NeedParameters

Proprietà DedAcadSaveDistNeedParameters

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAcadSaveDist


Metodi di DedAcadSaveDist

Il tipo DedAcadSaveDist espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAcadSaveDist


Metodo DedAcadSaveDist.ClearCommand

Metodo DedAcadSaveDistClearCommand

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadSaveDist


Metodo DedAcadSaveDist.Enabled

Metodo DedAcadSaveDistEnabled

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadSaveDist


Metodo DedAcadSaveDist.ExecuteCommand

Metodo DedAcadSaveDistExecuteCommand

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedAcadSaveDist


Metodo DedAcadSaveDist.SetContext

Metodo DedAcadSaveDistSetContext

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAcadSaveDist


Classe DedApiAcad
NOTA : Da Lua usare DEDACADAPI per accedere ai metodi.
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedApiAcad

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedApiAcad
Public Class DedApiAcad
public ref class DedApiAcad
type DedApiAcad = class end

Il tipo DedApiAcad espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedApiAcad |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRuleOnPrt | Applica le regole di autocomposizione sulla parte passata.
Metodo pubblico | AssociaDoc | Associa documento. Riceve in ingresso una table di parametri.
Metodo pubblico | CheckOldRevisions | Esegue il controllo delle revisioni superate. Permette di controllare gli stati di visibilità del comando.
Metodo pubblico | DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
Metodo pubblico | Rilascia | Esegue il rilascio dell'anagrafica utilizzando il documento corrente come fosse lanciata dal comando
Metodo pubblico | SalvaNelDb | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | ShowLastException |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedApiAcad

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedApiAcad(
    DedNetApplication app,
    DedLuaApplication luaApp
)
Public Sub New (
    app As DedNetApplication,
    luaApp As DedLuaApplication
)
public:
DedApiAcad(
    DedNetApplication^ app,
    DedLuaApplication^ luaApp
)
new :
        app : DedNetApplication *
        luaApp : DedLuaApplication -> DedApiAcad

Parametri

app DedNetApplication
luaApp DedLuaApplication
Vedi anche

Documentazione

Classe DedApiAcad


Proprietà di DedApiAcad

Il tipo DedApiAcad espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Vedi anche

Documentazione

Classe DedApiAcad


Proprietà DedApiAcad.LastException

Proprietà DedApiAcadLastException

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}
member LastException : Exception with get

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodi di DedApiAcad

Il tipo DedApiAcad espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRuleOnPrt | Applica le regole di autocomposizione sulla parte passata.
Metodo pubblico | AssociaDoc | Associa documento. Riceve in ingresso una table di parametri.
Metodo pubblico | CheckOldRevisions | Esegue il controllo delle revisioni superate. Permette di controllare gli stati di visibilità del comando.
Metodo pubblico | DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
Metodo pubblico | Rilascia | Esegue il rilascio dell'anagrafica utilizzando il documento corrente come fosse lanciata dal comando
Metodo pubblico | SalvaNelDb | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | ShowLastException |
Torna su
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.ApplyRuleOnPrt

Metodo DedApiAcadApplyRuleOnPrt
Applica le regole di autocomposizione sulla parte passata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ApplyRuleOnPrt(
    PartInfo prt
)
Public Sub ApplyRuleOnPrt (
    prt As PartInfo
)
public:
void ApplyRuleOnPrt(
    PartInfo^ prt
)
member ApplyRuleOnPrt :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Parte sulla quale applicare le regole.
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.AssociaDoc

Metodo DedApiAcadAssociaDoc
Associa documento. Riceve in ingresso una table di parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AssociaDoc(
    LuaTable args
)
Public Function AssociaDoc (
    args As LuaTable
) As Boolean
public:
bool AssociaDoc(
    LuaTable^ args
)
member AssociaDoc :
        args : LuaTable -> bool

Parametri

args LuaTable
id : id anagrafica (obbligatorio) rev : revisione dell'anagrafica (obbligatorio) silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil useDocValues : indica se nell'associa usare gli attributi di documento 1/nil primaryContext : indica se deve essere associato come file primario - 1/nil enforceOverwriteMode : indica se deve essere sovrascritto o creare una rappresentazione - 1/nil savePrt : indica se è un salva parte - 1/nil

Valore di ritorno

Boolean
Restituisce true se riesce altimenti false
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.CheckOldRevisions

Metodo DedApiAcadCheckOldRevisions
Esegue il controllo delle revisioni superate. Permette di controllare gli stati di visibilità del comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckOldRevisions(
    LuaTable args
)
Public Function CheckOldRevisions (
    args As LuaTable
) As Boolean
public:
bool CheckOldRevisions(
    LuaTable^ args
)
member CheckOldRevisions :
        args : LuaTable -> bool

Parametri

args LuaTable
Argomenti del Rilascio

Valore di ritorno

Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.DedDistSave

Metodo DedApiAcadDedDistSave
Salva la distinta del documento correntemente aperto, nel Datbase.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DedDistSave(
    LuaTable args
)
Public Function DedDistSave (
    args As LuaTable
) As Boolean
public:
bool DedDistSave(
    LuaTable^ args
)
member DedDistSave :
        args : LuaTable -> bool

Parametri

args LuaTable
Argomenti del salva distinta "silent"

Valore di ritorno

Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.Rilascia

Metodo DedApiAcadRilascia
Esegue il rilascio dell'anagrafica utilizzando il documento corrente come fosse lanciata dal comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Rilascia(
    LuaTable args
)
Public Function Rilascia (
    args As LuaTable
) As Boolean
public:
bool Rilascia(
    LuaTable^ args
)
member Rilascia :
        args : LuaTable -> bool

Parametri

args LuaTable
Argomenti del Rilascio

Valore di ritorno

Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.SalvaNelDb

Metodo DedApiAcadSalvaNelDb
Creazione dell'anagrafica. Riceve in ingresso una table di parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool SalvaNelDb(
    LuaTable args
)
Public Function SalvaNelDb (
    args As LuaTable
) As Boolean
public:
bool SalvaNelDb(
    LuaTable^ args
)
member SalvaNelDb :
        args : LuaTable -> bool

Parametri

args LuaTable
dbpath : path di salvataggio dell'anagrafica (obbligatorio) progr : progressivo (obbligatorio) rev : revisione dell'anagrafica infoUser : eventuale tassello utente format : informazione sul formato silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil useDocValues : indica se nell'associa usare gli attributi di documento 1/nil attrs : LuaTable contenente prompt e valori degli attributi da preimpostare nell'anagrafica in creazione validateAttrs : indica se validare gli attributi 1/nil forcedata : Indica se utilizzare gli attributi passati invece di calcolarli - 1/nil primaryContext : indica se deve essere associato come file primario - 1/nil savePrt : indica se è un salva parte - 1/nil

Valore di ritorno

Boolean
Restituisce true se riesce altimenti false
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.ShowLastException

Metodo DedApiAcadShowLastException

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowLastException()
Public Sub ShowLastException
public:
void ShowLastException()
member ShowLastException : unit -> unit
Vedi anche

Documentazione

Classe DedApiAcad


Campi di DedApiAcad

Il tipo DedApiAcad espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Classe DedApiAcad


Campo DedApiAcad._app

Campo DedApiAcad_app

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication _app
Public _app As DedNetApplication
public:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

DedNetApplication
Vedi anche

Documentazione

Classe DedApiAcad


Campo DedApiAcad._luaApp

Campo DedApiAcad_luaApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication _luaApp
Public _luaApp As DedLuaApplication
public:
DedLuaApplication^ _luaApp
val mutable _luaApp: DedLuaApplication

Valore del campo

DedLuaApplication
Vedi anche

Documentazione

Classe DedApiAcad


Classe DedNetAcadApp
Classe principale dell'add-in per Autocad di DedNet. Viene pubblicata l'istanza di questo oggetto attraverso la variabile globale LUA DEDACAD.
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedNetAcadApp : IFileStateInformer
Public Class DedNetAcadApp
    Implements IFileStateInformer
public ref class DedNetAcadApp : IFileStateInformer
type DedNetAcadApp =
    class
        interface IFileStateInformer
    end

Il tipo DedNetAcadApp espone i seguenti membri.

Proprietà
Nome | Descrizione
AssemblyAcadPath | Restituisce il percorso della cartella DED nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QSMech15_A2012\DED.
CheckInChiusuraRunning | Indica se si sta eseguendo un checkin causato dalla chiusura del documento
ComApp |
CommandRunFromLua | Indica se il comando è stato lanciato da lua.
DedNetApp | Restituisce l'applicazione DedNetApplication sottostante.
DedNetInstallPath | Restituisce il percorso di installazione del DedNet.
FileStateManager | Restituisce l'oggetto gestore dello stato dei file. Utilizzato dal browser delle dipendenze dei documenti.
HideCompareDialogOnSavingDwg | Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.
HideWarningMessageOnModDocCheckout | Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.
IgnoreCheckInOnClose | Indica di ignorare il checkin in chiusura
IsDedAcadOpenDocRunning | Indica se è in esecuzione il comando di apertura documenti di Inventor.
IsMechanicalLoaded | Indica se è caricato il mechanical ( viene valutato all'avvio di Autocad )
IsProgramaticalQsaveRunning | Indica se si sta eseguendo un salvataggio da software
IsSDIOperation | Restituisce true se la variabile SDI è impostata a 1.
LuaApp | Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.
NavigatorArgsArray | Restituisce l'array di parti sulle quali il comando ApriDwgDaDb deve lavorare. Vedi PostNavigatorArgs().
NavigatorArgsLastRev | Restituisce se il comando ApriDwgDaDb debba aprire l'ultima revisione. Vedi PostNavigatorArgs().
NavigatorArgsReadOnly | Restituisce se il comando ApriDwgDaDb debba aprire in read-only. Vedi PostNavigatorArgs().
Ricerca | Restituisce il comando per effettuare la ricerca.
RicercaDocs | Restituisce il comando per effettuare la ricerca.
SalvaNelDbRunning | Indica se si sta eseguendo un salva nel database
VisAnagr | Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.
Xmx | Restitusice l'oggetto per la traduzione dei messaggi.
XrefDialog |
Torna su
Metodi
 | Nome | Descrizione
 | AggiornaAttributiDaDb | Aggiorna gli attributi delle parti passate dal Database. Se c'é la parte Top aggiorna solo se il documento attivo è coerente con l'anagrafica.
Metodo pubblico | AllowHotTracking | Determina se l'elemento è passibile di hot tracking
 | CaricaParteDaDb | Carica una seconda volta la parte dal Database, se a questa vi è associato un Dwg.
 | CheckMechanicalLoaded |
 | CreareDedAcadSaveDist | Crea e restituisce il comando di salvataggio distinta
 | CreateApriAllegati | Crea e restituisce il comando di apertura dei file allegati.
 | CreateApriAssociati | Crea e restituisce il comando di apertura dei file associati.
 | CreateApriInNuovaFinestra | Crea e restituisce il comando di apertura di un documento in una nuova finestra.
 | CreateArchiviaDwg | Crea e restituisce il comando Associa documento.
 | CreateArchiviaXref | Crea e restituisce il comando di archiviazione di un xref.
 | CreateAssociaCommXref | Crea e restituisce il comando che permette di associare un xref a una commessa.
 | CreateAssociaDwg | Crea e restituisce il comando Associa documento.
 | CreateAssociatoA | Crea e restituisce il comando che mostra a quali anagrafiche è associato un documento.
 | CreateAssociaXref | Crea e restituisce il comando che permette di associare un xref a un'anagrafica.
 | CreateCaricaBlocco | Crea e restituisce il comando di carica blocco.
 | CreateCaricaParte | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteEsterno | Crea e restituisce il comando di carica blocco.
 | CreateCaricaXref | Crea e restituisce il comando di carica xref.
 | CreateChangeState | Crea e restituisce il comando di rilascio
 | CreateCheckIn | Crea e restituisce il comando di CheckIn per il documento correntemente attivo.
 | CreateCheckInAssociati | Crea e restituisce il comando di CheckIn con Associati per i file passati.
 | CreateCheckInStruttura | Crea e restituisce il comando di CheckIn Struttura per i file passati.
 | CreateCheckInStrutturaAssociati | Crea e restituisce il comando di CheckIn Struttura con Associati per i file passati.
 | CreateCheckInXref | Crea e restituisce il comando di CheckIn per i file passati.
 | CreateCheckOut | Crea e restituisce il comando di CheckOut per il documento correntemente attivo.
 | CreateCheckOutAssociati | Crea e restituisce il comando di CheckOut con Associati per i file passati.
 | CreateCheckOutStruttura | Crea e restituisce il comando di CheckOut Struttura per i file passati.
 | CreateCheckOutStrutturaAssociati | Crea e restituisce il comando di CheckOut Struttura con Associati per i file passati.
 | CreateCheckOutXref | Crea e restituisce il comando di CheckOut per i file passati.
 | CreateCompilaParteDaAnagrafica | Crea e restituisce il comando di compila parte da anagrafica.
 | CreateCreaAnagrafica | Crea e restituisce il comando di creazione anagrafica ovvero di Salva nel Database.
 | CreateCreaRev | Crea e restituisce il comando di creazione revisione.
 | CreateCreateSparePartsDrawing | Crea e restituisce il comando di carica parte.
 | CreateCreaVariante | Crea e restituisce il comando di creazione variante ovvero di Salva nel Database con tassello utente.
 | CreateFindInRicerca | Crea e restituisce il comando di individuazione nella Ricerca di un documento.
 | CreateForceMarkerAlignment | Crea e restituisce il comando di rilascio
 | CreateForzaAllineamento | Crea e restituisce il comando per forzare l'allineamento di un documento.
 | CreateLavorazioneMultiploXref | Crea e restituisce il comando di messa in lavorazione multipla xref.
 | CreateLavorazioneXref | Crea e restituisce il comando di messa in lavorazione xref.
 | CreateMarkerInfo | Crea e restituisce il comando di rilascio
 | CreatePackAngGoExport | Crea e restituisce il comando di creazione revisione.
 | CreatePackAngGoImport | Crea e restituisce il comando di creazione revisione.
 | CreatePubblica | Crea e restituisce il comando di pubblicazione dei documenti.
 | CreatePubblicaStruttura | Crea e restituisce il comando di pubblicazione dei documenti e della relativa struttura.
 | CreatePublishSparePartsDrawing | Crea e restituisce il comando di Pubblic tavola ricambi.
 | CreateRegistra | Crea e restituisce il comando di registrazione di un nuovo file.
 | CreateRilascioMultiploXref | Crea e restituisce il comando di rilascio multiplo xref.
 | CreateRilascioXref | Crea e restituisce il comando di rilascio xref.
 | CreateSalvaRevXref | Crea e restituisce il comando di salvataggio di una revisione di un xref.
 | CreateSalvaVarianteXref | Crea e restituisce il comando di salvataggio di una variante di un xref.
 | CreateSalvaXref | Crea e restituisce il comando di salvataggio di un xref nel database.
 | CreateSelezionaRiferimento | Crea e ritorna il comando per la selezione di un riferimento esterno.
 | CreateSostituisciRiferimenti | Crea e restituisce il comando di sostituzione riferimenti xref.
 | CreateStatoAllineamento | Crea e restituisce il comando di visualizzazione dello stato di allineamento di un documento.
 | CreateUpdateOldRev | Crea e restituisce il comando di aggiornamento delle revisioni superate degli xref.
 | CreateUsatoIn | Crea e restituisce il comando di visualizzazione del dialogo Usato In.
 | EditaAttributi | Aggiorna il controllo degli attributi
 | FindOpenDocument | Cerca un documento tra quelli correntemente aperti. Se lo trova lo restituisce altrimenti restituisce null. Normalizza i nomi prima di effettuare il confronto.
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetAnagStateName | Restituisce il il nome dello stato dell'anagrafica associata all'elemento passato
Metodo pubblico | GetAttr | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'oggetto passato. Per creare la struttura non utilizzo l'InvDocStructInfo per come gestisce la costruzione dei figli. Per agevolare il flusso dei dati nelle operazioni gli oggetti dei Ties vengono riciclati. Questo può causare problemi se ad esempio ho una reference nipote disponibile ed una figlia che invece non lo è...
Metodo pubblico | GetData | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetMovedDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetSelectionImageKey | Restituisce il nome dell'immagine che rappresenta un elemento. L'immagine rispecchia il tipo di documento ed è quella standard di Inventor.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce il nome dell'immagine che descrive lo stato di un elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento passato possiede figli
 | IndividuaNellaRicerca | Apre la ricerca nei recenti individuando l'anagrafica di una parte.
Metodo pubblico | Initialize | Inizializzazione dell'add-in.
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è associato ad un documento dirty
 | Log(Exception, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | Log(ListException, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | LogInfo | Registra l'eccezione nel file di log dell'applicazione.
Metodo pubblico | MakeAcadCommandContext | Ritorna l'oggetto context di Inventor in base alla lista di elementi passati dal controllo delle dipendenze documentali.
 | OnAcadRilPublishEvent | Lancia evento di pubblicazione formati al rilascio in Inventor
Metodo pubblico | OnElementDoubleClicked | Gestione doppio click su elemento
Metodo pubblico | OnElementsSelected | Si occupa di allineare la selezione dell'albero con la selezione dell'occorrenze a livello di documento
 | OnFileResolutionEvent | Lancia l'evento di FileResolutionEvent
Metodo pubblico | OnHotTrackElementClicked | Gestione click singolo su elemento hottracked
 | OnImportPackAndGoAfterLoadEvent | Lancia l'evento di ImportPackAndGoAfterLoadEvent
 | OnImportPackAndGoDocAttrCompareEvent | Lancia l'evento di ImportPackAndGoDocAttrCompareEvent
 | OnImportPackAndGoMappingRootEvent | Lancia l'evento di ImportPackAndGoMappingRootEvent
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent | Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent
 | OnImportPackAndGoPresetCodingOperationEvent | Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent
 | OnSkipLayoutOnPrintingEvent | Lancia l'evento di SkipLayoutOnPrintingEvent
Metodo pubblico | OnTopPrtCreated | Evento di creazione albero parti, chiamato dal LUA dopo la creazione del documento. Viene utilizzato per aggiornare la parte Top con gli attributi presenti nel Database.
 | OnUpdateAttribFromDbOnOpenEvent | Lancia evento per la gestione dell'aggiornamento degli attributi dal Db in apertura.
 | OnUpdateCartOnOpenEvent | Lancia evento per la gestione dell'aggiornamento del cartiglio in apertura.
Metodo pubblico | PartsTreeSelectionChanged | Chiamato sul cambio selezione nell'albero delle parti, per aggiornare la finestra di visualizzazione attributi.
 | PostNavigatorArgs | Imposta in una variabile globale l'array di parti da utilizzare poi nei comandi che saranno invocati tramite invio di una stringa alla riga di comando di autocad. Viene utilizzato subito prima di chiamare un comando in contesto application.
 | StatoDocAcad | Metodo che restituisce una stringa con lo stato attuale del doccumento.
Metodo pubblico | Terminate | Termine dell'add-in.
 | UpdateStateDocPanel | Aggiorna il pannello in base allo stato del documento.
Torna su
Eventi
Nome | Descrizione
AcadRilPublishEvent | Evento di pubblicazione formati al rilascio in Inventor
FileResolutionEvent | Evento di risoluzione file nel caso non vengano trovati.
ImportPackAndGoAfterLoadEvent | Evento per effettuare modifiche al form dopo il caricamento dei dati.
ImportPackAndGoDocAttrCompareEvent | Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent | Evento di override del settaggio del check in caso di operazione di codifica
ImportPackAndGoPresetCodingOperationEvent |
SkipLayoutOnPrintingEvent | Evento per decidere i layout da non stamapre.
UpdateAttribFromDbOnOpenEvent | Evento per la decidere se fare l'aggiornamento degli attributi dal Db in apertura.
UpdateCartOnOpenEvent | Evento per la decidere se fare l'aggiornamento del cartiglio in apertura.
Torna su
Campi
Nome | Descrizione
DedNetAcadDataRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.
DedNetAcadDocRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver del documento stesso utilizzata per conoscere la versione del documento in modalità detached.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Proprietà
Nome | Descrizione
AssemblyAcadPath | Restituisce il percorso della cartella DED nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QSMech15_A2012\DED.
CheckInChiusuraRunning | Indica se si sta eseguendo un checkin causato dalla chiusura del documento
ComApp |
CommandRunFromLua | Indica se il comando è stato lanciato da lua.
DedNetApp | Restituisce l'applicazione DedNetApplication sottostante.
DedNetInstallPath | Restituisce il percorso di installazione del DedNet.
FileStateManager | Restituisce l'oggetto gestore dello stato dei file. Utilizzato dal browser delle dipendenze dei documenti.
HideCompareDialogOnSavingDwg | Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.
HideWarningMessageOnModDocCheckout | Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.
IgnoreCheckInOnClose | Indica di ignorare il checkin in chiusura
IsDedAcadOpenDocRunning | Indica se è in esecuzione il comando di apertura documenti di Inventor.
IsMechanicalLoaded | Indica se è caricato il mechanical ( viene valutato all'avvio di Autocad )
IsProgramaticalQsaveRunning | Indica se si sta eseguendo un salvataggio da software
IsSDIOperation | Restituisce true se la variabile SDI è impostata a 1.
LuaApp | Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.
NavigatorArgsArray | Restituisce l'array di parti sulle quali il comando ApriDwgDaDb deve lavorare. Vedi PostNavigatorArgs().
NavigatorArgsLastRev | Restituisce se il comando ApriDwgDaDb debba aprire l'ultima revisione. Vedi PostNavigatorArgs().
NavigatorArgsReadOnly | Restituisce se il comando ApriDwgDaDb debba aprire in read-only. Vedi PostNavigatorArgs().
Ricerca | Restituisce il comando per effettuare la ricerca.
RicercaDocs | Restituisce il comando per effettuare la ricerca.
SalvaNelDbRunning | Indica se si sta eseguendo un salva nel database
VisAnagr | Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.
Xmx | Restitusice l'oggetto per la traduzione dei messaggi.
XrefDialog |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.AssemblyAcadPath

Proprietà DedNetAcadAppAssemblyAcadPath
Restituisce il percorso della cartella DED nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QSMech15_A2012\DED.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string AssemblyAcadPath { get; }
Public Shared ReadOnly Property AssemblyAcadPath As String
    Get
public:
static property String^ AssemblyAcadPath {
    String^ get ();
}
static member AssemblyAcadPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.CheckInChiusuraRunning

Proprietà DedNetAcadAppCheckInChiusuraRunning
Indica se si sta eseguendo un checkin causato dalla chiusura del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckInChiusuraRunning { get; set; }
Public Shared Property CheckInChiusuraRunning As Boolean
    Get
    Set
public:
static property bool CheckInChiusuraRunning {
    bool get ();
    void set (bool value);
}
static member CheckInChiusuraRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.ComApp

Proprietà DedNetAcadAppComApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static AcadApplication ComApp { get; }
Public Shared ReadOnly Property ComApp As AcadApplication
    Get
public:
static property AcadApplication^ ComApp {
    AcadApplication^ get ();
}
static member ComApp : AcadApplication with get

Valore della proprietà

AcadApplication
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.CommandRunFromLua

Proprietà DedNetAcadAppCommandRunFromLua
Indica se il comando è stato lanciato da lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CommandRunFromLua { get; set; }
Public Shared Property CommandRunFromLua As Boolean
    Get
    Set
public:
static property bool CommandRunFromLua {
    bool get ();
    void set (bool value);
}
static member CommandRunFromLua : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.DedNetApp

Proprietà DedNetAcadAppDedNetApp
Restituisce l'applicazione DedNetApplication sottostante.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedNetApplication DedNetApp { get; }
Public Shared ReadOnly Property DedNetApp As DedNetApplication
    Get
public:
static property DedNetApplication^ DedNetApp {
    DedNetApplication^ get ();
}
static member DedNetApp : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.DedNetInstallPath

Proprietà DedNetAcadAppDedNetInstallPath
Restituisce il percorso di installazione del DedNet.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string DedNetInstallPath { get; }
Public Shared ReadOnly Property DedNetInstallPath As String
    Get
public:
static property String^ DedNetInstallPath {
    String^ get ();
}
static member DedNetInstallPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.FileStateManager

Proprietà DedNetAcadAppFileStateManager
Restituisce l'oggetto gestore dello stato dei file. Utilizzato dal browser delle dipendenze dei documenti.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static FileStateManager FileStateManager { get; }
Public Shared ReadOnly Property FileStateManager As FileStateManager
    Get
public:
static property FileStateManager^ FileStateManager {
    FileStateManager^ get ();
}
static member FileStateManager : FileStateManager with get

Valore della proprietà

FileStateManager
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.HideCompareDialogOnSavingDwg

Proprietà DedNetAcadAppHideCompareDialogOnSavingDwg
Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool HideCompareDialogOnSavingDwg { get; set; }
Public Shared Property HideCompareDialogOnSavingDwg As Boolean
    Get
    Set
public:
static property bool HideCompareDialogOnSavingDwg {
    bool get ();
    void set (bool value);
}
static member HideCompareDialogOnSavingDwg : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.HideWarningMessageOnModDocCheckout

Proprietà DedNetAcadAppHideWarningMessageOnModDocCheckout
Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool HideWarningMessageOnModDocCheckout { get; set; }
Public Shared Property HideWarningMessageOnModDocCheckout As Boolean
    Get
    Set
public:
static property bool HideWarningMessageOnModDocCheckout {
    bool get ();
    void set (bool value);
}
static member HideWarningMessageOnModDocCheckout : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IgnoreCheckInOnClose

Proprietà DedNetAcadAppIgnoreCheckInOnClose
Indica di ignorare il checkin in chiusura

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreCheckInOnClose { get; set; }
Public Shared Property IgnoreCheckInOnClose As Boolean
    Get
    Set
public:
static property bool IgnoreCheckInOnClose {
    bool get ();
    void set (bool value);
}
static member IgnoreCheckInOnClose : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsDedAcadOpenDocRunning

Proprietà DedNetAcadAppIsDedAcadOpenDocRunning
Indica se è in esecuzione il comando di apertura documenti di Inventor.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedAcadOpenDocRunning { get; set; }
Public Shared Property IsDedAcadOpenDocRunning As Boolean
    Get
    Set
public:
static property bool IsDedAcadOpenDocRunning {
    bool get ();
    void set (bool value);
}
static member IsDedAcadOpenDocRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsMechanicalLoaded

Proprietà DedNetAcadAppIsMechanicalLoaded
Indica se è caricato il mechanical ( viene valutato all'avvio di Autocad )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsMechanicalLoaded { get; }
Public Shared ReadOnly Property IsMechanicalLoaded As Boolean
    Get
public:
static property bool IsMechanicalLoaded {
    bool get ();
}
static member IsMechanicalLoaded : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsProgramaticalQsaveRunning

Proprietà DedNetAcadAppIsProgramaticalQsaveRunning
Indica se si sta eseguendo un salvataggio da software

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsProgramaticalQsaveRunning { get; set; }
Public Shared Property IsProgramaticalQsaveRunning As Boolean
    Get
    Set
public:
static property bool IsProgramaticalQsaveRunning {
    bool get ();
    void set (bool value);
}
static member IsProgramaticalQsaveRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsSDIOperation

Proprietà DedNetAcadAppIsSDIOperation
Restituisce true se la variabile SDI è impostata a 1.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSDIOperation { get; }
Public Shared ReadOnly Property IsSDIOperation As Boolean
    Get
public:
static property bool IsSDIOperation {
    bool get ();
}
static member IsSDIOperation : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.LuaApp

Proprietà DedNetAcadAppLuaApp
Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedLuaApplication LuaApp { get; }
Public Shared ReadOnly Property LuaApp As DedLuaApplication
    Get
public:
static property DedLuaApplication^ LuaApp {
    DedLuaApplication^ get ();
}
static member LuaApp : DedLuaApplication with get

Valore della proprietà

DedLuaApplication
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.NavigatorArgsArray

Proprietà DedNetAcadAppNavigatorArgsArray
Restituisce l'array di parti sulle quali il comando ApriDwgDaDb deve lavorare. Vedi PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray NavigatorArgsArray { get; }
Public Shared ReadOnly Property NavigatorArgsArray As PartInfoArray
    Get
public:
static property PartInfoArray^ NavigatorArgsArray {
    PartInfoArray^ get ();
}
static member NavigatorArgsArray : PartInfoArray with get

Valore della proprietà

PartInfoArray
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.NavigatorArgsLastRev

Proprietà DedNetAcadAppNavigatorArgsLastRev
Restituisce se il comando ApriDwgDaDb debba aprire l'ultima revisione. Vedi PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool NavigatorArgsLastRev { get; }
Public Shared ReadOnly Property NavigatorArgsLastRev As Boolean
    Get
public:
static property bool NavigatorArgsLastRev {
    bool get ();
}
static member NavigatorArgsLastRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.NavigatorArgsReadOnly

Proprietà DedNetAcadAppNavigatorArgsReadOnly
Restituisce se il comando ApriDwgDaDb debba aprire in read-only. Vedi PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool NavigatorArgsReadOnly { get; }
Public Shared ReadOnly Property NavigatorArgsReadOnly As Boolean
    Get
public:
static property bool NavigatorArgsReadOnly {
    bool get ();
}
static member NavigatorArgsReadOnly : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.Ricerca

Proprietà DedNetAcadAppRicerca
Restituisce il comando per effettuare la ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static FindCommand Ricerca { get; }
Public Shared ReadOnly Property Ricerca As FindCommand
    Get
public:
static property FindCommand^ Ricerca {
    FindCommand^ get ();
}
static member Ricerca : FindCommand with get

Valore della proprietà

FindCommand
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.RicercaDocs

Proprietà DedNetAcadAppRicercaDocs
Restituisce il comando per effettuare la ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static FindDocCommand RicercaDocs { get; }
Public Shared ReadOnly Property RicercaDocs As FindDocCommand
    Get
public:
static property FindDocCommand^ RicercaDocs {
    FindDocCommand^ get ();
}
static member RicercaDocs : FindDocCommand with get

Valore della proprietà

FindDocCommand
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.SalvaNelDbRunning

Proprietà DedNetAcadAppSalvaNelDbRunning
Indica se si sta eseguendo un salva nel database

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SalvaNelDbRunning { get; set; }
Public Shared Property SalvaNelDbRunning As Boolean
    Get
    Set
public:
static property bool SalvaNelDbRunning {
    bool get ();
    void set (bool value);
}
static member SalvaNelDbRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.VisAnagr

Proprietà DedNetAcadAppVisAnagr
Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ShowAnagrCommand VisAnagr { get; }
Public Shared ReadOnly Property VisAnagr As ShowAnagrCommand
    Get
public:
static property ShowAnagrCommand^ VisAnagr {
    ShowAnagrCommand^ get ();
}
static member VisAnagr : ShowAnagrCommand with get

Valore della proprietà

ShowAnagrCommand
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.Xmx

Proprietà DedNetAcadAppXmx
Restitusice l'oggetto per la traduzione dei messaggi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static XMX Xmx { get; }
Public Shared ReadOnly Property Xmx As XMX
    Get
public:
static property XMX^ Xmx {
    XMX^ get ();
}
static member Xmx : XMX with get

Valore della proprietà

XMX
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.XrefDialog

Proprietà DedNetAcadAppXrefDialog

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedXrefDialog XrefDialog { get; }
Public Shared ReadOnly Property XrefDialog As DedXrefDialog
    Get
public:
static property DedXrefDialog^ XrefDialog {
    DedXrefDialog^ get ();
}
static member XrefDialog : DedXrefDialog with get

Valore della proprietà

DedXrefDialog
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodi di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | AggiornaAttributiDaDb | Aggiorna gli attributi delle parti passate dal Database. Se c'é la parte Top aggiorna solo se il documento attivo è coerente con l'anagrafica.
Metodo pubblico | AllowHotTracking | Determina se l'elemento è passibile di hot tracking
 | CaricaParteDaDb | Carica una seconda volta la parte dal Database, se a questa vi è associato un Dwg.
 | CheckMechanicalLoaded |
 | CreareDedAcadSaveDist | Crea e restituisce il comando di salvataggio distinta
 | CreateApriAllegati | Crea e restituisce il comando di apertura dei file allegati.
 | CreateApriAssociati | Crea e restituisce il comando di apertura dei file associati.
 | CreateApriInNuovaFinestra | Crea e restituisce il comando di apertura di un documento in una nuova finestra.
 | CreateArchiviaDwg | Crea e restituisce il comando Associa documento.
 | CreateArchiviaXref | Crea e restituisce il comando di archiviazione di un xref.
 | CreateAssociaCommXref | Crea e restituisce il comando che permette di associare un xref a una commessa.
 | CreateAssociaDwg | Crea e restituisce il comando Associa documento.
 | CreateAssociatoA | Crea e restituisce il comando che mostra a quali anagrafiche è associato un documento.
 | CreateAssociaXref | Crea e restituisce il comando che permette di associare un xref a un'anagrafica.
 | CreateCaricaBlocco | Crea e restituisce il comando di carica blocco.
 | CreateCaricaParte | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteEsterno | Crea e restituisce il comando di carica blocco.
 | CreateCaricaXref | Crea e restituisce il comando di carica xref.
 | CreateChangeState | Crea e restituisce il comando di rilascio
 | CreateCheckIn | Crea e restituisce il comando di CheckIn per il documento correntemente attivo.
 | CreateCheckInAssociati | Crea e restituisce il comando di CheckIn con Associati per i file passati.
 | CreateCheckInStruttura | Crea e restituisce il comando di CheckIn Struttura per i file passati.
 | CreateCheckInStrutturaAssociati | Crea e restituisce il comando di CheckIn Struttura con Associati per i file passati.
 | CreateCheckInXref | Crea e restituisce il comando di CheckIn per i file passati.
 | CreateCheckOut | Crea e restituisce il comando di CheckOut per il documento correntemente attivo.
 | CreateCheckOutAssociati | Crea e restituisce il comando di CheckOut con Associati per i file passati.
 | CreateCheckOutStruttura | Crea e restituisce il comando di CheckOut Struttura per i file passati.
 | CreateCheckOutStrutturaAssociati | Crea e restituisce il comando di CheckOut Struttura con Associati per i file passati.
 | CreateCheckOutXref | Crea e restituisce il comando di CheckOut per i file passati.
 | CreateCompilaParteDaAnagrafica | Crea e restituisce il comando di compila parte da anagrafica.
 | CreateCreaAnagrafica | Crea e restituisce il comando di creazione anagrafica ovvero di Salva nel Database.
 | CreateCreaRev | Crea e restituisce il comando di creazione revisione.
 | CreateCreateSparePartsDrawing | Crea e restituisce il comando di carica parte.
 | CreateCreaVariante | Crea e restituisce il comando di creazione variante ovvero di Salva nel Database con tassello utente.
 | CreateFindInRicerca | Crea e restituisce il comando di individuazione nella Ricerca di un documento.
 | CreateForceMarkerAlignment | Crea e restituisce il comando di rilascio
 | CreateForzaAllineamento | Crea e restituisce il comando per forzare l'allineamento di un documento.
 | CreateLavorazioneMultiploXref | Crea e restituisce il comando di messa in lavorazione multipla xref.
 | CreateLavorazioneXref | Crea e restituisce il comando di messa in lavorazione xref.
 | CreateMarkerInfo | Crea e restituisce il comando di rilascio
 | CreatePackAngGoExport | Crea e restituisce il comando di creazione revisione.
 | CreatePackAngGoImport | Crea e restituisce il comando di creazione revisione.
 | CreatePubblica | Crea e restituisce il comando di pubblicazione dei documenti.
 | CreatePubblicaStruttura | Crea e restituisce il comando di pubblicazione dei documenti e della relativa struttura.
 | CreatePublishSparePartsDrawing | Crea e restituisce il comando di Pubblic tavola ricambi.
 | CreateRegistra | Crea e restituisce il comando di registrazione di un nuovo file.
 | CreateRilascioMultiploXref | Crea e restituisce il comando di rilascio multiplo xref.
 | CreateRilascioXref | Crea e restituisce il comando di rilascio xref.
 | CreateSalvaRevXref | Crea e restituisce il comando di salvataggio di una revisione di un xref.
 | CreateSalvaVarianteXref | Crea e restituisce il comando di salvataggio di una variante di un xref.
 | CreateSalvaXref | Crea e restituisce il comando di salvataggio di un xref nel database.
 | CreateSelezionaRiferimento | Crea e ritorna il comando per la selezione di un riferimento esterno.
 | CreateSostituisciRiferimenti | Crea e restituisce il comando di sostituzione riferimenti xref.
 | CreateStatoAllineamento | Crea e restituisce il comando di visualizzazione dello stato di allineamento di un documento.
 | CreateUpdateOldRev | Crea e restituisce il comando di aggiornamento delle revisioni superate degli xref.
 | CreateUsatoIn | Crea e restituisce il comando di visualizzazione del dialogo Usato In.
 | EditaAttributi | Aggiorna il controllo degli attributi
 | FindOpenDocument | Cerca un documento tra quelli correntemente aperti. Se lo trova lo restituisce altrimenti restituisce null. Normalizza i nomi prima di effettuare il confronto.
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetAnagStateName | Restituisce il il nome dello stato dell'anagrafica associata all'elemento passato
Metodo pubblico | GetAttr | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'oggetto passato. Per creare la struttura non utilizzo l'InvDocStructInfo per come gestisce la costruzione dei figli. Per agevolare il flusso dei dati nelle operazioni gli oggetti dei Ties vengono riciclati. Questo può causare problemi se ad esempio ho una reference nipote disponibile ed una figlia che invece non lo è...
Metodo pubblico | GetData | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetMovedDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetSelectionImageKey | Restituisce il nome dell'immagine che rappresenta un elemento. L'immagine rispecchia il tipo di documento ed è quella standard di Inventor.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce il nome dell'immagine che descrive lo stato di un elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento passato possiede figli
 | IndividuaNellaRicerca | Apre la ricerca nei recenti individuando l'anagrafica di una parte.
Metodo pubblico | Initialize | Inizializzazione dell'add-in.
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è associato ad un documento dirty
 | Log(Exception, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | Log(ListException, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | LogInfo | Registra l'eccezione nel file di log dell'applicazione.
Metodo pubblico | MakeAcadCommandContext | Ritorna l'oggetto context di Inventor in base alla lista di elementi passati dal controllo delle dipendenze documentali.
 | OnAcadRilPublishEvent | Lancia evento di pubblicazione formati al rilascio in Inventor
Metodo pubblico | OnElementDoubleClicked | Gestione doppio click su elemento
Metodo pubblico | OnElementsSelected | Si occupa di allineare la selezione dell'albero con la selezione dell'occorrenze a livello di documento
 | OnFileResolutionEvent | Lancia l'evento di FileResolutionEvent
Metodo pubblico | OnHotTrackElementClicked | Gestione click singolo su elemento hottracked
 | OnImportPackAndGoAfterLoadEvent | Lancia l'evento di ImportPackAndGoAfterLoadEvent
 | OnImportPackAndGoDocAttrCompareEvent | Lancia l'evento di ImportPackAndGoDocAttrCompareEvent
 | OnImportPackAndGoMappingRootEvent | Lancia l'evento di ImportPackAndGoMappingRootEvent
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent | Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent
 | OnImportPackAndGoPresetCodingOperationEvent | Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent
 | OnSkipLayoutOnPrintingEvent | Lancia l'evento di SkipLayoutOnPrintingEvent
Metodo pubblico | OnTopPrtCreated | Evento di creazione albero parti, chiamato dal LUA dopo la creazione del documento. Viene utilizzato per aggiornare la parte Top con gli attributi presenti nel Database.
 | OnUpdateAttribFromDbOnOpenEvent | Lancia evento per la gestione dell'aggiornamento degli attributi dal Db in apertura.
 | OnUpdateCartOnOpenEvent | Lancia evento per la gestione dell'aggiornamento del cartiglio in apertura.
Metodo pubblico | PartsTreeSelectionChanged | Chiamato sul cambio selezione nell'albero delle parti, per aggiornare la finestra di visualizzazione attributi.
 | PostNavigatorArgs | Imposta in una variabile globale l'array di parti da utilizzare poi nei comandi che saranno invocati tramite invio di una stringa alla riga di comando di autocad. Viene utilizzato subito prima di chiamare un comando in contesto application.
 | StatoDocAcad | Metodo che restituisce una stringa con lo stato attuale del doccumento.
Metodo pubblico | Terminate | Termine dell'add-in.
 | UpdateStateDocPanel | Aggiorna il pannello in base allo stato del documento.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.AggiornaAttributiDaDb

Metodo DedNetAcadAppAggiornaAttributiDaDb
Aggiorna gli attributi delle parti passate dal Database. Se c'é la parte Top aggiorna solo se il documento attivo è coerente con l'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void AggiornaAttributiDaDb(
    PartInfoArray prtArray,
    int iLlastRev
)
Public Shared Sub AggiornaAttributiDaDb (
    prtArray As PartInfoArray,
    iLlastRev As Integer
)
public:
static void AggiornaAttributiDaDb(
    PartInfoArray^ prtArray,
    int iLlastRev
)
static member AggiornaAttributiDaDb :
        prtArray : PartInfoArray *
        iLlastRev : int -> unit

Parametri

prtArray PartInfoArray
Parti da aggiornare.
iLlastRev Int32
Se a 1 aggiorna all'ultima revisione altrimenti alla revisione corrente.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.AllowHotTracking

Metodo DedNetAcadAppAllowHotTracking
Determina se l'elemento è passibile di hot tracking

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowHotTracking(
    FileStateElement el
)
Public Function AllowHotTracking (
    el As FileStateElement
) As Boolean
public:
virtual bool AllowHotTracking(
    FileStateElement^ el
) sealed
abstract AllowHotTracking :
        el : FileStateElement -> bool
override AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean

Implementa

IFileStateInformerAllowHotTracking(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CaricaParteDaDb

Metodo DedNetAcadAppCaricaParteDaDb
Carica una seconda volta la parte dal Database, se a questa vi è associato un Dwg.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void CaricaParteDaDb(
    PartInfo prt
)
Public Shared Sub CaricaParteDaDb (
    prt As PartInfo
)
public:
static void CaricaParteDaDb(
    PartInfo^ prt
)
static member CaricaParteDaDb :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Parte da ricaricare.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CheckMechanicalLoaded

Metodo DedNetAcadAppCheckMechanicalLoaded

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckMechanicalLoaded()
Public Shared Sub CheckMechanicalLoaded
public:
static void CheckMechanicalLoaded()
static member CheckMechanicalLoaded : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreareDedAcadSaveDist

Metodo DedNetAcadAppCreareDedAcadSaveDist
Crea e restituisce il comando di salvataggio distinta

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadSaveDist CreareDedAcadSaveDist()
Public Shared Function CreareDedAcadSaveDist As DedAcadSaveDist
public:
static DedAcadSaveDist^ CreareDedAcadSaveDist()
static member CreareDedAcadSaveDist : unit -> DedAcadSaveDist

Valore di ritorno

DedAcadSaveDist
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateApriAllegati

Metodo DedNetAcadAppCreateApriAllegati
Crea e restituisce il comando di apertura dei file allegati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ApriFileAssociati CreateApriAllegati()
Public Shared Function CreateApriAllegati As ApriFileAssociati
public:
static ApriFileAssociati^ CreateApriAllegati()
static member CreateApriAllegati : unit -> ApriFileAssociati

Valore di ritorno

ApriFileAssociati
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateApriAssociati

Metodo DedNetAcadAppCreateApriAssociati
Crea e restituisce il comando di apertura dei file associati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ApriFileAssociati CreateApriAssociati()
Public Shared Function CreateApriAssociati As ApriFileAssociati
public:
static ApriFileAssociati^ CreateApriAssociati()
static member CreateApriAssociati : unit -> ApriFileAssociati

Valore di ritorno

ApriFileAssociati
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateApriInNuovaFinestra

Metodo DedNetAcadAppCreateApriInNuovaFinestra
Crea e restituisce il comando di apertura di un documento in una nuova finestra.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ApriInNuovaFinestra CreateApriInNuovaFinestra()
Public Shared Function CreateApriInNuovaFinestra As ApriInNuovaFinestra
public:
static ApriInNuovaFinestra^ CreateApriInNuovaFinestra()
static member CreateApriInNuovaFinestra : unit -> ApriInNuovaFinestra

Valore di ritorno

ApriInNuovaFinestra
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateArchiviaDwg

Metodo DedNetAcadAppCreateArchiviaDwg
Crea e restituisce il comando Associa documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadArchiviaDwg CreateArchiviaDwg()
Public Shared Function CreateArchiviaDwg As DedAcadArchiviaDwg
public:
static DedAcadArchiviaDwg^ CreateArchiviaDwg()
static member CreateArchiviaDwg : unit -> DedAcadArchiviaDwg

Valore di ritorno

DedAcadArchiviaDwg
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateArchiviaXref

Metodo DedNetAcadAppCreateArchiviaXref
Crea e restituisce il comando di archiviazione di un xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ArchiviaXref CreateArchiviaXref()
Public Shared Function CreateArchiviaXref As ArchiviaXref
public:
static ArchiviaXref^ CreateArchiviaXref()
static member CreateArchiviaXref : unit -> ArchiviaXref

Valore di ritorno

ArchiviaXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateAssociaCommXref

Metodo DedNetAcadAppCreateAssociaCommXref
Crea e restituisce il comando che permette di associare un xref a una commessa.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static AssociaCommXref CreateAssociaCommXref()
Public Shared Function CreateAssociaCommXref As AssociaCommXref
public:
static AssociaCommXref^ CreateAssociaCommXref()
static member CreateAssociaCommXref : unit -> AssociaCommXref

Valore di ritorno

AssociaCommXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateAssociaDwg

Metodo DedNetAcadAppCreateAssociaDwg
Crea e restituisce il comando Associa documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadAssociaDwg CreateAssociaDwg()
Public Shared Function CreateAssociaDwg As DedAcadAssociaDwg
public:
static DedAcadAssociaDwg^ CreateAssociaDwg()
static member CreateAssociaDwg : unit -> DedAcadAssociaDwg

Valore di ritorno

DedAcadAssociaDwg
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateAssociatoA

Metodo DedNetAcadAppCreateAssociatoA
Crea e restituisce il comando che mostra a quali anagrafiche è associato un documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static AssociatoA CreateAssociatoA()
Public Shared Function CreateAssociatoA As AssociatoA
public:
static AssociatoA^ CreateAssociatoA()
static member CreateAssociatoA : unit -> AssociatoA

Valore di ritorno

AssociatoA
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateAssociaXref

Metodo DedNetAcadAppCreateAssociaXref
Crea e restituisce il comando che permette di associare un xref a un'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static AssociaXref CreateAssociaXref()
Public Shared Function CreateAssociaXref As AssociaXref
public:
static AssociaXref^ CreateAssociaXref()
static member CreateAssociaXref : unit -> AssociaXref

Valore di ritorno

AssociaXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaBlocco

Metodo DedNetAcadAppCreateCaricaBlocco
Crea e restituisce il comando di carica blocco.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaBlocco()
Public Shared Function CreateCaricaBlocco As CaricaParte
public:
static CaricaParte^ CreateCaricaBlocco()
static member CreateCaricaBlocco : unit -> CaricaParte

Valore di ritorno

CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaParte

Metodo DedNetAcadAppCreateCaricaParte
Crea e restituisce il comando di carica parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParte()
Public Shared Function CreateCaricaParte As CaricaParte
public:
static CaricaParte^ CreateCaricaParte()
static member CreateCaricaParte : unit -> CaricaParte

Valore di ritorno

CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaParteEsterno

Metodo DedNetAcadAppCreateCaricaParteEsterno
Crea e restituisce il comando di carica blocco.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParteEsterno()
Public Shared Function CreateCaricaParteEsterno As CaricaParte
public:
static CaricaParte^ CreateCaricaParteEsterno()
static member CreateCaricaParteEsterno : unit -> CaricaParte

Valore di ritorno

CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaXref

Metodo DedNetAcadAppCreateCaricaXref
Crea e restituisce il comando di carica xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaXref()
Public Shared Function CreateCaricaXref As CaricaParte
public:
static CaricaParte^ CreateCaricaXref()
static member CreateCaricaXref : unit -> CaricaParte

Valore di ritorno

CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateChangeState

Metodo DedNetAcadAppCreateChangeState
Crea e restituisce il comando di rilascio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadChangeState CreateChangeState(
    string internalname,
    string name,
    string tooltip,
    DedState targetState,
    bool multiple
)
Public Shared Function CreateChangeState (
    internalname As String,
    name As String,
    tooltip As String,
    targetState As DedState,
    multiple As Boolean
) As DedAcadChangeState
public:
static DedAcadChangeState^ CreateChangeState(
    String^ internalname,
    String^ name,
    String^ tooltip,
    DedState^ targetState,
    bool multiple
)
static member CreateChangeState :
        internalname : string *
        name : string *
        tooltip : string *
        targetState : DedState *
        multiple : bool -> DedAcadChangeState

Parametri

internalname String
name String
tooltip String
targetState DedState
multiple Boolean

Valore di ritorno

DedAcadChangeState
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckIn

Metodo DedNetAcadAppCreateCheckIn
Crea e restituisce il comando di CheckIn per il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckIn()
Public Shared Function CreateCheckIn As CheckIn
public:
static CheckIn^ CreateCheckIn()
static member CreateCheckIn : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckInAssociati

Metodo DedNetAcadAppCreateCheckInAssociati
Crea e restituisce il comando di CheckIn con Associati per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInAssociati()
Public Shared Function CreateCheckInAssociati As CheckIn
public:
static CheckIn^ CreateCheckInAssociati()
static member CreateCheckInAssociati : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckInStruttura

Metodo DedNetAcadAppCreateCheckInStruttura
Crea e restituisce il comando di CheckIn Struttura per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInStruttura()
Public Shared Function CreateCheckInStruttura As CheckIn
public:
static CheckIn^ CreateCheckInStruttura()
static member CreateCheckInStruttura : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckInStrutturaAssociati

Metodo DedNetAcadAppCreateCheckInStrutturaAssociati
Crea e restituisce il comando di CheckIn Struttura con Associati per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInStrutturaAssociati()
Public Shared Function CreateCheckInStrutturaAssociati As CheckIn
public:
static CheckIn^ CreateCheckInStrutturaAssociati()
static member CreateCheckInStrutturaAssociati : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckInXref

Metodo DedNetAcadAppCreateCheckInXref
Crea e restituisce il comando di CheckIn per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInXref()
Public Shared Function CreateCheckInXref As CheckIn
public:
static CheckIn^ CreateCheckInXref()
static member CreateCheckInXref : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckOut

Metodo DedNetAcadAppCreateCheckOut
Crea e restituisce il comando di CheckOut per il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOut()
Public Shared Function CreateCheckOut As CheckOut
public:
static CheckOut^ CreateCheckOut()
static member CreateCheckOut : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckOutAssociati

Metodo DedNetAcadAppCreateCheckOutAssociati
Crea e restituisce il comando di CheckOut con Associati per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutAssociati()
Public Shared Function CreateCheckOutAssociati As CheckOut
public:
static CheckOut^ CreateCheckOutAssociati()
static member CreateCheckOutAssociati : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckOutStruttura

Metodo DedNetAcadAppCreateCheckOutStruttura
Crea e restituisce il comando di CheckOut Struttura per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutStruttura()
Public Shared Function CreateCheckOutStruttura As CheckOut
public:
static CheckOut^ CreateCheckOutStruttura()
static member CreateCheckOutStruttura : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckOutStrutturaAssociati

Metodo DedNetAcadAppCreateCheckOutStrutturaAssociati
Crea e restituisce il comando di CheckOut Struttura con Associati per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutStrutturaAssociati()
Public Shared Function CreateCheckOutStrutturaAssociati As CheckOut
public:
static CheckOut^ CreateCheckOutStrutturaAssociati()
static member CreateCheckOutStrutturaAssociati : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckOutXref

Metodo DedNetAcadAppCreateCheckOutXref
Crea e restituisce il comando di CheckOut per i file passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutXref()
Public Shared Function CreateCheckOutXref As CheckOut
public:
static CheckOut^ CreateCheckOutXref()
static member CreateCheckOutXref : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCompilaParteDaAnagrafica

Metodo DedNetAcadAppCreateCompilaParteDaAnagrafica
Crea e restituisce il comando di compila parte da anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CompilaParteDaAnagrafica CreateCompilaParteDaAnagrafica()
Public Shared Function CreateCompilaParteDaAnagrafica As CompilaParteDaAnagrafica
public:
static CompilaParteDaAnagrafica^ CreateCompilaParteDaAnagrafica()
static member CreateCompilaParteDaAnagrafica : unit -> CompilaParteDaAnagrafica

Valore di ritorno

CompilaParteDaAnagrafica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreaAnagrafica

Metodo DedNetAcadAppCreateCreaAnagrafica
Crea e restituisce il comando di creazione anagrafica ovvero di Salva nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadCreaAnagrafica CreateCreaAnagrafica()
Public Shared Function CreateCreaAnagrafica As DedAcadCreaAnagrafica
public:
static DedAcadCreaAnagrafica^ CreateCreaAnagrafica()
static member CreateCreaAnagrafica : unit -> DedAcadCreaAnagrafica

Valore di ritorno

DedAcadCreaAnagrafica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreaRev

Metodo DedNetAcadAppCreateCreaRev
Crea e restituisce il comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadCreaRev CreateCreaRev()
Public Shared Function CreateCreaRev As DedAcadCreaRev
public:
static DedAcadCreaRev^ CreateCreaRev()
static member CreateCreaRev : unit -> DedAcadCreaRev

Valore di ritorno

DedAcadCreaRev
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreateSparePartsDrawing

Metodo DedNetAcadAppCreateCreateSparePartsDrawing
Crea e restituisce il comando di carica parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static CreateSparePartsDrawing CreateCreateSparePartsDrawing()
Public Shared Function CreateCreateSparePartsDrawing As CreateSparePartsDrawing
public:
static CreateSparePartsDrawing^ CreateCreateSparePartsDrawing()
static member CreateCreateSparePartsDrawing : unit -> CreateSparePartsDrawing

Valore di ritorno

CreateSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreaVariante

Metodo DedNetAcadAppCreateCreaVariante
Crea e restituisce il comando di creazione variante ovvero di Salva nel Database con tassello utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadCreaAnagrafica CreateCreaVariante()
Public Shared Function CreateCreaVariante As DedAcadCreaAnagrafica
public:
static DedAcadCreaAnagrafica^ CreateCreaVariante()
static member CreateCreaVariante : unit -> DedAcadCreaAnagrafica

Valore di ritorno

DedAcadCreaAnagrafica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateFindInRicerca

Metodo DedNetAcadAppCreateFindInRicerca
Crea e restituisce il comando di individuazione nella Ricerca di un documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static FindInRicerca CreateFindInRicerca()
Public Shared Function CreateFindInRicerca As FindInRicerca
public:
static FindInRicerca^ CreateFindInRicerca()
static member CreateFindInRicerca : unit -> FindInRicerca

Valore di ritorno

FindInRicerca
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateForceMarkerAlignment

Metodo DedNetAcadAppCreateForceMarkerAlignment
Crea e restituisce il comando di rilascio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadForceMarkerAlingment CreateForceMarkerAlignment()
Public Shared Function CreateForceMarkerAlignment As DedAcadForceMarkerAlingment
public:
static DedAcadForceMarkerAlingment^ CreateForceMarkerAlignment()
static member CreateForceMarkerAlignment : unit -> DedAcadForceMarkerAlingment

Valore di ritorno

DedAcadForceMarkerAlingment
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateForzaAllineamento

Metodo DedNetAcadAppCreateForzaAllineamento
Crea e restituisce il comando per forzare l'allineamento di un documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ForzaAllineamento CreateForzaAllineamento()
Public Shared Function CreateForzaAllineamento As ForzaAllineamento
public:
static ForzaAllineamento^ CreateForzaAllineamento()
static member CreateForzaAllineamento : unit -> ForzaAllineamento

Valore di ritorno

ForzaAllineamento
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateLavorazioneMultiploXref

Metodo DedNetAcadAppCreateLavorazioneMultiploXref
Crea e restituisce il comando di messa in lavorazione multipla xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ChangeStateXref CreateLavorazioneMultiploXref()
Public Shared Function CreateLavorazioneMultiploXref As ChangeStateXref
public:
static ChangeStateXref^ CreateLavorazioneMultiploXref()
static member CreateLavorazioneMultiploXref : unit -> ChangeStateXref

Valore di ritorno

ChangeStateXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateLavorazioneXref

Metodo DedNetAcadAppCreateLavorazioneXref
Crea e restituisce il comando di messa in lavorazione xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ChangeStateXref CreateLavorazioneXref()
Public Shared Function CreateLavorazioneXref As ChangeStateXref
public:
static ChangeStateXref^ CreateLavorazioneXref()
static member CreateLavorazioneXref : unit -> ChangeStateXref

Valore di ritorno

ChangeStateXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateMarkerInfo

Metodo DedNetAcadAppCreateMarkerInfo
Crea e restituisce il comando di rilascio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadMarkerInfo CreateMarkerInfo()
Public Shared Function CreateMarkerInfo As DedAcadMarkerInfo
public:
static DedAcadMarkerInfo^ CreateMarkerInfo()
static member CreateMarkerInfo : unit -> DedAcadMarkerInfo

Valore di ritorno

DedAcadMarkerInfo
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePackAngGoExport

Metodo DedNetAcadAppCreatePackAngGoExport
Crea e restituisce il comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoExport CreatePackAngGoExport()
Public Shared Function CreatePackAngGoExport As PackAndGoExport
public:
static PackAndGoExport^ CreatePackAngGoExport()
static member CreatePackAngGoExport : unit -> PackAndGoExport

Valore di ritorno

PackAndGoExport
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePackAngGoImport

Metodo DedNetAcadAppCreatePackAngGoImport
Crea e restituisce il comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoImport CreatePackAngGoImport()
Public Shared Function CreatePackAngGoImport As PackAndGoImport
public:
static PackAndGoImport^ CreatePackAngGoImport()
static member CreatePackAngGoImport : unit -> PackAndGoImport

Valore di ritorno

PackAndGoImport
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePubblica

Metodo DedNetAcadAppCreatePubblica
Crea e restituisce il comando di pubblicazione dei documenti.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Pubblica CreatePubblica()
Public Shared Function CreatePubblica As Pubblica
public:
static Pubblica^ CreatePubblica()
static member CreatePubblica : unit -> Pubblica

Valore di ritorno

Pubblica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePubblicaStruttura

Metodo DedNetAcadAppCreatePubblicaStruttura
Crea e restituisce il comando di pubblicazione dei documenti e della relativa struttura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Pubblica CreatePubblicaStruttura()
Public Shared Function CreatePubblicaStruttura As Pubblica
public:
static Pubblica^ CreatePubblicaStruttura()
static member CreatePubblicaStruttura : unit -> Pubblica

Valore di ritorno

Pubblica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePublishSparePartsDrawing

Metodo DedNetAcadAppCreatePublishSparePartsDrawing
Crea e restituisce il comando di Pubblic tavola ricambi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PublishSparePartsDrawing CreatePublishSparePartsDrawing()
Public Shared Function CreatePublishSparePartsDrawing As PublishSparePartsDrawing
public:
static PublishSparePartsDrawing^ CreatePublishSparePartsDrawing()
static member CreatePublishSparePartsDrawing : unit -> PublishSparePartsDrawing

Valore di ritorno

PublishSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateRegistra

Metodo DedNetAcadAppCreateRegistra
Crea e restituisce il comando di registrazione di un nuovo file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Registra CreateRegistra()
Public Shared Function CreateRegistra As Registra
public:
static Registra^ CreateRegistra()
static member CreateRegistra : unit -> Registra

Valore di ritorno

Registra
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateRilascioMultiploXref

Metodo DedNetAcadAppCreateRilascioMultiploXref
Crea e restituisce il comando di rilascio multiplo xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ChangeStateXref CreateRilascioMultiploXref()
Public Shared Function CreateRilascioMultiploXref As ChangeStateXref
public:
static ChangeStateXref^ CreateRilascioMultiploXref()
static member CreateRilascioMultiploXref : unit -> ChangeStateXref

Valore di ritorno

ChangeStateXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateRilascioXref

Metodo DedNetAcadAppCreateRilascioXref
Crea e restituisce il comando di rilascio xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ChangeStateXref CreateRilascioXref()
Public Shared Function CreateRilascioXref As ChangeStateXref
public:
static ChangeStateXref^ CreateRilascioXref()
static member CreateRilascioXref : unit -> ChangeStateXref

Valore di ritorno

ChangeStateXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateSalvaRevXref

Metodo DedNetAcadAppCreateSalvaRevXref
Crea e restituisce il comando di salvataggio di una revisione di un xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static SalvaRevXref CreateSalvaRevXref()
Public Shared Function CreateSalvaRevXref As SalvaRevXref
public:
static SalvaRevXref^ CreateSalvaRevXref()
static member CreateSalvaRevXref : unit -> SalvaRevXref

Valore di ritorno

SalvaRevXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateSalvaVarianteXref

Metodo DedNetAcadAppCreateSalvaVarianteXref
Crea e restituisce il comando di salvataggio di una variante di un xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static SalvaXref CreateSalvaVarianteXref()
Public Shared Function CreateSalvaVarianteXref As SalvaXref
public:
static SalvaXref^ CreateSalvaVarianteXref()
static member CreateSalvaVarianteXref : unit -> SalvaXref

Valore di ritorno

SalvaXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateSalvaXref

Metodo DedNetAcadAppCreateSalvaXref
Crea e restituisce il comando di salvataggio di un xref nel database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static SalvaXref CreateSalvaXref()
Public Shared Function CreateSalvaXref As SalvaXref
public:
static SalvaXref^ CreateSalvaXref()
static member CreateSalvaXref : unit -> SalvaXref

Valore di ritorno

SalvaXref
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateSelezionaRiferimento

Metodo DedNetAcadAppCreateSelezionaRiferimento
Crea e ritorna il comando per la selezione di un riferimento esterno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static SelezionaRiferimento CreateSelezionaRiferimento()
Public Shared Function CreateSelezionaRiferimento As SelezionaRiferimento
public:
static SelezionaRiferimento^ CreateSelezionaRiferimento()
static member CreateSelezionaRiferimento : unit -> SelezionaRiferimento

Valore di ritorno

SelezionaRiferimento
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateSostituisciRiferimenti

Metodo DedNetAcadAppCreateSostituisciRiferimenti
Crea e restituisce il comando di sostituzione riferimenti xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciRiferimenti CreateSostituisciRiferimenti()
Public Shared Function CreateSostituisciRiferimenti As SostituisciRiferimenti
public:
static SostituisciRiferimenti^ CreateSostituisciRiferimenti()
static member CreateSostituisciRiferimenti : unit -> SostituisciRiferimenti

Valore di ritorno

SostituisciRiferimenti
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateStatoAllineamento

Metodo DedNetAcadAppCreateStatoAllineamento
Crea e restituisce il comando di visualizzazione dello stato di allineamento di un documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static StatoAllineamento CreateStatoAllineamento()
Public Shared Function CreateStatoAllineamento As StatoAllineamento
public:
static StatoAllineamento^ CreateStatoAllineamento()
static member CreateStatoAllineamento : unit -> StatoAllineamento

Valore di ritorno

StatoAllineamento
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateUpdateOldRev

Metodo DedNetAcadAppCreateUpdateOldRev
Crea e restituisce il comando di aggiornamento delle revisioni superate degli xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static UpdateOldRev CreateUpdateOldRev()
Public Shared Function CreateUpdateOldRev As UpdateOldRev
public:
static UpdateOldRev^ CreateUpdateOldRev()
static member CreateUpdateOldRev : unit -> UpdateOldRev

Valore di ritorno

UpdateOldRev
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateUsatoIn

Metodo DedNetAcadAppCreateUsatoIn
Crea e restituisce il comando di visualizzazione del dialogo Usato In.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static UsatoIn CreateUsatoIn()
Public Shared Function CreateUsatoIn As UsatoIn
public:
static UsatoIn^ CreateUsatoIn()
static member CreateUsatoIn : unit -> UsatoIn

Valore di ritorno

UsatoIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.EditaAttributi

Metodo DedNetAcadAppEditaAttributi
Aggiorna il controllo degli attributi

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void EditaAttributi(
    DedEditAnagrControl ctr,
    PartInfoArray selParts,
    int readOnly,
    bool selChanged = false
)
Public Shared Sub EditaAttributi (
    ctr As DedEditAnagrControl,
    selParts As PartInfoArray,
    readOnly As Integer,
    Optional selChanged As Boolean = false
)
public:
static void EditaAttributi(
    DedEditAnagrControl^ ctr,
    PartInfoArray^ selParts,
    int readOnly,
    bool selChanged = false
)
static member EditaAttributi :
        ctr : DedEditAnagrControl *
        selParts : PartInfoArray *
        readOnly : int *
        ?selChanged : bool
(* Defaults:
        let _selChanged = defaultArg selChanged false
*)
-> unit

Parametri

ctr DedEditAnagrControl
selParts PartInfoArray
Array di parti.
readOnly Int32
selChanged Boolean (Optional)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.FindOpenDocument

Metodo DedNetAcadAppFindOpenDocument
Cerca un documento tra quelli correntemente aperti. Se lo trova lo restituisce altrimenti restituisce null. Normalizza i nomi prima di effettuare il confronto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument FindOpenDocument(
    string fullFileName
)
Public Shared Function FindOpenDocument (
    fullFileName As String
) As QsDocument
public:
static QsDocument^ FindOpenDocument(
    String^ fullFileName
)
static member FindOpenDocument :
        fullFileName : string -> QsDocument

Parametri

fullFileName String
File da cercare.

Valore di ritorno

QsDocument
Restituisce il documento trovato oppure null se non lo trova.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetActiveElement

Metodo DedNetAcadAppGetActiveElement
Restituisce l'elemento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetActiveElement()
Public Function GetActiveElement As FileStateElement
public:
virtual FileStateElement^ GetActiveElement() sealed
abstract GetActiveElement : unit -> FileStateElement
override GetActiveElement : unit -> FileStateElement

Valore di ritorno

FileStateElement

Implementa

IFileStateInformerGetActiveElement
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetAnagStateImageKey

Metodo DedNetAcadAppGetAnagStateImageKey
Restituisce il valore dell'attributo identificato dal nome passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image GetAnagStateImageKey(
    FileStateElement el
)
Public Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
public:
virtual Image^ GetAnagStateImageKey(
    FileStateElement^ el
) sealed
abstract GetAnagStateImageKey :
        el : FileStateElement -> Image
override GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el FileStateElement

Valore di ritorno

Image

Implementa

IFileStateInformerGetAnagStateImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetAnagStateName

Metodo DedNetAcadAppGetAnagStateName
Restituisce il il nome dello stato dell'anagrafica associata all'elemento passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAnagStateName(
    FileStateElement el
)
Public Function GetAnagStateName (
    el As FileStateElement
) As String
public:
virtual String^ GetAnagStateName(
    FileStateElement^ el
) sealed
abstract GetAnagStateName :
        el : FileStateElement -> string
override GetAnagStateName :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String

Implementa

IFileStateInformerGetAnagStateName(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetAttr

Metodo DedNetAcadAppGetAttr
Restituisce il valore dell'attributo identificato dal nome passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAttr(
    FileStateElement el,
    string attrPrompt
)
Public Function GetAttr (
    el As FileStateElement,
    attrPrompt As String
) As String
public:
virtual String^ GetAttr(
    FileStateElement^ el,
    String^ attrPrompt
) sealed
abstract GetAttr :
        el : FileStateElement *
        attrPrompt : string -> string
override GetAttr :
        el : FileStateElement *
        attrPrompt : string -> string

Parametri

el FileStateElement
attrPrompt String

Valore di ritorno

String

Implementa

IFileStateInformerGetAttr(FileStateElement, String)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetChildrenElements

Metodo DedNetAcadAppGetChildrenElements
Ritorna gli elementi figli dell'oggetto passato. Per creare la struttura non utilizzo l'InvDocStructInfo per come gestisce la costruzione dei figli. Per agevolare il flusso dei dati nelle operazioni gli oggetti dei Ties vengono riciclati. Questo può causare problemi se ad esempio ho una reference nipote disponibile ed una figlia che invece non lo è...

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList GetChildrenElements(
    FileStateElement el
)
Public Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
public:
virtual FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
) sealed
abstract GetChildrenElements :
        el : FileStateElement -> FileStateElementList
override GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el FileStateElement
Elemento Padre

Valore di ritorno

FileStateElementList
Lista di elementi

Implementa

IFileStateInformerGetChildrenElements(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetData

Metodo DedNetAcadAppGetData
Restituisce il valore dell'attributo identificato dal nome passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetData(
    FileStateElement el
)
Public Function GetData (
    el As FileStateElement
) As DedData
public:
virtual DedData^ GetData(
    FileStateElement^ el
) sealed
abstract GetData :
        el : FileStateElement -> DedData
override GetData :
        el : FileStateElement -> DedData

Parametri

el FileStateElement

Valore di ritorno

DedData

Implementa

IFileStateInformerGetData(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetDocument

Metodo DedNetAcadAppGetDocument
Restituisce il documento associato all'oggetto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetDocument(
    FileStateElement el
)
Public Function GetDocument (
    el As FileStateElement
) As DedDoc
public:
virtual DedDoc^ GetDocument(
    FileStateElement^ el
) sealed
abstract GetDocument :
        el : FileStateElement -> DedDoc
override GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc

Implementa

IFileStateInformerGetDocument(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetMovedDocument

Metodo DedNetAcadAppGetMovedDocument
Restituisce il documento associato all'oggetto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDocument(
    FileStateElement el
)
Public Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
public:
virtual DedDoc^ GetMovedDocument(
    FileStateElement^ el
) sealed
abstract GetMovedDocument :
        el : FileStateElement -> DedDoc
override GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc

Implementa

IFileStateInformerGetMovedDocument(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetSelectionImageKey

Metodo DedNetAcadAppGetSelectionImageKey
Restituisce il nome dell'immagine che rappresenta un elemento. L'immagine rispecchia il tipo di documento ed è quella standard di Inventor.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetSelectionImageKey(
    FileStateElement el
)
Public Function GetSelectionImageKey (
    el As FileStateElement
) As String
public:
virtual String^ GetSelectionImageKey(
    FileStateElement^ el
) sealed
abstract GetSelectionImageKey :
        el : FileStateElement -> string
override GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement
Elemento per il quale fornire il nome dell'immagine.

Valore di ritorno

String

Implementa

IFileStateInformerGetSelectionImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetState

Metodo DedNetAcadAppGetState
Restituisce lo stato dell'elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int GetState(
    FileStateElement el
)
Public Function GetState (
    el As FileStateElement
) As Integer
public:
virtual int GetState(
    FileStateElement^ el
) sealed
abstract GetState :
        el : FileStateElement -> int
override GetState :
        el : FileStateElement -> int

Parametri

el FileStateElement
Elemento da valutare.

Valore di ritorno

Int32

Implementa

IFileStateInformerGetState(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.GetStateImageKey

Metodo DedNetAcadAppGetStateImageKey
Restituisce il nome dell'immagine che descrive lo stato di un elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetStateImageKey(
    FileStateElement el
)
Public Function GetStateImageKey (
    el As FileStateElement
) As String
public:
virtual String^ GetStateImageKey(
    FileStateElement^ el
) sealed
abstract GetStateImageKey :
        el : FileStateElement -> string
override GetStateImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement
Elemento per il quale fornire il nome dell'immagine.

Valore di ritorno

String

Implementa

IFileStateInformerGetStateImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.HasChildrenElements

Metodo DedNetAcadAppHasChildrenElements
Indica se l'elemento passato possiede figli

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildrenElements(
    FileStateElement el
)
Public Function HasChildrenElements (
    el As FileStateElement
) As Boolean
public:
virtual bool HasChildrenElements(
    FileStateElement^ el
) sealed
abstract HasChildrenElements :
        el : FileStateElement -> bool
override HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el FileStateElement
Elemento di riferimento

Valore di ritorno

Boolean

Implementa

IFileStateInformerHasChildrenElements(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.IndividuaNellaRicerca

Metodo DedNetAcadAppIndividuaNellaRicerca
Apre la ricerca nei recenti individuando l'anagrafica di una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void IndividuaNellaRicerca(
    PartInfo prt
)
Public Shared Sub IndividuaNellaRicerca (
    prt As PartInfo
)
public:
static void IndividuaNellaRicerca(
    PartInfo^ prt
)
static member IndividuaNellaRicerca :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Parte da individuare.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Initialize

Metodo DedNetAcadAppInitialize
Inizializzazione dell'add-in.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.IsDirty

Metodo DedNetAcadAppIsDirty
Ritorna vero se l'elemento passato è associato ad un documento dirty

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty(
    FileStateElement el
)
Public Function IsDirty (
    el As FileStateElement
) As Boolean
public:
virtual bool IsDirty(
    FileStateElement^ el
) sealed
abstract IsDirty :
        el : FileStateElement -> bool
override IsDirty :
        el : FileStateElement -> bool

Parametri

el FileStateElement
Elemento di riferimento

Valore di ritorno

Boolean

Implementa

IFileStateInformerIsDirty(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Log

Metodo DedNetAcadAppLog
Lista degli overload
Nome | Descrizione
Log(Exception, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
Log(ListException, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Log(Exception, Boolean)

Metodo DedNetAcadAppLog(Exception, Boolean)
Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex,
    bool silent
)
Public Shared Sub Log (
    ex As Exception,
    silent As Boolean
)
public:
static void Log(
    Exception^ ex,
    bool silent
)
static member Log :
        ex : Exception *
        silent : bool -> unit

Parametri

ex Exception
Eccezione da registrare.
silent Boolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetAcadApp
Overload di Log


Metodo DedNetAcadApp.Log(List<Exception>, Boolean)

Metodo DedNetAcadAppLog(ListException, Boolean)
Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    List<Exception> ex,
    bool silent
)
Public Shared Sub Log (
    ex As List(Of Exception),
    silent As Boolean
)
public:
static void Log(
    List<Exception^>^ ex,
    bool silent
)
static member Log :
        ex : List<Exception> *
        silent : bool -> unit

Parametri

ex List Exception
Eccezione da registrare.
silent Boolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetAcadApp
Overload di Log


Metodo DedNetAcadApp.LogInfo

Metodo DedNetAcadAppLogInfo
Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void LogInfo(
    string msg,
    bool silent
)
Public Shared Sub LogInfo (
    msg As String,
    silent As Boolean
)
public:
static void LogInfo(
    String^ msg,
    bool silent
)
static member LogInfo :
        msg : string *
        silent : bool -> unit

Parametri

msg String
Messaggio da locggare
silent Boolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.MakeAcadCommandContext

Metodo DedNetAcadAppMakeAcadCommandContext
Ritorna l'oggetto context di Inventor in base alla lista di elementi passati dal controllo delle dipendenze documentali.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAcadCommandContext MakeAcadCommandContext(
    FileStateElementList elsList
)
Public Function MakeAcadCommandContext (
    elsList As FileStateElementList
) As DedAcadCommandContext
public:
virtual DedAcadCommandContext^ MakeAcadCommandContext(
    FileStateElementList^ elsList
) sealed
abstract MakeAcadCommandContext :
        elsList : FileStateElementList -> DedAcadCommandContext
override MakeAcadCommandContext :
        elsList : FileStateElementList -> DedAcadCommandContext

Parametri

elsList FileStateElementList
Lista degli elementi da considerare per la creazione del contesto

Valore di ritorno

DedAcadCommandContext

Implementa

IFileStateInformerMakeAcadCommandContext(FileStateElementList)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnAcadRilPublishEvent

Metodo DedNetAcadAppOnAcadRilPublishEvent
Lancia evento di pubblicazione formati al rilascio in Inventor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnAcadRilPublishEvent(
    Object sender,
    DedNetAcadAppAcadRilPublishEventArgs e
)
Public Shared Sub OnAcadRilPublishEvent (
    sender As Object,
    e As DedNetAcadAppAcadRilPublishEventArgs
)
public:
static void OnAcadRilPublishEvent(
    Object^ sender,
    DedNetAcadAppAcadRilPublishEventArgs^ e
)
static member OnAcadRilPublishEvent :
        sender : Object *
        e : DedNetAcadAppAcadRilPublishEventArgs -> unit

Parametri

sender Object
Applicazione di Ded per Inventor
e DedNetAcadAppAcadRilPublishEventArgs
Argomenti specifici dell'evento
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnElementDoubleClicked

Metodo DedNetAcadAppOnElementDoubleClicked
Gestione doppio click su elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void OnElementDoubleClicked(
    FileStateElement el
)
Public Sub OnElementDoubleClicked (
    el As FileStateElement
)
public:
virtual void OnElementDoubleClicked(
    FileStateElement^ el
) sealed
abstract OnElementDoubleClicked :
        el : FileStateElement -> unit
override OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el FileStateElement

Implementa

IFileStateInformerOnElementDoubleClicked(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnElementsSelected

Metodo DedNetAcadAppOnElementsSelected
Si occupa di allineare la selezione dell'albero con la selezione dell'occorrenze a livello di documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void OnElementsSelected(
    FileStateElementList elsList
)
Public Sub OnElementsSelected (
    elsList As FileStateElementList
)
public:
virtual void OnElementsSelected(
    FileStateElementList^ elsList
) sealed
abstract OnElementsSelected :
        elsList : FileStateElementList -> unit
override OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList FileStateElementList
Lista degli elementi da considerare per la selezione

Implementa

IFileStateInformerOnElementsSelected(FileStateElementList)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnFileResolutionEvent

Metodo DedNetAcadAppOnFileResolutionEvent
Lancia l'evento di FileResolutionEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnFileResolutionEvent(
    Object sender,
    DedNetAcadAppResolutionEventArgs e
)
Public Shared Sub OnFileResolutionEvent (
    sender As Object,
    e As DedNetAcadAppResolutionEventArgs
)
public:
static void OnFileResolutionEvent(
    Object^ sender,
    DedNetAcadAppResolutionEventArgs^ e
)
static member OnFileResolutionEvent :
        sender : Object *
        e : DedNetAcadAppResolutionEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnHotTrackElementClicked

Metodo DedNetAcadAppOnHotTrackElementClicked
Gestione click singolo su elemento hottracked

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnHotTrackElementClicked(
    FileStateElement el
)
Public Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
public:
virtual bool OnHotTrackElementClicked(
    FileStateElement^ el
) sealed
abstract OnHotTrackElementClicked :
        el : FileStateElement -> bool
override OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean

Implementa

IFileStateInformerOnHotTrackElementClicked(FileStateElement)
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoAfterLoadEvent

Metodo DedNetAcadAppOnImportPackAndGoAfterLoadEvent
Lancia l'evento di ImportPackAndGoAfterLoadEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoAfterLoadEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoAfterLoadEventArgs e
)
Public Shared Sub OnImportPackAndGoAfterLoadEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoAfterLoadEventArgs
)
public:
static void OnImportPackAndGoAfterLoadEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoAfterLoadEventArgs^ e
)
static member OnImportPackAndGoAfterLoadEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoAfterLoadEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoDocAttrCompareEvent

Metodo DedNetAcadAppOnImportPackAndGoDocAttrCompareEvent
Lancia l'evento di ImportPackAndGoDocAttrCompareEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoDocAttrCompareEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs e
)
Public Shared Sub OnImportPackAndGoDocAttrCompareEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
)
public:
static void OnImportPackAndGoDocAttrCompareEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^ e
)
static member OnImportPackAndGoDocAttrCompareEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoMappingRootEvent

Metodo DedNetAcadAppOnImportPackAndGoMappingRootEvent
Lancia l'evento di ImportPackAndGoMappingRootEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoMappingRootEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoMappingRootEventArgs e
)
Public Shared Sub OnImportPackAndGoMappingRootEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoMappingRootEventArgs
)
public:
static void OnImportPackAndGoMappingRootEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoMappingRootEventArgs^ e
)
static member OnImportPackAndGoMappingRootEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoMappingRootEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoOverrideCheckOverwriteOperationEvent

Metodo DedNetAcadAppOnImportPackAndGoOverrideCheckOverwriteOperationEvent
Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoOverrideCheckOverwriteOperationEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
)
public:
static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^ e
)
static member OnImportPackAndGoOverrideCheckOverwriteOperationEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoPresetCodingOperationEvent

Metodo DedNetAcadAppOnImportPackAndGoPresetCodingOperationEvent
Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoPresetCodingOperationEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoPresetCodingOperationEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
)
public:
static void OnImportPackAndGoPresetCodingOperationEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^ e
)
static member OnImportPackAndGoPresetCodingOperationEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnSkipLayoutOnPrintingEvent

Metodo DedNetAcadAppOnSkipLayoutOnPrintingEvent
Lancia l'evento di SkipLayoutOnPrintingEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnSkipLayoutOnPrintingEvent(
    Object sender,
    DedNetAcadAppSkipLayoutOnPrintingEventArgs e
)
Public Shared Sub OnSkipLayoutOnPrintingEvent (
    sender As Object,
    e As DedNetAcadAppSkipLayoutOnPrintingEventArgs
)
public:
static void OnSkipLayoutOnPrintingEvent(
    Object^ sender,
    DedNetAcadAppSkipLayoutOnPrintingEventArgs^ e
)
static member OnSkipLayoutOnPrintingEvent :
        sender : Object *
        e : DedNetAcadAppSkipLayoutOnPrintingEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppSkipLayoutOnPrintingEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnTopPrtCreated

Metodo DedNetAcadAppOnTopPrtCreated
Evento di creazione albero parti, chiamato dal LUA dopo la creazione del documento. Viene utilizzato per aggiornare la parte Top con gli attributi presenti nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void OnTopPrtCreated(
    string fileName
)
Public Sub OnTopPrtCreated (
    fileName As String
)
public:
void OnTopPrtCreated(
    String^ fileName
)
member OnTopPrtCreated :
        fileName : string -> unit

Parametri

fileName String
Nome completo del file in apertura.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnUpdateAttribFromDbOnOpenEvent

Metodo DedNetAcadAppOnUpdateAttribFromDbOnOpenEvent
Lancia evento per la gestione dell'aggiornamento degli attributi dal Db in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnUpdateAttribFromDbOnOpenEvent(
    Object sender,
    DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs e
)
Public Shared Sub OnUpdateAttribFromDbOnOpenEvent (
    sender As Object,
    e As DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
)
public:
static void OnUpdateAttribFromDbOnOpenEvent(
    Object^ sender,
    DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^ e
)
static member OnUpdateAttribFromDbOnOpenEvent :
        sender : Object *
        e : DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnUpdateCartOnOpenEvent

Metodo DedNetAcadAppOnUpdateCartOnOpenEvent
Lancia evento per la gestione dell'aggiornamento del cartiglio in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void OnUpdateCartOnOpenEvent(
    Object sender,
    DedNetAcadAppUpdateCartOnOpenEventArgs e
)
Public Shared Sub OnUpdateCartOnOpenEvent (
    sender As Object,
    e As DedNetAcadAppUpdateCartOnOpenEventArgs
)
public:
static void OnUpdateCartOnOpenEvent(
    Object^ sender,
    DedNetAcadAppUpdateCartOnOpenEventArgs^ e
)
static member OnUpdateCartOnOpenEvent :
        sender : Object *
        e : DedNetAcadAppUpdateCartOnOpenEventArgs -> unit

Parametri

sender Object
e DedNetAcadAppUpdateCartOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.PartsTreeSelectionChanged

Metodo DedNetAcadAppPartsTreeSelectionChanged
Chiamato sul cambio selezione nell'albero delle parti, per aggiornare la finestra di visualizzazione attributi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PartsTreeSelectionChanged(
    LuaUserData prtUserData
)
Public Sub PartsTreeSelectionChanged (
    prtUserData As LuaUserData
)
public:
void PartsTreeSelectionChanged(
    LuaUserData^ prtUserData
)
member PartsTreeSelectionChanged :
        prtUserData : LuaUserData -> unit

Parametri

prtUserData LuaUserData
Parte attivata.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.PostNavigatorArgs

Metodo DedNetAcadAppPostNavigatorArgs
Imposta in una variabile globale l'array di parti da utilizzare poi nei comandi che saranno invocati tramite invio di una stringa alla riga di comando di autocad. Viene utilizzato subito prima di chiamare un comando in contesto application.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void PostNavigatorArgs(
    PartInfoArray prtArray,
    bool readOnly,
    bool lastRev
)
Public Shared Sub PostNavigatorArgs (
    prtArray As PartInfoArray,
    readOnly As Boolean,
    lastRev As Boolean
)
public:
static void PostNavigatorArgs(
    PartInfoArray^ prtArray,
    bool readOnly,
    bool lastRev
)
static member PostNavigatorArgs :
        prtArray : PartInfoArray *
        readOnly : bool *
        lastRev : bool -> unit

Parametri

prtArray PartInfoArray
Array di parti.
readOnly Boolean
Indica se aprire in sola lettura i documenti.
lastRev Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.StatoDocAcad

Metodo DedNetAcadAppStatoDocAcad
Metodo che restituisce una stringa con lo stato attuale del doccumento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string StatoDocAcad(
    QsDocument acadDoc,
    DedDoc doc,
    bool isMyPwsDocEqualsToVaultDoc
)
Public Shared Function StatoDocAcad (
    acadDoc As QsDocument,
    doc As DedDoc,
    isMyPwsDocEqualsToVaultDoc As Boolean
) As String
public:
static String^ StatoDocAcad(
    QsDocument^ acadDoc,
    DedDoc^ doc,
    bool isMyPwsDocEqualsToVaultDoc
)
static member StatoDocAcad :
        acadDoc : QsDocument *
        doc : DedDoc *
        isMyPwsDocEqualsToVaultDoc : bool -> string

Parametri

acadDoc QsDocument
doc DedDoc
isMyPwsDocEqualsToVaultDoc Boolean

Valore di ritorno

String
Stringa con lo stato attuale del documento.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Terminate

Metodo DedNetAcadAppTerminate
Termine dell'add-in.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Terminate()
Public Sub Terminate
public:
void Terminate()
member Terminate : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.UpdateStateDocPanel

Metodo DedNetAcadAppUpdateStateDocPanel
Aggiorna il pannello in base allo stato del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateStateDocPanel()
Public Shared Sub UpdateStateDocPanel
public:
static void UpdateStateDocPanel()
static member UpdateStateDocPanel : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Eventi di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Eventi
Nome | Descrizione
AcadRilPublishEvent | Evento di pubblicazione formati al rilascio in Inventor
FileResolutionEvent | Evento di risoluzione file nel caso non vengano trovati.
ImportPackAndGoAfterLoadEvent | Evento per effettuare modifiche al form dopo il caricamento dei dati.
ImportPackAndGoDocAttrCompareEvent | Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent | Evento di override del settaggio del check in caso di operazione di codifica
ImportPackAndGoPresetCodingOperationEvent |
SkipLayoutOnPrintingEvent | Evento per decidere i layout da non stamapre.
UpdateAttribFromDbOnOpenEvent | Evento per la decidere se fare l'aggiornamento degli attributi dal Db in apertura.
UpdateCartOnOpenEvent | Evento per la decidere se fare l'aggiornamento del cartiglio in apertura.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.AcadRilPublishEvent

Evento DedNetAcadAppAcadRilPublishEvent
Evento di pubblicazione formati al rilascio in Inventor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppAcadRilPublishEventArgs> AcadRilPublishEvent
Public Shared Event AcadRilPublishEvent As EventHandler(Of DedNetAcadAppAcadRilPublishEventArgs)
public:
static  event EventHandler<DedNetAcadAppAcadRilPublishEventArgs^>^ AcadRilPublishEvent {
    void add (EventHandler<DedNetAcadAppAcadRilPublishEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppAcadRilPublishEventArgs^>^ value);
}
member AcadRilPublishEvent : IEvent<EventHandler<DedNetAcadAppAcadRilPublishEventArgs>,
    DedNetAcadAppAcadRilPublishEventArgs>

Valore

EventHandler DedNetAcadAppAcadRilPublishEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.FileResolutionEvent

Evento DedNetAcadAppFileResolutionEvent
Evento di risoluzione file nel caso non vengano trovati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppResolutionEventArgs> FileResolutionEvent
Public Shared Event FileResolutionEvent As EventHandler(Of DedNetAcadAppResolutionEventArgs)
public:
static  event EventHandler<DedNetAcadAppResolutionEventArgs^>^ FileResolutionEvent {
    void add (EventHandler<DedNetAcadAppResolutionEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppResolutionEventArgs^>^ value);
}
member FileResolutionEvent : IEvent<EventHandler<DedNetAcadAppResolutionEventArgs>,
    DedNetAcadAppResolutionEventArgs>

Valore

EventHandler DedNetAcadAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoAfterLoadEvent

Evento DedNetAcadAppImportPackAndGoAfterLoadEvent
Evento per effettuare modifiche al form dopo il caricamento dei dati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs> ImportPackAndGoAfterLoadEvent
Public Shared Event ImportPackAndGoAfterLoadEvent As EventHandler(Of DedNetAcadAppImportPackAndGoAfterLoadEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs^>^ ImportPackAndGoAfterLoadEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs^>^ value);
}
member ImportPackAndGoAfterLoadEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs>,
    DedNetAcadAppImportPackAndGoAfterLoadEventArgs>

Valore

EventHandler DedNetAcadAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoDocAttrCompareEvent

Evento DedNetAcadAppImportPackAndGoDocAttrCompareEvent
Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs> ImportPackAndGoDocAttrCompareEvent
Public Shared Event ImportPackAndGoDocAttrCompareEvent As EventHandler(Of DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^>^ ImportPackAndGoDocAttrCompareEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
}
member ImportPackAndGoDocAttrCompareEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs>,
    DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs>

Valore

EventHandler DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoMappingRootEvent

Evento DedNetAcadAppImportPackAndGoMappingRootEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs> ImportPackAndGoMappingRootEvent
Public Shared Event ImportPackAndGoMappingRootEvent As EventHandler(Of DedNetAcadAppImportPackAndGoMappingRootEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs^>^ ImportPackAndGoMappingRootEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs^>^ value);
}
member ImportPackAndGoMappingRootEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs>,
    DedNetAcadAppImportPackAndGoMappingRootEventArgs>

Valore

EventHandler DedNetAcadAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEvent

Evento DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEvent
Evento di override del settaggio del check in caso di operazione di codifica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs> ImportPackAndGoOverrideCheckOverwriteOperationEvent
Public Shared Event ImportPackAndGoOverrideCheckOverwriteOperationEvent As EventHandler(Of DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ ImportPackAndGoOverrideCheckOverwriteOperationEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
}
member ImportPackAndGoOverrideCheckOverwriteOperationEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>,
    DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>

Valore

EventHandler DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoPresetCodingOperationEvent

Evento DedNetAcadAppImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs> ImportPackAndGoPresetCodingOperationEvent
Public Shared Event ImportPackAndGoPresetCodingOperationEvent As EventHandler(Of DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^>^ ImportPackAndGoPresetCodingOperationEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
}
member ImportPackAndGoPresetCodingOperationEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs>,
    DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs>

Valore

EventHandler DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.SkipLayoutOnPrintingEvent

Evento DedNetAcadAppSkipLayoutOnPrintingEvent
Evento per decidere i layout da non stamapre.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppSkipLayoutOnPrintingEventArgs> SkipLayoutOnPrintingEvent
Public Shared Event SkipLayoutOnPrintingEvent As EventHandler(Of DedNetAcadAppSkipLayoutOnPrintingEventArgs)
public:
static  event EventHandler<DedNetAcadAppSkipLayoutOnPrintingEventArgs^>^ SkipLayoutOnPrintingEvent {
    void add (EventHandler<DedNetAcadAppSkipLayoutOnPrintingEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppSkipLayoutOnPrintingEventArgs^>^ value);
}
member SkipLayoutOnPrintingEvent : IEvent<EventHandler<DedNetAcadAppSkipLayoutOnPrintingEventArgs>,
    DedNetAcadAppSkipLayoutOnPrintingEventArgs>

Valore

EventHandler DedNetAcadAppSkipLayoutOnPrintingEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.UpdateAttribFromDbOnOpenEvent

Evento DedNetAcadAppUpdateAttribFromDbOnOpenEvent
Evento per la decidere se fare l'aggiornamento degli attributi dal Db in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs> UpdateAttribFromDbOnOpenEvent
Public Shared Event UpdateAttribFromDbOnOpenEvent As EventHandler(Of DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs)
public:
static  event EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^>^ UpdateAttribFromDbOnOpenEvent {
    void add (EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^>^ value);
}
member UpdateAttribFromDbOnOpenEvent : IEvent<EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs>,
    DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs>

Valore

EventHandler DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.UpdateCartOnOpenEvent

Evento DedNetAcadAppUpdateCartOnOpenEvent
Evento per la decidere se fare l'aggiornamento del cartiglio in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs> UpdateCartOnOpenEvent
Public Shared Event UpdateCartOnOpenEvent As EventHandler(Of DedNetAcadAppUpdateCartOnOpenEventArgs)
public:
static  event EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs^>^ UpdateCartOnOpenEvent {
    void add (EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs^>^ value);
}
member UpdateCartOnOpenEvent : IEvent<EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs>,
    DedNetAcadAppUpdateCartOnOpenEventArgs>

Valore

EventHandler DedNetAcadAppUpdateCartOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Campi di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Campi
Nome | Descrizione
DedNetAcadDataRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.
DedNetAcadDocRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver del documento stesso utilizzata per conoscere la versione del documento in modalità detached.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Campo DedNetAcadApp.DedNetAcadDataRowVerString

Campo DedNetAcadAppDedNetAcadDataRowVerString
Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string DedNetAcadDataRowVerString = "DedNetAcadDataRowVer"
Public Const DedNetAcadDataRowVerString As String = "DedNetAcadDataRowVer"
public:
literal String^ DedNetAcadDataRowVerString = "DedNetAcadDataRowVer"
static val mutable DedNetAcadDataRowVerString: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetAcadApp


Campo DedNetAcadApp.DedNetAcadDocRowVerString

Campo DedNetAcadAppDedNetAcadDocRowVerString
Nome della chiave del dizionario documento nella quale è presente il rowver del documento stesso utilizzata per conoscere la versione del documento in modalità detached.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string DedNetAcadDocRowVerString = "DedNetAcadDocRowVer"
Public Const DedNetAcadDocRowVerString As String = "DedNetAcadDocRowVer"
public:
literal String^ DedNetAcadDocRowVerString = "DedNetAcadDocRowVer"
static val mutable DedNetAcadDocRowVerString: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetAcadApp


Classe DedNetAcadApp.AcadRilPublishEventArgs

Classe DedNetAcadAppAcadRilPublishEventArgs
Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetAcadDedNetAcadAppAcadRilPublishEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class AcadRilPublishEventArgs : DedEventArgs
Public Class AcadRilPublishEventArgs
    Inherits DedEventArgs
public ref class AcadRilPublishEventArgs : public DedEventArgs
type AcadRilPublishEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetAcadAppAcadRilPublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppAcadRilPublishEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationManager | Restituisce il documento di Autocad oggetto di pubblicazione
Proprietà pubblica | PublishingAcadDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.AcadRilPublishEventArgs

Costruttore DedNetAcadAppAcadRilPublishEventArgs
Costruttore. Salva gli argomenti nei campi

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public AcadRilPublishEventArgs(
    StateCommandEventArgs stateCmdArgs,
    QsDocument pubDoc,
    DedPublicationManager pubMan
)
Public Sub New (
    stateCmdArgs As StateCommandEventArgs,
    pubDoc As QsDocument,
    pubMan As DedPublicationManager
)
public:
AcadRilPublishEventArgs(
    StateCommandEventArgs^ stateCmdArgs,
    QsDocument^ pubDoc,
    DedPublicationManager^ pubMan
)
new :
        stateCmdArgs : StateCommandEventArgs *
        pubDoc : QsDocument *
        pubMan : DedPublicationManager -> AcadRilPublishEventArgs

Parametri

stateCmdArgs StateCommandEventArgs
pubDoc QsDocument
pubMan DedPublicationManager
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà di AcadRilPublishEventArgs

Il tipo DedNetAcadAppAcadRilPublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationManager | Restituisce il documento di Autocad oggetto di pubblicazione
Proprietà pubblica | PublishingAcadDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.Data

Proprietà DedNetAcadAppAcadRilPublishEventArgsData
Restituisce l'anagrafica associata al documento in elaborazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.Document

Proprietà DedNetAcadAppAcadRilPublishEventArgsDocument
Restituisce il documento in elaborazione dal comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.PublicationManager

Proprietà DedNetAcadAppAcadRilPublishEventArgsPublicationManager
Restituisce il documento di Autocad oggetto di pubblicazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager PublicationManager { get; }
Public ReadOnly Property PublicationManager As DedPublicationManager
    Get
public:
property DedPublicationManager^ PublicationManager {
    DedPublicationManager^ get ();
}
member PublicationManager : DedPublicationManager with get

Valore della proprietà

DedPublicationManager
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.PublishingAcadDoc

Proprietà DedNetAcadAppAcadRilPublishEventArgsPublishingAcadDoc
Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsDocument PublishingAcadDoc { get; }
Public ReadOnly Property PublishingAcadDoc As QsDocument
    Get
public:
property QsDocument^ PublishingAcadDoc {
    QsDocument^ get ();
}
member PublishingAcadDoc : QsDocument with get

Valore della proprietà

QsDocument
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Classe DedNetAcadApp.ImportPackAndGoAfterLoadEventArgs

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs
Argomento usato per effettuare modifiche al form dopo caricamento nodi.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoAfterLoadEventArgs : EventArgs
Public Class ImportPackAndGoAfterLoadEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoAfterLoadEventArgs : public EventArgs
type ImportPackAndGoAfterLoadEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoAfterLoadEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoAfterLoadEventArgs

Costruttore DedNetAcadAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoAfterLoadEventArgs(
    DedAcadPackAndGoImportForm frm
)
Public Sub New (
    frm As DedAcadPackAndGoImportForm
)
public:
ImportPackAndGoAfterLoadEventArgs(
    DedAcadPackAndGoImportForm^ frm
)
new :
        frm : DedAcadPackAndGoImportForm -> ImportPackAndGoAfterLoadEventArgs

Parametri

frm DedAcadPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs


Proprietà di ImportPackAndGoAfterLoadEventArgs

Il tipo DedNetAcadAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoAfterLoadEventArgs.Frm

Proprietà DedNetAcadAppImportPackAndGoAfterLoadEventArgsFrm

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAcadPackAndGoImportForm Frm { get; set; }
Public Property Frm As DedAcadPackAndGoImportForm
    Get
    Set
public:
property DedAcadPackAndGoImportForm^ Frm {
    DedAcadPackAndGoImportForm^ get ();
    void set (DedAcadPackAndGoImportForm^ value);
}
member Frm : DedAcadPackAndGoImportForm with get, set

Valore della proprietà

DedAcadPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs


Classe DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Argomento usato per gestire la comparazione degli attributi nelle azioni che lo richiedono
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoDocAttrCompareEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoDocAttrCompareEventArgs : DedEventArgs
Public Class ImportPackAndGoDocAttrCompareEventArgs
    Inherits DedEventArgs
public ref class ImportPackAndGoDocAttrCompareEventArgs : public DedEventArgs
type ImportPackAndGoDocAttrCompareEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Ritorna l'anagrafica associata al nodo
Proprietà pubblica | DataDoc | Ritorna il DedDataPart associato al documento
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs)
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Proprietà pubblica | UsesDocValues | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs

Costruttore DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp,
    DedData data,
    DedDataPart dataDoc
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper,
    data As DedData,
    dataDoc As DedDataPart
)
public:
ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp,
    DedData^ data,
    DedDataPart^ dataDoc
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper *
        data : DedData *
        dataDoc : DedDataPart -> ImportPackAndGoDocAttrCompareEventArgs

Parametri

dedcase PackAndGoImportDedCases
dbMaster Boolean
pckNodeWrp PackAndGoNodeWrapper
data DedData
dataDoc DedDataPart
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà di ImportPackAndGoDocAttrCompareEventArgs

Il tipo DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Ritorna l'anagrafica associata al nodo
Proprietà pubblica | DataDoc | Ritorna il DedDataPart associato al documento
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs)
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Proprietà pubblica | UsesDocValues | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.Data

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsData
Ritorna l'anagrafica associata al nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.DataDoc

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsDataDoc
Ritorna il DedDataPart associato al documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DataDoc { get; }
Public ReadOnly Property DataDoc As DedDataPart
    Get
public:
property DedDataPart^ DataDoc {
    DedDataPart^ get ();
}
member DataDoc : DedDataPart with get

Valore della proprietà

DedDataPart
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.DbMaster

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsDbMaster
Ritorna verso se il db è master nel contesto dell'importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.DedCase

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsDedCase
Ritorna la tipologia di importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.PackAndGoNodeWrapper

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsPackAndGoNodeWrapper
Wrapper associato all'evento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.UsesDocValues

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsUsesDocValues
Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool UsesDocValues { get; set; }
Public Property UsesDocValues As Boolean
    Get
    Set
public:
property bool UsesDocValues {
    bool get ();
    void set (bool value);
}
member UsesDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Classe DedNetAcadApp.ImportPackAndGoMappingRootEventArgs

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoMappingRootEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoMappingRootEventArgs : EventArgs
Public Class ImportPackAndGoMappingRootEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoMappingRootEventArgs : public EventArgs
type ImportPackAndGoMappingRootEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoMappingRootEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoMappingRootEventArgs

Costruttore DedNetAcadAppImportPackAndGoMappingRootEventArgs
Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject> ipjPaths
)
Public Sub New (
    ipjPaths As List(Of MappingRootObject)
)
public:
ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject^>^ ipjPaths
)
new :
        ipjPaths : List<MappingRootObject> -> ImportPackAndGoMappingRootEventArgs

Parametri

ipjPaths List MappingRootObject
Mappatura root.
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs


Proprietà di ImportPackAndGoMappingRootEventArgs

Il tipo DedNetAcadAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoMappingRootEventArgs.IpjPaths

Proprietà DedNetAcadAppImportPackAndGoMappingRootEventArgsIpjPaths

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<MappingRootObject> IpjPaths { get; set; }
Public Property IpjPaths As List(Of MappingRootObject)
    Get
    Set
public:
property List<MappingRootObject^>^ IpjPaths {
    List<MappingRootObject^>^ get ();
    void set (List<MappingRootObject^>^ value);
}
member IpjPaths : List<MappingRootObject> with get, set

Valore della proprietà

List MappingRootObject
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs


Classe DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : EventArgs
Public Class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : public EventArgs
type ImportPackAndGoOverrideCheckOverwriteOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | OverrideCheck | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Costruttore DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper
)
public:
ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper -> ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Parametri

dedcase PackAndGoImportDedCases
dbMaster Boolean
pckNodeWrp PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà di ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Il tipo DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | OverrideCheck | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DbMaster

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDbMaster
Ritorna verso se il db è master nel contesto dell'importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DedCase

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDedCase
Ritorna la tipologia di importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.OverrideCheck

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsOverrideCheck
Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OverrideCheck { get; set; }
Public Property OverrideCheck As Boolean
    Get
    Set
public:
property bool OverrideCheck {
    bool get ();
    void set (bool value);
}
member OverrideCheck : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.PackAndGoNodeWrapper

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsPackAndGoNodeWrapper
Wrapper associato all'evento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Classe DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoPresetCodingOperationEventArgs : EventArgs
Public Class ImportPackAndGoPresetCodingOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoPresetCodingOperationEventArgs : public EventArgs
type ImportPackAndGoPresetCodingOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica da associare al documento in importazione.
Proprietà pubblica | DedCase | Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )
Proprietà pubblica | DedType | Famiglia nel quale codificare il documento.
Proprietà pubblica | DestRoot | Nome della root nella quale posizionare il file ( nel caso clona o libreria )
Proprietà pubblica | DizAttr | Dizionario con attributi ( prompt,valore )
Proprietà pubblica | Fullfilename | Nome del file in importazione
Proprietà pubblica | InfoUser | Tassello utente da utilizzare.
Proprietà pubblica | NewFullFileName | Nuovo file da utilizzare nel caso di operazione di Salta.
Proprietà pubblica | Operation | Operazione da effettuare sul file
Proprietà pubblica | Progr | Progressivo da utilizzare.
Proprietà pubblica | Rev | Revisione da utilizzare.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs

Costruttore DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoPresetCodingOperationEventArgs(
    string fullfilename,
    Dictionary<string, Object> dizAttr
)
Public Sub New (
    fullfilename As String,
    dizAttr As Dictionary(Of String, Object)
)
public:
ImportPackAndGoPresetCodingOperationEventArgs(
    String^ fullfilename,
    Dictionary<String^, Object^>^ dizAttr
)
new :
        fullfilename : string *
        dizAttr : Dictionary<string, Object> -> ImportPackAndGoPresetCodingOperationEventArgs

Parametri

fullfilename String
Filename del documento in importazione.
dizAttr Dictionary String, Object
Dizionario contenete attributi documento.
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà di ImportPackAndGoPresetCodingOperationEventArgs

Il tipo DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica da associare al documento in importazione.
Proprietà pubblica | DedCase | Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )
Proprietà pubblica | DedType | Famiglia nel quale codificare il documento.
Proprietà pubblica | DestRoot | Nome della root nella quale posizionare il file ( nel caso clona o libreria )
Proprietà pubblica | DizAttr | Dizionario con attributi ( prompt,valore )
Proprietà pubblica | Fullfilename | Nome del file in importazione
Proprietà pubblica | InfoUser | Tassello utente da utilizzare.
Proprietà pubblica | NewFullFileName | Nuovo file da utilizzare nel caso di operazione di Salta.
Proprietà pubblica | Operation | Operazione da effettuare sul file
Proprietà pubblica | Progr | Progressivo da utilizzare.
Proprietà pubblica | Rev | Revisione da utilizzare.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Data

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsData
Anagrafica da associare al documento in importazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DedCase

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDedCase
Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DedType

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDedType
Famiglia nel quale codificare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DestRoot

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDestRoot
Nome della root nella quale posizionare il file ( nel caso clona o libreria )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DizAttr

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDizAttr
Dizionario con attributi ( prompt,valore )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DizAttr { get; }
Public ReadOnly Property DizAttr As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ DizAttr {
    Dictionary<String^, Object^>^ get ();
}
member DizAttr : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Fullfilename

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsFullfilename
Nome del file in importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Fullfilename { get; }
Public ReadOnly Property Fullfilename As String
    Get
public:
property String^ Fullfilename {
    String^ get ();
}
member Fullfilename : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.InfoUser

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsInfoUser
Tassello utente da utilizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.NewFullFileName

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsNewFullFileName
Nuovo file da utilizzare nel caso di operazione di Salta.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Operation

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsOperation
Operazione da effettuare sul file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation Operation { get; set; }
Public Property Operation As PackAndGoImportOperation
    Get
    Set
public:
property PackAndGoImportOperation Operation {
    PackAndGoImportOperation get ();
    void set (PackAndGoImportOperation value);
}
member Operation : PackAndGoImportOperation with get, set

Valore della proprietà

PackAndGoImportOperation
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Progr

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsProgr
Progressivo da utilizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Rev

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsRev
Revisione da utilizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Classe DedNetAcadApp.ResolutionEventArgs

Classe DedNetAcadAppResolutionEventArgs
Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppResolutionEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ResolutionEventArgs : EventArgs
Public Class ResolutionEventArgs
    Inherits EventArgs
public ref class ResolutionEventArgs : public EventArgs
type ResolutionEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppResolutionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppResolutionEventArgs | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName | Nome del file non trovato
Proprietà pubblica | SostFileName | Nuovo file da sostituire
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ResolutionEventArgs

Costruttore DedNetAcadAppResolutionEventArgs
Costruttore.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ResolutionEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
ResolutionEventArgs(
    String^ fileName
)
new :
        fileName : string -> ResolutionEventArgs

Parametri

fileName String
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Proprietà di ResolutionEventArgs

Il tipo DedNetAcadAppResolutionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName | Nome del file non trovato
Proprietà pubblica | SostFileName | Nuovo file da sostituire
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Proprietà DedNetAcadApp.ResolutionEventArgs.FileName

Proprietà DedNetAcadAppResolutionEventArgsFileName
Nome del file non trovato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Proprietà DedNetAcadApp.ResolutionEventArgs.SostFileName

Proprietà DedNetAcadAppResolutionEventArgsSostFileName
Nuovo file da sostituire

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string SostFileName { get; set; }
Public Property SostFileName As String
    Get
    Set
public:
property String^ SostFileName {
    String^ get ();
    void set (String^ value);
}
member SostFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Classe DedNetAcadApp.SkipLayoutOnPrintingEventArgs

Classe DedNetAcadAppSkipLayoutOnPrintingEventArgs
Argomento usato per decidere quali layou skippare in fase di stampa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppSkipLayoutOnPrintingEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SkipLayoutOnPrintingEventArgs : EventArgs
Public Class SkipLayoutOnPrintingEventArgs
    Inherits EventArgs
public ref class SkipLayoutOnPrintingEventArgs : public EventArgs
type SkipLayoutOnPrintingEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppSkipLayoutOnPrintingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppSkipLayoutOnPrintingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Layout |
Proprietà pubblica | PrintInfo |
Proprietà pubblica | ToSkip |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.SkipLayoutOnPrintingEventArgs

Costruttore DedNetAcadAppSkipLayoutOnPrintingEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public SkipLayoutOnPrintingEventArgs(
    LuaTable printInfo,
    Layout btr
)
Public Sub New (
    printInfo As LuaTable,
    btr As Layout
)
public:
SkipLayoutOnPrintingEventArgs(
    LuaTable^ printInfo,
    Layout^ btr
)
new :
        printInfo : LuaTable *
        btr : Layout -> SkipLayoutOnPrintingEventArgs

Parametri

printInfo LuaTable
btr Layout
Vedi anche

Documentazione

Classe DedNetAcadAppSkipLayoutOnPrintingEventArgs


Proprietà di SkipLayoutOnPrintingEventArgs

Il tipo DedNetAcadAppSkipLayoutOnPrintingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Layout |
Proprietà pubblica | PrintInfo |
Proprietà pubblica | ToSkip |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppSkipLayoutOnPrintingEventArgs


Proprietà DedNetAcadApp.SkipLayoutOnPrintingEventArgs.Layout

Proprietà DedNetAcadAppSkipLayoutOnPrintingEventArgsLayout

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Layout Layout { get; set; }
Public Property Layout As Layout
    Get
    Set
public:
property Layout^ Layout {
    Layout^ get ();
    void set (Layout^ value);
}
member Layout : Layout with get, set

Valore della proprietà

Layout
Vedi anche

Documentazione

Classe DedNetAcadAppSkipLayoutOnPrintingEventArgs


Proprietà DedNetAcadApp.SkipLayoutOnPrintingEventArgs.PrintInfo

Proprietà DedNetAcadAppSkipLayoutOnPrintingEventArgsPrintInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public LuaTable PrintInfo { get; set; }
Public Property PrintInfo As LuaTable
    Get
    Set
public:
property LuaTable^ PrintInfo {
    LuaTable^ get ();
    void set (LuaTable^ value);
}
member PrintInfo : LuaTable with get, set

Valore della proprietà

LuaTable
Vedi anche

Documentazione

Classe DedNetAcadAppSkipLayoutOnPrintingEventArgs


Proprietà DedNetAcadApp.SkipLayoutOnPrintingEventArgs.ToSkip

Proprietà DedNetAcadAppSkipLayoutOnPrintingEventArgsToSkip

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToSkip { get; set; }
Public Property ToSkip As Boolean
    Get
    Set
public:
property bool ToSkip {
    bool get ();
    void set (bool value);
}
member ToSkip : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppSkipLayoutOnPrintingEventArgs


Classe DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppUpdateAttribFromDbOnOpenEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateAttribFromDbOnOpenEventArgs : EventArgs
Public Class UpdateAttribFromDbOnOpenEventArgs
    Inherits EventArgs
public ref class UpdateAttribFromDbOnOpenEventArgs : public EventArgs
type UpdateAttribFromDbOnOpenEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs

Costruttore DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateAttribFromDbOnOpenEventArgs(
    DedData data,
    PartInfo prt
)
Public Sub New (
    data As DedData,
    prt As PartInfo
)
public:
UpdateAttribFromDbOnOpenEventArgs(
    DedData^ data,
    PartInfo^ prt
)
new :
        data : DedData *
        prt : PartInfo -> UpdateAttribFromDbOnOpenEventArgs

Parametri

data DedData
prt PartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà di UpdateAttribFromDbOnOpenEventArgs

Il tipo DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs.DedData

Proprietà DedNetAcadAppUpdateAttribFromDbOnOpenEventArgsDedData
Restituisce il percorso del file del quale visualizzare l'anteprima.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DedData { get; set; }
Public Property DedData As DedData
    Get
    Set
public:
property DedData^ DedData {
    DedData^ get ();
    void set (DedData^ value);
}
member DedData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs.HandlingCode

Proprietà DedNetAcadAppUpdateAttribFromDbOnOpenEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs.PrtInfo

Proprietà DedNetAcadAppUpdateAttribFromDbOnOpenEventArgsPrtInfo
Restituisce l'estensione del file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtInfo { get; set; }
Public Property PrtInfo As PartInfo
    Get
    Set
public:
property PartInfo^ PrtInfo {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtInfo : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Classe DedNetAcadApp.UpdateCartOnOpenEventArgs

Classe DedNetAcadAppUpdateCartOnOpenEventArgs
Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppUpdateCartOnOpenEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateCartOnOpenEventArgs : EventArgs
Public Class UpdateCartOnOpenEventArgs
    Inherits EventArgs
public ref class UpdateCartOnOpenEventArgs : public EventArgs
type UpdateCartOnOpenEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppUpdateCartOnOpenEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppUpdateCartOnOpenEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.UpdateCartOnOpenEventArgs

Costruttore DedNetAcadAppUpdateCartOnOpenEventArgs
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateCartOnOpenEventArgs(
    DedData data,
    PartInfo prt
)
Public Sub New (
    data As DedData,
    prt As PartInfo
)
public:
UpdateCartOnOpenEventArgs(
    DedData^ data,
    PartInfo^ prt
)
new :
        data : DedData *
        prt : PartInfo -> UpdateCartOnOpenEventArgs

Parametri

data DedData
prt PartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà di UpdateCartOnOpenEventArgs

Il tipo DedNetAcadAppUpdateCartOnOpenEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateCartOnOpenEventArgs.DedData

Proprietà DedNetAcadAppUpdateCartOnOpenEventArgsDedData
Restituisce il percorso del file del quale visualizzare l'anteprima.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DedData { get; set; }
Public Property DedData As DedData
    Get
    Set
public:
property DedData^ DedData {
    DedData^ get ();
    void set (DedData^ value);
}
member DedData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateCartOnOpenEventArgs.HandlingCode

Proprietà DedNetAcadAppUpdateCartOnOpenEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateCartOnOpenEventArgs.PrtInfo

Proprietà DedNetAcadAppUpdateCartOnOpenEventArgsPrtInfo
Restituisce l'estensione del file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtInfo { get; set; }
Public Property PrtInfo As PartInfo
    Get
    Set
public:
property PartInfo^ PrtInfo {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtInfo : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Classe DedNetAcadCommands
Classe di definizione dei comandi.
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadCommands

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedNetAcadCommands
Public Class DedNetAcadCommands
public ref class DedNetAcadCommands
type DedNetAcadCommands = class end

Il tipo DedNetAcadCommands espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadCommands |
Torna su
Metodi
Nome | Descrizione
ApriDwgDaDb | Apre tutti i DWG delle parti selezionate nel Navigator. Presuppone che siano stati impostati i parametri con la funzione PostNavigatorArgs().
DedAbout | Apre la finestra di help.
DedAcadChangeState | Comando di cambio stato.
DedAcadChangeStateMultiple | Comando di cambio stato multiplo.
DedAcadCreateSparePartDrawing | Crea tavola ricambi.
DedAcadForceMarker | Forza l'allineamento del marker
DedAcadMarkerInfo | Visualizza lo stato del marker
DedAcadPublishSparePartDrawing | Pubblica tavola ricambi.
DedAnnullaCheckOut |
DedApriAllegati | Apre il file allegato oppure visualizza la finestra di selezione file allegati.
DedApriAssociati | Apre il file associato oppure visualizza la finestra di selezione file associati.
DedApriLettura | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in lettura.
DedApriModifica | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in modifica.
DedArchiviaDoc | Archivia il documento correntemente aperto nel percorso selezionato dall'utente.
DedArchiviaDocPrt | Archivia la parte correntemente attiva nel percorso selezionato dall'utente.
DedAssociaDoc | Salva il documento correntemente aperto associandolo ad un'anagrafica già presente nel Database.
DedAssociaDocPrt | Associa la parte correntemente attiva ad un'anagrafica già presente nel Database.
DedCambiaPwd | Finestra che permette di modificare la password dell'utente connesso.
DedCheckIn |
DedCheckOldRev | Controlla e permette di aggiornare le revisioni superate.
DedCheckOut | Mette in check-out il documento attivo.
DedComm | Lancia l'editor delle commesse.
DedCreaAnagr | Salva il documento correntemente aperto nel Database con un nuovo codice.
DedCreaAnagrPrt | Salva la parte correntemente attiva nel Database con un nuovo codice.
DedCreaRev | Salva il documento correntemente aperto con nuova revisione.
DedCreaVariante | Salva una variante del documento correntemente aperto.
DedCreaVariantePrt | Salva una variante della parte correntemente attiva.
DedDistEdit | Lancia l'editor della distinta con l'eventuale codice in editazione.
DedDistEspl | Visualizza la distinta esplosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistImpl | Visualizza la distinta implosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDistSave(LuaTable) | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDocRecognizer | Lancia il riconoscitore massivo di documenti
DedDocRegister | Lancia il comando per registrare il documento attivo
DedECO | Lancia l'editor degli ECO.
DedEseguiLua | Apre la finestra di esecuzione codice LUA.
DedGestioneXref | Apre il file allegato oppure visualizza la finestra di selezione file allegati.
DedHelp | Apre la finestra di help.
DedIntroduction | Apre la finestra principale della ricerca.
DedLavMulti | Effettua la lavorazione multipla del documento attivo.
DedLogIn | Comando che permette di cambiare utente all'interno del CAD.
DedModificaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedPackAndGoExport | Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo
DedPackAndGoImport | Esegue l'importazione di un pacchetto di file
DedPubblica |
DedPwsCache |
DedRicerca | Apre la finestra principale della ricerca.
DedRicercaDocumentale | Apre la finestra della ricerca documentale.
DedRicercaNew | Apre la finestra principale della ricerca.
DedRil | Rilascia l'anagrafica associata al documento correntemente attivo.
DedRilMulti | Effettua il rilascio multiplo del documento attivo.
DedSalvaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedSblocca |
DedStatoDoc | Visualizza lo stato dell'anagrafica e del documento correntemente attivo.
DedUnRil | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadCommands

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetAcadCommands()
Public Sub New
public:
DedNetAcadCommands()
new : unit -> DedNetAcadCommands
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodi di DedNetAcadCommands

Il tipo DedNetAcadCommands espone i seguenti membri.

Metodi
Nome | Descrizione
ApriDwgDaDb | Apre tutti i DWG delle parti selezionate nel Navigator. Presuppone che siano stati impostati i parametri con la funzione PostNavigatorArgs().
DedAbout | Apre la finestra di help.
DedAcadChangeState | Comando di cambio stato.
DedAcadChangeStateMultiple | Comando di cambio stato multiplo.
DedAcadCreateSparePartDrawing | Crea tavola ricambi.
DedAcadForceMarker | Forza l'allineamento del marker
DedAcadMarkerInfo | Visualizza lo stato del marker
DedAcadPublishSparePartDrawing | Pubblica tavola ricambi.
DedAnnullaCheckOut |
DedApriAllegati | Apre il file allegato oppure visualizza la finestra di selezione file allegati.
DedApriAssociati | Apre il file associato oppure visualizza la finestra di selezione file associati.
DedApriLettura | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in lettura.
DedApriModifica | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in modifica.
DedArchiviaDoc | Archivia il documento correntemente aperto nel percorso selezionato dall'utente.
DedArchiviaDocPrt | Archivia la parte correntemente attiva nel percorso selezionato dall'utente.
DedAssociaDoc | Salva il documento correntemente aperto associandolo ad un'anagrafica già presente nel Database.
DedAssociaDocPrt | Associa la parte correntemente attiva ad un'anagrafica già presente nel Database.
DedCambiaPwd | Finestra che permette di modificare la password dell'utente connesso.
DedCheckIn |
DedCheckOldRev | Controlla e permette di aggiornare le revisioni superate.
DedCheckOut | Mette in check-out il documento attivo.
DedComm | Lancia l'editor delle commesse.
DedCreaAnagr | Salva il documento correntemente aperto nel Database con un nuovo codice.
DedCreaAnagrPrt | Salva la parte correntemente attiva nel Database con un nuovo codice.
DedCreaRev | Salva il documento correntemente aperto con nuova revisione.
DedCreaVariante | Salva una variante del documento correntemente aperto.
DedCreaVariantePrt | Salva una variante della parte correntemente attiva.
DedDistEdit | Lancia l'editor della distinta con l'eventuale codice in editazione.
DedDistEspl | Visualizza la distinta esplosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistImpl | Visualizza la distinta implosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDistSave(LuaTable) | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDocRecognizer | Lancia il riconoscitore massivo di documenti
DedDocRegister | Lancia il comando per registrare il documento attivo
DedECO | Lancia l'editor degli ECO.
DedEseguiLua | Apre la finestra di esecuzione codice LUA.
DedGestioneXref | Apre il file allegato oppure visualizza la finestra di selezione file allegati.
DedHelp | Apre la finestra di help.
DedIntroduction | Apre la finestra principale della ricerca.
DedLavMulti | Effettua la lavorazione multipla del documento attivo.
DedLogIn | Comando che permette di cambiare utente all'interno del CAD.
DedModificaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedPackAndGoExport | Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo
DedPackAndGoImport | Esegue l'importazione di un pacchetto di file
DedPubblica |
DedPwsCache |
DedRicerca | Apre la finestra principale della ricerca.
DedRicercaDocumentale | Apre la finestra della ricerca documentale.
DedRicercaNew | Apre la finestra principale della ricerca.
DedRil | Rilascia l'anagrafica associata al documento correntemente attivo.
DedRilMulti | Effettua il rilascio multiplo del documento attivo.
DedSalvaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedSblocca |
DedStatoDoc | Visualizza lo stato dell'anagrafica e del documento correntemente attivo.
DedUnRil | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.ApriDwgDaDb

Metodo DedNetAcadCommandsApriDwgDaDb
Apre tutti i DWG delle parti selezionate nel Navigator. Presuppone che siano stati impostati i parametri con la funzione PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ApriDwgDaDb()
Public Shared Sub ApriDwgDaDb
public:
static void ApriDwgDaDb()
static member ApriDwgDaDb : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAbout

Metodo DedNetAcadCommandsDedAbout
Apre la finestra di help.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAbout()
Public Shared Sub DedAbout
public:
static void DedAbout()
static member DedAbout : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadChangeState

Metodo DedNetAcadCommandsDedAcadChangeState
Comando di cambio stato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadChangeState()
Public Shared Sub DedAcadChangeState
public:
static void DedAcadChangeState()
static member DedAcadChangeState : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadChangeStateMultiple

Metodo DedNetAcadCommandsDedAcadChangeStateMultiple
Comando di cambio stato multiplo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadChangeStateMultiple()
Public Shared Sub DedAcadChangeStateMultiple
public:
static void DedAcadChangeStateMultiple()
static member DedAcadChangeStateMultiple : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadCreateSparePartDrawing

Metodo DedNetAcadCommandsDedAcadCreateSparePartDrawing
Crea tavola ricambi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadCreateSparePartDrawing()
Public Shared Sub DedAcadCreateSparePartDrawing
public:
static void DedAcadCreateSparePartDrawing()
static member DedAcadCreateSparePartDrawing : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadForceMarker

Metodo DedNetAcadCommandsDedAcadForceMarker
Forza l'allineamento del marker

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadForceMarker()
Public Shared Sub DedAcadForceMarker
public:
static void DedAcadForceMarker()
static member DedAcadForceMarker : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadMarkerInfo

Metodo DedNetAcadCommandsDedAcadMarkerInfo
Visualizza lo stato del marker

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadMarkerInfo()
Public Shared Sub DedAcadMarkerInfo
public:
static void DedAcadMarkerInfo()
static member DedAcadMarkerInfo : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadPublishSparePartDrawing

Metodo DedNetAcadCommandsDedAcadPublishSparePartDrawing
Pubblica tavola ricambi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadPublishSparePartDrawing()
Public Shared Sub DedAcadPublishSparePartDrawing
public:
static void DedAcadPublishSparePartDrawing()
static member DedAcadPublishSparePartDrawing : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAnnullaCheckOut

Metodo DedNetAcadCommandsDedAnnullaCheckOut

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAnnullaCheckOut()
Public Shared Sub DedAnnullaCheckOut
public:
static void DedAnnullaCheckOut()
static member DedAnnullaCheckOut : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriAllegati

Metodo DedNetAcadCommandsDedApriAllegati
Apre il file allegato oppure visualizza la finestra di selezione file allegati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriAllegati()
Public Shared Sub DedApriAllegati
public:
static void DedApriAllegati()
static member DedApriAllegati : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriAssociati

Metodo DedNetAcadCommandsDedApriAssociati
Apre il file associato oppure visualizza la finestra di selezione file associati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriAssociati()
Public Shared Sub DedApriAssociati
public:
static void DedApriAssociati()
static member DedApriAssociati : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriLettura

Metodo DedNetAcadCommandsDedApriLettura
Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in lettura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriLettura()
Public Shared Sub DedApriLettura
public:
static void DedApriLettura()
static member DedApriLettura : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriModifica

Metodo DedNetAcadCommandsDedApriModifica
Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in modifica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriModifica()
Public Shared Sub DedApriModifica
public:
static void DedApriModifica()
static member DedApriModifica : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedArchiviaDoc

Metodo DedNetAcadCommandsDedArchiviaDoc
Archivia il documento correntemente aperto nel percorso selezionato dall'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedArchiviaDoc()
Public Shared Sub DedArchiviaDoc
public:
static void DedArchiviaDoc()
static member DedArchiviaDoc : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedArchiviaDocPrt

Metodo DedNetAcadCommandsDedArchiviaDocPrt
Archivia la parte correntemente attiva nel percorso selezionato dall'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedArchiviaDocPrt()
Public Shared Sub DedArchiviaDocPrt
public:
static void DedArchiviaDocPrt()
static member DedArchiviaDocPrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAssociaDoc

Metodo DedNetAcadCommandsDedAssociaDoc
Salva il documento correntemente aperto associandolo ad un'anagrafica già presente nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAssociaDoc()
Public Shared Sub DedAssociaDoc
public:
static void DedAssociaDoc()
static member DedAssociaDoc : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAssociaDocPrt

Metodo DedNetAcadCommandsDedAssociaDocPrt
Associa la parte correntemente attiva ad un'anagrafica già presente nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAssociaDocPrt()
Public Shared Sub DedAssociaDocPrt
public:
static void DedAssociaDocPrt()
static member DedAssociaDocPrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCambiaPwd

Metodo DedNetAcadCommandsDedCambiaPwd
Finestra che permette di modificare la password dell'utente connesso.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCambiaPwd()
Public Shared Sub DedCambiaPwd
public:
static void DedCambiaPwd()
static member DedCambiaPwd : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCheckIn

Metodo DedNetAcadCommandsDedCheckIn

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCheckIn()
Public Shared Sub DedCheckIn
public:
static void DedCheckIn()
static member DedCheckIn : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCheckOldRev

Metodo DedNetAcadCommandsDedCheckOldRev
Controlla e permette di aggiornare le revisioni superate.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCheckOldRev()
Public Shared Sub DedCheckOldRev
public:
static void DedCheckOldRev()
static member DedCheckOldRev : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCheckOut

Metodo DedNetAcadCommandsDedCheckOut
Mette in check-out il documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCheckOut()
Public Shared Sub DedCheckOut
public:
static void DedCheckOut()
static member DedCheckOut : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedComm

Metodo DedNetAcadCommandsDedComm
Lancia l'editor delle commesse.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedComm()
Public Shared Sub DedComm
public:
static void DedComm()
static member DedComm : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaAnagr

Metodo DedNetAcadCommandsDedCreaAnagr
Salva il documento correntemente aperto nel Database con un nuovo codice.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaAnagr()
Public Shared Sub DedCreaAnagr
public:
static void DedCreaAnagr()
static member DedCreaAnagr : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaAnagrPrt

Metodo DedNetAcadCommandsDedCreaAnagrPrt
Salva la parte correntemente attiva nel Database con un nuovo codice.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaAnagrPrt()
Public Shared Sub DedCreaAnagrPrt
public:
static void DedCreaAnagrPrt()
static member DedCreaAnagrPrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaRev

Metodo DedNetAcadCommandsDedCreaRev
Salva il documento correntemente aperto con nuova revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaRev()
Public Shared Sub DedCreaRev
public:
static void DedCreaRev()
static member DedCreaRev : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaVariante

Metodo DedNetAcadCommandsDedCreaVariante
Salva una variante del documento correntemente aperto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaVariante()
Public Shared Sub DedCreaVariante
public:
static void DedCreaVariante()
static member DedCreaVariante : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaVariantePrt

Metodo DedNetAcadCommandsDedCreaVariantePrt
Salva una variante della parte correntemente attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaVariantePrt()
Public Shared Sub DedCreaVariantePrt
public:
static void DedCreaVariantePrt()
static member DedCreaVariantePrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistEdit

Metodo DedNetAcadCommandsDedDistEdit
Lancia l'editor della distinta con l'eventuale codice in editazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistEdit()
Public Shared Sub DedDistEdit
public:
static void DedDistEdit()
static member DedDistEdit : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistEspl

Metodo DedNetAcadCommandsDedDistEspl
Visualizza la distinta esplosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistEspl()
Public Shared Sub DedDistEspl
public:
static void DedDistEspl()
static member DedDistEspl : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistImpl

Metodo DedNetAcadCommandsDedDistImpl
Visualizza la distinta implosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistImpl()
Public Shared Sub DedDistImpl
public:
static void DedDistImpl()
static member DedDistImpl : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistSave

Metodo DedNetAcadCommandsDedDistSave
Lista degli overload
Nome | Descrizione
DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDistSave(LuaTable) | Salva la distinta del documento correntemente aperto, nel Datbase.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistSave

Metodo DedNetAcadCommandsDedDistSave
Salva la distinta del documento correntemente aperto, nel Datbase.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistSave()
Public Shared Sub DedDistSave
public:
static void DedDistSave()
static member DedDistSave : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands
Overload di DedDistSave


Metodo DedNetAcadCommands.DedDistSave(LuaTable)

Metodo DedNetAcadCommandsDedDistSave(LuaTable)
Salva la distinta del documento correntemente aperto, nel Datbase.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistSave(
    LuaTable args
)
Public Shared Sub DedDistSave (
    args As LuaTable
)
public:
static void DedDistSave(
    LuaTable^ args
)
static member DedDistSave :
        args : LuaTable -> unit

Parametri

args LuaTable
Vedi anche

Documentazione

Classe DedNetAcadCommands
Overload di DedDistSave


Metodo DedNetAcadCommands.DedDocRecognizer

Metodo DedNetAcadCommandsDedDocRecognizer
Lancia il riconoscitore massivo di documenti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDocRecognizer()
Public Shared Sub DedDocRecognizer
public:
static void DedDocRecognizer()
static member DedDocRecognizer : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDocRegister

Metodo DedNetAcadCommandsDedDocRegister
Lancia il comando per registrare il documento attivo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedDocRegister()
Public Shared Sub DedDocRegister
public:
static void DedDocRegister()
static member DedDocRegister : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedECO

Metodo DedNetAcadCommandsDedECO
Lancia l'editor degli ECO.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedECO()
Public Shared Sub DedECO
public:
static void DedECO()
static member DedECO : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedEseguiLua

Metodo DedNetAcadCommandsDedEseguiLua
Apre la finestra di esecuzione codice LUA.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedEseguiLua()
Public Shared Sub DedEseguiLua
public:
static void DedEseguiLua()
static member DedEseguiLua : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedGestioneXref

Metodo DedNetAcadCommandsDedGestioneXref
Apre il file allegato oppure visualizza la finestra di selezione file allegati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedGestioneXref()
Public Shared Sub DedGestioneXref
public:
static void DedGestioneXref()
static member DedGestioneXref : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedHelp

Metodo DedNetAcadCommandsDedHelp
Apre la finestra di help.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedHelp()
Public Shared Sub DedHelp
public:
static void DedHelp()
static member DedHelp : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedIntroduction

Metodo DedNetAcadCommandsDedIntroduction
Apre la finestra principale della ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedIntroduction()
Public Shared Sub DedIntroduction
public:
static void DedIntroduction()
static member DedIntroduction : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedLavMulti

Metodo DedNetAcadCommandsDedLavMulti
Effettua la lavorazione multipla del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedLavMulti()
Public Shared Sub DedLavMulti
public:
static void DedLavMulti()
static member DedLavMulti : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedLogIn

Metodo DedNetAcadCommandsDedLogIn
Comando che permette di cambiare utente all'interno del CAD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedLogIn()
Public Shared Sub DedLogIn
public:
static void DedLogIn()
static member DedLogIn : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedModificaSup

Metodo DedNetAcadCommandsDedModificaSup
Toglie il rilascio all'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedModificaSup()
Public Shared Sub DedModificaSup
public:
static void DedModificaSup()
static member DedModificaSup : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPackAndGoExport

Metodo DedNetAcadCommandsDedPackAndGoExport
Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedPackAndGoExport()
Public Shared Sub DedPackAndGoExport
public:
static void DedPackAndGoExport()
static member DedPackAndGoExport : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPackAndGoImport

Metodo DedNetAcadCommandsDedPackAndGoImport
Esegue l'importazione di un pacchetto di file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedPackAndGoImport()
Public Shared Sub DedPackAndGoImport
public:
static void DedPackAndGoImport()
static member DedPackAndGoImport : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPubblica

Metodo DedNetAcadCommandsDedPubblica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedPubblica()
Public Shared Sub DedPubblica
public:
static void DedPubblica()
static member DedPubblica : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPwsCache

Metodo DedNetAcadCommandsDedPwsCache

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedPwsCache()
Public Shared Sub DedPwsCache
public:
static void DedPwsCache()
static member DedPwsCache : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRicerca

Metodo DedNetAcadCommandsDedRicerca
Apre la finestra principale della ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedRicerca()
Public Shared Sub DedRicerca
public:
static void DedRicerca()
static member DedRicerca : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRicercaDocumentale

Metodo DedNetAcadCommandsDedRicercaDocumentale
Apre la finestra della ricerca documentale.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedRicercaDocumentale()
Public Shared Sub DedRicercaDocumentale
public:
static void DedRicercaDocumentale()
static member DedRicercaDocumentale : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRicercaNew

Metodo DedNetAcadCommandsDedRicercaNew
Apre la finestra principale della ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedRicercaNew()
Public Shared Sub DedRicercaNew
public:
static void DedRicercaNew()
static member DedRicercaNew : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRil

Metodo DedNetAcadCommandsDedRil
Rilascia l'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedRil()
Public Shared Sub DedRil
public:
static void DedRil()
static member DedRil : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRilMulti

Metodo DedNetAcadCommandsDedRilMulti
Effettua il rilascio multiplo del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedRilMulti()
Public Shared Sub DedRilMulti
public:
static void DedRilMulti()
static member DedRilMulti : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedSalvaSup

Metodo DedNetAcadCommandsDedSalvaSup
Toglie il rilascio all'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedSalvaSup()
Public Shared Sub DedSalvaSup
public:
static void DedSalvaSup()
static member DedSalvaSup : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedSblocca

Metodo DedNetAcadCommandsDedSblocca

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedSblocca()
Public Shared Sub DedSblocca
public:
static void DedSblocca()
static member DedSblocca : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedStatoDoc

Metodo DedNetAcadCommandsDedStatoDoc
Visualizza lo stato dell'anagrafica e del documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedStatoDoc()
Public Shared Sub DedStatoDoc
public:
static void DedStatoDoc()
static member DedStatoDoc : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedUnRil

Metodo DedNetAcadCommandsDedUnRil
Toglie il rilascio all'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedUnRil()
Public Shared Sub DedUnRil
public:
static void DedUnRil()
static member DedUnRil : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Classe DedNetAcadFileResolution
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadFileResolution

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class DedNetAcadFileResolution
Public NotInheritable Class DedNetAcadFileResolution
public ref class DedNetAcadFileResolution abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DedNetAcadFileResolution = class end

Il tipo DedNetAcadFileResolution espone i seguenti membri.

Metodi
Nome | Descrizione
GetReplaceFullFileName | Ritorna il nuovo nome file tornato dalla risoluzione tramite MOVED e OLDFILE.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di DedNetAcadFileResolution

Il tipo DedNetAcadFileResolution espone i seguenti membri.

Metodi
Nome | Descrizione
GetReplaceFullFileName | Ritorna il nuovo nome file tornato dalla risoluzione tramite MOVED e OLDFILE.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadFileResolution


Metodo DedNetAcadFileResolution.GetReplaceFullFileName

Metodo DedNetAcadFileResolutionGetReplaceFullFileName
Ritorna il nuovo nome file tornato dalla risoluzione tramite MOVED e OLDFILE.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetReplaceFullFileName(
    string strOldFullFileName
)
Public Shared Function GetReplaceFullFileName (
    strOldFullFileName As String
) As String
public:
static String^ GetReplaceFullFileName(
    String^ strOldFullFileName
)
static member GetReplaceFullFileName :
        strOldFullFileName : string -> string

Parametri

strOldFullFileName String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNetAcadFileResolution


Classe DedNetAcadFileResolution.OnFileResolutionSostItem

Classe DedNetAcadFileResolutionOnFileResolutionSostItem
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadFileResolutionOnFileResolutionSostItem

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItem
Public Class OnFileResolutionSostItem
public ref class OnFileResolutionSostItem
type OnFileResolutionSostItem = class end

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadFileResolutionOnFileResolutionSostItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Proprietà pubblica | PreviewFile |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadFileResolution.OnFileResolutionSostItem

Costruttore DedNetAcadFileResolutionOnFileResolutionSostItem

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItem()
Public Sub New
public:
OnFileResolutionSostItem()
new : unit -> OnFileResolutionSostItem
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà di OnFileResolutionSostItem

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Proprietà pubblica | PreviewFile |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà DedNetAcadFileResolution.OnFileResolutionSostItem.DbFile

Proprietà DedNetAcadFileResolutionOnFileResolutionSostItemDbFile

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DbFile { get; set; }
Public Property DbFile As String
    Get
    Set
public:
property String^ DbFile {
    String^ get ();
    void set (String^ value);
}
member DbFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà DedNetAcadFileResolution.OnFileResolutionSostItem.OldFile

Proprietà DedNetAcadFileResolutionOnFileResolutionSostItemOldFile

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; set; }
Public Property OldFile As String
    Get
    Set
public:
property String^ OldFile {
    String^ get ();
    void set (String^ value);
}
member OldFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà DedNetAcadFileResolution.OnFileResolutionSostItem.PreviewFile

Proprietà DedNetAcadFileResolutionOnFileResolutionSostItemPreviewFile

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string PreviewFile { get; set; }
Public Property PreviewFile As String
    Get
    Set
public:
property String^ PreviewFile {
    String^ get ();
    void set (String^ value);
}
member PreviewFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Campi di OnFileResolutionSostItem

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Campo DedNetAcadFileResolution.OnFileResolutionSostItem.DocGuid

Campo DedNetAcadFileResolutionOnFileResolutionSostItemDocGuid

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocGuid
Public DocGuid As Guid
public:
Guid DocGuid
val mutable DocGuid: Guid

Valore del campo

Guid
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Classe DedNetAcadFileResolution.OnFileResolutionSostItemList

Classe DedNetAcadFileResolutionOnFileResolutionSostItemList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetAcadFileResolutionOnFileResolutionSostItem
DedNetAcadDedNetAcadFileResolutionOnFileResolutionSostItemList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItemList : List<DedNetAcadFileResolutionOnFileResolutionSostItem>
Public Class OnFileResolutionSostItemList
    Inherits List(Of DedNetAcadFileResolutionOnFileResolutionSostItem)
public ref class OnFileResolutionSostItemList : public List<DedNetAcadFileResolutionOnFileResolutionSostItem^>
type OnFileResolutionSostItemList =
    class
        inherit List<DedNetAcadFileResolutionOnFileResolutionSostItem>
    end

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadFileResolutionOnFileResolutionSostItemList |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadFileResolution.OnFileResolutionSostItemList

Costruttore DedNetAcadFileResolutionOnFileResolutionSostItemList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItemList()
Public Sub New
public:
OnFileResolutionSostItemList()
new : unit -> OnFileResolutionSostItemList
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItemList


Enumerazione DedNetAcadFileResolution.RispostaUtenteSost

Enumerazione DedNetAcadFileResolutionRispostaUtenteSost

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum RispostaUtenteSost
Public Enumeration RispostaUtenteSost
public enum class RispostaUtenteSost
type RispostaUtenteSost
Membri
Nome | Valore | Descrizione
Si | 0 |
No | 1 |
SiTutti | 2 |
NoTutti | 3 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe FileStateElement
Oggetto descrivente un singolo documento ed il suo stato. Funge da ponte tra chi sa determinare lo stato del documento e deve decidere cosa fare nelle varie situazioni e chi deve visualizzare lo stato del documento e le sue dipendenze.
Gerarchia di ereditarietà
SystemObject
DedNetAcadFileStateElement

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElement
Public Class FileStateElement
public ref class FileStateElement
type FileStateElement = class end

Il tipo FileStateElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica associata all'elemento
Proprietà pubblica | Description | Imposta o restituisce la descrizione di questo elemento.
Proprietà pubblica | Document | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | Existing | Imposta o restituisce se l'elemento è mancante
Proprietà pubblica | FileDescriptor | Documento di AutoCAD se esistente
Proprietà pubblica | FullFileName | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | ID | ID interno del riferimento.
Proprietà pubblica | IsTop | Imposta o restituisce la descrizione di questo elemento.
Proprietà pubblica | NameOnly | Restituisce il solo nome senza estensione del file con eventuale livello di dettaglio.
Proprietà pubblica | Parent | Oggetto FileStateElement padre. E' null in caso di parte top.
Proprietà pubblica | RefName | Imposta o restituisce il nome del riferimento descritto da questo elemento.
Proprietà pubblica | StateID | Restituisce o imposta lo stato dell'elemento.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | RefreshElement | Forza il ricarimento del documento
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di FileStateElement

Il tipo FileStateElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica associata all'elemento
Proprietà pubblica | Description | Imposta o restituisce la descrizione di questo elemento.
Proprietà pubblica | Document | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | Existing | Imposta o restituisce se l'elemento è mancante
Proprietà pubblica | FileDescriptor | Documento di AutoCAD se esistente
Proprietà pubblica | FullFileName | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | ID | ID interno del riferimento.
Proprietà pubblica | IsTop | Imposta o restituisce la descrizione di questo elemento.
Proprietà pubblica | NameOnly | Restituisce il solo nome senza estensione del file con eventuale livello di dettaglio.
Proprietà pubblica | Parent | Oggetto FileStateElement padre. E' null in caso di parte top.
Proprietà pubblica | RefName | Imposta o restituisce il nome del riferimento descritto da questo elemento.
Proprietà pubblica | StateID | Restituisce o imposta lo stato dell'elemento.
Torna su
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.Data

Proprietà FileStateElementData
Anagrafica associata all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.Description

Proprietà FileStateElementDescription
Imposta o restituisce la descrizione di questo elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.Document

Proprietà FileStateElementDocument
Nome completo del file sotteso a questo elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.Existing

Proprietà FileStateElementExisting
Imposta o restituisce se l'elemento è mancante

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Existing { get; }
Public ReadOnly Property Existing As Boolean
    Get
public:
property bool Existing {
    bool get ();
}
member Existing : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.FileDescriptor

Proprietà FileStateElementFileDescriptor
Documento di AutoCAD se esistente

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object FileDescriptor { get; set; }
Public Property FileDescriptor As Object
    Get
    Set
public:
property Object^ FileDescriptor {
    Object^ get ();
    void set (Object^ value);
}
member FileDescriptor : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.FullFileName

Proprietà FileStateElementFullFileName
Nome completo del file sotteso a questo elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.ID

Proprietà FileStateElementID
ID interno del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object ID { get; }
Public ReadOnly Property ID As Object
    Get
public:
property Object^ ID {
    Object^ get ();
}
member ID : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.IsTop

Proprietà FileStateElementIsTop
Imposta o restituisce la descrizione di questo elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTop { get; set; }
Public Property IsTop As Boolean
    Get
    Set
public:
property bool IsTop {
    bool get ();
    void set (bool value);
}
member IsTop : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.NameOnly

Proprietà FileStateElementNameOnly
Restituisce il solo nome senza estensione del file con eventuale livello di dettaglio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string NameOnly { get; }
Public ReadOnly Property NameOnly As String
    Get
public:
property String^ NameOnly {
    String^ get ();
}
member NameOnly : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.Parent

Proprietà FileStateElementParent
Oggetto FileStateElement padre. E' null in caso di parte top.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement Parent { get; }
Public ReadOnly Property Parent As FileStateElement
    Get
public:
property FileStateElement^ Parent {
    FileStateElement^ get ();
}
member Parent : FileStateElement with get

Valore della proprietà

FileStateElement
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.RefName

Proprietà FileStateElementRefName
Imposta o restituisce il nome del riferimento descritto da questo elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RefName { get; set; }
Public Property RefName As String
    Get
    Set
public:
property String^ RefName {
    String^ get ();
    void set (String^ value);
}
member RefName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement


Proprietà FileStateElement.StateID

Proprietà FileStateElementStateID
Restituisce o imposta lo stato dell'elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int StateID { get; set; }
Public Property StateID As Integer
    Get
    Set
public:
property int StateID {
    int get ();
    void set (int value);
}
member StateID : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FileStateElement


Metodi di FileStateElement

Il tipo FileStateElement espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | RefreshElement | Forza il ricarimento del documento
Torna su
Vedi anche

Documentazione

Classe FileStateElement


Metodo FileStateElement.Equals

Metodo FileStateElementEquals

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateElement


Metodo FileStateElement.RefreshElement

Metodo FileStateElementRefreshElement
Forza il ricarimento del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshElement(
    bool reloadMoved
)
Public Sub RefreshElement (
    reloadMoved As Boolean
)
public:
void RefreshElement(
    bool reloadMoved
)
member RefreshElement :
        reloadMoved : bool -> unit

Parametri

reloadMoved Boolean
Vedi anche

Documentazione

Classe FileStateElement


Classe FileStateElementList
Lista di elementi di tipo FileStateElement.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList FileStateElement
DedNetAcadFileStateElementList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElementList : List<FileStateElement>
Public Class FileStateElementList
    Inherits List(Of FileStateElement)
public ref class FileStateElementList : public List<FileStateElement^>
type FileStateElementList =
    class
        inherit List<FileStateElement>
    end

Il tipo FileStateElementList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileStateElementList |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FileStateElementList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList()
Public Sub New
public:
FileStateElementList()
new : unit -> FileStateElementList
Vedi anche

Documentazione

Classe FileStateElementList


Classe FileStateManager
Gestisce lo stato di tutti i documenti presenti in Inventor aperti in modo visibile o meno. Centralizza le funzionalità necessarie al Check-in/out o al riservarsi o meno i documenti. Attraverso l'implementazione di una stessa interfaccia rende possibile avere un albero di documenti con la gestione integrata del loro stato, fruibile sia nel DedPlus che nel Ded tradizionale. Pensa questa classe a registrarsi agli eventi e visualizzare il browser con lo stato dei documenti. Chiama i metodi dell'interfaccia, necessari al check-out/riservo dei documenti.
Gerarchia di ereditarietà
SystemObject
DedNetAcadFileStateManager

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FileStateManager
Public Class FileStateManager
public ref class FileStateManager
type FileStateManager = class end

Il tipo FileStateManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileStateManager | Costruttore unico.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Chiama la funzione dell'informer che dermina se il nodo ammette hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager. Restituisce null se non ci sono elementi attivi.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine o icona associata allo stato d'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il Nome dello stato d'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restrituisce il valore della proprietà passata.
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetElement | Restituisce l'elemento con le informazioni del documento. Se esiste già lo restituisce altrimenti lo crea, lo aggiunge e lo restituisce.
Metodo pubblico | GetMovedDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | HasChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è in uno stato di dirty
Metodo pubblico | MakeAcadCommandContext | Ritorna il contesto per i comandi contestuali in base agli oggetti passati
Metodo protetto | OnElementActivatedEvent | Solleva l'evento ElementActivatedEvent.
Metodo protetto | OnElementChangedEvent | Solleva l'evento ElementChangedEvent.
Metodo pubblico | OnElementDoubleClicked | Chiama la funzione dell'informer che si occupa di gestire il doppio click sull'elemento
Metodo pubblico | OnElementsSelected | Chiama la funzione dell'informer che si occupa di gestire la selezione di elementi sull'albero
Metodo pubblico | OnHotTrackElementClicked | Chiama la funzione dell'informer che si occupa di gestire il click singolo sull'elemento in stato di link
Metodo pubblico | RaiseElementActivatedEvent | Solleva l'evento ElementActivatedEvent con l'elemento passato come argomento.
Metodo pubblico | RaiseElementChangedEvent | Solleva l'evento ElementChangedEvent con l'elemento passato come argomento.
Metodo pubblico | ReloadElementInformations | Ricarico le informazioni legate al nodo
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ElementActivatedEvent | Evento che si verifica quando un elemento è diventato attivo.
Evento pubblico | ElementChangedEvent | Elemento che si verifica quando un elemento è stato modificato.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FileStateManager
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateManager(
    IFileStateInformer informer
)
Public Sub New (
    informer As IFileStateInformer
)
public:
FileStateManager(
    IFileStateInformer^ informer
)
new :
        informer : IFileStateInformer -> FileStateManager

Parametri

informer IFileStateInformer
Oggetto al quale chiedere informazioni sui singoli elementi.
Vedi anche

Documentazione

Classe FileStateManager


Metodi di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Chiama la funzione dell'informer che dermina se il nodo ammette hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager. Restituisce null se non ci sono elementi attivi.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine o icona associata allo stato d'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il Nome dello stato d'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restrituisce il valore della proprietà passata.
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetElement | Restituisce l'elemento con le informazioni del documento. Se esiste già lo restituisce altrimenti lo crea, lo aggiunge e lo restituisce.
Metodo pubblico | GetMovedDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | HasChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è in uno stato di dirty
Metodo pubblico | MakeAcadCommandContext | Ritorna il contesto per i comandi contestuali in base agli oggetti passati
Metodo protetto | OnElementActivatedEvent | Solleva l'evento ElementActivatedEvent.
Metodo protetto | OnElementChangedEvent | Solleva l'evento ElementChangedEvent.
Metodo pubblico | OnElementDoubleClicked | Chiama la funzione dell'informer che si occupa di gestire il doppio click sull'elemento
Metodo pubblico | OnElementsSelected | Chiama la funzione dell'informer che si occupa di gestire la selezione di elementi sull'albero
Metodo pubblico | OnHotTrackElementClicked | Chiama la funzione dell'informer che si occupa di gestire il click singolo sull'elemento in stato di link
Metodo pubblico | RaiseElementActivatedEvent | Solleva l'evento ElementActivatedEvent con l'elemento passato come argomento.
Metodo pubblico | RaiseElementChangedEvent | Solleva l'evento ElementChangedEvent con l'elemento passato come argomento.
Metodo pubblico | ReloadElementInformations | Ricarico le informazioni legate al nodo
Torna su
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.AllowHotTracking

Metodo FileStateManagerAllowHotTracking
Chiama la funzione dell'informer che dermina se il nodo ammette hot tracking

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowHotTracking(
    FileStateElement el
)
Public Function AllowHotTracking (
    el As FileStateElement
) As Boolean
public:
bool AllowHotTracking(
    FileStateElement^ el
)
member AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetActiveElement

Metodo FileStateManagerGetActiveElement
Restituisce l'elemento correntemente attivo. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager. Restituisce null se non ci sono elementi attivi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetActiveElement()
Public Function GetActiveElement As FileStateElement
public:
FileStateElement^ GetActiveElement()
member GetActiveElement : unit -> FileStateElement

Valore di ritorno

FileStateElement
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetAnagStateImageKey

Metodo FileStateManagerGetAnagStateImageKey
Restituisce l'immagine o icona associata allo stato d'anagrafica associata all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image GetAnagStateImageKey(
    FileStateElement el
)
Public Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
public:
Image^ GetAnagStateImageKey(
    FileStateElement^ el
)
member GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el FileStateElement

Valore di ritorno

Image
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetAnagStateName

Metodo FileStateManagerGetAnagStateName
Restituisce il Nome dello stato d'anagrafica associata all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAnagStateName(
    FileStateElement el
)
Public Function GetAnagStateName (
    el As FileStateElement
) As String
public:
String^ GetAnagStateName(
    FileStateElement^ el
)
member GetAnagStateName :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetAttr

Metodo FileStateManagerGetAttr
Restrituisce il valore della proprietà passata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetAttr(
    FileStateElement el,
    string nome
)
Public Function GetAttr (
    el As FileStateElement,
    nome As String
) As Object
public:
Object^ GetAttr(
    FileStateElement^ el,
    String^ nome
)
member GetAttr :
        el : FileStateElement *
        nome : string -> Object

Parametri

el FileStateElement
nome String

Valore di ritorno

Object
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetChildrenElements

Metodo FileStateManagerGetChildrenElements
Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList GetChildrenElements(
    FileStateElement el
)
Public Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
public:
FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
)
member GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el FileStateElement

Valore di ritorno

FileStateElementList
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetDocument

Metodo FileStateManagerGetDocument
Ritorna il documento associato all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetDocument(
    FileStateElement el
)
Public Function GetDocument (
    el As FileStateElement
) As DedDoc
public:
DedDoc^ GetDocument(
    FileStateElement^ el
)
member GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetElement

Metodo FileStateManagerGetElement
Restituisce l'elemento con le informazioni del documento. Se esiste già lo restituisce altrimenti lo crea, lo aggiunge e lo restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetElement(
    Object id,
    string fullFileName,
    string refName,
    FileStateElement parent
)
Public Function GetElement (
    id As Object,
    fullFileName As String,
    refName As String,
    parent As FileStateElement
) As FileStateElement
public:
FileStateElement^ GetElement(
    Object^ id,
    String^ fullFileName,
    String^ refName,
    FileStateElement^ parent
)
member GetElement :
        id : Object *
        fullFileName : string *
        refName : string *
        parent : FileStateElement -> FileStateElement

Parametri

id Object
fullFileName String
refName String
parent FileStateElement

Valore di ritorno

FileStateElement
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetMovedDocument

Metodo FileStateManagerGetMovedDocument
Ritorna il documento associato all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDocument(
    FileStateElement el
)
Public Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
public:
DedDoc^ GetMovedDocument(
    FileStateElement^ el
)
member GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetSelectionImageKey

Metodo FileStateManagerGetSelectionImageKey
Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetSelectionImageKey(
    FileStateElement el
)
Public Function GetSelectionImageKey (
    el As FileStateElement
) As String
public:
String^ GetSelectionImageKey(
    FileStateElement^ el
)
member GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement
Elemento in oggetto.

Valore di ritorno

String
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.GetStateImageKey

Metodo FileStateManagerGetStateImageKey
Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetStateImageKey(
    FileStateElement el
)
Public Function GetStateImageKey (
    el As FileStateElement
) As String
public:
String^ GetStateImageKey(
    FileStateElement^ el
)
member GetStateImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement
Elemento in oggetto.

Valore di ritorno

String
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.HasChildrenElements

Metodo FileStateManagerHasChildrenElements
Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildrenElements(
    FileStateElement el
)
Public Function HasChildrenElements (
    el As FileStateElement
) As Boolean
public:
bool HasChildrenElements(
    FileStateElement^ el
)
member HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.IsDirty

Metodo FileStateManagerIsDirty
Ritorna vero se l'elemento passato è in uno stato di dirty

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty(
    FileStateElement el
)
Public Function IsDirty (
    el As FileStateElement
) As Boolean
public:
bool IsDirty(
    FileStateElement^ el
)
member IsDirty :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.MakeAcadCommandContext

Metodo FileStateManagerMakeAcadCommandContext
Ritorna il contesto per i comandi contestuali in base agli oggetti passati

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAcadCommandContext MakeAcadCommandContext(
    FileStateElementList elsList
)
Public Function MakeAcadCommandContext (
    elsList As FileStateElementList
) As DedAcadCommandContext
public:
DedAcadCommandContext^ MakeAcadCommandContext(
    FileStateElementList^ elsList
)
member MakeAcadCommandContext :
        elsList : FileStateElementList -> DedAcadCommandContext

Parametri

elsList FileStateElementList

Valore di ritorno

DedAcadCommandContext
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.OnElementActivatedEvent

Metodo FileStateManagerOnElementActivatedEvent
Solleva l'evento ElementActivatedEvent.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnElementActivatedEvent(
    bool restoreStatus
)
Protected Sub OnElementActivatedEvent (
    restoreStatus As Boolean
)
protected:
void OnElementActivatedEvent(
    bool restoreStatus
)
member OnElementActivatedEvent :
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.OnElementChangedEvent

Metodo FileStateManagerOnElementChangedEvent
Solleva l'evento ElementChangedEvent.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnElementChangedEvent(
    FileStateElement el
)
Protected Sub OnElementChangedEvent (
    el As FileStateElement
)
protected:
void OnElementChangedEvent(
    FileStateElement^ el
)
member OnElementChangedEvent :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Elemento da passare all'evento.
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.OnElementDoubleClicked

Metodo FileStateManagerOnElementDoubleClicked
Chiama la funzione dell'informer che si occupa di gestire il doppio click sull'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void OnElementDoubleClicked(
    FileStateElement el
)
Public Sub OnElementDoubleClicked (
    el As FileStateElement
)
public:
void OnElementDoubleClicked(
    FileStateElement^ el
)
member OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.OnElementsSelected

Metodo FileStateManagerOnElementsSelected
Chiama la funzione dell'informer che si occupa di gestire la selezione di elementi sull'albero

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void OnElementsSelected(
    FileStateElementList elsList
)
Public Sub OnElementsSelected (
    elsList As FileStateElementList
)
public:
void OnElementsSelected(
    FileStateElementList^ elsList
)
member OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList FileStateElementList
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.OnHotTrackElementClicked

Metodo FileStateManagerOnHotTrackElementClicked
Chiama la funzione dell'informer che si occupa di gestire il click singolo sull'elemento in stato di link

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnHotTrackElementClicked(
    FileStateElement el
)
Public Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
public:
bool OnHotTrackElementClicked(
    FileStateElement^ el
)
member OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.RaiseElementActivatedEvent

Metodo FileStateManagerRaiseElementActivatedEvent
Solleva l'evento ElementActivatedEvent con l'elemento passato come argomento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RaiseElementActivatedEvent(
    bool restoreStatus
)
Public Sub RaiseElementActivatedEvent (
    restoreStatus As Boolean
)
public:
void RaiseElementActivatedEvent(
    bool restoreStatus
)
member RaiseElementActivatedEvent :
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.RaiseElementChangedEvent

Metodo FileStateManagerRaiseElementChangedEvent
Solleva l'evento ElementChangedEvent con l'elemento passato come argomento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RaiseElementChangedEvent(
    FileStateElement el
)
Public Sub RaiseElementChangedEvent (
    el As FileStateElement
)
public:
void RaiseElementChangedEvent(
    FileStateElement^ el
)
member RaiseElementChangedEvent :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Elemento di cui si vuole notificare l'avvenuto aggiornamento.
Vedi anche

Documentazione

Classe FileStateManager


Metodo FileStateManager.ReloadElementInformations

Metodo FileStateManagerReloadElementInformations
Ricarico le informazioni legate al nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadElementInformations(
    FileStateElement el,
    bool reloadMoved
)
Public Sub ReloadElementInformations (
    el As FileStateElement,
    reloadMoved As Boolean
)
public:
void ReloadElementInformations(
    FileStateElement^ el,
    bool reloadMoved
)
member ReloadElementInformations :
        el : FileStateElement *
        reloadMoved : bool -> unit

Parametri

el FileStateElement
Elemento di riferimento
reloadMoved Boolean
Indica se ricaricare eventuali documenti moved
Vedi anche

Documentazione

Classe FileStateManager


Eventi di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ElementActivatedEvent | Evento che si verifica quando un elemento è diventato attivo.
Evento pubblico | ElementChangedEvent | Elemento che si verifica quando un elemento è stato modificato.
Torna su
Vedi anche

Documentazione

Classe FileStateManager


Evento FileStateManager.ElementActivatedEvent

Evento FileStateManagerElementActivatedEvent
Evento che si verifica quando un elemento è diventato attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public event FileStateManagerActivateEventHandler ElementActivatedEvent
Public Event ElementActivatedEvent As FileStateManagerActivateEventHandler
public:
 event FileStateManagerActivateEventHandler^ ElementActivatedEvent {
    void add (FileStateManagerActivateEventHandler^ value);
    void remove (FileStateManagerActivateEventHandler^ value);
}
member ElementActivatedEvent : IEvent<FileStateManagerActivateEventHandler,
    EventArgs>

Valore

FileStateManagerActivateEventHandler
Vedi anche

Documentazione

Classe FileStateManager


Evento FileStateManager.ElementChangedEvent

Evento FileStateManagerElementChangedEvent
Elemento che si verifica quando un elemento è stato modificato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ElementChangedEvent
Public Event ElementChangedEvent As EventHandler
public:
 event EventHandler^ ElementChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ElementChangedEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe FileStateManager


Delegate FileStateManager.ActivateEventHandler

Delegate FileStateManagerActivateEventHandler
Elemento che si verifica quando un elemento è stato aggiunto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ActivateEventHandler(
    bool restoreStatus
)
Public Delegate Sub ActivateEventHandler (
    restoreStatus As Boolean
)
public delegate void ActivateEventHandler(
    bool restoreStatus
)
type ActivateEventHandler =
    delegate of
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe FindInRicerca
Apre la finestra della ricerca con preselezionata l'anagrafica interessata.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadFindInRicerca

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FindInRicerca : AcadCommandBase
Public Class FindInRicerca
    Inherits AcadCommandBase
public ref class FindInRicerca : public AcadCommandBase
type FindInRicerca =
    class
        inherit AcadCommandBase
    end

Il tipo FindInRicerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di FindInRicerca

Il tipo FindInRicerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe FindInRicerca


Proprietà FindInRicerca.NeedParameters

Proprietà FindInRicercaNeedParameters
Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindInRicerca


Metodi di FindInRicerca

Il tipo FindInRicerca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInRicerca


Metodo FindInRicerca.AcadEnabled

Metodo FindInRicercaAcadEnabled
Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindInRicerca


Metodo FindInRicerca.AcadSetContext

Metodo FindInRicercaAcadSetContext
Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindInRicerca


Metodo FindInRicerca.ClearCommand

Metodo FindInRicercaClearCommand
Azzera e rigenera il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindInRicerca


Metodo FindInRicerca.ExecuteCommand

Metodo FindInRicercaExecuteCommand
Lancia il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe FindInRicerca


Classe ForzaAllineamento
Comando per forzare l'allineamento di un documento registrato nel DB.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadForzaAllineamento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ForzaAllineamento : AcadCommandBase
Public Class ForzaAllineamento
    Inherits AcadCommandBase
public ref class ForzaAllineamento : public AcadCommandBase
type ForzaAllineamento =
    class
        inherit AcadCommandBase
    end

Il tipo ForzaAllineamento espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ForzaAllineamento | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Filename | Restituisce o imposta il nome del file su cui andare a forzare l'allineamento.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ForzaAllineamento
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ForzaAllineamento(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
ForzaAllineamento(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> ForzaAllineamento

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe ForzaAllineamento


Proprietà di ForzaAllineamento

Il tipo ForzaAllineamento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Filename | Restituisce o imposta il nome del file su cui andare a forzare l'allineamento.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe ForzaAllineamento


Proprietà ForzaAllineamento.Filename

Proprietà ForzaAllineamentoFilename
Restituisce o imposta il nome del file su cui andare a forzare l'allineamento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}
member Filename : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ForzaAllineamento


Proprietà ForzaAllineamento.NeedParameters

Proprietà ForzaAllineamentoNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ForzaAllineamento


Metodi di ForzaAllineamento

Il tipo ForzaAllineamento espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForzaAllineamento


Metodo ForzaAllineamento.AcadEnabled

Metodo ForzaAllineamentoAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ForzaAllineamento


Metodo ForzaAllineamento.AcadSetContext

Metodo ForzaAllineamentoAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ForzaAllineamento


Metodo ForzaAllineamento.ClearCommand

Metodo ForzaAllineamentoClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ForzaAllineamento


Metodo ForzaAllineamento.ExecuteCommand

Metodo ForzaAllineamentoExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ForzaAllineamento


Interfaccia IFileStateInformer

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public interface IFileStateInformer
Public Interface IFileStateInformer
public interface class IFileStateInformer
type IFileStateInformer = interface end

Il tipo IFileStateInformer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Restituisce true se l'elemento ammeytte hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il nome dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restituisce il valore della proprietà passata
Metodo pubblico | GetChildrenElements | Restutuisce gli elementi figli dell'elemento passato.
Metodo pubblico | GetData | Ritorna l'anagrafica associata all'elemento
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetMovedDocument | Ritorna il documento moved associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento ha figli
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è dirty
Metodo pubblico | MakeAcadCommandContext | Restituisce il contesto dei comandi contestuali in base alla lista di oggetti passati.
Metodo pubblico | OnElementDoubleClicked | Gestione del doppio click su singolo elemento
Metodo pubblico | OnElementsSelected | Gestione della selezione degli elementi sul controllo
Metodo pubblico | OnHotTrackElementClicked | Gestione del singolo click su elemento hot tracking
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di IFileStateInformer

Il tipo IFileStateInformer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Restituisce true se l'elemento ammeytte hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il nome dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restituisce il valore della proprietà passata
Metodo pubblico | GetChildrenElements | Restutuisce gli elementi figli dell'elemento passato.
Metodo pubblico | GetData | Ritorna l'anagrafica associata all'elemento
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetMovedDocument | Ritorna il documento moved associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento ha figli
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è dirty
Metodo pubblico | MakeAcadCommandContext | Restituisce il contesto dei comandi contestuali in base alla lista di oggetti passati.
Metodo pubblico | OnElementDoubleClicked | Gestione del doppio click su singolo elemento
Metodo pubblico | OnElementsSelected | Gestione della selezione degli elementi sul controllo
Metodo pubblico | OnHotTrackElementClicked | Gestione del singolo click su elemento hot tracking
Torna su
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.AllowHotTracking

Metodo IFileStateInformerAllowHotTracking
Restituisce true se l'elemento ammeytte hot tracking

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
bool AllowHotTracking(
    FileStateElement el
)
Function AllowHotTracking (
    el As FileStateElement
) As Boolean
bool AllowHotTracking(
    FileStateElement^ el
)
abstract AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetActiveElement

Metodo IFileStateInformerGetActiveElement
Restituisce l'elemento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
FileStateElement GetActiveElement()
Function GetActiveElement As FileStateElement
FileStateElement^ GetActiveElement()
abstract GetActiveElement : unit -> FileStateElement

Valore di ritorno

FileStateElement
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetAnagStateImageKey

Metodo IFileStateInformerGetAnagStateImageKey
Restituisce l'immagine dello stato dell'anagrafica associata all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
Image GetAnagStateImageKey(
    FileStateElement el
)
Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
Image^ GetAnagStateImageKey(
    FileStateElement^ el
)
abstract GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el FileStateElement

Valore di ritorno

Image
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetAnagStateName

Metodo IFileStateInformerGetAnagStateName
Restituisce il nome dello stato dell'anagrafica associata all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
string GetAnagStateName(
    FileStateElement el
)
Function GetAnagStateName (
    el As FileStateElement
) As String
String^ GetAnagStateName(
    FileStateElement^ el
)
abstract GetAnagStateName :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetAttr

Metodo IFileStateInformerGetAttr
Restituisce il valore della proprietà passata

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
string GetAttr(
    FileStateElement el,
    string attrName
)
Function GetAttr (
    el As FileStateElement,
    attrName As String
) As String
String^ GetAttr(
    FileStateElement^ el,
    String^ attrName
)
abstract GetAttr :
        el : FileStateElement *
        attrName : string -> string

Parametri

el FileStateElement
attrName String

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetChildrenElements

Metodo IFileStateInformerGetChildrenElements
Restutuisce gli elementi figli dell'elemento passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
FileStateElementList GetChildrenElements(
    FileStateElement el
)
Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
)
abstract GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el FileStateElement

Valore di ritorno

FileStateElementList
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetData

Metodo IFileStateInformerGetData
Ritorna l'anagrafica associata all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
DedData GetData(
    FileStateElement el
)
Function GetData (
    el As FileStateElement
) As DedData
DedData^ GetData(
    FileStateElement^ el
)
abstract GetData :
        el : FileStateElement -> DedData

Parametri

el FileStateElement

Valore di ritorno

DedData
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetDocument

Metodo IFileStateInformerGetDocument
Ritorna il documento associato all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
DedDoc GetDocument(
    FileStateElement el
)
Function GetDocument (
    el As FileStateElement
) As DedDoc
DedDoc^ GetDocument(
    FileStateElement^ el
)
abstract GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetMovedDocument

Metodo IFileStateInformerGetMovedDocument
Ritorna il documento moved associato all'elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
DedDoc GetMovedDocument(
    FileStateElement el
)
Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
DedDoc^ GetMovedDocument(
    FileStateElement^ el
)
abstract GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetSelectionImageKey

Metodo IFileStateInformerGetSelectionImageKey
Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
string GetSelectionImageKey(
    FileStateElement el
)
Function GetSelectionImageKey (
    el As FileStateElement
) As String
String^ GetSelectionImageKey(
    FileStateElement^ el
)
abstract GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement
Elemento in oggetto.

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetState

Metodo IFileStateInformerGetState
Restituisce lo stato dell'elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
int GetState(
    FileStateElement el
)
Function GetState (
    el As FileStateElement
) As Integer
int GetState(
    FileStateElement^ el
)
abstract GetState :
        el : FileStateElement -> int

Parametri

el FileStateElement
Elemento da verificare.

Valore di ritorno

Int32
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.GetStateImageKey

Metodo IFileStateInformerGetStateImageKey
Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
string GetStateImageKey(
    FileStateElement el
)
Function GetStateImageKey (
    el As FileStateElement
) As String
String^ GetStateImageKey(
    FileStateElement^ el
)
abstract GetStateImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement
Elemento in oggetto.

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.HasChildrenElements

Metodo IFileStateInformerHasChildrenElements
Indica se l'elemento ha figli

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
bool HasChildrenElements(
    FileStateElement el
)
Function HasChildrenElements (
    el As FileStateElement
) As Boolean
bool HasChildrenElements(
    FileStateElement^ el
)
abstract HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.IsDirty

Metodo IFileStateInformerIsDirty
Ritorna vero se l'elemento passato è dirty

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
bool IsDirty(
    FileStateElement el
)
Function IsDirty (
    el As FileStateElement
) As Boolean
bool IsDirty(
    FileStateElement^ el
)
abstract IsDirty :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.MakeAcadCommandContext

Metodo IFileStateInformerMakeAcadCommandContext
Restituisce il contesto dei comandi contestuali in base alla lista di oggetti passati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
DedAcadCommandContext MakeAcadCommandContext(
    FileStateElementList elsList
)
Function MakeAcadCommandContext (
    elsList As FileStateElementList
) As DedAcadCommandContext
DedAcadCommandContext^ MakeAcadCommandContext(
    FileStateElementList^ elsList
)
abstract MakeAcadCommandContext :
        elsList : FileStateElementList -> DedAcadCommandContext

Parametri

elsList FileStateElementList

Valore di ritorno

DedAcadCommandContext
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.OnElementDoubleClicked

Metodo IFileStateInformerOnElementDoubleClicked
Gestione del doppio click su singolo elemento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
void OnElementDoubleClicked(
    FileStateElement el
)
Sub OnElementDoubleClicked (
    el As FileStateElement
)
void OnElementDoubleClicked(
    FileStateElement^ el
)
abstract OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.OnElementsSelected

Metodo IFileStateInformerOnElementsSelected
Gestione della selezione degli elementi sul controllo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
void OnElementsSelected(
    FileStateElementList elsList
)
Sub OnElementsSelected (
    elsList As FileStateElementList
)
void OnElementsSelected(
    FileStateElementList^ elsList
)
abstract OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList FileStateElementList
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Metodo IFileStateInformer.OnHotTrackElementClicked

Metodo IFileStateInformerOnHotTrackElementClicked
Gestione del singolo click su elemento hot tracking

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
bool OnHotTrackElementClicked(
    FileStateElement el
)
Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
bool OnHotTrackElementClicked(
    FileStateElement^ el
)
abstract OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer


Classe Lua
Utilizzata per chiamare direttamente, in modo trasparente al .NET, funzioni LUA definite sia dai vari file lua del DedNetAcad che native di Top/Top_prt.
Gerarchia di ereditarietà
SystemObject
DedNetAcadLua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class Lua
Public NotInheritable Class Lua
public ref class Lua abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Lua = class end

Il tipo Lua espone i seguenti membri.

Proprietà
Nome | Descrizione
SilentUpdateDedDisOnOpen | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.
Torna su
Metodi
Nome | Descrizione
CreateEmptyLuaTable | Crea e restituisce una nuova table lua vuota, e vrappata.
CreateEmptyPrtArray | Crea e restituisce un nuovo array di parti vuoto.
CreateStructureForPackAndGoExport | Chiama l'omonima funzione lua.
CreateStructureForRilLavMulti | Chiama l'omonima funzione lua.
DbModPop | Ripristina il valore della variabile DBMOD.
DbModPush | Salva il valore della variabile DBMOD.
DedAcadGetCurrentPosAttrName | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DedAcadGetDedIdDedRevFromBomPart | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.
DedAcadGetDedIdDedRevFromPart | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.
DedAcadGetDistSaveStruct | Carica la struttura della distinta in salvataggio
DedAcadGetLolForDistSave | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DumpStack |
LNavRefreshPartIcon | Chiama l'omonima funzione lua.
LNavRefreshPartLabel | Chiama l'omonima funzione lua.
LNavSetDedIcon | Chiama l'omonima funzione lua.
ResetPrtLoadTable | Metodo per il reset della tabella di servizio del carica parte
SetAssemblyOldRevCodes | Chiama l'omonima funzione lua.
setfunhelp | Chiama l'omonima funzione per la registrazione dell'help per i vari comandi.
top_aggtab | Chiama l'omonima funzione lua di aggiornamento generale della tabella
top_updcart | Chiama l'omonima funzione lua.
top_updtab | Chiama l'omonima funzione lua. Se prt è null viene aggiornata tutta la tabella di pallinatura.
top_updtabrev | Chiama la funzione lua qsUpdateTabRev.
TopEditAttrPost | Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.
TopSavePost | Lancia LuaStartEvent() con l'evento TopSavePost passandogli la parte.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di Lua

Il tipo Lua espone i seguenti membri.

Proprietà
Nome | Descrizione
SilentUpdateDedDisOnOpen | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.
Torna su
Vedi anche

Documentazione

Classe Lua


Proprietà Lua.SilentUpdateDedDisOnOpen

Proprietà LuaSilentUpdateDedDisOnOpen
Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SilentUpdateDedDisOnOpen { get; }
Public Shared ReadOnly Property SilentUpdateDedDisOnOpen As Boolean
    Get
public:
static property bool SilentUpdateDedDisOnOpen {
    bool get ();
}
static member SilentUpdateDedDisOnOpen : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Lua


Metodi di Lua

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CreateEmptyLuaTable | Crea e restituisce una nuova table lua vuota, e vrappata.
CreateEmptyPrtArray | Crea e restituisce un nuovo array di parti vuoto.
CreateStructureForPackAndGoExport | Chiama l'omonima funzione lua.
CreateStructureForRilLavMulti | Chiama l'omonima funzione lua.
DbModPop | Ripristina il valore della variabile DBMOD.
DbModPush | Salva il valore della variabile DBMOD.
DedAcadGetCurrentPosAttrName | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DedAcadGetDedIdDedRevFromBomPart | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.
DedAcadGetDedIdDedRevFromPart | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.
DedAcadGetDistSaveStruct | Carica la struttura della distinta in salvataggio
DedAcadGetLolForDistSave | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DumpStack |
LNavRefreshPartIcon | Chiama l'omonima funzione lua.
LNavRefreshPartLabel | Chiama l'omonima funzione lua.
LNavSetDedIcon | Chiama l'omonima funzione lua.
ResetPrtLoadTable | Metodo per il reset della tabella di servizio del carica parte
SetAssemblyOldRevCodes | Chiama l'omonima funzione lua.
setfunhelp | Chiama l'omonima funzione per la registrazione dell'help per i vari comandi.
top_aggtab | Chiama l'omonima funzione lua di aggiornamento generale della tabella
top_updcart | Chiama l'omonima funzione lua.
top_updtab | Chiama l'omonima funzione lua. Se prt è null viene aggiornata tutta la tabella di pallinatura.
top_updtabrev | Chiama la funzione lua qsUpdateTabRev.
TopEditAttrPost | Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.
TopSavePost | Lancia LuaStartEvent() con l'evento TopSavePost passandogli la parte.
Torna su
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateEmptyLuaTable

Metodo LuaCreateEmptyLuaTable
Crea e restituisce una nuova table lua vuota, e vrappata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable CreateEmptyLuaTable()
Public Shared Function CreateEmptyLuaTable As LuaTable
public:
static LuaTable^ CreateEmptyLuaTable()
static member CreateEmptyLuaTable : unit -> LuaTable

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateEmptyPrtArray

Metodo LuaCreateEmptyPrtArray
Crea e restituisce un nuovo array di parti vuoto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray CreateEmptyPrtArray()
Public Shared Function CreateEmptyPrtArray As PartInfoArray
public:
static PartInfoArray^ CreateEmptyPrtArray()
static member CreateEmptyPrtArray : unit -> PartInfoArray

Valore di ritorno

PartInfoArray
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateStructureForPackAndGoExport

Metodo LuaCreateStructureForPackAndGoExport
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void CreateStructureForPackAndGoExport(
    DedCommandDocAnagrInfoList elementList
)
Public Shared Sub CreateStructureForPackAndGoExport (
    elementList As DedCommandDocAnagrInfoList
)
public:
static void CreateStructureForPackAndGoExport(
    DedCommandDocAnagrInfoList^ elementList
)
static member CreateStructureForPackAndGoExport :
        elementList : DedCommandDocAnagrInfoList -> unit

Parametri

elementList DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateStructureForRilLavMulti

Metodo LuaCreateStructureForRilLavMulti
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void CreateStructureForRilLavMulti(
    List<MultipleStateOperationPartInfoDoc> elementList
)
Public Shared Sub CreateStructureForRilLavMulti (
    elementList As List(Of MultipleStateOperationPartInfoDoc)
)
public:
static void CreateStructureForRilLavMulti(
    List<MultipleStateOperationPartInfoDoc^>^ elementList
)
static member CreateStructureForRilLavMulti :
        elementList : List<MultipleStateOperationPartInfoDoc> -> unit

Parametri

elementList List MultipleStateOperationPartInfoDoc
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DbModPop

Metodo LuaDbModPop
Ripristina il valore della variabile DBMOD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DbModPop()
Public Shared Sub DbModPop
public:
static void DbModPop()
static member DbModPop : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DbModPush

Metodo LuaDbModPush
Salva il valore della variabile DBMOD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DbModPush()
Public Shared Sub DbModPush
public:
static void DbModPush()
static member DbModPush : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetCurrentPosAttrName

Metodo LuaDedAcadGetCurrentPosAttrName
Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string DedAcadGetCurrentPosAttrName()
Public Shared Function DedAcadGetCurrentPosAttrName As String
public:
static String^ DedAcadGetCurrentPosAttrName()
static member DedAcadGetCurrentPosAttrName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetDedIdDedRevFromBomPart

Metodo LuaDedAcadGetDedIdDedRevFromBomPart
Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadGetDedIdDedRevFromBomPart(
    BomPartInfo prt,
    out string dedid,
    out string dedrev
)
Public Shared Sub DedAcadGetDedIdDedRevFromBomPart (
    prt As BomPartInfo,
    <OutAttribute> ByRef dedid As String,
    <OutAttribute> ByRef dedrev As String
)
public:
static void DedAcadGetDedIdDedRevFromBomPart(
    BomPartInfo^ prt,
    [OutAttribute] String^% dedid,
    [OutAttribute] String^% dedrev
)
static member DedAcadGetDedIdDedRevFromBomPart :
        prt : BomPartInfo *
        dedid : string byref *
        dedrev : string byref -> unit

Parametri

prt BomPartInfo
dedid String
dedrev String
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetDedIdDedRevFromPart

Metodo LuaDedAcadGetDedIdDedRevFromPart
Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadGetDedIdDedRevFromPart(
    PartInfo prt,
    out string dedid,
    out string dedrev
)
Public Shared Sub DedAcadGetDedIdDedRevFromPart (
    prt As PartInfo,
    <OutAttribute> ByRef dedid As String,
    <OutAttribute> ByRef dedrev As String
)
public:
static void DedAcadGetDedIdDedRevFromPart(
    PartInfo^ prt,
    [OutAttribute] String^% dedid,
    [OutAttribute] String^% dedrev
)
static member DedAcadGetDedIdDedRevFromPart :
        prt : PartInfo *
        dedid : string byref *
        dedrev : string byref -> unit

Parametri

prt PartInfo
dedid String
dedrev String
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetDistSaveStruct

Metodo LuaDedAcadGetDistSaveStruct
Carica la struttura della distinta in salvataggio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedAcadGetDistSaveStruct(
    LuaTable args
)
Public Shared Function DedAcadGetDistSaveStruct (
    args As LuaTable
) As LuaTable
public:
static LuaTable^ DedAcadGetDistSaveStruct(
    LuaTable^ args
)
static member DedAcadGetDistSaveStruct :
        args : LuaTable -> LuaTable

Parametri

args LuaTable

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetLolForDistSave

Metodo LuaDedAcadGetLolForDistSave
Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedAcadGetLolForDistSave(
    LuaTable arg
)
Public Shared Function DedAcadGetLolForDistSave (
    arg As LuaTable
) As LuaTable
public:
static LuaTable^ DedAcadGetLolForDistSave(
    LuaTable^ arg
)
static member DedAcadGetLolForDistSave :
        arg : LuaTable -> LuaTable

Parametri

arg LuaTable

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DumpStack

Metodo LuaDumpStack

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void DumpStack()
Public Shared Sub DumpStack
public:
static void DumpStack()
static member DumpStack : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.LNavRefreshPartIcon

Metodo LuaLNavRefreshPartIcon
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void LNavRefreshPartIcon(
    PartInfo prt
)
Public Shared Sub LNavRefreshPartIcon (
    prt As PartInfo
)
public:
static void LNavRefreshPartIcon(
    PartInfo^ prt
)
static member LNavRefreshPartIcon :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Vedi anche

Documentazione

Classe Lua


Metodo Lua.LNavRefreshPartLabel

Metodo LuaLNavRefreshPartLabel
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void LNavRefreshPartLabel(
    PartInfo prt
)
Public Shared Sub LNavRefreshPartLabel (
    prt As PartInfo
)
public:
static void LNavRefreshPartLabel(
    PartInfo^ prt
)
static member LNavRefreshPartLabel :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Vedi anche

Documentazione

Classe Lua


Metodo Lua.LNavSetDedIcon

Metodo LuaLNavSetDedIcon
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void LNavSetDedIcon(
    PartInfo prt,
    int dwgstatus,
    int anagrStatus
)
Public Shared Sub LNavSetDedIcon (
    prt As PartInfo,
    dwgstatus As Integer,
    anagrStatus As Integer
)
public:
static void LNavSetDedIcon(
    PartInfo^ prt,
    int dwgstatus,
    int anagrStatus
)
static member LNavSetDedIcon :
        prt : PartInfo *
        dwgstatus : int *
        anagrStatus : int -> unit

Parametri

prt PartInfo
dwgstatus Int32
anagrStatus Int32
Vedi anche

Documentazione

Classe Lua


Metodo Lua.ResetPrtLoadTable

Metodo LuaResetPrtLoadTable
Metodo per il reset della tabella di servizio del carica parte

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ResetPrtLoadTable()
Public Shared Sub ResetPrtLoadTable
public:
static void ResetPrtLoadTable()
static member ResetPrtLoadTable : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.SetAssemblyOldRevCodes

Metodo LuaSetAssemblyOldRevCodes
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetAssemblyOldRevCodes(
    ListObjToUpdate elementList
)
Public Shared Sub SetAssemblyOldRevCodes (
    elementList As ListObjToUpdate
)
public:
static void SetAssemblyOldRevCodes(
    ListObjToUpdate^ elementList
)
static member SetAssemblyOldRevCodes :
        elementList : ListObjToUpdate -> unit

Parametri

elementList ListObjToUpdate
Vedi anche

Documentazione

Classe Lua


Metodo Lua.setfunhelp

Metodo Luasetfunhelp
Chiama l'omonima funzione per la registrazione dell'help per i vari comandi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void setfunhelp(
    string cmdName,
    string helpFullFileName,
    string topicName
)
Public Shared Sub setfunhelp (
    cmdName As String,
    helpFullFileName As String,
    topicName As String
)
public:
static void setfunhelp(
    String^ cmdName,
    String^ helpFullFileName,
    String^ topicName
)
static member setfunhelp :
        cmdName : string *
        helpFullFileName : string *
        topicName : string -> unit

Parametri

cmdName String
Nome del comando.
helpFullFileName String
Nome completo del file di help.
topicName String
Nome univoco argomento.
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_aggtab

Metodo Luatop_aggtab
Chiama l'omonima funzione lua di aggiornamento generale della tabella

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void top_aggtab()
Public Shared Sub top_aggtab
public:
static void top_aggtab()
static member top_aggtab : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_updcart

Metodo Luatop_updcart
Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void top_updcart()
Public Shared Sub top_updcart
public:
static void top_updcart()
static member top_updcart : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_updtab

Metodo Luatop_updtab
Chiama l'omonima funzione lua. Se prt è null viene aggiornata tutta la tabella di pallinatura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void top_updtab(
    PartInfo prt
)
Public Shared Sub top_updtab (
    prt As PartInfo
)
public:
static void top_updtab(
    PartInfo^ prt
)
static member top_updtab :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_updtabrev

Metodo Luatop_updtabrev
Chiama la funzione lua qsUpdateTabRev.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void top_updtabrev()
Public Shared Sub top_updtabrev
public:
static void top_updtabrev()
static member top_updtabrev : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.TopEditAttrPost

Metodo LuaTopEditAttrPost
Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void TopEditAttrPost(
    PartInfo prt
)
Public Shared Sub TopEditAttrPost (
    prt As PartInfo
)
public:
static void TopEditAttrPost(
    PartInfo^ prt
)
static member TopEditAttrPost :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Parte da passare all'evento.
Vedi anche

Documentazione

Classe Lua


Metodo Lua.TopSavePost

Metodo LuaTopSavePost
Lancia LuaStartEvent() con l'evento TopSavePost passandogli la parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void TopSavePost(
    PartInfo prt
)
Public Shared Sub TopSavePost (
    prt As PartInfo
)
public:
static void TopSavePost(
    PartInfo^ prt
)
static member TopSavePost :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Parte da passare all'evento.
Vedi anche

Documentazione

Classe Lua


Enumerazione PackAndGoContext
Definizione possibili contesti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoContext
Public Enumeration PackAndGoContext
public enum class PackAndGoContext
type PackAndGoContext
Membri
Nome | Valore | Descrizione
Import | 0 |
Export | 1 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PackAndGoExport
Esportazione packAndgo Autocad
Gerarchia di ereditarietà
SystemObject
DedCommand
DedDocumentCommand
DedNetAcadPackAndGoExport

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoExport : DedDocumentCommand
Public Class PackAndGoExport
    Inherits DedDocumentCommand
public ref class PackAndGoExport : public DedDocumentCommand
type PackAndGoExport =
    class
        inherit DedDocumentCommand
    end

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedDocumentCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunFromAcad | Imposta/Restituisce se il comando è stato lanciato dalle icone di Autocad o no
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedDocumentCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedDocumentCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunFromAcad | Imposta/Restituisce se il comando è stato lanciato dalle icone di Autocad o no
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport


Proprietà PackAndGoExport.NeedParameters

Proprietà PackAndGoExportNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoExport


Proprietà PackAndGoExport.RunFromAcad

Proprietà PackAndGoExportRunFromAcad
Imposta/Restituisce se il comando è stato lanciato dalle icone di Autocad o no

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool RunFromAcad { get; set; }
Public Property RunFromAcad As Boolean
    Get
    Set
public:
property bool RunFromAcad {
    bool get ();
    void set (bool value);
}
member RunFromAcad : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoExport


Metodi di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedDocumentCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.ClearCommand

Metodo PackAndGoExportClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.Enabled

Metodo PackAndGoExportEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.ExecuteCommand

Metodo PackAndGoExportExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.SetContext

Metodo PackAndGoExportSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PackAndGoExport


Classe PackAndGoImport
Esportazione packAndgo Autocad
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadPackAndGoImport

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImport : DedCommand
Public Class PackAndGoImport
    Inherits DedCommand
public ref class PackAndGoImport : public DedCommand
type PackAndGoImport =
    class
        inherit DedCommand
    end

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport


Proprietà PackAndGoImport.NeedParameters

Proprietà PackAndGoImportNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoImport


Metodi di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.ClearCommand

Metodo PackAndGoImportClearCommand

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.Enabled

Metodo PackAndGoImportEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.ExecuteCommand

Metodo PackAndGoImportExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.SetContext

Metodo PackAndGoImportSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PackAndGoImport


Enumerazione PackAndGoImportAttrStatus
Stato attributi in validazione importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportAttrStatus
Public Enumeration PackAndGoImportAttrStatus
public enum class PackAndGoImportAttrStatus
type PackAndGoImportAttrStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Compare | 1 |
MandatoryMissing | 2 |
Undefined | 3 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione PackAndGoImportDedCases
Possibili casi del database in fase di importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportDedCases
Public Enumeration PackAndGoImportDedCases
public enum class PackAndGoImportDedCases
type PackAndGoImportDedCases
Membri
Nome | Valore | Descrizione
None | 0 |
NoDed | 1 |
DedRemote | 2 |
DedVpn | 3 |
UserFolder | 4 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PackAndGoImportingStructureInfo
Oggetto di servizio per l'impostazione delle informazioni di descrittore e operazione
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoImportingStructureInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImportingStructureInfo
Public Class PackAndGoImportingStructureInfo
public ref class PackAndGoImportingStructureInfo
type PackAndGoImportingStructureInfo = class end

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoImportingStructureInfo |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoImportingStructureInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo()
Public Sub New
public:
PackAndGoImportingStructureInfo()
new : unit -> PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Metodi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Metodo PackAndGoImportingStructureInfo.Clone

Metodo PackAndGoImportingStructureInfoClone
Clonazione dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo Clone()
Public Function Clone As PackAndGoImportingStructureInfo
public:
PackAndGoImportingStructureInfo^ Clone()
member Clone : unit -> PackAndGoImportingStructureInfo

Valore di ritorno

PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.AttrStatus

Campo PackAndGoImportingStructureInfoAttrStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportAttrStatus AttrStatus
Public AttrStatus As PackAndGoImportAttrStatus
public:
PackAndGoImportAttrStatus AttrStatus
val mutable AttrStatus: PackAndGoImportAttrStatus

Valore del campo

PackAndGoImportAttrStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.AttrStatusRepresentation

Campo PackAndGoImportingStructureInfoAttrStatusRepresentation

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Image AttrStatusRepresentation
Public AttrStatusRepresentation As Image
public:
Image^ AttrStatusRepresentation
val mutable AttrStatusRepresentation: Image

Valore del campo

Image
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.Checkable

Campo PackAndGoImportingStructureInfoCheckable

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Checkable
Public Checkable As Boolean
public:
bool Checkable
val mutable Checkable: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.DocAlreadyCompared

Campo PackAndGoImportingStructureInfoDocAlreadyCompared

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocAlreadyCompared
Public DocAlreadyCompared As Boolean
public:
bool DocAlreadyCompared
val mutable DocAlreadyCompared: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.ImportNote

Campo PackAndGoImportingStructureInfoImportNote

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ImportNote
Public ImportNote As String
public:
String^ ImportNote
val mutable ImportNote: string

Valore del campo

String
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.OperationStatus

Campo PackAndGoImportingStructureInfoOperationStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperationStatus OperationStatus
Public OperationStatus As PackAndGoImportOperationStatus
public:
PackAndGoImportOperationStatus OperationStatus
val mutable OperationStatus: PackAndGoImportOperationStatus

Valore del campo

PackAndGoImportOperationStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.PckImportOperation

Campo PackAndGoImportingStructureInfoPckImportOperation

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation PckImportOperation
Public PckImportOperation As PackAndGoImportOperation
public:
PackAndGoImportOperation PckImportOperation
val mutable PckImportOperation: PackAndGoImportOperation

Valore del campo

PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.PckNdDescr

Campo PackAndGoImportingStructureInfoPckNdDescr

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor PckNdDescr
Public PckNdDescr As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ PckNdDescr
val mutable PckNdDescr: PackAndGoNodeDescriptor

Valore del campo

PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Enumerazione PackAndGoImportOperation
Definizione possibili azioni su oggetti importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperation
Public Enumeration PackAndGoImportOperation
public enum class PackAndGoImportOperation
type PackAndGoImportOperation
Membri
Nome | Valore | Descrizione
Ignora | 0 |
Sovrascrivi | 1 |
Codifica | 2 |
Associa | 3 |
Clona | 4 |
Salta | 5 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione PackAndGoImportOperationStatus
Stato di validazione dell'operazione ( per ora non usata sempre Ok )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperationStatus
Public Enumeration PackAndGoImportOperationStatus
public enum class PackAndGoImportOperationStatus
type PackAndGoImportOperationStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Error | 1 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PackAndGoNodeDescriptor
Descrittore singolo nodo di struttura
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoNodeDescriptor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptor
<SerializableAttribute>
Public Class PackAndGoNodeDescriptor
[SerializableAttribute]
public ref class PackAndGoNodeDescriptor
[<SerializableAttribute>]
type PackAndGoNodeDescriptor = class end

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor | Costruttore senza parametri per la serializzazione
Metodo pubblico | PackAndGoNodeDescriptor(AcadDocStructInfo) | Costruttore dell'oggetto
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData) | Costruttore alternativo con informazioni documentali ed anagrafiche.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Children | Sotto struttura dei descrittori
Proprietà pubblica | Context | Eventuale contesto di associazione
Proprietà pubblica | DbPath | Path della famiglia dell'anagrafica associata
Proprietà pubblica | DedId | Id della angrafica
Proprietà pubblica | DedRev | Revisione anagrafica
Proprietà pubblica | DocId | Id del documento
Proprietà pubblica | DocIsMovingDestination | Indica se il documento è stato movato.
Proprietà pubblica | DocRowVer | Revisione del documento
Proprietà pubblica | FullFileName | Percorso assoluto del file
Proprietà pubblica | HasData | Restituisce se il documento è collegato ad una anagrafica.
Proprietà pubblica | InfoUser | Tassello utente dell'anagrafica
Proprietà pubblica | MakeAnagrObs | Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Progr | Progressivo dell'anagrafica
Proprietà pubblica | RelativeFileName | Percorso relativo alla root del packandgo
Proprietà pubblica | RootedPath | Path rooted del documento
Proprietà pubblica | ToBeMoved | Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IsSameVersion | Controlla se la versione passata coincide con quella del nodo.
Metodo pubblico | MatchRelativeFileName | Controlla il match tra il nodo in esame ed il percorso relativo passato
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoNodeDescriptor
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor | Costruttore senza parametri per la serializzazione
Metodo pubblico | PackAndGoNodeDescriptor(AcadDocStructInfo) | Costruttore dell'oggetto
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData) | Costruttore alternativo con informazioni documentali ed anagrafiche.
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Costruttore PackAndGoNodeDescriptor
Costruttore senza parametri per la serializzazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor()
Public Sub New
public:
PackAndGoNodeDescriptor()
new : unit -> PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor


Costruttore PackAndGoNodeDescriptor(AcadDocStructInfo)
Costruttore dell'oggetto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    AcadDocStructInfo ds
)
Public Sub New (
    ds As AcadDocStructInfo
)
public:
PackAndGoNodeDescriptor(
    AcadDocStructInfo^ ds
)
new :
        ds : AcadDocStructInfo -> PackAndGoNodeDescriptor

Parametri

ds AcadDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor


Costruttore PackAndGoNodeDescriptor(DedDoc, DedData)
Costruttore alternativo con informazioni documentali ed anagrafiche.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    DedDoc ddoc,
    DedData ddata
)
Public Sub New (
    ddoc As DedDoc,
    ddata As DedData
)
public:
PackAndGoNodeDescriptor(
    DedDoc^ ddoc,
    DedData^ ddata
)
new :
        ddoc : DedDoc *
        ddata : DedData -> PackAndGoNodeDescriptor

Parametri

ddoc DedDoc
Documento
ddata DedData
Anagrafica
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor


Proprietà di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Children | Sotto struttura dei descrittori
Proprietà pubblica | Context | Eventuale contesto di associazione
Proprietà pubblica | DbPath | Path della famiglia dell'anagrafica associata
Proprietà pubblica | DedId | Id della angrafica
Proprietà pubblica | DedRev | Revisione anagrafica
Proprietà pubblica | DocId | Id del documento
Proprietà pubblica | DocIsMovingDestination | Indica se il documento è stato movato.
Proprietà pubblica | DocRowVer | Revisione del documento
Proprietà pubblica | FullFileName | Percorso assoluto del file
Proprietà pubblica | HasData | Restituisce se il documento è collegato ad una anagrafica.
Proprietà pubblica | InfoUser | Tassello utente dell'anagrafica
Proprietà pubblica | MakeAnagrObs | Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Progr | Progressivo dell'anagrafica
Proprietà pubblica | RelativeFileName | Percorso relativo alla root del packandgo
Proprietà pubblica | RootedPath | Path rooted del documento
Proprietà pubblica | ToBeMoved | Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.Children

Proprietà PackAndGoNodeDescriptorChildren
Sotto struttura dei descrittori

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Children { get; set; }
Public Property Children As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Children {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Children : PackAndGoNodeDescriptors with get, set

Valore della proprietà

PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.Context

Proprietà PackAndGoNodeDescriptorContext
Eventuale contesto di associazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DbPath

Proprietà PackAndGoNodeDescriptorDbPath
Path della famiglia dell'anagrafica associata

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DedId

Proprietà PackAndGoNodeDescriptorDedId
Id della angrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; set; }
Public Property DedId As String
    Get
    Set
public:
property String^ DedId {
    String^ get ();
    void set (String^ value);
}
member DedId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DedRev

Proprietà PackAndGoNodeDescriptorDedRev
Revisione anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; set; }
Public Property DedRev As String
    Get
    Set
public:
property String^ DedRev {
    String^ get ();
    void set (String^ value);
}
member DedRev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DocId

Proprietà PackAndGoNodeDescriptorDocId
Id del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocId { get; set; }
Public Property DocId As Guid
    Get
    Set
public:
property Guid DocId {
    Guid get ();
    void set (Guid value);
}
member DocId : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DocIsMovingDestination

Proprietà PackAndGoNodeDescriptorDocIsMovingDestination
Indica se il documento è stato movato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocIsMovingDestination { get; set; }
Public Property DocIsMovingDestination As Boolean
    Get
    Set
public:
property bool DocIsMovingDestination {
    bool get ();
    void set (bool value);
}
member DocIsMovingDestination : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DocRowVer

Proprietà PackAndGoNodeDescriptorDocRowVer
Revisione del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocRowVer { get; set; }
Public Property DocRowVer As Guid
    Get
    Set
public:
property Guid DocRowVer {
    Guid get ();
    void set (Guid value);
}
member DocRowVer : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.FullFileName

Proprietà PackAndGoNodeDescriptorFullFileName
Percorso assoluto del file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.HasData

Proprietà PackAndGoNodeDescriptorHasData
Restituisce se il documento è collegato ad una anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasData { get; }
Public ReadOnly Property HasData As Boolean
    Get
public:
property bool HasData {
    bool get ();
}
member HasData : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.InfoUser

Proprietà PackAndGoNodeDescriptorInfoUser
Tassello utente dell'anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.MakeAnagrObs

Proprietà PackAndGoNodeDescriptorMakeAnagrObs
Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool MakeAnagrObs { get; set; }
Public Property MakeAnagrObs As Boolean
    Get
    Set
public:
property bool MakeAnagrObs {
    bool get ();
    void set (bool value);
}
member MakeAnagrObs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.MovedByMasterAfterSend

Proprietà PackAndGoNodeDescriptorMovedByMasterAfterSend

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool MovedByMasterAfterSend { get; set; }
Public Property MovedByMasterAfterSend As Boolean
    Get
    Set
public:
property bool MovedByMasterAfterSend {
    bool get ();
    void set (bool value);
}
member MovedByMasterAfterSend : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.Progr

Proprietà PackAndGoNodeDescriptorProgr
Progressivo dell'anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.RelativeFileName

Proprietà PackAndGoNodeDescriptorRelativeFileName
Percorso relativo alla root del packandgo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RelativeFileName { get; set; }
Public Property RelativeFileName As String
    Get
    Set
public:
property String^ RelativeFileName {
    String^ get ();
    void set (String^ value);
}
member RelativeFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.RootedPath

Proprietà PackAndGoNodeDescriptorRootedPath
Path rooted del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RootedPath { get; set; }
Public Property RootedPath As String
    Get
    Set
public:
property String^ RootedPath {
    String^ get ();
    void set (String^ value);
}
member RootedPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.ToBeMoved

Proprietà PackAndGoNodeDescriptorToBeMoved
Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeMoved { get; set; }
Public Property ToBeMoved As Boolean
    Get
    Set
public:
property bool ToBeMoved {
    bool get ();
    void set (bool value);
}
member ToBeMoved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodi di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IsSameVersion | Controlla se la versione passata coincide con quella del nodo.
Metodo pubblico | MatchRelativeFileName | Controlla il match tra il nodo in esame ed il percorso relativo passato
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.Equals

Metodo PackAndGoNodeDescriptorEquals

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.GetHashCode

Metodo PackAndGoNodeDescriptorGetHashCode

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.IsSameVersion

Metodo PackAndGoNodeDescriptorIsSameVersion
Controlla se la versione passata coincide con quella del nodo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSameVersion(
    Guid docRowVer
)
Public Function IsSameVersion (
    docRowVer As Guid
) As Boolean
public:
bool IsSameVersion(
    Guid docRowVer
)
member IsSameVersion :
        docRowVer : Guid -> bool

Parametri

docRowVer Guid

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.MatchRelativeFileName

Metodo PackAndGoNodeDescriptorMatchRelativeFileName
Controlla il match tra il nodo in esame ed il percorso relativo passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool MatchRelativeFileName(
    string relativePath
)
Public Function MatchRelativeFileName (
    relativePath As String
) As Boolean
public:
bool MatchRelativeFileName(
    String^ relativePath
)
member MatchRelativeFileName :
        relativePath : string -> bool

Parametri

relativePath String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.ToString

Metodo PackAndGoNodeDescriptorToString

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Classe PackAndGoNodeDescriptors
Classe gestione lista nodi di struttura
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList PackAndGoNodeDescriptor
DedNetAcadPackAndGoNodeDescriptors

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptors : List<PackAndGoNodeDescriptor>
<SerializableAttribute>
Public Class PackAndGoNodeDescriptors
    Inherits List(Of PackAndGoNodeDescriptor)
[SerializableAttribute]
public ref class PackAndGoNodeDescriptors : public List<PackAndGoNodeDescriptor^>
[<SerializableAttribute>]
type PackAndGoNodeDescriptors =
    class
        inherit List<PackAndGoNodeDescriptor>
    end

Il tipo PackAndGoNodeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptors |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoNodeDescriptors

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors()
Public Sub New
public:
PackAndGoNodeDescriptors()
new : unit -> PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptors


Classe PackAndGoNodeWrapper
Classe rappresentante l'oggetto nodo nel controllo treeList del form
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoNodeWrapper

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoNodeWrapper
Public Class PackAndGoNodeWrapper
public ref class PackAndGoNodeWrapper
type PackAndGoNodeWrapper = class end

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) | Costrutture basato su DedDoc
Metodo pubblico | PackAndGoNodeWrapper(DedData, AcadDocStructInfo, PackAndGoContext) | Costruttore del descrittore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto dell'operazione (import/export)
Proprietà pubblica | Data | Anagrafica di riferimento del nodo rappresentante una anagrafica
Proprietà pubblica | DedDoc |
Proprietà pubblica | DedType | Famiglia nella quale codificare il documento (import)
Proprietà pubblica | DestRoot | Root di destinazione del file
Proprietà pubblica | DocStructInfo | Ritorna l'AcadDocStructInfo di riferimento per il descrittore
Proprietà pubblica | FullFileName | Percorso assoluto del file che identifica il nodo
Proprietà pubblica | ImportStructureInfo | Informazioni di importazione associabili al descrittore
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | InvolvedInImportOperations | Indica se l'oggetto sarà coinvolto nelle operazioni di import
Proprietà pubblica | IsDataNode | Ritorna vero se il nodo rappresenta una anagrafica
Proprietà pubblica | NewFullFileName | Indica il nuovo file da utilizzare nel caso di Salta ( impostato solo tramite Lua )
Proprietà pubblica | Node | Ritorna/Importa l'oggetto nodo nativo corrispondente
Proprietà pubblica | NodeInfoCompleted | Restituisce se il nodo ha tutte le informazioni necessarie
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Metodo pubblico | SetData | Setta i dati sul nodo
Metodo pubblico | SetNodeIcon | Setta l'icona sul nodo
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoNodeWrapper
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) | Costrutture basato su DedDoc
Metodo pubblico | PackAndGoNodeWrapper(DedData, AcadDocStructInfo, PackAndGoContext) | Costruttore del descrittore
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Costruttore PackAndGoNodeWrapper(DedDoc, PackAndGoContext)
Costrutture basato su DedDoc

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedDoc ddoc,
    PackAndGoContext context
)
Public Sub New (
    ddoc As DedDoc,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedDoc^ ddoc,
    PackAndGoContext context
)
new :
        ddoc : DedDoc *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddoc DedDoc
context PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper


Costruttore PackAndGoNodeWrapper(DedData, AcadDocStructInfo, PackAndGoContext)
Costruttore del descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedData ddata,
    AcadDocStructInfo acadDsInfo,
    PackAndGoContext context
)
Public Sub New (
    ddata As DedData,
    acadDsInfo As AcadDocStructInfo,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedData^ ddata,
    AcadDocStructInfo^ acadDsInfo,
    PackAndGoContext context
)
new :
        ddata : DedData *
        acadDsInfo : AcadDocStructInfo *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddata DedData
acadDsInfo AcadDocStructInfo
context PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper


Proprietà di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto dell'operazione (import/export)
Proprietà pubblica | Data | Anagrafica di riferimento del nodo rappresentante una anagrafica
Proprietà pubblica | DedDoc |
Proprietà pubblica | DedType | Famiglia nella quale codificare il documento (import)
Proprietà pubblica | DestRoot | Root di destinazione del file
Proprietà pubblica | DocStructInfo | Ritorna l'AcadDocStructInfo di riferimento per il descrittore
Proprietà pubblica | FullFileName | Percorso assoluto del file che identifica il nodo
Proprietà pubblica | ImportStructureInfo | Informazioni di importazione associabili al descrittore
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | InvolvedInImportOperations | Indica se l'oggetto sarà coinvolto nelle operazioni di import
Proprietà pubblica | IsDataNode | Ritorna vero se il nodo rappresenta una anagrafica
Proprietà pubblica | NewFullFileName | Indica il nuovo file da utilizzare nel caso di Salta ( impostato solo tramite Lua )
Proprietà pubblica | Node | Ritorna/Importa l'oggetto nodo nativo corrispondente
Proprietà pubblica | NodeInfoCompleted | Restituisce se il nodo ha tutte le informazioni necessarie
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Context

Proprietà PackAndGoNodeWrapperContext
Contesto dell'operazione (import/export)

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoContext Context { get; set; }
Public Property Context As PackAndGoContext
    Get
    Set
public:
property PackAndGoContext Context {
    PackAndGoContext get ();
    void set (PackAndGoContext value);
}
member Context : PackAndGoContext with get, set

Valore della proprietà

PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Data

Proprietà PackAndGoNodeWrapperData
Anagrafica di riferimento del nodo rappresentante una anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DedDoc

Proprietà PackAndGoNodeWrapperDedDoc

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DedType

Proprietà PackAndGoNodeWrapperDedType
Famiglia nella quale codificare il documento (import)

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DestRoot

Proprietà PackAndGoNodeWrapperDestRoot
Root di destinazione del file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DocStructInfo

Proprietà PackAndGoNodeWrapperDocStructInfo
Ritorna l'AcadDocStructInfo di riferimento per il descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public AcadDocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As AcadDocStructInfo
    Get
public:
property AcadDocStructInfo^ DocStructInfo {
    AcadDocStructInfo^ get ();
}
member DocStructInfo : AcadDocStructInfo with get

Valore della proprietà

AcadDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.FullFileName

Proprietà PackAndGoNodeWrapperFullFileName
Percorso assoluto del file che identifica il nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.ImportStructureInfo

Proprietà PackAndGoNodeWrapperImportStructureInfo
Informazioni di importazione associabili al descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo ImportStructureInfo { get; set; }
Public Property ImportStructureInfo As PackAndGoImportingStructureInfo
    Get
    Set
public:
property PackAndGoImportingStructureInfo^ ImportStructureInfo {
    PackAndGoImportingStructureInfo^ get ();
    void set (PackAndGoImportingStructureInfo^ value);
}
member ImportStructureInfo : PackAndGoImportingStructureInfo with get, set

Valore della proprietà

PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.InfoUser

Proprietà PackAndGoNodeWrapperInfoUser
Infouser impostato da pers Lua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.InvolvedInImportOperations

Proprietà PackAndGoNodeWrapperInvolvedInImportOperations
Indica se l'oggetto sarà coinvolto nelle operazioni di import

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool InvolvedInImportOperations { get; set; }
Public Property InvolvedInImportOperations As Boolean
    Get
    Set
public:
property bool InvolvedInImportOperations {
    bool get ();
    void set (bool value);
}
member InvolvedInImportOperations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.IsDataNode

Proprietà PackAndGoNodeWrapperIsDataNode
Ritorna vero se il nodo rappresenta una anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDataNode { get; }
Public ReadOnly Property IsDataNode As Boolean
    Get
public:
property bool IsDataNode {
    bool get ();
}
member IsDataNode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.NewFullFileName

Proprietà PackAndGoNodeWrapperNewFullFileName
Indica il nuovo file da utilizzare nel caso di Salta ( impostato solo tramite Lua )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Node

Proprietà PackAndGoNodeWrapperNode
Ritorna/Importa l'oggetto nodo nativo corrispondente

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; set; }
Public Property Node As TreeListNode
    Get
    Set
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
    void set (TreeListNode^ value);
}
member Node : TreeListNode with get, set

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.NodeInfoCompleted

Proprietà PackAndGoNodeWrapperNodeInfoCompleted
Restituisce se il nodo ha tutte le informazioni necessarie

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool NodeInfoCompleted { get; }
Public ReadOnly Property NodeInfoCompleted As Boolean
    Get
public:
property bool NodeInfoCompleted {
    bool get ();
}
member NodeInfoCompleted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.OutofPackGo

Proprietà PackAndGoNodeWrapperOutofPackGo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool OutofPackGo { get; set; }
Public Property OutofPackGo As Boolean
    Get
    Set
public:
property bool OutofPackGo {
    bool get ();
    void set (bool value);
}
member OutofPackGo : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Progr

Proprietà PackAndGoNodeWrapperProgr
Progr impostato da pers Lua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Rev

Proprietà PackAndGoNodeWrapperRev
Rev impostato da pers Lua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodi di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Metodo pubblico | SetData | Setta i dati sul nodo
Metodo pubblico | SetNodeIcon | Setta l'icona sul nodo
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodo PackAndGoNodeWrapper.Clone

Metodo PackAndGoNodeWrapperClone
Clonazione dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper Clone()
Public Function Clone As PackAndGoNodeWrapper
public:
PackAndGoNodeWrapper^ Clone()
member Clone : unit -> PackAndGoNodeWrapper

Valore di ritorno

PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodo PackAndGoNodeWrapper.SetData

Metodo PackAndGoNodeWrapperSetData
Setta i dati sul nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    TreeListNode node
)
Public Sub SetData (
    node As TreeListNode
)
public:
void SetData(
    TreeListNode^ node
)
member SetData :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodo PackAndGoNodeWrapper.SetNodeIcon

Metodo PackAndGoNodeWrapperSetNodeIcon
Setta l'icona sul nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetNodeIcon(
    ImageList il,
    TreeListNode node
)
Public Sub SetNodeIcon (
    il As ImageList,
    node As TreeListNode
)
public:
void SetNodeIcon(
    ImageList^ il,
    TreeListNode^ node
)
member SetNodeIcon :
        il : ImageList *
        node : TreeListNode -> unit

Parametri

il ImageList
node TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Classe PackAndGoStructureDescriptor
Descrittore di tutta la struttura che viene serializzato. Contiene informazioni sul database e sulla struttura esportata
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoStructureDescriptor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoStructureDescriptor
<SerializableAttribute>
Public Class PackAndGoStructureDescriptor
[SerializableAttribute]
public ref class PackAndGoStructureDescriptor
[<SerializableAttribute>]
type PackAndGoStructureDescriptor = class end

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoStructureDescriptor | Costrutture della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported | Indica se il pacchetto è già stato importato.
Proprietà pubblica | CorporateId | Identificativo aziendale
Proprietà pubblica | DbType | Ritorna il tipo di database. Può essere master o slave
Proprietà pubblica | DescriptorFullPath | Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore
Proprietà pubblica | MajorVer | Identificativo della versione
Proprietà pubblica | MinorVer | Identificativo della versione
Proprietà pubblica | Structure | Sotto struttura dei descrittori
Proprietà pubblica | UserId | Identificativo dell'utente che ha eseguito l'operazione
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna se esisto il descrittore nodo corrispondente al nodo passato
Metodo pubblico | GetCurrentImportAction | Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.
Metodo pubblico | SerializeMe | Metodo per la serializzazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoStructureDescriptor
Costrutture della classe

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor()
Public Sub New
public:
PackAndGoStructureDescriptor()
new : unit -> PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported | Indica se il pacchetto è già stato importato.
Proprietà pubblica | CorporateId | Identificativo aziendale
Proprietà pubblica | DbType | Ritorna il tipo di database. Può essere master o slave
Proprietà pubblica | DescriptorFullPath | Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore
Proprietà pubblica | MajorVer | Identificativo della versione
Proprietà pubblica | MinorVer | Identificativo della versione
Proprietà pubblica | Structure | Sotto struttura dei descrittori
Proprietà pubblica | UserId | Identificativo dell'utente che ha eseguito l'operazione
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.AlreadyImported

Proprietà PackAndGoStructureDescriptorAlreadyImported
Indica se il pacchetto è già stato importato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AlreadyImported { get; set; }
Public Property AlreadyImported As Boolean
    Get
    Set
public:
property bool AlreadyImported {
    bool get ();
    void set (bool value);
}
member AlreadyImported : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.CorporateId

Proprietà PackAndGoStructureDescriptorCorporateId
Identificativo aziendale

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string CorporateId { get; set; }
Public Property CorporateId As String
    Get
    Set
public:
property String^ CorporateId {
    String^ get ();
    void set (String^ value);
}
member CorporateId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.DbType

Proprietà PackAndGoStructureDescriptorDbType
Ritorna il tipo di database. Può essere master o slave

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DbType { get; set; }
Public Property DbType As String
    Get
    Set
public:
property String^ DbType {
    String^ get ();
    void set (String^ value);
}
member DbType : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.DescriptorFullPath

Proprietà PackAndGoStructureDescriptorDescriptorFullPath
Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DescriptorFullPath { get; set; }
Public Property DescriptorFullPath As String
    Get
    Set
public:
property String^ DescriptorFullPath {
    String^ get ();
    void set (String^ value);
}
member DescriptorFullPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.MajorVer

Proprietà PackAndGoStructureDescriptorMajorVer
Identificativo della versione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int MajorVer { get; set; }
Public Property MajorVer As Integer
    Get
    Set
public:
property int MajorVer {
    int get ();
    void set (int value);
}
member MajorVer : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.MinorVer

Proprietà PackAndGoStructureDescriptorMinorVer
Identificativo della versione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int MinorVer { get; set; }
Public Property MinorVer As Integer
    Get
    Set
public:
property int MinorVer {
    int get ();
    void set (int value);
}
member MinorVer : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.Structure

Proprietà PackAndGoStructureDescriptorStructure
Sotto struttura dei descrittori

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Structure { get; set; }
Public Property Structure As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Structure {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Structure : PackAndGoNodeDescriptors with get, set

Valore della proprietà

PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.UserId

Proprietà PackAndGoStructureDescriptorUserId
Identificativo dell'utente che ha eseguito l'operazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodi di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna se esisto il descrittore nodo corrispondente al nodo passato
Metodo pubblico | GetCurrentImportAction | Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.
Metodo pubblico | SerializeMe | Metodo per la serializzazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodo PackAndGoStructureDescriptor.Find

Metodo PackAndGoStructureDescriptorFind
Ritorna se esisto il descrittore nodo corrispondente al nodo passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor Find(
    string fullFileName
)
Public Function Find (
    fullFileName As String
) As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ Find(
    String^ fullFileName
)
member Find :
        fullFileName : string -> PackAndGoNodeDescriptor

Parametri

fullFileName String
Percorso del file da utilizzare per la ricerca

Valore di ritorno

PackAndGoNodeDescriptor
Oggetto nodo descrittore, oppure null se l'oggetto non viene trovato
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodo PackAndGoStructureDescriptor.GetCurrentImportAction

Metodo PackAndGoStructureDescriptorGetCurrentImportAction
Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor pckNdDescr,
    string currentFullFileName,
    PackAndGoImportDedCases dedcase
)
Public Function GetCurrentImportAction (
    pckNdDescr As PackAndGoNodeDescriptor,
    currentFullFileName As String,
    dedcase As PackAndGoImportDedCases
) As PackAndGoImportOperation
public:
PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor^ pckNdDescr,
    String^ currentFullFileName,
    PackAndGoImportDedCases dedcase
)
member GetCurrentImportAction :
        pckNdDescr : PackAndGoNodeDescriptor *
        currentFullFileName : string *
        dedcase : PackAndGoImportDedCases -> PackAndGoImportOperation

Parametri

pckNdDescr PackAndGoNodeDescriptor
currentFullFileName String
dedcase PackAndGoImportDedCases

Valore di ritorno

PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodo PackAndGoStructureDescriptor.SerializeMe

Metodo PackAndGoStructureDescriptorSerializeMe
Metodo per la serializzazione dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SerializeMe(
    string fn
)
Public Sub SerializeMe (
    fn As String
)
public:
void SerializeMe(
    String^ fn
)
member SerializeMe :
        fn : string -> unit

Parametri

fn String
file name da scrivere
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Classe PartInfo
Classe utilizzata per ottenere informazioni, chiamando metodi, sulla parte correntemente selezionata, sulla parte Top del disegno oppure su di una parte utilizzata nella creazione dell'oggetto.
Gerarchia di ereditarietà
SystemObject
LuaRefBase
DedNetAcadPartInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PartInfo : LuaRefBase
Public Class PartInfo
    Inherits LuaRefBase
public ref class PartInfo : public LuaRefBase
type PartInfo =
    class
        inherit LuaRefBase
    end

Il tipo PartInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Restituisce l'anagrafica letta da questa parte, oppure null se on è una parte codificata.
Proprietà pubblica | IsInDb | Restituisce se questa parte sia salvata nel Database.
Proprietà pubblica | IsLocked | Restituisce se si tratti ddi una parte bloccata.
Proprietà pubblica | IsLockedRec | Restituisce vero se la parte e' bloccata oppure lo e' una ad un livello superiore.
Proprietà pubblica | isTop |
Proprietà pubblica | IsTop | Restituisce se si tratti della parte Top.
Proprietà pubblica | Name | Restituisce il nome della parte.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | activate |
Metodo pubblico | Activate | Attiva la parte.
Metodo pubblico | AssertLuaObject | (Ereditato da LuaRefBase)
 | CreatePartInfo | Crea un oggetto PartInfo leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoFromLuaStack | Crea un oggetto .net PartInfo wrappando la perte passata come argomento nello stack del lua e la restituisce.
 | CreatePartInfoParteCorrente | Crea un oggetto PartInfo della parte correntemente attiva e lo restituisce. Restituisce null se non riesce.
 | CreatePartInfoTop | Crea un oggetto PartInfo della parte Top e lo restituisce. Restituisce null se non riesce.
Metodo pubblico | DelAllAttr | Elimina tutti gli attributi attualmente presenti nella parte.
Metodo pubblico | DelAttr | Elimina l'attributo passato, se esiste.
Metodo pubblico | Dispose | (Ereditato da LuaRefBase)
Metodo protetto | Dispose(Boolean) | (Ereditato da LuaRefBase)
Metodo protetto | Finalize | (Ereditato da LuaRefBase)
Metodo pubblico | GetAllAttr | Restituisce un dizionario con tutti gli attributi presenti nella parte. Restituisce sempre un dizionario inizializzato.
Metodo pubblico | getAttr | Rimappate le funzioni con le iniziali minuscole per compatibilità con Inventor e con il passato.
Metodo pubblico | GetAttr | Legge il valore di un attributo della parte. Non è case sensitive. Restituisce comunque stringa vuota anche se non riesce a leggere l'attributo.
Metodo pubblico | GetBasePoint | Restituisce il punto di inserimento della parte.
Metodo pubblico | GetDwgStatus |
Metodo pubblico | getName |
Metodo pubblico | getParent |
 | GetPrtFromPartInfo | Restituisce la parte lua dal PartInfo passato
Metodo protetto | GetReference | (Ereditato da LuaRefBase)
Metodo pubblico | GetStateStatus |
Metodo pubblico | Load | Carica un DWG come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | LoadAsinch | Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.
Metodo pubblico | LoadPrtMultiASynch | Esegue un carica parte multiplo in modalità asincrona
Metodo pubblico | New | Crea una parte come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | Push | (Ereditato da LuaRefBase)
Metodo pubblico | RefreshColor | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshColor(Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(DedData, Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(Int32, Int32) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshPrtInfo | Aggiorna il colore della parte e le icone del DED.
Metodo pubblico | save |
Metodo pubblico | Save | Effettua il salva parte creando un nuovo file.
Metodo pubblico | SaveAsinch | Effettua il salva parte creando un nuovo file, in modo asincrono.
Metodo pubblico | SetAllAttr | Imposta tutti gli attributi nella parte.
Metodo pubblico | setAttr |
Metodo pubblico | SetAttr | Imposta il valore di un attributo.
Metodo pubblico | ToString | (Ereditato da LuaRefBase)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PartInfo

Il tipo PartInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Restituisce l'anagrafica letta da questa parte, oppure null se on è una parte codificata.
Proprietà pubblica | IsInDb | Restituisce se questa parte sia salvata nel Database.
Proprietà pubblica | IsLocked | Restituisce se si tratti ddi una parte bloccata.
Proprietà pubblica | IsLockedRec | Restituisce vero se la parte e' bloccata oppure lo e' una ad un livello superiore.
Proprietà pubblica | isTop |
Proprietà pubblica | IsTop | Restituisce se si tratti della parte Top.
Proprietà pubblica | Name | Restituisce il nome della parte.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.Data

Proprietà PartInfoData
Restituisce l'anagrafica letta da questa parte, oppure null se on è una parte codificata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsInDb

Proprietà PartInfoIsInDb
Restituisce se questa parte sia salvata nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInDb { get; }
Public ReadOnly Property IsInDb As Boolean
    Get
public:
property bool IsInDb {
    bool get ();
}
member IsInDb : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsLocked

Proprietà PartInfoIsLocked
Restituisce se si tratti ddi una parte bloccata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
property bool IsLocked {
    bool get ();
}
member IsLocked : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsLockedRec

Proprietà PartInfoIsLockedRec
Restituisce vero se la parte e' bloccata oppure lo e' una ad un livello superiore.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLockedRec { get; }
Public ReadOnly Property IsLockedRec As Boolean
    Get
public:
property bool IsLockedRec {
    bool get ();
}
member IsLockedRec : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsTop

Proprietà PartInfoIsTop
Restituisce se si tratti della parte Top.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTop { get; }
Public ReadOnly Property IsTop As Boolean
    Get
public:
property bool IsTop {
    bool get ();
}
member IsTop : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.Name

Proprietà PartInfoName
Restituisce il nome della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe PartInfo


Metodi di PartInfo

Il tipo PartInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | activate |
Metodo pubblico | Activate | Attiva la parte.
Metodo pubblico | AssertLuaObject | (Ereditato da LuaRefBase)
 | CreatePartInfo | Crea un oggetto PartInfo leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoFromLuaStack | Crea un oggetto .net PartInfo wrappando la perte passata come argomento nello stack del lua e la restituisce.
 | CreatePartInfoParteCorrente | Crea un oggetto PartInfo della parte correntemente attiva e lo restituisce. Restituisce null se non riesce.
 | CreatePartInfoTop | Crea un oggetto PartInfo della parte Top e lo restituisce. Restituisce null se non riesce.
Metodo pubblico | DelAllAttr | Elimina tutti gli attributi attualmente presenti nella parte.
Metodo pubblico | DelAttr | Elimina l'attributo passato, se esiste.
Metodo pubblico | Dispose | (Ereditato da LuaRefBase)
Metodo protetto | Dispose(Boolean) | (Ereditato da LuaRefBase)
Metodo protetto | Finalize | (Ereditato da LuaRefBase)
Metodo pubblico | GetAllAttr | Restituisce un dizionario con tutti gli attributi presenti nella parte. Restituisce sempre un dizionario inizializzato.
Metodo pubblico | getAttr | Rimappate le funzioni con le iniziali minuscole per compatibilità con Inventor e con il passato.
Metodo pubblico | GetAttr | Legge il valore di un attributo della parte. Non è case sensitive. Restituisce comunque stringa vuota anche se non riesce a leggere l'attributo.
Metodo pubblico | GetBasePoint | Restituisce il punto di inserimento della parte.
Metodo pubblico | GetDwgStatus |
Metodo pubblico | getName |
Metodo pubblico | getParent |
 | GetPrtFromPartInfo | Restituisce la parte lua dal PartInfo passato
Metodo protetto | GetReference | (Ereditato da LuaRefBase)
Metodo pubblico | GetStateStatus |
Metodo pubblico | Load | Carica un DWG come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | LoadAsinch | Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.
Metodo pubblico | LoadPrtMultiASynch | Esegue un carica parte multiplo in modalità asincrona
Metodo pubblico | New | Crea una parte come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | Push | (Ereditato da LuaRefBase)
Metodo pubblico | RefreshColor | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshColor(Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(DedData, Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(Int32, Int32) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshPrtInfo | Aggiorna il colore della parte e le icone del DED.
Metodo pubblico | save |
Metodo pubblico | Save | Effettua il salva parte creando un nuovo file.
Metodo pubblico | SaveAsinch | Effettua il salva parte creando un nuovo file, in modo asincrono.
Metodo pubblico | SetAllAttr | Imposta tutti gli attributi nella parte.
Metodo pubblico | setAttr |
Metodo pubblico | SetAttr | Imposta il valore di un attributo.
Metodo pubblico | ToString | (Ereditato da LuaRefBase)
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Activate

Metodo PartInfoActivate
Attiva la parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Activate()
Public Sub Activate
public:
void Activate()
member Activate : unit -> unit
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfo

Metodo PartInfoCreatePartInfo
Crea un oggetto PartInfo leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfo CreatePartInfo(
    int stackIdx
)
Public Shared Function CreatePartInfo (
    stackIdx As Integer
) As PartInfo
public:
static PartInfo^ CreatePartInfo(
    int stackIdx
)
static member CreatePartInfo :
        stackIdx : int -> PartInfo

Parametri

stackIdx Int32
Indice dello stack dal quale leggere la parte.

Valore di ritorno

PartInfo
Restituisce l'oggetto PartInfo oppure null.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfoFromLuaStack

Metodo PartInfoCreatePartInfoFromLuaStack
Crea un oggetto .net PartInfo wrappando la perte passata come argomento nello stack del lua e la restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static int CreatePartInfoFromLuaStack()
Public Shared Function CreatePartInfoFromLuaStack As Integer
public:
static int CreatePartInfoFromLuaStack()
static member CreatePartInfoFromLuaStack : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfoParteCorrente

Metodo PartInfoCreatePartInfoParteCorrente
Crea un oggetto PartInfo della parte correntemente attiva e lo restituisce. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfo CreatePartInfoParteCorrente()
Public Shared Function CreatePartInfoParteCorrente As PartInfo
public:
static PartInfo^ CreatePartInfoParteCorrente()
static member CreatePartInfoParteCorrente : unit -> PartInfo

Valore di ritorno

PartInfo
Restituisce l'oggetto PartInfo della parte corrente oppure null.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfoTop

Metodo PartInfoCreatePartInfoTop
Crea un oggetto PartInfo della parte Top e lo restituisce. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfo CreatePartInfoTop()
Public Shared Function CreatePartInfoTop As PartInfo
public:
static PartInfo^ CreatePartInfoTop()
static member CreatePartInfoTop : unit -> PartInfo

Valore di ritorno

PartInfo
Restituisce l'oggetto PartInfo della parte Top oppure null.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.DelAllAttr

Metodo PartInfoDelAllAttr
Elimina tutti gli attributi attualmente presenti nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void DelAllAttr()
Public Sub DelAllAttr
public:
void DelAllAttr()
member DelAllAttr : unit -> unit
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.DelAttr

Metodo PartInfoDelAttr
Elimina l'attributo passato, se esiste.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void DelAttr(
    string attrName
)
Public Sub DelAttr (
    attrName As String
)
public:
void DelAttr(
    String^ attrName
)
member DelAttr :
        attrName : string -> unit

Parametri

attrName String
Attributo da eliminare nella parte.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetAllAttr

Metodo PartInfoGetAllAttr
Restituisce un dizionario con tutti gli attributi presenti nella parte. Restituisce sempre un dizionario inizializzato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetAllAttr()
Public Function GetAllAttr As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetAllAttr()
member GetAllAttr : unit -> Dictionary<string, string>

Valore di ritorno

Dictionary String, String
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetAttr

Metodo PartInfoGetAttr
Legge il valore di un attributo della parte. Non è case sensitive. Restituisce comunque stringa vuota anche se non riesce a leggere l'attributo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAttr(
    string attrName
)
Public Function GetAttr (
    attrName As String
) As String
public:
String^ GetAttr(
    String^ attrName
)
member GetAttr :
        attrName : string -> string

Parametri

attrName String
Nome dell'attributo da leggere.

Valore di ritorno

String
Restituisce l'attributo letto oppure stringa vuota.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetBasePoint

Metodo PartInfoGetBasePoint
Restituisce il punto di inserimento della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Point3d GetBasePoint()
Public Function GetBasePoint As Point3d
public:
Point3d GetBasePoint()
member GetBasePoint : unit -> Point3d

Valore di ritorno

Point3d
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetDwgStatus

Metodo PartInfoGetDwgStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int GetDwgStatus(
    DedDoc doc
)
Public Function GetDwgStatus (
    doc As DedDoc
) As Integer
public:
int GetDwgStatus(
    DedDoc^ doc
)
member GetDwgStatus :
        doc : DedDoc -> int

Parametri

doc DedDoc

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.getName

Metodo PartInfogetName

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string getName()
Public Function getName As String
public:
String^ getName()
member getName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.getParent

Metodo PartInfogetParent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo getParent()
Public Function getParent As PartInfo
public:
PartInfo^ getParent()
member getParent : unit -> PartInfo

Valore di ritorno

PartInfo
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetPrtFromPartInfo

Metodo PartInfoGetPrtFromPartInfo
Restituisce la parte lua dal PartInfo passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static int GetPrtFromPartInfo()
Public Shared Function GetPrtFromPartInfo As Integer
public:
static int GetPrtFromPartInfo()
static member GetPrtFromPartInfo : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetStateStatus

Metodo PartInfoGetStateStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int GetStateStatus(
    DedState state
)
Public Function GetStateStatus (
    state As DedState
) As Integer
public:
int GetStateStatus(
    DedState^ state
)
member GetStateStatus :
        state : DedState -> int

Parametri

state DedState

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Load

Metodo PartInfoLoad
Carica un DWG come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Load(
    string dwgName
)
Public Function Load (
    dwgName As String
) As PartInfo
public:
PartInfo^ Load(
    String^ dwgName
)
member Load :
        dwgName : string -> PartInfo

Parametri

dwgName String
Nome completo del file da caricare.

Valore di ritorno

PartInfo
Restituisce la parte caricata oppure null se avvengono errori.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.LoadAsinch

Metodo PartInfoLoadAsinch
Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadAsinch(
    string dwgName,
    DedAttrList attrList,
    DedData anagr,
    bool isInDb
)
Public Sub LoadAsinch (
    dwgName As String,
    attrList As DedAttrList,
    anagr As DedData,
    isInDb As Boolean
)
public:
void LoadAsinch(
    String^ dwgName,
    DedAttrList^ attrList,
    DedData^ anagr,
    bool isInDb
)
member LoadAsinch :
        dwgName : string *
        attrList : DedAttrList *
        anagr : DedData *
        isInDb : bool -> unit

Parametri

dwgName String
Nome completo del file da caricare.
attrList DedAttrList
Lista degli attributi da impostare nella parte.
anagr DedData
Anagrafica.
isInDb Boolean
Indica se la parte sia o meno nel Database.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.LoadPrtMultiASynch

Metodo PartInfoLoadPrtMultiASynch
Esegue un carica parte multiplo in modalità asincrona

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadPrtMultiASynch(
    CaricaParteLoadMode loadMode,
    List<PartInfoLoadPartData> loadPrtData
)
Public Sub LoadPrtMultiASynch (
    loadMode As CaricaParteLoadMode,
    loadPrtData As List(Of PartInfoLoadPartData)
)
public:
void LoadPrtMultiASynch(
    CaricaParteLoadMode loadMode,
    List<PartInfoLoadPartData^>^ loadPrtData
)
member LoadPrtMultiASynch :
        loadMode : CaricaParteLoadMode *
        loadPrtData : List<PartInfoLoadPartData> -> unit

Parametri

loadMode CaricaParteLoadMode
loadPrtData List PartInfoLoadPartData
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.New

Metodo PartInfoNew
Crea una parte come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo New()
Public Function New As PartInfo
public:
PartInfo^ New()
member New : unit -> PartInfo

Valore di ritorno

PartInfo
Restituisce la parte caricata oppure null se avvengono errori.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.RefreshColor

Metodo PartInfoRefreshColor
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RefreshColor | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshColor(Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.RefreshColor

Metodo PartInfoRefreshColor
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshColor()
Public Sub RefreshColor
public:
void RefreshColor()
member RefreshColor : unit -> unit
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshColor


Metodo PartInfo.RefreshColor(Boolean)

Metodo PartInfoRefreshColor(Boolean)
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshColor(
    bool isInDb
)
Public Sub RefreshColor (
    isInDb As Boolean
)
public:
void RefreshColor(
    bool isInDb
)
member RefreshColor :
        isInDb : bool -> unit

Parametri

isInDb Boolean
Indica se la parte sia o meno nel Database.
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshColor


Metodo PartInfo.RefreshDedIcon

Metodo PartInfoRefreshDedIcon
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RefreshDedIcon(DedData, Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(Int32, Int32) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.RefreshDedIcon(DedData, Boolean)

Metodo PartInfoRefreshDedIcon(DedData, Boolean)
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshDedIcon(
    DedData anagr,
    bool reloadDataIfNull = true
)
Public Sub RefreshDedIcon (
    anagr As DedData,
    Optional reloadDataIfNull As Boolean = true
)
public:
void RefreshDedIcon(
    DedData^ anagr,
    bool reloadDataIfNull = true
)
member RefreshDedIcon :
        anagr : DedData *
        ?reloadDataIfNull : bool
(* Defaults:
        let _reloadDataIfNull = defaultArg reloadDataIfNull true
*)
-> unit

Parametri

anagr DedData
Anagrafica di riferimento.
reloadDataIfNull Boolean (Optional)
Inidca se rileggere l'anagrafica se viene passata null
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshDedIcon


Metodo PartInfo.RefreshDedIcon(Int32, Int32)

Metodo PartInfoRefreshDedIcon(Int32, Int32)
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshDedIcon(
    int dwgStatus,
    int anagrStatus
)
Public Sub RefreshDedIcon (
    dwgStatus As Integer,
    anagrStatus As Integer
)
public:
void RefreshDedIcon(
    int dwgStatus,
    int anagrStatus
)
member RefreshDedIcon :
        dwgStatus : int *
        anagrStatus : int -> unit

Parametri

dwgStatus Int32
anagrStatus Int32
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshDedIcon


Metodo PartInfo.RefreshPrtInfo

Metodo PartInfoRefreshPrtInfo
Aggiorna il colore della parte e le icone del DED.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshPrtInfo(
    DedData data
)
Public Sub RefreshPrtInfo (
    data As DedData
)
public:
void RefreshPrtInfo(
    DedData^ data
)
member RefreshPrtInfo :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da utilizzare
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Save

Metodo PartInfoSave
Effettua il salva parte creando un nuovo file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public double Save(
    string fileName,
    bool alsoSubParts
)
Public Function Save (
    fileName As String,
    alsoSubParts As Boolean
) As Double
public:
double Save(
    String^ fileName,
    bool alsoSubParts
)
member Save :
        fileName : string *
        alsoSubParts : bool -> float

Parametri

fileName String
File .dwg sul quale esportare la parte.
alsoSubParts Boolean
Indica se esportare anche le sottoparti o solo la parte in salvataggio.

Valore di ritorno

Double
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.SaveAsinch

Metodo PartInfoSaveAsinch
Effettua il salva parte creando un nuovo file, in modo asincrono.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveAsinch(
    string fileName,
    bool alsoSubParts
)
Public Sub SaveAsinch (
    fileName As String,
    alsoSubParts As Boolean
)
public:
void SaveAsinch(
    String^ fileName,
    bool alsoSubParts
)
member SaveAsinch :
        fileName : string *
        alsoSubParts : bool -> unit

Parametri

fileName String
File .dwg sul quale esportare la parte.
alsoSubParts Boolean
Indica se esportare anche le sottoparti o solo la parte in salvataggio.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.SetAllAttr

Metodo PartInfoSetAllAttr
Imposta tutti gli attributi nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetAllAttr(
    Dictionary<string, string> attrs
)
Public Sub SetAllAttr (
    attrs As Dictionary(Of String, String)
)
public:
void SetAllAttr(
    Dictionary<String^, String^>^ attrs
)
member SetAllAttr :
        attrs : Dictionary<string, string> -> unit

Parametri

attrs Dictionary String, String
Dizionario di attributi da impostare.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.SetAttr

Metodo PartInfoSetAttr
Imposta il valore di un attributo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetAttr(
    string attrName,
    string attrVal
)
Public Sub SetAttr (
    attrName As String,
    attrVal As String
)
public:
void SetAttr(
    String^ attrName,
    String^ attrVal
)
member SetAttr :
        attrName : string *
        attrVal : string -> unit

Parametri

attrName String
Nome dell'attributo da impostare.
attrVal String
Valore da impostare.
Vedi anche

Documentazione

Classe PartInfo


Classe PartInfo.LoadPartData

Classe PartInfoLoadPartData
Gerarchia di ereditarietà
SystemObject
DedNetAcadPartInfoLoadPartData

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class LoadPartData
Public Class LoadPartData
public ref class LoadPartData
type LoadPartData = class end

Il tipo PartInfoLoadPartData espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PartInfoLoadPartData |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr |
Proprietà pubblica | AttrList |
Proprietà pubblica | DwgName |
Proprietà pubblica | IsInDb |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PartInfo.LoadPartData

Costruttore PartInfoLoadPartData

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public LoadPartData()
Public Sub New
public:
LoadPartData()
new : unit -> LoadPartData
Vedi anche

Documentazione

Classe PartInfoLoadPartData


Proprietà di LoadPartData

Il tipo PartInfoLoadPartData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr |
Proprietà pubblica | AttrList |
Proprietà pubblica | DwgName |
Proprietà pubblica | IsInDb |
Torna su
Vedi anche

Documentazione

Classe PartInfoLoadPartData


Proprietà PartInfo.LoadPartData.Anagr

Proprietà PartInfoLoadPartDataAnagr

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; set; }
Public Property Anagr As DedData
    Get
    Set
public:
property DedData^ Anagr {
    DedData^ get ();
    void set (DedData^ value);
}
member Anagr : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe PartInfoLoadPartData


Proprietà PartInfo.LoadPartData.AttrList

Proprietà PartInfoLoadPartDataAttrList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { get; set; }
Public Property AttrList As DedAttrList
    Get
    Set
public:
property DedAttrList^ AttrList {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member AttrList : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe PartInfoLoadPartData


Proprietà PartInfo.LoadPartData.DwgName

Proprietà PartInfoLoadPartDataDwgName

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DwgName { get; set; }
Public Property DwgName As String
    Get
    Set
public:
property String^ DwgName {
    String^ get ();
    void set (String^ value);
}
member DwgName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PartInfoLoadPartData


Proprietà PartInfo.LoadPartData.IsInDb

Proprietà PartInfoLoadPartDataIsInDb

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInDb { get; set; }
Public Property IsInDb As Boolean
    Get
    Set
public:
property bool IsInDb {
    bool get ();
    void set (bool value);
}
member IsInDb : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PartInfoLoadPartData


Classe PartInfoArray
Classe utilizzata per ottenere informazioni su di un oggetto PrtArray LUA. Chiama i metodi dell'oggetto via LUA come l'oggetto PartInfo. Questo oggetto è creabile solo via LUA.
Gerarchia di ereditarietà
SystemObject
LuaRefBase
DedNetAcadPartInfoArray

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PartInfoArray : LuaRefBase
Public Class PartInfoArray
    Inherits LuaRefBase
public ref class PartInfoArray : public LuaRefBase
type PartInfoArray =
    class
        inherit LuaRefBase
    end

Il tipo PartInfoArray espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nell'array.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge la parte passata all'array.
Metodo pubblico | AssertLuaObject | (Ereditato da LuaRefBase)
 | CreatePartInfoArray | Crea un oggetto PartInfoArray leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoArrayFromLuaStack | Crea un oggetto .net PartInfoArray wrappando l'array passato come argomento nello stack del lua e lo restituisce.
Metodo pubblico | Dispose | (Ereditato da LuaRefBase)
Metodo protetto | Dispose(Boolean) | (Ereditato da LuaRefBase)
Metodo protetto | Finalize | (Ereditato da LuaRefBase)
Metodo pubblico | GetAt | Restituisce la parte iesima dell'array (zero based index). Restituisce null se si specifica un numero non compreso nell'intervallo.
 | GetNavSelectedParts | Restituisce le parti correntemente selezionate nell'area grafica (chiama LNavGetNavSelectedItems()).
Metodo protetto | GetReference | (Ereditato da LuaRefBase)
 | GetTreeSelectedParts | Restituisce le parti correntemente selezionate (chiama LNavGetTreeSelectedItems()).
Metodo pubblico | Push | (Ereditato da LuaRefBase)
Metodo pubblico | ToString | (Ereditato da LuaRefBase)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PartInfoArray

Il tipo PartInfoArray espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nell'array.
Torna su
Vedi anche

Documentazione

Classe PartInfoArray


Proprietà PartInfoArray.Count

Proprietà PartInfoArrayCount
Restituisce il numero di elementi presenti nell'array.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe PartInfoArray


Metodi di PartInfoArray

Il tipo PartInfoArray espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge la parte passata all'array.
Metodo pubblico | AssertLuaObject | (Ereditato da LuaRefBase)
 | CreatePartInfoArray | Crea un oggetto PartInfoArray leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoArrayFromLuaStack | Crea un oggetto .net PartInfoArray wrappando l'array passato come argomento nello stack del lua e lo restituisce.
Metodo pubblico | Dispose | (Ereditato da LuaRefBase)
Metodo protetto | Dispose(Boolean) | (Ereditato da LuaRefBase)
Metodo protetto | Finalize | (Ereditato da LuaRefBase)
Metodo pubblico | GetAt | Restituisce la parte iesima dell'array (zero based index). Restituisce null se si specifica un numero non compreso nell'intervallo.
 | GetNavSelectedParts | Restituisce le parti correntemente selezionate nell'area grafica (chiama LNavGetNavSelectedItems()).
Metodo protetto | GetReference | (Ereditato da LuaRefBase)
 | GetTreeSelectedParts | Restituisce le parti correntemente selezionate (chiama LNavGetTreeSelectedItems()).
Metodo pubblico | Push | (Ereditato da LuaRefBase)
Metodo pubblico | ToString | (Ereditato da LuaRefBase)
Torna su
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.Add

Metodo PartInfoArrayAdd
Aggiunge la parte passata all'array.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    PartInfo prt
)
Public Sub Add (
    prt As PartInfo
)
public:
void Add(
    PartInfo^ prt
)
member Add :
        prt : PartInfo -> unit

Parametri

prt PartInfo
Parte da aggiungere.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.CreatePartInfoArray

Metodo PartInfoArrayCreatePartInfoArray
Crea un oggetto PartInfoArray leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray CreatePartInfoArray(
    int stackIdx
)
Public Shared Function CreatePartInfoArray (
    stackIdx As Integer
) As PartInfoArray
public:
static PartInfoArray^ CreatePartInfoArray(
    int stackIdx
)
static member CreatePartInfoArray :
        stackIdx : int -> PartInfoArray

Parametri

stackIdx Int32
Indice dello stack dal quale leggere l'array.

Valore di ritorno

PartInfoArray
Restituisce l'oggetto PartInfoArray oppure null.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.CreatePartInfoArrayFromLuaStack

Metodo PartInfoArrayCreatePartInfoArrayFromLuaStack
Crea un oggetto .net PartInfoArray wrappando l'array passato come argomento nello stack del lua e lo restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static int CreatePartInfoArrayFromLuaStack()
Public Shared Function CreatePartInfoArrayFromLuaStack As Integer
public:
static int CreatePartInfoArrayFromLuaStack()
static member CreatePartInfoArrayFromLuaStack : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.GetAt

Metodo PartInfoArrayGetAt
Restituisce la parte iesima dell'array (zero based index). Restituisce null se si specifica un numero non compreso nell'intervallo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo GetAt(
    int idx
)
Public Function GetAt (
    idx As Integer
) As PartInfo
public:
PartInfo^ GetAt(
    int idx
)
member GetAt :
        idx : int -> PartInfo

Parametri

idx Int32
Indice dell'elemento da restituire.

Valore di ritorno

PartInfo
Restituisce la parte letto oppure null se non è presente.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.GetNavSelectedParts

Metodo PartInfoArrayGetNavSelectedParts
Restituisce le parti correntemente selezionate nell'area grafica (chiama LNavGetNavSelectedItems()).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray GetNavSelectedParts()
Public Shared Function GetNavSelectedParts As PartInfoArray
public:
static PartInfoArray^ GetNavSelectedParts()
static member GetNavSelectedParts : unit -> PartInfoArray

Valore di ritorno

PartInfoArray
Restituisce l'oggetto PartInfoArray oppure null.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.GetTreeSelectedParts

Metodo PartInfoArrayGetTreeSelectedParts
Restituisce le parti correntemente selezionate (chiama LNavGetTreeSelectedItems()).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray GetTreeSelectedParts(
    bool subParts
)
Public Shared Function GetTreeSelectedParts (
    subParts As Boolean
) As PartInfoArray
public:
static PartInfoArray^ GetTreeSelectedParts(
    bool subParts
)
static member GetTreeSelectedParts :
        subParts : bool -> PartInfoArray

Parametri

subParts Boolean
Indica se selezionare anche le sottoparti nel caso di ramo chiuso.

Valore di ritorno

PartInfoArray
Restituisce l'oggetto PartInfoArray oppure null.
Vedi anche

Documentazione

Classe PartInfoArray


Classe PrtArraySelectStatusInfo
Classe che verifica lo stato di un array di parti e restituisce informazioni utili per la disponibilità e l'esecuzione dei comandi.
Gerarchia di ereditarietà
SystemObject
DedNetAcadPrtArraySelectStatusInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PrtArraySelectStatusInfo
Public Class PrtArraySelectStatusInfo
public ref class PrtArraySelectStatusInfo
type PrtArraySelectStatusInfo = class end

Il tipo PrtArraySelectStatusInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PrtArraySelectStatusInfo | Costruttore unico che inizializza le proprietà dell'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | AllInDb | Tutte le parti selezionate sono nel Database.
Campo pubblico | AlmenoUnaInDb | Indica se c'é almeno una parte codficata.
Campo pubblico | AlmenoUnaSubPrtInDb | Indica se c'é almeno una parte figlia (non Top) codificata nel Db.
Campo pubblico | AlmenoUnaSubPrtNotLastRev | Indica se c'é almeno una parte figlia (non Top) codificata nel Db che non sia all'ultima revisione.
Campo pubblico | IsTopInDb | La parte Top è selezionata ed è presente nel Database.
Campo pubblico | IsTopSelected | La parte Top è selezionata.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PrtArraySelectStatusInfo
Costruttore unico che inizializza le proprietà dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PrtArraySelectStatusInfo(
    PartInfoArray prtArray
)
Public Sub New (
    prtArray As PartInfoArray
)
public:
PrtArraySelectStatusInfo(
    PartInfoArray^ prtArray
)
new :
        prtArray : PartInfoArray -> PrtArraySelectStatusInfo

Parametri

prtArray PartInfoArray
Array del quale restituire le informazioni.
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campi di PrtArraySelectStatusInfo

Il tipo PrtArraySelectStatusInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AllInDb | Tutte le parti selezionate sono nel Database.
Campo pubblico | AlmenoUnaInDb | Indica se c'é almeno una parte codficata.
Campo pubblico | AlmenoUnaSubPrtInDb | Indica se c'é almeno una parte figlia (non Top) codificata nel Db.
Campo pubblico | AlmenoUnaSubPrtNotLastRev | Indica se c'é almeno una parte figlia (non Top) codificata nel Db che non sia all'ultima revisione.
Campo pubblico | IsTopInDb | La parte Top è selezionata ed è presente nel Database.
Campo pubblico | IsTopSelected | La parte Top è selezionata.
Torna su
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AllInDb

Campo PrtArraySelectStatusInfoAllInDb
Tutte le parti selezionate sono nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AllInDb
Public ReadOnly AllInDb As Boolean
public:
initonly bool AllInDb
val AllInDb: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AlmenoUnaInDb

Campo PrtArraySelectStatusInfoAlmenoUnaInDb
Indica se c'é almeno una parte codficata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AlmenoUnaInDb
Public ReadOnly AlmenoUnaInDb As Boolean
public:
initonly bool AlmenoUnaInDb
val AlmenoUnaInDb: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AlmenoUnaSubPrtInDb

Campo PrtArraySelectStatusInfoAlmenoUnaSubPrtInDb
Indica se c'é almeno una parte figlia (non Top) codificata nel Db.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AlmenoUnaSubPrtInDb
Public ReadOnly AlmenoUnaSubPrtInDb As Boolean
public:
initonly bool AlmenoUnaSubPrtInDb
val AlmenoUnaSubPrtInDb: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AlmenoUnaSubPrtNotLastRev

Campo PrtArraySelectStatusInfoAlmenoUnaSubPrtNotLastRev
Indica se c'é almeno una parte figlia (non Top) codificata nel Db che non sia all'ultima revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AlmenoUnaSubPrtNotLastRev
Public ReadOnly AlmenoUnaSubPrtNotLastRev As Boolean
public:
initonly bool AlmenoUnaSubPrtNotLastRev
val AlmenoUnaSubPrtNotLastRev: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.IsTopInDb

Campo PrtArraySelectStatusInfoIsTopInDb
La parte Top è selezionata ed è presente nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool IsTopInDb
Public ReadOnly IsTopInDb As Boolean
public:
initonly bool IsTopInDb
val IsTopInDb: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.IsTopSelected

Campo PrtArraySelectStatusInfoIsTopSelected
La parte Top è selezionata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool IsTopSelected
Public ReadOnly IsTopSelected As Boolean
public:
initonly bool IsTopSelected
val IsTopSelected: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Classe Pubblica
Comando di pubblicazione.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadPubblica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Pubblica : AcadCommandBase
Public Class Pubblica
    Inherits AcadCommandBase
public ref class Pubblica : public AcadCommandBase
type Pubblica =
    class
        inherit AcadCommandBase
    end

Il tipo Pubblica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FnList | Lista di file da pubblicare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di Pubblica

Il tipo Pubblica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FnList | Lista di file da pubblicare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe Pubblica


Proprietà Pubblica.FnList

Proprietà PubblicaFnList
Lista di file da pubblicare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FnList { get; set; }
Public Property FnList As List(Of String)
    Get
    Set
public:
property List<String^>^ FnList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FnList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe Pubblica


Proprietà Pubblica.NeedParameters

Proprietà PubblicaNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Pubblica


Metodi di Pubblica

Il tipo Pubblica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Pubblica


Metodo Pubblica.AcadEnabled

Metodo PubblicaAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe Pubblica


Metodo Pubblica.AcadSetContext

Metodo PubblicaAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe Pubblica


Metodo Pubblica.ClearCommand

Metodo PubblicaClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Pubblica


Metodo Pubblica.ExecuteCommand

Metodo PubblicaExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe Pubblica


Classe Pubblish
Gerarchia di ereditarietà
SystemObject
DedNetAcadPubblish

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class Pubblish
Public NotInheritable Class Pubblish
public ref class Pubblish abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Pubblish = class end

Il tipo Pubblish espone i seguenti membri.

Metodi
Nome | Descrizione
GetTypeLayoutExp | Dato il valore in stringa ritorna il tipo associato
MergePDFs | Metodo che unisce più pdf in un unico pdf
PublishAcad | Effettua la pubbilcazione del documento.
SortLayout | Ordino il layout per avere le pagine del pdf in ordine
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di Pubblish

Il tipo Pubblish espone i seguenti membri.

Metodi
Nome | Descrizione
GetTypeLayoutExp | Dato il valore in stringa ritorna il tipo associato
MergePDFs | Metodo che unisce più pdf in un unico pdf
PublishAcad | Effettua la pubbilcazione del documento.
SortLayout | Ordino il layout per avere le pagine del pdf in ordine
Torna su
Vedi anche

Documentazione

Classe Pubblish


Metodo Pubblish.GetTypeLayoutExp

Metodo PubblishGetTypeLayoutExp
Dato il valore in stringa ritorna il tipo associato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PubblishTypeLayoutExp GetTypeLayoutExp(
    string descriptor
)
Public Shared Function GetTypeLayoutExp (
    descriptor As String
) As PubblishTypeLayoutExp
public:
static PubblishTypeLayoutExp GetTypeLayoutExp(
    String^ descriptor
)
static member GetTypeLayoutExp :
        descriptor : string -> PubblishTypeLayoutExp

Parametri

descriptor String

Valore di ritorno

PubblishTypeLayoutExp
Vedi anche

Documentazione

Classe Pubblish


Metodo Pubblish.MergePDFs

Metodo PubblishMergePDFs
Metodo che unisce più pdf in un unico pdf

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void MergePDFs(
    string namePdf,
    params string[] pdfs
)
Public Shared Sub MergePDFs (
    namePdf As String,
    ParamArray pdfs As String()
)
public:
static void MergePDFs(
    String^ namePdf,
    ... array<String^>^ pdfs
)
static member MergePDFs :
        namePdf : string *
        pdfs : string[] -> unit

Parametri

namePdf String
pdfs String
Vedi anche

Documentazione

Classe Pubblish


Metodo Pubblish.PublishAcad

Metodo PubblishPublishAcad
Effettua la pubbilcazione del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishAcad(
    LuaTable printInfo
)
Public Shared Function PublishAcad (
    printInfo As LuaTable
) As Boolean
public:
static bool PublishAcad(
    LuaTable^ printInfo
)
static member PublishAcad :
        printInfo : LuaTable -> bool

Parametri

printInfo LuaTable

Valore di ritorno

Boolean
Restituisce true se riesce false altrimenti
Vedi anche

Documentazione

Classe Pubblish


Metodo Pubblish.SortLayout

Metodo PubblishSortLayout
Ordino il layout per avere le pagine del pdf in ordine

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<ObjectId> SortLayout(
    Transaction tr,
    ObjectIdCollection layoutsToPlot
)
Public Shared Function SortLayout (
    tr As Transaction,
    layoutsToPlot As ObjectIdCollection
) As List(Of ObjectId)
public:
static List<ObjectId>^ SortLayout(
    Transaction^ tr,
    ObjectIdCollection^ layoutsToPlot
)
static member SortLayout :
        tr : Transaction *
        layoutsToPlot : ObjectIdCollection -> List<ObjectId>

Parametri

tr Transaction
layoutsToPlot ObjectIdCollection

Valore di ritorno

List ObjectId
Vedi anche

Documentazione

Classe Pubblish


Enumerazione Pubblish.TypeLayoutExp

Enumerazione PubblishTypeLayoutExp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum TypeLayoutExp
Public Enumeration TypeLayoutExp
public enum class TypeLayoutExp
type TypeLayoutExp
Membri
Nome | Valore | Descrizione
Foglio_corrente | 0 | Indica di pubblicare solo documento selezionato
Foglio_modello | 1 | Indica di pubblicare solo il modello
Fogli_layout | 2 | Indica di pubblicare solo i layout
Tutti_fogli | 3 | Indica di pubblicare tutti i documenti
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PublishSparePartsDrawing
Comando che pubblica una tavola tecnica ricambi in formato pdf.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadPublishSparePartsDrawing

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PublishSparePartsDrawing : DedCommand
Public Class PublishSparePartsDrawing
    Inherits DedCommand
public ref class PublishSparePartsDrawing : public DedCommand
type PublishSparePartsDrawing =
    class
        inherit DedCommand
    end

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..
Proprietà pubblica | Document | Documento che si vuole pubblicare in formato pdf.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..
Proprietà pubblica | Document | Documento che si vuole pubblicare in formato pdf.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Proprietà PublishSparePartsDrawing.Data

Proprietà PublishSparePartsDrawingData
Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Proprietà PublishSparePartsDrawing.Document

Proprietà PublishSparePartsDrawingDocument
Documento che si vuole pubblicare in formato pdf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Proprietà PublishSparePartsDrawing.NeedParameters

Proprietà PublishSparePartsDrawingNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodi di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.ClearCommand

Metodo PublishSparePartsDrawingClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.Enabled

Metodo PublishSparePartsDrawingEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.ExecuteCommand

Metodo PublishSparePartsDrawingExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.SetContext

Metodo PublishSparePartsDrawingSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Classe QsDocument
Gerarchia di ereditarietà
SystemObject
DedNetAcadQsDocument

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsDocument
Public Class QsDocument
public ref class QsDocument
type QsDocument = class end

Il tipo QsDocument espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsDocument | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Database | Restituisce il Database del documento.
Proprietà pubblica | Editor | Restituisce l'Editor del documento.
Proprietà pubblica | IsReadOnly | Restituisce se il documento è read only.
Proprietà pubblica | Name | Restituisce il percorso completo del documento.
Proprietà pubblica | UserData | Restituisce l'UserData.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Activate | Permette di attivare il documento.
 | ActiveDocument | Restituisce il docuumento attualmente attivo.
 | AssertActiveDocument | Verifica che sia presente un documento attivo in Autocad e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.
 | AssertDataDocument | Verifica che il documento specificato in ingresso sia associato ad una anagrafica. Genera una eccezione se non la trova, altrimenti la restituisce.
Metodo pubblico | CloseAndDiscard | Chiude il documento senza salvare.
Metodo pubblico | CloseAndSave | Chiude e salva il documento.
 | CurrentDocument | Legge il percorso del documento correntemente attivo e ne resituisce il DedDoc. Se il documento non è ancora selvato o se non è nel Database restituisce null. Ignora eventuali errori.
 | DefaultFormatForSave | Legge dal registro il valore del formato di default di salvataggio. Da notare che il valore scritto nel rigistro è da interpretare nel seguente modo: 48 - AutoCAD 2010 DWG format 36 - AutoCAD 2007 DWG format 24 - AutoCAD 2004 DWG format 12 - AutoCAD 2000 DWG format 8 - AutoCAD 14 DWG format
 | DocIsDirty | Restituisce true se il documento passato è dirty altrimenti false.
Metodo pubblico | DowngradeDocOpen | Effettua il downgrade del documento.
 | EnsureActiveDocumentReadableWritable | Si assicura che il documento attivo sia scrivibile o in sola lettura.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
 | FileIsActiveDocument | Verifica se il nome file completo passato coincida con il documento correntemente attivo. Perché questa funzione dia un risultato attendibile il documento attivo deve essere salvato e non deve essere nuovo.
 | GetDataDocument | Ritorna l'anagrafica associata al documento. Ritorna null se non la trova
Metodo pubblico | GetHashCode | Ridefinizione HashCode. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | LockDocument | Effettua il Lock del documento.
Metodo pubblico | LockDocument(String) | Effettua il Lock del documento esplicito.
 | OpenDocument | Apre un documento verificando che non sia già aperto.
Metodo pubblico | PopDbmod | Effettua il pop del DbMod.
Metodo pubblico | PushDbmod | Effettua il push del DbMod.
 | Save | Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.
 | Save(QsDocument) | Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.
 | SaveAs(String) | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveAs(QsDocument, String, Boolean) | Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveCopyAs | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
Metodo pubblico | SendStringToExecute | Esegue il comando.
Metodo pubblico | UpgradeDocOpen | Effettua l'upgrade del documento.
Torna su
Operatori
Nome | Descrizione
Equality(QsDocument, QsDocument) | Ridefinizione dell'operatore ==.
Inequality(QsDocument, QsDocument) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsDocument
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsDocument(
    Document doc
)
Public Sub New (
    doc As Document
)
public:
QsDocument(
    Document^ doc
)
new :
        doc : Document -> QsDocument

Parametri

doc Document
Documento di Autocad.
Vedi anche

Documentazione

Classe QsDocument


Proprietà di QsDocument

Il tipo QsDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Database | Restituisce il Database del documento.
Proprietà pubblica | Editor | Restituisce l'Editor del documento.
Proprietà pubblica | IsReadOnly | Restituisce se il documento è read only.
Proprietà pubblica | Name | Restituisce il percorso completo del documento.
Proprietà pubblica | UserData | Restituisce l'UserData.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.Database

Proprietà QsDocumentDatabase
Restituisce il Database del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}
member Database : Database with get

Valore della proprietà

Database
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.Editor

Proprietà QsDocumentEditor
Restituisce l'Editor del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Editor Editor { get; }
Public ReadOnly Property Editor As Editor
    Get
public:
property Editor^ Editor {
    Editor^ get ();
}
member Editor : Editor with get

Valore della proprietà

Editor
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.IsReadOnly

Proprietà QsDocumentIsReadOnly
Restituisce se il documento è read only.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.Name

Proprietà QsDocumentName
Restituisce il percorso completo del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.UserData

Proprietà QsDocumentUserData
Restituisce l'UserData.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Hashtable UserData { get; }
Public ReadOnly Property UserData As Hashtable
    Get
public:
property Hashtable^ UserData {
    Hashtable^ get ();
}
member UserData : Hashtable with get

Valore della proprietà

Hashtable
Vedi anche

Documentazione

Classe QsDocument


Metodi di QsDocument

Il tipo QsDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Activate | Permette di attivare il documento.
 | ActiveDocument | Restituisce il docuumento attualmente attivo.
 | AssertActiveDocument | Verifica che sia presente un documento attivo in Autocad e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.
 | AssertDataDocument | Verifica che il documento specificato in ingresso sia associato ad una anagrafica. Genera una eccezione se non la trova, altrimenti la restituisce.
Metodo pubblico | CloseAndDiscard | Chiude il documento senza salvare.
Metodo pubblico | CloseAndSave | Chiude e salva il documento.
 | CurrentDocument | Legge il percorso del documento correntemente attivo e ne resituisce il DedDoc. Se il documento non è ancora selvato o se non è nel Database restituisce null. Ignora eventuali errori.
 | DefaultFormatForSave | Legge dal registro il valore del formato di default di salvataggio. Da notare che il valore scritto nel rigistro è da interpretare nel seguente modo: 48 - AutoCAD 2010 DWG format 36 - AutoCAD 2007 DWG format 24 - AutoCAD 2004 DWG format 12 - AutoCAD 2000 DWG format 8 - AutoCAD 14 DWG format
 | DocIsDirty | Restituisce true se il documento passato è dirty altrimenti false.
Metodo pubblico | DowngradeDocOpen | Effettua il downgrade del documento.
 | EnsureActiveDocumentReadableWritable | Si assicura che il documento attivo sia scrivibile o in sola lettura.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
 | FileIsActiveDocument | Verifica se il nome file completo passato coincida con il documento correntemente attivo. Perché questa funzione dia un risultato attendibile il documento attivo deve essere salvato e non deve essere nuovo.
 | GetDataDocument | Ritorna l'anagrafica associata al documento. Ritorna null se non la trova
Metodo pubblico | GetHashCode | Ridefinizione HashCode. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | LockDocument | Effettua il Lock del documento.
Metodo pubblico | LockDocument(String) | Effettua il Lock del documento esplicito.
 | OpenDocument | Apre un documento verificando che non sia già aperto.
Metodo pubblico | PopDbmod | Effettua il pop del DbMod.
Metodo pubblico | PushDbmod | Effettua il push del DbMod.
 | Save | Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.
 | Save(QsDocument) | Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.
 | SaveAs(String) | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveAs(QsDocument, String, Boolean) | Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveCopyAs | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
Metodo pubblico | SendStringToExecute | Esegue il comando.
Metodo pubblico | UpgradeDocOpen | Effettua l'upgrade del documento.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Activate

Metodo QsDocumentActivate
Permette di attivare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Activate()
Public Sub Activate
public:
void Activate()
member Activate : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.ActiveDocument

Metodo QsDocumentActiveDocument
Restituisce il docuumento attualmente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument ActiveDocument()
Public Shared Function ActiveDocument As QsDocument
public:
static QsDocument^ ActiveDocument()
static member ActiveDocument : unit -> QsDocument

Valore di ritorno

QsDocument
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.AssertActiveDocument

Metodo QsDocumentAssertActiveDocument
Verifica che sia presente un documento attivo in Autocad e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument AssertActiveDocument()
Public Shared Function AssertActiveDocument As QsDocument
public:
static QsDocument^ AssertActiveDocument()
static member AssertActiveDocument : unit -> QsDocument

Valore di ritorno

QsDocument
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.AssertDataDocument

Metodo QsDocumentAssertDataDocument
Verifica che il documento specificato in ingresso sia associato ad una anagrafica. Genera una eccezione se non la trova, altrimenti la restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertDataDocument()
Public Shared Function AssertDataDocument As DedData
public:
static DedData^ AssertDataDocument()
static member AssertDataDocument : unit -> DedData

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.CloseAndDiscard

Metodo QsDocumentCloseAndDiscard
Chiude il documento senza salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void CloseAndDiscard()
Public Sub CloseAndDiscard
public:
void CloseAndDiscard()
member CloseAndDiscard : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.CloseAndSave

Metodo QsDocumentCloseAndSave
Chiude e salva il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void CloseAndSave(
    string fileName
)
Public Sub CloseAndSave (
    fileName As String
)
public:
void CloseAndSave(
    String^ fileName
)
member CloseAndSave :
        fileName : string -> unit

Parametri

fileName String
Nome del documento.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.CurrentDocument

Metodo QsDocumentCurrentDocument
Legge il percorso del documento correntemente attivo e ne resituisce il DedDoc. Se il documento non è ancora selvato o se non è nel Database restituisce null. Ignora eventuali errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc CurrentDocument()
Public Shared Function CurrentDocument As DedDoc
public:
static DedDoc^ CurrentDocument()
static member CurrentDocument : unit -> DedDoc

Valore di ritorno

DedDoc
Restituisce il DedDoc associato al documento attivo oppure null se non lo trova.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.DefaultFormatForSave

Metodo QsDocumentDefaultFormatForSave
Legge dal registro il valore del formato di default di salvataggio. Da notare che il valore scritto nel rigistro è da interpretare nel seguente modo: 48 - AutoCAD 2010 DWG format 36 - AutoCAD 2007 DWG format 24 - AutoCAD 2004 DWG format 12 - AutoCAD 2000 DWG format 8 - AutoCAD 14 DWG format

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DwgVersion DefaultFormatForSave()
Public Shared Function DefaultFormatForSave As DwgVersion
public:
static DwgVersion DefaultFormatForSave()
static member DefaultFormatForSave : unit -> DwgVersion

Valore di ritorno

DwgVersion
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.DocIsDirty

Metodo QsDocumentDocIsDirty
Restituisce true se il documento passato è dirty altrimenti false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool DocIsDirty()
Public Shared Function DocIsDirty As Boolean
public:
static bool DocIsDirty()
static member DocIsDirty : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.DowngradeDocOpen

Metodo QsDocumentDowngradeDocOpen
Effettua il downgrade del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void DowngradeDocOpen(
    bool bPromptForSave
)
Public Sub DowngradeDocOpen (
    bPromptForSave As Boolean
)
public:
void DowngradeDocOpen(
    bool bPromptForSave
)
member DowngradeDocOpen :
        bPromptForSave : bool -> unit

Parametri

bPromptForSave Boolean
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.EnsureActiveDocumentReadableWritable

Metodo QsDocumentEnsureActiveDocumentReadableWritable
Si assicura che il documento attivo sia scrivibile o in sola lettura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void EnsureActiveDocumentReadableWritable(
    bool readOnly
)
Public Shared Sub EnsureActiveDocumentReadableWritable (
    readOnly As Boolean
)
public:
static void EnsureActiveDocumentReadableWritable(
    bool readOnly
)
static member EnsureActiveDocumentReadableWritable :
        readOnly : bool -> unit

Parametri

readOnly Boolean
Se true si assicura che sia in sola lettura altrimenti che sia scrivibile.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Equals

Metodo QsDocumentEquals
Ridefinizione di uguaglianza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da confrontare.

Valore di ritorno

Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.FileIsActiveDocument

Metodo QsDocumentFileIsActiveDocument
Verifica se il nome file completo passato coincida con il documento correntemente attivo. Perché questa funzione dia un risultato attendibile il documento attivo deve essere salvato e non deve essere nuovo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsActiveDocument(
    string fileName
)
Public Shared Function FileIsActiveDocument (
    fileName As String
) As Boolean
public:
static bool FileIsActiveDocument(
    String^ fileName
)
static member FileIsActiveDocument :
        fileName : string -> bool

Parametri

fileName String
Nome file da comparare.

Valore di ritorno

Boolean
Restituisce true se combacia col documento attivo altrimenti false.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.GetDataDocument

Metodo QsDocumentGetDataDocument
Ritorna l'anagrafica associata al documento. Ritorna null se non la trova

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData GetDataDocument()
Public Shared Function GetDataDocument As DedData
public:
static DedData^ GetDataDocument()
static member GetDataDocument : unit -> DedData

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.GetHashCode

Metodo QsDocumentGetHashCode
Ridefinizione HashCode.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.LockDocument

Metodo QsDocumentLockDocument
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | LockDocument | Effettua il Lock del documento.
Metodo pubblico | LockDocument(String) | Effettua il Lock del documento esplicito.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.LockDocument

Metodo QsDocumentLockDocument
Effettua il Lock del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentLock LockDocument()
Public Function LockDocument As DocumentLock
public:
DocumentLock^ LockDocument()
member LockDocument : unit -> DocumentLock

Valore di ritorno

DocumentLock
Vedi anche

Documentazione

Classe QsDocument
Overload di LockDocument


Metodo QsDocument.LockDocument(String)

Metodo QsDocumentLockDocument(String)
Effettua il Lock del documento esplicito.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentLock LockDocument(
    string cmdname
)
Public Function LockDocument (
    cmdname As String
) As DocumentLock
public:
DocumentLock^ LockDocument(
    String^ cmdname
)
member LockDocument :
        cmdname : string -> DocumentLock

Parametri

cmdname String

Valore di ritorno

DocumentLock
Vedi anche

Documentazione

Classe QsDocument
Overload di LockDocument


Metodo QsDocument.OpenDocument

Metodo QsDocumentOpenDocument
Apre un documento verificando che non sia già aperto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument OpenDocument(
    string fullFileName,
    bool readOnly
)
Public Shared Function OpenDocument (
    fullFileName As String,
    readOnly As Boolean
) As QsDocument
public:
static QsDocument^ OpenDocument(
    String^ fullFileName,
    bool readOnly
)
static member OpenDocument :
        fullFileName : string *
        readOnly : bool -> QsDocument

Parametri

fullFileName String
File da aprire.
readOnly Boolean
Modalità di apertura (usata solo nel caso il documento sia da aprire).

Valore di ritorno

QsDocument
Restituisce il documento aperto o attivato.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.PopDbmod

Metodo QsDocumentPopDbmod
Effettua il pop del DbMod.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PopDbmod()
Public Sub PopDbmod
public:
void PopDbmod()
member PopDbmod : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.PushDbmod

Metodo QsDocumentPushDbmod
Effettua il push del DbMod.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void PushDbmod()
Public Sub PushDbmod
public:
void PushDbmod()
member PushDbmod : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Save

Metodo QsDocumentSave
Lista degli overload
Nome | Descrizione
Save | Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.
Save(QsDocument) | Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Save

Metodo QsDocumentSave
Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Save()
Public Shared Sub Save
public:
static void Save()
static member Save : unit -> unit
Vedi anche

Documentazione

Classe QsDocument
Overload di Save


Metodo QsDocument.Save(QsDocument)

Metodo QsDocumentSave(QsDocument)
Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Save(
    QsDocument doc
)
Public Shared Sub Save (
    doc As QsDocument
)
public:
static void Save(
    QsDocument^ doc
)
static member Save :
        doc : QsDocument -> unit

Parametri

doc QsDocument
Vedi anche

Documentazione

Classe QsDocument
Overload di Save


Metodo QsDocument.SaveAs

Metodo QsDocumentSaveAs
Lista degli overload
Nome | Descrizione
SaveAs(String) | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
SaveAs(QsDocument, String, Boolean) | Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.SaveAs(String)

Metodo QsDocumentSaveAs(String)
Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SaveAs(
    string destFileName
)
Public Shared Sub SaveAs (
    destFileName As String
)
public:
static void SaveAs(
    String^ destFileName
)
static member SaveAs :
        destFileName : string -> unit

Parametri

destFileName String
File di destinazione.
Vedi anche

Documentazione

Classe QsDocument
Overload di SaveAs


Metodo QsDocument.SaveAs(QsDocument, String, Boolean)

Metodo QsDocumentSaveAs(QsDocument, String, Boolean)
Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SaveAs(
    QsDocument doc,
    string destFileName,
    bool copyAs = false
)
Public Shared Sub SaveAs (
    doc As QsDocument,
    destFileName As String,
    Optional copyAs As Boolean = false
)
public:
static void SaveAs(
    QsDocument^ doc,
    String^ destFileName,
    bool copyAs = false
)
static member SaveAs :
        doc : QsDocument *
        destFileName : string *
        ?copyAs : bool
(* Defaults:
        let _copyAs = defaultArg copyAs false
*)
-> unit

Parametri

doc QsDocument
Documento da salvare.
destFileName String
File di destinazione.
copyAs Boolean (Optional)
Indica se fare un CopyAs ovvero mantiene il file attuale com'è e lo salva con nome.
Vedi anche

Documentazione

Classe QsDocument
Overload di SaveAs


Metodo QsDocument.SaveCopyAs

Metodo QsDocumentSaveCopyAs
Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SaveCopyAs(
    string destFileName
)
Public Shared Sub SaveCopyAs (
    destFileName As String
)
public:
static void SaveCopyAs(
    String^ destFileName
)
static member SaveCopyAs :
        destFileName : string -> unit

Parametri

destFileName String
File di destinazione.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.SendStringToExecute

Metodo QsDocumentSendStringToExecute
Esegue il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SendStringToExecute(
    string command,
    bool activate,
    bool wrapUpInactiveDoc,
    bool echoCommand
)
Public Sub SendStringToExecute (
    command As String,
    activate As Boolean,
    wrapUpInactiveDoc As Boolean,
    echoCommand As Boolean
)
public:
void SendStringToExecute(
    String^ command,
    bool activate,
    bool wrapUpInactiveDoc,
    bool echoCommand
)
member SendStringToExecute :
        command : string *
        activate : bool *
        wrapUpInactiveDoc : bool *
        echoCommand : bool -> unit

Parametri

command String
activate Boolean
wrapUpInactiveDoc Boolean
echoCommand Boolean
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.UpgradeDocOpen

Metodo QsDocumentUpgradeDocOpen
Effettua l'upgrade del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void UpgradeDocOpen()
Public Sub UpgradeDocOpen
public:
void UpgradeDocOpen()
member UpgradeDocOpen : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


QsDocument Operators

Il tipo QsDocument espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(QsDocument, QsDocument) | Ridefinizione dell'operatore ==.
Inequality(QsDocument, QsDocument) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe QsDocument


QsDocument.Equality Operatore

QsDocumentEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    QsDocument a,
    QsDocument b
)
Public Shared Operator = (
    a As QsDocument,
    b As QsDocument
) As Boolean
public:
static bool operator ==(
    QsDocument^ a,
    QsDocument^ b
)
static let inline (=)
        a : QsDocument *
        b : QsDocument  : bool

Parametri

a QsDocument
b QsDocument

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QsDocument


QsDocument.Inequality Operatore

QsDocumentInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    QsDocument a,
    QsDocument b
)
Public Shared Operator <> (
    a As QsDocument,
    b As QsDocument
) As Boolean
public:
static bool operator !=(
    QsDocument^ a,
    QsDocument^ b
)
static let inline (<>)
        a : QsDocument *
        b : QsDocument  : bool

Parametri

a QsDocument
b QsDocument

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QsDocument


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
DedNetAcadQsResources

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsResources

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s String
a Assembly
Vedi anche

Documentazione

Classe QsResources


Metodi di QsResources

Il tipo QsResources espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Classe QsResources


Metodo QsResources.GetString

Metodo QsResourcesGetString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo
Torna su
Vedi anche

Documentazione

Classe QsResources


Metodo QsResources.GetString(String)

Metodo QsResourcesGetString(String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString


Metodo QsResources.GetString(String, CultureInfo)

Metodo QsResourcesGetString(String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name String
culture CultureInfo

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString


Classe Registra
Comando di registrazione di un nuovo documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadRegistra

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Registra : AcadCommandBase
Public Class Registra
    Inherits AcadCommandBase
public ref class Registra : public AcadCommandBase
type Registra =
    class
        inherit AcadCommandBase
    end

Il tipo Registra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FnList | Imposta o ritorna la lista di file da registrare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo. (Sovrascrive AcadCommandBaseRequireStatePanelRefresh)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di Registra

Il tipo Registra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | FnList | Imposta o ritorna la lista di file da registrare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo. (Sovrascrive AcadCommandBaseRequireStatePanelRefresh)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe Registra


Proprietà Registra.FnList

Proprietà RegistraFnList
Imposta o ritorna la lista di file da registrare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FnList { get; set; }
Public Property FnList As List(Of String)
    Get
    Set
public:
property List<String^>^ FnList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FnList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe Registra


Proprietà Registra.NeedParameters

Proprietà RegistraNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Registra


Proprietà Registra.RequireStatePanelRefresh

Proprietà RegistraRequireStatePanelRefresh
Ritorna True se le operazioni effettuate dal comando richiedono un refresh della toolbar di stato del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool RequireStatePanelRefresh { get; }
Public Overrides ReadOnly Property RequireStatePanelRefresh As Boolean
    Get
public:
virtual property bool RequireStatePanelRefresh {
    bool get () override;
}
abstract RequireStatePanelRefresh : bool with get
override RequireStatePanelRefresh : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Registra


Metodi di Registra

Il tipo Registra espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Registra


Metodo Registra.AcadEnabled

Metodo RegistraAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe Registra


Metodo Registra.AcadSetContext

Metodo RegistraAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe Registra


Metodo Registra.ClearCommand

Metodo RegistraClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Registra


Metodo Registra.ExecuteCommand

Metodo RegistraExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe Registra


Classe Resolver
Classe di inizializzazione add-in. Viene utilizzata per registrare l'evento di risuluzione assembly in modo che nell'inizializzazione vera e propria dell'oggetto DedNetAcadApp si possa liberamente dichiarare i vari tipi di dato senza compromettere il caricamento dell'add-in.
Gerarchia di ereditarietà
SystemObject
DedNetAcadResolver

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Resolver : IExtensionApplication
Public Class Resolver
    Implements IExtensionApplication
public ref class Resolver : IExtensionApplication
type Resolver =
    class
        interface IExtensionApplication
    end

Il tipo Resolver espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Resolver |
Torna su
Proprietà
Nome | Descrizione
App |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Initialize | Metodo di inizializzazione chiamato da Autocad.
Metodo pubblico | Terminate | Metodo di chiusura chiamato da Autocad.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore Resolver

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Resolver()
Public Sub New
public:
Resolver()
new : unit -> Resolver
Vedi anche

Documentazione

Classe Resolver


Proprietà di Resolver

Il tipo Resolver espone i seguenti membri.

Proprietà
Nome | Descrizione
App |
Torna su
Vedi anche

Documentazione

Classe Resolver


Proprietà Resolver.App

Proprietà ResolverApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedNetAcadApp App { get; }
Public Shared ReadOnly Property App As DedNetAcadApp
    Get
public:
static property DedNetAcadApp^ App {
    DedNetAcadApp^ get ();
}
static member App : DedNetAcadApp with get

Valore della proprietà

DedNetAcadApp
Vedi anche

Documentazione

Classe Resolver


Metodi di Resolver

Il tipo Resolver espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Initialize | Metodo di inizializzazione chiamato da Autocad.
Metodo pubblico | Terminate | Metodo di chiusura chiamato da Autocad.
Torna su
Vedi anche

Documentazione

Classe Resolver


Metodo Resolver.Initialize

Metodo ResolverInitialize
Metodo di inizializzazione chiamato da Autocad.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
virtual void Initialize() sealed
abstract Initialize : unit -> unit
override Initialize : unit -> unit

Implementa

IExtensionApplication.Initialize
Vedi anche

Documentazione

Classe Resolver


Metodo Resolver.Terminate

Metodo ResolverTerminate
Metodo di chiusura chiamato da Autocad.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Terminate()
Public Sub Terminate
public:
virtual void Terminate() sealed
abstract Terminate : unit -> unit
override Terminate : unit -> unit

Implementa

IExtensionApplication.Terminate
Vedi anche

Documentazione

Classe Resolver


Classe SalvaRevXref
Comando Salva Revisione per Xref. Permette di codificare il file e poi sostituisce i riferimenti impostando il nuovo codificato all'interno del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadSalvaRevXref

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SalvaRevXref : AcadCommandBase
Public Class SalvaRevXref
    Inherits AcadCommandBase
public ref class SalvaRevXref : public AcadCommandBase
type SalvaRevXref =
    class
        inherit AcadCommandBase
    end

Il tipo SalvaRevXref espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SalvaRevXref | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore SalvaRevXref
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public SalvaRevXref(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
SalvaRevXref(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> SalvaRevXref

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe SalvaRevXref


Proprietà di SalvaRevXref

Il tipo SalvaRevXref espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Vedi anche

Documentazione

Classe SalvaRevXref


Proprietà SalvaRevXref.CreazioneVariante

Proprietà SalvaRevXrefCreazioneVariante
Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaRevXref


Proprietà SalvaRevXref.NeedParameters

Proprietà SalvaRevXrefNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaRevXref


Proprietà SalvaRevXref.XrefFileName

Proprietà SalvaRevXrefXrefFileName
Restituisce o imposta il filename dell'xref di partenza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string XrefFileName { get; set; }
Public Property XrefFileName As String
    Get
    Set
public:
property String^ XrefFileName {
    String^ get ();
    void set (String^ value);
}
member XrefFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SalvaRevXref


Metodi di SalvaRevXref

Il tipo SalvaRevXref espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaRevXref


Metodo SalvaRevXref.AcadEnabled

Metodo SalvaRevXrefAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SalvaRevXref


Metodo SalvaRevXref.AcadSetContext

Metodo SalvaRevXrefAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SalvaRevXref


Metodo SalvaRevXref.ClearCommand

Metodo SalvaRevXrefClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaRevXref


Metodo SalvaRevXref.ExecuteCommand

Metodo SalvaRevXrefExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe SalvaRevXref


Classe SalvaXref
Comando Salva per Xref. Permette di codificare il file e poi sostituisce i riferimenti impostando il nuovo codificato all'interno del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadSalvaXref

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SalvaXref : AcadCommandBase
Public Class SalvaXref
    Inherits AcadCommandBase
public ref class SalvaXref : public AcadCommandBase
type SalvaXref =
    class
        inherit AcadCommandBase
    end

Il tipo SalvaXref espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SalvaXref | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore SalvaXref
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public SalvaXref(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
SalvaXref(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> SalvaXref

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe SalvaXref


Proprietà di SalvaXref

Il tipo SalvaXref espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | XrefFileName | Restituisce o imposta il filename dell'xref di partenza.
Torna su
Vedi anche

Documentazione

Classe SalvaXref


Proprietà SalvaXref.CreazioneVariante

Proprietà SalvaXrefCreazioneVariante
Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaXref


Proprietà SalvaXref.NeedParameters

Proprietà SalvaXrefNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaXref


Proprietà SalvaXref.SaveCommand

Proprietà SalvaXrefSaveCommand
Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

SaveCommand
Vedi anche

Documentazione

Classe SalvaXref


Proprietà SalvaXref.XrefFileName

Proprietà SalvaXrefXrefFileName
Restituisce o imposta il filename dell'xref di partenza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string XrefFileName { get; set; }
Public Property XrefFileName As String
    Get
    Set
public:
property String^ XrefFileName {
    String^ get ();
    void set (String^ value);
}
member XrefFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SalvaXref


Metodi di SalvaXref

Il tipo SalvaXref espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaXref


Metodo SalvaXref.AcadEnabled

Metodo SalvaXrefAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SalvaXref


Metodo SalvaXref.AcadSetContext

Metodo SalvaXrefAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SalvaXref


Metodo SalvaXref.ClearCommand

Metodo SalvaXrefClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaXref


Metodo SalvaXref.ExecuteCommand

Metodo SalvaXrefExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe SalvaXref


Classe SelezionaRiferimento
Comando di selezione di un riferimento nell'interfaccia grafica.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadSelezionaRiferimento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SelezionaRiferimento : AcadCommandBase
Public Class SelezionaRiferimento
    Inherits AcadCommandBase
public ref class SelezionaRiferimento : public AcadCommandBase
type SelezionaRiferimento =
    class
        inherit AcadCommandBase
    end

Il tipo SelezionaRiferimento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Ext | Estensione del file a cui punta il riferimento.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | Id | Identificativo del riferimento.
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RefName | Nome del riferimento.
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di SelezionaRiferimento

Il tipo SelezionaRiferimento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Ext | Estensione del file a cui punta il riferimento.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | Id | Identificativo del riferimento.
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RefName | Nome del riferimento.
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe SelezionaRiferimento


Proprietà SelezionaRiferimento.Ext

Proprietà SelezionaRiferimentoExt
Estensione del file a cui punta il riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Ext { get; set; }
Public Property Ext As String
    Get
    Set
public:
property String^ Ext {
    String^ get ();
    void set (String^ value);
}
member Ext : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SelezionaRiferimento


Proprietà SelezionaRiferimento.Id

Proprietà SelezionaRiferimentoId
Identificativo del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Id { get; set; }
Public Property Id As Object
    Get
    Set
public:
property Object^ Id {
    Object^ get ();
    void set (Object^ value);
}
member Id : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe SelezionaRiferimento


Proprietà SelezionaRiferimento.NeedParameters

Proprietà SelezionaRiferimentoNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelezionaRiferimento


Proprietà SelezionaRiferimento.RefName

Proprietà SelezionaRiferimentoRefName
Nome del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RefName { get; set; }
Public Property RefName As String
    Get
    Set
public:
property String^ RefName {
    String^ get ();
    void set (String^ value);
}
member RefName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SelezionaRiferimento


Metodi di SelezionaRiferimento

Il tipo SelezionaRiferimento espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SelezionaRiferimento


Metodo SelezionaRiferimento.AcadEnabled

Metodo SelezionaRiferimentoAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SelezionaRiferimento


Metodo SelezionaRiferimento.AcadSetContext

Metodo SelezionaRiferimentoAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SelezionaRiferimento


Metodo SelezionaRiferimento.ClearCommand

Metodo SelezionaRiferimentoClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SelezionaRiferimento


Metodo SelezionaRiferimento.ExecuteCommand

Metodo SelezionaRiferimentoExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe SelezionaRiferimento


Classe SostituisciRiferimenti
Comando di sostituzione dei riferimenti di un xref sul documento attivo. Il comando lavora SEMPRE e SOLO sul documento attivo, per cui gli unici riferimenti sostituibili sono quelli di primo livello.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadSostituisciRiferimenti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciRiferimenti : AcadCommandBase
Public Class SostituisciRiferimenti
    Inherits AcadCommandBase
public ref class SostituisciRiferimenti : public AcadCommandBase
type SostituisciRiferimenti =
    class
        inherit AcadCommandBase
    end

Il tipo SostituisciRiferimenti espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SostituisciRiferimenti | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | DestDoc | Oggetto DedDoc che rappresenta il documento di sostituzione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SourceFilename | Percorso completo del file da sostituire.
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore SostituisciRiferimenti
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public SostituisciRiferimenti(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
SostituisciRiferimenti(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> SostituisciRiferimenti

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Proprietà di SostituisciRiferimenti

Il tipo SostituisciRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | DestDoc | Oggetto DedDoc che rappresenta il documento di sostituzione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | SourceFilename | Percorso completo del file da sostituire.
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Proprietà SostituisciRiferimenti.DestDoc

Proprietà SostituisciRiferimentiDestDoc
Oggetto DedDoc che rappresenta il documento di sostituzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DestDoc { get; set; }
Public Property DestDoc As DedDoc
    Get
    Set
public:
property DedDoc^ DestDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member DestDoc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Proprietà SostituisciRiferimenti.NeedParameters

Proprietà SostituisciRiferimentiNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Proprietà SostituisciRiferimenti.SourceFilename

Proprietà SostituisciRiferimentiSourceFilename
Percorso completo del file da sostituire.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string SourceFilename { get; set; }
Public Property SourceFilename As String
    Get
    Set
public:
property String^ SourceFilename {
    String^ get ();
    void set (String^ value);
}
member SourceFilename : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Metodi di SostituisciRiferimenti

Il tipo SostituisciRiferimenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Metodo SostituisciRiferimenti.AcadEnabled

Metodo SostituisciRiferimentiAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Metodo SostituisciRiferimenti.AcadSetContext

Metodo SostituisciRiferimentiAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Metodo SostituisciRiferimenti.ClearCommand

Metodo SostituisciRiferimentiClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Metodo SostituisciRiferimenti.ExecuteCommand

Metodo SostituisciRiferimentiExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe SostituisciRiferimenti


Classe StatoAllineamento
Comando che visualizza il dialogo di stato dell'allineamento di un documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadStatoAllineamento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class StatoAllineamento : AcadCommandBase
Public Class StatoAllineamento
    Inherits AcadCommandBase
public ref class StatoAllineamento : public AcadCommandBase
type StatoAllineamento =
    class
        inherit AcadCommandBase
    end

Il tipo StatoAllineamento espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | StatoAllineamento | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Filename | Restituisce o imposta il nome del file su cui lavorare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore StatoAllineamento
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public StatoAllineamento(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
StatoAllineamento(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> StatoAllineamento

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe StatoAllineamento


Proprietà di StatoAllineamento

Il tipo StatoAllineamento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Filename | Restituisce o imposta il nome del file su cui lavorare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe StatoAllineamento


Proprietà StatoAllineamento.Filename

Proprietà StatoAllineamentoFilename
Restituisce o imposta il nome del file su cui lavorare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}
member Filename : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe StatoAllineamento


Proprietà StatoAllineamento.NeedParameters

Proprietà StatoAllineamentoNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe StatoAllineamento


Metodi di StatoAllineamento

Il tipo StatoAllineamento espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StatoAllineamento


Metodo StatoAllineamento.AcadEnabled

Metodo StatoAllineamentoAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe StatoAllineamento


Metodo StatoAllineamento.AcadSetContext

Metodo StatoAllineamentoAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe StatoAllineamento


Metodo StatoAllineamento.ClearCommand

Metodo StatoAllineamentoClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe StatoAllineamento


Metodo StatoAllineamento.ExecuteCommand

Metodo StatoAllineamentoExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe StatoAllineamento


Classe UpdateOldRev
Aggiorna i riferimenti degli xref superati all'interno del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadUpdateOldRev

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateOldRev : AcadCommandBase
Public Class UpdateOldRev
    Inherits AcadCommandBase
public ref class UpdateOldRev : public AcadCommandBase
type UpdateOldRev =
    class
        inherit AcadCommandBase
    end

Il tipo UpdateOldRev espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpdateOldRev | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore UpdateOldRev
Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateOldRev(
    DedNetApplication app,
    string internalName,
    string displayName
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String
)
public:
UpdateOldRev(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string -> UpdateOldRev

Parametri

app DedNetApplication
internalName String
displayName String
Vedi anche

Documentazione

Classe UpdateOldRev


Proprietà di UpdateOldRev

Il tipo UpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRev


Proprietà UpdateOldRev.NeedParameters

Proprietà UpdateOldRevNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateOldRev


Metodi di UpdateOldRev

Il tipo UpdateOldRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRev


Metodo UpdateOldRev.AcadEnabled

Metodo UpdateOldRevAcadEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe UpdateOldRev


Metodo UpdateOldRev.AcadSetContext

Metodo UpdateOldRevAcadSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadSetContext (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe UpdateOldRev


Metodo UpdateOldRev.ClearCommand

Metodo UpdateOldRevClearCommand
Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateOldRev


Metodo UpdateOldRev.ExecuteCommand

Metodo UpdateOldRevExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe UpdateOldRev


Classe UsatoIn
Comando per visualizzare all'interno di quali documenti è usato un determinato documento
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadAcadCommandBase
DedNetAcadUsatoIn

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class UsatoIn : AcadCommandBase
Public Class UsatoIn
    Inherits AcadCommandBase
public ref class UsatoIn : public AcadCommandBase
type UsatoIn =
    class
        inherit AcadCommandBase
    end

Il tipo UsatoIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento.
Proprietà pubblica | Doc | Documento da visualizzare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Imposta il comando in base alla selezione. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di UsatoIn

Il tipo UsatoIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da AcadCommandBase)
Proprietà pubblica | Application | (Ereditato da DedCommand)
Proprietà pubblica | Client | (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento.
Proprietà pubblica | Doc | Documento da visualizzare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand)
Proprietà pubblica | Img16 | (Ereditato da DedCommand)
Proprietà pubblica | Img32 | (Ereditato da DedCommand)
Proprietà pubblica | InternalName | (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand)
Proprietà pubblica | LastException | (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand)
Proprietà pubblica | Name | (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive AcadCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand)
Proprietà pubblica | RequireStatePanelRefresh | Indica se il comando richiede un refresh della status bar con le informazioni sul documento attivo. (Ereditato da AcadCommandBase)
Proprietà pubblica | Result | (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | (Ereditato da DedCommand)
Proprietà pubblica | Silent | (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da AcadCommandBase)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | (Ereditato da DedCommand)
Proprietà pubblica | UseUI | (Ereditato da DedCommand)
Proprietà pubblica | WorkOnActiveDoc | Indica se il comando va a lavorare sul documento attualmente aperto e attivo. (Ereditato da AcadCommandBase)
Torna su
Vedi anche

Documentazione

Classe UsatoIn


Proprietà UsatoIn.Data

Proprietà UsatoInData
Anagrafica a cui appartiene il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe UsatoIn


Proprietà UsatoIn.Doc

Proprietà UsatoInDoc
Documento da visualizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe UsatoIn


Proprietà UsatoIn.NeedParameters

Proprietà UsatoInNeedParameters
Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UsatoIn


Metodi di UsatoIn

Il tipo UsatoIn espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AcadEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive AcadCommandBaseAcadEnabled(DedAcadCommandContext))
Metodo pubblico | AcadSetContext | Imposta il comando in base alla selezione. (Sovrascrive AcadCommandBaseAcadSetContext(DedAcadCommandContext))
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive AcadCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive AcadCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand)
Metodo pubblico | Run | (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da AcadCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UsatoIn


Metodo UsatoIn.AcadEnabled

Metodo UsatoInAcadEnabled
Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadEnabled(
    DedAcadCommandContext acadCmdCtx
)
Public Overrides Function AcadEnabled (
    acadCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadEnabled(
    DedAcadCommandContext^ acadCmdCtx
) override
abstract AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool
override AcadEnabled :
        acadCmdCtx : DedAcadCommandContext -> bool

Parametri

acadCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsatoIn


Metodo UsatoIn.AcadSetContext

Metodo UsatoInAcadSetContext
Imposta il comando in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override bool AcadSetContext(
    DedAcadCommandContext invCmdCtx
)
Public Overrides Function AcadSetContext (
    invCmdCtx As DedAcadCommandContext
) As Boolean
public:
virtual bool AcadSetContext(
    DedAcadCommandContext^ invCmdCtx
) override
abstract AcadSetContext :
        invCmdCtx : DedAcadCommandContext -> bool
override AcadSetContext :
        invCmdCtx : DedAcadCommandContext -> bool

Parametri

invCmdCtx DedAcadCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsatoIn


Metodo UsatoIn.ClearCommand

Metodo UsatoInClearCommand
Azzera il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UsatoIn


Metodo UsatoIn.ExecuteCommand

Metodo UsatoInExecuteCommand
Lancia il comando di "Usato in".

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe UsatoIn


Classe Util
Utility con gli assert e varie altre funzioni di utilizzo frequente.
Gerarchia di ereditarietà
SystemObject
DedNetAcadUtil

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class Util
Public NotInheritable Class Util
public ref class Util abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Util = class end

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
AcadFile2DedDataPart | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
AssertAllDocumentsClose | Controlla che non ci siano dei documenti aperti
AssertCurrentDocument | Chiama la funzione CurrentDocument() per avere il DedDoc corrente e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertDocumentClosed | Controllo che il file passato non sia correntemente aperto nel CAD. Se lo trova aperto, genera un'eccezione per avvisare l'utente.
AssertReadDataFromPart | Viene utilizzata la funzione ReadDataFromPart() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.
AssertReadDataFromPartManager | Viene utilizzata la funzione ReadDataFromFile() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.
CheckForModel | Verifica se il layout attivo è il modello
CreaStrutturaCambioStatoMultiploXref | Crea la struttura da dare in pasto al dialogo di cambio stato multiplo in caso di gestione di xref.
CreateDataPartFromAllAttr(PartInfo) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
CreateDataPartFromAllAttr(PartManager) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
CreatePartManager | Crea e restiruisce il part manager leggendo le opzioni dal top_arx.
DocDataIsWritable | Ritorna vero se l'anagrafica associata al documento è scrivibile ma anche se il documento non ha anagrafica associata
ExecuteCadCommandAsync | Execute command
File2DedDataPart(PartManager, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
File2DedDataPart(PartManager, DedType, DedAttrList) | Legge i dati dal file di autocad e li inserisce in una DedDataPart.
FileAttrMatchData |
FileIsDwg | Restituisce se il file passato sia o meno un DWG di AutoCAD.
FileIsNew | Verifica se il file passato, letto da Document.Name, sia o meno un file nuovo.
FileIsOpen | Restituisce vero se il file risulta aperto
FillWithAssociatedFiles | Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.
GetAllAutocadFiles | Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti
GetCurrentLayout | Restituisce il layout attivo
GetDedIdDedRevFromPartFile | Legge e restituisce i valori di dedid e dedrev dal file dwg.
GetDwgVerEnumFromString | Dato il nome di una versione di salvataggio ne restituisce il rispettivo Enum.
GetDxfOutVers | Restituisce le versioni di salvataggio supportate per i Dxf.
GetDxfOutVersWithDescr | Restituisce le versioni di salvataggio supportate per i Dxf.
GetEnvFullPath | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathBase | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathUser | Ritorna la posizione dell'ambiente corrente.
GetLastDataRowVer(PartInfo) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(PartManager) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetOpenedDocumentFromFile | Controlla se il documento identificato dal file passato è aperto nella sessione corrente
GetPrinterStyleSheetDir | Restituisce il percorso dove sono presenti i fogli di stile, usato dalla pubblicazione.
GetRVerFromVersion | Restiruisce la versione R? in base all'anno.
GetXrefList | Ritorna l'elenco di tutti gli xref del disegno
GetXrefPathType | Dato un percorso il tipo di percorso secondo le regole degli xref sulla tipologia del percorso.
HasXref | Ritorna True se il file passato contiene delle dipendenze xref, altrimenti False.
InizializzaStrutturaUpdateRevision | Crea e restituisce la lista di riferimenti che andranno aggiornati dal comando Aggiorna revisioni superate Xref.
IsAutocad2016SP1 | Restituisce True se è installato Autocad 2016 con SP1
OpenDoc | Metodo di apertura
PartAttrMatchData |
PrecompilaCodice | Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.
ReadAllAttr(BomPartInfo, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllAttr(PartInfo, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllAttr(PartManager, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllProperties(PartInfo) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAllProperties(PartManager) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAnagr | Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.
ReadDataFromBomPart | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromFile | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromFileProperties | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPart | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPartProperties | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica.
ReadFileProperties |
RefreshAttributes | Aggiorna il pannello attributi.
RelativizeXrefPath | Relativizza i riferimenti di 'filename' in base alla propria posizione.
ReloadReference | Chiama un reload dell'xref passato.
RelocateReferences | Riloca le dipendenze dal file di partenza al file di destinazione
SelectXrefProgrammatically | Metodo per selezionare graficamente il riferimento passato.
SetCurrentLayout | Setta il layout attivo
SetLastDataRowVer(PartInfo, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.
SetLastDataRowVer(PartManager, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
UnloadReference | Chiama un unload dell'xref passato.
UpdateAllDocumentReferences | Aggiorna tutti i riferimenti che puntano al startRefName passato.
UpdateDocumentReference | Aggiorna il riferimento identificato da refId impostandogli il percorso di destinazione destRefName.
WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean) | Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.
WriteAllAttr(IDedData, Part, DedAttrList, String) | Scrive tutti gli attributi nel file leggendoli dall'anagrafica.
WriteAllProperties(DedDoc, PartInfo) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, PartManager) | Scrive tutte le proprietà del documento nel Database
WriteAttr(Part, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteAttr(PartInfo, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteDataToFile | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteDataToPart | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteUserProperties | Scrive le proprietà presenti nel dizionario all'interno del file.
Torna su
Campi
Nome | Descrizione
_dataTimeMin |
RILPDF | Ritorna il nome della configurazione da utilizzare per esportare il documento in PDF.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di Util

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
AcadFile2DedDataPart | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
AssertAllDocumentsClose | Controlla che non ci siano dei documenti aperti
AssertCurrentDocument | Chiama la funzione CurrentDocument() per avere il DedDoc corrente e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertDocumentClosed | Controllo che il file passato non sia correntemente aperto nel CAD. Se lo trova aperto, genera un'eccezione per avvisare l'utente.
AssertReadDataFromPart | Viene utilizzata la funzione ReadDataFromPart() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.
AssertReadDataFromPartManager | Viene utilizzata la funzione ReadDataFromFile() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.
CheckForModel | Verifica se il layout attivo è il modello
CreaStrutturaCambioStatoMultiploXref | Crea la struttura da dare in pasto al dialogo di cambio stato multiplo in caso di gestione di xref.
CreateDataPartFromAllAttr(PartInfo) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
CreateDataPartFromAllAttr(PartManager) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
CreatePartManager | Crea e restiruisce il part manager leggendo le opzioni dal top_arx.
DocDataIsWritable | Ritorna vero se l'anagrafica associata al documento è scrivibile ma anche se il documento non ha anagrafica associata
ExecuteCadCommandAsync | Execute command
File2DedDataPart(PartManager, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
File2DedDataPart(PartManager, DedType, DedAttrList) | Legge i dati dal file di autocad e li inserisce in una DedDataPart.
FileAttrMatchData |
FileIsDwg | Restituisce se il file passato sia o meno un DWG di AutoCAD.
FileIsNew | Verifica se il file passato, letto da Document.Name, sia o meno un file nuovo.
FileIsOpen | Restituisce vero se il file risulta aperto
FillWithAssociatedFiles | Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.
GetAllAutocadFiles | Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti
GetCurrentLayout | Restituisce il layout attivo
GetDedIdDedRevFromPartFile | Legge e restituisce i valori di dedid e dedrev dal file dwg.
GetDwgVerEnumFromString | Dato il nome di una versione di salvataggio ne restituisce il rispettivo Enum.
GetDxfOutVers | Restituisce le versioni di salvataggio supportate per i Dxf.
GetDxfOutVersWithDescr | Restituisce le versioni di salvataggio supportate per i Dxf.
GetEnvFullPath | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathBase | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathUser | Ritorna la posizione dell'ambiente corrente.
GetLastDataRowVer(PartInfo) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(PartManager) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetOpenedDocumentFromFile | Controlla se il documento identificato dal file passato è aperto nella sessione corrente
GetPrinterStyleSheetDir | Restituisce il percorso dove sono presenti i fogli di stile, usato dalla pubblicazione.
GetRVerFromVersion | Restiruisce la versione R? in base all'anno.
GetXrefList | Ritorna l'elenco di tutti gli xref del disegno
GetXrefPathType | Dato un percorso il tipo di percorso secondo le regole degli xref sulla tipologia del percorso.
HasXref | Ritorna True se il file passato contiene delle dipendenze xref, altrimenti False.
InizializzaStrutturaUpdateRevision | Crea e restituisce la lista di riferimenti che andranno aggiornati dal comando Aggiorna revisioni superate Xref.
IsAutocad2016SP1 | Restituisce True se è installato Autocad 2016 con SP1
OpenDoc | Metodo di apertura
PartAttrMatchData |
PrecompilaCodice | Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.
ReadAllAttr(BomPartInfo, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllAttr(PartInfo, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllAttr(PartManager, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllProperties(PartInfo) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAllProperties(PartManager) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAnagr | Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.
ReadDataFromBomPart | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromFile | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromFileProperties | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPart | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPartProperties | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica.
ReadFileProperties |
RefreshAttributes | Aggiorna il pannello attributi.
RelativizeXrefPath | Relativizza i riferimenti di 'filename' in base alla propria posizione.
ReloadReference | Chiama un reload dell'xref passato.
RelocateReferences | Riloca le dipendenze dal file di partenza al file di destinazione
SelectXrefProgrammatically | Metodo per selezionare graficamente il riferimento passato.
SetCurrentLayout | Setta il layout attivo
SetLastDataRowVer(PartInfo, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.
SetLastDataRowVer(PartManager, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
UnloadReference | Chiama un unload dell'xref passato.
UpdateAllDocumentReferences | Aggiorna tutti i riferimenti che puntano al startRefName passato.
UpdateDocumentReference | Aggiorna il riferimento identificato da refId impostandogli il percorso di destinazione destRefName.
WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean) | Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.
WriteAllAttr(IDedData, Part, DedAttrList, String) | Scrive tutti gli attributi nel file leggendoli dall'anagrafica.
WriteAllProperties(DedDoc, PartInfo) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, PartManager) | Scrive tutte le proprietà del documento nel Database
WriteAttr(Part, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteAttr(PartInfo, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteDataToFile | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteDataToPart | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteUserProperties | Scrive le proprietà presenti nel dizionario all'interno del file.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.AcadFile2DedDataPart

Metodo UtilAcadFile2DedDataPart
Legge i dati dal file di inventor e li inserisce in una DedDataPart.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart AcadFile2DedDataPart(
    string filename,
    DedType refType
)
Public Shared Function AcadFile2DedDataPart (
    filename As String,
    refType As DedType
) As DedDataPart
public:
static DedDataPart^ AcadFile2DedDataPart(
    String^ filename,
    DedType^ refType
)
static member AcadFile2DedDataPart :
        filename : string *
        refType : DedType -> DedDataPart

Parametri

filename String
File di interesse di Inventor
refType DedType
Famiglia di riferimento

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertAllDocumentsClose

Metodo UtilAssertAllDocumentsClose
Controlla che non ci siano dei documenti aperti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void AssertAllDocumentsClose()
Public Shared Sub AssertAllDocumentsClose
public:
static void AssertAllDocumentsClose()
static member AssertAllDocumentsClose : unit -> unit
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertCurrentDocument

Metodo UtilAssertCurrentDocument
Chiama la funzione CurrentDocument() per avere il DedDoc corrente e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc AssertCurrentDocument()
Public Shared Function AssertCurrentDocument As DedDoc
public:
static DedDoc^ AssertCurrentDocument()
static member AssertCurrentDocument : unit -> DedDoc

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertDocumentClosed

Metodo UtilAssertDocumentClosed
Controllo che il file passato non sia correntemente aperto nel CAD. Se lo trova aperto, genera un'eccezione per avvisare l'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocumentClosed(
    string fn
)
Public Shared Sub AssertDocumentClosed (
    fn As String
)
public:
static void AssertDocumentClosed(
    String^ fn
)
static member AssertDocumentClosed :
        fn : string -> unit

Parametri

fn String
Nome del file da cercare.
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertReadDataFromPart

Metodo UtilAssertReadDataFromPart
Viene utilizzata la funzione ReadDataFromPart() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromPart(
    PartInfo prt
)
Public Shared Function AssertReadDataFromPart (
    prt As PartInfo
) As DedData
public:
static DedData^ AssertReadDataFromPart(
    PartInfo^ prt
)
static member AssertReadDataFromPart :
        prt : PartInfo -> DedData

Parametri

prt PartInfo
Parte dalla quale leggere l'anagrafica.

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertReadDataFromPartManager

Metodo UtilAssertReadDataFromPartManager
Viene utilizzata la funzione ReadDataFromFile() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromPartManager(
    PartManager partManager
)
Public Shared Function AssertReadDataFromPartManager (
    partManager As PartManager
) As DedData
public:
static DedData^ AssertReadDataFromPartManager(
    PartManager^ partManager
)
static member AssertReadDataFromPartManager :
        partManager : PartManager -> DedData

Parametri

partManager PartManager
Parte dalla quale leggere l'anagrafica.

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util


Metodo Util.CheckForModel

Metodo UtilCheckForModel
Verifica se il layout attivo è il modello

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckForModel()
Public Shared Function CheckForModel As Boolean
public:
static bool CheckForModel()
static member CheckForModel : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.CreaStrutturaCambioStatoMultiploXref

Metodo UtilCreaStrutturaCambioStatoMultiploXref
Crea la struttura da dare in pasto al dialogo di cambio stato multiplo in caso di gestione di xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<MultipleStateOperationPartInfoDoc> CreaStrutturaCambioStatoMultiploXref(
    string fname
)
Public Shared Function CreaStrutturaCambioStatoMultiploXref (
    fname As String
) As List(Of MultipleStateOperationPartInfoDoc)
public:
static List<MultipleStateOperationPartInfoDoc^>^ CreaStrutturaCambioStatoMultiploXref(
    String^ fname
)
static member CreaStrutturaCambioStatoMultiploXref :
        fname : string -> List<MultipleStateOperationPartInfoDoc>

Parametri

fname String
Nome del file di root.

Valore di ritorno

List MultipleStateOperationPartInfoDoc
Vedi anche

Documentazione

Classe Util


Metodo Util.CreateDataPartFromAllAttr

Metodo UtilCreateDataPartFromAllAttr
Lista degli overload
Nome | Descrizione
CreateDataPartFromAllAttr(PartInfo) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
CreateDataPartFromAllAttr(PartManager) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.CreateDataPartFromAllAttr(PartInfo)

Metodo UtilCreateDataPartFromAllAttr(PartInfo)
Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> CreateDataPartFromAllAttr(
    PartInfo prt
)
Public Shared Function CreateDataPartFromAllAttr (
    prt As PartInfo
) As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ CreateDataPartFromAllAttr(
    PartInfo^ prt
)
static member CreateDataPartFromAllAttr :
        prt : PartInfo -> Dictionary<string, string>

Parametri

prt PartInfo
Parte dalla quale leggere le informazioni.

Valore di ritorno

Dictionary String, String
Vedi anche

Documentazione

Classe Util
Overload di CreateDataPartFromAllAttr


Metodo Util.CreateDataPartFromAllAttr(PartManager)

Metodo UtilCreateDataPartFromAllAttr(PartManager)
Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> CreateDataPartFromAllAttr(
    PartManager partManager
)
Public Shared Function CreateDataPartFromAllAttr (
    partManager As PartManager
) As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ CreateDataPartFromAllAttr(
    PartManager^ partManager
)
static member CreateDataPartFromAllAttr :
        partManager : PartManager -> Dictionary<string, string>

Parametri

partManager PartManager
Parte dalla quale leggere le informazioni.

Valore di ritorno

Dictionary String, String
Vedi anche

Documentazione

Classe Util
Overload di CreateDataPartFromAllAttr


Metodo Util.CreatePartManager

Metodo UtilCreatePartManager
Crea e restiruisce il part manager leggendo le opzioni dal top_arx.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static PartManager CreatePartManager(
    OdaManager odaManager,
    string acadFileName
)
Public Shared Function CreatePartManager (
    odaManager As OdaManager,
    acadFileName As String
) As PartManager
public:
static PartManager^ CreatePartManager(
    OdaManager^ odaManager,
    String^ acadFileName
)
static member CreatePartManager :
        odaManager : OdaManager *
        acadFileName : string -> PartManager

Parametri

odaManager OdaManager
acadFileName String
File del quale creare il PartManager.

Valore di ritorno

PartManager
Vedi anche

Documentazione

Classe Util


Metodo Util.DocDataIsWritable

Metodo UtilDocDataIsWritable
Ritorna vero se l'anagrafica associata al documento è scrivibile ma anche se il documento non ha anagrafica associata

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool DocDataIsWritable(
    DedDoc deddoc
)
Public Shared Function DocDataIsWritable (
    deddoc As DedDoc
) As Boolean
public:
static bool DocDataIsWritable(
    DedDoc^ deddoc
)
static member DocDataIsWritable :
        deddoc : DedDoc -> bool

Parametri

deddoc DedDoc

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.ExecuteCadCommandAsync

Metodo UtilExecuteCadCommandAsync
Execute command

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ExecuteCadCommandAsync(
    string command,
    bool activateDoc,
    bool wrapUpInactiveDoc,
    bool echo,
    bool cancelCmd
)
Public Shared Sub ExecuteCadCommandAsync (
    command As String,
    activateDoc As Boolean,
    wrapUpInactiveDoc As Boolean,
    echo As Boolean,
    cancelCmd As Boolean
)
public:
static void ExecuteCadCommandAsync(
    String^ command,
    bool activateDoc,
    bool wrapUpInactiveDoc,
    bool echo,
    bool cancelCmd
)
static member ExecuteCadCommandAsync :
        command : string *
        activateDoc : bool *
        wrapUpInactiveDoc : bool *
        echo : bool *
        cancelCmd : bool -> unit

Parametri

command String
activateDoc Boolean
wrapUpInactiveDoc Boolean
echo Boolean
cancelCmd Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.File2DedDataPart

Metodo UtilFile2DedDataPart
Lista degli overload
Nome | Descrizione
File2DedDataPart(PartManager, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
File2DedDataPart(PartManager, DedType, DedAttrList) | Legge i dati dal file di autocad e li inserisce in una DedDataPart.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.File2DedDataPart(PartManager, DedType)

Metodo UtilFile2DedDataPart(PartManager, DedType)
Legge i dati dal file di inventor e li inserisce in una DedDataPart.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart File2DedDataPart(
    PartManager partManager,
    DedType refType
)
Public Shared Function File2DedDataPart (
    partManager As PartManager,
    refType As DedType
) As DedDataPart
public:
static DedDataPart^ File2DedDataPart(
    PartManager^ partManager,
    DedType^ refType
)
static member File2DedDataPart :
        partManager : PartManager *
        refType : DedType -> DedDataPart

Parametri

partManager PartManager
refType DedType
Famiglia di riferimento

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di File2DedDataPart


Metodo Util.File2DedDataPart(PartManager, DedType, DedAttrList)

Metodo UtilFile2DedDataPart(PartManager, DedType, DedAttrList)
Legge i dati dal file di autocad e li inserisce in una DedDataPart.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart File2DedDataPart(
    PartManager partManager,
    DedType refType,
    DedAttrList attrList
)
Public Shared Function File2DedDataPart (
    partManager As PartManager,
    refType As DedType,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ File2DedDataPart(
    PartManager^ partManager,
    DedType^ refType,
    DedAttrList^ attrList
)
static member File2DedDataPart :
        partManager : PartManager *
        refType : DedType *
        attrList : DedAttrList -> DedDataPart

Parametri

partManager PartManager
refType DedType
Famiglia di riferimento
attrList DedAttrList
Elenco attributi per creare il dedDataPart.

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di File2DedDataPart


Metodo Util.FileAttrMatchData

Metodo UtilFileAttrMatchData

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileAttrMatchData(
    PartManager partManager,
    DedData data
)
Public Shared Function FileAttrMatchData (
    partManager As PartManager,
    data As DedData
) As Boolean
public:
static bool FileAttrMatchData(
    PartManager^ partManager,
    DedData^ data
)
static member FileAttrMatchData :
        partManager : PartManager *
        data : DedData -> bool

Parametri

partManager PartManager
data DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.FileIsDwg

Metodo UtilFileIsDwg
Restituisce se il file passato sia o meno un DWG di AutoCAD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsDwg(
    string fileName
)
Public Shared Function FileIsDwg (
    fileName As String
) As Boolean
public:
static bool FileIsDwg(
    String^ fileName
)
static member FileIsDwg :
        fileName : string -> bool

Parametri

fileName String
File da analizzare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.FileIsNew

Metodo UtilFileIsNew
Verifica se il file passato, letto da Document.Name, sia o meno un file nuovo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsNew(
    string fileName
)
Public Shared Function FileIsNew (
    fileName As String
) As Boolean
public:
static bool FileIsNew(
    String^ fileName
)
static member FileIsNew :
        fileName : string -> bool

Parametri

fileName String
File da verificare, letto dalla proprietà Document.Name.

Valore di ritorno

Boolean
Restituisce true se è nuovo altrimenti false.
Vedi anche

Documentazione

Classe Util


Metodo Util.FileIsOpen

Metodo UtilFileIsOpen
Restituisce vero se il file risulta aperto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsOpen(
    string fileName
)
Public Shared Function FileIsOpen (
    fileName As String
) As Boolean
public:
static bool FileIsOpen(
    String^ fileName
)
static member FileIsOpen :
        fileName : string -> bool

Parametri

fileName String
File da analizzare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.FillWithAssociatedFiles

Metodo UtilFillWithAssociatedFiles
Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList FillWithAssociatedFiles(
    AcadDocStructInfo infoItem,
    DocStructInfoList associatedFilledList = null
)
Public Shared Function FillWithAssociatedFiles (
    infoItem As AcadDocStructInfo,
    Optional associatedFilledList As DocStructInfoList = Nothing
) As DocStructInfoList
public:
static DocStructInfoList^ FillWithAssociatedFiles(
    AcadDocStructInfo^ infoItem,
    DocStructInfoList^ associatedFilledList = nullptr
)
static member FillWithAssociatedFiles :
        infoItem : AcadDocStructInfo *
        ?associatedFilledList : DocStructInfoList
(* Defaults:
        let _associatedFilledList = defaultArg associatedFilledList null
*)
-> DocStructInfoList

Parametri

infoItem AcadDocStructInfo
Elemento del quale trovare i file associati.
associatedFilledList DocStructInfoList (Optional)

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe Util


Metodo Util.GetAllAutocadFiles

Metodo UtilGetAllAutocadFiles
Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetAllAutocadFiles(
    string refPath
)
Public Shared Function GetAllAutocadFiles (
    refPath As String
) As List(Of String)
public:
static List<String^>^ GetAllAutocadFiles(
    String^ refPath
)
static member GetAllAutocadFiles :
        refPath : string -> List<string>

Parametri

refPath String

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetCurrentLayout

Metodo UtilGetCurrentLayout
Restituisce il layout attivo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetCurrentLayout()
Public Shared Function GetCurrentLayout As String
public:
static String^ GetCurrentLayout()
static member GetCurrentLayout : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDedIdDedRevFromPartFile

Metodo UtilGetDedIdDedRevFromPartFile
Legge e restituisce i valori di dedid e dedrev dal file dwg.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void GetDedIdDedRevFromPartFile(
    PartManager prtManager,
    out string dedid,
    out string dedrev
)
Public Shared Sub GetDedIdDedRevFromPartFile (
    prtManager As PartManager,
    <OutAttribute> ByRef dedid As String,
    <OutAttribute> ByRef dedrev As String
)
public:
static void GetDedIdDedRevFromPartFile(
    PartManager^ prtManager,
    [OutAttribute] String^% dedid,
    [OutAttribute] String^% dedrev
)
static member GetDedIdDedRevFromPartFile :
        prtManager : PartManager *
        dedid : string byref *
        dedrev : string byref -> unit

Parametri

prtManager PartManager
Oggetto PartManager
dedid String
Valore del campo DEDID
dedrev String
Valore del campo DEDREV
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDwgVerEnumFromString

Metodo UtilGetDwgVerEnumFromString
Dato il nome di una versione di salvataggio ne restituisce il rispettivo Enum.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DwgVersion GetDwgVerEnumFromString(
    string val
)
Public Shared Function GetDwgVerEnumFromString (
    val As String
) As DwgVersion
public:
static DwgVersion GetDwgVerEnumFromString(
    String^ val
)
static member GetDwgVerEnumFromString :
        val : string -> DwgVersion

Parametri

val String
Versione di salvataggio

Valore di ritorno

DwgVersion
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDxfOutVers

Metodo UtilGetDxfOutVers
Restituisce le versioni di salvataggio supportate per i Dxf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DwgVersion> GetDxfOutVers()
Public Shared Function GetDxfOutVers As List(Of DwgVersion)
public:
static List<DwgVersion>^ GetDxfOutVers()
static member GetDxfOutVers : unit -> List<DwgVersion>

Valore di ritorno

List DwgVersion
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDxfOutVersWithDescr

Metodo UtilGetDxfOutVersWithDescr
Restituisce le versioni di salvataggio supportate per i Dxf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetDxfOutVersWithDescr()
Public Shared Function GetDxfOutVersWithDescr As List(Of String)
public:
static List<String^>^ GetDxfOutVersWithDescr()
static member GetDxfOutVersWithDescr : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetEnvFullPath

Metodo UtilGetEnvFullPath
Ritorna la posizione dell'ambiente corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetEnvFullPath()
Public Shared Function GetEnvFullPath As String
public:
static String^ GetEnvFullPath()
static member GetEnvFullPath : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetEnvFullPathBase

Metodo UtilGetEnvFullPathBase
Ritorna la posizione dell'ambiente corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetEnvFullPathBase()
Public Shared Function GetEnvFullPathBase As String
public:
static String^ GetEnvFullPathBase()
static member GetEnvFullPathBase : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetEnvFullPathUser

Metodo UtilGetEnvFullPathUser
Ritorna la posizione dell'ambiente corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetEnvFullPathUser()
Public Shared Function GetEnvFullPathUser As String
public:
static String^ GetEnvFullPathUser()
static member GetEnvFullPathUser : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetLastDataRowVer

Metodo UtilGetLastDataRowVer
Lista degli overload
Nome | Descrizione
GetLastDataRowVer(PartInfo) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(PartManager) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.GetLastDataRowVer(PartInfo)

Metodo UtilGetLastDataRowVer(PartInfo)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    PartInfo prtInfo
)
Public Shared Function GetLastDataRowVer (
    prtInfo As PartInfo
) As Guid
public:
static Guid GetLastDataRowVer(
    PartInfo^ prtInfo
)
static member GetLastDataRowVer :
        prtInfo : PartInfo -> Guid

Parametri

prtInfo PartInfo
PartInfo del disegno.

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer


Metodo Util.GetLastDataRowVer(PartManager)

Metodo UtilGetLastDataRowVer(PartManager)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    PartManager partManager
)
Public Shared Function GetLastDataRowVer (
    partManager As PartManager
) As Guid
public:
static Guid GetLastDataRowVer(
    PartManager^ partManager
)
static member GetLastDataRowVer :
        partManager : PartManager -> Guid

Parametri

partManager PartManager

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer


Metodo Util.GetOpenedDocumentFromFile

Metodo UtilGetOpenedDocumentFromFile
Controlla se il documento identificato dal file passato è aperto nella sessione corrente

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Document GetOpenedDocumentFromFile(
    string fileName
)
Public Shared Function GetOpenedDocumentFromFile (
    fileName As String
) As Document
public:
static Document^ GetOpenedDocumentFromFile(
    String^ fileName
)
static member GetOpenedDocumentFromFile :
        fileName : string -> Document

Parametri

fileName String
File da analizzare

Valore di ritorno

Document
Vedi anche

Documentazione

Classe Util


Metodo Util.GetPrinterStyleSheetDir

Metodo UtilGetPrinterStyleSheetDir
Restituisce il percorso dove sono presenti i fogli di stile, usato dalla pubblicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetPrinterStyleSheetDir()
Public Shared Function GetPrinterStyleSheetDir As String
public:
static String^ GetPrinterStyleSheetDir()
static member GetPrinterStyleSheetDir : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetRVerFromVersion

Metodo UtilGetRVerFromVersion
Restiruisce la versione R? in base all'anno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetRVerFromVersion(
    string ver
)
Public Shared Function GetRVerFromVersion (
    ver As String
) As String
public:
static String^ GetRVerFromVersion(
    String^ ver
)
static member GetRVerFromVersion :
        ver : string -> string

Parametri

ver String
Anno di AutocadLT

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetXrefList

Metodo UtilGetXrefList
Ritorna l'elenco di tutti gli xref del disegno

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static List<XrefDescriptor> GetXrefList(
    string filename,
    bool allLevels = false
)
Public Shared Function GetXrefList (
    filename As String,
    Optional allLevels As Boolean = false
) As List(Of XrefDescriptor)
public:
static List<XrefDescriptor^>^ GetXrefList(
    String^ filename,
    bool allLevels = false
)
static member GetXrefList :
        filename : string *
        ?allLevels : bool
(* Defaults:
        let _allLevels = defaultArg allLevels false
*)
-> List<XrefDescriptor>

Parametri

filename String
FileName di riferimento del documento
allLevels Boolean (Optional)
Indica se ritornare un elenco di tutti i livelli

Valore di ritorno

List XrefDescriptor
Vedi anche

Documentazione

Classe Util


Metodo Util.GetXrefPathType

Metodo UtilGetXrefPathType
Dato un percorso il tipo di percorso secondo le regole degli xref sulla tipologia del percorso.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static UtilXrefPathType GetXrefPathType(
    string path
)
Public Shared Function GetXrefPathType (
    path As String
) As UtilXrefPathType
public:
static UtilXrefPathType GetXrefPathType(
    String^ path
)
static member GetXrefPathType :
        path : string -> UtilXrefPathType

Parametri

path String
Percorso da analizzare.

Valore di ritorno

UtilXrefPathType
Vedi anche

Documentazione

Classe Util


Metodo Util.HasXref

Metodo UtilHasXref
Ritorna True se il file passato contiene delle dipendenze xref, altrimenti False.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool HasXref(
    string filename
)
Public Shared Function HasXref (
    filename As String
) As Boolean
public:
static bool HasXref(
    String^ filename
)
static member HasXref :
        filename : string -> bool

Parametri

filename String
Nome del file da analizzare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.InizializzaStrutturaUpdateRevision

Metodo UtilInizializzaStrutturaUpdateRevision
Crea e restituisce la lista di riferimenti che andranno aggiornati dal comando Aggiorna revisioni superate Xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static ListObjToUpdate InizializzaStrutturaUpdateRevision()
Public Shared Function InizializzaStrutturaUpdateRevision As ListObjToUpdate
public:
static ListObjToUpdate^ InizializzaStrutturaUpdateRevision()
static member InizializzaStrutturaUpdateRevision : unit -> ListObjToUpdate

Valore di ritorno

ListObjToUpdate
Vedi anche

Documentazione

Classe Util


Metodo Util.IsAutocad2016SP1

Metodo UtilIsAutocad2016SP1
Restituisce True se è installato Autocad 2016 con SP1

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAutocad2016SP1()
Public Shared Function IsAutocad2016SP1 As Boolean
public:
static bool IsAutocad2016SP1()
static member IsAutocad2016SP1 : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.OpenDoc

Metodo UtilOpenDoc
Metodo di apertura

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument OpenDoc(
    string fullFileName,
    bool readOnly
)
Public Shared Function OpenDoc (
    fullFileName As String,
    readOnly As Boolean
) As QsDocument
public:
static QsDocument^ OpenDoc(
    String^ fullFileName,
    bool readOnly
)
static member OpenDoc :
        fullFileName : string *
        readOnly : bool -> QsDocument

Parametri

fullFileName String
fullfilename
readOnly Boolean
sola lettura

Valore di ritorno

QsDocument
Vedi anche

Documentazione

Classe Util


Metodo Util.PartAttrMatchData

Metodo UtilPartAttrMatchData

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool PartAttrMatchData(
    PartInfo pInfo,
    DedData data
)
Public Shared Function PartAttrMatchData (
    pInfo As PartInfo,
    data As DedData
) As Boolean
public:
static bool PartAttrMatchData(
    PartInfo^ pInfo,
    DedData^ data
)
static member PartAttrMatchData :
        pInfo : PartInfo *
        data : DedData -> bool

Parametri

pInfo PartInfo
data DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.PrecompilaCodice

Metodo UtilPrecompilaCodice
Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void PrecompilaCodice(
    FindCodeCommand cmd
)
Public Shared Sub PrecompilaCodice (
    cmd As FindCodeCommand
)
public:
static void PrecompilaCodice(
    FindCodeCommand^ cmd
)
static member PrecompilaCodice :
        cmd : FindCodeCommand -> unit

Parametri

cmd FindCodeCommand
Comando di apri veloce.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadAllAttr

Metodo UtilReadAllAttr
Lista degli overload
Nome | Descrizione
ReadAllAttr(BomPartInfo, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllAttr(PartInfo, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllAttr(PartManager, DedAttrList) | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadAllAttr(BomPartInfo, DedAttrList)

Metodo UtilReadAllAttr(BomPartInfo, DedAttrList)
Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart ReadAllAttr(
    BomPartInfo prt,
    DedAttrList attrList
)
Public Shared Function ReadAllAttr (
    prt As BomPartInfo,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ ReadAllAttr(
    BomPartInfo^ prt,
    DedAttrList^ attrList
)
static member ReadAllAttr :
        prt : BomPartInfo *
        attrList : DedAttrList -> DedDataPart

Parametri

prt BomPartInfo
Parte dalla quale leggere le informazioni.
attrList DedAttrList
Lista degli attributi da leggere dalla parte.

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di ReadAllAttr


Metodo Util.ReadAllAttr(PartInfo, DedAttrList)

Metodo UtilReadAllAttr(PartInfo, DedAttrList)
Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart ReadAllAttr(
    PartInfo prt,
    DedAttrList attrList
)
Public Shared Function ReadAllAttr (
    prt As PartInfo,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ ReadAllAttr(
    PartInfo^ prt,
    DedAttrList^ attrList
)
static member ReadAllAttr :
        prt : PartInfo *
        attrList : DedAttrList -> DedDataPart

Parametri

prt PartInfo
Parte dalla quale leggere le informazioni.
attrList DedAttrList
Lista degli attributi da leggere dalla parte.

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di ReadAllAttr


Metodo Util.ReadAllAttr(PartManager, DedAttrList)

Metodo UtilReadAllAttr(PartManager, DedAttrList)
Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart ReadAllAttr(
    PartManager partManager,
    DedAttrList attrList
)
Public Shared Function ReadAllAttr (
    partManager As PartManager,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ ReadAllAttr(
    PartManager^ partManager,
    DedAttrList^ attrList
)
static member ReadAllAttr :
        partManager : PartManager *
        attrList : DedAttrList -> DedDataPart

Parametri

partManager PartManager
Parte dalla quale leggere le informazioni.
attrList DedAttrList
Lista degli attributi da leggere dalla parte.

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di ReadAllAttr


Metodo Util.ReadAllProperties

Metodo UtilReadAllProperties
Lista degli overload
Nome | Descrizione
ReadAllProperties(PartInfo) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAllProperties(PartManager) | Legge le proprietà presenti all'interno del file e li restituisce.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadAllProperties(PartInfo)

Metodo UtilReadAllProperties(PartInfo)
Legge le proprietà presenti all'interno del file e li restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    PartInfo prtInfo
)
Public Shared Function ReadAllProperties (
    prtInfo As PartInfo
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    PartInfo^ prtInfo
)
static member ReadAllProperties :
        prtInfo : PartInfo -> Dictionary<string, Object>

Parametri

prtInfo PartInfo

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties


Metodo Util.ReadAllProperties(PartManager)

Metodo UtilReadAllProperties(PartManager)
Legge le proprietà presenti all'interno del file e li restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    PartManager partManager
)
Public Shared Function ReadAllProperties (
    partManager As PartManager
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    PartManager^ partManager
)
static member ReadAllProperties :
        partManager : PartManager -> Dictionary<string, Object>

Parametri

partManager PartManager

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties


Metodo Util.ReadAnagr

Metodo UtilReadAnagr
Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadAnagr(
    string dedid,
    string dedrev
)
Public Shared Function ReadAnagr (
    dedid As String,
    dedrev As String
) As DedData
public:
static DedData^ ReadAnagr(
    String^ dedid,
    String^ dedrev
)
static member ReadAnagr :
        dedid : string *
        dedrev : string -> DedData

Parametri

dedid String
dedrev String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromBomPart

Metodo UtilReadDataFromBomPart
Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromBomPart(
    BomPartInfo prt,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromBomPart (
    prt As BomPartInfo,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromBomPart(
    BomPartInfo^ prt,
    bool checkDataMatching = true
)
static member ReadDataFromBomPart :
        prt : BomPartInfo *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

prt BomPartInfo
Parte dalla quale leggere le informazioni.
checkDataMatching Boolean (Optional)

Valore di ritorno

DedData
Restituisce l'anagrafica di appartenenza della parte oppure null se non è codificata.
Note
Questa funzione suppone che all'apertura siano stati inseriti nella parte Top i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromFile

Metodo UtilReadDataFromFile
Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromFile(
    PartManager partManager,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromFile (
    partManager As PartManager,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromFile(
    PartManager^ partManager,
    bool checkDataMatching = true
)
static member ReadDataFromFile :
        partManager : PartManager *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

partManager PartManager
PartManager del file dal quale leggere le informazioni.
checkDataMatching Boolean (Optional)

Valore di ritorno

DedData
Restituisce l'anagrafica di appartenenza del file oppure null se non è codificata.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromFileProperties

Metodo UtilReadDataFromFileProperties
Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromFileProperties(
    PartManager partManager
)
Public Shared Function ReadDataFromFileProperties (
    partManager As PartManager
) As DedData
public:
static DedData^ ReadDataFromFileProperties(
    PartManager^ partManager
)
static member ReadDataFromFileProperties :
        partManager : PartManager -> DedData

Parametri

partManager PartManager
PartManager del file dal quale leggere le informazioni.

Valore di ritorno

DedData
Restituisce l'anagrafica di appartenenza del file oppure null se non è codificata.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromPart

Metodo UtilReadDataFromPart
Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromPart(
    PartInfo prt,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromPart (
    prt As PartInfo,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromPart(
    PartInfo^ prt,
    bool checkDataMatching = true
)
static member ReadDataFromPart :
        prt : PartInfo *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

prt PartInfo
Parte dalla quale leggere le informazioni.
checkDataMatching Boolean (Optional)

Valore di ritorno

DedData
Restituisce l'anagrafica di appartenenza della parte oppure null se non è codificata.
Note
Questa funzione suppone che all'apertura siano stati inseriti nella parte Top i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromPartProperties

Metodo UtilReadDataFromPartProperties
Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromPartProperties(
    PartInfo prt
)
Public Shared Function ReadDataFromPartProperties (
    prt As PartInfo
) As DedData
public:
static DedData^ ReadDataFromPartProperties(
    PartInfo^ prt
)
static member ReadDataFromPartProperties :
        prt : PartInfo -> DedData

Parametri

prt PartInfo
Parte dalla quale leggere le informazioni.

Valore di ritorno

DedData
Restituisce l'anagrafica di appartenenza della parte oppure null se non è codificata.
Note
Attenzione! Questa funzione suppone che all'apertura siano stati inseriti nella parte Top i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Non ne verifica la coerenza!!
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadFileProperties

Metodo UtilReadFileProperties

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadFileProperties(
    PartManager partManager
)
Public Shared Function ReadFileProperties (
    partManager As PartManager
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadFileProperties(
    PartManager^ partManager
)
static member ReadFileProperties :
        partManager : PartManager -> Dictionary<string, Object>

Parametri

partManager PartManager

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe Util


Metodo Util.RefreshAttributes

Metodo UtilRefreshAttributes
Aggiorna il pannello attributi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void RefreshAttributes()
Public Shared Sub RefreshAttributes
public:
static void RefreshAttributes()
static member RefreshAttributes : unit -> unit
Vedi anche

Documentazione

Classe Util


Metodo Util.RelativizeXrefPath

Metodo UtilRelativizeXrefPath
Relativizza i riferimenti di 'filename' in base alla propria posizione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool RelativizeXrefPath(
    string filename,
    bool allLevels = false,
    bool onlyResolve = false
)
Public Shared Function RelativizeXrefPath (
    filename As String,
    Optional allLevels As Boolean = false,
    Optional onlyResolve As Boolean = false
) As Boolean
public:
static bool RelativizeXrefPath(
    String^ filename,
    bool allLevels = false,
    bool onlyResolve = false
)
static member RelativizeXrefPath :
        filename : string *
        ?allLevels : bool *
        ?onlyResolve : bool
(* Defaults:
        let _allLevels = defaultArg allLevels false
        let _onlyResolve = defaultArg onlyResolve false
*)
-> bool

Parametri

filename String
File di partenza
allLevels Boolean (Optional)
Indica se aprire tutte i livelli di dipendenze
onlyResolve Boolean (Optional)
Indica che è stato chiamato solo per far scattare la risoluzione per i riferimenti mancanti.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.ReloadReference

Metodo UtilReloadReference
Chiama un reload dell'xref passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void ReloadReference(
    string filename,
    Object refId
)
Public Shared Sub ReloadReference (
    filename As String,
    refId As Object
)
public:
static void ReloadReference(
    String^ filename,
    Object^ refId
)
static member ReloadReference :
        filename : string *
        refId : Object -> unit

Parametri

filename String
File principale.
refId Object
ID dell'xref da scaricare.
Vedi anche

Documentazione

Classe Util


Metodo Util.RelocateReferences

Metodo UtilRelocateReferences
Riloca le dipendenze dal file di partenza al file di destinazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void RelocateReferences(
    string startFileName,
    string fileName
)
Public Shared Sub RelocateReferences (
    startFileName As String,
    fileName As String
)
public:
static void RelocateReferences(
    String^ startFileName,
    String^ fileName
)
static member RelocateReferences :
        startFileName : string *
        fileName : string -> unit

Parametri

startFileName String
Nome file di partenza.
fileName String
Nome file di destinazione.
Vedi anche

Documentazione

Classe Util


Metodo Util.SelectXrefProgrammatically

Metodo UtilSelectXrefProgrammatically
Metodo per selezionare graficamente il riferimento passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SelectXrefProgrammatically(
    UtilDxfReferenceType refType,
    Object reference
)
Public Shared Sub SelectXrefProgrammatically (
    refType As UtilDxfReferenceType,
    reference As Object
)
public:
static void SelectXrefProgrammatically(
    UtilDxfReferenceType refType,
    Object^ reference
)
static member SelectXrefProgrammatically :
        refType : UtilDxfReferenceType *
        reference : Object -> unit

Parametri

refType UtilDxfReferenceType
Tipologia di riferimento da selezionare.
reference Object
Identificativo del riferimento, può essere il nome del riferimento (con i dwg) o il suo id.
Vedi anche

Documentazione

Classe Util


Metodo Util.SetCurrentLayout

Metodo UtilSetCurrentLayout
Setta il layout attivo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetCurrentLayout(
    string layout
)
Public Shared Sub SetCurrentLayout (
    layout As String
)
public:
static void SetCurrentLayout(
    String^ layout
)
static member SetCurrentLayout :
        layout : string -> unit

Parametri

layout String
layout da attivare
Vedi anche

Documentazione

Classe Util


Metodo Util.SetLastDataRowVer

Metodo UtilSetLastDataRowVer
Lista degli overload
Nome | Descrizione
SetLastDataRowVer(PartInfo, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.
SetLastDataRowVer(PartManager, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.SetLastDataRowVer(PartInfo, Guid)

Metodo UtilSetLastDataRowVer(PartInfo, Guid)
Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    PartInfo prtInfo,
    Guid rowver
)
Public Shared Sub SetLastDataRowVer (
    prtInfo As PartInfo,
    rowver As Guid
)
public:
static void SetLastDataRowVer(
    PartInfo^ prtInfo,
    Guid rowver
)
static member SetLastDataRowVer :
        prtInfo : PartInfo *
        rowver : Guid -> unit

Parametri

prtInfo PartInfo
PartInfo del disegno..
rowver Guid
Rowver da impostare nel documento.
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer


Metodo Util.SetLastDataRowVer(PartManager, Guid)

Metodo UtilSetLastDataRowVer(PartManager, Guid)
Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    PartManager partManager,
    Guid rowver
)
Public Shared Sub SetLastDataRowVer (
    partManager As PartManager,
    rowver As Guid
)
public:
static void SetLastDataRowVer(
    PartManager^ partManager,
    Guid rowver
)
static member SetLastDataRowVer :
        partManager : PartManager *
        rowver : Guid -> unit

Parametri

partManager PartManager
rowver Guid
Rowver da impostare nel documento.
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer


Metodo Util.UnloadReference

Metodo UtilUnloadReference
Chiama un unload dell'xref passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void UnloadReference(
    string filename,
    Object refId
)
Public Shared Sub UnloadReference (
    filename As String,
    refId As Object
)
public:
static void UnloadReference(
    String^ filename,
    Object^ refId
)
static member UnloadReference :
        filename : string *
        refId : Object -> unit

Parametri

filename String
File principale.
refId Object
ID dell'xref da scaricare.
Vedi anche

Documentazione

Classe Util


Metodo Util.UpdateAllDocumentReferences

Metodo UtilUpdateAllDocumentReferences
Aggiorna tutti i riferimenti che puntano al startRefName passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateAllDocumentReferences(
    string fileName,
    string startRefName,
    string destRefName,
    bool saveDocument = true
)
Public Shared Function UpdateAllDocumentReferences (
    fileName As String,
    startRefName As String,
    destRefName As String,
    Optional saveDocument As Boolean = true
) As Boolean
public:
static bool UpdateAllDocumentReferences(
    String^ fileName,
    String^ startRefName,
    String^ destRefName,
    bool saveDocument = true
)
static member UpdateAllDocumentReferences :
        fileName : string *
        startRefName : string *
        destRefName : string *
        ?saveDocument : bool
(* Defaults:
        let _saveDocument = defaultArg saveDocument true
*)
-> bool

Parametri

fileName String
File del quale aggiornare i riferimenti
startRefName String
Riferimento di partenza
destRefName String
Riferimento di destinazione
saveDocument Boolean (Optional)
Indica se salvare il documento al termine dell'operazione di aggiornamento riferimenti.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.UpdateDocumentReference

Metodo UtilUpdateDocumentReference
Aggiorna il riferimento identificato da refId impostandogli il percorso di destinazione destRefName.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateDocumentReference(
    string fileName,
    Object refId,
    string destRefName,
    bool saveDocument = true
)
Public Shared Function UpdateDocumentReference (
    fileName As String,
    refId As Object,
    destRefName As String,
    Optional saveDocument As Boolean = true
) As Boolean
public:
static bool UpdateDocumentReference(
    String^ fileName,
    Object^ refId,
    String^ destRefName,
    bool saveDocument = true
)
static member UpdateDocumentReference :
        fileName : string *
        refId : Object *
        destRefName : string *
        ?saveDocument : bool
(* Defaults:
        let _saveDocument = defaultArg saveDocument true
*)
-> bool

Parametri

fileName String
File del quale aggiornare i riferimenti
refId Object
Identificativo del riferimento da aggiornare.
destRefName String
Riferimento di destinazione
saveDocument Boolean (Optional)
Indica se salvare il documento al termine dell'operazione di aggiornamento riferimenti.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAllAttr

Metodo UtilWriteAllAttr
Lista degli overload
Nome | Descrizione
WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean) | Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.
WriteAllAttr(IDedData, Part, DedAttrList, String) | Scrive tutti gli attributi nel file leggendoli dall'anagrafica.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean)

Metodo UtilWriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean)
Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllAttr(
    IDedData data,
    PartInfo prt,
    DedAttrList attrList,
    bool ignoreEsclAttrList = false
)
Public Shared Sub WriteAllAttr (
    data As IDedData,
    prt As PartInfo,
    attrList As DedAttrList,
    Optional ignoreEsclAttrList As Boolean = false
)
public:
static void WriteAllAttr(
    IDedData^ data,
    PartInfo^ prt,
    DedAttrList^ attrList,
    bool ignoreEsclAttrList = false
)
static member WriteAllAttr :
        data : IDedData *
        prt : PartInfo *
        attrList : DedAttrList *
        ?ignoreEsclAttrList : bool
(* Defaults:
        let _ignoreEsclAttrList = defaultArg ignoreEsclAttrList false
*)
-> unit

Parametri

data IDedData
Anagrafica dalla quale prendere gli attributi.
prt PartInfo
Parte nella quale scrivere gli attributi.
attrList DedAttrList
Lista degli attributi da scrivere nella parte.
ignoreEsclAttrList Boolean (Optional)
Vedi anche

Documentazione

Classe Util
Overload di WriteAllAttr


Metodo Util.WriteAllAttr(IDedData, Part, DedAttrList, String)

Metodo UtilWriteAllAttr(IDedData, Part, DedAttrList, String)
Scrive tutti gli attributi nel file leggendoli dall'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllAttr(
    IDedData data,
    Part part,
    DedAttrList attrList,
    string fname
)
Public Shared Sub WriteAllAttr (
    data As IDedData,
    part As Part,
    attrList As DedAttrList,
    fname As String
)
public:
static void WriteAllAttr(
    IDedData^ data,
    Part^ part,
    DedAttrList^ attrList,
    String^ fname
)
static member WriteAllAttr :
        data : IDedData *
        part : Part *
        attrList : DedAttrList *
        fname : string -> unit

Parametri

data IDedData
Anagrafica dalla quale prendere gli attributi.
part Part
attrList DedAttrList
Lista degli attributi da scrivere nella parte.
fname String
Vedi anche

Documentazione

Classe Util
Overload di WriteAllAttr


Metodo Util.WriteAllProperties

Metodo UtilWriteAllProperties
Lista degli overload
Nome | Descrizione
WriteAllProperties(DedDoc, PartInfo) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, PartManager) | Scrive tutte le proprietà del documento nel Database
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAllProperties(DedDoc, PartInfo)

Metodo UtilWriteAllProperties(DedDoc, PartInfo)
Scrive tutte le proprietà del documento nel Database

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    PartInfo prtInfo
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    prtInfo As PartInfo
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    PartInfo^ prtInfo
)
static member WriteAllProperties :
        doc : DedDoc *
        prtInfo : PartInfo -> unit

Parametri

doc DedDoc
DedDoc dal quale leggere le propretà
prtInfo PartInfo
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties


Metodo Util.WriteAllProperties(DedDoc, PartManager)

Metodo UtilWriteAllProperties(DedDoc, PartManager)
Scrive tutte le proprietà del documento nel Database

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    PartManager partManager
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    partManager As PartManager
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    PartManager^ partManager
)
static member WriteAllProperties :
        doc : DedDoc *
        partManager : PartManager -> unit

Parametri

doc DedDoc
DedDoc dal quale leggere le propretà
partManager PartManager
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties


Metodo Util.WriteAttr

Metodo UtilWriteAttr
Lista degli overload
Nome | Descrizione
WriteAttr(Part, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteAttr(PartInfo, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAttr(Part, DedAttr, Object)

Metodo UtilWriteAttr(Part, DedAttr, Object)
Scrive il valore di un attributo, proveniente dal Database, in una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAttr(
    Part prt,
    DedAttr attr,
    Object val
)
Public Shared Sub WriteAttr (
    prt As Part,
    attr As DedAttr,
    val As Object
)
public:
static void WriteAttr(
    Part^ prt,
    DedAttr^ attr,
    Object^ val
)
static member WriteAttr :
        prt : Part *
        attr : DedAttr *
        val : Object -> unit

Parametri

prt Part
Parte nella quale scrivere il valore.
attr DedAttr
Attributo da compilare.
val Object
Valore presente nel Database.
Vedi anche

Documentazione

Classe Util
Overload di WriteAttr


Metodo Util.WriteAttr(PartInfo, DedAttr, Object)

Metodo UtilWriteAttr(PartInfo, DedAttr, Object)
Scrive il valore di un attributo, proveniente dal Database, in una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAttr(
    PartInfo prt,
    DedAttr attr,
    Object val
)
Public Shared Sub WriteAttr (
    prt As PartInfo,
    attr As DedAttr,
    val As Object
)
public:
static void WriteAttr(
    PartInfo^ prt,
    DedAttr^ attr,
    Object^ val
)
static member WriteAttr :
        prt : PartInfo *
        attr : DedAttr *
        val : Object -> unit

Parametri

prt PartInfo
Parte nella quale scrivere il valore.
attr DedAttr
Attributo da compilare.
val Object
Valore presente nel Database.
Vedi anche

Documentazione

Classe Util
Overload di WriteAttr


Metodo Util.WriteDataToFile

Metodo UtilWriteDataToFile
Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteDataToFile(
    DedData data,
    PartManager partManager
)
Public Shared Sub WriteDataToFile (
    data As DedData,
    partManager As PartManager
)
public:
static void WriteDataToFile(
    DedData^ data,
    PartManager^ partManager
)
static member WriteDataToFile :
        data : DedData *
        partManager : PartManager -> unit

Parametri

data DedData
Anagrafica da scrivere nella parte e proveniente dal Database.
partManager PartManager
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteDataToPart

Metodo UtilWriteDataToPart
Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteDataToPart(
    DedData data,
    PartInfo prt,
    bool enforceOperation = false
)
Public Shared Sub WriteDataToPart (
    data As DedData,
    prt As PartInfo,
    Optional enforceOperation As Boolean = false
)
public:
static void WriteDataToPart(
    DedData^ data,
    PartInfo^ prt,
    bool enforceOperation = false
)
static member WriteDataToPart :
        data : DedData *
        prt : PartInfo *
        ?enforceOperation : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
*)
-> unit

Parametri

data DedData
Anagrafica da scrivere nella parte e proveniente dal Database.
prt PartInfo
Parte nella quale aggiornare gli attributi.
enforceOperation Boolean (Optional)
Se attivo forzo l'operazione. Copia anche se il documento non corrisponde al deddata passato.
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteUserProperties

Metodo UtilWriteUserProperties
Scrive le proprietà presenti nel dizionario all'interno del file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void WriteUserProperties(
    string fullFileName,
    Dictionary<string, Object> attrs
)
Public Shared Sub WriteUserProperties (
    fullFileName As String,
    attrs As Dictionary(Of String, Object)
)
public:
static void WriteUserProperties(
    String^ fullFileName,
    Dictionary<String^, Object^>^ attrs
)
static member WriteUserProperties :
        fullFileName : string *
        attrs : Dictionary<string, Object> -> unit

Parametri

fullFileName String
File nel quale scrivere
attrs Dictionary String, Object
Vedi anche

Documentazione

Classe Util


Campi di Util

Il tipo Util espone i seguenti membri.

Campi
Nome | Descrizione
_dataTimeMin |
RILPDF | Ritorna il nome della configurazione da utilizzare per esportare il documento in PDF.
Torna su
Vedi anche

Documentazione

Classe Util


Campo Util._dataTimeMin

Campo Util_dataTimeMin

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static DateTime _dataTimeMin
Public Shared _dataTimeMin As DateTime
public:
static DateTime _dataTimeMin
static val mutable _dataTimeMin: DateTime

Valore del campo

DateTime
Vedi anche

Documentazione

Classe Util


Campo Util.RILPDF

Campo UtilRILPDF
Ritorna il nome della configurazione da utilizzare per esportare il documento in PDF.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string RILPDF = "RILPDF"
Public Const RILPDF As String = "RILPDF"
public:
literal String^ RILPDF = "RILPDF"
static val mutable RILPDF: string

Valore del campo

String
Vedi anche

Documentazione

Classe Util


Classe Util.CommandHelper

Classe UtilCommandHelper
Gerarchia di ereditarietà
SystemObject
DedNetAcadUtilCommandHelper

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public static class CommandHelper
Public NotInheritable Class CommandHelper
public ref class CommandHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CommandHelper = class end

Il tipo UtilCommandHelper espone i seguenti membri.

Campi
Nome | Descrizione
DoubleCancel |
EnterCmd |
EnterSendString |
EnterSendString2 |
PauseCmd |
SingleCancel |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Campi di CommandHelper

Il tipo UtilCommandHelper espone i seguenti membri.

Campi
Nome | Descrizione
DoubleCancel |
EnterCmd |
EnterSendString |
EnterSendString2 |
PauseCmd |
SingleCancel |
Torna su
Vedi anche

Documentazione

Classe UtilCommandHelper


Campo Util.CommandHelper.DoubleCancel

Campo UtilCommandHelperDoubleCancel

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string DoubleCancel = ""
Public Const DoubleCancel As String = ""
public:
literal String^ DoubleCancel = ""
static val mutable DoubleCancel: string

Valore del campo

String
Vedi anche

Documentazione

Classe UtilCommandHelper


Campo Util.CommandHelper.EnterCmd

Campo UtilCommandHelperEnterCmd

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string EnterCmd = ""
Public Const EnterCmd As String = ""
public:
literal String^ EnterCmd = ""
static val mutable EnterCmd: string

Valore del campo

String
Vedi anche

Documentazione

Classe UtilCommandHelper


Campo Util.CommandHelper.EnterSendString

Campo UtilCommandHelperEnterSendString

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string EnterSendString = ""
Public Const EnterSendString As String = ""
public:
literal String^ EnterSendString = ""
static val mutable EnterSendString: string

Valore del campo

String
Vedi anche

Documentazione

Classe UtilCommandHelper


Campo Util.CommandHelper.EnterSendString2

Campo UtilCommandHelperEnterSendString2

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string EnterSendString2 = ""
Public Const EnterSendString2 As String = ""
public:
literal String^ EnterSendString2 = ""
static val mutable EnterSendString2: string

Valore del campo

String
Vedi anche

Documentazione

Classe UtilCommandHelper


Campo Util.CommandHelper.PauseCmd

Campo UtilCommandHelperPauseCmd

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string PauseCmd = "\"
Public Const PauseCmd As String = "\"
public:
literal String^ PauseCmd = "\"
static val mutable PauseCmd: string

Valore del campo

String
Vedi anche

Documentazione

Classe UtilCommandHelper


Campo Util.CommandHelper.SingleCancel

Campo UtilCommandHelperSingleCancel

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public const string SingleCancel = ""
Public Const SingleCancel As String = ""
public:
literal String^ SingleCancel = ""
static val mutable SingleCancel: string

Valore del campo

String
Vedi anche

Documentazione

Classe UtilCommandHelper


Enumerazione Util.DxfReferenceType

Enumerazione UtilDxfReferenceType
Enum che contiene le varie tipologie di file da cercare tramite dxf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum DxfReferenceType
Public Enumeration DxfReferenceType
public enum class DxfReferenceType
type DxfReferenceType
Membri
Nome | Valore | Descrizione
INSERT | 0 | DWG.
PDFUNDERLAY | 1 | PDF.
DGNUNDERLAY | 2 | DGN.
DWFUNDERLAY | 3 | DWF.
ACAD_TABLE | 4 | TABELLE.
IMAGE | 5 | IMMAGINI.
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione Util.XrefPathType

Enumerazione UtilXrefPathType
Enum che descrive il tipo di percorso nell'inserimento di un xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum XrefPathType
Public Enumeration XrefPathType
public enum class XrefPathType
type XrefPathType
Membri
Nome | Valore | Descrizione
Unknown | 0 | Tipo di percorso sconosciuto.
Absolute | 1 | Percorso assoluto.
Relative | 2 | Percorso relativo.
FileName | 3 | Solo il nome file.
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe XrefDescriptor
Classe che descrive le informazioni di un riferimento in lettura.
Gerarchia di ereditarietà
SystemObject
DedNetAcadXrefDescriptor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class XrefDescriptor
Public Class XrefDescriptor
public ref class XrefDescriptor
type XrefDescriptor = class end

Il tipo XrefDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | XrefDescriptor | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName | Nome file del riferimento.
Proprietà pubblica | Id | Identificaivo del riferimento.
Proprietà pubblica | RefName | Nome del riferimento.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore XrefDescriptor
Costruttore.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public XrefDescriptor(
    Object id,
    string fullFileName,
    string refName
)
Public Sub New (
    id As Object,
    fullFileName As String,
    refName As String
)
public:
XrefDescriptor(
    Object^ id,
    String^ fullFileName,
    String^ refName
)
new :
        id : Object *
        fullFileName : string *
        refName : string -> XrefDescriptor

Parametri

id Object
fullFileName String
refName String
Vedi anche

Documentazione

Classe XrefDescriptor


Proprietà di XrefDescriptor

Il tipo XrefDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName | Nome file del riferimento.
Proprietà pubblica | Id | Identificaivo del riferimento.
Proprietà pubblica | RefName | Nome del riferimento.
Torna su
Vedi anche

Documentazione

Classe XrefDescriptor


Proprietà XrefDescriptor.FullFileName

Proprietà XrefDescriptorFullFileName
Nome file del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe XrefDescriptor


Proprietà XrefDescriptor.Id

Proprietà XrefDescriptorId
Identificaivo del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Id { get; set; }
Public Property Id As Object
    Get
    Set
public:
property Object^ Id {
    Object^ get ();
    void set (Object^ value);
}
member Id : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe XrefDescriptor


Proprietà XrefDescriptor.RefName

Proprietà XrefDescriptorRefName
Nome del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RefName { get; set; }
Public Property RefName As String
    Get
    Set
public:
property String^ RefName {
    String^ get ();
    void set (String^ value);
}
member RefName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe XrefDescriptor


DedNetAcad.Controls Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedXrefControl | Controllo che permette di visualizzare in una struttura ad albero i riferimenti esterni del documento attivo.
Classe pubblica | DedXrefControlFileStateElementNodeWrapper | Tipo wrapper per la gestione del binding dei dati
Classe pubblica | FindNodesOperation | Operazione custom di Find dei nodi.


Classe DedXrefControl
Controllo che permette di visualizzare in una struttura ad albero i riferimenti esterni del documento attivo.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNetAcad.ControlsDedXrefControl

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedXrefControl : XtraUserControl
Public Class DedXrefControl
    Inherits XtraUserControl
public ref class DedXrefControl : public XtraUserControl
type DedXrefControl =
    class
        inherit XtraUserControl
    end

Il tipo DedXrefControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedXrefControl | Costruttore del form ovvero della finestra dockabile.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsFrozen | Indica se il controllo è in fase di "freeze".
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectionImageSize | Restituisce o imposta le dimensioni delle immagini di Selezione.
Proprietà pubblica | SelectionTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Selezione.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | StateImageSize | Restituisce o imposta le dimensioni delle immagini di Stato.
Proprietà pubblica | StateTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Stato.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddSelectionImage | Aggiunge una immagine alla lista delle immagini di Selezione.
Metodo pubblico | AddStateImage | Aggiunge una immagine alla lista delle immagini di Stato.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | ClearSelection | Pulisce la selezione dell'albero
Metodo pubblico | ContainsSelectionImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di selezione.
Metodo pubblico | ContainsStateImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di stato.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | Freeze | Chiama un freeze del dialogo.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | Highlight | Evidenzia l'elemento nell'albero
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnVirtualNodeGetValues | Evento per l'aggiunta operazioni sull'aggiornamento del singolo nodo
Metodo protetto | OnVisibleChanged | Su ritorno a visibilità, aggiorno la visualizzazione. (Sovrascrive ScrollableControlOnVisibleChanged(EventArgs))
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshTree | Aggiorna l'albero in modo che siano ricreati i nodi, dal documento attivo (in editazione) fino all'ultimo.
Metodo pubblico | ReloadRootNodeState | Chiama un reload delle informazioni del nodo principale.
Metodo pubblico | ReloadStateInformations | Aggiorna le informazioni di stato del nodo selezionato e di tutti i figli
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | Svuota | Svuota l'albero.
Metodo pubblico | Thaw | Toglie il dialogo dallo stato di "freeze".
Metodo pubblico | Update | Aggiorna il nodo e tutti i suoi figli (se presente).
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Controls


Costruttore DedXrefControl
Costruttore del form ovvero della finestra dockabile.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedXrefControl()
Public Sub New
public:
DedXrefControl()
new : unit -> DedXrefControl
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Proprietà di DedXrefControl

Il tipo DedXrefControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsFrozen | Indica se il controllo è in fase di "freeze".
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectionImageSize | Restituisce o imposta le dimensioni delle immagini di Selezione.
Proprietà pubblica | SelectionTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Selezione.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | StateImageSize | Restituisce o imposta le dimensioni delle immagini di Stato.
Proprietà pubblica | StateTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Stato.
Torna su
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.IsFrozen

Proprietà DedXrefControlIsFrozen
Indica se il controllo è in fase di "freeze".

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFrozen { get; }
Public ReadOnly Property IsFrozen As Boolean
    Get
public:
property bool IsFrozen {
    bool get ();
}
member IsFrozen : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.SelectionImageSize

Proprietà DedXrefControlSelectionImageSize
Restituisce o imposta le dimensioni delle immagini di Selezione.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Size SelectionImageSize { get; set; }
Public Property SelectionImageSize As Size
    Get
    Set
public:
property Size SelectionImageSize {
    Size get ();
    void set (Size value);
}
member SelectionImageSize : Size with get, set

Valore della proprietà

Size
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.SelectionTrasparentColor

Proprietà DedXrefControlSelectionTrasparentColor
Restituisce o imposta il colore di trasparenza delle immagini di Selezione.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Color SelectionTrasparentColor { get; set; }
Public Property SelectionTrasparentColor As Color
    Get
    Set
public:
property Color SelectionTrasparentColor {
    Color get ();
    void set (Color value);
}
member SelectionTrasparentColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.StateImageSize

Proprietà DedXrefControlStateImageSize
Restituisce o imposta le dimensioni delle immagini di Stato.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Size StateImageSize { get; set; }
Public Property StateImageSize As Size
    Get
    Set
public:
property Size StateImageSize {
    Size get ();
    void set (Size value);
}
member StateImageSize : Size with get, set

Valore della proprietà

Size
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.StateTrasparentColor

Proprietà DedXrefControlStateTrasparentColor
Restituisce o imposta il colore di trasparenza delle immagini di Stato.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Color StateTrasparentColor { get; set; }
Public Property StateTrasparentColor As Color
    Get
    Set
public:
property Color StateTrasparentColor {
    Color get ();
    void set (Color value);
}
member StateTrasparentColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodi di DedXrefControl

Il tipo DedXrefControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddSelectionImage | Aggiunge una immagine alla lista delle immagini di Selezione.
Metodo pubblico | AddStateImage | Aggiunge una immagine alla lista delle immagini di Stato.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | ClearSelection | Pulisce la selezione dell'albero
Metodo pubblico | ContainsSelectionImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di selezione.
Metodo pubblico | ContainsStateImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di stato.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | Freeze | Chiama un freeze del dialogo.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | Highlight | Evidenzia l'elemento nell'albero
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnVirtualNodeGetValues | Evento per l'aggiunta operazioni sull'aggiornamento del singolo nodo
Metodo protetto | OnVisibleChanged | Su ritorno a visibilità, aggiorno la visualizzazione. (Sovrascrive ScrollableControlOnVisibleChanged(EventArgs))
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshTree | Aggiorna l'albero in modo che siano ricreati i nodi, dal documento attivo (in editazione) fino all'ultimo.
Metodo pubblico | ReloadRootNodeState | Chiama un reload delle informazioni del nodo principale.
Metodo pubblico | ReloadStateInformations | Aggiorna le informazioni di stato del nodo selezionato e di tutti i figli
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | Svuota | Svuota l'albero.
Metodo pubblico | Thaw | Toglie il dialogo dallo stato di "freeze".
Metodo pubblico | Update | Aggiorna il nodo e tutti i suoi figli (se presente).
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.AddSelectionImage

Metodo DedXrefControlAddSelectionImage
Aggiunge una immagine alla lista delle immagini di Selezione.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddSelectionImage(
    Image img,
    string name
)
Public Sub AddSelectionImage (
    img As Image,
    name As String
)
public:
void AddSelectionImage(
    Image^ img,
    String^ name
)
member AddSelectionImage :
        img : Image *
        name : string -> unit

Parametri

img Image
Immagine da aggiungere.
name String
Nome dell'immagine.
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.AddStateImage

Metodo DedXrefControlAddStateImage
Aggiunge una immagine alla lista delle immagini di Stato.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddStateImage(
    Image img,
    string name
)
Public Sub AddStateImage (
    img As Image,
    name As String
)
public:
void AddStateImage(
    Image^ img,
    String^ name
)
member AddStateImage :
        img : Image *
        name : string -> unit

Parametri

img Image
Immagine da aggiungere.
name String
Nome dell'immagine.
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.ClearSelection

Metodo DedXrefControlClearSelection
Pulisce la selezione dell'albero

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearSelection()
Public Sub ClearSelection
public:
void ClearSelection()
member ClearSelection : unit -> unit
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.ContainsSelectionImage

Metodo DedXrefControlContainsSelectionImage
Verifica l'esistenza di una perticolare chiave nella lista delle immagini di selezione.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsSelectionImage(
    string name
)
Public Function ContainsSelectionImage (
    name As String
) As Boolean
public:
bool ContainsSelectionImage(
    String^ name
)
member ContainsSelectionImage :
        name : string -> bool

Parametri

name String
Nome dell'immagine da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.ContainsStateImage

Metodo DedXrefControlContainsStateImage
Verifica l'esistenza di una perticolare chiave nella lista delle immagini di stato.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsStateImage(
    string name
)
Public Function ContainsStateImage (
    name As String
) As Boolean
public:
bool ContainsStateImage(
    String^ name
)
member ContainsStateImage :
        name : string -> bool

Parametri

name String
Nome dell'immagine da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.Dispose

Metodo DedXrefControlDispose
Clean up any resources being used.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.Freeze

Metodo DedXrefControlFreeze
Chiama un freeze del dialogo.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Freeze()
Public Sub Freeze
public:
void Freeze()
member Freeze : unit -> unit
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.Highlight

Metodo DedXrefControlHighlight
Evidenzia l'elemento nell'albero

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Highlight(
    FileStateElementList fsePath
)
Public Sub Highlight (
    fsePath As FileStateElementList
)
public:
void Highlight(
    FileStateElementList^ fsePath
)
member Highlight :
        fsePath : FileStateElementList -> unit

Parametri

fsePath FileStateElementList
Path degli elementi che identificano il nodo
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.OnVirtualNodeGetValues

Metodo DedXrefControlOnVirtualNodeGetValues
Evento per l'aggiunta operazioni sull'aggiornamento del singolo nodo

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnVirtualNodeGetValues(
    Object node
)
Protected Friend Sub OnVirtualNodeGetValues (
    node As Object
)
protected public:
void OnVirtualNodeGetValues(
    Object^ node
)
member OnVirtualNodeGetValues :
        node : Object -> unit

Parametri

node Object
Nodo di riferimento
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.OnVisibleChanged

Metodo DedXrefControlOnVisibleChanged
Su ritorno a visibilità, aggiorno la visualizzazione.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.RefreshTree

Metodo DedXrefControlRefreshTree
Aggiorna l'albero in modo che siano ricreati i nodi, dal documento attivo (in editazione) fino all'ultimo.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshTree(
    bool restoreStatus
)
Public Sub RefreshTree (
    restoreStatus As Boolean
)
public:
void RefreshTree(
    bool restoreStatus
)
member RefreshTree :
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.ReloadRootNodeState

Metodo DedXrefControlReloadRootNodeState
Chiama un reload delle informazioni del nodo principale.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadRootNodeState(
    bool refreshChildren
)
Public Sub ReloadRootNodeState (
    refreshChildren As Boolean
)
public:
void ReloadRootNodeState(
    bool refreshChildren
)
member ReloadRootNodeState :
        refreshChildren : bool -> unit

Parametri

refreshChildren Boolean
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.ReloadStateInformations

Metodo DedXrefControlReloadStateInformations
Aggiorna le informazioni di stato del nodo selezionato e di tutti i figli

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadStateInformations(
    bool refreshChildren,
    bool reloadMoved
)
Public Sub ReloadStateInformations (
    refreshChildren As Boolean,
    reloadMoved As Boolean
)
public:
void ReloadStateInformations(
    bool refreshChildren,
    bool reloadMoved
)
member ReloadStateInformations :
        refreshChildren : bool *
        reloadMoved : bool -> unit

Parametri

refreshChildren Boolean
reloadMoved Boolean
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.RestoreLayoutFromRegistry

Metodo DedXrefControlRestoreLayoutFromRegistry
Ripristina il layout del controllo leggendolo dal registro di sistema.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey String
Path della chiave da cui leggere il layout.
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.SaveLayoutToRegistry

Metodo DedXrefControlSaveLayoutToRegistry
Salva il layout del controllo nel registro di sistema.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey String
Path della chiave dove salvare il layout.
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.Svuota

Metodo DedXrefControlSvuota
Svuota l'albero.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Svuota()
Public Sub Svuota
public:
void Svuota()
member Svuota : unit -> unit
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.Thaw

Metodo DedXrefControlThaw
Toglie il dialogo dallo stato di "freeze".

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Thaw()
Public Sub Thaw
public:
void Thaw()
member Thaw : unit -> unit
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Metodo DedXrefControl.Update

Metodo DedXrefControlUpdate
Aggiorna il nodo e tutti i suoi figli (se presente).

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    FileStateElement el
)
Public Sub Update (
    el As FileStateElement
)
public:
void Update(
    FileStateElement^ el
)
member Update :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Elemento da aggiornare.
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Eventi di DedXrefControl

Il tipo DedXrefControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedXrefControl
Namespace DedNetAcad.Controls


Classe DedXrefControl.FileStateElementNodeWrapper

Classe DedXrefControlFileStateElementNodeWrapper
Tipo wrapper per la gestione del binding dei dati
Gerarchia di ereditarietà
SystemObject
DedNetAcad.ControlsDedXrefControlFileStateElementNodeWrapper

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElementNodeWrapper
Public Class FileStateElementNodeWrapper
public ref class FileStateElementNodeWrapper
type FileStateElementNodeWrapper = class end

Il tipo DedXrefControlFileStateElementNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedXrefControlFileStateElementNodeWrapper |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Element | Elemento legato al nodo.
Proprietà pubblica | Expanded | Indica se il nodo è espanso.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Controls


Costruttore DedXrefControl.FileStateElementNodeWrapper

Costruttore DedXrefControlFileStateElementNodeWrapper

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementNodeWrapper()
Public Sub New
public:
FileStateElementNodeWrapper()
new : unit -> FileStateElementNodeWrapper
Vedi anche

Documentazione

Classe DedXrefControlFileStateElementNodeWrapper
Namespace DedNetAcad.Controls


Proprietà di FileStateElementNodeWrapper

Il tipo DedXrefControlFileStateElementNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Element | Elemento legato al nodo.
Proprietà pubblica | Expanded | Indica se il nodo è espanso.
Torna su
Vedi anche

Documentazione

Classe DedXrefControlFileStateElementNodeWrapper
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.FileStateElementNodeWrapper.Element

Proprietà DedXrefControlFileStateElementNodeWrapperElement
Elemento legato al nodo.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement Element { get; set; }
Public Property Element As FileStateElement
    Get
    Set
public:
property FileStateElement^ Element {
    FileStateElement^ get ();
    void set (FileStateElement^ value);
}
member Element : FileStateElement with get, set

Valore della proprietà

FileStateElement
Vedi anche

Documentazione

Classe DedXrefControlFileStateElementNodeWrapper
Namespace DedNetAcad.Controls


Proprietà DedXrefControl.FileStateElementNodeWrapper.Expanded

Proprietà DedXrefControlFileStateElementNodeWrapperExpanded
Indica se il nodo è espanso.

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool Expanded { get; set; }
Public Property Expanded As Boolean
    Get
    Set
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}
member Expanded : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedXrefControlFileStateElementNodeWrapper
Namespace DedNetAcad.Controls


Classe FindNodesOperation
Operazione custom di Find dei nodi.
Gerarchia di ereditarietà
SystemObject
TreeListOperation
DedNetAcad.ControlsFindNodesOperation

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FindNodesOperation : TreeListOperation
Public Class FindNodesOperation
    Inherits TreeListOperation
public ref class FindNodesOperation : public TreeListOperation
type FindNodesOperation =
    class
        inherit TreeListOperation
    end

Il tipo FindNodesOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FindNodesOperation |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FoundNodes |
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Controls


Costruttore FindNodesOperation

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public FindNodesOperation(
    TreeListColumn column,
    Object value
)
Public Sub New (
    column As TreeListColumn,
    value As Object
)
public:
FindNodesOperation(
    TreeListColumn^ column,
    Object^ value
)
new :
        column : TreeListColumn *
        value : Object -> FindNodesOperation

Parametri

column TreeListColumn
value Object
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetAcad.Controls


Proprietà di FindNodesOperation

Il tipo FindNodesOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FoundNodes |
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetAcad.Controls


Proprietà FindNodesOperation.FoundNodes

Proprietà FindNodesOperationFoundNodes

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public ArrayList FoundNodes { get; }
Public ReadOnly Property FoundNodes As ArrayList
    Get
public:
property ArrayList^ FoundNodes {
    ArrayList^ get ();
}
member FoundNodes : ArrayList with get

Valore della proprietà

ArrayList
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetAcad.Controls


Metodi di FindNodesOperation

Il tipo FindNodesOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetAcad.Controls


Metodo FindNodesOperation.Execute

Metodo FindNodesOperationExecute

Namespace: DedNetAcad.Controls
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Execute(
    TreeListNode node
)
Public Overrides Sub Execute (
    node As TreeListNode
)
public:
virtual void Execute(
    TreeListNode^ node
) override
abstract Execute :
        node : TreeListNode -> unit
override Execute :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetAcad.Controls


DedNetAcad.Forms Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedAcadPackAndGoExportForm |
Classe pubblica | DedAcadPackAndGoImportForm |
Classe pubblica | DedXrefDialog | Dialogo che gestisce il pannello delle dipendenze degli xref per AutoCAD/BricsCAD.
Classe pubblica | DocumentsForm |
Classe pubblica | MultipleStateOperation |
Classe pubblica | MultipleStateOperationPartInfoDoc |
Classe pubblica | ResolveFileForm |
Delegate
 | Delegate | Descrizione
Delegate pubblico | MultipleStateOperationOperationDelagateHandler |


Classe DedAcadPackAndGoExportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsDedAcadPackAndGoExportForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadPackAndGoExportForm : BaseForm
Public Class DedAcadPackAndGoExportForm
    Inherits BaseForm
public ref class DedAcadPackAndGoExportForm : public BaseForm
type DedAcadPackAndGoExportForm =
    class
        inherit BaseForm
    end

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Proprietà di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Metodi di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Metodo DedAcadPackAndGoExportForm.Dispose

Metodo DedAcadPackAndGoExportFormDispose
Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Eventi di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Campi di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Classe DedAcadPackAndGoImportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsDedAcadPackAndGoImportForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadPackAndGoImportForm : BaseForm
Public Class DedAcadPackAndGoImportForm
    Inherits BaseForm
public ref class DedAcadPackAndGoImportForm : public BaseForm
type DedAcadPackAndGoImportForm =
    class
        inherit BaseForm
    end

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAcadPackAndGoImportForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo pubblico | DeSerializeXml | Deserializza il file .xml
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore DedAcadPackAndGoImportForm
Costruttore unico.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedAcadPackAndGoImportForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedAcadPackAndGoImportForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedAcadPackAndGoImportForm

Parametri

app DedNetApplication
Applicazione
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Proprietà di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Metodi di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo pubblico | DeSerializeXml | Deserializza il file .xml
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Metodo DedAcadPackAndGoImportForm.DeSerializeXml

Metodo DedAcadPackAndGoImportFormDeSerializeXml
Deserializza il file .xml

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor DeSerializeXml(
    string fn
)
Public Function DeSerializeXml (
    fn As String
) As PackAndGoStructureDescriptor
public:
PackAndGoStructureDescriptor^ DeSerializeXml(
    String^ fn
)
member DeSerializeXml :
        fn : string -> PackAndGoStructureDescriptor

Parametri

fn String
File da deserializzare.

Valore di ritorno

PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Metodo DedAcadPackAndGoImportForm.Dispose

Metodo DedAcadPackAndGoImportFormDispose
Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Eventi di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Campi di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Classe DedXrefDialog
Dialogo che gestisce il pannello delle dipendenze degli xref per AutoCAD/BricsCAD.
Gerarchia di ereditarietà
SystemObject
DedNetAcad.FormsDedXrefDialog

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DedXrefDialog : IDisposable
Public Class DedXrefDialog
    Implements IDisposable
public ref class DedXrefDialog : IDisposable
type DedXrefDialog =
    class
        interface IDisposable
    end

Il tipo DedXrefDialog espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedXrefDialog | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | XrefControl | Espone il controllo delle dipendenze degli xref.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Dispose | Libera le risorse.
Metodo pubblico | Freeze | Congela il controllo evitando che avvengano refresh grafici sullo stesso.
Metodo pubblico | Hide | Nasconde il pannello.
Metodo pubblico | IsVisible | Ritorna True se il pannello è correntemente visibile, altrimenti False.
Metodo pubblico | Refresh | Chiama un refresh sull'albero delle dipendenze (se il pannello è visibile).
Metodo pubblico | ReloadRootNodeState | Ricarica le informazioni del nodo di root ed eventualmente dei figli (se il pannello è visibile).
Metodo pubblico | Show | Rende visibile il pannello e ne chiama un refresh se questo era nascosto.
Metodo pubblico | Thaw | Scongela il controllo rendendo nuovamente possibile aggiornarlo graficamente.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore DedXrefDialog
Costruttore unico.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedXrefDialog()
Public Sub New
public:
DedXrefDialog()
new : unit -> DedXrefDialog
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Proprietà di DedXrefDialog

Il tipo DedXrefDialog espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | XrefControl | Espone il controllo delle dipendenze degli xref.
Torna su
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Proprietà DedXrefDialog.XrefControl

Proprietà DedXrefDialogXrefControl
Espone il controllo delle dipendenze degli xref.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedXrefControl XrefControl { get; }
Public ReadOnly Property XrefControl As DedXrefControl
    Get
public:
property DedXrefControl^ XrefControl {
    DedXrefControl^ get ();
}
member XrefControl : DedXrefControl with get

Valore della proprietà

DedXrefControl
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodi di DedXrefDialog

Il tipo DedXrefDialog espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Dispose | Libera le risorse.
Metodo pubblico | Freeze | Congela il controllo evitando che avvengano refresh grafici sullo stesso.
Metodo pubblico | Hide | Nasconde il pannello.
Metodo pubblico | IsVisible | Ritorna True se il pannello è correntemente visibile, altrimenti False.
Metodo pubblico | Refresh | Chiama un refresh sull'albero delle dipendenze (se il pannello è visibile).
Metodo pubblico | ReloadRootNodeState | Ricarica le informazioni del nodo di root ed eventualmente dei figli (se il pannello è visibile).
Metodo pubblico | Show | Rende visibile il pannello e ne chiama un refresh se questo era nascosto.
Metodo pubblico | Thaw | Scongela il controllo rendendo nuovamente possibile aggiornarlo graficamente.
Torna su
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.Dispose

Metodo DedXrefDialogDispose
Libera le risorse.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.Freeze

Metodo DedXrefDialogFreeze
Congela il controllo evitando che avvengano refresh grafici sullo stesso.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Freeze()
Public Sub Freeze
public:
void Freeze()
member Freeze : unit -> unit
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.Hide

Metodo DedXrefDialogHide
Nasconde il pannello.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Hide()
Public Sub Hide
public:
void Hide()
member Hide : unit -> unit
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.IsVisible

Metodo DedXrefDialogIsVisible
Ritorna True se il pannello è correntemente visibile, altrimenti False.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsVisible()
Public Function IsVisible As Boolean
public:
bool IsVisible()
member IsVisible : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.Refresh

Metodo DedXrefDialogRefresh
Chiama un refresh sull'albero delle dipendenze (se il pannello è visibile).

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh(
    bool restoreStatus = true
)
Public Sub Refresh (
    Optional restoreStatus As Boolean = true
)
public:
void Refresh(
    bool restoreStatus = true
)
member Refresh :
        ?restoreStatus : bool
(* Defaults:
        let _restoreStatus = defaultArg restoreStatus true
*)
-> unit

Parametri

restoreStatus Boolean (Optional)
Indica se ripristinare lo stato di espansione dei nodi precedente.
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.ReloadRootNodeState

Metodo DedXrefDialogReloadRootNodeState
Ricarica le informazioni del nodo di root ed eventualmente dei figli (se il pannello è visibile).

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadRootNodeState(
    bool refreshChildren
)
Public Sub ReloadRootNodeState (
    refreshChildren As Boolean
)
public:
void ReloadRootNodeState(
    bool refreshChildren
)
member ReloadRootNodeState :
        refreshChildren : bool -> unit

Parametri

refreshChildren Boolean
Indica se ricaricare anche i nodi figli.
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.Show

Metodo DedXrefDialogShow
Rende visibile il pannello e ne chiama un refresh se questo era nascosto.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Show()
Public Sub Show
public:
void Show()
member Show : unit -> unit
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Metodo DedXrefDialog.Thaw

Metodo DedXrefDialogThaw
Scongela il controllo rendendo nuovamente possibile aggiornarlo graficamente.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Thaw()
Public Sub Thaw
public:
void Thaw()
member Thaw : unit -> unit
Vedi anche

Documentazione

Classe DedXrefDialog
Namespace DedNetAcad.Forms


Classe DocumentsForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsDocumentsForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentsForm : BaseForm
Public Class DocumentsForm
    Inherits BaseForm
public ref class DocumentsForm : public BaseForm
type DocumentsForm =
    class
        inherit BaseForm
    end

Il tipo DocumentsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentsForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | ctrDoc |
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore DocumentsForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentsForm(
    DedNetApplication _app
)
Public Sub New (
    _app As DedNetApplication
)
public:
DocumentsForm(
    DedNetApplication^ _app
)
new :
        _app : DedNetApplication -> DocumentsForm

Parametri

_app DedNetApplication
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Proprietà di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Metodi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Metodo DocumentsForm.Dispose

Metodo DocumentsFormDispose
Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Eventi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Campi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | ctrDoc |
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Campo DocumentsForm.ctrDoc

Campo DocumentsFormctrDoc

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocControl ctrDoc
Public ctrDoc As DedDocControl
public:
DedDocControl^ ctrDoc
val mutable ctrDoc: DedDocControl

Valore del campo

DedDocControl
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Classe MultipleStateOperation
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsMultipleStateOperation

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class MultipleStateOperation : BaseForm
Public Class MultipleStateOperation
    Inherits BaseForm
public ref class MultipleStateOperation : public BaseForm
type MultipleStateOperation =
    class
        inherit BaseForm
    end

Il tipo MultipleStateOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateOperation | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | ChangeStateNote | Note di cambio stato
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OperationDelegate | Proprietà per impostare il delegate dell'operazione sul singolo oggetto
Proprietà pubblica | Res | Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore MultipleStateOperation
Costruttore

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperation(
    DedNetApplication app,
    DedState operation,
    List<MultipleStateOperationPartInfoDoc> dl,
    Bitmap cmdImg
)
Public Sub New (
    app As DedNetApplication,
    operation As DedState,
    dl As List(Of MultipleStateOperationPartInfoDoc),
    cmdImg As Bitmap
)
public:
MultipleStateOperation(
    DedNetApplication^ app,
    DedState^ operation,
    List<MultipleStateOperationPartInfoDoc^>^ dl,
    Bitmap^ cmdImg
)
new :
        app : DedNetApplication *
        operation : DedState *
        dl : List<MultipleStateOperationPartInfoDoc> *
        cmdImg : Bitmap -> MultipleStateOperation

Parametri

app DedNetApplication
Applicazione DedNet
operation DedState
Tipo di operazione da applicare
dl List MultipleStateOperationPartInfoDoc
Descrittore Struttura del Documento di Testa
cmdImg Bitmap
Icona del comando. Dipende dal tipo di operazione da attuare.
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | ChangeStateNote | Note di cambio stato
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OperationDelegate | Proprietà per impostare il delegate dell'operazione sul singolo oggetto
Proprietà pubblica | Res | Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.ChangeStateNote

Proprietà MultipleStateOperationChangeStateNote
Note di cambio stato

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ChangeStateNote { get; set; }
Public Property ChangeStateNote As String
    Get
    Set
public:
property String^ ChangeStateNote {
    String^ get ();
    void set (String^ value);
}
member ChangeStateNote : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.OperationDelegate

Proprietà MultipleStateOperationOperationDelegate
Proprietà per impostare il delegate dell'operazione sul singolo oggetto

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperationOperationDelagateHandler OperationDelegate { get; set; }
Public Property OperationDelegate As MultipleStateOperationOperationDelagateHandler
    Get
    Set
public:
property MultipleStateOperationOperationDelagateHandler^ OperationDelegate {
    MultipleStateOperationOperationDelagateHandler^ get ();
    void set (MultipleStateOperationOperationDelagateHandler^ value);
}
member OperationDelegate : MultipleStateOperationOperationDelagateHandler with get, set

Valore della proprietà

MultipleStateOperationOperationDelagateHandler
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.Res

Proprietà MultipleStateOperationRes
Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult Res { get; }
Public ReadOnly Property Res As DedCmdResult
    Get
public:
property DedCmdResult Res {
    DedCmdResult get ();
}
member Res : DedCmdResult with get

Valore della proprietà

DedCmdResult
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodo MultipleStateOperation.Dispose

Metodo MultipleStateOperationDispose
Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodo MultipleStateOperation.LoadRegistrySettings

Metodo MultipleStateOperationLoadRegistrySettings
Carica dal registro lo stato di visualizzazione livelli dell'albero

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings()
Public Sub LoadRegistrySettings
public:
void LoadRegistrySettings()
member LoadRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodo MultipleStateOperation.SaveRegistrySettings

Metodo MultipleStateOperationSaveRegistrySettings
Salva nel registro lo stato di visualizzazione livelli dell'albero.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Eventi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Campi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Delegate MultipleStateOperation.OperationDelagateHandler

Delegate MultipleStateOperationOperationDelagateHandler

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public delegate DedCmdResult OperationDelagateHandler(
    DedState targetState,
    string changeNote,
    MultipleStateOperationPartInfoDoc docInfo,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Delegate Function OperationDelagateHandler (
    targetState As DedState,
    changeNote As String,
    docInfo As MultipleStateOperationPartInfoDoc,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public delegate DedCmdResult OperationDelagateHandler(
    DedState^ targetState,
    String^ changeNote,
    MultipleStateOperationPartInfoDoc^ docInfo,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
type OperationDelagateHandler =
    delegate of
        targetState : DedState *
        changeNote : string *
        docInfo : MultipleStateOperationPartInfoDoc *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState DedState
changeNote String
docInfo MultipleStateOperationPartInfoDoc
multiplo Boolean
message String
pubExtList List Exception

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Classe MultipleStateOperation.PartInfoDoc

Classe MultipleStateOperationPartInfoDoc
Gerarchia di ereditarietà
SystemObject
DedNetAcad.FormsMultipleStateOperationPartInfoDoc

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PartInfoDoc
Public Class PartInfoDoc
public ref class PartInfoDoc
type PartInfoDoc = class end

Il tipo MultipleStateOperationPartInfoDoc espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateOperationPartInfoDoc |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Lev |
Proprietà pubblica | PrtInfo |
Proprietà pubblica | UserData |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore MultipleStateOperation.PartInfoDoc

Costruttore MultipleStateOperationPartInfoDoc

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfoDoc(
    PartInfo prt,
    DedDoc doc
)
Public Sub New (
    prt As PartInfo,
    doc As DedDoc
)
public:
PartInfoDoc(
    PartInfo^ prt,
    DedDoc^ doc
)
new :
        prt : PartInfo *
        doc : DedDoc -> PartInfoDoc

Parametri

prt PartInfo
doc DedDoc
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà di PartInfoDoc

Il tipo MultipleStateOperationPartInfoDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Lev |
Proprietà pubblica | PrtInfo |
Proprietà pubblica | UserData |
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.Data

Proprietà MultipleStateOperationPartInfoDocData

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.Document

Proprietà MultipleStateOperationPartInfoDocDocument

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.Lev

Proprietà MultipleStateOperationPartInfoDocLev

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Lev { get; set; }
Public Property Lev As Integer
    Get
    Set
public:
property int Lev {
    int get ();
    void set (int value);
}
member Lev : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.PrtInfo

Proprietà MultipleStateOperationPartInfoDocPrtInfo

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtInfo { get; set; }
Public Property PrtInfo As PartInfo
    Get
    Set
public:
property PartInfo^ PrtInfo {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtInfo : PartInfo with get, set

Valore della proprietà

PartInfo
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.UserData

Proprietà MultipleStateOperationPartInfoDocUserData

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object UserData { get; set; }
Public Property UserData As Object
    Get
    Set
public:
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}
member UserData : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Classe ResolveFileForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsResolveFileForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ResolveFileForm : BaseForm
Public Class ResolveFileForm
    Inherits BaseForm
public ref class ResolveFileForm : public BaseForm
type ResolveFileForm =
    class
        inherit BaseForm
    end

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Proprietà di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetAcad.Forms


Proprietà ResolveFileForm.SetText

Proprietà ResolveFileFormSetText

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
public string SetText { get; set; }
Public Property SetText As String
    Get
    Set
public:
property String^ SetText {
    String^ get ();
    void set (String^ value);
}
member SetText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetAcad.Forms


Metodi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetAcad.Forms


Metodo ResolveFileForm.Dispose

Metodo ResolveFileFormDispose
Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 28.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetAcad.Forms


Eventi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetAcad.Forms


Campi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetAcad.Forms