QSAdoNet Namespace
Classi
 | Classe | Descrizione
Esempio di codice | ConnOpCloser | Gestisce l'apertura e la chiusura della connessione in modo che le operazioni racchiuse nella clausola using siano svolte con la connessione aperta.
Classe pubblica | QSCommandBase | Classe base per i comandi SQL.
Classe pubblica | QSConnection | Gestisce la connessione ad un Database Ado.net.
Classe pubblica | QSConnectionIndexProperty | Classe usata per salvare le proprietà di un indice.
Classe pubblica | QSConnectionReflectionUtils | Classe per la gestione alla connessione
Classe pubblica | QsCreateBackupCommand | Classe per creare un indice su un insieme di campi di una tabella.
Classe pubblica | QsCreateConstraintCommand | Classe per creare un indice su un insieme di campi di una tabella.
Classe pubblica | QsCreateFieldCommand | Classe per creare un insieme di campi in una tabella.
Classe pubblica | QsCreateIndexCommand | Classe per creare un indice su un insieme di campi di una tabella.
Classe pubblica | QsCreateTableCommand | Classe per creare una tabella.
Classe pubblica | QSDeleteCommand | Implementa le funzionalità di DELETE.
Classe pubblica | QsDropConstraintCommand | Classe per eliminare un insieme di campi da una tabella.
Classe pubblica | QsDropFieldCommand | Classe per eliminare un insieme di campi da una tabella.
Classe pubblica | QsDropIndexCommand | Classe per eliminare un insieme di campi da una tabella.
Classe pubblica | QsDropTableCommand | Classe per droppare una tabella.
Classe pubblica | QSInsertCommand | Implementa le funzionalità di INSERT.
Classe pubblica | QsRebuildIndexCommand | Classe per creare un indice su un insieme di campi di una tabella.
Classe pubblica | QSSelectCommand | Implementa le funzionalità di SELECT.
Classe pubblica | QSSql |
Classe pubblica | QSSqlBetweenOperator | Descrive un operatore BETWEEN che lega tre elementi. Es: (A BETWEEN B AND C).
Classe pubblica | QSSqlBinaryOperator | Descrive un operatore binario che lega due elementi. Es: (A = B).
Classe pubblica | QSSqlColumnField | Descrive un singolo campo di una istruzione di modifica/aggiunta di un campo.
Classe pubblica | QSSqlCommaStatementList | Lista di elementi ISqlStatement che vengono concatenati con una virgola.
Classe pubblica | QSSqlField | Descrive un singolo campo di una istruzione SQL.
Classe pubblica | QSSqlFunction | Descrive una funzione di aggregazione come COUNT, SUM, MAX, MIN, AVERAGE.
Classe pubblica | QSSqlFunctionReplace | Descrive una funzione di replace
Classe pubblica | QSSqlInQuery | Crea una sottoquery in forma: "CAMPO IN ('valore1','valore2',....)".
Classe pubblica | QSSqlJoinQuery | Crea una JOIN in forma: "XXX JOIN TABLE/(SELECT) ON ....".
Classe pubblica | QSSqlLikeOperator | Descrive un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Classe pubblica | QSSqlLiteral | Descrive un singolo campo di una istruzione SQL.
Classe pubblica | QSSqlSpaceStatementList | Lista di elementi ISqlStatement che vengono concatenati da spazio e racchiusi tra parentesi.
Classe pubblica | QSSqlStatementBase | Classe base per tutti gli elementi di una istruzione SQL.
Classe pubblica | QSSqlSubQuery | Crea una sottoquery in forma: "CAMPO IN (SELECT ....)".
Classe pubblica | QSSqlUnaryOperator | Descrive un operatore unario legato ad un elemento. Es: "NOT (...)".
Classe pubblica | QSUpdateCommand | Implementa le funzionalità di UPDATE.
Classe pubblica | QsUpdateFieldCommand | Classe per alterare un insieme di campi di una tabella.
Classe pubblica | QSUpdateInsertCommand | Implementa le funzionalità di UPDATE se il record esiste altrimenti effettua un INSERT. Nei Fileds inserire tutti i campi da aggiornare o inserire.
Classe pubblica | RecordReaderEventArgs | Argomento passato al QsAdoNetRecordReaderHandler contenente le informazioni necessarie alla lettura dei dati.
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | ISqlStatement | Interfaccia comune alle istruzioni SQL.
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | SqlBinaryOperatorEnum | Enumerazione degli operatori di comparazione binaria.
Enumerazione pubblica | SqlJoinEnum | Enumerazione tipologie Join
Enumerazione pubblica | SqlLikeOperatorEnum | Enumerazione degli operatori di Like.
Enumerazione pubblica | SqlUnaryOperatorEnum | Enumerazione degli operatori unari.

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ConnOpCloser
Gestisce l'apertura e la chiusura della connessione in modo che le operazioni racchiuse nella clausola using siano svolte con la connessione aperta.
Gerarchia di ereditarietà
SystemObject
QSAdoNetConnOpCloser

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnOpCloser : IDisposable
Public Class ConnOpCloser
    Implements IDisposable
public ref class ConnOpCloser : IDisposable
type ConnOpCloser =
    class
        interface IDisposable
    end

Il tipo ConnOpCloser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Dispose | Rilascia tutte le risorse utilizzate da ConnOpCloser.
Metodo protetto | Dispose(Boolean) | Rilascia le risorse unmanaged usate da ConnOpCloser e opzionalmente rilascia anche le risorse managed.
Metodo protetto | Finalize | (Sovrascrive ObjectFinalize)
Torna su
Esempio
using(QSConnectionObj.CreateConnOpCloser()) {
                // Codice che utilizza l'oggetto QSConnectionObj e che necessita della connessione aperta.
            }
Vedi anche

Documentazione

Namespace QSAdoNet


Metodi di ConnOpCloser

Il tipo ConnOpCloser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Dispose |
Metodo protetto | Dispose(Boolean) |
Metodo protetto | Finalize | (Sovrascrive ObjectFinalize)
Torna su
Vedi anche

Documentazione

Classe ConnOpCloser


Metodo ConnOpCloser.Dispose

Libreria query DedNet

Metodo ConnOpCloserDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Rilascia tutte le risorse utilizzate da ConnOpCloser.
Metodo protetto | Dispose(Boolean) | Rilascia le risorse unmanaged usate da ConnOpCloser e opzionalmente rilascia anche le risorse managed.
Torna su
Vedi anche

Documentazione

Classe ConnOpCloser


Metodo ConnOpCloser.Dispose

Metodo ConnOpCloserDispose
Rilascia tutte le risorse utilizzate da ConnOpCloser.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe ConnOpCloser
Overload di Dispose


Metodo ConnOpCloser.Dispose(Boolean)

Metodo ConnOpCloserDispose(Boolean)
Rilascia le risorse unmanaged usate da ConnOpCloser e opzionalmente rilascia anche le risorse managed.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
True per rilasciare sia le risorse managed che quelle unmanaged; false per rilasciare solo quelle unmanaged.
Vedi anche

Documentazione

Classe ConnOpCloser
Overload di Dispose


Metodo ConnOpCloser.Finalize

Metodo ConnOpCloserFinalize

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
~Finalize()
Protected Overrides Sub Finalize
!Finalize()
abstract Finalize : unit -> unit
override Finalize : unit -> unit
Vedi anche

Documentazione

Classe ConnOpCloser


Interfaccia ISqlStatement
Interfaccia comune alle istruzioni SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface ISqlStatement
Public Interface ISqlStatement
public interface class ISqlStatement
type ISqlStatement = interface end

Il tipo ISqlStatement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di ISqlStatement

Il tipo ISqlStatement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL.
Torna su
Vedi anche

Documentazione

Interfaccia ISqlStatement


Proprietà ISqlStatement.SqlStatement

Proprietà ISqlStatementSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
string SqlStatement { get; }
ReadOnly Property SqlStatement As String
    Get
property String^ SqlStatement {
    String^ get ();
}
abstract SqlStatement : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Interfaccia ISqlStatement


Classe QSCommandBase
Classe base per i comandi SQL.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
Altro

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSCommandBase : ISqlStatement
Public Class QSCommandBase
    Implements ISqlStatement
public ref class QSCommandBase : ISqlStatement
type QSCommandBase =
    class
        interface ISqlStatement
    end

Il tipo QSCommandBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSCommandBase | Crea l'oggetto inizializzando il riferimento alla connessione.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella.
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente.
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti.
Proprietà pubblica | SqlStatement | Restituisce la clausola completa della WHERE oppure stringa vuota "".
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null.
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri.
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste.
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa.
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri.
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa.
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico.
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL.
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico.
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo.
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico.
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro.
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where.
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null.
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null.
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsCreateBackupCommand
QSAdoNetQsCreateConstraintCommand
QSAdoNetQsCreateFieldCommand
QSAdoNetQsCreateIndexCommand
QSAdoNetQsCreateTableCommand
QSAdoNetQSDeleteCommand
QSAdoNetQsDropConstraintCommand
QSAdoNetQsDropFieldCommand
QSAdoNetQsDropIndexCommand
QSAdoNetQsDropTableCommand
QSAdoNetQSInsertCommand
QSAdoNetQsRebuildIndexCommand
QSAdoNetQSSelectCommand
QSAdoNetQSUpdateCommand
QSAdoNetQsUpdateFieldCommand
QSAdoNetQSUpdateInsertCommand


Costruttore QSCommandBase
Crea l'oggetto inizializzando il riferimento alla connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QSCommandBase(
    QSConnection conn
)
Protected Friend Sub New (
    conn As QSConnection
)
protected public:
QSCommandBase(
    QSConnection^ conn
)
new :
        conn : QSConnection -> QSCommandBase

Parametri

conn QSConnection
Connessione non necessariamente aperta.
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà di QSCommandBase

Il tipo QSCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella.
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente.
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti.
Proprietà pubblica | SqlStatement | Restituisce la clausola completa della WHERE oppure stringa vuota "".
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null.
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.Alias

Proprietà QSCommandBaseAlias
Restituisce o imposta l'alias della tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set
public:
property String^ Alias {
    String^ get ();
    void set (String^ value);
}
member Alias : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.Command

Proprietà QSCommandBaseCommand
Restituisce il comando utilizzato internamente.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbCommand Command { get; }
Public ReadOnly Property Command As DbCommand
    Get
public:
property DbCommand^ Command {
    DbCommand^ get ();
}
member Command : DbCommand with get

Valore della proprietà

DbCommand
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.Connection

Proprietà QSCommandBaseConnection
Restituisce l'oggetto connessione al quale questo comando appartiene.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.Parameters

Proprietà QSCommandBaseParameters
Restituisce la collezione contenente tutti i parametri presenti.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As DbParameterCollection
    Get
public:
property DbParameterCollection^ Parameters {
    DbParameterCollection^ get ();
}
member Parameters : DbParameterCollection with get

Valore della proprietà

DbParameterCollection
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.SqlStatement

Proprietà QSCommandBaseSqlStatement
Restituisce la clausola completa della WHERE oppure stringa vuota "".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string SqlStatement { get; }
Public Overridable ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get ();
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.TableName

Proprietà QSCommandBaseTableName
Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TableName { get; set; }
Public Property TableName As String
    Get
    Set
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}
member TableName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSCommandBase


Proprietà QSCommandBase.WhereList

Proprietà QSCommandBaseWhereList
Restituisce la lista delle istruzioni Where.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlSpaceStatementList WhereList { get; }
Public ReadOnly Property WhereList As QSSqlSpaceStatementList
    Get
public:
property QSSqlSpaceStatementList^ WhereList {
    QSSqlSpaceStatementList^ get ();
}
member WhereList : QSSqlSpaceStatementList with get

Valore della proprietà

QSSqlSpaceStatementList
Vedi anche

Documentazione

Classe QSCommandBase


Metodi di QSCommandBase

Il tipo QSCommandBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri.
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste.
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa.
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri.
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa.
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico.
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL.
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico.
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo.
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico.
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro.
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where.
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null.
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null.
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereBetween

Metodo QSCommandBaseAddWhereBetween
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereBetween(String, Object, Object)

Metodo QSCommandBaseAddWhereBetween(String, Object, Object)
Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereBetween(
    string fieldName,
    Object minValue,
    Object maxValue
)
Public Sub AddWhereBetween (
    fieldName As String,
    minValue As Object,
    maxValue As Object
)
public:
void AddWhereBetween(
    String^ fieldName,
    Object^ minValue,
    Object^ maxValue
)
member AddWhereBetween :
        fieldName : string *
        minValue : Object *
        maxValue : Object -> unit

Parametri

fieldName String
Nome del campo.
minValue Object
Valore minimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereBetween


Metodo QSCommandBase.AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object)

Metodo QSCommandBaseAddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object)
Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereBetween(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    Object minValue,
    Object maxValue
)
Public Sub AddWhereBetween (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    minValue As Object,
    maxValue As Object
)
public:
void AddWhereBetween(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    Object^ minValue,
    Object^ maxValue
)
member AddWhereBetween :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        minValue : Object *
        maxValue : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
minValue Object
Valore minimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereBetween


Metodo QSCommandBase.AddWhereBetween(String, String, Object, String, Object)

Metodo QSCommandBaseAddWhereBetween(String, String, Object, String, Object)
Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereBetween(
    string fieldName,
    string minParam,
    Object minValue,
    string maxParam,
    Object maxValue
)
Public Sub AddWhereBetween (
    fieldName As String,
    minParam As String,
    minValue As Object,
    maxParam As String,
    maxValue As Object
)
public:
void AddWhereBetween(
    String^ fieldName,
    String^ minParam,
    Object^ minValue,
    String^ maxParam,
    Object^ maxValue
)
member AddWhereBetween :
        fieldName : string *
        minParam : string *
        minValue : Object *
        maxParam : string *
        maxValue : Object -> unit

Parametri

fieldName String
Nome del campo.
minParam String
Nome del parametro del valore minimo.
minValue Object
Valore minimo.
maxParam String
Nome del parametro del valore massimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereBetween


Metodo QSCommandBase.AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object)

Metodo QSCommandBaseAddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object)
Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereBetween(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    string minParam,
    Object minValue,
    string maxParam,
    Object maxValue
)
Public Sub AddWhereBetween (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    minParam As String,
    minValue As Object,
    maxParam As String,
    maxValue As Object
)
public:
void AddWhereBetween(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    String^ minParam,
    Object^ minValue,
    String^ maxParam,
    Object^ maxValue
)
member AddWhereBetween :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        minParam : string *
        minValue : Object *
        maxParam : string *
        maxValue : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
minParam String
Nome del parametro del valore minimo.
minValue Object
Valore minimo.
maxParam String
Nome del parametro del valore massimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereBetween


Metodo QSCommandBase.AddWhereElement

Metodo QSCommandBaseAddWhereElement
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereElement(ISqlStatement)

Metodo QSCommandBaseAddWhereElement(ISqlStatement)
Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereElement(
    ISqlStatement item
)
Public Sub AddWhereElement (
    item As ISqlStatement
)
public:
void AddWhereElement(
    ISqlStatement^ item
)
member AddWhereElement :
        item : ISqlStatement -> unit

Parametri

item ISqlStatement
Elemento da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereElement


Metodo QSCommandBase.AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement)

Metodo QSCommandBaseAddWhereElement(SqlBinaryOperatorEnum, ISqlStatement)
Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereElement(
    SqlBinaryOperatorEnum precOperator,
    ISqlStatement item
)
Public Sub AddWhereElement (
    precOperator As SqlBinaryOperatorEnum,
    item As ISqlStatement
)
public:
void AddWhereElement(
    SqlBinaryOperatorEnum precOperator,
    ISqlStatement^ item
)
member AddWhereElement :
        precOperator : SqlBinaryOperatorEnum *
        item : ISqlStatement -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente.
item ISqlStatement
Elemento da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereElement


Metodo QSCommandBase.AddWhereImpossible

Metodo QSCommandBaseAddWhereImpossible
Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereImpossible()
Public Sub AddWhereImpossible
public:
void AddWhereImpossible()
member AddWhereImpossible : unit -> unit
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereInList

Metodo QSCommandBaseAddWhereInList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereInList(String, List<String>)

Metodo QSCommandBaseAddWhereInList(String, ListString)
Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereInList(
    string fieldName,
    List<string> list
)
Public Sub AddWhereInList (
    fieldName As String,
    list As List(Of String)
)
public:
void AddWhereInList(
    String^ fieldName,
    List<String^>^ list
)
member AddWhereInList :
        fieldName : string *
        list : List<string> -> unit

Parametri

fieldName String
Nome del campo di cui verificare l'esistenza nella lista
list List String
Lista di elmenti da verificare
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereInList


Metodo QSCommandBase.AddWhereInList(SqlBinaryOperatorEnum, String, List<String>)

Metodo QSCommandBaseAddWhereInList(SqlBinaryOperatorEnum, String, ListString)
Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereInList(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    List<string> list
)
Public Sub AddWhereInList (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    list As List(Of String)
)
public:
void AddWhereInList(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    List<String^>^ list
)
member AddWhereInList :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        list : List<string> -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo di cui verificare l'esistenza nella lista
list List String
Lista di elmenti da verificare
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereInList


Metodo QSCommandBase.AddWhereItem

Metodo QSCommandBaseAddWhereItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico.
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereItem(ISqlStatement)

Metodo QSCommandBaseAddWhereItem(ISqlStatement)
Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    ISqlStatement item
)
Public Sub AddWhereItem (
    item As ISqlStatement
)
public:
void AddWhereItem(
    ISqlStatement^ item
)
member AddWhereItem :
        item : ISqlStatement -> unit

Parametri

item ISqlStatement
Elemento da accodare.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement)

Metodo QSCommandBaseAddWhereItem(SqlBinaryOperatorEnum, ISqlStatement)
Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    ISqlStatement item
)
Public Sub AddWhereItem (
    precOperator As SqlBinaryOperatorEnum,
    item As ISqlStatement
)
public:
void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    ISqlStatement^ item
)
member AddWhereItem :
        precOperator : SqlBinaryOperatorEnum *
        item : ISqlStatement -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
item ISqlStatement
Elemento da accodare.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(String, Object)

Metodo QSCommandBaseAddWhereItem(String, Object)
Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    string fieldName,
    Object value
)
Public Sub AddWhereItem (
    fieldName As String,
    value As Object
)
public:
void AddWhereItem(
    String^ fieldName,
    Object^ value
)
member AddWhereItem :
        fieldName : string *
        value : Object -> unit

Parametri

fieldName String
Nome del campo.
value Object
Valore del parametro da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(SqlBinaryOperatorEnum, String, Object)

Metodo QSCommandBaseAddWhereItem(SqlBinaryOperatorEnum, String, Object)
Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    Object value
)
Public Sub AddWhereItem (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    value As Object
)
public:
void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    Object^ value
)
member AddWhereItem :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        value : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
value Object
Valore del parametro da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(String, SqlBinaryOperatorEnum, Object)

Metodo QSCommandBaseAddWhereItem(String, SqlBinaryOperatorEnum, Object)
Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    string fieldName,
    SqlBinaryOperatorEnum comparator,
    Object value
)
Public Sub AddWhereItem (
    fieldName As String,
    comparator As SqlBinaryOperatorEnum,
    value As Object
)
public:
void AddWhereItem(
    String^ fieldName,
    SqlBinaryOperatorEnum comparator,
    Object^ value
)
member AddWhereItem :
        fieldName : string *
        comparator : SqlBinaryOperatorEnum *
        value : Object -> unit

Parametri

fieldName String
Nome del campo.
comparator SqlBinaryOperatorEnum
Operatore di comparazione.
value Object
Valore del parametro da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object)

Metodo QSCommandBaseAddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object)
Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlBinaryOperatorEnum comparator,
    Object value
)
Public Sub AddWhereItem (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    comparator As SqlBinaryOperatorEnum,
    value As Object
)
public:
void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlBinaryOperatorEnum comparator,
    Object^ value
)
member AddWhereItem :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        comparator : SqlBinaryOperatorEnum *
        value : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
comparator SqlBinaryOperatorEnum
Operatore di comparazione.
value Object
Valore del parametro da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(String, SqlBinaryOperatorEnum, String, Object)

Metodo QSCommandBaseAddWhereItem(String, SqlBinaryOperatorEnum, String, Object)
Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    string fieldName,
    SqlBinaryOperatorEnum comparator,
    string parameter,
    Object value
)
Public Sub AddWhereItem (
    fieldName As String,
    comparator As SqlBinaryOperatorEnum,
    parameter As String,
    value As Object
)
public:
void AddWhereItem(
    String^ fieldName,
    SqlBinaryOperatorEnum comparator,
    String^ parameter,
    Object^ value
)
member AddWhereItem :
        fieldName : string *
        comparator : SqlBinaryOperatorEnum *
        parameter : string *
        value : Object -> unit

Parametri

fieldName String
Nome del campo.
comparator SqlBinaryOperatorEnum
Operatore di comparazione.
parameter String
Nome del parametro da aggiungere.
value Object
Valore del parametro da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object)

Metodo QSCommandBaseAddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object)
Aggiunge alla clausola where un elemento ed un parametro contemporaneamente.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlBinaryOperatorEnum comparator,
    string parameter,
    Object value
)
Public Sub AddWhereItem (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    comparator As SqlBinaryOperatorEnum,
    parameter As String,
    value As Object
)
public:
void AddWhereItem(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlBinaryOperatorEnum comparator,
    String^ parameter,
    Object^ value
)
member AddWhereItem :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        comparator : SqlBinaryOperatorEnum *
        parameter : string *
        value : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
comparator SqlBinaryOperatorEnum
Operatore di comparazione.
parameter String
Nome del parametro da aggiungere.
value Object
Valore del parametro da aggiungere.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereItem


Metodo QSCommandBase.AddWhereLike

Metodo QSCommandBaseAddWhereLike
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico.
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereLike(String, SqlLikeOperatorEnum, String)

Metodo QSCommandBaseAddWhereLike(String, SqlLikeOperatorEnum, String)
Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereLike(
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike
)
Public Sub AddWhereLike (
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String
)
public:
void AddWhereLike(
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike
)
member AddWhereLike :
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string -> unit

Parametri

fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereLike


Metodo QSCommandBase.AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String)

Metodo QSCommandBaseAddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String)
Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereLike(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike
)
Public Sub AddWhereLike (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String
)
public:
void AddWhereLike(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike
)
member AddWhereLike :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro. NB: Nel caso di SqlLikeOperatorEnum.Free viene impostato il quoteWildeChars a false in modo che non vengano wrappati in automatico eventuali caratteri jolly
valueLike String
Stringa da valutare.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereLike


Metodo QSCommandBase.AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean)

Metodo QSCommandBaseAddWhereLike(String, SqlLikeOperatorEnum, String, Boolean)
Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereLike(
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereLike (
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereLike(
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereLike :
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereLike


Metodo QSCommandBase.AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean)

Metodo QSCommandBaseAddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean)
Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereLike(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereLike (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereLike(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereLike :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereLike


Metodo QSCommandBase.AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean)

Metodo QSCommandBaseAddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean)
Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereLike(
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string parameter,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereLike (
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    parameter As String,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereLike(
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ parameter,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereLike :
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        parameter : string *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
parameter String
Nome del parametro da aggiungere.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereLike


Metodo QSCommandBase.AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean)

Metodo QSCommandBaseAddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean)
Aggiunge alla clausola where un operatore LIKE che verifica una stringa.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereLike(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string parameter,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereLike (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    parameter As String,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereLike(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ parameter,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereLike :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        parameter : string *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
parameter String
Nome del parametro da aggiungere.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereLike


Metodo QSCommandBase.AddWhereNotBetween

Metodo QSCommandBaseAddWhereNotBetween
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereNotBetween(String, Object, Object)

Metodo QSCommandBaseAddWhereNotBetween(String, Object, Object)
Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotBetween(
    string fieldName,
    Object minValue,
    Object maxValue
)
Public Sub AddWhereNotBetween (
    fieldName As String,
    minValue As Object,
    maxValue As Object
)
public:
void AddWhereNotBetween(
    String^ fieldName,
    Object^ minValue,
    Object^ maxValue
)
member AddWhereNotBetween :
        fieldName : string *
        minValue : Object *
        maxValue : Object -> unit

Parametri

fieldName String
Nome del campo.
minValue Object
Valore minimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotBetween


Metodo QSCommandBase.AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object)

Metodo QSCommandBaseAddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object)
Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotBetween(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    Object minValue,
    Object maxValue
)
Public Sub AddWhereNotBetween (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    minValue As Object,
    maxValue As Object
)
public:
void AddWhereNotBetween(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    Object^ minValue,
    Object^ maxValue
)
member AddWhereNotBetween :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        minValue : Object *
        maxValue : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
minValue Object
Valore minimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotBetween


Metodo QSCommandBase.AddWhereNotBetween(String, String, Object, String, Object)

Metodo QSCommandBaseAddWhereNotBetween(String, String, Object, String, Object)
Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotBetween(
    string fieldName,
    string minParam,
    Object minValue,
    string maxParam,
    Object maxValue
)
Public Sub AddWhereNotBetween (
    fieldName As String,
    minParam As String,
    minValue As Object,
    maxParam As String,
    maxValue As Object
)
public:
void AddWhereNotBetween(
    String^ fieldName,
    String^ minParam,
    Object^ minValue,
    String^ maxParam,
    Object^ maxValue
)
member AddWhereNotBetween :
        fieldName : string *
        minParam : string *
        minValue : Object *
        maxParam : string *
        maxValue : Object -> unit

Parametri

fieldName String
Nome del campo.
minParam String
Nome del parametro del valore minimo.
minValue Object
Valore minimo.
maxParam String
Nome del parametro del valore massimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotBetween


Metodo QSCommandBase.AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object)

Metodo QSCommandBaseAddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object)
Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotBetween(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    string minParam,
    Object minValue,
    string maxParam,
    Object maxValue
)
Public Sub AddWhereNotBetween (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    minParam As String,
    minValue As Object,
    maxParam As String,
    maxValue As Object
)
public:
void AddWhereNotBetween(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    String^ minParam,
    Object^ minValue,
    String^ maxParam,
    Object^ maxValue
)
member AddWhereNotBetween :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        minParam : string *
        minValue : Object *
        maxParam : string *
        maxValue : Object -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
minParam String
Nome del parametro del valore minimo.
minValue Object
Valore minimo.
maxParam String
Nome del parametro del valore massimo.
maxValue Object
Valore massimo.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotBetween


Metodo QSCommandBase.AddWhereNotInList

Metodo QSCommandBaseAddWhereNotInList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereNotInList(String, List<String>)

Metodo QSCommandBaseAddWhereNotInList(String, ListString)
Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotInList(
    string fieldName,
    List<string> list
)
Public Sub AddWhereNotInList (
    fieldName As String,
    list As List(Of String)
)
public:
void AddWhereNotInList(
    String^ fieldName,
    List<String^>^ list
)
member AddWhereNotInList :
        fieldName : string *
        list : List<string> -> unit

Parametri

fieldName String
ome del campo di cui verificare la non esistenza nella lista
list List String
Lista di elmenti da verificare
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotInList


Metodo QSCommandBase.AddWhereNotInList(SqlBinaryOperatorEnum, String, List<String>)

Metodo QSCommandBaseAddWhereNotInList(SqlBinaryOperatorEnum, String, ListString)
Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotInList(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    List<string> list
)
Public Sub AddWhereNotInList (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    list As List(Of String)
)
public:
void AddWhereNotInList(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    List<String^>^ list
)
member AddWhereNotInList :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        list : List<string> -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo di cui verificare la non esistenza nella lista
list List String
Lista di elmenti da verificare
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotInList


Metodo QSCommandBase.AddWhereNotLike

Metodo QSCommandBaseAddWhereNotLike
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico.
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereNotLike(String, SqlLikeOperatorEnum, String)

Metodo QSCommandBaseAddWhereNotLike(String, SqlLikeOperatorEnum, String)
Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotLike(
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike
)
Public Sub AddWhereNotLike (
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String
)
public:
void AddWhereNotLike(
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike
)
member AddWhereNotLike :
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string -> unit

Parametri

fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotLike


Metodo QSCommandBase.AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String)

Metodo QSCommandBaseAddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String)
Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotLike(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike
)
Public Sub AddWhereNotLike (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String
)
public:
void AddWhereNotLike(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike
)
member AddWhereNotLike :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotLike


Metodo QSCommandBase.AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean)

Metodo QSCommandBaseAddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean)
Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotLike(
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereNotLike (
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereNotLike(
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereNotLike :
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotLike


Metodo QSCommandBase.AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean)

Metodo QSCommandBaseAddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean)
Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotLike(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereNotLike (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereNotLike(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereNotLike :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotLike


Metodo QSCommandBase.AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean)

Metodo QSCommandBaseAddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean)
Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotLike(
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string parameter,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereNotLike (
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    parameter As String,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereNotLike(
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ parameter,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereNotLike :
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        parameter : string *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
parameter String
Nome del parametro da aggiungere.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotLike


Metodo QSCommandBase.AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean)

Metodo QSCommandBaseAddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean)
Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNotLike(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    SqlLikeOperatorEnum likeType,
    string parameter,
    string valueLike,
    bool quoteWildechars
)
Public Sub AddWhereNotLike (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    likeType As SqlLikeOperatorEnum,
    parameter As String,
    valueLike As String,
    quoteWildechars As Boolean
)
public:
void AddWhereNotLike(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    SqlLikeOperatorEnum likeType,
    String^ parameter,
    String^ valueLike,
    bool quoteWildechars
)
member AddWhereNotLike :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        likeType : SqlLikeOperatorEnum *
        parameter : string *
        valueLike : string *
        quoteWildechars : bool -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
likeType SqlLikeOperatorEnum
Tipo di LIKE da applicare: aggiunge i carattiri '%' nella corretta posizione in base a questo parametro.
parameter String
Nome del parametro da aggiungere.
valueLike String
Stringa da valutare.
quoteWildechars Boolean
Indica se quotare o meno i caratteri speciali come '%' e '_'.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNotLike


Metodo QSCommandBase.AddWhereNull

Metodo QSCommandBaseAddWhereNull
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico.
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereNull(String, Boolean)

Metodo QSCommandBaseAddWhereNull(String, Boolean)
Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNull(
    string fieldName,
    bool isNull
)
Public Sub AddWhereNull (
    fieldName As String,
    isNull As Boolean
)
public:
void AddWhereNull(
    String^ fieldName,
    bool isNull
)
member AddWhereNull :
        fieldName : string *
        isNull : bool -> unit

Parametri

fieldName String
Nome del campo.
isNull Boolean
Se debba essere NULL oppure NOT NULL
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNull


Metodo QSCommandBase.AddWhereNull(SqlBinaryOperatorEnum, String, Boolean)

Metodo QSCommandBaseAddWhereNull(SqlBinaryOperatorEnum, String, Boolean)
Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNull(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    bool isNull
)
Public Sub AddWhereNull (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    isNull As Boolean
)
public:
void AddWhereNull(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    bool isNull
)
member AddWhereNull :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        isNull : bool -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
isNull Boolean
Se debba essere NULL oppure NOT NULL
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNull


Metodo QSCommandBase.AddWhereNullOrEmpty

Metodo QSCommandBaseAddWhereNullOrEmpty
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico.
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereNullOrEmpty(String, Boolean)

Metodo QSCommandBaseAddWhereNullOrEmpty(String, Boolean)
Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNullOrEmpty(
    string fieldName,
    bool isNull
)
Public Sub AddWhereNullOrEmpty (
    fieldName As String,
    isNull As Boolean
)
public:
void AddWhereNullOrEmpty(
    String^ fieldName,
    bool isNull
)
member AddWhereNullOrEmpty :
        fieldName : string *
        isNull : bool -> unit

Parametri

fieldName String
Nome del campo.
isNull Boolean
Se si specifica true si ottiene: (CAMPO IS NULL OR CAMPO = ''). Se si specifica false si ottiene: (NOT CAMPO IS NULL AND CAMPO (diverso da) '').
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNullOrEmpty


Metodo QSCommandBase.AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean)

Metodo QSCommandBaseAddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean)
Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereNullOrEmpty(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    bool isNull
)
Public Sub AddWhereNullOrEmpty (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    isNull As Boolean
)
public:
void AddWhereNullOrEmpty(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    bool isNull
)
member AddWhereNullOrEmpty :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        isNull : bool -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo.
isNull Boolean
Se si specifica true si ottiene: (CAMPO IS NULL OR CAMPO = ''). Se si specifica false si ottiene: (NOT CAMPO IS NULL AND CAMPO (diverso da) '').
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereNullOrEmpty


Metodo QSCommandBase.AddWhereSubquery

Metodo QSCommandBaseAddWhereSubquery
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico.
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.AddWhereSubquery(String, Boolean, QSSelectCommand)

Metodo QSCommandBaseAddWhereSubquery(String, Boolean, QSSelectCommand)
Aggiunge alla clausola where una sottoquery anteponendo un AND logico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereSubquery(
    string fieldName,
    bool notIn,
    QSSelectCommand subCmd
)
Public Sub AddWhereSubquery (
    fieldName As String,
    notIn As Boolean,
    subCmd As QSSelectCommand
)
public:
void AddWhereSubquery(
    String^ fieldName,
    bool notIn,
    QSSelectCommand^ subCmd
)
member AddWhereSubquery :
        fieldName : string *
        notIn : bool *
        subCmd : QSSelectCommand -> unit

Parametri

fieldName String
Nome del campo di cui verificare l'esistenza nella sotto-query.
notIn Boolean
Negazione dell'inclusione.
subCmd QSSelectCommand
Comando select da utilizzare per la sotto-query.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereSubquery


Metodo QSCommandBase.AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand)

Metodo QSCommandBaseAddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand)
Aggiunge alla clausola where una sottoquery.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhereSubquery(
    SqlBinaryOperatorEnum precOperator,
    string fieldName,
    bool notIn,
    QSSelectCommand subCmd
)
Public Sub AddWhereSubquery (
    precOperator As SqlBinaryOperatorEnum,
    fieldName As String,
    notIn As Boolean,
    subCmd As QSSelectCommand
)
public:
void AddWhereSubquery(
    SqlBinaryOperatorEnum precOperator,
    String^ fieldName,
    bool notIn,
    QSSelectCommand^ subCmd
)
member AddWhereSubquery :
        precOperator : SqlBinaryOperatorEnum *
        fieldName : string *
        notIn : bool *
        subCmd : QSSelectCommand -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore con il quale concatenarsi ad una eventuale clausola precedente di pari livello.
fieldName String
Nome del campo di cui verificare l'esistenza nella sotto-query.
notIn Boolean
Negazione dell'inclusione.
subCmd QSSelectCommand
Comando select da utilizzare per la sotto-query.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di AddWhereSubquery


Metodo QSCommandBase.ContainsParameter

Metodo QSCommandBaseContainsParameter
Verifica l'esistenza di un parametro.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsParameter(
    string paramName
)
Public Function ContainsParameter (
    paramName As String
) As Boolean
public:
bool ContainsParameter(
    String^ paramName
)
member ContainsParameter :
        paramName : string -> bool

Parametri

paramName String
Nome del parametro da verificare.

Valore di ritorno

Boolean
Restituisce true se il parametro esiste altrimenti false.
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.ContainsWhereParameter

Metodo QSCommandBaseContainsWhereParameter
Verifica l'esistenza di un parametro dedicato alla clausola where.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsWhereParameter(
    string paramName
)
Public Function ContainsWhereParameter (
    paramName As String
) As Boolean
public:
bool ContainsWhereParameter(
    String^ paramName
)
member ContainsWhereParameter :
        paramName : string -> bool

Parametri

paramName String
Nome del parametro da verificare.

Valore di ritorno

Boolean
Restituisce true se il parametro esiste altrimenti false.
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.CopyParametersFrom

Metodo QSCommandBaseCopyParametersFrom
Copia i parametri dal comando passato a questo oggetto

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyParametersFrom(
    QSCommandBase cmd,
    bool overwrite
)
Public Sub CopyParametersFrom (
    cmd As QSCommandBase,
    overwrite As Boolean
)
public:
void CopyParametersFrom(
    QSCommandBase^ cmd,
    bool overwrite
)
member CopyParametersFrom :
        cmd : QSCommandBase *
        overwrite : bool -> unit

Parametri

cmd QSCommandBase
Comando dal quale copiare i parametri.
overwrite Boolean
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.CopyParametersTo

Metodo QSCommandBaseCopyParametersTo
Copia i parametri da questo oggetto al comando passato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyParametersTo(
    QSCommandBase cmd,
    bool overwrite
)
Public Sub CopyParametersTo (
    cmd As QSCommandBase,
    overwrite As Boolean
)
public:
void CopyParametersTo(
    QSCommandBase^ cmd,
    bool overwrite
)
member CopyParametersTo :
        cmd : QSCommandBase *
        overwrite : bool -> unit

Parametri

cmd QSCommandBase
Comando nel quale copiare i parametri.
overwrite Boolean
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.GetParameterValue

Metodo QSCommandBaseGetParameterValue
Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetParameterValue(
    string paramName
)
Public Function GetParameterValue (
    paramName As String
) As Object
public:
Object^ GetParameterValue(
    String^ paramName
)
member GetParameterValue :
        paramName : string -> Object

Parametri

paramName String
Nome del parametro.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.GetWhereParameterValue

Metodo QSCommandBaseGetWhereParameterValue
Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetWhereParameterValue(
    string paramName
)
Public Function GetWhereParameterValue (
    paramName As String
) As Object
public:
Object^ GetWhereParameterValue(
    String^ paramName
)
member GetWhereParameterValue :
        paramName : string -> Object

Parametri

paramName String
Nome del parametro.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.IsEqualTo

Metodo QSCommandBaseIsEqualTo
Confronta un comando con questa istanza.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsEqualTo(
    QSCommandBase cmd
)
Public Overridable Function IsEqualTo (
    cmd As QSCommandBase
) As Boolean
public:
virtual bool IsEqualTo(
    QSCommandBase^ cmd
)
abstract IsEqualTo :
        cmd : QSCommandBase -> bool
override IsEqualTo :
        cmd : QSCommandBase -> bool

Parametri

cmd QSCommandBase
Comando da comparare.

Valore di ritorno

Boolean
Restituisce true se il comando passato è uguale a questo oppure false.
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.SetParameterValue

Metodo QSCommandBaseSetParameterValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.SetParameterValue(String, Object)

Metodo QSCommandBaseSetParameterValue(String, Object)
Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetParameterValue(
    string paramName,
    Object value
)
Public Sub SetParameterValue (
    paramName As String,
    value As Object
)
public:
void SetParameterValue(
    String^ paramName,
    Object^ value
)
member SetParameterValue :
        paramName : string *
        value : Object -> unit

Parametri

paramName String
Nome del parametro da impostare.
value Object
Valore del parametro.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di SetParameterValue


Metodo QSCommandBase.SetParameterValue(String, Object, DbType)

Metodo QSCommandBaseSetParameterValue(String, Object, DbType)
Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetParameterValue(
    string paramName,
    Object value,
    DbType dbT
)
Public Sub SetParameterValue (
    paramName As String,
    value As Object,
    dbT As DbType
)
public:
void SetParameterValue(
    String^ paramName,
    Object^ value,
    DbType dbT
)
member SetParameterValue :
        paramName : string *
        value : Object *
        dbT : DbType -> unit

Parametri

paramName String
Nome del parametro da impostare.
value Object
Valore del parametro.
dbT DbType
Tipo dati presente nel Database.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di SetParameterValue


Metodo QSCommandBase.SetWhereParameterValue

Metodo QSCommandBaseSetWhereParameterValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.
Torna su
Vedi anche

Documentazione

Classe QSCommandBase


Metodo QSCommandBase.SetWhereParameterValue(String, Object)

Metodo QSCommandBaseSetWhereParameterValue(String, Object)
Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType).

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetWhereParameterValue(
    string paramName,
    Object value
)
Public Sub SetWhereParameterValue (
    paramName As String,
    value As Object
)
public:
void SetWhereParameterValue(
    String^ paramName,
    Object^ value
)
member SetWhereParameterValue :
        paramName : string *
        value : Object -> unit

Parametri

paramName String
Nome del parametro da impostare.
value Object
Valore del parametro.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di SetWhereParameterValue


Metodo QSCommandBase.SetWhereParameterValue(String, Object, DbType)

Metodo QSCommandBaseSetWhereParameterValue(String, Object, DbType)
Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetWhereParameterValue(
    string paramName,
    Object value,
    DbType dbT
)
Public Sub SetWhereParameterValue (
    paramName As String,
    value As Object,
    dbT As DbType
)
public:
void SetWhereParameterValue(
    String^ paramName,
    Object^ value,
    DbType dbT
)
member SetWhereParameterValue :
        paramName : string *
        value : Object *
        dbT : DbType -> unit

Parametri

paramName String
Nome del parametro da impostare.
value Object
Valore del parametro.
dbT DbType
Tipo dati presente nel Database.
Vedi anche

Documentazione

Classe QSCommandBase
Overload di SetWhereParameterValue


Classe QSConnection
Gestisce la connessione ad un Database Ado.net.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSConnection

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSConnection : IDisposable
Public Class QSConnection
    Implements IDisposable
public ref class QSConnection : IDisposable
type QSConnection =
    class
        interface IDisposable
    end

Il tipo QSConnection espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSConnection | Inizializza la connessione al Database tramite i parametri indispensabili.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CaseSensitive | Imposta se il database è case sensitive
Proprietà pubblica | Connection | Restituisce l'oggetto DbConnection di collegamento al Database.
Proprietà pubblica | ConnectionString | Restituisce la stringa di connessione al Database.
Proprietà pubblica | EnableLog | Restituisce o imposta se attivare la registrazione degli errori su file di Log.
Proprietà pubblica | Factory | Restituisce l'oggetto DbProviderFactory correlato alla connessione.
Proprietà pubblica | IsSql | Metodo che ritorna True se il providerName corrisponde a quello di SqlServer, False altrimenti.
Proprietà pubblica | IsSqlCE | Metodo che ritorna True se il providerName corrisponde a quello di SqlServerCE, False altrimenti.
Proprietà pubblica | IsTransactionAborted | Indica se ci sono stati errori nella transazione.
Proprietà pubblica | IsTransactionOpened | Restiruisce true se la transazione è aperta.
Proprietà pubblica | LastError | Restituisce l'ultimo errore registrato dalle funzioni di questa classe o stringa vuota se non ce ne sono stati.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione verificatasi nel codice di questo oggetto oppure negli oggetti comando creati da questa connessione.
Proprietà pubblica | ProviderName | Restituisce il nome invariante del provider.
Proprietà pubblica | RemoveQuote | Imposta/Restituisce se rimuovere le [] dai nomi colonne/tabelle
Proprietà pubblica | RemoveSemicolon | Imposta/Restituisce se rimuovere il ; dalla fine delle query
Proprietà pubblica | Transaction | Restituisce l'oggetto DbTransaction correntemente in uso oppure null se non sono in atto transazioni.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AdjustParameter | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@'. Sostituisce ' ' con '_'.
Metodo pubblico | AdjustParameterQuery | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@'. Sostituisce ' ' con '_'.
Metodo pubblico | AdjustWhereParameter | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@' e che sicuramente termini con "WHERE" in modo da essere differenziato dagli altri parametri. Sostituisce ' ' con '_'.
Metodo pubblico | AdjustWhereParameterQuery | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@' e che sicuramente termini con "WHERE" in modo da essere differenziato dagli altri parametri. Sostituisce ' ' con '_'.
Metodo pubblico | BeginTransaction | Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.
Metodo pubblico | BeginTransaction(IsolationLevel) | Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.
Metodo pubblico | CloseConnection | Decrementa il numero di richieste di apertura della connessione al Database oppure chiude effettivamente la connessione se si tratta dell'ultima richiesta. DEVE SEMPRE ESSERE USATA IN ACCOPPIAMENTO A OpenConnection() e chiamata solo se questa ha esito positivo.
Metodo pubblico | ColumnExists | Funzione che controlla l'esistenza di una colonna, restituisce true se esiste altimenti false.
Metodo pubblico | CreateAddFieldCommand | Crea e restituisce un comando di ADD di un insieme di campi.
Metodo pubblico | CreateAddTableCommand | Crea e restituisce un comando di CREATE di una tabella.
Metodo pubblico | CreateBackupCommand | Crea e restituisce un comando di creazione BACKUP del database
Metodo pubblico | CreateConnOpCloser | Restituisce un nuovo oggetto che, racchiuso dentro una clausola using, consente di aprire e chiudere in automatico la connessione al Database.
Metodo pubblico | CreateConstraintCommand | Crea e restituisce un comando di CREATE PRIMARY KEY.
Metodo pubblico | CreateDeleteCommand | Crea e restituisce un comando di DELETE.
Metodo pubblico | CreateDropConstraintCommand | Crea e restituisce un comando di DROP di una chiave primaria.
Metodo pubblico | CreateDropFieldCommand | Crea e restituisce un comando di DROP di un insieme di campi.
Metodo pubblico | CreateDropIndexCommand | Crea e restituisce un comando di DROP di una chiave primaria.
Metodo pubblico | CreateDropTableCommand | Crea e restituisce un comando di DROP di una tabella.
Metodo pubblico | CreateIndexCommand(String, String, Boolean) | Crea e restituisce un comando di CREATE INDEX.
Metodo pubblico | CreateIndexCommand(String, String, Boolean, Boolean) | Crea e restituisce un comando di CREATE INDEX.
Metodo pubblico | CreateInsertCommand | Crea e restituisce un comando di esecuzione INSERT.
Metodo pubblico | CreateRebuildIndexCommand |
Metodo pubblico | CreateSelectCommand | Crea e restituisce un comando di esecuzione SELECT.
Metodo pubblico | CreateSqlBetweenOperator | Costruisce un operatore BETWEEN che lega tre elementi. Es: (A BETWEEN B AND C).
Metodo pubblico | CreateSqlBinaryOperator(SqlBinaryOperatorEnum) | Costruisce un solo operatore binario.
Metodo pubblico | CreateSqlBinaryOperator(ISqlStatement, SqlBinaryOperatorEnum, ISqlStatement) | Costruisce un operatore binario che lega due elementi SQL.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean, Object) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean, Object, Int32, Int32) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlField | Crea un oggetto descrivente il nome di un campo da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunction(String, String) | Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunction(String, String, String) | Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunctionString | Crea un oggetto descrivente una funzione di REPLACE da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlInQuery | Crea una sottoquery in forma: "CAMPO IN ('valore1','valore2',....)".
Metodo pubblico | CreateSqlJoinQuery(SqlJoinEnum, String) | Crea una sintassi per il Join. Esempio : INNER JOIN tableName
Metodo pubblico | CreateSqlJoinQuery(SqlJoinEnum, QSSelectCommand, String) | Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias
Metodo pubblico | CreateSqlLikeOperator(ISqlStatement, String) | Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Metodo pubblico | CreateSqlLikeOperator(ISqlStatement, String, Char) | Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Metodo pubblico | CreateSqlLiteral | Costruisce un elemento costituito da una espressione testuale libera non vuota.
Metodo pubblico | CreateSqlSubQuery | Crea una sottoquery in forma: "CAMPO IN (SELECT ....)".
Metodo pubblico | CreateSqlUnaryOperator | Costruisce un operatore unario legato ad un elemento SQL. Es: "NOT (...)", "CAMPO IS NULL".
Metodo pubblico | CreateUpdateCommand | Crea e restituisce un comando di esecuzione UPDATE.
Metodo pubblico | CreateUpdateFieldCommand | Crea e restituisce un comando di ALTER di un insieme di campi.
Metodo pubblico | CreateUpdateInsertCommand | Crea e restituisce un comando di esecuzione UPDATE se riesce altrimenti effettua INSERT.
Metodo pubblico | Dispose | Rilascia tutte le risorse utilizzate da QSConnection.
Metodo protetto | Dispose(Boolean) | Rilascia le risorse unmanaged usate da QSConnection e opzionalmente rilascia anche le risorse managed.
Metodo pubblico | EndTransaction | Termina la transazione in atto effettuando opzionalmente il Rollback(). QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A BeginTransaction().
Metodo protetto | Finalize | (Sovrascrive ObjectFinalize)
Metodo pubblico | GetBackupTables | Restituisce i nomi delle tabelle di backup ordinate.
Metodo pubblico | GetIdentityColumnForDboSchema | Metodo che ritorna la lista delle colonne 'Identity' associate allo schema dbo
Metodo pubblico | GetIndexesInfo | Restituisce un dizionari con il nome della chiave e la lista di tutte le colonne che la compongono.
Metodo pubblico | GetNETType | Metodo che in base al tipo di dato passato in ingresso, ritorna la relativa controparte .NET
Metodo pubblico | GetPrimaryKeyInfo | Restituisce un dizionari con il nome della chiave e la lista di tutte le colonne che la compongono.
Metodo pubblico | GetRowGuidColumns | Restituisce le colonne utilizzare dalla Replica come RowGuid.
Metodo pubblico | GetTableFieldsList | Restituisce la lista dei nomi dei campi di una determinata table, in maiuscolo. Restituisce null se la table non esiste.
Metodo pubblico | GetTables | Restituisce i nomi delle tabelle presenti nel DB esculdento i BK_.
Metodo pubblico | IndexExist | Restituisce true se l'indice esiste nella tabella altrimenti false.
Metodo pubblico | IsValidConnection | Restituisce true se riesce a connettersi altrimenti false.
Metodo pubblico | MakeFieldList | Restituisce la lista dei nomi dei campi concatenati con una virgola e racchiusi dalle quadre (o dal carattere utilizzato dal Database al quale si è connessi). Es.: " [DED_DIS], [DED_COD] ". I valori di default per il prefisso ed il suffisso sono il singolo spazio ' '.
Metodo pubblico | MakeFieldValueList | Restituisce una stringa contenente le coppie nome = valore per l'istruzione UPDATE, concatenati con una virgola e racchiusi dalle quadre (o dal carattere utilizzato dal Database al quale si è connessi). Es.: " [DED_DIS] = '12646545', [DED_COD] = '12646545' ". O meglio : " [DED_DIS] = @DED_DIS, [DED_COD] = @DED_COD ". La stringa restituita ha uno spazio all'inizio ed uno alla fine.
Metodo pubblico | MakeValueList | Restituisce una stringa contenente la lista dei parametri concatenati concatenati con una virgola. Es.: "@Param1, @Param2, Param3". La stringa restituita non ha spazi all'inizio e alla fine.
Metodo pubblico | OpenConnection | Si assicura che la connessione al Database sia aperta. Se risulta già aperta incrementa il numero di richieste di apertura. DEVE SEMPRE ESSERE USATA IN ACCOPPIAMENTO A ColseConnection() che deve essere chiamata solo se questa funzione ha avuto successo.
Metodo pubblico | PerformDuplicatSchemaTable(String, String) |
Metodo pubblico | PerformDuplicatSchemaTable(String, String, Boolean, Boolean) |
Metodo pubblico | PerformTableBackup |
Metodo pubblico | QuoteIdentifier | Restituisce la stringa racchiusa tra parentesi quadre '[]' o comunque tra i corretti identificatori.
Metodo pubblico | QuoteLikeWildechars(String) | Restituisce la stringa con quotati i caratteri speciali del LIKE, come '%' e '_'.
Metodo pubblico | QuoteLikeWildechars(String, Char) | Restituisce la stringa con quotati con il valore di escape passato, come '%' e '_'.
Metodo pubblico | Select | Effettua una query e restituisce il risultato sotto forma di tabella lua
Metodo pubblico | SelectTxt | Effettua una query e restituisce il risultato sotto forma di tabella lua
Metodo pubblico | TableExists | Funzione che controlla l'esistenza di una tabella, restituisce true se esiste altimenti false.
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | StateChange | Evento di notifica su stato connessione.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSConnection
Inizializza la connessione al Database tramite i parametri indispensabili.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection(
    string providerName,
    string connectionString
)
Public Sub New (
    providerName As String,
    connectionString As String
)
public:
QSConnection(
    String^ providerName,
    String^ connectionString
)
new :
        providerName : string *
        connectionString : string -> QSConnection

Parametri

providerName String
Nome del provider.
connectionString String
Stringa di connessione.
Vedi anche

Documentazione

Classe QSConnection


Proprietà di QSConnection

Il tipo QSConnection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CaseSensitive | Imposta se il database è case sensitive
Proprietà pubblica | Connection | Restituisce l'oggetto DbConnection di collegamento al Database.
Proprietà pubblica | ConnectionString | Restituisce la stringa di connessione al Database.
Proprietà pubblica | EnableLog | Restituisce o imposta se attivare la registrazione degli errori su file di Log.
Proprietà pubblica | Factory | Restituisce l'oggetto DbProviderFactory correlato alla connessione.
Proprietà pubblica | IsSql | Metodo che ritorna True se il providerName corrisponde a quello di SqlServer, False altrimenti.
Proprietà pubblica | IsSqlCE | Metodo che ritorna True se il providerName corrisponde a quello di SqlServerCE, False altrimenti.
Proprietà pubblica | IsTransactionAborted | Indica se ci sono stati errori nella transazione.
Proprietà pubblica | IsTransactionOpened | Restiruisce true se la transazione è aperta.
Proprietà pubblica | LastError | Restituisce l'ultimo errore registrato dalle funzioni di questa classe o stringa vuota se non ce ne sono stati.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione verificatasi nel codice di questo oggetto oppure negli oggetti comando creati da questa connessione.
Proprietà pubblica | ProviderName | Restituisce il nome invariante del provider.
Proprietà pubblica | RemoveQuote | Imposta/Restituisce se rimuovere le [] dai nomi colonne/tabelle
Proprietà pubblica | RemoveSemicolon | Imposta/Restituisce se rimuovere il ; dalla fine delle query
Proprietà pubblica | Transaction | Restituisce l'oggetto DbTransaction correntemente in uso oppure null se non sono in atto transazioni.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.CaseSensitive

Proprietà QSConnectionCaseSensitive
Imposta se il database è case sensitive

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
    Get
    Set
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
member CaseSensitive : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.Connection

Proprietà QSConnectionConnection
Restituisce l'oggetto DbConnection di collegamento al Database.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbConnection Connection { get; }
Public ReadOnly Property Connection As DbConnection
    Get
public:
property DbConnection^ Connection {
    DbConnection^ get ();
}
member Connection : DbConnection with get

Valore della proprietà

DbConnection
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.ConnectionString

Proprietà QSConnectionConnectionString
Restituisce la stringa di connessione al Database.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ConnectionString { get; }
Public ReadOnly Property ConnectionString As String
    Get
public:
property String^ ConnectionString {
    String^ get ();
}
member ConnectionString : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.EnableLog

Proprietà QSConnectionEnableLog
Restituisce o imposta se attivare la registrazione degli errori su file di Log.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableLog { get; set; }
Public Property EnableLog As Boolean
    Get
    Set
public:
property bool EnableLog {
    bool get ();
    void set (bool value);
}
member EnableLog : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.Factory

Proprietà QSConnectionFactory
Restituisce l'oggetto DbProviderFactory correlato alla connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbProviderFactory Factory { get; }
Public ReadOnly Property Factory As DbProviderFactory
    Get
public:
property DbProviderFactory^ Factory {
    DbProviderFactory^ get ();
}
member Factory : DbProviderFactory with get

Valore della proprietà

DbProviderFactory
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.IsSql

Proprietà QSConnectionIsSql
Metodo che ritorna True se il providerName corrisponde a quello di SqlServer, False altrimenti.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSql { get; }
Public ReadOnly Property IsSql As Boolean
    Get
public:
property bool IsSql {
    bool get ();
}
member IsSql : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.IsSqlCE

Proprietà QSConnectionIsSqlCE
Metodo che ritorna True se il providerName corrisponde a quello di SqlServerCE, False altrimenti.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSqlCE { get; }
Public ReadOnly Property IsSqlCE As Boolean
    Get
public:
property bool IsSqlCE {
    bool get ();
}
member IsSqlCE : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.IsTransactionAborted

Proprietà QSConnectionIsTransactionAborted
Indica se ci sono stati errori nella transazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTransactionAborted { get; }
Public ReadOnly Property IsTransactionAborted As Boolean
    Get
public:
property bool IsTransactionAborted {
    bool get ();
}
member IsTransactionAborted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.IsTransactionOpened

Proprietà QSConnectionIsTransactionOpened
Restiruisce true se la transazione è aperta.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTransactionOpened { get; }
Public ReadOnly Property IsTransactionOpened As Boolean
    Get
public:
property bool IsTransactionOpened {
    bool get ();
}
member IsTransactionOpened : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.LastError

Proprietà QSConnectionLastError
Restituisce l'ultimo errore registrato dalle funzioni di questa classe o stringa vuota se non ce ne sono stati.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string LastError { get; }
Public ReadOnly Property LastError As String
    Get
public:
property String^ LastError {
    String^ get ();
}
member LastError : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.LastException

Proprietà QSConnectionLastException
Restituisce l'ultima eccezione verificatasi nel codice di questo oggetto oppure negli oggetti comando creati da questa connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}
member LastException : Exception with get

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.ProviderName

Proprietà QSConnectionProviderName
Restituisce il nome invariante del provider.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ProviderName { get; }
Public ReadOnly Property ProviderName As String
    Get
public:
property String^ ProviderName {
    String^ get ();
}
member ProviderName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.RemoveQuote

Proprietà QSConnectionRemoveQuote
Imposta/Restituisce se rimuovere le [] dai nomi colonne/tabelle

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RemoveQuote { get; set; }
Public Property RemoveQuote As Boolean
    Get
    Set
public:
property bool RemoveQuote {
    bool get ();
    void set (bool value);
}
member RemoveQuote : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.RemoveSemicolon

Proprietà QSConnectionRemoveSemicolon
Imposta/Restituisce se rimuovere il ; dalla fine delle query

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RemoveSemicolon { get; set; }
Public Property RemoveSemicolon As Boolean
    Get
    Set
public:
property bool RemoveSemicolon {
    bool get ();
    void set (bool value);
}
member RemoveSemicolon : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnection


Proprietà QSConnection.Transaction

Proprietà QSConnectionTransaction
Restituisce l'oggetto DbTransaction correntemente in uso oppure null se non sono in atto transazioni.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbTransaction Transaction { get; }
Public ReadOnly Property Transaction As DbTransaction
    Get
public:
property DbTransaction^ Transaction {
    DbTransaction^ get ();
}
member Transaction : DbTransaction with get

Valore della proprietà

DbTransaction
Vedi anche

Documentazione

Classe QSConnection


Metodi di QSConnection

Il tipo QSConnection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AdjustParameter | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@'. Sostituisce ' ' con '_'.
Metodo pubblico | AdjustParameterQuery | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@'. Sostituisce ' ' con '_'.
Metodo pubblico | AdjustWhereParameter | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@' e che sicuramente termini con "WHERE" in modo da essere differenziato dagli altri parametri. Sostituisce ' ' con '_'.
Metodo pubblico | AdjustWhereParameterQuery | Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@' e che sicuramente termini con "WHERE" in modo da essere differenziato dagli altri parametri. Sostituisce ' ' con '_'.
Metodo pubblico | BeginTransaction | Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.
Metodo pubblico | BeginTransaction(IsolationLevel) | Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.
Metodo pubblico | CloseConnection | Decrementa il numero di richieste di apertura della connessione al Database oppure chiude effettivamente la connessione se si tratta dell'ultima richiesta. DEVE SEMPRE ESSERE USATA IN ACCOPPIAMENTO A OpenConnection() e chiamata solo se questa ha esito positivo.
Metodo pubblico | ColumnExists | Funzione che controlla l'esistenza di una colonna, restituisce true se esiste altimenti false.
Metodo pubblico | CreateAddFieldCommand | Crea e restituisce un comando di ADD di un insieme di campi.
Metodo pubblico | CreateAddTableCommand | Crea e restituisce un comando di CREATE di una tabella.
Metodo pubblico | CreateBackupCommand | Crea e restituisce un comando di creazione BACKUP del database
Metodo pubblico | CreateConnOpCloser | Restituisce un nuovo oggetto che, racchiuso dentro una clausola using, consente di aprire e chiudere in automatico la connessione al Database.
Metodo pubblico | CreateConstraintCommand | Crea e restituisce un comando di CREATE PRIMARY KEY.
Metodo pubblico | CreateDeleteCommand | Crea e restituisce un comando di DELETE.
Metodo pubblico | CreateDropConstraintCommand | Crea e restituisce un comando di DROP di una chiave primaria.
Metodo pubblico | CreateDropFieldCommand | Crea e restituisce un comando di DROP di un insieme di campi.
Metodo pubblico | CreateDropIndexCommand | Crea e restituisce un comando di DROP di una chiave primaria.
Metodo pubblico | CreateDropTableCommand | Crea e restituisce un comando di DROP di una tabella.
Metodo pubblico | CreateIndexCommand(String, String, Boolean) | Crea e restituisce un comando di CREATE INDEX.
Metodo pubblico | CreateIndexCommand(String, String, Boolean, Boolean) | Crea e restituisce un comando di CREATE INDEX.
Metodo pubblico | CreateInsertCommand | Crea e restituisce un comando di esecuzione INSERT.
Metodo pubblico | CreateRebuildIndexCommand |
Metodo pubblico | CreateSelectCommand | Crea e restituisce un comando di esecuzione SELECT.
Metodo pubblico | CreateSqlBetweenOperator | Costruisce un operatore BETWEEN che lega tre elementi. Es: (A BETWEEN B AND C).
Metodo pubblico | CreateSqlBinaryOperator(SqlBinaryOperatorEnum) | Costruisce un solo operatore binario.
Metodo pubblico | CreateSqlBinaryOperator(ISqlStatement, SqlBinaryOperatorEnum, ISqlStatement) | Costruisce un operatore binario che lega due elementi SQL.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean, Object) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean, Object, Int32, Int32) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlField | Crea un oggetto descrivente il nome di un campo da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunction(String, String) | Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunction(String, String, String) | Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunctionString | Crea un oggetto descrivente una funzione di REPLACE da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlInQuery | Crea una sottoquery in forma: "CAMPO IN ('valore1','valore2',....)".
Metodo pubblico | CreateSqlJoinQuery(SqlJoinEnum, String) | Crea una sintassi per il Join. Esempio : INNER JOIN tableName
Metodo pubblico | CreateSqlJoinQuery(SqlJoinEnum, QSSelectCommand, String) | Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias
Metodo pubblico | CreateSqlLikeOperator(ISqlStatement, String) | Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Metodo pubblico | CreateSqlLikeOperator(ISqlStatement, String, Char) | Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Metodo pubblico | CreateSqlLiteral | Costruisce un elemento costituito da una espressione testuale libera non vuota.
Metodo pubblico | CreateSqlSubQuery | Crea una sottoquery in forma: "CAMPO IN (SELECT ....)".
Metodo pubblico | CreateSqlUnaryOperator | Costruisce un operatore unario legato ad un elemento SQL. Es: "NOT (...)", "CAMPO IS NULL".
Metodo pubblico | CreateUpdateCommand | Crea e restituisce un comando di esecuzione UPDATE.
Metodo pubblico | CreateUpdateFieldCommand | Crea e restituisce un comando di ALTER di un insieme di campi.
Metodo pubblico | CreateUpdateInsertCommand | Crea e restituisce un comando di esecuzione UPDATE se riesce altrimenti effettua INSERT.
Metodo pubblico | Dispose |
Metodo protetto | Dispose(Boolean) |
Metodo pubblico | EndTransaction | Termina la transazione in atto effettuando opzionalmente il Rollback(). QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A BeginTransaction().
Metodo protetto | Finalize | (Sovrascrive ObjectFinalize)
Metodo pubblico | GetBackupTables | Restituisce i nomi delle tabelle di backup ordinate.
Metodo pubblico | GetIdentityColumnForDboSchema | Metodo che ritorna la lista delle colonne 'Identity' associate allo schema dbo
Metodo pubblico | GetIndexesInfo | Restituisce un dizionari con il nome della chiave e la lista di tutte le colonne che la compongono.
Metodo pubblico | GetNETType | Metodo che in base al tipo di dato passato in ingresso, ritorna la relativa controparte .NET
Metodo pubblico | GetPrimaryKeyInfo | Restituisce un dizionari con il nome della chiave e la lista di tutte le colonne che la compongono.
Metodo pubblico | GetRowGuidColumns | Restituisce le colonne utilizzare dalla Replica come RowGuid.
Metodo pubblico | GetTableFieldsList | Restituisce la lista dei nomi dei campi di una determinata table, in maiuscolo. Restituisce null se la table non esiste.
Metodo pubblico | GetTables | Restituisce i nomi delle tabelle presenti nel DB esculdento i BK_.
Metodo pubblico | IndexExist | Restituisce true se l'indice esiste nella tabella altrimenti false.
Metodo pubblico | IsValidConnection | Restituisce true se riesce a connettersi altrimenti false.
Metodo pubblico | MakeFieldList | Restituisce la lista dei nomi dei campi concatenati con una virgola e racchiusi dalle quadre (o dal carattere utilizzato dal Database al quale si è connessi). Es.: " [DED_DIS], [DED_COD] ". I valori di default per il prefisso ed il suffisso sono il singolo spazio ' '.
Metodo pubblico | MakeFieldValueList | Restituisce una stringa contenente le coppie nome = valore per l'istruzione UPDATE, concatenati con una virgola e racchiusi dalle quadre (o dal carattere utilizzato dal Database al quale si è connessi). Es.: " [DED_DIS] = '12646545', [DED_COD] = '12646545' ". O meglio : " [DED_DIS] = @DED_DIS, [DED_COD] = @DED_COD ". La stringa restituita ha uno spazio all'inizio ed uno alla fine.
Metodo pubblico | MakeValueList | Restituisce una stringa contenente la lista dei parametri concatenati concatenati con una virgola. Es.: "@Param1, @Param2, Param3". La stringa restituita non ha spazi all'inizio e alla fine.
Metodo pubblico | OpenConnection | Si assicura che la connessione al Database sia aperta. Se risulta già aperta incrementa il numero di richieste di apertura. DEVE SEMPRE ESSERE USATA IN ACCOPPIAMENTO A ColseConnection() che deve essere chiamata solo se questa funzione ha avuto successo.
Metodo pubblico | PerformDuplicatSchemaTable(String, String) |
Metodo pubblico | PerformDuplicatSchemaTable(String, String, Boolean, Boolean) |
Metodo pubblico | PerformTableBackup |
Metodo pubblico | QuoteIdentifier | Restituisce la stringa racchiusa tra parentesi quadre '[]' o comunque tra i corretti identificatori.
Metodo pubblico | QuoteLikeWildechars(String) | Restituisce la stringa con quotati i caratteri speciali del LIKE, come '%' e '_'.
Metodo pubblico | QuoteLikeWildechars(String, Char) | Restituisce la stringa con quotati con il valore di escape passato, come '%' e '_'.
Metodo pubblico | Select | Effettua una query e restituisce il risultato sotto forma di tabella lua
Metodo pubblico | SelectTxt | Effettua una query e restituisce il risultato sotto forma di tabella lua
Metodo pubblico | TableExists | Funzione che controlla l'esistenza di una tabella, restituisce true se esiste altimenti false.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.AdjustParameter

Metodo QSConnectionAdjustParameter
Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@'. Sostituisce ' ' con '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AdjustParameter(
    string paramName
)
Public Function AdjustParameter (
    paramName As String
) As String
public:
String^ AdjustParameter(
    String^ paramName
)
member AdjustParameter :
        paramName : string -> string

Parametri

paramName String
Nome da sistemare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.AdjustParameterQuery

Metodo QSConnectionAdjustParameterQuery
Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@'. Sostituisce ' ' con '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AdjustParameterQuery(
    string paramName
)
Public Function AdjustParameterQuery (
    paramName As String
) As String
public:
String^ AdjustParameterQuery(
    String^ paramName
)
member AdjustParameterQuery :
        paramName : string -> string

Parametri

paramName String
Nome da sistemare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.AdjustWhereParameter

Metodo QSConnectionAdjustWhereParameter
Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@' e che sicuramente termini con "WHERE" in modo da essere differenziato dagli altri parametri. Sostituisce ' ' con '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AdjustWhereParameter(
    string paramName
)
Public Function AdjustWhereParameter (
    paramName As String
) As String
public:
String^ AdjustWhereParameter(
    String^ paramName
)
member AdjustWhereParameter :
        paramName : string -> string

Parametri

paramName String
Nome da sistemare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.AdjustWhereParameterQuery

Metodo QSConnectionAdjustWhereParameterQuery
Restituisce il nome del parametro in modo che sicuramente abbia davanti la chiocciola '@' e che sicuramente termini con "WHERE" in modo da essere differenziato dagli altri parametri. Sostituisce ' ' con '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AdjustWhereParameterQuery(
    string paramName
)
Public Function AdjustWhereParameterQuery (
    paramName As String
) As String
public:
String^ AdjustWhereParameterQuery(
    String^ paramName
)
member AdjustWhereParameterQuery :
        paramName : string -> string

Parametri

paramName String
Nome da sistemare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.BeginTransaction

Metodo QSConnectionBeginTransaction
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | BeginTransaction | Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.
Metodo pubblico | BeginTransaction(IsolationLevel) | Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.BeginTransaction

Metodo QSConnectionBeginTransaction
Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbTransaction BeginTransaction()
Public Function BeginTransaction As DbTransaction
public:
DbTransaction^ BeginTransaction()
member BeginTransaction : unit -> DbTransaction

Valore di ritorno

DbTransaction
Vedi anche

Documentazione

Classe QSConnection
Overload di BeginTransaction


Metodo QSConnection.BeginTransaction(IsolationLevel)

Metodo QSConnectionBeginTransaction(IsolationLevel)
Restituisce una nuova transazione se non ne esiste nessuna oppure quella che è in atto. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndTransaction() e si deve chiamare solo dopo aver aperto la connession con OpenConnection() altrimenti restituisce null.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbTransaction BeginTransaction(
    IsolationLevel isolationLevel
)
Public Function BeginTransaction (
    isolationLevel As IsolationLevel
) As DbTransaction
public:
DbTransaction^ BeginTransaction(
    IsolationLevel isolationLevel
)
member BeginTransaction :
        isolationLevel : IsolationLevel -> DbTransaction

Parametri

isolationLevel IsolationLevel

Valore di ritorno

DbTransaction
Vedi anche

Documentazione

Classe QSConnection
Overload di BeginTransaction


Metodo QSConnection.CloseConnection

Metodo QSConnectionCloseConnection
Decrementa il numero di richieste di apertura della connessione al Database oppure chiude effettivamente la connessione se si tratta dell'ultima richiesta. DEVE SEMPRE ESSERE USATA IN ACCOPPIAMENTO A OpenConnection() e chiamata solo se questa ha esito positivo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CloseConnection()
Public Sub CloseConnection
public:
void CloseConnection()
member CloseConnection : unit -> unit
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.ColumnExists

Metodo QSConnectionColumnExists
Funzione che controlla l'esistenza di una colonna, restituisce true se esiste altimenti false.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ColumnExists(
    string tablename,
    string columnname
)
Public Function ColumnExists (
    tablename As String,
    columnname As String
) As Boolean
public:
bool ColumnExists(
    String^ tablename,
    String^ columnname
)
member ColumnExists :
        tablename : string *
        columnname : string -> bool

Parametri

tablename String
Nome della tabella.
columnname String
Nome della colonna da cercare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateAddFieldCommand

Metodo QSConnectionCreateAddFieldCommand
Crea e restituisce un comando di ADD di un insieme di campi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsCreateFieldCommand CreateAddFieldCommand(
    string tableName
)
Public Function CreateAddFieldCommand (
    tableName As String
) As QsCreateFieldCommand
public:
QsCreateFieldCommand^ CreateAddFieldCommand(
    String^ tableName
)
member CreateAddFieldCommand :
        tableName : string -> QsCreateFieldCommand

Parametri

tableName String
Nome della table sulla quale eseguire l'ADD di un insime di campi.

Valore di ritorno

QsCreateFieldCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateAddTableCommand

Metodo QSConnectionCreateAddTableCommand
Crea e restituisce un comando di CREATE di una tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsCreateTableCommand CreateAddTableCommand(
    string tableName
)
Public Function CreateAddTableCommand (
    tableName As String
) As QsCreateTableCommand
public:
QsCreateTableCommand^ CreateAddTableCommand(
    String^ tableName
)
member CreateAddTableCommand :
        tableName : string -> QsCreateTableCommand

Parametri

tableName String
Nome della table sulla quale eseguire la creazione.

Valore di ritorno

QsCreateTableCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateBackupCommand

Metodo QSConnectionCreateBackupCommand
Crea e restituisce un comando di creazione BACKUP del database

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsCreateBackupCommand CreateBackupCommand(
    string filename
)
Public Function CreateBackupCommand (
    filename As String
) As QsCreateBackupCommand
public:
QsCreateBackupCommand^ CreateBackupCommand(
    String^ filename
)
member CreateBackupCommand :
        filename : string -> QsCreateBackupCommand

Parametri

filename String
Nome file out di backup

Valore di ritorno

QsCreateBackupCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateConnOpCloser

Metodo QSConnectionCreateConnOpCloser
Restituisce un nuovo oggetto che, racchiuso dentro una clausola using, consente di aprire e chiudere in automatico la connessione al Database.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConnOpCloser CreateConnOpCloser()
Public Function CreateConnOpCloser As ConnOpCloser
public:
ConnOpCloser^ CreateConnOpCloser()
member CreateConnOpCloser : unit -> ConnOpCloser

Valore di ritorno

ConnOpCloser
Restituisce un nuovo oggetto ConnOpCloser.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateConstraintCommand

Metodo QSConnectionCreateConstraintCommand
Crea e restituisce un comando di CREATE PRIMARY KEY.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsCreateConstraintCommand CreateConstraintCommand(
    string tableName,
    string nomeChiave
)
Public Function CreateConstraintCommand (
    tableName As String,
    nomeChiave As String
) As QsCreateConstraintCommand
public:
QsCreateConstraintCommand^ CreateConstraintCommand(
    String^ tableName,
    String^ nomeChiave
)
member CreateConstraintCommand :
        tableName : string *
        nomeChiave : string -> QsCreateConstraintCommand

Parametri

tableName String
Nome della table sulla quale creare un indice di un insieme di campi.
nomeChiave String

Valore di ritorno

QsCreateConstraintCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateDeleteCommand

Metodo QSConnectionCreateDeleteCommand
Crea e restituisce un comando di DELETE.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSDeleteCommand CreateDeleteCommand(
    string tableName
)
Public Function CreateDeleteCommand (
    tableName As String
) As QSDeleteCommand
public:
QSDeleteCommand^ CreateDeleteCommand(
    String^ tableName
)
member CreateDeleteCommand :
        tableName : string -> QSDeleteCommand

Parametri

tableName String
Nome della table sulla quale eseguire il DELETE.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateDropConstraintCommand

Metodo QSConnectionCreateDropConstraintCommand
Crea e restituisce un comando di DROP di una chiave primaria.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsDropConstraintCommand CreateDropConstraintCommand(
    string tableName,
    string nomeChiave
)
Public Function CreateDropConstraintCommand (
    tableName As String,
    nomeChiave As String
) As QsDropConstraintCommand
public:
QsDropConstraintCommand^ CreateDropConstraintCommand(
    String^ tableName,
    String^ nomeChiave
)
member CreateDropConstraintCommand :
        tableName : string *
        nomeChiave : string -> QsDropConstraintCommand

Parametri

tableName String
Nome della table sulla quale eseguire il DROP di un insime di campi.
nomeChiave String

Valore di ritorno

QsDropConstraintCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateDropFieldCommand

Metodo QSConnectionCreateDropFieldCommand
Crea e restituisce un comando di DROP di un insieme di campi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsDropFieldCommand CreateDropFieldCommand(
    string tableName
)
Public Function CreateDropFieldCommand (
    tableName As String
) As QsDropFieldCommand
public:
QsDropFieldCommand^ CreateDropFieldCommand(
    String^ tableName
)
member CreateDropFieldCommand :
        tableName : string -> QsDropFieldCommand

Parametri

tableName String
Nome della table sulla quale eseguire il DROP di un insime di campi.

Valore di ritorno

QsDropFieldCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateDropIndexCommand

Metodo QSConnectionCreateDropIndexCommand
Crea e restituisce un comando di DROP di una chiave primaria.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsDropIndexCommand CreateDropIndexCommand(
    string tableName,
    string nomeIndice
)
Public Function CreateDropIndexCommand (
    tableName As String,
    nomeIndice As String
) As QsDropIndexCommand
public:
QsDropIndexCommand^ CreateDropIndexCommand(
    String^ tableName,
    String^ nomeIndice
)
member CreateDropIndexCommand :
        tableName : string *
        nomeIndice : string -> QsDropIndexCommand

Parametri

tableName String
Nome della table sulla quale eseguire il DROP di un insime di campi.
nomeIndice String

Valore di ritorno

QsDropIndexCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateDropTableCommand

Metodo QSConnectionCreateDropTableCommand
Crea e restituisce un comando di DROP di una tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsDropTableCommand CreateDropTableCommand(
    string tableName
)
Public Function CreateDropTableCommand (
    tableName As String
) As QsDropTableCommand
public:
QsDropTableCommand^ CreateDropTableCommand(
    String^ tableName
)
member CreateDropTableCommand :
        tableName : string -> QsDropTableCommand

Parametri

tableName String
Nome della table sulla quale eseguire il DROP.

Valore di ritorno

QsDropTableCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateIndexCommand

Metodo QSConnectionCreateIndexCommand
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateIndexCommand(String, String, Boolean) | Crea e restituisce un comando di CREATE INDEX.
Metodo pubblico | CreateIndexCommand(String, String, Boolean, Boolean) | Crea e restituisce un comando di CREATE INDEX.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateIndexCommand(String, String, Boolean)

Metodo QSConnectionCreateIndexCommand(String, String, Boolean)
Crea e restituisce un comando di CREATE INDEX.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsCreateIndexCommand CreateIndexCommand(
    string tableName,
    string nomeIndice,
    bool unique
)
Public Function CreateIndexCommand (
    tableName As String,
    nomeIndice As String,
    unique As Boolean
) As QsCreateIndexCommand
public:
QsCreateIndexCommand^ CreateIndexCommand(
    String^ tableName,
    String^ nomeIndice,
    bool unique
)
member CreateIndexCommand :
        tableName : string *
        nomeIndice : string *
        unique : bool -> QsCreateIndexCommand

Parametri

tableName String
Nome della table sulla quale creare un indice di un insieme di campi.
nomeIndice String
unique Boolean

Valore di ritorno

QsCreateIndexCommand
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateIndexCommand


Metodo QSConnection.CreateIndexCommand(String, String, Boolean, Boolean)

Metodo QSConnectionCreateIndexCommand(String, String, Boolean, Boolean)
Crea e restituisce un comando di CREATE INDEX.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsCreateIndexCommand CreateIndexCommand(
    string tableName,
    string nomeIndice,
    bool unique,
    bool clustered
)
Public Function CreateIndexCommand (
    tableName As String,
    nomeIndice As String,
    unique As Boolean,
    clustered As Boolean
) As QsCreateIndexCommand
public:
QsCreateIndexCommand^ CreateIndexCommand(
    String^ tableName,
    String^ nomeIndice,
    bool unique,
    bool clustered
)
member CreateIndexCommand :
        tableName : string *
        nomeIndice : string *
        unique : bool *
        clustered : bool -> QsCreateIndexCommand

Parametri

tableName String
Nome della table sulla quale creare un indice di un insieme di campi.
nomeIndice String
unique Boolean
clustered Boolean

Valore di ritorno

QsCreateIndexCommand
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateIndexCommand


Metodo QSConnection.CreateInsertCommand

Metodo QSConnectionCreateInsertCommand
Crea e restituisce un comando di esecuzione INSERT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSInsertCommand CreateInsertCommand(
    string tableName
)
Public Function CreateInsertCommand (
    tableName As String
) As QSInsertCommand
public:
QSInsertCommand^ CreateInsertCommand(
    String^ tableName
)
member CreateInsertCommand :
        tableName : string -> QSInsertCommand

Parametri

tableName String
Nome della table sulla quale eseguire l'INSERT.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateRebuildIndexCommand

Metodo QSConnectionCreateRebuildIndexCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsRebuildIndexCommand CreateRebuildIndexCommand()
Public Function CreateRebuildIndexCommand As QsRebuildIndexCommand
public:
QsRebuildIndexCommand^ CreateRebuildIndexCommand()
member CreateRebuildIndexCommand : unit -> QsRebuildIndexCommand

Valore di ritorno

QsRebuildIndexCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSelectCommand

Metodo QSConnectionCreateSelectCommand
Crea e restituisce un comando di esecuzione SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSelectCommand CreateSelectCommand(
    string tableName
)
Public Function CreateSelectCommand (
    tableName As String
) As QSSelectCommand
public:
QSSelectCommand^ CreateSelectCommand(
    String^ tableName
)
member CreateSelectCommand :
        tableName : string -> QSSelectCommand

Parametri

tableName String
Nome della table sulla quale eseguire la SELECT.

Valore di ritorno

QSSelectCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlBetweenOperator

Metodo QSConnectionCreateSqlBetweenOperator
Costruisce un operatore BETWEEN che lega tre elementi. Es: (A BETWEEN B AND C).

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlBetweenOperator CreateSqlBetweenOperator(
    ISqlStatement subject,
    ISqlStatement minValue,
    ISqlStatement maxValue
)
Public Function CreateSqlBetweenOperator (
    subject As ISqlStatement,
    minValue As ISqlStatement,
    maxValue As ISqlStatement
) As QSSqlBetweenOperator
public:
QSSqlBetweenOperator^ CreateSqlBetweenOperator(
    ISqlStatement^ subject,
    ISqlStatement^ minValue,
    ISqlStatement^ maxValue
)
member CreateSqlBetweenOperator :
        subject : ISqlStatement *
        minValue : ISqlStatement *
        maxValue : ISqlStatement -> QSSqlBetweenOperator

Parametri

subject ISqlStatement
Soggetto da valutare nell'espressione.
minValue ISqlStatement
Valore minimo di comparazione.
maxValue ISqlStatement
Valore massimo di comparazione.

Valore di ritorno

QSSqlBetweenOperator
Restituisce l'oggetto descrivente l'elemento BETWEEN.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlBinaryOperator

Metodo QSConnectionCreateSqlBinaryOperator
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateSqlBinaryOperator(SqlBinaryOperatorEnum) | Costruisce un solo operatore binario.
Metodo pubblico | CreateSqlBinaryOperator(ISqlStatement, SqlBinaryOperatorEnum, ISqlStatement) | Costruisce un operatore binario che lega due elementi SQL.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlBinaryOperator(SqlBinaryOperatorEnum)

Metodo QSConnectionCreateSqlBinaryOperator(SqlBinaryOperatorEnum)
Costruisce un solo operatore binario.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlBinaryOperator CreateSqlBinaryOperator(
    SqlBinaryOperatorEnum op
)
Public Function CreateSqlBinaryOperator (
    op As SqlBinaryOperatorEnum
) As QSSqlBinaryOperator
public:
QSSqlBinaryOperator^ CreateSqlBinaryOperator(
    SqlBinaryOperatorEnum op
)
member CreateSqlBinaryOperator :
        op : SqlBinaryOperatorEnum -> QSSqlBinaryOperator

Parametri

op SqlBinaryOperatorEnum
Operatore binario.

Valore di ritorno

QSSqlBinaryOperator
Restituisce l'oggetto descrivente l'operatore binario.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlBinaryOperator


Metodo QSConnection.CreateSqlBinaryOperator(ISqlStatement, SqlBinaryOperatorEnum, ISqlStatement)

Metodo QSConnectionCreateSqlBinaryOperator(ISqlStatement, SqlBinaryOperatorEnum, ISqlStatement)
Costruisce un operatore binario che lega due elementi SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlBinaryOperator CreateSqlBinaryOperator(
    ISqlStatement left,
    SqlBinaryOperatorEnum op,
    ISqlStatement right
)
Public Function CreateSqlBinaryOperator (
    left As ISqlStatement,
    op As SqlBinaryOperatorEnum,
    right As ISqlStatement
) As QSSqlBinaryOperator
public:
QSSqlBinaryOperator^ CreateSqlBinaryOperator(
    ISqlStatement^ left,
    SqlBinaryOperatorEnum op,
    ISqlStatement^ right
)
member CreateSqlBinaryOperator :
        left : ISqlStatement *
        op : SqlBinaryOperatorEnum *
        right : ISqlStatement -> QSSqlBinaryOperator

Parametri

left ISqlStatement
Elemento alla sinistra dell'operatore.
op SqlBinaryOperatorEnum
Operatore binario.
right ISqlStatement
Elemento alla destra dell'operatore.

Valore di ritorno

QSSqlBinaryOperator
Restituisce l'oggetto descrivente due elementi legati da un operatore binario.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlBinaryOperator


Metodo QSConnection.CreateSqlColumnField

Metodo QSConnectionCreateSqlColumnField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean, Object) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Metodo pubblico | CreateSqlColumnField(String, Type, Int32, Boolean, Object, Int32, Int32) | Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlColumnField(String, Type, Int32, Boolean)

Metodo QSConnectionCreateSqlColumnField(String, Type, Int32, Boolean)
Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlColumnField CreateSqlColumnField(
    string fieldName,
    Type dataType,
    int lunghezza,
    bool notNull
)
Public Function CreateSqlColumnField (
    fieldName As String,
    dataType As Type,
    lunghezza As Integer,
    notNull As Boolean
) As QSSqlColumnField
public:
QSSqlColumnField^ CreateSqlColumnField(
    String^ fieldName,
    Type^ dataType,
    int lunghezza,
    bool notNull
)
member CreateSqlColumnField :
        fieldName : string *
        dataType : Type *
        lunghezza : int *
        notNull : bool -> QSSqlColumnField

Parametri

fieldName String
Nome del campo.
dataType Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile

Valore di ritorno

QSSqlColumnField
Restituisce l'oggetto descrivente il nome di un campo
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlColumnField


Metodo QSConnection.CreateSqlColumnField(String, Type, Int32, Boolean, Object)

Metodo QSConnectionCreateSqlColumnField(String, Type, Int32, Boolean, Object)
Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlColumnField CreateSqlColumnField(
    string fieldName,
    Type dataType,
    int lunghezza,
    bool notNull,
    Object defVal
)
Public Function CreateSqlColumnField (
    fieldName As String,
    dataType As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object
) As QSSqlColumnField
public:
QSSqlColumnField^ CreateSqlColumnField(
    String^ fieldName,
    Type^ dataType,
    int lunghezza,
    bool notNull,
    Object^ defVal
)
member CreateSqlColumnField :
        fieldName : string *
        dataType : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object -> QSSqlColumnField

Parametri

fieldName String
Nome del campo.
dataType Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object

Valore di ritorno

QSSqlColumnField
Restituisce l'oggetto descrivente il nome di un campo
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlColumnField


Metodo QSConnection.CreateSqlColumnField(String, Type, Int32, Boolean, Object, Int32, Int32)

Metodo QSConnectionCreateSqlColumnField(String, Type, Int32, Boolean, Object, Int32, Int32)
Crea un oggetto descrivente il campo da aggiungere/modificare in una tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlColumnField CreateSqlColumnField(
    string fieldName,
    Type dataType,
    int lunghezza,
    bool notNull,
    Object defVal,
    int identitySeed,
    int identityIncrement
)
Public Function CreateSqlColumnField (
    fieldName As String,
    dataType As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object,
    identitySeed As Integer,
    identityIncrement As Integer
) As QSSqlColumnField
public:
QSSqlColumnField^ CreateSqlColumnField(
    String^ fieldName,
    Type^ dataType,
    int lunghezza,
    bool notNull,
    Object^ defVal,
    int identitySeed,
    int identityIncrement
)
member CreateSqlColumnField :
        fieldName : string *
        dataType : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object *
        identitySeed : int *
        identityIncrement : int -> QSSqlColumnField

Parametri

fieldName String
Nome del campo.
dataType Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
identitySeed Int32
identityIncrement Int32

Valore di ritorno

QSSqlColumnField
Restituisce l'oggetto descrivente il nome di un campo
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlColumnField


Metodo QSConnection.CreateSqlField

Metodo QSConnectionCreateSqlField
Crea un oggetto descrivente il nome di un campo da utilizzare nelle istruzioni SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlField CreateSqlField(
    string fieldName
)
Public Function CreateSqlField (
    fieldName As String
) As QSSqlField
public:
QSSqlField^ CreateSqlField(
    String^ fieldName
)
member CreateSqlField :
        fieldName : string -> QSSqlField

Parametri

fieldName String
Nome del campo.

Valore di ritorno

QSSqlField
Restituisce l'oggetto descrivente il nome di un campo
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlFunction

Metodo QSConnectionCreateSqlFunction
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateSqlFunction(String, String) | Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.
Metodo pubblico | CreateSqlFunction(String, String, String) | Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlFunction(String, String)

Metodo QSConnectionCreateSqlFunction(String, String)
Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlFunction CreateSqlFunction(
    string fieldName,
    string funcName
)
Public Function CreateSqlFunction (
    fieldName As String,
    funcName As String
) As QSSqlFunction
public:
QSSqlFunction^ CreateSqlFunction(
    String^ fieldName,
    String^ funcName
)
member CreateSqlFunction :
        fieldName : string *
        funcName : string -> QSSqlFunction

Parametri

fieldName String
Nome del campo al quale applicare la funzione (se null viene utilizzato l'asterisco '*').
funcName String
Nome della funzione di aggragazione: COUNT, MAX, MIN, AVERAGE, SUM, ecc.

Valore di ritorno

QSSqlFunction
Restituisce l'oggetto descrivente una funzione di aggragazione.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlFunction


Metodo QSConnection.CreateSqlFunction(String, String, String)

Metodo QSConnectionCreateSqlFunction(String, String, String)
Crea un oggetto descrivente una funzione di aggragazione come COUNT, SUM, MAX, MIN, AVERAGE, da utilizzare nelle istruzioni SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlFunction CreateSqlFunction(
    string fieldName,
    string funcName,
    string asNome
)
Public Function CreateSqlFunction (
    fieldName As String,
    funcName As String,
    asNome As String
) As QSSqlFunction
public:
QSSqlFunction^ CreateSqlFunction(
    String^ fieldName,
    String^ funcName,
    String^ asNome
)
member CreateSqlFunction :
        fieldName : string *
        funcName : string *
        asNome : string -> QSSqlFunction

Parametri

fieldName String
Nome del campo al quale applicare la funzione (se null viene utilizzato l'asterisco '*').
funcName String
Nome della funzione di aggragazione: COUNT, MAX, MIN, AVERAGE, SUM, ecc.
asNome String

Valore di ritorno

QSSqlFunction
Restituisce l'oggetto descrivente una funzione di aggragazione.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlFunction


Metodo QSConnection.CreateSqlFunctionString

Metodo QSConnectionCreateSqlFunctionString
Crea un oggetto descrivente una funzione di REPLACE da utilizzare nelle istruzioni SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlFunctionReplace CreateSqlFunctionString(
    string fieldName,
    string funcName,
    string oldValue,
    string newValue
)
Public Function CreateSqlFunctionString (
    fieldName As String,
    funcName As String,
    oldValue As String,
    newValue As String
) As QSSqlFunctionReplace
public:
QSSqlFunctionReplace^ CreateSqlFunctionString(
    String^ fieldName,
    String^ funcName,
    String^ oldValue,
    String^ newValue
)
member CreateSqlFunctionString :
        fieldName : string *
        funcName : string *
        oldValue : string *
        newValue : string -> QSSqlFunctionReplace

Parametri

fieldName String
Nome del campo al quale applicare la funzione
funcName String
Nome della funzione
oldValue String
Valore da sostituire
newValue String
Valore di sostituzione

Valore di ritorno

QSSqlFunctionReplace
Restituisce l'oggetto descrivente una funzione di REPLACE.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlInQuery

Metodo QSConnectionCreateSqlInQuery
Crea una sottoquery in forma: "CAMPO IN ('valore1','valore2',....)".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlInQuery CreateSqlInQuery(
    string fieldName,
    bool inList,
    List<string> list
)
Public Function CreateSqlInQuery (
    fieldName As String,
    inList As Boolean,
    list As List(Of String)
) As QSSqlInQuery
public:
QSSqlInQuery^ CreateSqlInQuery(
    String^ fieldName,
    bool inList,
    List<String^>^ list
)
member CreateSqlInQuery :
        fieldName : string *
        inList : bool *
        list : List<string> -> QSSqlInQuery

Parametri

fieldName String
Nome del campo di cui verificare l'esistenza nella sotto-query.
inList Boolean
Inclusione.
list List String
Lista di stringhe da includere

Valore di ritorno

QSSqlInQuery
Restituisce una espressione sottoquery.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlJoinQuery

Metodo QSConnectionCreateSqlJoinQuery
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateSqlJoinQuery(SqlJoinEnum, String) | Crea una sintassi per il Join. Esempio : INNER JOIN tableName
Metodo pubblico | CreateSqlJoinQuery(SqlJoinEnum, QSSelectCommand, String) | Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlJoinQuery(SqlJoinEnum, String)

Metodo QSConnectionCreateSqlJoinQuery(SqlJoinEnum, String)
Crea una sintassi per il Join. Esempio : INNER JOIN tableName

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlJoinQuery CreateSqlJoinQuery(
    SqlJoinEnum joinType,
    string tableName
)
Public Function CreateSqlJoinQuery (
    joinType As SqlJoinEnum,
    tableName As String
) As QSSqlJoinQuery
public:
QSSqlJoinQuery^ CreateSqlJoinQuery(
    SqlJoinEnum joinType,
    String^ tableName
)
member CreateSqlJoinQuery :
        joinType : SqlJoinEnum *
        tableName : string -> QSSqlJoinQuery

Parametri

joinType SqlJoinEnum
Tipologia di Join
tableName String
Tabella sulla quale effettuare il Join

Valore di ritorno

QSSqlJoinQuery
Restituisce una espressione sottoquery.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlJoinQuery


Metodo QSConnection.CreateSqlJoinQuery(SqlJoinEnum, QSSelectCommand, String)

Metodo QSConnectionCreateSqlJoinQuery(SqlJoinEnum, QSSelectCommand, String)
Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlJoinQuery CreateSqlJoinQuery(
    SqlJoinEnum joinType,
    QSSelectCommand selcmd,
    string alias
)
Public Function CreateSqlJoinQuery (
    joinType As SqlJoinEnum,
    selcmd As QSSelectCommand,
    alias As String
) As QSSqlJoinQuery
public:
QSSqlJoinQuery^ CreateSqlJoinQuery(
    SqlJoinEnum joinType,
    QSSelectCommand^ selcmd,
    String^ alias
)
member CreateSqlJoinQuery :
        joinType : SqlJoinEnum *
        selcmd : QSSelectCommand *
        alias : string -> QSSqlJoinQuery

Parametri

joinType SqlJoinEnum
Tipologia di Join
selcmd QSSelectCommand
Select da usare come tabella di Join
alias String
Alias della select passata

Valore di ritorno

QSSqlJoinQuery
Restituisce una espressione sottoquery.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlJoinQuery


Metodo QSConnection.CreateSqlLikeOperator

Metodo QSConnectionCreateSqlLikeOperator
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateSqlLikeOperator(ISqlStatement, String) | Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Metodo pubblico | CreateSqlLikeOperator(ISqlStatement, String, Char) | Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlLikeOperator(ISqlStatement, String)

Metodo QSConnectionCreateSqlLikeOperator(ISqlStatement, String)
Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlLikeOperator CreateSqlLikeOperator(
    ISqlStatement subject,
    string value
)
Public Function CreateSqlLikeOperator (
    subject As ISqlStatement,
    value As String
) As QSSqlLikeOperator
public:
QSSqlLikeOperator^ CreateSqlLikeOperator(
    ISqlStatement^ subject,
    String^ value
)
member CreateSqlLikeOperator :
        subject : ISqlStatement *
        value : string -> QSSqlLikeOperator

Parametri

subject ISqlStatement
Soggetto da valutare nell'espressione.
value String
Stringa che deve essere valutata dal LIKE.

Valore di ritorno

QSSqlLikeOperator
Restituisce l'oggetto descrivente l'elemento LIKE.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlLikeOperator


Metodo QSConnection.CreateSqlLikeOperator(ISqlStatement, String, Char)

Metodo QSConnectionCreateSqlLikeOperator(ISqlStatement, String, Char)
Crea un operatore LIKE un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlLikeOperator CreateSqlLikeOperator(
    ISqlStatement subject,
    string value,
    char escapeValue
)
Public Function CreateSqlLikeOperator (
    subject As ISqlStatement,
    value As String,
    escapeValue As Char
) As QSSqlLikeOperator
public:
QSSqlLikeOperator^ CreateSqlLikeOperator(
    ISqlStatement^ subject,
    String^ value,
    wchar_t escapeValue
)
member CreateSqlLikeOperator :
        subject : ISqlStatement *
        value : string *
        escapeValue : char -> QSSqlLikeOperator

Parametri

subject ISqlStatement
Soggetto da valutare nell'espressione.
value String
Stringa che deve essere valutata dal LIKE.
escapeValue Char

Valore di ritorno

QSSqlLikeOperator
Restituisce l'oggetto descrivente l'elemento LIKE.
Vedi anche

Documentazione

Classe QSConnection
Overload di CreateSqlLikeOperator


Metodo QSConnection.CreateSqlLiteral

Metodo QSConnectionCreateSqlLiteral
Costruisce un elemento costituito da una espressione testuale libera non vuota.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlLiteral CreateSqlLiteral(
    string literal
)
Public Function CreateSqlLiteral (
    literal As String
) As QSSqlLiteral
public:
QSSqlLiteral^ CreateSqlLiteral(
    String^ literal
)
member CreateSqlLiteral :
        literal : string -> QSSqlLiteral

Parametri

literal String
Elemento da inserire.

Valore di ritorno

QSSqlLiteral
Restituisce l'oggetto descrivente il nome di un campo
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlSubQuery

Metodo QSConnectionCreateSqlSubQuery
Crea una sottoquery in forma: "CAMPO IN (SELECT ....)".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlSubQuery CreateSqlSubQuery(
    string fieldName,
    bool notIn,
    QSSelectCommand subCmd
)
Public Function CreateSqlSubQuery (
    fieldName As String,
    notIn As Boolean,
    subCmd As QSSelectCommand
) As QSSqlSubQuery
public:
QSSqlSubQuery^ CreateSqlSubQuery(
    String^ fieldName,
    bool notIn,
    QSSelectCommand^ subCmd
)
member CreateSqlSubQuery :
        fieldName : string *
        notIn : bool *
        subCmd : QSSelectCommand -> QSSqlSubQuery

Parametri

fieldName String
Nome del campo di cui verificare l'esistenza nella sotto-query.
notIn Boolean
Negazione dell'inclusione.
subCmd QSSelectCommand
Comando select da utilizzare per la sotto-query.

Valore di ritorno

QSSqlSubQuery
Restituisce una espressione sottoquery.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateSqlUnaryOperator

Metodo QSConnectionCreateSqlUnaryOperator
Costruisce un operatore unario legato ad un elemento SQL. Es: "NOT (...)", "CAMPO IS NULL".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlUnaryOperator CreateSqlUnaryOperator(
    ISqlStatement expression,
    SqlUnaryOperatorEnum op
)
Public Function CreateSqlUnaryOperator (
    expression As ISqlStatement,
    op As SqlUnaryOperatorEnum
) As QSSqlUnaryOperator
public:
QSSqlUnaryOperator^ CreateSqlUnaryOperator(
    ISqlStatement^ expression,
    SqlUnaryOperatorEnum op
)
member CreateSqlUnaryOperator :
        expression : ISqlStatement *
        op : SqlUnaryOperatorEnum -> QSSqlUnaryOperator

Parametri

expression ISqlStatement
Elemento da abbinare all'operatore.
op SqlUnaryOperatorEnum
Operatore unario.

Valore di ritorno

QSSqlUnaryOperator
Restituisce l'oggetto descrivente l'elemento legato all'operatore.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateUpdateCommand

Metodo QSConnectionCreateUpdateCommand
Crea e restituisce un comando di esecuzione UPDATE.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSUpdateCommand CreateUpdateCommand(
    string tableName
)
Public Function CreateUpdateCommand (
    tableName As String
) As QSUpdateCommand
public:
QSUpdateCommand^ CreateUpdateCommand(
    String^ tableName
)
member CreateUpdateCommand :
        tableName : string -> QSUpdateCommand

Parametri

tableName String
Nome della table sulla quale eseguire l'UPDATE.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateUpdateFieldCommand

Metodo QSConnectionCreateUpdateFieldCommand
Crea e restituisce un comando di ALTER di un insieme di campi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsUpdateFieldCommand CreateUpdateFieldCommand(
    string tableName
)
Public Function CreateUpdateFieldCommand (
    tableName As String
) As QsUpdateFieldCommand
public:
QsUpdateFieldCommand^ CreateUpdateFieldCommand(
    String^ tableName
)
member CreateUpdateFieldCommand :
        tableName : string -> QsUpdateFieldCommand

Parametri

tableName String
Nome della table sulla quale eseguire l'ALTER di un insieme di campi.

Valore di ritorno

QsUpdateFieldCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.CreateUpdateInsertCommand

Metodo QSConnectionCreateUpdateInsertCommand
Crea e restituisce un comando di esecuzione UPDATE se riesce altrimenti effettua INSERT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSUpdateInsertCommand CreateUpdateInsertCommand(
    string tableName
)
Public Function CreateUpdateInsertCommand (
    tableName As String
) As QSUpdateInsertCommand
public:
QSUpdateInsertCommand^ CreateUpdateInsertCommand(
    String^ tableName
)
member CreateUpdateInsertCommand :
        tableName : string -> QSUpdateInsertCommand

Parametri

tableName String
Nome della table sulla quale eseguire l'UPDATE/INSERT.

Valore di ritorno

QSUpdateInsertCommand
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.Dispose

Metodo QSConnectionDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Rilascia tutte le risorse utilizzate da QSConnection.
Metodo protetto | Dispose(Boolean) | Rilascia le risorse unmanaged usate da QSConnection e opzionalmente rilascia anche le risorse managed.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.Dispose

Metodo QSConnectionDispose
Rilascia tutte le risorse utilizzate da QSConnection.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe QSConnection
Overload di Dispose


Metodo QSConnection.Dispose(Boolean)

Metodo QSConnectionDispose(Boolean)
Rilascia le risorse unmanaged usate da QSConnection e opzionalmente rilascia anche le risorse managed.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
True per rilasciare sia le risorse managed che quelle unmanaged; false per rilasciare solo quelle unmanaged.
Vedi anche

Documentazione

Classe QSConnection
Overload di Dispose


Metodo QSConnection.EndTransaction

Metodo QSConnectionEndTransaction
Termina la transazione in atto effettuando opzionalmente il Rollback(). QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A BeginTransaction().

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EndTransaction(
    bool rollback
)
Public Sub EndTransaction (
    rollback As Boolean
)
public:
void EndTransaction(
    bool rollback
)
member EndTransaction :
        rollback : bool -> unit

Parametri

rollback Boolean
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.Finalize

Metodo QSConnectionFinalize

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
~Finalize()
Protected Overrides Sub Finalize
!Finalize()
abstract Finalize : unit -> unit
override Finalize : unit -> unit
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetBackupTables

Metodo QSConnectionGetBackupTables
Restituisce i nomi delle tabelle di backup ordinate.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetBackupTables()
Public Function GetBackupTables As List(Of String)
public:
List<String^>^ GetBackupTables()
member GetBackupTables : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetIdentityColumnForDboSchema

Metodo QSConnectionGetIdentityColumnForDboSchema
Metodo che ritorna la lista delle colonne 'Identity' associate allo schema dbo

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, List<string>> GetIdentityColumnForDboSchema(
    QSConnection conn
)
Public Function GetIdentityColumnForDboSchema (
    conn As QSConnection
) As Dictionary(Of String, List(Of String))
public:
Dictionary<String^, List<String^>^>^ GetIdentityColumnForDboSchema(
    QSConnection^ conn
)
member GetIdentityColumnForDboSchema :
        conn : QSConnection -> Dictionary<string, List<string>>

Parametri

conn QSConnection
Connessione al database.

Valore di ritorno

Dictionary String, List String
Lista delle colonne trovate.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetIndexesInfo

Metodo QSConnectionGetIndexesInfo
Restituisce un dizionari con il nome della chiave e la lista di tutte le colonne che la compongono.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, QSConnectionIndexProperty> GetIndexesInfo(
    string TableName
)
Public Function GetIndexesInfo (
    TableName As String
) As Dictionary(Of String, QSConnectionIndexProperty)
public:
Dictionary<String^, QSConnectionIndexProperty^>^ GetIndexesInfo(
    String^ TableName
)
member GetIndexesInfo :
        TableName : string -> Dictionary<string, QSConnectionIndexProperty>

Parametri

TableName String
Nome della tabella.

Valore di ritorno

Dictionary String, QSConnectionIndexProperty
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetNETType

Metodo QSConnectionGetNETType
Metodo che in base al tipo di dato passato in ingresso, ritorna la relativa controparte .NET

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Type GetNETType(
    string sqlType
)
Public Function GetNETType (
    sqlType As String
) As Type
public:
Type^ GetNETType(
    String^ sqlType
)
member GetNETType :
        sqlType : string -> Type

Parametri

sqlType String
Tipo di dato presente nel database.

Valore di ritorno

Type
Tipo di dato .NET
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetPrimaryKeyInfo

Metodo QSConnectionGetPrimaryKeyInfo
Restituisce un dizionari con il nome della chiave e la lista di tutte le colonne che la compongono.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, List<string>> GetPrimaryKeyInfo(
    string TableName
)
Public Function GetPrimaryKeyInfo (
    TableName As String
) As Dictionary(Of String, List(Of String))
public:
Dictionary<String^, List<String^>^>^ GetPrimaryKeyInfo(
    String^ TableName
)
member GetPrimaryKeyInfo :
        TableName : string -> Dictionary<string, List<string>>

Parametri

TableName String
Nome della tabella.

Valore di ritorno

Dictionary String, List String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetRowGuidColumns

Metodo QSConnectionGetRowGuidColumns
Restituisce le colonne utilizzare dalla Replica come RowGuid.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetRowGuidColumns(
    string TableName
)
Public Function GetRowGuidColumns (
    TableName As String
) As List(Of String)
public:
List<String^>^ GetRowGuidColumns(
    String^ TableName
)
member GetRowGuidColumns :
        TableName : string -> List<string>

Parametri

TableName String
Nome della tabella.

Valore di ritorno

List String
I nomi dei campi sono inseriti nella lista in maiuscolo.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetTableFieldsList

Metodo QSConnectionGetTableFieldsList
Restituisce la lista dei nomi dei campi di una determinata table, in maiuscolo. Restituisce null se la table non esiste.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetTableFieldsList(
    string TableName
)
Public Function GetTableFieldsList (
    TableName As String
) As List(Of String)
public:
List<String^>^ GetTableFieldsList(
    String^ TableName
)
member GetTableFieldsList :
        TableName : string -> List<string>

Parametri

TableName String

Valore di ritorno

List String
Note
I nomi dei campi sono inseriti nella lista in maiuscolo.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.GetTables

Metodo QSConnectionGetTables
Restituisce i nomi delle tabelle presenti nel DB esculdento i BK_.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetTables(
    bool includeBck = false
)
Public Function GetTables (
    Optional includeBck As Boolean = false
) As List(Of String)
public:
List<String^>^ GetTables(
    bool includeBck = false
)
member GetTables :
        ?includeBck : bool
(* Defaults:
        let _includeBck = defaultArg includeBck false
*)
-> List<string>

Parametri

includeBck Boolean (Optional)

Valore di ritorno

List String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.IndexExist

Metodo QSConnectionIndexExist
Restituisce true se l'indice esiste nella tabella altrimenti false.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IndexExist(
    string TableName,
    string IndexName
)
Public Function IndexExist (
    TableName As String,
    IndexName As String
) As Boolean
public:
bool IndexExist(
    String^ TableName,
    String^ IndexName
)
member IndexExist :
        TableName : string *
        IndexName : string -> bool

Parametri

TableName String
Nome della tabella.
IndexName String
Nome dell'indice.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.IsValidConnection

Metodo QSConnectionIsValidConnection
Restituisce true se riesce a connettersi altrimenti false.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValidConnection()
Public Function IsValidConnection As Boolean
public:
bool IsValidConnection()
member IsValidConnection : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.MakeFieldList

Metodo QSConnectionMakeFieldList
Restituisce la lista dei nomi dei campi concatenati con una virgola e racchiusi dalle quadre (o dal carattere utilizzato dal Database al quale si è connessi). Es.: " [DED_DIS], [DED_COD] ". I valori di default per il prefisso ed il suffisso sono il singolo spazio ' '.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MakeFieldList(
    string prefix,
    string[] fieldList,
    string postfix
)
Public Function MakeFieldList (
    prefix As String,
    fieldList As String(),
    postfix As String
) As String
public:
String^ MakeFieldList(
    String^ prefix,
    array<String^>^ fieldList,
    String^ postfix
)
member MakeFieldList :
        prefix : string *
        fieldList : string[] *
        postfix : string -> string

Parametri

prefix String
Prefisso da anteporre (se null viene anteposto uno spazio).
fieldList String
postfix String
Suffisso da postporre (se null viene aggiunto uno spazio).

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.MakeFieldValueList

Metodo QSConnectionMakeFieldValueList
Restituisce una stringa contenente le coppie nome = valore per l'istruzione UPDATE, concatenati con una virgola e racchiusi dalle quadre (o dal carattere utilizzato dal Database al quale si è connessi). Es.: " [DED_DIS] = '12646545', [DED_COD] = '12646545' ". O meglio : " [DED_DIS] = @DED_DIS, [DED_COD] = @DED_COD ". La stringa restituita ha uno spazio all'inizio ed uno alla fine.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MakeFieldValueList(
    Dictionary<string, string> nameValue
)
Public Function MakeFieldValueList (
    nameValue As Dictionary(Of String, String)
) As String
public:
String^ MakeFieldValueList(
    Dictionary<String^, String^>^ nameValue
)
member MakeFieldValueList :
        nameValue : Dictionary<string, string> -> string

Parametri

nameValue Dictionary String, String
Dizionario contenente le coppie nome-valore da utilizzare nell'istruzione.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.MakeValueList

Metodo QSConnectionMakeValueList
Restituisce una stringa contenente la lista dei parametri concatenati concatenati con una virgola. Es.: "@Param1, @Param2, Param3". La stringa restituita non ha spazi all'inizio e alla fine.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MakeValueList(
    string[] paramList
)
Public Function MakeValueList (
    paramList As String()
) As String
public:
String^ MakeValueList(
    array<String^>^ paramList
)
member MakeValueList :
        paramList : string[] -> string

Parametri

paramList String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.OpenConnection

Metodo QSConnectionOpenConnection
Si assicura che la connessione al Database sia aperta. Se risulta già aperta incrementa il numero di richieste di apertura. DEVE SEMPRE ESSERE USATA IN ACCOPPIAMENTO A ColseConnection() che deve essere chiamata solo se questa funzione ha avuto successo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OpenConnection()
Public Function OpenConnection As Boolean
public:
bool OpenConnection()
member OpenConnection : unit -> bool

Valore di ritorno

Boolean
Restituisce true se riesce ad aprire la connessione altrimenti false ed imposta in LastError l'errore avvenuto.
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.PerformDuplicatSchemaTable

Metodo QSConnectionPerformDuplicatSchemaTable
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PerformDuplicatSchemaTable(String, String) |
Metodo pubblico | PerformDuplicatSchemaTable(String, String, Boolean, Boolean) |
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.PerformDuplicatSchemaTable(String, String)

Metodo QSConnectionPerformDuplicatSchemaTable(String, String)

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PerformDuplicatSchemaTable(
    string TableName,
    string NewTableName
)
Public Function PerformDuplicatSchemaTable (
    TableName As String,
    NewTableName As String
) As Boolean
public:
bool PerformDuplicatSchemaTable(
    String^ TableName,
    String^ NewTableName
)
member PerformDuplicatSchemaTable :
        TableName : string *
        NewTableName : string -> bool

Parametri

TableName String
NewTableName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection
Overload di PerformDuplicatSchemaTable


Metodo QSConnection.PerformDuplicatSchemaTable(String, String, Boolean, Boolean)

Metodo QSConnectionPerformDuplicatSchemaTable(String, String, Boolean, Boolean)

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PerformDuplicatSchemaTable(
    string TableName,
    string NewTableName,
    bool includeRowGuidColumn,
    bool includeIndexsAndKeys
)
Public Function PerformDuplicatSchemaTable (
    TableName As String,
    NewTableName As String,
    includeRowGuidColumn As Boolean,
    includeIndexsAndKeys As Boolean
) As Boolean
public:
bool PerformDuplicatSchemaTable(
    String^ TableName,
    String^ NewTableName,
    bool includeRowGuidColumn,
    bool includeIndexsAndKeys
)
member PerformDuplicatSchemaTable :
        TableName : string *
        NewTableName : string *
        includeRowGuidColumn : bool *
        includeIndexsAndKeys : bool -> bool

Parametri

TableName String
NewTableName String
includeRowGuidColumn Boolean
includeIndexsAndKeys Boolean

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection
Overload di PerformDuplicatSchemaTable


Metodo QSConnection.PerformTableBackup

Metodo QSConnectionPerformTableBackup

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PerformTableBackup(
    string TableName,
    string BackupTableName
)
Public Function PerformTableBackup (
    TableName As String,
    BackupTableName As String
) As Boolean
public:
bool PerformTableBackup(
    String^ TableName,
    String^ BackupTableName
)
member PerformTableBackup :
        TableName : string *
        BackupTableName : string -> bool

Parametri

TableName String
BackupTableName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.QuoteIdentifier

Metodo QSConnectionQuoteIdentifier
Restituisce la stringa racchiusa tra parentesi quadre '[]' o comunque tra i corretti identificatori.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string QuoteIdentifier(
    string identifier
)
Public Function QuoteIdentifier (
    identifier As String
) As String
public:
String^ QuoteIdentifier(
    String^ identifier
)
member QuoteIdentifier :
        identifier : string -> string

Parametri

identifier String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.QuoteLikeWildechars

Metodo QSConnectionQuoteLikeWildechars
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | QuoteLikeWildechars(String) | Restituisce la stringa con quotati i caratteri speciali del LIKE, come '%' e '_'.
Metodo pubblico | QuoteLikeWildechars(String, Char) | Restituisce la stringa con quotati con il valore di escape passato, come '%' e '_'.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.QuoteLikeWildechars(String)

Metodo QSConnectionQuoteLikeWildechars(String)
Restituisce la stringa con quotati i caratteri speciali del LIKE, come '%' e '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string QuoteLikeWildechars(
    string expression
)
Public Function QuoteLikeWildechars (
    expression As String
) As String
public:
String^ QuoteLikeWildechars(
    String^ expression
)
member QuoteLikeWildechars :
        expression : string -> string

Parametri

expression String
Espressione da quotare.

Valore di ritorno

String
Restituisce una stringa con quotati i caratteri speciali del LIKE.
Vedi anche

Documentazione

Classe QSConnection
Overload di QuoteLikeWildechars


Metodo QSConnection.QuoteLikeWildechars(String, Char)

Metodo QSConnectionQuoteLikeWildechars(String, Char)
Restituisce la stringa con quotati con il valore di escape passato, come '%' e '_'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string QuoteLikeWildechars(
    string expression,
    char escapeValue
)
Public Function QuoteLikeWildechars (
    expression As String,
    escapeValue As Char
) As String
public:
String^ QuoteLikeWildechars(
    String^ expression,
    wchar_t escapeValue
)
member QuoteLikeWildechars :
        expression : string *
        escapeValue : char -> string

Parametri

expression String
Espressione da quotare.
escapeValue Char
Valore di escape

Valore di ritorno

String
Restituisce una stringa con quotati i caratteri speciali del LIKE.
Vedi anche

Documentazione

Classe QSConnection
Overload di QuoteLikeWildechars


Metodo QSConnection.Select

Metodo QSConnectionSelect
Effettua una query e restituisce il risultato sotto forma di tabella lua

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LuaTable Select(
    string tablename,
    LuaTable fields,
    LuaTable where,
    LuaTable orderby,
    bool desc
)
Public Function Select (
    tablename As String,
    fields As LuaTable,
    where As LuaTable,
    orderby As LuaTable,
    desc As Boolean
) As LuaTable
public:
LuaTable^ Select(
    String^ tablename,
    LuaTable^ fields,
    LuaTable^ where,
    LuaTable^ orderby,
    bool desc
)
member Select :
        tablename : string *
        fields : LuaTable *
        where : LuaTable *
        orderby : LuaTable *
        desc : bool -> LuaTable

Parametri

tablename String
Nome della tabella
fields LuaTable
Tabella LUA : {"DEDID","DEDREV",etc...} or null = *
where LuaTable
Tabella LUA : {["DEDID"] = "pippo", ["REV"] = 0} or null
orderby LuaTable
Tabella LUA : {"DEDID","DEDREV"} or null
desc Boolean
true/false

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.SelectTxt

Metodo QSConnectionSelectTxt
Effettua una query e restituisce il risultato sotto forma di tabella lua

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LuaTable SelectTxt(
    string sqlText
)
Public Function SelectTxt (
    sqlText As String
) As LuaTable
public:
LuaTable^ SelectTxt(
    String^ sqlText
)
member SelectTxt :
        sqlText : string -> LuaTable

Parametri

sqlText String
Stringa della query da eseguire

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe QSConnection


Metodo QSConnection.TableExists

Metodo QSConnectionTableExists
Funzione che controlla l'esistenza di una tabella, restituisce true se esiste altimenti false.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TableExists(
    string tablename
)
Public Function TableExists (
    tablename As String
) As Boolean
public:
bool TableExists(
    String^ tablename
)
member TableExists :
        tablename : string -> bool

Parametri

tablename String
Nome della tabella da cercare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSConnection


Eventi di QSConnection

Il tipo QSConnection espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | StateChange | Evento di notifica su stato connessione.
Torna su
Vedi anche

Documentazione

Classe QSConnection


Evento QSConnection.StateChange

Evento QSConnectionStateChange
Evento di notifica su stato connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual event StateChangeEventHandler StateChange
Public Overridable Event StateChange As StateChangeEventHandler
public:
virtual  event StateChangeEventHandler^ StateChange {
    void add (StateChangeEventHandler^ value);
    void remove (StateChangeEventHandler^ value);
}
abstract StateChange : IEvent<StateChangeEventHandler,
    StateChangeEventArgs>
override StateChange : IEvent<StateChangeEventHandler,
    StateChangeEventArgs>

Valore

StateChangeEventHandler
Vedi anche

Documentazione

Classe QSConnection


Classe QSConnection.IndexProperty

Classe QSConnectionIndexProperty
Classe usata per salvare le proprietà di un indice.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSConnectionIndexProperty

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class IndexProperty
Public Class IndexProperty
public ref class IndexProperty
type IndexProperty = class end

Il tipo QSConnectionIndexProperty espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSConnectionIndexProperty | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Columns | Indica le colonne coinvolte nell'indice.
Proprietà pubblica | IndexName | Nome dell'indice.
Proprietà pubblica | IsClustered | Indica se l'indice è di tipo cluster.
Proprietà pubblica | IsUnique | Indica se l'indice è unico.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSConnection.IndexProperty

Costruttore QSConnectionIndexProperty
Costruttore unico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IndexProperty(
    string indexName,
    bool isUnique,
    bool isCLustered
)
Public Sub New (
    indexName As String,
    isUnique As Boolean,
    isCLustered As Boolean
)
public:
IndexProperty(
    String^ indexName,
    bool isUnique,
    bool isCLustered
)
new :
        indexName : string *
        isUnique : bool *
        isCLustered : bool -> IndexProperty

Parametri

indexName String
Nome dell'indice.
isUnique Boolean
Indice unico o no.
isCLustered Boolean
Indice di tipo cluster o no.
Vedi anche

Documentazione

Classe QSConnectionIndexProperty


Proprietà di IndexProperty

Il tipo QSConnectionIndexProperty espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Columns | Indica le colonne coinvolte nell'indice.
Proprietà pubblica | IndexName | Nome dell'indice.
Proprietà pubblica | IsClustered | Indica se l'indice è di tipo cluster.
Proprietà pubblica | IsUnique | Indica se l'indice è unico.
Torna su
Vedi anche

Documentazione

Classe QSConnectionIndexProperty


Proprietà QSConnection.IndexProperty.Columns

Proprietà QSConnectionIndexPropertyColumns
Indica le colonne coinvolte nell'indice.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Columns { get; set; }
Public Property Columns As List(Of String)
    Get
    Set
public:
property List<String^>^ Columns {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Columns : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe QSConnectionIndexProperty


Proprietà QSConnection.IndexProperty.IndexName

Proprietà QSConnectionIndexPropertyIndexName
Nome dell'indice.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string IndexName { get; set; }
Public Property IndexName As String
    Get
    Set
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}
member IndexName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSConnectionIndexProperty


Proprietà QSConnection.IndexProperty.IsClustered

Proprietà QSConnectionIndexPropertyIsClustered
Indica se l'indice è di tipo cluster.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsClustered { get; set; }
Public Property IsClustered As Boolean
    Get
    Set
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
member IsClustered : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnectionIndexProperty


Proprietà QSConnection.IndexProperty.IsUnique

Proprietà QSConnectionIndexPropertyIsUnique
Indica se l'indice è unico.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUnique { get; set; }
Public Property IsUnique As Boolean
    Get
    Set
public:
property bool IsUnique {
    bool get ();
    void set (bool value);
}
member IsUnique : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSConnectionIndexProperty


Classe QSConnection.ReflectionUtils

Classe QSConnectionReflectionUtils
Classe per la gestione alla connessione
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSConnectionReflectionUtils

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReflectionUtils
Public Class ReflectionUtils
public ref class ReflectionUtils
type ReflectionUtils = class end

Il tipo QSConnectionReflectionUtils espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSConnectionReflectionUtils | Inizializza una nuova istanza della classe QSConnectionReflectionUtils.
Torna su
Metodi
Nome | Descrizione
GetStaticProperty(String, String) | Retrieves a value from a static property by specifying a type full name and property
GetStaticProperty(Type, String) | Returns a static property from a given type
GetTypeFromName(String) | Overload for backwards compatibility which only tries to load assemblies that are already loaded in memory.
GetTypeFromName(String, String) | Helper routine that looks up a type name and tries to retrieve the full type reference using GetType() and if not found looking in the actively executing assemblies and optionally loading the specified assembly name.
LoadAssembly | Try to load an assembly into the application's app domain. Loads by name first then checks for filename
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSConnection.ReflectionUtils

Costruttore QSConnectionReflectionUtils
Inizializza una nuova istanza della classe QSConnectionReflectionUtils.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReflectionUtils()
Public Sub New
public:
ReflectionUtils()
new : unit -> ReflectionUtils
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils


Metodi di ReflectionUtils

Il tipo QSConnectionReflectionUtils espone i seguenti membri.

Metodi
Nome | Descrizione
GetStaticProperty(String, String) | Retrieves a value from a static property by specifying a type full name and property
GetStaticProperty(Type, String) | Returns a static property from a given type
GetTypeFromName(String) | Overload for backwards compatibility which only tries to load assemblies that are already loaded in memory.
GetTypeFromName(String, String) | Helper routine that looks up a type name and tries to retrieve the full type reference using GetType() and if not found looking in the actively executing assemblies and optionally loading the specified assembly name.
LoadAssembly | Try to load an assembly into the application's app domain. Loads by name first then checks for filename
Torna su
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils


Metodo QSConnection.ReflectionUtils.GetStaticProperty

Metodo QSConnectionReflectionUtilsGetStaticProperty
Lista degli overload
Nome | Descrizione
GetStaticProperty(String, String) | Retrieves a value from a static property by specifying a type full name and property
GetStaticProperty(Type, String) | Returns a static property from a given type
Torna su
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils


Metodo QSConnection.ReflectionUtils.GetStaticProperty(String, String)

Metodo QSConnectionReflectionUtilsGetStaticProperty(String, String)
Retrieves a value from a static property by specifying a type full name and property

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Object GetStaticProperty(
    string typeName,
    string property
)
Public Shared Function GetStaticProperty (
    typeName As String,
    property As String
) As Object
public:
static Object^ GetStaticProperty(
    String^ typeName,
    String^ property
)
static member GetStaticProperty :
        typeName : string *
        property : string -> Object

Parametri

typeName String
Full type name (namespace.class)
property String
Property to get value from

Valore di ritorno

Object
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils
Overload di GetStaticProperty


Metodo QSConnection.ReflectionUtils.GetStaticProperty(Type, String)

Metodo QSConnectionReflectionUtilsGetStaticProperty(Type, String)
Returns a static property from a given type

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Object GetStaticProperty(
    Type type,
    string property
)
Public Shared Function GetStaticProperty (
    type As Type,
    property As String
) As Object
public:
static Object^ GetStaticProperty(
    Type^ type,
    String^ property
)
static member GetStaticProperty :
        type : Type *
        property : string -> Object

Parametri

type Type
Type instance for the static property
property String
Property name as a string

Valore di ritorno

Object
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils
Overload di GetStaticProperty


Metodo QSConnection.ReflectionUtils.GetTypeFromName

Metodo QSConnectionReflectionUtilsGetTypeFromName
Lista degli overload
Nome | Descrizione
GetTypeFromName(String) | Overload for backwards compatibility which only tries to load assemblies that are already loaded in memory.
GetTypeFromName(String, String) | Helper routine that looks up a type name and tries to retrieve the full type reference using GetType() and if not found looking in the actively executing assemblies and optionally loading the specified assembly name.
Torna su
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils


Metodo QSConnection.ReflectionUtils.GetTypeFromName(String)

Metodo QSConnectionReflectionUtilsGetTypeFromName(String)
Overload for backwards compatibility which only tries to load assemblies that are already loaded in memory.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Type GetTypeFromName(
    string typeName
)
Public Shared Function GetTypeFromName (
    typeName As String
) As Type
public:
static Type^ GetTypeFromName(
    String^ typeName
)
static member GetTypeFromName :
        typeName : string -> Type

Parametri

typeName String

Valore di ritorno

Type
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils
Overload di GetTypeFromName


Metodo QSConnection.ReflectionUtils.GetTypeFromName(String, String)

Metodo QSConnectionReflectionUtilsGetTypeFromName(String, String)
Helper routine that looks up a type name and tries to retrieve the full type reference using GetType() and if not found looking in the actively executing assemblies and optionally loading the specified assembly name.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Type GetTypeFromName(
    string typeName,
    string assemblyName
)
Public Shared Function GetTypeFromName (
    typeName As String,
    assemblyName As String
) As Type
public:
static Type^ GetTypeFromName(
    String^ typeName,
    String^ assemblyName
)
static member GetTypeFromName :
        typeName : string *
        assemblyName : string -> Type

Parametri

typeName String
type to load
assemblyName String
Optional assembly name to load from if type cannot be loaded initially. Use for lazy loading of assemblies without taking a type dependency.

Valore di ritorno

Type
null
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils
Overload di GetTypeFromName


Metodo QSConnection.ReflectionUtils.LoadAssembly

Metodo QSConnectionReflectionUtilsLoadAssembly
Try to load an assembly into the application's app domain. Loads by name first then checks for filename

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Assembly LoadAssembly(
    string assemblyName
)
Public Shared Function LoadAssembly (
    assemblyName As String
) As Assembly
public:
static Assembly^ LoadAssembly(
    String^ assemblyName
)
static member LoadAssembly :
        assemblyName : string -> Assembly

Parametri

assemblyName String
Assembly name or full path

Valore di ritorno

Assembly
null on failure
Vedi anche

Documentazione

Classe QSConnectionReflectionUtils


Classe QsCreateBackupCommand
Classe per creare un indice su un insieme di campi di una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsCreateBackupCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsCreateBackupCommand : QSCommandBase
Public Class QsCreateBackupCommand
    Inherits QSCommandBase
public ref class QsCreateBackupCommand : public QSCommandBase
type QsCreateBackupCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsCreateBackupCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsCreateBackupCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsCreateBackupCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsCreateBackupCommand(
    QSConnection conn,
    string filename
)
Protected Friend Sub New (
    conn As QSConnection,
    filename As String
)
protected public:
QsCreateBackupCommand(
    QSConnection^ conn,
    String^ filename
)
new :
        conn : QSConnection *
        filename : string -> QsCreateBackupCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
filename String
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Proprietà di QsCreateBackupCommand

Il tipo QsCreateBackupCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Proprietà QsCreateBackupCommand.SqlStatement

Proprietà QsCreateBackupCommandSqlStatement
Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Proprietà QsCreateBackupCommand.SqlText

Proprietà QsCreateBackupCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Metodi di QsCreateBackupCommand

Il tipo QsCreateBackupCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Metodo QsCreateBackupCommand.ResetSqlText

Metodo QsCreateBackupCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Metodo QsCreateBackupCommand.Run

Metodo QsCreateBackupCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsCreateBackupCommand


Classe QsCreateConstraintCommand
Classe per creare un indice su un insieme di campi di una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsCreateConstraintCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsCreateConstraintCommand : QSCommandBase
Public Class QsCreateConstraintCommand
    Inherits QSCommandBase
public ref class QsCreateConstraintCommand : public QSCommandBase
type QsCreateConstraintCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsCreateConstraintCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsCreateConstraintCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField | Aggiunge un campo alla lista degli indici.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsCreateConstraintCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsCreateConstraintCommand(
    QSConnection conn,
    string tableName,
    string nomeChiave
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String,
    nomeChiave As String
)
protected public:
QsCreateConstraintCommand(
    QSConnection^ conn,
    String^ tableName,
    String^ nomeChiave
)
new :
        conn : QSConnection *
        tableName : string *
        nomeChiave : string -> QsCreateConstraintCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
nomeChiave String
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Proprietà di QsCreateConstraintCommand

Il tipo QsCreateConstraintCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Proprietà QsCreateConstraintCommand.SqlStatement

Proprietà QsCreateConstraintCommandSqlStatement
Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Proprietà QsCreateConstraintCommand.SqlText

Proprietà QsCreateConstraintCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Metodi di QsCreateConstraintCommand

Il tipo QsCreateConstraintCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField | Aggiunge un campo alla lista degli indici.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Metodo QsCreateConstraintCommand.AddField

Metodo QsCreateConstraintCommandAddField
Aggiunge un campo alla lista degli indici.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName
)
Public Sub AddField (
    fieldName As String
)
public:
void AddField(
    String^ fieldName
)
member AddField :
        fieldName : string -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Metodo QsCreateConstraintCommand.ResetSqlText

Metodo QsCreateConstraintCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Metodo QsCreateConstraintCommand.Run

Metodo QsCreateConstraintCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsCreateConstraintCommand


Classe QsCreateFieldCommand
Classe per creare un insieme di campi in una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsCreateFieldCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsCreateFieldCommand : QSCommandBase
Public Class QsCreateFieldCommand
    Inherits QSCommandBase
public ref class QsCreateFieldCommand : public QSCommandBase
type QsCreateFieldCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsCreateFieldCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsCreateFieldCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla tabella.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla tabella.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsCreateFieldCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsCreateFieldCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QsCreateFieldCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QsCreateFieldCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Proprietà di QsCreateFieldCommand

Il tipo QsCreateFieldCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Proprietà QsCreateFieldCommand.SqlStatement

Proprietà QsCreateFieldCommandSqlStatement
Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Proprietà QsCreateFieldCommand.SqlText

Proprietà QsCreateFieldCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Metodi di QsCreateFieldCommand

Il tipo QsCreateFieldCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla tabella.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla tabella.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Metodo QsCreateFieldCommand.AddField

Metodo QsCreateFieldCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla tabella.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla tabella.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla lista dei campi da modificare.
Torna su
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Metodo QsCreateFieldCommand.AddField(String, Type, Int32, Boolean)

Metodo QsCreateFieldCommandAddField(String, Type, Int32, Boolean)
Aggiunge un campo alla tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
Vedi anche

Documentazione

Classe QsCreateFieldCommand
Overload di AddField


Metodo QsCreateFieldCommand.AddField(String, Type, Int32, Boolean, Object)

Metodo QsCreateFieldCommandAddField(String, Type, Int32, Boolean, Object)
Aggiunge un campo alla tabella.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull,
    Object defVal
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull,
    Object^ defVal
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
Vedi anche

Documentazione

Classe QsCreateFieldCommand
Overload di AddField


Metodo QsCreateFieldCommand.AddField(String, Type, Int32, Boolean, Object, Int32, Int32)

Metodo QsCreateFieldCommandAddField(String, Type, Int32, Boolean, Object, Int32, Int32)
Aggiunge un campo alla lista dei campi da modificare.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull,
    Object defVal,
    int identitySeed,
    int identityIncrement
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object,
    identitySeed As Integer,
    identityIncrement As Integer
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull,
    Object^ defVal,
    int identitySeed,
    int identityIncrement
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object *
        identitySeed : int *
        identityIncrement : int -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
identitySeed Int32
identityIncrement Int32
Vedi anche

Documentazione

Classe QsCreateFieldCommand
Overload di AddField


Metodo QsCreateFieldCommand.ResetSqlText

Metodo QsCreateFieldCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Metodo QsCreateFieldCommand.Run

Metodo QsCreateFieldCommandRun
Esegue l'istruzione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsCreateFieldCommand


Classe QsCreateIndexCommand
Classe per creare un indice su un insieme di campi di una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsCreateIndexCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsCreateIndexCommand : QSCommandBase
Public Class QsCreateIndexCommand
    Inherits QSCommandBase
public ref class QsCreateIndexCommand : public QSCommandBase
type QsCreateIndexCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsCreateIndexCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsCreateIndexCommand(QSConnection, String, String, Boolean) | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Metodo protetto | QsCreateIndexCommand(QSConnection, String, String, Boolean, Boolean) | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField | Aggiunge un campo alla lista degli indici.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsCreateIndexCommand
Lista degli overload
 | Nome | Descrizione
Metodo protetto | QsCreateIndexCommand(QSConnection, String, String, Boolean) | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Metodo protetto | QsCreateIndexCommand(QSConnection, String, String, Boolean, Boolean) | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Costruttore QsCreateIndexCommand(QSConnection, String, String, Boolean)
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsCreateIndexCommand(
    QSConnection conn,
    string tableName,
    string nomeIndice,
    bool unique
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String,
    nomeIndice As String,
    unique As Boolean
)
protected public:
QsCreateIndexCommand(
    QSConnection^ conn,
    String^ tableName,
    String^ nomeIndice,
    bool unique
)
new :
        conn : QSConnection *
        tableName : string *
        nomeIndice : string *
        unique : bool -> QsCreateIndexCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
nomeIndice String
unique Boolean
Vedi anche

Documentazione

Classe QsCreateIndexCommand
Overload di QsCreateIndexCommand


Costruttore QsCreateIndexCommand(QSConnection, String, String, Boolean, Boolean)
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsCreateIndexCommand(
    QSConnection conn,
    string tableName,
    string nomeIndice,
    bool unique,
    bool clustered
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String,
    nomeIndice As String,
    unique As Boolean,
    clustered As Boolean
)
protected public:
QsCreateIndexCommand(
    QSConnection^ conn,
    String^ tableName,
    String^ nomeIndice,
    bool unique,
    bool clustered
)
new :
        conn : QSConnection *
        tableName : string *
        nomeIndice : string *
        unique : bool *
        clustered : bool -> QsCreateIndexCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
nomeIndice String
unique Boolean
clustered Boolean
Vedi anche

Documentazione

Classe QsCreateIndexCommand
Overload di QsCreateIndexCommand


Proprietà di QsCreateIndexCommand

Il tipo QsCreateIndexCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Proprietà QsCreateIndexCommand.SqlStatement

Proprietà QsCreateIndexCommandSqlStatement
Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Proprietà QsCreateIndexCommand.SqlText

Proprietà QsCreateIndexCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Metodi di QsCreateIndexCommand

Il tipo QsCreateIndexCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField | Aggiunge un campo alla lista degli indici.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Metodo QsCreateIndexCommand.AddField

Metodo QsCreateIndexCommandAddField
Aggiunge un campo alla lista degli indici.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName
)
Public Sub AddField (
    fieldName As String
)
public:
void AddField(
    String^ fieldName
)
member AddField :
        fieldName : string -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Metodo QsCreateIndexCommand.ResetSqlText

Metodo QsCreateIndexCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Metodo QsCreateIndexCommand.Run

Metodo QsCreateIndexCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsCreateIndexCommand


Classe QsCreateTableCommand
Classe per creare una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsCreateTableCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsCreateTableCommand : QSCommandBase
Public Class QsCreateTableCommand
    Inherits QSCommandBase
public ref class QsCreateTableCommand : public QSCommandBase
type QsCreateTableCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsCreateTableCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsCreateTableCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsCreateTableCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsCreateTableCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QsCreateTableCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QsCreateTableCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QsCreateTableCommand


Proprietà di QsCreateTableCommand

Il tipo QsCreateTableCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateTableCommand


Proprietà QsCreateTableCommand.SqlStatement

Proprietà QsCreateTableCommandSqlStatement
Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsCreateTableCommand


Proprietà QsCreateTableCommand.SqlText

Proprietà QsCreateTableCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsCreateTableCommand


Metodi di QsCreateTableCommand

Il tipo QsCreateTableCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsCreateTableCommand


Metodo QsCreateTableCommand.AddField

Metodo QsCreateTableCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla Tabella in creazione.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla Tabella in creazione.
Torna su
Vedi anche

Documentazione

Classe QsCreateTableCommand


Metodo QsCreateTableCommand.AddField(String, Type, Int32, Boolean)

Metodo QsCreateTableCommandAddField(String, Type, Int32, Boolean)
Aggiunge un campo alla Tabella in creazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
Vedi anche

Documentazione

Classe QsCreateTableCommand
Overload di AddField


Metodo QsCreateTableCommand.AddField(String, Type, Int32, Boolean, Object)

Metodo QsCreateTableCommandAddField(String, Type, Int32, Boolean, Object)
Aggiunge un campo alla Tabella in creazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull,
    Object defVal
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull,
    Object^ defVal
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
Vedi anche

Documentazione

Classe QsCreateTableCommand
Overload di AddField


Metodo QsCreateTableCommand.AddField(String, Type, Int32, Boolean, Object, Int32, Int32)

Metodo QsCreateTableCommandAddField(String, Type, Int32, Boolean, Object, Int32, Int32)
Aggiunge un campo alla Tabella in creazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull,
    Object defVal,
    int identitySeed,
    int identityIncrement
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object,
    identitySeed As Integer,
    identityIncrement As Integer
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull,
    Object^ defVal,
    int identitySeed,
    int identityIncrement
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object *
        identitySeed : int *
        identityIncrement : int -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
identitySeed Int32
identityIncrement Int32
Vedi anche

Documentazione

Classe QsCreateTableCommand
Overload di AddField


Metodo QsCreateTableCommand.ResetSqlText

Metodo QsCreateTableCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsCreateTableCommand


Metodo QsCreateTableCommand.Run

Metodo QsCreateTableCommandRun
Esegue l'istruzione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsCreateTableCommand


Classe QSDeleteCommand
Implementa le funzionalità di DELETE.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQSDeleteCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSDeleteCommand : QSCommandBase
Public Class QSDeleteCommand
    Inherits QSCommandBase
public ref class QSDeleteCommand : public QSCommandBase
type QSDeleteCommand =
    class
        inherit QSCommandBase
    end

Il tipo QSDeleteCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSDeleteCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSDeleteCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QSDeleteCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QSDeleteCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QSDeleteCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QSDeleteCommand


Proprietà di QSDeleteCommand

Il tipo QSDeleteCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSDeleteCommand


Proprietà QSDeleteCommand.RowLock

Proprietà QSDeleteCommandRowLock

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RowLock { get; set; }
Public Property RowLock As Boolean
    Get
    Set
public:
property bool RowLock {
    bool get ();
    void set (bool value);
}
member RowLock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSDeleteCommand


Proprietà QSDeleteCommand.SqlStatement

Proprietà QSDeleteCommandSqlStatement
Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSDeleteCommand


Proprietà QSDeleteCommand.SqlText

Proprietà QSDeleteCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSDeleteCommand


Metodi di QSDeleteCommand

Il tipo QSDeleteCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSDeleteCommand


Metodo QSDeleteCommand.ResetSqlText

Metodo QSDeleteCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QSDeleteCommand


Metodo QSDeleteCommand.Run

Metodo QSDeleteCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QSDeleteCommand


Classe QsDropConstraintCommand
Classe per eliminare un insieme di campi da una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsDropConstraintCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsDropConstraintCommand : QSCommandBase
Public Class QsDropConstraintCommand
    Inherits QSCommandBase
public ref class QsDropConstraintCommand : public QSCommandBase
type QsDropConstraintCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsDropConstraintCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsDropConstraintCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsDropConstraintCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsDropConstraintCommand(
    QSConnection conn,
    string tableName,
    string nomeChiave
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String,
    nomeChiave As String
)
protected public:
QsDropConstraintCommand(
    QSConnection^ conn,
    String^ tableName,
    String^ nomeChiave
)
new :
        conn : QSConnection *
        tableName : string *
        nomeChiave : string -> QsDropConstraintCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
nomeChiave String
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Proprietà di QsDropConstraintCommand

Il tipo QsDropConstraintCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Proprietà QsDropConstraintCommand.SqlStatement

Proprietà QsDropConstraintCommandSqlStatement
Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Proprietà QsDropConstraintCommand.SqlText

Proprietà QsDropConstraintCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Metodi di QsDropConstraintCommand

Il tipo QsDropConstraintCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Metodo QsDropConstraintCommand.ResetSqlText

Metodo QsDropConstraintCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Metodo QsDropConstraintCommand.Run

Metodo QsDropConstraintCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsDropConstraintCommand


Classe QsDropFieldCommand
Classe per eliminare un insieme di campi da una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsDropFieldCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsDropFieldCommand : QSCommandBase
Public Class QsDropFieldCommand
    Inherits QSCommandBase
public ref class QsDropFieldCommand : public QSCommandBase
type QsDropFieldCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsDropFieldCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsDropFieldCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField | Aggiunge un campo alla DROP COLUMN.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsDropFieldCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsDropFieldCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QsDropFieldCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QsDropFieldCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QsDropFieldCommand


Proprietà di QsDropFieldCommand

Il tipo QsDropFieldCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropFieldCommand


Proprietà QsDropFieldCommand.SqlStatement

Proprietà QsDropFieldCommandSqlStatement
Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsDropFieldCommand


Proprietà QsDropFieldCommand.SqlText

Proprietà QsDropFieldCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsDropFieldCommand


Metodi di QsDropFieldCommand

Il tipo QsDropFieldCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField | Aggiunge un campo alla DROP COLUMN.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropFieldCommand


Metodo QsDropFieldCommand.AddField

Metodo QsDropFieldCommandAddField
Aggiunge un campo alla DROP COLUMN.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName
)
Public Sub AddField (
    fieldName As String
)
public:
void AddField(
    String^ fieldName
)
member AddField :
        fieldName : string -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe QsDropFieldCommand


Metodo QsDropFieldCommand.ResetSqlText

Metodo QsDropFieldCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsDropFieldCommand


Metodo QsDropFieldCommand.Run

Metodo QsDropFieldCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsDropFieldCommand


Classe QsDropIndexCommand
Classe per eliminare un insieme di campi da una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsDropIndexCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsDropIndexCommand : QSCommandBase
Public Class QsDropIndexCommand
    Inherits QSCommandBase
public ref class QsDropIndexCommand : public QSCommandBase
type QsDropIndexCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsDropIndexCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsDropIndexCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsDropIndexCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsDropIndexCommand(
    QSConnection conn,
    string tableName,
    string nomeIndice
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String,
    nomeIndice As String
)
protected public:
QsDropIndexCommand(
    QSConnection^ conn,
    String^ tableName,
    String^ nomeIndice
)
new :
        conn : QSConnection *
        tableName : string *
        nomeIndice : string -> QsDropIndexCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
nomeIndice String
Vedi anche

Documentazione

Classe QsDropIndexCommand


Proprietà di QsDropIndexCommand

Il tipo QsDropIndexCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropIndexCommand


Proprietà QsDropIndexCommand.SqlStatement

Proprietà QsDropIndexCommandSqlStatement
Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsDropIndexCommand


Proprietà QsDropIndexCommand.SqlText

Proprietà QsDropIndexCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsDropIndexCommand


Metodi di QsDropIndexCommand

Il tipo QsDropIndexCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropIndexCommand


Metodo QsDropIndexCommand.ResetSqlText

Metodo QsDropIndexCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsDropIndexCommand


Metodo QsDropIndexCommand.Run

Metodo QsDropIndexCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsDropIndexCommand


Classe QsDropTableCommand
Classe per droppare una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsDropTableCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsDropTableCommand : QSCommandBase
Public Class QsDropTableCommand
    Inherits QSCommandBase
public ref class QsDropTableCommand : public QSCommandBase
type QsDropTableCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsDropTableCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsDropTableCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsDropTableCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsDropTableCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QsDropTableCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QsDropTableCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QsDropTableCommand


Proprietà di QsDropTableCommand

Il tipo QsDropTableCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropTableCommand


Proprietà QsDropTableCommand.SqlStatement

Proprietà QsDropTableCommandSqlStatement
Restituisce l'istruzione DELETE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsDropTableCommand


Proprietà QsDropTableCommand.SqlText

Proprietà QsDropTableCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsDropTableCommand


Metodi di QsDropTableCommand

Il tipo QsDropTableCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsDropTableCommand


Metodo QsDropTableCommand.ResetSqlText

Metodo QsDropTableCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsDropTableCommand


Metodo QsDropTableCommand.Run

Metodo QsDropTableCommandRun
Esegue l'istruzione di DELETE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsDropTableCommand


Classe QSInsertCommand
Implementa le funzionalità di INSERT.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQSInsertCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSInsertCommand : QSCommandBase
Public Class QSInsertCommand
    Inherits QSCommandBase
public ref class QSInsertCommand : public QSCommandBase
type QSInsertCommand =
    class
        inherit QSCommandBase
    end

Il tipo QSInsertCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSInsertCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | FieldValueDictionary | Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".
Proprietà pubblica | Item | Imposta o restituisce il valore di un campo della clausola INSERT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione INSERT completa in base alle informazioni presenti nell'oggetto oppure stringa vuota se non sono presenti dei campi. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetField | Restituisce il valore abbinato al campo specificato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di INSERT. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSInsertCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QSInsertCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QSInsertCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QSInsertCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QSInsertCommand


Proprietà di QSInsertCommand

Il tipo QSInsertCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | FieldValueDictionary | Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".
Proprietà pubblica | Item | Imposta o restituisce il valore di un campo della clausola INSERT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione INSERT completa in base alle informazioni presenti nell'oggetto oppure stringa vuota se non sono presenti dei campi. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSInsertCommand


Proprietà QSInsertCommand.FieldValueDictionary

Proprietà QSInsertCommandFieldValueDictionary
Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> FieldValueDictionary { get; }
Public ReadOnly Property FieldValueDictionary As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ FieldValueDictionary {
    Dictionary<String^, String^>^ get ();
}
member FieldValueDictionary : Dictionary<string, string> with get

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe QSInsertCommand


Proprietà QSInsertCommand.Item

Proprietà QSInsertCommandItem
Imposta o restituisce il valore di un campo della clausola INSERT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object this[
    string fieldName
] { get; set; }
Public Default Property Item (
    fieldName As String
) As Object
    Get
    Set
public:
property Object^ default[String^ fieldName] {
    Object^ get (String^ fieldName);
    void set (String^ fieldName, Object^ value);
}
member Item : Object with get, set

Parametri

fieldName String
Nome del campo.

Valore di ritorno

Object
Restituisce il valore del campo oppure null se non esiste.
Vedi anche

Documentazione

Classe QSInsertCommand


Proprietà QSInsertCommand.RowLock

Proprietà QSInsertCommandRowLock

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RowLock { get; set; }
Public Property RowLock As Boolean
    Get
    Set
public:
property bool RowLock {
    bool get ();
    void set (bool value);
}
member RowLock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSInsertCommand


Proprietà QSInsertCommand.SqlStatement

Proprietà QSInsertCommandSqlStatement
Restituisce l'istruzione INSERT completa in base alle informazioni presenti nell'oggetto oppure stringa vuota se non sono presenti dei campi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSInsertCommand


Proprietà QSInsertCommand.SqlText

Proprietà QSInsertCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSInsertCommand


Metodi di QSInsertCommand

Il tipo QSInsertCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetField | Restituisce il valore abbinato al campo specificato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di INSERT. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSInsertCommand


Metodo QSInsertCommand.AddField

Metodo QSInsertCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Torna su
Vedi anche

Documentazione

Classe QSInsertCommand


Metodo QSInsertCommand.AddField(String, Object)

Metodo QSInsertCommandAddField(String, Object)
Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Object fieldValue
)
Public Sub AddField (
    fieldName As String,
    fieldValue As Object
)
public:
void AddField(
    String^ fieldName,
    Object^ fieldValue
)
member AddField :
        fieldName : string *
        fieldValue : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
fieldValue Object
Valore del campo da aggiungere.
Vedi anche

Documentazione

Classe QSInsertCommand
Overload di AddField


Metodo QSInsertCommand.AddField(String, String, Object)

Metodo QSInsertCommandAddField(String, String, Object)
Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    string paramName,
    Object paramValue
)
Public Sub AddField (
    fieldName As String,
    paramName As String,
    paramValue As Object
)
public:
void AddField(
    String^ fieldName,
    String^ paramName,
    Object^ paramValue
)
member AddField :
        fieldName : string *
        paramName : string *
        paramValue : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
paramName String
Nome del parametro.
paramValue Object
Valore del parametro.
Vedi anche

Documentazione

Classe QSInsertCommand
Overload di AddField


Metodo QSInsertCommand.AddField(String, String, Object, DbType)

Metodo QSInsertCommandAddField(String, String, Object, DbType)
Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    string paramName,
    Object paramValue,
    DbType dbT
)
Public Sub AddField (
    fieldName As String,
    paramName As String,
    paramValue As Object,
    dbT As DbType
)
public:
void AddField(
    String^ fieldName,
    String^ paramName,
    Object^ paramValue,
    DbType dbT
)
member AddField :
        fieldName : string *
        paramName : string *
        paramValue : Object *
        dbT : DbType -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
paramName String
Nome del parametro.
paramValue Object
Valore del parametro.
dbT DbType
Tipo dati presente nel Database.
Vedi anche

Documentazione

Classe QSInsertCommand
Overload di AddField


Metodo QSInsertCommand.ContainsField

Metodo QSInsertCommandContainsField
Verifica se un campo esiste già.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsField(
    string fieldName
)
Public Function ContainsField (
    fieldName As String
) As Boolean
public:
bool ContainsField(
    String^ fieldName
)
member ContainsField :
        fieldName : string -> bool

Parametri

fieldName String
Nome del campo da verificare.

Valore di ritorno

Boolean
Restituisce true se esiste altrimenti false.
Vedi anche

Documentazione

Classe QSInsertCommand


Metodo QSInsertCommand.GetField

Metodo QSInsertCommandGetField
Restituisce il valore abbinato al campo specificato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetField(
    string fieldName
)
Public Function GetField (
    fieldName As String
) As Object
public:
Object^ GetField(
    String^ fieldName
)
member GetField :
        fieldName : string -> Object

Parametri

fieldName String
Nome del campo del quale restituire il valore.

Valore di ritorno

Object
Restituisce il valore del campo oppure null se non esiste.
Vedi anche

Documentazione

Classe QSInsertCommand


Metodo QSInsertCommand.ResetSqlText

Metodo QSInsertCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QSInsertCommand


Metodo QSInsertCommand.Run

Metodo QSInsertCommandRun
Esegue l'istruzione di INSERT. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual int Run()
Public Overridable Function Run As Integer
public:
virtual int Run()
abstract Run : unit -> int
override Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'aggiornamento.
Vedi anche

Documentazione

Classe QSInsertCommand


Classe QsRebuildIndexCommand
Classe per creare un indice su un insieme di campi di una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsRebuildIndexCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsRebuildIndexCommand : QSCommandBase
Public Class QsRebuildIndexCommand
    Inherits QSCommandBase
public ref class QsRebuildIndexCommand : public QSCommandBase
type QsRebuildIndexCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsRebuildIndexCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsRebuildIndexCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce la clausola completa della WHERE oppure stringa vuota "". (Ereditato da QSCommandBase)
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | Run | Esegue il rebuild degli indici. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsRebuildIndexCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsRebuildIndexCommand(
    QSConnection conn
)
Protected Friend Sub New (
    conn As QSConnection
)
protected public:
QsRebuildIndexCommand(
    QSConnection^ conn
)
new :
        conn : QSConnection -> QsRebuildIndexCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
Vedi anche

Documentazione

Classe QsRebuildIndexCommand


Proprietà di QsRebuildIndexCommand

Il tipo QsRebuildIndexCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce la clausola completa della WHERE oppure stringa vuota "". (Ereditato da QSCommandBase)
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsRebuildIndexCommand


Metodi di QsRebuildIndexCommand

Il tipo QsRebuildIndexCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | Run | Esegue il rebuild degli indici. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsRebuildIndexCommand


Metodo QsRebuildIndexCommand.Run

Metodo QsRebuildIndexCommandRun
Esegue il rebuild degli indici. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsRebuildIndexCommand


Classe QSSelectCommand
Implementa le funzionalità di SELECT.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQSSelectCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSelectCommand : QSCommandBase
Public Class QSSelectCommand
    Inherits QSCommandBase
public ref class QSSelectCommand : public QSCommandBase
type QSSelectCommand =
    class
        inherit QSCommandBase
    end

Il tipo QSSelectCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSSelectCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Desc | Restituisce o imposta se l'ordinamento debba essere decrescente. Viene ignorato se la lista dei campi dell'ordinamento è vuota.
Proprietà pubblica | DisableLogException | Se true le eventuali eccezioni nei command non vengono loggate
Proprietà pubblica | Distinct | Restituisce o imposta se la SELECT è preceduta dalla clausola DISTINCT.
Proprietà pubblica | Fields | Restituisce la lista dei campi/elementi sui quali eseguire la SELECT. Se la lista dei campi è vuota viene fatta una query con '*'.
Proprietà pubblica | GroupFields | Restituisce la lista dei campi sui quali eseguire la clausola GROUP BY della SELECT.
Proprietà pubblica | OrderFields | Restituisce la lista dei campi sui quali eseguire la clausola ORDER BY della SELECT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | ReadRecordEventAlreadyRegistered | Restituisce true se risulta già registrato un delegate per l'evento ReadRecord altrimenti restituisce false.
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SELECT completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | TopNumber | Restituisce ed imposta il numero di righe da visualizzare nella clausola TOP. Specificare -1 se non deve essere presente (default).
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Proprietà pubblica | XLock | Indica se bloccare il set di righe in attesa di lettura di dati commitati
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(ISqlStatement) | Aggiunge un elemento libero alla lista dei campi. Non aggiunge nessun parametro al comando.
Metodo pubblico | AddField(String) | Aggiunge un campo alla SELECT.
Metodo pubblico | AddField(String, Boolean) | Aggiunge un campo alla SELECT.
Metodo pubblico | AddFields | Aggiunge la lista dei campi alla SELECT.
Metodo pubblico | AddFunction(String, String) | Permette di inserire nella clausola SELECT una funzione di aggregazione.
Metodo pubblico | AddFunction(String, String, String) | Permette di inserire nella clausola SELECT una funzione di aggregazione.
Metodo pubblico | AddGroupField | Aggiunge un campo alla clausola GROUP BY della SELECT.
Metodo pubblico | AddGroupFields | Aggiunge la lista dei campi alla clausola GROUP BY della SELECT.
Metodo pubblico | AddJoinQuery | Aggiunge il Join alla lista interna.
Metodo pubblico | AddOrderField | Aggiunge un campo alla clausola ORDER BY della SELECT.
Metodo pubblico | AddOrderFields | Aggiunge la lista dei campi alla clausola ORDER BY della SELECT.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Sovrascrive QSCommandBaseIsEqualTo(QSCommandBase))
Metodo pubblico | MakeReader | Crea e restituisce un reader inizializzandolo con i dati impostati nell'oggetto. La connessione deve essere già aperta prima di chiamare questo metodo, altrimenti viene restituito null. È responsabilità del chiamante chiamare il close() sul DbDataReader restituito.
Metodo protetto | OnReadRecord | Chiama l'evento di elaborazione record.
Metodo pubblico | ResetReadRecordEvent | Azzera le la lista dei delegate che si sono registrati per l'evento ReadRecord.
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue la query e la lettura ciclica dei dati. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | RunScalar | Esegue una queri in modo scalare e restituisce il risultato del primo campo della prima riga.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ReadRecord | Evento chiamato sulla lettura del singolo record.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSSelectCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QSSelectCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QSSelectCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QSSelectCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà di QSSelectCommand

Il tipo QSSelectCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Desc | Restituisce o imposta se l'ordinamento debba essere decrescente. Viene ignorato se la lista dei campi dell'ordinamento è vuota.
Proprietà pubblica | DisableLogException | Se true le eventuali eccezioni nei command non vengono loggate
Proprietà pubblica | Distinct | Restituisce o imposta se la SELECT è preceduta dalla clausola DISTINCT.
Proprietà pubblica | Fields | Restituisce la lista dei campi/elementi sui quali eseguire la SELECT. Se la lista dei campi è vuota viene fatta una query con '*'.
Proprietà pubblica | GroupFields | Restituisce la lista dei campi sui quali eseguire la clausola GROUP BY della SELECT.
Proprietà pubblica | OrderFields | Restituisce la lista dei campi sui quali eseguire la clausola ORDER BY della SELECT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | ReadRecordEventAlreadyRegistered | Restituisce true se risulta già registrato un delegate per l'evento ReadRecord altrimenti restituisce false.
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SELECT completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | TopNumber | Restituisce ed imposta il numero di righe da visualizzare nella clausola TOP. Specificare -1 se non deve essere presente (default).
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Proprietà pubblica | XLock | Indica se bloccare il set di righe in attesa di lettura di dati commitati
Torna su
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.Desc

Proprietà QSSelectCommandDesc
Restituisce o imposta se l'ordinamento debba essere decrescente. Viene ignorato se la lista dei campi dell'ordinamento è vuota.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Desc { get; set; }
Public Property Desc As Boolean
    Get
    Set
public:
property bool Desc {
    bool get ();
    void set (bool value);
}
member Desc : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.DisableLogException

Proprietà QSSelectCommandDisableLogException
Se true le eventuali eccezioni nei command non vengono loggate

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableLogException { get; set; }
Public Property DisableLogException As Boolean
    Get
    Set
public:
property bool DisableLogException {
    bool get ();
    void set (bool value);
}
member DisableLogException : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.Distinct

Proprietà QSSelectCommandDistinct
Restituisce o imposta se la SELECT è preceduta dalla clausola DISTINCT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Distinct { get; set; }
Public Property Distinct As Boolean
    Get
    Set
public:
property bool Distinct {
    bool get ();
    void set (bool value);
}
member Distinct : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.Fields

Proprietà QSSelectCommandFields
Restituisce la lista dei campi/elementi sui quali eseguire la SELECT. Se la lista dei campi è vuota viene fatta una query con '*'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IList<ISqlStatement> Fields { get; }
Public ReadOnly Property Fields As IList(Of ISqlStatement)
    Get
public:
property IList<ISqlStatement^>^ Fields {
    IList<ISqlStatement^>^ get ();
}
member Fields : IList<ISqlStatement> with get

Valore della proprietà

IList ISqlStatement
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.GroupFields

Proprietà QSSelectCommandGroupFields
Restituisce la lista dei campi sui quali eseguire la clausola GROUP BY della SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IList<string> GroupFields { get; }
Public ReadOnly Property GroupFields As IList(Of String)
    Get
public:
property IList<String^>^ GroupFields {
    IList<String^>^ get ();
}
member GroupFields : IList<string> with get

Valore della proprietà

IList String
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.OrderFields

Proprietà QSSelectCommandOrderFields
Restituisce la lista dei campi sui quali eseguire la clausola ORDER BY della SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IList<string> OrderFields { get; }
Public ReadOnly Property OrderFields As IList(Of String)
    Get
public:
property IList<String^>^ OrderFields {
    IList<String^>^ get ();
}
member OrderFields : IList<string> with get

Valore della proprietà

IList String
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.ReadRecordEventAlreadyRegistered

Proprietà QSSelectCommandReadRecordEventAlreadyRegistered
Restituisce true se risulta già registrato un delegate per l'evento ReadRecord altrimenti restituisce false.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadRecordEventAlreadyRegistered { get; }
Public ReadOnly Property ReadRecordEventAlreadyRegistered As Boolean
    Get
public:
property bool ReadRecordEventAlreadyRegistered {
    bool get ();
}
member ReadRecordEventAlreadyRegistered : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.RowLock

Proprietà QSSelectCommandRowLock

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RowLock { get; set; }
Public Property RowLock As Boolean
    Get
    Set
public:
property bool RowLock {
    bool get ();
    void set (bool value);
}
member RowLock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.SqlStatement

Proprietà QSSelectCommandSqlStatement
Restituisce l'istruzione SELECT completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.SqlText

Proprietà QSSelectCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.TopNumber

Proprietà QSSelectCommandTopNumber
Restituisce ed imposta il numero di righe da visualizzare nella clausola TOP. Specificare -1 se non deve essere presente (default).

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int TopNumber { get; set; }
Public Property TopNumber As Integer
    Get
    Set
public:
property int TopNumber {
    int get ();
    void set (int value);
}
member TopNumber : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe QSSelectCommand


Proprietà QSSelectCommand.XLock

Proprietà QSSelectCommandXLock
Indica se bloccare il set di righe in attesa di lettura di dati commitati

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool XLock { get; set; }
Public Property XLock As Boolean
    Get
    Set
public:
property bool XLock {
    bool get ();
    void set (bool value);
}
member XLock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSelectCommand


Metodi di QSSelectCommand

Il tipo QSSelectCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(ISqlStatement) | Aggiunge un elemento libero alla lista dei campi. Non aggiunge nessun parametro al comando.
Metodo pubblico | AddField(String) | Aggiunge un campo alla SELECT.
Metodo pubblico | AddField(String, Boolean) | Aggiunge un campo alla SELECT.
Metodo pubblico | AddFields | Aggiunge la lista dei campi alla SELECT.
Metodo pubblico | AddFunction(String, String) | Permette di inserire nella clausola SELECT una funzione di aggregazione.
Metodo pubblico | AddFunction(String, String, String) | Permette di inserire nella clausola SELECT una funzione di aggregazione.
Metodo pubblico | AddGroupField | Aggiunge un campo alla clausola GROUP BY della SELECT.
Metodo pubblico | AddGroupFields | Aggiunge la lista dei campi alla clausola GROUP BY della SELECT.
Metodo pubblico | AddJoinQuery | Aggiunge il Join alla lista interna.
Metodo pubblico | AddOrderField | Aggiunge un campo alla clausola ORDER BY della SELECT.
Metodo pubblico | AddOrderFields | Aggiunge la lista dei campi alla clausola ORDER BY della SELECT.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Sovrascrive QSCommandBaseIsEqualTo(QSCommandBase))
Metodo pubblico | MakeReader | Crea e restituisce un reader inizializzandolo con i dati impostati nell'oggetto. La connessione deve essere già aperta prima di chiamare questo metodo, altrimenti viene restituito null. È responsabilità del chiamante chiamare il close() sul DbDataReader restituito.
Metodo protetto | OnReadRecord | Chiama l'evento di elaborazione record.
Metodo pubblico | ResetReadRecordEvent | Azzera le la lista dei delegate che si sono registrati per l'evento ReadRecord.
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue la query e la lettura ciclica dei dati. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | RunScalar | Esegue una queri in modo scalare e restituisce il risultato del primo campo della prima riga.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddField

Metodo QSSelectCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(ISqlStatement) | Aggiunge un elemento libero alla lista dei campi. Non aggiunge nessun parametro al comando.
Metodo pubblico | AddField(String) | Aggiunge un campo alla SELECT.
Metodo pubblico | AddField(String, Boolean) | Aggiunge un campo alla SELECT.
Torna su
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddField(ISqlStatement)

Metodo QSSelectCommandAddField(ISqlStatement)
Aggiunge un elemento libero alla lista dei campi. Non aggiunge nessun parametro al comando.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    ISqlStatement statement
)
Public Sub AddField (
    statement As ISqlStatement
)
public:
void AddField(
    ISqlStatement^ statement
)
member AddField :
        statement : ISqlStatement -> unit

Parametri

statement ISqlStatement
Elemento libero da aggiungere alla lista dei campi.
Vedi anche

Documentazione

Classe QSSelectCommand
Overload di AddField


Metodo QSSelectCommand.AddField(String)

Metodo QSSelectCommandAddField(String)
Aggiunge un campo alla SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName
)
Public Sub AddField (
    fieldName As String
)
public:
void AddField(
    String^ fieldName
)
member AddField :
        fieldName : string -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe QSSelectCommand
Overload di AddField


Metodo QSSelectCommand.AddField(String, Boolean)

Metodo QSSelectCommandAddField(String, Boolean)
Aggiunge un campo alla SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    bool ignoreDuplicate
)
Public Sub AddField (
    fieldName As String,
    ignoreDuplicate As Boolean
)
public:
void AddField(
    String^ fieldName,
    bool ignoreDuplicate
)
member AddField :
        fieldName : string *
        ignoreDuplicate : bool -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
ignoreDuplicate Boolean
Se true inserisce anche campi doppi altimenti si comporta come AddField(string fieldName)
Vedi anche

Documentazione

Classe QSSelectCommand
Overload di AddField


Metodo QSSelectCommand.AddFields

Metodo QSSelectCommandAddFields
Aggiunge la lista dei campi alla SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddFields(
    string[] fieldList
)
Public Sub AddFields (
    fieldList As String()
)
public:
void AddFields(
    array<String^>^ fieldList
)
member AddFields :
        fieldList : string[] -> unit

Parametri

fieldList String
Lista dei nomi di campo da aggiungere.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddFunction

Metodo QSSelectCommandAddFunction
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddFunction(String, String) | Permette di inserire nella clausola SELECT una funzione di aggregazione.
Metodo pubblico | AddFunction(String, String, String) | Permette di inserire nella clausola SELECT una funzione di aggregazione.
Torna su
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddFunction(String, String)

Metodo QSSelectCommandAddFunction(String, String)
Permette di inserire nella clausola SELECT una funzione di aggregazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddFunction(
    string fieldName,
    string funcName
)
Public Sub AddFunction (
    fieldName As String,
    funcName As String
)
public:
void AddFunction(
    String^ fieldName,
    String^ funcName
)
member AddFunction :
        fieldName : string *
        funcName : string -> unit

Parametri

fieldName String
Nome del campo al quale applicare la funzione (se null viene utilizzato l'asterisco '*').
funcName String
Nome della funzione di aggragazione: COUNT, MAX, MIN, AVERAGE, ecc.
Vedi anche

Documentazione

Classe QSSelectCommand
Overload di AddFunction


Metodo QSSelectCommand.AddFunction(String, String, String)

Metodo QSSelectCommandAddFunction(String, String, String)
Permette di inserire nella clausola SELECT una funzione di aggregazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddFunction(
    string fieldName,
    string funcName,
    string asNome
)
Public Sub AddFunction (
    fieldName As String,
    funcName As String,
    asNome As String
)
public:
void AddFunction(
    String^ fieldName,
    String^ funcName,
    String^ asNome
)
member AddFunction :
        fieldName : string *
        funcName : string *
        asNome : string -> unit

Parametri

fieldName String
Nome del campo al quale applicare la funzione (se null viene utilizzato l'asterisco '*').
funcName String
Nome della funzione di aggragazione: COUNT, MAX, MIN, AVERAGE, ecc.
asNome String
Vedi anche

Documentazione

Classe QSSelectCommand
Overload di AddFunction


Metodo QSSelectCommand.AddGroupField

Metodo QSSelectCommandAddGroupField
Aggiunge un campo alla clausola GROUP BY della SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddGroupField(
    string fieldName
)
Public Sub AddGroupField (
    fieldName As String
)
public:
void AddGroupField(
    String^ fieldName
)
member AddGroupField :
        fieldName : string -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddGroupFields

Metodo QSSelectCommandAddGroupFields
Aggiunge la lista dei campi alla clausola GROUP BY della SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddGroupFields(
    string[] fieldList
)
Public Sub AddGroupFields (
    fieldList As String()
)
public:
void AddGroupFields(
    array<String^>^ fieldList
)
member AddGroupFields :
        fieldList : string[] -> unit

Parametri

fieldList String
Lista dei nomi di campo da aggiungere.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddJoinQuery

Metodo QSSelectCommandAddJoinQuery
Aggiunge il Join alla lista interna.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddJoinQuery(
    QSSqlJoinQuery join
)
Public Sub AddJoinQuery (
    join As QSSqlJoinQuery
)
public:
void AddJoinQuery(
    QSSqlJoinQuery^ join
)
member AddJoinQuery :
        join : QSSqlJoinQuery -> unit

Parametri

join QSSqlJoinQuery

Valore di ritorno

Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddOrderField

Metodo QSSelectCommandAddOrderField
Aggiunge un campo alla clausola ORDER BY della SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddOrderField(
    string fieldName
)
Public Sub AddOrderField (
    fieldName As String
)
public:
void AddOrderField(
    String^ fieldName
)
member AddOrderField :
        fieldName : string -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.AddOrderFields

Metodo QSSelectCommandAddOrderFields
Aggiunge la lista dei campi alla clausola ORDER BY della SELECT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddOrderFields(
    string[] fieldList
)
Public Sub AddOrderFields (
    fieldList As String()
)
public:
void AddOrderFields(
    array<String^>^ fieldList
)
member AddOrderFields :
        fieldList : string[] -> unit

Parametri

fieldList String
Lista dei nomi di campo da aggiungere.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.ContainsField

Metodo QSSelectCommandContainsField
Verifica se un campo esiste già.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsField(
    string fieldName
)
Public Function ContainsField (
    fieldName As String
) As Boolean
public:
bool ContainsField(
    String^ fieldName
)
member ContainsField :
        fieldName : string -> bool

Parametri

fieldName String
Nome del campo da verificare.

Valore di ritorno

Boolean
Restituisce true se esiste altrimenti false.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.IsEqualTo

Metodo QSSelectCommandIsEqualTo
Confronta un comando con questa istanza.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsEqualTo(
    QSCommandBase cmd
)
Public Overrides Function IsEqualTo (
    cmd As QSCommandBase
) As Boolean
public:
virtual bool IsEqualTo(
    QSCommandBase^ cmd
) override
abstract IsEqualTo :
        cmd : QSCommandBase -> bool
override IsEqualTo :
        cmd : QSCommandBase -> bool

Parametri

cmd QSCommandBase
Comando da comparare.

Valore di ritorno

Boolean
Restituisce true se il comando passato è uguale a questo oppure false.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.MakeReader

Metodo QSSelectCommandMakeReader
Crea e restituisce un reader inizializzandolo con i dati impostati nell'oggetto. La connessione deve essere già aperta prima di chiamare questo metodo, altrimenti viene restituito null. È responsabilità del chiamante chiamare il close() sul DbDataReader restituito.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbDataReader MakeReader()
Public Function MakeReader As DbDataReader
public:
DbDataReader^ MakeReader()
member MakeReader : unit -> DbDataReader

Valore di ritorno

DbDataReader
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.OnReadRecord

Metodo QSSelectCommandOnReadRecord
Chiama l'evento di elaborazione record.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnReadRecord(
    RecordReaderEventArgs e
)
Protected Overridable Sub OnReadRecord (
    e As RecordReaderEventArgs
)
protected:
virtual void OnReadRecord(
    RecordReaderEventArgs^ e
)
abstract OnReadRecord :
        e : RecordReaderEventArgs -> unit
override OnReadRecord :
        e : RecordReaderEventArgs -> unit

Parametri

e RecordReaderEventArgs
Informazioni sull'evento.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.ResetReadRecordEvent

Metodo QSSelectCommandResetReadRecordEvent
Azzera le la lista dei delegate che si sono registrati per l'evento ReadRecord.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetReadRecordEvent()
Public Sub ResetReadRecordEvent
public:
void ResetReadRecordEvent()
member ResetReadRecordEvent : unit -> unit
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.ResetSqlText

Metodo QSSelectCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.Run

Metodo QSSelectCommandRun
Esegue la query e la lettura ciclica dei dati. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Run(
    Object data
)
Public Function Run (
    data As Object
) As Boolean
public:
bool Run(
    Object^ data
)
member Run :
        data : Object -> bool

Parametri

data Object
Dati aggiuntivi da passare all'evento.

Valore di ritorno

Boolean
Restituisce true se l'esecuzione riesce altrimenti false.
Vedi anche

Documentazione

Classe QSSelectCommand


Metodo QSSelectCommand.RunScalar

Metodo QSSelectCommandRunScalar
Esegue una queri in modo scalare e restituisce il risultato del primo campo della prima riga.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object RunScalar()
Public Function RunScalar As Object
public:
Object^ RunScalar()
member RunScalar : unit -> Object

Valore di ritorno

Object
Restituisce il risultato della query oppure null.
Vedi anche

Documentazione

Classe QSSelectCommand


Eventi di QSSelectCommand

Il tipo QSSelectCommand espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ReadRecord | Evento chiamato sulla lettura del singolo record.
Torna su
Vedi anche

Documentazione

Classe QSSelectCommand


Evento QSSelectCommand.ReadRecord

Evento QSSelectCommandReadRecord
Evento chiamato sulla lettura del singolo record.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RecordReaderEventArgs> ReadRecord
Public Event ReadRecord As EventHandler(Of RecordReaderEventArgs)
public:
 event EventHandler<RecordReaderEventArgs^>^ ReadRecord {
    void add (EventHandler<RecordReaderEventArgs^>^ value);
    void remove (EventHandler<RecordReaderEventArgs^>^ value);
}
member ReadRecord : IEvent<EventHandler<RecordReaderEventArgs>,
    RecordReaderEventArgs>

Valore

EventHandler RecordReaderEventArgs
Vedi anche

Documentazione

Classe QSSelectCommand


Classe QSSql
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSql

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class QSSql
Public NotInheritable Class QSSql
public ref class QSSql abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QSSql = class end

Il tipo QSSql espone i seguenti membri.

Metodi
Nome | Descrizione
DateAreEquals | Verifica se due date siano uguali confrontando fino ai secondi.
Guid2String | Converte da Guid a stringa in base 64.
IsDBNull | REstitusice true se il campo è nullo.
ReadBool | Legge un valore bool da un oggetto DbDataReader e lo restituisce.
ReadBytes | Legge un array di byte da un DbDataReader e lo restituisce.
ReadDateTime | Legge un valore DateTime da un oggetto DbDataReader e lo restituisce.
ReadDouble | Legge un valore double da un oggetto DbDataReader e lo restituisce.
ReadGuid | Legge un valore Guid salvato come stringa di 22 caratteri, da un oggetto DbDataReader e lo restituisce come Guid.
ReadInt | Legge un valore int da un oggetto DbDataReader e lo restituisce.
ReadInt64 | Legge un valore Int64 (long) da un DbDataReader e lo restituisce.
ReadRealBool | Legge un valore bool da un oggetto DbDataReader e lo restituisce.
ReadString | Legge un valore stringa da un oggetto DbDataReader e lo restituisce.
SqlEscapeWildCards | Racchiude i caratteri utilizzati dal LIKE tra parentesi quadre.
String2Guid | Converte da stringa in base 64 a Guid.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di QSSql

Il tipo QSSql espone i seguenti membri.

Metodi
Nome | Descrizione
DateAreEquals | Verifica se due date siano uguali confrontando fino ai secondi.
Guid2String | Converte da Guid a stringa in base 64.
IsDBNull | REstitusice true se il campo è nullo.
ReadBool | Legge un valore bool da un oggetto DbDataReader e lo restituisce.
ReadBytes | Legge un array di byte da un DbDataReader e lo restituisce.
ReadDateTime | Legge un valore DateTime da un oggetto DbDataReader e lo restituisce.
ReadDouble | Legge un valore double da un oggetto DbDataReader e lo restituisce.
ReadGuid | Legge un valore Guid salvato come stringa di 22 caratteri, da un oggetto DbDataReader e lo restituisce come Guid.
ReadInt | Legge un valore int da un oggetto DbDataReader e lo restituisce.
ReadInt64 | Legge un valore Int64 (long) da un DbDataReader e lo restituisce.
ReadRealBool | Legge un valore bool da un oggetto DbDataReader e lo restituisce.
ReadString | Legge un valore stringa da un oggetto DbDataReader e lo restituisce.
SqlEscapeWildCards | Racchiude i caratteri utilizzati dal LIKE tra parentesi quadre.
String2Guid | Converte da stringa in base 64 a Guid.
Torna su
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.DateAreEquals

Metodo QSSqlDateAreEquals
Verifica se due date siano uguali confrontando fino ai secondi.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool DateAreEquals(
    DateTime date1,
    DateTime date2
)
Public Shared Function DateAreEquals (
    date1 As DateTime,
    date2 As DateTime
) As Boolean
public:
static bool DateAreEquals(
    DateTime date1,
    DateTime date2
)
static member DateAreEquals :
        date1 : DateTime *
        date2 : DateTime -> bool

Parametri

date1 DateTime
Prima data da confrontare.
date2 DateTime

Valore di ritorno

Boolean
Restituisce true se le date sono uguali altrienti false.
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.Guid2String

Metodo QSSqlGuid2String
Converte da Guid a stringa in base 64.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string Guid2String(
    Guid value
)
Public Shared Function Guid2String (
    value As Guid
) As String
public:
static String^ Guid2String(
    Guid value
)
static member Guid2String :
        value : Guid -> string

Parametri

value Guid

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.IsDBNull

Metodo QSSqlIsDBNull
REstitusice true se il campo è nullo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDBNull(
    DbDataReader rd,
    int idx
)
Public Shared Function IsDBNull (
    rd As DbDataReader,
    idx As Integer
) As Boolean
public:
static bool IsDBNull(
    DbDataReader^ rd,
    int idx
)
static member IsDBNull :
        rd : DbDataReader *
        idx : int -> bool

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
idx Int32
Indice al quale si trova il campo da leggere.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadBool

Metodo QSSqlReadBool
Legge un valore bool da un oggetto DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ReadBool(
    DbDataReader rd,
    bool defval,
    ref int idx
)
Public Shared Function ReadBool (
    rd As DbDataReader,
    defval As Boolean,
    ByRef idx As Integer
) As Boolean
public:
static bool ReadBool(
    DbDataReader^ rd,
    bool defval,
    int% idx
)
static member ReadBool :
        rd : DbDataReader *
        defval : bool *
        idx : int byref -> bool

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Boolean
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadBytes

Metodo QSSqlReadBytes
Legge un array di byte da un DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static byte[] ReadBytes(
    DbDataReader rd,
    byte[] defval,
    ref int idx
)
Public Shared Function ReadBytes (
    rd As DbDataReader,
    defval As Byte(),
    ByRef idx As Integer
) As Byte()
public:
static array<unsigned char>^ ReadBytes(
    DbDataReader^ rd,
    array<unsigned char>^ defval,
    int% idx
)
static member ReadBytes :
        rd : DbDataReader *
        defval : byte[] *
        idx : int byref -> byte[]

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Byte
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Byte
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadDateTime

Metodo QSSqlReadDateTime
Legge un valore DateTime da un oggetto DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DateTime? ReadDateTime(
    DbDataReader rd,
    DateTime? defval,
    ref int idx
)
Public Shared Function ReadDateTime (
    rd As DbDataReader,
    defval As DateTime?,
    ByRef idx As Integer
) As DateTime?
public:
static Nullable<DateTime> ReadDateTime(
    DbDataReader^ rd,
    Nullable<DateTime> defval,
    int% idx
)
static member ReadDateTime :
        rd : DbDataReader *
        defval : Nullable<DateTime> *
        idx : int byref -> Nullable<DateTime>

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Nullable DateTime
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Nullable DateTime
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadDouble

Metodo QSSqlReadDouble
Legge un valore double da un oggetto DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static double ReadDouble(
    DbDataReader rd,
    double defval,
    ref int idx
)
Public Shared Function ReadDouble (
    rd As DbDataReader,
    defval As Double,
    ByRef idx As Integer
) As Double
public:
static double ReadDouble(
    DbDataReader^ rd,
    double defval,
    int% idx
)
static member ReadDouble :
        rd : DbDataReader *
        defval : float *
        idx : int byref -> float

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Double
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Double
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadGuid

Metodo QSSqlReadGuid
Legge un valore Guid salvato come stringa di 22 caratteri, da un oggetto DbDataReader e lo restituisce come Guid.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid ReadGuid(
    DbDataReader rd,
    Guid defval,
    ref int idx
)
Public Shared Function ReadGuid (
    rd As DbDataReader,
    defval As Guid,
    ByRef idx As Integer
) As Guid
public:
static Guid ReadGuid(
    DbDataReader^ rd,
    Guid defval,
    int% idx
)
static member ReadGuid :
        rd : DbDataReader *
        defval : Guid *
        idx : int byref -> Guid

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Guid
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadInt

Metodo QSSqlReadInt
Legge un valore int da un oggetto DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int ReadInt(
    DbDataReader rd,
    int defval,
    ref int idx
)
Public Shared Function ReadInt (
    rd As DbDataReader,
    defval As Integer,
    ByRef idx As Integer
) As Integer
public:
static int ReadInt(
    DbDataReader^ rd,
    int defval,
    int% idx
)
static member ReadInt :
        rd : DbDataReader *
        defval : int *
        idx : int byref -> int

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Int32
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadInt64

Metodo QSSqlReadInt64
Legge un valore Int64 (long) da un DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static long ReadInt64(
    DbDataReader rd,
    long defval,
    ref int idx
)
Public Shared Function ReadInt64 (
    rd As DbDataReader,
    defval As Long,
    ByRef idx As Integer
) As Long
public:
static long long ReadInt64(
    DbDataReader^ rd,
    long long defval,
    int% idx
)
static member ReadInt64 :
        rd : DbDataReader *
        defval : int64 *
        idx : int byref -> int64

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Int64
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Int64
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadRealBool

Metodo QSSqlReadRealBool
Legge un valore bool da un oggetto DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ReadRealBool(
    DbDataReader rd,
    bool defval,
    ref int idx
)
Public Shared Function ReadRealBool (
    rd As DbDataReader,
    defval As Boolean,
    ByRef idx As Integer
) As Boolean
public:
static bool ReadRealBool(
    DbDataReader^ rd,
    bool defval,
    int% idx
)
static member ReadRealBool :
        rd : DbDataReader *
        defval : bool *
        idx : int byref -> bool

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval Boolean
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.ReadString

Metodo QSSqlReadString
Legge un valore stringa da un oggetto DbDataReader e lo restituisce.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ReadString(
    DbDataReader rd,
    string defval,
    ref int idx
)
Public Shared Function ReadString (
    rd As DbDataReader,
    defval As String,
    ByRef idx As Integer
) As String
public:
static String^ ReadString(
    DbDataReader^ rd,
    String^ defval,
    int% idx
)
static member ReadString :
        rd : DbDataReader *
        defval : string *
        idx : int byref -> string

Parametri

rd DbDataReader
Oggetto DbDataReader dal quale leggere il valore.
defval String
Valore di default da restituire in caso di valore NULL.
idx Int32
Indice al quale si trova il campo da leggere. Questo indice viene incrementato di 1 prima di restituire il valore al chiamante.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.SqlEscapeWildCards

Metodo QSSqlSqlEscapeWildCards
Racchiude i caratteri utilizzati dal LIKE tra parentesi quadre.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string SqlEscapeWildCards(
    string str
)
Public Shared Function SqlEscapeWildCards (
    str As String
) As String
public:
static String^ SqlEscapeWildCards(
    String^ str
)
static member SqlEscapeWildCards :
        str : string -> string

Parametri

str String
Stringa da elaborare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe QSSql


Metodo QSSql.String2Guid

Metodo QSSqlString2Guid
Converte da stringa in base 64 a Guid.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid String2Guid(
    string guid
)
Public Shared Function String2Guid (
    guid As String
) As Guid
public:
static Guid String2Guid(
    String^ guid
)
static member String2Guid :
        guid : string -> Guid

Parametri

guid String

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe QSSql


Classe QSSqlBetweenOperator
Descrive un operatore BETWEEN che lega tre elementi. Es: (A BETWEEN B AND C).
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlBetweenOperator

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlBetweenOperator : QSSqlStatementBase
Public Class QSSqlBetweenOperator
    Inherits QSSqlStatementBase
public ref class QSSqlBetweenOperator : public QSSqlStatementBase
type QSSqlBetweenOperator =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlBetweenOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | MaxValue | Restituisce il valore massimo della comparazione.
Proprietà pubblica | MinValue | Restituisce il valore minimo della comparazione.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | Subject | Restituisce il soggetto della comparazione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlBetweenOperator

Il tipo QSSqlBetweenOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | MaxValue | Restituisce il valore massimo della comparazione.
Proprietà pubblica | MinValue | Restituisce il valore minimo della comparazione.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | Subject | Restituisce il soggetto della comparazione.
Torna su
Vedi anche

Documentazione

Classe QSSqlBetweenOperator


Proprietà QSSqlBetweenOperator.MaxValue

Proprietà QSSqlBetweenOperatorMaxValue
Restituisce il valore massimo della comparazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement MaxValue { get; }
Public ReadOnly Property MaxValue As ISqlStatement
    Get
public:
property ISqlStatement^ MaxValue {
    ISqlStatement^ get ();
}
member MaxValue : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlBetweenOperator


Proprietà QSSqlBetweenOperator.MinValue

Proprietà QSSqlBetweenOperatorMinValue
Restituisce il valore minimo della comparazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement MinValue { get; }
Public ReadOnly Property MinValue As ISqlStatement
    Get
public:
property ISqlStatement^ MinValue {
    ISqlStatement^ get ();
}
member MinValue : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlBetweenOperator


Proprietà QSSqlBetweenOperator.SqlStatement

Proprietà QSSqlBetweenOperatorSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlBetweenOperator


Proprietà QSSqlBetweenOperator.Subject

Proprietà QSSqlBetweenOperatorSubject
Restituisce il soggetto della comparazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement Subject { get; }
Public ReadOnly Property Subject As ISqlStatement
    Get
public:
property ISqlStatement^ Subject {
    ISqlStatement^ get ();
}
member Subject : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlBetweenOperator


Metodi di QSSqlBetweenOperator

Il tipo QSSqlBetweenOperator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlBetweenOperator


Classe QSSqlBinaryOperator
Descrive un operatore binario che lega due elementi. Es: (A = B).
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlBinaryOperator

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlBinaryOperator : QSSqlStatementBase
Public Class QSSqlBinaryOperator
    Inherits QSSqlStatementBase
public ref class QSSqlBinaryOperator : public QSSqlStatementBase
type QSSqlBinaryOperator =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlBinaryOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LeftSide | Restituisce l'elemento alla sinistra dell'operatore.
Proprietà pubblica | Operator | Restituisce l'operatore.
Proprietà pubblica | RightSide | Restituisce l'elemento alla destra dell'operatore.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlBinaryOperator

Il tipo QSSqlBinaryOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LeftSide | Restituisce l'elemento alla sinistra dell'operatore.
Proprietà pubblica | Operator | Restituisce l'operatore.
Proprietà pubblica | RightSide | Restituisce l'elemento alla destra dell'operatore.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlBinaryOperator


Proprietà QSSqlBinaryOperator.LeftSide

Proprietà QSSqlBinaryOperatorLeftSide
Restituisce l'elemento alla sinistra dell'operatore.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement LeftSide { get; }
Public ReadOnly Property LeftSide As ISqlStatement
    Get
public:
property ISqlStatement^ LeftSide {
    ISqlStatement^ get ();
}
member LeftSide : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlBinaryOperator


Proprietà QSSqlBinaryOperator.Operator

Proprietà QSSqlBinaryOperatorOperator
Restituisce l'operatore.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SqlBinaryOperatorEnum Operator { get; }
Public ReadOnly Property Operator As SqlBinaryOperatorEnum
    Get
public:
property SqlBinaryOperatorEnum Operator {
    SqlBinaryOperatorEnum get ();
}
member Operator : SqlBinaryOperatorEnum with get

Valore della proprietà

SqlBinaryOperatorEnum
Vedi anche

Documentazione

Classe QSSqlBinaryOperator


Proprietà QSSqlBinaryOperator.RightSide

Proprietà QSSqlBinaryOperatorRightSide
Restituisce l'elemento alla destra dell'operatore.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement RightSide { get; }
Public ReadOnly Property RightSide As ISqlStatement
    Get
public:
property ISqlStatement^ RightSide {
    ISqlStatement^ get ();
}
member RightSide : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlBinaryOperator


Proprietà QSSqlBinaryOperator.SqlStatement

Proprietà QSSqlBinaryOperatorSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlBinaryOperator


Metodi di QSSqlBinaryOperator

Il tipo QSSqlBinaryOperator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlBinaryOperator


Classe QSSqlColumnField
Descrive un singolo campo di una istruzione di modifica/aggiunta di un campo.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlColumnField

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlColumnField : QSSqlStatementBase
Public Class QSSqlColumnField
    Inherits QSSqlStatementBase
public ref class QSSqlColumnField : public QSSqlStatementBase
type QSSqlColumnField =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlColumnField espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo.
Proprietà pubblica | Lunghezza |
Proprietà pubblica | NotNull |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | Tipo |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlColumnField

Il tipo QSSqlColumnField espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo.
Proprietà pubblica | Lunghezza |
Proprietà pubblica | NotNull |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | Tipo |
Torna su
Vedi anche

Documentazione

Classe QSSqlColumnField


Proprietà QSSqlColumnField.Connection

Proprietà QSSqlColumnFieldConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlColumnField


Proprietà QSSqlColumnField.FieldName

Proprietà QSSqlColumnFieldFieldName
Restituisce il nome del campo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlColumnField


Proprietà QSSqlColumnField.Lunghezza

Proprietà QSSqlColumnFieldLunghezza

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Lunghezza { get; }
Public ReadOnly Property Lunghezza As Integer
    Get
public:
property int Lunghezza {
    int get ();
}
member Lunghezza : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe QSSqlColumnField


Proprietà QSSqlColumnField.NotNull

Proprietà QSSqlColumnFieldNotNull

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotNull { get; }
Public ReadOnly Property NotNull As Boolean
    Get
public:
property bool NotNull {
    bool get ();
}
member NotNull : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSqlColumnField


Proprietà QSSqlColumnField.SqlStatement

Proprietà QSSqlColumnFieldSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlColumnField


Proprietà QSSqlColumnField.Tipo

Proprietà QSSqlColumnFieldTipo

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Type Tipo { get; }
Public ReadOnly Property Tipo As Type
    Get
public:
property Type^ Tipo {
    Type^ get ();
}
member Tipo : Type with get

Valore della proprietà

Type
Vedi anche

Documentazione

Classe QSSqlColumnField


Metodi di QSSqlColumnField

Il tipo QSSqlColumnField espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlColumnField


Classe QSSqlCommaStatementList
Lista di elementi ISqlStatement che vengono concatenati con una virgola.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ISqlStatement
QSAdoNetQSSqlCommaStatementList

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlCommaStatementList : List<ISqlStatement>,
    ISqlStatement
Public Class QSSqlCommaStatementList
    Inherits List(Of ISqlStatement)
    Implements ISqlStatement
public ref class QSSqlCommaStatementList : public List<ISqlStatement^>,
    ISqlStatement
type QSSqlCommaStatementList =
    class
        inherit List<ISqlStatement>
        interface ISqlStatement
    end

Il tipo QSSqlCommaStatementList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSSqlCommaStatementList | Inizializza una nuova istanza della classe QSSqlCommaStatementList.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSSqlCommaStatementList
Inizializza una nuova istanza della classe QSSqlCommaStatementList.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlCommaStatementList()
Public Sub New
public:
QSSqlCommaStatementList()
new : unit -> QSSqlCommaStatementList
Vedi anche

Documentazione

Classe QSSqlCommaStatementList


Proprietà di QSSqlCommaStatementList

Il tipo QSSqlCommaStatementList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL.
Torna su
Vedi anche

Documentazione

Classe QSSqlCommaStatementList


Proprietà QSSqlCommaStatementList.SqlStatement

Proprietà QSSqlCommaStatementListSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlStatement { get; }
Public ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () sealed;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlCommaStatementList


Metodi di QSSqlCommaStatementList

Il tipo QSSqlCommaStatementList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Classe QSSqlCommaStatementList


Metodo QSSqlCommaStatementList.Equals

Metodo QSSqlCommaStatementListEquals

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSSqlCommaStatementList


Metodo QSSqlCommaStatementList.GetHashCode

Metodo QSSqlCommaStatementListGetHashCode

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe QSSqlCommaStatementList


Classe QSSqlField
Descrive un singolo campo di una istruzione SQL.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlField

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlField : QSSqlStatementBase
Public Class QSSqlField
    Inherits QSSqlStatementBase
public ref class QSSqlField : public QSSqlStatementBase
type QSSqlField =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlField espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlField

Il tipo QSSqlField espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlField


Proprietà QSSqlField.Connection

Proprietà QSSqlFieldConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlField


Proprietà QSSqlField.FieldName

Proprietà QSSqlFieldFieldName
Restituisce il nome del campo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlField


Proprietà QSSqlField.SqlStatement

Proprietà QSSqlFieldSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlField


Metodi di QSSqlField

Il tipo QSSqlField espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlField


Classe QSSqlFunction
Descrive una funzione di aggregazione come COUNT, SUM, MAX, MIN, AVERAGE.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlFunction

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlFunction : QSSqlStatementBase
Public Class QSSqlFunction
    Inherits QSSqlStatementBase
public ref class QSSqlFunction : public QSSqlStatementBase
type QSSqlFunction =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlFunction espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AsNome |
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo oppure null se si utilizza '*'.
Proprietà pubblica | FuncName | Restituisce il nome della funzione di aggregazione.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlFunction

Il tipo QSSqlFunction espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AsNome |
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo oppure null se si utilizza '*'.
Proprietà pubblica | FuncName | Restituisce il nome della funzione di aggregazione.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlFunction


Proprietà QSSqlFunction.AsNome

Proprietà QSSqlFunctionAsNome

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AsNome { get; }
Public ReadOnly Property AsNome As String
    Get
public:
property String^ AsNome {
    String^ get ();
}
member AsNome : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunction


Proprietà QSSqlFunction.Connection

Proprietà QSSqlFunctionConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlFunction


Proprietà QSSqlFunction.FieldName

Proprietà QSSqlFunctionFieldName
Restituisce il nome del campo oppure null se si utilizza '*'.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunction


Proprietà QSSqlFunction.FuncName

Proprietà QSSqlFunctionFuncName
Restituisce il nome della funzione di aggregazione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FuncName { get; }
Public ReadOnly Property FuncName As String
    Get
public:
property String^ FuncName {
    String^ get ();
}
member FuncName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunction


Proprietà QSSqlFunction.SqlStatement

Proprietà QSSqlFunctionSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlFunction


Metodi di QSSqlFunction

Il tipo QSSqlFunction espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlFunction


Classe QSSqlFunctionReplace
Descrive una funzione di replace
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlFunctionReplace

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlFunctionReplace : QSSqlStatementBase
Public Class QSSqlFunctionReplace
    Inherits QSSqlStatementBase
public ref class QSSqlFunctionReplace : public QSSqlStatementBase
type QSSqlFunctionReplace =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlFunctionReplace espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo
Proprietà pubblica | FuncName | Restituisce il nome della funzione
Proprietà pubblica | NewValue | Restituisce il valore di sostituzione
Proprietà pubblica | OldValue | Restituisce il valore da sostituire
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlFunctionReplace

Il tipo QSSqlFunctionReplace espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo
Proprietà pubblica | FuncName | Restituisce il nome della funzione
Proprietà pubblica | NewValue | Restituisce il valore di sostituzione
Proprietà pubblica | OldValue | Restituisce il valore da sostituire
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Proprietà QSSqlFunctionReplace.Connection

Proprietà QSSqlFunctionReplaceConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Proprietà QSSqlFunctionReplace.FieldName

Proprietà QSSqlFunctionReplaceFieldName
Restituisce il nome del campo

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Proprietà QSSqlFunctionReplace.FuncName

Proprietà QSSqlFunctionReplaceFuncName
Restituisce il nome della funzione

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FuncName { get; }
Public ReadOnly Property FuncName As String
    Get
public:
property String^ FuncName {
    String^ get ();
}
member FuncName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Proprietà QSSqlFunctionReplace.NewValue

Proprietà QSSqlFunctionReplaceNewValue
Restituisce il valore di sostituzione

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewValue { get; }
Public ReadOnly Property NewValue As String
    Get
public:
property String^ NewValue {
    String^ get ();
}
member NewValue : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Proprietà QSSqlFunctionReplace.OldValue

Proprietà QSSqlFunctionReplaceOldValue
Restituisce il valore da sostituire

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldValue { get; }
Public ReadOnly Property OldValue As String
    Get
public:
property String^ OldValue {
    String^ get ();
}
member OldValue : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Proprietà QSSqlFunctionReplace.SqlStatement

Proprietà QSSqlFunctionReplaceSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Metodi di QSSqlFunctionReplace

Il tipo QSSqlFunctionReplace espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlFunctionReplace


Classe QSSqlInQuery
Crea una sottoquery in forma: "CAMPO IN ('valore1','valore2',....)".
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlInQuery

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlInQuery : QSSqlStatementBase
Public Class QSSqlInQuery
    Inherits QSSqlStatementBase
public ref class QSSqlInQuery : public QSSqlStatementBase
type QSSqlInQuery =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlInQuery espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo da utilizzare nella sottoquery.
Proprietà pubblica | InList | Restituisce se debba essere negata o meno l'inclusione.
Proprietà pubblica | List | Restituisce la lista di oggetti da controllare.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlInQuery

Il tipo QSSqlInQuery espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo da utilizzare nella sottoquery.
Proprietà pubblica | InList | Restituisce se debba essere negata o meno l'inclusione.
Proprietà pubblica | List | Restituisce la lista di oggetti da controllare.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlInQuery


Proprietà QSSqlInQuery.Connection

Proprietà QSSqlInQueryConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlInQuery


Proprietà QSSqlInQuery.FieldName

Proprietà QSSqlInQueryFieldName
Restituisce il nome del campo da utilizzare nella sottoquery.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlInQuery


Proprietà QSSqlInQuery.InList

Proprietà QSSqlInQueryInList
Restituisce se debba essere negata o meno l'inclusione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool InList { get; }
Public ReadOnly Property InList As Boolean
    Get
public:
property bool InList {
    bool get ();
}
member InList : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSqlInQuery


Proprietà QSSqlInQuery.List

Proprietà QSSqlInQueryList
Restituisce la lista di oggetti da controllare.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> List { get; }
Public ReadOnly Property List As List(Of String)
    Get
public:
property List<String^>^ List {
    List<String^>^ get ();
}
member List : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe QSSqlInQuery


Proprietà QSSqlInQuery.SqlStatement

Proprietà QSSqlInQuerySqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlInQuery


Metodi di QSSqlInQuery

Il tipo QSSqlInQuery espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlInQuery


Classe QSSqlJoinQuery
Crea una JOIN in forma: "XXX JOIN TABLE/(SELECT) ON ....".
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlJoinQuery

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlJoinQuery : QSSqlStatementBase
Public Class QSSqlJoinQuery
    Inherits QSSqlStatementBase
public ref class QSSqlJoinQuery : public QSSqlStatementBase
type QSSqlJoinQuery =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlJoinQuery espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSSqlJoinQuery(QSConnection, SqlJoinEnum, String) | Crea una sintassi per il Join. Esempio : INNER JOIN tableName
Metodo pubblico | QSSqlJoinQuery(QSConnection, SqlJoinEnum, QSSelectCommand, String) | Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | JoinType | Tipologia di Join
Proprietà pubblica | SelectCmd | Select sul quale fare il Join (in alternativa a TableName)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | TableName | Tabella sulla quale fare il Join
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddOnClause | Aggiunge la clausula ON alla Join
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSSqlJoinQuery
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | QSSqlJoinQuery(QSConnection, SqlJoinEnum, String) | Crea una sintassi per il Join. Esempio : INNER JOIN tableName
Metodo pubblico | QSSqlJoinQuery(QSConnection, SqlJoinEnum, QSSelectCommand, String) | Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias
Torna su
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Costruttore QSSqlJoinQuery(QSConnection, SqlJoinEnum, String)
Crea una sintassi per il Join. Esempio : INNER JOIN tableName

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlJoinQuery(
    QSConnection conn,
    SqlJoinEnum joinType,
    string tablename
)
Public Sub New (
    conn As QSConnection,
    joinType As SqlJoinEnum,
    tablename As String
)
public:
QSSqlJoinQuery(
    QSConnection^ conn,
    SqlJoinEnum joinType,
    String^ tablename
)
new :
        conn : QSConnection *
        joinType : SqlJoinEnum *
        tablename : string -> QSSqlJoinQuery

Parametri

conn QSConnection
Connessione.
joinType SqlJoinEnum
Tipologia di Join
tablename String
Tabella sulla quale effettuare il Join
Vedi anche

Documentazione

Classe QSSqlJoinQuery
Overload di QSSqlJoinQuery


Costruttore QSSqlJoinQuery(QSConnection, SqlJoinEnum, QSSelectCommand, String)
Crea una sintassi per il Join. Esempio : INNER JOIN (SELECT .... ) alias

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlJoinQuery(
    QSConnection conn,
    SqlJoinEnum joinType,
    QSSelectCommand selcmd,
    string alias
)
Public Sub New (
    conn As QSConnection,
    joinType As SqlJoinEnum,
    selcmd As QSSelectCommand,
    alias As String
)
public:
QSSqlJoinQuery(
    QSConnection^ conn,
    SqlJoinEnum joinType,
    QSSelectCommand^ selcmd,
    String^ alias
)
new :
        conn : QSConnection *
        joinType : SqlJoinEnum *
        selcmd : QSSelectCommand *
        alias : string -> QSSqlJoinQuery

Parametri

conn QSConnection
Connessione.
joinType SqlJoinEnum
Tipologia di Join
selcmd QSSelectCommand
Select da usare come tabella di Join
alias String
Alias della select passata
Vedi anche

Documentazione

Classe QSSqlJoinQuery
Overload di QSSqlJoinQuery


Proprietà di QSSqlJoinQuery

Il tipo QSSqlJoinQuery espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | JoinType | Tipologia di Join
Proprietà pubblica | SelectCmd | Select sul quale fare il Join (in alternativa a TableName)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | TableName | Tabella sulla quale fare il Join
Torna su
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Proprietà QSSqlJoinQuery.Connection

Proprietà QSSqlJoinQueryConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Proprietà QSSqlJoinQuery.JoinType

Proprietà QSSqlJoinQueryJoinType
Tipologia di Join

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SqlJoinEnum JoinType { get; }
Public ReadOnly Property JoinType As SqlJoinEnum
    Get
public:
property SqlJoinEnum JoinType {
    SqlJoinEnum get ();
}
member JoinType : SqlJoinEnum with get

Valore della proprietà

SqlJoinEnum
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Proprietà QSSqlJoinQuery.SelectCmd

Proprietà QSSqlJoinQuerySelectCmd
Select sul quale fare il Join (in alternativa a TableName)

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSelectCommand SelectCmd { get; }
Public ReadOnly Property SelectCmd As QSSelectCommand
    Get
public:
property QSSelectCommand^ SelectCmd {
    QSSelectCommand^ get ();
}
member SelectCmd : QSSelectCommand with get

Valore della proprietà

QSSelectCommand
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Proprietà QSSqlJoinQuery.SqlStatement

Proprietà QSSqlJoinQuerySqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Proprietà QSSqlJoinQuery.TableName

Proprietà QSSqlJoinQueryTableName
Tabella sulla quale fare il Join

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TableName { get; }
Public ReadOnly Property TableName As String
    Get
public:
property String^ TableName {
    String^ get ();
}
member TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Metodi di QSSqlJoinQuery

Il tipo QSSqlJoinQuery espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddOnClause | Aggiunge la clausula ON alla Join
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Metodo QSSqlJoinQuery.AddOnClause

Metodo QSSqlJoinQueryAddOnClause
Aggiunge la clausula ON alla Join

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddOnClause(
    SqlBinaryOperatorEnum precOperator,
    string tableNameJ1,
    string fieldNameJ1,
    SqlBinaryOperatorEnum comparator,
    string tableNameJ2,
    string fieldNameJ2
)
Public Sub AddOnClause (
    precOperator As SqlBinaryOperatorEnum,
    tableNameJ1 As String,
    fieldNameJ1 As String,
    comparator As SqlBinaryOperatorEnum,
    tableNameJ2 As String,
    fieldNameJ2 As String
)
public:
void AddOnClause(
    SqlBinaryOperatorEnum precOperator,
    String^ tableNameJ1,
    String^ fieldNameJ1,
    SqlBinaryOperatorEnum comparator,
    String^ tableNameJ2,
    String^ fieldNameJ2
)
member AddOnClause :
        precOperator : SqlBinaryOperatorEnum *
        tableNameJ1 : string *
        fieldNameJ1 : string *
        comparator : SqlBinaryOperatorEnum *
        tableNameJ2 : string *
        fieldNameJ2 : string -> unit

Parametri

precOperator SqlBinaryOperatorEnum
Operatore dal collegare all'operazione precedente
tableNameJ1 String
Nome della tabella di riferimento del primo field
fieldNameJ1 String
Nome del campo sul quale effettuare il controllo
comparator SqlBinaryOperatorEnum
Tipologia di comparazione
tableNameJ2 String
Nome della tabella di riferimento del secondo field
fieldNameJ2 String
Nome del campo sul quale effettuare il controllo
Vedi anche

Documentazione

Classe QSSqlJoinQuery


Classe QSSqlLikeOperator
Descrive un operatore LIKE. Es: (A LIKE @A) dove @A è una stringa con %.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlLikeOperator

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlLikeOperator : QSSqlStatementBase
Public Class QSSqlLikeOperator
    Inherits QSSqlStatementBase
public ref class QSSqlLikeOperator : public QSSqlStatementBase
type QSSqlLikeOperator =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlLikeOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | EscapeValue | Simbolo di escape usato in SqlCe
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | Subject | Restituisce il soggetto della comparazione (di solito il campo).
Proprietà pubblica | Value | Restituisce la stringa da valutare dal LIKE.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlLikeOperator

Il tipo QSSqlLikeOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | EscapeValue | Simbolo di escape usato in SqlCe
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | Subject | Restituisce il soggetto della comparazione (di solito il campo).
Proprietà pubblica | Value | Restituisce la stringa da valutare dal LIKE.
Torna su
Vedi anche

Documentazione

Classe QSSqlLikeOperator


Proprietà QSSqlLikeOperator.EscapeValue

Proprietà QSSqlLikeOperatorEscapeValue
Simbolo di escape usato in SqlCe

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public char EscapeValue { get; }
Public ReadOnly Property EscapeValue As Char
    Get
public:
property wchar_t EscapeValue {
    wchar_t get ();
}
member EscapeValue : char with get

Valore della proprietà

Char
Vedi anche

Documentazione

Classe QSSqlLikeOperator


Proprietà QSSqlLikeOperator.SqlStatement

Proprietà QSSqlLikeOperatorSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlLikeOperator


Proprietà QSSqlLikeOperator.Subject

Proprietà QSSqlLikeOperatorSubject
Restituisce il soggetto della comparazione (di solito il campo).

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement Subject { get; }
Public ReadOnly Property Subject As ISqlStatement
    Get
public:
property ISqlStatement^ Subject {
    ISqlStatement^ get ();
}
member Subject : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlLikeOperator


Proprietà QSSqlLikeOperator.Value

Proprietà QSSqlLikeOperatorValue
Restituisce la stringa da valutare dal LIKE.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get
public:
property String^ Value {
    String^ get ();
}
member Value : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlLikeOperator


Metodi di QSSqlLikeOperator

Il tipo QSSqlLikeOperator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlLikeOperator


Classe QSSqlLiteral
Descrive un singolo campo di una istruzione SQL.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlLiteral

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlLiteral : QSSqlStatementBase
Public Class QSSqlLiteral
    Inherits QSSqlStatementBase
public ref class QSSqlLiteral : public QSSqlStatementBase
type QSSqlLiteral =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlLiteral espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Literal | Espressione stringa libera.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlLiteral

Il tipo QSSqlLiteral espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Literal | Espressione stringa libera.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlLiteral


Proprietà QSSqlLiteral.Literal

Proprietà QSSqlLiteralLiteral
Espressione stringa libera.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Literal { get; }
Public ReadOnly Property Literal As String
    Get
public:
property String^ Literal {
    String^ get ();
}
member Literal : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlLiteral


Proprietà QSSqlLiteral.SqlStatement

Proprietà QSSqlLiteralSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlLiteral


Metodi di QSSqlLiteral

Il tipo QSSqlLiteral espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlLiteral


Classe QSSqlSpaceStatementList
Lista di elementi ISqlStatement che vengono concatenati da spazio e racchiusi tra parentesi.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ISqlStatement
QSAdoNetQSSqlSpaceStatementList

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlSpaceStatementList : List<ISqlStatement>,
    ISqlStatement
Public Class QSSqlSpaceStatementList
    Inherits List(Of ISqlStatement)
    Implements ISqlStatement
public ref class QSSqlSpaceStatementList : public List<ISqlStatement^>,
    ISqlStatement
type QSSqlSpaceStatementList =
    class
        inherit List<ISqlStatement>
        interface ISqlStatement
    end

Il tipo QSSqlSpaceStatementList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSSqlSpaceStatementList | Inizializza una nuova istanza della classe QSSqlSpaceStatementList.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSSqlSpaceStatementList
Inizializza una nuova istanza della classe QSSqlSpaceStatementList.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlSpaceStatementList()
Public Sub New
public:
QSSqlSpaceStatementList()
new : unit -> QSSqlSpaceStatementList
Vedi anche

Documentazione

Classe QSSqlSpaceStatementList


Proprietà di QSSqlSpaceStatementList

Il tipo QSSqlSpaceStatementList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL.
Torna su
Vedi anche

Documentazione

Classe QSSqlSpaceStatementList


Proprietà QSSqlSpaceStatementList.SqlStatement

Proprietà QSSqlSpaceStatementListSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlStatement { get; }
Public ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () sealed;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlSpaceStatementList


Metodi di QSSqlSpaceStatementList

Il tipo QSSqlSpaceStatementList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Classe QSSqlSpaceStatementList


Metodo QSSqlSpaceStatementList.Equals

Metodo QSSqlSpaceStatementListEquals

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSSqlSpaceStatementList


Metodo QSSqlSpaceStatementList.GetHashCode

Metodo QSSqlSpaceStatementListGetHashCode

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe QSSqlSpaceStatementList


Classe QSSqlStatementBase
Classe base per tutti gli elementi di una istruzione SQL.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
Altro

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class QSSqlStatementBase : ISqlStatement
Public MustInherit Class QSSqlStatementBase
    Implements ISqlStatement
public ref class QSSqlStatementBase abstract : ISqlStatement
[<AbstractClassAttribute>]
type QSSqlStatementBase =
    class
        interface ISqlStatement
    end

Il tipo QSSqlStatementBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSSqlStatementBase | Inizializza una nuova istanza della classe QSSqlStatementBase.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlBetweenOperator
QSAdoNetQSSqlBinaryOperator
QSAdoNetQSSqlColumnField
QSAdoNetQSSqlField
QSAdoNetQSSqlFunction
QSAdoNetQSSqlFunctionReplace
QSAdoNetQSSqlInQuery
QSAdoNetQSSqlJoinQuery
QSAdoNetQSSqlLikeOperator
QSAdoNetQSSqlLiteral
QSAdoNetQSSqlSubQuery
QSAdoNetQSSqlUnaryOperator


Costruttore QSSqlStatementBase
Inizializza una nuova istanza della classe QSSqlStatementBase.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected QSSqlStatementBase()
Protected Sub New
protected:
QSSqlStatementBase()
new : unit -> QSSqlStatementBase
Vedi anche

Documentazione

Classe QSSqlStatementBase


Proprietà di QSSqlStatementBase

Il tipo QSSqlStatementBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SqlStatement |
Torna su
Vedi anche

Documentazione

Classe QSSqlStatementBase


Proprietà QSSqlStatementBase.SqlStatement

Proprietà QSSqlStatementBaseSqlStatement

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string SqlStatement { get; }
Public MustOverride ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () abstract;
}
abstract SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlStatementBase


Metodi di QSSqlStatementBase

Il tipo QSSqlStatementBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Classe QSSqlStatementBase


Metodo QSSqlStatementBase.Equals

Metodo QSSqlStatementBaseEquals

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe QSSqlStatementBase


Metodo QSSqlStatementBase.GetHashCode

Metodo QSSqlStatementBaseGetHashCode

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe QSSqlStatementBase


Classe QSSqlSubQuery
Crea una sottoquery in forma: "CAMPO IN (SELECT ....)".
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlSubQuery

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlSubQuery : QSSqlStatementBase
Public Class QSSqlSubQuery
    Inherits QSSqlStatementBase
public ref class QSSqlSubQuery : public QSSqlStatementBase
type QSSqlSubQuery =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlSubQuery espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo da utilizzare nella sottoquery.
Proprietà pubblica | NotIn | Restituisce se debba essere negata l'inclusione.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | SubCmd | Restituisce il comando che implementa la subquery.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlSubQuery

Il tipo QSSqlSubQuery espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce la connessione.
Proprietà pubblica | FieldName | Restituisce il nome del campo da utilizzare nella sottoquery.
Proprietà pubblica | NotIn | Restituisce se debba essere negata l'inclusione.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Proprietà pubblica | SubCmd | Restituisce il comando che implementa la subquery.
Torna su
Vedi anche

Documentazione

Classe QSSqlSubQuery


Proprietà QSSqlSubQuery.Connection

Proprietà QSSqlSubQueryConnection
Restituisce la connessione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
property QSConnection^ Connection {
    QSConnection^ get ();
}
member Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe QSSqlSubQuery


Proprietà QSSqlSubQuery.FieldName

Proprietà QSSqlSubQueryFieldName
Restituisce il nome del campo da utilizzare nella sottoquery.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSSqlSubQuery


Proprietà QSSqlSubQuery.NotIn

Proprietà QSSqlSubQueryNotIn
Restituisce se debba essere negata l'inclusione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotIn { get; }
Public ReadOnly Property NotIn As Boolean
    Get
public:
property bool NotIn {
    bool get ();
}
member NotIn : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSSqlSubQuery


Proprietà QSSqlSubQuery.SqlStatement

Proprietà QSSqlSubQuerySqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlSubQuery


Proprietà QSSqlSubQuery.SubCmd

Proprietà QSSqlSubQuerySubCmd
Restituisce il comando che implementa la subquery.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSelectCommand SubCmd { get; }
Public ReadOnly Property SubCmd As QSSelectCommand
    Get
public:
property QSSelectCommand^ SubCmd {
    QSSelectCommand^ get ();
}
member SubCmd : QSSelectCommand with get

Valore della proprietà

QSSelectCommand
Vedi anche

Documentazione

Classe QSSqlSubQuery


Metodi di QSSqlSubQuery

Il tipo QSSqlSubQuery espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlSubQuery


Classe QSSqlUnaryOperator
Descrive un operatore unario legato ad un elemento. Es: "NOT (...)".
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSSqlStatementBase
QSAdoNetQSSqlUnaryOperator

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSSqlUnaryOperator : QSSqlStatementBase
Public Class QSSqlUnaryOperator
    Inherits QSSqlStatementBase
public ref class QSSqlUnaryOperator : public QSSqlStatementBase
type QSSqlUnaryOperator =
    class
        inherit QSSqlStatementBase
    end

Il tipo QSSqlUnaryOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Expression | Restituisce l'elemento da abbinare all'operatore.
Proprietà pubblica | Operator | Restituisce l'operatore.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QSSqlUnaryOperator

Il tipo QSSqlUnaryOperator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Expression | Restituisce l'elemento da abbinare all'operatore.
Proprietà pubblica | Operator | Restituisce l'operatore.
Proprietà pubblica | SqlStatement | Restituisce l'istruzione SQL. (Sovrascrive QSSqlStatementBaseSqlStatement)
Torna su
Vedi anche

Documentazione

Classe QSSqlUnaryOperator


Proprietà QSSqlUnaryOperator.Expression

Proprietà QSSqlUnaryOperatorExpression
Restituisce l'elemento da abbinare all'operatore.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ISqlStatement Expression { get; }
Public ReadOnly Property Expression As ISqlStatement
    Get
public:
property ISqlStatement^ Expression {
    ISqlStatement^ get ();
}
member Expression : ISqlStatement with get

Valore della proprietà

ISqlStatement
Vedi anche

Documentazione

Classe QSSqlUnaryOperator


Proprietà QSSqlUnaryOperator.Operator

Proprietà QSSqlUnaryOperatorOperator
Restituisce l'operatore.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SqlUnaryOperatorEnum Operator { get; }
Public ReadOnly Property Operator As SqlUnaryOperatorEnum
    Get
public:
property SqlUnaryOperatorEnum Operator {
    SqlUnaryOperatorEnum get ();
}
member Operator : SqlUnaryOperatorEnum with get

Valore della proprietà

SqlUnaryOperatorEnum
Vedi anche

Documentazione

Classe QSSqlUnaryOperator


Proprietà QSSqlUnaryOperator.SqlStatement

Proprietà QSSqlUnaryOperatorSqlStatement
Restituisce l'istruzione SQL.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSSqlUnaryOperator


Metodi di QSSqlUnaryOperator

Il tipo QSSqlUnaryOperator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da QSSqlStatementBase)
Metodo pubblico | GetHashCode | (Ereditato da QSSqlStatementBase)
Torna su
Vedi anche

Documentazione

Classe QSSqlUnaryOperator


Classe QSUpdateCommand
Implementa le funzionalità di UPDATE.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQSUpdateCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSUpdateCommand : QSCommandBase
Public Class QSUpdateCommand
    Inherits QSCommandBase
public ref class QSUpdateCommand : public QSCommandBase
type QSUpdateCommand =
    class
        inherit QSCommandBase
    end

Il tipo QSUpdateCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSUpdateCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | FieldValueDictionary | Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".
Proprietà pubblica | Function | Lista dei nomi campo per la funzione REPLACE
Proprietà pubblica | Item | Imposta o restituisce il valore di un campo della clausola INSERT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione UPDATE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddFunction | Permette di inserire nella clausola UPDATE la funzione di REPLACE
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetField | Restituisce il valore abbinato al campo specificato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di UPDATE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSUpdateCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QSUpdateCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QSUpdateCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QSUpdateCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà di QSUpdateCommand

Il tipo QSUpdateCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | FieldValueDictionary | Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".
Proprietà pubblica | Function | Lista dei nomi campo per la funzione REPLACE
Proprietà pubblica | Item | Imposta o restituisce il valore di un campo della clausola INSERT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione UPDATE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà QSUpdateCommand.FieldValueDictionary

Proprietà QSUpdateCommandFieldValueDictionary
Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> FieldValueDictionary { get; }
Public ReadOnly Property FieldValueDictionary As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ FieldValueDictionary {
    Dictionary<String^, String^>^ get ();
}
member FieldValueDictionary : Dictionary<string, string> with get

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà QSUpdateCommand.Function

Proprietà QSUpdateCommandFunction
Lista dei nomi campo per la funzione REPLACE

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSqlCommaStatementList Function { get; }
Public ReadOnly Property Function As QSSqlCommaStatementList
    Get
public:
property QSSqlCommaStatementList^ Function {
    QSSqlCommaStatementList^ get ();
}
member Function : QSSqlCommaStatementList with get

Valore della proprietà

QSSqlCommaStatementList
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà QSUpdateCommand.Item

Proprietà QSUpdateCommandItem
Imposta o restituisce il valore di un campo della clausola INSERT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object this[
    string fieldName
] { get; set; }
Public Default Property Item (
    fieldName As String
) As Object
    Get
    Set
public:
property Object^ default[String^ fieldName] {
    Object^ get (String^ fieldName);
    void set (String^ fieldName, Object^ value);
}
member Item : Object with get, set

Parametri

fieldName String
Nome del campo.

Valore di ritorno

Object
Restituisce il valore del campo oppure null se non esiste.
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà QSUpdateCommand.RowLock

Proprietà QSUpdateCommandRowLock

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RowLock { get; set; }
Public Property RowLock As Boolean
    Get
    Set
public:
property bool RowLock {
    bool get ();
    void set (bool value);
}
member RowLock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà QSUpdateCommand.SqlStatement

Proprietà QSUpdateCommandSqlStatement
Restituisce l'istruzione UPDATE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSUpdateCommand


Proprietà QSUpdateCommand.SqlText

Proprietà QSUpdateCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodi di QSUpdateCommand

Il tipo QSUpdateCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddFunction | Permette di inserire nella clausola UPDATE la funzione di REPLACE
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetField | Restituisce il valore abbinato al campo specificato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di UPDATE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodo QSUpdateCommand.AddField

Metodo QSUpdateCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Torna su
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodo QSUpdateCommand.AddField(String, Object)

Metodo QSUpdateCommandAddField(String, Object)
Aggiunge un campo all'istruzione INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Object fieldValue
)
Public Sub AddField (
    fieldName As String,
    fieldValue As Object
)
public:
void AddField(
    String^ fieldName,
    Object^ fieldValue
)
member AddField :
        fieldName : string *
        fieldValue : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
fieldValue Object
Valore del campo da aggiungere.
Vedi anche

Documentazione

Classe QSUpdateCommand
Overload di AddField


Metodo QSUpdateCommand.AddField(String, String, Object)

Metodo QSUpdateCommandAddField(String, String, Object)
Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    string paramName,
    Object paramValue
)
Public Sub AddField (
    fieldName As String,
    paramName As String,
    paramValue As Object
)
public:
void AddField(
    String^ fieldName,
    String^ paramName,
    Object^ paramValue
)
member AddField :
        fieldName : string *
        paramName : string *
        paramValue : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
paramName String
Nome del parametro.
paramValue Object
Valore del parametro.
Vedi anche

Documentazione

Classe QSUpdateCommand
Overload di AddField


Metodo QSUpdateCommand.AddField(String, String, Object, DbType)

Metodo QSUpdateCommandAddField(String, String, Object, DbType)
Aggiunge un campo all'istruzione INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    string paramName,
    Object paramValue,
    DbType dbT
)
Public Sub AddField (
    fieldName As String,
    paramName As String,
    paramValue As Object,
    dbT As DbType
)
public:
void AddField(
    String^ fieldName,
    String^ paramName,
    Object^ paramValue,
    DbType dbT
)
member AddField :
        fieldName : string *
        paramName : string *
        paramValue : Object *
        dbT : DbType -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
paramName String
Nome del parametro.
paramValue Object
Valore del parametro.
dbT DbType
Tipo dati presente nel Database.
Vedi anche

Documentazione

Classe QSUpdateCommand
Overload di AddField


Metodo QSUpdateCommand.AddFunction

Metodo QSUpdateCommandAddFunction
Permette di inserire nella clausola UPDATE la funzione di REPLACE

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddFunction(
    string fieldName,
    string funcName,
    string oldValue,
    string newValue
)
Public Sub AddFunction (
    fieldName As String,
    funcName As String,
    oldValue As String,
    newValue As String
)
public:
void AddFunction(
    String^ fieldName,
    String^ funcName,
    String^ oldValue,
    String^ newValue
)
member AddFunction :
        fieldName : string *
        funcName : string *
        oldValue : string *
        newValue : string -> unit

Parametri

fieldName String
Nome del campo al quale applicare la funzione
funcName String
Nome della funzione
oldValue String
Valore da sostituire
newValue String
Valore di sostituzione
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodo QSUpdateCommand.ContainsField

Metodo QSUpdateCommandContainsField
Verifica se un campo esiste già.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsField(
    string fieldName
)
Public Function ContainsField (
    fieldName As String
) As Boolean
public:
bool ContainsField(
    String^ fieldName
)
member ContainsField :
        fieldName : string -> bool

Parametri

fieldName String
Nome del campo da verificare.

Valore di ritorno

Boolean
Restituisce true se esiste altrimenti false.
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodo QSUpdateCommand.GetField

Metodo QSUpdateCommandGetField
Restituisce il valore abbinato al campo specificato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetField(
    string fieldName
)
Public Function GetField (
    fieldName As String
) As Object
public:
Object^ GetField(
    String^ fieldName
)
member GetField :
        fieldName : string -> Object

Parametri

fieldName String
Nome del campo del quale restituire il valore.

Valore di ritorno

Object
Restituisce il valore del campo oppure null se non esiste.
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodo QSUpdateCommand.ResetSqlText

Metodo QSUpdateCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QSUpdateCommand


Metodo QSUpdateCommand.Run

Metodo QSUpdateCommandRun
Esegue l'istruzione di UPDATE. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'aggiornamento.
Vedi anche

Documentazione

Classe QSUpdateCommand


Classe QsUpdateFieldCommand
Classe per alterare un insieme di campi di una tabella.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQsUpdateFieldCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsUpdateFieldCommand : QSCommandBase
Public Class QsUpdateFieldCommand
    Inherits QSCommandBase
public ref class QsUpdateFieldCommand : public QSCommandBase
type QsUpdateFieldCommand =
    class
        inherit QSCommandBase
    end

Il tipo QsUpdateFieldCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QsUpdateFieldCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsUpdateFieldCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QsUpdateFieldCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QsUpdateFieldCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QsUpdateFieldCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Proprietà di QsUpdateFieldCommand

Il tipo QsUpdateFieldCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | SqlStatement | Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Proprietà QsUpdateFieldCommand.SqlStatement

Proprietà QsUpdateFieldCommandSqlStatement
Restituisce l'istruzione completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Proprietà QsUpdateFieldCommand.SqlText

Proprietà QsUpdateFieldCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Metodi di QsUpdateFieldCommand

Il tipo QsUpdateFieldCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Metodo QsUpdateFieldCommand.AddField

Metodo QsUpdateFieldCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(String, Type, Int32, Boolean) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object) | Aggiunge un campo alla lista dei campi da modificare.
Metodo pubblico | AddField(String, Type, Int32, Boolean, Object, Int32, Int32) | Aggiunge un campo alla lista dei campi da modificare.
Torna su
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Metodo QsUpdateFieldCommand.AddField(String, Type, Int32, Boolean)

Metodo QsUpdateFieldCommandAddField(String, Type, Int32, Boolean)
Aggiunge un campo alla lista dei campi da modificare.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
Vedi anche

Documentazione

Classe QsUpdateFieldCommand
Overload di AddField


Metodo QsUpdateFieldCommand.AddField(String, Type, Int32, Boolean, Object)

Metodo QsUpdateFieldCommandAddField(String, Type, Int32, Boolean, Object)
Aggiunge un campo alla lista dei campi da modificare.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull,
    Object defVal
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull,
    Object^ defVal
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
Vedi anche

Documentazione

Classe QsUpdateFieldCommand
Overload di AddField


Metodo QsUpdateFieldCommand.AddField(String, Type, Int32, Boolean, Object, Int32, Int32)

Metodo QsUpdateFieldCommandAddField(String, Type, Int32, Boolean, Object, Int32, Int32)
Aggiunge un campo alla lista dei campi da modificare.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Type type,
    int lunghezza,
    bool notNull,
    Object defVal,
    int identitySeed,
    int identityIncrement
)
Public Sub AddField (
    fieldName As String,
    type As Type,
    lunghezza As Integer,
    notNull As Boolean,
    defVal As Object,
    identitySeed As Integer,
    identityIncrement As Integer
)
public:
void AddField(
    String^ fieldName,
    Type^ type,
    int lunghezza,
    bool notNull,
    Object^ defVal,
    int identitySeed,
    int identityIncrement
)
member AddField :
        fieldName : string *
        type : Type *
        lunghezza : int *
        notNull : bool *
        defVal : Object *
        identitySeed : int *
        identityIncrement : int -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
type Type
Tipo di dato del campo.
lunghezza Int32
Lunghezza del campo ( usata solo se tipo di campo è testo )
notNull Boolean
Indica se il campo non deve essere annullabile
defVal Object
identitySeed Int32
identityIncrement Int32
Vedi anche

Documentazione

Classe QsUpdateFieldCommand
Overload di AddField


Metodo QsUpdateFieldCommand.ResetSqlText

Metodo QsUpdateFieldCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Metodo QsUpdateFieldCommand.Run

Metodo QsUpdateFieldCommandRun
Esegue l'istruzione.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'eliminazione.
Vedi anche

Documentazione

Classe QsUpdateFieldCommand


Classe QSUpdateInsertCommand
Implementa le funzionalità di UPDATE se il record esiste altrimenti effettua un INSERT. Nei Fileds inserire tutti i campi da aggiornare o inserire.
Gerarchia di ereditarietà
SystemObject
QSAdoNetQSCommandBase
QSAdoNetQSUpdateInsertCommand

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSUpdateInsertCommand : QSCommandBase
Public Class QSUpdateInsertCommand
    Inherits QSCommandBase
public ref class QSUpdateInsertCommand : public QSCommandBase
type QSUpdateInsertCommand =
    class
        inherit QSCommandBase
    end

Il tipo QSUpdateInsertCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | QSUpdateInsertCommand | Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | FieldValueDictionary | Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".
Proprietà pubblica | Item | Imposta o restituisce il valore di un campo della clausola UPDATE/INSERT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione UPDATE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione UPDATE/INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetField | Restituisce il valore abbinato al campo specificato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di UPDATE/INSERT. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QSUpdateInsertCommand
Crea l'oggetto inizializzando il riferimento alla connessione ed il nome della table.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal QSUpdateInsertCommand(
    QSConnection conn,
    string tableName
)
Protected Friend Sub New (
    conn As QSConnection,
    tableName As String
)
protected public:
QSUpdateInsertCommand(
    QSConnection^ conn,
    String^ tableName
)
new :
        conn : QSConnection *
        tableName : string -> QSUpdateInsertCommand

Parametri

conn QSConnection
Connessione non necessariamente aperta.
tableName String
Nome della table sulla quale effettuare l'istruzione.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Proprietà di QSUpdateInsertCommand

Il tipo QSUpdateInsertCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Alias | Restituisce o imposta l'alias della tabella. (Ereditato da QSCommandBase)
Proprietà pubblica | Command | Restituisce il comando utilizzato internamente. (Ereditato da QSCommandBase)
Proprietà pubblica | Connection | Restituisce l'oggetto connessione al quale questo comando appartiene. (Ereditato da QSCommandBase)
Proprietà pubblica | FieldValueDictionary | Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".
Proprietà pubblica | Item | Imposta o restituisce il valore di un campo della clausola UPDATE/INSERT.
Proprietà pubblica | Parameters | Restituisce la collezione contenente tutti i parametri presenti. (Ereditato da QSCommandBase)
Proprietà pubblica | RowLock |
Proprietà pubblica | SqlStatement | Restituisce l'istruzione UPDATE completa in base alle informazioni presenti nell'oggetto. (Sovrascrive QSCommandBaseSqlStatement)
Proprietà pubblica | SqlText | Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.
Proprietà pubblica | TableName | Restituisce o imposta il nome della tabella sulla quale effettuare il comando. Accetta anche la stringa vuota "" ma non il valore null. (Ereditato da QSCommandBase)
Proprietà pubblica | WhereList | Restituisce la lista delle istruzioni Where. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Proprietà QSUpdateInsertCommand.FieldValueDictionary

Proprietà QSUpdateInsertCommandFieldValueDictionary
Restituisce il dizionario con le coppie nome-valore da utilizzare nell'INSERT. Tipicamente "NomeCampo" = "@NomeCampo".

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> FieldValueDictionary { get; }
Public ReadOnly Property FieldValueDictionary As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ FieldValueDictionary {
    Dictionary<String^, String^>^ get ();
}
member FieldValueDictionary : Dictionary<string, string> with get

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Proprietà QSUpdateInsertCommand.Item

Proprietà QSUpdateInsertCommandItem
Imposta o restituisce il valore di un campo della clausola UPDATE/INSERT.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object this[
    string fieldName
] { get; set; }
Public Default Property Item (
    fieldName As String
) As Object
    Get
    Set
public:
property Object^ default[String^ fieldName] {
    Object^ get (String^ fieldName);
    void set (String^ fieldName, Object^ value);
}
member Item : Object with get, set

Parametri

fieldName String
Nome del campo.

Valore di ritorno

Object
Restituisce il valore del campo oppure null se non esiste.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Proprietà QSUpdateInsertCommand.RowLock

Proprietà QSUpdateInsertCommandRowLock

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RowLock { get; set; }
Public Property RowLock As Boolean
    Get
    Set
public:
property bool RowLock {
    bool get ();
    void set (bool value);
}
member RowLock : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Proprietà QSUpdateInsertCommand.SqlStatement

Proprietà QSUpdateInsertCommandSqlStatement
Restituisce l'istruzione UPDATE completa in base alle informazioni presenti nell'oggetto.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SqlStatement { get; }
Public Overrides ReadOnly Property SqlStatement As String
    Get
public:
virtual property String^ SqlStatement {
    String^ get () override;
}
abstract SqlStatement : string with get
override SqlStatement : string with get

Valore della proprietà

String

Implementa

ISqlStatementSqlStatement
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Proprietà QSUpdateInsertCommand.SqlText

Proprietà QSUpdateInsertCommandSqlText
Restituisce o imposta il testo che verrà utilizzato nella query SQL. Se questo valore non viene impostato verrà utilizzato il risultato di GetStatement() che calcola la query in base ai campi ed alle proprietà dell'oggetto, altrimenti verrà usata direttamente questa stringa nell'istruzione SQL senza effettuare alcun controllo.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SqlText { get; set; }
Public Property SqlText As String
    Get
    Set
public:
property String^ SqlText {
    String^ get ();
    void set (String^ value);
}
member SqlText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Metodi di QSUpdateInsertCommand

Il tipo QSUpdateInsertCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione UPDATE/INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddWhereBetween(String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(ISqlStatement) | Aggiunge alla clausola where l'elemento specificato anteponendo un AND logico. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereElement(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where l'elemento specificato. Se esiste un'altra espressione la lega con l'operatore specificato abbassandola di livello. Es: Clausola presente: (A=@A AND B=@B) ---> Diventa: ((A=@A AND B=@B) (Operatore) (WhereElementInserito)) Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereImpossible | Aggiunge alla clausola where la condizione 1 = 0 ovvero la condizione impossibile. Se esistono altre clausole where viene messa in AND logico con queste. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti anteponendo un AND logico. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, ISqlStatement) | Aggiunge alla clausola where un elemento accodandolo sullo stesso livello delle clausole precedenti. Se l'elemento passato è un QSCommandBase o una classe derivata, copia tutti i parametri presenti all'interno di questo comando e ne legge solo la clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro con comparatore Uguale. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereItem(SqlBinaryOperatorEnum, String, SqlBinaryOperatorEnum, String, Object) | Aggiunge alla clausola where un elemento ed un parametro contemporaneamente. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, Object, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. Crea i parametri con stesso nome di fieldName aggiungendo il suffisso MIN e MAX. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri ed anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotBetween(SqlBinaryOperatorEnum, String, String, Object, String, Object) | Aggiunge alla clausola where un elemento NOT BETWEEN creando contemporaneamente i parametri. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotInList(SqlBinaryOperatorEnum, String, ListString) | Aggiunge alla clausola where una condizione di non esistenza del campo in una lista di elementi. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. Quota sempre i caratteri speciali come '%' e '_'. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. Crea il parametro con stesso nome di fieldName. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNotLike(SqlBinaryOperatorEnum, String, SqlLikeOperatorEnum, String, String, Boolean) | Aggiunge alla clausola where un operatore NOT LIKE che verifica una stringa. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNull(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo NULL oppure NOT NULL. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo, anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereNullOrEmpty(SqlBinaryOperatorEnum, String, Boolean) | Aggiunge alla clausola where la verifica di un campo di tipo stringa che sia vuoto o nullo oppure non vuoto e non nullo. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery anteponendo un AND logico. (Ereditato da QSCommandBase)
Metodo pubblico | AddWhereSubquery(SqlBinaryOperatorEnum, String, Boolean, QSSelectCommand) | Aggiunge alla clausola where una sottoquery. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsField | Verifica se un campo esiste già.
Metodo pubblico | ContainsParameter | Verifica l'esistenza di un parametro. (Ereditato da QSCommandBase)
Metodo pubblico | ContainsWhereParameter | Verifica l'esistenza di un parametro dedicato alla clausola where. (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersFrom | Copia i parametri dal comando passato a questo oggetto (Ereditato da QSCommandBase)
Metodo pubblico | CopyParametersTo | Copia i parametri da questo oggetto al comando passato. (Ereditato da QSCommandBase)
Metodo pubblico | GetField | Restituisce il valore abbinato al campo specificato.
Metodo pubblico | GetParameterValue | Restituisce il valore di un parametro. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | GetWhereParameterValue | Restituisce il valore di un parametro dedicato alla clausola where. Se il parametro richiesto non è presente restituisce null. (Ereditato da QSCommandBase)
Metodo pubblico | IsEqualTo | Confronta un comando con questa istanza. (Ereditato da QSCommandBase)
Metodo pubblico | ResetSqlText | Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.
Metodo pubblico | Run | Esegue l'istruzione di UPDATE/INSERT. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.
Metodo pubblico | SetParameterValue(String, Object) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetParameterValue(String, Object, DbType) | Imposta il valore di un parametro. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. I parametri sono di default con direzione input e dello stesso tipo dati passato (riconoscimento automatico del DbType). (Ereditato da QSCommandBase)
Metodo pubblico | SetWhereParameterValue(String, Object, DbType) | Imposta il valore di un parametro dedicato alla clausola where. Se il parametro esiste già sovrascrive il valore. Forza il DbType del Database. (Ereditato da QSCommandBase)
Torna su
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Metodo QSUpdateInsertCommand.AddField

Metodo QSUpdateInsertCommandAddField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddField(String, Object) | Aggiunge un campo all'istruzione UPDATE/INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object) | Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore
Metodo pubblico | AddField(String, String, Object, DbType) | Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore
Torna su
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Metodo QSUpdateInsertCommand.AddField(String, Object)

Metodo QSUpdateInsertCommandAddField(String, Object)
Aggiunge un campo all'istruzione UPDATE/INSERT creando in automatico un parametro omonimo. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    Object fieldValue
)
Public Sub AddField (
    fieldName As String,
    fieldValue As Object
)
public:
void AddField(
    String^ fieldName,
    Object^ fieldValue
)
member AddField :
        fieldName : string *
        fieldValue : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
fieldValue Object
Valore del campo da aggiungere.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand
Overload di AddField


Metodo QSUpdateInsertCommand.AddField(String, String, Object)

Metodo QSUpdateInsertCommandAddField(String, String, Object)
Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    string paramName,
    Object paramValue
)
Public Sub AddField (
    fieldName As String,
    paramName As String,
    paramValue As Object
)
public:
void AddField(
    String^ fieldName,
    String^ paramName,
    Object^ paramValue
)
member AddField :
        fieldName : string *
        paramName : string *
        paramValue : Object -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
paramName String
Nome del parametro.
paramValue Object
Valore del parametro.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand
Overload di AddField


Metodo QSUpdateInsertCommand.AddField(String, String, Object, DbType)

Metodo QSUpdateInsertCommandAddField(String, String, Object, DbType)
Aggiunge un campo all'istruzione UPDATE/INSERT creando anche il parametro abbinato specificandone il DbType. Se il campo esiste già ne sovrascrive il valore

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName,
    string paramName,
    Object paramValue,
    DbType dbT
)
Public Sub AddField (
    fieldName As String,
    paramName As String,
    paramValue As Object,
    dbT As DbType
)
public:
void AddField(
    String^ fieldName,
    String^ paramName,
    Object^ paramValue,
    DbType dbT
)
member AddField :
        fieldName : string *
        paramName : string *
        paramValue : Object *
        dbT : DbType -> unit

Parametri

fieldName String
Nome del campo da aggiungere.
paramName String
Nome del parametro.
paramValue Object
Valore del parametro.
dbT DbType
Tipo dati presente nel Database.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand
Overload di AddField


Metodo QSUpdateInsertCommand.ContainsField

Metodo QSUpdateInsertCommandContainsField
Verifica se un campo esiste già.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsField(
    string fieldName
)
Public Function ContainsField (
    fieldName As String
) As Boolean
public:
bool ContainsField(
    String^ fieldName
)
member ContainsField :
        fieldName : string -> bool

Parametri

fieldName String
Nome del campo da verificare.

Valore di ritorno

Boolean
Restituisce true se esiste altrimenti false.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Metodo QSUpdateInsertCommand.GetField

Metodo QSUpdateInsertCommandGetField
Restituisce il valore abbinato al campo specificato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetField(
    string fieldName
)
Public Function GetField (
    fieldName As String
) As Object
public:
Object^ GetField(
    String^ fieldName
)
member GetField :
        fieldName : string -> Object

Parametri

fieldName String
Nome del campo del quale restituire il valore.

Valore di ritorno

Object
Restituisce il valore del campo oppure null se non esiste.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Metodo QSUpdateInsertCommand.ResetSqlText

Metodo QSUpdateInsertCommandResetSqlText
Azzera la proprietà SqlText in modo che venga utilizzato il risultato di GetStatement() per effettuare la query.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetSqlText()
Public Sub ResetSqlText
public:
void ResetSqlText()
member ResetSqlText : unit -> unit
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Metodo QSUpdateInsertCommand.Run

Metodo QSUpdateInsertCommandRun
Esegue l'istruzione di UPDATE/INSERT. Eventuali errori sono registrati nella proprietà LastError dell'oggetto QSConnection dal quale questo comando è stato creato.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Run()
Public Function Run As Integer
public:
int Run()
member Run : unit -> int

Valore di ritorno

Int32
Restituisce il numero di record affetti dall'aggiornamento.
Vedi anche

Documentazione

Classe QSUpdateInsertCommand


Classe RecordReaderEventArgs
Argomento passato al QsAdoNetRecordReaderHandler contenente le informazioni necessarie alla lettura dei dati.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QSAdoNetRecordReaderEventArgs

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RecordReaderEventArgs : EventArgs
Public Class RecordReaderEventArgs
    Inherits EventArgs
public ref class RecordReaderEventArgs : public EventArgs
type RecordReaderEventArgs =
    class
        inherit EventArgs
    end

Il tipo RecordReaderEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | RecordReaderEventArgs | Inizializza una nuova istanza della classe RecordReaderEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel | Se impostato a true interrompe la lettura dei dati.
Proprietà pubblica | Data | Dati aggiuntivi passati al metodo Run().
Proprietà pubblica | Index | Indice del record corrente (parte da 1).
Proprietà pubblica | Reader | DbDataReader posizionato sul record corrente.
Torna su
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore RecordReaderEventArgs
Inizializza una nuova istanza della classe RecordReaderEventArgs.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal RecordReaderEventArgs(
    DbDataReader dr,
    Object data,
    int index
)
Protected Friend Sub New (
    dr As DbDataReader,
    data As Object,
    index As Integer
)
protected public:
RecordReaderEventArgs(
    DbDataReader^ dr,
    Object^ data,
    int index
)
new :
        dr : DbDataReader *
        data : Object *
        index : int -> RecordReaderEventArgs

Parametri

dr DbDataReader
data Object
index Int32
Vedi anche

Documentazione

Classe RecordReaderEventArgs


Proprietà di RecordReaderEventArgs

Il tipo RecordReaderEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel | Se impostato a true interrompe la lettura dei dati.
Proprietà pubblica | Data | Dati aggiuntivi passati al metodo Run().
Proprietà pubblica | Index | Indice del record corrente (parte da 1).
Proprietà pubblica | Reader | DbDataReader posizionato sul record corrente.
Torna su
Vedi anche

Documentazione

Classe RecordReaderEventArgs


Proprietà RecordReaderEventArgs.Cancel

Proprietà RecordReaderEventArgsCancel
Se impostato a true interrompe la lettura dei dati.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RecordReaderEventArgs


Proprietà RecordReaderEventArgs.Data

Proprietà RecordReaderEventArgsData
Dati aggiuntivi passati al metodo Run().

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Data { get; }
Public ReadOnly Property Data As Object
    Get
public:
property Object^ Data {
    Object^ get ();
}
member Data : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe RecordReaderEventArgs


Proprietà RecordReaderEventArgs.Index

Proprietà RecordReaderEventArgsIndex
Indice del record corrente (parte da 1).

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe RecordReaderEventArgs


Proprietà RecordReaderEventArgs.Reader

Proprietà RecordReaderEventArgsReader
DbDataReader posizionato sul record corrente.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbDataReader Reader { get; }
Public ReadOnly Property Reader As DbDataReader
    Get
public:
property DbDataReader^ Reader {
    DbDataReader^ get ();
}
member Reader : DbDataReader with get

Valore della proprietà

DbDataReader
Vedi anche

Documentazione

Classe RecordReaderEventArgs


Enumerazione SqlBinaryOperatorEnum
Enumerazione degli operatori di comparazione binaria.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum SqlBinaryOperatorEnum
Public Enumeration SqlBinaryOperatorEnum
public enum class SqlBinaryOperatorEnum
type SqlBinaryOperatorEnum
Membri
Nome | Valore | Descrizione
Uguale | 0 |
Diverso | 1 |
Minore | 2 |
MinoreUguale | 3 |
Maggiore | 4 |
MaggioreUguale | 5 |
And | 6 |
Or | 7 |
Addizione | 8 |
Sottrazione | 9 |
Moltiplicazione | 10 |
Divisione | 11 |
None | 12 |
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione SqlJoinEnum
Enumerazione tipologie Join

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum SqlJoinEnum
Public Enumeration SqlJoinEnum
public enum class SqlJoinEnum
type SqlJoinEnum
Membri
Nome | Valore | Descrizione
Inner | 0 | Inner Join
Left | 1 | Left Join
Rigth | 2 | Rigth Join
Outer | 3 | Outer Join
Full | 4 | Full Join
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione SqlLikeOperatorEnum
Enumerazione degli operatori di Like.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum SqlLikeOperatorEnum
Public Enumeration SqlLikeOperatorEnum
public enum class SqlLikeOperatorEnum
type SqlLikeOperatorEnum
Membri
Nome | Valore | Descrizione
Free | 0 | Utilizza l'espressione così com'è.
Contiene | 1 | Racchiude tra '%' l'espressione: Es: '%xxx%'.
IniziaPer | 2 | Pospone '%' all'espressione: Es: 'xxx%'.
FiniscePer | 3 | Antepone '%' all'espressione: Es: '%xxx'.
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione SqlUnaryOperatorEnum
Enumerazione degli operatori unari.

Namespace: QSAdoNet
Assembly: QSAdoNet (in QSAdoNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum SqlUnaryOperatorEnum
Public Enumeration SqlUnaryOperatorEnum
public enum class SqlUnaryOperatorEnum
type SqlUnaryOperatorEnum
Membri
Nome | Valore | Descrizione
Not | 0 | Negazione.
IsNull | 1 | IS NULL
Vedi anche

Documentazione

Namespace QSAdoNet

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it