InitPrtFast Namespace
Classi
 | Classe | Descrizione
Classe pubblica | InitPrtFast | Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.
Classe pubblica | InitPrtFastElement | Classe che rappreseneta l'oggetto cella.
Classe pubblica | InitPrtFastInitPrtFastCtxMenuCommand | Classe per gestire i comandi personalizzati sul tasto dx.
Classe pubblica | InitPrtFastInitPrtFastCtxMenuCommandList | Lista di oggetti InitPrtFastCtxMenuCommand.
Classe pubblica | InitPrtFastInitPrtFastCtxMenuItemClickEventArgs | Argomento utilizzato durante il click su un menu constestuale personalizzato.
Classe pubblica | InitPrtFastPrtInitSelectionEventArgs | Classe contenente le informazioni per l'evento SelectionChanged.
Classe pubblica | InitPrtFastRow |
Classe pubblica | InitPrtFastRows |
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | InitPrtFastSelectionVisibility | Definizione possibili azioni su oggetti importazione

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe InitPrtFast
Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
InitPrtFastInitPrtFast

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFast : XtraUserControl
Public Class InitPrtFast
    Inherits XtraUserControl
public ref class InitPrtFast : public XtraUserControl
type InitPrtFast =
    class
        inherit XtraUserControl
    end

Il tipo InitPrtFast espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFast | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà pubblica | DefaultDataSource |
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InitPrtFastMenuCommandList | Lista dei comandi custom del menu constestuale.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedConnection |
Proprietà pubblica | SelectedRows |
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AdjustControlFocus |
Metodo pubblico | AllowDragAndDrop |
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Liberare le risorse in uso. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
 | Log | Utilità di logging delle Eccezionii
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnInitPrtFastCtxMenuItemClick | Lancia l'evento InitPrtFastCtxMenuItemClick.
Metodo protetto | OnInitPrtFastSelectionChanged |
Metodo protetto | OnInitPrtFastSelectionConfirmed |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le impostazioni della griglia.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetDataSources | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | StopThread | Funzione per bloccate l'esecuzione del thread.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | InitPrtFastCtxMenuItemClick | Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento su modifica della selezione.
Evento pubblico | SelectionConfirmed |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast
Costruttore unico.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFast()
Public Sub New
public:
InitPrtFast()
new : unit -> InitPrtFast
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà di InitPrtFast

Il tipo InitPrtFast espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà pubblica | DefaultDataSource |
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InitPrtFastMenuCommandList | Lista dei comandi custom del menu constestuale.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedConnection |
Proprietà pubblica | SelectedRows |
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.DefaultDataSource

Libreria query DedNet

Proprietà InitPrtFastDefaultDataSource

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.DefaultDataSource"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultDataSource { get; set; }
Public Property DefaultDataSource As String
    Get
    Set
public:
property String^ DefaultDataSource {
    String^ get ();
    void set (String^ value);
}
member DefaultDataSource : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastMenuCommandList

Proprietà InitPrtFastInitPrtFastMenuCommandList
Lista dei comandi custom del menu constestuale.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastInitPrtFastCtxMenuCommandList InitPrtFastMenuCommandList { get; }
Public ReadOnly Property InitPrtFastMenuCommandList As InitPrtFastInitPrtFastCtxMenuCommandList
    Get
public:
property InitPrtFastInitPrtFastCtxMenuCommandList^ InitPrtFastMenuCommandList {
    InitPrtFastInitPrtFastCtxMenuCommandList^ get ();
}
member InitPrtFastMenuCommandList : InitPrtFastInitPrtFastCtxMenuCommandList with get

Valore della proprietà

InitPrtFastInitPrtFastCtxMenuCommandList
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.SelectedConnection

Proprietà InitPrtFastSelectedConnection

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.SelectedConnection"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnBase SelectedConnection { get; }
Public ReadOnly Property SelectedConnection As ConnBase
    Get
public:
property ConnBase^ SelectedConnection {
    ConnBase^ get ();
}
member SelectedConnection : ConnBase with get

Valore della proprietà

ConnBase
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Proprietà InitPrtFast.SelectedRows

Proprietà InitPrtFastSelectedRows

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.SelectedRows"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows SelectedRows { get; set; }
Public Property SelectedRows As InitPrtFastRows
    Get
    Set
public:
property InitPrtFastRows^ SelectedRows {
    InitPrtFastRows^ get ();
    void set (InitPrtFastRows^ value);
}
member SelectedRows : InitPrtFastRows with get, set

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodi di InitPrtFast

Il tipo InitPrtFast espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AdjustControlFocus |
Metodo pubblico | AllowDragAndDrop |
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Liberare le risorse in uso. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
 | Log | Utilità di logging delle Eccezionii
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnInitPrtFastCtxMenuItemClick | Lancia l'evento InitPrtFastCtxMenuItemClick.
Metodo protetto | OnInitPrtFastSelectionChanged |
Metodo protetto | OnInitPrtFastSelectionConfirmed |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le impostazioni della griglia.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetDataSources | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | StopThread | Funzione per bloccate l'esecuzione del thread.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AdjustControlFocus

Metodo InitPrtFastAdjustControlFocus

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.AdjustControlFocus"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AdjustControlFocus()
Public Sub AdjustControlFocus
public:
void AdjustControlFocus()
member AdjustControlFocus : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.AllowDragAndDrop

Metodo InitPrtFastAllowDragAndDrop

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.AllowDragAndDrop(System.Boolean)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AllowDragAndDrop(
    bool allowDrop
)
Public Sub AllowDragAndDrop (
    allowDrop As Boolean
)
public:
void AllowDragAndDrop(
    bool allowDrop
)
member AllowDragAndDrop :
        allowDrop : bool -> unit

Parametri

allowDrop Boolean
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.Dispose

Metodo InitPrtFastDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Liberare le risorse in uso.
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.Dispose

Metodo InitPrtFastDispose
Esegue il dispose dei controlli utente particolarmente dispendiosi

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Overload di Dispose
Namespace InitPrtFast


Metodo InitPrtFast.Dispose(Boolean)

Metodo InitPrtFastDispose(Boolean)
Liberare le risorse in uso.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe InitPrtFast
Overload di Dispose
Namespace InitPrtFast


Metodo InitPrtFast.InizializeInitPrtFast

Metodo InitPrtFastInizializeInitPrtFast
Chiama la funzione InizializeInitPrt definita nei lua comuni.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void InizializeInitPrtFast(
    string caller
)
Public Sub InizializeInitPrtFast (
    caller As String
)
public:
void InizializeInitPrtFast(
    String^ caller
)
member InizializeInitPrtFast :
        caller : string -> unit

Parametri

caller String
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.Log

Metodo InitPrtFastLog
Utilità di logging delle Eccezionii

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex
)
Public Shared Sub Log (
    ex As Exception
)
public:
static void Log(
    Exception^ ex
)
static member Log :
        ex : Exception -> unit

Parametri

ex Exception
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastCtxMenuItemClick

Metodo InitPrtFastOnInitPrtFastCtxMenuItemClick
Lancia l'evento InitPrtFastCtxMenuItemClick.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnInitPrtFastCtxMenuItemClick(
    Object sender,
    InitPrtFastInitPrtFastCtxMenuItemClickEventArgs e
)
Protected Friend Sub OnInitPrtFastCtxMenuItemClick (
    sender As Object,
    e As InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
)
protected public:
void OnInitPrtFastCtxMenuItemClick(
    Object^ sender,
    InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^ e
)
member OnInitPrtFastCtxMenuItemClick :
        sender : Object *
        e : InitPrtFastInitPrtFastCtxMenuItemClickEventArgs -> unit

Parametri

sender Object
e InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastSelectionChanged

Metodo InitPrtFastOnInitPrtFastSelectionChanged

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.OnInitPrtFastSelectionChanged(System.Object,InitPrtFast.InitPrtFast.PrtInitSelectionEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnInitPrtFastSelectionChanged(
    Object sender,
    InitPrtFastPrtInitSelectionEventArgs ev
)
Protected Sub OnInitPrtFastSelectionChanged (
    sender As Object,
    ev As InitPrtFastPrtInitSelectionEventArgs
)
protected:
void OnInitPrtFastSelectionChanged(
    Object^ sender,
    InitPrtFastPrtInitSelectionEventArgs^ ev
)
member OnInitPrtFastSelectionChanged :
        sender : Object *
        ev : InitPrtFastPrtInitSelectionEventArgs -> unit

Parametri

sender Object
ev InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.OnInitPrtFastSelectionConfirmed

Metodo InitPrtFastOnInitPrtFastSelectionConfirmed

[Manca la documentazione <summary> per "M:InitPrtFast.InitPrtFast.OnInitPrtFastSelectionConfirmed(System.Object,InitPrtFast.InitPrtFast.PrtInitSelectionEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnInitPrtFastSelectionConfirmed(
    Object sender,
    InitPrtFastPrtInitSelectionEventArgs ev
)
Protected Sub OnInitPrtFastSelectionConfirmed (
    sender As Object,
    ev As InitPrtFastPrtInitSelectionEventArgs
)
protected:
void OnInitPrtFastSelectionConfirmed(
    Object^ sender,
    InitPrtFastPrtInitSelectionEventArgs^ ev
)
member OnInitPrtFastSelectionConfirmed :
        sender : Object *
        ev : InitPrtFastPrtInitSelectionEventArgs -> unit

Parametri

sender Object
ev InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.SaveRegistrySettings

Metodo InitPrtFastSaveRegistrySettings
Salva nel registro le impostazioni della griglia.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.SetDataSources

Metodo InitPrtFastSetDataSources
Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDataSources(
    List<ConnBase> sources
)
Public Sub SetDataSources (
    sources As List(Of ConnBase)
)
public:
void SetDataSources(
    List<ConnBase^>^ sources
)
member SetDataSources :
        sources : List<ConnBase> -> unit

Parametri

sources List ConnBase
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Metodo InitPrtFast.StopThread

Metodo InitPrtFastStopThread
Funzione per bloccate l'esecuzione del thread.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void StopThread()
Public Sub StopThread
public:
void StopThread()
member StopThread : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Eventi di InitPrtFast

Il tipo InitPrtFast espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | InitPrtFastCtxMenuItemClick | Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento su modifica della selezione.
Evento pubblico | SelectionConfirmed |
Torna su
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.InitPrtFastCtxMenuItemClick

Evento InitPrtFastInitPrtFastCtxMenuItemClick
Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs> InitPrtFastCtxMenuItemClick
Public Event InitPrtFastCtxMenuItemClick As EventHandler(Of InitPrtFastInitPrtFastCtxMenuItemClickEventArgs)
public:
 event EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^>^ InitPrtFastCtxMenuItemClick {
    void add (EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs^>^ value);
}
member InitPrtFastCtxMenuItemClick : IEvent<EventHandler<InitPrtFastInitPrtFastCtxMenuItemClickEventArgs>,
    InitPrtFastInitPrtFastCtxMenuItemClickEventArgs>

Valore

EventHandler InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.SelectionChanged

Evento InitPrtFastSelectionChanged
Evento su modifica della selezione.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastPrtInitSelectionEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of InitPrtFastPrtInitSelectionEventArgs)
public:
 event EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ SelectionChanged {
    void add (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<InitPrtFastPrtInitSelectionEventArgs>,
    InitPrtFastPrtInitSelectionEventArgs>

Valore

EventHandler InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Evento InitPrtFast.SelectionConfirmed

Evento InitPrtFastSelectionConfirmed

[Manca la documentazione <summary> per "E:InitPrtFast.InitPrtFast.SelectionConfirmed"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastPrtInitSelectionEventArgs> SelectionConfirmed
Public Event SelectionConfirmed As EventHandler(Of InitPrtFastPrtInitSelectionEventArgs)
public:
 event EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ SelectionConfirmed {
    void add (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastPrtInitSelectionEventArgs^>^ value);
}
member SelectionConfirmed : IEvent<EventHandler<InitPrtFastPrtInitSelectionEventArgs>,
    InitPrtFastPrtInitSelectionEventArgs>

Valore

EventHandler InitPrtFastPrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFast
Namespace InitPrtFast


Classe InitPrtFast.Element

Classe InitPrtFastElement
Classe che rappreseneta l'oggetto cella.
Gerarchia di ereditarietà
SystemObject
InitPrtFastInitPrtFastElement

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Element
Public Class Element
public ref class Element
type Element = class end

Il tipo InitPrtFastElement espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastElement | Inizializza una nuova istanza della classe InitPrtFastElement.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink |
Proprietà pubblica | Field |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.Element

Costruttore InitPrtFastElement
Inizializza una nuova istanza della classe InitPrtFastElement.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Element(
    string field,
    string dedlink,
    Object value
)
Public Sub New (
    field As String,
    dedlink As String,
    value As Object
)
public:
Element(
    String^ field,
    String^ dedlink,
    Object^ value
)
new :
        field : string *
        dedlink : string *
        value : Object -> Element

Parametri

field String
dedlink String
value Object
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà di Element

Il tipo InitPrtFastElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink |
Proprietà pubblica | Field |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.DedLink

Proprietà InitPrtFastElementDedLink

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.Element.DedLink"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DedLink { get; set; }
Public Property DedLink As String
    Get
    Set
public:
property String^ DedLink {
    String^ get ();
    void set (String^ value);
}
member DedLink : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.Field

Proprietà InitPrtFastElementField

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.Element.Field"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Field { get; set; }
Public Property Field As String
    Get
    Set
public:
property String^ Field {
    String^ get ();
    void set (String^ value);
}
member Field : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Proprietà InitPrtFast.Element.Value

Proprietà InitPrtFastElementValue

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.Element.Value"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe InitPrtFastElement
Namespace InitPrtFast


Classe InitPrtFast.InitPrtFastCtxMenuCommand

Classe InitPrtFastInitPrtFastCtxMenuCommand
Classe per gestire i comandi personalizzati sul tasto dx.
Gerarchia di ereditarietà
SystemObject
InitPrtFastInitPrtFastInitPrtFastCtxMenuCommand

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastCtxMenuCommand
Public Class InitPrtFastCtxMenuCommand
public ref class InitPrtFastCtxMenuCommand
type InitPrtFastCtxMenuCommand = class end

Il tipo InitPrtFastInitPrtFastCtxMenuCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommand | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeginGroup |
Proprietà pubblica | ImagePath |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | SelectionVisibility |
Proprietà pubblica | ToolStripItem |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuCommand

Costruttore InitPrtFastInitPrtFastCtxMenuCommand
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommand.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuCommand(
    string name,
    string prompt,
    string tooltip,
    string imagePath,
    bool beginGroup,
    InitPrtFastSelectionVisibility selectionVisibility
)
Public Sub New (
    name As String,
    prompt As String,
    tooltip As String,
    imagePath As String,
    beginGroup As Boolean,
    selectionVisibility As InitPrtFastSelectionVisibility
)
public:
InitPrtFastCtxMenuCommand(
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath,
    bool beginGroup,
    InitPrtFastSelectionVisibility selectionVisibility
)
new :
        name : string *
        prompt : string *
        tooltip : string *
        imagePath : string *
        beginGroup : bool *
        selectionVisibility : InitPrtFastSelectionVisibility -> InitPrtFastCtxMenuCommand

Parametri

name String
prompt String
tooltip String
imagePath String
beginGroup Boolean
selectionVisibility InitPrtFastSelectionVisibility
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà di InitPrtFastCtxMenuCommand

Il tipo InitPrtFastInitPrtFastCtxMenuCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeginGroup |
Proprietà pubblica | ImagePath |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | SelectionVisibility |
Proprietà pubblica | ToolStripItem |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.BeginGroup

Proprietà InitPrtFastInitPrtFastCtxMenuCommandBeginGroup

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.BeginGroup"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool BeginGroup { get; set; }
Public Property BeginGroup As Boolean
    Get
    Set
public:
property bool BeginGroup {
    bool get ();
    void set (bool value);
}
member BeginGroup : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.ImagePath

Proprietà InitPrtFastInitPrtFastCtxMenuCommandImagePath

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.ImagePath"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string ImagePath { get; set; }
Public Property ImagePath As String
    Get
    Set
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}
member ImagePath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Name

Proprietà InitPrtFastInitPrtFastCtxMenuCommandName

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Name"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Prompt

Proprietà InitPrtFastInitPrtFastCtxMenuCommandPrompt

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Prompt"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.SelectionVisibility

Proprietà InitPrtFastInitPrtFastCtxMenuCommandSelectionVisibility

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.SelectionVisibility"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastSelectionVisibility SelectionVisibility { get; set; }
Public Property SelectionVisibility As InitPrtFastSelectionVisibility
    Get
    Set
public:
property InitPrtFastSelectionVisibility SelectionVisibility {
    InitPrtFastSelectionVisibility get ();
    void set (InitPrtFastSelectionVisibility value);
}
member SelectionVisibility : InitPrtFastSelectionVisibility with get, set

Valore della proprietà

InitPrtFastSelectionVisibility
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.ToolStripItem

Proprietà InitPrtFastInitPrtFastCtxMenuCommandToolStripItem

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.ToolStripItem"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public BarItem ToolStripItem { get; }
Public ReadOnly Property ToolStripItem As BarItem
    Get
public:
property BarItem^ ToolStripItem {
    BarItem^ get ();
}
member ToolStripItem : BarItem with get

Valore della proprietà

BarItem
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuCommand.Tooltip

Proprietà InitPrtFastInitPrtFastCtxMenuCommandTooltip

[Manca la documentazione <summary> per "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Tooltip"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommand
Namespace InitPrtFast


Classe InitPrtFast.InitPrtFastCtxMenuCommandList

Classe InitPrtFastInitPrtFastCtxMenuCommandList
Lista di oggetti InitPrtFastCtxMenuCommand.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList InitPrtFastInitPrtFastCtxMenuCommand
InitPrtFastInitPrtFastInitPrtFastCtxMenuCommandList

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastCtxMenuCommandList : List<InitPrtFastInitPrtFastCtxMenuCommand>
Public Class InitPrtFastCtxMenuCommandList
    Inherits List(Of InitPrtFastInitPrtFastCtxMenuCommand)
public ref class InitPrtFastCtxMenuCommandList : public List<InitPrtFastInitPrtFastCtxMenuCommand^>
type InitPrtFastCtxMenuCommandList =
    class
        inherit List<InitPrtFastInitPrtFastCtxMenuCommand>
    end

Il tipo InitPrtFastInitPrtFastCtxMenuCommandList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuCommandList | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommandList.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuCommandList

Costruttore InitPrtFastInitPrtFastCtxMenuCommandList
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuCommandList.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuCommandList()
Public Sub New
public:
InitPrtFastCtxMenuCommandList()
new : unit -> InitPrtFastCtxMenuCommandList
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuCommandList
Namespace InitPrtFast


Classe InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Argomento utilizzato durante il click su un menu constestuale personalizzato.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastInitPrtFastInitPrtFastCtxMenuItemClickEventArgs

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastCtxMenuItemClickEventArgs : EventArgs
Public Class InitPrtFastCtxMenuItemClickEventArgs
    Inherits EventArgs
public ref class InitPrtFastCtxMenuItemClickEventArgs : public EventArgs
type InitPrtFastCtxMenuItemClickEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastInitPrtFastCtxMenuItemClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastInitPrtFastCtxMenuItemClickEventArgs | Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CtrlGrid | Restituisce il controllo griglia.
Proprietà pubblica | CtrlInitPrtFast | Restituisce il controllo InitPrtFast
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | MainForm | Form che contiente il controllo.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | SelectedConnection | Restiruisce la connessione selezionata
Proprietà pubblica | SelectedRows | Restituisce le righe selezionate.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs

Costruttore InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Inizializza una nuova istanza della classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastCtxMenuItemClickEventArgs()
Public Sub New
public:
InitPrtFastCtxMenuItemClickEventArgs()
new : unit -> InitPrtFastCtxMenuItemClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà di InitPrtFastCtxMenuItemClickEventArgs

Il tipo InitPrtFastInitPrtFastCtxMenuItemClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CtrlGrid | Restituisce il controllo griglia.
Proprietà pubblica | CtrlInitPrtFast | Restituisce il controllo InitPrtFast
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | MainForm | Form che contiente il controllo.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | SelectedConnection | Restiruisce la connessione selezionata
Proprietà pubblica | SelectedRows | Restituisce le righe selezionate.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.CtrlGrid

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsCtrlGrid
Restituisce il controllo griglia.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl CtrlGrid { get; }
Public ReadOnly Property CtrlGrid As GridControl
    Get
public:
property GridControl^ CtrlGrid {
    GridControl^ get ();
}
member CtrlGrid : GridControl with get

Valore della proprietà

GridControl
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.CtrlInitPrtFast

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsCtrlInitPrtFast
Restituisce il controllo InitPrtFast

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFast CtrlInitPrtFast { get; set; }
Public Property CtrlInitPrtFast As InitPrtFast
    Get
    Set
public:
property InitPrtFast^ CtrlInitPrtFast {
    InitPrtFast^ get ();
    void set (InitPrtFast^ value);
}
member CtrlInitPrtFast : InitPrtFast with get, set

Valore della proprietà

InitPrtFast
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.ItemClicked

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsItemClicked
Restuisce l'elemento cliccato.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public BarButtonItem ItemClicked { get; }
Public ReadOnly Property ItemClicked As BarButtonItem
    Get
public:
property BarButtonItem^ ItemClicked {
    BarButtonItem^ get ();
}
member ItemClicked : BarButtonItem with get

Valore della proprietà

BarButtonItem
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.MainForm

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsMainForm
Form che contiente il controllo.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Form MainForm { get; set; }
Public Property MainForm As Form
    Get
    Set
public:
property Form^ MainForm {
    Form^ get ();
    void set (Form^ value);
}
member MainForm : Form with get, set

Valore della proprietà

Form
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.NeedRefresh

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsNeedRefresh
Indica se è necessario un refresh dopo il comando.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRefresh { get; set; }
Public Property NeedRefresh As Boolean
    Get
    Set
public:
property bool NeedRefresh {
    bool get ();
    void set (bool value);
}
member NeedRefresh : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.SelectedConnection

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsSelectedConnection
Restiruisce la connessione selezionata

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnBase SelectedConnection { get; }
Public ReadOnly Property SelectedConnection As ConnBase
    Get
public:
property ConnBase^ SelectedConnection {
    ConnBase^ get ();
}
member SelectedConnection : ConnBase with get

Valore della proprietà

ConnBase
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs.SelectedRows

Proprietà InitPrtFastInitPrtFastCtxMenuItemClickEventArgsSelectedRows
Restituisce le righe selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows SelectedRows { get; }
Public ReadOnly Property SelectedRows As InitPrtFastRows
    Get
public:
property InitPrtFastRows^ SelectedRows {
    InitPrtFastRows^ get ();
}
member SelectedRows : InitPrtFastRows with get

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFastInitPrtFastCtxMenuItemClickEventArgs
Namespace InitPrtFast


Classe InitPrtFast.PrtInitSelectionEventArgs

Classe InitPrtFastPrtInitSelectionEventArgs
Classe contenente le informazioni per l'evento SelectionChanged.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastInitPrtFastPrtInitSelectionEventArgs

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class PrtInitSelectionEventArgs : EventArgs
Public Class PrtInitSelectionEventArgs
    Inherits EventArgs
public ref class PrtInitSelectionEventArgs : public EventArgs
type PrtInitSelectionEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastPrtInitSelectionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastPrtInitSelectionEventArgs | Inizializza una nuova istanza della classe InitPrtFastPrtInitSelectionEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Rows | Lista delle righe selezionate.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.PrtInitSelectionEventArgs

Costruttore InitPrtFastPrtInitSelectionEventArgs
Inizializza una nuova istanza della classe InitPrtFastPrtInitSelectionEventArgs.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public PrtInitSelectionEventArgs()
Public Sub New
public:
PrtInitSelectionEventArgs()
new : unit -> PrtInitSelectionEventArgs
Vedi anche

Documentazione

Classe InitPrtFastPrtInitSelectionEventArgs
Namespace InitPrtFast


Proprietà di PrtInitSelectionEventArgs

Il tipo InitPrtFastPrtInitSelectionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Rows | Lista delle righe selezionate.
Torna su
Vedi anche

Documentazione

Classe InitPrtFastPrtInitSelectionEventArgs
Namespace InitPrtFast


Proprietà InitPrtFast.PrtInitSelectionEventArgs.Rows

Proprietà InitPrtFastPrtInitSelectionEventArgsRows
Lista delle righe selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows Rows { get; }
Public ReadOnly Property Rows As InitPrtFastRows
    Get
public:
property InitPrtFastRows^ Rows {
    InitPrtFastRows^ get ();
}
member Rows : InitPrtFastRows with get

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFastPrtInitSelectionEventArgs
Namespace InitPrtFast


Classe InitPrtFast.Row

Classe InitPrtFastRow

[Manca la documentazione <summary> per "T:InitPrtFast.InitPrtFast.Row"]

Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList InitPrtFastElement
InitPrtFastInitPrtFastRow

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Row : List<InitPrtFastElement>
Public Class Row
    Inherits List(Of InitPrtFastElement)
public ref class Row : public List<InitPrtFastElement^>
type Row =
    class
        inherit List<InitPrtFastElement>
    end

Il tipo InitPrtFastRow espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastRow | Inizializza una nuova istanza della classe InitPrtFastRow.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.Row

Costruttore InitPrtFastRow
Inizializza una nuova istanza della classe InitPrtFastRow.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Row()
Public Sub New
public:
Row()
new : unit -> Row
Vedi anche

Documentazione

Classe InitPrtFastRow
Namespace InitPrtFast


Classe InitPrtFast.Rows

Classe InitPrtFastRows

[Manca la documentazione <summary> per "T:InitPrtFast.InitPrtFast.Rows"]

Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList InitPrtFastRow
InitPrtFastInitPrtFastRows

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Rows : List<InitPrtFastRow>
Public Class Rows
    Inherits List(Of InitPrtFastRow)
public ref class Rows : public List<InitPrtFastRow^>
type Rows =
    class
        inherit List<InitPrtFastRow>
    end

Il tipo InitPrtFastRows espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastRows | Inizializza una nuova istanza della classe InitPrtFastRows.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore InitPrtFast.Rows

Costruttore InitPrtFastRows
Inizializza una nuova istanza della classe InitPrtFastRows.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Rows()
Public Sub New
public:
Rows()
new : unit -> Rows
Vedi anche

Documentazione

Classe InitPrtFastRows
Namespace InitPrtFast


Enumerazione InitPrtFast.SelectionVisibility

Enumerazione InitPrtFastSelectionVisibility
Definizione possibili azioni su oggetti importazione

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public enum SelectionVisibility
Public Enumeration SelectionVisibility
public enum class SelectionVisibility
type SelectionVisibility
Membri
Nome | Valore | Descrizione
Single | 0 |
Multiple | 1 |
SingleAndMultiple | 2 |
None | 3 |
Always | 4 |
Vedi anche

Documentazione

Namespace InitPrtFast


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
InitPrtFastQsResources

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources | Inizializza una nuova istanza della classe QsResources.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast


Costruttore QsResources
Inizializza una nuova istanza della classe QsResources.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s String
a Assembly
Vedi anche

Documentazione

Classe QsResources
Namespace InitPrtFast


Metodi di QsResources

Il tipo QsResources espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace InitPrtFast


Metodo QsResources.GetString

Metodo QsResourcesGetString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace InitPrtFast


Metodo QsResources.GetString(String)

Metodo QsResourcesGetString(String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace InitPrtFast


Metodo QsResources.GetString(String, CultureInfo)

Metodo QsResourcesGetString(String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name String
culture CultureInfo

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace InitPrtFast


InitPrtFast.ConnType Namespace
Classi
 | Classe | Descrizione
Classe pubblica | ConnBase | Definisce i metodi di accesso all'oggetto della connessione. Impostare i campi su cui effettuare la query tramite la proprietà FieldList.
Classe pubblica | ConnDB | Classe che rappresenta la connessione a un DB.
Classe pubblica | ConnFileFixedLenght | Classe che rappresenta la connessione a un file con elementi a spaziatura fissa.
Classe pubblica | ConnFileSeparator | Classe che rappresenta la connessione a un file con elementi separati con separatore.
Classe pubblica | Field | Classe che rappresenta un campo generico.
Classe pubblica | FieldFileFixedLenght | Classe che rappresenta un campo a lunghezza fissa.
Classe pubblica | FieldFileSeparator | Classe che rappresenta un campo con separatore.
Classe pubblica | FieldList |
Classe pubblica | SearchRule | Classe che rappresenta un singolo criterio di ricerca
Classe pubblica | SearchRules | Insieme di criteri di ricerca


Classe ConnBase
Definisce i metodi di accesso all'oggetto della connessione. Impostare i campi su cui effettuare la query tramite la proprietà FieldList.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnDB
InitPrtFast.ConnTypeConnFileFixedLenght

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class ConnBase
Public MustInherit Class ConnBase
public ref class ConnBase abstract
[<AbstractClassAttribute>]
type ConnBase = class end

Il tipo ConnBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnBase | Costruttore della classe base.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete |
Proprietà pubblica | DisableUpdateResultsOnLoad |
Proprietà pubblica | Ds |
Proprietà pubblica | Fields |
Proprietà pubblica | FitColumnsOnSearch |
Proprietà pubblica | Posname |
Proprietà pubblica | PrecompileLastSearch |
Proprietà pubblica | Prompt |
Proprietà pubblica | RegistryBaseDir |
Proprietà pubblica | SearchOnEnter |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Run | Metodo per effettuare la query.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source
Campo protetto | _fields | Lista dei campi.
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte
Campo protetto | _prompt | Prompt della connessione.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnBase
Costruttore della classe base.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnBase(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnBase(
    String^ prompt
)
new :
        prompt : string -> ConnBase

Parametri

prompt String
Prompt della connessione.
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà di ConnBase

Il tipo ConnBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete |
Proprietà pubblica | DisableUpdateResultsOnLoad |
Proprietà pubblica | Ds |
Proprietà pubblica | Fields |
Proprietà pubblica | FitColumnsOnSearch |
Proprietà pubblica | Posname |
Proprietà pubblica | PrecompileLastSearch |
Proprietà pubblica | Prompt |
Proprietà pubblica | RegistryBaseDir |
Proprietà pubblica | SearchOnEnter |
Torna su
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.AutoComplete

Proprietà ConnBaseAutoComplete

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.AutoComplete"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoComplete { get; set; }
Public Property AutoComplete As Boolean
    Get
    Set
public:
property bool AutoComplete {
    bool get ();
    void set (bool value);
}
member AutoComplete : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.DisableUpdateResultsOnLoad

Proprietà ConnBaseDisableUpdateResultsOnLoad

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.DisableUpdateResultsOnLoad"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableUpdateResultsOnLoad { get; set; }
Public Property DisableUpdateResultsOnLoad As Boolean
    Get
    Set
public:
property bool DisableUpdateResultsOnLoad {
    bool get ();
    void set (bool value);
}
member DisableUpdateResultsOnLoad : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Ds

Proprietà ConnBaseDs

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.Ds"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Object Ds { get; set; }
Public Property Ds As Object
    Get
    Set
public:
property Object^ Ds {
    Object^ get ();
    void set (Object^ value);
}
member Ds : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Fields

Proprietà ConnBaseFields

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.Fields"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldList Fields { get; }
Public ReadOnly Property Fields As FieldList
    Get
public:
property FieldList^ Fields {
    FieldList^ get ();
}
member Fields : FieldList with get

Valore della proprietà

FieldList
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.FitColumnsOnSearch

Proprietà ConnBaseFitColumnsOnSearch

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.FitColumnsOnSearch"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool FitColumnsOnSearch { get; set; }
Public Property FitColumnsOnSearch As Boolean
    Get
    Set
public:
property bool FitColumnsOnSearch {
    bool get ();
    void set (bool value);
}
member FitColumnsOnSearch : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Posname

Proprietà ConnBasePosname

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.Posname"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Posname { get; set; }
Public Property Posname As Integer
    Get
    Set
public:
property int Posname {
    int get ();
    void set (int value);
}
member Posname : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.PrecompileLastSearch

Proprietà ConnBasePrecompileLastSearch

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.PrecompileLastSearch"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrecompileLastSearch { get; set; }
Public Property PrecompileLastSearch As Boolean
    Get
    Set
public:
property bool PrecompileLastSearch {
    bool get ();
    void set (bool value);
}
member PrecompileLastSearch : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.Prompt

Proprietà ConnBasePrompt

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.Prompt"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; }
Public ReadOnly Property Prompt As String
    Get
public:
property String^ Prompt {
    String^ get ();
}
member Prompt : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.RegistryBaseDir

Proprietà ConnBaseRegistryBaseDir

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.RegistryBaseDir"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseDir { get; }
Public ReadOnly Property RegistryBaseDir As String
    Get
public:
property String^ RegistryBaseDir {
    String^ get ();
}
member RegistryBaseDir : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Proprietà ConnBase.SearchOnEnter

Proprietà ConnBaseSearchOnEnter

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnBase.SearchOnEnter"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool SearchOnEnter { get; set; }
Public Property SearchOnEnter As Boolean
    Get
    Set
public:
property bool SearchOnEnter {
    bool get ();
    void set (bool value);
}
member SearchOnEnter : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodi di ConnBase

Il tipo ConnBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Run | Metodo per effettuare la query.
Torna su
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Metodo ConnBase.Run

Metodo ConnBaseRun
Metodo per effettuare la query.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void Run(
    SearchRules search
)
Public MustOverride Sub Run (
    search As SearchRules
)
public:
virtual void Run(
    SearchRules^ search
) abstract
abstract Run :
        search : SearchRules -> unit

Parametri

search SearchRules
Criteri di ricerca scelti.
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Campi di ConnBase

Il tipo ConnBase espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source
Campo protetto | _fields | Lista dei campi.
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte
Campo protetto | _prompt | Prompt della connessione.
Torna su
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Campo ConnBase._ds

Campo ConnBase_ds
Data source

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected Object _ds
Protected _ds As Object
protected:
Object^ _ds
val mutable _ds: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Campo ConnBase._fields

Campo ConnBase_fields
Lista dei campi.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected FieldList _fields
Protected _fields As FieldList
protected:
FieldList^ _fields
val mutable _fields: FieldList

Valore del campo

FieldList
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Campo ConnBase._posname

Campo ConnBase_posname
Imposta/Restituice l'indice del campo che da il nome alla parte

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected int _posname
Protected _posname As Integer
protected:
int _posname
val mutable _posname: int

Valore del campo

Int32
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Campo ConnBase._prompt

Campo ConnBase_prompt
Prompt della connessione.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected string _prompt
Protected _prompt As String
protected:
String^ _prompt
val mutable _prompt: string

Valore del campo

String
Vedi anche

Documentazione

Classe ConnBase
Namespace InitPrtFast.ConnType


Classe ConnDB
Classe che rappresenta la connessione a un DB.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnDB

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnDB : ConnBase
Public Class ConnDB
    Inherits ConnBase
public ref class ConnDB : public ConnBase
type ConnDB =
    class
        inherit ConnBase
    end

Il tipo ConnDB espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnDB | Construttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | (Ereditato da ConnBase)
Proprietà pubblica | Connection |
Proprietà pubblica | DisableUpdateResultsOnLoad | (Ereditato da ConnBase)
Proprietà pubblica | Ds | (Ereditato da ConnBase)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FitColumnsOnSearch | (Ereditato da ConnBase)
Proprietà pubblica | Posname | (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | (Ereditato da ConnBase)
Proprietà pubblica | Prompt | (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | (Ereditato da ConnBase)
Proprietà pubblica | Table |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhere |
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(SearchRules))
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source (Ereditato da ConnBase)
Campo protetto | _fields | Lista dei campi. (Ereditato da ConnBase)
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Campo protetto | _prompt | Prompt della connessione. (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnDB
Construttore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnDB(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnDB(
    String^ prompt
)
new :
        prompt : string -> ConnDB

Parametri

prompt String
Nome della connessione.
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà di ConnDB

Il tipo ConnDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | (Ereditato da ConnBase)
Proprietà pubblica | Connection |
Proprietà pubblica | DisableUpdateResultsOnLoad | (Ereditato da ConnBase)
Proprietà pubblica | Ds | (Ereditato da ConnBase)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FitColumnsOnSearch | (Ereditato da ConnBase)
Proprietà pubblica | Posname | (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | (Ereditato da ConnBase)
Proprietà pubblica | Prompt | (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | (Ereditato da ConnBase)
Proprietà pubblica | Table |
Torna su
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.Connection

Proprietà ConnDBConnection

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnDB.Connection"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; set; }
Public Property Connection As QSConnection
    Get
    Set
public:
property QSConnection^ Connection {
    QSConnection^ get ();
    void set (QSConnection^ value);
}
member Connection : QSConnection with get, set

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Proprietà ConnDB.Table

Proprietà ConnDBTable

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnDB.Table"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Table { get; set; }
Public Property Table As String
    Get
    Set
public:
property String^ Table {
    String^ get ();
    void set (String^ value);
}
member Table : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodi di ConnDB

Il tipo ConnDB espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddWhere |
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(SearchRules))
Torna su
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.AddWhere

Metodo ConnDBAddWhere

[Manca la documentazione <summary> per "M:InitPrtFast.ConnType.ConnDB.AddWhere(System.String)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddWhere(
    string wstr
)
Public Sub AddWhere (
    wstr As String
)
public:
void AddWhere(
    String^ wstr
)
member AddWhere :
        wstr : string -> unit

Parametri

wstr String
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Metodo ConnDB.Run

Metodo ConnDBRun
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Run(
    SearchRules searchRules
)
Public Overrides Sub Run (
    searchRules As SearchRules
)
public:
virtual void Run(
    SearchRules^ searchRules
) override
abstract Run :
        searchRules : SearchRules -> unit
override Run :
        searchRules : SearchRules -> unit

Parametri

searchRules SearchRules
Regole per eseguire la ricerca

Valore di ritorno

Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Campi di ConnDB

Il tipo ConnDB espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source (Ereditato da ConnBase)
Campo protetto | _fields | Lista dei campi. (Ereditato da ConnBase)
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Campo protetto | _prompt | Prompt della connessione. (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Classe ConnDB
Namespace InitPrtFast.ConnType


Classe ConnFileFixedLenght
Classe che rappresenta la connessione a un file con elementi a spaziatura fissa.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnFileFixedLenght
InitPrtFast.ConnTypeConnFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileFixedLenght : ConnBase
Public Class ConnFileFixedLenght
    Inherits ConnBase
public ref class ConnFileFixedLenght : public ConnBase
type ConnFileFixedLenght =
    class
        inherit ConnBase
    end

Il tipo ConnFileFixedLenght espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileFixedLenght | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | (Ereditato da ConnBase)
Proprietà pubblica | Ds | (Ereditato da ConnBase)
Proprietà pubblica | Encoding |
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData |
Proprietà pubblica | FitColumnsOnSearch | (Ereditato da ConnBase)
Proprietà pubblica | Posname | (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | (Ereditato da ConnBase)
Proprietà pubblica | Prompt | (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | (Ereditato da ConnBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file.
Metodo protetto | readLine | Legge la linea del file.
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(SearchRules))
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source (Ereditato da ConnBase)
Campo protetto | _encoding | Indica il tipo di codifica del file.
Campo protetto | _fields | Lista dei campi. (Ereditato da ConnBase)
Campo protetto | _fileData | Percorso del file contenente le anagrafiche.
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Campo protetto | _prompt | Prompt della connessione. (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileFixedLenght
Costruttore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileFixedLenght(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnFileFixedLenght(
    String^ prompt
)
new :
        prompt : string -> ConnFileFixedLenght

Parametri

prompt String
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà di ConnFileFixedLenght

Il tipo ConnFileFixedLenght espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | (Ereditato da ConnBase)
Proprietà pubblica | Ds | (Ereditato da ConnBase)
Proprietà pubblica | Encoding |
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData |
Proprietà pubblica | FitColumnsOnSearch | (Ereditato da ConnBase)
Proprietà pubblica | Posname | (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | (Ereditato da ConnBase)
Proprietà pubblica | Prompt | (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.Encoding

Proprietà ConnFileFixedLenghtEncoding

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileFixedLenght.Encoding"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Valore della proprietà

Encoding
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà ConnFileFixedLenght.FileData

Proprietà ConnFileFixedLenghtFileData

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileFixedLenght.FileData"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FileData { get; set; }
Public Property FileData As String
    Get
    Set
public:
property String^ FileData {
    String^ get ();
    void set (String^ value);
}
member FileData : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodi di ConnFileFixedLenght

Il tipo ConnFileFixedLenght espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file.
Metodo protetto | readLine | Legge la linea del file.
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnBaseRun(SearchRules))
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.CreateFilterExpression

Metodo ConnFileFixedLenghtCreateFilterExpression
Metodo usato per creare i filtri per la ricerca all'interno del DataView file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected string CreateFilterExpression(
    SearchRules searchRules
)
Protected Function CreateFilterExpression (
    searchRules As SearchRules
) As String
protected:
String^ CreateFilterExpression(
    SearchRules^ searchRules
)
member CreateFilterExpression :
        searchRules : SearchRules -> string

Parametri

searchRules SearchRules

Valore di ritorno

String
Stringa per il filtraggio del DataView
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.readLine

Metodo ConnFileFixedLenghtreadLine
Legge la linea del file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void readLine(
    DataTable t,
    string line
)
Protected Overridable Sub readLine (
    t As DataTable,
    line As String
)
protected:
virtual void readLine(
    DataTable^ t,
    String^ line
)
abstract readLine :
        t : DataTable *
        line : string -> unit
override readLine :
        t : DataTable *
        line : string -> unit

Parametri

t DataTable
Data table da riempire con i valori della linea.
line String
Linea da valutare.
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Metodo ConnFileFixedLenght.Run

Metodo ConnFileFixedLenghtRun
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Run(
    SearchRules search
)
Public Overrides Sub Run (
    search As SearchRules
)
public:
virtual void Run(
    SearchRules^ search
) override
abstract Run :
        search : SearchRules -> unit
override Run :
        search : SearchRules -> unit

Parametri

search SearchRules
Dizionario contenente le coppie colonna - valore da cercare

Valore di ritorno

Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Campi di ConnFileFixedLenght

Il tipo ConnFileFixedLenght espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source (Ereditato da ConnBase)
Campo protetto | _encoding | Indica il tipo di codifica del file.
Campo protetto | _fields | Lista dei campi. (Ereditato da ConnBase)
Campo protetto | _fileData | Percorso del file contenente le anagrafiche.
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Campo protetto | _prompt | Prompt della connessione. (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Campo ConnFileFixedLenght._encoding

Campo ConnFileFixedLenght_encoding
Indica il tipo di codifica del file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected Encoding _encoding
Protected _encoding As Encoding
protected:
Encoding^ _encoding
val mutable _encoding: Encoding

Valore del campo

Encoding
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Campo ConnFileFixedLenght._fileData

Campo ConnFileFixedLenght_fileData
Percorso del file contenente le anagrafiche.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected string _fileData
Protected _fileData As String
protected:
String^ _fileData
val mutable _fileData: string

Valore del campo

String
Vedi anche

Documentazione

Classe ConnFileFixedLenght
Namespace InitPrtFast.ConnType


Classe ConnFileSeparator
Classe che rappresenta la connessione a un file con elementi separati con separatore.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeConnBase
InitPrtFast.ConnTypeConnFileFixedLenght
InitPrtFast.ConnTypeConnFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class ConnFileSeparator : ConnFileFixedLenght
Public Class ConnFileSeparator
    Inherits ConnFileFixedLenght
public ref class ConnFileSeparator : public ConnFileFixedLenght
type ConnFileSeparator =
    class
        inherit ConnFileFixedLenght
    end

Il tipo ConnFileSeparator espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConnFileSeparator | Inizializza una nuova istanza della classe ConnFileSeparator.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | (Ereditato da ConnBase)
Proprietà pubblica | Ds | (Ereditato da ConnBase)
Proprietà pubblica | Encoding | (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData | (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | FitColumnsOnSearch | (Ereditato da ConnBase)
Proprietà pubblica | Posname | (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | (Ereditato da ConnBase)
Proprietà pubblica | Prompt | (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | (Ereditato da ConnBase)
Proprietà pubblica | Separator |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file. (Ereditato da ConnFileFixedLenght)
Metodo protetto | readLine | Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable. (Sovrascrive ConnFileFixedLenghtreadLine(DataTable, String))
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnFileFixedLenghtRun(SearchRules))
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source (Ereditato da ConnBase)
Campo protetto | _encoding | Indica il tipo di codifica del file. (Ereditato da ConnFileFixedLenght)
Campo protetto | _fields | Lista dei campi. (Ereditato da ConnBase)
Campo protetto | _fileData | Percorso del file contenente le anagrafiche. (Ereditato da ConnFileFixedLenght)
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Campo protetto | _prompt | Prompt della connessione. (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore ConnFileSeparator
Inizializza una nuova istanza della classe ConnFileSeparator.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public ConnFileSeparator(
    string prompt
)
Public Sub New (
    prompt As String
)
public:
ConnFileSeparator(
    String^ prompt
)
new :
        prompt : string -> ConnFileSeparator

Parametri

prompt String
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà di ConnFileSeparator

Il tipo ConnFileSeparator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AutoComplete | (Ereditato da ConnBase)
Proprietà pubblica | DisableUpdateResultsOnLoad | (Ereditato da ConnBase)
Proprietà pubblica | Ds | (Ereditato da ConnBase)
Proprietà pubblica | Encoding | (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | Fields | (Ereditato da ConnBase)
Proprietà pubblica | FileData | (Ereditato da ConnFileFixedLenght)
Proprietà pubblica | FitColumnsOnSearch | (Ereditato da ConnBase)
Proprietà pubblica | Posname | (Ereditato da ConnBase)
Proprietà pubblica | PrecompileLastSearch | (Ereditato da ConnBase)
Proprietà pubblica | Prompt | (Ereditato da ConnBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da ConnBase)
Proprietà pubblica | SearchOnEnter | (Ereditato da ConnBase)
Proprietà pubblica | Separator |
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Proprietà ConnFileSeparator.Separator

Proprietà ConnFileSeparatorSeparator

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.ConnFileSeparator.Separator"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public char Separator { get; set; }
Public Property Separator As Char
    Get
    Set
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}
member Separator : char with get, set

Valore della proprietà

Char
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodi di ConnFileSeparator

Il tipo ConnFileSeparator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file. (Ereditato da ConnFileFixedLenght)
Metodo protetto | readLine | Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable. (Sovrascrive ConnFileFixedLenghtreadLine(DataTable, String))
Metodo pubblico | Run | Metodo per effettuare la query e riempire la DataTable. (Sovrascrive ConnFileFixedLenghtRun(SearchRules))
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparator.readLine

Metodo ConnFileSeparatorreadLine
Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void readLine(
    DataTable t,
    string line
)
Protected Overrides Sub readLine (
    t As DataTable,
    line As String
)
protected:
virtual void readLine(
    DataTable^ t,
    String^ line
) override
abstract readLine :
        t : DataTable *
        line : string -> unit
override readLine :
        t : DataTable *
        line : string -> unit

Parametri

t DataTable
DataTable
line String
Linea da analizzare.
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Metodo ConnFileSeparator.Run

Metodo ConnFileSeparatorRun
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public override void Run(
    SearchRules search
)
Public Overrides Sub Run (
    search As SearchRules
)
public:
virtual void Run(
    SearchRules^ search
) override
abstract Run :
        search : SearchRules -> unit
override Run :
        search : SearchRules -> unit

Parametri

search SearchRules

Valore di ritorno

Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Campi di ConnFileSeparator

Il tipo ConnFileSeparator espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _ds | Data source (Ereditato da ConnBase)
Campo protetto | _encoding | Indica il tipo di codifica del file. (Ereditato da ConnFileFixedLenght)
Campo protetto | _fields | Lista dei campi. (Ereditato da ConnBase)
Campo protetto | _fileData | Percorso del file contenente le anagrafiche. (Ereditato da ConnFileFixedLenght)
Campo protetto | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Ereditato da ConnBase)
Campo protetto | _prompt | Prompt della connessione. (Ereditato da ConnBase)
Torna su
Vedi anche

Documentazione

Classe ConnFileSeparator
Namespace InitPrtFast.ConnType


Classe Field
Classe che rappresenta un campo generico.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeField
InitPrtFast.ConnTypeFieldFileFixedLenght
InitPrtFast.ConnTypeFieldFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class Field
Public Class Field
public ref class Field
type Field = class end

Il tipo Field espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink |
Proprietà pubblica | Format |
Proprietà pubblica | IsResult |
Proprietà pubblica | IsReturn |
Proprietà pubblica | IsSearch |
Proprietà pubblica | List |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | Translation |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore Field
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String) | Costruttore unico.
Metodo pubblico | Field(String, String, String, Boolean, Boolean, Boolean, String, String, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String[])

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String()
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String[], String)

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    string format
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    format As String
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    String^ format
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        format : string -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
format String
Formattazione del campo
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String[], String, String)

Costruttore Field(String, String, String, Boolean, Boolean, Boolean, String, String, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    string format,
    string translation
)
Public Sub New (
    prompt As String,
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    format As String,
    translation As String
)
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    String^ format,
    String^ translation
)
new :
        prompt : string *
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        format : string *
        translation : string -> Field

Parametri

prompt String
Prompt del campo.
name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
format String
Formattazione del campo
translation String
Traduzione prompt del campo
Vedi anche

Documentazione

Classe Field
Overload di Field
Namespace InitPrtFast.ConnType


Proprietà di Field

Il tipo Field espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink |
Proprietà pubblica | Format |
Proprietà pubblica | IsResult |
Proprietà pubblica | IsReturn |
Proprietà pubblica | IsSearch |
Proprietà pubblica | List |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | Translation |
Torna su
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.DedLink

Proprietà FieldDedLink

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.DedLink"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string DedLink { get; }
Public ReadOnly Property DedLink As String
    Get
public:
property String^ DedLink {
    String^ get ();
}
member DedLink : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Format

Proprietà FieldFormat

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.Format"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Format { get; }
Public ReadOnly Property Format As String
    Get
public:
property String^ Format {
    String^ get ();
}
member Format : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsResult

Proprietà FieldIsResult

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.IsResult"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsResult { get; }
Public ReadOnly Property IsResult As Boolean
    Get
public:
property bool IsResult {
    bool get ();
}
member IsResult : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsReturn

Proprietà FieldIsReturn

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.IsReturn"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReturn { get; }
Public ReadOnly Property IsReturn As Boolean
    Get
public:
property bool IsReturn {
    bool get ();
}
member IsReturn : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.IsSearch

Proprietà FieldIsSearch

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.IsSearch"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSearch { get; }
Public ReadOnly Property IsSearch As Boolean
    Get
public:
property bool IsSearch {
    bool get ();
}
member IsSearch : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.List

Proprietà FieldList

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.List"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string[] List { get; }
Public ReadOnly Property List As String()
    Get
public:
property array<String^>^ List {
    array<String^>^ get ();
}
member List : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Name

Proprietà FieldName

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Prompt

Proprietà FieldPrompt

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.Prompt"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; }
Public ReadOnly Property Prompt As String
    Get
public:
property String^ Prompt {
    String^ get ();
}
member Prompt : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Proprietà Field.Translation

Proprietà FieldTranslation

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.Field.Translation"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Translation { get; }
Public ReadOnly Property Translation As String
    Get
public:
property String^ Translation {
    String^ get ();
}
member Translation : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe Field
Namespace InitPrtFast.ConnType


Classe FieldFileFixedLenght
Classe che rappresenta un campo a lunghezza fissa.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeField
InitPrtFast.ConnTypeFieldFileFixedLenght

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldFileFixedLenght : Field
Public Class FieldFileFixedLenght
    Inherits Field
public ref class FieldFileFixedLenght : public Field
type FieldFileFixedLenght =
    class
        inherit Field
    end

Il tipo FieldFileFixedLenght espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32) | Costruttore unico.
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | (Ereditato da Field)
Proprietà pubblica | Format | (Ereditato da Field)
Proprietà pubblica | IsResult | (Ereditato da Field)
Proprietà pubblica | IsReturn | (Ereditato da Field)
Proprietà pubblica | IsSearch | (Ereditato da Field)
Proprietà pubblica | Lenght |
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | (Ereditato da Field)
Proprietà pubblica | Prompt | (Ereditato da Field)
Proprietà pubblica | StartIndex |
Proprietà pubblica | Translation | (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32) | Costruttore unico.
Metodo pubblico | FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String[], Int32, Int32)

Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLenght(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int startIndex,
    int lenght
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    startIndex As Integer,
    lenght As Integer
)
public:
FieldFileFixedLenght(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int startIndex,
    int lenght
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        startIndex : int *
        lenght : int -> FieldFileFixedLenght

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
startIndex Int32
Indica l'indice del carattere di partenza del campo.
lenght Int32
Indica la lunghezza del campo ( in caratteri )
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Overload di FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String[], Int32, Int32, String)

Costruttore FieldFileFixedLenght(String, String, Boolean, Boolean, Boolean, String, Int32, Int32, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileFixedLenght(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int startIndex,
    int lenght,
    string format
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    startIndex As Integer,
    lenght As Integer,
    format As String
)
public:
FieldFileFixedLenght(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int startIndex,
    int lenght,
    String^ format
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        startIndex : int *
        lenght : int *
        format : string -> FieldFileFixedLenght

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
startIndex Int32
Indica l'indice del carattere di partenza del campo.
lenght Int32
Indica la lunghezza del campo ( in caratteri )
format String
Formattazione del campo
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Overload di FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà di FieldFileFixedLenght

Il tipo FieldFileFixedLenght espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | (Ereditato da Field)
Proprietà pubblica | Format | (Ereditato da Field)
Proprietà pubblica | IsResult | (Ereditato da Field)
Proprietà pubblica | IsReturn | (Ereditato da Field)
Proprietà pubblica | IsSearch | (Ereditato da Field)
Proprietà pubblica | Lenght |
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | (Ereditato da Field)
Proprietà pubblica | Prompt | (Ereditato da Field)
Proprietà pubblica | StartIndex |
Proprietà pubblica | Translation | (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà FieldFileFixedLenght.Lenght

Proprietà FieldFileFixedLenghtLenght

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.FieldFileFixedLenght.Lenght"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Lenght { get; set; }
Public Property Lenght As Integer
    Get
    Set
public:
property int Lenght {
    int get ();
    void set (int value);
}
member Lenght : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Proprietà FieldFileFixedLenght.StartIndex

Proprietà FieldFileFixedLenghtStartIndex

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.FieldFileFixedLenght.StartIndex"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int StartIndex { get; set; }
Public Property StartIndex As Integer
    Get
    Set
public:
property int StartIndex {
    int get ();
    void set (int value);
}
member StartIndex : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileFixedLenght
Namespace InitPrtFast.ConnType


Classe FieldFileSeparator
Classe che rappresenta un campo con separatore.
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeField
InitPrtFast.ConnTypeFieldFileSeparator

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldFileSeparator : Field
Public Class FieldFileSeparator
    Inherits Field
public ref class FieldFileSeparator : public Field
type FieldFileSeparator =
    class
        inherit Field
    end

Il tipo FieldFileSeparator espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32) | Costruttore unico.
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | (Ereditato da Field)
Proprietà pubblica | Format | (Ereditato da Field)
Proprietà pubblica | Index |
Proprietà pubblica | IsResult | (Ereditato da Field)
Proprietà pubblica | IsReturn | (Ereditato da Field)
Proprietà pubblica | IsSearch | (Ereditato da Field)
Proprietà pubblica | Lenght |
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | (Ereditato da Field)
Proprietà pubblica | Prompt | (Ereditato da Field)
Proprietà pubblica | Translation | (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32) | Costruttore unico.
Metodo pubblico | FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String[], Int32)

Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparator(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int index
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    index As Integer
)
public:
FieldFileSeparator(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int index
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        index : int -> FieldFileSeparator

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
index Int32
Indica la posizione del campo ( zero-based )
Vedi anche

Documentazione

Classe FieldFileSeparator
Overload di FieldFileSeparator
Namespace InitPrtFast.ConnType


Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String[], Int32, String)

Costruttore FieldFileSeparator(String, String, Boolean, Boolean, Boolean, String, Int32, String)
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldFileSeparator(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int index,
    string format = null
)
Public Sub New (
    name As String,
    dedlink As String,
    isSearch As Boolean,
    isResult As Boolean,
    isReturn As Boolean,
    attList As String(),
    index As Integer,
    Optional format As String = Nothing
)
public:
FieldFileSeparator(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int index,
    String^ format = nullptr
)
new :
        name : string *
        dedlink : string *
        isSearch : bool *
        isResult : bool *
        isReturn : bool *
        attList : string[] *
        index : int *
        ?format : string
(* Defaults:
        let _format = defaultArg format null
*)
-> FieldFileSeparator

Parametri

name String
Nome del campo.
dedlink String
Nome del campo ded collegato.
isSearch Boolean
Indica se è un campo di ricerca
isResult Boolean
Indica se è un campo presente nel risultato
isReturn Boolean
Indica se è un campo di cui fare tornare il valore
attList String
Valori da mostrare nel menù a tendina
index Int32
Indica la posizione del campo ( zero-based )
format String (Optional)
Formattazione del campo
Vedi anche

Documentazione

Classe FieldFileSeparator
Overload di FieldFileSeparator
Namespace InitPrtFast.ConnType


Proprietà di FieldFileSeparator

Il tipo FieldFileSeparator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedLink | (Ereditato da Field)
Proprietà pubblica | Format | (Ereditato da Field)
Proprietà pubblica | Index |
Proprietà pubblica | IsResult | (Ereditato da Field)
Proprietà pubblica | IsReturn | (Ereditato da Field)
Proprietà pubblica | IsSearch | (Ereditato da Field)
Proprietà pubblica | Lenght |
Proprietà pubblica | List | (Ereditato da Field)
Proprietà pubblica | Name | (Ereditato da Field)
Proprietà pubblica | Prompt | (Ereditato da Field)
Proprietà pubblica | Translation | (Ereditato da Field)
Torna su
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Proprietà FieldFileSeparator.Index

Proprietà FieldFileSeparatorIndex

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.FieldFileSeparator.Index"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Proprietà FieldFileSeparator.Lenght

Proprietà FieldFileSeparatorLenght

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.FieldFileSeparator.Lenght"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public int Lenght { get; set; }
Public Property Lenght As Integer
    Get
    Set
public:
property int Lenght {
    int get ();
    void set (int value);
}
member Lenght : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FieldFileSeparator
Namespace InitPrtFast.ConnType


Classe FieldList

[Manca la documentazione <summary> per "T:InitPrtFast.ConnType.FieldList"]

Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList Field
InitPrtFast.ConnTypeFieldList

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class FieldList : List<Field>
Public Class FieldList
    Inherits List(Of Field)
public ref class FieldList : public List<Field^>
type FieldList =
    class
        inherit List<Field>
    end

Il tipo FieldList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FieldList | Inizializza una nuova istanza della classe FieldList.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore FieldList
Inizializza una nuova istanza della classe FieldList.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public FieldList()
Public Sub New
public:
FieldList()
new : unit -> FieldList
Vedi anche

Documentazione

Classe FieldList
Namespace InitPrtFast.ConnType


Classe SearchRule
Classe che rappresenta un singolo criterio di ricerca
Gerarchia di ereditarietà
SystemObject
InitPrtFast.ConnTypeSearchRule

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SearchRule
Public Class SearchRule
public ref class SearchRule
type SearchRule = class end

Il tipo SearchRule espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SearchRule | Inizializza una nuova istanza della classe SearchRule.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore SearchRule
Inizializza una nuova istanza della classe SearchRule.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchRule()
Public Sub New
public:
SearchRule()
new : unit -> SearchRule
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Proprietà di SearchRule

Il tipo SearchRule espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Proprietà SearchRule.Name

Proprietà SearchRuleName

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.SearchRule.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Proprietà SearchRule.Value

Proprietà SearchRuleValue

[Manca la documentazione <summary> per "P:InitPrtFast.ConnType.SearchRule.Value"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SearchRule
Namespace InitPrtFast.ConnType


Classe SearchRules
Insieme di criteri di ricerca
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, SearchRule
InitPrtFast.ConnTypeSearchRules

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class SearchRules : Dictionary<string, SearchRule>
Public Class SearchRules
    Inherits Dictionary(Of String, SearchRule)
public ref class SearchRules : public Dictionary<String^, SearchRule^>
type SearchRules =
    class
        inherit Dictionary<string, SearchRule>
    end

Il tipo SearchRules espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SearchRules | Inizializza una nuova istanza della classe SearchRules.
Metodo pubblico | SearchRules(SearchRules) | Inizializza una nuova istanza della classe SearchRules.
Torna su
Vedi anche

Documentazione

Namespace InitPrtFast.ConnType


Costruttore SearchRules
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SearchRules | Inizializza una nuova istanza della classe SearchRules.
Metodo pubblico | SearchRules(SearchRules) | Inizializza una nuova istanza della classe SearchRules.
Torna su
Vedi anche

Documentazione

Classe SearchRules
Namespace InitPrtFast.ConnType


Costruttore SearchRules
Inizializza una nuova istanza della classe SearchRules.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchRules()
Public Sub New
public:
SearchRules()
new : unit -> SearchRules
Vedi anche

Documentazione

Classe SearchRules
Overload di SearchRules
Namespace InitPrtFast.ConnType


Costruttore SearchRules(SearchRules)
Inizializza una nuova istanza della classe SearchRules.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public SearchRules(
    SearchRules from
)
Public Sub New (
    from As SearchRules
)
public:
SearchRules(
    SearchRules^ from
)
new :
        from : SearchRules -> SearchRules

Parametri

from SearchRules
Vedi anche

Documentazione

Classe SearchRules
Overload di SearchRules
Namespace InitPrtFast.ConnType


InitPrtFastForm Namespace
Classi
 | Classe | Descrizione
Classe pubblica | InitPrtFastForm |
Classe pubblica | InitPrtFastFormBtnClickEventArgs | Classe contenente le informazioni per l'evento BtnClick.


Classe InitPrtFastForm

[Manca la documentazione <summary> per "T:InitPrtFastForm.InitPrtFastForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
InitPrtFastFormInitPrtFastForm

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class InitPrtFastForm : XtraForm
Public Class InitPrtFastForm
    Inherits XtraForm
public ref class InitPrtFastForm : public XtraForm
type InitPrtFastForm =
    class
        inherit XtraForm
    end

Il tipo InitPrtFastForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | ctrInitPrtFast | Restituisce il controllo dell'inizia parte veloce.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FormTitle | Imposta il titolo della finestra.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | InizializeInitPrtFast | Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedRow | Restituisce l'insieme delle righe attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | FindButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBtnClick |
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetDataSources | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDefaultDataSource | Imposta la sorgente dati da pre-selezionare di default.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BtnClick | Evento sul click del bottone.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace InitPrtFastForm


Costruttore InitPrtFastForm
Costruttore unico.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastForm()
Public Sub New
public:
InitPrtFastForm()
new : unit -> InitPrtFastForm
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | ctrInitPrtFast | Restituisce il controllo dell'inizia parte veloce.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FormTitle | Imposta il titolo della finestra.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | InizializeInitPrtFast | Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedRow | Restituisce l'insieme delle righe attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.ctrInitPrtFast

Proprietà InitPrtFastFormctrInitPrtFast
Restituisce il controllo dell'inizia parte veloce.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFast ctrInitPrtFast { get; }
Public ReadOnly Property ctrInitPrtFast As InitPrtFast
    Get
public:
property InitPrtFast^ ctrInitPrtFast {
    InitPrtFast^ get ();
}
member ctrInitPrtFast : InitPrtFast with get

Valore della proprietà

InitPrtFast
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.FormTitle

Proprietà InitPrtFastFormFormTitle
Imposta il titolo della finestra.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string FormTitle { set; }
Public WriteOnly Property FormTitle As String
    Set
public:
property String^ FormTitle {
    void set (String^ value);
}
member FormTitle : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.InizializeInitPrtFast

Proprietà InitPrtFastFormInizializeInitPrtFast
Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string InizializeInitPrtFast { set; }
Public WriteOnly Property InizializeInitPrtFast As String
    Set
public:
property String^ InizializeInitPrtFast {
    void set (String^ value);
}
member InizializeInitPrtFast : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.SelectedRow

Proprietà InitPrtFastFormSelectedRow
Restituisce l'insieme delle righe attualmente selezionate.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public InitPrtFastRows SelectedRow { get; }
Public ReadOnly Property SelectedRow As InitPrtFastRows
    Get
public:
property InitPrtFastRows^ SelectedRow {
    InitPrtFastRows^ get ();
}
member SelectedRow : InitPrtFastRows with get

Valore della proprietà

InitPrtFastRows
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodi di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AddButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | FindButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBtnClick |
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetDataSources | Imposta le sorgenti dati da visualizzare.
Metodo pubblico | SetDefaultDataSource | Imposta la sorgente dati da pre-selezionare di default.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.AddButton

Metodo InitPrtFastFormAddButton
Metodo che permette di aggiungere un bottone ( da destra a sinistra ).

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void AddButton(
    string text,
    string tagText
)
Public Sub AddButton (
    text As String,
    tagText As String
)
public:
void AddButton(
    String^ text,
    String^ tagText
)
member AddButton :
        text : string *
        tagText : string -> unit

Parametri

text String
Testo da visualizzare sul bottone.
tagText String
Testo usato come tag del bottone.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.Dispose

Metodo InitPrtFastFormDispose
Liberare le risorse in uso.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.FindButton

Metodo InitPrtFastFormFindButton
Metodo che permette di aggiungere un bottone ( da destra a sinistra ).

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public BaseButton FindButton(
    string text
)
Public Function FindButton (
    text As String
) As BaseButton
public:
BaseButton^ FindButton(
    String^ text
)
member FindButton :
        text : string -> BaseButton

Parametri

text String
Testo visualizzato sul bottone.

Valore di ritorno

BaseButton
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.LoadSizeAndPosition

Metodo InitPrtFastFormLoadSizeAndPosition
Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void LoadSizeAndPosition()
Protected Sub LoadSizeAndPosition
protected:
void LoadSizeAndPosition()
member LoadSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.OnBtnClick

Metodo InitPrtFastFormOnBtnClick

[Manca la documentazione <summary> per "M:InitPrtFastForm.InitPrtFastForm.OnBtnClick(System.Object,InitPrtFastForm.InitPrtFastForm.BtnClickEventArgs)"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnBtnClick(
    Object sender,
    InitPrtFastFormBtnClickEventArgs ev
)
Protected Sub OnBtnClick (
    sender As Object,
    ev As InitPrtFastFormBtnClickEventArgs
)
protected:
void OnBtnClick(
    Object^ sender,
    InitPrtFastFormBtnClickEventArgs^ ev
)
member OnBtnClick :
        sender : Object *
        ev : InitPrtFastFormBtnClickEventArgs -> unit

Parametri

sender Object
ev InitPrtFastFormBtnClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SaveSizeAndPosition

Metodo InitPrtFastFormSaveSizeAndPosition
Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
protected void SaveSizeAndPosition()
Protected Sub SaveSizeAndPosition
protected:
void SaveSizeAndPosition()
member SaveSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetDataSources

Metodo InitPrtFastFormSetDataSources
Imposta le sorgenti dati da visualizzare.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDataSources(
    List<ConnBase> sources
)
Public Sub SetDataSources (
    sources As List(Of ConnBase)
)
public:
void SetDataSources(
    List<ConnBase^>^ sources
)
member SetDataSources :
        sources : List<ConnBase> -> unit

Parametri

sources List ConnBase
Lista di sorgenti dati.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Metodo InitPrtFastForm.SetDefaultDataSource

Metodo InitPrtFastFormSetDefaultDataSource
Imposta la sorgente dati da pre-selezionare di default.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDefaultDataSource(
    string sourceName
)
Public Sub SetDefaultDataSource (
    sourceName As String
)
public:
void SetDefaultDataSource(
    String^ sourceName
)
member SetDefaultDataSource :
        sourceName : string -> unit

Parametri

sourceName String
Nome della sorgente dati da pre-selezionare.
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Eventi di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BtnClick | Evento sul click del bottone.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Evento InitPrtFastForm.BtnClick

Evento InitPrtFastFormBtnClick
Evento sul click del bottone.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<InitPrtFastFormBtnClickEventArgs> BtnClick
Public Event BtnClick As EventHandler(Of InitPrtFastFormBtnClickEventArgs)
public:
 event EventHandler<InitPrtFastFormBtnClickEventArgs^>^ BtnClick {
    void add (EventHandler<InitPrtFastFormBtnClickEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastFormBtnClickEventArgs^>^ value);
}
member BtnClick : IEvent<EventHandler<InitPrtFastFormBtnClickEventArgs>,
    InitPrtFastFormBtnClickEventArgs>

Valore

EventHandler InitPrtFastFormBtnClickEventArgs
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Campi di InitPrtFastForm

Il tipo InitPrtFastForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe InitPrtFastForm
Namespace InitPrtFastForm


Classe InitPrtFastForm.BtnClickEventArgs

Classe InitPrtFastFormBtnClickEventArgs
Classe contenente le informazioni per l'evento BtnClick.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
InitPrtFastFormInitPrtFastFormBtnClickEventArgs

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public class BtnClickEventArgs : EventArgs
Public Class BtnClickEventArgs
    Inherits EventArgs
public ref class BtnClickEventArgs : public EventArgs
type BtnClickEventArgs =
    class
        inherit EventArgs
    end

Il tipo InitPrtFastFormBtnClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InitPrtFastFormBtnClickEventArgs | Inizializza una nuova istanza della classe InitPrtFastFormBtnClickEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BtnTag |
Torna su
Vedi anche

Documentazione

Namespace InitPrtFastForm


Costruttore InitPrtFastForm.BtnClickEventArgs

Costruttore InitPrtFastFormBtnClickEventArgs
Inizializza una nuova istanza della classe InitPrtFastFormBtnClickEventArgs.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public BtnClickEventArgs(
    string text
)
Public Sub New (
    text As String
)
public:
BtnClickEventArgs(
    String^ text
)
new :
        text : string -> BtnClickEventArgs

Parametri

text String
Vedi anche

Documentazione

Classe InitPrtFastFormBtnClickEventArgs
Namespace InitPrtFastForm


Proprietà di BtnClickEventArgs

Il tipo InitPrtFastFormBtnClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BtnTag |
Torna su
Vedi anche

Documentazione

Classe InitPrtFastFormBtnClickEventArgs
Namespace InitPrtFastForm


Proprietà InitPrtFastForm.BtnClickEventArgs.BtnTag

Proprietà InitPrtFastFormBtnClickEventArgsBtnTag

[Manca la documentazione <summary> per "P:InitPrtFastForm.InitPrtFastForm.BtnClickEventArgs.BtnTag"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 27.0.0
Sintassi
C#
VB
C++
F#
Copy
public string BtnTag { get; }
Public ReadOnly Property BtnTag As String
    Get
public:
property String^ BtnTag {
    String^ get ();
}
member BtnTag : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe InitPrtFastFormBtnClickEventArgs
Namespace InitPrtFastForm