DedNetSw Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AssemblyEventHandler |
Classe pubblica | AttributeControl |
Classe pubblica | AttributeTagInfo |
Classe pubblica | DedApiSw |
Classe pubblica | DedNetSwApp |
Classe pubblica | DedNetSwAppChangeDsInfoStructEventArgs |
Classe pubblica | DedNetSwAppDedSwPublishEventArgs |
Classe pubblica | DedNetSwAppImportOnSaveEventArgs |
Classe pubblica | DedNetSwAppImportPackAndGoAfterLoadEventArgs |
Classe pubblica | DedNetSwAppImportPackAndGoDocAttrCompareEventArgs |
Classe pubblica | DedNetSwAppImportPackAndGoMappingRootEventArgs |
Classe pubblica | DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs |
Classe pubblica | DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs |
Classe pubblica | DedNetSwAppItemAddedEventArgs |
Classe pubblica | DedNetSwAppMultiSaverExecutionInfoEventArgs |
Classe pubblica | DedNetSwAppMultiSaverItemElaborationEventArgs |
Classe pubblica | DedNetSwAppMultiSaverOverrideDedTypeEventArgs |
Classe pubblica | DedNetSwAppResolutionEventArgs |
Classe pubblica | DedNetSwAppSwRilCheckCoherenceEventArgs |
Classe pubblica | DedNetSwAppSwRilPublishEventArgs |
Classe pubblica | DedNetSwAppUpdateDataDescriptor |
Classe pubblica | DedNetSwAppUpdateDataDescriptors |
Classe pubblica | DedNetSwOldFileResolution |
Classe pubblica | DedNetSwOldFileResolutionOnFileResolutionSostItem |
Classe pubblica | DedNetSwOldFileResolutionOnFileResolutionSostItemList |
Classe pubblica | DedNetSwServer |
Classe pubblica | DedSwCommandContext |
Classe pubblica | DedSwCommandContextDocDepTreeItem |
Classe pubblica | DedSwCommandContextSwDocDepTreeSelInfo |
Classe pubblica | DedSwDocAssistantControl |
Classe pubblica | DocumentControl |
Classe pubblica | DocumentControlFileStateElementNodeWrapper |
Classe pubblica | DocumentEventHandler |
Classe pubblica | DocView |
Classe pubblica | DrawingEventHandler |
Classe pubblica | FileStateElement |
Classe pubblica | FileStateElementList |
Classe pubblica | FileStateManager |
Classe pubblica | FindNodesOperation |
Classe pubblica | Lua |
Classe pubblica | ModifyingDocumentInfo |
Classe pubblica | ModifyingDocumentInfoList |
Classe pubblica | OperationPanelExecuter |
Classe pubblica | Options |
Classe pubblica | OptionsCancelStartingStateConfiguration |
Classe pubblica | OptionsLocalizedCategoryAttribute |
Classe pubblica | OptionsLocalizedDisplayNameAttribute |
Classe pubblica | OptionsSaveDistChildrenRestrictionStatusConfiguration |
Classe pubblica | PartEventHandler |
Classe pubblica | QsPropertiesInterfaceWrapper |
Classe pubblica | QsResources |
Classe pubblica | ReplaceComponentPropertyPage |
Classe pubblica | ResolveFileForm |
Classe pubblica | SelInfoItem |
Classe pubblica | SelInfoItemList |
Classe pubblica | SolidworksOpenEventInfo |
Classe pubblica | SwCommandBase |
Classe pubblica | SwCurSelInfo |
Classe pubblica | SwDocStructInfo |
Classe pubblica | SwDocStructInfoEventHandlers |
Classe pubblica | SwDocStructInfoFileDescriptor |
Classe pubblica | Util |
Classe pubblica | UtilIniFiles |
Classe pubblica | UtilPrtDwgExporterHelper |
Classe pubblica | UtilSwPublisherHelper |
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | IFileStateInformer |
Delegate
 | Delegate | Descrizione
Delegate pubblico | FileStateManagerActivateEventHandler |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DedNetSwAppEditAllConfigurationBehaviour |
Enumerazione pubblica | DedNetSwAppOnFileDirtyBehaviour |
Enumerazione pubblica | DedNetSwOldFileResolutionRispostaUtenteSost |
Enumerazione pubblica | DedSwCommandContextSourceEnum |
Enumerazione pubblica | UtilDataAttrTypeEnum |

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe AssemblyEventHandler
Gerarchia di ereditarietà
SystemObject
DedNetSwDocumentEventHandler
DedNetSwAssemblyEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssemblyEventHandler : DocumentEventHandler
Public Class AssemblyEventHandler
    Inherits DocumentEventHandler
public ref class AssemblyEventHandler : public DocumentEventHandler
type AssemblyEventHandler =
    class
        inherit DocumentEventHandler
    end

Il tipo AssemblyEventHandler espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AssemblyEventHandler |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers | (Sovrascrive DocumentEventHandlerAttachEventHandlers)
Metodo protetto | ComponentStateChange(Object) |
Metodo protetto | ComponentStateChange(Object, Int16) |
Metodo pubblico | ComponentStateChangeNotify2 |
Metodo pubblico | ConnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | DetachEventHandlers | (Sovrascrive DocumentEventHandlerDetachEventHandlers)
Metodo pubblico | DetachModelViewEventHandler | (Ereditato da DocumentEventHandler)
Metodo pubblico | DisconnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | OnAddItemNotify |
Metodo pubblico | OnDestroy |
Metodo pubblico | OnFileSaveNotify |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | document | (Ereditato da DocumentEventHandler)
Campo protetto | iSwApp | (Ereditato da DocumentEventHandler)
Campo protetto | openModelViews | (Ereditato da DocumentEventHandler)
Campo protetto | userAddin | (Ereditato da DocumentEventHandler)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore AssemblyEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AssemblyEventHandler(
    ModelDoc2 modDoc,
    DedNetSwApp addin,
    ISldWorks sldwrk
)
Public Sub New (
    modDoc As ModelDoc2,
    addin As DedNetSwApp,
    sldwrk As ISldWorks
)
public:
AssemblyEventHandler(
    ModelDoc2^ modDoc,
    DedNetSwApp^ addin,
    ISldWorks^ sldwrk
)
new :
        modDoc : ModelDoc2 *
        addin : DedNetSwApp *
        sldwrk : ISldWorks -> AssemblyEventHandler

Parametri

modDoc ModelDoc2
addin DedNetSwApp
sldwrk ISldWorks
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodi di AssemblyEventHandler

Il tipo AssemblyEventHandler espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers | (Sovrascrive DocumentEventHandlerAttachEventHandlers)
Metodo protetto | ComponentStateChange(Object) |
Metodo protetto | ComponentStateChange(Object, Int16) |
Metodo pubblico | ComponentStateChangeNotify2 |
Metodo pubblico | ConnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | DetachEventHandlers | (Sovrascrive DocumentEventHandlerDetachEventHandlers)
Metodo pubblico | DetachModelViewEventHandler | (Ereditato da DocumentEventHandler)
Metodo pubblico | DisconnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | OnAddItemNotify |
Metodo pubblico | OnDestroy |
Metodo pubblico | OnFileSaveNotify |
Torna su
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.AttachEventHandlers

Libreria DedNetSw

Metodo AssemblyEventHandlerAttachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool AttachEventHandlers()
Public Overrides Function AttachEventHandlers As Boolean
public:
virtual bool AttachEventHandlers() override
abstract AttachEventHandlers : unit -> bool
override AttachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.ComponentStateChange

Metodo AssemblyEventHandlerComponentStateChange
Lista degli overload
 | Nome | Descrizione
Metodo protetto | ComponentStateChange(Object) |
Metodo protetto | ComponentStateChange(Object, Int16) |
Torna su
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.ComponentStateChange(Object)

Metodo AssemblyEventHandlerComponentStateChange(Object)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected int ComponentStateChange(
    Object componentModel
)
Protected Function ComponentStateChange (
    componentModel As Object
) As Integer
protected:
int ComponentStateChange(
    Object^ componentModel
)
member ComponentStateChange :
        componentModel : Object -> int

Parametri

componentModel Object

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe AssemblyEventHandler
Overload di ComponentStateChange
Namespace DedNetSw


Metodo AssemblyEventHandler.ComponentStateChange(Object, Int16)

Metodo AssemblyEventHandlerComponentStateChange(Object, Int16)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void ComponentStateChange(
    Object componentModel,
    short newCompState
)
Protected Sub ComponentStateChange (
    componentModel As Object,
    newCompState As Short
)
protected:
void ComponentStateChange(
    Object^ componentModel,
    short newCompState
)
member ComponentStateChange :
        componentModel : Object *
        newCompState : int16 -> unit

Parametri

componentModel Object
newCompState Int16
Vedi anche

Documentazione

Classe AssemblyEventHandler
Overload di ComponentStateChange
Namespace DedNetSw


Metodo AssemblyEventHandler.ComponentStateChangeNotify2

Metodo AssemblyEventHandlerComponentStateChangeNotify2

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int ComponentStateChangeNotify2(
    Object componentModel,
    string CompName,
    short oldCompState,
    short newCompState
)
Public Function ComponentStateChangeNotify2 (
    componentModel As Object,
    CompName As String,
    oldCompState As Short,
    newCompState As Short
) As Integer
public:
int ComponentStateChangeNotify2(
    Object^ componentModel,
    String^ CompName,
    short oldCompState,
    short newCompState
)
member ComponentStateChangeNotify2 :
        componentModel : Object *
        CompName : string *
        oldCompState : int16 *
        newCompState : int16 -> int

Parametri

componentModel Object
CompName String
oldCompState Int16
newCompState Int16

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.DetachEventHandlers

Metodo AssemblyEventHandlerDetachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool DetachEventHandlers()
Public Overrides Function DetachEventHandlers As Boolean
public:
virtual bool DetachEventHandlers() override
abstract DetachEventHandlers : unit -> bool
override DetachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.OnAddItemNotify

Metodo AssemblyEventHandlerOnAddItemNotify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnAddItemNotify(
    int EntityType,
    string itemName
)
Public Function OnAddItemNotify (
    EntityType As Integer,
    itemName As String
) As Integer
public:
int OnAddItemNotify(
    int EntityType,
    String^ itemName
)
member OnAddItemNotify :
        EntityType : int *
        itemName : string -> int

Parametri

EntityType Int32
itemName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.OnDestroy

Metodo AssemblyEventHandlerOnDestroy

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnDestroy(
    int destroyType
)
Public Function OnDestroy (
    destroyType As Integer
) As Integer
public:
int OnDestroy(
    int destroyType
)
member OnDestroy :
        destroyType : int -> int

Parametri

destroyType Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Metodo AssemblyEventHandler.OnFileSaveNotify

Metodo AssemblyEventHandlerOnFileSaveNotify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnFileSaveNotify(
    string FileName
)
Public Function OnFileSaveNotify (
    FileName As String
) As Integer
public:
int OnFileSaveNotify(
    String^ FileName
)
member OnFileSaveNotify :
        FileName : string -> int

Parametri

FileName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Campi di AssemblyEventHandler

Il tipo AssemblyEventHandler espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | document | (Ereditato da DocumentEventHandler)
Campo protetto | iSwApp | (Ereditato da DocumentEventHandler)
Campo protetto | openModelViews | (Ereditato da DocumentEventHandler)
Campo protetto | userAddin | (Ereditato da DocumentEventHandler)
Torna su
Vedi anche

Documentazione

Classe AssemblyEventHandler
Namespace DedNetSw


Classe AttributeControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
DedNetSwAttributeControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AttributeControl : UserControl
Public Class AttributeControl
    Inherits UserControl
public ref class AttributeControl : public UserControl
type AttributeControl =
    class
        inherit UserControl
    end

Il tipo AttributeControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeControl |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | Dispose | (Sovrascrive ContainerControlDispose(Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore AttributeControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AttributeControl()
Public Sub New
public:
AttributeControl()
new : unit -> AttributeControl
Vedi anche

Documentazione

Classe AttributeControl
Namespace DedNetSw


Metodi di AttributeControl

Il tipo AttributeControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | Dispose | (Sovrascrive ContainerControlDispose(Boolean))
Torna su
Vedi anche

Documentazione

Classe AttributeControl
Namespace DedNetSw


Metodo AttributeControl.Dispose

Metodo AttributeControlDispose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe AttributeControl
Namespace DedNetSw


Classe AttributeTagInfo
Gerarchia di ereditarietà
SystemObject
DedNetSwAttributeTagInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AttributeTagInfo
Public Class AttributeTagInfo
public ref class AttributeTagInfo
type AttributeTagInfo = class end

Il tipo AttributeTagInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeTagInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Conf |
Proprietà pubblica | DataPart |
Proprietà pubblica | Part |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore AttributeTagInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AttributeTagInfo(
    Object part,
    DedDataPart dataPart,
    string conf
)
Public Sub New (
    part As Object,
    dataPart As DedDataPart,
    conf As String
)
public:
AttributeTagInfo(
    Object^ part,
    DedDataPart^ dataPart,
    String^ conf
)
new :
        part : Object *
        dataPart : DedDataPart *
        conf : string -> AttributeTagInfo

Parametri

part Object
dataPart DedDataPart
conf String
Vedi anche

Documentazione

Classe AttributeTagInfo
Namespace DedNetSw


Proprietà di AttributeTagInfo

Il tipo AttributeTagInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Conf |
Proprietà pubblica | DataPart |
Proprietà pubblica | Part |
Torna su
Vedi anche

Documentazione

Classe AttributeTagInfo
Namespace DedNetSw


Proprietà AttributeTagInfo.Conf

Proprietà AttributeTagInfoConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Conf { get; set; }
Public Property Conf As String
    Get
    Set
public:
property String^ Conf {
    String^ get ();
    void set (String^ value);
}
member Conf : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AttributeTagInfo
Namespace DedNetSw


Proprietà AttributeTagInfo.DataPart

Proprietà AttributeTagInfoDataPart

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DataPart { get; set; }
Public Property DataPart As DedDataPart
    Get
    Set
public:
property DedDataPart^ DataPart {
    DedDataPart^ get ();
    void set (DedDataPart^ value);
}
member DataPart : DedDataPart with get, set

Valore della proprietà

DedDataPart
Vedi anche

Documentazione

Classe AttributeTagInfo
Namespace DedNetSw


Proprietà AttributeTagInfo.Part

Proprietà AttributeTagInfoPart

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Part { get; set; }
Public Property Part As Object
    Get
    Set
public:
property Object^ Part {
    Object^ get ();
    void set (Object^ value);
}
member Part : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe AttributeTagInfo
Namespace DedNetSw


Classe DedApiSw
Gerarchia di ereditarietà
SystemObject
DedNetSwDedApiSw

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedApiSw
Public Class DedApiSw
public ref class DedApiSw
type DedApiSw = class end

Il tipo DedApiSw espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedApiSw |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AssociaDoc |
Metodo pubblico | Rilascia |
Metodo pubblico | SalvaNelDb |
Metodo pubblico | ShowLastException |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedApiSw

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedApiSw(
    DedNetApplication app,
    DedLuaApplication luaApp
)
Public Sub New (
    app As DedNetApplication,
    luaApp As DedLuaApplication
)
public:
DedApiSw(
    DedNetApplication^ app,
    DedLuaApplication^ luaApp
)
new :
        app : DedNetApplication *
        luaApp : DedLuaApplication -> DedApiSw

Parametri

app DedNetApplication
luaApp DedLuaApplication
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Proprietà di DedApiSw

Il tipo DedApiSw espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Proprietà DedApiSw.LastException

Proprietà DedApiSwLastException

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}
member LastException : Exception with get

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Metodi di DedApiSw

Il tipo DedApiSw espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AssociaDoc |
Metodo pubblico | Rilascia |
Metodo pubblico | SalvaNelDb |
Metodo pubblico | ShowLastException |
Torna su
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Metodo DedApiSw.AssociaDoc

Metodo DedApiSwAssociaDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AssociaDoc(
    LuaTable args
)
Public Function AssociaDoc (
    args As LuaTable
) As Boolean
public:
bool AssociaDoc(
    LuaTable^ args
)
member AssociaDoc :
        args : LuaTable -> bool

Parametri

args LuaTable

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Metodo DedApiSw.Rilascia

Metodo DedApiSwRilascia

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Rilascia(
    LuaTable args
)
Public Function Rilascia (
    args As LuaTable
) As Boolean
public:
bool Rilascia(
    LuaTable^ args
)
member Rilascia :
        args : LuaTable -> bool

Parametri

args LuaTable

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Metodo DedApiSw.SalvaNelDb

Metodo DedApiSwSalvaNelDb

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SalvaNelDb(
    LuaTable args
)
Public Function SalvaNelDb (
    args As LuaTable
) As Boolean
public:
bool SalvaNelDb(
    LuaTable^ args
)
member SalvaNelDb :
        args : LuaTable -> bool

Parametri

args LuaTable

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Metodo DedApiSw.ShowLastException

Metodo DedApiSwShowLastException

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ShowLastException()
Public Sub ShowLastException
public:
void ShowLastException()
member ShowLastException : unit -> unit
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Campi di DedApiSw

Il tipo DedApiSw espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Campo DedApiSw._app

Campo DedApiSw_app

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication _app
Public _app As DedNetApplication
public:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

DedNetApplication
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Campo DedApiSw._luaApp

Campo DedApiSw_luaApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication _luaApp
Public _luaApp As DedLuaApplication
public:
DedLuaApplication^ _luaApp
val mutable _luaApp: DedLuaApplication

Valore del campo

DedLuaApplication
Vedi anche

Documentazione

Classe DedApiSw
Namespace DedNetSw


Classe DedNetSwApp
Gerarchia di ereditarietà
SystemObject
DedNetSwDedNetSwApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetSwApp : IFileStateInformer
Public Class DedNetSwApp
    Implements IFileStateInformer
public ref class DedNetSwApp : IFileStateInformer
type DedNetSwApp =
    class
        interface IFileStateInformer
    end

Il tipo DedNetSwApp espone i seguenti membri.

Proprietà
 | Nome | Descrizione
 | ApprenticeServer |
 | AssemblySwPath |
 | BeginEditInContextComponent |
 | ChangeStateMultiConfInfo |
 | CurrentWorkingDirectory |
 | DedNetApp |
 | DiscardDocChangesSilently |
 | DropToolbox |
 | EnforceCheckOutSilently |
 | FileStateManager |
 | HideCompareDialogOnSavingDwg |
 | IgnoreDocStatusSilently |
 | IgnoreFileDirty |
 | IgnoreRefreshAttributeControl |
 | IgnoreRefreshDocumentAssistantControl |
 | IgnoreRefreshDocumentControl |
 | IsCommandPatternRunning |
 | IsCommandUIRunning |
 | IsDedSwOpenDocRunning |
 | IsDedSwSaveInDBRunning |
 | IsDedSwSaveRevRunning |
 | IsReplaceReferencesRunning |
 | IsResolveAllOperationRunning |
 | IsSavingOnOpenEventStateCommand |
 | IsStateCommandRunning |
 | LuaApp |
 | OccAttributeDef |
Proprietà pubblica | OpenDocs |
 | OperationExecuter |
 | PropLoader |
 | Ricerca |
 | SwApp |
 | SwEnabledAlreadyShowSpecificMessage |
 | ToolBoxAdded |
 | Xmx |
Torna su
Metodi
 | Nome | Descrizione
 | AddComponentToolbox |
 | AggiornaVersioneDocumento |
 | AlignFileToVault |
Metodo pubblico | AllowHotTracking |
Metodo pubblico | AttachEventHandlers |
Metodo pubblico | AttachEventsToAllDocuments |
Metodo pubblico | AttachModelDocEventHandler |
 | BeginApprenticeServer |
 | CheckIsToolbox |
 | CreaAggiornaRevisioniSuperate |
 | CreaArchiviaDoc |
 | CreaArchiviaDocParte |
 | CreateAggiornaAttributiDaDB |
 | CreateAggiornaDocumentoLocale |
 | CreateAggiornaDocumentoLocaleStruttura |
 | CreateAnnullaCheckoOut |
 | CreateApriconOpzioniComponente |
 | CreateApriFileAllegati |
 | CreateApriFileAssociati |
 | CreateApriInLettura |
 | CreateApriInModifica |
 | CreateApriInNuovaFinestra |
 | CreateAssociaTavola |
 | CreateAssociatedECO |
 | CreateAssociatedTranslations |
 | CreateAttributi |
 | CreateCambiaPassword |
 | CreateCambioStato |
 | CreateCambioStatoMultiplo |
 | CreateCaricaParte |
 | CreateCheckIn |
 | CreateCheckInAssociati |
 | CreateCheckInStruttura |
 | CreateCheckInStrutturaAssociati |
 | CreateCheckOut |
 | CreateCheckOutStruttura |
 | CreateCheckOutStrutturaDirty |
 | CreateConfiguraDistinta |
 | CreateControlloCoerenzaRiferimenti |
 | CreateCreaComponenteAnagrafica |
 | CreateCreateSparePartsDrawing |
 | CreateDipendenze |
 | CreateDistintaComponenti |
 | CreateDistintaEsplosa |
 | CreateDistintaImplosa |
 | CreateDocAssocSw |
 | CreateDocRecognizer |
 | CreateDocumentAssistant |
 | CreateDocumentStatesAnalyzer |
 | CreateEditaAttributiSoloDB |
 | CreateEditaCommesse |
 | CreateEditaDistinta |
 | CreateEditaECO |
 | CreateEnsureLocalStrutturaAssociati |
 | CreateEnvMan |
 | CreateEseguiLua |
 | CreateFindInRicerca |
 | CreateForceMarkerAlingment |
 | CreateFormAbout |
 | CreateHelp |
 | CreateIndividuaGrafica |
 | CreateLavorazione |
 | CreateLavorazioneMultiplo |
 | CreateLinkDEDApplicazione |
 | CreateLoginCommand |
 | CreateMarkerInfo |
 | CreateModificaSuperato |
 | CreateNewRepresentation |
 | CreateNewRicerca |
 | CreateOpzioniApplicazione |
 | CreatePackAndGoExport |
 | CreatePackAndGoImport |
 | CreatePublish |
 | CreatePublishSparePartsDrawing |
 | CreatePublishStruttura |
 | CreatePwsCache |
 | CreateRegistra |
 | CreateRicerca |
 | CreateRicercaDocAssociati |
 | CreateRicercaDocumenti |
 | CreateRilascio |
 | CreateRilascioMultiplo |
 | CreateSalva |
 | CreateSalvaConf |
 | CreateSalvaDist |
 | CreateSalvaMultiplo |
 | CreateSalvaPrt |
 | CreateSalvaPrtConf |
 | CreateSalvaPrtRev |
 | CreateSalvaPrtVariante |
 | CreateSalvaPrtVarianteConf |
 | CreateSalvaRev |
 | CreateSalvaSuperato |
 | CreateSalvaVariante |
 | CreateSalvaVarianteConf |
 | CreateSblocca |
 | CreateSostituisciComponente |
 | CreateSostituisciComponenteRapidoSelezione |
 | CreateSostituisciComponenteRapidoTutti |
 | CreateSostituisciComponenteRapidoTuttiStessoLivello |
 | CreateSostituisciMoved |
 | CreateStatoDocumento |
 | CreateSwAssociaConf |
 | CreateSwAssociaConfPrt |
 | CreateSwAssociaDocument |
 | CreateSwAssociaDocumentPrt |
 | CreateSwScollegaConf |
 | CreateTabellaRevisioni |
 | CreateTrovaNelBrowser |
 | CreateUpdateBranchInformations |
 | CreateWhereUsedSw |
Metodo pubblico | DedpTopDistPre |
Metodo pubblico | DetachEventHandlers |
Metodo pubblico | DetachModelEventHandler |
 | DisableModifyEntity |
 | EndApprenticeServer |
Metodo pubblico | GetActiveElement |
Metodo pubblico | GetAnagStateImageKey |
Metodo pubblico | GetAnagStateName |
Metodo pubblico | GetAttr |
Metodo pubblico | GetChildrenElements |
Metodo pubblico | GetData |
Metodo pubblico | GetDocument |
Metodo pubblico | GetMovedDocument |
Metodo pubblico | GetSelectionImageKey |
Metodo pubblico | GetState |
Metodo pubblico | GetStateImageKey |
Metodo pubblico | HasChildrenElements |
 | InvalidOperation |
 | IsActiveDocument |
Metodo pubblico | IsDirty |
 | Log |
 | LogError |
 | LogInfo |
 | LogWarning |
Metodo pubblico | m_tbAppEvents_Destroy |
Metodo pubblico | m_tbPDMDocManagerEvents_AfterCopyingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_AfterDeletingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_AfterWritingToDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_BeforeCopyingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_BeforeDeletingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_BeforeWritingToDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_Destroy |
Metodo pubblico | m_tbPDMDocManagerEvents_NewDocumentAdded |
Metodo pubblico | m_tbPDMDocManagerEvents_PreInsertDocument |
Metodo pubblico | MakeSwCommandContext(FileStateElement) |
Metodo pubblico | MakeSwCommandContext(FileStateElementList) |
 | OnAddTiesApprenticeEvent |
 | OnChangeDsInfoStructOnPackAndGoExportEvent |
 | OnDedSwPublishEvent |
Metodo pubblico | OnElementDoubleClicked |
Metodo pubblico | OnElementsSelected |
Metodo pubblico | OnFileNew |
 | OnFileResolutionEvent |
Metodo pubblico | OnHotTrackElementClicked |
 | OnImportOnSaveEvent |
 | OnImportPackAndGoAfterLoadEvent |
 | OnImportPackAndGoDocAttrCompareEvent |
 | OnImportPackAndGoMappingRootEvent |
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent |
 | OnImportPackAndGoPresetCodingOperationEvent |
 | OnItemAddedEvent |
 | OnMultiSaverElaborateItemEvent |
 | OnMultiSaverElaborateStructEvent |
 | OnMultiSaverOverrideDedTypeEvent |
 | OnMultiSaverPopulateListEvent |
 | OnSwRilInvRilCheckCoherence |
 | OnSwRilPublishEvent |
 | SalvaVeloce |
 | SetCurrentWorkingDirectory |
 | UpdateAttrib |
 | UpdateCfg |
 | UpdateComponentToolbox |
Torna su
Eventi
Nome | Descrizione
AddTiesApprenticeEvent |
ChangeDsInfoStructOnPackAndGoExportEvent |
DedSwPublishEvent |
FileResolutionEvent |
ImportOnSaveEvent |
ImportPackAndGoAfterLoadEvent |
ImportPackAndGoDocAttrCompareEvent |
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent |
ImportPackAndGoPresetCodingOperationEvent |
ItemAddedEvent |
MultiSaverElaborateItemEvent |
MultiSaverElaborateStructEvent |
MultiSaverOverrideDedTypeEvent |
MultiSaverPopulateListEvent |
SwRilInvRilCheckCoherence |
SwRilPublishEvent |
Torna su
Campi
 | Nome | Descrizione
 | _currentWorkingDirectory |
 | DedNetSwDataRowVerString |
 | mTaskpaneHostAttributi |
 | mTaskpaneHostDocumentAssistant |
 | mTaskpaneHostDocumenti |
 | mTaskpaneViewAttributi |
 | mTaskpaneViewDocumentAssistant |
 | mTaskpaneViewDocumenti |
Campo pubblico | ToolboxVaultFolder |
Campo pubblico | ToolboxWorkFolder |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Proprietà di DedNetSwApp

Il tipo DedNetSwApp espone i seguenti membri.

Proprietà
 | Nome | Descrizione
 | ApprenticeServer |
 | AssemblySwPath |
 | BeginEditInContextComponent |
 | ChangeStateMultiConfInfo |
 | CurrentWorkingDirectory |
 | DedNetApp |
 | DiscardDocChangesSilently |
 | DropToolbox |
 | EnforceCheckOutSilently |
 | FileStateManager |
 | HideCompareDialogOnSavingDwg |
 | IgnoreDocStatusSilently |
 | IgnoreFileDirty |
 | IgnoreRefreshAttributeControl |
 | IgnoreRefreshDocumentAssistantControl |
 | IgnoreRefreshDocumentControl |
 | IsCommandPatternRunning |
 | IsCommandUIRunning |
 | IsDedSwOpenDocRunning |
 | IsDedSwSaveInDBRunning |
 | IsDedSwSaveRevRunning |
 | IsReplaceReferencesRunning |
 | IsResolveAllOperationRunning |
 | IsSavingOnOpenEventStateCommand |
 | IsStateCommandRunning |
 | LuaApp |
 | OccAttributeDef |
Proprietà pubblica | OpenDocs |
 | OperationExecuter |
 | PropLoader |
 | Ricerca |
 | SwApp |
 | SwEnabledAlreadyShowSpecificMessage |
 | ToolBoxAdded |
 | Xmx |
Torna su
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.ApprenticeServer

Proprietà DedNetSwAppApprenticeServer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SwApprNetApplicationInterface ApprenticeServer { get; }
Public Shared ReadOnly Property ApprenticeServer As SwApprNetApplicationInterface
    Get
public:
static property SwApprNetApplicationInterface^ ApprenticeServer {
    SwApprNetApplicationInterface^ get ();
}
static member ApprenticeServer : SwApprNetApplicationInterface with get

Valore della proprietà

SwApprNetApplicationInterface
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.AssemblySwPath

Proprietà DedNetSwAppAssemblySwPath

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string AssemblySwPath { get; }
Public Shared ReadOnly Property AssemblySwPath As String
    Get
public:
static property String^ AssemblySwPath {
    String^ get ();
}
static member AssemblySwPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.BeginEditInContextComponent

Proprietà DedNetSwAppBeginEditInContextComponent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IComponent2 BeginEditInContextComponent { get; set; }
Public Shared Property BeginEditInContextComponent As IComponent2
    Get
    Set
public:
static property IComponent2^ BeginEditInContextComponent {
    IComponent2^ get ();
    void set (IComponent2^ value);
}
static member BeginEditInContextComponent : IComponent2 with get, set

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.ChangeStateMultiConfInfo

Proprietà DedNetSwAppChangeStateMultiConfInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ChangeStateMultiConfInfo ChangeStateMultiConfInfo { get; set; }
Public Shared Property ChangeStateMultiConfInfo As ChangeStateMultiConfInfo
    Get
    Set
public:
static property ChangeStateMultiConfInfo^ ChangeStateMultiConfInfo {
    ChangeStateMultiConfInfo^ get ();
    void set (ChangeStateMultiConfInfo^ value);
}
static member ChangeStateMultiConfInfo : ChangeStateMultiConfInfo with get, set

Valore della proprietà

ChangeStateMultiConfInfo
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.CurrentWorkingDirectory

Proprietà DedNetSwAppCurrentWorkingDirectory

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string CurrentWorkingDirectory { get; set; }
Public Shared Property CurrentWorkingDirectory As String
    Get
    Set
public:
static property String^ CurrentWorkingDirectory {
    String^ get ();
    void set (String^ value);
}
static member CurrentWorkingDirectory : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.DedNetApp

Proprietà DedNetSwAppDedNetApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedNetApplication DedNetApp { get; }
Public Shared ReadOnly Property DedNetApp As DedNetApplication
    Get
public:
static property DedNetApplication^ DedNetApp {
    DedNetApplication^ get ();
}
static member DedNetApp : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.DiscardDocChangesSilently

Proprietà DedNetSwAppDiscardDocChangesSilently

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DiscardDocChangesSilently { get; set; }
Public Shared Property DiscardDocChangesSilently As Boolean
    Get
    Set
public:
static property bool DiscardDocChangesSilently {
    bool get ();
    void set (bool value);
}
static member DiscardDocChangesSilently : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.DropToolbox

Proprietà DedNetSwAppDropToolbox

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DropToolbox { get; }
Public Shared ReadOnly Property DropToolbox As Boolean
    Get
public:
static property bool DropToolbox {
    bool get ();
}
static member DropToolbox : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.EnforceCheckOutSilently

Proprietà DedNetSwAppEnforceCheckOutSilently

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool EnforceCheckOutSilently { get; set; }
Public Shared Property EnforceCheckOutSilently As Boolean
    Get
    Set
public:
static property bool EnforceCheckOutSilently {
    bool get ();
    void set (bool value);
}
static member EnforceCheckOutSilently : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.FileStateManager

Proprietà DedNetSwAppFileStateManager

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FileStateManager FileStateManager { get; }
Public Shared ReadOnly Property FileStateManager As FileStateManager
    Get
public:
static property FileStateManager^ FileStateManager {
    FileStateManager^ get ();
}
static member FileStateManager : FileStateManager with get

Valore della proprietà

FileStateManager
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.HideCompareDialogOnSavingDwg

Proprietà DedNetSwAppHideCompareDialogOnSavingDwg

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HideCompareDialogOnSavingDwg { get; set; }
Public Shared Property HideCompareDialogOnSavingDwg As Boolean
    Get
    Set
public:
static property bool HideCompareDialogOnSavingDwg {
    bool get ();
    void set (bool value);
}
static member HideCompareDialogOnSavingDwg : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IgnoreDocStatusSilently

Proprietà DedNetSwAppIgnoreDocStatusSilently

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreDocStatusSilently { get; set; }
Public Shared Property IgnoreDocStatusSilently As Boolean
    Get
    Set
public:
static property bool IgnoreDocStatusSilently {
    bool get ();
    void set (bool value);
}
static member IgnoreDocStatusSilently : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IgnoreFileDirty

Proprietà DedNetSwAppIgnoreFileDirty

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreFileDirty { get; }
Public Shared ReadOnly Property IgnoreFileDirty As Boolean
    Get
public:
static property bool IgnoreFileDirty {
    bool get ();
}
static member IgnoreFileDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IgnoreRefreshAttributeControl

Proprietà DedNetSwAppIgnoreRefreshAttributeControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreRefreshAttributeControl { get; set; }
Public Shared Property IgnoreRefreshAttributeControl As Boolean
    Get
    Set
public:
static property bool IgnoreRefreshAttributeControl {
    bool get ();
    void set (bool value);
}
static member IgnoreRefreshAttributeControl : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IgnoreRefreshDocumentAssistantControl

Proprietà DedNetSwAppIgnoreRefreshDocumentAssistantControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreRefreshDocumentAssistantControl { get; set; }
Public Shared Property IgnoreRefreshDocumentAssistantControl As Boolean
    Get
    Set
public:
static property bool IgnoreRefreshDocumentAssistantControl {
    bool get ();
    void set (bool value);
}
static member IgnoreRefreshDocumentAssistantControl : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IgnoreRefreshDocumentControl

Proprietà DedNetSwAppIgnoreRefreshDocumentControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreRefreshDocumentControl { get; set; }
Public Shared Property IgnoreRefreshDocumentControl As Boolean
    Get
    Set
public:
static property bool IgnoreRefreshDocumentControl {
    bool get ();
    void set (bool value);
}
static member IgnoreRefreshDocumentControl : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsCommandPatternRunning

Proprietà DedNetSwAppIsCommandPatternRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsCommandPatternRunning { get; }
Public Shared ReadOnly Property IsCommandPatternRunning As Boolean
    Get
public:
static property bool IsCommandPatternRunning {
    bool get ();
}
static member IsCommandPatternRunning : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsCommandUIRunning

Proprietà DedNetSwAppIsCommandUIRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsCommandUIRunning { get; }
Public Shared ReadOnly Property IsCommandUIRunning As Boolean
    Get
public:
static property bool IsCommandUIRunning {
    bool get ();
}
static member IsCommandUIRunning : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsDedSwOpenDocRunning

Proprietà DedNetSwAppIsDedSwOpenDocRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedSwOpenDocRunning { get; set; }
Public Shared Property IsDedSwOpenDocRunning As Boolean
    Get
    Set
public:
static property bool IsDedSwOpenDocRunning {
    bool get ();
    void set (bool value);
}
static member IsDedSwOpenDocRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsDedSwSaveInDBRunning

Proprietà DedNetSwAppIsDedSwSaveInDBRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedSwSaveInDBRunning { get; }
Public Shared ReadOnly Property IsDedSwSaveInDBRunning As Boolean
    Get
public:
static property bool IsDedSwSaveInDBRunning {
    bool get ();
}
static member IsDedSwSaveInDBRunning : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsDedSwSaveRevRunning

Proprietà DedNetSwAppIsDedSwSaveRevRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedSwSaveRevRunning { get; }
Public Shared ReadOnly Property IsDedSwSaveRevRunning As Boolean
    Get
public:
static property bool IsDedSwSaveRevRunning {
    bool get ();
}
static member IsDedSwSaveRevRunning : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsReplaceReferencesRunning

Proprietà DedNetSwAppIsReplaceReferencesRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsReplaceReferencesRunning { get; }
Public Shared ReadOnly Property IsReplaceReferencesRunning As Boolean
    Get
public:
static property bool IsReplaceReferencesRunning {
    bool get ();
}
static member IsReplaceReferencesRunning : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsResolveAllOperationRunning

Proprietà DedNetSwAppIsResolveAllOperationRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsResolveAllOperationRunning { get; set; }
Public Shared Property IsResolveAllOperationRunning As Boolean
    Get
    Set
public:
static property bool IsResolveAllOperationRunning {
    bool get ();
    void set (bool value);
}
static member IsResolveAllOperationRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsSavingOnOpenEventStateCommand

Proprietà DedNetSwAppIsSavingOnOpenEventStateCommand

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSavingOnOpenEventStateCommand { get; set; }
Public Shared Property IsSavingOnOpenEventStateCommand As Boolean
    Get
    Set
public:
static property bool IsSavingOnOpenEventStateCommand {
    bool get ();
    void set (bool value);
}
static member IsSavingOnOpenEventStateCommand : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.IsStateCommandRunning

Proprietà DedNetSwAppIsStateCommandRunning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsStateCommandRunning { get; set; }
Public Shared Property IsStateCommandRunning As Boolean
    Get
    Set
public:
static property bool IsStateCommandRunning {
    bool get ();
    void set (bool value);
}
static member IsStateCommandRunning : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.LuaApp

Proprietà DedNetSwAppLuaApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedLuaApplication LuaApp { get; }
Public Shared ReadOnly Property LuaApp As DedLuaApplication
    Get
public:
static property DedLuaApplication^ LuaApp {
    DedLuaApplication^ get ();
}
static member LuaApp : DedLuaApplication with get

Valore della proprietà

DedLuaApplication
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.OccAttributeDef

Proprietà DedNetSwAppOccAttributeDef

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IAttributeDef OccAttributeDef { get; set; }
Public Shared Property OccAttributeDef As IAttributeDef
    Get
    Set
public:
static property IAttributeDef^ OccAttributeDef {
    IAttributeDef^ get ();
    void set (IAttributeDef^ value);
}
static member OccAttributeDef : IAttributeDef with get, set

Valore della proprietà

IAttributeDef
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.OpenDocs

Proprietà DedNetSwAppOpenDocs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Hashtable OpenDocs { get; }
Public ReadOnly Property OpenDocs As Hashtable
    Get
public:
property Hashtable^ OpenDocs {
    Hashtable^ get ();
}
member OpenDocs : Hashtable with get

Valore della proprietà

Hashtable
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.OperationExecuter

Proprietà DedNetSwAppOperationExecuter

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OperationPanelExecuter OperationExecuter { get; }
Public Shared ReadOnly Property OperationExecuter As OperationPanelExecuter
    Get
public:
static property OperationPanelExecuter^ OperationExecuter {
    OperationPanelExecuter^ get ();
}
static member OperationExecuter : OperationPanelExecuter with get

Valore della proprietà

OperationPanelExecuter
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.PropLoader

Proprietà DedNetSwAppPropLoader

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QsPropertiesInterfaceWrapper PropLoader { get; }
Public Shared ReadOnly Property PropLoader As QsPropertiesInterfaceWrapper
    Get
public:
static property QsPropertiesInterfaceWrapper^ PropLoader {
    QsPropertiesInterfaceWrapper^ get ();
}
static member PropLoader : QsPropertiesInterfaceWrapper with get

Valore della proprietà

QsPropertiesInterfaceWrapper
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.Ricerca

Proprietà DedNetSwAppRicerca

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindCommand Ricerca { get; }
Public Shared ReadOnly Property Ricerca As FindCommand
    Get
public:
static property FindCommand^ Ricerca {
    FindCommand^ get ();
}
static member Ricerca : FindCommand with get

Valore della proprietà

FindCommand
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.SwApp

Proprietà DedNetSwAppSwApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SldWorks SwApp { get; }
Public Shared ReadOnly Property SwApp As SldWorks
    Get
public:
static property SldWorks^ SwApp {
    SldWorks^ get ();
}
static member SwApp : SldWorks with get

Valore della proprietà

SldWorks
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.SwEnabledAlreadyShowSpecificMessage

Proprietà DedNetSwAppSwEnabledAlreadyShowSpecificMessage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SwEnabledAlreadyShowSpecificMessage { get; }
Public Shared ReadOnly Property SwEnabledAlreadyShowSpecificMessage As Boolean
    Get
public:
static property bool SwEnabledAlreadyShowSpecificMessage {
    bool get ();
}
static member SwEnabledAlreadyShowSpecificMessage : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.ToolBoxAdded

Proprietà DedNetSwAppToolBoxAdded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> ToolBoxAdded { get; set; }
Public Shared Property ToolBoxAdded As List(Of String)
    Get
    Set
public:
static property List<String^>^ ToolBoxAdded {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
static member ToolBoxAdded : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Proprietà DedNetSwApp.Xmx

Proprietà DedNetSwAppXmx

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static XMX Xmx { get; }
Public Shared ReadOnly Property Xmx As XMX
    Get
public:
static property XMX^ Xmx {
    XMX^ get ();
}
static member Xmx : XMX with get

Valore della proprietà

XMX
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodi di DedNetSwApp

Il tipo DedNetSwApp espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | AddComponentToolbox |
 | AggiornaVersioneDocumento |
 | AlignFileToVault |
Metodo pubblico | AllowHotTracking |
Metodo pubblico | AttachEventHandlers |
Metodo pubblico | AttachEventsToAllDocuments |
Metodo pubblico | AttachModelDocEventHandler |
 | BeginApprenticeServer |
 | CheckIsToolbox |
 | CreaAggiornaRevisioniSuperate |
 | CreaArchiviaDoc |
 | CreaArchiviaDocParte |
 | CreateAggiornaAttributiDaDB |
 | CreateAggiornaDocumentoLocale |
 | CreateAggiornaDocumentoLocaleStruttura |
 | CreateAnnullaCheckoOut |
 | CreateApriconOpzioniComponente |
 | CreateApriFileAllegati |
 | CreateApriFileAssociati |
 | CreateApriInLettura |
 | CreateApriInModifica |
 | CreateApriInNuovaFinestra |
 | CreateAssociaTavola |
 | CreateAssociatedECO |
 | CreateAssociatedTranslations |
 | CreateAttributi |
 | CreateCambiaPassword |
 | CreateCambioStato |
 | CreateCambioStatoMultiplo |
 | CreateCaricaParte |
 | CreateCheckIn |
 | CreateCheckInAssociati |
 | CreateCheckInStruttura |
 | CreateCheckInStrutturaAssociati |
 | CreateCheckOut |
 | CreateCheckOutStruttura |
 | CreateCheckOutStrutturaDirty |
 | CreateConfiguraDistinta |
 | CreateControlloCoerenzaRiferimenti |
 | CreateCreaComponenteAnagrafica |
 | CreateCreateSparePartsDrawing |
 | CreateDipendenze |
 | CreateDistintaComponenti |
 | CreateDistintaEsplosa |
 | CreateDistintaImplosa |
 | CreateDocAssocSw |
 | CreateDocRecognizer |
 | CreateDocumentAssistant |
 | CreateDocumentStatesAnalyzer |
 | CreateEditaAttributiSoloDB |
 | CreateEditaCommesse |
 | CreateEditaDistinta |
 | CreateEditaECO |
 | CreateEnsureLocalStrutturaAssociati |
 | CreateEnvMan |
 | CreateEseguiLua |
 | CreateFindInRicerca |
 | CreateForceMarkerAlingment |
 | CreateFormAbout |
 | CreateHelp |
 | CreateIndividuaGrafica |
 | CreateLavorazione |
 | CreateLavorazioneMultiplo |
 | CreateLinkDEDApplicazione |
 | CreateLoginCommand |
 | CreateMarkerInfo |
 | CreateModificaSuperato |
 | CreateNewRepresentation |
 | CreateNewRicerca |
 | CreateOpzioniApplicazione |
 | CreatePackAndGoExport |
 | CreatePackAndGoImport |
 | CreatePublish |
 | CreatePublishSparePartsDrawing |
 | CreatePublishStruttura |
 | CreatePwsCache |
 | CreateRegistra |
 | CreateRicerca |
 | CreateRicercaDocAssociati |
 | CreateRicercaDocumenti |
 | CreateRilascio |
 | CreateRilascioMultiplo |
 | CreateSalva |
 | CreateSalvaConf |
 | CreateSalvaDist |
 | CreateSalvaMultiplo |
 | CreateSalvaPrt |
 | CreateSalvaPrtConf |
 | CreateSalvaPrtRev |
 | CreateSalvaPrtVariante |
 | CreateSalvaPrtVarianteConf |
 | CreateSalvaRev |
 | CreateSalvaSuperato |
 | CreateSalvaVariante |
 | CreateSalvaVarianteConf |
 | CreateSblocca |
 | CreateSostituisciComponente |
 | CreateSostituisciComponenteRapidoSelezione |
 | CreateSostituisciComponenteRapidoTutti |
 | CreateSostituisciComponenteRapidoTuttiStessoLivello |
 | CreateSostituisciMoved |
 | CreateStatoDocumento |
 | CreateSwAssociaConf |
 | CreateSwAssociaConfPrt |
 | CreateSwAssociaDocument |
 | CreateSwAssociaDocumentPrt |
 | CreateSwScollegaConf |
 | CreateTabellaRevisioni |
 | CreateTrovaNelBrowser |
 | CreateUpdateBranchInformations |
 | CreateWhereUsedSw |
Metodo pubblico | DedpTopDistPre |
Metodo pubblico | DetachEventHandlers |
Metodo pubblico | DetachModelEventHandler |
 | DisableModifyEntity |
 | EndApprenticeServer |
Metodo pubblico | GetActiveElement |
Metodo pubblico | GetAnagStateImageKey |
Metodo pubblico | GetAnagStateName |
Metodo pubblico | GetAttr |
Metodo pubblico | GetChildrenElements |
Metodo pubblico | GetData |
Metodo pubblico | GetDocument |
Metodo pubblico | GetMovedDocument |
Metodo pubblico | GetSelectionImageKey |
Metodo pubblico | GetState |
Metodo pubblico | GetStateImageKey |
Metodo pubblico | HasChildrenElements |
 | InvalidOperation |
 | IsActiveDocument |
Metodo pubblico | IsDirty |
 | Log |
 | LogError |
 | LogInfo |
 | LogWarning |
Metodo pubblico | m_tbAppEvents_Destroy |
Metodo pubblico | m_tbPDMDocManagerEvents_AfterCopyingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_AfterDeletingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_AfterWritingToDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_BeforeCopyingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_BeforeDeletingDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_BeforeWritingToDocument |
Metodo pubblico | m_tbPDMDocManagerEvents_Destroy |
Metodo pubblico | m_tbPDMDocManagerEvents_NewDocumentAdded |
Metodo pubblico | m_tbPDMDocManagerEvents_PreInsertDocument |
Metodo pubblico | MakeSwCommandContext(FileStateElement) |
Metodo pubblico | MakeSwCommandContext(FileStateElementList) |
 | OnAddTiesApprenticeEvent |
 | OnChangeDsInfoStructOnPackAndGoExportEvent |
 | OnDedSwPublishEvent |
Metodo pubblico | OnElementDoubleClicked |
Metodo pubblico | OnElementsSelected |
Metodo pubblico | OnFileNew |
 | OnFileResolutionEvent |
Metodo pubblico | OnHotTrackElementClicked |
 | OnImportOnSaveEvent |
 | OnImportPackAndGoAfterLoadEvent |
 | OnImportPackAndGoDocAttrCompareEvent |
 | OnImportPackAndGoMappingRootEvent |
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent |
 | OnImportPackAndGoPresetCodingOperationEvent |
 | OnItemAddedEvent |
 | OnMultiSaverElaborateItemEvent |
 | OnMultiSaverElaborateStructEvent |
 | OnMultiSaverOverrideDedTypeEvent |
 | OnMultiSaverPopulateListEvent |
 | OnSwRilInvRilCheckCoherence |
 | OnSwRilPublishEvent |
 | SalvaVeloce |
 | SetCurrentWorkingDirectory |
 | UpdateAttrib |
 | UpdateCfg |
 | UpdateComponentToolbox |
Torna su
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AddComponentToolbox

Metodo DedNetSwAppAddComponentToolbox

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AddComponentToolbox(
    string componentName
)
Public Shared Sub AddComponentToolbox (
    componentName As String
)
public:
static void AddComponentToolbox(
    String^ componentName
)
static member AddComponentToolbox :
        componentName : string -> unit

Parametri

componentName String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AggiornaVersioneDocumento

Metodo DedNetSwAppAggiornaVersioneDocumento

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int AggiornaVersioneDocumento(
    string FileName
)
Public Shared Function AggiornaVersioneDocumento (
    FileName As String
) As Integer
public:
static int AggiornaVersioneDocumento(
    String^ FileName
)
static member AggiornaVersioneDocumento :
        FileName : string -> int

Parametri

FileName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AlignFileToVault

Metodo DedNetSwAppAlignFileToVault

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AlignFileToVault(
    IComponent2 cmp,
    string fullFileName
)
Public Shared Sub AlignFileToVault (
    cmp As IComponent2,
    fullFileName As String
)
public:
static void AlignFileToVault(
    IComponent2^ cmp,
    String^ fullFileName
)
static member AlignFileToVault :
        cmp : IComponent2 *
        fullFileName : string -> unit

Parametri

cmp IComponent2
fullFileName String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AllowHotTracking

Metodo DedNetSwAppAllowHotTracking

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllowHotTracking(
    FileStateElement el
)
Public Function AllowHotTracking (
    el As FileStateElement
) As Boolean
public:
virtual bool AllowHotTracking(
    FileStateElement^ el
) sealed
abstract AllowHotTracking :
        el : FileStateElement -> bool
override AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean

Implementa

IFileStateInformerAllowHotTracking(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AttachEventHandlers

Metodo DedNetSwAppAttachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AttachEventHandlers()
Public Function AttachEventHandlers As Boolean
public:
bool AttachEventHandlers()
member AttachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AttachEventsToAllDocuments

Metodo DedNetSwAppAttachEventsToAllDocuments

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AttachEventsToAllDocuments()
Public Sub AttachEventsToAllDocuments
public:
void AttachEventsToAllDocuments()
member AttachEventsToAllDocuments : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.AttachModelDocEventHandler

Metodo DedNetSwAppAttachModelDocEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AttachModelDocEventHandler(
    ModelDoc2 modDoc
)
Public Function AttachModelDocEventHandler (
    modDoc As ModelDoc2
) As Boolean
public:
bool AttachModelDocEventHandler(
    ModelDoc2^ modDoc
)
member AttachModelDocEventHandler :
        modDoc : ModelDoc2 -> bool

Parametri

modDoc ModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.BeginApprenticeServer

Metodo DedNetSwAppBeginApprenticeServer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool BeginApprenticeServer()
Public Shared Function BeginApprenticeServer As Boolean
public:
static bool BeginApprenticeServer()
static member BeginApprenticeServer : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CheckIsToolbox

Metodo DedNetSwAppCheckIsToolbox

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckIsToolbox(
    Component2 cmp
)
Public Shared Function CheckIsToolbox (
    cmp As Component2
) As Boolean
public:
static bool CheckIsToolbox(
    Component2^ cmp
)
static member CheckIsToolbox :
        cmp : Component2 -> bool

Parametri

cmp Component2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreaAggiornaRevisioniSuperate

Metodo DedNetSwAppCreaAggiornaRevisioniSuperate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static UpdateOldRev CreaAggiornaRevisioniSuperate()
Public Shared Function CreaAggiornaRevisioniSuperate As UpdateOldRev
public:
static UpdateOldRev^ CreaAggiornaRevisioniSuperate()
static member CreaAggiornaRevisioniSuperate : unit -> UpdateOldRev

Valore di ritorno

UpdateOldRev
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreaArchiviaDoc

Metodo DedNetSwAppCreaArchiviaDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ArchiviaDoc CreaArchiviaDoc()
Public Shared Function CreaArchiviaDoc As ArchiviaDoc
public:
static ArchiviaDoc^ CreaArchiviaDoc()
static member CreaArchiviaDoc : unit -> ArchiviaDoc

Valore di ritorno

ArchiviaDoc
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreaArchiviaDocParte

Metodo DedNetSwAppCreaArchiviaDocParte

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ArchiviaDoc CreaArchiviaDocParte()
Public Shared Function CreaArchiviaDocParte As ArchiviaDoc
public:
static ArchiviaDoc^ CreaArchiviaDocParte()
static member CreaArchiviaDocParte : unit -> ArchiviaDoc

Valore di ritorno

ArchiviaDoc
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAggiornaAttributiDaDB

Metodo DedNetSwAppCreateAggiornaAttributiDaDB

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AggiornaAttributiDaDB CreateAggiornaAttributiDaDB()
Public Shared Function CreateAggiornaAttributiDaDB As AggiornaAttributiDaDB
public:
static AggiornaAttributiDaDB^ CreateAggiornaAttributiDaDB()
static member CreateAggiornaAttributiDaDB : unit -> AggiornaAttributiDaDB

Valore di ritorno

AggiornaAttributiDaDB
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAggiornaDocumentoLocale

Metodo DedNetSwAppCreateAggiornaDocumentoLocale

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AggiornaDocumentoLocale CreateAggiornaDocumentoLocale()
Public Shared Function CreateAggiornaDocumentoLocale As AggiornaDocumentoLocale
public:
static AggiornaDocumentoLocale^ CreateAggiornaDocumentoLocale()
static member CreateAggiornaDocumentoLocale : unit -> AggiornaDocumentoLocale

Valore di ritorno

AggiornaDocumentoLocale
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAggiornaDocumentoLocaleStruttura

Metodo DedNetSwAppCreateAggiornaDocumentoLocaleStruttura

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AggiornaDocumentoLocale CreateAggiornaDocumentoLocaleStruttura()
Public Shared Function CreateAggiornaDocumentoLocaleStruttura As AggiornaDocumentoLocale
public:
static AggiornaDocumentoLocale^ CreateAggiornaDocumentoLocaleStruttura()
static member CreateAggiornaDocumentoLocaleStruttura : unit -> AggiornaDocumentoLocale

Valore di ritorno

AggiornaDocumentoLocale
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAnnullaCheckoOut

Metodo DedNetSwAppCreateAnnullaCheckoOut

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AnnullaCheckOut CreateAnnullaCheckoOut()
Public Shared Function CreateAnnullaCheckoOut As AnnullaCheckOut
public:
static AnnullaCheckOut^ CreateAnnullaCheckoOut()
static member CreateAnnullaCheckoOut : unit -> AnnullaCheckOut

Valore di ritorno

AnnullaCheckOut
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateApriconOpzioniComponente

Metodo DedNetSwAppCreateApriconOpzioniComponente

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriconOpzioni CreateApriconOpzioniComponente()
Public Shared Function CreateApriconOpzioniComponente As ApriconOpzioni
public:
static ApriconOpzioni^ CreateApriconOpzioniComponente()
static member CreateApriconOpzioniComponente : unit -> ApriconOpzioni

Valore di ritorno

ApriconOpzioni
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateApriFileAllegati

Metodo DedNetSwAppCreateApriFileAllegati

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriFileAssociati CreateApriFileAllegati()
Public Shared Function CreateApriFileAllegati As ApriFileAssociati
public:
static ApriFileAssociati^ CreateApriFileAllegati()
static member CreateApriFileAllegati : unit -> ApriFileAssociati

Valore di ritorno

ApriFileAssociati
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateApriFileAssociati

Metodo DedNetSwAppCreateApriFileAssociati

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriFileAssociati CreateApriFileAssociati()
Public Shared Function CreateApriFileAssociati As ApriFileAssociati
public:
static ApriFileAssociati^ CreateApriFileAssociati()
static member CreateApriFileAssociati : unit -> ApriFileAssociati

Valore di ritorno

ApriFileAssociati
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateApriInLettura

Metodo DedNetSwAppCreateApriInLettura

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriInLettura CreateApriInLettura()
Public Shared Function CreateApriInLettura As ApriInLettura
public:
static ApriInLettura^ CreateApriInLettura()
static member CreateApriInLettura : unit -> ApriInLettura

Valore di ritorno

ApriInLettura
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateApriInModifica

Metodo DedNetSwAppCreateApriInModifica

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriInModifica CreateApriInModifica()
Public Shared Function CreateApriInModifica As ApriInModifica
public:
static ApriInModifica^ CreateApriInModifica()
static member CreateApriInModifica : unit -> ApriInModifica

Valore di ritorno

ApriInModifica
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateApriInNuovaFinestra

Metodo DedNetSwAppCreateApriInNuovaFinestra

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriInNuovaFinestra CreateApriInNuovaFinestra()
Public Shared Function CreateApriInNuovaFinestra As ApriInNuovaFinestra
public:
static ApriInNuovaFinestra^ CreateApriInNuovaFinestra()
static member CreateApriInNuovaFinestra : unit -> ApriInNuovaFinestra

Valore di ritorno

ApriInNuovaFinestra
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAssociaTavola

Metodo DedNetSwAppCreateAssociaTavola

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociaTavola CreateAssociaTavola()
Public Shared Function CreateAssociaTavola As AssociaTavola
public:
static AssociaTavola^ CreateAssociaTavola()
static member CreateAssociaTavola : unit -> AssociaTavola

Valore di ritorno

AssociaTavola
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAssociatedECO

Metodo DedNetSwAppCreateAssociatedECO

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociatedECO CreateAssociatedECO()
Public Shared Function CreateAssociatedECO As AssociatedECO
public:
static AssociatedECO^ CreateAssociatedECO()
static member CreateAssociatedECO : unit -> AssociatedECO

Valore di ritorno

AssociatedECO
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAssociatedTranslations

Metodo DedNetSwAppCreateAssociatedTranslations

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociatedTranslations CreateAssociatedTranslations()
Public Shared Function CreateAssociatedTranslations As AssociatedTranslations
public:
static AssociatedTranslations^ CreateAssociatedTranslations()
static member CreateAssociatedTranslations : unit -> AssociatedTranslations

Valore di ritorno

AssociatedTranslations
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateAttributi

Metodo DedNetSwAppCreateAttributi

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Attributi CreateAttributi()
Public Shared Function CreateAttributi As Attributi
public:
static Attributi^ CreateAttributi()
static member CreateAttributi : unit -> Attributi

Valore di ritorno

Attributi
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCambiaPassword

Metodo DedNetSwAppCreateCambiaPassword

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CambiaPassword CreateCambiaPassword()
Public Shared Function CreateCambiaPassword As CambiaPassword
public:
static CambiaPassword^ CreateCambiaPassword()
static member CreateCambiaPassword : unit -> CambiaPassword

Valore di ritorno

CambiaPassword
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCambioStato

Metodo DedNetSwAppCreateCambioStato

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CambiaStato CreateCambioStato()
Public Shared Function CreateCambioStato As CambiaStato
public:
static CambiaStato^ CreateCambioStato()
static member CreateCambioStato : unit -> CambiaStato

Valore di ritorno

CambiaStato
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCambioStatoMultiplo

Metodo DedNetSwAppCreateCambioStatoMultiplo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CambiaStato CreateCambioStatoMultiplo()
Public Shared Function CreateCambioStatoMultiplo As CambiaStato
public:
static CambiaStato^ CreateCambioStatoMultiplo()
static member CreateCambioStatoMultiplo : unit -> CambiaStato

Valore di ritorno

CambiaStato
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCaricaParte

Metodo DedNetSwAppCreateCaricaParte

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParte()
Public Shared Function CreateCaricaParte As CaricaParte
public:
static CaricaParte^ CreateCaricaParte()
static member CreateCaricaParte : unit -> CaricaParte

Valore di ritorno

CaricaParte
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckIn

Metodo DedNetSwAppCreateCheckIn

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckIn()
Public Shared Function CreateCheckIn As CheckIn
public:
static CheckIn^ CreateCheckIn()
static member CreateCheckIn : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckInAssociati

Metodo DedNetSwAppCreateCheckInAssociati

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInAssociati()
Public Shared Function CreateCheckInAssociati As CheckIn
public:
static CheckIn^ CreateCheckInAssociati()
static member CreateCheckInAssociati : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckInStruttura

Metodo DedNetSwAppCreateCheckInStruttura

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInStruttura()
Public Shared Function CreateCheckInStruttura As CheckIn
public:
static CheckIn^ CreateCheckInStruttura()
static member CreateCheckInStruttura : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckInStrutturaAssociati

Metodo DedNetSwAppCreateCheckInStrutturaAssociati

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInStrutturaAssociati()
Public Shared Function CreateCheckInStrutturaAssociati As CheckIn
public:
static CheckIn^ CreateCheckInStrutturaAssociati()
static member CreateCheckInStrutturaAssociati : unit -> CheckIn

Valore di ritorno

CheckIn
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckOut

Metodo DedNetSwAppCreateCheckOut

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOut()
Public Shared Function CreateCheckOut As CheckOut
public:
static CheckOut^ CreateCheckOut()
static member CreateCheckOut : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckOutStruttura

Metodo DedNetSwAppCreateCheckOutStruttura

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutStruttura()
Public Shared Function CreateCheckOutStruttura As CheckOut
public:
static CheckOut^ CreateCheckOutStruttura()
static member CreateCheckOutStruttura : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCheckOutStrutturaDirty

Metodo DedNetSwAppCreateCheckOutStrutturaDirty

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutStrutturaDirty()
Public Shared Function CreateCheckOutStrutturaDirty As CheckOut
public:
static CheckOut^ CreateCheckOutStrutturaDirty()
static member CreateCheckOutStrutturaDirty : unit -> CheckOut

Valore di ritorno

CheckOut
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateConfiguraDistinta

Metodo DedNetSwAppCreateConfiguraDistinta

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ConfiguraDistinta CreateConfiguraDistinta()
Public Shared Function CreateConfiguraDistinta As ConfiguraDistinta
public:
static ConfiguraDistinta^ CreateConfiguraDistinta()
static member CreateConfiguraDistinta : unit -> ConfiguraDistinta

Valore di ritorno

ConfiguraDistinta
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateControlloCoerenzaRiferimenti

Metodo DedNetSwAppCreateControlloCoerenzaRiferimenti

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ControlloCoerenzaRiferimenti CreateControlloCoerenzaRiferimenti()
Public Shared Function CreateControlloCoerenzaRiferimenti As ControlloCoerenzaRiferimenti
public:
static ControlloCoerenzaRiferimenti^ CreateControlloCoerenzaRiferimenti()
static member CreateControlloCoerenzaRiferimenti : unit -> ControlloCoerenzaRiferimenti

Valore di ritorno

ControlloCoerenzaRiferimenti
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCreaComponenteAnagrafica

Metodo DedNetSwAppCreateCreaComponenteAnagrafica

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaComponenteAnagrafica CreateCreaComponenteAnagrafica()
Public Shared Function CreateCreaComponenteAnagrafica As CreaComponenteAnagrafica
public:
static CreaComponenteAnagrafica^ CreateCreaComponenteAnagrafica()
static member CreateCreaComponenteAnagrafica : unit -> CreaComponenteAnagrafica

Valore di ritorno

CreaComponenteAnagrafica
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateCreateSparePartsDrawing

Metodo DedNetSwAppCreateCreateSparePartsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreateSparePartsDrawing CreateCreateSparePartsDrawing()
Public Shared Function CreateCreateSparePartsDrawing As CreateSparePartsDrawing
public:
static CreateSparePartsDrawing^ CreateCreateSparePartsDrawing()
static member CreateCreateSparePartsDrawing : unit -> CreateSparePartsDrawing

Valore di ritorno

CreateSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDipendenze

Metodo DedNetSwAppCreateDipendenze

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dipendenze CreateDipendenze()
Public Shared Function CreateDipendenze As Dipendenze
public:
static Dipendenze^ CreateDipendenze()
static member CreateDipendenze : unit -> Dipendenze

Valore di ritorno

Dipendenze
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDistintaComponenti

Metodo DedNetSwAppCreateDistintaComponenti

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaComponenti CreateDistintaComponenti()
Public Shared Function CreateDistintaComponenti As DistintaComponenti
public:
static DistintaComponenti^ CreateDistintaComponenti()
static member CreateDistintaComponenti : unit -> DistintaComponenti

Valore di ritorno

DistintaComponenti
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDistintaEsplosa

Metodo DedNetSwAppCreateDistintaEsplosa

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaEsplosa CreateDistintaEsplosa()
Public Shared Function CreateDistintaEsplosa As DistintaEsplosa
public:
static DistintaEsplosa^ CreateDistintaEsplosa()
static member CreateDistintaEsplosa : unit -> DistintaEsplosa

Valore di ritorno

DistintaEsplosa
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDistintaImplosa

Metodo DedNetSwAppCreateDistintaImplosa

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaImplosa CreateDistintaImplosa()
Public Shared Function CreateDistintaImplosa As DistintaImplosa
public:
static DistintaImplosa^ CreateDistintaImplosa()
static member CreateDistintaImplosa : unit -> DistintaImplosa

Valore di ritorno

DistintaImplosa
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDocAssocSw

Metodo DedNetSwAppCreateDocAssocSw

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocAssocSw CreateDocAssocSw()
Public Shared Function CreateDocAssocSw As DocAssocSw
public:
static DocAssocSw^ CreateDocAssocSw()
static member CreateDocAssocSw : unit -> DocAssocSw

Valore di ritorno

DocAssocSw
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDocRecognizer

Metodo DedNetSwAppCreateDocRecognizer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocRecognizer CreateDocRecognizer()
Public Shared Function CreateDocRecognizer As DocRecognizer
public:
static DocRecognizer^ CreateDocRecognizer()
static member CreateDocRecognizer : unit -> DocRecognizer

Valore di ritorno

DocRecognizer
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDocumentAssistant

Metodo DedNetSwAppCreateDocumentAssistant

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocumentAssistant CreateDocumentAssistant()
Public Shared Function CreateDocumentAssistant As DocumentAssistant
public:
static DocumentAssistant^ CreateDocumentAssistant()
static member CreateDocumentAssistant : unit -> DocumentAssistant

Valore di ritorno

DocumentAssistant
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateDocumentStatesAnalyzer

Metodo DedNetSwAppCreateDocumentStatesAnalyzer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SwDataStatisticsAnalyzer CreateDocumentStatesAnalyzer()
Public Shared Function CreateDocumentStatesAnalyzer As SwDataStatisticsAnalyzer
public:
static SwDataStatisticsAnalyzer^ CreateDocumentStatesAnalyzer()
static member CreateDocumentStatesAnalyzer : unit -> SwDataStatisticsAnalyzer

Valore di ritorno

SwDataStatisticsAnalyzer
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEditaAttributiSoloDB

Metodo DedNetSwAppCreateEditaAttributiSoloDB

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaAttributiSoloDB CreateEditaAttributiSoloDB()
Public Shared Function CreateEditaAttributiSoloDB As EditaAttributiSoloDB
public:
static EditaAttributiSoloDB^ CreateEditaAttributiSoloDB()
static member CreateEditaAttributiSoloDB : unit -> EditaAttributiSoloDB

Valore di ritorno

EditaAttributiSoloDB
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEditaCommesse

Metodo DedNetSwAppCreateEditaCommesse

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaCommesse CreateEditaCommesse()
Public Shared Function CreateEditaCommesse As EditaCommesse
public:
static EditaCommesse^ CreateEditaCommesse()
static member CreateEditaCommesse : unit -> EditaCommesse

Valore di ritorno

EditaCommesse
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEditaDistinta

Metodo DedNetSwAppCreateEditaDistinta

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaDistinta CreateEditaDistinta()
Public Shared Function CreateEditaDistinta As EditaDistinta
public:
static EditaDistinta^ CreateEditaDistinta()
static member CreateEditaDistinta : unit -> EditaDistinta

Valore di ritorno

EditaDistinta
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEditaECO

Metodo DedNetSwAppCreateEditaECO

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaECO CreateEditaECO()
Public Shared Function CreateEditaECO As EditaECO
public:
static EditaECO^ CreateEditaECO()
static member CreateEditaECO : unit -> EditaECO

Valore di ritorno

EditaECO
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEnsureLocalStrutturaAssociati

Metodo DedNetSwAppCreateEnsureLocalStrutturaAssociati

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EnsureLocalAssociated CreateEnsureLocalStrutturaAssociati()
Public Shared Function CreateEnsureLocalStrutturaAssociati As EnsureLocalAssociated
public:
static EnsureLocalAssociated^ CreateEnsureLocalStrutturaAssociati()
static member CreateEnsureLocalStrutturaAssociati : unit -> EnsureLocalAssociated

Valore di ritorno

EnsureLocalAssociated
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEnvMan

Metodo DedNetSwAppCreateEnvMan

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EnvMan CreateEnvMan()
Public Shared Function CreateEnvMan As EnvMan
public:
static EnvMan^ CreateEnvMan()
static member CreateEnvMan : unit -> EnvMan

Valore di ritorno

EnvMan
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateEseguiLua

Metodo DedNetSwAppCreateEseguiLua

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EseguiLua CreateEseguiLua()
Public Shared Function CreateEseguiLua As EseguiLua
public:
static EseguiLua^ CreateEseguiLua()
static member CreateEseguiLua : unit -> EseguiLua

Valore di ritorno

EseguiLua
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateFindInRicerca

Metodo DedNetSwAppCreateFindInRicerca

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindInRicerca CreateFindInRicerca()
Public Shared Function CreateFindInRicerca As FindInRicerca
public:
static FindInRicerca^ CreateFindInRicerca()
static member CreateFindInRicerca : unit -> FindInRicerca

Valore di ritorno

FindInRicerca
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateForceMarkerAlingment

Metodo DedNetSwAppCreateForceMarkerAlingment

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ForceMarkerAlingment CreateForceMarkerAlingment()
Public Shared Function CreateForceMarkerAlingment As ForceMarkerAlingment
public:
static ForceMarkerAlingment^ CreateForceMarkerAlingment()
static member CreateForceMarkerAlingment : unit -> ForceMarkerAlingment

Valore di ritorno

ForceMarkerAlingment
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateFormAbout

Metodo DedNetSwAppCreateFormAbout

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FormAbout CreateFormAbout()
Public Shared Function CreateFormAbout As FormAbout
public:
static FormAbout^ CreateFormAbout()
static member CreateFormAbout : unit -> FormAbout

Valore di ritorno

FormAbout
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateHelp

Metodo DedNetSwAppCreateHelp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static HelpSolidWorks CreateHelp()
Public Shared Function CreateHelp As HelpSolidWorks
public:
static HelpSolidWorks^ CreateHelp()
static member CreateHelp : unit -> HelpSolidWorks

Valore di ritorno

HelpSolidWorks
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateIndividuaGrafica

Metodo DedNetSwAppCreateIndividuaGrafica

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IndividuaGrafica CreateIndividuaGrafica()
Public Shared Function CreateIndividuaGrafica As IndividuaGrafica
public:
static IndividuaGrafica^ CreateIndividuaGrafica()
static member CreateIndividuaGrafica : unit -> IndividuaGrafica

Valore di ritorno

IndividuaGrafica
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateLavorazione

Metodo DedNetSwAppCreateLavorazione

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Lavorazione CreateLavorazione()
Public Shared Function CreateLavorazione As Lavorazione
public:
static Lavorazione^ CreateLavorazione()
static member CreateLavorazione : unit -> Lavorazione

Valore di ritorno

Lavorazione
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateLavorazioneMultiplo

Metodo DedNetSwAppCreateLavorazioneMultiplo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Lavorazione CreateLavorazioneMultiplo()
Public Shared Function CreateLavorazioneMultiplo As Lavorazione
public:
static Lavorazione^ CreateLavorazioneMultiplo()
static member CreateLavorazioneMultiplo : unit -> Lavorazione

Valore di ritorno

Lavorazione
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateLinkDEDApplicazione

Metodo DedNetSwAppCreateLinkDEDApplicazione

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LinkDEDApplicazione CreateLinkDEDApplicazione()
Public Shared Function CreateLinkDEDApplicazione As LinkDEDApplicazione
public:
static LinkDEDApplicazione^ CreateLinkDEDApplicazione()
static member CreateLinkDEDApplicazione : unit -> LinkDEDApplicazione

Valore di ritorno

LinkDEDApplicazione
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateLoginCommand

Metodo DedNetSwAppCreateLoginCommand

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SwUserLogin CreateLoginCommand()
Public Shared Function CreateLoginCommand As SwUserLogin
public:
static SwUserLogin^ CreateLoginCommand()
static member CreateLoginCommand : unit -> SwUserLogin

Valore di ritorno

SwUserLogin
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateMarkerInfo

Metodo DedNetSwAppCreateMarkerInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static MarkerInfo CreateMarkerInfo()
Public Shared Function CreateMarkerInfo As MarkerInfo
public:
static MarkerInfo^ CreateMarkerInfo()
static member CreateMarkerInfo : unit -> MarkerInfo

Valore di ritorno

MarkerInfo
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateModificaSuperato

Metodo DedNetSwAppCreateModificaSuperato

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ModificaSuperato CreateModificaSuperato()
Public Shared Function CreateModificaSuperato As ModificaSuperato
public:
static ModificaSuperato^ CreateModificaSuperato()
static member CreateModificaSuperato : unit -> ModificaSuperato

Valore di ritorno

ModificaSuperato
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateNewRepresentation

Metodo DedNetSwAppCreateNewRepresentation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaNuovaRappresentazione CreateNewRepresentation()
Public Shared Function CreateNewRepresentation As CreaNuovaRappresentazione
public:
static CreaNuovaRappresentazione^ CreateNewRepresentation()
static member CreateNewRepresentation : unit -> CreaNuovaRappresentazione

Valore di ritorno

CreaNuovaRappresentazione
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateNewRicerca

Metodo DedNetSwAppCreateNewRicerca

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Ricerca CreateNewRicerca()
Public Shared Function CreateNewRicerca As Ricerca
public:
static Ricerca^ CreateNewRicerca()
static member CreateNewRicerca : unit -> Ricerca

Valore di ritorno

Ricerca
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateOpzioniApplicazione

Metodo DedNetSwAppCreateOpzioniApplicazione

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OpzioniApplicazione CreateOpzioniApplicazione()
Public Shared Function CreateOpzioniApplicazione As OpzioniApplicazione
public:
static OpzioniApplicazione^ CreateOpzioniApplicazione()
static member CreateOpzioniApplicazione : unit -> OpzioniApplicazione

Valore di ritorno

OpzioniApplicazione
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreatePackAndGoExport

Metodo DedNetSwAppCreatePackAndGoExport

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoExport CreatePackAndGoExport()
Public Shared Function CreatePackAndGoExport As PackAndGoExport
public:
static PackAndGoExport^ CreatePackAndGoExport()
static member CreatePackAndGoExport : unit -> PackAndGoExport

Valore di ritorno

PackAndGoExport
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreatePackAndGoImport

Metodo DedNetSwAppCreatePackAndGoImport

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoImport CreatePackAndGoImport()
Public Shared Function CreatePackAndGoImport As PackAndGoImport
public:
static PackAndGoImport^ CreatePackAndGoImport()
static member CreatePackAndGoImport : unit -> PackAndGoImport

Valore di ritorno

PackAndGoImport
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreatePublish

Metodo DedNetSwAppCreatePublish

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Pubblica CreatePublish()
Public Shared Function CreatePublish As Pubblica
public:
static Pubblica^ CreatePublish()
static member CreatePublish : unit -> Pubblica

Valore di ritorno

Pubblica
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreatePublishSparePartsDrawing

Metodo DedNetSwAppCreatePublishSparePartsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PublishSparePartsDrawing CreatePublishSparePartsDrawing()
Public Shared Function CreatePublishSparePartsDrawing As PublishSparePartsDrawing
public:
static PublishSparePartsDrawing^ CreatePublishSparePartsDrawing()
static member CreatePublishSparePartsDrawing : unit -> PublishSparePartsDrawing

Valore di ritorno

PublishSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreatePublishStruttura

Metodo DedNetSwAppCreatePublishStruttura

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Pubblica CreatePublishStruttura()
Public Shared Function CreatePublishStruttura As Pubblica
public:
static Pubblica^ CreatePublishStruttura()
static member CreatePublishStruttura : unit -> Pubblica

Valore di ritorno

Pubblica
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreatePwsCache

Metodo DedNetSwAppCreatePwsCache

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PwsCache CreatePwsCache()
Public Shared Function CreatePwsCache As PwsCache
public:
static PwsCache^ CreatePwsCache()
static member CreatePwsCache : unit -> PwsCache

Valore di ritorno

PwsCache
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateRegistra

Metodo DedNetSwAppCreateRegistra

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Registra CreateRegistra()
Public Shared Function CreateRegistra As Registra
public:
static Registra^ CreateRegistra()
static member CreateRegistra : unit -> Registra

Valore di ritorno

Registra
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateRicerca

Metodo DedNetSwAppCreateRicerca

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Ricerca CreateRicerca()
Public Shared Function CreateRicerca As Ricerca
public:
static Ricerca^ CreateRicerca()
static member CreateRicerca : unit -> Ricerca

Valore di ritorno

Ricerca
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateRicercaDocAssociati

Metodo DedNetSwAppCreateRicercaDocAssociati

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindDoc CreateRicercaDocAssociati()
Public Shared Function CreateRicercaDocAssociati As FindDoc
public:
static FindDoc^ CreateRicercaDocAssociati()
static member CreateRicercaDocAssociati : unit -> FindDoc

Valore di ritorno

FindDoc
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateRicercaDocumenti

Metodo DedNetSwAppCreateRicercaDocumenti

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindDoc CreateRicercaDocumenti()
Public Shared Function CreateRicercaDocumenti As FindDoc
public:
static FindDoc^ CreateRicercaDocumenti()
static member CreateRicercaDocumenti : unit -> FindDoc

Valore di ritorno

FindDoc
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateRilascio

Metodo DedNetSwAppCreateRilascio

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Rilascia CreateRilascio()
Public Shared Function CreateRilascio As Rilascia
public:
static Rilascia^ CreateRilascio()
static member CreateRilascio : unit -> Rilascia

Valore di ritorno

Rilascia
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateRilascioMultiplo

Metodo DedNetSwAppCreateRilascioMultiplo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Rilascia CreateRilascioMultiplo()
Public Shared Function CreateRilascioMultiplo As Rilascia
public:
static Rilascia^ CreateRilascioMultiplo()
static member CreateRilascioMultiplo : unit -> Rilascia

Valore di ritorno

Rilascia
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalva

Metodo DedNetSwAppCreateSalva

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalva()
Public Shared Function CreateSalva As Salva
public:
static Salva^ CreateSalva()
static member CreateSalva : unit -> Salva

Valore di ritorno

Salva
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaConf

Metodo DedNetSwAppCreateSalvaConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaConf()
Public Shared Function CreateSalvaConf As SalvaConf
public:
static SalvaConf^ CreateSalvaConf()
static member CreateSalvaConf : unit -> SalvaConf

Valore di ritorno

SalvaConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaDist

Metodo DedNetSwAppCreateSalvaDist

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaDist CreateSalvaDist()
Public Shared Function CreateSalvaDist As SalvaDist
public:
static SalvaDist^ CreateSalvaDist()
static member CreateSalvaDist : unit -> SalvaDist

Valore di ritorno

SalvaDist
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaMultiplo

Metodo DedNetSwAppCreateSalvaMultiplo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaMultiplo CreateSalvaMultiplo()
Public Shared Function CreateSalvaMultiplo As SalvaMultiplo
public:
static SalvaMultiplo^ CreateSalvaMultiplo()
static member CreateSalvaMultiplo : unit -> SalvaMultiplo

Valore di ritorno

SalvaMultiplo
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaPrt

Metodo DedNetSwAppCreateSalvaPrt

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalvaPrt()
Public Shared Function CreateSalvaPrt As Salva
public:
static Salva^ CreateSalvaPrt()
static member CreateSalvaPrt : unit -> Salva

Valore di ritorno

Salva
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaPrtConf

Metodo DedNetSwAppCreateSalvaPrtConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaPrtConf()
Public Shared Function CreateSalvaPrtConf As SalvaConf
public:
static SalvaConf^ CreateSalvaPrtConf()
static member CreateSalvaPrtConf : unit -> SalvaConf

Valore di ritorno

SalvaConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaPrtRev

Metodo DedNetSwAppCreateSalvaPrtRev

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaRev CreateSalvaPrtRev()
Public Shared Function CreateSalvaPrtRev As SalvaRev
public:
static SalvaRev^ CreateSalvaPrtRev()
static member CreateSalvaPrtRev : unit -> SalvaRev

Valore di ritorno

SalvaRev
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaPrtVariante

Metodo DedNetSwAppCreateSalvaPrtVariante

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalvaPrtVariante()
Public Shared Function CreateSalvaPrtVariante As Salva
public:
static Salva^ CreateSalvaPrtVariante()
static member CreateSalvaPrtVariante : unit -> Salva

Valore di ritorno

Salva
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaPrtVarianteConf

Metodo DedNetSwAppCreateSalvaPrtVarianteConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaPrtVarianteConf()
Public Shared Function CreateSalvaPrtVarianteConf As SalvaConf
public:
static SalvaConf^ CreateSalvaPrtVarianteConf()
static member CreateSalvaPrtVarianteConf : unit -> SalvaConf

Valore di ritorno

SalvaConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaRev

Metodo DedNetSwAppCreateSalvaRev

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaRev CreateSalvaRev()
Public Shared Function CreateSalvaRev As SalvaRev
public:
static SalvaRev^ CreateSalvaRev()
static member CreateSalvaRev : unit -> SalvaRev

Valore di ritorno

SalvaRev
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaSuperato

Metodo DedNetSwAppCreateSalvaSuperato

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaSuperato CreateSalvaSuperato()
Public Shared Function CreateSalvaSuperato As SalvaSuperato
public:
static SalvaSuperato^ CreateSalvaSuperato()
static member CreateSalvaSuperato : unit -> SalvaSuperato

Valore di ritorno

SalvaSuperato
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaVariante

Metodo DedNetSwAppCreateSalvaVariante

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalvaVariante()
Public Shared Function CreateSalvaVariante As Salva
public:
static Salva^ CreateSalvaVariante()
static member CreateSalvaVariante : unit -> Salva

Valore di ritorno

Salva
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSalvaVarianteConf

Metodo DedNetSwAppCreateSalvaVarianteConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaVarianteConf()
Public Shared Function CreateSalvaVarianteConf As SalvaConf
public:
static SalvaConf^ CreateSalvaVarianteConf()
static member CreateSalvaVarianteConf : unit -> SalvaConf

Valore di ritorno

SalvaConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSblocca

Metodo DedNetSwAppCreateSblocca

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Sblocca CreateSblocca()
Public Shared Function CreateSblocca As Sblocca
public:
static Sblocca^ CreateSblocca()
static member CreateSblocca : unit -> Sblocca

Valore di ritorno

Sblocca
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSostituisciComponente

Metodo DedNetSwAppCreateSostituisciComponente

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponente CreateSostituisciComponente()
Public Shared Function CreateSostituisciComponente As SostituisciComponente
public:
static SostituisciComponente^ CreateSostituisciComponente()
static member CreateSostituisciComponente : unit -> SostituisciComponente

Valore di ritorno

SostituisciComponente
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSostituisciComponenteRapidoSelezione

Metodo DedNetSwAppCreateSostituisciComponenteRapidoSelezione

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteRapido CreateSostituisciComponenteRapidoSelezione()
Public Shared Function CreateSostituisciComponenteRapidoSelezione As SostituisciComponenteRapido
public:
static SostituisciComponenteRapido^ CreateSostituisciComponenteRapidoSelezione()
static member CreateSostituisciComponenteRapidoSelezione : unit -> SostituisciComponenteRapido

Valore di ritorno

SostituisciComponenteRapido
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSostituisciComponenteRapidoTutti

Metodo DedNetSwAppCreateSostituisciComponenteRapidoTutti

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteRapido CreateSostituisciComponenteRapidoTutti()
Public Shared Function CreateSostituisciComponenteRapidoTutti As SostituisciComponenteRapido
public:
static SostituisciComponenteRapido^ CreateSostituisciComponenteRapidoTutti()
static member CreateSostituisciComponenteRapidoTutti : unit -> SostituisciComponenteRapido

Valore di ritorno

SostituisciComponenteRapido
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSostituisciComponenteRapidoTuttiStessoLivello

Metodo DedNetSwAppCreateSostituisciComponenteRapidoTuttiStessoLivello

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteRapido CreateSostituisciComponenteRapidoTuttiStessoLivello()
Public Shared Function CreateSostituisciComponenteRapidoTuttiStessoLivello As SostituisciComponenteRapido
public:
static SostituisciComponenteRapido^ CreateSostituisciComponenteRapidoTuttiStessoLivello()
static member CreateSostituisciComponenteRapidoTuttiStessoLivello : unit -> SostituisciComponenteRapido

Valore di ritorno

SostituisciComponenteRapido
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSostituisciMoved

Metodo DedNetSwAppCreateSostituisciMoved

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciMoved CreateSostituisciMoved()
Public Shared Function CreateSostituisciMoved As SostituisciMoved
public:
static SostituisciMoved^ CreateSostituisciMoved()
static member CreateSostituisciMoved : unit -> SostituisciMoved

Valore di ritorno

SostituisciMoved
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateStatoDocumento

Metodo DedNetSwAppCreateStatoDocumento

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static StatoDocumento CreateStatoDocumento()
Public Shared Function CreateStatoDocumento As StatoDocumento
public:
static StatoDocumento^ CreateStatoDocumento()
static member CreateStatoDocumento : unit -> StatoDocumento

Valore di ritorno

StatoDocumento
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSwAssociaConf

Metodo DedNetSwAppCreateSwAssociaConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaSwAssociaConf CreateSwAssociaConf()
Public Shared Function CreateSwAssociaConf As CreaSwAssociaConf
public:
static CreaSwAssociaConf^ CreateSwAssociaConf()
static member CreateSwAssociaConf : unit -> CreaSwAssociaConf

Valore di ritorno

CreaSwAssociaConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSwAssociaConfPrt

Metodo DedNetSwAppCreateSwAssociaConfPrt

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaSwAssociaConf CreateSwAssociaConfPrt()
Public Shared Function CreateSwAssociaConfPrt As CreaSwAssociaConf
public:
static CreaSwAssociaConf^ CreateSwAssociaConfPrt()
static member CreateSwAssociaConfPrt : unit -> CreaSwAssociaConf

Valore di ritorno

CreaSwAssociaConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSwAssociaDocument

Metodo DedNetSwAppCreateSwAssociaDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaSwAssociaDocument CreateSwAssociaDocument()
Public Shared Function CreateSwAssociaDocument As CreaSwAssociaDocument
public:
static CreaSwAssociaDocument^ CreateSwAssociaDocument()
static member CreateSwAssociaDocument : unit -> CreaSwAssociaDocument

Valore di ritorno

CreaSwAssociaDocument
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSwAssociaDocumentPrt

Metodo DedNetSwAppCreateSwAssociaDocumentPrt

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaSwAssociaDocument CreateSwAssociaDocumentPrt()
Public Shared Function CreateSwAssociaDocumentPrt As CreaSwAssociaDocument
public:
static CreaSwAssociaDocument^ CreateSwAssociaDocumentPrt()
static member CreateSwAssociaDocumentPrt : unit -> CreaSwAssociaDocument

Valore di ritorno

CreaSwAssociaDocument
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateSwScollegaConf

Metodo DedNetSwAppCreateSwScollegaConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaSwDisconnectConf CreateSwScollegaConf()
Public Shared Function CreateSwScollegaConf As CreaSwDisconnectConf
public:
static CreaSwDisconnectConf^ CreateSwScollegaConf()
static member CreateSwScollegaConf : unit -> CreaSwDisconnectConf

Valore di ritorno

CreaSwDisconnectConf
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateTabellaRevisioni

Metodo DedNetSwAppCreateTabellaRevisioni

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static TabellaRevisioni CreateTabellaRevisioni()
Public Shared Function CreateTabellaRevisioni As TabellaRevisioni
public:
static TabellaRevisioni^ CreateTabellaRevisioni()
static member CreateTabellaRevisioni : unit -> TabellaRevisioni

Valore di ritorno

TabellaRevisioni
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateTrovaNelBrowser

Metodo DedNetSwAppCreateTrovaNelBrowser

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindInBrowser CreateTrovaNelBrowser()
Public Shared Function CreateTrovaNelBrowser As FindInBrowser
public:
static FindInBrowser^ CreateTrovaNelBrowser()
static member CreateTrovaNelBrowser : unit -> FindInBrowser

Valore di ritorno

FindInBrowser
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateUpdateBranchInformations

Metodo DedNetSwAppCreateUpdateBranchInformations

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static UpdateBranchInformations CreateUpdateBranchInformations()
Public Shared Function CreateUpdateBranchInformations As UpdateBranchInformations
public:
static UpdateBranchInformations^ CreateUpdateBranchInformations()
static member CreateUpdateBranchInformations : unit -> UpdateBranchInformations

Valore di ritorno

UpdateBranchInformations
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.CreateWhereUsedSw

Metodo DedNetSwAppCreateWhereUsedSw

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static WhereUsedSw CreateWhereUsedSw()
Public Shared Function CreateWhereUsedSw As WhereUsedSw
public:
static WhereUsedSw^ CreateWhereUsedSw()
static member CreateWhereUsedSw : unit -> WhereUsedSw

Valore di ritorno

WhereUsedSw
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.DedpTopDistPre

Metodo DedNetSwAppDedpTopDistPre

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DedpTopDistPre()
Public Sub DedpTopDistPre
public:
void DedpTopDistPre()
member DedpTopDistPre : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.DetachEventHandlers

Metodo DedNetSwAppDetachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DetachEventHandlers()
Public Function DetachEventHandlers As Boolean
public:
bool DetachEventHandlers()
member DetachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.DetachModelEventHandler

Metodo DedNetSwAppDetachModelEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DetachModelEventHandler(
    ModelDoc2 modDoc
)
Public Function DetachModelEventHandler (
    modDoc As ModelDoc2
) As Boolean
public:
bool DetachModelEventHandler(
    ModelDoc2^ modDoc
)
member DetachModelEventHandler :
        modDoc : ModelDoc2 -> bool

Parametri

modDoc ModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.DisableModifyEntity

Metodo DedNetSwAppDisableModifyEntity

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int DisableModifyEntity(
    IModelDoc2 doc,
    int EntityType,
    string name
)
Public Shared Function DisableModifyEntity (
    doc As IModelDoc2,
    EntityType As Integer,
    name As String
) As Integer
public:
static int DisableModifyEntity(
    IModelDoc2^ doc,
    int EntityType,
    String^ name
)
static member DisableModifyEntity :
        doc : IModelDoc2 *
        EntityType : int *
        name : string -> int

Parametri

doc IModelDoc2
EntityType Int32
name String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.EndApprenticeServer

Metodo DedNetSwAppEndApprenticeServer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void EndApprenticeServer()
Public Shared Sub EndApprenticeServer
public:
static void EndApprenticeServer()
static member EndApprenticeServer : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetActiveElement

Metodo DedNetSwAppGetActiveElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetActiveElement()
Public Function GetActiveElement As FileStateElement
public:
virtual FileStateElement^ GetActiveElement() sealed
abstract GetActiveElement : unit -> FileStateElement
override GetActiveElement : unit -> FileStateElement

Valore di ritorno

FileStateElement

Implementa

IFileStateInformerGetActiveElement
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetAnagStateImageKey

Metodo DedNetSwAppGetAnagStateImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image GetAnagStateImageKey(
    FileStateElement el
)
Public Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
public:
virtual Image^ GetAnagStateImageKey(
    FileStateElement^ el
) sealed
abstract GetAnagStateImageKey :
        el : FileStateElement -> Image
override GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el FileStateElement

Valore di ritorno

Image

Implementa

IFileStateInformerGetAnagStateImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetAnagStateName

Metodo DedNetSwAppGetAnagStateName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAnagStateName(
    FileStateElement el
)
Public Function GetAnagStateName (
    el As FileStateElement
) As String
public:
virtual String^ GetAnagStateName(
    FileStateElement^ el
) sealed
abstract GetAnagStateName :
        el : FileStateElement -> string
override GetAnagStateName :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String

Implementa

IFileStateInformerGetAnagStateName(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetAttr

Metodo DedNetSwAppGetAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAttr(
    FileStateElement el,
    string attrPrompt
)
Public Function GetAttr (
    el As FileStateElement,
    attrPrompt As String
) As String
public:
virtual String^ GetAttr(
    FileStateElement^ el,
    String^ attrPrompt
) sealed
abstract GetAttr :
        el : FileStateElement *
        attrPrompt : string -> string
override GetAttr :
        el : FileStateElement *
        attrPrompt : string -> string

Parametri

el FileStateElement
attrPrompt String

Valore di ritorno

String

Implementa

IFileStateInformerGetAttr(FileStateElement, String)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetChildrenElements

Metodo DedNetSwAppGetChildrenElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList GetChildrenElements(
    FileStateElement el
)
Public Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
public:
virtual FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
) sealed
abstract GetChildrenElements :
        el : FileStateElement -> FileStateElementList
override GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el FileStateElement

Valore di ritorno

FileStateElementList

Implementa

IFileStateInformerGetChildrenElements(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetData

Metodo DedNetSwAppGetData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData GetData(
    FileStateElement el
)
Public Function GetData (
    el As FileStateElement
) As DedData
public:
virtual DedData^ GetData(
    FileStateElement^ el
) sealed
abstract GetData :
        el : FileStateElement -> DedData
override GetData :
        el : FileStateElement -> DedData

Parametri

el FileStateElement

Valore di ritorno

DedData

Implementa

IFileStateInformerGetData(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetDocument

Metodo DedNetSwAppGetDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetDocument(
    FileStateElement el
)
Public Function GetDocument (
    el As FileStateElement
) As DedDoc
public:
virtual DedDoc^ GetDocument(
    FileStateElement^ el
) sealed
abstract GetDocument :
        el : FileStateElement -> DedDoc
override GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc

Implementa

IFileStateInformerGetDocument(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetMovedDocument

Metodo DedNetSwAppGetMovedDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDocument(
    FileStateElement el
)
Public Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
public:
virtual DedDoc^ GetMovedDocument(
    FileStateElement^ el
) sealed
abstract GetMovedDocument :
        el : FileStateElement -> DedDoc
override GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc

Implementa

IFileStateInformerGetMovedDocument(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetSelectionImageKey

Metodo DedNetSwAppGetSelectionImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetSelectionImageKey(
    FileStateElement el
)
Public Function GetSelectionImageKey (
    el As FileStateElement
) As String
public:
virtual String^ GetSelectionImageKey(
    FileStateElement^ el
) sealed
abstract GetSelectionImageKey :
        el : FileStateElement -> string
override GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String

Implementa

IFileStateInformerGetSelectionImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetState

Metodo DedNetSwAppGetState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int GetState(
    FileStateElement el
)
Public Function GetState (
    el As FileStateElement
) As Integer
public:
virtual int GetState(
    FileStateElement^ el
) sealed
abstract GetState :
        el : FileStateElement -> int
override GetState :
        el : FileStateElement -> int

Parametri

el FileStateElement

Valore di ritorno

Int32

Implementa

IFileStateInformerGetState(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.GetStateImageKey

Metodo DedNetSwAppGetStateImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetStateImageKey(
    FileStateElement el
)
Public Function GetStateImageKey (
    el As FileStateElement
) As String
public:
virtual String^ GetStateImageKey(
    FileStateElement^ el
) sealed
abstract GetStateImageKey :
        el : FileStateElement -> string
override GetStateImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String

Implementa

IFileStateInformerGetStateImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.HasChildrenElements

Metodo DedNetSwAppHasChildrenElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildrenElements(
    FileStateElement el
)
Public Function HasChildrenElements (
    el As FileStateElement
) As Boolean
public:
virtual bool HasChildrenElements(
    FileStateElement^ el
) sealed
abstract HasChildrenElements :
        el : FileStateElement -> bool
override HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean

Implementa

IFileStateInformerHasChildrenElements(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.InvalidOperation

Metodo DedNetSwAppInvalidOperation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool InvalidOperation(
    IModelDoc2 swdoc
)
Public Shared Function InvalidOperation (
    swdoc As IModelDoc2
) As Boolean
public:
static bool InvalidOperation(
    IModelDoc2^ swdoc
)
static member InvalidOperation :
        swdoc : IModelDoc2 -> bool

Parametri

swdoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.IsActiveDocument

Metodo DedNetSwAppIsActiveDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsActiveDocument(
    IModelDoc2 doc
)
Public Shared Function IsActiveDocument (
    doc As IModelDoc2
) As Boolean
public:
static bool IsActiveDocument(
    IModelDoc2^ doc
)
static member IsActiveDocument :
        doc : IModelDoc2 -> bool

Parametri

doc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.IsDirty

Metodo DedNetSwAppIsDirty

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty(
    FileStateElement el
)
Public Function IsDirty (
    el As FileStateElement
) As Boolean
public:
virtual bool IsDirty(
    FileStateElement^ el
) sealed
abstract IsDirty :
        el : FileStateElement -> bool
override IsDirty :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean

Implementa

IFileStateInformerIsDirty(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.Log

Metodo DedNetSwAppLog

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex,
    bool silent
)
Public Shared Sub Log (
    ex As Exception,
    silent As Boolean
)
public:
static void Log(
    Exception^ ex,
    bool silent
)
static member Log :
        ex : Exception *
        silent : bool -> unit

Parametri

ex Exception
silent Boolean
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.LogError

Metodo DedNetSwAppLogError

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogError(
    string str
)
Public Shared Sub LogError (
    str As String
)
public:
static void LogError(
    String^ str
)
static member LogError :
        str : string -> unit

Parametri

str String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.LogInfo

Metodo DedNetSwAppLogInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogInfo(
    string str
)
Public Shared Sub LogInfo (
    str As String
)
public:
static void LogInfo(
    String^ str
)
static member LogInfo :
        str : string -> unit

Parametri

str String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.LogWarning

Metodo DedNetSwAppLogWarning

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogWarning(
    string str
)
Public Shared Sub LogWarning (
    str As String
)
public:
static void LogWarning(
    String^ str
)
static member LogWarning :
        str : string -> unit

Parametri

str String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbAppEvents_Destroy

Metodo DedNetSwAppm_tbAppEvents_Destroy

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbAppEvents_Destroy()
Public Function m_tbAppEvents_Destroy As Integer
public:
int m_tbAppEvents_Destroy()
member m_tbAppEvents_Destroy : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_AfterCopyingDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_AfterCopyingDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_AfterCopyingDocument(
    string strFileNameToCopyPath,
    string strFileNameToCopyToPath,
    int deleteSource
)
Public Function m_tbPDMDocManagerEvents_AfterCopyingDocument (
    strFileNameToCopyPath As String,
    strFileNameToCopyToPath As String,
    deleteSource As Integer
) As Integer
public:
int m_tbPDMDocManagerEvents_AfterCopyingDocument(
    String^ strFileNameToCopyPath,
    String^ strFileNameToCopyToPath,
    int deleteSource
)
member m_tbPDMDocManagerEvents_AfterCopyingDocument :
        strFileNameToCopyPath : string *
        strFileNameToCopyToPath : string *
        deleteSource : int -> int

Parametri

strFileNameToCopyPath String
strFileNameToCopyToPath String
deleteSource Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_AfterDeletingDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_AfterDeletingDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_AfterDeletingDocument(
    string strFileNameToCopyPath
)
Public Function m_tbPDMDocManagerEvents_AfterDeletingDocument (
    strFileNameToCopyPath As String
) As Integer
public:
int m_tbPDMDocManagerEvents_AfterDeletingDocument(
    String^ strFileNameToCopyPath
)
member m_tbPDMDocManagerEvents_AfterDeletingDocument :
        strFileNameToCopyPath : string -> int

Parametri

strFileNameToCopyPath String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_AfterWritingToDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_AfterWritingToDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_AfterWritingToDocument(
    string strFileNameToWritePath
)
Public Function m_tbPDMDocManagerEvents_AfterWritingToDocument (
    strFileNameToWritePath As String
) As Integer
public:
int m_tbPDMDocManagerEvents_AfterWritingToDocument(
    String^ strFileNameToWritePath
)
member m_tbPDMDocManagerEvents_AfterWritingToDocument :
        strFileNameToWritePath : string -> int

Parametri

strFileNameToWritePath String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_BeforeCopyingDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_BeforeCopyingDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_BeforeCopyingDocument(
    string strFileNameToCopyPath,
    string strFileNameToCopyToPath,
    int deleteSource
)
Public Function m_tbPDMDocManagerEvents_BeforeCopyingDocument (
    strFileNameToCopyPath As String,
    strFileNameToCopyToPath As String,
    deleteSource As Integer
) As Integer
public:
int m_tbPDMDocManagerEvents_BeforeCopyingDocument(
    String^ strFileNameToCopyPath,
    String^ strFileNameToCopyToPath,
    int deleteSource
)
member m_tbPDMDocManagerEvents_BeforeCopyingDocument :
        strFileNameToCopyPath : string *
        strFileNameToCopyToPath : string *
        deleteSource : int -> int

Parametri

strFileNameToCopyPath String
strFileNameToCopyToPath String
deleteSource Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_BeforeDeletingDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_BeforeDeletingDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_BeforeDeletingDocument(
    string strFileNameToDeletePath
)
Public Function m_tbPDMDocManagerEvents_BeforeDeletingDocument (
    strFileNameToDeletePath As String
) As Integer
public:
int m_tbPDMDocManagerEvents_BeforeDeletingDocument(
    String^ strFileNameToDeletePath
)
member m_tbPDMDocManagerEvents_BeforeDeletingDocument :
        strFileNameToDeletePath : string -> int

Parametri

strFileNameToDeletePath String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_BeforeWritingToDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_BeforeWritingToDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_BeforeWritingToDocument(
    string strFileNameToWritePath
)
Public Function m_tbPDMDocManagerEvents_BeforeWritingToDocument (
    strFileNameToWritePath As String
) As Integer
public:
int m_tbPDMDocManagerEvents_BeforeWritingToDocument(
    String^ strFileNameToWritePath
)
member m_tbPDMDocManagerEvents_BeforeWritingToDocument :
        strFileNameToWritePath : string -> int

Parametri

strFileNameToWritePath String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_Destroy

Metodo DedNetSwAppm_tbPDMDocManagerEvents_Destroy

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_Destroy()
Public Function m_tbPDMDocManagerEvents_Destroy As Integer
public:
int m_tbPDMDocManagerEvents_Destroy()
member m_tbPDMDocManagerEvents_Destroy : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_NewDocumentAdded

Metodo DedNetSwAppm_tbPDMDocManagerEvents_NewDocumentAdded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_NewDocumentAdded(
    string strInsertedFileNamePath,
    int iToolboxID,
    int iAddedToBrowser
)
Public Function m_tbPDMDocManagerEvents_NewDocumentAdded (
    strInsertedFileNamePath As String,
    iToolboxID As Integer,
    iAddedToBrowser As Integer
) As Integer
public:
int m_tbPDMDocManagerEvents_NewDocumentAdded(
    String^ strInsertedFileNamePath,
    int iToolboxID,
    int iAddedToBrowser
)
member m_tbPDMDocManagerEvents_NewDocumentAdded :
        strInsertedFileNamePath : string *
        iToolboxID : int *
        iAddedToBrowser : int -> int

Parametri

strInsertedFileNamePath String
iToolboxID Int32
iAddedToBrowser Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.m_tbPDMDocManagerEvents_PreInsertDocument

Metodo DedNetSwAppm_tbPDMDocManagerEvents_PreInsertDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int m_tbPDMDocManagerEvents_PreInsertDocument(
    string strInsertedFileNamePath,
    int iToolboxID
)
Public Function m_tbPDMDocManagerEvents_PreInsertDocument (
    strInsertedFileNamePath As String,
    iToolboxID As Integer
) As Integer
public:
int m_tbPDMDocManagerEvents_PreInsertDocument(
    String^ strInsertedFileNamePath,
    int iToolboxID
)
member m_tbPDMDocManagerEvents_PreInsertDocument :
        strInsertedFileNamePath : string *
        iToolboxID : int -> int

Parametri

strInsertedFileNamePath String
iToolboxID Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.MakeSwCommandContext

Metodo DedNetSwAppMakeSwCommandContext
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeSwCommandContext(FileStateElement) |
Metodo pubblico | MakeSwCommandContext(FileStateElementList) |
Torna su
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.MakeSwCommandContext(FileStateElement)

Metodo DedNetSwAppMakeSwCommandContext(FileStateElement)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwCommandContext MakeSwCommandContext(
    FileStateElement el
)
Public Function MakeSwCommandContext (
    el As FileStateElement
) As DedSwCommandContext
public:
DedSwCommandContext^ MakeSwCommandContext(
    FileStateElement^ el
)
member MakeSwCommandContext :
        el : FileStateElement -> DedSwCommandContext

Parametri

el FileStateElement

Valore di ritorno

DedSwCommandContext
Vedi anche

Documentazione

Classe DedNetSwApp
Overload di MakeSwCommandContext
Namespace DedNetSw


Metodo DedNetSwApp.MakeSwCommandContext(FileStateElementList)

Metodo DedNetSwAppMakeSwCommandContext(FileStateElementList)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwCommandContext MakeSwCommandContext(
    FileStateElementList elsList
)
Public Function MakeSwCommandContext (
    elsList As FileStateElementList
) As DedSwCommandContext
public:
virtual DedSwCommandContext^ MakeSwCommandContext(
    FileStateElementList^ elsList
) sealed
abstract MakeSwCommandContext :
        elsList : FileStateElementList -> DedSwCommandContext
override MakeSwCommandContext :
        elsList : FileStateElementList -> DedSwCommandContext

Parametri

elsList FileStateElementList

Valore di ritorno

DedSwCommandContext

Implementa

IFileStateInformerMakeSwCommandContext(FileStateElementList)
Vedi anche

Documentazione

Classe DedNetSwApp
Overload di MakeSwCommandContext
Namespace DedNetSw


Metodo DedNetSwApp.OnAddTiesApprenticeEvent

Metodo DedNetSwAppOnAddTiesApprenticeEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnAddTiesApprenticeEvent(
    Object sender,
    DedNetSwAppResolutionEventArgs e
)
Public Shared Sub OnAddTiesApprenticeEvent (
    sender As Object,
    e As DedNetSwAppResolutionEventArgs
)
public:
static void OnAddTiesApprenticeEvent(
    Object^ sender,
    DedNetSwAppResolutionEventArgs^ e
)
static member OnAddTiesApprenticeEvent :
        sender : Object *
        e : DedNetSwAppResolutionEventArgs -> unit

Parametri

sender Object
e DedNetSwAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnChangeDsInfoStructOnPackAndGoExportEvent

Metodo DedNetSwAppOnChangeDsInfoStructOnPackAndGoExportEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnChangeDsInfoStructOnPackAndGoExportEvent(
    Object sender,
    DedNetSwAppChangeDsInfoStructEventArgs e
)
Public Shared Sub OnChangeDsInfoStructOnPackAndGoExportEvent (
    sender As Object,
    e As DedNetSwAppChangeDsInfoStructEventArgs
)
public:
static void OnChangeDsInfoStructOnPackAndGoExportEvent(
    Object^ sender,
    DedNetSwAppChangeDsInfoStructEventArgs^ e
)
static member OnChangeDsInfoStructOnPackAndGoExportEvent :
        sender : Object *
        e : DedNetSwAppChangeDsInfoStructEventArgs -> unit

Parametri

sender Object
e DedNetSwAppChangeDsInfoStructEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnDedSwPublishEvent

Metodo DedNetSwAppOnDedSwPublishEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnDedSwPublishEvent(
    Object sender,
    DedNetSwAppDedSwPublishEventArgs e
)
Public Shared Sub OnDedSwPublishEvent (
    sender As Object,
    e As DedNetSwAppDedSwPublishEventArgs
)
public:
static void OnDedSwPublishEvent(
    Object^ sender,
    DedNetSwAppDedSwPublishEventArgs^ e
)
static member OnDedSwPublishEvent :
        sender : Object *
        e : DedNetSwAppDedSwPublishEventArgs -> unit

Parametri

sender Object
e DedNetSwAppDedSwPublishEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnElementDoubleClicked

Metodo DedNetSwAppOnElementDoubleClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementDoubleClicked(
    FileStateElement el
)
Public Sub OnElementDoubleClicked (
    el As FileStateElement
)
public:
virtual void OnElementDoubleClicked(
    FileStateElement^ el
) sealed
abstract OnElementDoubleClicked :
        el : FileStateElement -> unit
override OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el FileStateElement

Implementa

IFileStateInformerOnElementDoubleClicked(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnElementsSelected

Metodo DedNetSwAppOnElementsSelected

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementsSelected(
    FileStateElementList elsList
)
Public Sub OnElementsSelected (
    elsList As FileStateElementList
)
public:
virtual void OnElementsSelected(
    FileStateElementList^ elsList
) sealed
abstract OnElementsSelected :
        elsList : FileStateElementList -> unit
override OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList FileStateElementList

Implementa

IFileStateInformerOnElementsSelected(FileStateElementList)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnFileNew

Metodo DedNetSwAppOnFileNew

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnFileNew(
    Object newDoc,
    int docType,
    string templateName
)
Public Function OnFileNew (
    newDoc As Object,
    docType As Integer,
    templateName As String
) As Integer
public:
int OnFileNew(
    Object^ newDoc,
    int docType,
    String^ templateName
)
member OnFileNew :
        newDoc : Object *
        docType : int *
        templateName : string -> int

Parametri

newDoc Object
docType Int32
templateName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnFileResolutionEvent

Metodo DedNetSwAppOnFileResolutionEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnFileResolutionEvent(
    Object sender,
    DedNetSwAppResolutionEventArgs e
)
Public Shared Sub OnFileResolutionEvent (
    sender As Object,
    e As DedNetSwAppResolutionEventArgs
)
public:
static void OnFileResolutionEvent(
    Object^ sender,
    DedNetSwAppResolutionEventArgs^ e
)
static member OnFileResolutionEvent :
        sender : Object *
        e : DedNetSwAppResolutionEventArgs -> unit

Parametri

sender Object
e DedNetSwAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnHotTrackElementClicked

Metodo DedNetSwAppOnHotTrackElementClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OnHotTrackElementClicked(
    FileStateElement el
)
Public Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
public:
virtual bool OnHotTrackElementClicked(
    FileStateElement^ el
) sealed
abstract OnHotTrackElementClicked :
        el : FileStateElement -> bool
override OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean

Implementa

IFileStateInformerOnHotTrackElementClicked(FileStateElement)
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnImportOnSaveEvent

Metodo DedNetSwAppOnImportOnSaveEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportOnSaveEvent(
    Object sender,
    DedNetSwAppImportOnSaveEventArgs e
)
Public Shared Sub OnImportOnSaveEvent (
    sender As Object,
    e As DedNetSwAppImportOnSaveEventArgs
)
public:
static void OnImportOnSaveEvent(
    Object^ sender,
    DedNetSwAppImportOnSaveEventArgs^ e
)
static member OnImportOnSaveEvent :
        sender : Object *
        e : DedNetSwAppImportOnSaveEventArgs -> unit

Parametri

sender Object
e DedNetSwAppImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnImportPackAndGoAfterLoadEvent

Metodo DedNetSwAppOnImportPackAndGoAfterLoadEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoAfterLoadEvent(
    Object sender,
    DedNetSwAppImportPackAndGoAfterLoadEventArgs e
)
Public Shared Sub OnImportPackAndGoAfterLoadEvent (
    sender As Object,
    e As DedNetSwAppImportPackAndGoAfterLoadEventArgs
)
public:
static void OnImportPackAndGoAfterLoadEvent(
    Object^ sender,
    DedNetSwAppImportPackAndGoAfterLoadEventArgs^ e
)
static member OnImportPackAndGoAfterLoadEvent :
        sender : Object *
        e : DedNetSwAppImportPackAndGoAfterLoadEventArgs -> unit

Parametri

sender Object
e DedNetSwAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnImportPackAndGoDocAttrCompareEvent

Metodo DedNetSwAppOnImportPackAndGoDocAttrCompareEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoDocAttrCompareEvent(
    Object sender,
    DedNetSwAppImportPackAndGoDocAttrCompareEventArgs e
)
Public Shared Sub OnImportPackAndGoDocAttrCompareEvent (
    sender As Object,
    e As DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
)
public:
static void OnImportPackAndGoDocAttrCompareEvent(
    Object^ sender,
    DedNetSwAppImportPackAndGoDocAttrCompareEventArgs^ e
)
static member OnImportPackAndGoDocAttrCompareEvent :
        sender : Object *
        e : DedNetSwAppImportPackAndGoDocAttrCompareEventArgs -> unit

Parametri

sender Object
e DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnImportPackAndGoMappingRootEvent

Metodo DedNetSwAppOnImportPackAndGoMappingRootEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoMappingRootEvent(
    Object sender,
    DedNetSwAppImportPackAndGoMappingRootEventArgs e
)
Public Shared Sub OnImportPackAndGoMappingRootEvent (
    sender As Object,
    e As DedNetSwAppImportPackAndGoMappingRootEventArgs
)
public:
static void OnImportPackAndGoMappingRootEvent(
    Object^ sender,
    DedNetSwAppImportPackAndGoMappingRootEventArgs^ e
)
static member OnImportPackAndGoMappingRootEvent :
        sender : Object *
        e : DedNetSwAppImportPackAndGoMappingRootEventArgs -> unit

Parametri

sender Object
e DedNetSwAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnImportPackAndGoOverrideCheckOverwriteOperationEvent

Metodo DedNetSwAppOnImportPackAndGoOverrideCheckOverwriteOperationEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object sender,
    DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoOverrideCheckOverwriteOperationEvent (
    sender As Object,
    e As DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
)
public:
static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object^ sender,
    DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^ e
)
static member OnImportPackAndGoOverrideCheckOverwriteOperationEvent :
        sender : Object *
        e : DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs -> unit

Parametri

sender Object
e DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnImportPackAndGoPresetCodingOperationEvent

Metodo DedNetSwAppOnImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoPresetCodingOperationEvent(
    Object sender,
    DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoPresetCodingOperationEvent (
    sender As Object,
    e As DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
)
public:
static void OnImportPackAndGoPresetCodingOperationEvent(
    Object^ sender,
    DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs^ e
)
static member OnImportPackAndGoPresetCodingOperationEvent :
        sender : Object *
        e : DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs -> unit

Parametri

sender Object
e DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnItemAddedEvent

Metodo DedNetSwAppOnItemAddedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnItemAddedEvent(
    Object sender,
    DedNetSwAppItemAddedEventArgs e
)
Public Shared Sub OnItemAddedEvent (
    sender As Object,
    e As DedNetSwAppItemAddedEventArgs
)
public:
static void OnItemAddedEvent(
    Object^ sender,
    DedNetSwAppItemAddedEventArgs^ e
)
static member OnItemAddedEvent :
        sender : Object *
        e : DedNetSwAppItemAddedEventArgs -> unit

Parametri

sender Object
e DedNetSwAppItemAddedEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnMultiSaverElaborateItemEvent

Metodo DedNetSwAppOnMultiSaverElaborateItemEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverElaborateItemEvent(
    Object sender,
    DedNetSwAppMultiSaverItemElaborationEventArgs e
)
Public Shared Sub OnMultiSaverElaborateItemEvent (
    sender As Object,
    e As DedNetSwAppMultiSaverItemElaborationEventArgs
)
public:
static void OnMultiSaverElaborateItemEvent(
    Object^ sender,
    DedNetSwAppMultiSaverItemElaborationEventArgs^ e
)
static member OnMultiSaverElaborateItemEvent :
        sender : Object *
        e : DedNetSwAppMultiSaverItemElaborationEventArgs -> unit

Parametri

sender Object
e DedNetSwAppMultiSaverItemElaborationEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnMultiSaverElaborateStructEvent

Metodo DedNetSwAppOnMultiSaverElaborateStructEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverElaborateStructEvent(
    Object sender,
    DedNetSwAppMultiSaverExecutionInfoEventArgs e
)
Public Shared Sub OnMultiSaverElaborateStructEvent (
    sender As Object,
    e As DedNetSwAppMultiSaverExecutionInfoEventArgs
)
public:
static void OnMultiSaverElaborateStructEvent(
    Object^ sender,
    DedNetSwAppMultiSaverExecutionInfoEventArgs^ e
)
static member OnMultiSaverElaborateStructEvent :
        sender : Object *
        e : DedNetSwAppMultiSaverExecutionInfoEventArgs -> unit

Parametri

sender Object
e DedNetSwAppMultiSaverExecutionInfoEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnMultiSaverOverrideDedTypeEvent

Metodo DedNetSwAppOnMultiSaverOverrideDedTypeEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverOverrideDedTypeEvent(
    Object sender,
    DedNetSwAppMultiSaverOverrideDedTypeEventArgs e
)
Public Shared Sub OnMultiSaverOverrideDedTypeEvent (
    sender As Object,
    e As DedNetSwAppMultiSaverOverrideDedTypeEventArgs
)
public:
static void OnMultiSaverOverrideDedTypeEvent(
    Object^ sender,
    DedNetSwAppMultiSaverOverrideDedTypeEventArgs^ e
)
static member OnMultiSaverOverrideDedTypeEvent :
        sender : Object *
        e : DedNetSwAppMultiSaverOverrideDedTypeEventArgs -> unit

Parametri

sender Object
e DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnMultiSaverPopulateListEvent

Metodo DedNetSwAppOnMultiSaverPopulateListEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverPopulateListEvent(
    Object sender,
    EventArgs e
)
Public Shared Sub OnMultiSaverPopulateListEvent (
    sender As Object,
    e As EventArgs
)
public:
static void OnMultiSaverPopulateListEvent(
    Object^ sender,
    EventArgs^ e
)
static member OnMultiSaverPopulateListEvent :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnSwRilInvRilCheckCoherence

Metodo DedNetSwAppOnSwRilInvRilCheckCoherence

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnSwRilInvRilCheckCoherence(
    Object sender,
    DedNetSwAppSwRilCheckCoherenceEventArgs e
)
Public Shared Sub OnSwRilInvRilCheckCoherence (
    sender As Object,
    e As DedNetSwAppSwRilCheckCoherenceEventArgs
)
public:
static void OnSwRilInvRilCheckCoherence(
    Object^ sender,
    DedNetSwAppSwRilCheckCoherenceEventArgs^ e
)
static member OnSwRilInvRilCheckCoherence :
        sender : Object *
        e : DedNetSwAppSwRilCheckCoherenceEventArgs -> unit

Parametri

sender Object
e DedNetSwAppSwRilCheckCoherenceEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.OnSwRilPublishEvent

Metodo DedNetSwAppOnSwRilPublishEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnSwRilPublishEvent(
    Object sender,
    DedNetSwAppSwRilPublishEventArgs e
)
Public Shared Sub OnSwRilPublishEvent (
    sender As Object,
    e As DedNetSwAppSwRilPublishEventArgs
)
public:
static void OnSwRilPublishEvent(
    Object^ sender,
    DedNetSwAppSwRilPublishEventArgs^ e
)
static member OnSwRilPublishEvent :
        sender : Object *
        e : DedNetSwAppSwRilPublishEventArgs -> unit

Parametri

sender Object
e DedNetSwAppSwRilPublishEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.SalvaVeloce

Metodo DedNetSwAppSalvaVeloce

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int SalvaVeloce(
    string FileName
)
Public Shared Function SalvaVeloce (
    FileName As String
) As Integer
public:
static int SalvaVeloce(
    String^ FileName
)
static member SalvaVeloce :
        FileName : string -> int

Parametri

FileName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.SetCurrentWorkingDirectory

Metodo DedNetSwAppSetCurrentWorkingDirectory

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetCurrentWorkingDirectory()
Public Shared Sub SetCurrentWorkingDirectory
public:
static void SetCurrentWorkingDirectory()
static member SetCurrentWorkingDirectory : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.UpdateAttrib

Metodo DedNetSwAppUpdateAttrib

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateAttrib(
    string filename
)
Public Shared Sub UpdateAttrib (
    filename As String
)
public:
static void UpdateAttrib(
    String^ filename
)
static member UpdateAttrib :
        filename : string -> unit

Parametri

filename String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.UpdateCfg

Metodo DedNetSwAppUpdateCfg

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int UpdateCfg(
    IModelDoc2 doc,
    int EntityType
)
Public Shared Function UpdateCfg (
    doc As IModelDoc2,
    EntityType As Integer
) As Integer
public:
static int UpdateCfg(
    IModelDoc2^ doc,
    int EntityType
)
static member UpdateCfg :
        doc : IModelDoc2 *
        EntityType : int -> int

Parametri

doc IModelDoc2
EntityType Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Metodo DedNetSwApp.UpdateComponentToolbox

Metodo DedNetSwAppUpdateComponentToolbox

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateComponentToolbox(
    string componentName
)
Public Shared Sub UpdateComponentToolbox (
    componentName As String
)
public:
static void UpdateComponentToolbox(
    String^ componentName
)
static member UpdateComponentToolbox :
        componentName : string -> unit

Parametri

componentName String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Eventi di DedNetSwApp

Il tipo DedNetSwApp espone i seguenti membri.

Eventi
Nome | Descrizione
AddTiesApprenticeEvent |
ChangeDsInfoStructOnPackAndGoExportEvent |
DedSwPublishEvent |
FileResolutionEvent |
ImportOnSaveEvent |
ImportPackAndGoAfterLoadEvent |
ImportPackAndGoDocAttrCompareEvent |
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent |
ImportPackAndGoPresetCodingOperationEvent |
ItemAddedEvent |
MultiSaverElaborateItemEvent |
MultiSaverElaborateStructEvent |
MultiSaverOverrideDedTypeEvent |
MultiSaverPopulateListEvent |
SwRilInvRilCheckCoherence |
SwRilPublishEvent |
Torna su
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.AddTiesApprenticeEvent

Evento DedNetSwAppAddTiesApprenticeEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppResolutionEventArgs> AddTiesApprenticeEvent
Public Shared Event AddTiesApprenticeEvent As EventHandler(Of DedNetSwAppResolutionEventArgs)
public:
static  event EventHandler<DedNetSwAppResolutionEventArgs^>^ AddTiesApprenticeEvent {
    void add (EventHandler<DedNetSwAppResolutionEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppResolutionEventArgs^>^ value);
}
member AddTiesApprenticeEvent : IEvent<EventHandler<DedNetSwAppResolutionEventArgs>,
    DedNetSwAppResolutionEventArgs>

Valore

EventHandler DedNetSwAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ChangeDsInfoStructOnPackAndGoExportEvent

Evento DedNetSwAppChangeDsInfoStructOnPackAndGoExportEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppChangeDsInfoStructEventArgs> ChangeDsInfoStructOnPackAndGoExportEvent
Public Shared Event ChangeDsInfoStructOnPackAndGoExportEvent As EventHandler(Of DedNetSwAppChangeDsInfoStructEventArgs)
public:
static  event EventHandler<DedNetSwAppChangeDsInfoStructEventArgs^>^ ChangeDsInfoStructOnPackAndGoExportEvent {
    void add (EventHandler<DedNetSwAppChangeDsInfoStructEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppChangeDsInfoStructEventArgs^>^ value);
}
member ChangeDsInfoStructOnPackAndGoExportEvent : IEvent<EventHandler<DedNetSwAppChangeDsInfoStructEventArgs>,
    DedNetSwAppChangeDsInfoStructEventArgs>

Valore

EventHandler DedNetSwAppChangeDsInfoStructEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.DedSwPublishEvent

Evento DedNetSwAppDedSwPublishEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppDedSwPublishEventArgs> DedSwPublishEvent
Public Shared Event DedSwPublishEvent As EventHandler(Of DedNetSwAppDedSwPublishEventArgs)
public:
static  event EventHandler<DedNetSwAppDedSwPublishEventArgs^>^ DedSwPublishEvent {
    void add (EventHandler<DedNetSwAppDedSwPublishEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppDedSwPublishEventArgs^>^ value);
}
member DedSwPublishEvent : IEvent<EventHandler<DedNetSwAppDedSwPublishEventArgs>,
    DedNetSwAppDedSwPublishEventArgs>

Valore

EventHandler DedNetSwAppDedSwPublishEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.FileResolutionEvent

Evento DedNetSwAppFileResolutionEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppResolutionEventArgs> FileResolutionEvent
Public Shared Event FileResolutionEvent As EventHandler(Of DedNetSwAppResolutionEventArgs)
public:
static  event EventHandler<DedNetSwAppResolutionEventArgs^>^ FileResolutionEvent {
    void add (EventHandler<DedNetSwAppResolutionEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppResolutionEventArgs^>^ value);
}
member FileResolutionEvent : IEvent<EventHandler<DedNetSwAppResolutionEventArgs>,
    DedNetSwAppResolutionEventArgs>

Valore

EventHandler DedNetSwAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ImportOnSaveEvent

Evento DedNetSwAppImportOnSaveEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppImportOnSaveEventArgs> ImportOnSaveEvent
Public Shared Event ImportOnSaveEvent As EventHandler(Of DedNetSwAppImportOnSaveEventArgs)
public:
static  event EventHandler<DedNetSwAppImportOnSaveEventArgs^>^ ImportOnSaveEvent {
    void add (EventHandler<DedNetSwAppImportOnSaveEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppImportOnSaveEventArgs^>^ value);
}
member ImportOnSaveEvent : IEvent<EventHandler<DedNetSwAppImportOnSaveEventArgs>,
    DedNetSwAppImportOnSaveEventArgs>

Valore

EventHandler DedNetSwAppImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ImportPackAndGoAfterLoadEvent

Evento DedNetSwAppImportPackAndGoAfterLoadEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppImportPackAndGoAfterLoadEventArgs> ImportPackAndGoAfterLoadEvent
Public Shared Event ImportPackAndGoAfterLoadEvent As EventHandler(Of DedNetSwAppImportPackAndGoAfterLoadEventArgs)
public:
static  event EventHandler<DedNetSwAppImportPackAndGoAfterLoadEventArgs^>^ ImportPackAndGoAfterLoadEvent {
    void add (EventHandler<DedNetSwAppImportPackAndGoAfterLoadEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppImportPackAndGoAfterLoadEventArgs^>^ value);
}
member ImportPackAndGoAfterLoadEvent : IEvent<EventHandler<DedNetSwAppImportPackAndGoAfterLoadEventArgs>,
    DedNetSwAppImportPackAndGoAfterLoadEventArgs>

Valore

EventHandler DedNetSwAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ImportPackAndGoDocAttrCompareEvent

Evento DedNetSwAppImportPackAndGoDocAttrCompareEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppImportPackAndGoDocAttrCompareEventArgs> ImportPackAndGoDocAttrCompareEvent
Public Shared Event ImportPackAndGoDocAttrCompareEvent As EventHandler(Of DedNetSwAppImportPackAndGoDocAttrCompareEventArgs)
public:
static  event EventHandler<DedNetSwAppImportPackAndGoDocAttrCompareEventArgs^>^ ImportPackAndGoDocAttrCompareEvent {
    void add (EventHandler<DedNetSwAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
}
member ImportPackAndGoDocAttrCompareEvent : IEvent<EventHandler<DedNetSwAppImportPackAndGoDocAttrCompareEventArgs>,
    DedNetSwAppImportPackAndGoDocAttrCompareEventArgs>

Valore

EventHandler DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ImportPackAndGoMappingRootEvent

Evento DedNetSwAppImportPackAndGoMappingRootEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppImportPackAndGoMappingRootEventArgs> ImportPackAndGoMappingRootEvent
Public Shared Event ImportPackAndGoMappingRootEvent As EventHandler(Of DedNetSwAppImportPackAndGoMappingRootEventArgs)
public:
static  event EventHandler<DedNetSwAppImportPackAndGoMappingRootEventArgs^>^ ImportPackAndGoMappingRootEvent {
    void add (EventHandler<DedNetSwAppImportPackAndGoMappingRootEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppImportPackAndGoMappingRootEventArgs^>^ value);
}
member ImportPackAndGoMappingRootEvent : IEvent<EventHandler<DedNetSwAppImportPackAndGoMappingRootEventArgs>,
    DedNetSwAppImportPackAndGoMappingRootEventArgs>

Valore

EventHandler DedNetSwAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEvent

Evento DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs> ImportPackAndGoOverrideCheckOverwriteOperationEvent
Public Shared Event ImportPackAndGoOverrideCheckOverwriteOperationEvent As EventHandler(Of DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs)
public:
static  event EventHandler<DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ ImportPackAndGoOverrideCheckOverwriteOperationEvent {
    void add (EventHandler<DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
}
member ImportPackAndGoOverrideCheckOverwriteOperationEvent : IEvent<EventHandler<DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>,
    DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>

Valore

EventHandler DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ImportPackAndGoPresetCodingOperationEvent

Evento DedNetSwAppImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs> ImportPackAndGoPresetCodingOperationEvent
Public Shared Event ImportPackAndGoPresetCodingOperationEvent As EventHandler(Of DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs)
public:
static  event EventHandler<DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs^>^ ImportPackAndGoPresetCodingOperationEvent {
    void add (EventHandler<DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
}
member ImportPackAndGoPresetCodingOperationEvent : IEvent<EventHandler<DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs>,
    DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs>

Valore

EventHandler DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.ItemAddedEvent

Evento DedNetSwAppItemAddedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppItemAddedEventArgs> ItemAddedEvent
Public Shared Event ItemAddedEvent As EventHandler(Of DedNetSwAppItemAddedEventArgs)
public:
static  event EventHandler<DedNetSwAppItemAddedEventArgs^>^ ItemAddedEvent {
    void add (EventHandler<DedNetSwAppItemAddedEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppItemAddedEventArgs^>^ value);
}
member ItemAddedEvent : IEvent<EventHandler<DedNetSwAppItemAddedEventArgs>,
    DedNetSwAppItemAddedEventArgs>

Valore

EventHandler DedNetSwAppItemAddedEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.MultiSaverElaborateItemEvent

Evento DedNetSwAppMultiSaverElaborateItemEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppMultiSaverItemElaborationEventArgs> MultiSaverElaborateItemEvent
Public Shared Event MultiSaverElaborateItemEvent As EventHandler(Of DedNetSwAppMultiSaverItemElaborationEventArgs)
public:
static  event EventHandler<DedNetSwAppMultiSaverItemElaborationEventArgs^>^ MultiSaverElaborateItemEvent {
    void add (EventHandler<DedNetSwAppMultiSaverItemElaborationEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppMultiSaverItemElaborationEventArgs^>^ value);
}
member MultiSaverElaborateItemEvent : IEvent<EventHandler<DedNetSwAppMultiSaverItemElaborationEventArgs>,
    DedNetSwAppMultiSaverItemElaborationEventArgs>

Valore

EventHandler DedNetSwAppMultiSaverItemElaborationEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.MultiSaverElaborateStructEvent

Evento DedNetSwAppMultiSaverElaborateStructEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppMultiSaverExecutionInfoEventArgs> MultiSaverElaborateStructEvent
Public Shared Event MultiSaverElaborateStructEvent As EventHandler(Of DedNetSwAppMultiSaverExecutionInfoEventArgs)
public:
static  event EventHandler<DedNetSwAppMultiSaverExecutionInfoEventArgs^>^ MultiSaverElaborateStructEvent {
    void add (EventHandler<DedNetSwAppMultiSaverExecutionInfoEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppMultiSaverExecutionInfoEventArgs^>^ value);
}
member MultiSaverElaborateStructEvent : IEvent<EventHandler<DedNetSwAppMultiSaverExecutionInfoEventArgs>,
    DedNetSwAppMultiSaverExecutionInfoEventArgs>

Valore

EventHandler DedNetSwAppMultiSaverExecutionInfoEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.MultiSaverOverrideDedTypeEvent

Evento DedNetSwAppMultiSaverOverrideDedTypeEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppMultiSaverOverrideDedTypeEventArgs> MultiSaverOverrideDedTypeEvent
Public Shared Event MultiSaverOverrideDedTypeEvent As EventHandler(Of DedNetSwAppMultiSaverOverrideDedTypeEventArgs)
public:
static  event EventHandler<DedNetSwAppMultiSaverOverrideDedTypeEventArgs^>^ MultiSaverOverrideDedTypeEvent {
    void add (EventHandler<DedNetSwAppMultiSaverOverrideDedTypeEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppMultiSaverOverrideDedTypeEventArgs^>^ value);
}
member MultiSaverOverrideDedTypeEvent : IEvent<EventHandler<DedNetSwAppMultiSaverOverrideDedTypeEventArgs>,
    DedNetSwAppMultiSaverOverrideDedTypeEventArgs>

Valore

EventHandler DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.MultiSaverPopulateListEvent

Evento DedNetSwAppMultiSaverPopulateListEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<EventArgs> MultiSaverPopulateListEvent
Public Shared Event MultiSaverPopulateListEvent As EventHandler(Of EventArgs)
public:
static  event EventHandler<EventArgs^>^ MultiSaverPopulateListEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member MultiSaverPopulateListEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.SwRilInvRilCheckCoherence

Evento DedNetSwAppSwRilInvRilCheckCoherence

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppSwRilCheckCoherenceEventArgs> SwRilInvRilCheckCoherence
Public Shared Event SwRilInvRilCheckCoherence As EventHandler(Of DedNetSwAppSwRilCheckCoherenceEventArgs)
public:
static  event EventHandler<DedNetSwAppSwRilCheckCoherenceEventArgs^>^ SwRilInvRilCheckCoherence {
    void add (EventHandler<DedNetSwAppSwRilCheckCoherenceEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppSwRilCheckCoherenceEventArgs^>^ value);
}
member SwRilInvRilCheckCoherence : IEvent<EventHandler<DedNetSwAppSwRilCheckCoherenceEventArgs>,
    DedNetSwAppSwRilCheckCoherenceEventArgs>

Valore

EventHandler DedNetSwAppSwRilCheckCoherenceEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Evento DedNetSwApp.SwRilPublishEvent

Evento DedNetSwAppSwRilPublishEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetSwAppSwRilPublishEventArgs> SwRilPublishEvent
Public Shared Event SwRilPublishEvent As EventHandler(Of DedNetSwAppSwRilPublishEventArgs)
public:
static  event EventHandler<DedNetSwAppSwRilPublishEventArgs^>^ SwRilPublishEvent {
    void add (EventHandler<DedNetSwAppSwRilPublishEventArgs^>^ value);
    void remove (EventHandler<DedNetSwAppSwRilPublishEventArgs^>^ value);
}
member SwRilPublishEvent : IEvent<EventHandler<DedNetSwAppSwRilPublishEventArgs>,
    DedNetSwAppSwRilPublishEventArgs>

Valore

EventHandler DedNetSwAppSwRilPublishEventArgs
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campi di DedNetSwApp

Il tipo DedNetSwApp espone i seguenti membri.

Campi
 | Nome | Descrizione
 | _currentWorkingDirectory |
 | DedNetSwDataRowVerString |
 | mTaskpaneHostAttributi |
 | mTaskpaneHostDocumentAssistant |
 | mTaskpaneHostDocumenti |
 | mTaskpaneViewAttributi |
 | mTaskpaneViewDocumentAssistant |
 | mTaskpaneViewDocumenti |
Campo pubblico | ToolboxVaultFolder |
Campo pubblico | ToolboxWorkFolder |
Torna su
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp._currentWorkingDirectory

Campo DedNetSwApp_currentWorkingDirectory

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string _currentWorkingDirectory
Public Shared _currentWorkingDirectory As String
public:
static String^ _currentWorkingDirectory
static val mutable _currentWorkingDirectory: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.DedNetSwDataRowVerString

Campo DedNetSwAppDedNetSwDataRowVerString

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string DedNetSwDataRowVerString = "DedNetSwDataRowVer"
Public Const DedNetSwDataRowVerString As String = "DedNetSwDataRowVer"
public:
literal String^ DedNetSwDataRowVerString = "DedNetSwDataRowVer"
static val mutable DedNetSwDataRowVerString: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.mTaskpaneHostAttributi

Campo DedNetSwAppmTaskpaneHostAttributi

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AttributeControl mTaskpaneHostAttributi
Public Shared mTaskpaneHostAttributi As AttributeControl
public:
static AttributeControl^ mTaskpaneHostAttributi
static val mutable mTaskpaneHostAttributi: AttributeControl

Valore del campo

AttributeControl
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.mTaskpaneHostDocumentAssistant

Campo DedNetSwAppmTaskpaneHostDocumentAssistant

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedSwDocAssistantControl mTaskpaneHostDocumentAssistant
Public Shared mTaskpaneHostDocumentAssistant As DedSwDocAssistantControl
public:
static DedSwDocAssistantControl^ mTaskpaneHostDocumentAssistant
static val mutable mTaskpaneHostDocumentAssistant: DedSwDocAssistantControl

Valore del campo

DedSwDocAssistantControl
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.mTaskpaneHostDocumenti

Campo DedNetSwAppmTaskpaneHostDocumenti

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocumentControl mTaskpaneHostDocumenti
Public Shared mTaskpaneHostDocumenti As DocumentControl
public:
static DocumentControl^ mTaskpaneHostDocumenti
static val mutable mTaskpaneHostDocumenti: DocumentControl

Valore del campo

DocumentControl
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.mTaskpaneViewAttributi

Campo DedNetSwAppmTaskpaneViewAttributi

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static TaskpaneView mTaskpaneViewAttributi
Public Shared mTaskpaneViewAttributi As TaskpaneView
public:
static TaskpaneView^ mTaskpaneViewAttributi
static val mutable mTaskpaneViewAttributi: TaskpaneView

Valore del campo

TaskpaneView
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.mTaskpaneViewDocumentAssistant

Campo DedNetSwAppmTaskpaneViewDocumentAssistant

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static TaskpaneView mTaskpaneViewDocumentAssistant
Public Shared mTaskpaneViewDocumentAssistant As TaskpaneView
public:
static TaskpaneView^ mTaskpaneViewDocumentAssistant
static val mutable mTaskpaneViewDocumentAssistant: TaskpaneView

Valore del campo

TaskpaneView
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.mTaskpaneViewDocumenti

Campo DedNetSwAppmTaskpaneViewDocumenti

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static TaskpaneView mTaskpaneViewDocumenti
Public Shared mTaskpaneViewDocumenti As TaskpaneView
public:
static TaskpaneView^ mTaskpaneViewDocumenti
static val mutable mTaskpaneViewDocumenti: TaskpaneView

Valore del campo

TaskpaneView
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.ToolboxVaultFolder

Campo DedNetSwAppToolboxVaultFolder

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ToolboxVaultFolder
Public ToolboxVaultFolder As String
public:
String^ ToolboxVaultFolder
val mutable ToolboxVaultFolder: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Campo DedNetSwApp.ToolboxWorkFolder

Campo DedNetSwAppToolboxWorkFolder

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ToolboxWorkFolder
Public ToolboxWorkFolder As String
public:
String^ ToolboxWorkFolder
val mutable ToolboxWorkFolder: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetSwApp
Namespace DedNetSw


Classe DedNetSwApp.ChangeDsInfoStructEventArgs

Classe DedNetSwAppChangeDsInfoStructEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppChangeDsInfoStructEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ChangeDsInfoStructEventArgs : DedEventArgs
Public Class ChangeDsInfoStructEventArgs
    Inherits DedEventArgs
public ref class ChangeDsInfoStructEventArgs : public DedEventArgs
type ChangeDsInfoStructEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppChangeDsInfoStructEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppChangeDsInfoStructEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | SwDsInfo |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ChangeDsInfoStructEventArgs

Costruttore DedNetSwAppChangeDsInfoStructEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ChangeDsInfoStructEventArgs(
    SwDocStructInfo swDsInfo
)
Public Sub New (
    swDsInfo As SwDocStructInfo
)
public:
ChangeDsInfoStructEventArgs(
    SwDocStructInfo^ swDsInfo
)
new :
        swDsInfo : SwDocStructInfo -> ChangeDsInfoStructEventArgs

Parametri

swDsInfo SwDocStructInfo
Vedi anche

Documentazione

Classe DedNetSwAppChangeDsInfoStructEventArgs
Namespace DedNetSw


Proprietà di ChangeDsInfoStructEventArgs

Il tipo DedNetSwAppChangeDsInfoStructEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | SwDsInfo |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppChangeDsInfoStructEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ChangeDsInfoStructEventArgs.SwDsInfo

Proprietà DedNetSwAppChangeDsInfoStructEventArgsSwDsInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo SwDsInfo { get; }
Public ReadOnly Property SwDsInfo As SwDocStructInfo
    Get
public:
property SwDocStructInfo^ SwDsInfo {
    SwDocStructInfo^ get ();
}
member SwDsInfo : SwDocStructInfo with get

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe DedNetSwAppChangeDsInfoStructEventArgs
Namespace DedNetSw


Classe DedNetSwApp.DedSwPublishEventArgs

Classe DedNetSwAppDedSwPublishEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppDedSwPublishEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedSwPublishEventArgs : DedEventArgs
Public Class DedSwPublishEventArgs
    Inherits DedEventArgs
public ref class DedSwPublishEventArgs : public DedEventArgs
type DedSwPublishEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppDedSwPublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppDedSwPublishEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationManager |
Proprietà pubblica | PublishingSwDoc |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.DedSwPublishEventArgs

Costruttore DedNetSwAppDedSwPublishEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwPublishEventArgs(
    DedDoc dedDoc,
    DedData data,
    IModelDoc2 pubDoc,
    DedPublicationManager pubMan
)
Public Sub New (
    dedDoc As DedDoc,
    data As DedData,
    pubDoc As IModelDoc2,
    pubMan As DedPublicationManager
)
public:
DedSwPublishEventArgs(
    DedDoc^ dedDoc,
    DedData^ data,
    IModelDoc2^ pubDoc,
    DedPublicationManager^ pubMan
)
new :
        dedDoc : DedDoc *
        data : DedData *
        pubDoc : IModelDoc2 *
        pubMan : DedPublicationManager -> DedSwPublishEventArgs

Parametri

dedDoc DedDoc
data DedData
pubDoc IModelDoc2
pubMan DedPublicationManager
Vedi anche

Documentazione

Classe DedNetSwAppDedSwPublishEventArgs
Namespace DedNetSw


Proprietà di DedSwPublishEventArgs

Il tipo DedNetSwAppDedSwPublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationManager |
Proprietà pubblica | PublishingSwDoc |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppDedSwPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.DedSwPublishEventArgs.Data

Proprietà DedNetSwAppDedSwPublishEventArgsData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetSwAppDedSwPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.DedSwPublishEventArgs.Document

Proprietà DedNetSwAppDedSwPublishEventArgsDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedNetSwAppDedSwPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.DedSwPublishEventArgs.PublicationManager

Proprietà DedNetSwAppDedSwPublishEventArgsPublicationManager

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager PublicationManager { get; }
Public ReadOnly Property PublicationManager As DedPublicationManager
    Get
public:
property DedPublicationManager^ PublicationManager {
    DedPublicationManager^ get ();
}
member PublicationManager : DedPublicationManager with get

Valore della proprietà

DedPublicationManager
Vedi anche

Documentazione

Classe DedNetSwAppDedSwPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.DedSwPublishEventArgs.PublishingSwDoc

Proprietà DedNetSwAppDedSwPublishEventArgsPublishingSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 PublishingSwDoc { get; }
Public ReadOnly Property PublishingSwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ PublishingSwDoc {
    IModelDoc2^ get ();
}
member PublishingSwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe DedNetSwAppDedSwPublishEventArgs
Namespace DedNetSw


Enumerazione DedNetSwApp.EditAllConfigurationBehaviour

Enumerazione DedNetSwAppEditAllConfigurationBehaviour

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum EditAllConfigurationBehaviour
Public Enumeration EditAllConfigurationBehaviour
public enum class EditAllConfigurationBehaviour
type EditAllConfigurationBehaviour
Membri
Nome | Valore | Descrizione
Disattiva | 0 |
AttivaDefaultFalse | 1 |
AttivaDefaultTrue | 2 |
Vedi anche

Documentazione

Namespace DedNetSw


Classe DedNetSwApp.ImportOnSaveEventArgs

Classe DedNetSwAppImportOnSaveEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppImportOnSaveEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportOnSaveEventArgs : DedEventArgs
Public Class ImportOnSaveEventArgs
    Inherits DedEventArgs
public ref class ImportOnSaveEventArgs : public DedEventArgs
type ImportOnSaveEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppImportOnSaveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppImportOnSaveEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ImportFileInNewData |
Proprietà pubblica | SwDsInfo |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ImportOnSaveEventArgs

Costruttore DedNetSwAppImportOnSaveEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportOnSaveEventArgs(
    SwDocStructInfo swDsInfo,
    bool importFileInNewData
)
Public Sub New (
    swDsInfo As SwDocStructInfo,
    importFileInNewData As Boolean
)
public:
ImportOnSaveEventArgs(
    SwDocStructInfo^ swDsInfo,
    bool importFileInNewData
)
new :
        swDsInfo : SwDocStructInfo *
        importFileInNewData : bool -> ImportOnSaveEventArgs

Parametri

swDsInfo SwDocStructInfo
importFileInNewData Boolean
Vedi anche

Documentazione

Classe DedNetSwAppImportOnSaveEventArgs
Namespace DedNetSw


Proprietà di ImportOnSaveEventArgs

Il tipo DedNetSwAppImportOnSaveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ImportFileInNewData |
Proprietà pubblica | SwDsInfo |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppImportOnSaveEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportOnSaveEventArgs.ImportFileInNewData

Proprietà DedNetSwAppImportOnSaveEventArgsImportFileInNewData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ImportFileInNewData { get; set; }
Public Property ImportFileInNewData As Boolean
    Get
    Set
public:
property bool ImportFileInNewData {
    bool get ();
    void set (bool value);
}
member ImportFileInNewData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppImportOnSaveEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportOnSaveEventArgs.SwDsInfo

Proprietà DedNetSwAppImportOnSaveEventArgsSwDsInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo SwDsInfo { get; }
Public ReadOnly Property SwDsInfo As SwDocStructInfo
    Get
public:
property SwDocStructInfo^ SwDsInfo {
    SwDocStructInfo^ get ();
}
member SwDsInfo : SwDocStructInfo with get

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe DedNetSwAppImportOnSaveEventArgs
Namespace DedNetSw


Classe DedNetSwApp.ImportPackAndGoAfterLoadEventArgs

Classe DedNetSwAppImportPackAndGoAfterLoadEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSwDedNetSwAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoAfterLoadEventArgs : EventArgs
Public Class ImportPackAndGoAfterLoadEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoAfterLoadEventArgs : public EventArgs
type ImportPackAndGoAfterLoadEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetSwAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppImportPackAndGoAfterLoadEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ImportPackAndGoAfterLoadEventArgs

Costruttore DedNetSwAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoAfterLoadEventArgs(
    DedSwPackAndGoImportForm frm
)
Public Sub New (
    frm As DedSwPackAndGoImportForm
)
public:
ImportPackAndGoAfterLoadEventArgs(
    DedSwPackAndGoImportForm^ frm
)
new :
        frm : DedSwPackAndGoImportForm -> ImportPackAndGoAfterLoadEventArgs

Parametri

frm DedSwPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoAfterLoadEventArgs
Namespace DedNetSw


Proprietà di ImportPackAndGoAfterLoadEventArgs

Il tipo DedNetSwAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoAfterLoadEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoAfterLoadEventArgs.Frm

Proprietà DedNetSwAppImportPackAndGoAfterLoadEventArgsFrm

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwPackAndGoImportForm Frm { get; set; }
Public Property Frm As DedSwPackAndGoImportForm
    Get
    Set
public:
property DedSwPackAndGoImportForm^ Frm {
    DedSwPackAndGoImportForm^ get ();
    void set (DedSwPackAndGoImportForm^ value);
}
member Frm : DedSwPackAndGoImportForm with get, set

Valore della proprietà

DedSwPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoAfterLoadEventArgs
Namespace DedNetSw


Classe DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppImportPackAndGoDocAttrCompareEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoDocAttrCompareEventArgs : DedEventArgs
Public Class ImportPackAndGoDocAttrCompareEventArgs
    Inherits DedEventArgs
public ref class ImportPackAndGoDocAttrCompareEventArgs : public DedEventArgs
type ImportPackAndGoDocAttrCompareEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppImportPackAndGoDocAttrCompareEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | DataDoc |
Proprietà pubblica | DbMaster |
Proprietà pubblica | DedCase |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PackAndGoNodeWrapper |
Proprietà pubblica | UsesDocValues |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs

Costruttore DedNetSwAppImportPackAndGoDocAttrCompareEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp,
    DedData data,
    DedDataPart dataDoc
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper,
    data As DedData,
    dataDoc As DedDataPart
)
public:
ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp,
    DedData^ data,
    DedDataPart^ dataDoc
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper *
        data : DedData *
        dataDoc : DedDataPart -> ImportPackAndGoDocAttrCompareEventArgs

Parametri

dedcase PackAndGoImportDedCases
dbMaster Boolean
pckNodeWrp PackAndGoNodeWrapper
data DedData
dataDoc DedDataPart
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà di ImportPackAndGoDocAttrCompareEventArgs

Il tipo DedNetSwAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | DataDoc |
Proprietà pubblica | DbMaster |
Proprietà pubblica | DedCase |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PackAndGoNodeWrapper |
Proprietà pubblica | UsesDocValues |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs.Data

Proprietà DedNetSwAppImportPackAndGoDocAttrCompareEventArgsData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs.DataDoc

Proprietà DedNetSwAppImportPackAndGoDocAttrCompareEventArgsDataDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DataDoc { get; }
Public ReadOnly Property DataDoc As DedDataPart
    Get
public:
property DedDataPart^ DataDoc {
    DedDataPart^ get ();
}
member DataDoc : DedDataPart with get

Valore della proprietà

DedDataPart
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs.DbMaster

Proprietà DedNetSwAppImportPackAndGoDocAttrCompareEventArgsDbMaster

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs.DedCase

Proprietà DedNetSwAppImportPackAndGoDocAttrCompareEventArgsDedCase

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs.PackAndGoNodeWrapper

Proprietà DedNetSwAppImportPackAndGoDocAttrCompareEventArgsPackAndGoNodeWrapper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoDocAttrCompareEventArgs.UsesDocValues

Proprietà DedNetSwAppImportPackAndGoDocAttrCompareEventArgsUsesDocValues

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UsesDocValues { get; set; }
Public Property UsesDocValues As Boolean
    Get
    Set
public:
property bool UsesDocValues {
    bool get ();
    void set (bool value);
}
member UsesDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetSw


Classe DedNetSwApp.ImportPackAndGoMappingRootEventArgs

Classe DedNetSwAppImportPackAndGoMappingRootEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSwDedNetSwAppImportPackAndGoMappingRootEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoMappingRootEventArgs : EventArgs
Public Class ImportPackAndGoMappingRootEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoMappingRootEventArgs : public EventArgs
type ImportPackAndGoMappingRootEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetSwAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppImportPackAndGoMappingRootEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ImportPackAndGoMappingRootEventArgs

Costruttore DedNetSwAppImportPackAndGoMappingRootEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject> ipjPaths
)
Public Sub New (
    ipjPaths As List(Of MappingRootObject)
)
public:
ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject^>^ ipjPaths
)
new :
        ipjPaths : List<MappingRootObject> -> ImportPackAndGoMappingRootEventArgs

Parametri

ipjPaths List MappingRootObject
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoMappingRootEventArgs
Namespace DedNetSw


Proprietà di ImportPackAndGoMappingRootEventArgs

Il tipo DedNetSwAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoMappingRootEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoMappingRootEventArgs.IpjPaths

Proprietà DedNetSwAppImportPackAndGoMappingRootEventArgsIpjPaths

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<MappingRootObject> IpjPaths { get; set; }
Public Property IpjPaths As List(Of MappingRootObject)
    Get
    Set
public:
property List<MappingRootObject^>^ IpjPaths {
    List<MappingRootObject^>^ get ();
    void set (List<MappingRootObject^>^ value);
}
member IpjPaths : List<MappingRootObject> with get, set

Valore della proprietà

List MappingRootObject
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoMappingRootEventArgs
Namespace DedNetSw


Classe DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSwDedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : EventArgs
Public Class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : public EventArgs
type ImportPackAndGoOverrideCheckOverwriteOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster |
Proprietà pubblica | DedCase |
Proprietà pubblica | OverrideCheck |
Proprietà pubblica | PackAndGoNodeWrapper |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Costruttore DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper
)
public:
ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper -> ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Parametri

dedcase PackAndGoImportDedCases
dbMaster Boolean
pckNodeWrp PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetSw


Proprietà di ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Il tipo DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster |
Proprietà pubblica | DedCase |
Proprietà pubblica | OverrideCheck |
Proprietà pubblica | PackAndGoNodeWrapper |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DbMaster

Proprietà DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDbMaster

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DedCase

Proprietà DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDedCase

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.OverrideCheck

Proprietà DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsOverrideCheck

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OverrideCheck { get; set; }
Public Property OverrideCheck As Boolean
    Get
    Set
public:
property bool OverrideCheck {
    bool get ();
    void set (bool value);
}
member OverrideCheck : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.PackAndGoNodeWrapper

Proprietà DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsPackAndGoNodeWrapper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetSw


Classe DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSwDedNetSwAppImportPackAndGoPresetCodingOperationEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoPresetCodingOperationEventArgs : EventArgs
Public Class ImportPackAndGoPresetCodingOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoPresetCodingOperationEventArgs : public EventArgs
type ImportPackAndGoPresetCodingOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | DedCase |
Proprietà pubblica | DedType |
Proprietà pubblica | DestRoot |
Proprietà pubblica | DizAttr |
Proprietà pubblica | Fullfilename |
Proprietà pubblica | InfoUser |
Proprietà pubblica | NewFullFileName |
Proprietà pubblica | Note |
Proprietà pubblica | Operation |
Proprietà pubblica | Progr |
Proprietà pubblica | Rev |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs

Costruttore DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoPresetCodingOperationEventArgs(
    string fullfilename,
    Dictionary<string, Object> dizAttr
)
Public Sub New (
    fullfilename As String,
    dizAttr As Dictionary(Of String, Object)
)
public:
ImportPackAndGoPresetCodingOperationEventArgs(
    String^ fullfilename,
    Dictionary<String^, Object^>^ dizAttr
)
new :
        fullfilename : string *
        dizAttr : Dictionary<string, Object> -> ImportPackAndGoPresetCodingOperationEventArgs

Parametri

fullfilename String
dizAttr Dictionary String, Object
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà di ImportPackAndGoPresetCodingOperationEventArgs

Il tipo DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | DedCase |
Proprietà pubblica | DedType |
Proprietà pubblica | DestRoot |
Proprietà pubblica | DizAttr |
Proprietà pubblica | Fullfilename |
Proprietà pubblica | InfoUser |
Proprietà pubblica | NewFullFileName |
Proprietà pubblica | Note |
Proprietà pubblica | Operation |
Proprietà pubblica | Progr |
Proprietà pubblica | Rev |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.Data

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.DedCase

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsDedCase

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.DedType

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsDedType

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.DestRoot

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsDestRoot

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.DizAttr

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsDizAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DizAttr { get; }
Public ReadOnly Property DizAttr As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ DizAttr {
    Dictionary<String^, Object^>^ get ();
}
member DizAttr : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.Fullfilename

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsFullfilename

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Fullfilename { get; }
Public ReadOnly Property Fullfilename As String
    Get
public:
property String^ Fullfilename {
    String^ get ();
}
member Fullfilename : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.InfoUser

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsInfoUser

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.NewFullFileName

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsNewFullFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.Note

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsNote

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}
member Note : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.Operation

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsOperation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation Operation { get; set; }
Public Property Operation As PackAndGoImportOperation
    Get
    Set
public:
property PackAndGoImportOperation Operation {
    PackAndGoImportOperation get ();
    void set (PackAndGoImportOperation value);
}
member Operation : PackAndGoImportOperation with get, set

Valore della proprietà

PackAndGoImportOperation
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.Progr

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsProgr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ImportPackAndGoPresetCodingOperationEventArgs.Rev

Proprietà DedNetSwAppImportPackAndGoPresetCodingOperationEventArgsRev

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetSw


Classe DedNetSwApp.ItemAddedEventArgs

Classe DedNetSwAppItemAddedEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSwDedNetSwAppItemAddedEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ItemAddedEventArgs : EventArgs
Public Class ItemAddedEventArgs
    Inherits EventArgs
public ref class ItemAddedEventArgs : public EventArgs
type ItemAddedEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetSwAppItemAddedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppItemAddedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ItemName |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ItemAddedEventArgs

Costruttore DedNetSwAppItemAddedEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ItemAddedEventArgs(
    string itemName
)
Public Sub New (
    itemName As String
)
public:
ItemAddedEventArgs(
    String^ itemName
)
new :
        itemName : string -> ItemAddedEventArgs

Parametri

itemName String
Vedi anche

Documentazione

Classe DedNetSwAppItemAddedEventArgs
Namespace DedNetSw


Proprietà di ItemAddedEventArgs

Il tipo DedNetSwAppItemAddedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ItemName |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppItemAddedEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ItemAddedEventArgs.ItemName

Proprietà DedNetSwAppItemAddedEventArgsItemName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ItemName { get; }
Public ReadOnly Property ItemName As String
    Get
public:
property String^ ItemName {
    String^ get ();
}
member ItemName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppItemAddedEventArgs
Namespace DedNetSw


Classe DedNetSwApp.MultiSaverExecutionInfoEventArgs

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppMultiSaverExecutionInfoEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverExecutionInfoEventArgs : DedEventArgs
Public Class MultiSaverExecutionInfoEventArgs
    Inherits DedEventArgs
public ref class MultiSaverExecutionInfoEventArgs : public DedEventArgs
type MultiSaverExecutionInfoEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppMultiSaverExecutionInfoEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppMultiSaverExecutionInfoEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria |
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | InvolvedNodes |
Proprietà pubblica | Message |
Proprietà pubblica | SelectedType |
Proprietà pubblica | SkipElaboration |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.MultiSaverExecutionInfoEventArgs

Costruttore DedNetSwAppMultiSaverExecutionInfoEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverExecutionInfoEventArgs(
    List<DedSwSaveMulipleFormMultiSaverNodeDescriptor> involvedNodes,
    DedSwSaveMulipleFormMultiSaverModeCriteria activeCriteria,
    DedType selectedType
)
Public Sub New (
    involvedNodes As List(Of DedSwSaveMulipleFormMultiSaverNodeDescriptor),
    activeCriteria As DedSwSaveMulipleFormMultiSaverModeCriteria,
    selectedType As DedType
)
public:
MultiSaverExecutionInfoEventArgs(
    List<DedSwSaveMulipleFormMultiSaverNodeDescriptor^>^ involvedNodes,
    DedSwSaveMulipleFormMultiSaverModeCriteria^ activeCriteria,
    DedType^ selectedType
)
new :
        involvedNodes : List<DedSwSaveMulipleFormMultiSaverNodeDescriptor> *
        activeCriteria : DedSwSaveMulipleFormMultiSaverModeCriteria *
        selectedType : DedType -> MultiSaverExecutionInfoEventArgs

Parametri

involvedNodes List DedSwSaveMulipleFormMultiSaverNodeDescriptor
activeCriteria DedSwSaveMulipleFormMultiSaverModeCriteria
selectedType DedType
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Proprietà di MultiSaverExecutionInfoEventArgs

Il tipo DedNetSwAppMultiSaverExecutionInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria |
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | InvolvedNodes |
Proprietà pubblica | Message |
Proprietà pubblica | SelectedType |
Proprietà pubblica | SkipElaboration |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverExecutionInfoEventArgs.ActiveCriteria

Proprietà DedNetSwAppMultiSaverExecutionInfoEventArgsActiveCriteria

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteria ActiveCriteria { get; }
Public ReadOnly Property ActiveCriteria As DedSwSaveMulipleFormMultiSaverModeCriteria
    Get
public:
property DedSwSaveMulipleFormMultiSaverModeCriteria^ ActiveCriteria {
    DedSwSaveMulipleFormMultiSaverModeCriteria^ get ();
}
member ActiveCriteria : DedSwSaveMulipleFormMultiSaverModeCriteria with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverExecutionInfoEventArgs.InvolvedNodes

Proprietà DedNetSwAppMultiSaverExecutionInfoEventArgsInvolvedNodes

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedSwSaveMulipleFormMultiSaverNodeDescriptor> InvolvedNodes { get; }
Public ReadOnly Property InvolvedNodes As List(Of DedSwSaveMulipleFormMultiSaverNodeDescriptor)
    Get
public:
property List<DedSwSaveMulipleFormMultiSaverNodeDescriptor^>^ InvolvedNodes {
    List<DedSwSaveMulipleFormMultiSaverNodeDescriptor^>^ get ();
}
member InvolvedNodes : List<DedSwSaveMulipleFormMultiSaverNodeDescriptor> with get

Valore della proprietà

List DedSwSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverExecutionInfoEventArgs.Message

Proprietà DedNetSwAppMultiSaverExecutionInfoEventArgsMessage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverExecutionInfoEventArgs.SelectedType

Proprietà DedNetSwAppMultiSaverExecutionInfoEventArgsSelectedType

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectedType { get; set; }
Public Property SelectedType As DedType
    Get
    Set
public:
property DedType^ SelectedType {
    DedType^ get ();
    void set (DedType^ value);
}
member SelectedType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverExecutionInfoEventArgs.SkipElaboration

Proprietà DedNetSwAppMultiSaverExecutionInfoEventArgsSkipElaboration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipElaboration { get; set; }
Public Property SkipElaboration As Boolean
    Get
    Set
public:
property bool SkipElaboration {
    bool get ();
    void set (bool value);
}
member SkipElaboration : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverExecutionInfoEventArgs
Namespace DedNetSw


Classe DedNetSwApp.MultiSaverItemElaborationEventArgs

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppMultiSaverItemElaborationEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverItemElaborationEventArgs : DedEventArgs
Public Class MultiSaverItemElaborationEventArgs
    Inherits DedEventArgs
public ref class MultiSaverItemElaborationEventArgs : public DedEventArgs
type MultiSaverItemElaborationEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppMultiSaverItemElaborationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppMultiSaverItemElaborationEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria |
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Doc |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FreeCode |
Proprietà pubblica | FreeFile |
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | InfoUser |
Proprietà pubblica | Message |
Proprietà pubblica | NodeItem |
Proprietà pubblica | Progr |
Proprietà pubblica | Rev |
Proprietà pubblica | SelectedType |
Proprietà pubblica | SkipElaboration |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.MultiSaverItemElaborationEventArgs

Costruttore DedNetSwAppMultiSaverItemElaborationEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverItemElaborationEventArgs(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor item,
    DedSwSaveMulipleFormMultiSaverModeCriteria activeCriteria,
    DedType selectedType
)
Public Sub New (
    item As DedSwSaveMulipleFormMultiSaverNodeDescriptor,
    activeCriteria As DedSwSaveMulipleFormMultiSaverModeCriteria,
    selectedType As DedType
)
public:
MultiSaverItemElaborationEventArgs(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ item,
    DedSwSaveMulipleFormMultiSaverModeCriteria^ activeCriteria,
    DedType^ selectedType
)
new :
        item : DedSwSaveMulipleFormMultiSaverNodeDescriptor *
        activeCriteria : DedSwSaveMulipleFormMultiSaverModeCriteria *
        selectedType : DedType -> MultiSaverItemElaborationEventArgs

Parametri

item DedSwSaveMulipleFormMultiSaverNodeDescriptor
activeCriteria DedSwSaveMulipleFormMultiSaverModeCriteria
selectedType DedType
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà di MultiSaverItemElaborationEventArgs

Il tipo DedNetSwAppMultiSaverItemElaborationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria |
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Doc |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FreeCode |
Proprietà pubblica | FreeFile |
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | InfoUser |
Proprietà pubblica | Message |
Proprietà pubblica | NodeItem |
Proprietà pubblica | Progr |
Proprietà pubblica | Rev |
Proprietà pubblica | SelectedType |
Proprietà pubblica | SkipElaboration |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.ActiveCriteria

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsActiveCriteria

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteria ActiveCriteria { get; }
Public ReadOnly Property ActiveCriteria As DedSwSaveMulipleFormMultiSaverModeCriteria
    Get
public:
property DedSwSaveMulipleFormMultiSaverModeCriteria^ ActiveCriteria {
    DedSwSaveMulipleFormMultiSaverModeCriteria^ get ();
}
member ActiveCriteria : DedSwSaveMulipleFormMultiSaverModeCriteria with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.Data

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.Doc

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.FreeCode

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsFreeCode

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FreeCode { get; set; }
Public Property FreeCode As String
    Get
    Set
public:
property String^ FreeCode {
    String^ get ();
    void set (String^ value);
}
member FreeCode : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.FreeFile

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsFreeFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FreeFile { get; set; }
Public Property FreeFile As String
    Get
    Set
public:
property String^ FreeFile {
    String^ get ();
    void set (String^ value);
}
member FreeFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.InfoUser

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsInfoUser

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.Message

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsMessage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.NodeItem

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsNodeItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverNodeDescriptor NodeItem { get; }
Public ReadOnly Property NodeItem As DedSwSaveMulipleFormMultiSaverNodeDescriptor
    Get
public:
property DedSwSaveMulipleFormMultiSaverNodeDescriptor^ NodeItem {
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ get ();
}
member NodeItem : DedSwSaveMulipleFormMultiSaverNodeDescriptor with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.Progr

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsProgr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.Rev

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsRev

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.SelectedType

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsSelectedType

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectedType { get; set; }
Public Property SelectedType As DedType
    Get
    Set
public:
property DedType^ SelectedType {
    DedType^ get ();
    void set (DedType^ value);
}
member SelectedType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverItemElaborationEventArgs.SkipElaboration

Proprietà DedNetSwAppMultiSaverItemElaborationEventArgsSkipElaboration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipElaboration { get; set; }
Public Property SkipElaboration As Boolean
    Get
    Set
public:
property bool SkipElaboration {
    bool get ();
    void set (bool value);
}
member SkipElaboration : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverItemElaborationEventArgs
Namespace DedNetSw


Classe DedNetSwApp.MultiSaverOverrideDedTypeEventArgs

Classe DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppMultiSaverOverrideDedTypeEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverOverrideDedTypeEventArgs : DedEventArgs
Public Class MultiSaverOverrideDedTypeEventArgs
    Inherits DedEventArgs
public ref class MultiSaverOverrideDedTypeEventArgs : public DedEventArgs
type MultiSaverOverrideDedTypeEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppMultiSaverOverrideDedTypeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppMultiSaverOverrideDedTypeEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria |
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NodeItem |
Proprietà pubblica | OverrideType |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.MultiSaverOverrideDedTypeEventArgs

Costruttore DedNetSwAppMultiSaverOverrideDedTypeEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverOverrideDedTypeEventArgs(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor item,
    DedSwSaveMulipleFormMultiSaverModeCriteria activeCriteria
)
Public Sub New (
    item As DedSwSaveMulipleFormMultiSaverNodeDescriptor,
    activeCriteria As DedSwSaveMulipleFormMultiSaverModeCriteria
)
public:
MultiSaverOverrideDedTypeEventArgs(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ item,
    DedSwSaveMulipleFormMultiSaverModeCriteria^ activeCriteria
)
new :
        item : DedSwSaveMulipleFormMultiSaverNodeDescriptor *
        activeCriteria : DedSwSaveMulipleFormMultiSaverModeCriteria -> MultiSaverOverrideDedTypeEventArgs

Parametri

item DedSwSaveMulipleFormMultiSaverNodeDescriptor
activeCriteria DedSwSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetSw


Proprietà di MultiSaverOverrideDedTypeEventArgs

Il tipo DedNetSwAppMultiSaverOverrideDedTypeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria |
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NodeItem |
Proprietà pubblica | OverrideType |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverOverrideDedTypeEventArgs.ActiveCriteria

Proprietà DedNetSwAppMultiSaverOverrideDedTypeEventArgsActiveCriteria

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteria ActiveCriteria { get; }
Public ReadOnly Property ActiveCriteria As DedSwSaveMulipleFormMultiSaverModeCriteria
    Get
public:
property DedSwSaveMulipleFormMultiSaverModeCriteria^ ActiveCriteria {
    DedSwSaveMulipleFormMultiSaverModeCriteria^ get ();
}
member ActiveCriteria : DedSwSaveMulipleFormMultiSaverModeCriteria with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverOverrideDedTypeEventArgs.NodeItem

Proprietà DedNetSwAppMultiSaverOverrideDedTypeEventArgsNodeItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverNodeDescriptor NodeItem { get; }
Public ReadOnly Property NodeItem As DedSwSaveMulipleFormMultiSaverNodeDescriptor
    Get
public:
property DedSwSaveMulipleFormMultiSaverNodeDescriptor^ NodeItem {
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ get ();
}
member NodeItem : DedSwSaveMulipleFormMultiSaverNodeDescriptor with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.MultiSaverOverrideDedTypeEventArgs.OverrideType

Proprietà DedNetSwAppMultiSaverOverrideDedTypeEventArgsOverrideType

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType OverrideType { get; set; }
Public Property OverrideType As DedType
    Get
    Set
public:
property DedType^ OverrideType {
    DedType^ get ();
    void set (DedType^ value);
}
member OverrideType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedNetSwAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetSw


Enumerazione DedNetSwApp.OnFileDirtyBehaviour

Enumerazione DedNetSwAppOnFileDirtyBehaviour

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum OnFileDirtyBehaviour
Public Enumeration OnFileDirtyBehaviour
public enum class OnFileDirtyBehaviour
type OnFileDirtyBehaviour
Membri
Nome | Valore | Descrizione
ShowForm | 0 |
IgnoreDocStatus | 1 |
EnforceCheckOut | 2 |
Vedi anche

Documentazione

Namespace DedNetSw


Classe DedNetSwApp.ResolutionEventArgs

Classe DedNetSwAppResolutionEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSwDedNetSwAppResolutionEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResolutionEventArgs : EventArgs
Public Class ResolutionEventArgs
    Inherits EventArgs
public ref class ResolutionEventArgs : public EventArgs
type ResolutionEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetSwAppResolutionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppResolutionEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName |
Proprietà pubblica | SostFileName |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.ResolutionEventArgs

Costruttore DedNetSwAppResolutionEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ResolutionEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
ResolutionEventArgs(
    String^ fileName
)
new :
        fileName : string -> ResolutionEventArgs

Parametri

fileName String
Vedi anche

Documentazione

Classe DedNetSwAppResolutionEventArgs
Namespace DedNetSw


Proprietà di ResolutionEventArgs

Il tipo DedNetSwAppResolutionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName |
Proprietà pubblica | SostFileName |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppResolutionEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ResolutionEventArgs.FileName

Proprietà DedNetSwAppResolutionEventArgsFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppResolutionEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.ResolutionEventArgs.SostFileName

Proprietà DedNetSwAppResolutionEventArgsSostFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SostFileName { get; set; }
Public Property SostFileName As String
    Get
    Set
public:
property String^ SostFileName {
    String^ get ();
    void set (String^ value);
}
member SostFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppResolutionEventArgs
Namespace DedNetSw


Classe DedNetSwApp.SwRilCheckCoherenceEventArgs

Classe DedNetSwAppSwRilCheckCoherenceEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppSwRilCheckCoherenceEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwRilCheckCoherenceEventArgs : DedEventArgs
Public Class SwRilCheckCoherenceEventArgs
    Inherits DedEventArgs
public ref class SwRilCheckCoherenceEventArgs : public DedEventArgs
type SwRilCheckCoherenceEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppSwRilCheckCoherenceEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppSwRilCheckCoherenceEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublishingInvDoc |
Proprietà pubblica | StateCommandArgs |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.SwRilCheckCoherenceEventArgs

Costruttore DedNetSwAppSwRilCheckCoherenceEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwRilCheckCoherenceEventArgs(
    StateCommandEventArgs stateCmdArgs,
    IModelDoc2 pubDoc
)
Public Sub New (
    stateCmdArgs As StateCommandEventArgs,
    pubDoc As IModelDoc2
)
public:
SwRilCheckCoherenceEventArgs(
    StateCommandEventArgs^ stateCmdArgs,
    IModelDoc2^ pubDoc
)
new :
        stateCmdArgs : StateCommandEventArgs *
        pubDoc : IModelDoc2 -> SwRilCheckCoherenceEventArgs

Parametri

stateCmdArgs StateCommandEventArgs
pubDoc IModelDoc2
Vedi anche

Documentazione

Classe DedNetSwAppSwRilCheckCoherenceEventArgs
Namespace DedNetSw


Proprietà di SwRilCheckCoherenceEventArgs

Il tipo DedNetSwAppSwRilCheckCoherenceEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublishingInvDoc |
Proprietà pubblica | StateCommandArgs |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppSwRilCheckCoherenceEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.SwRilCheckCoherenceEventArgs.PublishingInvDoc

Proprietà DedNetSwAppSwRilCheckCoherenceEventArgsPublishingInvDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 PublishingInvDoc { get; }
Public ReadOnly Property PublishingInvDoc As IModelDoc2
    Get
public:
property IModelDoc2^ PublishingInvDoc {
    IModelDoc2^ get ();
}
member PublishingInvDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe DedNetSwAppSwRilCheckCoherenceEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.SwRilCheckCoherenceEventArgs.StateCommandArgs

Proprietà DedNetSwAppSwRilCheckCoherenceEventArgsStateCommandArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public StateCommandEventArgs StateCommandArgs { get; }
Public ReadOnly Property StateCommandArgs As StateCommandEventArgs
    Get
public:
property StateCommandEventArgs^ StateCommandArgs {
    StateCommandEventArgs^ get ();
}
member StateCommandArgs : StateCommandEventArgs with get

Valore della proprietà

StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetSwAppSwRilCheckCoherenceEventArgs
Namespace DedNetSw


Classe DedNetSwApp.SwRilPublishEventArgs

Classe DedNetSwAppSwRilPublishEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetSwDedNetSwAppSwRilPublishEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwRilPublishEventArgs : DedEventArgs
Public Class SwRilPublishEventArgs
    Inherits DedEventArgs
public ref class SwRilPublishEventArgs : public DedEventArgs
type SwRilPublishEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetSwAppSwRilPublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppSwRilPublishEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationManager |
Proprietà pubblica | PublishingSwDoc |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.SwRilPublishEventArgs

Costruttore DedNetSwAppSwRilPublishEventArgs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwRilPublishEventArgs(
    StateCommandEventArgs stateCmdArgs,
    IModelDoc2 pubDoc,
    DedPublicationManager pubMan
)
Public Sub New (
    stateCmdArgs As StateCommandEventArgs,
    pubDoc As IModelDoc2,
    pubMan As DedPublicationManager
)
public:
SwRilPublishEventArgs(
    StateCommandEventArgs^ stateCmdArgs,
    IModelDoc2^ pubDoc,
    DedPublicationManager^ pubMan
)
new :
        stateCmdArgs : StateCommandEventArgs *
        pubDoc : IModelDoc2 *
        pubMan : DedPublicationManager -> SwRilPublishEventArgs

Parametri

stateCmdArgs StateCommandEventArgs
pubDoc IModelDoc2
pubMan DedPublicationManager
Vedi anche

Documentazione

Classe DedNetSwAppSwRilPublishEventArgs
Namespace DedNetSw


Proprietà di SwRilPublishEventArgs

Il tipo DedNetSwAppSwRilPublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationManager |
Proprietà pubblica | PublishingSwDoc |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppSwRilPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.SwRilPublishEventArgs.Data

Proprietà DedNetSwAppSwRilPublishEventArgsData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetSwAppSwRilPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.SwRilPublishEventArgs.Document

Proprietà DedNetSwAppSwRilPublishEventArgsDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedNetSwAppSwRilPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.SwRilPublishEventArgs.PublicationManager

Proprietà DedNetSwAppSwRilPublishEventArgsPublicationManager

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager PublicationManager { get; }
Public ReadOnly Property PublicationManager As DedPublicationManager
    Get
public:
property DedPublicationManager^ PublicationManager {
    DedPublicationManager^ get ();
}
member PublicationManager : DedPublicationManager with get

Valore della proprietà

DedPublicationManager
Vedi anche

Documentazione

Classe DedNetSwAppSwRilPublishEventArgs
Namespace DedNetSw


Proprietà DedNetSwApp.SwRilPublishEventArgs.PublishingSwDoc

Proprietà DedNetSwAppSwRilPublishEventArgsPublishingSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 PublishingSwDoc { get; }
Public ReadOnly Property PublishingSwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ PublishingSwDoc {
    IModelDoc2^ get ();
}
member PublishingSwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe DedNetSwAppSwRilPublishEventArgs
Namespace DedNetSw


Classe DedNetSwApp.UpdateDataDescriptor

Classe DedNetSwAppUpdateDataDescriptor
Gerarchia di ereditarietà
SystemObject
DedNetSwDedNetSwAppUpdateDataDescriptor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateDataDescriptor
Public Class UpdateDataDescriptor
public ref class UpdateDataDescriptor
type UpdateDataDescriptor = class end

Il tipo DedNetSwAppUpdateDataDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppUpdateDataDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Data |
Proprietà pubblica | DocDataPart |
Proprietà pubblica | SwDoc |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.UpdateDataDescriptor

Costruttore DedNetSwAppUpdateDataDescriptor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public UpdateDataDescriptor()
Public Sub New
public:
UpdateDataDescriptor()
new : unit -> UpdateDataDescriptor
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptor
Namespace DedNetSw


Proprietà di UpdateDataDescriptor

Il tipo DedNetSwAppUpdateDataDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Data |
Proprietà pubblica | DocDataPart |
Proprietà pubblica | SwDoc |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptor
Namespace DedNetSw


Proprietà DedNetSwApp.UpdateDataDescriptor.Config

Proprietà DedNetSwAppUpdateDataDescriptorConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptor
Namespace DedNetSw


Proprietà DedNetSwApp.UpdateDataDescriptor.Data

Proprietà DedNetSwAppUpdateDataDescriptorData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptor
Namespace DedNetSw


Proprietà DedNetSwApp.UpdateDataDescriptor.DocDataPart

Proprietà DedNetSwAppUpdateDataDescriptorDocDataPart

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DocDataPart { get; set; }
Public Property DocDataPart As DedDataPart
    Get
    Set
public:
property DedDataPart^ DocDataPart {
    DedDataPart^ get ();
    void set (DedDataPart^ value);
}
member DocDataPart : DedDataPart with get, set

Valore della proprietà

DedDataPart
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptor
Namespace DedNetSw


Proprietà DedNetSwApp.UpdateDataDescriptor.SwDoc

Proprietà DedNetSwAppUpdateDataDescriptorSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; set; }
Public Property SwDoc As IModelDoc2
    Get
    Set
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
    void set (IModelDoc2^ value);
}
member SwDoc : IModelDoc2 with get, set

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptor
Namespace DedNetSw


Classe DedNetSwApp.UpdateDataDescriptors

Classe DedNetSwAppUpdateDataDescriptors
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetSwAppUpdateDataDescriptor
DedNetSwDedNetSwAppUpdateDataDescriptors

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateDataDescriptors : List<DedNetSwAppUpdateDataDescriptor>
Public Class UpdateDataDescriptors
    Inherits List(Of DedNetSwAppUpdateDataDescriptor)
public ref class UpdateDataDescriptors : public List<DedNetSwAppUpdateDataDescriptor^>
type UpdateDataDescriptors =
    class
        inherit List<DedNetSwAppUpdateDataDescriptor>
    end

Il tipo DedNetSwAppUpdateDataDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwAppUpdateDataDescriptors |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwApp.UpdateDataDescriptors

Costruttore DedNetSwAppUpdateDataDescriptors

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public UpdateDataDescriptors()
Public Sub New
public:
UpdateDataDescriptors()
new : unit -> UpdateDataDescriptors
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptors
Namespace DedNetSw


Metodi di UpdateDataDescriptors

Il tipo DedNetSwAppUpdateDataDescriptors espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Torna su
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptors
Namespace DedNetSw


Metodo DedNetSwApp.UpdateDataDescriptors.Add

Metodo DedNetSwAppUpdateDataDescriptorsAdd

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedDataPart docDataPart,
    DedData data,
    IModelDoc2 swDoc,
    string config
)
Public Sub Add (
    docDataPart As DedDataPart,
    data As DedData,
    swDoc As IModelDoc2,
    config As String
)
public:
void Add(
    DedDataPart^ docDataPart,
    DedData^ data,
    IModelDoc2^ swDoc,
    String^ config
)
member Add :
        docDataPart : DedDataPart *
        data : DedData *
        swDoc : IModelDoc2 *
        config : string -> unit

Parametri

docDataPart DedDataPart
data DedData
swDoc IModelDoc2
config String
Vedi anche

Documentazione

Classe DedNetSwAppUpdateDataDescriptors
Namespace DedNetSw


Classe DedNetSwOldFileResolution
Gerarchia di ereditarietà
SystemObject
DedNetSwDedNetSwOldFileResolution

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetSwOldFileResolution
Public Class DedNetSwOldFileResolution
public ref class DedNetSwOldFileResolution
type DedNetSwOldFileResolution = class end

Il tipo DedNetSwOldFileResolution espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwOldFileResolution |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | TopLevelFileName |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetReplaceFullFileName |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwOldFileResolution

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetSwOldFileResolution(
    string FileName
)
Public Sub New (
    FileName As String
)
public:
DedNetSwOldFileResolution(
    String^ FileName
)
new :
        FileName : string -> DedNetSwOldFileResolution

Parametri

FileName String
Vedi anche

Documentazione

Classe DedNetSwOldFileResolution
Namespace DedNetSw


Proprietà di DedNetSwOldFileResolution

Il tipo DedNetSwOldFileResolution espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | TopLevelFileName |
Torna su
Vedi anche

Documentazione

Classe DedNetSwOldFileResolution
Namespace DedNetSw


Proprietà DedNetSwOldFileResolution.TopLevelFileName

Proprietà DedNetSwOldFileResolutionTopLevelFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string TopLevelFileName { get; }
Public ReadOnly Property TopLevelFileName As String
    Get
public:
property String^ TopLevelFileName {
    String^ get ();
}
member TopLevelFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwOldFileResolution
Namespace DedNetSw


Metodi di DedNetSwOldFileResolution

Il tipo DedNetSwOldFileResolution espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetReplaceFullFileName |
Torna su
Vedi anche

Documentazione

Classe DedNetSwOldFileResolution
Namespace DedNetSw


Metodo DedNetSwOldFileResolution.GetReplaceFullFileName

Metodo DedNetSwOldFileResolutionGetReplaceFullFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetReplaceFullFileName()
Public Function GetReplaceFullFileName As String
public:
String^ GetReplaceFullFileName()
member GetReplaceFullFileName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNetSwOldFileResolution
Namespace DedNetSw


Classe DedNetSwOldFileResolution.OnFileResolutionSostItem

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Gerarchia di ereditarietà
SystemObject
DedNetSwDedNetSwOldFileResolutionOnFileResolutionSostItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItem
Public Class OnFileResolutionSostItem
public ref class OnFileResolutionSostItem
type OnFileResolutionSostItem = class end

Il tipo DedNetSwOldFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwOldFileResolutionOnFileResolutionSostItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Campo pubblico | PreviewFile |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwOldFileResolution.OnFileResolutionSostItem

Costruttore DedNetSwOldFileResolutionOnFileResolutionSostItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItem()
Public Sub New
public:
OnFileResolutionSostItem()
new : unit -> OnFileResolutionSostItem
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Proprietà di OnFileResolutionSostItem

Il tipo DedNetSwOldFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Torna su
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Proprietà DedNetSwOldFileResolution.OnFileResolutionSostItem.DbFile

Proprietà DedNetSwOldFileResolutionOnFileResolutionSostItemDbFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbFile { get; set; }
Public Property DbFile As String
    Get
    Set
public:
property String^ DbFile {
    String^ get ();
    void set (String^ value);
}
member DbFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Proprietà DedNetSwOldFileResolution.OnFileResolutionSostItem.OldFile

Proprietà DedNetSwOldFileResolutionOnFileResolutionSostItemOldFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; set; }
Public Property OldFile As String
    Get
    Set
public:
property String^ OldFile {
    String^ get ();
    void set (String^ value);
}
member OldFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Campi di OnFileResolutionSostItem

Il tipo DedNetSwOldFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Campo pubblico | PreviewFile |
Torna su
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Campo DedNetSwOldFileResolution.OnFileResolutionSostItem.DocGuid

Campo DedNetSwOldFileResolutionOnFileResolutionSostItemDocGuid

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocGuid
Public DocGuid As Guid
public:
Guid DocGuid
val mutable DocGuid: Guid

Valore del campo

Guid
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Campo DedNetSwOldFileResolution.OnFileResolutionSostItem.PreviewFile

Campo DedNetSwOldFileResolutionOnFileResolutionSostItemPreviewFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string PreviewFile
Public PreviewFile As String
public:
String^ PreviewFile
val mutable PreviewFile: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItem
Namespace DedNetSw


Classe DedNetSwOldFileResolution.OnFileResolutionSostItemList

Classe DedNetSwOldFileResolutionOnFileResolutionSostItemList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetSwOldFileResolutionOnFileResolutionSostItem
DedNetSwDedNetSwOldFileResolutionOnFileResolutionSostItemList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItemList : List<DedNetSwOldFileResolutionOnFileResolutionSostItem>
Public Class OnFileResolutionSostItemList
    Inherits List(Of DedNetSwOldFileResolutionOnFileResolutionSostItem)
public ref class OnFileResolutionSostItemList : public List<DedNetSwOldFileResolutionOnFileResolutionSostItem^>
type OnFileResolutionSostItemList =
    class
        inherit List<DedNetSwOldFileResolutionOnFileResolutionSostItem>
    end

Il tipo DedNetSwOldFileResolutionOnFileResolutionSostItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwOldFileResolutionOnFileResolutionSostItemList |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwOldFileResolution.OnFileResolutionSostItemList

Costruttore DedNetSwOldFileResolutionOnFileResolutionSostItemList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItemList()
Public Sub New
public:
OnFileResolutionSostItemList()
new : unit -> OnFileResolutionSostItemList
Vedi anche

Documentazione

Classe DedNetSwOldFileResolutionOnFileResolutionSostItemList
Namespace DedNetSw


Enumerazione DedNetSwOldFileResolution.RispostaUtenteSost

Enumerazione DedNetSwOldFileResolutionRispostaUtenteSost

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum RispostaUtenteSost
Public Enumeration RispostaUtenteSost
public enum class RispostaUtenteSost
type RispostaUtenteSost
Membri
Nome | Valore | Descrizione
Si | 0 |
No | 1 |
SiTutti | 2 |
NoTutti | 3 |
Vedi anche

Documentazione

Namespace DedNetSw


Classe DedNetSwServer
Gerarchia di ereditarietà
SystemObject
DedNetSwDedNetSwServer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetSwServer
Public Class DedNetSwServer
public ref class DedNetSwServer
type DedNetSwServer = class end

Il tipo DedNetSwServer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetSwServer |
Torna su
Proprietà
Nome | Descrizione
App |
Loaded |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CallBackFunctionDed |
Metodo pubblico | ConnectToSW |
Metodo pubblico | DisconnectFromSW |
Metodo pubblico | EnableFunctionDed |
Metodo pubblico | FlyoutCallbackArchiveDed |
Metodo pubblico | FlyoutCallbackArchivePrtDed |
Metodo pubblico | FlyoutCallbackAttributeDed |
Metodo pubblico | FlyoutCallbackDistEsplDed |
Metodo pubblico | FlyoutCallbackFindDed |
Metodo pubblico | FlyoutCallbackInitPrtDed |
Metodo pubblico | FlyoutCallbackOpen2Ded |
Metodo pubblico | FlyoutCallbackOpenDed |
Metodo pubblico | FlyoutCallbackRilDed |
Metodo pubblico | FlyoutCallbackRilMultiDed |
Metodo pubblico | FlyoutCallbackSaveConfDed |
Metodo pubblico | FlyoutCallbackSaveConfPrtDed |
Metodo pubblico | FlyoutCallbackSaveDistDed |
Metodo pubblico | FlyoutCallbackSaveRevDed |
Metodo pubblico | FlyoutCallbackSaveRevPrtDed |
Metodo pubblico | FlyoutCallbackStateDed |
Metodo pubblico | FlyoutCallbackSupportDed |
Metodo pubblico | FlyoutEnableArchiveDed |
Metodo pubblico | FlyoutEnableArchivePrtDed |
Metodo pubblico | FlyoutEnableAttributeDed |
Metodo pubblico | FlyoutEnableDistEsplDed |
Metodo pubblico | FlyoutEnableFindDed |
Metodo pubblico | FlyoutEnableInitPrtDed |
Metodo pubblico | FlyoutEnableOpen2Ded |
Metodo pubblico | FlyoutEnableOpenDed |
Metodo pubblico | FlyoutEnableRilDed |
Metodo pubblico | FlyoutEnableRilMultiDed |
Metodo pubblico | FlyoutEnableSaveConfDed |
Metodo pubblico | FlyoutEnableSaveConfPrtDed |
Metodo pubblico | FlyoutEnableSaveDistDed |
Metodo pubblico | FlyoutEnableSaveRevDed |
Metodo pubblico | FlyoutEnableSaveRevPrtDed |
Metodo pubblico | FlyoutEnableStateDed |
Metodo pubblico | FlyoutEnableSupportDed |
Torna su
Campi
Nome | Descrizione
_dedNetInstallPath |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedNetSwServer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetSwServer()
Public Sub New
public:
DedNetSwServer()
new : unit -> DedNetSwServer
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Proprietà di DedNetSwServer

Il tipo DedNetSwServer espone i seguenti membri.

Proprietà
Nome | Descrizione
App |
Loaded |
Torna su
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Proprietà DedNetSwServer.App

Proprietà DedNetSwServerApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedNetSwApp App { get; }
Public Shared ReadOnly Property App As DedNetSwApp
    Get
public:
static property DedNetSwApp^ App {
    DedNetSwApp^ get ();
}
static member App : DedNetSwApp with get

Valore della proprietà

DedNetSwApp
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Proprietà DedNetSwServer.Loaded

Proprietà DedNetSwServerLoaded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool Loaded { get; }
Public Shared ReadOnly Property Loaded As Boolean
    Get
public:
static property bool Loaded {
    bool get ();
}
static member Loaded : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodi di DedNetSwServer

Il tipo DedNetSwServer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CallBackFunctionDed |
Metodo pubblico | ConnectToSW |
Metodo pubblico | DisconnectFromSW |
Metodo pubblico | EnableFunctionDed |
Metodo pubblico | FlyoutCallbackArchiveDed |
Metodo pubblico | FlyoutCallbackArchivePrtDed |
Metodo pubblico | FlyoutCallbackAttributeDed |
Metodo pubblico | FlyoutCallbackDistEsplDed |
Metodo pubblico | FlyoutCallbackFindDed |
Metodo pubblico | FlyoutCallbackInitPrtDed |
Metodo pubblico | FlyoutCallbackOpen2Ded |
Metodo pubblico | FlyoutCallbackOpenDed |
Metodo pubblico | FlyoutCallbackRilDed |
Metodo pubblico | FlyoutCallbackRilMultiDed |
Metodo pubblico | FlyoutCallbackSaveConfDed |
Metodo pubblico | FlyoutCallbackSaveConfPrtDed |
Metodo pubblico | FlyoutCallbackSaveDistDed |
Metodo pubblico | FlyoutCallbackSaveRevDed |
Metodo pubblico | FlyoutCallbackSaveRevPrtDed |
Metodo pubblico | FlyoutCallbackStateDed |
Metodo pubblico | FlyoutCallbackSupportDed |
Metodo pubblico | FlyoutEnableArchiveDed |
Metodo pubblico | FlyoutEnableArchivePrtDed |
Metodo pubblico | FlyoutEnableAttributeDed |
Metodo pubblico | FlyoutEnableDistEsplDed |
Metodo pubblico | FlyoutEnableFindDed |
Metodo pubblico | FlyoutEnableInitPrtDed |
Metodo pubblico | FlyoutEnableOpen2Ded |
Metodo pubblico | FlyoutEnableOpenDed |
Metodo pubblico | FlyoutEnableRilDed |
Metodo pubblico | FlyoutEnableRilMultiDed |
Metodo pubblico | FlyoutEnableSaveConfDed |
Metodo pubblico | FlyoutEnableSaveConfPrtDed |
Metodo pubblico | FlyoutEnableSaveDistDed |
Metodo pubblico | FlyoutEnableSaveRevDed |
Metodo pubblico | FlyoutEnableSaveRevPrtDed |
Metodo pubblico | FlyoutEnableStateDed |
Metodo pubblico | FlyoutEnableSupportDed |
Torna su
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.CallBackFunctionDed

Metodo DedNetSwServerCallBackFunctionDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void CallBackFunctionDed(
    string commandName
)
Public Sub CallBackFunctionDed (
    commandName As String
)
public:
void CallBackFunctionDed(
    String^ commandName
)
member CallBackFunctionDed :
        commandName : string -> unit

Parametri

commandName String
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.ConnectToSW

Metodo DedNetSwServerConnectToSW

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ConnectToSW(
    Object ThisSW,
    int Cookie
)
Public Function ConnectToSW (
    ThisSW As Object,
    Cookie As Integer
) As Boolean
public:
virtual bool ConnectToSW(
    Object^ ThisSW,
    int Cookie
) sealed
abstract ConnectToSW :
        ThisSW : Object *
        Cookie : int -> bool
override ConnectToSW :
        ThisSW : Object *
        Cookie : int -> bool

Parametri

ThisSW Object
Cookie Int32

Valore di ritorno

Boolean

Implementa

ISwAddin.ConnectToSW(Object, Int32)
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.DisconnectFromSW

Metodo DedNetSwServerDisconnectFromSW

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DisconnectFromSW()
Public Function DisconnectFromSW As Boolean
public:
virtual bool DisconnectFromSW() sealed
abstract DisconnectFromSW : unit -> bool
override DisconnectFromSW : unit -> bool

Valore di ritorno

Boolean

Implementa

ISwAddin.DisconnectFromSW
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.EnableFunctionDed

Metodo DedNetSwServerEnableFunctionDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int EnableFunctionDed(
    string commandName
)
Public Function EnableFunctionDed (
    commandName As String
) As Integer
public:
int EnableFunctionDed(
    String^ commandName
)
member EnableFunctionDed :
        commandName : string -> int

Parametri

commandName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackArchiveDed

Metodo DedNetSwServerFlyoutCallbackArchiveDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackArchiveDed()
Public Sub FlyoutCallbackArchiveDed
public:
void FlyoutCallbackArchiveDed()
member FlyoutCallbackArchiveDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackArchivePrtDed

Metodo DedNetSwServerFlyoutCallbackArchivePrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackArchivePrtDed()
Public Sub FlyoutCallbackArchivePrtDed
public:
void FlyoutCallbackArchivePrtDed()
member FlyoutCallbackArchivePrtDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackAttributeDed

Metodo DedNetSwServerFlyoutCallbackAttributeDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackAttributeDed()
Public Sub FlyoutCallbackAttributeDed
public:
void FlyoutCallbackAttributeDed()
member FlyoutCallbackAttributeDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackDistEsplDed

Metodo DedNetSwServerFlyoutCallbackDistEsplDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackDistEsplDed()
Public Sub FlyoutCallbackDistEsplDed
public:
void FlyoutCallbackDistEsplDed()
member FlyoutCallbackDistEsplDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackFindDed

Metodo DedNetSwServerFlyoutCallbackFindDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackFindDed()
Public Sub FlyoutCallbackFindDed
public:
void FlyoutCallbackFindDed()
member FlyoutCallbackFindDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackInitPrtDed

Metodo DedNetSwServerFlyoutCallbackInitPrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackInitPrtDed()
Public Sub FlyoutCallbackInitPrtDed
public:
void FlyoutCallbackInitPrtDed()
member FlyoutCallbackInitPrtDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackOpen2Ded

Metodo DedNetSwServerFlyoutCallbackOpen2Ded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackOpen2Ded()
Public Sub FlyoutCallbackOpen2Ded
public:
void FlyoutCallbackOpen2Ded()
member FlyoutCallbackOpen2Ded : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackOpenDed

Metodo DedNetSwServerFlyoutCallbackOpenDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackOpenDed()
Public Sub FlyoutCallbackOpenDed
public:
void FlyoutCallbackOpenDed()
member FlyoutCallbackOpenDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackRilDed

Metodo DedNetSwServerFlyoutCallbackRilDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackRilDed()
Public Sub FlyoutCallbackRilDed
public:
void FlyoutCallbackRilDed()
member FlyoutCallbackRilDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackRilMultiDed

Metodo DedNetSwServerFlyoutCallbackRilMultiDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackRilMultiDed()
Public Sub FlyoutCallbackRilMultiDed
public:
void FlyoutCallbackRilMultiDed()
member FlyoutCallbackRilMultiDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackSaveConfDed

Metodo DedNetSwServerFlyoutCallbackSaveConfDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackSaveConfDed()
Public Sub FlyoutCallbackSaveConfDed
public:
void FlyoutCallbackSaveConfDed()
member FlyoutCallbackSaveConfDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackSaveConfPrtDed

Metodo DedNetSwServerFlyoutCallbackSaveConfPrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackSaveConfPrtDed()
Public Sub FlyoutCallbackSaveConfPrtDed
public:
void FlyoutCallbackSaveConfPrtDed()
member FlyoutCallbackSaveConfPrtDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackSaveDistDed

Metodo DedNetSwServerFlyoutCallbackSaveDistDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackSaveDistDed()
Public Sub FlyoutCallbackSaveDistDed
public:
void FlyoutCallbackSaveDistDed()
member FlyoutCallbackSaveDistDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackSaveRevDed

Metodo DedNetSwServerFlyoutCallbackSaveRevDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackSaveRevDed()
Public Sub FlyoutCallbackSaveRevDed
public:
void FlyoutCallbackSaveRevDed()
member FlyoutCallbackSaveRevDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackSaveRevPrtDed

Metodo DedNetSwServerFlyoutCallbackSaveRevPrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackSaveRevPrtDed()
Public Sub FlyoutCallbackSaveRevPrtDed
public:
void FlyoutCallbackSaveRevPrtDed()
member FlyoutCallbackSaveRevPrtDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackStateDed

Metodo DedNetSwServerFlyoutCallbackStateDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackStateDed()
Public Sub FlyoutCallbackStateDed
public:
void FlyoutCallbackStateDed()
member FlyoutCallbackStateDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutCallbackSupportDed

Metodo DedNetSwServerFlyoutCallbackSupportDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FlyoutCallbackSupportDed()
Public Sub FlyoutCallbackSupportDed
public:
void FlyoutCallbackSupportDed()
member FlyoutCallbackSupportDed : unit -> unit
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableArchiveDed

Metodo DedNetSwServerFlyoutEnableArchiveDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableArchiveDed()
Public Function FlyoutEnableArchiveDed As Integer
public:
int FlyoutEnableArchiveDed()
member FlyoutEnableArchiveDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableArchivePrtDed

Metodo DedNetSwServerFlyoutEnableArchivePrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableArchivePrtDed()
Public Function FlyoutEnableArchivePrtDed As Integer
public:
int FlyoutEnableArchivePrtDed()
member FlyoutEnableArchivePrtDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableAttributeDed

Metodo DedNetSwServerFlyoutEnableAttributeDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableAttributeDed()
Public Function FlyoutEnableAttributeDed As Integer
public:
int FlyoutEnableAttributeDed()
member FlyoutEnableAttributeDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableDistEsplDed

Metodo DedNetSwServerFlyoutEnableDistEsplDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableDistEsplDed()
Public Function FlyoutEnableDistEsplDed As Integer
public:
int FlyoutEnableDistEsplDed()
member FlyoutEnableDistEsplDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableFindDed

Metodo DedNetSwServerFlyoutEnableFindDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableFindDed()
Public Function FlyoutEnableFindDed As Integer
public:
int FlyoutEnableFindDed()
member FlyoutEnableFindDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableInitPrtDed

Metodo DedNetSwServerFlyoutEnableInitPrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableInitPrtDed()
Public Function FlyoutEnableInitPrtDed As Integer
public:
int FlyoutEnableInitPrtDed()
member FlyoutEnableInitPrtDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableOpen2Ded

Metodo DedNetSwServerFlyoutEnableOpen2Ded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableOpen2Ded()
Public Function FlyoutEnableOpen2Ded As Integer
public:
int FlyoutEnableOpen2Ded()
member FlyoutEnableOpen2Ded : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableOpenDed

Metodo DedNetSwServerFlyoutEnableOpenDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableOpenDed()
Public Function FlyoutEnableOpenDed As Integer
public:
int FlyoutEnableOpenDed()
member FlyoutEnableOpenDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableRilDed

Metodo DedNetSwServerFlyoutEnableRilDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableRilDed()
Public Function FlyoutEnableRilDed As Integer
public:
int FlyoutEnableRilDed()
member FlyoutEnableRilDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableRilMultiDed

Metodo DedNetSwServerFlyoutEnableRilMultiDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableRilMultiDed()
Public Function FlyoutEnableRilMultiDed As Integer
public:
int FlyoutEnableRilMultiDed()
member FlyoutEnableRilMultiDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableSaveConfDed

Metodo DedNetSwServerFlyoutEnableSaveConfDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableSaveConfDed()
Public Function FlyoutEnableSaveConfDed As Integer
public:
int FlyoutEnableSaveConfDed()
member FlyoutEnableSaveConfDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableSaveConfPrtDed

Metodo DedNetSwServerFlyoutEnableSaveConfPrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableSaveConfPrtDed()
Public Function FlyoutEnableSaveConfPrtDed As Integer
public:
int FlyoutEnableSaveConfPrtDed()
member FlyoutEnableSaveConfPrtDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableSaveDistDed

Metodo DedNetSwServerFlyoutEnableSaveDistDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableSaveDistDed()
Public Function FlyoutEnableSaveDistDed As Integer
public:
int FlyoutEnableSaveDistDed()
member FlyoutEnableSaveDistDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableSaveRevDed

Metodo DedNetSwServerFlyoutEnableSaveRevDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableSaveRevDed()
Public Function FlyoutEnableSaveRevDed As Integer
public:
int FlyoutEnableSaveRevDed()
member FlyoutEnableSaveRevDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableSaveRevPrtDed

Metodo DedNetSwServerFlyoutEnableSaveRevPrtDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableSaveRevPrtDed()
Public Function FlyoutEnableSaveRevPrtDed As Integer
public:
int FlyoutEnableSaveRevPrtDed()
member FlyoutEnableSaveRevPrtDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableStateDed

Metodo DedNetSwServerFlyoutEnableStateDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableStateDed()
Public Function FlyoutEnableStateDed As Integer
public:
int FlyoutEnableStateDed()
member FlyoutEnableStateDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Metodo DedNetSwServer.FlyoutEnableSupportDed

Metodo DedNetSwServerFlyoutEnableSupportDed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int FlyoutEnableSupportDed()
Public Function FlyoutEnableSupportDed As Integer
public:
int FlyoutEnableSupportDed()
member FlyoutEnableSupportDed : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Campi di DedNetSwServer

Il tipo DedNetSwServer espone i seguenti membri.

Campi
Nome | Descrizione
_dedNetInstallPath |
Torna su
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Campo DedNetSwServer._dedNetInstallPath

Campo DedNetSwServer_dedNetInstallPath

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string _dedNetInstallPath
Public Shared _dedNetInstallPath As String
public:
static String^ _dedNetInstallPath
static val mutable _dedNetInstallPath: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetSwServer
Namespace DedNetSw


Classe DedSwCommandContext
Gerarchia di ereditarietà
SystemObject
DedNetSwDedSwCommandContext

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedSwCommandContext
Public Class DedSwCommandContext
public ref class DedSwCommandContext
type DedSwCommandContext = class end

Il tipo DedSwCommandContext espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwCommandContext |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ContextSource |
Proprietà pubblica | Data |
Proprietà pubblica | SolidWorksCurrentSelection |
Proprietà pubblica | SolidWorksDocDepSelection |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedSwCommandContext

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwCommandContext()
Public Sub New
public:
DedSwCommandContext()
new : unit -> DedSwCommandContext
Vedi anche

Documentazione

Classe DedSwCommandContext
Namespace DedNetSw


Proprietà di DedSwCommandContext

Il tipo DedSwCommandContext espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ContextSource |
Proprietà pubblica | Data |
Proprietà pubblica | SolidWorksCurrentSelection |
Proprietà pubblica | SolidWorksDocDepSelection |
Torna su
Vedi anche

Documentazione

Classe DedSwCommandContext
Namespace DedNetSw


Proprietà DedSwCommandContext.ContextSource

Proprietà DedSwCommandContextContextSource

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwCommandContextSourceEnum ContextSource { get; set; }
Public Property ContextSource As DedSwCommandContextSourceEnum
    Get
    Set
public:
property DedSwCommandContextSourceEnum ContextSource {
    DedSwCommandContextSourceEnum get ();
    void set (DedSwCommandContextSourceEnum value);
}
member ContextSource : DedSwCommandContextSourceEnum with get, set

Valore della proprietà

DedSwCommandContextSourceEnum
Vedi anche

Documentazione

Classe DedSwCommandContext
Namespace DedNetSw


Proprietà DedSwCommandContext.Data

Proprietà DedSwCommandContextData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedSwCommandContext
Namespace DedNetSw


Proprietà DedSwCommandContext.SolidWorksCurrentSelection

Proprietà DedSwCommandContextSolidWorksCurrentSelection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwCurSelInfo SolidWorksCurrentSelection { get; }
Public ReadOnly Property SolidWorksCurrentSelection As SwCurSelInfo
    Get
public:
property SwCurSelInfo^ SolidWorksCurrentSelection {
    SwCurSelInfo^ get ();
}
member SolidWorksCurrentSelection : SwCurSelInfo with get

Valore della proprietà

SwCurSelInfo
Vedi anche

Documentazione

Classe DedSwCommandContext
Namespace DedNetSw


Proprietà DedSwCommandContext.SolidWorksDocDepSelection

Proprietà DedSwCommandContextSolidWorksDocDepSelection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwCommandContextSwDocDepTreeSelInfo SolidWorksDocDepSelection { get; }
Public ReadOnly Property SolidWorksDocDepSelection As DedSwCommandContextSwDocDepTreeSelInfo
    Get
public:
property DedSwCommandContextSwDocDepTreeSelInfo^ SolidWorksDocDepSelection {
    DedSwCommandContextSwDocDepTreeSelInfo^ get ();
}
member SolidWorksDocDepSelection : DedSwCommandContextSwDocDepTreeSelInfo with get

Valore della proprietà

DedSwCommandContextSwDocDepTreeSelInfo
Vedi anche

Documentazione

Classe DedSwCommandContext
Namespace DedNetSw


Classe DedSwCommandContext.DocDepTreeItem

Classe DedSwCommandContextDocDepTreeItem
Gerarchia di ereditarietà
SystemObject
DedNetSwDedSwCommandContextDocDepTreeItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocDepTreeItem
Public Class DocDepTreeItem
public ref class DocDepTreeItem
type DocDepTreeItem = class end

Il tipo DedSwCommandContextDocDepTreeItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwCommandContextDocDepTreeItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Doc |
Proprietà pubblica | IsComp |
Proprietà pubblica | IsDoc |
Proprietà pubblica | Item |
Proprietà pubblica | Path |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedSwCommandContext.DocDepTreeItem

Costruttore DedSwCommandContextDocDepTreeItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocDepTreeItem(
    Object item,
    string config
)
Public Sub New (
    item As Object,
    config As String
)
public:
DocDepTreeItem(
    Object^ item,
    String^ config
)
new :
        item : Object *
        config : string -> DocDepTreeItem

Parametri

item Object
config String
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà di DocDepTreeItem

Il tipo DedSwCommandContextDocDepTreeItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Doc |
Proprietà pubblica | IsComp |
Proprietà pubblica | IsDoc |
Proprietà pubblica | Item |
Proprietà pubblica | Path |
Torna su
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà DedSwCommandContext.DocDepTreeItem.Config

Proprietà DedSwCommandContextDocDepTreeItemConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà DedSwCommandContext.DocDepTreeItem.Doc

Proprietà DedSwCommandContextDocDepTreeItemDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 Doc { get; }
Public ReadOnly Property Doc As IModelDoc2
    Get
public:
property IModelDoc2^ Doc {
    IModelDoc2^ get ();
}
member Doc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà DedSwCommandContext.DocDepTreeItem.IsComp

Proprietà DedSwCommandContextDocDepTreeItemIsComp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsComp { get; }
Public ReadOnly Property IsComp As Boolean
    Get
public:
property bool IsComp {
    bool get ();
}
member IsComp : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà DedSwCommandContext.DocDepTreeItem.IsDoc

Proprietà DedSwCommandContextDocDepTreeItemIsDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDoc { get; }
Public ReadOnly Property IsDoc As Boolean
    Get
public:
property bool IsDoc {
    bool get ();
}
member IsDoc : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà DedSwCommandContext.DocDepTreeItem.Item

Proprietà DedSwCommandContextDocDepTreeItemItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Item { get; set; }
Public Property Item As Object
    Get
    Set
public:
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}
member Item : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Proprietà DedSwCommandContext.DocDepTreeItem.Path

Proprietà DedSwCommandContextDocDepTreeItemPath

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwCommandContextDocDepTreeItem
Namespace DedNetSw


Classe DedSwCommandContext.SwDocDepTreeSelInfo

Classe DedSwCommandContextSwDocDepTreeSelInfo
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedSwCommandContextDocDepTreeItem
DedNetSwDedSwCommandContextSwDocDepTreeSelInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwDocDepTreeSelInfo : List<DedSwCommandContextDocDepTreeItem>
Public Class SwDocDepTreeSelInfo
    Inherits List(Of DedSwCommandContextDocDepTreeItem)
public ref class SwDocDepTreeSelInfo : public List<DedSwCommandContextDocDepTreeItem^>
type SwDocDepTreeSelInfo =
    class
        inherit List<DedSwCommandContextDocDepTreeItem>
    end

Il tipo DedSwCommandContextSwDocDepTreeSelInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwCommandContextSwDocDepTreeSelInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | OtherDocumentList |
Proprietà pubblica | SolidWorksComponentList |
Proprietà pubblica | SolidWorksDocumentList |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedSwCommandContext.SwDocDepTreeSelInfo

Costruttore DedSwCommandContextSwDocDepTreeSelInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocDepTreeSelInfo()
Public Sub New
public:
SwDocDepTreeSelInfo()
new : unit -> SwDocDepTreeSelInfo
Vedi anche

Documentazione

Classe DedSwCommandContextSwDocDepTreeSelInfo
Namespace DedNetSw


Proprietà di SwDocDepTreeSelInfo

Il tipo DedSwCommandContextSwDocDepTreeSelInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | OtherDocumentList |
Proprietà pubblica | SolidWorksComponentList |
Proprietà pubblica | SolidWorksDocumentList |
Torna su
Vedi anche

Documentazione

Classe DedSwCommandContextSwDocDepTreeSelInfo
Namespace DedNetSw


Proprietà DedSwCommandContext.SwDocDepTreeSelInfo.OtherDocumentList

Proprietà DedSwCommandContextSwDocDepTreeSelInfoOtherDocumentList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> OtherDocumentList { get; }
Public ReadOnly Property OtherDocumentList As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ OtherDocumentList {
    Dictionary<String^, String^>^ get ();
}
member OtherDocumentList : Dictionary<string, string> with get

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe DedSwCommandContextSwDocDepTreeSelInfo
Namespace DedNetSw


Proprietà DedSwCommandContext.SwDocDepTreeSelInfo.SolidWorksComponentList

Proprietà DedSwCommandContextSwDocDepTreeSelInfoSolidWorksComponentList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<IComponent2, string> SolidWorksComponentList { get; }
Public ReadOnly Property SolidWorksComponentList As Dictionary(Of IComponent2, String)
    Get
public:
property Dictionary<IComponent2^, String^>^ SolidWorksComponentList {
    Dictionary<IComponent2^, String^>^ get ();
}
member SolidWorksComponentList : Dictionary<IComponent2, string> with get

Valore della proprietà

Dictionary IComponent2, String
Vedi anche

Documentazione

Classe DedSwCommandContextSwDocDepTreeSelInfo
Namespace DedNetSw


Proprietà DedSwCommandContext.SwDocDepTreeSelInfo.SolidWorksDocumentList

Proprietà DedSwCommandContextSwDocDepTreeSelInfoSolidWorksDocumentList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<IModelDoc2, string> SolidWorksDocumentList { get; }
Public ReadOnly Property SolidWorksDocumentList As Dictionary(Of IModelDoc2, String)
    Get
public:
property Dictionary<IModelDoc2^, String^>^ SolidWorksDocumentList {
    Dictionary<IModelDoc2^, String^>^ get ();
}
member SolidWorksDocumentList : Dictionary<IModelDoc2, string> with get

Valore della proprietà

Dictionary IModelDoc2, String
Vedi anche

Documentazione

Classe DedSwCommandContextSwDocDepTreeSelInfo
Namespace DedNetSw


Enumerazione DedSwCommandContextSourceEnum

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum DedSwCommandContextSourceEnum
Public Enumeration DedSwCommandContextSourceEnum
public enum class DedSwCommandContextSourceEnum
type DedSwCommandContextSourceEnum
Membri
Nome | Valore | Descrizione
NotAvailable | 0 |
Menu | 1 |
DocDepTree | 2 |
DocAssist | 3 |
Vedi anche

Documentazione

Namespace DedNetSw


Classe DedSwDocAssistantControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
DedNetSwDedSwDocAssistantControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedSwDocAssistantControl : UserControl
Public Class DedSwDocAssistantControl
    Inherits UserControl
public ref class DedSwDocAssistantControl : public UserControl
type DedSwDocAssistantControl =
    class
        inherit UserControl
    end

Il tipo DedSwDocAssistantControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwDocAssistantControl |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clear |
Metodo protetto | Dispose | (Sovrascrive ContainerControlDispose(Boolean))
Metodo protetto | OnVisibleChanged | (Sovrascrive ScrollableControlOnVisibleChanged(EventArgs))
Metodo pubblico | RestoreLayoutFromRegistry |
Metodo pubblico | SaveLayoutToRegistry |
Metodo pubblico | Update |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DedSwDocAssistantControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwDocAssistantControl()
Public Sub New
public:
DedSwDocAssistantControl()
new : unit -> DedSwDocAssistantControl
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodi di DedSwDocAssistantControl

Il tipo DedSwDocAssistantControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clear |
Metodo protetto | Dispose | (Sovrascrive ContainerControlDispose(Boolean))
Metodo protetto | OnVisibleChanged | (Sovrascrive ScrollableControlOnVisibleChanged(EventArgs))
Metodo pubblico | RestoreLayoutFromRegistry |
Metodo pubblico | SaveLayoutToRegistry |
Metodo pubblico | Update |
Torna su
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodo DedSwDocAssistantControl.Clear

Metodo DedSwDocAssistantControlClear

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodo DedSwDocAssistantControl.Dispose

Metodo DedSwDocAssistantControlDispose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodo DedSwDocAssistantControl.OnVisibleChanged

Metodo DedSwDocAssistantControlOnVisibleChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodo DedSwDocAssistantControl.RestoreLayoutFromRegistry

Metodo DedSwDocAssistantControlRestoreLayoutFromRegistry

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey String
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodo DedSwDocAssistantControl.SaveLayoutToRegistry

Metodo DedSwDocAssistantControlSaveLayoutToRegistry

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey String
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Metodo DedSwDocAssistantControl.Update

Metodo DedSwDocAssistantControlUpdate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    SwCurSelInfo swCurSelInfo
)
Public Sub Update (
    swCurSelInfo As SwCurSelInfo
)
public:
void Update(
    SwCurSelInfo^ swCurSelInfo
)
member Update :
        swCurSelInfo : SwCurSelInfo -> unit

Parametri

swCurSelInfo SwCurSelInfo
Vedi anche

Documentazione

Classe DedSwDocAssistantControl
Namespace DedNetSw


Classe DocumentControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
DedNetSwDocumentControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentControl : UserControl
Public Class DocumentControl
    Inherits UserControl
public ref class DocumentControl : public UserControl
type DocumentControl =
    class
        inherit UserControl
    end

Il tipo DocumentControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsActive |
Proprietà pubblica | NeedRefresh |
Proprietà pubblica | SelectionImageSize |
Proprietà pubblica | SelectionTrasparentColor |
Proprietà pubblica | StateImageSize |
Proprietà pubblica | StateTrasparentColor |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddSelectionImage |
Metodo pubblico | AddStateImage |
Metodo pubblico | Aggiorna |
Metodo pubblico | ClearSelection |
Metodo pubblico | ContainsSelectionImage |
Metodo pubblico | ContainsStateImage |
Metodo protetto | Dispose | (Sovrascrive ContainerControlDispose(Boolean))
Metodo pubblico | HighLight |
Metodo pubblico | Init |
Metodo protetto | OnHandleDestroyed | (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnVisibleChanged | (Sovrascrive ScrollableControlOnVisibleChanged(EventArgs))
Metodo pubblico | ReloadStateInformations |
Metodo pubblico | RestoreLayoutFromRegistry |
Metodo pubblico | SaveLayoutToRegistry |
Metodo pubblico | Svuota |
Metodo pubblico | Update |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DocumentControl

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentControl()
Public Sub New
public:
DocumentControl()
new : unit -> DocumentControl
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà di DocumentControl

Il tipo DocumentControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsActive |
Proprietà pubblica | NeedRefresh |
Proprietà pubblica | SelectionImageSize |
Proprietà pubblica | SelectionTrasparentColor |
Proprietà pubblica | StateImageSize |
Proprietà pubblica | StateTrasparentColor |
Torna su
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà DocumentControl.IsActive

Proprietà DocumentControlIsActive

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
member IsActive : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà DocumentControl.NeedRefresh

Proprietà DocumentControlNeedRefresh

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRefresh { get; set; }
Public Property NeedRefresh As Boolean
    Get
    Set
public:
property bool NeedRefresh {
    bool get ();
    void set (bool value);
}
member NeedRefresh : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà DocumentControl.SelectionImageSize

Proprietà DocumentControlSelectionImageSize

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Size SelectionImageSize { get; set; }
Public Property SelectionImageSize As Size
    Get
    Set
public:
property Size SelectionImageSize {
    Size get ();
    void set (Size value);
}
member SelectionImageSize : Size with get, set

Valore della proprietà

Size
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà DocumentControl.SelectionTrasparentColor

Proprietà DocumentControlSelectionTrasparentColor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Color SelectionTrasparentColor { get; set; }
Public Property SelectionTrasparentColor As Color
    Get
    Set
public:
property Color SelectionTrasparentColor {
    Color get ();
    void set (Color value);
}
member SelectionTrasparentColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà DocumentControl.StateImageSize

Proprietà DocumentControlStateImageSize

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Size StateImageSize { get; set; }
Public Property StateImageSize As Size
    Get
    Set
public:
property Size StateImageSize {
    Size get ();
    void set (Size value);
}
member StateImageSize : Size with get, set

Valore della proprietà

Size
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Proprietà DocumentControl.StateTrasparentColor

Proprietà DocumentControlStateTrasparentColor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Color StateTrasparentColor { get; set; }
Public Property StateTrasparentColor As Color
    Get
    Set
public:
property Color StateTrasparentColor {
    Color get ();
    void set (Color value);
}
member StateTrasparentColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodi di DocumentControl

Il tipo DocumentControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddSelectionImage |
Metodo pubblico | AddStateImage |
Metodo pubblico | Aggiorna |
Metodo pubblico | ClearSelection |
Metodo pubblico | ContainsSelectionImage |
Metodo pubblico | ContainsStateImage |
Metodo protetto | Dispose | (Sovrascrive ContainerControlDispose(Boolean))
Metodo pubblico | HighLight |
Metodo pubblico | Init |
Metodo protetto | OnHandleDestroyed | (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnVisibleChanged | (Sovrascrive ScrollableControlOnVisibleChanged(EventArgs))
Metodo pubblico | ReloadStateInformations |
Metodo pubblico | RestoreLayoutFromRegistry |
Metodo pubblico | SaveLayoutToRegistry |
Metodo pubblico | Svuota |
Metodo pubblico | Update |
Torna su
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.AddSelectionImage

Metodo DocumentControlAddSelectionImage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AddSelectionImage(
    Image img,
    string name
)
Public Sub AddSelectionImage (
    img As Image,
    name As String
)
public:
void AddSelectionImage(
    Image^ img,
    String^ name
)
member AddSelectionImage :
        img : Image *
        name : string -> unit

Parametri

img Image
name String
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.AddStateImage

Metodo DocumentControlAddStateImage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AddStateImage(
    Image img,
    string name
)
Public Sub AddStateImage (
    img As Image,
    name As String
)
public:
void AddStateImage(
    Image^ img,
    String^ name
)
member AddStateImage :
        img : Image *
        name : string -> unit

Parametri

img Image
name String
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.Aggiorna

Metodo DocumentControlAggiorna

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Aggiorna(
    bool restoreStatus
)
Public Sub Aggiorna (
    restoreStatus As Boolean
)
public:
void Aggiorna(
    bool restoreStatus
)
member Aggiorna :
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.ClearSelection

Metodo DocumentControlClearSelection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ClearSelection()
Public Sub ClearSelection
public:
void ClearSelection()
member ClearSelection : unit -> unit
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.ContainsSelectionImage

Metodo DocumentControlContainsSelectionImage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsSelectionImage(
    string name
)
Public Function ContainsSelectionImage (
    name As String
) As Boolean
public:
bool ContainsSelectionImage(
    String^ name
)
member ContainsSelectionImage :
        name : string -> bool

Parametri

name String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.ContainsStateImage

Metodo DocumentControlContainsStateImage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsStateImage(
    string name
)
Public Function ContainsStateImage (
    name As String
) As Boolean
public:
bool ContainsStateImage(
    String^ name
)
member ContainsStateImage :
        name : string -> bool

Parametri

name String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.Dispose

Metodo DocumentControlDispose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.HighLight

Metodo DocumentControlHighLight

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void HighLight(
    FileStateElementList fsePath
)
Public Sub HighLight (
    fsePath As FileStateElementList
)
public:
void HighLight(
    FileStateElementList^ fsePath
)
member HighLight :
        fsePath : FileStateElementList -> unit

Parametri

fsePath FileStateElementList
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.Init

Metodo DocumentControlInit

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Init(
    FileStateManager stateMan,
    DedNetApplication app
)
Public Sub Init (
    stateMan As FileStateManager,
    app As DedNetApplication
)
public:
void Init(
    FileStateManager^ stateMan,
    DedNetApplication^ app
)
member Init :
        stateMan : FileStateManager *
        app : DedNetApplication -> unit

Parametri

stateMan FileStateManager
app DedNetApplication
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.OnHandleDestroyed

Metodo DocumentControlOnHandleDestroyed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void OnHandleDestroyed(
    EventArgs e
)
Protected Overrides Sub OnHandleDestroyed (
    e As EventArgs
)
protected:
virtual void OnHandleDestroyed(
    EventArgs^ e
) override
abstract OnHandleDestroyed :
        e : EventArgs -> unit
override OnHandleDestroyed :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.OnVisibleChanged

Metodo DocumentControlOnVisibleChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.ReloadStateInformations

Metodo DocumentControlReloadStateInformations

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ReloadStateInformations(
    bool refreshChildren,
    bool reloadMoved
)
Public Sub ReloadStateInformations (
    refreshChildren As Boolean,
    reloadMoved As Boolean
)
public:
void ReloadStateInformations(
    bool refreshChildren,
    bool reloadMoved
)
member ReloadStateInformations :
        refreshChildren : bool *
        reloadMoved : bool -> unit

Parametri

refreshChildren Boolean
reloadMoved Boolean
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.RestoreLayoutFromRegistry

Metodo DocumentControlRestoreLayoutFromRegistry

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey String
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.SaveLayoutToRegistry

Metodo DocumentControlSaveLayoutToRegistry

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey String
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.Svuota

Metodo DocumentControlSvuota

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Svuota()
Public Sub Svuota
public:
void Svuota()
member Svuota : unit -> unit
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Metodo DocumentControl.Update

Metodo DocumentControlUpdate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    FileStateElement el
)
Public Sub Update (
    el As FileStateElement
)
public:
void Update(
    FileStateElement^ el
)
member Update :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Classe DocumentControl
Namespace DedNetSw


Classe DocumentControl.FileStateElementNodeWrapper

Classe DocumentControlFileStateElementNodeWrapper
Gerarchia di ereditarietà
SystemObject
DedNetSwDocumentControlFileStateElementNodeWrapper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElementNodeWrapper
Public Class FileStateElementNodeWrapper
public ref class FileStateElementNodeWrapper
type FileStateElementNodeWrapper = class end

Il tipo DocumentControlFileStateElementNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentControlFileStateElementNodeWrapper |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Element |
Proprietà pubblica | Expanded |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DocumentControl.FileStateElementNodeWrapper

Costruttore DocumentControlFileStateElementNodeWrapper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementNodeWrapper()
Public Sub New
public:
FileStateElementNodeWrapper()
new : unit -> FileStateElementNodeWrapper
Vedi anche

Documentazione

Classe DocumentControlFileStateElementNodeWrapper
Namespace DedNetSw


Proprietà di FileStateElementNodeWrapper

Il tipo DocumentControlFileStateElementNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Element |
Proprietà pubblica | Expanded |
Torna su
Vedi anche

Documentazione

Classe DocumentControlFileStateElementNodeWrapper
Namespace DedNetSw


Proprietà DocumentControl.FileStateElementNodeWrapper.Element

Proprietà DocumentControlFileStateElementNodeWrapperElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement Element { get; set; }
Public Property Element As FileStateElement
    Get
    Set
public:
property FileStateElement^ Element {
    FileStateElement^ get ();
    void set (FileStateElement^ value);
}
member Element : FileStateElement with get, set

Valore della proprietà

FileStateElement
Vedi anche

Documentazione

Classe DocumentControlFileStateElementNodeWrapper
Namespace DedNetSw


Proprietà DocumentControl.FileStateElementNodeWrapper.Expanded

Proprietà DocumentControlFileStateElementNodeWrapperExpanded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Expanded { get; set; }
Public Property Expanded As Boolean
    Get
    Set
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}
member Expanded : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocumentControlFileStateElementNodeWrapper
Namespace DedNetSw


Classe DocumentEventHandler
Gerarchia di ereditarietà
SystemObject
DedNetSwDocumentEventHandler
DedNetSwAssemblyEventHandler
DedNetSwDrawingEventHandler
DedNetSwPartEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentEventHandler
Public Class DocumentEventHandler
public ref class DocumentEventHandler
type DocumentEventHandler = class end

Il tipo DocumentEventHandler espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentEventHandler |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers |
Metodo pubblico | ConnectModelViews |
Metodo pubblico | DetachEventHandlers |
Metodo pubblico | DetachModelViewEventHandler |
Metodo pubblico | DisconnectModelViews |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | document |
Campo protetto | iSwApp |
Campo protetto | openModelViews |
Campo protetto | userAddin |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DocumentEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentEventHandler(
    ModelDoc2 modDoc,
    DedNetSwApp addin,
    ISldWorks sldwrk
)
Public Sub New (
    modDoc As ModelDoc2,
    addin As DedNetSwApp,
    sldwrk As ISldWorks
)
public:
DocumentEventHandler(
    ModelDoc2^ modDoc,
    DedNetSwApp^ addin,
    ISldWorks^ sldwrk
)
new :
        modDoc : ModelDoc2 *
        addin : DedNetSwApp *
        sldwrk : ISldWorks -> DocumentEventHandler

Parametri

modDoc ModelDoc2
addin DedNetSwApp
sldwrk ISldWorks
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Metodi di DocumentEventHandler

Il tipo DocumentEventHandler espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers |
Metodo pubblico | ConnectModelViews |
Metodo pubblico | DetachEventHandlers |
Metodo pubblico | DetachModelViewEventHandler |
Metodo pubblico | DisconnectModelViews |
Torna su
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Metodo DocumentEventHandler.AttachEventHandlers

Metodo DocumentEventHandlerAttachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public virtual bool AttachEventHandlers()
Public Overridable Function AttachEventHandlers As Boolean
public:
virtual bool AttachEventHandlers()
abstract AttachEventHandlers : unit -> bool
override AttachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Metodo DocumentEventHandler.ConnectModelViews

Metodo DocumentEventHandlerConnectModelViews

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ConnectModelViews()
Public Function ConnectModelViews As Boolean
public:
bool ConnectModelViews()
member ConnectModelViews : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Metodo DocumentEventHandler.DetachEventHandlers

Metodo DocumentEventHandlerDetachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public virtual bool DetachEventHandlers()
Public Overridable Function DetachEventHandlers As Boolean
public:
virtual bool DetachEventHandlers()
abstract DetachEventHandlers : unit -> bool
override DetachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Metodo DocumentEventHandler.DetachModelViewEventHandler

Metodo DocumentEventHandlerDetachModelViewEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DetachModelViewEventHandler(
    ModelView mView
)
Public Function DetachModelViewEventHandler (
    mView As ModelView
) As Boolean
public:
bool DetachModelViewEventHandler(
    ModelView^ mView
)
member DetachModelViewEventHandler :
        mView : ModelView -> bool

Parametri

mView ModelView

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Metodo DocumentEventHandler.DisconnectModelViews

Metodo DocumentEventHandlerDisconnectModelViews

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DisconnectModelViews()
Public Function DisconnectModelViews As Boolean
public:
bool DisconnectModelViews()
member DisconnectModelViews : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Campi di DocumentEventHandler

Il tipo DocumentEventHandler espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | document |
Campo protetto | iSwApp |
Campo protetto | openModelViews |
Campo protetto | userAddin |
Torna su
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Campo DocumentEventHandler.document

Campo DocumentEventHandlerdocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected ModelDoc2 document
Protected document As ModelDoc2
protected:
ModelDoc2^ document
val mutable document: ModelDoc2

Valore del campo

ModelDoc2
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Campo DocumentEventHandler.iSwApp

Campo DocumentEventHandleriSwApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected ISldWorks iSwApp
Protected iSwApp As ISldWorks
protected:
ISldWorks^ iSwApp
val mutable iSwApp: ISldWorks

Valore del campo

ISldWorks
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Campo DocumentEventHandler.openModelViews

Campo DocumentEventHandleropenModelViews

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected Hashtable openModelViews
Protected openModelViews As Hashtable
protected:
Hashtable^ openModelViews
val mutable openModelViews: Hashtable

Valore del campo

Hashtable
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Campo DocumentEventHandler.userAddin

Campo DocumentEventHandleruserAddin

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected DedNetSwApp userAddin
Protected userAddin As DedNetSwApp
protected:
DedNetSwApp^ userAddin
val mutable userAddin: DedNetSwApp

Valore del campo

DedNetSwApp
Vedi anche

Documentazione

Classe DocumentEventHandler
Namespace DedNetSw


Classe DocView
Gerarchia di ereditarietà
SystemObject
DedNetSwDocView

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocView
Public Class DocView
public ref class DocView
type DocView = class end

Il tipo DocView espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocView |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers |
Metodo pubblico | DetachEventHandlers |
Metodo pubblico | OnDestroy |
Metodo pubblico | OnRepaint |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DocView

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocView(
    DedNetSwApp addin,
    ISldWorks sldwrk,
    IModelView mv,
    DocumentEventHandler doc
)
Public Sub New (
    addin As DedNetSwApp,
    sldwrk As ISldWorks,
    mv As IModelView,
    doc As DocumentEventHandler
)
public:
DocView(
    DedNetSwApp^ addin,
    ISldWorks^ sldwrk,
    IModelView^ mv,
    DocumentEventHandler^ doc
)
new :
        addin : DedNetSwApp *
        sldwrk : ISldWorks *
        mv : IModelView *
        doc : DocumentEventHandler -> DocView

Parametri

addin DedNetSwApp
sldwrk ISldWorks
mv IModelView
doc DocumentEventHandler
Vedi anche

Documentazione

Classe DocView
Namespace DedNetSw


Metodi di DocView

Il tipo DocView espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers |
Metodo pubblico | DetachEventHandlers |
Metodo pubblico | OnDestroy |
Metodo pubblico | OnRepaint |
Torna su
Vedi anche

Documentazione

Classe DocView
Namespace DedNetSw


Metodo DocView.AttachEventHandlers

Metodo DocViewAttachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AttachEventHandlers()
Public Function AttachEventHandlers As Boolean
public:
bool AttachEventHandlers()
member AttachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocView
Namespace DedNetSw


Metodo DocView.DetachEventHandlers

Metodo DocViewDetachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DetachEventHandlers()
Public Function DetachEventHandlers As Boolean
public:
bool DetachEventHandlers()
member DetachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocView
Namespace DedNetSw


Metodo DocView.OnDestroy

Metodo DocViewOnDestroy

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnDestroy(
    int destroyType
)
Public Function OnDestroy (
    destroyType As Integer
) As Integer
public:
int OnDestroy(
    int destroyType
)
member OnDestroy :
        destroyType : int -> int

Parametri

destroyType Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DocView
Namespace DedNetSw


Metodo DocView.OnRepaint

Metodo DocViewOnRepaint

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnRepaint(
    int repaintType
)
Public Function OnRepaint (
    repaintType As Integer
) As Integer
public:
int OnRepaint(
    int repaintType
)
member OnRepaint :
        repaintType : int -> int

Parametri

repaintType Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DocView
Namespace DedNetSw


Classe DrawingEventHandler
Gerarchia di ereditarietà
SystemObject
DedNetSwDocumentEventHandler
DedNetSwDrawingEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DrawingEventHandler : DocumentEventHandler
Public Class DrawingEventHandler
    Inherits DocumentEventHandler
public ref class DrawingEventHandler : public DocumentEventHandler
type DrawingEventHandler =
    class
        inherit DocumentEventHandler
    end

Il tipo DrawingEventHandler espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DrawingEventHandler |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers | (Sovrascrive DocumentEventHandlerAttachEventHandlers)
Metodo pubblico | ConnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | DetachEventHandlers | (Sovrascrive DocumentEventHandlerDetachEventHandlers)
Metodo pubblico | DetachModelViewEventHandler | (Ereditato da DocumentEventHandler)
Metodo pubblico | DisconnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | OnAddItemNotify |
Metodo pubblico | OnDestroy |
Metodo pubblico | OnFileSaveNotify |
Metodo pubblico | OnNewSelection |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | document | (Ereditato da DocumentEventHandler)
Campo protetto | iSwApp | (Ereditato da DocumentEventHandler)
Campo protetto | openModelViews | (Ereditato da DocumentEventHandler)
Campo protetto | userAddin | (Ereditato da DocumentEventHandler)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore DrawingEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DrawingEventHandler(
    ModelDoc2 modDoc,
    DedNetSwApp addin,
    ISldWorks sldwrk
)
Public Sub New (
    modDoc As ModelDoc2,
    addin As DedNetSwApp,
    sldwrk As ISldWorks
)
public:
DrawingEventHandler(
    ModelDoc2^ modDoc,
    DedNetSwApp^ addin,
    ISldWorks^ sldwrk
)
new :
        modDoc : ModelDoc2 *
        addin : DedNetSwApp *
        sldwrk : ISldWorks -> DrawingEventHandler

Parametri

modDoc ModelDoc2
addin DedNetSwApp
sldwrk ISldWorks
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodi di DrawingEventHandler

Il tipo DrawingEventHandler espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers | (Sovrascrive DocumentEventHandlerAttachEventHandlers)
Metodo pubblico | ConnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | DetachEventHandlers | (Sovrascrive DocumentEventHandlerDetachEventHandlers)
Metodo pubblico | DetachModelViewEventHandler | (Ereditato da DocumentEventHandler)
Metodo pubblico | DisconnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | OnAddItemNotify |
Metodo pubblico | OnDestroy |
Metodo pubblico | OnFileSaveNotify |
Metodo pubblico | OnNewSelection |
Torna su
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodo DrawingEventHandler.AttachEventHandlers

Metodo DrawingEventHandlerAttachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool AttachEventHandlers()
Public Overrides Function AttachEventHandlers As Boolean
public:
virtual bool AttachEventHandlers() override
abstract AttachEventHandlers : unit -> bool
override AttachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodo DrawingEventHandler.DetachEventHandlers

Metodo DrawingEventHandlerDetachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool DetachEventHandlers()
Public Overrides Function DetachEventHandlers As Boolean
public:
virtual bool DetachEventHandlers() override
abstract DetachEventHandlers : unit -> bool
override DetachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodo DrawingEventHandler.OnAddItemNotify

Metodo DrawingEventHandlerOnAddItemNotify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnAddItemNotify(
    int EntityType,
    string itemName
)
Public Function OnAddItemNotify (
    EntityType As Integer,
    itemName As String
) As Integer
public:
int OnAddItemNotify(
    int EntityType,
    String^ itemName
)
member OnAddItemNotify :
        EntityType : int *
        itemName : string -> int

Parametri

EntityType Int32
itemName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodo DrawingEventHandler.OnDestroy

Metodo DrawingEventHandlerOnDestroy

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnDestroy(
    int destroyType
)
Public Function OnDestroy (
    destroyType As Integer
) As Integer
public:
int OnDestroy(
    int destroyType
)
member OnDestroy :
        destroyType : int -> int

Parametri

destroyType Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodo DrawingEventHandler.OnFileSaveNotify

Metodo DrawingEventHandlerOnFileSaveNotify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnFileSaveNotify(
    string FileName
)
Public Function OnFileSaveNotify (
    FileName As String
) As Integer
public:
int OnFileSaveNotify(
    String^ FileName
)
member OnFileSaveNotify :
        FileName : string -> int

Parametri

FileName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Metodo DrawingEventHandler.OnNewSelection

Metodo DrawingEventHandlerOnNewSelection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnNewSelection()
Public Function OnNewSelection As Integer
public:
int OnNewSelection()
member OnNewSelection : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Campi di DrawingEventHandler

Il tipo DrawingEventHandler espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | document | (Ereditato da DocumentEventHandler)
Campo protetto | iSwApp | (Ereditato da DocumentEventHandler)
Campo protetto | openModelViews | (Ereditato da DocumentEventHandler)
Campo protetto | userAddin | (Ereditato da DocumentEventHandler)
Torna su
Vedi anche

Documentazione

Classe DrawingEventHandler
Namespace DedNetSw


Classe FileStateElement
Gerarchia di ereditarietà
SystemObject
DedNetSwFileStateElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElement
Public Class FileStateElement
public ref class FileStateElement
type FileStateElement = class end

Il tipo FileStateElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Data |
Proprietà pubblica | Description |
Proprietà pubblica | Document |
Proprietà pubblica | Embedded |
Proprietà pubblica | EmbeddedVirtual |
Proprietà pubblica | Existing |
Proprietà pubblica | ExtensionForced |
Proprietà pubblica | FullDocumentName |
Proprietà pubblica | FullFileName |
Proprietà pubblica | IsVirtual |
Proprietà pubblica | Missing |
Proprietà pubblica | NameOnly |
Proprietà pubblica | StateID |
Proprietà pubblica | StopScan |
Proprietà pubblica | SwComp |
Proprietà pubblica | SwDoc |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | RefreshElement |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Proprietà di FileStateElement

Il tipo FileStateElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Data |
Proprietà pubblica | Description |
Proprietà pubblica | Document |
Proprietà pubblica | Embedded |
Proprietà pubblica | EmbeddedVirtual |
Proprietà pubblica | Existing |
Proprietà pubblica | ExtensionForced |
Proprietà pubblica | FullDocumentName |
Proprietà pubblica | FullFileName |
Proprietà pubblica | IsVirtual |
Proprietà pubblica | Missing |
Proprietà pubblica | NameOnly |
Proprietà pubblica | StateID |
Proprietà pubblica | StopScan |
Proprietà pubblica | SwComp |
Proprietà pubblica | SwDoc |
Torna su
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Config

Proprietà FileStateElementConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Data

Proprietà FileStateElementData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Description

Proprietà FileStateElementDescription

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Document

Proprietà FileStateElementDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Embedded

Proprietà FileStateElementEmbedded

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Embedded { get; set; }
Public Property Embedded As Boolean
    Get
    Set
public:
property bool Embedded {
    bool get ();
    void set (bool value);
}
member Embedded : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.EmbeddedVirtual

Proprietà FileStateElementEmbeddedVirtual

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EmbeddedVirtual { get; set; }
Public Property EmbeddedVirtual As Boolean
    Get
    Set
public:
property bool EmbeddedVirtual {
    bool get ();
    void set (bool value);
}
member EmbeddedVirtual : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Existing

Proprietà FileStateElementExisting

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Existing { get; }
Public ReadOnly Property Existing As Boolean
    Get
public:
property bool Existing {
    bool get ();
}
member Existing : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.ExtensionForced

Proprietà FileStateElementExtensionForced

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ExtensionForced { get; set; }
Public Property ExtensionForced As String
    Get
    Set
public:
property String^ ExtensionForced {
    String^ get ();
    void set (String^ value);
}
member ExtensionForced : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.FullDocumentName

Proprietà FileStateElementFullDocumentName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullDocumentName { get; }
Public ReadOnly Property FullDocumentName As String
    Get
public:
property String^ FullDocumentName {
    String^ get ();
}
member FullDocumentName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.FullFileName

Proprietà FileStateElementFullFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.IsVirtual

Proprietà FileStateElementIsVirtual

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsVirtual { get; set; }
Public Property IsVirtual As Boolean
    Get
    Set
public:
property bool IsVirtual {
    bool get ();
    void set (bool value);
}
member IsVirtual : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.Missing

Proprietà FileStateElementMissing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Missing { get; set; }
Public Property Missing As Boolean
    Get
    Set
public:
property bool Missing {
    bool get ();
    void set (bool value);
}
member Missing : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.NameOnly

Proprietà FileStateElementNameOnly

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NameOnly { get; }
Public ReadOnly Property NameOnly As String
    Get
public:
property String^ NameOnly {
    String^ get ();
}
member NameOnly : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.StateID

Proprietà FileStateElementStateID

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int StateID { get; set; }
Public Property StateID As Integer
    Get
    Set
public:
property int StateID {
    int get ();
    void set (int value);
}
member StateID : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.StopScan

Proprietà FileStateElementStopScan

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool StopScan { get; set; }
Public Property StopScan As Boolean
    Get
    Set
public:
property bool StopScan {
    bool get ();
    void set (bool value);
}
member StopScan : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.SwComp

Proprietà FileStateElementSwComp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IComponent2 SwComp { get; set; }
Public Property SwComp As IComponent2
    Get
    Set
public:
property IComponent2^ SwComp {
    IComponent2^ get ();
    void set (IComponent2^ value);
}
member SwComp : IComponent2 with get, set

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Proprietà FileStateElement.SwDoc

Proprietà FileStateElementSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; set; }
Public Property SwDoc As IModelDoc2
    Get
    Set
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
    void set (IModelDoc2^ value);
}
member SwDoc : IModelDoc2 with get, set

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Metodi di FileStateElement

Il tipo FileStateElement espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | RefreshElement |
Torna su
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Metodo FileStateElement.Equals

Metodo FileStateElementEquals

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Metodo FileStateElement.RefreshElement

Metodo FileStateElementRefreshElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RefreshElement(
    bool reloadMoved
)
Public Sub RefreshElement (
    reloadMoved As Boolean
)
public:
void RefreshElement(
    bool reloadMoved
)
member RefreshElement :
        reloadMoved : bool -> unit

Parametri

reloadMoved Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetSw


Classe FileStateElementList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList FileStateElement
DedNetSwFileStateElementList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElementList : List<FileStateElement>
Public Class FileStateElementList
    Inherits List(Of FileStateElement)
public ref class FileStateElementList : public List<FileStateElement^>
type FileStateElementList =
    class
        inherit List<FileStateElement>
    end

Il tipo FileStateElementList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileStateElementList |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore FileStateElementList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList()
Public Sub New
public:
FileStateElementList()
new : unit -> FileStateElementList
Vedi anche

Documentazione

Classe FileStateElementList
Namespace DedNetSw


Classe FileStateManager
Gerarchia di ereditarietà
SystemObject
DedNetSwFileStateManager

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateManager
Public Class FileStateManager
public ref class FileStateManager
type FileStateManager = class end

Il tipo FileStateManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileStateManager |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | SwApp |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking |
Metodo pubblico | GetActiveElement |
Metodo pubblico | GetAnagStateImageKey |
Metodo pubblico | GetAnagStateName |
Metodo pubblico | GetAttr |
Metodo pubblico | GetChildrenElements |
Metodo pubblico | GetDocument |
Metodo pubblico | GetElement |
Metodo pubblico | GetMovedDocument |
Metodo pubblico | GetSelectionImageKey |
Metodo pubblico | GetStateImageKey |
Metodo pubblico | HasChildrenElements |
Metodo pubblico | IsDirty |
Metodo pubblico | MakeSwCommandContext |
Metodo protetto | OnElementActivatedEvent |
Metodo protetto | OnElementChangedEvent |
Metodo pubblico | OnElementDoubleClicked |
Metodo pubblico | OnElementsSelected |
Metodo pubblico | OnHotTrackElementClicked |
Metodo pubblico | RaiseElementActivatedEvent |
Metodo pubblico | RaiseElementChangedEvent |
Metodo pubblico | ReloadElementInformations |
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ElementActivatedEvent |
Evento pubblico | ElementChangedEvent |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore FileStateManager

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateManager(
    SldWorks swApp,
    IFileStateInformer informer
)
Public Sub New (
    swApp As SldWorks,
    informer As IFileStateInformer
)
public:
FileStateManager(
    SldWorks^ swApp,
    IFileStateInformer^ informer
)
new :
        swApp : SldWorks *
        informer : IFileStateInformer -> FileStateManager

Parametri

swApp SldWorks
informer IFileStateInformer
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Proprietà di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SwApp |
Torna su
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Proprietà FileStateManager.SwApp

Proprietà FileStateManagerSwApp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SldWorks SwApp { get; }
Public ReadOnly Property SwApp As SldWorks
    Get
public:
property SldWorks^ SwApp {
    SldWorks^ get ();
}
member SwApp : SldWorks with get

Valore della proprietà

SldWorks
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodi di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking |
Metodo pubblico | GetActiveElement |
Metodo pubblico | GetAnagStateImageKey |
Metodo pubblico | GetAnagStateName |
Metodo pubblico | GetAttr |
Metodo pubblico | GetChildrenElements |
Metodo pubblico | GetDocument |
Metodo pubblico | GetElement |
Metodo pubblico | GetMovedDocument |
Metodo pubblico | GetSelectionImageKey |
Metodo pubblico | GetStateImageKey |
Metodo pubblico | HasChildrenElements |
Metodo pubblico | IsDirty |
Metodo pubblico | MakeSwCommandContext |
Metodo protetto | OnElementActivatedEvent |
Metodo protetto | OnElementChangedEvent |
Metodo pubblico | OnElementDoubleClicked |
Metodo pubblico | OnElementsSelected |
Metodo pubblico | OnHotTrackElementClicked |
Metodo pubblico | RaiseElementActivatedEvent |
Metodo pubblico | RaiseElementChangedEvent |
Metodo pubblico | ReloadElementInformations |
Torna su
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.AllowHotTracking

Metodo FileStateManagerAllowHotTracking

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllowHotTracking(
    FileStateElement el
)
Public Function AllowHotTracking (
    el As FileStateElement
) As Boolean
public:
bool AllowHotTracking(
    FileStateElement^ el
)
member AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetActiveElement

Metodo FileStateManagerGetActiveElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetActiveElement()
Public Function GetActiveElement As FileStateElement
public:
FileStateElement^ GetActiveElement()
member GetActiveElement : unit -> FileStateElement

Valore di ritorno

FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetAnagStateImageKey

Metodo FileStateManagerGetAnagStateImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image GetAnagStateImageKey(
    FileStateElement el
)
Public Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
public:
Image^ GetAnagStateImageKey(
    FileStateElement^ el
)
member GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el FileStateElement

Valore di ritorno

Image
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetAnagStateName

Metodo FileStateManagerGetAnagStateName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAnagStateName(
    FileStateElement el
)
Public Function GetAnagStateName (
    el As FileStateElement
) As String
public:
String^ GetAnagStateName(
    FileStateElement^ el
)
member GetAnagStateName :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetAttr

Metodo FileStateManagerGetAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object GetAttr(
    FileStateElement el,
    string nome
)
Public Function GetAttr (
    el As FileStateElement,
    nome As String
) As Object
public:
Object^ GetAttr(
    FileStateElement^ el,
    String^ nome
)
member GetAttr :
        el : FileStateElement *
        nome : string -> Object

Parametri

el FileStateElement
nome String

Valore di ritorno

Object
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetChildrenElements

Metodo FileStateManagerGetChildrenElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList GetChildrenElements(
    FileStateElement el
)
Public Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
public:
FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
)
member GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el FileStateElement

Valore di ritorno

FileStateElementList
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetDocument

Metodo FileStateManagerGetDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetDocument(
    FileStateElement el
)
Public Function GetDocument (
    el As FileStateElement
) As DedDoc
public:
DedDoc^ GetDocument(
    FileStateElement^ el
)
member GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetElement

Metodo FileStateManagerGetElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetElement(
    string fullFileName,
    string fullDocumentName,
    string config = "*"
)
Public Function GetElement (
    fullFileName As String,
    fullDocumentName As String,
    Optional config As String = "*"
) As FileStateElement
public:
FileStateElement^ GetElement(
    String^ fullFileName,
    String^ fullDocumentName,
    String^ config = L"*"
)
member GetElement :
        fullFileName : string *
        fullDocumentName : string *
        ?config : string
(* Defaults:
        let _config = defaultArg config "*"
*)
-> FileStateElement

Parametri

fullFileName String
fullDocumentName String
config String (Optional)

Valore di ritorno

FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetMovedDocument

Metodo FileStateManagerGetMovedDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDocument(
    FileStateElement el
)
Public Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
public:
DedDoc^ GetMovedDocument(
    FileStateElement^ el
)
member GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetSelectionImageKey

Metodo FileStateManagerGetSelectionImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetSelectionImageKey(
    FileStateElement el
)
Public Function GetSelectionImageKey (
    el As FileStateElement
) As String
public:
String^ GetSelectionImageKey(
    FileStateElement^ el
)
member GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.GetStateImageKey

Metodo FileStateManagerGetStateImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetStateImageKey(
    FileStateElement el
)
Public Function GetStateImageKey (
    el As FileStateElement
) As String
public:
String^ GetStateImageKey(
    FileStateElement^ el
)
member GetStateImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.HasChildrenElements

Metodo FileStateManagerHasChildrenElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildrenElements(
    FileStateElement el
)
Public Function HasChildrenElements (
    el As FileStateElement
) As Boolean
public:
bool HasChildrenElements(
    FileStateElement^ el
)
member HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.IsDirty

Metodo FileStateManagerIsDirty

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty(
    FileStateElement el
)
Public Function IsDirty (
    el As FileStateElement
) As Boolean
public:
bool IsDirty(
    FileStateElement^ el
)
member IsDirty :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.MakeSwCommandContext

Metodo FileStateManagerMakeSwCommandContext

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwCommandContext MakeSwCommandContext(
    FileStateElementList elsList
)
Public Function MakeSwCommandContext (
    elsList As FileStateElementList
) As DedSwCommandContext
public:
DedSwCommandContext^ MakeSwCommandContext(
    FileStateElementList^ elsList
)
member MakeSwCommandContext :
        elsList : FileStateElementList -> DedSwCommandContext

Parametri

elsList FileStateElementList

Valore di ritorno

DedSwCommandContext
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.OnElementActivatedEvent

Metodo FileStateManagerOnElementActivatedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnElementActivatedEvent(
    bool restoreStatus
)
Protected Sub OnElementActivatedEvent (
    restoreStatus As Boolean
)
protected:
void OnElementActivatedEvent(
    bool restoreStatus
)
member OnElementActivatedEvent :
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.OnElementChangedEvent

Metodo FileStateManagerOnElementChangedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnElementChangedEvent(
    FileStateElement el
)
Protected Sub OnElementChangedEvent (
    el As FileStateElement
)
protected:
void OnElementChangedEvent(
    FileStateElement^ el
)
member OnElementChangedEvent :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.OnElementDoubleClicked

Metodo FileStateManagerOnElementDoubleClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementDoubleClicked(
    FileStateElement el
)
Public Sub OnElementDoubleClicked (
    el As FileStateElement
)
public:
void OnElementDoubleClicked(
    FileStateElement^ el
)
member OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.OnElementsSelected

Metodo FileStateManagerOnElementsSelected

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementsSelected(
    FileStateElementList elsList
)
Public Sub OnElementsSelected (
    elsList As FileStateElementList
)
public:
void OnElementsSelected(
    FileStateElementList^ elsList
)
member OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList FileStateElementList
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.OnHotTrackElementClicked

Metodo FileStateManagerOnHotTrackElementClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OnHotTrackElementClicked(
    FileStateElement el
)
Public Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
public:
bool OnHotTrackElementClicked(
    FileStateElement^ el
)
member OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.RaiseElementActivatedEvent

Metodo FileStateManagerRaiseElementActivatedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RaiseElementActivatedEvent(
    bool restoreStatus
)
Public Sub RaiseElementActivatedEvent (
    restoreStatus As Boolean
)
public:
void RaiseElementActivatedEvent(
    bool restoreStatus
)
member RaiseElementActivatedEvent :
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.RaiseElementChangedEvent

Metodo FileStateManagerRaiseElementChangedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RaiseElementChangedEvent(
    FileStateElement el
)
Public Sub RaiseElementChangedEvent (
    el As FileStateElement
)
public:
void RaiseElementChangedEvent(
    FileStateElement^ el
)
member RaiseElementChangedEvent :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Metodo FileStateManager.ReloadElementInformations

Metodo FileStateManagerReloadElementInformations

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ReloadElementInformations(
    FileStateElement el,
    bool reloadMoved
)
Public Sub ReloadElementInformations (
    el As FileStateElement,
    reloadMoved As Boolean
)
public:
void ReloadElementInformations(
    FileStateElement^ el,
    bool reloadMoved
)
member ReloadElementInformations :
        el : FileStateElement *
        reloadMoved : bool -> unit

Parametri

el FileStateElement
reloadMoved Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Eventi di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ElementActivatedEvent |
Evento pubblico | ElementChangedEvent |
Torna su
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Evento FileStateManager.ElementActivatedEvent

Evento FileStateManagerElementActivatedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event FileStateManagerActivateEventHandler ElementActivatedEvent
Public Event ElementActivatedEvent As FileStateManagerActivateEventHandler
public:
 event FileStateManagerActivateEventHandler^ ElementActivatedEvent {
    void add (FileStateManagerActivateEventHandler^ value);
    void remove (FileStateManagerActivateEventHandler^ value);
}
member ElementActivatedEvent : IEvent<FileStateManagerActivateEventHandler,
    EventArgs>

Valore

FileStateManagerActivateEventHandler
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Evento FileStateManager.ElementChangedEvent

Evento FileStateManagerElementChangedEvent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ElementChangedEvent
Public Event ElementChangedEvent As EventHandler
public:
 event EventHandler^ ElementChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ElementChangedEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetSw


Delegate FileStateManager.ActivateEventHandler

Delegate FileStateManagerActivateEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void ActivateEventHandler(
    bool restoreStatus
)
Public Delegate Sub ActivateEventHandler (
    restoreStatus As Boolean
)
public delegate void ActivateEventHandler(
    bool restoreStatus
)
type ActivateEventHandler =
    delegate of
        restoreStatus : bool -> unit

Parametri

restoreStatus Boolean
Vedi anche

Documentazione

Namespace DedNetSw


Classe FindNodesOperation
Gerarchia di ereditarietà
SystemObject
TreeListOperation
DedNetSwFindNodesOperation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindNodesOperation : TreeListOperation
Public Class FindNodesOperation
    Inherits TreeListOperation
public ref class FindNodesOperation : public TreeListOperation
type FindNodesOperation =
    class
        inherit TreeListOperation
    end

Il tipo FindNodesOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FindNodesOperation |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FoundNodes |
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore FindNodesOperation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FindNodesOperation(
    TreeListColumn column,
    Object value
)
Public Sub New (
    column As TreeListColumn,
    value As Object
)
public:
FindNodesOperation(
    TreeListColumn^ column,
    Object^ value
)
new :
        column : TreeListColumn *
        value : Object -> FindNodesOperation

Parametri

column TreeListColumn
value Object
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetSw


Proprietà di FindNodesOperation

Il tipo FindNodesOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FoundNodes |
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetSw


Proprietà FindNodesOperation.FoundNodes

Proprietà FindNodesOperationFoundNodes

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ArrayList FoundNodes { get; }
Public ReadOnly Property FoundNodes As ArrayList
    Get
public:
property ArrayList^ FoundNodes {
    ArrayList^ get ();
}
member FoundNodes : ArrayList with get

Valore della proprietà

ArrayList
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetSw


Metodi di FindNodesOperation

Il tipo FindNodesOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetSw


Metodo FindNodesOperation.Execute

Metodo FindNodesOperationExecute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void Execute(
    TreeListNode node
)
Public Overrides Sub Execute (
    node As TreeListNode
)
public:
virtual void Execute(
    TreeListNode^ node
) override
abstract Execute :
        node : TreeListNode -> unit
override Execute :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetSw


Interfaccia IFileStateInformer

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public interface IFileStateInformer
Public Interface IFileStateInformer
public interface class IFileStateInformer
type IFileStateInformer = interface end

Il tipo IFileStateInformer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking |
Metodo pubblico | GetActiveElement |
Metodo pubblico | GetAnagStateImageKey |
Metodo pubblico | GetAnagStateName |
Metodo pubblico | GetAttr |
Metodo pubblico | GetChildrenElements |
Metodo pubblico | GetData |
Metodo pubblico | GetDocument |
Metodo pubblico | GetMovedDocument |
Metodo pubblico | GetSelectionImageKey |
Metodo pubblico | GetState |
Metodo pubblico | GetStateImageKey |
Metodo pubblico | HasChildrenElements |
Metodo pubblico | IsDirty |
Metodo pubblico | MakeSwCommandContext |
Metodo pubblico | OnElementDoubleClicked |
Metodo pubblico | OnElementsSelected |
Metodo pubblico | OnHotTrackElementClicked |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Metodi di IFileStateInformer

Il tipo IFileStateInformer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking |
Metodo pubblico | GetActiveElement |
Metodo pubblico | GetAnagStateImageKey |
Metodo pubblico | GetAnagStateName |
Metodo pubblico | GetAttr |
Metodo pubblico | GetChildrenElements |
Metodo pubblico | GetData |
Metodo pubblico | GetDocument |
Metodo pubblico | GetMovedDocument |
Metodo pubblico | GetSelectionImageKey |
Metodo pubblico | GetState |
Metodo pubblico | GetStateImageKey |
Metodo pubblico | HasChildrenElements |
Metodo pubblico | IsDirty |
Metodo pubblico | MakeSwCommandContext |
Metodo pubblico | OnElementDoubleClicked |
Metodo pubblico | OnElementsSelected |
Metodo pubblico | OnHotTrackElementClicked |
Torna su
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.AllowHotTracking

Metodo IFileStateInformerAllowHotTracking

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool AllowHotTracking(
    FileStateElement el
)
Function AllowHotTracking (
    el As FileStateElement
) As Boolean
bool AllowHotTracking(
    FileStateElement^ el
)
abstract AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetActiveElement

Metodo IFileStateInformerGetActiveElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
FileStateElement GetActiveElement()
Function GetActiveElement As FileStateElement
FileStateElement^ GetActiveElement()
abstract GetActiveElement : unit -> FileStateElement

Valore di ritorno

FileStateElement
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetAnagStateImageKey

Metodo IFileStateInformerGetAnagStateImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
Image GetAnagStateImageKey(
    FileStateElement el
)
Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
Image^ GetAnagStateImageKey(
    FileStateElement^ el
)
abstract GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el FileStateElement

Valore di ritorno

Image
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetAnagStateName

Metodo IFileStateInformerGetAnagStateName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetAnagStateName(
    FileStateElement el
)
Function GetAnagStateName (
    el As FileStateElement
) As String
String^ GetAnagStateName(
    FileStateElement^ el
)
abstract GetAnagStateName :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetAttr

Metodo IFileStateInformerGetAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetAttr(
    FileStateElement el,
    string attrName
)
Function GetAttr (
    el As FileStateElement,
    attrName As String
) As String
String^ GetAttr(
    FileStateElement^ el,
    String^ attrName
)
abstract GetAttr :
        el : FileStateElement *
        attrName : string -> string

Parametri

el FileStateElement
attrName String

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetChildrenElements

Metodo IFileStateInformerGetChildrenElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
FileStateElementList GetChildrenElements(
    FileStateElement el
)
Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
)
abstract GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el FileStateElement

Valore di ritorno

FileStateElementList
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetData

Metodo IFileStateInformerGetData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedData GetData(
    FileStateElement el
)
Function GetData (
    el As FileStateElement
) As DedData
DedData^ GetData(
    FileStateElement^ el
)
abstract GetData :
        el : FileStateElement -> DedData

Parametri

el FileStateElement

Valore di ritorno

DedData
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetDocument

Metodo IFileStateInformerGetDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedDoc GetDocument(
    FileStateElement el
)
Function GetDocument (
    el As FileStateElement
) As DedDoc
DedDoc^ GetDocument(
    FileStateElement^ el
)
abstract GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetMovedDocument

Metodo IFileStateInformerGetMovedDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedDoc GetMovedDocument(
    FileStateElement el
)
Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
DedDoc^ GetMovedDocument(
    FileStateElement^ el
)
abstract GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el FileStateElement

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetSelectionImageKey

Metodo IFileStateInformerGetSelectionImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetSelectionImageKey(
    FileStateElement el
)
Function GetSelectionImageKey (
    el As FileStateElement
) As String
String^ GetSelectionImageKey(
    FileStateElement^ el
)
abstract GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetState

Metodo IFileStateInformerGetState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
int GetState(
    FileStateElement el
)
Function GetState (
    el As FileStateElement
) As Integer
int GetState(
    FileStateElement^ el
)
abstract GetState :
        el : FileStateElement -> int

Parametri

el FileStateElement

Valore di ritorno

Int32
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.GetStateImageKey

Metodo IFileStateInformerGetStateImageKey

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetStateImageKey(
    FileStateElement el
)
Function GetStateImageKey (
    el As FileStateElement
) As String
String^ GetStateImageKey(
    FileStateElement^ el
)
abstract GetStateImageKey :
        el : FileStateElement -> string

Parametri

el FileStateElement

Valore di ritorno

String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.HasChildrenElements

Metodo IFileStateInformerHasChildrenElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool HasChildrenElements(
    FileStateElement el
)
Function HasChildrenElements (
    el As FileStateElement
) As Boolean
bool HasChildrenElements(
    FileStateElement^ el
)
abstract HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.IsDirty

Metodo IFileStateInformerIsDirty

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IsDirty(
    FileStateElement el
)
Function IsDirty (
    el As FileStateElement
) As Boolean
bool IsDirty(
    FileStateElement^ el
)
abstract IsDirty :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.MakeSwCommandContext

Metodo IFileStateInformerMakeSwCommandContext

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedSwCommandContext MakeSwCommandContext(
    FileStateElementList elsList
)
Function MakeSwCommandContext (
    elsList As FileStateElementList
) As DedSwCommandContext
DedSwCommandContext^ MakeSwCommandContext(
    FileStateElementList^ elsList
)
abstract MakeSwCommandContext :
        elsList : FileStateElementList -> DedSwCommandContext

Parametri

elsList FileStateElementList

Valore di ritorno

DedSwCommandContext
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.OnElementDoubleClicked

Metodo IFileStateInformerOnElementDoubleClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void OnElementDoubleClicked(
    FileStateElement el
)
Sub OnElementDoubleClicked (
    el As FileStateElement
)
void OnElementDoubleClicked(
    FileStateElement^ el
)
abstract OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el FileStateElement
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.OnElementsSelected

Metodo IFileStateInformerOnElementsSelected

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void OnElementsSelected(
    FileStateElementList elsList
)
Sub OnElementsSelected (
    elsList As FileStateElementList
)
void OnElementsSelected(
    FileStateElementList^ elsList
)
abstract OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList FileStateElementList
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Metodo IFileStateInformer.OnHotTrackElementClicked

Metodo IFileStateInformerOnHotTrackElementClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool OnHotTrackElementClicked(
    FileStateElement el
)
Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
bool OnHotTrackElementClicked(
    FileStateElement^ el
)
abstract OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el FileStateElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetSw


Classe Lua
Gerarchia di ereditarietà
SystemObject
DedNetSwLua

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Lua
Public NotInheritable Class Lua
public ref class Lua abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Lua = class end

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CloseBomEnforcedOpenedDocs |
DedSwGetDistSaveStruct |
DedSwGetLolForDistSave |
DedSwOnOpenDocument |
TopEditAttrPost |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Metodi di Lua

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CloseBomEnforcedOpenedDocs |
DedSwGetDistSaveStruct |
DedSwGetLolForDistSave |
DedSwOnOpenDocument |
TopEditAttrPost |
Torna su
Vedi anche

Documentazione

Classe Lua
Namespace DedNetSw


Metodo Lua.CloseBomEnforcedOpenedDocs

Metodo LuaCloseBomEnforcedOpenedDocs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CloseBomEnforcedOpenedDocs()
Public Shared Sub CloseBomEnforcedOpenedDocs
public:
static void CloseBomEnforcedOpenedDocs()
static member CloseBomEnforcedOpenedDocs : unit -> unit
Vedi anche

Documentazione

Classe Lua
Namespace DedNetSw


Metodo Lua.DedSwGetDistSaveStruct

Metodo LuaDedSwGetDistSaveStruct

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedSwGetDistSaveStruct(
    LuaTable args
)
Public Shared Function DedSwGetDistSaveStruct (
    args As LuaTable
) As LuaTable
public:
static LuaTable^ DedSwGetDistSaveStruct(
    LuaTable^ args
)
static member DedSwGetDistSaveStruct :
        args : LuaTable -> LuaTable

Parametri

args LuaTable

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Lua
Namespace DedNetSw


Metodo Lua.DedSwGetLolForDistSave

Metodo LuaDedSwGetLolForDistSave

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedSwGetLolForDistSave(
    LuaTable arg
)
Public Shared Function DedSwGetLolForDistSave (
    arg As LuaTable
) As LuaTable
public:
static LuaTable^ DedSwGetLolForDistSave(
    LuaTable^ arg
)
static member DedSwGetLolForDistSave :
        arg : LuaTable -> LuaTable

Parametri

arg LuaTable

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Lua
Namespace DedNetSw


Metodo Lua.DedSwOnOpenDocument

Metodo LuaDedSwOnOpenDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedSwOnOpenDocument(
    string FullDocumentName,
    DedEventTimeEnum BeforeOrAfter
)
Public Shared Sub DedSwOnOpenDocument (
    FullDocumentName As String,
    BeforeOrAfter As DedEventTimeEnum
)
public:
static void DedSwOnOpenDocument(
    String^ FullDocumentName,
    DedEventTimeEnum BeforeOrAfter
)
static member DedSwOnOpenDocument :
        FullDocumentName : string *
        BeforeOrAfter : DedEventTimeEnum -> unit

Parametri

FullDocumentName String
BeforeOrAfter DedEventTimeEnum
Vedi anche

Documentazione

Classe Lua
Namespace DedNetSw


Metodo Lua.TopEditAttrPost

Metodo LuaTopEditAttrPost

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void TopEditAttrPost(
    Object prt
)
Public Shared Sub TopEditAttrPost (
    prt As Object
)
public:
static void TopEditAttrPost(
    Object^ prt
)
static member TopEditAttrPost :
        prt : Object -> unit

Parametri

prt Object
Vedi anche

Documentazione

Classe Lua
Namespace DedNetSw


Classe ModifyingDocumentInfo
Gerarchia di ereditarietà
SystemObject
DedNetSwModifyingDocumentInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentInfo
Public Class ModifyingDocumentInfo
public ref class ModifyingDocumentInfo
type ModifyingDocumentInfo = class end

Il tipo ModifyingDocumentInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentInfo(String) |
Metodo pubblico | ModifyingDocumentInfo(String, String) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask |
Proprietà pubblica | CurrentStateDescription |
Proprietà pubblica | Datas |
Proprietà pubblica | DedDoc |
Proprietà pubblica | FullFileName |
Proprietà pubblica | HasDatas |
Proprietà pubblica | HasDocument |
Proprietà pubblica | HasToBeCheckedOut |
Proprietà pubblica | HasToBeUpdated |
Proprietà pubblica | IsCheckedIn |
Proprietà pubblica | IsCheckOutAble |
Proprietà pubblica | NeedReload |
Proprietà pubblica | UserCanModify |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore ModifyingDocumentInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentInfo(String) |
Metodo pubblico | ModifyingDocumentInfo(String, String) |
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Costruttore ModifyingDocumentInfo(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfo(
    string fullfileName
)
Public Sub New (
    fullfileName As String
)
public:
ModifyingDocumentInfo(
    String^ fullfileName
)
new :
        fullfileName : string -> ModifyingDocumentInfo

Parametri

fullfileName String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Overload di ModifyingDocumentInfo
Namespace DedNetSw


Costruttore ModifyingDocumentInfo(String, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfo(
    string fullfileName,
    string state
)
Public Sub New (
    fullfileName As String,
    state As String
)
public:
ModifyingDocumentInfo(
    String^ fullfileName,
    String^ state
)
new :
        fullfileName : string *
        state : string -> ModifyingDocumentInfo

Parametri

fullfileName String
state String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Overload di ModifyingDocumentInfo
Namespace DedNetSw


Proprietà di ModifyingDocumentInfo

Il tipo ModifyingDocumentInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask |
Proprietà pubblica | CurrentStateDescription |
Proprietà pubblica | Datas |
Proprietà pubblica | DedDoc |
Proprietà pubblica | FullFileName |
Proprietà pubblica | HasDatas |
Proprietà pubblica | HasDocument |
Proprietà pubblica | HasToBeCheckedOut |
Proprietà pubblica | HasToBeUpdated |
Proprietà pubblica | IsCheckedIn |
Proprietà pubblica | IsCheckOutAble |
Proprietà pubblica | NeedReload |
Proprietà pubblica | UserCanModify |
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.Ask

Proprietà ModifyingDocumentInfoAsk

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Ask { get; }
Public ReadOnly Property Ask As Boolean
    Get
public:
property bool Ask {
    bool get ();
}
member Ask : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.CurrentStateDescription

Proprietà ModifyingDocumentInfoCurrentStateDescription

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string CurrentStateDescription { get; }
Public ReadOnly Property CurrentStateDescription As String
    Get
public:
property String^ CurrentStateDescription {
    String^ get ();
}
member CurrentStateDescription : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.Datas

Proprietà ModifyingDocumentInfoDatas

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; }
Public ReadOnly Property Datas As DedDataList
    Get
public:
property DedDataList^ Datas {
    DedDataList^ get ();
}
member Datas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.DedDoc

Proprietà ModifyingDocumentInfoDedDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.FullFileName

Proprietà ModifyingDocumentInfoFullFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.HasDatas

Proprietà ModifyingDocumentInfoHasDatas

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDatas { get; }
Public ReadOnly Property HasDatas As Boolean
    Get
public:
property bool HasDatas {
    bool get ();
}
member HasDatas : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.HasDocument

Proprietà ModifyingDocumentInfoHasDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDocument { get; }
Public ReadOnly Property HasDocument As Boolean
    Get
public:
property bool HasDocument {
    bool get ();
}
member HasDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.HasToBeCheckedOut

Proprietà ModifyingDocumentInfoHasToBeCheckedOut

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasToBeCheckedOut { get; set; }
Public Property HasToBeCheckedOut As Boolean
    Get
    Set
public:
property bool HasToBeCheckedOut {
    bool get ();
    void set (bool value);
}
member HasToBeCheckedOut : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.HasToBeUpdated

Proprietà ModifyingDocumentInfoHasToBeUpdated

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasToBeUpdated { get; }
Public ReadOnly Property HasToBeUpdated As Boolean
    Get
public:
property bool HasToBeUpdated {
    bool get ();
}
member HasToBeUpdated : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.IsCheckedIn

Proprietà ModifyingDocumentInfoIsCheckedIn

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedIn { get; }
Public ReadOnly Property IsCheckedIn As Boolean
    Get
public:
property bool IsCheckedIn {
    bool get ();
}
member IsCheckedIn : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.IsCheckOutAble

Proprietà ModifyingDocumentInfoIsCheckOutAble

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckOutAble { get; }
Public ReadOnly Property IsCheckOutAble As Boolean
    Get
public:
property bool IsCheckOutAble {
    bool get ();
}
member IsCheckOutAble : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.NeedReload

Proprietà ModifyingDocumentInfoNeedReload

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NeedReload { get; }
Public ReadOnly Property NeedReload As Boolean
    Get
public:
property bool NeedReload {
    bool get ();
}
member NeedReload : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Proprietà ModifyingDocumentInfo.UserCanModify

Proprietà ModifyingDocumentInfoUserCanModify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanModify { get; }
Public ReadOnly Property UserCanModify As Boolean
    Get
public:
property bool UserCanModify {
    bool get ();
}
member UserCanModify : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetSw


Classe ModifyingDocumentInfoList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ModifyingDocumentInfo
DedNetSwModifyingDocumentInfoList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentInfoList : List<ModifyingDocumentInfo>
Public Class ModifyingDocumentInfoList
    Inherits List(Of ModifyingDocumentInfo)
public ref class ModifyingDocumentInfoList : public List<ModifyingDocumentInfo^>
type ModifyingDocumentInfoList =
    class
        inherit List<ModifyingDocumentInfo>
    end

Il tipo ModifyingDocumentInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentInfoList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask |
Proprietà pubblica | AskList |
Proprietà pubblica | CannotModifyList |
Proprietà pubblica | HasToBeUpdated |
Proprietà pubblica | HasToBeUpdatedList |
Proprietà pubblica | UserCanModify |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore ModifyingDocumentInfoList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList()
Public Sub New
public:
ModifyingDocumentInfoList()
new : unit -> ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà di ModifyingDocumentInfoList

Il tipo ModifyingDocumentInfoList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask |
Proprietà pubblica | AskList |
Proprietà pubblica | CannotModifyList |
Proprietà pubblica | HasToBeUpdated |
Proprietà pubblica | HasToBeUpdatedList |
Proprietà pubblica | UserCanModify |
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà ModifyingDocumentInfoList.Ask

Proprietà ModifyingDocumentInfoListAsk

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Ask { get; }
Public ReadOnly Property Ask As Boolean
    Get
public:
property bool Ask {
    bool get ();
}
member Ask : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà ModifyingDocumentInfoList.AskList

Proprietà ModifyingDocumentInfoListAskList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList AskList { get; }
Public ReadOnly Property AskList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ AskList {
    ModifyingDocumentInfoList^ get ();
}
member AskList : ModifyingDocumentInfoList with get

Valore della proprietà

ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà ModifyingDocumentInfoList.CannotModifyList

Proprietà ModifyingDocumentInfoListCannotModifyList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList CannotModifyList { get; }
Public ReadOnly Property CannotModifyList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ CannotModifyList {
    ModifyingDocumentInfoList^ get ();
}
member CannotModifyList : ModifyingDocumentInfoList with get

Valore della proprietà

ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà ModifyingDocumentInfoList.HasToBeUpdated

Proprietà ModifyingDocumentInfoListHasToBeUpdated

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasToBeUpdated { get; }
Public ReadOnly Property HasToBeUpdated As Boolean
    Get
public:
property bool HasToBeUpdated {
    bool get ();
}
member HasToBeUpdated : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà ModifyingDocumentInfoList.HasToBeUpdatedList

Proprietà ModifyingDocumentInfoListHasToBeUpdatedList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList HasToBeUpdatedList { get; }
Public ReadOnly Property HasToBeUpdatedList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ HasToBeUpdatedList {
    ModifyingDocumentInfoList^ get ();
}
member HasToBeUpdatedList : ModifyingDocumentInfoList with get

Valore della proprietà

ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Proprietà ModifyingDocumentInfoList.UserCanModify

Proprietà ModifyingDocumentInfoListUserCanModify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanModify { get; }
Public ReadOnly Property UserCanModify As Boolean
    Get
public:
property bool UserCanModify {
    bool get ();
}
member UserCanModify : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetSw


Classe OperationPanelExecuter
Gerarchia di ereditarietà
SystemObject
DedNetSwOperationPanelExecuter

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OperationPanelExecuter
Public Class OperationPanelExecuter
public ref class OperationPanelExecuter
type OperationPanelExecuter = class end

Il tipo OperationPanelExecuter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OperationPanelExecuter |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Execute |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | RefreshAttribute |
Campo pubblico | RefreshDependencies |
Campo pubblico | RefreshDependenciesAndRestoreStatus |
Campo pubblico | RefreshDocAssistant |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore OperationPanelExecuter

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OperationPanelExecuter()
Public Sub New
public:
OperationPanelExecuter()
new : unit -> OperationPanelExecuter
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Metodi di OperationPanelExecuter

Il tipo OperationPanelExecuter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Execute |
Torna su
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Metodo OperationPanelExecuter.Execute

Metodo OperationPanelExecuterExecute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Execute()
Public Sub Execute
public:
void Execute()
member Execute : unit -> unit
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Campi di OperationPanelExecuter

Il tipo OperationPanelExecuter espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | RefreshAttribute |
Campo pubblico | RefreshDependencies |
Campo pubblico | RefreshDependenciesAndRestoreStatus |
Campo pubblico | RefreshDocAssistant |
Torna su
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Campo OperationPanelExecuter.RefreshAttribute

Campo OperationPanelExecuterRefreshAttribute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshAttribute
Public RefreshAttribute As Boolean
public:
bool RefreshAttribute
val mutable RefreshAttribute: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Campo OperationPanelExecuter.RefreshDependencies

Campo OperationPanelExecuterRefreshDependencies

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshDependencies
Public RefreshDependencies As Boolean
public:
bool RefreshDependencies
val mutable RefreshDependencies: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Campo OperationPanelExecuter.RefreshDependenciesAndRestoreStatus

Campo OperationPanelExecuterRefreshDependenciesAndRestoreStatus

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshDependenciesAndRestoreStatus
Public RefreshDependenciesAndRestoreStatus As Boolean
public:
bool RefreshDependenciesAndRestoreStatus
val mutable RefreshDependenciesAndRestoreStatus: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Campo OperationPanelExecuter.RefreshDocAssistant

Campo OperationPanelExecuterRefreshDocAssistant

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshDocAssistant
Public RefreshDocAssistant As Boolean
public:
bool RefreshDocAssistant
val mutable RefreshDocAssistant: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe OperationPanelExecuter
Namespace DedNetSw


Classe Options
Gerarchia di ereditarietà
SystemObject
DedNetSwOptions

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Options
Public Class Options
public ref class Options
type Options = class end

Il tipo Options espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Options |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddAssociatedFilesCreatingNewRep |
Proprietà pubblica | AlignDataNotWorkingOnDocument |
Proprietà pubblica | AllowSaveDistOnRappConfig |
Proprietà pubblica | CancelStartingState |
Proprietà pubblica | CheckDrawingReferenceCoherence |
Proprietà pubblica | ConsiderVirtualSearchingCancelState |
Proprietà pubblica | ContextSensitiveToolBar |
Proprietà pubblica | DisableAeroPeek |
Proprietà pubblica | EditAllConf |
Proprietà pubblica | ExecuteFindBrowserOnEditDocument |
Proprietà pubblica | ExecuteMultilevelCancelStartingStateCheck |
Proprietà pubblica | ExecuteParentCheckOnRemovingApprovation |
Proprietà pubblica | ExecuteSingleChangeOnAllConfigurations |
Proprietà pubblica | HideDirtyHighlight |
Proprietà pubblica | OnFileDirtyActiveBehaviour |
Proprietà pubblica | QuickDocChangeStateMode |
Proprietà pubblica | RefreshDocumentMassOnCheckIn |
Proprietà pubblica | RestrictSaveDistApprovedConfiguration |
Proprietà pubblica | RestrictSaveDistOutOfDateConfiguration |
Proprietà pubblica | RestrictSaveDistPendingApprovalConfiguration |
Proprietà pubblica | RestrictSaveDistUnchangeableConfiguration |
Proprietà pubblica | RestrictSaveDistWritableOutOfDateConfiguration |
Proprietà pubblica | SaveDistChildrenRestrictionConfiguration |
Proprietà pubblica | SaveDistOnApproved |
Proprietà pubblica | TimeSaverMode |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Options

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Options()
Public Sub New
public:
Options()
new : unit -> Options
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà di Options

Il tipo Options espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddAssociatedFilesCreatingNewRep |
Proprietà pubblica | AlignDataNotWorkingOnDocument |
Proprietà pubblica | AllowSaveDistOnRappConfig |
Proprietà pubblica | CancelStartingState |
Proprietà pubblica | CheckDrawingReferenceCoherence |
Proprietà pubblica | ConsiderVirtualSearchingCancelState |
Proprietà pubblica | ContextSensitiveToolBar |
Proprietà pubblica | DisableAeroPeek |
Proprietà pubblica | EditAllConf |
Proprietà pubblica | ExecuteFindBrowserOnEditDocument |
Proprietà pubblica | ExecuteMultilevelCancelStartingStateCheck |
Proprietà pubblica | ExecuteParentCheckOnRemovingApprovation |
Proprietà pubblica | ExecuteSingleChangeOnAllConfigurations |
Proprietà pubblica | HideDirtyHighlight |
Proprietà pubblica | OnFileDirtyActiveBehaviour |
Proprietà pubblica | QuickDocChangeStateMode |
Proprietà pubblica | RefreshDocumentMassOnCheckIn |
Proprietà pubblica | RestrictSaveDistApprovedConfiguration |
Proprietà pubblica | RestrictSaveDistOutOfDateConfiguration |
Proprietà pubblica | RestrictSaveDistPendingApprovalConfiguration |
Proprietà pubblica | RestrictSaveDistUnchangeableConfiguration |
Proprietà pubblica | RestrictSaveDistWritableOutOfDateConfiguration |
Proprietà pubblica | SaveDistChildrenRestrictionConfiguration |
Proprietà pubblica | SaveDistOnApproved |
Proprietà pubblica | TimeSaverMode |
Torna su
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.AddAssociatedFilesCreatingNewRep

Proprietà OptionsAddAssociatedFilesCreatingNewRep

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AddAssociatedFilesCreatingNewRep { get; set; }
Public Property AddAssociatedFilesCreatingNewRep As Boolean
    Get
    Set
public:
property bool AddAssociatedFilesCreatingNewRep {
    bool get ();
    void set (bool value);
}
member AddAssociatedFilesCreatingNewRep : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.AlignDataNotWorkingOnDocument

Proprietà OptionsAlignDataNotWorkingOnDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlignDataNotWorkingOnDocument { get; set; }
Public Property AlignDataNotWorkingOnDocument As Boolean
    Get
    Set
public:
property bool AlignDataNotWorkingOnDocument {
    bool get ();
    void set (bool value);
}
member AlignDataNotWorkingOnDocument : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.AllowSaveDistOnRappConfig

Proprietà OptionsAllowSaveDistOnRappConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllowSaveDistOnRappConfig { get; set; }
Public Property AllowSaveDistOnRappConfig As Boolean
    Get
    Set
public:
property bool AllowSaveDistOnRappConfig {
    bool get ();
    void set (bool value);
}
member AllowSaveDistOnRappConfig : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.CancelStartingState

Proprietà OptionsCancelStartingState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OptionsCancelStartingStateConfiguration CancelStartingState { get; set; }
Public Property CancelStartingState As OptionsCancelStartingStateConfiguration
    Get
    Set
public:
property OptionsCancelStartingStateConfiguration^ CancelStartingState {
    OptionsCancelStartingStateConfiguration^ get ();
    void set (OptionsCancelStartingStateConfiguration^ value);
}
member CancelStartingState : OptionsCancelStartingStateConfiguration with get, set

Valore della proprietà

OptionsCancelStartingStateConfiguration
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.CheckDrawingReferenceCoherence

Proprietà OptionsCheckDrawingReferenceCoherence

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CheckDrawingReferenceCoherence { get; set; }
Public Property CheckDrawingReferenceCoherence As Boolean
    Get
    Set
public:
property bool CheckDrawingReferenceCoherence {
    bool get ();
    void set (bool value);
}
member CheckDrawingReferenceCoherence : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.ConsiderVirtualSearchingCancelState

Proprietà OptionsConsiderVirtualSearchingCancelState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ConsiderVirtualSearchingCancelState { get; set; }
Public Property ConsiderVirtualSearchingCancelState As Boolean
    Get
    Set
public:
property bool ConsiderVirtualSearchingCancelState {
    bool get ();
    void set (bool value);
}
member ConsiderVirtualSearchingCancelState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.ContextSensitiveToolBar

Proprietà OptionsContextSensitiveToolBar

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ContextSensitiveToolBar { get; set; }
Public Property ContextSensitiveToolBar As Boolean
    Get
    Set
public:
property bool ContextSensitiveToolBar {
    bool get ();
    void set (bool value);
}
member ContextSensitiveToolBar : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.DisableAeroPeek

Proprietà OptionsDisableAeroPeek

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DisableAeroPeek { get; set; }
Public Property DisableAeroPeek As Boolean
    Get
    Set
public:
property bool DisableAeroPeek {
    bool get ();
    void set (bool value);
}
member DisableAeroPeek : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.EditAllConf

Proprietà OptionsEditAllConf

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetSwAppEditAllConfigurationBehaviour EditAllConf { get; set; }
Public Property EditAllConf As DedNetSwAppEditAllConfigurationBehaviour
    Get
    Set
public:
property DedNetSwAppEditAllConfigurationBehaviour EditAllConf {
    DedNetSwAppEditAllConfigurationBehaviour get ();
    void set (DedNetSwAppEditAllConfigurationBehaviour value);
}
member EditAllConf : DedNetSwAppEditAllConfigurationBehaviour with get, set

Valore della proprietà

DedNetSwAppEditAllConfigurationBehaviour
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.ExecuteFindBrowserOnEditDocument

Proprietà OptionsExecuteFindBrowserOnEditDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteFindBrowserOnEditDocument { get; set; }
Public Property ExecuteFindBrowserOnEditDocument As Boolean
    Get
    Set
public:
property bool ExecuteFindBrowserOnEditDocument {
    bool get ();
    void set (bool value);
}
member ExecuteFindBrowserOnEditDocument : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.ExecuteMultilevelCancelStartingStateCheck

Proprietà OptionsExecuteMultilevelCancelStartingStateCheck

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteMultilevelCancelStartingStateCheck { get; set; }
Public Property ExecuteMultilevelCancelStartingStateCheck As Boolean
    Get
    Set
public:
property bool ExecuteMultilevelCancelStartingStateCheck {
    bool get ();
    void set (bool value);
}
member ExecuteMultilevelCancelStartingStateCheck : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.ExecuteParentCheckOnRemovingApprovation

Proprietà OptionsExecuteParentCheckOnRemovingApprovation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteParentCheckOnRemovingApprovation { get; set; }
Public Property ExecuteParentCheckOnRemovingApprovation As Boolean
    Get
    Set
public:
property bool ExecuteParentCheckOnRemovingApprovation {
    bool get ();
    void set (bool value);
}
member ExecuteParentCheckOnRemovingApprovation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.ExecuteSingleChangeOnAllConfigurations

Proprietà OptionsExecuteSingleChangeOnAllConfigurations

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteSingleChangeOnAllConfigurations { get; set; }
Public Property ExecuteSingleChangeOnAllConfigurations As Boolean
    Get
    Set
public:
property bool ExecuteSingleChangeOnAllConfigurations {
    bool get ();
    void set (bool value);
}
member ExecuteSingleChangeOnAllConfigurations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.HideDirtyHighlight

Proprietà OptionsHideDirtyHighlight

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HideDirtyHighlight { get; set; }
Public Property HideDirtyHighlight As Boolean
    Get
    Set
public:
property bool HideDirtyHighlight {
    bool get ();
    void set (bool value);
}
member HideDirtyHighlight : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.OnFileDirtyActiveBehaviour

Proprietà OptionsOnFileDirtyActiveBehaviour

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetSwAppOnFileDirtyBehaviour OnFileDirtyActiveBehaviour { get; set; }
Public Property OnFileDirtyActiveBehaviour As DedNetSwAppOnFileDirtyBehaviour
    Get
    Set
public:
property DedNetSwAppOnFileDirtyBehaviour OnFileDirtyActiveBehaviour {
    DedNetSwAppOnFileDirtyBehaviour get ();
    void set (DedNetSwAppOnFileDirtyBehaviour value);
}
member OnFileDirtyActiveBehaviour : DedNetSwAppOnFileDirtyBehaviour with get, set

Valore della proprietà

DedNetSwAppOnFileDirtyBehaviour
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.QuickDocChangeStateMode

Proprietà OptionsQuickDocChangeStateMode

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool QuickDocChangeStateMode { get; set; }
Public Property QuickDocChangeStateMode As Boolean
    Get
    Set
public:
property bool QuickDocChangeStateMode {
    bool get ();
    void set (bool value);
}
member QuickDocChangeStateMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.RefreshDocumentMassOnCheckIn

Proprietà OptionsRefreshDocumentMassOnCheckIn

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshDocumentMassOnCheckIn { get; set; }
Public Property RefreshDocumentMassOnCheckIn As Boolean
    Get
    Set
public:
property bool RefreshDocumentMassOnCheckIn {
    bool get ();
    void set (bool value);
}
member RefreshDocumentMassOnCheckIn : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.RestrictSaveDistApprovedConfiguration

Proprietà OptionsRestrictSaveDistApprovedConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistApprovedConfiguration { get; set; }
Public Property RestrictSaveDistApprovedConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistApprovedConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistApprovedConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.RestrictSaveDistOutOfDateConfiguration

Proprietà OptionsRestrictSaveDistOutOfDateConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistOutOfDateConfiguration { get; set; }
Public Property RestrictSaveDistOutOfDateConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistOutOfDateConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistOutOfDateConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.RestrictSaveDistPendingApprovalConfiguration

Proprietà OptionsRestrictSaveDistPendingApprovalConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistPendingApprovalConfiguration { get; set; }
Public Property RestrictSaveDistPendingApprovalConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistPendingApprovalConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistPendingApprovalConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.RestrictSaveDistUnchangeableConfiguration

Proprietà OptionsRestrictSaveDistUnchangeableConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistUnchangeableConfiguration { get; set; }
Public Property RestrictSaveDistUnchangeableConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistUnchangeableConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistUnchangeableConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.RestrictSaveDistWritableOutOfDateConfiguration

Proprietà OptionsRestrictSaveDistWritableOutOfDateConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistWritableOutOfDateConfiguration { get; set; }
Public Property RestrictSaveDistWritableOutOfDateConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistWritableOutOfDateConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistWritableOutOfDateConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionConfiguration

Proprietà OptionsSaveDistChildrenRestrictionConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OptionsSaveDistChildrenRestrictionStatusConfiguration SaveDistChildrenRestrictionConfiguration { get; set; }
Public Property SaveDistChildrenRestrictionConfiguration As OptionsSaveDistChildrenRestrictionStatusConfiguration
    Get
    Set
public:
property OptionsSaveDistChildrenRestrictionStatusConfiguration^ SaveDistChildrenRestrictionConfiguration {
    OptionsSaveDistChildrenRestrictionStatusConfiguration^ get ();
    void set (OptionsSaveDistChildrenRestrictionStatusConfiguration^ value);
}
member SaveDistChildrenRestrictionConfiguration : OptionsSaveDistChildrenRestrictionStatusConfiguration with get, set

Valore della proprietà

OptionsSaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.SaveDistOnApproved

Proprietà OptionsSaveDistOnApproved

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SaveDistOnApproved { get; set; }
Public Property SaveDistOnApproved As Boolean
    Get
    Set
public:
property bool SaveDistOnApproved {
    bool get ();
    void set (bool value);
}
member SaveDistOnApproved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Proprietà Options.TimeSaverMode

Proprietà OptionsTimeSaverMode

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool TimeSaverMode { get; set; }
Public Property TimeSaverMode As Boolean
    Get
    Set
public:
property bool TimeSaverMode {
    bool get ();
    void set (bool value);
}
member TimeSaverMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetSw


Classe Options.CancelStartingStateConfiguration

Classe OptionsCancelStartingStateConfiguration
Gerarchia di ereditarietà
SystemObject
DedNetSwOptionsCancelStartingStateConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CancelStartingStateConfiguration
Public Class CancelStartingStateConfiguration
public ref class CancelStartingStateConfiguration
type CancelStartingStateConfiguration = class end

Il tipo OptionsCancelStartingStateConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsCancelStartingStateConfiguration |
Metodo pubblico | OptionsCancelStartingStateConfiguration(OptionsCancelStartingStateConfiguration) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Proprietà pubblica | Working |
Torna su
Metodi
 | Nome | Descrizione
 | FromDescriptor |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Options.CancelStartingStateConfiguration

Costruttore OptionsCancelStartingStateConfiguration
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OptionsCancelStartingStateConfiguration |
Metodo pubblico | OptionsCancelStartingStateConfiguration(OptionsCancelStartingStateConfiguration) |
Torna su
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Costruttore Options.CancelStartingStateConfiguration

Costruttore OptionsCancelStartingStateConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CancelStartingStateConfiguration()
Public Sub New
public:
CancelStartingStateConfiguration()
new : unit -> CancelStartingStateConfiguration
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Overload di OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Costruttore Options.CancelStartingStateConfiguration(Options.CancelStartingStateConfiguration)

Costruttore OptionsCancelStartingStateConfiguration(OptionsCancelStartingStateConfiguration)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CancelStartingStateConfiguration(
    OptionsCancelStartingStateConfiguration obj
)
Public Sub New (
    obj As OptionsCancelStartingStateConfiguration
)
public:
CancelStartingStateConfiguration(
    OptionsCancelStartingStateConfiguration^ obj
)
new :
        obj : OptionsCancelStartingStateConfiguration -> CancelStartingStateConfiguration

Parametri

obj OptionsCancelStartingStateConfiguration
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Overload di OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Proprietà di CancelStartingStateConfiguration

Il tipo OptionsCancelStartingStateConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Proprietà pubblica | Working |
Torna su
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Proprietà Options.CancelStartingStateConfiguration.OutOfDate

Proprietà OptionsCancelStartingStateConfigurationOutOfDate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutOfDate { get; set; }
Public Property OutOfDate As Boolean
    Get
    Set
public:
property bool OutOfDate {
    bool get ();
    void set (bool value);
}
member OutOfDate : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Proprietà Options.CancelStartingStateConfiguration.PendingApproval

Proprietà OptionsCancelStartingStateConfigurationPendingApproval

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PendingApproval { get; set; }
Public Property PendingApproval As Boolean
    Get
    Set
public:
property bool PendingApproval {
    bool get ();
    void set (bool value);
}
member PendingApproval : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Proprietà Options.CancelStartingStateConfiguration.Unchangeable

Proprietà OptionsCancelStartingStateConfigurationUnchangeable

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Unchangeable { get; set; }
Public Property Unchangeable As Boolean
    Get
    Set
public:
property bool Unchangeable {
    bool get ();
    void set (bool value);
}
member Unchangeable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Proprietà Options.CancelStartingStateConfiguration.Working

Proprietà OptionsCancelStartingStateConfigurationWorking

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Working { get; set; }
Public Property Working As Boolean
    Get
    Set
public:
property bool Working {
    bool get ();
    void set (bool value);
}
member Working : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Metodi di CancelStartingStateConfiguration

Il tipo OptionsCancelStartingStateConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | FromDescriptor |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Metodo Options.CancelStartingStateConfiguration.FromDescriptor

Metodo OptionsCancelStartingStateConfigurationFromDescriptor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OptionsCancelStartingStateConfiguration FromDescriptor(
    string cancelStatesDescriptor
)
Public Shared Function FromDescriptor (
    cancelStatesDescriptor As String
) As OptionsCancelStartingStateConfiguration
public:
static OptionsCancelStartingStateConfiguration^ FromDescriptor(
    String^ cancelStatesDescriptor
)
static member FromDescriptor :
        cancelStatesDescriptor : string -> OptionsCancelStartingStateConfiguration

Parametri

cancelStatesDescriptor String

Valore di ritorno

OptionsCancelStartingStateConfiguration
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Metodo Options.CancelStartingStateConfiguration.ToString

Metodo OptionsCancelStartingStateConfigurationToString

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetSw


Classe Options.LocalizedCategoryAttribute

Classe OptionsLocalizedCategoryAttribute
Gerarchia di ereditarietà
SystemObject
SystemAttribute
System.ComponentModelCategoryAttribute
DedNetSwOptionsLocalizedCategoryAttribute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LocalizedCategoryAttribute : CategoryAttribute
Public Class LocalizedCategoryAttribute
    Inherits CategoryAttribute
public ref class LocalizedCategoryAttribute : public CategoryAttribute
type LocalizedCategoryAttribute =
    class
        inherit CategoryAttribute
    end

Il tipo OptionsLocalizedCategoryAttribute espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsLocalizedCategoryAttribute |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | GetLocalizedString | (Sovrascrive CategoryAttributeGetLocalizedString(String))
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Options.LocalizedCategoryAttribute

Costruttore OptionsLocalizedCategoryAttribute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LocalizedCategoryAttribute(
    string resourceKey,
    Type resourceType
)
Public Sub New (
    resourceKey As String,
    resourceType As Type
)
public:
LocalizedCategoryAttribute(
    String^ resourceKey,
    Type^ resourceType
)
new :
        resourceKey : string *
        resourceType : Type -> LocalizedCategoryAttribute

Parametri

resourceKey String
resourceType Type
Vedi anche

Documentazione

Classe OptionsLocalizedCategoryAttribute
Namespace DedNetSw


Metodi di LocalizedCategoryAttribute

Il tipo OptionsLocalizedCategoryAttribute espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | GetLocalizedString | (Sovrascrive CategoryAttributeGetLocalizedString(String))
Torna su
Vedi anche

Documentazione

Classe OptionsLocalizedCategoryAttribute
Namespace DedNetSw


Metodo Options.LocalizedCategoryAttribute.GetLocalizedString

Metodo OptionsLocalizedCategoryAttributeGetLocalizedString

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override string GetLocalizedString(
    string value
)
Protected Overrides Function GetLocalizedString (
    value As String
) As String
protected:
virtual String^ GetLocalizedString(
    String^ value
) override
abstract GetLocalizedString :
        value : string -> string
override GetLocalizedString :
        value : string -> string

Parametri

value String

Valore di ritorno

String
Vedi anche

Documentazione

Classe OptionsLocalizedCategoryAttribute
Namespace DedNetSw


Classe Options.LocalizedDisplayNameAttribute

Classe OptionsLocalizedDisplayNameAttribute
Gerarchia di ereditarietà
SystemObject
SystemAttribute
System.ComponentModelDisplayNameAttribute
DedNetSwOptionsLocalizedDisplayNameAttribute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LocalizedDisplayNameAttribute : DisplayNameAttribute
Public Class LocalizedDisplayNameAttribute
    Inherits DisplayNameAttribute
public ref class LocalizedDisplayNameAttribute : public DisplayNameAttribute
type LocalizedDisplayNameAttribute =
    class
        inherit DisplayNameAttribute
    end

Il tipo OptionsLocalizedDisplayNameAttribute espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsLocalizedDisplayNameAttribute |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DisplayName | (Sovrascrive DisplayNameAttributeDisplayName)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Options.LocalizedDisplayNameAttribute

Costruttore OptionsLocalizedDisplayNameAttribute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LocalizedDisplayNameAttribute(
    string resourceKey,
    Type resourceType
)
Public Sub New (
    resourceKey As String,
    resourceType As Type
)
public:
LocalizedDisplayNameAttribute(
    String^ resourceKey,
    Type^ resourceType
)
new :
        resourceKey : string *
        resourceType : Type -> LocalizedDisplayNameAttribute

Parametri

resourceKey String
resourceType Type
Vedi anche

Documentazione

Classe OptionsLocalizedDisplayNameAttribute
Namespace DedNetSw


Proprietà di LocalizedDisplayNameAttribute

Il tipo OptionsLocalizedDisplayNameAttribute espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DisplayName | (Sovrascrive DisplayNameAttributeDisplayName)
Torna su
Vedi anche

Documentazione

Classe OptionsLocalizedDisplayNameAttribute
Namespace DedNetSw


Proprietà Options.LocalizedDisplayNameAttribute.DisplayName

Proprietà OptionsLocalizedDisplayNameAttributeDisplayName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get
public:
virtual property String^ DisplayName {
    String^ get () override;
}
abstract DisplayName : string with get
override DisplayName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe OptionsLocalizedDisplayNameAttribute
Namespace DedNetSw


Classe Options.SaveDistChildrenRestrictionStatusConfiguration

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Gerarchia di ereditarietà
SystemObject
DedNetSwOptionsSaveDistChildrenRestrictionStatusConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SaveDistChildrenRestrictionStatusConfiguration
Public Class SaveDistChildrenRestrictionStatusConfiguration
public ref class SaveDistChildrenRestrictionStatusConfiguration
type SaveDistChildrenRestrictionStatusConfiguration = class end

Il tipo OptionsSaveDistChildrenRestrictionStatusConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration |
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration(OptionsSaveDistChildrenRestrictionStatusConfiguration) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Approved |
Proprietà pubblica | ModifyingOutOfDate |
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Proprietà pubblica | Working |
Torna su
Metodi
 | Nome | Descrizione
 | FromDescriptor |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Options.SaveDistChildrenRestrictionStatusConfiguration

Costruttore OptionsSaveDistChildrenRestrictionStatusConfiguration
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration |
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration(OptionsSaveDistChildrenRestrictionStatusConfiguration) |
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Costruttore Options.SaveDistChildrenRestrictionStatusConfiguration

Costruttore OptionsSaveDistChildrenRestrictionStatusConfiguration

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveDistChildrenRestrictionStatusConfiguration()
Public Sub New
public:
SaveDistChildrenRestrictionStatusConfiguration()
new : unit -> SaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Overload di OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Costruttore Options.SaveDistChildrenRestrictionStatusConfiguration(Options.SaveDistChildrenRestrictionStatusConfiguration)

Costruttore OptionsSaveDistChildrenRestrictionStatusConfiguration(OptionsSaveDistChildrenRestrictionStatusConfiguration)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveDistChildrenRestrictionStatusConfiguration(
    OptionsSaveDistChildrenRestrictionStatusConfiguration obj
)
Public Sub New (
    obj As OptionsSaveDistChildrenRestrictionStatusConfiguration
)
public:
SaveDistChildrenRestrictionStatusConfiguration(
    OptionsSaveDistChildrenRestrictionStatusConfiguration^ obj
)
new :
        obj : OptionsSaveDistChildrenRestrictionStatusConfiguration -> SaveDistChildrenRestrictionStatusConfiguration

Parametri

obj OptionsSaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Overload di OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà di SaveDistChildrenRestrictionStatusConfiguration

Il tipo OptionsSaveDistChildrenRestrictionStatusConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Approved |
Proprietà pubblica | ModifyingOutOfDate |
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Proprietà pubblica | Working |
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.Approved

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationApproved

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Approved { get; set; }
Public Property Approved As Boolean
    Get
    Set
public:
property bool Approved {
    bool get ();
    void set (bool value);
}
member Approved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.ModifyingOutOfDate

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationModifyingOutOfDate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ModifyingOutOfDate { get; set; }
Public Property ModifyingOutOfDate As Boolean
    Get
    Set
public:
property bool ModifyingOutOfDate {
    bool get ();
    void set (bool value);
}
member ModifyingOutOfDate : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.OutOfDate

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationOutOfDate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutOfDate { get; set; }
Public Property OutOfDate As Boolean
    Get
    Set
public:
property bool OutOfDate {
    bool get ();
    void set (bool value);
}
member OutOfDate : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.PendingApproval

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationPendingApproval

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PendingApproval { get; set; }
Public Property PendingApproval As Boolean
    Get
    Set
public:
property bool PendingApproval {
    bool get ();
    void set (bool value);
}
member PendingApproval : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.Unchangeable

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationUnchangeable

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Unchangeable { get; set; }
Public Property Unchangeable As Boolean
    Get
    Set
public:
property bool Unchangeable {
    bool get ();
    void set (bool value);
}
member Unchangeable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.Working

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationWorking

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Working { get; set; }
Public Property Working As Boolean
    Get
    Set
public:
property bool Working {
    bool get ();
    void set (bool value);
}
member Working : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Metodi di SaveDistChildrenRestrictionStatusConfiguration

Il tipo OptionsSaveDistChildrenRestrictionStatusConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | FromDescriptor |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Metodo Options.SaveDistChildrenRestrictionStatusConfiguration.FromDescriptor

Metodo OptionsSaveDistChildrenRestrictionStatusConfigurationFromDescriptor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OptionsSaveDistChildrenRestrictionStatusConfiguration FromDescriptor(
    string saveDistChildrenRestrictionStatusConfiguration
)
Public Shared Function FromDescriptor (
    saveDistChildrenRestrictionStatusConfiguration As String
) As OptionsSaveDistChildrenRestrictionStatusConfiguration
public:
static OptionsSaveDistChildrenRestrictionStatusConfiguration^ FromDescriptor(
    String^ saveDistChildrenRestrictionStatusConfiguration
)
static member FromDescriptor :
        saveDistChildrenRestrictionStatusConfiguration : string -> OptionsSaveDistChildrenRestrictionStatusConfiguration

Parametri

saveDistChildrenRestrictionStatusConfiguration String

Valore di ritorno

OptionsSaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Metodo Options.SaveDistChildrenRestrictionStatusConfiguration.ToString

Metodo OptionsSaveDistChildrenRestrictionStatusConfigurationToString

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetSw


Classe PartEventHandler
Gerarchia di ereditarietà
SystemObject
DedNetSwDocumentEventHandler
DedNetSwPartEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PartEventHandler : DocumentEventHandler
Public Class PartEventHandler
    Inherits DocumentEventHandler
public ref class PartEventHandler : public DocumentEventHandler
type PartEventHandler =
    class
        inherit DocumentEventHandler
    end

Il tipo PartEventHandler espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PartEventHandler |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers | (Sovrascrive DocumentEventHandlerAttachEventHandlers)
Metodo pubblico | ConnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | DetachEventHandlers | (Sovrascrive DocumentEventHandlerDetachEventHandlers)
Metodo pubblico | DetachModelViewEventHandler | (Ereditato da DocumentEventHandler)
Metodo pubblico | DisconnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | OnDestroy |
Metodo pubblico | OnFileSaveNotify |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | document | (Ereditato da DocumentEventHandler)
Campo protetto | iSwApp | (Ereditato da DocumentEventHandler)
Campo protetto | openModelViews | (Ereditato da DocumentEventHandler)
Campo protetto | userAddin | (Ereditato da DocumentEventHandler)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore PartEventHandler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartEventHandler(
    ModelDoc2 modDoc,
    DedNetSwApp addin,
    ISldWorks sldwrk
)
Public Sub New (
    modDoc As ModelDoc2,
    addin As DedNetSwApp,
    sldwrk As ISldWorks
)
public:
PartEventHandler(
    ModelDoc2^ modDoc,
    DedNetSwApp^ addin,
    ISldWorks^ sldwrk
)
new :
        modDoc : ModelDoc2 *
        addin : DedNetSwApp *
        sldwrk : ISldWorks -> PartEventHandler

Parametri

modDoc ModelDoc2
addin DedNetSwApp
sldwrk ISldWorks
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Metodi di PartEventHandler

Il tipo PartEventHandler espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttachEventHandlers | (Sovrascrive DocumentEventHandlerAttachEventHandlers)
Metodo pubblico | ConnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | DetachEventHandlers | (Sovrascrive DocumentEventHandlerDetachEventHandlers)
Metodo pubblico | DetachModelViewEventHandler | (Ereditato da DocumentEventHandler)
Metodo pubblico | DisconnectModelViews | (Ereditato da DocumentEventHandler)
Metodo pubblico | OnDestroy |
Metodo pubblico | OnFileSaveNotify |
Torna su
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Metodo PartEventHandler.AttachEventHandlers

Metodo PartEventHandlerAttachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool AttachEventHandlers()
Public Overrides Function AttachEventHandlers As Boolean
public:
virtual bool AttachEventHandlers() override
abstract AttachEventHandlers : unit -> bool
override AttachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Metodo PartEventHandler.DetachEventHandlers

Metodo PartEventHandlerDetachEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool DetachEventHandlers()
Public Overrides Function DetachEventHandlers As Boolean
public:
virtual bool DetachEventHandlers() override
abstract DetachEventHandlers : unit -> bool
override DetachEventHandlers : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Metodo PartEventHandler.OnDestroy

Metodo PartEventHandlerOnDestroy

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnDestroy(
    int destroyType
)
Public Function OnDestroy (
    destroyType As Integer
) As Integer
public:
int OnDestroy(
    int destroyType
)
member OnDestroy :
        destroyType : int -> int

Parametri

destroyType Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Metodo PartEventHandler.OnFileSaveNotify

Metodo PartEventHandlerOnFileSaveNotify

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnFileSaveNotify(
    string FileName
)
Public Function OnFileSaveNotify (
    FileName As String
) As Integer
public:
int OnFileSaveNotify(
    String^ FileName
)
member OnFileSaveNotify :
        FileName : string -> int

Parametri

FileName String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Campi di PartEventHandler

Il tipo PartEventHandler espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | document | (Ereditato da DocumentEventHandler)
Campo protetto | iSwApp | (Ereditato da DocumentEventHandler)
Campo protetto | openModelViews | (Ereditato da DocumentEventHandler)
Campo protetto | userAddin | (Ereditato da DocumentEventHandler)
Torna su
Vedi anche

Documentazione

Classe PartEventHandler
Namespace DedNetSw


Classe QsPropertiesInterfaceWrapper
Gerarchia di ereditarietà
SystemObject
DedNetSwQsPropertiesInterfaceWrapper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsPropertiesInterfaceWrapper : IDataOptions
Public Class QsPropertiesInterfaceWrapper
    Implements IDataOptions
public ref class QsPropertiesInterfaceWrapper : IDataOptions
type QsPropertiesInterfaceWrapper =
    class
        interface IDataOptions
    end

Il tipo QsPropertiesInterfaceWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsPropertiesInterfaceWrapper |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Cancel |
Metodo pubblico | GetPropertiesObject |
Metodo pubblico | Load |
Metodo pubblico | Save |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore QsPropertiesInterfaceWrapper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsPropertiesInterfaceWrapper()
Public Sub New
public:
QsPropertiesInterfaceWrapper()
new : unit -> QsPropertiesInterfaceWrapper
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetSw


Metodi di QsPropertiesInterfaceWrapper

Il tipo QsPropertiesInterfaceWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Cancel |
Metodo pubblico | GetPropertiesObject |
Metodo pubblico | Load |
Metodo pubblico | Save |
Torna su
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetSw


Metodo QsPropertiesInterfaceWrapper.Cancel

Metodo QsPropertiesInterfaceWrapperCancel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
virtual void Cancel() sealed
abstract Cancel : unit -> unit
override Cancel : unit -> unit

Implementa

IDataOptions.Cancel
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetSw


Metodo QsPropertiesInterfaceWrapper.GetPropertiesObject

Metodo QsPropertiesInterfaceWrapperGetPropertiesObject

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object GetPropertiesObject()
Public Function GetPropertiesObject As Object
public:
virtual Object^ GetPropertiesObject() sealed
abstract GetPropertiesObject : unit -> Object
override GetPropertiesObject : unit -> Object

Valore di ritorno

Object

Implementa

IDataOptions.GetPropertiesObject
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetSw


Metodo QsPropertiesInterfaceWrapper.Load

Metodo QsPropertiesInterfaceWrapperLoad

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Load()
Public Sub Load
public:
virtual void Load() sealed
abstract Load : unit -> unit
override Load : unit -> unit

Implementa

IDataOptions.Load
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetSw


Metodo QsPropertiesInterfaceWrapper.Save

Metodo QsPropertiesInterfaceWrapperSave

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDataOptions.Save
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetSw


Classe QsResources
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
DedNetSwQsResources

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore QsResources

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s String
a Assembly
Vedi anche

Documentazione

Classe QsResources
Namespace DedNetSw


Metodi di QsResources

Il tipo QsResources espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace DedNetSw


Metodo QsResources.GetString

Metodo QsResourcesGetString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) |
Metodo pubblico | GetString(String, CultureInfo) |
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace DedNetSw


Metodo QsResources.GetString(String)

Metodo QsResourcesGetString(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace DedNetSw


Metodo QsResources.GetString(String, CultureInfo)

Metodo QsResourcesGetString(String, CultureInfo)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name String
culture CultureInfo

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace DedNetSw


Classe ReplaceComponentPropertyPage
Gerarchia di ereditarietà
SystemObject
DedNetSwReplaceComponentPropertyPage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ReplaceComponentPropertyPage
Public Class ReplaceComponentPropertyPage
public ref class ReplaceComponentPropertyPage
type ReplaceComponentPropertyPage = class end

Il tipo ReplaceComponentPropertyPage espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ReplaceComponentPropertyPage |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | OnActiveXControlCreated |
Metodo pubblico | OnCheckboxCheck |
Metodo pubblico | Show |
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.AfterActivation |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.AfterClose |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnButtonPress |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnClose |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnComboboxEditChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnComboboxSelectionChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnGainedFocus |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnGroupCheck |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnGroupExpand |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnHelp |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnKeystroke |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnListboxRMBUp |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnListboxSelectionChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnLostFocus |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnNextPage |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnNumberboxChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnNumberBoxTrackingCompleted |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnOptionCheck |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPopupMenuItem |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPopupMenuItemUpdate |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPreview |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPreviousPage |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnRedo |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxCalloutCreated |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxCalloutDestroyed |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxFocusChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxListChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSliderPositionChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSliderTrackingCompleted |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSubmitSelection |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnTabClicked |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnTextboxChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnUndo |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnWhatsNew |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnWindowFromHandleControlCreated |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore ReplaceComponentPropertyPage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ReplaceComponentPropertyPage(
    SldWorks swApp
)
Public Sub New (
    swApp As SldWorks
)
public:
ReplaceComponentPropertyPage(
    SldWorks^ swApp
)
new :
        swApp : SldWorks -> ReplaceComponentPropertyPage

Parametri

swApp SldWorks
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodi di ReplaceComponentPropertyPage

Il tipo ReplaceComponentPropertyPage espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | OnActiveXControlCreated |
Metodo pubblico | OnCheckboxCheck |
Metodo pubblico | Show |
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.AfterActivation |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.AfterClose |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnButtonPress |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnClose |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnComboboxEditChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnComboboxSelectionChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnGainedFocus |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnGroupCheck |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnGroupExpand |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnHelp |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnKeystroke |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnListboxRMBUp |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnListboxSelectionChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnLostFocus |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnNextPage |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnNumberboxChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnNumberBoxTrackingCompleted |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnOptionCheck |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPopupMenuItem |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPopupMenuItemUpdate |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPreview |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnPreviousPage |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnRedo |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxCalloutCreated |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxCalloutDestroyed |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxFocusChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSelectionboxListChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSliderPositionChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSliderTrackingCompleted |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnSubmitSelection |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnTabClicked |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnTextboxChanged |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnUndo |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnWhatsNew |
Implementazione esplicita di interfacce | IPropertyManagerPage2Handler9.OnWindowFromHandleControlCreated |
Torna su
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.AfterActivation

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9AfterActivation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.AfterActivation()
Private Sub AfterActivation Implements IPropertyManagerPage2Handler9.AfterActivation
private:
virtual void AfterActivation() sealed = IPropertyManagerPage2Handler9::AfterActivation
private abstract AfterActivation : unit -> unit
private override AfterActivation : unit -> unit

Implementa

IPropertyManagerPage2Handler9.AfterActivation
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.AfterClose

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9AfterClose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.AfterClose()
Private Sub AfterClose Implements IPropertyManagerPage2Handler9.AfterClose
private:
virtual void AfterClose() sealed = IPropertyManagerPage2Handler9::AfterClose
private abstract AfterClose : unit -> unit
private override AfterClose : unit -> unit

Implementa

IPropertyManagerPage2Handler9.AfterClose
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnButtonPress

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnButtonPress

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnButtonPress(
    int Id
)
Private Sub OnButtonPress (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnButtonPress
private:
virtual void OnButtonPress(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnButtonPress
private abstract OnButtonPress :
        Id : int -> unit
private override OnButtonPress :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnButtonPress(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnClose

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnClose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnClose(
    int Reason
)
Private Sub OnClose (
    Reason As Integer
) Implements IPropertyManagerPage2Handler9.OnClose
private:
virtual void OnClose(
    int Reason
) sealed = IPropertyManagerPage2Handler9::OnClose
private abstract OnClose :
        Reason : int -> unit
private override OnClose :
        Reason : int -> unit

Parametri

Reason Int32

Implementa

IPropertyManagerPage2Handler9.OnClose(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnComboboxEditChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnComboboxEditChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnComboboxEditChanged(
    int Id,
    string Text
)
Private Sub OnComboboxEditChanged (
    Id As Integer,
    Text As String
) Implements IPropertyManagerPage2Handler9.OnComboboxEditChanged
private:
virtual void OnComboboxEditChanged(
    int Id,
    String^ Text
) sealed = IPropertyManagerPage2Handler9::OnComboboxEditChanged
private abstract OnComboboxEditChanged :
        Id : int *
        Text : string -> unit
private override OnComboboxEditChanged :
        Id : int *
        Text : string -> unit

Parametri

Id Int32
Text String

Implementa

IPropertyManagerPage2Handler9.OnComboboxEditChanged(Int32, String)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnComboboxSelectionChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnComboboxSelectionChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnComboboxSelectionChanged(
    int Id,
    int Item
)
Private Sub OnComboboxSelectionChanged (
    Id As Integer,
    Item As Integer
) Implements IPropertyManagerPage2Handler9.OnComboboxSelectionChanged
private:
virtual void OnComboboxSelectionChanged(
    int Id,
    int Item
) sealed = IPropertyManagerPage2Handler9::OnComboboxSelectionChanged
private abstract OnComboboxSelectionChanged :
        Id : int *
        Item : int -> unit
private override OnComboboxSelectionChanged :
        Id : int *
        Item : int -> unit

Parametri

Id Int32
Item Int32

Implementa

IPropertyManagerPage2Handler9.OnComboboxSelectionChanged(Int32, Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnGainedFocus

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnGainedFocus

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnGainedFocus(
    int Id
)
Private Sub OnGainedFocus (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnGainedFocus
private:
virtual void OnGainedFocus(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnGainedFocus
private abstract OnGainedFocus :
        Id : int -> unit
private override OnGainedFocus :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnGainedFocus(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnGroupCheck

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnGroupCheck

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnGroupCheck(
    int Id,
    bool Checked
)
Private Sub OnGroupCheck (
    Id As Integer,
    Checked As Boolean
) Implements IPropertyManagerPage2Handler9.OnGroupCheck
private:
virtual void OnGroupCheck(
    int Id,
    bool Checked
) sealed = IPropertyManagerPage2Handler9::OnGroupCheck
private abstract OnGroupCheck :
        Id : int *
        Checked : bool -> unit
private override OnGroupCheck :
        Id : int *
        Checked : bool -> unit

Parametri

Id Int32
Checked Boolean

Implementa

IPropertyManagerPage2Handler9.OnGroupCheck(Int32, Boolean)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnGroupExpand

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnGroupExpand

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnGroupExpand(
    int Id,
    bool Expanded
)
Private Sub OnGroupExpand (
    Id As Integer,
    Expanded As Boolean
) Implements IPropertyManagerPage2Handler9.OnGroupExpand
private:
virtual void OnGroupExpand(
    int Id,
    bool Expanded
) sealed = IPropertyManagerPage2Handler9::OnGroupExpand
private abstract OnGroupExpand :
        Id : int *
        Expanded : bool -> unit
private override OnGroupExpand :
        Id : int *
        Expanded : bool -> unit

Parametri

Id Int32
Expanded Boolean

Implementa

IPropertyManagerPage2Handler9.OnGroupExpand(Int32, Boolean)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnHelp

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnHelp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnHelp()
Private Function OnHelp As Boolean Implements IPropertyManagerPage2Handler9.OnHelp
private:
virtual bool OnHelp() sealed = IPropertyManagerPage2Handler9::OnHelp
private abstract OnHelp : unit -> bool
private override OnHelp : unit -> bool

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnHelp
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnKeystroke

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnKeystroke

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnKeystroke(
    int Wparam,
    int Message,
    int Lparam,
    int Id
)
Private Function OnKeystroke (
    Wparam As Integer,
    Message As Integer,
    Lparam As Integer,
    Id As Integer
) As Boolean Implements IPropertyManagerPage2Handler9.OnKeystroke
private:
virtual bool OnKeystroke(
    int Wparam,
    int Message,
    int Lparam,
    int Id
) sealed = IPropertyManagerPage2Handler9::OnKeystroke
private abstract OnKeystroke :
        Wparam : int *
        Message : int *
        Lparam : int *
        Id : int -> bool
private override OnKeystroke :
        Wparam : int *
        Message : int *
        Lparam : int *
        Id : int -> bool

Parametri

Wparam Int32
Message Int32
Lparam Int32
Id Int32

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnKeystroke(Int32, Int32, Int32, Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnListboxRMBUp

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnListboxRMBUp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnListboxRMBUp(
    int Id,
    int PosX,
    int PosY
)
Private Sub OnListboxRMBUp (
    Id As Integer,
    PosX As Integer,
    PosY As Integer
) Implements IPropertyManagerPage2Handler9.OnListboxRMBUp
private:
virtual void OnListboxRMBUp(
    int Id,
    int PosX,
    int PosY
) sealed = IPropertyManagerPage2Handler9::OnListboxRMBUp
private abstract OnListboxRMBUp :
        Id : int *
        PosX : int *
        PosY : int -> unit
private override OnListboxRMBUp :
        Id : int *
        PosX : int *
        PosY : int -> unit

Parametri

Id Int32
PosX Int32
PosY Int32

Implementa

IPropertyManagerPage2Handler9.OnListboxRMBUp(Int32, Int32, Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnListboxSelectionChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnListboxSelectionChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnListboxSelectionChanged(
    int Id,
    int Item
)
Private Sub OnListboxSelectionChanged (
    Id As Integer,
    Item As Integer
) Implements IPropertyManagerPage2Handler9.OnListboxSelectionChanged
private:
virtual void OnListboxSelectionChanged(
    int Id,
    int Item
) sealed = IPropertyManagerPage2Handler9::OnListboxSelectionChanged
private abstract OnListboxSelectionChanged :
        Id : int *
        Item : int -> unit
private override OnListboxSelectionChanged :
        Id : int *
        Item : int -> unit

Parametri

Id Int32
Item Int32

Implementa

IPropertyManagerPage2Handler9.OnListboxSelectionChanged(Int32, Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnLostFocus

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnLostFocus

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnLostFocus(
    int Id
)
Private Sub OnLostFocus (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnLostFocus
private:
virtual void OnLostFocus(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnLostFocus
private abstract OnLostFocus :
        Id : int -> unit
private override OnLostFocus :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnLostFocus(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnNextPage

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnNextPage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnNextPage()
Private Function OnNextPage As Boolean
    Implements IPropertyManagerPage2Handler9.OnNextPage
private:
virtual bool OnNextPage() sealed = IPropertyManagerPage2Handler9::OnNextPage
private abstract OnNextPage : unit -> bool
private override OnNextPage : unit -> bool

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnNextPage
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnNumberboxChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnNumberboxChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnNumberboxChanged(
    int Id,
    double Value
)
Private Sub OnNumberboxChanged (
    Id As Integer,
    Value As Double
) Implements IPropertyManagerPage2Handler9.OnNumberboxChanged
private:
virtual void OnNumberboxChanged(
    int Id,
    double Value
) sealed = IPropertyManagerPage2Handler9::OnNumberboxChanged
private abstract OnNumberboxChanged :
        Id : int *
        Value : float -> unit
private override OnNumberboxChanged :
        Id : int *
        Value : float -> unit

Parametri

Id Int32
Value Double

Implementa

IPropertyManagerPage2Handler9.OnNumberboxChanged(Int32, Double)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnNumberBoxTrackingCompleted

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnNumberBoxTrackingCompleted

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnNumberBoxTrackingCompleted(
    int Id,
    double Value
)
Private Sub OnNumberBoxTrackingCompleted (
    Id As Integer,
    Value As Double
) Implements IPropertyManagerPage2Handler9.OnNumberBoxTrackingCompleted
private:
virtual void OnNumberBoxTrackingCompleted(
    int Id,
    double Value
) sealed = IPropertyManagerPage2Handler9::OnNumberBoxTrackingCompleted
private abstract OnNumberBoxTrackingCompleted :
        Id : int *
        Value : float -> unit
private override OnNumberBoxTrackingCompleted :
        Id : int *
        Value : float -> unit

Parametri

Id Int32
Value Double

Implementa

IPropertyManagerPage2Handler9.OnNumberBoxTrackingCompleted(Int32, Double)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnOptionCheck

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnOptionCheck

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnOptionCheck(
    int Id
)
Private Sub OnOptionCheck (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnOptionCheck
private:
virtual void OnOptionCheck(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnOptionCheck
private abstract OnOptionCheck :
        Id : int -> unit
private override OnOptionCheck :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnOptionCheck(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnPopupMenuItem

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnPopupMenuItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnPopupMenuItem(
    int Id
)
Private Sub OnPopupMenuItem (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnPopupMenuItem
private:
virtual void OnPopupMenuItem(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnPopupMenuItem
private abstract OnPopupMenuItem :
        Id : int -> unit
private override OnPopupMenuItem :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnPopupMenuItem(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnPopupMenuItemUpdate

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnPopupMenuItemUpdate

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnPopupMenuItemUpdate(
    int Id,
    ref int retval
)
Private Sub OnPopupMenuItemUpdate (
    Id As Integer,
    ByRef retval As Integer
) Implements IPropertyManagerPage2Handler9.OnPopupMenuItemUpdate
private:
virtual void OnPopupMenuItemUpdate(
    int Id,
    int% retval
) sealed = IPropertyManagerPage2Handler9::OnPopupMenuItemUpdate
private abstract OnPopupMenuItemUpdate :
        Id : int *
        retval : int byref -> unit
private override OnPopupMenuItemUpdate :
        Id : int *
        retval : int byref -> unit

Parametri

Id Int32
retval Int32

Implementa

IPropertyManagerPage2Handler9.OnPopupMenuItemUpdate(Int32, Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnPreview

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnPreview

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnPreview()
Private Function OnPreview As Boolean
    Implements IPropertyManagerPage2Handler9.OnPreview
private:
virtual bool OnPreview() sealed = IPropertyManagerPage2Handler9::OnPreview
private abstract OnPreview : unit -> bool
private override OnPreview : unit -> bool

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnPreview
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnPreviousPage

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnPreviousPage

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnPreviousPage()
Private Function OnPreviousPage As Boolean
    Implements IPropertyManagerPage2Handler9.OnPreviousPage
private:
virtual bool OnPreviousPage() sealed = IPropertyManagerPage2Handler9::OnPreviousPage
private abstract OnPreviousPage : unit -> bool
private override OnPreviousPage : unit -> bool

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnPreviousPage
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnRedo

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnRedo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnRedo()
Private Sub OnRedo Implements IPropertyManagerPage2Handler9.OnRedo
private:
virtual void OnRedo() sealed = IPropertyManagerPage2Handler9::OnRedo
private abstract OnRedo : unit -> unit
private override OnRedo : unit -> unit

Implementa

IPropertyManagerPage2Handler9.OnRedo
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSelectionboxCalloutCreated

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSelectionboxCalloutCreated

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnSelectionboxCalloutCreated(
    int Id
)
Private Sub OnSelectionboxCalloutCreated (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnSelectionboxCalloutCreated
private:
virtual void OnSelectionboxCalloutCreated(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnSelectionboxCalloutCreated
private abstract OnSelectionboxCalloutCreated :
        Id : int -> unit
private override OnSelectionboxCalloutCreated :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnSelectionboxCalloutCreated(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSelectionboxCalloutDestroyed

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSelectionboxCalloutDestroyed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnSelectionboxCalloutDestroyed(
    int Id
)
Private Sub OnSelectionboxCalloutDestroyed (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnSelectionboxCalloutDestroyed
private:
virtual void OnSelectionboxCalloutDestroyed(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnSelectionboxCalloutDestroyed
private abstract OnSelectionboxCalloutDestroyed :
        Id : int -> unit
private override OnSelectionboxCalloutDestroyed :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnSelectionboxCalloutDestroyed(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSelectionboxFocusChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSelectionboxFocusChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnSelectionboxFocusChanged(
    int Id
)
Private Sub OnSelectionboxFocusChanged (
    Id As Integer
) Implements IPropertyManagerPage2Handler9.OnSelectionboxFocusChanged
private:
virtual void OnSelectionboxFocusChanged(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnSelectionboxFocusChanged
private abstract OnSelectionboxFocusChanged :
        Id : int -> unit
private override OnSelectionboxFocusChanged :
        Id : int -> unit

Parametri

Id Int32

Implementa

IPropertyManagerPage2Handler9.OnSelectionboxFocusChanged(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSelectionboxListChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSelectionboxListChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnSelectionboxListChanged(
    int Id,
    int Count
)
Private Sub OnSelectionboxListChanged (
    Id As Integer,
    Count As Integer
) Implements IPropertyManagerPage2Handler9.OnSelectionboxListChanged
private:
virtual void OnSelectionboxListChanged(
    int Id,
    int Count
) sealed = IPropertyManagerPage2Handler9::OnSelectionboxListChanged
private abstract OnSelectionboxListChanged :
        Id : int *
        Count : int -> unit
private override OnSelectionboxListChanged :
        Id : int *
        Count : int -> unit

Parametri

Id Int32
Count Int32

Implementa

IPropertyManagerPage2Handler9.OnSelectionboxListChanged(Int32, Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSliderPositionChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSliderPositionChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnSliderPositionChanged(
    int Id,
    double Value
)
Private Sub OnSliderPositionChanged (
    Id As Integer,
    Value As Double
) Implements IPropertyManagerPage2Handler9.OnSliderPositionChanged
private:
virtual void OnSliderPositionChanged(
    int Id,
    double Value
) sealed = IPropertyManagerPage2Handler9::OnSliderPositionChanged
private abstract OnSliderPositionChanged :
        Id : int *
        Value : float -> unit
private override OnSliderPositionChanged :
        Id : int *
        Value : float -> unit

Parametri

Id Int32
Value Double

Implementa

IPropertyManagerPage2Handler9.OnSliderPositionChanged(Int32, Double)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSliderTrackingCompleted

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSliderTrackingCompleted

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnSliderTrackingCompleted(
    int Id,
    double Value
)
Private Sub OnSliderTrackingCompleted (
    Id As Integer,
    Value As Double
) Implements IPropertyManagerPage2Handler9.OnSliderTrackingCompleted
private:
virtual void OnSliderTrackingCompleted(
    int Id,
    double Value
) sealed = IPropertyManagerPage2Handler9::OnSliderTrackingCompleted
private abstract OnSliderTrackingCompleted :
        Id : int *
        Value : float -> unit
private override OnSliderTrackingCompleted :
        Id : int *
        Value : float -> unit

Parametri

Id Int32
Value Double

Implementa

IPropertyManagerPage2Handler9.OnSliderTrackingCompleted(Int32, Double)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnSubmitSelection

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnSubmitSelection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnSubmitSelection(
    int Id,
    Object Selection,
    int SelType,
    ref string ItemText
)
Private Function OnSubmitSelection (
    Id As Integer,
    Selection As Object,
    SelType As Integer,
    ByRef ItemText As String
) As Boolean Implements IPropertyManagerPage2Handler9.OnSubmitSelection
private:
virtual bool OnSubmitSelection(
    int Id,
    Object^ Selection,
    int SelType,
    String^% ItemText
) sealed = IPropertyManagerPage2Handler9::OnSubmitSelection
private abstract OnSubmitSelection :
        Id : int *
        Selection : Object *
        SelType : int *
        ItemText : string byref -> bool
private override OnSubmitSelection :
        Id : int *
        Selection : Object *
        SelType : int *
        ItemText : string byref -> bool

Parametri

Id Int32
Selection Object
SelType Int32
ItemText String

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnSubmitSelection(Int32, Object, Int32, String)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnTabClicked

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnTabClicked

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IPropertyManagerPage2Handler9.OnTabClicked(
    int Id
)
Private Function OnTabClicked (
    Id As Integer
) As Boolean Implements IPropertyManagerPage2Handler9.OnTabClicked
private:
virtual bool OnTabClicked(
    int Id
) sealed = IPropertyManagerPage2Handler9::OnTabClicked
private abstract OnTabClicked :
        Id : int -> bool
private override OnTabClicked :
        Id : int -> bool

Parametri

Id Int32

Valore di ritorno

Boolean

Implementa

IPropertyManagerPage2Handler9.OnTabClicked(Int32)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnTextboxChanged

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnTextboxChanged

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnTextboxChanged(
    int Id,
    string Text
)
Private Sub OnTextboxChanged (
    Id As Integer,
    Text As String
) Implements IPropertyManagerPage2Handler9.OnTextboxChanged
private:
virtual void OnTextboxChanged(
    int Id,
    String^ Text
) sealed = IPropertyManagerPage2Handler9::OnTextboxChanged
private abstract OnTextboxChanged :
        Id : int *
        Text : string -> unit
private override OnTextboxChanged :
        Id : int *
        Text : string -> unit

Parametri

Id Int32
Text String

Implementa

IPropertyManagerPage2Handler9.OnTextboxChanged(Int32, String)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnUndo

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnUndo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnUndo()
Private Sub OnUndo Implements IPropertyManagerPage2Handler9.OnUndo
private:
virtual void OnUndo() sealed = IPropertyManagerPage2Handler9::OnUndo
private abstract OnUndo : unit -> unit
private override OnUndo : unit -> unit

Implementa

IPropertyManagerPage2Handler9.OnUndo
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnWhatsNew

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnWhatsNew

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
void IPropertyManagerPage2Handler9.OnWhatsNew()
Private Sub OnWhatsNew Implements IPropertyManagerPage2Handler9.OnWhatsNew
private:
virtual void OnWhatsNew() sealed = IPropertyManagerPage2Handler9::OnWhatsNew
private abstract OnWhatsNew : unit -> unit
private override OnWhatsNew : unit -> unit

Implementa

IPropertyManagerPage2Handler9.OnWhatsNew
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.IPropertyManagerPage2Handler9.OnWindowFromHandleControlCreated

Metodo ReplaceComponentPropertyPageIPropertyManagerPage2Handler9OnWindowFromHandleControlCreated

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
int IPropertyManagerPage2Handler9.OnWindowFromHandleControlCreated(
    int Id,
    bool Status
)
Private Function OnWindowFromHandleControlCreated (
    Id As Integer,
    Status As Boolean
) As Integer Implements IPropertyManagerPage2Handler9.OnWindowFromHandleControlCreated
private:
virtual int OnWindowFromHandleControlCreated(
    int Id,
    bool Status
) sealed = IPropertyManagerPage2Handler9::OnWindowFromHandleControlCreated
private abstract OnWindowFromHandleControlCreated :
        Id : int *
        Status : bool -> int
private override OnWindowFromHandleControlCreated :
        Id : int *
        Status : bool -> int

Parametri

Id Int32
Status Boolean

Valore di ritorno

Int32

Implementa

IPropertyManagerPage2Handler9.OnWindowFromHandleControlCreated(Int32, Boolean)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.OnActiveXControlCreated

Metodo ReplaceComponentPropertyPageOnActiveXControlCreated

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int OnActiveXControlCreated(
    int Id,
    bool Status
)
Public Function OnActiveXControlCreated (
    Id As Integer,
    Status As Boolean
) As Integer
public:
virtual int OnActiveXControlCreated(
    int Id,
    bool Status
) sealed
abstract OnActiveXControlCreated :
        Id : int *
        Status : bool -> int
override OnActiveXControlCreated :
        Id : int *
        Status : bool -> int

Parametri

Id Int32
Status Boolean

Valore di ritorno

Int32

Implementa

IPropertyManagerPage2Handler9.OnActiveXControlCreated(Int32, Boolean)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.OnCheckboxCheck

Metodo ReplaceComponentPropertyPageOnCheckboxCheck

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnCheckboxCheck(
    int Id,
    bool Checked
)
Public Sub OnCheckboxCheck (
    Id As Integer,
    Checked As Boolean
)
public:
virtual void OnCheckboxCheck(
    int Id,
    bool Checked
) sealed
abstract OnCheckboxCheck :
        Id : int *
        Checked : bool -> unit
override OnCheckboxCheck :
        Id : int *
        Checked : bool -> unit

Parametri

Id Int32
Checked Boolean

Implementa

IPropertyManagerPage2Handler9.OnCheckboxCheck(Int32, Boolean)
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Metodo ReplaceComponentPropertyPage.Show

Metodo ReplaceComponentPropertyPageShow

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Show()
Public Sub Show
public:
void Show()
member Show : unit -> unit
Vedi anche

Documentazione

Classe ReplaceComponentPropertyPage
Namespace DedNetSw


Classe ResolveFileForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSwResolveFileForm

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResolveFileForm : BaseForm
Public Class ResolveFileForm
    Inherits BaseForm
public ref class ResolveFileForm : public BaseForm
type ResolveFileForm =
    class
        inherit BaseForm
    end

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Proprietà di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetSw


Proprietà ResolveFileForm.SetText

Proprietà ResolveFileFormSetText

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SetText { get; set; }
Public Property SetText As String
    Get
    Set
public:
property String^ SetText {
    String^ get ();
    void set (String^ value);
}
member SetText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetSw


Metodi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetSw


Metodo ResolveFileForm.Dispose

Metodo ResolveFileFormDispose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetSw


Eventi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetSw


Campi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetSw


Classe SelInfoItem
Gerarchia di ereditarietà
SystemObject
DedNetSwSelInfoItem

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SelInfoItem
Public Class SelInfoItem
public ref class SelInfoItem
type SelInfoItem = class end

Il tipo SelInfoItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SelInfoItem(IFeature) |
Metodo pubblico | SelInfoItem(IComponent2, String) |
Metodo pubblico | SelInfoItem(IModelDoc2, String) |
Metodo pubblico | SelInfoItem(String, String) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ComponentIsSubstitute |
Proprietà pubblica | ComponentIsSuppressedOrMissing |
Proprietà pubblica | ComponentIsVirtual |
Proprietà pubblica | Config |
Proprietà pubblica | DedData |
Proprietà pubblica | DedDoc |
Proprietà pubblica | DocumentIsAssembly |
Proprietà pubblica | DocumentIsDrawing |
Proprietà pubblica | DocumentIsModel |
Proprietà pubblica | DocumentIsPart |
Proprietà pubblica | DocumentIsPresentation |
Proprietà pubblica | FeatureIsSuppressedOrMissing |
Proprietà pubblica | HasDedData |
Proprietà pubblica | HasDedDoc |
Proprietà pubblica | HasDocument |
Proprietà pubblica | IsComponent |
Proprietà pubblica | IsEditDocument |
Proprietà pubblica | IsFeature |
Proprietà pubblica | IsTopDocument |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | RawReferenceFileName |
Campo pubblico | SwComponent |
Campo pubblico | SwDocument |
Campo pubblico | SwFeature |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SelInfoItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SelInfoItem(IFeature) |
Metodo pubblico | SelInfoItem(IComponent2, String) |
Metodo pubblico | SelInfoItem(IModelDoc2, String) |
Metodo pubblico | SelInfoItem(String, String) |
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Costruttore SelInfoItem(IFeature)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    IFeature feature
)
Public Sub New (
    feature As IFeature
)
public:
SelInfoItem(
    IFeature^ feature
)
new :
        feature : IFeature -> SelInfoItem

Parametri

feature IFeature
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetSw


Costruttore SelInfoItem(IComponent2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    IComponent2 comp,
    string config
)
Public Sub New (
    comp As IComponent2,
    config As String
)
public:
SelInfoItem(
    IComponent2^ comp,
    String^ config
)
new :
        comp : IComponent2 *
        config : string -> SelInfoItem

Parametri

comp IComponent2
config String
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetSw


Costruttore SelInfoItem(IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    IModelDoc2 doc,
    string config
)
Public Sub New (
    doc As IModelDoc2,
    config As String
)
public:
SelInfoItem(
    IModelDoc2^ doc,
    String^ config
)
new :
        doc : IModelDoc2 *
        config : string -> SelInfoItem

Parametri

doc IModelDoc2
config String
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetSw


Costruttore SelInfoItem(String, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    string fn,
    string config
)
Public Sub New (
    fn As String,
    config As String
)
public:
SelInfoItem(
    String^ fn,
    String^ config
)
new :
        fn : string *
        config : string -> SelInfoItem

Parametri

fn String
config String
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetSw


Proprietà di SelInfoItem

Il tipo SelInfoItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ComponentIsSubstitute |
Proprietà pubblica | ComponentIsSuppressedOrMissing |
Proprietà pubblica | ComponentIsVirtual |
Proprietà pubblica | Config |
Proprietà pubblica | DedData |
Proprietà pubblica | DedDoc |
Proprietà pubblica | DocumentIsAssembly |
Proprietà pubblica | DocumentIsDrawing |
Proprietà pubblica | DocumentIsModel |
Proprietà pubblica | DocumentIsPart |
Proprietà pubblica | DocumentIsPresentation |
Proprietà pubblica | FeatureIsSuppressedOrMissing |
Proprietà pubblica | HasDedData |
Proprietà pubblica | HasDedDoc |
Proprietà pubblica | HasDocument |
Proprietà pubblica | IsComponent |
Proprietà pubblica | IsEditDocument |
Proprietà pubblica | IsFeature |
Proprietà pubblica | IsTopDocument |
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.ComponentIsSubstitute

Proprietà SelInfoItemComponentIsSubstitute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ComponentIsSubstitute { get; }
Public ReadOnly Property ComponentIsSubstitute As Boolean
    Get
public:
property bool ComponentIsSubstitute {
    bool get ();
}
member ComponentIsSubstitute : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.ComponentIsSuppressedOrMissing

Proprietà SelInfoItemComponentIsSuppressedOrMissing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ComponentIsSuppressedOrMissing { get; }
Public ReadOnly Property ComponentIsSuppressedOrMissing As Boolean
    Get
public:
property bool ComponentIsSuppressedOrMissing {
    bool get ();
}
member ComponentIsSuppressedOrMissing : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.ComponentIsVirtual

Proprietà SelInfoItemComponentIsVirtual

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ComponentIsVirtual { get; }
Public ReadOnly Property ComponentIsVirtual As Boolean
    Get
public:
property bool ComponentIsVirtual {
    bool get ();
}
member ComponentIsVirtual : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.Config

Proprietà SelInfoItemConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; }
Public ReadOnly Property Config As String
    Get
public:
property String^ Config {
    String^ get ();
}
member Config : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DedData

Proprietà SelInfoItemDedData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData DedData { get; }
Public ReadOnly Property DedData As DedData
    Get
public:
property DedData^ DedData {
    DedData^ get ();
}
member DedData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DedDoc

Proprietà SelInfoItemDedDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DocumentIsAssembly

Proprietà SelInfoItemDocumentIsAssembly

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsAssembly { get; }
Public ReadOnly Property DocumentIsAssembly As Boolean
    Get
public:
property bool DocumentIsAssembly {
    bool get ();
}
member DocumentIsAssembly : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DocumentIsDrawing

Proprietà SelInfoItemDocumentIsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsDrawing { get; }
Public ReadOnly Property DocumentIsDrawing As Boolean
    Get
public:
property bool DocumentIsDrawing {
    bool get ();
}
member DocumentIsDrawing : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DocumentIsModel

Proprietà SelInfoItemDocumentIsModel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsModel { get; }
Public ReadOnly Property DocumentIsModel As Boolean
    Get
public:
property bool DocumentIsModel {
    bool get ();
}
member DocumentIsModel : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DocumentIsPart

Proprietà SelInfoItemDocumentIsPart

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsPart { get; }
Public ReadOnly Property DocumentIsPart As Boolean
    Get
public:
property bool DocumentIsPart {
    bool get ();
}
member DocumentIsPart : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.DocumentIsPresentation

Proprietà SelInfoItemDocumentIsPresentation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsPresentation { get; }
Public ReadOnly Property DocumentIsPresentation As Boolean
    Get
public:
property bool DocumentIsPresentation {
    bool get ();
}
member DocumentIsPresentation : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.FeatureIsSuppressedOrMissing

Proprietà SelInfoItemFeatureIsSuppressedOrMissing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool FeatureIsSuppressedOrMissing { get; }
Public ReadOnly Property FeatureIsSuppressedOrMissing As Boolean
    Get
public:
property bool FeatureIsSuppressedOrMissing {
    bool get ();
}
member FeatureIsSuppressedOrMissing : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.HasDedData

Proprietà SelInfoItemHasDedData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDedData { get; }
Public ReadOnly Property HasDedData As Boolean
    Get
public:
property bool HasDedData {
    bool get ();
}
member HasDedData : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.HasDedDoc

Proprietà SelInfoItemHasDedDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDedDoc { get; }
Public ReadOnly Property HasDedDoc As Boolean
    Get
public:
property bool HasDedDoc {
    bool get ();
}
member HasDedDoc : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.HasDocument

Proprietà SelInfoItemHasDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDocument { get; }
Public ReadOnly Property HasDocument As Boolean
    Get
public:
property bool HasDocument {
    bool get ();
}
member HasDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.IsComponent

Proprietà SelInfoItemIsComponent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsComponent { get; }
Public ReadOnly Property IsComponent As Boolean
    Get
public:
property bool IsComponent {
    bool get ();
}
member IsComponent : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.IsEditDocument

Proprietà SelInfoItemIsEditDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsEditDocument { get; }
Public ReadOnly Property IsEditDocument As Boolean
    Get
public:
property bool IsEditDocument {
    bool get ();
}
member IsEditDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.IsFeature

Proprietà SelInfoItemIsFeature

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsFeature { get; }
Public ReadOnly Property IsFeature As Boolean
    Get
public:
property bool IsFeature {
    bool get ();
}
member IsFeature : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Proprietà SelInfoItem.IsTopDocument

Proprietà SelInfoItemIsTopDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsTopDocument { get; }
Public ReadOnly Property IsTopDocument As Boolean
    Get
public:
property bool IsTopDocument {
    bool get ();
}
member IsTopDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Metodi di SelInfoItem

Il tipo SelInfoItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Metodo SelInfoItem.Equals

Metodo SelInfoItemEquals

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Metodo SelInfoItem.GetHashCode

Metodo SelInfoItemGetHashCode

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Metodo SelInfoItem.ToString

Metodo SelInfoItemToString

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Campi di SelInfoItem

Il tipo SelInfoItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | RawReferenceFileName |
Campo pubblico | SwComponent |
Campo pubblico | SwDocument |
Campo pubblico | SwFeature |
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Campo SelInfoItem.RawReferenceFileName

Campo SelInfoItemRawReferenceFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly string RawReferenceFileName
Public ReadOnly RawReferenceFileName As String
public:
initonly String^ RawReferenceFileName
val RawReferenceFileName: string

Valore del campo

String
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Campo SelInfoItem.SwComponent

Campo SelInfoItemSwComponent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly IComponent2 SwComponent
Public ReadOnly SwComponent As IComponent2
public:
initonly IComponent2^ SwComponent
val SwComponent: IComponent2

Valore del campo

IComponent2
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Campo SelInfoItem.SwDocument

Campo SelInfoItemSwDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly IModelDoc2 SwDocument
Public ReadOnly SwDocument As IModelDoc2
public:
initonly IModelDoc2^ SwDocument
val SwDocument: IModelDoc2

Valore del campo

IModelDoc2
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Campo SelInfoItem.SwFeature

Campo SelInfoItemSwFeature

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly IFeature SwFeature
Public ReadOnly SwFeature As IFeature
public:
initonly IFeature^ SwFeature
val SwFeature: IFeature

Valore del campo

IFeature
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetSw


Classe SelInfoItemList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList SelInfoItem
DedNetSwSelInfoItemList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SelInfoItemList : List<SelInfoItem>
Public Class SelInfoItemList
    Inherits List(Of SelInfoItem)
public ref class SelInfoItemList : public List<SelInfoItem^>
type SelInfoItemList =
    class
        inherit List<SelInfoItem>
    end

Il tipo SelInfoItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SelInfoItemList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllSelectedOccurrencesAreEqual |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SelInfoItemList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItemList()
Public Sub New
public:
SelInfoItemList()
new : unit -> SelInfoItemList
Vedi anche

Documentazione

Classe SelInfoItemList
Namespace DedNetSw


Proprietà di SelInfoItemList

Il tipo SelInfoItemList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllSelectedOccurrencesAreEqual |
Torna su
Vedi anche

Documentazione

Classe SelInfoItemList
Namespace DedNetSw


Proprietà SelInfoItemList.AllSelectedOccurrencesAreEqual

Proprietà SelInfoItemListAllSelectedOccurrencesAreEqual

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllSelectedOccurrencesAreEqual { get; }
Public ReadOnly Property AllSelectedOccurrencesAreEqual As Boolean
    Get
public:
property bool AllSelectedOccurrencesAreEqual {
    bool get ();
}
member AllSelectedOccurrencesAreEqual : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelInfoItemList
Namespace DedNetSw


Classe SolidworksOpenEventInfo
Gerarchia di ereditarietà
SystemObject
DedNetSwSolidworksOpenEventInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SolidworksOpenEventInfo
Public Class SolidworksOpenEventInfo
public ref class SolidworksOpenEventInfo
type SolidworksOpenEventInfo = class end

Il tipo SolidworksOpenEventInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SolidworksOpenEventInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | MainFileName |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | RestoreStatus |
Metodo pubblico | SaveStatus |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SolidworksOpenEventInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SolidworksOpenEventInfo(
    string FullFileName
)
Public Sub New (
    FullFileName As String
)
public:
SolidworksOpenEventInfo(
    String^ FullFileName
)
new :
        FullFileName : string -> SolidworksOpenEventInfo

Parametri

FullFileName String
Vedi anche

Documentazione

Classe SolidworksOpenEventInfo
Namespace DedNetSw


Proprietà di SolidworksOpenEventInfo

Il tipo SolidworksOpenEventInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | MainFileName |
Torna su
Vedi anche

Documentazione

Classe SolidworksOpenEventInfo
Namespace DedNetSw


Proprietà SolidworksOpenEventInfo.MainFileName

Proprietà SolidworksOpenEventInfoMainFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string MainFileName { get; set; }
Public Property MainFileName As String
    Get
    Set
public:
property String^ MainFileName {
    String^ get ();
    void set (String^ value);
}
member MainFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SolidworksOpenEventInfo
Namespace DedNetSw


Metodi di SolidworksOpenEventInfo

Il tipo SolidworksOpenEventInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | RestoreStatus |
Metodo pubblico | SaveStatus |
Torna su
Vedi anche

Documentazione

Classe SolidworksOpenEventInfo
Namespace DedNetSw


Metodo SolidworksOpenEventInfo.RestoreStatus

Metodo SolidworksOpenEventInfoRestoreStatus

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreStatus()
Public Sub RestoreStatus
public:
void RestoreStatus()
member RestoreStatus : unit -> unit
Vedi anche

Documentazione

Classe SolidworksOpenEventInfo
Namespace DedNetSw


Metodo SolidworksOpenEventInfo.SaveStatus

Metodo SolidworksOpenEventInfoSaveStatus

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveStatus()
Public Sub SaveStatus
public:
void SaveStatus()
member SaveStatus : unit -> unit
Vedi anche

Documentazione

Classe SolidworksOpenEventInfo
Namespace DedNetSw


Classe SwCommandBase
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
Altro

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public abstract class SwCommandBase : DedCommand
Public MustInherit Class SwCommandBase
    Inherits DedCommand
public ref class SwCommandBase abstract : public DedCommand
[<AbstractClassAttribute>]
type SwCommandBase =
    class
        inherit DedCommand
    end

Il tipo SwCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx |
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura |
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute |
Metodo protetto | ExecuteCommand | (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | SwEnabled |
Metodo pubblico | SwSetContext |
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAggiornaAttributiDaDB
DedNetSw.CommandsAggiornaDocumentoLocale
DedNetSw.CommandsAnnullaCheckOut
DedNetSw.CommandsApriconOpzioni
DedNetSw.CommandsApriFileAssociati
DedNetSw.CommandsApriInLettura
DedNetSw.CommandsApriInModifica
DedNetSw.CommandsApriInNuovaFinestra
DedNetSw.CommandsArchiviaDoc
DedNetSw.CommandsAssociaTavola
DedNetSw.CommandsAssociatedECO
DedNetSw.CommandsAssociatedTranslations
DedNetSw.CommandsAttributi
DedNetSw.CommandsCambiaPassword
DedNetSw.CommandsCambiaStato
DedNetSw.CommandsCaricaParte
DedNetSw.CommandsCheckIn
DedNetSw.CommandsCheckOut
DedNetSw.CommandsConfiguraDistinta
DedNetSw.CommandsControlloCoerenzaRiferimenti
DedNetSw.CommandsCreaComponenteAnagrafica
DedNetSw.CommandsCreaNuovaRappresentazione
DedNetSw.CommandsCreaSwAssociaConf
DedNetSw.CommandsCreaSwAssociaDocument
DedNetSw.CommandsCreaSwDisconnectConf
DedNetSw.CommandsCreateSparePartsDrawing
DedNetSw.CommandsDipendenze
DedNetSw.CommandsDistintaComponenti
DedNetSw.CommandsDistintaEsplosa
DedNetSw.CommandsDistintaImplosa
DedNetSw.CommandsDocAssocSw
DedNetSw.CommandsDocRecognizer
DedNetSw.CommandsDocumentAssistant
DedNetSw.CommandsEditaAttributiSoloDB
DedNetSw.CommandsEditaCommesse
DedNetSw.CommandsEditaDistinta
DedNetSw.CommandsEditaECO
DedNetSw.CommandsEnsureLocalAssociated
DedNetSw.CommandsEnvMan
DedNetSw.CommandsEseguiLua
DedNetSw.CommandsFindDoc
DedNetSw.CommandsFindInBrowser
DedNetSw.CommandsFindInRicerca
DedNetSw.CommandsForceMarkerAlingment
DedNetSw.CommandsFormAbout
DedNetSw.CommandsHelpSolidWorks
DedNetSw.CommandsIndividuaGrafica
DedNetSw.CommandsLinkDEDApplicazione
DedNetSw.CommandsMarkerInfo
DedNetSw.CommandsOpzioniApplicazione
DedNetSw.CommandsPackAndGoExport
DedNetSw.CommandsPackAndGoImport
DedNetSw.CommandsPubblica
DedNetSw.CommandsPublishSparePartsDrawing
DedNetSw.CommandsPwsCache
DedNetSw.CommandsRegistra
DedNetSw.CommandsRicerca
DedNetSw.CommandsSalva
DedNetSw.CommandsSalvaConf
DedNetSw.CommandsSalvaDist
DedNetSw.CommandsSalvaMultiplo
DedNetSw.CommandsSalvaRev
DedNetSw.CommandsSblocca
DedNetSw.CommandsSostituisciComponente
DedNetSw.CommandsSostituisciComponenteRapido
DedNetSw.CommandsSostituisciMoved
DedNetSw.CommandsStatoDocumento
DedNetSw.CommandsSwDataStatisticsAnalyzer
DedNetSw.CommandsSwUserLogin
DedNetSw.CommandsTabellaRevisioni
DedNetSw.CommandsUpdateBranchInformations
DedNetSw.CommandsUpdateOldRev
DedNetSw.CommandsWhereUsedSw


Proprietà di SwCommandBase

Il tipo SwCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx |
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommand.NeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura |
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Proprietà SwCommandBase.AddToolbar

Proprietà SwCommandBaseAddToolbar

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AddToolbar { get; set; }
Public Property AddToolbar As Boolean
    Get
    Set
public:
property bool AddToolbar {
    bool get ();
    void set (bool value);
}
member AddToolbar : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Proprietà SwCommandBase.IconIdx

Proprietà SwCommandBaseIconIdx

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int IconIdx { get; set; }
Public Property IconIdx As Integer
    Get
    Set
public:
property int IconIdx {
    int get ();
    void set (int value);
}
member IconIdx : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Proprietà SwCommandBase.NeedParameters

Proprietà SwCommandBaseNeedParameters

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Proprietà SwCommandBase.ShowInDocumentType

Proprietà SwCommandBaseShowInDocumentType

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public swDocTemplateTypes_e ShowInDocumentType { get; set; }
Public Property ShowInDocumentType As swDocTemplateTypes_e
    Get
    Set
public:
property swDocTemplateTypes_e ShowInDocumentType {
    swDocTemplateTypes_e get ();
    void set (swDocTemplateTypes_e value);
}
member ShowInDocumentType : swDocTemplateTypes_e with get, set

Valore della proprietà

swDocTemplateTypes_e
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Proprietà SwCommandBase.Struttura

Proprietà SwCommandBaseStruttura

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodi di SwCommandBase

Il tipo SwCommandBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand)
Metodo pubblico | Enabled | (Sovrascrive DedCommand.Enabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute |
Metodo protetto | ExecuteCommand | (Sovrascrive DedCommand.ExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommand.SetContext(DedCommandContext))
Metodo pubblico | SwEnabled |
Metodo pubblico | SwSetContext |
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.ClearCommand

Metodo SwCommandBaseClearCommand

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.Enabled

Metodo SwCommandBaseEnabled

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.Execute

Metodo SwCommandBaseExecute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public virtual void Execute()
Public Overridable Sub Execute
public:
virtual void Execute()
abstract Execute : unit -> unit
override Execute : unit -> unit
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.ExecuteCommand

Metodo SwCommandBaseExecuteCommand

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCmdResult ExecuteCommand()
Protected MustOverride Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() abstract override
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.SetContext

Metodo SwCommandBaseSetContext

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.SwEnabled

Metodo SwCommandBaseSwEnabled

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public abstract bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public MustOverride Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) abstract
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Metodo SwCommandBase.SwSetContext

Metodo SwCommandBaseSwSetContext

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public abstract bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public MustOverride Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) abstract
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwCommandBase
Namespace DedNetSw


Classe SwCurSelInfo
Gerarchia di ereditarietà
SystemObject
DedNetSwSwCurSelInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwCurSelInfo
Public Class SwCurSelInfo
public ref class SwCurSelInfo
type SwCurSelInfo = class end

Il tipo SwCurSelInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SwCurSelInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FirstElement |
Proprietà pubblica | HasSelectedElements |
Proprietà pubblica | IsEditSelected |
Proprietà pubblica | IsTopSelected |
Proprietà pubblica | MultiSelect |
Proprietà pubblica | SingleSelect |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | DoTheWork |
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | TraverseFeatures |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | EditDocument |
Campo pubblico | EditMode |
Campo pubblico | Elements |
Campo pubblico | ThereAreDocuments |
Campo pubblico | TopDocument |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SwCurSelInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwCurSelInfo()
Public Sub New
public:
SwCurSelInfo()
new : unit -> SwCurSelInfo
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà di SwCurSelInfo

Il tipo SwCurSelInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FirstElement |
Proprietà pubblica | HasSelectedElements |
Proprietà pubblica | IsEditSelected |
Proprietà pubblica | IsTopSelected |
Proprietà pubblica | MultiSelect |
Proprietà pubblica | SingleSelect |
Torna su
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà SwCurSelInfo.FirstElement

Proprietà SwCurSelInfoFirstElement

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem FirstElement { get; }
Public ReadOnly Property FirstElement As SelInfoItem
    Get
public:
property SelInfoItem^ FirstElement {
    SelInfoItem^ get ();
}
member FirstElement : SelInfoItem with get

Valore della proprietà

SelInfoItem
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà SwCurSelInfo.HasSelectedElements

Proprietà SwCurSelInfoHasSelectedElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasSelectedElements { get; }
Public ReadOnly Property HasSelectedElements As Boolean
    Get
public:
property bool HasSelectedElements {
    bool get ();
}
member HasSelectedElements : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà SwCurSelInfo.IsEditSelected

Proprietà SwCurSelInfoIsEditSelected

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsEditSelected { get; }
Public ReadOnly Property IsEditSelected As Boolean
    Get
public:
property bool IsEditSelected {
    bool get ();
}
member IsEditSelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà SwCurSelInfo.IsTopSelected

Proprietà SwCurSelInfoIsTopSelected

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsTopSelected { get; }
Public ReadOnly Property IsTopSelected As Boolean
    Get
public:
property bool IsTopSelected {
    bool get ();
}
member IsTopSelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà SwCurSelInfo.MultiSelect

Proprietà SwCurSelInfoMultiSelect

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MultiSelect { get; }
Public ReadOnly Property MultiSelect As Boolean
    Get
public:
property bool MultiSelect {
    bool get ();
}
member MultiSelect : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Proprietà SwCurSelInfo.SingleSelect

Proprietà SwCurSelInfoSingleSelect

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SingleSelect { get; }
Public ReadOnly Property SingleSelect As Boolean
    Get
public:
property bool SingleSelect {
    bool get ();
}
member SingleSelect : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Metodi di SwCurSelInfo

Il tipo SwCurSelInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | DoTheWork |
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | TraverseFeatures |
Torna su
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Metodo SwCurSelInfo.DoTheWork

Metodo SwCurSelInfoDoTheWork

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DoTheWork(
    Feature thisFeat,
    string ParentName,
    Body2 bToFind
)
Public Sub DoTheWork (
    thisFeat As Feature,
    ParentName As String,
    bToFind As Body2
)
public:
void DoTheWork(
    Feature^ thisFeat,
    String^ ParentName,
    Body2^ bToFind
)
member DoTheWork :
        thisFeat : Feature *
        ParentName : string *
        bToFind : Body2 -> unit

Parametri

thisFeat Feature
ParentName String
bToFind Body2
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Metodo SwCurSelInfo.Equals

Metodo SwCurSelInfoEquals

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Metodo SwCurSelInfo.TraverseFeatures

Metodo SwCurSelInfoTraverseFeatures

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void TraverseFeatures(
    Feature thisFeat,
    bool isTopLevel,
    string ParentName,
    Body2 bToFind
)
Public Sub TraverseFeatures (
    thisFeat As Feature,
    isTopLevel As Boolean,
    ParentName As String,
    bToFind As Body2
)
public:
void TraverseFeatures(
    Feature^ thisFeat,
    bool isTopLevel,
    String^ ParentName,
    Body2^ bToFind
)
member TraverseFeatures :
        thisFeat : Feature *
        isTopLevel : bool *
        ParentName : string *
        bToFind : Body2 -> unit

Parametri

thisFeat Feature
isTopLevel Boolean
ParentName String
bToFind Body2
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Campi di SwCurSelInfo

Il tipo SwCurSelInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | EditDocument |
Campo pubblico | EditMode |
Campo pubblico | Elements |
Campo pubblico | ThereAreDocuments |
Campo pubblico | TopDocument |
Torna su
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Campo SwCurSelInfo.EditDocument

Campo SwCurSelInfoEditDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly SelInfoItem EditDocument
Public ReadOnly EditDocument As SelInfoItem
public:
initonly SelInfoItem^ EditDocument
val EditDocument: SelInfoItem

Valore del campo

SelInfoItem
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Campo SwCurSelInfo.EditMode

Campo SwCurSelInfoEditMode

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool EditMode
Public ReadOnly EditMode As Boolean
public:
initonly bool EditMode
val EditMode: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Campo SwCurSelInfo.Elements

Campo SwCurSelInfoElements

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly SelInfoItemList Elements
Public ReadOnly Elements As SelInfoItemList
public:
initonly SelInfoItemList^ Elements
val Elements: SelInfoItemList

Valore del campo

SelInfoItemList
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Campo SwCurSelInfo.ThereAreDocuments

Campo SwCurSelInfoThereAreDocuments

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool ThereAreDocuments
Public ReadOnly ThereAreDocuments As Boolean
public:
initonly bool ThereAreDocuments
val ThereAreDocuments: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Campo SwCurSelInfo.TopDocument

Campo SwCurSelInfoTopDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly SelInfoItem TopDocument
Public ReadOnly TopDocument As SelInfoItem
public:
initonly SelInfoItem^ TopDocument
val TopDocument: SelInfoItem

Valore del campo

SelInfoItem
Vedi anche

Documentazione

Classe SwCurSelInfo
Namespace DedNetSw


Classe SwDocStructInfo
Gerarchia di ereditarietà
SystemObject
DocStructInfo
DedNetSwSwDocStructInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwDocStructInfo : DocStructInfo
Public Class SwDocStructInfo
    Inherits DocStructInfo
public ref class SwDocStructInfo : public DocStructInfo
type SwDocStructInfo =
    class
        inherit DocStructInfo
    end

Il tipo SwDocStructInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | SwDocStructInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DocStructInfo)
Proprietà pubblica | CfgDescr | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate. (Ereditato da DocStructInfo)
Proprietà pubblica | ChildrenMade | Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta. (Ereditato da DocStructInfo)
Proprietà pubblica | CloneFullName | Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true). (Ereditato da DocStructInfo)
Proprietà pubblica | Config | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate. (Ereditato da DocStructInfo)
Proprietà pubblica | Data |
Proprietà pubblica | DataUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo)
Proprietà pubblica | DelToMake | Indica che si deve creare il .del del file di partenza. (Ereditato da DocStructInfo)
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza. (Ereditato da DocStructInfo)
Proprietà pubblica | Description | Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client. (Ereditato da DocStructInfo)
Proprietà pubblica | DocRowVer | Restituisce il DocRowVer calcolato tramite Md5. (Ereditato da DocStructInfo)
Proprietà pubblica | DoNotMoveOrDelete | Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard (Ereditato da DocStructInfo)
Proprietà pubblica | FileDescriptor | Restituisce il file descriptor utilizzato alla creazione dell'oggetto (Ereditato da DocStructInfo)
Proprietà pubblica | FileOperationExecuted | Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite. (Ereditato da DocStructInfo)
Proprietà pubblica | FirstOperation | Restituisce la prima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | Folder | Cartella nella quale spostare il file (usata nell'importazione di cartelle) (Ereditato da DocStructInfo)
Proprietà pubblica | FullFileName |
Proprietà pubblica | HasChildren | Restitusice se questo elemento ha delle dipendenze. (Ereditato da DocStructInfo)
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo)
Proprietà pubblica | HasSubstitutes | Restituisce se l'elemento abbia o meno sostituti di livello di dettaglio. (Ereditato da DocStructInfo)
Proprietà pubblica | HasSwDoc |
Proprietà pubblica | IgnoreSuppressed |
Proprietà pubblica | InternalName | Restituisce o imposta l'internalname dell'elemento (Ereditato da DocStructInfo)
Proprietà pubblica | IsElaborated | Restituisce se l'ultima operazione sia o meno stata effettuata. (Ereditato da DocStructInfo)
Proprietà pubblica | IsiModelMember | Restituisce se l'elemento sia o meno un elemento di layout (Ereditato da DocStructInfo)
Proprietà pubblica | IsInRootCopy | Indica se appartiene ad una root su cui fare il Copy. Se non appartiene a nessuna Root restituisce False (Ereditato da DocStructInfo)
Proprietà pubblica | IsLayoutAsset | Restituisce se l'elemento sia o meno un elemento di layout (Ereditato da DocStructInfo)
Proprietà pubblica | IsModel |
Proprietà pubblica | IsParentSubstitute | Restituisce se l'elemento sia o meno un sostituto di livello di dettaglio dell'assieme padre in salvataggio. (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructContainer | Restituisce se l'elemento sia contenitore o meno di strutture speciali (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructElement | Restituisce se l'elemento rappresenti un componente di struttura speciale (Ereditato da DocStructInfo)
Proprietà pubblica | IsSubstitute | Restituisce se l'elemento sia o meno un parte rappresentante un sostituto di livello di dettaglio (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperation | Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperationEnum | Restituisce l'ultima operazione eseguita. (Ereditato da DocStructInfo)
Proprietà pubblica | MakeChildrenOutOfMemory | Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client (Ereditato da DocStructInfo)
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se il documento debba essere spostato invece di importato. (Ereditato da DocStructInfo)
Proprietà pubblica | OperationList | Restituisce la lista in sola lettura, presenti per questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | OpListHierarchy | Restituisce la lista in sola lettura, presenti per questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | Parent | Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root. (Ereditato da DocStructInfo)
Proprietà pubblica | ReferenceUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo)
Proprietà pubblica | RelocateInfo | Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato (Ereditato da DocStructInfo)
Proprietà pubblica | SavingTypeDoc | Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio. (Ereditato da DocStructInfo)
Proprietà pubblica | SkipReferenceUpdate | Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference (Ereditato da DocStructInfo)
Proprietà pubblica | SwDoc |
Proprietà pubblica | Ties | Restituisce la collezione delle dipendenze. (Ereditato da DocStructInfo)
Proprietà pubblica | ToClone | Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione. (Ereditato da DocStructInfo)
Proprietà pubblica | UserData | Restituisce o imposta i dati utente abbinati a questo oggetto. (Ereditato da DocStructInfo)
Proprietà pubblica | WasInDb | Restituisce se il file risultasse già registrato nel Database in partenza. (Ereditato da DocStructInfo)
Proprietà pubblica | WasInLibraryPath | Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor). (Ereditato da DocStructInfo)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | Annulla il check-out di un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInOperation | Imposta in checkin un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa. (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingStrutturaOperation | Operazione di esportazione del documento (struttura) (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInOperation | Forza in checkin un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaStrutturaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo)
Metodo pubblico | AddRemovingOperation | Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista. (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddSbloccaOperation | Sblocca un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddUpdatingOperation | Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo)
Metodo pubblico | BottomUpCall | Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto. (Ereditato da DocStructInfo)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor))
Metodo pubblico | CreateDocStructInfo(String) | (Sovrascrive DocStructInfo.CreateDocStructInfo(String))
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) |
 | CreateDocStructInfo(DedNetApplication, String) |
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo))
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Ereditato da DocStructInfo)
Metodo pubblico | EnforcedMakeChildrenAuto | (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String))
Metodo pubblico | Equals | (Ereditato da DocStructInfo)
Metodo pubblico | FileNameAreEquals | (Ereditato da DocStructInfo)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo)
Metodo pubblico | GetAllSpecialChildren | Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale (Ereditato da DocStructInfo)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetLastQueuedOperation | Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null. (Ereditato da DocStructInfo)
Metodo pubblico | GetOperation | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null. (Ereditato da DocStructInfo)
Metodo pubblico | GetOperationHierarchy | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null. (Ereditato da DocStructInfo)
Metodo pubblico | HasOperation | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato (Ereditato da DocStructInfo)
Metodo pubblico | HasOperationHierarchy | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato (Ereditato da DocStructInfo)
 | IsInChildrenCollection |
Metodo pubblico | MakeChildrenAuto | (Sovrascrive DocStructInfo.MakeChildrenAuto)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database. (Ereditato da DocStructInfo)
Metodo pubblico | MakeChildrenAutoByDocDep | Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura. (Ereditato da DocStructInfo)
 | MakeFromDocDocStructInfo |
 | MakeFromDocList |
 | MakeFromFileList |
 | MakeFromFileListUsingApprentice |
 | MakeFromSwDocList |
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo)
Metodo pubblico | Rebuild | Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file. (Ereditato da DocStructInfo)
Metodo pubblico | Reinit | Reinizializza il DocStructInfo riportandolo allo stato originale. Svuota la lista delle operazioni. (Ereditato da DocStructInfo)
Metodo pubblico | SetNotToClone | Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null). (Ereditato da DocStructInfo)
Metodo pubblico | SetToClone | Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName). (Ereditato da DocStructInfo)
Metodo pubblico | ToString | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateData | Aggiorna le anagrafiche collegate sugli oggetti elaborati. Nella classebase non fa niente. (Ereditato da DocStructInfo)
Metodo pubblico | UpdateDocumentData | Aggiorna tutti il documento dell'oggetto e di tutti i figli (Ereditato da DocStructInfo)
Metodo pubblico | UpdateParentReferences | Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Nella classe base non fa niente. (Ereditato da DocStructInfo)
Metodo pubblico | UpdateReferences | (Sovrascrive DocStructInfo.UpdateReferences)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Elements | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo)
Campo pubblico | IgnoreCheckParentCollection | Indica se ignorare il controllo sulla ricorsione dei padri. (Ereditato da DocStructInfo)
Campo protetto | Operations | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SwDocStructInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected SwDocStructInfo(
    DedNetApplication app,
    DocStructInfoCollection parent,
    DocStructInfoDictionary elements,
    DocStructInfoOperationListDictionary operations,
    DocStructInfoFileDescriptor fileDescr,
    DocDepEnum depType
)
Protected Sub New (
    app As DedNetApplication,
    parent As DocStructInfoCollection,
    elements As DocStructInfoDictionary,
    operations As DocStructInfoOperationListDictionary,
    fileDescr As DocStructInfoFileDescriptor,
    depType As DocDepEnum
)
protected:
SwDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoCollection^ parent,
    DocStructInfoDictionary^ elements,
    DocStructInfoOperationListDictionary^ operations,
    DocStructInfoFileDescriptor^ fileDescr,
    DocDepEnum depType
)
new :
        app : DedNetApplication *
        parent : DocStructInfoCollection *
        elements : DocStructInfoDictionary *
        operations : DocStructInfoOperationListDictionary *
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> SwDocStructInfo

Parametri

app DedNetApplication
parent DocStructInfoCollection
elements DocStructInfoDictionary
operations DocStructInfoOperationListDictionary
fileDescr DocStructInfoFileDescriptor
depType DocDepEnum
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà di SwDocStructInfo

Il tipo SwDocStructInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DocStructInfo)
Proprietà pubblica | CfgDescr | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate. (Ereditato da DocStructInfo)
Proprietà pubblica | ChildrenMade | Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta. (Ereditato da DocStructInfo)
Proprietà pubblica | CloneFullName | Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true). (Ereditato da DocStructInfo)
Proprietà pubblica | Config | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate. (Ereditato da DocStructInfo)
Proprietà pubblica | Data |
Proprietà pubblica | DataUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo)
Proprietà pubblica | DelToMake | Indica che si deve creare il .del del file di partenza. (Ereditato da DocStructInfo)
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza. (Ereditato da DocStructInfo)
Proprietà pubblica | Description | Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client. (Ereditato da DocStructInfo)
Proprietà pubblica | DocRowVer | Restituisce il DocRowVer calcolato tramite Md5. (Ereditato da DocStructInfo)
Proprietà pubblica | DoNotMoveOrDelete | Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard (Ereditato da DocStructInfo)
Proprietà pubblica | FileDescriptor | Restituisce il file descriptor utilizzato alla creazione dell'oggetto (Ereditato da DocStructInfo)
Proprietà pubblica | FileOperationExecuted | Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite. (Ereditato da DocStructInfo)
Proprietà pubblica | FirstOperation | Restituisce la prima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | Folder | Cartella nella quale spostare il file (usata nell'importazione di cartelle) (Ereditato da DocStructInfo)
Proprietà pubblica | FullFileName |
Proprietà pubblica | HasChildren | Restitusice se questo elemento ha delle dipendenze. (Ereditato da DocStructInfo)
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo)
Proprietà pubblica | HasSubstitutes | Restituisce se l'elemento abbia o meno sostituti di livello di dettaglio. (Ereditato da DocStructInfo)
Proprietà pubblica | HasSwDoc |
Proprietà pubblica | IgnoreSuppressed |
Proprietà pubblica | InternalName | Restituisce o imposta l'internalname dell'elemento (Ereditato da DocStructInfo)
Proprietà pubblica | IsElaborated | Restituisce se l'ultima operazione sia o meno stata effettuata. (Ereditato da DocStructInfo)
Proprietà pubblica | IsiModelMember | Restituisce se l'elemento sia o meno un elemento di layout (Ereditato da DocStructInfo)
Proprietà pubblica | IsInRootCopy | Indica se appartiene ad una root su cui fare il Copy. Se non appartiene a nessuna Root restituisce False (Ereditato da DocStructInfo)
Proprietà pubblica | IsLayoutAsset | Restituisce se l'elemento sia o meno un elemento di layout (Ereditato da DocStructInfo)
Proprietà pubblica | IsModel |
Proprietà pubblica | IsParentSubstitute | Restituisce se l'elemento sia o meno un sostituto di livello di dettaglio dell'assieme padre in salvataggio. (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructContainer | Restituisce se l'elemento sia contenitore o meno di strutture speciali (Ereditato da DocStructInfo)
Proprietà pubblica | IsSpecialStructElement | Restituisce se l'elemento rappresenti un componente di struttura speciale (Ereditato da DocStructInfo)
Proprietà pubblica | IsSubstitute | Restituisce se l'elemento sia o meno un parte rappresentante un sostituto di livello di dettaglio (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperation | Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | LastOperationEnum | Restituisce l'ultima operazione eseguita. (Ereditato da DocStructInfo)
Proprietà pubblica | MakeChildrenOutOfMemory | Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client (Ereditato da DocStructInfo)
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se il documento debba essere spostato invece di importato. (Ereditato da DocStructInfo)
Proprietà pubblica | OperationList | Restituisce la lista in sola lettura, presenti per questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | OpListHierarchy | Restituisce la lista in sola lettura, presenti per questo elemento. (Ereditato da DocStructInfo)
Proprietà pubblica | Parent | Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root. (Ereditato da DocStructInfo)
Proprietà pubblica | ReferenceUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo)
Proprietà pubblica | RelocateInfo | Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato (Ereditato da DocStructInfo)
Proprietà pubblica | SavingTypeDoc | Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio. (Ereditato da DocStructInfo)
Proprietà pubblica | SkipReferenceUpdate | Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference (Ereditato da DocStructInfo)
Proprietà pubblica | SwDoc |
Proprietà pubblica | Ties | Restituisce la collezione delle dipendenze. (Ereditato da DocStructInfo)
Proprietà pubblica | ToClone | Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione. (Ereditato da DocStructInfo)
Proprietà pubblica | UserData | Restituisce o imposta i dati utente abbinati a questo oggetto. (Ereditato da DocStructInfo)
Proprietà pubblica | WasInDb | Restituisce se il file risultasse già registrato nel Database in partenza. (Ereditato da DocStructInfo)
Proprietà pubblica | WasInLibraryPath | Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor). (Ereditato da DocStructInfo)
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà SwDocStructInfo.Data

Proprietà SwDocStructInfoData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà SwDocStructInfo.FullFileName

Proprietà SwDocStructInfoFullFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà SwDocStructInfo.HasSwDoc

Proprietà SwDocStructInfoHasSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasSwDoc { get; }
Public ReadOnly Property HasSwDoc As Boolean
    Get
public:
property bool HasSwDoc {
    bool get ();
}
member HasSwDoc : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà SwDocStructInfo.IgnoreSuppressed

Proprietà SwDocStructInfoIgnoreSuppressed

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreSuppressed { get; set; }
Public Property IgnoreSuppressed As Boolean
    Get
    Set
public:
property bool IgnoreSuppressed {
    bool get ();
    void set (bool value);
}
member IgnoreSuppressed : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà SwDocStructInfo.IsModel

Proprietà SwDocStructInfoIsModel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsModel { get; }
Public ReadOnly Property IsModel As Boolean
    Get
public:
property bool IsModel {
    bool get ();
}
member IsModel : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Proprietà SwDocStructInfo.SwDoc

Proprietà SwDocStructInfoSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; }
Public ReadOnly Property SwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
}
member SwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodi di SwDocStructInfo

Il tipo SwDocStructInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | Annulla il check-out di un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInOperation | Imposta in checkin un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa. (Ereditato da DocStructInfo)
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento (Ereditato da DocStructInfo)
Metodo pubblico | AddExportingStrutturaOperation | Operazione di esportazione del documento (struttura) (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInOperation | Forza in checkin un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddPubblicaStrutturaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo)
Metodo pubblico | AddRemovingOperation | Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista. (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo)
Metodo pubblico | AddSbloccaOperation | Sblocca un documento. (Ereditato da DocStructInfo)
Metodo pubblico | AddUpdatingOperation | Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo)
Metodo pubblico | BottomUpCall | Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto. (Ereditato da DocStructInfo)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor))
Metodo pubblico | CreateDocStructInfo(String) | (Sovrascrive DocStructInfo.CreateDocStructInfo(String))
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) |
 | CreateDocStructInfo(DedNetApplication, String) |
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo))
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Ereditato da DocStructInfo)
Metodo pubblico | EnforcedMakeChildrenAuto | (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String))
Metodo pubblico | Equals | (Ereditato da DocStructInfo)
Metodo pubblico | FileNameAreEquals | (Ereditato da DocStructInfo)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo)
Metodo pubblico | GetAllSpecialChildren | Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale (Ereditato da DocStructInfo)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo)
Metodo pubblico | GetHashString | (Ereditato da DocStructInfo)
Metodo pubblico | GetLastQueuedOperation | Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null. (Ereditato da DocStructInfo)
Metodo pubblico | GetOperation | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null. (Ereditato da DocStructInfo)
Metodo pubblico | GetOperationHierarchy | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null. (Ereditato da DocStructInfo)
Metodo pubblico | HasOperation | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato (Ereditato da DocStructInfo)
Metodo pubblico | HasOperationHierarchy | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato (Ereditato da DocStructInfo)
 | IsInChildrenCollection |
Metodo pubblico | MakeChildrenAuto | (Sovrascrive DocStructInfo.MakeChildrenAuto)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database. (Ereditato da DocStructInfo)
Metodo pubblico | MakeChildrenAutoByDocDep | Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura. (Ereditato da DocStructInfo)
 | MakeFromDocDocStructInfo |
 | MakeFromDocList |
 | MakeFromFileList |
 | MakeFromFileListUsingApprentice |
 | MakeFromSwDocList |
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo)
Metodo pubblico | Rebuild | Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file. (Ereditato da DocStructInfo)
Metodo pubblico | Reinit | Reinizializza il DocStructInfo riportandolo allo stato originale. Svuota la lista delle operazioni. (Ereditato da DocStructInfo)
Metodo pubblico | SetNotToClone | Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null). (Ereditato da DocStructInfo)
Metodo pubblico | SetToClone | Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName). (Ereditato da DocStructInfo)
Metodo pubblico | ToString | (Ereditato da DocStructInfo)
Metodo pubblico | UpdateData | Aggiorna le anagrafiche collegate sugli oggetti elaborati. Nella classebase non fa niente. (Ereditato da DocStructInfo)
Metodo pubblico | UpdateDocumentData | Aggiorna tutti il documento dell'oggetto e di tutti i figli (Ereditato da DocStructInfo)
Metodo pubblico | UpdateParentReferences | Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Nella classe base non fa niente. (Ereditato da DocStructInfo)
Metodo pubblico | UpdateReferences | (Sovrascrive DocStructInfo.UpdateReferences)
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.CreateDocStructInfo

Metodo SwDocStructInfoCreateDocStructInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) |
Metodo pubblico | CreateDocStructInfo(String) |
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) |
 | CreateDocStructInfo(DedNetApplication, String) |
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) |
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor)

Metodo SwDocStructInfoCreateDocStructInfo(DocStructInfoFileDescriptor)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr
)
Public Overrides Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr
) override
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo

Parametri

fileDescr DocStructInfoFileDescriptor

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe SwDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.CreateDocStructInfo(String)

Metodo SwDocStructInfoCreateDocStructInfo(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    string fileName
)
Public Overrides Function CreateDocStructInfo (
    fileName As String
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    String^ fileName
) override
abstract CreateDocStructInfo :
        fileName : string -> DocStructInfo
override CreateDocStructInfo :
        fileName : string -> DocStructInfo

Parametri

fileName String

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe SwDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor)

Metodo SwDocStructInfoCreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SwDocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    DocStructInfoFileDescriptor fileDescr
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileDescr As DocStructInfoFileDescriptor
) As SwDocStructInfo
public:
static SwDocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoFileDescriptor^ fileDescr
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileDescr : DocStructInfoFileDescriptor -> SwDocStructInfo

Parametri

app DedNetApplication
fileDescr DocStructInfoFileDescriptor

Valore di ritorno

SwDocStructInfo
Vedi anche

Documentazione

Classe SwDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.CreateDocStructInfo(DedNetApplication, String)

Metodo SwDocStructInfoCreateDocStructInfo(DedNetApplication, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    string fileName
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileName As String
) As DocStructInfo
public:
static DocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    String^ fileName
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileName : string -> DocStructInfo

Parametri

app DedNetApplication
fileName String

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe SwDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo)

Metodo SwDocStructInfoCreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr,
    DocStructInfo parent
)
Public Overrides Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor,
    parent As DocStructInfo
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr,
    DocStructInfo^ parent
) override
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo

Parametri

fileDescr DocStructInfoFileDescriptor
parent DocStructInfo

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe SwDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.EnforcedMakeChildrenAuto

Metodo SwDocStructInfoEnforcedMakeChildrenAuto

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void EnforcedMakeChildrenAuto(
    string enforcedTiesSourceFileName
)
Public Overrides Sub EnforcedMakeChildrenAuto (
    enforcedTiesSourceFileName As String
)
public:
virtual void EnforcedMakeChildrenAuto(
    String^ enforcedTiesSourceFileName
) override
abstract EnforcedMakeChildrenAuto :
        enforcedTiesSourceFileName : string -> unit
override EnforcedMakeChildrenAuto :
        enforcedTiesSourceFileName : string -> unit

Parametri

enforcedTiesSourceFileName String
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.IsInChildrenCollection

Metodo SwDocStructInfoIsInChildrenCollection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsInChildrenCollection(
    DocStructInfo refDs,
    DocStructInfo ds
)
Public Shared Function IsInChildrenCollection (
    refDs As DocStructInfo,
    ds As DocStructInfo
) As Boolean
public:
static bool IsInChildrenCollection(
    DocStructInfo^ refDs,
    DocStructInfo^ ds
)
static member IsInChildrenCollection :
        refDs : DocStructInfo *
        ds : DocStructInfo -> bool

Parametri

refDs DocStructInfo
ds DocStructInfo

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.MakeChildrenAuto

Metodo SwDocStructInfoMakeChildrenAuto
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeChildrenAuto |
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database.
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.MakeChildrenAuto

Metodo SwDocStructInfoMakeChildrenAuto

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void MakeChildrenAuto()
Public Overrides Sub MakeChildrenAuto
public:
virtual void MakeChildrenAuto() override
abstract MakeChildrenAuto : unit -> unit
override MakeChildrenAuto : unit -> unit
Vedi anche

Documentazione

Classe SwDocStructInfo
Overload di MakeChildrenAuto
Namespace DedNetSw


Metodo SwDocStructInfo.MakeFromDocDocStructInfo

Metodo SwDocStructInfoMakeFromDocDocStructInfo

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromDocDocStructInfo(
    DedNetApplication app,
    DocStructInfoList docList
)
Public Shared Function MakeFromDocDocStructInfo (
    app As DedNetApplication,
    docList As DocStructInfoList
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromDocDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoList^ docList
)
static member MakeFromDocDocStructInfo :
        app : DedNetApplication *
        docList : DocStructInfoList -> DocStructInfoList

Parametri

app DedNetApplication
docList DocStructInfoList

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.MakeFromDocList

Metodo SwDocStructInfoMakeFromDocList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromDocList(
    DedNetApplication app,
    DedDocList docList
)
Public Shared Function MakeFromDocList (
    app As DedNetApplication,
    docList As DedDocList
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromDocList(
    DedNetApplication^ app,
    DedDocList^ docList
)
static member MakeFromDocList :
        app : DedNetApplication *
        docList : DedDocList -> DocStructInfoList

Parametri

app DedNetApplication
docList DedDocList

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.MakeFromFileList

Metodo SwDocStructInfoMakeFromFileList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileList(
    DedNetApplication app,
    string[] fileList
)
Public Shared Function MakeFromFileList (
    app As DedNetApplication,
    fileList As String()
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileList(
    DedNetApplication^ app,
    array<String^>^ fileList
)
static member MakeFromFileList :
        app : DedNetApplication *
        fileList : string[] -> DocStructInfoList

Parametri

app DedNetApplication
fileList String

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.MakeFromFileListUsingApprentice

Metodo SwDocStructInfoMakeFromFileListUsingApprentice

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileListUsingApprentice(
    DedNetApplication app,
    string[] fileList
)
Public Shared Function MakeFromFileListUsingApprentice (
    app As DedNetApplication,
    fileList As String()
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileListUsingApprentice(
    DedNetApplication^ app,
    array<String^>^ fileList
)
static member MakeFromFileListUsingApprentice :
        app : DedNetApplication *
        fileList : string[] -> DocStructInfoList

Parametri

app DedNetApplication
fileList String

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.MakeFromSwDocList

Metodo SwDocStructInfoMakeFromSwDocList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromSwDocList(
    DedNetApplication app,
    IEnumerable<IModelDoc2> swDocs
)
Public Shared Function MakeFromSwDocList (
    app As DedNetApplication,
    swDocs As IEnumerable(Of IModelDoc2)
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromSwDocList(
    DedNetApplication^ app,
    IEnumerable<IModelDoc2^>^ swDocs
)
static member MakeFromSwDocList :
        app : DedNetApplication *
        swDocs : IEnumerable<IModelDoc2> -> DocStructInfoList

Parametri

app DedNetApplication
swDocs IEnumerable IModelDoc2

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Metodo SwDocStructInfo.UpdateReferences

Metodo SwDocStructInfoUpdateReferences

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateReferences()
Public Overrides Sub UpdateReferences
public:
virtual void UpdateReferences() override
abstract UpdateReferences : unit -> unit
override UpdateReferences : unit -> unit
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Campi di SwDocStructInfo

Il tipo SwDocStructInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Elements | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo)
Campo pubblico | IgnoreCheckParentCollection | Indica se ignorare il controllo sulla ricorsione dei padri. (Ereditato da DocStructInfo)
Campo protetto | Operations | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo)
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfo
Namespace DedNetSw


Classe SwDocStructInfoEventHandlers
Gerarchia di ereditarietà
SystemObject
DedNetSwSwDocStructInfoEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwDocStructInfoEventHandlers
Public Class SwDocStructInfoEventHandlers
public ref class SwDocStructInfoEventHandlers
type SwDocStructInfoEventHandlers = class end

Il tipo SwDocStructInfoEventHandlers espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SwDocStructInfoEventHandlers |
Torna su
Metodi
Nome | Descrizione
InitializeDocStructInfoEvents |
OnDocStructInfoCreated |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SwDocStructInfoEventHandlers

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfoEventHandlers()
Public Sub New
public:
SwDocStructInfoEventHandlers()
new : unit -> SwDocStructInfoEventHandlers
Vedi anche

Documentazione

Classe SwDocStructInfoEventHandlers
Namespace DedNetSw


Metodi di SwDocStructInfoEventHandlers

Il tipo SwDocStructInfoEventHandlers espone i seguenti membri.

Metodi
Nome | Descrizione
InitializeDocStructInfoEvents |
OnDocStructInfoCreated |
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfoEventHandlers
Namespace DedNetSw


Metodo SwDocStructInfoEventHandlers.InitializeDocStructInfoEvents

Metodo SwDocStructInfoEventHandlersInitializeDocStructInfoEvents

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void InitializeDocStructInfoEvents()
Public Shared Sub InitializeDocStructInfoEvents
public:
static void InitializeDocStructInfoEvents()
static member InitializeDocStructInfoEvents : unit -> unit
Vedi anche

Documentazione

Classe SwDocStructInfoEventHandlers
Namespace DedNetSw


Metodo SwDocStructInfoEventHandlers.OnDocStructInfoCreated

Metodo SwDocStructInfoEventHandlersOnDocStructInfoCreated

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnDocStructInfoCreated(
    Object sender,
    ResolveDocStructInfoEventArgs args
)
Public Shared Sub OnDocStructInfoCreated (
    sender As Object,
    args As ResolveDocStructInfoEventArgs
)
public:
static void OnDocStructInfoCreated(
    Object^ sender,
    ResolveDocStructInfoEventArgs^ args
)
static member OnDocStructInfoCreated :
        sender : Object *
        args : ResolveDocStructInfoEventArgs -> unit

Parametri

sender Object
args ResolveDocStructInfoEventArgs
Vedi anche

Documentazione

Classe SwDocStructInfoEventHandlers
Namespace DedNetSw


Classe SwDocStructInfoFileDescriptor
Gerarchia di ereditarietà
SystemObject
DocStructInfoFileDescriptor
DedNetSwSwDocStructInfoFileDescriptor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwDocStructInfoFileDescriptor : DocStructInfoFileDescriptor
Public Class SwDocStructInfoFileDescriptor
    Inherits DocStructInfoFileDescriptor
public ref class SwDocStructInfoFileDescriptor : public DocStructInfoFileDescriptor
type SwDocStructInfoFileDescriptor =
    class
        inherit DocStructInfoFileDescriptor
    end

Il tipo SwDocStructInfoFileDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SwDocStructInfoFileDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDecr | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor)
Proprietà pubblica | Config | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor)
Proprietà pubblica | FileName | Restituisce il file name sotteso a questo elemento. (Ereditato da DocStructInfoFileDescriptor)
Proprietà pubblica | SwDoc |
Proprietà pubblica | VaultPath | Restituisce il path di vault dato il descrittore creato (Ereditato da DocStructInfoFileDescriptor)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | GetHashString | (Sovrascrive DocStructInfoFileDescriptor.GetHashString)
Metodo pubblico | GetSimpleHashString | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | ToString | (Ereditato da DocStructInfoFileDescriptor)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore SwDocStructInfoFileDescriptor

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfoFileDescriptor(
    IModelDoc2 swDoc,
    string fileName,
    ConfigDescriptor cfgDescr
)
Public Sub New (
    swDoc As IModelDoc2,
    fileName As String,
    cfgDescr As ConfigDescriptor
)
public:
SwDocStructInfoFileDescriptor(
    IModelDoc2^ swDoc,
    String^ fileName,
    ConfigDescriptor^ cfgDescr
)
new :
        swDoc : IModelDoc2 *
        fileName : string *
        cfgDescr : ConfigDescriptor -> SwDocStructInfoFileDescriptor

Parametri

swDoc IModelDoc2
fileName String
cfgDescr ConfigDescriptor
Vedi anche

Documentazione

Classe SwDocStructInfoFileDescriptor
Namespace DedNetSw


Proprietà di SwDocStructInfoFileDescriptor

Il tipo SwDocStructInfoFileDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDecr | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor)
Proprietà pubblica | Config | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor)
Proprietà pubblica | FileName | Restituisce il file name sotteso a questo elemento. (Ereditato da DocStructInfoFileDescriptor)
Proprietà pubblica | SwDoc |
Proprietà pubblica | VaultPath | Restituisce il path di vault dato il descrittore creato (Ereditato da DocStructInfoFileDescriptor)
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfoFileDescriptor
Namespace DedNetSw


Proprietà SwDocStructInfoFileDescriptor.SwDoc

Proprietà SwDocStructInfoFileDescriptorSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; }
Public ReadOnly Property SwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
}
member SwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe SwDocStructInfoFileDescriptor
Namespace DedNetSw


Metodi di SwDocStructInfoFileDescriptor

Il tipo SwDocStructInfoFileDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | GetHashString | (Sovrascrive DocStructInfoFileDescriptor.GetHashString)
Metodo pubblico | GetSimpleHashString | (Ereditato da DocStructInfoFileDescriptor)
Metodo pubblico | ToString | (Ereditato da DocStructInfoFileDescriptor)
Torna su
Vedi anche

Documentazione

Classe SwDocStructInfoFileDescriptor
Namespace DedNetSw


Metodo SwDocStructInfoFileDescriptor.GetHashString

Metodo SwDocStructInfoFileDescriptorGetHashString

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetHashString()
Public Overrides Function GetHashString As String
public:
virtual String^ GetHashString() override
abstract GetHashString : unit -> string
override GetHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe SwDocStructInfoFileDescriptor
Namespace DedNetSw


Classe Util
Gerarchia di ereditarietà
SystemObject
DedNetSwUtil

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Util
Public NotInheritable Class Util
public ref class Util abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Util = class end

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
ActivateDocument |
AlignCustomAttrToConfig |
AskUseMasterModelState |
AssertActiveDocument |
AssertAllDocumentsClose |
AssertComponentIsNotSuppressedOrMissing |
AssertComponentIsNotVirtual |
AssertCurrentDocument |
AssertDataHasSameRevType |
AssertDataNotHasSameExt |
AssertDocHasData |
AssertDocHasModelStates |
AssertDocIsAssembly |
AssertDocIsDrawing |
AssertDocIsInDb |
AssertDocIsModel |
AssertDocIsNotNothing |
AssertDocIsNotToolbox |
AssertDocIsNotTopDocument |
AssertDocIsTopDocument |
AssertDocIsValidComp |
AssertDocument |
AssertReadDataFromSwComp |
AssertReadDataFromSwDoc |
AssertReadDataFromSwDocOrMatchingModelState |
AttrListDisabler(DedAttrList) |
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) |
AttrListEnabler |
ChangeRefUsingApprentice |
CheckNoDelFile |
CheckSiDelFile |
CreateDataPartFromAllAttr |
DataToSwComp |
DataToSwDoc |
DataToSwFeature |
DataToSwFile |
DedDataPart2SwComp |
DedDataPart2SwDoc |
DedDataPart2SwFeature |
DedDataPart2SwFile |
DocIsAssembly |
DocIsDrawing |
DocIsPart |
DocNoFile |
DocReloadOrReplace |
DocumentIsDrawing |
DocumentIsModel |
DrawingFirstReferenceFileName |
DrawingReferenceFileNames |
FileIsAsm |
FileIsDrawing |
FileIsModel |
FileIsPrt |
FileIsSolidWorks |
FileIsToolBox |
FillWithAssociatedFiles |
FixSearchPath |
FormatAttr |
GetActiveConfigName(IComponent2) |
GetActiveConfigName(IModelDoc2) |
GetActiveConfigName(String) |
GetActiveConfigName(View) |
GetActualConfigName(IModelDoc2) |
GetActualConfigName(String) |
GetAllSolidworksFiles |
GetAttrList |
GetAttrs(IModelDoc2, String) |
GetAttrs(String, String) |
GetCfgStructure |
GetDBTableAnnotation |
GetDerivedDocs |
GetEmbeddedIcon |
getFileNameRandom |
GetLastDataRowVer(IModelDoc2, String) |
GetLastDataRowVer(String, String) |
GetMeasure |
GetModelStates(IModelDoc2) |
GetModelStates(String) |
GetQsPublisherOutName |
GetSmallFileIcon |
GetSolidworksVersion |
HasAtLeastTwoModelStates |
HasDependencies(IComponent2) |
HasDependencies(IModelDoc2) |
HasModelStates |
InsertComponent |
IsDrawing |
IsLastVisibleDocument |
IsMasterModelState(IModelDoc2) |
IsMasterModelState(String) |
IsModel |
Open(String, Boolean, Int32, Int32, String) |
Open(String, Boolean, Int32, Int32, DedData, DedDoc, String) |
OpenDocInvisible |
OrderDocumentList |
PathIsRootLibrary |
PrecompilaCodice |
ReadAllProperties(IModelDoc2, String) |
ReadAllProperties(String, Boolean, String) |
ReadAnagr |
ReadDataFromSwComp(IComponent2, Boolean) |
ReadDataFromSwComp(IComponent2, String, Boolean) |
ReadDataFromSwCompOrMatchingModelState |
ReadDataFromSwCompProperties(IComponent2) |
ReadDataFromSwCompProperties(IComponent2, String) |
ReadDataFromSwDoc |
ReadDataFromSwDocOrMatchingModelState |
ReadDataFromSwDocProperties |
ReadDataFromSwFeature |
ReadDataFromSwFile |
ReadDataFromSwFileProperties |
RemoveAttribute |
ReplaceClosingDrawing |
RunMacro |
Save |
SaveAs |
SelectComponentByNameAndConfig |
SetAttrs |
SetLastDataRowVer(IModelDoc2, Guid, String) |
SetLastDataRowVer(String, Guid, String) |
SetOnFileDirtyFlags |
SwComp2DedDataPart(IComponent2, DedAttrList) |
SwComp2DedDataPart(IComponent2, UtilDataAttrTypeEnum) |
SwComp2DedDoc |
SwDoc2DedDataPart(IModelDoc2, String) |
SwDoc2DedDataPart(IModelDoc2, DedAttrList, String) |
SwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String) |
SwDoc2DedDataPart(IModelDoc2, String, Boolean) |
SwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String, Boolean) |
SwDoc2DedDoc |
SwDocAttrMatchData |
SwFeature2DedDataPart(IFeature, DedAttrList) |
SwFeature2DedDataPart(IFeature, UtilDataAttrTypeEnum) |
SwFile2DedDataPart(String, DedType, String) |
SwFile2DedDataPart(String, DedType, DedAttrList, String) |
SwFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum, String) |
SwFileAttrMatchData |
UpdateMaterialAttr |
UpdateReference |
UpdateSingleDocumentReference |
WriteAllProperties(DedDoc, String) |
WriteAllProperties(DedDoc, IModelDoc2, String) |
WriteAttr |
WriteUserProperties |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Metodi di Util

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
ActivateDocument |
AlignCustomAttrToConfig |
AskUseMasterModelState |
AssertActiveDocument |
AssertAllDocumentsClose |
AssertComponentIsNotSuppressedOrMissing |
AssertComponentIsNotVirtual |
AssertCurrentDocument |
AssertDataHasSameRevType |
AssertDataNotHasSameExt |
AssertDocHasData |
AssertDocHasModelStates |
AssertDocIsAssembly |
AssertDocIsDrawing |
AssertDocIsInDb |
AssertDocIsModel |
AssertDocIsNotNothing |
AssertDocIsNotToolbox |
AssertDocIsNotTopDocument |
AssertDocIsTopDocument |
AssertDocIsValidComp |
AssertDocument |
AssertReadDataFromSwComp |
AssertReadDataFromSwDoc |
AssertReadDataFromSwDocOrMatchingModelState |
AttrListDisabler(DedAttrList) |
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) |
AttrListEnabler |
ChangeRefUsingApprentice |
CheckNoDelFile |
CheckSiDelFile |
CreateDataPartFromAllAttr |
DataToSwComp |
DataToSwDoc |
DataToSwFeature |
DataToSwFile |
DedDataPart2SwComp |
DedDataPart2SwDoc |
DedDataPart2SwFeature |
DedDataPart2SwFile |
DocIsAssembly |
DocIsDrawing |
DocIsPart |
DocNoFile |
DocReloadOrReplace |
DocumentIsDrawing |
DocumentIsModel |
DrawingFirstReferenceFileName |
DrawingReferenceFileNames |
FileIsAsm |
FileIsDrawing |
FileIsModel |
FileIsPrt |
FileIsSolidWorks |
FileIsToolBox |
FillWithAssociatedFiles |
FixSearchPath |
FormatAttr |
GetActiveConfigName(IComponent2) |
GetActiveConfigName(IModelDoc2) |
GetActiveConfigName(String) |
GetActiveConfigName(View) |
GetActualConfigName(IModelDoc2) |
GetActualConfigName(String) |
GetAllSolidworksFiles |
GetAttrList |
GetAttrs(IModelDoc2, String) |
GetAttrs(String, String) |
GetCfgStructure |
GetDBTableAnnotation |
GetDerivedDocs |
GetEmbeddedIcon |
getFileNameRandom |
GetLastDataRowVer(IModelDoc2, String) |
GetLastDataRowVer(String, String) |
GetMeasure |
GetModelStates(IModelDoc2) |
GetModelStates(String) |
GetQsPublisherOutName |
GetSmallFileIcon |
GetSolidworksVersion |
HasAtLeastTwoModelStates |
HasDependencies(IComponent2) |
HasDependencies(IModelDoc2) |
HasModelStates |
InsertComponent |
IsDrawing |
IsLastVisibleDocument |
IsMasterModelState(IModelDoc2) |
IsMasterModelState(String) |
IsModel |
Open(String, Boolean, Int32, Int32, String) |
Open(String, Boolean, Int32, Int32, DedData, DedDoc, String) |
OpenDocInvisible |
OrderDocumentList |
PathIsRootLibrary |
PrecompilaCodice |
ReadAllProperties(IModelDoc2, String) |
ReadAllProperties(String, Boolean, String) |
ReadAnagr |
ReadDataFromSwComp(IComponent2, Boolean) |
ReadDataFromSwComp(IComponent2, String, Boolean) |
ReadDataFromSwCompOrMatchingModelState |
ReadDataFromSwCompProperties(IComponent2) |
ReadDataFromSwCompProperties(IComponent2, String) |
ReadDataFromSwDoc |
ReadDataFromSwDocOrMatchingModelState |
ReadDataFromSwDocProperties |
ReadDataFromSwFeature |
ReadDataFromSwFile |
ReadDataFromSwFileProperties |
RemoveAttribute |
ReplaceClosingDrawing |
RunMacro |
Save |
SaveAs |
SelectComponentByNameAndConfig |
SetAttrs |
SetLastDataRowVer(IModelDoc2, Guid, String) |
SetLastDataRowVer(String, Guid, String) |
SetOnFileDirtyFlags |
SwComp2DedDataPart(IComponent2, DedAttrList) |
SwComp2DedDataPart(IComponent2, UtilDataAttrTypeEnum) |
SwComp2DedDoc |
SwDoc2DedDataPart(IModelDoc2, String) |
SwDoc2DedDataPart(IModelDoc2, DedAttrList, String) |
SwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String) |
SwDoc2DedDataPart(IModelDoc2, String, Boolean) |
SwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String, Boolean) |
SwDoc2DedDoc |
SwDocAttrMatchData |
SwFeature2DedDataPart(IFeature, DedAttrList) |
SwFeature2DedDataPart(IFeature, UtilDataAttrTypeEnum) |
SwFile2DedDataPart(String, DedType, String) |
SwFile2DedDataPart(String, DedType, DedAttrList, String) |
SwFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum, String) |
SwFileAttrMatchData |
UpdateMaterialAttr |
UpdateReference |
UpdateSingleDocumentReference |
WriteAllProperties(DedDoc, String) |
WriteAllProperties(DedDoc, IModelDoc2, String) |
WriteAttr |
WriteUserProperties |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ActivateDocument

Metodo UtilActivateDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void ActivateDocument(
    string title
)
Public Shared Sub ActivateDocument (
    title As String
)
public:
static void ActivateDocument(
    String^ title
)
static member ActivateDocument :
        title : string -> unit

Parametri

title String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AlignCustomAttrToConfig

Metodo UtilAlignCustomAttrToConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AlignCustomAttrToConfig(
    IModelDoc2 modDoc
)
Public Shared Sub AlignCustomAttrToConfig (
    modDoc As IModelDoc2
)
public:
static void AlignCustomAttrToConfig(
    IModelDoc2^ modDoc
)
static member AlignCustomAttrToConfig :
        modDoc : IModelDoc2 -> unit

Parametri

modDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AskUseMasterModelState

Metodo UtilAskUseMasterModelState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool AskUseMasterModelState(
    string conf,
    bool askUser
)
Public Shared Function AskUseMasterModelState (
    conf As String,
    askUser As Boolean
) As Boolean
public:
static bool AskUseMasterModelState(
    String^ conf,
    bool askUser
)
static member AskUseMasterModelState :
        conf : string *
        askUser : bool -> bool

Parametri

conf String
askUser Boolean

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertActiveDocument

Metodo UtilAssertActiveDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IModelDoc2 AssertActiveDocument()
Public Shared Function AssertActiveDocument As IModelDoc2
public:
static IModelDoc2^ AssertActiveDocument()
static member AssertActiveDocument : unit -> IModelDoc2

Valore di ritorno

IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertAllDocumentsClose

Metodo UtilAssertAllDocumentsClose

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertAllDocumentsClose()
Public Shared Sub AssertAllDocumentsClose
public:
static void AssertAllDocumentsClose()
static member AssertAllDocumentsClose : unit -> unit
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertComponentIsNotSuppressedOrMissing

Metodo UtilAssertComponentIsNotSuppressedOrMissing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertComponentIsNotSuppressedOrMissing(
    IComponent2 swComp
)
Public Shared Sub AssertComponentIsNotSuppressedOrMissing (
    swComp As IComponent2
)
public:
static void AssertComponentIsNotSuppressedOrMissing(
    IComponent2^ swComp
)
static member AssertComponentIsNotSuppressedOrMissing :
        swComp : IComponent2 -> unit

Parametri

swComp IComponent2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertComponentIsNotVirtual

Metodo UtilAssertComponentIsNotVirtual

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertComponentIsNotVirtual(
    IComponent2 swComp
)
Public Shared Sub AssertComponentIsNotVirtual (
    swComp As IComponent2
)
public:
static void AssertComponentIsNotVirtual(
    IComponent2^ swComp
)
static member AssertComponentIsNotVirtual :
        swComp : IComponent2 -> unit

Parametri

swComp IComponent2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertCurrentDocument

Metodo UtilAssertCurrentDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc AssertCurrentDocument()
Public Shared Function AssertCurrentDocument As DedDoc
public:
static DedDoc^ AssertCurrentDocument()
static member AssertCurrentDocument : unit -> DedDoc

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDataHasSameRevType

Metodo UtilAssertDataHasSameRevType

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDataHasSameRevType(
    DedDoc doc,
    DedData data
)
Public Shared Sub AssertDataHasSameRevType (
    doc As DedDoc,
    data As DedData
)
public:
static void AssertDataHasSameRevType(
    DedDoc^ doc,
    DedData^ data
)
static member AssertDataHasSameRevType :
        doc : DedDoc *
        data : DedData -> unit

Parametri

doc DedDoc
data DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDataNotHasSameExt

Metodo UtilAssertDataNotHasSameExt

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDataNotHasSameExt(
    DedData data,
    string ext
)
Public Shared Sub AssertDataNotHasSameExt (
    data As DedData,
    ext As String
)
public:
static void AssertDataNotHasSameExt(
    DedData^ data,
    String^ ext
)
static member AssertDataNotHasSameExt :
        data : DedData *
        ext : string -> unit

Parametri

data DedData
ext String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocHasData

Metodo UtilAssertDocHasData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocHasData(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocHasData (
    oDoc As IModelDoc2
)
public:
static void AssertDocHasData(
    IModelDoc2^ oDoc
)
static member AssertDocHasData :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocHasModelStates

Metodo UtilAssertDocHasModelStates

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocHasModelStates(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocHasModelStates (
    oDoc As IModelDoc2
)
public:
static void AssertDocHasModelStates(
    IModelDoc2^ oDoc
)
static member AssertDocHasModelStates :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsAssembly

Metodo UtilAssertDocIsAssembly

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsAssembly(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsAssembly (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsAssembly(
    IModelDoc2^ oDoc
)
static member AssertDocIsAssembly :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsDrawing

Metodo UtilAssertDocIsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsDrawing(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsDrawing (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsDrawing(
    IModelDoc2^ oDoc
)
static member AssertDocIsDrawing :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsInDb

Metodo UtilAssertDocIsInDb

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsInDb(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsInDb (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsInDb(
    IModelDoc2^ oDoc
)
static member AssertDocIsInDb :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsModel

Metodo UtilAssertDocIsModel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsModel(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsModel (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsModel(
    IModelDoc2^ oDoc
)
static member AssertDocIsModel :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsNotNothing

Metodo UtilAssertDocIsNotNothing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotNothing(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsNotNothing (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsNotNothing(
    IModelDoc2^ oDoc
)
static member AssertDocIsNotNothing :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsNotToolbox

Metodo UtilAssertDocIsNotToolbox

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotToolbox(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsNotToolbox (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsNotToolbox(
    IModelDoc2^ oDoc
)
static member AssertDocIsNotToolbox :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsNotTopDocument

Metodo UtilAssertDocIsNotTopDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotTopDocument(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsNotTopDocument (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsNotTopDocument(
    IModelDoc2^ oDoc
)
static member AssertDocIsNotTopDocument :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsTopDocument

Metodo UtilAssertDocIsTopDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsTopDocument(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsTopDocument (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsTopDocument(
    IModelDoc2^ oDoc
)
static member AssertDocIsTopDocument :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocIsValidComp

Metodo UtilAssertDocIsValidComp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsValidComp(
    IModelDoc2 oDoc
)
Public Shared Sub AssertDocIsValidComp (
    oDoc As IModelDoc2
)
public:
static void AssertDocIsValidComp(
    IModelDoc2^ oDoc
)
static member AssertDocIsValidComp :
        oDoc : IModelDoc2 -> unit

Parametri

oDoc IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertDocument

Metodo UtilAssertDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc AssertDocument(
    IModelDoc2 swDoc
)
Public Shared Function AssertDocument (
    swDoc As IModelDoc2
) As DedDoc
public:
static DedDoc^ AssertDocument(
    IModelDoc2^ swDoc
)
static member AssertDocument :
        swDoc : IModelDoc2 -> DedDoc

Parametri

swDoc IModelDoc2

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertReadDataFromSwComp

Metodo UtilAssertReadDataFromSwComp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromSwComp(
    IComponent2 swComp
)
Public Shared Function AssertReadDataFromSwComp (
    swComp As IComponent2
) As DedData
public:
static DedData^ AssertReadDataFromSwComp(
    IComponent2^ swComp
)
static member AssertReadDataFromSwComp :
        swComp : IComponent2 -> DedData

Parametri

swComp IComponent2

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertReadDataFromSwDoc

Metodo UtilAssertReadDataFromSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromSwDoc(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function AssertReadDataFromSwDoc (
    swDoc As IModelDoc2,
    config As String
) As DedData
public:
static DedData^ AssertReadDataFromSwDoc(
    IModelDoc2^ swDoc,
    String^ config
)
static member AssertReadDataFromSwDoc :
        swDoc : IModelDoc2 *
        config : string -> DedData

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AssertReadDataFromSwDocOrMatchingModelState

Metodo UtilAssertReadDataFromSwDocOrMatchingModelState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromSwDocOrMatchingModelState(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function AssertReadDataFromSwDocOrMatchingModelState (
    swDoc As IModelDoc2,
    config As String
) As DedData
public:
static DedData^ AssertReadDataFromSwDocOrMatchingModelState(
    IModelDoc2^ swDoc,
    String^ config
)
static member AssertReadDataFromSwDocOrMatchingModelState :
        swDoc : IModelDoc2 *
        config : string -> DedData

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AttrListDisabler

Metodo UtilAttrListDisabler
Lista degli overload
Nome | Descrizione
AttrListDisabler(DedAttrList) |
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.AttrListDisabler(DedAttrList)

Metodo UtilAttrListDisabler(DedAttrList)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListDisabler(
    DedAttrList inList
)
Public Shared Function AttrListDisabler (
    inList As DedAttrList
) As DedAttrList
public:
static DedAttrList^ AttrListDisabler(
    DedAttrList^ inList
)
static member AttrListDisabler :
        inList : DedAttrList -> DedAttrList

Parametri

inList DedAttrList

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe Util
Overload di AttrListDisabler
Namespace DedNetSw


Metodo Util.AttrListDisabler(DedAttrList, DedAttrEnvDestEnum)

Metodo UtilAttrListDisabler(DedAttrList, DedAttrEnvDestEnum)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListDisabler(
    DedAttrList inList,
    DedAttrEnvDestEnum attrEnvDestType
)
Public Shared Function AttrListDisabler (
    inList As DedAttrList,
    attrEnvDestType As DedAttrEnvDestEnum
) As DedAttrList
public:
static DedAttrList^ AttrListDisabler(
    DedAttrList^ inList,
    DedAttrEnvDestEnum attrEnvDestType
)
static member AttrListDisabler :
        inList : DedAttrList *
        attrEnvDestType : DedAttrEnvDestEnum -> DedAttrList

Parametri

inList DedAttrList
attrEnvDestType DedAttrEnvDestEnum

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe Util
Overload di AttrListDisabler
Namespace DedNetSw


Metodo Util.AttrListEnabler

Metodo UtilAttrListEnabler

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListEnabler(
    DedAttrList inList,
    DedAttrEnvDestEnum attrEnvDestType
)
Public Shared Function AttrListEnabler (
    inList As DedAttrList,
    attrEnvDestType As DedAttrEnvDestEnum
) As DedAttrList
public:
static DedAttrList^ AttrListEnabler(
    DedAttrList^ inList,
    DedAttrEnvDestEnum attrEnvDestType
)
static member AttrListEnabler :
        inList : DedAttrList *
        attrEnvDestType : DedAttrEnvDestEnum -> DedAttrList

Parametri

inList DedAttrList
attrEnvDestType DedAttrEnvDestEnum

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ChangeRefUsingApprentice

Metodo UtilChangeRefUsingApprentice

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ChangeRefUsingApprentice(
    string fileName,
    string startRefName,
    string destRefName
)
Public Shared Function ChangeRefUsingApprentice (
    fileName As String,
    startRefName As String,
    destRefName As String
) As Boolean
public:
static bool ChangeRefUsingApprentice(
    String^ fileName,
    String^ startRefName,
    String^ destRefName
)
static member ChangeRefUsingApprentice :
        fileName : string *
        startRefName : string *
        destRefName : string -> bool

Parametri

fileName String
startRefName String
destRefName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.CheckNoDelFile

Metodo UtilCheckNoDelFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckNoDelFile(
    DedData data
)
Public Shared Function CheckNoDelFile (
    data As DedData
) As Boolean
public:
static bool CheckNoDelFile(
    DedData^ data
)
static member CheckNoDelFile :
        data : DedData -> bool

Parametri

data DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.CheckSiDelFile

Metodo UtilCheckSiDelFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckSiDelFile(
    DedData data
)
Public Shared Function CheckSiDelFile (
    data As DedData
) As Boolean
public:
static bool CheckSiDelFile(
    DedData^ data
)
static member CheckSiDelFile :
        data : DedData -> bool

Parametri

data DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.CreateDataPartFromAllAttr

Metodo UtilCreateDataPartFromAllAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart CreateDataPartFromAllAttr(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function CreateDataPartFromAllAttr (
    swDoc As IModelDoc2,
    config As String
) As DedDataPart
public:
static DedDataPart^ CreateDataPartFromAllAttr(
    IModelDoc2^ swDoc,
    String^ config
)
static member CreateDataPartFromAllAttr :
        swDoc : IModelDoc2 *
        config : string -> DedDataPart

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DataToSwComp

Metodo UtilDataToSwComp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToSwComp(
    DedData data,
    IComponent2 swComp,
    bool enforceOperation = false
)
Public Shared Sub DataToSwComp (
    data As DedData,
    swComp As IComponent2,
    Optional enforceOperation As Boolean = false
)
public:
static void DataToSwComp(
    DedData^ data,
    IComponent2^ swComp,
    bool enforceOperation = false
)
static member DataToSwComp :
        data : DedData *
        swComp : IComponent2 *
        ?enforceOperation : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
*)
-> unit

Parametri

data DedData
swComp IComponent2
enforceOperation Boolean (Optional)
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DataToSwDoc

Metodo UtilDataToSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToSwDoc(
    DedData data,
    IModelDoc2 swDoc,
    string config,
    bool enforceOperation = false,
    bool ignoreEsclAttrList = false
)
Public Shared Sub DataToSwDoc (
    data As DedData,
    swDoc As IModelDoc2,
    config As String,
    Optional enforceOperation As Boolean = false,
    Optional ignoreEsclAttrList As Boolean = false
)
public:
static void DataToSwDoc(
    DedData^ data,
    IModelDoc2^ swDoc,
    String^ config,
    bool enforceOperation = false,
    bool ignoreEsclAttrList = false
)
static member DataToSwDoc :
        data : DedData *
        swDoc : IModelDoc2 *
        config : string *
        ?enforceOperation : bool *
        ?ignoreEsclAttrList : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
        let _ignoreEsclAttrList = defaultArg ignoreEsclAttrList false
*)
-> unit

Parametri

data DedData
swDoc IModelDoc2
config String
enforceOperation Boolean (Optional)
ignoreEsclAttrList Boolean (Optional)
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DataToSwFeature

Metodo UtilDataToSwFeature

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToSwFeature(
    DedData data,
    IFeature swFeat
)
Public Shared Sub DataToSwFeature (
    data As DedData,
    swFeat As IFeature
)
public:
static void DataToSwFeature(
    DedData^ data,
    IFeature^ swFeat
)
static member DataToSwFeature :
        data : DedData *
        swFeat : IFeature -> unit

Parametri

data DedData
swFeat IFeature
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DataToSwFile

Metodo UtilDataToSwFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToSwFile(
    DedData data,
    string fileName,
    bool enforceOperation = false,
    string config = "*"
)
Public Shared Sub DataToSwFile (
    data As DedData,
    fileName As String,
    Optional enforceOperation As Boolean = false,
    Optional config As String = "*"
)
public:
static void DataToSwFile(
    DedData^ data,
    String^ fileName,
    bool enforceOperation = false,
    String^ config = L"*"
)
static member DataToSwFile :
        data : DedData *
        fileName : string *
        ?enforceOperation : bool *
        ?config : string
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
        let _config = defaultArg config "*"
*)
-> unit

Parametri

data DedData
fileName String
enforceOperation Boolean (Optional)
config String (Optional)
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DedDataPart2SwComp

Metodo UtilDedDataPart2SwComp

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2SwComp(
    DedDataPart dataPart,
    IComponent2 swComp,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2SwComp (
    dataPart As DedDataPart,
    swComp As IComponent2,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2SwComp(
    DedDataPart^ dataPart,
    IComponent2^ swComp,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2SwComp :
        dataPart : DedDataPart *
        swComp : IComponent2 *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart DedDataPart
swComp IComponent2
attrsType UtilDataAttrTypeEnum
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DedDataPart2SwDoc

Metodo UtilDedDataPart2SwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2SwDoc(
    IDedData dataPart,
    IModelDoc2 swDoc,
    UtilDataAttrTypeEnum attrsType,
    string config
)
Public Shared Sub DedDataPart2SwDoc (
    dataPart As IDedData,
    swDoc As IModelDoc2,
    attrsType As UtilDataAttrTypeEnum,
    config As String
)
public:
static void DedDataPart2SwDoc(
    IDedData^ dataPart,
    IModelDoc2^ swDoc,
    UtilDataAttrTypeEnum attrsType,
    String^ config
)
static member DedDataPart2SwDoc :
        dataPart : IDedData *
        swDoc : IModelDoc2 *
        attrsType : UtilDataAttrTypeEnum *
        config : string -> unit

Parametri

dataPart IDedData
swDoc IModelDoc2
attrsType UtilDataAttrTypeEnum
config String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DedDataPart2SwFeature

Metodo UtilDedDataPart2SwFeature

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2SwFeature(
    DedDataPart dataPart,
    IFeature swFeat,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2SwFeature (
    dataPart As DedDataPart,
    swFeat As IFeature,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2SwFeature(
    DedDataPart^ dataPart,
    IFeature^ swFeat,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2SwFeature :
        dataPart : DedDataPart *
        swFeat : IFeature *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart DedDataPart
swFeat IFeature
attrsType UtilDataAttrTypeEnum
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DedDataPart2SwFile

Metodo UtilDedDataPart2SwFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2SwFile(
    IDedData dataPart,
    string filename,
    UtilDataAttrTypeEnum attrsType,
    string config
)
Public Shared Sub DedDataPart2SwFile (
    dataPart As IDedData,
    filename As String,
    attrsType As UtilDataAttrTypeEnum,
    config As String
)
public:
static void DedDataPart2SwFile(
    IDedData^ dataPart,
    String^ filename,
    UtilDataAttrTypeEnum attrsType,
    String^ config
)
static member DedDataPart2SwFile :
        dataPart : IDedData *
        filename : string *
        attrsType : UtilDataAttrTypeEnum *
        config : string -> unit

Parametri

dataPart IDedData
filename String
attrsType UtilDataAttrTypeEnum
config String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocIsAssembly

Metodo UtilDocIsAssembly

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocIsAssembly(
    IModelDoc2 oDoc
)
Public Shared Function DocIsAssembly (
    oDoc As IModelDoc2
) As Boolean
public:
static bool DocIsAssembly(
    IModelDoc2^ oDoc
)
static member DocIsAssembly :
        oDoc : IModelDoc2 -> bool

Parametri

oDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocIsDrawing

Metodo UtilDocIsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocIsDrawing(
    IModelDoc2 oDoc
)
Public Shared Function DocIsDrawing (
    oDoc As IModelDoc2
) As Boolean
public:
static bool DocIsDrawing(
    IModelDoc2^ oDoc
)
static member DocIsDrawing :
        oDoc : IModelDoc2 -> bool

Parametri

oDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocIsPart

Metodo UtilDocIsPart

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocIsPart(
    IModelDoc2 oDoc
)
Public Shared Function DocIsPart (
    oDoc As IModelDoc2
) As Boolean
public:
static bool DocIsPart(
    IModelDoc2^ oDoc
)
static member DocIsPart :
        oDoc : IModelDoc2 -> bool

Parametri

oDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocNoFile

Metodo UtilDocNoFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DocNoFile()
Public Shared Sub DocNoFile
public:
static void DocNoFile()
static member DocNoFile : unit -> unit
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocReloadOrReplace

Metodo UtilDocReloadOrReplace

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DocReloadOrReplace(
    IModelDoc2 doc,
    string path,
    bool readOnly,
    bool discardChanges
)
Public Shared Sub DocReloadOrReplace (
    doc As IModelDoc2,
    path As String,
    readOnly As Boolean,
    discardChanges As Boolean
)
public:
static void DocReloadOrReplace(
    IModelDoc2^ doc,
    String^ path,
    bool readOnly,
    bool discardChanges
)
static member DocReloadOrReplace :
        doc : IModelDoc2 *
        path : string *
        readOnly : bool *
        discardChanges : bool -> unit

Parametri

doc IModelDoc2
path String
readOnly Boolean
discardChanges Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocumentIsDrawing

Metodo UtilDocumentIsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsDrawing(
    DedDoc doc
)
Public Shared Function DocumentIsDrawing (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsDrawing(
    DedDoc^ doc
)
static member DocumentIsDrawing :
        doc : DedDoc -> bool

Parametri

doc DedDoc

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DocumentIsModel

Metodo UtilDocumentIsModel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsModel(
    DedDoc doc
)
Public Shared Function DocumentIsModel (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsModel(
    DedDoc^ doc
)
static member DocumentIsModel :
        doc : DedDoc -> bool

Parametri

doc DedDoc

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DrawingFirstReferenceFileName

Metodo UtilDrawingFirstReferenceFileName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string DrawingFirstReferenceFileName(
    string newFileName
)
Public Shared Function DrawingFirstReferenceFileName (
    newFileName As String
) As String
public:
static String^ DrawingFirstReferenceFileName(
    String^ newFileName
)
static member DrawingFirstReferenceFileName :
        newFileName : string -> string

Parametri

newFileName String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.DrawingReferenceFileNames

Metodo UtilDrawingReferenceFileNames

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Array DrawingReferenceFileNames(
    string newFileName
)
Public Shared Function DrawingReferenceFileNames (
    newFileName As String
) As Array
public:
static Array^ DrawingReferenceFileNames(
    String^ newFileName
)
static member DrawingReferenceFileNames :
        newFileName : string -> Array

Parametri

newFileName String

Valore di ritorno

Array
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FileIsAsm

Metodo UtilFileIsAsm

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsAsm(
    string filename
)
Public Shared Function FileIsAsm (
    filename As String
) As Boolean
public:
static bool FileIsAsm(
    String^ filename
)
static member FileIsAsm :
        filename : string -> bool

Parametri

filename String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FileIsDrawing

Metodo UtilFileIsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsDrawing(
    string filename
)
Public Shared Function FileIsDrawing (
    filename As String
) As Boolean
public:
static bool FileIsDrawing(
    String^ filename
)
static member FileIsDrawing :
        filename : string -> bool

Parametri

filename String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FileIsModel

Metodo UtilFileIsModel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsModel(
    string filename
)
Public Shared Function FileIsModel (
    filename As String
) As Boolean
public:
static bool FileIsModel(
    String^ filename
)
static member FileIsModel :
        filename : string -> bool

Parametri

filename String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FileIsPrt

Metodo UtilFileIsPrt

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsPrt(
    string filename
)
Public Shared Function FileIsPrt (
    filename As String
) As Boolean
public:
static bool FileIsPrt(
    String^ filename
)
static member FileIsPrt :
        filename : string -> bool

Parametri

filename String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FileIsSolidWorks

Metodo UtilFileIsSolidWorks

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsSolidWorks(
    string fileName
)
Public Shared Function FileIsSolidWorks (
    fileName As String
) As Boolean
public:
static bool FileIsSolidWorks(
    String^ fileName
)
static member FileIsSolidWorks :
        fileName : string -> bool

Parametri

fileName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FileIsToolBox

Metodo UtilFileIsToolBox

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsToolBox(
    string fname
)
Public Shared Function FileIsToolBox (
    fname As String
) As Boolean
public:
static bool FileIsToolBox(
    String^ fname
)
static member FileIsToolBox :
        fname : string -> bool

Parametri

fname String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FillWithAssociatedFiles

Metodo UtilFillWithAssociatedFiles

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList FillWithAssociatedFiles(
    SwDocStructInfo infoItem,
    bool ignoreDataDocs = false
)
Public Shared Function FillWithAssociatedFiles (
    infoItem As SwDocStructInfo,
    Optional ignoreDataDocs As Boolean = false
) As DocStructInfoList
public:
static DocStructInfoList^ FillWithAssociatedFiles(
    SwDocStructInfo^ infoItem,
    bool ignoreDataDocs = false
)
static member FillWithAssociatedFiles :
        infoItem : SwDocStructInfo *
        ?ignoreDataDocs : bool
(* Defaults:
        let _ignoreDataDocs = defaultArg ignoreDataDocs false
*)
-> DocStructInfoList

Parametri

infoItem SwDocStructInfo
ignoreDataDocs Boolean (Optional)

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FixSearchPath

Metodo UtilFixSearchPath

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void FixSearchPath(
    UsrUser user,
    DedNetApplication app,
    SldWorks sld
)
Public Shared Sub FixSearchPath (
    user As UsrUser,
    app As DedNetApplication,
    sld As SldWorks
)
public:
static void FixSearchPath(
    UsrUser^ user,
    DedNetApplication^ app,
    SldWorks^ sld
)
static member FixSearchPath :
        user : UsrUser *
        app : DedNetApplication *
        sld : SldWorks -> unit

Parametri

user UsrUser
app DedNetApplication
sld SldWorks
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.FormatAttr

Metodo UtilFormatAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Object FormatAttr(
    QsSwAttr attrManager,
    DedAttr attr,
    IComponent2 prt,
    bool isFeature = false
)
Public Shared Function FormatAttr (
    attrManager As QsSwAttr,
    attr As DedAttr,
    prt As IComponent2,
    Optional isFeature As Boolean = false
) As Object
public:
static Object^ FormatAttr(
    QsSwAttr^ attrManager,
    DedAttr^ attr,
    IComponent2^ prt,
    bool isFeature = false
)
static member FormatAttr :
        attrManager : QsSwAttr *
        attr : DedAttr *
        prt : IComponent2 *
        ?isFeature : bool
(* Defaults:
        let _isFeature = defaultArg isFeature false
*)
-> Object

Parametri

attrManager QsSwAttr
attr DedAttr
prt IComponent2
isFeature Boolean (Optional)

Valore di ritorno

Object
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetActiveConfigName

Metodo UtilGetActiveConfigName
Lista degli overload
Nome | Descrizione
GetActiveConfigName(IComponent2) |
GetActiveConfigName(IModelDoc2) |
GetActiveConfigName(String) |
GetActiveConfigName(View) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetActiveConfigName(IComponent2)

Metodo UtilGetActiveConfigName(IComponent2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActiveConfigName(
    IComponent2 swComp
)
Public Shared Function GetActiveConfigName (
    swComp As IComponent2
) As String
public:
static String^ GetActiveConfigName(
    IComponent2^ swComp
)
static member GetActiveConfigName :
        swComp : IComponent2 -> string

Parametri

swComp IComponent2

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Overload di GetActiveConfigName
Namespace DedNetSw


Metodo Util.GetActiveConfigName(IModelDoc2)

Metodo UtilGetActiveConfigName(IModelDoc2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActiveConfigName(
    IModelDoc2 swDoc
)
Public Shared Function GetActiveConfigName (
    swDoc As IModelDoc2
) As String
public:
static String^ GetActiveConfigName(
    IModelDoc2^ swDoc
)
static member GetActiveConfigName :
        swDoc : IModelDoc2 -> string

Parametri

swDoc IModelDoc2

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Overload di GetActiveConfigName
Namespace DedNetSw


Metodo Util.GetActiveConfigName(String)

Metodo UtilGetActiveConfigName(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActiveConfigName(
    string config
)
Public Shared Function GetActiveConfigName (
    config As String
) As String
public:
static String^ GetActiveConfigName(
    String^ config
)
static member GetActiveConfigName :
        config : string -> string

Parametri

config String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Overload di GetActiveConfigName
Namespace DedNetSw


Metodo Util.GetActiveConfigName(View)

Metodo UtilGetActiveConfigName(View)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActiveConfigName(
    View view
)
Public Shared Function GetActiveConfigName (
    view As View
) As String
public:
static String^ GetActiveConfigName(
    View^ view
)
static member GetActiveConfigName :
        view : View -> string

Parametri

view View

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Overload di GetActiveConfigName
Namespace DedNetSw


Metodo Util.GetActualConfigName

Metodo UtilGetActualConfigName
Lista degli overload
Nome | Descrizione
GetActualConfigName(IModelDoc2) |
GetActualConfigName(String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetActualConfigName(IModelDoc2)

Metodo UtilGetActualConfigName(IModelDoc2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActualConfigName(
    IModelDoc2 swDoc
)
Public Shared Function GetActualConfigName (
    swDoc As IModelDoc2
) As String
public:
static String^ GetActualConfigName(
    IModelDoc2^ swDoc
)
static member GetActualConfigName :
        swDoc : IModelDoc2 -> string

Parametri

swDoc IModelDoc2

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Overload di GetActualConfigName
Namespace DedNetSw


Metodo Util.GetActualConfigName(String)

Metodo UtilGetActualConfigName(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActualConfigName(
    string config
)
Public Shared Function GetActualConfigName (
    config As String
) As String
public:
static String^ GetActualConfigName(
    String^ config
)
static member GetActualConfigName :
        config : string -> string

Parametri

config String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Overload di GetActualConfigName
Namespace DedNetSw


Metodo Util.GetAllSolidworksFiles

Metodo UtilGetAllSolidworksFiles

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetAllSolidworksFiles(
    string refPath
)
Public Shared Function GetAllSolidworksFiles (
    refPath As String
) As List(Of String)
public:
static List<String^>^ GetAllSolidworksFiles(
    String^ refPath
)
static member GetAllSolidworksFiles :
        refPath : string -> List<string>

Parametri

refPath String

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetAttrList

Metodo UtilGetAttrList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList GetAttrList(
    IDedData data,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function GetAttrList (
    data As IDedData,
    attrsType As UtilDataAttrTypeEnum
) As DedAttrList
public:
static DedAttrList^ GetAttrList(
    IDedData^ data,
    UtilDataAttrTypeEnum attrsType
)
static member GetAttrList :
        data : IDedData *
        attrsType : UtilDataAttrTypeEnum -> DedAttrList

Parametri

data IDedData
attrsType UtilDataAttrTypeEnum

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetAttrs

Metodo UtilGetAttrs
Lista degli overload
Nome | Descrizione
GetAttrs(IModelDoc2, String) |
GetAttrs(String, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetAttrs(IModelDoc2, String)

Metodo UtilGetAttrs(IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable GetAttrs(
    IModelDoc2 doc,
    string config
)
Public Shared Function GetAttrs (
    doc As IModelDoc2,
    config As String
) As LuaTable
public:
static LuaTable^ GetAttrs(
    IModelDoc2^ doc,
    String^ config
)
static member GetAttrs :
        doc : IModelDoc2 *
        config : string -> LuaTable

Parametri

doc IModelDoc2
config String

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Util
Overload di GetAttrs
Namespace DedNetSw


Metodo Util.GetAttrs(String, String)

Metodo UtilGetAttrs(String, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable GetAttrs(
    string filename,
    string config
)
Public Shared Function GetAttrs (
    filename As String,
    config As String
) As LuaTable
public:
static LuaTable^ GetAttrs(
    String^ filename,
    String^ config
)
static member GetAttrs :
        filename : string *
        config : string -> LuaTable

Parametri

filename String
config String

Valore di ritorno

LuaTable
Vedi anche

Documentazione

Classe Util
Overload di GetAttrs
Namespace DedNetSw


Metodo Util.GetCfgStructure

Metodo UtilGetCfgStructure

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> GetCfgStructure(
    IModelDoc2 swdoc
)
Public Shared Function GetCfgStructure (
    swdoc As IModelDoc2
) As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ GetCfgStructure(
    IModelDoc2^ swdoc
)
static member GetCfgStructure :
        swdoc : IModelDoc2 -> Dictionary<string, string>

Parametri

swdoc IModelDoc2

Valore di ritorno

Dictionary String, String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetDBTableAnnotation

Metodo UtilGetDBTableAnnotation

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static TableAnnotation GetDBTableAnnotation(
    ModelDoc2 model,
    string tableName,
    bool ignoreExisting
)
Public Shared Function GetDBTableAnnotation (
    model As ModelDoc2,
    tableName As String,
    ignoreExisting As Boolean
) As TableAnnotation
public:
static TableAnnotation^ GetDBTableAnnotation(
    ModelDoc2^ model,
    String^ tableName,
    bool ignoreExisting
)
static member GetDBTableAnnotation :
        model : ModelDoc2 *
        tableName : string *
        ignoreExisting : bool -> TableAnnotation

Parametri

model ModelDoc2
tableName String
ignoreExisting Boolean

Valore di ritorno

TableAnnotation
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetDerivedDocs

Metodo UtilGetDerivedDocs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<Tuple<IModelDoc2, string>> GetDerivedDocs(
    IModelDoc2 oDoc
)
Public Shared Function GetDerivedDocs (
    oDoc As IModelDoc2
) As List(Of Tuple(Of IModelDoc2, String))
public:
static List<Tuple<IModelDoc2^, String^>^>^ GetDerivedDocs(
    IModelDoc2^ oDoc
)
static member GetDerivedDocs :
        oDoc : IModelDoc2 -> List<Tuple<IModelDoc2, string>>

Parametri

oDoc IModelDoc2

Valore di ritorno

List Tuple IModelDoc2, String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetEmbeddedIcon

Metodo UtilGetEmbeddedIcon

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Image GetEmbeddedIcon(
    string ext
)
Public Shared Function GetEmbeddedIcon (
    ext As String
) As Image
public:
static Image^ GetEmbeddedIcon(
    String^ ext
)
static member GetEmbeddedIcon :
        ext : string -> Image

Parametri

ext String

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.getFileNameRandom

Metodo UtilgetFileNameRandom

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string getFileNameRandom(
    string path = "",
    string filename = "",
    string ext = ""
)
Public Shared Function getFileNameRandom (
    Optional path As String = "",
    Optional filename As String = "",
    Optional ext As String = ""
) As String
public:
static String^ getFileNameRandom(
    String^ path = L"",
    String^ filename = L"",
    String^ ext = L""
)
static member getFileNameRandom :
        ?path : string *
        ?filename : string *
        ?ext : string
(* Defaults:
        let _path = defaultArg path ""
        let _filename = defaultArg filename ""
        let _ext = defaultArg ext ""
*)
-> string

Parametri

path String (Optional)
filename String (Optional)
ext String (Optional)

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetLastDataRowVer

Metodo UtilGetLastDataRowVer
Lista degli overload
Nome | Descrizione
GetLastDataRowVer(IModelDoc2, String) |
GetLastDataRowVer(String, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetLastDataRowVer(IModelDoc2, String)

Metodo UtilGetLastDataRowVer(IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function GetLastDataRowVer (
    swDoc As IModelDoc2,
    config As String
) As Guid
public:
static Guid GetLastDataRowVer(
    IModelDoc2^ swDoc,
    String^ config
)
static member GetLastDataRowVer :
        swDoc : IModelDoc2 *
        config : string -> Guid

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer
Namespace DedNetSw


Metodo Util.GetLastDataRowVer(String, String)

Metodo UtilGetLastDataRowVer(String, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    string fullFileName,
    string config
)
Public Shared Function GetLastDataRowVer (
    fullFileName As String,
    config As String
) As Guid
public:
static Guid GetLastDataRowVer(
    String^ fullFileName,
    String^ config
)
static member GetLastDataRowVer :
        fullFileName : string *
        config : string -> Guid

Parametri

fullFileName String
config String

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer
Namespace DedNetSw


Metodo Util.GetMeasure

Metodo UtilGetMeasure

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static double? GetMeasure()
Public Shared Function GetMeasure As Double?
public:
static Nullable<double> GetMeasure()
static member GetMeasure : unit -> Nullable<float>

Valore di ritorno

Nullable Double
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetModelStates

Metodo UtilGetModelStates
Lista degli overload
Nome | Descrizione
GetModelStates(IModelDoc2) |
GetModelStates(String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetModelStates(IModelDoc2)

Metodo UtilGetModelStates(IModelDoc2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetModelStates(
    IModelDoc2 swDoc
)
Public Shared Function GetModelStates (
    swDoc As IModelDoc2
) As List(Of String)
public:
static List<String^>^ GetModelStates(
    IModelDoc2^ swDoc
)
static member GetModelStates :
        swDoc : IModelDoc2 -> List<string>

Parametri

swDoc IModelDoc2

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Util
Overload di GetModelStates
Namespace DedNetSw


Metodo Util.GetModelStates(String)

Metodo UtilGetModelStates(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetModelStates(
    string filename
)
Public Shared Function GetModelStates (
    filename As String
) As List(Of String)
public:
static List<String^>^ GetModelStates(
    String^ filename
)
static member GetModelStates :
        filename : string -> List<string>

Parametri

filename String

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Util
Overload di GetModelStates
Namespace DedNetSw


Metodo Util.GetQsPublisherOutName

Metodo UtilGetQsPublisherOutName

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetQsPublisherOutName(
    IModelDoc2 swDoc,
    string cfg
)
Public Shared Function GetQsPublisherOutName (
    swDoc As IModelDoc2,
    cfg As String
) As String
public:
static String^ GetQsPublisherOutName(
    IModelDoc2^ swDoc,
    String^ cfg
)
static member GetQsPublisherOutName :
        swDoc : IModelDoc2 *
        cfg : string -> string

Parametri

swDoc IModelDoc2
cfg String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetSmallFileIcon

Metodo UtilGetSmallFileIcon

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Image GetSmallFileIcon(
    IModelDoc2 swDoc
)
Public Shared Function GetSmallFileIcon (
    swDoc As IModelDoc2
) As Image
public:
static Image^ GetSmallFileIcon(
    IModelDoc2^ swDoc
)
static member GetSmallFileIcon :
        swDoc : IModelDoc2 -> Image

Parametri

swDoc IModelDoc2

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.GetSolidworksVersion

Metodo UtilGetSolidworksVersion

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetSolidworksVersion()
Public Shared Function GetSolidworksVersion As String
public:
static String^ GetSolidworksVersion()
static member GetSolidworksVersion : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.HasAtLeastTwoModelStates

Metodo UtilHasAtLeastTwoModelStates

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HasAtLeastTwoModelStates(
    IModelDoc2 oDoc
)
Public Shared Function HasAtLeastTwoModelStates (
    oDoc As IModelDoc2
) As Boolean
public:
static bool HasAtLeastTwoModelStates(
    IModelDoc2^ oDoc
)
static member HasAtLeastTwoModelStates :
        oDoc : IModelDoc2 -> bool

Parametri

oDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.HasDependencies

Metodo UtilHasDependencies
Lista degli overload
Nome | Descrizione
HasDependencies(IComponent2) |
HasDependencies(IModelDoc2) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.HasDependencies(IComponent2)

Metodo UtilHasDependencies(IComponent2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HasDependencies(
    IComponent2 swComp
)
Public Shared Function HasDependencies (
    swComp As IComponent2
) As Boolean
public:
static bool HasDependencies(
    IComponent2^ swComp
)
static member HasDependencies :
        swComp : IComponent2 -> bool

Parametri

swComp IComponent2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Overload di HasDependencies
Namespace DedNetSw


Metodo Util.HasDependencies(IModelDoc2)

Metodo UtilHasDependencies(IModelDoc2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HasDependencies(
    IModelDoc2 swDoc
)
Public Shared Function HasDependencies (
    swDoc As IModelDoc2
) As Boolean
public:
static bool HasDependencies(
    IModelDoc2^ swDoc
)
static member HasDependencies :
        swDoc : IModelDoc2 -> bool

Parametri

swDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Overload di HasDependencies
Namespace DedNetSw


Metodo Util.HasModelStates

Metodo UtilHasModelStates

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HasModelStates(
    IModelDoc2 oDoc
)
Public Shared Function HasModelStates (
    oDoc As IModelDoc2
) As Boolean
public:
static bool HasModelStates(
    IModelDoc2^ oDoc
)
static member HasModelStates :
        oDoc : IModelDoc2 -> bool

Parametri

oDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.InsertComponent

Metodo UtilInsertComponent

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool InsertComponent(
    string path,
    string config,
    double xValue,
    double yValue,
    double zValue
)
Public Shared Function InsertComponent (
    path As String,
    config As String,
    xValue As Double,
    yValue As Double,
    zValue As Double
) As Boolean
public:
static bool InsertComponent(
    String^ path,
    String^ config,
    double xValue,
    double yValue,
    double zValue
)
static member InsertComponent :
        path : string *
        config : string *
        xValue : float *
        yValue : float *
        zValue : float -> bool

Parametri

path String
config String
xValue Double
yValue Double
zValue Double

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.IsDrawing

Metodo UtilIsDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDrawing(
    IModelDoc2 swDoc
)
Public Shared Function IsDrawing (
    swDoc As IModelDoc2
) As Boolean
public:
static bool IsDrawing(
    IModelDoc2^ swDoc
)
static member IsDrawing :
        swDoc : IModelDoc2 -> bool

Parametri

swDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.IsLastVisibleDocument

Metodo UtilIsLastVisibleDocument

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsLastVisibleDocument()
Public Shared Function IsLastVisibleDocument As Boolean
public:
static bool IsLastVisibleDocument()
static member IsLastVisibleDocument : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.IsMasterModelState

Metodo UtilIsMasterModelState
Lista degli overload
Nome | Descrizione
IsMasterModelState(IModelDoc2) |
IsMasterModelState(String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.IsMasterModelState(IModelDoc2)

Metodo UtilIsMasterModelState(IModelDoc2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsMasterModelState(
    IModelDoc2 swDoc
)
Public Shared Function IsMasterModelState (
    swDoc As IModelDoc2
) As Boolean
public:
static bool IsMasterModelState(
    IModelDoc2^ swDoc
)
static member IsMasterModelState :
        swDoc : IModelDoc2 -> bool

Parametri

swDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Overload di IsMasterModelState
Namespace DedNetSw


Metodo Util.IsMasterModelState(String)

Metodo UtilIsMasterModelState(String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsMasterModelState(
    string msName
)
Public Shared Function IsMasterModelState (
    msName As String
) As Boolean
public:
static bool IsMasterModelState(
    String^ msName
)
static member IsMasterModelState :
        msName : string -> bool

Parametri

msName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Overload di IsMasterModelState
Namespace DedNetSw


Metodo Util.IsModel

Metodo UtilIsModel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsModel(
    IModelDoc2 swDoc
)
Public Shared Function IsModel (
    swDoc As IModelDoc2
) As Boolean
public:
static bool IsModel(
    IModelDoc2^ swDoc
)
static member IsModel :
        swDoc : IModelDoc2 -> bool

Parametri

swDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.Open

Metodo UtilOpen
Lista degli overload
Nome | Descrizione
Open(String, Boolean, Int32, Int32, String) |
Open(String, Boolean, Int32, Int32, DedData, DedDoc, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.Open(String, Boolean, Int32, Int32, String)

Metodo UtilOpen(String, Boolean, Int32, Int32, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IModelDoc2 Open(
    string fullFileName,
    bool visible,
    out int errors,
    out int warnings,
    string config = null
)
Public Shared Function Open (
    fullFileName As String,
    visible As Boolean,
    <OutAttribute> ByRef errors As Integer,
    <OutAttribute> ByRef warnings As Integer,
    Optional config As String = Nothing
) As IModelDoc2
public:
static IModelDoc2^ Open(
    String^ fullFileName,
    bool visible,
    [OutAttribute] int% errors,
    [OutAttribute] int% warnings,
    String^ config = nullptr
)
static member Open :
        fullFileName : string *
        visible : bool *
        errors : int byref *
        warnings : int byref *
        ?config : string
(* Defaults:
        let _config = defaultArg config null
*)
-> IModelDoc2

Parametri

fullFileName String
visible Boolean
errors Int32
warnings Int32
config String (Optional)

Valore di ritorno

IModelDoc2
Vedi anche

Documentazione

Classe Util
Overload di Open
Namespace DedNetSw


Metodo Util.Open(String, Boolean, Int32, Int32, DedData, DedDoc, String)

Metodo UtilOpen(String, Boolean, Int32, Int32, DedData, DedDoc, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IModelDoc2 Open(
    string fullFileName,
    bool visible,
    out int errors,
    out int warnings,
    DedData anagr,
    DedDoc doc,
    string config = null
)
Public Shared Function Open (
    fullFileName As String,
    visible As Boolean,
    <OutAttribute> ByRef errors As Integer,
    <OutAttribute> ByRef warnings As Integer,
    anagr As DedData,
    doc As DedDoc,
    Optional config As String = Nothing
) As IModelDoc2
public:
static IModelDoc2^ Open(
    String^ fullFileName,
    bool visible,
    [OutAttribute] int% errors,
    [OutAttribute] int% warnings,
    DedData^ anagr,
    DedDoc^ doc,
    String^ config = nullptr
)
static member Open :
        fullFileName : string *
        visible : bool *
        errors : int byref *
        warnings : int byref *
        anagr : DedData *
        doc : DedDoc *
        ?config : string
(* Defaults:
        let _config = defaultArg config null
*)
-> IModelDoc2

Parametri

fullFileName String
visible Boolean
errors Int32
warnings Int32
anagr DedData
doc DedDoc
config String (Optional)

Valore di ritorno

IModelDoc2
Vedi anche

Documentazione

Classe Util
Overload di Open
Namespace DedNetSw


Metodo Util.OpenDocInvisible

Metodo UtilOpenDocInvisible

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IModelDoc2 OpenDocInvisible(
    string filename,
    out int errors,
    out int warnings,
    out bool alreadyOpen
)
Public Shared Function OpenDocInvisible (
    filename As String,
    <OutAttribute> ByRef errors As Integer,
    <OutAttribute> ByRef warnings As Integer,
    <OutAttribute> ByRef alreadyOpen As Boolean
) As IModelDoc2
public:
static IModelDoc2^ OpenDocInvisible(
    String^ filename,
    [OutAttribute] int% errors,
    [OutAttribute] int% warnings,
    [OutAttribute] bool% alreadyOpen
)
static member OpenDocInvisible :
        filename : string *
        errors : int byref *
        warnings : int byref *
        alreadyOpen : bool byref -> IModelDoc2

Parametri

filename String
errors Int32
warnings Int32
alreadyOpen Boolean

Valore di ritorno

IModelDoc2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.OrderDocumentList

Metodo UtilOrderDocumentList

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OrderDocumentList(
    DedDocList dedDocList
)
Public Shared Sub OrderDocumentList (
    dedDocList As DedDocList
)
public:
static void OrderDocumentList(
    DedDocList^ dedDocList
)
static member OrderDocumentList :
        dedDocList : DedDocList -> unit

Parametri

dedDocList DedDocList
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.PathIsRootLibrary

Metodo UtilPathIsRootLibrary

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PathIsRootLibrary(
    string filePath
)
Public Shared Function PathIsRootLibrary (
    filePath As String
) As Boolean
public:
static bool PathIsRootLibrary(
    String^ filePath
)
static member PathIsRootLibrary :
        filePath : string -> bool

Parametri

filePath String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.PrecompilaCodice

Metodo UtilPrecompilaCodice

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void PrecompilaCodice(
    FindCodeCommand cmd
)
Public Shared Sub PrecompilaCodice (
    cmd As FindCodeCommand
)
public:
static void PrecompilaCodice(
    FindCodeCommand^ cmd
)
static member PrecompilaCodice :
        cmd : FindCodeCommand -> unit

Parametri

cmd FindCodeCommand
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadAllProperties

Metodo UtilReadAllProperties
Lista degli overload
Nome | Descrizione
ReadAllProperties(IModelDoc2, String) |
ReadAllProperties(String, Boolean, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadAllProperties(IModelDoc2, String)

Metodo UtilReadAllProperties(IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function ReadAllProperties (
    swDoc As IModelDoc2,
    config As String
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    IModelDoc2^ swDoc,
    String^ config
)
static member ReadAllProperties :
        swDoc : IModelDoc2 *
        config : string -> Dictionary<string, Object>

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties
Namespace DedNetSw


Metodo Util.ReadAllProperties(String, Boolean, String)

Metodo UtilReadAllProperties(String, Boolean, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    string filename,
    bool includeStandardProperties = false,
    string config = "*"
)
Public Shared Function ReadAllProperties (
    filename As String,
    Optional includeStandardProperties As Boolean = false,
    Optional config As String = "*"
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    String^ filename,
    bool includeStandardProperties = false,
    String^ config = L"*"
)
static member ReadAllProperties :
        filename : string *
        ?includeStandardProperties : bool *
        ?config : string
(* Defaults:
        let _includeStandardProperties = defaultArg includeStandardProperties false
        let _config = defaultArg config "*"
*)
-> Dictionary<string, Object>

Parametri

filename String
includeStandardProperties Boolean (Optional)
config String (Optional)

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties
Namespace DedNetSw


Metodo Util.ReadAnagr

Metodo UtilReadAnagr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadAnagr(
    string dedid,
    string dedrev
)
Public Shared Function ReadAnagr (
    dedid As String,
    dedrev As String
) As DedData
public:
static DedData^ ReadAnagr(
    String^ dedid,
    String^ dedrev
)
static member ReadAnagr :
        dedid : string *
        dedrev : string -> DedData

Parametri

dedid String
dedrev String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwComp

Metodo UtilReadDataFromSwComp
Lista degli overload
Nome | Descrizione
ReadDataFromSwComp(IComponent2, Boolean) |
ReadDataFromSwComp(IComponent2, String, Boolean) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwComp(IComponent2, Boolean)

Metodo UtilReadDataFromSwComp(IComponent2, Boolean)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwComp(
    IComponent2 comp,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromSwComp (
    comp As IComponent2,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromSwComp(
    IComponent2^ comp,
    bool checkDataMatching = true
)
static member ReadDataFromSwComp :
        comp : IComponent2 *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

comp IComponent2
checkDataMatching Boolean (Optional)

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Overload di ReadDataFromSwComp
Namespace DedNetSw


Metodo Util.ReadDataFromSwComp(IComponent2, String, Boolean)

Metodo UtilReadDataFromSwComp(IComponent2, String, Boolean)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwComp(
    IComponent2 comp,
    string config,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromSwComp (
    comp As IComponent2,
    config As String,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromSwComp(
    IComponent2^ comp,
    String^ config,
    bool checkDataMatching = true
)
static member ReadDataFromSwComp :
        comp : IComponent2 *
        config : string *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

comp IComponent2
config String
checkDataMatching Boolean (Optional)

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Overload di ReadDataFromSwComp
Namespace DedNetSw


Metodo Util.ReadDataFromSwCompOrMatchingModelState

Metodo UtilReadDataFromSwCompOrMatchingModelState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwCompOrMatchingModelState(
    IComponent2 comp
)
Public Shared Function ReadDataFromSwCompOrMatchingModelState (
    comp As IComponent2
) As DedData
public:
static DedData^ ReadDataFromSwCompOrMatchingModelState(
    IComponent2^ comp
)
static member ReadDataFromSwCompOrMatchingModelState :
        comp : IComponent2 -> DedData

Parametri

comp IComponent2

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwCompProperties

Metodo UtilReadDataFromSwCompProperties
Lista degli overload
Nome | Descrizione
ReadDataFromSwCompProperties(IComponent2) |
ReadDataFromSwCompProperties(IComponent2, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwCompProperties(IComponent2)

Metodo UtilReadDataFromSwCompProperties(IComponent2)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwCompProperties(
    IComponent2 swComp
)
Public Shared Function ReadDataFromSwCompProperties (
    swComp As IComponent2
) As DedData
public:
static DedData^ ReadDataFromSwCompProperties(
    IComponent2^ swComp
)
static member ReadDataFromSwCompProperties :
        swComp : IComponent2 -> DedData

Parametri

swComp IComponent2

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Overload di ReadDataFromSwCompProperties
Namespace DedNetSw


Metodo Util.ReadDataFromSwCompProperties(IComponent2, String)

Metodo UtilReadDataFromSwCompProperties(IComponent2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwCompProperties(
    IComponent2 swComp,
    string config
)
Public Shared Function ReadDataFromSwCompProperties (
    swComp As IComponent2,
    config As String
) As DedData
public:
static DedData^ ReadDataFromSwCompProperties(
    IComponent2^ swComp,
    String^ config
)
static member ReadDataFromSwCompProperties :
        swComp : IComponent2 *
        config : string -> DedData

Parametri

swComp IComponent2
config String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Overload di ReadDataFromSwCompProperties
Namespace DedNetSw


Metodo Util.ReadDataFromSwDoc

Metodo UtilReadDataFromSwDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwDoc(
    IModelDoc2 swDoc,
    string config,
    DedDoc dbDoc = null,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromSwDoc (
    swDoc As IModelDoc2,
    config As String,
    Optional dbDoc As DedDoc = Nothing,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromSwDoc(
    IModelDoc2^ swDoc,
    String^ config,
    DedDoc^ dbDoc = nullptr,
    bool checkDataMatching = true
)
static member ReadDataFromSwDoc :
        swDoc : IModelDoc2 *
        config : string *
        ?dbDoc : DedDoc *
        ?checkDataMatching : bool
(* Defaults:
        let _dbDoc = defaultArg dbDoc null
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

swDoc IModelDoc2
config String
dbDoc DedDoc (Optional)
checkDataMatching Boolean (Optional)

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwDocOrMatchingModelState

Metodo UtilReadDataFromSwDocOrMatchingModelState

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwDocOrMatchingModelState(
    IModelDoc2 swDoc,
    string config,
    DedDoc dbDoc = null
)
Public Shared Function ReadDataFromSwDocOrMatchingModelState (
    swDoc As IModelDoc2,
    config As String,
    Optional dbDoc As DedDoc = Nothing
) As DedData
public:
static DedData^ ReadDataFromSwDocOrMatchingModelState(
    IModelDoc2^ swDoc,
    String^ config,
    DedDoc^ dbDoc = nullptr
)
static member ReadDataFromSwDocOrMatchingModelState :
        swDoc : IModelDoc2 *
        config : string *
        ?dbDoc : DedDoc
(* Defaults:
        let _dbDoc = defaultArg dbDoc null
*)
-> DedData

Parametri

swDoc IModelDoc2
config String
dbDoc DedDoc (Optional)

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwDocProperties

Metodo UtilReadDataFromSwDocProperties

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwDocProperties(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function ReadDataFromSwDocProperties (
    swDoc As IModelDoc2,
    config As String
) As DedData
public:
static DedData^ ReadDataFromSwDocProperties(
    IModelDoc2^ swDoc,
    String^ config
)
static member ReadDataFromSwDocProperties :
        swDoc : IModelDoc2 *
        config : string -> DedData

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwFeature

Metodo UtilReadDataFromSwFeature

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwFeature(
    IFeature feature
)
Public Shared Function ReadDataFromSwFeature (
    feature As IFeature
) As DedData
public:
static DedData^ ReadDataFromSwFeature(
    IFeature^ feature
)
static member ReadDataFromSwFeature :
        feature : IFeature -> DedData

Parametri

feature IFeature

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwFile

Metodo UtilReadDataFromSwFile

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwFile(
    string swFileName,
    bool checkDataMatching = true,
    string config = "*"
)
Public Shared Function ReadDataFromSwFile (
    swFileName As String,
    Optional checkDataMatching As Boolean = true,
    Optional config As String = "*"
) As DedData
public:
static DedData^ ReadDataFromSwFile(
    String^ swFileName,
    bool checkDataMatching = true,
    String^ config = L"*"
)
static member ReadDataFromSwFile :
        swFileName : string *
        ?checkDataMatching : bool *
        ?config : string
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
        let _config = defaultArg config "*"
*)
-> DedData

Parametri

swFileName String
checkDataMatching Boolean (Optional)
config String (Optional)

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReadDataFromSwFileProperties

Metodo UtilReadDataFromSwFileProperties

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromSwFileProperties(
    string swFileName,
    string config
)
Public Shared Function ReadDataFromSwFileProperties (
    swFileName As String,
    config As String
) As DedData
public:
static DedData^ ReadDataFromSwFileProperties(
    String^ swFileName,
    String^ config
)
static member ReadDataFromSwFileProperties :
        swFileName : string *
        config : string -> DedData

Parametri

swFileName String
config String

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.RemoveAttribute

Metodo UtilRemoveAttribute

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FileAttributes RemoveAttribute(
    FileAttributes attributes,
    FileAttributes attributesToRemove
)
Public Shared Function RemoveAttribute (
    attributes As FileAttributes,
    attributesToRemove As FileAttributes
) As FileAttributes
public:
static FileAttributes RemoveAttribute(
    FileAttributes attributes,
    FileAttributes attributesToRemove
)
static member RemoveAttribute :
        attributes : FileAttributes *
        attributesToRemove : FileAttributes -> FileAttributes

Parametri

attributes FileAttributes
attributesToRemove FileAttributes

Valore di ritorno

FileAttributes
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.ReplaceClosingDrawing

Metodo UtilReplaceClosingDrawing

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ReplaceClosingDrawing(
    string filename,
    string startRefName,
    string destRefName,
    ref IModelDoc2 swDoc
)
Public Shared Function ReplaceClosingDrawing (
    filename As String,
    startRefName As String,
    destRefName As String,
    ByRef swDoc As IModelDoc2
) As Boolean
public:
static bool ReplaceClosingDrawing(
    String^ filename,
    String^ startRefName,
    String^ destRefName,
    IModelDoc2^% swDoc
)
static member ReplaceClosingDrawing :
        filename : string *
        startRefName : string *
        destRefName : string *
        swDoc : IModelDoc2 byref -> bool

Parametri

filename String
startRefName String
destRefName String
swDoc IModelDoc2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.RunMacro

Metodo UtilRunMacro

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool RunMacro(
    string filePathName,
    string moduleName,
    string procedureName,
    int options,
    out int error
)
Public Shared Function RunMacro (
    filePathName As String,
    moduleName As String,
    procedureName As String,
    options As Integer,
    <OutAttribute> ByRef error As Integer
) As Boolean
public:
static bool RunMacro(
    String^ filePathName,
    String^ moduleName,
    String^ procedureName,
    int options,
    [OutAttribute] int% error
)
static member RunMacro :
        filePathName : string *
        moduleName : string *
        procedureName : string *
        options : int *
        error : int byref -> bool

Parametri

filePathName String
moduleName String
procedureName String
options Int32
error Int32

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.Save

Metodo UtilSave

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Save(
    IModelDoc2 swDoc,
    bool askUser,
    bool saveDep
)
Public Shared Sub Save (
    swDoc As IModelDoc2,
    askUser As Boolean,
    saveDep As Boolean
)
public:
static void Save(
    IModelDoc2^ swDoc,
    bool askUser,
    bool saveDep
)
static member Save :
        swDoc : IModelDoc2 *
        askUser : bool *
        saveDep : bool -> unit

Parametri

swDoc IModelDoc2
askUser Boolean
saveDep Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SaveAs

Metodo UtilSaveAs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SaveAs(
    IModelDoc2 swDoc,
    string fullDestName,
    bool copyAs
)
Public Shared Sub SaveAs (
    swDoc As IModelDoc2,
    fullDestName As String,
    copyAs As Boolean
)
public:
static void SaveAs(
    IModelDoc2^ swDoc,
    String^ fullDestName,
    bool copyAs
)
static member SaveAs :
        swDoc : IModelDoc2 *
        fullDestName : string *
        copyAs : bool -> unit

Parametri

swDoc IModelDoc2
fullDestName String
copyAs Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SelectComponentByNameAndConfig

Metodo UtilSelectComponentByNameAndConfig

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SelectComponentByNameAndConfig(
    IModelDoc2 topDocument,
    IComponent2 swcomp
)
Public Shared Sub SelectComponentByNameAndConfig (
    topDocument As IModelDoc2,
    swcomp As IComponent2
)
public:
static void SelectComponentByNameAndConfig(
    IModelDoc2^ topDocument,
    IComponent2^ swcomp
)
static member SelectComponentByNameAndConfig :
        topDocument : IModelDoc2 *
        swcomp : IComponent2 -> unit

Parametri

topDocument IModelDoc2
swcomp IComponent2
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SetAttrs

Metodo UtilSetAttrs

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SetAttrs(
    DedData data,
    DedDoc doc,
    string config
)
Public Shared Function SetAttrs (
    data As DedData,
    doc As DedDoc,
    config As String
) As Boolean
public:
static bool SetAttrs(
    DedData^ data,
    DedDoc^ doc,
    String^ config
)
static member SetAttrs :
        data : DedData *
        doc : DedDoc *
        config : string -> bool

Parametri

data DedData
doc DedDoc
config String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SetLastDataRowVer

Metodo UtilSetLastDataRowVer
Lista degli overload
Nome | Descrizione
SetLastDataRowVer(IModelDoc2, Guid, String) |
SetLastDataRowVer(String, Guid, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SetLastDataRowVer(IModelDoc2, Guid, String)

Metodo UtilSetLastDataRowVer(IModelDoc2, Guid, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    IModelDoc2 swDoc,
    Guid rowver,
    string config
)
Public Shared Sub SetLastDataRowVer (
    swDoc As IModelDoc2,
    rowver As Guid,
    config As String
)
public:
static void SetLastDataRowVer(
    IModelDoc2^ swDoc,
    Guid rowver,
    String^ config
)
static member SetLastDataRowVer :
        swDoc : IModelDoc2 *
        rowver : Guid *
        config : string -> unit

Parametri

swDoc IModelDoc2
rowver Guid
config String
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer
Namespace DedNetSw


Metodo Util.SetLastDataRowVer(String, Guid, String)

Metodo UtilSetLastDataRowVer(String, Guid, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    string fullFileName,
    Guid rowver,
    string config
)
Public Shared Sub SetLastDataRowVer (
    fullFileName As String,
    rowver As Guid,
    config As String
)
public:
static void SetLastDataRowVer(
    String^ fullFileName,
    Guid rowver,
    String^ config
)
static member SetLastDataRowVer :
        fullFileName : string *
        rowver : Guid *
        config : string -> unit

Parametri

fullFileName String
rowver Guid
config String
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer
Namespace DedNetSw


Metodo Util.SetOnFileDirtyFlags

Metodo UtilSetOnFileDirtyFlags

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetOnFileDirtyFlags(
    DedNetSwAppOnFileDirtyBehaviour ofdMode
)
Public Shared Sub SetOnFileDirtyFlags (
    ofdMode As DedNetSwAppOnFileDirtyBehaviour
)
public:
static void SetOnFileDirtyFlags(
    DedNetSwAppOnFileDirtyBehaviour ofdMode
)
static member SetOnFileDirtyFlags :
        ofdMode : DedNetSwAppOnFileDirtyBehaviour -> unit

Parametri

ofdMode DedNetSwAppOnFileDirtyBehaviour
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwComp2DedDataPart

Metodo UtilSwComp2DedDataPart
Lista degli overload
Nome | Descrizione
SwComp2DedDataPart(IComponent2, DedAttrList) |
SwComp2DedDataPart(IComponent2, UtilDataAttrTypeEnum) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwComp2DedDataPart(IComponent2, DedAttrList)

Metodo UtilSwComp2DedDataPart(IComponent2, DedAttrList)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwComp2DedDataPart(
    IComponent2 swComp,
    DedAttrList attrList
)
Public Shared Function SwComp2DedDataPart (
    swComp As IComponent2,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ SwComp2DedDataPart(
    IComponent2^ swComp,
    DedAttrList^ attrList
)
static member SwComp2DedDataPart :
        swComp : IComponent2 *
        attrList : DedAttrList -> DedDataPart

Parametri

swComp IComponent2
attrList DedAttrList

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwComp2DedDataPart
Namespace DedNetSw


Metodo Util.SwComp2DedDataPart(IComponent2, Util.DataAttrTypeEnum)

Metodo UtilSwComp2DedDataPart(IComponent2, UtilDataAttrTypeEnum)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwComp2DedDataPart(
    IComponent2 swComp,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function SwComp2DedDataPart (
    swComp As IComponent2,
    attrsType As UtilDataAttrTypeEnum
) As DedDataPart
public:
static DedDataPart^ SwComp2DedDataPart(
    IComponent2^ swComp,
    UtilDataAttrTypeEnum attrsType
)
static member SwComp2DedDataPart :
        swComp : IComponent2 *
        attrsType : UtilDataAttrTypeEnum -> DedDataPart

Parametri

swComp IComponent2
attrsType UtilDataAttrTypeEnum

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwComp2DedDataPart
Namespace DedNetSw


Metodo Util.SwComp2DedDoc

Metodo UtilSwComp2DedDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc SwComp2DedDoc(
    IComponent2 comp
)
Public Shared Function SwComp2DedDoc (
    comp As IComponent2
) As DedDoc
public:
static DedDoc^ SwComp2DedDoc(
    IComponent2^ comp
)
static member SwComp2DedDoc :
        comp : IComponent2 -> DedDoc

Parametri

comp IComponent2

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwDoc2DedDataPart

Metodo UtilSwDoc2DedDataPart
Lista degli overload
Nome | Descrizione
SwDoc2DedDataPart(IModelDoc2, String) |
SwDoc2DedDataPart(IModelDoc2, DedAttrList, String) |
SwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String) |
SwDoc2DedDataPart(IModelDoc2, String, Boolean) |
SwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String, Boolean) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwDoc2DedDataPart(IModelDoc2, String)

Metodo UtilSwDoc2DedDataPart(IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwDoc2DedDataPart(
    IModelDoc2 swDoc,
    string config
)
Public Shared Function SwDoc2DedDataPart (
    swDoc As IModelDoc2,
    config As String
) As DedDataPart
public:
static DedDataPart^ SwDoc2DedDataPart(
    IModelDoc2^ swDoc,
    String^ config
)
static member SwDoc2DedDataPart :
        swDoc : IModelDoc2 *
        config : string -> DedDataPart

Parametri

swDoc IModelDoc2
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwDoc2DedDataPart
Namespace DedNetSw


Metodo Util.SwDoc2DedDataPart(IModelDoc2, DedAttrList, String)

Metodo UtilSwDoc2DedDataPart(IModelDoc2, DedAttrList, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwDoc2DedDataPart(
    IModelDoc2 swDoc,
    DedAttrList attrList,
    string config
)
Public Shared Function SwDoc2DedDataPart (
    swDoc As IModelDoc2,
    attrList As DedAttrList,
    config As String
) As DedDataPart
public:
static DedDataPart^ SwDoc2DedDataPart(
    IModelDoc2^ swDoc,
    DedAttrList^ attrList,
    String^ config
)
static member SwDoc2DedDataPart :
        swDoc : IModelDoc2 *
        attrList : DedAttrList *
        config : string -> DedDataPart

Parametri

swDoc IModelDoc2
attrList DedAttrList
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwDoc2DedDataPart
Namespace DedNetSw


Metodo Util.SwDoc2DedDataPart(IModelDoc2, Util.DataAttrTypeEnum, String)

Metodo UtilSwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwDoc2DedDataPart(
    IModelDoc2 swDoc,
    UtilDataAttrTypeEnum attrsType,
    string config
)
Public Shared Function SwDoc2DedDataPart (
    swDoc As IModelDoc2,
    attrsType As UtilDataAttrTypeEnum,
    config As String
) As DedDataPart
public:
static DedDataPart^ SwDoc2DedDataPart(
    IModelDoc2^ swDoc,
    UtilDataAttrTypeEnum attrsType,
    String^ config
)
static member SwDoc2DedDataPart :
        swDoc : IModelDoc2 *
        attrsType : UtilDataAttrTypeEnum *
        config : string -> DedDataPart

Parametri

swDoc IModelDoc2
attrsType UtilDataAttrTypeEnum
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwDoc2DedDataPart
Namespace DedNetSw


Metodo Util.SwDoc2DedDataPart(IModelDoc2, String, Boolean)

Metodo UtilSwDoc2DedDataPart(IModelDoc2, String, Boolean)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwDoc2DedDataPart(
    IModelDoc2 swDoc,
    string config,
    bool checkDataMatching
)
Public Shared Function SwDoc2DedDataPart (
    swDoc As IModelDoc2,
    config As String,
    checkDataMatching As Boolean
) As DedDataPart
public:
static DedDataPart^ SwDoc2DedDataPart(
    IModelDoc2^ swDoc,
    String^ config,
    bool checkDataMatching
)
static member SwDoc2DedDataPart :
        swDoc : IModelDoc2 *
        config : string *
        checkDataMatching : bool -> DedDataPart

Parametri

swDoc IModelDoc2
config String
checkDataMatching Boolean

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwDoc2DedDataPart
Namespace DedNetSw


Metodo Util.SwDoc2DedDataPart(IModelDoc2, Util.DataAttrTypeEnum, String, Boolean)

Metodo UtilSwDoc2DedDataPart(IModelDoc2, UtilDataAttrTypeEnum, String, Boolean)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwDoc2DedDataPart(
    IModelDoc2 swDoc,
    UtilDataAttrTypeEnum attrsType,
    string config,
    bool checkDataMatching
)
Public Shared Function SwDoc2DedDataPart (
    swDoc As IModelDoc2,
    attrsType As UtilDataAttrTypeEnum,
    config As String,
    checkDataMatching As Boolean
) As DedDataPart
public:
static DedDataPart^ SwDoc2DedDataPart(
    IModelDoc2^ swDoc,
    UtilDataAttrTypeEnum attrsType,
    String^ config,
    bool checkDataMatching
)
static member SwDoc2DedDataPart :
        swDoc : IModelDoc2 *
        attrsType : UtilDataAttrTypeEnum *
        config : string *
        checkDataMatching : bool -> DedDataPart

Parametri

swDoc IModelDoc2
attrsType UtilDataAttrTypeEnum
config String
checkDataMatching Boolean

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwDoc2DedDataPart
Namespace DedNetSw


Metodo Util.SwDoc2DedDoc

Metodo UtilSwDoc2DedDoc

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc SwDoc2DedDoc(
    IModelDoc2 doc
)
Public Shared Function SwDoc2DedDoc (
    doc As IModelDoc2
) As DedDoc
public:
static DedDoc^ SwDoc2DedDoc(
    IModelDoc2^ doc
)
static member SwDoc2DedDoc :
        doc : IModelDoc2 -> DedDoc

Parametri

doc IModelDoc2

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwDocAttrMatchData

Metodo UtilSwDocAttrMatchData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SwDocAttrMatchData(
    IModelDoc2 swDoc,
    DedData data,
    string config
)
Public Shared Function SwDocAttrMatchData (
    swDoc As IModelDoc2,
    data As DedData,
    config As String
) As Boolean
public:
static bool SwDocAttrMatchData(
    IModelDoc2^ swDoc,
    DedData^ data,
    String^ config
)
static member SwDocAttrMatchData :
        swDoc : IModelDoc2 *
        data : DedData *
        config : string -> bool

Parametri

swDoc IModelDoc2
data DedData
config String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwFeature2DedDataPart

Metodo UtilSwFeature2DedDataPart
Lista degli overload
Nome | Descrizione
SwFeature2DedDataPart(IFeature, DedAttrList) |
SwFeature2DedDataPart(IFeature, UtilDataAttrTypeEnum) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwFeature2DedDataPart(IFeature, DedAttrList)

Metodo UtilSwFeature2DedDataPart(IFeature, DedAttrList)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwFeature2DedDataPart(
    IFeature swFeat,
    DedAttrList attrList
)
Public Shared Function SwFeature2DedDataPart (
    swFeat As IFeature,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ SwFeature2DedDataPart(
    IFeature^ swFeat,
    DedAttrList^ attrList
)
static member SwFeature2DedDataPart :
        swFeat : IFeature *
        attrList : DedAttrList -> DedDataPart

Parametri

swFeat IFeature
attrList DedAttrList

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwFeature2DedDataPart
Namespace DedNetSw


Metodo Util.SwFeature2DedDataPart(IFeature, Util.DataAttrTypeEnum)

Metodo UtilSwFeature2DedDataPart(IFeature, UtilDataAttrTypeEnum)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwFeature2DedDataPart(
    IFeature swFeat,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function SwFeature2DedDataPart (
    swFeat As IFeature,
    attrsType As UtilDataAttrTypeEnum
) As DedDataPart
public:
static DedDataPart^ SwFeature2DedDataPart(
    IFeature^ swFeat,
    UtilDataAttrTypeEnum attrsType
)
static member SwFeature2DedDataPart :
        swFeat : IFeature *
        attrsType : UtilDataAttrTypeEnum -> DedDataPart

Parametri

swFeat IFeature
attrsType UtilDataAttrTypeEnum

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwFeature2DedDataPart
Namespace DedNetSw


Metodo Util.SwFile2DedDataPart

Metodo UtilSwFile2DedDataPart
Lista degli overload
Nome | Descrizione
SwFile2DedDataPart(String, DedType, String) |
SwFile2DedDataPart(String, DedType, DedAttrList, String) |
SwFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.SwFile2DedDataPart(String, DedType, String)

Metodo UtilSwFile2DedDataPart(String, DedType, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwFile2DedDataPart(
    string filename,
    DedType refType,
    string config
)
Public Shared Function SwFile2DedDataPart (
    filename As String,
    refType As DedType,
    config As String
) As DedDataPart
public:
static DedDataPart^ SwFile2DedDataPart(
    String^ filename,
    DedType^ refType,
    String^ config
)
static member SwFile2DedDataPart :
        filename : string *
        refType : DedType *
        config : string -> DedDataPart

Parametri

filename String
refType DedType
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwFile2DedDataPart
Namespace DedNetSw


Metodo Util.SwFile2DedDataPart(String, DedType, DedAttrList, String)

Metodo UtilSwFile2DedDataPart(String, DedType, DedAttrList, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwFile2DedDataPart(
    string filename,
    DedType refType,
    DedAttrList attrList,
    string config
)
Public Shared Function SwFile2DedDataPart (
    filename As String,
    refType As DedType,
    attrList As DedAttrList,
    config As String
) As DedDataPart
public:
static DedDataPart^ SwFile2DedDataPart(
    String^ filename,
    DedType^ refType,
    DedAttrList^ attrList,
    String^ config
)
static member SwFile2DedDataPart :
        filename : string *
        refType : DedType *
        attrList : DedAttrList *
        config : string -> DedDataPart

Parametri

filename String
refType DedType
attrList DedAttrList
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwFile2DedDataPart
Namespace DedNetSw


Metodo Util.SwFile2DedDataPart(String, DedType, Util.DataAttrTypeEnum, String)

Metodo UtilSwFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart SwFile2DedDataPart(
    string filename,
    DedType refType,
    UtilDataAttrTypeEnum attrsType,
    string config
)
Public Shared Function SwFile2DedDataPart (
    filename As String,
    refType As DedType,
    attrsType As UtilDataAttrTypeEnum,
    config As String
) As DedDataPart
public:
static DedDataPart^ SwFile2DedDataPart(
    String^ filename,
    DedType^ refType,
    UtilDataAttrTypeEnum attrsType,
    String^ config
)
static member SwFile2DedDataPart :
        filename : string *
        refType : DedType *
        attrsType : UtilDataAttrTypeEnum *
        config : string -> DedDataPart

Parametri

filename String
refType DedType
attrsType UtilDataAttrTypeEnum
config String

Valore di ritorno

DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di SwFile2DedDataPart
Namespace DedNetSw


Metodo Util.SwFileAttrMatchData

Metodo UtilSwFileAttrMatchData

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SwFileAttrMatchData(
    string swFileName,
    DedData data,
    string config
)
Public Shared Function SwFileAttrMatchData (
    swFileName As String,
    data As DedData,
    config As String
) As Boolean
public:
static bool SwFileAttrMatchData(
    String^ swFileName,
    DedData^ data,
    String^ config
)
static member SwFileAttrMatchData :
        swFileName : string *
        data : DedData *
        config : string -> bool

Parametri

swFileName String
data DedData
config String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.UpdateMaterialAttr

Metodo UtilUpdateMaterialAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateMaterialAttr(
    PartDoc part,
    string material,
    string config
)
Public Shared Sub UpdateMaterialAttr (
    part As PartDoc,
    material As String,
    config As String
)
public:
static void UpdateMaterialAttr(
    PartDoc^ part,
    String^ material,
    String^ config
)
static member UpdateMaterialAttr :
        part : PartDoc *
        material : string *
        config : string -> unit

Parametri

part PartDoc
material String
config String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.UpdateReference

Metodo UtilUpdateReference

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateReference(
    IModelDoc2 doc,
    DocStructInfo item,
    DocStructInfoList list
)
Public Shared Function UpdateReference (
    doc As IModelDoc2,
    item As DocStructInfo,
    list As DocStructInfoList
) As Boolean
public:
static bool UpdateReference(
    IModelDoc2^ doc,
    DocStructInfo^ item,
    DocStructInfoList^ list
)
static member UpdateReference :
        doc : IModelDoc2 *
        item : DocStructInfo *
        list : DocStructInfoList -> bool

Parametri

doc IModelDoc2
item DocStructInfo
list DocStructInfoList

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.UpdateSingleDocumentReference

Metodo UtilUpdateSingleDocumentReference

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateSingleDocumentReference(
    string filename,
    string startRefName,
    string destRefName
)
Public Shared Function UpdateSingleDocumentReference (
    filename As String,
    startRefName As String,
    destRefName As String
) As Boolean
public:
static bool UpdateSingleDocumentReference(
    String^ filename,
    String^ startRefName,
    String^ destRefName
)
static member UpdateSingleDocumentReference :
        filename : string *
        startRefName : string *
        destRefName : string -> bool

Parametri

filename String
startRefName String
destRefName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.WriteAllProperties

Metodo UtilWriteAllProperties
Lista degli overload
Nome | Descrizione
WriteAllProperties(DedDoc, String) |
WriteAllProperties(DedDoc, IModelDoc2, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.WriteAllProperties(DedDoc, String)

Metodo UtilWriteAllProperties(DedDoc, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    string config
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    config As String
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    String^ config
)
static member WriteAllProperties :
        doc : DedDoc *
        config : string -> unit

Parametri

doc DedDoc
config String
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties
Namespace DedNetSw


Metodo Util.WriteAllProperties(DedDoc, IModelDoc2, String)

Metodo UtilWriteAllProperties(DedDoc, IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    IModelDoc2 swDoc,
    string config
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    swDoc As IModelDoc2,
    config As String
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    IModelDoc2^ swDoc,
    String^ config
)
static member WriteAllProperties :
        doc : DedDoc *
        swDoc : IModelDoc2 *
        config : string -> unit

Parametri

doc DedDoc
swDoc IModelDoc2
config String
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties
Namespace DedNetSw


Metodo Util.WriteAttr

Metodo UtilWriteAttr

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool WriteAttr(
    QsSwAttr attrManager,
    DedAttr attr,
    Object valore,
    IComponent2 occ
)
Public Shared Function WriteAttr (
    attrManager As QsSwAttr,
    attr As DedAttr,
    valore As Object,
    occ As IComponent2
) As Boolean
public:
static bool WriteAttr(
    QsSwAttr^ attrManager,
    DedAttr^ attr,
    Object^ valore,
    IComponent2^ occ
)
static member WriteAttr :
        attrManager : QsSwAttr *
        attr : DedAttr *
        valore : Object *
        occ : IComponent2 -> bool

Parametri

attrManager QsSwAttr
attr DedAttr
valore Object
occ IComponent2

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Metodo Util.WriteUserProperties

Metodo UtilWriteUserProperties

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteUserProperties(
    string filename,
    Dictionary<string, Object> attrs,
    string config
)
Public Shared Sub WriteUserProperties (
    filename As String,
    attrs As Dictionary(Of String, Object),
    config As String
)
public:
static void WriteUserProperties(
    String^ filename,
    Dictionary<String^, Object^>^ attrs,
    String^ config
)
static member WriteUserProperties :
        filename : string *
        attrs : Dictionary<string, Object> *
        config : string -> unit

Parametri

filename String
attrs Dictionary String, Object
config String
Vedi anche

Documentazione

Classe Util
Namespace DedNetSw


Enumerazione Util.DataAttrTypeEnum

Enumerazione UtilDataAttrTypeEnum

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DataAttrTypeEnum
<FlagsAttribute>
Public Enumeration DataAttrTypeEnum
[FlagsAttribute]
public enum class DataAttrTypeEnum
[<FlagsAttribute>]
type DataAttrTypeEnum
Membri
Nome | Valore | Descrizione
Anagrafica | 0 |
Documento | 1 |
Distinta | 2 |
Occorrenza | 4 |
AnagraficaOccorrenza | 8 |
AnagraficaDocumento | 16 |
AnagraficaDocumentoOccorrenza | 32 |
AnagraficaDistinta | 64 |
AnagraficaDistintaOccorrenza | 128 |
All | 256 |
Vedi anche

Documentazione

Namespace DedNetSw


Classe Util.IniFiles

Classe UtilIniFiles
Gerarchia di ereditarietà
SystemObject
DedNetSwUtilIniFiles

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class IniFiles
Public Class IniFiles
public ref class IniFiles
type IniFiles = class end

Il tipo UtilIniFiles espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilIniFiles |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileIni |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ReadValue |
Metodo pubblico | ReadValuesFromSection |
Metodo pubblico | WriteValue |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Util.IniFiles

Costruttore UtilIniFiles

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IniFiles()
Public Sub New
public:
IniFiles()
new : unit -> IniFiles
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Proprietà di IniFiles

Il tipo UtilIniFiles espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileIni |
Torna su
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Proprietà Util.IniFiles.FileIni

Proprietà UtilIniFilesFileIni

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FileIni { get; set; }
Public Property FileIni As String
    Get
    Set
public:
property String^ FileIni {
    String^ get ();
    void set (String^ value);
}
member FileIni : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Metodi di IniFiles

Il tipo UtilIniFiles espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ReadValue |
Metodo pubblico | ReadValuesFromSection |
Metodo pubblico | WriteValue |
Torna su
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Metodo Util.IniFiles.ReadValue

Metodo UtilIniFilesReadValue

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ReadValue(
    string Section,
    string Key
)
Public Function ReadValue (
    Section As String,
    Key As String
) As String
public:
String^ ReadValue(
    String^ Section,
    String^ Key
)
member ReadValue :
        Section : string *
        Key : string -> string

Parametri

Section String
Key String

Valore di ritorno

String
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Metodo Util.IniFiles.ReadValuesFromSection

Metodo UtilIniFilesReadValuesFromSection

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> ReadValuesFromSection(
    string Section
)
Public Function ReadValuesFromSection (
    Section As String
) As List(Of String)
public:
List<String^>^ ReadValuesFromSection(
    String^ Section
)
member ReadValuesFromSection :
        Section : string -> List<string>

Parametri

Section String

Valore di ritorno

List String
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Metodo Util.IniFiles.WriteValue

Metodo UtilIniFilesWriteValue

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void WriteValue(
    string Section,
    string Key,
    string Value
)
Public Sub WriteValue (
    Section As String,
    Key As String,
    Value As String
)
public:
void WriteValue(
    String^ Section,
    String^ Key,
    String^ Value
)
member WriteValue :
        Section : string *
        Key : string *
        Value : string -> unit

Parametri

Section String
Key String
Value String
Vedi anche

Documentazione

Classe UtilIniFiles
Namespace DedNetSw


Classe Util.PrtDwgExporterHelper

Classe UtilPrtDwgExporterHelper
Gerarchia di ereditarietà
SystemObject
DedNetSwUtilPrtDwgExporterHelper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PrtDwgExporterHelper
Public Class PrtDwgExporterHelper
public ref class PrtDwgExporterHelper
type PrtDwgExporterHelper = class end

Il tipo UtilPrtDwgExporterHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilPrtDwgExporterHelper |
Torna su
Metodi
Nome | Descrizione
ExportDwgTop |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Util.PrtDwgExporterHelper

Costruttore UtilPrtDwgExporterHelper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PrtDwgExporterHelper()
Public Sub New
public:
PrtDwgExporterHelper()
new : unit -> PrtDwgExporterHelper
Vedi anche

Documentazione

Classe UtilPrtDwgExporterHelper
Namespace DedNetSw


Metodi di PrtDwgExporterHelper

Il tipo UtilPrtDwgExporterHelper espone i seguenti membri.

Metodi
Nome | Descrizione
ExportDwgTop |
Torna su
Vedi anche

Documentazione

Classe UtilPrtDwgExporterHelper
Namespace DedNetSw


Metodo Util.PrtDwgExporterHelper.ExportDwgTop

Metodo UtilPrtDwgExporterHelperExportDwgTop

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ExportDwgTop(
    IModelDoc2 doc,
    string fout
)
Public Shared Function ExportDwgTop (
    doc As IModelDoc2,
    fout As String
) As Boolean
public:
static bool ExportDwgTop(
    IModelDoc2^ doc,
    String^ fout
)
static member ExportDwgTop :
        doc : IModelDoc2 *
        fout : string -> bool

Parametri

doc IModelDoc2
fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilPrtDwgExporterHelper
Namespace DedNetSw


Classe Util.SwPublisherHelper

Classe UtilSwPublisherHelper
Gerarchia di ereditarietà
SystemObject
DedNetSwUtilSwPublisherHelper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwPublisherHelper
Public Class SwPublisherHelper
public ref class SwPublisherHelper
type SwPublisherHelper = class end

Il tipo UtilSwPublisherHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilSwPublisherHelper |
Torna su
Metodi
Nome | Descrizione
PublishDWG |
PublishDXF |
PublishEdrw |
PublishEmodel |
PublishIGES |
PublishPDF(IModelDoc2, String) |
PublishPDF(IModelDoc2, String, DictionaryString, Object) |
PublishPDF3D |
PublishSheetMetalDXF |
PublishSTEP |
PublishSTL |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw


Costruttore Util.SwPublisherHelper

Costruttore UtilSwPublisherHelper

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwPublisherHelper()
Public Sub New
public:
SwPublisherHelper()
new : unit -> SwPublisherHelper
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodi di SwPublisherHelper

Il tipo UtilSwPublisherHelper espone i seguenti membri.

Metodi
Nome | Descrizione
PublishDWG |
PublishDXF |
PublishEdrw |
PublishEmodel |
PublishIGES |
PublishPDF(IModelDoc2, String) |
PublishPDF(IModelDoc2, String, DictionaryString, Object) |
PublishPDF3D |
PublishSheetMetalDXF |
PublishSTEP |
PublishSTL |
Torna su
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishDWG

Metodo UtilSwPublisherHelperPublishDWG

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishDWG(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishDWG (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishDWG(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishDWG :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishDXF

Metodo UtilSwPublisherHelperPublishDXF

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishDXF(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishDXF (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishDXF(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishDXF :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishEdrw

Metodo UtilSwPublisherHelperPublishEdrw

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishEdrw(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishEdrw (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishEdrw(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishEdrw :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishEmodel

Metodo UtilSwPublisherHelperPublishEmodel

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishEmodel(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishEmodel (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishEmodel(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishEmodel :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishIGES

Metodo UtilSwPublisherHelperPublishIGES

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishIGES(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishIGES (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishIGES(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishIGES :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishPDF

Metodo UtilSwPublisherHelperPublishPDF
Lista degli overload
Nome | Descrizione
PublishPDF(IModelDoc2, String) |
PublishPDF(IModelDoc2, String, DictionaryString, Object) |
Torna su
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishPDF(IModelDoc2, String)

Metodo UtilSwPublisherHelperPublishPDF(IModelDoc2, String)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishPDF(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishPDF (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishPDF(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishPDF :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Overload di PublishPDF
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishPDF(IModelDoc2, String, Dictionary<String, Object>)

Metodo UtilSwPublisherHelperPublishPDF(IModelDoc2, String, DictionaryString, Object)

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishPDF(
    IModelDoc2 _doc,
    string _fout,
    Dictionary<string, Object> options
)
Public Shared Function PublishPDF (
    _doc As IModelDoc2,
    _fout As String,
    options As Dictionary(Of String, Object)
) As Boolean
public:
static bool PublishPDF(
    IModelDoc2^ _doc,
    String^ _fout,
    Dictionary<String^, Object^>^ options
)
static member PublishPDF :
        _doc : IModelDoc2 *
        _fout : string *
        options : Dictionary<string, Object> -> bool

Parametri

_doc IModelDoc2
_fout String
options Dictionary String, Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Overload di PublishPDF
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishPDF3D

Metodo UtilSwPublisherHelperPublishPDF3D

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishPDF3D(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishPDF3D (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishPDF3D(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishPDF3D :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishSheetMetalDXF

Metodo UtilSwPublisherHelperPublishSheetMetalDXF

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishSheetMetalDXF(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishSheetMetalDXF (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishSheetMetalDXF(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishSheetMetalDXF :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishSTEP

Metodo UtilSwPublisherHelperPublishSTEP

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishSTEP(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishSTEP (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishSTEP(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishSTEP :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


Metodo Util.SwPublisherHelper.PublishSTL

Metodo UtilSwPublisherHelperPublishSTL

Namespace: DedNetSw
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishSTL(
    IModelDoc2 _doc,
    string _fout
)
Public Shared Function PublishSTL (
    _doc As IModelDoc2,
    _fout As String
) As Boolean
public:
static bool PublishSTL(
    IModelDoc2^ _doc,
    String^ _fout
)
static member PublishSTL :
        _doc : IModelDoc2 *
        _fout : string -> bool

Parametri

_doc IModelDoc2
_fout String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UtilSwPublisherHelper
Namespace DedNetSw


DedNetSw.Commands Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AggiornaAttributiDaDB |
Classe pubblica | AggiornaDocumentoLocale |
Classe pubblica | AnnullaCheckOut |
Classe pubblica | ApriconOpzioni |
Classe pubblica | ApriFileAssociati |
Classe pubblica | ApriInLettura |
Classe pubblica | ApriInModifica |
Classe pubblica | ApriInNuovaFinestra |
Classe pubblica | ArchiviaDoc |
Classe pubblica | AssociaTavola |
Classe pubblica | AssociatedECO |
Classe pubblica | AssociatedTranslations |
Classe pubblica | Attributi |
Classe pubblica | CambiaPassword |
Classe pubblica | CambiaStato |
Classe pubblica | CambiaStatoPublishingDocumentDescriptor |
Classe pubblica | CaricaParte |
Classe pubblica | ChangeStateMultiConfInfo |
Classe pubblica | CheckIn |
Classe pubblica | CheckOut |
Classe pubblica | ConfiguraDistinta |
Classe pubblica | ControlloCoerenzaRiferimenti |
Classe pubblica | CreaComponenteAnagrafica |
Classe pubblica | CreaNuovaRappresentazione |
Classe pubblica | CreaSwAssociaConf |
Classe pubblica | CreaSwAssociaDocument |
Classe pubblica | CreaSwDisconnectConf |
Classe pubblica | CreateSparePartsDrawing |
Classe pubblica | Dipendenze |
Classe pubblica | DistintaComponenti |
Classe pubblica | DistintaEsplosa |
Classe pubblica | DistintaImplosa |
Classe pubblica | DocAssocSw |
Classe pubblica | DocRecognizer |
Classe pubblica | DocumentAssistant |
Classe pubblica | EditaAttributiSoloDB |
Classe pubblica | EditaCommesse |
Classe pubblica | EditaDistinta |
Classe pubblica | EditaECO |
Classe pubblica | EnsureLocalAssociated |
Classe pubblica | EnvMan |
Classe pubblica | EseguiLua |
Classe pubblica | FindDoc |
Classe pubblica | FindInBrowser |
Classe pubblica | FindInRicerca |
Classe pubblica | ForceMarkerAlingment |
Classe pubblica | FormAbout |
Classe pubblica | HelpSolidWorks |
Classe pubblica | IndividuaGrafica |
Classe pubblica | Lavorazione |
Classe pubblica | LinkDEDApplicazione |
Classe pubblica | MarkerInfo |
Classe pubblica | ModificaSuperato |
Classe pubblica | OpzioniApplicazione |
Classe pubblica | PackAndGoExport |
Classe pubblica | PackAndGoImport |
Classe pubblica | PackAndGoImportingStructureInfo |
Classe pubblica | PackAndGoNodeDescriptor |
Classe pubblica | PackAndGoNodeDescriptors |
Classe pubblica | PackAndGoNodeWrapper |
Classe pubblica | PackAndGoStructureDescriptor |
Classe pubblica | Pubblica |
Classe pubblica | PublishSparePartsDrawing |
Classe pubblica | PwsCache |
Classe pubblica | Registra |
Classe pubblica | Ricerca |
Classe pubblica | Rilascia |
Classe pubblica | Salva |
Classe pubblica | SalvaConf |
Classe pubblica | SalvaDist |
Classe pubblica | SalvaMultiplo |
Classe pubblica | SalvaRev |
Classe pubblica | SalvaSuperato |
Classe pubblica | Sblocca |
Classe pubblica | SostituisciComponente |
Classe pubblica | SostituisciComponenteRapido |
Classe pubblica | SostituisciMoved |
Classe pubblica | StatoDocumento |
Classe pubblica | SwDataStatisticsAnalyzer |
Classe pubblica | SwUserLogin |
Classe pubblica | TabellaRevisioni |
Classe pubblica | UpdateBranchInformations |
Classe pubblica | UpdateOldRev |
Classe pubblica | WhereUsedSw |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | PackAndGoContext |
Enumerazione pubblica | PackAndGoImportAttrStatus |
Enumerazione pubblica | PackAndGoImportDedCases |
Enumerazione pubblica | PackAndGoImportOperation |
Enumerazione pubblica | PackAndGoImportOperationStatus |


Classe AggiornaAttributiDaDB
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAggiornaAttributiDaDB

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AggiornaAttributiDaDB : SwCommandBase
Public Class AggiornaAttributiDaDB
    Inherits SwCommandBase
public ref class AggiornaAttributiDaDB : public SwCommandBase
type AggiornaAttributiDaDB =
    class
        inherit SwCommandBase
    end

Il tipo AggiornaAttributiDaDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di AggiornaAttributiDaDB

Il tipo AggiornaAttributiDaDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Proprietà AggiornaAttributiDaDB.NeedParameters

Proprietà AggiornaAttributiDaDBNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Metodi di AggiornaAttributiDaDB

Il tipo AggiornaAttributiDaDB espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Metodo AggiornaAttributiDaDB.ClearCommand

Metodo AggiornaAttributiDaDBClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Metodo AggiornaAttributiDaDB.ExecuteCommand

Metodo AggiornaAttributiDaDBExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Metodo AggiornaAttributiDaDB.SwEnabled

Metodo AggiornaAttributiDaDBSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Metodo AggiornaAttributiDaDB.SwSetContext

Metodo AggiornaAttributiDaDBSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetSw.Commands


Classe AggiornaDocumentoLocale
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAggiornaDocumentoLocale

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AggiornaDocumentoLocale : SwCommandBase
Public Class AggiornaDocumentoLocale
    Inherits SwCommandBase
public ref class AggiornaDocumentoLocale : public SwCommandBase
type AggiornaDocumentoLocale =
    class
        inherit SwCommandBase
    end

Il tipo AggiornaDocumentoLocale espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di AggiornaDocumentoLocale

Il tipo AggiornaDocumentoLocale espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Proprietà AggiornaDocumentoLocale.NeedParameters

Proprietà AggiornaDocumentoLocaleNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Metodi di AggiornaDocumentoLocale

Il tipo AggiornaDocumentoLocale espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Metodo AggiornaDocumentoLocale.ClearCommand

Metodo AggiornaDocumentoLocaleClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Metodo AggiornaDocumentoLocale.ExecuteCommand

Metodo AggiornaDocumentoLocaleExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Metodo AggiornaDocumentoLocale.SwEnabled

Metodo AggiornaDocumentoLocaleSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Metodo AggiornaDocumentoLocale.SwSetContext

Metodo AggiornaDocumentoLocaleSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetSw.Commands


Classe AnnullaCheckOut
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAnnullaCheckOut

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AnnullaCheckOut : SwCommandBase
Public Class AnnullaCheckOut
    Inherits SwCommandBase
public ref class AnnullaCheckOut : public SwCommandBase
type AnnullaCheckOut =
    class
        inherit SwCommandBase
    end

Il tipo AnnullaCheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di AnnullaCheckOut

Il tipo AnnullaCheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Proprietà AnnullaCheckOut.NeedParameters

Proprietà AnnullaCheckOutNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Metodi di AnnullaCheckOut

Il tipo AnnullaCheckOut espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Metodo AnnullaCheckOut.ClearCommand

Metodo AnnullaCheckOutClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Metodo AnnullaCheckOut.ExecuteCommand

Metodo AnnullaCheckOutExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Metodo AnnullaCheckOut.SwEnabled

Metodo AnnullaCheckOutSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Metodo AnnullaCheckOut.SwSetContext

Metodo AnnullaCheckOutSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetSw.Commands


Classe ApriconOpzioni
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsApriconOpzioni

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriconOpzioni : SwCommandBase
Public Class ApriconOpzioni
    Inherits SwCommandBase
public ref class ApriconOpzioni : public SwCommandBase
type ApriconOpzioni =
    class
        inherit SwCommandBase
    end

Il tipo ApriconOpzioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Sovrascrive DedCommand.NeedDocument)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ApriconOpzioni

Il tipo ApriconOpzioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | (Sovrascrive DedCommand.NeedDocument)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Proprietà ApriconOpzioni.DocumentInfos

Proprietà ApriconOpzioniDocumentInfos

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfoList DocumentInfos { get; }
Public ReadOnly Property DocumentInfos As DedCommandDocAnagrInfoList
    Get
public:
property DedCommandDocAnagrInfoList^ DocumentInfos {
    DedCommandDocAnagrInfoList^ get ();
}
member DocumentInfos : DedCommandDocAnagrInfoList with get

Valore della proprietà

DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Proprietà ApriconOpzioni.NeedDocument

Proprietà ApriconOpzioniNeedDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedDocument { get; }
Public Overrides ReadOnly Property NeedDocument As Boolean
    Get
public:
virtual property bool NeedDocument {
    bool get () override;
}
abstract NeedDocument : bool with get
override NeedDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Proprietà ApriconOpzioni.NeedParameters

Proprietà ApriconOpzioniNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodi di ApriconOpzioni

Il tipo ApriconOpzioni espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodo ApriconOpzioni.ClearCommand

Metodo ApriconOpzioniClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodo ApriconOpzioni.Enabled

Metodo ApriconOpzioniEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodo ApriconOpzioni.ExecuteCommand

Metodo ApriconOpzioniExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodo ApriconOpzioni.SetContext

Metodo ApriconOpzioniSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodo ApriconOpzioni.SwEnabled

Metodo ApriconOpzioniSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Metodo ApriconOpzioni.SwSetContext

Metodo ApriconOpzioniSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetSw.Commands


Classe ApriFileAssociati
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsApriFileAssociati

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriFileAssociati : SwCommandBase
Public Class ApriFileAssociati
    Inherits SwCommandBase
public ref class ApriFileAssociati : public SwCommandBase
type ApriFileAssociati =
    class
        inherit SwCommandBase
    end

Il tipo ApriFileAssociati espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowAttachFiles |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ApriFileAssociati

Il tipo ApriFileAssociati espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowAttachFiles |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Proprietà ApriFileAssociati.NeedParameters

Proprietà ApriFileAssociatiNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Proprietà ApriFileAssociati.ShowAttachFiles

Proprietà ApriFileAssociatiShowAttachFiles

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttachFiles { get; set; }
Public Property ShowAttachFiles As Boolean
    Get
    Set
public:
property bool ShowAttachFiles {
    bool get ();
    void set (bool value);
}
member ShowAttachFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Metodi di ApriFileAssociati

Il tipo ApriFileAssociati espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Metodo ApriFileAssociati.ClearCommand

Metodo ApriFileAssociatiClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Metodo ApriFileAssociati.ExecuteCommand

Metodo ApriFileAssociatiExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Metodo ApriFileAssociati.SwEnabled

Metodo ApriFileAssociatiSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Metodo ApriFileAssociati.SwSetContext

Metodo ApriFileAssociatiSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetSw.Commands


Classe ApriInLettura
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsApriInLettura

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriInLettura : SwCommandBase
Public Class ApriInLettura
    Inherits SwCommandBase
public ref class ApriInLettura : public SwCommandBase
type ApriInLettura =
    class
        inherit SwCommandBase
    end

Il tipo ApriInLettura espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ApriInLettura

Il tipo ApriInLettura espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetSw.Commands


Metodi di ApriInLettura

Il tipo ApriInLettura espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetSw.Commands


Metodo ApriInLettura.ExecuteCommand

Metodo ApriInLetturaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetSw.Commands


Metodo ApriInLettura.SwEnabled

Metodo ApriInLetturaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetSw.Commands


Metodo ApriInLettura.SwSetContext

Metodo ApriInLetturaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetSw.Commands


Classe ApriInModifica
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsApriInModifica

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriInModifica : SwCommandBase
Public Class ApriInModifica
    Inherits SwCommandBase
public ref class ApriInModifica : public SwCommandBase
type ApriInModifica =
    class
        inherit SwCommandBase
    end

Il tipo ApriInModifica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ApriInModifica

Il tipo ApriInModifica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetSw.Commands


Metodi di ApriInModifica

Il tipo ApriInModifica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetSw.Commands


Metodo ApriInModifica.ExecuteCommand

Metodo ApriInModificaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetSw.Commands


Metodo ApriInModifica.SwEnabled

Metodo ApriInModificaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetSw.Commands


Metodo ApriInModifica.SwSetContext

Metodo ApriInModificaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetSw.Commands


Classe ApriInNuovaFinestra
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsApriInNuovaFinestra

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriInNuovaFinestra : SwCommandBase
Public Class ApriInNuovaFinestra
    Inherits SwCommandBase
public ref class ApriInNuovaFinestra : public SwCommandBase
type ApriInNuovaFinestra =
    class
        inherit SwCommandBase
    end

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ApriInNuovaFinestra

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetSw.Commands


Metodi di ApriInNuovaFinestra

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetSw.Commands


Metodo ApriInNuovaFinestra.ClearCommand

Metodo ApriInNuovaFinestraClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetSw.Commands


Metodo ApriInNuovaFinestra.ExecuteCommand

Metodo ApriInNuovaFinestraExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetSw.Commands


Metodo ApriInNuovaFinestra.SwEnabled

Metodo ApriInNuovaFinestraSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetSw.Commands


Metodo ApriInNuovaFinestra.SwSetContext

Metodo ApriInNuovaFinestraSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetSw.Commands


Classe ArchiviaDoc
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsArchiviaDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ArchiviaDoc : SwCommandBase
Public Class ArchiviaDoc
    Inherits SwCommandBase
public ref class ArchiviaDoc : public SwCommandBase
type ArchiviaDoc =
    class
        inherit SwCommandBase
    end

Il tipo ArchiviaDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ArchiviaDoc

Il tipo ArchiviaDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Proprietà ArchiviaDoc.IsSavePrt

Proprietà ArchiviaDocIsSavePrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Proprietà ArchiviaDoc.NeedParameters

Proprietà ArchiviaDocNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Metodi di ArchiviaDoc

Il tipo ArchiviaDoc espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Metodo ArchiviaDoc.ClearCommand

Metodo ArchiviaDocClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Metodo ArchiviaDoc.ExecuteCommand

Metodo ArchiviaDocExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Metodo ArchiviaDoc.SwEnabled

Metodo ArchiviaDocSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Metodo ArchiviaDoc.SwSetContext

Metodo ArchiviaDocSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetSw.Commands


Classe AssociaTavola
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAssociaTavola

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociaTavola : SwCommandBase
Public Class AssociaTavola
    Inherits SwCommandBase
public ref class AssociaTavola : public SwCommandBase
type AssociaTavola =
    class
        inherit SwCommandBase
    end

Il tipo AssociaTavola espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | DrawingDoc |
Proprietà pubblica | EnforceOverWriteMode |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di AssociaTavola

Il tipo AssociaTavola espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | DrawingDoc |
Proprietà pubblica | EnforceOverWriteMode |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Proprietà AssociaTavola.DocInfo

Proprietà AssociaTavolaDocInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Proprietà AssociaTavola.DrawingDoc

Proprietà AssociaTavolaDrawingDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DrawingDoc { get; set; }
Public Property DrawingDoc As DedDoc
    Get
    Set
public:
property DedDoc^ DrawingDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member DrawingDoc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Proprietà AssociaTavola.EnforceOverWriteMode

Proprietà AssociaTavolaEnforceOverWriteMode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Proprietà AssociaTavola.NeedParameters

Proprietà AssociaTavolaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodi di AssociaTavola

Il tipo AssociaTavola espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodo AssociaTavola.ClearCommand

Metodo AssociaTavolaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodo AssociaTavola.Enabled

Metodo AssociaTavolaEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodo AssociaTavola.ExecuteCommand

Metodo AssociaTavolaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodo AssociaTavola.SetContext

Metodo AssociaTavolaSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodo AssociaTavola.SwEnabled

Metodo AssociaTavolaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Metodo AssociaTavola.SwSetContext

Metodo AssociaTavolaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetSw.Commands


Classe AssociatedECO
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAssociatedECO

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociatedECO : SwCommandBase
Public Class AssociatedECO
    Inherits SwCommandBase
public ref class AssociatedECO : public SwCommandBase
type AssociatedECO =
    class
        inherit SwCommandBase
    end

Il tipo AssociatedECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di AssociatedECO

Il tipo AssociatedECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Proprietà AssociatedECO.NeedParameters

Proprietà AssociatedECONeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Metodi di AssociatedECO

Il tipo AssociatedECO espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Metodo AssociatedECO.ClearCommand

Metodo AssociatedECOClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Metodo AssociatedECO.ExecuteCommand

Metodo AssociatedECOExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Metodo AssociatedECO.SwEnabled

Metodo AssociatedECOSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Metodo AssociatedECO.SwSetContext

Metodo AssociatedECOSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetSw.Commands


Classe AssociatedTranslations
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAssociatedTranslations

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociatedTranslations : SwCommandBase
Public Class AssociatedTranslations
    Inherits SwCommandBase
public ref class AssociatedTranslations : public SwCommandBase
type AssociatedTranslations =
    class
        inherit SwCommandBase
    end

Il tipo AssociatedTranslations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di AssociatedTranslations

Il tipo AssociatedTranslations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Proprietà AssociatedTranslations.NeedParameters

Proprietà AssociatedTranslationsNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Metodi di AssociatedTranslations

Il tipo AssociatedTranslations espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Metodo AssociatedTranslations.ClearCommand

Metodo AssociatedTranslationsClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Metodo AssociatedTranslations.ExecuteCommand

Metodo AssociatedTranslationsExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Metodo AssociatedTranslations.SwEnabled

Metodo AssociatedTranslationsSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Metodo AssociatedTranslations.SwSetContext

Metodo AssociatedTranslationsSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetSw.Commands


Classe Attributi
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsAttributi

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Attributi : SwCommandBase
Public Class Attributi
    Inherits SwCommandBase
public ref class Attributi : public SwCommandBase
type Attributi =
    class
        inherit SwCommandBase
    end

Il tipo Attributi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Attributi

Il tipo Attributi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetSw.Commands


Metodi di Attributi

Il tipo Attributi espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetSw.Commands


Metodo Attributi.ExecuteCommand

Metodo AttributiExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetSw.Commands


Metodo Attributi.SwEnabled

Metodo AttributiSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetSw.Commands


Metodo Attributi.SwSetContext

Metodo AttributiSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetSw.Commands


Classe CambiaPassword
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCambiaPassword

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CambiaPassword : SwCommandBase
Public Class CambiaPassword
    Inherits SwCommandBase
public ref class CambiaPassword : public SwCommandBase
type CambiaPassword =
    class
        inherit SwCommandBase
    end

Il tipo CambiaPassword espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CambiaPassword

Il tipo CambiaPassword espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Proprietà CambiaPassword.NeedParameters

Proprietà CambiaPasswordNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Metodi di CambiaPassword

Il tipo CambiaPassword espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Metodo CambiaPassword.ClearCommand

Metodo CambiaPasswordClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Metodo CambiaPassword.ExecuteCommand

Metodo CambiaPasswordExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Metodo CambiaPassword.SwEnabled

Metodo CambiaPasswordSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Metodo CambiaPassword.SwSetContext

Metodo CambiaPasswordSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetSw.Commands


Classe CambiaStato
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCambiaStato
DedNetSw.CommandsLavorazione
DedNetSw.CommandsModificaSuperato
DedNetSw.CommandsRilascia
DedNetSw.CommandsSalvaSuperato

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CambiaStato : SwCommandBase
Public Class CambiaStato
    Inherits SwCommandBase
public ref class CambiaStato : public SwCommandBase
type CambiaStato =
    class
        inherit SwCommandBase
    end

Il tipo CambiaStato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo |
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CambiaStato

Il tipo CambiaStato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo |
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Proprietà CambiaStato.LazyMode

Proprietà CambiaStatoLazyMode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Proprietà CambiaStato.Multiplo

Proprietà CambiaStatoMultiplo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Multiplo { get; set; }
Public Property Multiplo As Boolean
    Get
    Set
public:
property bool Multiplo {
    bool get ();
    void set (bool value);
}
member Multiplo : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Metodi di CambiaStato

Il tipo CambiaStato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Metodo CambiaStato.ClearCommand

Metodo CambiaStatoClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Metodo CambiaStato.ExecuteCommand

Metodo CambiaStatoExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Metodo CambiaStato.SwEnabled

Metodo CambiaStatoSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Metodo CambiaStato.SwSetContext

Metodo CambiaStatoSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetSw.Commands


Classe CambiaStato.PublishingDocumentDescriptor

Classe CambiaStatoPublishingDocumentDescriptor
Gerarchia di ereditarietà
SystemObject
DedNetSw.CommandsCambiaStatoPublishingDocumentDescriptor

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PublishingDocumentDescriptor
Public Class PublishingDocumentDescriptor
public ref class PublishingDocumentDescriptor
type PublishingDocumentDescriptor = class end

Il tipo CambiaStatoPublishingDocumentDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CambiaStatoPublishingDocumentDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName |
Proprietà pubblica | PublishDocNotOverwritten |
Proprietà pubblica | SourceDocument |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore CambiaStato.PublishingDocumentDescriptor

Costruttore CambiaStatoPublishingDocumentDescriptor

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PublishingDocumentDescriptor(
    DedDoc src,
    string outfn,
    bool publishDocNotOverwritten = false
)
Public Sub New (
    src As DedDoc,
    outfn As String,
    Optional publishDocNotOverwritten As Boolean = false
)
public:
PublishingDocumentDescriptor(
    DedDoc^ src,
    String^ outfn,
    bool publishDocNotOverwritten = false
)
new :
        src : DedDoc *
        outfn : string *
        ?publishDocNotOverwritten : bool
(* Defaults:
        let _publishDocNotOverwritten = defaultArg publishDocNotOverwritten false
*)
-> PublishingDocumentDescriptor

Parametri

src DedDoc
outfn String
publishDocNotOverwritten Boolean (Optional)
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetSw.Commands


Proprietà di PublishingDocumentDescriptor

Il tipo CambiaStatoPublishingDocumentDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName |
Proprietà pubblica | PublishDocNotOverwritten |
Proprietà pubblica | SourceDocument |
Torna su
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetSw.Commands


Proprietà CambiaStato.PublishingDocumentDescriptor.FullFileName

Proprietà CambiaStatoPublishingDocumentDescriptorFullFileName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetSw.Commands


Proprietà CambiaStato.PublishingDocumentDescriptor.PublishDocNotOverwritten

Proprietà CambiaStatoPublishingDocumentDescriptorPublishDocNotOverwritten

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PublishDocNotOverwritten { get; set; }
Public Property PublishDocNotOverwritten As Boolean
    Get
    Set
public:
property bool PublishDocNotOverwritten {
    bool get ();
    void set (bool value);
}
member PublishDocNotOverwritten : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetSw.Commands


Proprietà CambiaStato.PublishingDocumentDescriptor.SourceDocument

Proprietà CambiaStatoPublishingDocumentDescriptorSourceDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc SourceDocument { get; set; }
Public Property SourceDocument As DedDoc
    Get
    Set
public:
property DedDoc^ SourceDocument {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member SourceDocument : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetSw.Commands


Classe CaricaParte
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCaricaParte

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CaricaParte : SwCommandBase
Public Class CaricaParte
    Inherits SwCommandBase
public ref class CaricaParte : public SwCommandBase
type CaricaParte =
    class
        inherit SwCommandBase
    end

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Asynch |
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | DocInfos |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Asynch |
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | DocInfos |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Proprietà CaricaParte.Asynch

Proprietà CaricaParteAsynch

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Proprietà CaricaParte.DocInfo

Proprietà CaricaParteDocInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Proprietà CaricaParte.DocInfos

Proprietà CaricaParteDocInfos

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommandDocAnagrInfo> DocInfos { get; set; }
Public Property DocInfos As List(Of DedCommandDocAnagrInfo)
    Get
    Set
public:
property List<DedCommandDocAnagrInfo^>^ DocInfos {
    List<DedCommandDocAnagrInfo^>^ get ();
    void set (List<DedCommandDocAnagrInfo^>^ value);
}
member DocInfos : List<DedCommandDocAnagrInfo> with get, set

Valore della proprietà

List DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Proprietà CaricaParte.NeedParameters

Proprietà CaricaParteNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodi di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodo CaricaParte.ClearCommand

Metodo CaricaParteClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodo CaricaParte.Enabled

Metodo CaricaParteEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodo CaricaParte.ExecuteCommand

Metodo CaricaParteExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodo CaricaParte.SetContext

Metodo CaricaParteSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodo CaricaParte.SwEnabled

Metodo CaricaParteSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Metodo CaricaParte.SwSetContext

Metodo CaricaParteSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetSw.Commands


Classe ChangeStateMultiConfInfo
Gerarchia di ereditarietà
SystemObject
DedNetSw.CommandsChangeStateMultiConfInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ChangeStateMultiConfInfo
Public Class ChangeStateMultiConfInfo
public ref class ChangeStateMultiConfInfo
type ChangeStateMultiConfInfo = class end

Il tipo ChangeStateMultiConfInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ChangeStateMultiConfInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | InvolvedDatas |
Proprietà pubblica | MsName |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore ChangeStateMultiConfInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ChangeStateMultiConfInfo()
Public Sub New
public:
ChangeStateMultiConfInfo()
new : unit -> ChangeStateMultiConfInfo
Vedi anche

Documentazione

Classe ChangeStateMultiConfInfo
Namespace DedNetSw.Commands


Proprietà di ChangeStateMultiConfInfo

Il tipo ChangeStateMultiConfInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InvolvedDatas |
Proprietà pubblica | MsName |
Torna su
Vedi anche

Documentazione

Classe ChangeStateMultiConfInfo
Namespace DedNetSw.Commands


Proprietà ChangeStateMultiConfInfo.InvolvedDatas

Proprietà ChangeStateMultiConfInfoInvolvedDatas

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedData> InvolvedDatas { get; }
Public ReadOnly Property InvolvedDatas As List(Of DedData)
    Get
public:
property List<DedData^>^ InvolvedDatas {
    List<DedData^>^ get ();
}
member InvolvedDatas : List<DedData> with get

Valore della proprietà

List DedData
Vedi anche

Documentazione

Classe ChangeStateMultiConfInfo
Namespace DedNetSw.Commands


Proprietà ChangeStateMultiConfInfo.MsName

Proprietà ChangeStateMultiConfInfoMsName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string MsName { get; }
Public ReadOnly Property MsName As String
    Get
public:
property String^ MsName {
    String^ get ();
}
member MsName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangeStateMultiConfInfo
Namespace DedNetSw.Commands


Classe CheckIn
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCheckIn

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckIn : SwCommandBase
Public Class CheckIn
    Inherits SwCommandBase
public ref class CheckIn : public SwCommandBase
type CheckIn =
    class
        inherit SwCommandBase
    end

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AssociatedFiles |
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CheckIn

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AssociatedFiles |
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Proprietà CheckIn.AssociatedFiles

Proprietà CheckInAssociatedFiles

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AssociatedFiles { get; set; }
Public Property AssociatedFiles As Boolean
    Get
    Set
public:
property bool AssociatedFiles {
    bool get ();
    void set (bool value);
}
member AssociatedFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Proprietà CheckIn.NeedParameters

Proprietà CheckInNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Metodi di CheckIn

Il tipo CheckIn espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Metodo CheckIn.ClearCommand

Metodo CheckInClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Metodo CheckIn.ExecuteCommand

Metodo CheckInExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Metodo CheckIn.SwEnabled

Metodo CheckInSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Metodo CheckIn.SwSetContext

Metodo CheckInSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetSw.Commands


Classe CheckOut
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCheckOut

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckOut : SwCommandBase
Public Class CheckOut
    Inherits SwCommandBase
public ref class CheckOut : public SwCommandBase
type CheckOut =
    class
        inherit SwCommandBase
    end

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreDataLockState |
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OnlyDirty |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CheckOut

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreDataLockState |
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OnlyDirty |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Proprietà CheckOut.IgnoreDataLockState

Proprietà CheckOutIgnoreDataLockState

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataLockState { get; set; }
Public Property IgnoreDataLockState As Boolean
    Get
    Set
public:
property bool IgnoreDataLockState {
    bool get ();
    void set (bool value);
}
member IgnoreDataLockState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Proprietà CheckOut.NeedParameters

Proprietà CheckOutNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Proprietà CheckOut.OnlyDirty

Proprietà CheckOutOnlyDirty

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyDirty { get; set; }
Public Property OnlyDirty As Boolean
    Get
    Set
public:
property bool OnlyDirty {
    bool get ();
    void set (bool value);
}
member OnlyDirty : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Metodi di CheckOut

Il tipo CheckOut espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Metodo CheckOut.ClearCommand

Metodo CheckOutClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Metodo CheckOut.ExecuteCommand

Metodo CheckOutExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Metodo CheckOut.SwEnabled

Metodo CheckOutSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Metodo CheckOut.SwSetContext

Metodo CheckOutSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetSw.Commands


Classe ConfiguraDistinta
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsConfiguraDistinta

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ConfiguraDistinta : SwCommandBase
Public Class ConfiguraDistinta
    Inherits SwCommandBase
public ref class ConfiguraDistinta : public SwCommandBase
type ConfiguraDistinta =
    class
        inherit SwCommandBase
    end

Il tipo ConfiguraDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunDistConf |
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ConfiguraDistinta

Il tipo ConfiguraDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Proprietà ConfiguraDistinta.NeedParameters

Proprietà ConfiguraDistintaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Metodi di ConfiguraDistinta

Il tipo ConfiguraDistinta espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunDistConf |
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Metodo ConfiguraDistinta.ClearCommand

Metodo ConfiguraDistintaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Metodo ConfiguraDistinta.ExecuteCommand

Metodo ConfiguraDistintaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Metodo ConfiguraDistinta.RunDistConf

Metodo ConfiguraDistintaRunDistConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RunDistConf()
Public Sub RunDistConf
public:
void RunDistConf()
member RunDistConf : unit -> unit
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Metodo ConfiguraDistinta.SwEnabled

Metodo ConfiguraDistintaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Metodo ConfiguraDistinta.SwSetContext

Metodo ConfiguraDistintaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetSw.Commands


Classe ControlloCoerenzaRiferimenti
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsControlloCoerenzaRiferimenti

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ControlloCoerenzaRiferimenti : SwCommandBase
Public Class ControlloCoerenzaRiferimenti
    Inherits SwCommandBase
public ref class ControlloCoerenzaRiferimenti : public SwCommandBase
type ControlloCoerenzaRiferimenti =
    class
        inherit SwCommandBase
    end

Il tipo ControlloCoerenzaRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ControlloCoerenzaRiferimenti

Il tipo ControlloCoerenzaRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Proprietà ControlloCoerenzaRiferimenti.DocInfo

Proprietà ControlloCoerenzaRiferimentiDocInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Proprietà ControlloCoerenzaRiferimenti.NeedParameters

Proprietà ControlloCoerenzaRiferimentiNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodi di ControlloCoerenzaRiferimenti

Il tipo ControlloCoerenzaRiferimenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodo ControlloCoerenzaRiferimenti.ClearCommand

Metodo ControlloCoerenzaRiferimentiClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodo ControlloCoerenzaRiferimenti.Enabled

Metodo ControlloCoerenzaRiferimentiEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodo ControlloCoerenzaRiferimenti.ExecuteCommand

Metodo ControlloCoerenzaRiferimentiExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodo ControlloCoerenzaRiferimenti.SetContext

Metodo ControlloCoerenzaRiferimentiSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodo ControlloCoerenzaRiferimenti.SwEnabled

Metodo ControlloCoerenzaRiferimentiSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Metodo ControlloCoerenzaRiferimenti.SwSetContext

Metodo ControlloCoerenzaRiferimentiSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetSw.Commands


Classe CreaComponenteAnagrafica
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCreaComponenteAnagrafica

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaComponenteAnagrafica : SwCommandBase
Public Class CreaComponenteAnagrafica
    Inherits SwCommandBase
public ref class CreaComponenteAnagrafica : public SwCommandBase
type CreaComponenteAnagrafica =
    class
        inherit SwCommandBase
    end

Il tipo CreaComponenteAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CreaComponenteAnagrafica

Il tipo CreaComponenteAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Proprietà CreaComponenteAnagrafica.NeedParameters

Proprietà CreaComponenteAnagraficaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Metodi di CreaComponenteAnagrafica

Il tipo CreaComponenteAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Metodo CreaComponenteAnagrafica.ClearCommand

Metodo CreaComponenteAnagraficaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Metodo CreaComponenteAnagrafica.ExecuteCommand

Metodo CreaComponenteAnagraficaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Metodo CreaComponenteAnagrafica.SwEnabled

Metodo CreaComponenteAnagraficaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Metodo CreaComponenteAnagrafica.SwSetContext

Metodo CreaComponenteAnagraficaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetSw.Commands


Classe CreaNuovaRappresentazione
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCreaNuovaRappresentazione

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaNuovaRappresentazione : SwCommandBase
Public Class CreaNuovaRappresentazione
    Inherits SwCommandBase
public ref class CreaNuovaRappresentazione : public SwCommandBase
type CreaNuovaRappresentazione =
    class
        inherit SwCommandBase
    end

Il tipo CreaNuovaRappresentazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DsInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InterestDoc |
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsCreateRapOfPrt |
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewRapDocStructInfoList |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefData |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SkipCheckInNewRap |
Proprietà pubblica | SkipDocumentContextCheck |
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CreaNuovaRappresentazione

Il tipo CreaNuovaRappresentazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DsInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InterestDoc |
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsCreateRapOfPrt |
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewRapDocStructInfoList |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefData |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SkipCheckInNewRap |
Proprietà pubblica | SkipDocumentContextCheck |
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.DsInfo

Proprietà CreaNuovaRappresentazioneDsInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo DsInfo { get; set; }
Public Property DsInfo As SwDocStructInfo
    Get
    Set
public:
property SwDocStructInfo^ DsInfo {
    SwDocStructInfo^ get ();
    void set (SwDocStructInfo^ value);
}
member DsInfo : SwDocStructInfo with get, set

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.InterestDoc

Proprietà CreaNuovaRappresentazioneInterestDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 InterestDoc { get; set; }
Public Property InterestDoc As IModelDoc2
    Get
    Set
public:
property IModelDoc2^ InterestDoc {
    IModelDoc2^ get ();
    void set (IModelDoc2^ value);
}
member InterestDoc : IModelDoc2 with get, set

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.IsCreateRapOfPrt

Proprietà CreaNuovaRappresentazioneIsCreateRapOfPrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCreateRapOfPrt { get; set; }
Public Property IsCreateRapOfPrt As Boolean
    Get
    Set
public:
property bool IsCreateRapOfPrt {
    bool get ();
    void set (bool value);
}
member IsCreateRapOfPrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.NewRapDocStructInfoList

Proprietà CreaNuovaRappresentazioneNewRapDocStructInfoList

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList NewRapDocStructInfoList { get; }
Public ReadOnly Property NewRapDocStructInfoList As DocStructInfoList
    Get
public:
property DocStructInfoList^ NewRapDocStructInfoList {
    DocStructInfoList^ get ();
}
member NewRapDocStructInfoList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.RefData

Proprietà CreaNuovaRappresentazioneRefData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData RefData { get; set; }
Public Property RefData As DedData
    Get
    Set
public:
property DedData^ RefData {
    DedData^ get ();
    void set (DedData^ value);
}
member RefData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.SkipCheckInNewRap

Proprietà CreaNuovaRappresentazioneSkipCheckInNewRap

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipCheckInNewRap { get; set; }
Public Property SkipCheckInNewRap As Boolean
    Get
    Set
public:
property bool SkipCheckInNewRap {
    bool get ();
    void set (bool value);
}
member SkipCheckInNewRap : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Proprietà CreaNuovaRappresentazione.SkipDocumentContextCheck

Proprietà CreaNuovaRappresentazioneSkipDocumentContextCheck

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipDocumentContextCheck { get; set; }
Public Property SkipDocumentContextCheck As Boolean
    Get
    Set
public:
property bool SkipDocumentContextCheck {
    bool get ();
    void set (bool value);
}
member SkipDocumentContextCheck : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Metodi di CreaNuovaRappresentazione

Il tipo CreaNuovaRappresentazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Metodo CreaNuovaRappresentazione.ClearCommand

Metodo CreaNuovaRappresentazioneClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Metodo CreaNuovaRappresentazione.ExecuteCommand

Metodo CreaNuovaRappresentazioneExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Metodo CreaNuovaRappresentazione.SwEnabled

Metodo CreaNuovaRappresentazioneSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Metodo CreaNuovaRappresentazione.SwSetContext

Metodo CreaNuovaRappresentazioneSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetSw.Commands


Classe CreaSwAssociaConf
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCreaSwAssociaConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaSwAssociaConf : SwCommandBase
Public Class CreaSwAssociaConf
    Inherits SwCommandBase
public ref class CreaSwAssociaConf : public SwCommandBase
type CreaSwAssociaConf =
    class
        inherit SwCommandBase
    end

Il tipo CreaSwAssociaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues |
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CreaSwAssociaConf

Il tipo CreaSwAssociaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues |
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.Data

Proprietà CreaSwAssociaConfData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.IsSavePrt

Proprietà CreaSwAssociaConfIsSavePrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.NeedParameters

Proprietà CreaSwAssociaConfNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.PrimaryContext

Proprietà CreaSwAssociaConfPrimaryContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.SwComp

Proprietà CreaSwAssociaConfSwComp

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IComponent2 SwComp { get; }
Public ReadOnly Property SwComp As IComponent2
    Get
public:
property IComponent2^ SwComp {
    IComponent2^ get ();
}
member SwComp : IComponent2 with get

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.SwConf

Proprietà CreaSwAssociaConfSwConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SwConf { get; }
Public ReadOnly Property SwConf As String
    Get
public:
property String^ SwConf {
    String^ get ();
}
member SwConf : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.SwDoc

Proprietà CreaSwAssociaConfSwDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; }
Public ReadOnly Property SwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
}
member SwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.TopDocument

Proprietà CreaSwAssociaConfTopDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 TopDocument { get; }
Public ReadOnly Property TopDocument As IModelDoc2
    Get
public:
property IModelDoc2^ TopDocument {
    IModelDoc2^ get ();
}
member TopDocument : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaConf.UseDocValues

Proprietà CreaSwAssociaConfUseDocValues

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Metodi di CreaSwAssociaConf

Il tipo CreaSwAssociaConf espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Metodo CreaSwAssociaConf.ClearCommand

Metodo CreaSwAssociaConfClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Metodo CreaSwAssociaConf.ExecuteCommand

Metodo CreaSwAssociaConfExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Metodo CreaSwAssociaConf.SwEnabled

Metodo CreaSwAssociaConfSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Metodo CreaSwAssociaConf.SwSetContext

Metodo CreaSwAssociaConfSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaConf
Namespace DedNetSw.Commands


Classe CreaSwAssociaDocument
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCreaSwAssociaDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaSwAssociaDocument : SwCommandBase
Public Class CreaSwAssociaDocument
    Inherits SwCommandBase
public ref class CreaSwAssociaDocument : public SwCommandBase
type CreaSwAssociaDocument =
    class
        inherit SwCommandBase
    end

Il tipo CreaSwAssociaDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | AlsoSubParts |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | EnforceOverWriteMode |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InfoItem |
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy |
Proprietà pubblica | Mdres |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext |
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues |
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CreaSwAssociaDocument

Il tipo CreaSwAssociaDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | AlsoSubParts |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | EnforceOverWriteMode |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InfoItem |
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LinkNotCopy |
Proprietà pubblica | Mdres |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext |
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues |
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.AlsoSubParts

Proprietà CreaSwAssociaDocumentAlsoSubParts

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.Data

Proprietà CreaSwAssociaDocumentData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.EnforceOverWriteMode

Proprietà CreaSwAssociaDocumentEnforceOverWriteMode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.InfoItem

Proprietà CreaSwAssociaDocumentInfoItem

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
property DocStructInfo^ InfoItem {
    DocStructInfo^ get ();
}
member InfoItem : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.IsSavePrt

Proprietà CreaSwAssociaDocumentIsSavePrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.LinkNotCopy

Proprietà CreaSwAssociaDocumentLinkNotCopy

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.Mdres

Proprietà CreaSwAssociaDocumentMdres

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.NeedParameters

Proprietà CreaSwAssociaDocumentNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.PrimaryContext

Proprietà CreaSwAssociaDocumentPrimaryContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.SparePartsContext

Proprietà CreaSwAssociaDocumentSparePartsContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.SwComp

Proprietà CreaSwAssociaDocumentSwComp

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IComponent2 SwComp { get; }
Public ReadOnly Property SwComp As IComponent2
    Get
public:
property IComponent2^ SwComp {
    IComponent2^ get ();
}
member SwComp : IComponent2 with get

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.SwConf

Proprietà CreaSwAssociaDocumentSwConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SwConf { get; }
Public ReadOnly Property SwConf As String
    Get
public:
property String^ SwConf {
    String^ get ();
}
member SwConf : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.SwDoc

Proprietà CreaSwAssociaDocumentSwDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; }
Public ReadOnly Property SwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
}
member SwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.TopDocument

Proprietà CreaSwAssociaDocumentTopDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 TopDocument { get; }
Public ReadOnly Property TopDocument As IModelDoc2
    Get
public:
property IModelDoc2^ TopDocument {
    IModelDoc2^ get ();
}
member TopDocument : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Proprietà CreaSwAssociaDocument.UseDocValues

Proprietà CreaSwAssociaDocumentUseDocValues

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Metodi di CreaSwAssociaDocument

Il tipo CreaSwAssociaDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Metodo CreaSwAssociaDocument.ClearCommand

Metodo CreaSwAssociaDocumentClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Metodo CreaSwAssociaDocument.ExecuteCommand

Metodo CreaSwAssociaDocumentExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Metodo CreaSwAssociaDocument.SwEnabled

Metodo CreaSwAssociaDocumentSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Metodo CreaSwAssociaDocument.SwSetContext

Metodo CreaSwAssociaDocumentSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaSwAssociaDocument
Namespace DedNetSw.Commands


Classe CreaSwDisconnectConf
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCreaSwDisconnectConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaSwDisconnectConf : SwCommandBase
Public Class CreaSwDisconnectConf
    Inherits SwCommandBase
public ref class CreaSwDisconnectConf : public SwCommandBase
type CreaSwDisconnectConf =
    class
        inherit SwCommandBase
    end

Il tipo CreaSwDisconnectConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CreaSwDisconnectConf

Il tipo CreaSwDisconnectConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Proprietà CreaSwDisconnectConf.Data

Proprietà CreaSwDisconnectConfData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Proprietà CreaSwDisconnectConf.NeedParameters

Proprietà CreaSwDisconnectConfNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Proprietà CreaSwDisconnectConf.SwDoc

Proprietà CreaSwDisconnectConfSwDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; }
Public ReadOnly Property SwDoc As IModelDoc2
    Get
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
}
member SwDoc : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Proprietà CreaSwDisconnectConf.TopDocument

Proprietà CreaSwDisconnectConfTopDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 TopDocument { get; }
Public ReadOnly Property TopDocument As IModelDoc2
    Get
public:
property IModelDoc2^ TopDocument {
    IModelDoc2^ get ();
}
member TopDocument : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Metodi di CreaSwDisconnectConf

Il tipo CreaSwDisconnectConf espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Metodo CreaSwDisconnectConf.ClearCommand

Metodo CreaSwDisconnectConfClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Metodo CreaSwDisconnectConf.ExecuteCommand

Metodo CreaSwDisconnectConfExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Metodo CreaSwDisconnectConf.SwEnabled

Metodo CreaSwDisconnectConfSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Metodo CreaSwDisconnectConf.SwSetContext

Metodo CreaSwDisconnectConfSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreaSwDisconnectConf
Namespace DedNetSw.Commands


Classe CreateSparePartsDrawing
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCreateSparePartsDrawing

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreateSparePartsDrawing : SwCommandBase
Public Class CreateSparePartsDrawing
    Inherits SwCommandBase
public ref class CreateSparePartsDrawing : public SwCommandBase
type CreateSparePartsDrawing =
    class
        inherit SwCommandBase
    end

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Document |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Document |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Proprietà CreateSparePartsDrawing.Document

Proprietà CreateSparePartsDrawingDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Proprietà CreateSparePartsDrawing.NeedParameters

Proprietà CreateSparePartsDrawingNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Metodi di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Metodo CreateSparePartsDrawing.ClearCommand

Metodo CreateSparePartsDrawingClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Metodo CreateSparePartsDrawing.ExecuteCommand

Metodo CreateSparePartsDrawingExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Metodo CreateSparePartsDrawing.SwEnabled

Metodo CreateSparePartsDrawingSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext invCmdCtx
)
Public Overrides Function SwEnabled (
    invCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ invCmdCtx
) override
abstract SwEnabled :
        invCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        invCmdCtx : DedSwCommandContext -> bool

Parametri

invCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Metodo CreateSparePartsDrawing.SwSetContext

Metodo CreateSparePartsDrawingSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetSw.Commands


Classe Dipendenze
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDipendenze

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Dipendenze : SwCommandBase
Public Class Dipendenze
    Inherits SwCommandBase
public ref class Dipendenze : public SwCommandBase
type Dipendenze =
    class
        inherit SwCommandBase
    end

Il tipo Dipendenze espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Dipendenze

Il tipo Dipendenze espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Dipendenze
Namespace DedNetSw.Commands


Metodi di Dipendenze

Il tipo Dipendenze espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Dipendenze
Namespace DedNetSw.Commands


Metodo Dipendenze.ExecuteCommand

Metodo DipendenzeExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Dipendenze
Namespace DedNetSw.Commands


Metodo Dipendenze.SwEnabled

Metodo DipendenzeSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Dipendenze
Namespace DedNetSw.Commands


Metodo Dipendenze.SwSetContext

Metodo DipendenzeSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Dipendenze
Namespace DedNetSw.Commands


Classe DistintaComponenti
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDistintaComponenti

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DistintaComponenti : SwCommandBase
Public Class DistintaComponenti
    Inherits SwCommandBase
public ref class DistintaComponenti : public SwCommandBase
type DistintaComponenti =
    class
        inherit SwCommandBase
    end

Il tipo DistintaComponenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di DistintaComponenti

Il tipo DistintaComponenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Proprietà DistintaComponenti.NeedParameters

Proprietà DistintaComponentiNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Metodi di DistintaComponenti

Il tipo DistintaComponenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Metodo DistintaComponenti.ClearCommand

Metodo DistintaComponentiClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Metodo DistintaComponenti.ExecuteCommand

Metodo DistintaComponentiExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Metodo DistintaComponenti.SwEnabled

Metodo DistintaComponentiSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Metodo DistintaComponenti.SwSetContext

Metodo DistintaComponentiSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetSw.Commands


Classe DistintaEsplosa
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDistintaEsplosa

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DistintaEsplosa : SwCommandBase
Public Class DistintaEsplosa
    Inherits SwCommandBase
public ref class DistintaEsplosa : public SwCommandBase
type DistintaEsplosa =
    class
        inherit SwCommandBase
    end

Il tipo DistintaEsplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di DistintaEsplosa

Il tipo DistintaEsplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Proprietà DistintaEsplosa.NeedParameters

Proprietà DistintaEsplosaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Metodi di DistintaEsplosa

Il tipo DistintaEsplosa espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Metodo DistintaEsplosa.ClearCommand

Metodo DistintaEsplosaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Metodo DistintaEsplosa.ExecuteCommand

Metodo DistintaEsplosaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Metodo DistintaEsplosa.SwEnabled

Metodo DistintaEsplosaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Metodo DistintaEsplosa.SwSetContext

Metodo DistintaEsplosaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetSw.Commands


Classe DistintaImplosa
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDistintaImplosa

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DistintaImplosa : SwCommandBase
Public Class DistintaImplosa
    Inherits SwCommandBase
public ref class DistintaImplosa : public SwCommandBase
type DistintaImplosa =
    class
        inherit SwCommandBase
    end

Il tipo DistintaImplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di DistintaImplosa

Il tipo DistintaImplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Proprietà DistintaImplosa.NeedParameters

Proprietà DistintaImplosaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Metodi di DistintaImplosa

Il tipo DistintaImplosa espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Metodo DistintaImplosa.ClearCommand

Metodo DistintaImplosaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Metodo DistintaImplosa.ExecuteCommand

Metodo DistintaImplosaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Metodo DistintaImplosa.SwEnabled

Metodo DistintaImplosaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Metodo DistintaImplosa.SwSetContext

Metodo DistintaImplosaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetSw.Commands


Classe DocAssocSw
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDocAssocSw

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocAssocSw : SwCommandBase
Public Class DocAssocSw
    Inherits SwCommandBase
public ref class DocAssocSw : public SwCommandBase
type DocAssocSw =
    class
        inherit SwCommandBase
    end

Il tipo DocAssocSw espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di DocAssocSw

Il tipo DocAssocSw espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Proprietà DocAssocSw.NeedParameters

Proprietà DocAssocSwNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Metodi di DocAssocSw

Il tipo DocAssocSw espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Metodo DocAssocSw.ClearCommand

Metodo DocAssocSwClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Metodo DocAssocSw.ExecuteCommand

Metodo DocAssocSwExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Metodo DocAssocSw.SwEnabled

Metodo DocAssocSwSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Metodo DocAssocSw.SwSetContext

Metodo DocAssocSwSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocAssocSw
Namespace DedNetSw.Commands


Classe DocRecognizer
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDocRecognizer

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocRecognizer : SwCommandBase
Public Class DocRecognizer
    Inherits SwCommandBase
public ref class DocRecognizer : public SwCommandBase
type DocRecognizer =
    class
        inherit SwCommandBase
    end

Il tipo DocRecognizer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di DocRecognizer

Il tipo DocRecognizer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Proprietà DocRecognizer.NeedParameters

Proprietà DocRecognizerNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Metodi di DocRecognizer

Il tipo DocRecognizer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Metodo DocRecognizer.ClearCommand

Metodo DocRecognizerClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Metodo DocRecognizer.ExecuteCommand

Metodo DocRecognizerExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Metodo DocRecognizer.SwEnabled

Metodo DocRecognizerSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Metodo DocRecognizer.SwSetContext

Metodo DocRecognizerSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetSw.Commands


Classe DocumentAssistant
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsDocumentAssistant

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentAssistant : SwCommandBase
Public Class DocumentAssistant
    Inherits SwCommandBase
public ref class DocumentAssistant : public SwCommandBase
type DocumentAssistant =
    class
        inherit SwCommandBase
    end

Il tipo DocumentAssistant espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di DocumentAssistant

Il tipo DocumentAssistant espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetSw.Commands


Metodi di DocumentAssistant

Il tipo DocumentAssistant espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetSw.Commands


Metodo DocumentAssistant.ExecuteCommand

Metodo DocumentAssistantExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetSw.Commands


Metodo DocumentAssistant.SwEnabled

Metodo DocumentAssistantSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetSw.Commands


Metodo DocumentAssistant.SwSetContext

Metodo DocumentAssistantSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetSw.Commands


Classe EditaAttributiSoloDB
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEditaAttributiSoloDB

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaAttributiSoloDB : SwCommandBase
Public Class EditaAttributiSoloDB
    Inherits SwCommandBase
public ref class EditaAttributiSoloDB : public SwCommandBase
type EditaAttributiSoloDB =
    class
        inherit SwCommandBase
    end

Il tipo EditaAttributiSoloDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EditaAttributiSoloDB

Il tipo EditaAttributiSoloDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Proprietà EditaAttributiSoloDB.NeedParameters

Proprietà EditaAttributiSoloDBNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Metodi di EditaAttributiSoloDB

Il tipo EditaAttributiSoloDB espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Metodo EditaAttributiSoloDB.ClearCommand

Metodo EditaAttributiSoloDBClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Metodo EditaAttributiSoloDB.ExecuteCommand

Metodo EditaAttributiSoloDBExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Metodo EditaAttributiSoloDB.SwEnabled

Metodo EditaAttributiSoloDBSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Metodo EditaAttributiSoloDB.SwSetContext

Metodo EditaAttributiSoloDBSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext invCmdCtx
)
Public Overrides Function SwSetContext (
    invCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ invCmdCtx
) override
abstract SwSetContext :
        invCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        invCmdCtx : DedSwCommandContext -> bool

Parametri

invCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetSw.Commands


Classe EditaCommesse
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEditaCommesse

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaCommesse : SwCommandBase
Public Class EditaCommesse
    Inherits SwCommandBase
public ref class EditaCommesse : public SwCommandBase
type EditaCommesse =
    class
        inherit SwCommandBase
    end

Il tipo EditaCommesse espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EditaCommesse

Il tipo EditaCommesse espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Proprietà EditaCommesse.NeedParameters

Proprietà EditaCommesseNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Metodi di EditaCommesse

Il tipo EditaCommesse espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Metodo EditaCommesse.ClearCommand

Metodo EditaCommesseClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Metodo EditaCommesse.ExecuteCommand

Metodo EditaCommesseExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Metodo EditaCommesse.SwEnabled

Metodo EditaCommesseSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Metodo EditaCommesse.SwSetContext

Metodo EditaCommesseSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetSw.Commands


Classe EditaDistinta
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEditaDistinta

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaDistinta : SwCommandBase
Public Class EditaDistinta
    Inherits SwCommandBase
public ref class EditaDistinta : public SwCommandBase
type EditaDistinta =
    class
        inherit SwCommandBase
    end

Il tipo EditaDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EditaDistinta

Il tipo EditaDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Proprietà EditaDistinta.NeedParameters

Proprietà EditaDistintaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Metodi di EditaDistinta

Il tipo EditaDistinta espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Metodo EditaDistinta.ClearCommand

Metodo EditaDistintaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Metodo EditaDistinta.ExecuteCommand

Metodo EditaDistintaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Metodo EditaDistinta.SwEnabled

Metodo EditaDistintaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Metodo EditaDistinta.SwSetContext

Metodo EditaDistintaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetSw.Commands


Classe EditaECO
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEditaECO

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaECO : SwCommandBase
Public Class EditaECO
    Inherits SwCommandBase
public ref class EditaECO : public SwCommandBase
type EditaECO =
    class
        inherit SwCommandBase
    end

Il tipo EditaECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EditaECO

Il tipo EditaECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Proprietà EditaECO.NeedParameters

Proprietà EditaECONeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Metodi di EditaECO

Il tipo EditaECO espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Metodo EditaECO.ClearCommand

Metodo EditaECOClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Metodo EditaECO.ExecuteCommand

Metodo EditaECOExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Metodo EditaECO.SwEnabled

Metodo EditaECOSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Metodo EditaECO.SwSetContext

Metodo EditaECOSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetSw.Commands


Classe EnsureLocalAssociated
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEnsureLocalAssociated

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EnsureLocalAssociated : SwCommandBase
Public Class EnsureLocalAssociated
    Inherits SwCommandBase
public ref class EnsureLocalAssociated : public SwCommandBase
type EnsureLocalAssociated =
    class
        inherit SwCommandBase
    end

Il tipo EnsureLocalAssociated espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EnsureLocalAssociated

Il tipo EnsureLocalAssociated espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Proprietà EnsureLocalAssociated.NeedParameters

Proprietà EnsureLocalAssociatedNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Metodi di EnsureLocalAssociated

Il tipo EnsureLocalAssociated espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Metodo EnsureLocalAssociated.ClearCommand

Metodo EnsureLocalAssociatedClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Metodo EnsureLocalAssociated.ExecuteCommand

Metodo EnsureLocalAssociatedExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Metodo EnsureLocalAssociated.SwEnabled

Metodo EnsureLocalAssociatedSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Metodo EnsureLocalAssociated.SwSetContext

Metodo EnsureLocalAssociatedSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EnsureLocalAssociated
Namespace DedNetSw.Commands


Classe EnvMan
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEnvMan

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EnvMan : SwCommandBase
Public Class EnvMan
    Inherits SwCommandBase
public ref class EnvMan : public SwCommandBase
type EnvMan =
    class
        inherit SwCommandBase
    end

Il tipo EnvMan espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EnvMan

Il tipo EnvMan espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Proprietà EnvMan.NeedParameters

Proprietà EnvManNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Metodi di EnvMan

Il tipo EnvMan espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Metodo EnvMan.ClearCommand

Metodo EnvManClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Metodo EnvMan.ExecuteCommand

Metodo EnvManExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Metodo EnvMan.SwEnabled

Metodo EnvManSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Metodo EnvMan.SwSetContext

Metodo EnvManSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EnvMan
Namespace DedNetSw.Commands


Classe EseguiLua
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsEseguiLua

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EseguiLua : SwCommandBase
Public Class EseguiLua
    Inherits SwCommandBase
public ref class EseguiLua : public SwCommandBase
type EseguiLua =
    class
        inherit SwCommandBase
    end

Il tipo EseguiLua espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di EseguiLua

Il tipo EseguiLua espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Proprietà EseguiLua.NeedParameters

Proprietà EseguiLuaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Metodi di EseguiLua

Il tipo EseguiLua espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Metodo EseguiLua.ClearCommand

Metodo EseguiLuaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Metodo EseguiLua.ExecuteCommand

Metodo EseguiLuaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Metodo EseguiLua.SwEnabled

Metodo EseguiLuaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Metodo EseguiLua.SwSetContext

Metodo EseguiLuaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetSw.Commands


Classe FindDoc
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsFindDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindDoc : SwCommandBase
Public Class FindDoc
    Inherits SwCommandBase
public ref class FindDoc : public SwCommandBase
type FindDoc =
    class
        inherit SwCommandBase
    end

Il tipo FindDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | AllDbDocs |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di FindDoc

Il tipo FindDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | AllDbDocs |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetSw.Commands


Proprietà FindDoc.AllDbDocs

Proprietà FindDocAllDbDocs

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllDbDocs { get; set; }
Public Property AllDbDocs As Boolean
    Get
    Set
public:
property bool AllDbDocs {
    bool get ();
    void set (bool value);
}
member AllDbDocs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetSw.Commands


Metodi di FindDoc

Il tipo FindDoc espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetSw.Commands


Metodo FindDoc.ExecuteCommand

Metodo FindDocExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetSw.Commands


Metodo FindDoc.SwEnabled

Metodo FindDocSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetSw.Commands


Metodo FindDoc.SwSetContext

Metodo FindDocSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetSw.Commands


Classe FindInBrowser
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsFindInBrowser

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindInBrowser : SwCommandBase
Public Class FindInBrowser
    Inherits SwCommandBase
public ref class FindInBrowser : public SwCommandBase
type FindInBrowser =
    class
        inherit SwCommandBase
    end

Il tipo FindInBrowser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di FindInBrowser

Il tipo FindInBrowser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Proprietà FindInBrowser.NeedParameters

Proprietà FindInBrowserNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Metodi di FindInBrowser

Il tipo FindInBrowser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Metodo FindInBrowser.ClearCommand

Metodo FindInBrowserClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Metodo FindInBrowser.ExecuteCommand

Metodo FindInBrowserExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Metodo FindInBrowser.SwEnabled

Metodo FindInBrowserSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Metodo FindInBrowser.SwSetContext

Metodo FindInBrowserSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetSw.Commands


Classe FindInRicerca
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsFindInRicerca

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindInRicerca : SwCommandBase
Public Class FindInRicerca
    Inherits SwCommandBase
public ref class FindInRicerca : public SwCommandBase
type FindInRicerca =
    class
        inherit SwCommandBase
    end

Il tipo FindInRicerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di FindInRicerca

Il tipo FindInRicerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Proprietà FindInRicerca.NeedParameters

Proprietà FindInRicercaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Metodi di FindInRicerca

Il tipo FindInRicerca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Metodo FindInRicerca.ClearCommand

Metodo FindInRicercaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Metodo FindInRicerca.ExecuteCommand

Metodo FindInRicercaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Metodo FindInRicerca.SwEnabled

Metodo FindInRicercaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Metodo FindInRicerca.SwSetContext

Metodo FindInRicercaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetSw.Commands


Classe ForceMarkerAlingment
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsForceMarkerAlingment

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ForceMarkerAlingment : SwCommandBase
Public Class ForceMarkerAlingment
    Inherits SwCommandBase
public ref class ForceMarkerAlingment : public SwCommandBase
type ForceMarkerAlingment =
    class
        inherit SwCommandBase
    end

Il tipo ForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di ForceMarkerAlingment

Il tipo ForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Proprietà ForceMarkerAlingment.NeedParameters

Proprietà ForceMarkerAlingmentNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Metodi di ForceMarkerAlingment

Il tipo ForceMarkerAlingment espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Metodo ForceMarkerAlingment.ClearCommand

Metodo ForceMarkerAlingmentClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Metodo ForceMarkerAlingment.ExecuteCommand

Metodo ForceMarkerAlingmentExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Metodo ForceMarkerAlingment.SwEnabled

Metodo ForceMarkerAlingmentSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Metodo ForceMarkerAlingment.SwSetContext

Metodo ForceMarkerAlingmentSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetSw.Commands


Classe FormAbout
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsFormAbout

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FormAbout : SwCommandBase
Public Class FormAbout
    Inherits SwCommandBase
public ref class FormAbout : public SwCommandBase
type FormAbout =
    class
        inherit SwCommandBase
    end

Il tipo FormAbout espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di FormAbout

Il tipo FormAbout espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Proprietà FormAbout.NeedParameters

Proprietà FormAboutNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Metodi di FormAbout

Il tipo FormAbout espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Metodo FormAbout.ClearCommand

Metodo FormAboutClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Metodo FormAbout.ExecuteCommand

Metodo FormAboutExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Metodo FormAbout.SwEnabled

Metodo FormAboutSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Metodo FormAbout.SwSetContext

Metodo FormAboutSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetSw.Commands


Classe HelpSolidWorks
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsHelpSolidWorks

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class HelpSolidWorks : SwCommandBase
Public Class HelpSolidWorks
    Inherits SwCommandBase
public ref class HelpSolidWorks : public SwCommandBase
type HelpSolidWorks =
    class
        inherit SwCommandBase
    end

Il tipo HelpSolidWorks espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di HelpSolidWorks

Il tipo HelpSolidWorks espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Proprietà HelpSolidWorks.NeedParameters

Proprietà HelpSolidWorksNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Metodi di HelpSolidWorks

Il tipo HelpSolidWorks espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Metodo HelpSolidWorks.ClearCommand

Metodo HelpSolidWorksClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Metodo HelpSolidWorks.ExecuteCommand

Metodo HelpSolidWorksExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Metodo HelpSolidWorks.SwEnabled

Metodo HelpSolidWorksSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Metodo HelpSolidWorks.SwSetContext

Metodo HelpSolidWorksSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe HelpSolidWorks
Namespace DedNetSw.Commands


Classe IndividuaGrafica
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsIndividuaGrafica

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class IndividuaGrafica : SwCommandBase
Public Class IndividuaGrafica
    Inherits SwCommandBase
public ref class IndividuaGrafica : public SwCommandBase
type IndividuaGrafica =
    class
        inherit SwCommandBase
    end

Il tipo IndividuaGrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di IndividuaGrafica

Il tipo IndividuaGrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Proprietà IndividuaGrafica.NeedParameters

Proprietà IndividuaGraficaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Metodi di IndividuaGrafica

Il tipo IndividuaGrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Metodo IndividuaGrafica.ClearCommand

Metodo IndividuaGraficaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Metodo IndividuaGrafica.ExecuteCommand

Metodo IndividuaGraficaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Metodo IndividuaGrafica.SwEnabled

Metodo IndividuaGraficaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Metodo IndividuaGrafica.SwSetContext

Metodo IndividuaGraficaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetSw.Commands


Classe Lavorazione
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCambiaStato
DedNetSw.CommandsLavorazione

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Lavorazione : CambiaStato
Public Class Lavorazione
    Inherits CambiaStato
public ref class Lavorazione : public CambiaStato
type Lavorazione =
    class
        inherit CambiaStato
    end

Il tipo Lavorazione espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Lavorazione |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore Lavorazione

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Lavorazione(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
Lavorazione(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> Lavorazione

Parametri

app DedNetApplication
internalName String
displayName String
multiple Boolean
Vedi anche

Documentazione

Classe Lavorazione
Namespace DedNetSw.Commands


Proprietà di Lavorazione

Il tipo Lavorazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Lavorazione
Namespace DedNetSw.Commands


Metodi di Lavorazione

Il tipo Lavorazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Lavorazione
Namespace DedNetSw.Commands


Classe LinkDEDApplicazione
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsLinkDEDApplicazione

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LinkDEDApplicazione : SwCommandBase
Public Class LinkDEDApplicazione
    Inherits SwCommandBase
public ref class LinkDEDApplicazione : public SwCommandBase
type LinkDEDApplicazione =
    class
        inherit SwCommandBase
    end

Il tipo LinkDEDApplicazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Link |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di LinkDEDApplicazione

Il tipo LinkDEDApplicazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Link |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Proprietà LinkDEDApplicazione.Link

Proprietà LinkDEDApplicazioneLink

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Link { get; set; }
Public Property Link As String
    Get
    Set
public:
property String^ Link {
    String^ get ();
    void set (String^ value);
}
member Link : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Proprietà LinkDEDApplicazione.NeedParameters

Proprietà LinkDEDApplicazioneNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Metodi di LinkDEDApplicazione

Il tipo LinkDEDApplicazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Metodo LinkDEDApplicazione.ClearCommand

Metodo LinkDEDApplicazioneClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Metodo LinkDEDApplicazione.ExecuteCommand

Metodo LinkDEDApplicazioneExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Metodo LinkDEDApplicazione.SwEnabled

Metodo LinkDEDApplicazioneSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Metodo LinkDEDApplicazione.SwSetContext

Metodo LinkDEDApplicazioneSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe LinkDEDApplicazione
Namespace DedNetSw.Commands


Classe MarkerInfo
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsMarkerInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MarkerInfo : SwCommandBase
Public Class MarkerInfo
    Inherits SwCommandBase
public ref class MarkerInfo : public SwCommandBase
type MarkerInfo =
    class
        inherit SwCommandBase
    end

Il tipo MarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di MarkerInfo

Il tipo MarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Proprietà MarkerInfo.NeedParameters

Proprietà MarkerInfoNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Metodi di MarkerInfo

Il tipo MarkerInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Metodo MarkerInfo.ClearCommand

Metodo MarkerInfoClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Metodo MarkerInfo.ExecuteCommand

Metodo MarkerInfoExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Metodo MarkerInfo.SwEnabled

Metodo MarkerInfoSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Metodo MarkerInfo.SwSetContext

Metodo MarkerInfoSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetSw.Commands


Classe ModificaSuperato
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCambiaStato
DedNetSw.CommandsModificaSuperato

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModificaSuperato : CambiaStato
Public Class ModificaSuperato
    Inherits CambiaStato
public ref class ModificaSuperato : public CambiaStato
type ModificaSuperato =
    class
        inherit CambiaStato
    end

Il tipo ModificaSuperato espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModificaSuperato |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore ModificaSuperato

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModificaSuperato(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
ModificaSuperato(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> ModificaSuperato

Parametri

app DedNetApplication
internalName String
displayName String
multiple Boolean
Vedi anche

Documentazione

Classe ModificaSuperato
Namespace DedNetSw.Commands


Proprietà di ModificaSuperato

Il tipo ModificaSuperato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ModificaSuperato
Namespace DedNetSw.Commands


Metodi di ModificaSuperato

Il tipo ModificaSuperato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ModificaSuperato
Namespace DedNetSw.Commands


Classe OpzioniApplicazione
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsOpzioniApplicazione

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OpzioniApplicazione : SwCommandBase
Public Class OpzioniApplicazione
    Inherits SwCommandBase
public ref class OpzioniApplicazione : public SwCommandBase
type OpzioniApplicazione =
    class
        inherit SwCommandBase
    end

Il tipo OpzioniApplicazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di OpzioniApplicazione

Il tipo OpzioniApplicazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Proprietà OpzioniApplicazione.NeedParameters

Proprietà OpzioniApplicazioneNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Metodi di OpzioniApplicazione

Il tipo OpzioniApplicazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Metodo OpzioniApplicazione.ClearCommand

Metodo OpzioniApplicazioneClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Metodo OpzioniApplicazione.ExecuteCommand

Metodo OpzioniApplicazioneExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Metodo OpzioniApplicazione.SwEnabled

Metodo OpzioniApplicazioneSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Metodo OpzioniApplicazione.SwSetContext

Metodo OpzioniApplicazioneSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetSw.Commands


Enumerazione PackAndGoContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoContext
Public Enumeration PackAndGoContext
public enum class PackAndGoContext
type PackAndGoContext
Membri
Nome | Valore | Descrizione
Import | 0 |
Export | 1 |
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Classe PackAndGoExport
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsPackAndGoExport

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoExport : SwCommandBase
Public Class PackAndGoExport
    Inherits SwCommandBase
public ref class PackAndGoExport : public SwCommandBase
type PackAndGoExport =
    class
        inherit SwCommandBase
    end

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurSelInfo |
Proprietà pubblica | DocumentInfos |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurSelInfo |
Proprietà pubblica | DocumentInfos |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Proprietà PackAndGoExport.CurSelInfo

Proprietà PackAndGoExportCurSelInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwCurSelInfo CurSelInfo { get; }
Public ReadOnly Property CurSelInfo As SwCurSelInfo
    Get
public:
property SwCurSelInfo^ CurSelInfo {
    SwCurSelInfo^ get ();
}
member CurSelInfo : SwCurSelInfo with get

Valore della proprietà

SwCurSelInfo
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Proprietà PackAndGoExport.DocumentInfos

Proprietà PackAndGoExportDocumentInfos

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfoList DocumentInfos { get; }
Public ReadOnly Property DocumentInfos As DedCommandDocAnagrInfoList
    Get
public:
property DedCommandDocAnagrInfoList^ DocumentInfos {
    DedCommandDocAnagrInfoList^ get ();
}
member DocumentInfos : DedCommandDocAnagrInfoList with get

Valore della proprietà

DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodi di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodo PackAndGoExport.ClearCommand

Metodo PackAndGoExportClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodo PackAndGoExport.Enabled

Metodo PackAndGoExportEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodo PackAndGoExport.ExecuteCommand

Metodo PackAndGoExportExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodo PackAndGoExport.SetContext

Metodo PackAndGoExportSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodo PackAndGoExport.SwEnabled

Metodo PackAndGoExportSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Metodo PackAndGoExport.SwSetContext

Metodo PackAndGoExportSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetSw.Commands


Classe PackAndGoImport
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsPackAndGoImport

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImport : SwCommandBase
Public Class PackAndGoImport
    Inherits SwCommandBase
public ref class PackAndGoImport : public SwCommandBase
type PackAndGoImport =
    class
        inherit SwCommandBase
    end

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodi di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodo PackAndGoImport.ClearCommand

Metodo PackAndGoImportClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodo PackAndGoImport.Enabled

Metodo PackAndGoImportEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodo PackAndGoImport.ExecuteCommand

Metodo PackAndGoImportExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodo PackAndGoImport.SetContext

Metodo PackAndGoImportSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodo PackAndGoImport.SwEnabled

Metodo PackAndGoImportSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Metodo PackAndGoImport.SwSetContext

Metodo PackAndGoImportSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetSw.Commands


Enumerazione PackAndGoImportAttrStatus

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportAttrStatus
Public Enumeration PackAndGoImportAttrStatus
public enum class PackAndGoImportAttrStatus
type PackAndGoImportAttrStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Compare | 1 |
MandatoryMissing | 2 |
Undefined | 3 |
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Enumerazione PackAndGoImportDedCases

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportDedCases
Public Enumeration PackAndGoImportDedCases
public enum class PackAndGoImportDedCases
type PackAndGoImportDedCases
Membri
Nome | Valore | Descrizione
None | 0 |
NoDed | 1 |
DedRemote | 2 |
DedVpn | 3 |
InvPackAndGo | 4 |
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Classe PackAndGoImportingStructureInfo
Gerarchia di ereditarietà
SystemObject
DedNetSw.CommandsPackAndGoImportingStructureInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImportingStructureInfo
Public Class PackAndGoImportingStructureInfo
public ref class PackAndGoImportingStructureInfo
type PackAndGoImportingStructureInfo = class end

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoImportingStructureInfo |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore PackAndGoImportingStructureInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo()
Public Sub New
public:
PackAndGoImportingStructureInfo()
new : unit -> PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Metodi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone |
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Metodo PackAndGoImportingStructureInfo.Clone

Metodo PackAndGoImportingStructureInfoClone

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo Clone()
Public Function Clone As PackAndGoImportingStructureInfo
public:
PackAndGoImportingStructureInfo^ Clone()
member Clone : unit -> PackAndGoImportingStructureInfo

Valore di ritorno

PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.AttrStatus

Campo PackAndGoImportingStructureInfoAttrStatus

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportAttrStatus AttrStatus
Public AttrStatus As PackAndGoImportAttrStatus
public:
PackAndGoImportAttrStatus AttrStatus
val mutable AttrStatus: PackAndGoImportAttrStatus

Valore del campo

PackAndGoImportAttrStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.AttrStatusRepresentation

Campo PackAndGoImportingStructureInfoAttrStatusRepresentation

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image AttrStatusRepresentation
Public AttrStatusRepresentation As Image
public:
Image^ AttrStatusRepresentation
val mutable AttrStatusRepresentation: Image

Valore del campo

Image
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.Checkable

Campo PackAndGoImportingStructureInfoCheckable

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Checkable
Public Checkable As Boolean
public:
bool Checkable
val mutable Checkable: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.DocAlreadyCompared

Campo PackAndGoImportingStructureInfoDocAlreadyCompared

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocAlreadyCompared
Public DocAlreadyCompared As Boolean
public:
bool DocAlreadyCompared
val mutable DocAlreadyCompared: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.ImportNote

Campo PackAndGoImportingStructureInfoImportNote

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ImportNote
Public ImportNote As String
public:
String^ ImportNote
val mutable ImportNote: string

Valore del campo

String
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.OperationStatus

Campo PackAndGoImportingStructureInfoOperationStatus

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperationStatus OperationStatus
Public OperationStatus As PackAndGoImportOperationStatus
public:
PackAndGoImportOperationStatus OperationStatus
val mutable OperationStatus: PackAndGoImportOperationStatus

Valore del campo

PackAndGoImportOperationStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.PckImportOperation

Campo PackAndGoImportingStructureInfoPckImportOperation

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation PckImportOperation
Public PckImportOperation As PackAndGoImportOperation
public:
PackAndGoImportOperation PckImportOperation
val mutable PckImportOperation: PackAndGoImportOperation

Valore del campo

PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Campo PackAndGoImportingStructureInfo.PckNdDescr

Campo PackAndGoImportingStructureInfoPckNdDescr

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor PckNdDescr
Public PckNdDescr As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ PckNdDescr
val mutable PckNdDescr: PackAndGoNodeDescriptor

Valore del campo

PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetSw.Commands


Enumerazione PackAndGoImportOperation

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperation
Public Enumeration PackAndGoImportOperation
public enum class PackAndGoImportOperation
type PackAndGoImportOperation
Membri
Nome | Valore | Descrizione
Ignora | 0 |
Sovrascrivi | 1 |
Codifica | 2 |
Associa | 3 |
Libreria | 4 |
Clona | 5 |
Speciale | 6 |
Salta | 7 |
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Enumerazione PackAndGoImportOperationStatus

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperationStatus
Public Enumeration PackAndGoImportOperationStatus
public enum class PackAndGoImportOperationStatus
type PackAndGoImportOperationStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Error | 1 |
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Classe PackAndGoNodeDescriptor
Gerarchia di ereditarietà
SystemObject
DedNetSw.CommandsPackAndGoNodeDescriptor

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptor
<SerializableAttribute>
Public Class PackAndGoNodeDescriptor
[SerializableAttribute]
public ref class PackAndGoNodeDescriptor
[<SerializableAttribute>]
type PackAndGoNodeDescriptor = class end

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor |
Metodo pubblico | PackAndGoNodeDescriptor(SwDocStructInfo) |
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData, String) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg |
Proprietà pubblica | Children |
Proprietà pubblica | Configurations |
Proprietà pubblica | Context |
Proprietà pubblica | DbPath |
Proprietà pubblica | DedId |
Proprietà pubblica | DedRev |
Proprietà pubblica | DocId |
Proprietà pubblica | DocIsMovingDestination |
Proprietà pubblica | DocRowVer |
Proprietà pubblica | FullFileName |
Proprietà pubblica | HasData |
Proprietà pubblica | InfoUser |
Proprietà pubblica | MakeAnagrObs |
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Parent |
Proprietà pubblica | Progr |
Proprietà pubblica | RelativeFileName |
Proprietà pubblica | RootedPath |
Proprietà pubblica | ToBeMoved |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IsSameVersion |
Metodo pubblico | MatchRelativeFileName |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore PackAndGoNodeDescriptor
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor |
Metodo pubblico | PackAndGoNodeDescriptor(SwDocStructInfo) |
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData, String) |
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Costruttore PackAndGoNodeDescriptor

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor()
Public Sub New
public:
PackAndGoNodeDescriptor()
new : unit -> PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Costruttore PackAndGoNodeDescriptor(SwDocStructInfo)

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    SwDocStructInfo ds
)
Public Sub New (
    ds As SwDocStructInfo
)
public:
PackAndGoNodeDescriptor(
    SwDocStructInfo^ ds
)
new :
        ds : SwDocStructInfo -> PackAndGoNodeDescriptor

Parametri

ds SwDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Costruttore PackAndGoNodeDescriptor(DedDoc, DedData, String)

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    DedDoc ddoc,
    DedData ddata,
    string config
)
Public Sub New (
    ddoc As DedDoc,
    ddata As DedData,
    config As String
)
public:
PackAndGoNodeDescriptor(
    DedDoc^ ddoc,
    DedData^ ddata,
    String^ config
)
new :
        ddoc : DedDoc *
        ddata : DedData *
        config : string -> PackAndGoNodeDescriptor

Parametri

ddoc DedDoc
ddata DedData
config String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg |
Proprietà pubblica | Children |
Proprietà pubblica | Configurations |
Proprietà pubblica | Context |
Proprietà pubblica | DbPath |
Proprietà pubblica | DedId |
Proprietà pubblica | DedRev |
Proprietà pubblica | DocId |
Proprietà pubblica | DocIsMovingDestination |
Proprietà pubblica | DocRowVer |
Proprietà pubblica | FullFileName |
Proprietà pubblica | HasData |
Proprietà pubblica | InfoUser |
Proprietà pubblica | MakeAnagrObs |
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Parent |
Proprietà pubblica | Progr |
Proprietà pubblica | RelativeFileName |
Proprietà pubblica | RootedPath |
Proprietà pubblica | ToBeMoved |
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.Cfg

Proprietà PackAndGoNodeDescriptorCfg

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Cfg { get; set; }
Public Property Cfg As String
    Get
    Set
public:
property String^ Cfg {
    String^ get ();
    void set (String^ value);
}
member Cfg : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.Children

Proprietà PackAndGoNodeDescriptorChildren

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Children { get; set; }
Public Property Children As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Children {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Children : PackAndGoNodeDescriptors with get, set

Valore della proprietà

PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.Configurations

Proprietà PackAndGoNodeDescriptorConfigurations

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Configurations { get; set; }
Public Property Configurations As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Configurations {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Configurations : PackAndGoNodeDescriptors with get, set

Valore della proprietà

PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.Context

Proprietà PackAndGoNodeDescriptorContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.DbPath

Proprietà PackAndGoNodeDescriptorDbPath

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.DedId

Proprietà PackAndGoNodeDescriptorDedId

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; set; }
Public Property DedId As String
    Get
    Set
public:
property String^ DedId {
    String^ get ();
    void set (String^ value);
}
member DedId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.DedRev

Proprietà PackAndGoNodeDescriptorDedRev

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; set; }
Public Property DedRev As String
    Get
    Set
public:
property String^ DedRev {
    String^ get ();
    void set (String^ value);
}
member DedRev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.DocId

Proprietà PackAndGoNodeDescriptorDocId

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocId { get; set; }
Public Property DocId As Guid
    Get
    Set
public:
property Guid DocId {
    Guid get ();
    void set (Guid value);
}
member DocId : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.DocIsMovingDestination

Proprietà PackAndGoNodeDescriptorDocIsMovingDestination

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocIsMovingDestination { get; set; }
Public Property DocIsMovingDestination As Boolean
    Get
    Set
public:
property bool DocIsMovingDestination {
    bool get ();
    void set (bool value);
}
member DocIsMovingDestination : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.DocRowVer

Proprietà PackAndGoNodeDescriptorDocRowVer

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocRowVer { get; set; }
Public Property DocRowVer As Guid
    Get
    Set
public:
property Guid DocRowVer {
    Guid get ();
    void set (Guid value);
}
member DocRowVer : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.FullFileName

Proprietà PackAndGoNodeDescriptorFullFileName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.HasData

Proprietà PackAndGoNodeDescriptorHasData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasData { get; }
Public ReadOnly Property HasData As Boolean
    Get
public:
property bool HasData {
    bool get ();
}
member HasData : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.InfoUser

Proprietà PackAndGoNodeDescriptorInfoUser

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.MakeAnagrObs

Proprietà PackAndGoNodeDescriptorMakeAnagrObs

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MakeAnagrObs { get; set; }
Public Property MakeAnagrObs As Boolean
    Get
    Set
public:
property bool MakeAnagrObs {
    bool get ();
    void set (bool value);
}
member MakeAnagrObs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.MovedByMasterAfterSend

Proprietà PackAndGoNodeDescriptorMovedByMasterAfterSend

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MovedByMasterAfterSend { get; set; }
Public Property MovedByMasterAfterSend As Boolean
    Get
    Set
public:
property bool MovedByMasterAfterSend {
    bool get ();
    void set (bool value);
}
member MovedByMasterAfterSend : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.Parent

Proprietà PackAndGoNodeDescriptorParent

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor Parent { get; set; }
Public Property Parent As PackAndGoNodeDescriptor
    Get
    Set
public:
property PackAndGoNodeDescriptor^ Parent {
    PackAndGoNodeDescriptor^ get ();
    void set (PackAndGoNodeDescriptor^ value);
}
member Parent : PackAndGoNodeDescriptor with get, set

Valore della proprietà

PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.Progr

Proprietà PackAndGoNodeDescriptorProgr

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.RelativeFileName

Proprietà PackAndGoNodeDescriptorRelativeFileName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string RelativeFileName { get; set; }
Public Property RelativeFileName As String
    Get
    Set
public:
property String^ RelativeFileName {
    String^ get ();
    void set (String^ value);
}
member RelativeFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.RootedPath

Proprietà PackAndGoNodeDescriptorRootedPath

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string RootedPath { get; set; }
Public Property RootedPath As String
    Get
    Set
public:
property String^ RootedPath {
    String^ get ();
    void set (String^ value);
}
member RootedPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeDescriptor.ToBeMoved

Proprietà PackAndGoNodeDescriptorToBeMoved

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeMoved { get; set; }
Public Property ToBeMoved As Boolean
    Get
    Set
public:
property bool ToBeMoved {
    bool get ();
    void set (bool value);
}
member ToBeMoved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Metodi di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IsSameVersion |
Metodo pubblico | MatchRelativeFileName |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoNodeDescriptor.Equals

Metodo PackAndGoNodeDescriptorEquals

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoNodeDescriptor.GetHashCode

Metodo PackAndGoNodeDescriptorGetHashCode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoNodeDescriptor.IsSameVersion

Metodo PackAndGoNodeDescriptorIsSameVersion

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSameVersion(
    Guid docRowVer
)
Public Function IsSameVersion (
    docRowVer As Guid
) As Boolean
public:
bool IsSameVersion(
    Guid docRowVer
)
member IsSameVersion :
        docRowVer : Guid -> bool

Parametri

docRowVer Guid

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoNodeDescriptor.MatchRelativeFileName

Metodo PackAndGoNodeDescriptorMatchRelativeFileName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MatchRelativeFileName(
    string relativePath
)
Public Function MatchRelativeFileName (
    relativePath As String
) As Boolean
public:
bool MatchRelativeFileName(
    String^ relativePath
)
member MatchRelativeFileName :
        relativePath : string -> bool

Parametri

relativePath String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoNodeDescriptor.ToString

Metodo PackAndGoNodeDescriptorToString

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetSw.Commands


Classe PackAndGoNodeDescriptors
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList PackAndGoNodeDescriptor
DedNetSw.CommandsPackAndGoNodeDescriptors

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptors : List<PackAndGoNodeDescriptor>
<SerializableAttribute>
Public Class PackAndGoNodeDescriptors
    Inherits List(Of PackAndGoNodeDescriptor)
[SerializableAttribute]
public ref class PackAndGoNodeDescriptors : public List<PackAndGoNodeDescriptor^>
[<SerializableAttribute>]
type PackAndGoNodeDescriptors =
    class
        inherit List<PackAndGoNodeDescriptor>
    end

Il tipo PackAndGoNodeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptors |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore PackAndGoNodeDescriptors

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors()
Public Sub New
public:
PackAndGoNodeDescriptors()
new : unit -> PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptors
Namespace DedNetSw.Commands


Classe PackAndGoNodeWrapper
Gerarchia di ereditarietà
SystemObject
DedNetSw.CommandsPackAndGoNodeWrapper

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoNodeWrapper
Public Class PackAndGoNodeWrapper
public ref class PackAndGoNodeWrapper
type PackAndGoNodeWrapper = class end

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) |
Metodo pubblico | PackAndGoNodeWrapper(DedData, SwDocStructInfo, PackAndGoContext) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg |
Proprietà pubblica | Context |
Proprietà pubblica | Data |
Proprietà pubblica | DedDoc |
Proprietà pubblica | DedType |
Proprietà pubblica | DestRoot |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | FullFileName |
Proprietà pubblica | ImportStructureInfo |
Proprietà pubblica | InfoUser |
Proprietà pubblica | InvolvedInImportOperations |
Proprietà pubblica | IsDataNode |
Proprietà pubblica | NewFullFileName |
Proprietà pubblica | Node |
Proprietà pubblica | NodeInfoCompleted |
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr |
Proprietà pubblica | Rev |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone |
Metodo pubblico | SetData |
Metodo pubblico | SetNodeIcon |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore PackAndGoNodeWrapper
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) |
Metodo pubblico | PackAndGoNodeWrapper(DedData, SwDocStructInfo, PackAndGoContext) |
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Costruttore PackAndGoNodeWrapper(DedDoc, PackAndGoContext)

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedDoc ddoc,
    PackAndGoContext context
)
Public Sub New (
    ddoc As DedDoc,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedDoc^ ddoc,
    PackAndGoContext context
)
new :
        ddoc : DedDoc *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddoc DedDoc
context PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Costruttore PackAndGoNodeWrapper(DedData, SwDocStructInfo, PackAndGoContext)

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedData ddata,
    SwDocStructInfo swDsInfo,
    PackAndGoContext context
)
Public Sub New (
    ddata As DedData,
    swDsInfo As SwDocStructInfo,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedData^ ddata,
    SwDocStructInfo^ swDsInfo,
    PackAndGoContext context
)
new :
        ddata : DedData *
        swDsInfo : SwDocStructInfo *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddata DedData
swDsInfo SwDocStructInfo
context PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg |
Proprietà pubblica | Context |
Proprietà pubblica | Data |
Proprietà pubblica | DedDoc |
Proprietà pubblica | DedType |
Proprietà pubblica | DestRoot |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | FullFileName |
Proprietà pubblica | ImportStructureInfo |
Proprietà pubblica | InfoUser |
Proprietà pubblica | InvolvedInImportOperations |
Proprietà pubblica | IsDataNode |
Proprietà pubblica | NewFullFileName |
Proprietà pubblica | Node |
Proprietà pubblica | NodeInfoCompleted |
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr |
Proprietà pubblica | Rev |
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.Cfg

Proprietà PackAndGoNodeWrapperCfg

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Cfg { get; set; }
Public Property Cfg As String
    Get
    Set
public:
property String^ Cfg {
    String^ get ();
    void set (String^ value);
}
member Cfg : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.Context

Proprietà PackAndGoNodeWrapperContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoContext Context { get; set; }
Public Property Context As PackAndGoContext
    Get
    Set
public:
property PackAndGoContext Context {
    PackAndGoContext get ();
    void set (PackAndGoContext value);
}
member Context : PackAndGoContext with get, set

Valore della proprietà

PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.Data

Proprietà PackAndGoNodeWrapperData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.DedDoc

Proprietà PackAndGoNodeWrapperDedDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.DedType

Proprietà PackAndGoNodeWrapperDedType

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.DestRoot

Proprietà PackAndGoNodeWrapperDestRoot

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.DocStructInfo

Proprietà PackAndGoNodeWrapperDocStructInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As SwDocStructInfo
    Get
public:
property SwDocStructInfo^ DocStructInfo {
    SwDocStructInfo^ get ();
}
member DocStructInfo : SwDocStructInfo with get

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.FullFileName

Proprietà PackAndGoNodeWrapperFullFileName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.ImportStructureInfo

Proprietà PackAndGoNodeWrapperImportStructureInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo ImportStructureInfo { get; set; }
Public Property ImportStructureInfo As PackAndGoImportingStructureInfo
    Get
    Set
public:
property PackAndGoImportingStructureInfo^ ImportStructureInfo {
    PackAndGoImportingStructureInfo^ get ();
    void set (PackAndGoImportingStructureInfo^ value);
}
member ImportStructureInfo : PackAndGoImportingStructureInfo with get, set

Valore della proprietà

PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.InfoUser

Proprietà PackAndGoNodeWrapperInfoUser

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.InvolvedInImportOperations

Proprietà PackAndGoNodeWrapperInvolvedInImportOperations

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool InvolvedInImportOperations { get; set; }
Public Property InvolvedInImportOperations As Boolean
    Get
    Set
public:
property bool InvolvedInImportOperations {
    bool get ();
    void set (bool value);
}
member InvolvedInImportOperations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.IsDataNode

Proprietà PackAndGoNodeWrapperIsDataNode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDataNode { get; }
Public ReadOnly Property IsDataNode As Boolean
    Get
public:
property bool IsDataNode {
    bool get ();
}
member IsDataNode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.NewFullFileName

Proprietà PackAndGoNodeWrapperNewFullFileName

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.Node

Proprietà PackAndGoNodeWrapperNode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; set; }
Public Property Node As TreeListNode
    Get
    Set
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
    void set (TreeListNode^ value);
}
member Node : TreeListNode with get, set

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.NodeInfoCompleted

Proprietà PackAndGoNodeWrapperNodeInfoCompleted

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NodeInfoCompleted { get; }
Public ReadOnly Property NodeInfoCompleted As Boolean
    Get
public:
property bool NodeInfoCompleted {
    bool get ();
}
member NodeInfoCompleted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.OutofPackGo

Proprietà PackAndGoNodeWrapperOutofPackGo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutofPackGo { get; set; }
Public Property OutofPackGo As Boolean
    Get
    Set
public:
property bool OutofPackGo {
    bool get ();
    void set (bool value);
}
member OutofPackGo : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.Progr

Proprietà PackAndGoNodeWrapperProgr

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Proprietà PackAndGoNodeWrapper.Rev

Proprietà PackAndGoNodeWrapperRev

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Metodi di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone |
Metodo pubblico | SetData |
Metodo pubblico | SetNodeIcon |
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Metodo PackAndGoNodeWrapper.Clone

Metodo PackAndGoNodeWrapperClone

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper Clone()
Public Function Clone As PackAndGoNodeWrapper
public:
PackAndGoNodeWrapper^ Clone()
member Clone : unit -> PackAndGoNodeWrapper

Valore di ritorno

PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Metodo PackAndGoNodeWrapper.SetData

Metodo PackAndGoNodeWrapperSetData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    TreeListNode node
)
Public Sub SetData (
    node As TreeListNode
)
public:
void SetData(
    TreeListNode^ node
)
member SetData :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Metodo PackAndGoNodeWrapper.SetNodeIcon

Metodo PackAndGoNodeWrapperSetNodeIcon

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetNodeIcon(
    ImageList il,
    TreeListNode node
)
Public Sub SetNodeIcon (
    il As ImageList,
    node As TreeListNode
)
public:
void SetNodeIcon(
    ImageList^ il,
    TreeListNode^ node
)
member SetNodeIcon :
        il : ImageList *
        node : TreeListNode -> unit

Parametri

il ImageList
node TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetSw.Commands


Classe PackAndGoStructureDescriptor
Gerarchia di ereditarietà
SystemObject
DedNetSw.CommandsPackAndGoStructureDescriptor

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoStructureDescriptor
<SerializableAttribute>
Public Class PackAndGoStructureDescriptor
[SerializableAttribute]
public ref class PackAndGoStructureDescriptor
[<SerializableAttribute>]
type PackAndGoStructureDescriptor = class end

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoStructureDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported |
Proprietà pubblica | CorporateId |
Proprietà pubblica | DbType |
Proprietà pubblica | DescriptorFullPath |
Proprietà pubblica | MajorVer |
Proprietà pubblica | MinorVer |
Proprietà pubblica | Structure |
Proprietà pubblica | UserId |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Find |
Metodo pubblico | GetCurrentImportAction |
Metodo pubblico | SerializeMe |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore PackAndGoStructureDescriptor

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor()
Public Sub New
public:
PackAndGoStructureDescriptor()
new : unit -> PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported |
Proprietà pubblica | CorporateId |
Proprietà pubblica | DbType |
Proprietà pubblica | DescriptorFullPath |
Proprietà pubblica | MajorVer |
Proprietà pubblica | MinorVer |
Proprietà pubblica | Structure |
Proprietà pubblica | UserId |
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.AlreadyImported

Proprietà PackAndGoStructureDescriptorAlreadyImported

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlreadyImported { get; set; }
Public Property AlreadyImported As Boolean
    Get
    Set
public:
property bool AlreadyImported {
    bool get ();
    void set (bool value);
}
member AlreadyImported : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.CorporateId

Proprietà PackAndGoStructureDescriptorCorporateId

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string CorporateId { get; set; }
Public Property CorporateId As String
    Get
    Set
public:
property String^ CorporateId {
    String^ get ();
    void set (String^ value);
}
member CorporateId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.DbType

Proprietà PackAndGoStructureDescriptorDbType

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbType { get; set; }
Public Property DbType As String
    Get
    Set
public:
property String^ DbType {
    String^ get ();
    void set (String^ value);
}
member DbType : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.DescriptorFullPath

Proprietà PackAndGoStructureDescriptorDescriptorFullPath

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DescriptorFullPath { get; set; }
Public Property DescriptorFullPath As String
    Get
    Set
public:
property String^ DescriptorFullPath {
    String^ get ();
    void set (String^ value);
}
member DescriptorFullPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.MajorVer

Proprietà PackAndGoStructureDescriptorMajorVer

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int MajorVer { get; set; }
Public Property MajorVer As Integer
    Get
    Set
public:
property int MajorVer {
    int get ();
    void set (int value);
}
member MajorVer : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.MinorVer

Proprietà PackAndGoStructureDescriptorMinorVer

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int MinorVer { get; set; }
Public Property MinorVer As Integer
    Get
    Set
public:
property int MinorVer {
    int get ();
    void set (int value);
}
member MinorVer : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.Structure

Proprietà PackAndGoStructureDescriptorStructure

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Structure { get; set; }
Public Property Structure As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Structure {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Structure : PackAndGoNodeDescriptors with get, set

Valore della proprietà

PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Proprietà PackAndGoStructureDescriptor.UserId

Proprietà PackAndGoStructureDescriptorUserId

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Metodi di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find |
Metodo pubblico | GetCurrentImportAction |
Metodo pubblico | SerializeMe |
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoStructureDescriptor.Find

Metodo PackAndGoStructureDescriptorFind

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor Find(
    string fullFileName,
    string config
)
Public Function Find (
    fullFileName As String,
    config As String
) As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ Find(
    String^ fullFileName,
    String^ config
)
member Find :
        fullFileName : string *
        config : string -> PackAndGoNodeDescriptor

Parametri

fullFileName String
config String

Valore di ritorno

PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoStructureDescriptor.GetCurrentImportAction

Metodo PackAndGoStructureDescriptorGetCurrentImportAction

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor pckNdDescr,
    string currentFullFileName,
    PackAndGoImportDedCases dedcase
)
Public Function GetCurrentImportAction (
    pckNdDescr As PackAndGoNodeDescriptor,
    currentFullFileName As String,
    dedcase As PackAndGoImportDedCases
) As PackAndGoImportOperation
public:
PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor^ pckNdDescr,
    String^ currentFullFileName,
    PackAndGoImportDedCases dedcase
)
member GetCurrentImportAction :
        pckNdDescr : PackAndGoNodeDescriptor *
        currentFullFileName : string *
        dedcase : PackAndGoImportDedCases -> PackAndGoImportOperation

Parametri

pckNdDescr PackAndGoNodeDescriptor
currentFullFileName String
dedcase PackAndGoImportDedCases

Valore di ritorno

PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Metodo PackAndGoStructureDescriptor.SerializeMe

Metodo PackAndGoStructureDescriptorSerializeMe

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SerializeMe(
    string fn
)
Public Sub SerializeMe (
    fn As String
)
public:
void SerializeMe(
    String^ fn
)
member SerializeMe :
        fn : string -> unit

Parametri

fn String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetSw.Commands


Classe Pubblica
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsPubblica

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Pubblica : SwCommandBase
Public Class Pubblica
    Inherits SwCommandBase
public ref class Pubblica : public SwCommandBase
type Pubblica =
    class
        inherit SwCommandBase
    end

Il tipo Pubblica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Pubblica

Il tipo Pubblica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Proprietà Pubblica.NeedParameters

Proprietà PubblicaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Metodi di Pubblica

Il tipo Pubblica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Metodo Pubblica.ClearCommand

Metodo PubblicaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Metodo Pubblica.ExecuteCommand

Metodo PubblicaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Metodo Pubblica.SwEnabled

Metodo PubblicaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Metodo Pubblica.SwSetContext

Metodo PubblicaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetSw.Commands


Classe PublishSparePartsDrawing
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsPublishSparePartsDrawing

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PublishSparePartsDrawing : SwCommandBase
Public Class PublishSparePartsDrawing
    Inherits SwCommandBase
public ref class PublishSparePartsDrawing : public SwCommandBase
type PublishSparePartsDrawing =
    class
        inherit SwCommandBase
    end

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Proprietà PublishSparePartsDrawing.Data

Proprietà PublishSparePartsDrawingData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Proprietà PublishSparePartsDrawing.Document

Proprietà PublishSparePartsDrawingDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Proprietà PublishSparePartsDrawing.NeedParameters

Proprietà PublishSparePartsDrawingNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodi di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodo PublishSparePartsDrawing.ClearCommand

Metodo PublishSparePartsDrawingClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodo PublishSparePartsDrawing.Enabled

Metodo PublishSparePartsDrawingEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodo PublishSparePartsDrawing.ExecuteCommand

Metodo PublishSparePartsDrawingExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodo PublishSparePartsDrawing.SetContext

Metodo PublishSparePartsDrawingSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodo PublishSparePartsDrawing.SwEnabled

Metodo PublishSparePartsDrawingSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext invCmdCtx
)
Public Overrides Function SwEnabled (
    invCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ invCmdCtx
) override
abstract SwEnabled :
        invCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        invCmdCtx : DedSwCommandContext -> bool

Parametri

invCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Metodo PublishSparePartsDrawing.SwSetContext

Metodo PublishSparePartsDrawingSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext invCmdCtx
)
Public Overrides Function SwSetContext (
    invCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ invCmdCtx
) override
abstract SwSetContext :
        invCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        invCmdCtx : DedSwCommandContext -> bool

Parametri

invCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetSw.Commands


Classe PwsCache
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsPwsCache

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PwsCache : SwCommandBase
Public Class PwsCache
    Inherits SwCommandBase
public ref class PwsCache : public SwCommandBase
type PwsCache =
    class
        inherit SwCommandBase
    end

Il tipo PwsCache espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di PwsCache

Il tipo PwsCache espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Proprietà PwsCache.NeedParameters

Proprietà PwsCacheNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Metodi di PwsCache

Il tipo PwsCache espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Metodo PwsCache.ClearCommand

Metodo PwsCacheClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Metodo PwsCache.ExecuteCommand

Metodo PwsCacheExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Metodo PwsCache.SwEnabled

Metodo PwsCacheSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Metodo PwsCache.SwSetContext

Metodo PwsCacheSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetSw.Commands


Classe Registra
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsRegistra

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Registra : SwCommandBase
Public Class Registra
    Inherits SwCommandBase
public ref class Registra : public SwCommandBase
type Registra =
    class
        inherit SwCommandBase
    end

Il tipo Registra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Registra

Il tipo Registra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Proprietà Registra.NeedParameters

Proprietà RegistraNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Metodi di Registra

Il tipo Registra espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Metodo Registra.ClearCommand

Metodo RegistraClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Metodo Registra.ExecuteCommand

Metodo RegistraExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Metodo Registra.SwEnabled

Metodo RegistraSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Metodo Registra.SwSetContext

Metodo RegistraSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Registra
Namespace DedNetSw.Commands


Classe Ricerca
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsRicerca

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Ricerca : SwCommandBase
Public Class Ricerca
    Inherits SwCommandBase
public ref class Ricerca : public SwCommandBase
type Ricerca =
    class
        inherit SwCommandBase
    end

Il tipo Ricerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CloseDialogOnQuit |
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Ricerca

Il tipo Ricerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CloseDialogOnQuit |
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetSw.Commands


Proprietà Ricerca.CloseDialogOnQuit

Proprietà RicercaCloseDialogOnQuit

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CloseDialogOnQuit { set; }
Public WriteOnly Property CloseDialogOnQuit As Boolean
    Set
public:
property bool CloseDialogOnQuit {
    void set (bool value);
}
member CloseDialogOnQuit : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetSw.Commands


Metodi di Ricerca

Il tipo Ricerca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetSw.Commands


Metodo Ricerca.ExecuteCommand

Metodo RicercaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetSw.Commands


Metodo Ricerca.SwEnabled

Metodo RicercaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetSw.Commands


Metodo Ricerca.SwSetContext

Metodo RicercaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetSw.Commands


Classe Rilascia
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCambiaStato
DedNetSw.CommandsRilascia

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Rilascia : CambiaStato
Public Class Rilascia
    Inherits CambiaStato
public ref class Rilascia : public CambiaStato
type Rilascia =
    class
        inherit CambiaStato
    end

Il tipo Rilascia espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Rilascia |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore Rilascia

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Rilascia(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
Rilascia(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> Rilascia

Parametri

app DedNetApplication
internalName String
displayName String
multiple Boolean
Vedi anche

Documentazione

Classe Rilascia
Namespace DedNetSw.Commands


Proprietà di Rilascia

Il tipo Rilascia espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Rilascia
Namespace DedNetSw.Commands


Metodi di Rilascia

Il tipo Rilascia espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Rilascia
Namespace DedNetSw.Commands


Classe Salva
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSalva

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Salva : SwCommandBase
Public Class Salva
    Inherits SwCommandBase
public ref class Salva : public SwCommandBase
type Salva =
    class
        inherit SwCommandBase
    end

Il tipo Salva espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceAll |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Salva

Il tipo Salva espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceAll |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.CreazioneVariante

Proprietà SalvaCreazioneVariante

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.DocStructInfo

Proprietà SalvaDocStructInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo DocStructInfo { get; set; }
Public Property DocStructInfo As SwDocStructInfo
    Get
    Set
public:
property SwDocStructInfo^ DocStructInfo {
    SwDocStructInfo^ get ();
    void set (SwDocStructInfo^ value);
}
member DocStructInfo : SwDocStructInfo with get, set

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.IsSavePrt

Proprietà SalvaIsSavePrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; }
Public ReadOnly Property IsSavePrt As Boolean
    Get
public:
property bool IsSavePrt {
    bool get ();
}
member IsSavePrt : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.NeedParameters

Proprietà SalvaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.NewData

Proprietà SalvaNewData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.ReplaceAll

Proprietà SalvaReplaceAll

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}
member ReplaceAll : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.SaveCommand

Proprietà SalvaSaveCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

SaveCommand
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.SwComp

Proprietà SalvaSwComp

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IComponent2 SwComp { get; set; }
Public Property SwComp As IComponent2
    Get
    Set
public:
property IComponent2^ SwComp {
    IComponent2^ get ();
    void set (IComponent2^ value);
}
member SwComp : IComponent2 with get, set

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.SwConf

Proprietà SalvaSwConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SwConf { get; set; }
Public Property SwConf As String
    Get
    Set
public:
property String^ SwConf {
    String^ get ();
    void set (String^ value);
}
member SwConf : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.SwDoc

Proprietà SalvaSwDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; set; }
Public Property SwDoc As IModelDoc2
    Get
    Set
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
    void set (IModelDoc2^ value);
}
member SwDoc : IModelDoc2 with get, set

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Proprietà Salva.TopDocument

Proprietà SalvaTopDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 TopDocument { get; }
Public ReadOnly Property TopDocument As IModelDoc2
    Get
public:
property IModelDoc2^ TopDocument {
    IModelDoc2^ get ();
}
member TopDocument : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodi di Salva

Il tipo Salva espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.ClearCommand

Metodo SalvaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.Equals

Metodo SalvaEquals

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.ExecuteCommand

Metodo SalvaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.GetHashCode

Metodo SalvaGetHashCode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.SwEnabled

Metodo SalvaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.SwSetContext

Metodo SalvaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Metodo Salva.ToString

Metodo SalvaToString

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Salva
Namespace DedNetSw.Commands


Classe SalvaConf
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSalvaConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaConf : SwCommandBase
Public Class SalvaConf
    Inherits SwCommandBase
public ref class SalvaConf : public SwCommandBase
type SalvaConf =
    class
        inherit SwCommandBase
    end

Il tipo SalvaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwDoc |
Proprietà pubblica | SwOcc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SalvaConf

Il tipo SalvaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveCommand |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwDoc |
Proprietà pubblica | SwOcc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.CreazioneVariante

Proprietà SalvaConfCreazioneVariante

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.DocStructInfo

Proprietà SalvaConfDocStructInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo DocStructInfo { get; set; }
Public Property DocStructInfo As SwDocStructInfo
    Get
    Set
public:
property SwDocStructInfo^ DocStructInfo {
    SwDocStructInfo^ get ();
    void set (SwDocStructInfo^ value);
}
member DocStructInfo : SwDocStructInfo with get, set

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.IsSavePrt

Proprietà SalvaConfIsSavePrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; }
Public ReadOnly Property IsSavePrt As Boolean
    Get
public:
property bool IsSavePrt {
    bool get ();
}
member IsSavePrt : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.NeedParameters

Proprietà SalvaConfNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.NewData

Proprietà SalvaConfNewData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.SaveCommand

Proprietà SalvaConfSaveCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

SaveCommand
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.SwDoc

Proprietà SalvaConfSwDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; set; }
Public Property SwDoc As IModelDoc2
    Get
    Set
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
    void set (IModelDoc2^ value);
}
member SwDoc : IModelDoc2 with get, set

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.SwOcc

Proprietà SalvaConfSwOcc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IComponent2 SwOcc { get; set; }
Public Property SwOcc As IComponent2
    Get
    Set
public:
property IComponent2^ SwOcc {
    IComponent2^ get ();
    void set (IComponent2^ value);
}
member SwOcc : IComponent2 with get, set

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Proprietà SalvaConf.TopDocument

Proprietà SalvaConfTopDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 TopDocument { get; }
Public ReadOnly Property TopDocument As IModelDoc2
    Get
public:
property IModelDoc2^ TopDocument {
    IModelDoc2^ get ();
}
member TopDocument : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodi di SalvaConf

Il tipo SalvaConf espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.ClearCommand

Metodo SalvaConfClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.Equals

Metodo SalvaConfEquals

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.ExecuteCommand

Metodo SalvaConfExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.GetHashCode

Metodo SalvaConfGetHashCode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.SwEnabled

Metodo SalvaConfSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.SwSetContext

Metodo SalvaConfSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Metodo SalvaConf.ToString

Metodo SalvaConfToString

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetSw.Commands


Classe SalvaDist
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSalvaDist

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaDist : SwCommandBase
Public Class SalvaDist
    Inherits SwCommandBase
public ref class SalvaDist : public SwCommandBase
type SalvaDist =
    class
        inherit SwCommandBase
    end

Il tipo SalvaDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiLevel |
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveDistOnApproved |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SalvaDist

Il tipo SalvaDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiLevel |
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveDistOnApproved |
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Proprietà SalvaDist.LazyMode

Proprietà SalvaDistLazyMode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Proprietà SalvaDist.MultiLevel

Proprietà SalvaDistMultiLevel

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Proprietà SalvaDist.SaveDistOnApproved

Proprietà SalvaDistSaveDistOnApproved

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SaveDistOnApproved { get; set; }
Public Property SaveDistOnApproved As Boolean
    Get
    Set
public:
property bool SaveDistOnApproved {
    bool get ();
    void set (bool value);
}
member SaveDistOnApproved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Metodi di SalvaDist

Il tipo SalvaDist espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Metodo SalvaDist.ClearCommand

Metodo SalvaDistClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Metodo SalvaDist.ExecuteCommand

Metodo SalvaDistExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Metodo SalvaDist.SwEnabled

Metodo SalvaDistSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Metodo SalvaDist.SwSetContext

Metodo SalvaDistSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetSw.Commands


Classe SalvaMultiplo
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSalvaMultiplo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaMultiplo : SwCommandBase
Public Class SalvaMultiplo
    Inherits SwCommandBase
public ref class SalvaMultiplo : public SwCommandBase
type SalvaMultiplo =
    class
        inherit SwCommandBase
    end

Il tipo SalvaMultiplo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SalvaMultiplo

Il tipo SalvaMultiplo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Proprietà SalvaMultiplo.NeedParameters

Proprietà SalvaMultiploNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Metodi di SalvaMultiplo

Il tipo SalvaMultiplo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Metodo SalvaMultiplo.ClearCommand

Metodo SalvaMultiploClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Metodo SalvaMultiplo.ExecuteCommand

Metodo SalvaMultiploExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Metodo SalvaMultiplo.SwEnabled

Metodo SalvaMultiploSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Metodo SalvaMultiplo.SwSetContext

Metodo SalvaMultiploSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetSw.Commands


Classe SalvaRev
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSalvaRev

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaRev : SwCommandBase
Public Class SalvaRev
    Inherits SwCommandBase
public ref class SalvaRev : public SwCommandBase
type SalvaRev =
    class
        inherit SwCommandBase
    end

Il tipo SalvaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurData |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceAll |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RevCommand |
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SalvaRev

Il tipo SalvaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurData |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsSavePrt |
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceAll |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RevCommand |
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SwComp |
Proprietà pubblica | SwConf |
Proprietà pubblica | SwDoc |
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopDocument |
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.CurData

Proprietà SalvaRevCurData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData CurData { get; }
Public ReadOnly Property CurData As DedData
    Get
public:
property DedData^ CurData {
    DedData^ get ();
}
member CurData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.IsSavePrt

Proprietà SalvaRevIsSavePrt

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; }
Public ReadOnly Property IsSavePrt As Boolean
    Get
public:
property bool IsSavePrt {
    bool get ();
}
member IsSavePrt : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.NeedParameters

Proprietà SalvaRevNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.NewData

Proprietà SalvaRevNewData

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.ReplaceAll

Proprietà SalvaRevReplaceAll

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}
member ReplaceAll : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.RevCommand

Proprietà SalvaRevRevCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RevCommand RevCommand { get; set; }
Public Property RevCommand As RevCommand
    Get
    Set
public:
property RevCommand^ RevCommand {
    RevCommand^ get ();
    void set (RevCommand^ value);
}
member RevCommand : RevCommand with get, set

Valore della proprietà

RevCommand
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.SwComp

Proprietà SalvaRevSwComp

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IComponent2 SwComp { get; set; }
Public Property SwComp As IComponent2
    Get
    Set
public:
property IComponent2^ SwComp {
    IComponent2^ get ();
    void set (IComponent2^ value);
}
member SwComp : IComponent2 with get, set

Valore della proprietà

IComponent2
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.SwConf

Proprietà SalvaRevSwConf

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SwConf { get; set; }
Public Property SwConf As String
    Get
    Set
public:
property String^ SwConf {
    String^ get ();
    void set (String^ value);
}
member SwConf : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.SwDoc

Proprietà SalvaRevSwDoc

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 SwDoc { get; set; }
Public Property SwDoc As IModelDoc2
    Get
    Set
public:
property IModelDoc2^ SwDoc {
    IModelDoc2^ get ();
    void set (IModelDoc2^ value);
}
member SwDoc : IModelDoc2 with get, set

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Proprietà SalvaRev.TopDocument

Proprietà SalvaRevTopDocument

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IModelDoc2 TopDocument { get; }
Public ReadOnly Property TopDocument As IModelDoc2
    Get
public:
property IModelDoc2^ TopDocument {
    IModelDoc2^ get ();
}
member TopDocument : IModelDoc2 with get

Valore della proprietà

IModelDoc2
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodi di SalvaRev

Il tipo SalvaRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object))
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString)
Torna su
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.ClearCommand

Metodo SalvaRevClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.Equals

Metodo SalvaRevEquals

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.ExecuteCommand

Metodo SalvaRevExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.GetHashCode

Metodo SalvaRevGetHashCode

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.SwEnabled

Metodo SalvaRevSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.SwSetContext

Metodo SalvaRevSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Metodo SalvaRev.ToString

Metodo SalvaRevToString

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetSw.Commands


Classe SalvaSuperato
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsCambiaStato
DedNetSw.CommandsSalvaSuperato

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaSuperato : CambiaStato
Public Class SalvaSuperato
    Inherits CambiaStato
public ref class SalvaSuperato : public CambiaStato
type SalvaSuperato =
    class
        inherit CambiaStato
    end

Il tipo SalvaSuperato espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SalvaSuperato |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Costruttore SalvaSuperato

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SalvaSuperato(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
SalvaSuperato(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> SalvaSuperato

Parametri

app DedNetApplication
internalName String
displayName String
multiple Boolean
Vedi anche

Documentazione

Classe SalvaSuperato
Namespace DedNetSw.Commands


Proprietà di SalvaSuperato

Il tipo SalvaSuperato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | (Ereditato da CambiaStato)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Multiplo | (Ereditato da CambiaStato)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaSuperato
Namespace DedNetSw.Commands


Metodi di SalvaSuperato

Il tipo SalvaSuperato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da CambiaStato)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Ereditato da CambiaStato)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Ereditato da CambiaStato)
Metodo pubblico | SwSetContext | (Ereditato da CambiaStato)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SalvaSuperato
Namespace DedNetSw.Commands


Classe Sblocca
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSblocca

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Sblocca : SwCommandBase
Public Class Sblocca
    Inherits SwCommandBase
public ref class Sblocca : public SwCommandBase
type Sblocca =
    class
        inherit SwCommandBase
    end

Il tipo Sblocca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di Sblocca

Il tipo Sblocca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Proprietà Sblocca.NeedParameters

Proprietà SbloccaNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Metodi di Sblocca

Il tipo Sblocca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Metodo Sblocca.ClearCommand

Metodo SbloccaClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Metodo Sblocca.ExecuteCommand

Metodo SbloccaExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Metodo Sblocca.SwEnabled

Metodo SbloccaSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Metodo Sblocca.SwSetContext

Metodo SbloccaSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetSw.Commands


Classe SostituisciComponente
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSostituisciComponente

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciComponente : SwCommandBase
Public Class SostituisciComponente
    Inherits SwCommandBase
public ref class SostituisciComponente : public SwCommandBase
type SostituisciComponente =
    class
        inherit SwCommandBase
    end

Il tipo SostituisciComponente espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SostituisciComponente

Il tipo SostituisciComponente espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Proprietà SostituisciComponente.DocInfo

Proprietà SostituisciComponenteDocInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Proprietà SostituisciComponente.NeedParameters

Proprietà SostituisciComponenteNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Metodi di SostituisciComponente

Il tipo SostituisciComponente espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Metodo SostituisciComponente.ClearCommand

Metodo SostituisciComponenteClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Metodo SostituisciComponente.ExecuteCommand

Metodo SostituisciComponenteExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Metodo SostituisciComponente.SwEnabled

Metodo SostituisciComponenteSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Metodo SostituisciComponente.SwSetContext

Metodo SostituisciComponenteSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetSw.Commands


Classe SostituisciComponenteRapido
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSostituisciComponenteRapido

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciComponenteRapido : SwCommandBase
Public Class SostituisciComponenteRapido
    Inherits SwCommandBase
public ref class SostituisciComponenteRapido : public SwCommandBase
type SostituisciComponenteRapido =
    class
        inherit SwCommandBase
    end

Il tipo SostituisciComponenteRapido espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceAll |
Proprietà pubblica | ReplaceAllSameParent |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SostituisciComponenteRapido

Il tipo SostituisciComponenteRapido espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceAll |
Proprietà pubblica | ReplaceAllSameParent |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Proprietà SostituisciComponenteRapido.DocInfo

Proprietà SostituisciComponenteRapidoDocInfo

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Proprietà SostituisciComponenteRapido.NeedParameters

Proprietà SostituisciComponenteRapidoNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Proprietà SostituisciComponenteRapido.ReplaceAll

Proprietà SostituisciComponenteRapidoReplaceAll

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}
member ReplaceAll : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Proprietà SostituisciComponenteRapido.ReplaceAllSameParent

Proprietà SostituisciComponenteRapidoReplaceAllSameParent

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAllSameParent { get; set; }
Public Property ReplaceAllSameParent As Boolean
    Get
    Set
public:
property bool ReplaceAllSameParent {
    bool get ();
    void set (bool value);
}
member ReplaceAllSameParent : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodi di SostituisciComponenteRapido

Il tipo SostituisciComponenteRapido espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Sovrascrive SwCommandBaseEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive SwCommandBaseSetContext(DedCommandContext))
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodo SostituisciComponenteRapido.ClearCommand

Metodo SostituisciComponenteRapidoClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodo SostituisciComponenteRapido.Enabled

Metodo SostituisciComponenteRapidoEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodo SostituisciComponenteRapido.ExecuteCommand

Metodo SostituisciComponenteRapidoExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodo SostituisciComponenteRapido.SetContext

Metodo SostituisciComponenteRapidoSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodo SostituisciComponenteRapido.SwEnabled

Metodo SostituisciComponenteRapidoSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Metodo SostituisciComponenteRapido.SwSetContext

Metodo SostituisciComponenteRapidoSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetSw.Commands


Classe SostituisciMoved
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSostituisciMoved

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciMoved : SwCommandBase
Public Class SostituisciMoved
    Inherits SwCommandBase
public ref class SostituisciMoved : public SwCommandBase
type SostituisciMoved =
    class
        inherit SwCommandBase
    end

Il tipo SostituisciMoved espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SostituisciMoved

Il tipo SostituisciMoved espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Proprietà SostituisciMoved.NeedParameters

Proprietà SostituisciMovedNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Metodi di SostituisciMoved

Il tipo SostituisciMoved espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Metodo SostituisciMoved.ClearCommand

Metodo SostituisciMovedClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Metodo SostituisciMoved.ExecuteCommand

Metodo SostituisciMovedExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Metodo SostituisciMoved.SwEnabled

Metodo SostituisciMovedSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Metodo SostituisciMoved.SwSetContext

Metodo SostituisciMovedSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetSw.Commands


Classe StatoDocumento
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsStatoDocumento

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class StatoDocumento : SwCommandBase
Public Class StatoDocumento
    Inherits SwCommandBase
public ref class StatoDocumento : public SwCommandBase
type StatoDocumento =
    class
        inherit SwCommandBase
    end

Il tipo StatoDocumento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di StatoDocumento

Il tipo StatoDocumento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetSw.Commands


Metodi di StatoDocumento

Il tipo StatoDocumento espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetSw.Commands


Metodo StatoDocumento.ClearCommand

Metodo StatoDocumentoClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetSw.Commands


Metodo StatoDocumento.ExecuteCommand

Metodo StatoDocumentoExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetSw.Commands


Metodo StatoDocumento.SwEnabled

Metodo StatoDocumentoSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetSw.Commands


Metodo StatoDocumento.SwSetContext

Metodo StatoDocumentoSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetSw.Commands


Classe SwDataStatisticsAnalyzer
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSwDataStatisticsAnalyzer

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwDataStatisticsAnalyzer : SwCommandBase
Public Class SwDataStatisticsAnalyzer
    Inherits SwCommandBase
public ref class SwDataStatisticsAnalyzer : public SwCommandBase
type SwDataStatisticsAnalyzer =
    class
        inherit SwCommandBase
    end

Il tipo SwDataStatisticsAnalyzer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SwDataStatisticsAnalyzer

Il tipo SwDataStatisticsAnalyzer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SwDataStatisticsAnalyzer
Namespace DedNetSw.Commands


Metodi di SwDataStatisticsAnalyzer

Il tipo SwDataStatisticsAnalyzer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SwDataStatisticsAnalyzer
Namespace DedNetSw.Commands


Metodo SwDataStatisticsAnalyzer.ClearCommand

Metodo SwDataStatisticsAnalyzerClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SwDataStatisticsAnalyzer
Namespace DedNetSw.Commands


Metodo SwDataStatisticsAnalyzer.ExecuteCommand

Metodo SwDataStatisticsAnalyzerExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SwDataStatisticsAnalyzer
Namespace DedNetSw.Commands


Metodo SwDataStatisticsAnalyzer.SwEnabled

Metodo SwDataStatisticsAnalyzerSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwDataStatisticsAnalyzer
Namespace DedNetSw.Commands


Metodo SwDataStatisticsAnalyzer.SwSetContext

Metodo SwDataStatisticsAnalyzerSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwDataStatisticsAnalyzer
Namespace DedNetSw.Commands


Classe SwUserLogin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsSwUserLogin

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SwUserLogin : SwCommandBase
Public Class SwUserLogin
    Inherits SwCommandBase
public ref class SwUserLogin : public SwCommandBase
type SwUserLogin =
    class
        inherit SwCommandBase
    end

Il tipo SwUserLogin espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di SwUserLogin

Il tipo SwUserLogin espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SwUserLogin
Namespace DedNetSw.Commands


Metodi di SwUserLogin

Il tipo SwUserLogin espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SwUserLogin
Namespace DedNetSw.Commands


Metodo SwUserLogin.ExecuteCommand

Metodo SwUserLoginExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SwUserLogin
Namespace DedNetSw.Commands


Metodo SwUserLogin.SwEnabled

Metodo SwUserLoginSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwUserLogin
Namespace DedNetSw.Commands


Metodo SwUserLogin.SwSetContext

Metodo SwUserLoginSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SwUserLogin
Namespace DedNetSw.Commands


Classe TabellaRevisioni
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsTabellaRevisioni

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class TabellaRevisioni : SwCommandBase
Public Class TabellaRevisioni
    Inherits SwCommandBase
public ref class TabellaRevisioni : public SwCommandBase
type TabellaRevisioni =
    class
        inherit SwCommandBase
    end

Il tipo TabellaRevisioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di TabellaRevisioni

Il tipo TabellaRevisioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Proprietà TabellaRevisioni.NeedParameters

Proprietà TabellaRevisioniNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Metodi di TabellaRevisioni

Il tipo TabellaRevisioni espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Metodo TabellaRevisioni.ClearCommand

Metodo TabellaRevisioniClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Metodo TabellaRevisioni.ExecuteCommand

Metodo TabellaRevisioniExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Metodo TabellaRevisioni.SwEnabled

Metodo TabellaRevisioniSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Metodo TabellaRevisioni.SwSetContext

Metodo TabellaRevisioniSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetSw.Commands


Classe UpdateBranchInformations
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsUpdateBranchInformations

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateBranchInformations : SwCommandBase
Public Class UpdateBranchInformations
    Inherits SwCommandBase
public ref class UpdateBranchInformations : public SwCommandBase
type UpdateBranchInformations =
    class
        inherit SwCommandBase
    end

Il tipo UpdateBranchInformations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di UpdateBranchInformations

Il tipo UpdateBranchInformations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Ereditato da SwCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetSw.Commands


Metodi di UpdateBranchInformations

Il tipo UpdateBranchInformations espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Ereditato da SwCommandBase)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetSw.Commands


Metodo UpdateBranchInformations.ExecuteCommand

Metodo UpdateBranchInformationsExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetSw.Commands


Metodo UpdateBranchInformations.SwEnabled

Metodo UpdateBranchInformationsSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext invCmdCtx
)
Public Overrides Function SwEnabled (
    invCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ invCmdCtx
) override
abstract SwEnabled :
        invCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        invCmdCtx : DedSwCommandContext -> bool

Parametri

invCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetSw.Commands


Metodo UpdateBranchInformations.SwSetContext

Metodo UpdateBranchInformationsSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext invCmdCtx
)
Public Overrides Function SwSetContext (
    invCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ invCmdCtx
) override
abstract SwSetContext :
        invCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        invCmdCtx : DedSwCommandContext -> bool

Parametri

invCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetSw.Commands


Classe UpdateOldRev
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsUpdateOldRev

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateOldRev : SwCommandBase
Public Class UpdateOldRev
    Inherits SwCommandBase
public ref class UpdateOldRev : public SwCommandBase
type UpdateOldRev =
    class
        inherit SwCommandBase
    end

Il tipo UpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di UpdateOldRev

Il tipo UpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Proprietà UpdateOldRev.NeedParameters

Proprietà UpdateOldRevNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Metodi di UpdateOldRev

Il tipo UpdateOldRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Metodo UpdateOldRev.ClearCommand

Metodo UpdateOldRevClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Metodo UpdateOldRev.ExecuteCommand

Metodo UpdateOldRevExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Metodo UpdateOldRev.SwEnabled

Metodo UpdateOldRevSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Metodo UpdateOldRev.SwSetContext

Metodo UpdateOldRevSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetSw.Commands


Classe WhereUsedSw
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetSwSwCommandBase
DedNetSw.CommandsWhereUsedSw

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class WhereUsedSw : SwCommandBase
Public Class WhereUsedSw
    Inherits SwCommandBase
public ref class WhereUsedSw : public SwCommandBase
type WhereUsedSw =
    class
        inherit SwCommandBase
    end

Il tipo WhereUsedSw espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Commands


Proprietà di WhereUsedSw

Il tipo WhereUsedSw espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | (Ereditato da SwCommandBase)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IconIdx | (Ereditato da SwCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive SwCommandBaseNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowInDocumentType | (Ereditato da SwCommandBase)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | (Ereditato da SwCommandBase)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


Proprietà WhereUsedSw.NeedParameters

Proprietà WhereUsedSwNeedParameters

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


Metodi di WhereUsedSw

Il tipo WhereUsedSw espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive SwCommandBaseClearCommand)
Metodo pubblico | Enabled | (Ereditato da SwCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo pubblico | Execute | (Ereditato da SwCommandBase)
Metodo protetto | ExecuteCommand | (Sovrascrive SwCommandBaseExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Ereditato da SwCommandBase)
Metodo pubblico | SwEnabled | (Sovrascrive SwCommandBaseSwEnabled(DedSwCommandContext))
Metodo pubblico | SwSetContext | (Sovrascrive SwCommandBaseSwSetContext(DedSwCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


Metodo WhereUsedSw.ClearCommand

Metodo WhereUsedSwClearCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


Metodo WhereUsedSw.ExecuteCommand

Metodo WhereUsedSwExecuteCommand

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


Metodo WhereUsedSw.SwEnabled

Metodo WhereUsedSwSwEnabled

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwEnabled(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwEnabled (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwEnabled(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool
override SwEnabled :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


Metodo WhereUsedSw.SwSetContext

Metodo WhereUsedSwSwSetContext

Namespace: DedNetSw.Commands
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SwSetContext(
    DedSwCommandContext swCmdCtx
)
Public Overrides Function SwSetContext (
    swCmdCtx As DedSwCommandContext
) As Boolean
public:
virtual bool SwSetContext(
    DedSwCommandContext^ swCmdCtx
) override
abstract SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool
override SwSetContext :
        swCmdCtx : DedSwCommandContext -> bool

Parametri

swCmdCtx DedSwCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe WhereUsedSw
Namespace DedNetSw.Commands


DedNetSw.Forms Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedSwPackAndGoExportForm |
Classe pubblica | DedSwPackAndGoImportForm |
Classe pubblica | DedSwPackAndGoImportFormObjectSeriarizable |
Classe pubblica | DedSwSaveMulipleForm |
Classe pubblica | DedSwSaveMulipleFormMultiSaverModeCriteria |
Classe pubblica | DedSwSaveMulipleFormMultiSaverModeCriteriaList |
Classe pubblica | DedSwSaveMulipleFormMultiSaverNodeDescriptor |
Classe pubblica | DedSwSaveMulipleFormMultiSaverNodeDescriptors |
Classe pubblica | ModifyingDocumentsForm |
Classe pubblica | MultipleStateOperation |
Classe pubblica | OpenOptionsForm |
Delegate
 | Delegate | Descrizione
Delegate pubblico | DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate |
Delegate pubblico | DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate |
Delegate pubblico | MultipleStateOperationOperationDelagateHandler |


Classe DedSwPackAndGoExportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSw.FormsDedSwPackAndGoExportForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedSwPackAndGoExportForm : BaseForm
Public Class DedSwPackAndGoExportForm
    Inherits BaseForm
public ref class DedSwPackAndGoExportForm : public BaseForm
type DedSwPackAndGoExportForm =
    class
        inherit BaseForm
    end

Il tipo DedSwPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Proprietà di DedSwPackAndGoExportForm

Il tipo DedSwPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoExportForm
Namespace DedNetSw.Forms


Metodi di DedSwPackAndGoExportForm

Il tipo DedSwPackAndGoExportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoExportForm
Namespace DedNetSw.Forms


Metodo DedSwPackAndGoExportForm.Dispose

Metodo DedSwPackAndGoExportFormDispose

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe DedSwPackAndGoExportForm
Namespace DedNetSw.Forms


Eventi di DedSwPackAndGoExportForm

Il tipo DedSwPackAndGoExportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoExportForm
Namespace DedNetSw.Forms


Campi di DedSwPackAndGoExportForm

Il tipo DedSwPackAndGoExportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoExportForm
Namespace DedNetSw.Forms


Classe DedSwPackAndGoImportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSw.FormsDedSwPackAndGoImportForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedSwPackAndGoImportForm : BaseForm
Public Class DedSwPackAndGoImportForm
    Inherits BaseForm
public ref class DedSwPackAndGoImportForm : public BaseForm
type DedSwPackAndGoImportForm =
    class
        inherit BaseForm
    end

Il tipo DedSwPackAndGoImportForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwPackAndGoImportForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo pubblico | DeSerializeXml |
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _fileWithCfg |
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwPackAndGoImportForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwPackAndGoImportForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedSwPackAndGoImportForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedSwPackAndGoImportForm

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Proprietà di DedSwPackAndGoImportForm

Il tipo DedSwPackAndGoImportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Metodi di DedSwPackAndGoImportForm

Il tipo DedSwPackAndGoImportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo pubblico | DeSerializeXml |
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Metodo DedSwPackAndGoImportForm.DeSerializeXml

Metodo DedSwPackAndGoImportFormDeSerializeXml

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor DeSerializeXml(
    string fn
)
Public Function DeSerializeXml (
    fn As String
) As PackAndGoStructureDescriptor
public:
PackAndGoStructureDescriptor^ DeSerializeXml(
    String^ fn
)
member DeSerializeXml :
        fn : string -> PackAndGoStructureDescriptor

Parametri

fn String

Valore di ritorno

PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Metodo DedSwPackAndGoImportForm.Dispose

Metodo DedSwPackAndGoImportFormDispose

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Eventi di DedSwPackAndGoImportForm

Il tipo DedSwPackAndGoImportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Campi di DedSwPackAndGoImportForm

Il tipo DedSwPackAndGoImportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _fileWithCfg |
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Campo DedSwPackAndGoImportForm._fileWithCfg

Campo DedSwPackAndGoImportForm_fileWithCfg

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> _fileWithCfg
Public _fileWithCfg As List(Of String)
public:
List<String^>^ _fileWithCfg
val mutable _fileWithCfg: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportForm
Namespace DedNetSw.Forms


Classe DedSwPackAndGoImportForm.ObjectSeriarizable

Classe DedSwPackAndGoImportFormObjectSeriarizable
Gerarchia di ereditarietà
SystemObject
DedNetSw.FormsDedSwPackAndGoImportFormObjectSeriarizable

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ObjectSeriarizable
Public Class ObjectSeriarizable
public ref class ObjectSeriarizable
type ObjectSeriarizable = class end

Il tipo DedSwPackAndGoImportFormObjectSeriarizable espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwPackAndGoImportFormObjectSeriarizable |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Checked |
Proprietà pubblica | Config |
Proprietà pubblica | DbIndexData |
Proprietà pubblica | DbIndexDoc |
Proprietà pubblica | Dbpath |
Proprietà pubblica | DestRoot |
Proprietà pubblica | FullFileName |
Proprietà pubblica | Infouser |
Proprietà pubblica | Operation |
Proprietà pubblica | Progr |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwPackAndGoImportForm.ObjectSeriarizable

Costruttore DedSwPackAndGoImportFormObjectSeriarizable

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ObjectSeriarizable()
Public Sub New
public:
ObjectSeriarizable()
new : unit -> ObjectSeriarizable
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà di ObjectSeriarizable

Il tipo DedSwPackAndGoImportFormObjectSeriarizable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Checked |
Proprietà pubblica | Config |
Proprietà pubblica | DbIndexData |
Proprietà pubblica | DbIndexDoc |
Proprietà pubblica | Dbpath |
Proprietà pubblica | DestRoot |
Proprietà pubblica | FullFileName |
Proprietà pubblica | Infouser |
Proprietà pubblica | Operation |
Proprietà pubblica | Progr |
Torna su
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.Checked

Proprietà DedSwPackAndGoImportFormObjectSeriarizableChecked

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.Config

Proprietà DedSwPackAndGoImportFormObjectSeriarizableConfig

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.DbIndexData

Proprietà DedSwPackAndGoImportFormObjectSeriarizableDbIndexData

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbIndexData { get; set; }
Public Property DbIndexData As String
    Get
    Set
public:
property String^ DbIndexData {
    String^ get ();
    void set (String^ value);
}
member DbIndexData : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.DbIndexDoc

Proprietà DedSwPackAndGoImportFormObjectSeriarizableDbIndexDoc

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DbIndexDoc { get; set; }
Public Property DbIndexDoc As Guid
    Get
    Set
public:
property Guid DbIndexDoc {
    Guid get ();
    void set (Guid value);
}
member DbIndexDoc : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.Dbpath

Proprietà DedSwPackAndGoImportFormObjectSeriarizableDbpath

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Dbpath { get; set; }
Public Property Dbpath As String
    Get
    Set
public:
property String^ Dbpath {
    String^ get ();
    void set (String^ value);
}
member Dbpath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.DestRoot

Proprietà DedSwPackAndGoImportFormObjectSeriarizableDestRoot

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.FullFileName

Proprietà DedSwPackAndGoImportFormObjectSeriarizableFullFileName

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.Infouser

Proprietà DedSwPackAndGoImportFormObjectSeriarizableInfouser

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Infouser { get; set; }
Public Property Infouser As String
    Get
    Set
public:
property String^ Infouser {
    String^ get ();
    void set (String^ value);
}
member Infouser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.Operation

Proprietà DedSwPackAndGoImportFormObjectSeriarizableOperation

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Operation { get; set; }
Public Property Operation As String
    Get
    Set
public:
property String^ Operation {
    String^ get ();
    void set (String^ value);
}
member Operation : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Proprietà DedSwPackAndGoImportForm.ObjectSeriarizable.Progr

Proprietà DedSwPackAndGoImportFormObjectSeriarizableProgr

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwPackAndGoImportFormObjectSeriarizable
Namespace DedNetSw.Forms


Classe DedSwSaveMulipleForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSw.FormsDedSwSaveMulipleForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedSwSaveMulipleForm : BaseForm
Public Class DedSwSaveMulipleForm
    Inherits BaseForm
public ref class DedSwSaveMulipleForm : public BaseForm
type DedSwSaveMulipleForm =
    class
        inherit BaseForm
    end

Il tipo DedSwSaveMulipleForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwSaveMulipleForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommandException |
Proprietà pubblica | CommandResult |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CriteriaList |
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo pubblico | SetCheckNodeForSameStructInfo |
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwSaveMulipleForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleForm(
    DedNetApplication app,
    DocStructInfoList dsList,
    SwCurSelInfo swSelInfo
)
Public Sub New (
    app As DedNetApplication,
    dsList As DocStructInfoList,
    swSelInfo As SwCurSelInfo
)
public:
DedSwSaveMulipleForm(
    DedNetApplication^ app,
    DocStructInfoList^ dsList,
    SwCurSelInfo^ swSelInfo
)
new :
        app : DedNetApplication *
        dsList : DocStructInfoList *
        swSelInfo : SwCurSelInfo -> DedSwSaveMulipleForm

Parametri

app DedNetApplication
dsList DocStructInfoList
swSelInfo SwCurSelInfo
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Proprietà di DedSwSaveMulipleForm

Il tipo DedSwSaveMulipleForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommandException |
Proprietà pubblica | CommandResult |
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CriteriaList |
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.CommandException

Proprietà DedSwSaveMulipleFormCommandException

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Exception CommandException { get; }
Public ReadOnly Property CommandException As Exception
    Get
public:
property Exception^ CommandException {
    Exception^ get ();
}
member CommandException : Exception with get

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.CommandResult

Proprietà DedSwSaveMulipleFormCommandResult

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult CommandResult { get; }
Public ReadOnly Property CommandResult As DedCmdResult
    Get
public:
property DedCmdResult CommandResult {
    DedCmdResult get ();
}
member CommandResult : DedCmdResult with get

Valore della proprietà

DedCmdResult
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.CriteriaList

Proprietà DedSwSaveMulipleFormCriteriaList

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteriaList CriteriaList { get; }
Public ReadOnly Property CriteriaList As DedSwSaveMulipleFormMultiSaverModeCriteriaList
    Get
public:
property DedSwSaveMulipleFormMultiSaverModeCriteriaList^ CriteriaList {
    DedSwSaveMulipleFormMultiSaverModeCriteriaList^ get ();
}
member CriteriaList : DedSwSaveMulipleFormMultiSaverModeCriteriaList with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverModeCriteriaList
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Metodi di DedSwSaveMulipleForm

Il tipo DedSwSaveMulipleForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo pubblico | SetCheckNodeForSameStructInfo |
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.Dispose

Metodo DedSwSaveMulipleFormDispose

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.SetCheckNodeForSameStructInfo

Metodo DedSwSaveMulipleFormSetCheckNodeForSameStructInfo

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckNodeForSameStructInfo(
    bool value,
    SwDocStructInfo invDsInfo,
    TreeListNodes nodes
)
Public Sub SetCheckNodeForSameStructInfo (
    value As Boolean,
    invDsInfo As SwDocStructInfo,
    nodes As TreeListNodes
)
public:
void SetCheckNodeForSameStructInfo(
    bool value,
    SwDocStructInfo^ invDsInfo,
    TreeListNodes^ nodes
)
member SetCheckNodeForSameStructInfo :
        value : bool *
        invDsInfo : SwDocStructInfo *
        nodes : TreeListNodes -> unit

Parametri

value Boolean
invDsInfo SwDocStructInfo
nodes TreeListNodes
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Eventi di DedSwSaveMulipleForm

Il tipo DedSwSaveMulipleForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Campi di DedSwSaveMulipleForm

Il tipo DedSwSaveMulipleForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleForm
Namespace DedNetSw.Forms


Classe DedSwSaveMulipleForm.MultiSaverModeCriteria

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Gerarchia di ereditarietà
SystemObject
DedNetSw.FormsDedSwSaveMulipleFormMultiSaverModeCriteria

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverModeCriteria
Public Class MultiSaverModeCriteria
public ref class MultiSaverModeCriteria
type MultiSaverModeCriteria = class end

Il tipo DedSwSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwSaveMulipleFormMultiSaverModeCriteria |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActionCheckableControl |
Proprietà pubblica | CustomFormControl |
Proprietà pubblica | CustomLuaActionCheckableControl |
Proprietà pubblica | CustomUncheckedOnLoadControl |
Proprietà pubblica | Description |
Proprietà pubblica | EnableOkButtonRules |
Proprietà pubblica | Name |
Proprietà pubblica | RequireGenericDbType |
Proprietà pubblica | RequireSpecificDbType |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IsCheckable |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UncheckedOnLoad |
Torna su
Operatori
Nome | Descrizione
Equality(DedSwSaveMulipleFormMultiSaverModeCriteria, DedSwSaveMulipleFormMultiSaverModeCriteria) |
Inequality(DedSwSaveMulipleFormMultiSaverModeCriteria, DedSwSaveMulipleFormMultiSaverModeCriteria) |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwSaveMulipleForm.MultiSaverModeCriteria

Costruttore DedSwSaveMulipleFormMultiSaverModeCriteria

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverModeCriteria(
    string name
)
Public Sub New (
    name As String
)
public:
MultiSaverModeCriteria(
    String^ name
)
new :
        name : string -> MultiSaverModeCriteria

Parametri

name String
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà di MultiSaverModeCriteria

Il tipo DedSwSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActionCheckableControl |
Proprietà pubblica | CustomFormControl |
Proprietà pubblica | CustomLuaActionCheckableControl |
Proprietà pubblica | CustomUncheckedOnLoadControl |
Proprietà pubblica | Description |
Proprietà pubblica | EnableOkButtonRules |
Proprietà pubblica | Name |
Proprietà pubblica | RequireGenericDbType |
Proprietà pubblica | RequireSpecificDbType |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.ActionCheckableControl

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaActionCheckableControl

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate ActionCheckableControl { get; set; }
Public Property ActionCheckableControl As DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate
    Get
    Set
public:
property DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate^ ActionCheckableControl {
    DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate^ get ();
    void set (DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate^ value);
}
member ActionCheckableControl : DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate with get, set

Valore della proprietà

DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.CustomFormControl

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaCustomFormControl

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Control CustomFormControl { get; set; }
Public Property CustomFormControl As Control
    Get
    Set
public:
property Control^ CustomFormControl {
    Control^ get ();
    void set (Control^ value);
}
member CustomFormControl : Control with get, set

Valore della proprietà

Control
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.CustomLuaActionCheckableControl

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaCustomLuaActionCheckableControl

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaFunction CustomLuaActionCheckableControl { get; set; }
Public Property CustomLuaActionCheckableControl As LuaFunction
    Get
    Set
public:
property LuaFunction^ CustomLuaActionCheckableControl {
    LuaFunction^ get ();
    void set (LuaFunction^ value);
}
member CustomLuaActionCheckableControl : LuaFunction with get, set

Valore della proprietà

LuaFunction
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.CustomUncheckedOnLoadControl

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaCustomUncheckedOnLoadControl

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaFunction CustomUncheckedOnLoadControl { get; set; }
Public Property CustomUncheckedOnLoadControl As LuaFunction
    Get
    Set
public:
property LuaFunction^ CustomUncheckedOnLoadControl {
    LuaFunction^ get ();
    void set (LuaFunction^ value);
}
member CustomUncheckedOnLoadControl : LuaFunction with get, set

Valore della proprietà

LuaFunction
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.Description

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaDescription

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.EnableOkButtonRules

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonRules

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate EnableOkButtonRules { get; set; }
Public Property EnableOkButtonRules As DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate
    Get
    Set
public:
property DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate^ EnableOkButtonRules {
    DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate^ get ();
    void set (DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate^ value);
}
member EnableOkButtonRules : DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate with get, set

Valore della proprietà

DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.Name

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaName

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.RequireGenericDbType

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaRequireGenericDbType

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RequireGenericDbType { get; set; }
Public Property RequireGenericDbType As Boolean
    Get
    Set
public:
property bool RequireGenericDbType {
    bool get ();
    void set (bool value);
}
member RequireGenericDbType : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverModeCriteria.RequireSpecificDbType

Proprietà DedSwSaveMulipleFormMultiSaverModeCriteriaRequireSpecificDbType

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RequireSpecificDbType { get; set; }
Public Property RequireSpecificDbType As Boolean
    Get
    Set
public:
property bool RequireSpecificDbType {
    bool get ();
    void set (bool value);
}
member RequireSpecificDbType : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Metodi di MultiSaverModeCriteria

Il tipo DedSwSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IsCheckable |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UncheckedOnLoad |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverModeCriteria.Equals

Metodo DedSwSaveMulipleFormMultiSaverModeCriteriaEquals

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverModeCriteria.GetHashCode

Metodo DedSwSaveMulipleFormMultiSaverModeCriteriaGetHashCode

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverModeCriteria.IsCheckable

Metodo DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckable

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckable(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor msNd
)
Public Function IsCheckable (
    msNd As DedSwSaveMulipleFormMultiSaverNodeDescriptor
) As Boolean
public:
bool IsCheckable(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ msNd
)
member IsCheckable :
        msNd : DedSwSaveMulipleFormMultiSaverNodeDescriptor -> bool

Parametri

msNd DedSwSaveMulipleFormMultiSaverNodeDescriptor

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverModeCriteria.ToString

Metodo DedSwSaveMulipleFormMultiSaverModeCriteriaToString

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverModeCriteria.UncheckedOnLoad

Metodo DedSwSaveMulipleFormMultiSaverModeCriteriaUncheckedOnLoad

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UncheckedOnLoad(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor msNd
)
Public Function UncheckedOnLoad (
    msNd As DedSwSaveMulipleFormMultiSaverNodeDescriptor
) As Boolean
public:
bool UncheckedOnLoad(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ msNd
)
member UncheckedOnLoad :
        msNd : DedSwSaveMulipleFormMultiSaverNodeDescriptor -> bool

Parametri

msNd DedSwSaveMulipleFormMultiSaverNodeDescriptor

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


MultiSaverModeCriteria Operators

Il tipo DedSwSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(DedSwSaveMulipleFormMultiSaverModeCriteria, DedSwSaveMulipleFormMultiSaverModeCriteria) |
Inequality(DedSwSaveMulipleFormMultiSaverModeCriteria, DedSwSaveMulipleFormMultiSaverModeCriteria) |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


DedSwSaveMulipleForm.MultiSaverModeCriteria.Equality Operatore

DedSwSaveMulipleFormMultiSaverModeCriteriaEquality Operatore

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    DedSwSaveMulipleFormMultiSaverModeCriteria a,
    DedSwSaveMulipleFormMultiSaverModeCriteria b
)
Public Shared Operator = (
    a As DedSwSaveMulipleFormMultiSaverModeCriteria,
    b As DedSwSaveMulipleFormMultiSaverModeCriteria
) As Boolean
public:
static bool operator ==(
    DedSwSaveMulipleFormMultiSaverModeCriteria^ a,
    DedSwSaveMulipleFormMultiSaverModeCriteria^ b
)
static let inline (=)
        a : DedSwSaveMulipleFormMultiSaverModeCriteria *
        b : DedSwSaveMulipleFormMultiSaverModeCriteria  : bool

Parametri

a DedSwSaveMulipleFormMultiSaverModeCriteria
b DedSwSaveMulipleFormMultiSaverModeCriteria

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


DedSwSaveMulipleForm.MultiSaverModeCriteria.Inequality Operatore

DedSwSaveMulipleFormMultiSaverModeCriteriaInequality Operatore

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    DedSwSaveMulipleFormMultiSaverModeCriteria a,
    DedSwSaveMulipleFormMultiSaverModeCriteria b
)
Public Shared Operator <> (
    a As DedSwSaveMulipleFormMultiSaverModeCriteria,
    b As DedSwSaveMulipleFormMultiSaverModeCriteria
) As Boolean
public:
static bool operator !=(
    DedSwSaveMulipleFormMultiSaverModeCriteria^ a,
    DedSwSaveMulipleFormMultiSaverModeCriteria^ b
)
static let inline (<>)
        a : DedSwSaveMulipleFormMultiSaverModeCriteria *
        b : DedSwSaveMulipleFormMultiSaverModeCriteria  : bool

Parametri

a DedSwSaveMulipleFormMultiSaverModeCriteria
b DedSwSaveMulipleFormMultiSaverModeCriteria

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetSw.Forms


Delegate DedSwSaveMulipleForm.MultiSaverModeCriteria.EnableOkButtonDelegate

Delegate DedSwSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate bool EnableOkButtonDelegate(
    TreeListNodes refNodes
)
Public Delegate Function EnableOkButtonDelegate (
    refNodes As TreeListNodes
) As Boolean
public delegate bool EnableOkButtonDelegate(
    TreeListNodes^ refNodes
)
type EnableOkButtonDelegate =
    delegate of
        refNodes : TreeListNodes -> bool

Parametri

refNodes TreeListNodes

Valore di ritorno

Boolean
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Delegate DedSwSaveMulipleForm.MultiSaverModeCriteria.IsCheckableDelegate

Delegate DedSwSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate bool IsCheckableDelegate(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor msNd
)
Public Delegate Function IsCheckableDelegate (
    msNd As DedSwSaveMulipleFormMultiSaverNodeDescriptor
) As Boolean
public delegate bool IsCheckableDelegate(
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ msNd
)
type IsCheckableDelegate =
    delegate of
        msNd : DedSwSaveMulipleFormMultiSaverNodeDescriptor -> bool

Parametri

msNd DedSwSaveMulipleFormMultiSaverNodeDescriptor

Valore di ritorno

Boolean
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Classe DedSwSaveMulipleForm.MultiSaverModeCriteriaList

Classe DedSwSaveMulipleFormMultiSaverModeCriteriaList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedSwSaveMulipleFormMultiSaverModeCriteria
DedNetSw.FormsDedSwSaveMulipleFormMultiSaverModeCriteriaList

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverModeCriteriaList : List<DedSwSaveMulipleFormMultiSaverModeCriteria>
Public Class MultiSaverModeCriteriaList
    Inherits List(Of DedSwSaveMulipleFormMultiSaverModeCriteria)
public ref class MultiSaverModeCriteriaList : public List<DedSwSaveMulipleFormMultiSaverModeCriteria^>
type MultiSaverModeCriteriaList =
    class
        inherit List<DedSwSaveMulipleFormMultiSaverModeCriteria>
    end

Il tipo DedSwSaveMulipleFormMultiSaverModeCriteriaList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwSaveMulipleFormMultiSaverModeCriteriaList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CreateMultiSaverModeCriteria |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwSaveMulipleForm.MultiSaverModeCriteriaList

Costruttore DedSwSaveMulipleFormMultiSaverModeCriteriaList

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverModeCriteriaList()
Public Sub New
public:
MultiSaverModeCriteriaList()
new : unit -> MultiSaverModeCriteriaList
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteriaList
Namespace DedNetSw.Forms


Metodi di MultiSaverModeCriteriaList

Il tipo DedSwSaveMulipleFormMultiSaverModeCriteriaList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CreateMultiSaverModeCriteria |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteriaList
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverModeCriteriaList.CreateMultiSaverModeCriteria

Metodo DedSwSaveMulipleFormMultiSaverModeCriteriaListCreateMultiSaverModeCriteria

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverModeCriteria CreateMultiSaverModeCriteria(
    string name
)
Public Function CreateMultiSaverModeCriteria (
    name As String
) As DedSwSaveMulipleFormMultiSaverModeCriteria
public:
DedSwSaveMulipleFormMultiSaverModeCriteria^ CreateMultiSaverModeCriteria(
    String^ name
)
member CreateMultiSaverModeCriteria :
        name : string -> DedSwSaveMulipleFormMultiSaverModeCriteria

Parametri

name String

Valore di ritorno

DedSwSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverModeCriteriaList
Namespace DedNetSw.Forms


Classe DedSwSaveMulipleForm.MultiSaverNodeDescriptor

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Gerarchia di ereditarietà
SystemObject
DedNetSw.FormsDedSwSaveMulipleFormMultiSaverNodeDescriptor

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverNodeDescriptor
Public Class MultiSaverNodeDescriptor
public ref class MultiSaverNodeDescriptor
type MultiSaverNodeDescriptor = class end

Il tipo DedSwSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwSaveMulipleFormMultiSaverNodeDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrEdited |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | Elaborated |
Proprietà pubblica | ElaborationIsGood |
Proprietà pubblica | HasParentDescriptor |
Proprietà pubblica | IsCheckable |
Proprietà pubblica | Mdres |
Proprietà pubblica | Node |
Proprietà pubblica | OccurredParentErrors |
Proprietà pubblica | Parent |
Proprietà pubblica | ParentDescriptor |
Proprietà pubblica | SelectedDbType |
Proprietà pubblica | SkipChildren |
Proprietà pubblica | StatusMessage |
Proprietà pubblica | UncheckedOnLoad |
Proprietà pubblica | UserUnchecked |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | LoadExceptionIfExists |
Metodo pubblico | RecomputeCheckability |
Metodo pubblico | SetAttrEdited |
Metodo pubblico | SetCheckedStatus |
Metodo pubblico | SetDocumentOperation |
Metodo pubblico | SetOverridedDbType |
Metodo pubblico | UpdateElaborationStatus |
Torna su
Eventi
Nome | Descrizione
UserUncheckedChanged |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwSaveMulipleForm.MultiSaverNodeDescriptor

Costruttore DedSwSaveMulipleFormMultiSaverNodeDescriptor

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverNodeDescriptor(
    SwDocStructInfo ds,
    DedSwSaveMulipleForm commandForm,
    TreeListNode parentNode
)
Public Sub New (
    ds As SwDocStructInfo,
    commandForm As DedSwSaveMulipleForm,
    parentNode As TreeListNode
)
public:
MultiSaverNodeDescriptor(
    SwDocStructInfo^ ds,
    DedSwSaveMulipleForm^ commandForm,
    TreeListNode^ parentNode
)
new :
        ds : SwDocStructInfo *
        commandForm : DedSwSaveMulipleForm *
        parentNode : TreeListNode -> MultiSaverNodeDescriptor

Parametri

ds SwDocStructInfo
commandForm DedSwSaveMulipleForm
parentNode TreeListNode
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà di MultiSaverNodeDescriptor

Il tipo DedSwSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrEdited |
Proprietà pubblica | DocStructInfo |
Proprietà pubblica | Elaborated |
Proprietà pubblica | ElaborationIsGood |
Proprietà pubblica | HasParentDescriptor |
Proprietà pubblica | IsCheckable |
Proprietà pubblica | Mdres |
Proprietà pubblica | Node |
Proprietà pubblica | OccurredParentErrors |
Proprietà pubblica | Parent |
Proprietà pubblica | ParentDescriptor |
Proprietà pubblica | SelectedDbType |
Proprietà pubblica | SkipChildren |
Proprietà pubblica | StatusMessage |
Proprietà pubblica | UncheckedOnLoad |
Proprietà pubblica | UserUnchecked |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.AttrEdited

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorAttrEdited

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart AttrEdited { get; set; }
Public Property AttrEdited As DedDataPart
    Get
    Set
public:
property DedDataPart^ AttrEdited {
    DedDataPart^ get ();
    void set (DedDataPart^ value);
}
member AttrEdited : DedDataPart with get, set

Valore della proprietà

DedDataPart
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.DocStructInfo

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorDocStructInfo

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SwDocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As SwDocStructInfo
    Get
public:
property SwDocStructInfo^ DocStructInfo {
    SwDocStructInfo^ get ();
}
member DocStructInfo : SwDocStructInfo with get

Valore della proprietà

SwDocStructInfo
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.Elaborated

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorElaborated

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Elaborated { get; set; }
Public Property Elaborated As Boolean
    Get
    Set
public:
property bool Elaborated {
    bool get ();
    void set (bool value);
}
member Elaborated : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.ElaborationIsGood

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorElaborationIsGood

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ElaborationIsGood { get; set; }
Public Property ElaborationIsGood As Boolean
    Get
    Set
public:
property bool ElaborationIsGood {
    bool get ();
    void set (bool value);
}
member ElaborationIsGood : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.HasParentDescriptor

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorHasParentDescriptor

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasParentDescriptor { get; }
Public ReadOnly Property HasParentDescriptor As Boolean
    Get
public:
property bool HasParentDescriptor {
    bool get ();
}
member HasParentDescriptor : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.IsCheckable

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorIsCheckable

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckable { get; }
Public ReadOnly Property IsCheckable As Boolean
    Get
public:
property bool IsCheckable {
    bool get ();
}
member IsCheckable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.Mdres

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorMdres

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.Node

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorNode

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; }
Public ReadOnly Property Node As TreeListNode
    Get
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
}
member Node : TreeListNode with get

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.OccurredParentErrors

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorOccurredParentErrors

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OccurredParentErrors { get; }
Public ReadOnly Property OccurredParentErrors As Boolean
    Get
public:
property bool OccurredParentErrors {
    bool get ();
}
member OccurredParentErrors : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.Parent

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorParent

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Parent { get; }
Public ReadOnly Property Parent As TreeListNode
    Get
public:
property TreeListNode^ Parent {
    TreeListNode^ get ();
}
member Parent : TreeListNode with get

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.ParentDescriptor

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorParentDescriptor

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedSwSaveMulipleFormMultiSaverNodeDescriptor ParentDescriptor { get; }
Public ReadOnly Property ParentDescriptor As DedSwSaveMulipleFormMultiSaverNodeDescriptor
    Get
public:
property DedSwSaveMulipleFormMultiSaverNodeDescriptor^ ParentDescriptor {
    DedSwSaveMulipleFormMultiSaverNodeDescriptor^ get ();
}
member ParentDescriptor : DedSwSaveMulipleFormMultiSaverNodeDescriptor with get

Valore della proprietà

DedSwSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.SelectedDbType

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorSelectedDbType

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectedDbType { get; set; }
Public Property SelectedDbType As DedType
    Get
    Set
public:
property DedType^ SelectedDbType {
    DedType^ get ();
    void set (DedType^ value);
}
member SelectedDbType : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.SkipChildren

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorSkipChildren

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipChildren { get; set; }
Public Property SkipChildren As Boolean
    Get
    Set
public:
property bool SkipChildren {
    bool get ();
    void set (bool value);
}
member SkipChildren : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.StatusMessage

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorStatusMessage

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string StatusMessage { get; set; }
Public Property StatusMessage As String
    Get
    Set
public:
property String^ StatusMessage {
    String^ get ();
    void set (String^ value);
}
member StatusMessage : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.UncheckedOnLoad

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorUncheckedOnLoad

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UncheckedOnLoad { get; }
Public ReadOnly Property UncheckedOnLoad As Boolean
    Get
public:
property bool UncheckedOnLoad {
    bool get ();
}
member UncheckedOnLoad : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Proprietà DedSwSaveMulipleForm.MultiSaverNodeDescriptor.UserUnchecked

Proprietà DedSwSaveMulipleFormMultiSaverNodeDescriptorUserUnchecked

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UserUnchecked { get; set; }
Public Property UserUnchecked As Boolean
    Get
    Set
public:
property bool UserUnchecked {
    bool get ();
    void set (bool value);
}
member UserUnchecked : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodi di MultiSaverNodeDescriptor

Il tipo DedSwSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | LoadExceptionIfExists |
Metodo pubblico | RecomputeCheckability |
Metodo pubblico | SetAttrEdited |
Metodo pubblico | SetCheckedStatus |
Metodo pubblico | SetDocumentOperation |
Metodo pubblico | SetOverridedDbType |
Metodo pubblico | UpdateElaborationStatus |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.LoadExceptionIfExists

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorLoadExceptionIfExists

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadExceptionIfExists()
Public Sub LoadExceptionIfExists
public:
void LoadExceptionIfExists()
member LoadExceptionIfExists : unit -> unit
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.RecomputeCheckability

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorRecomputeCheckability

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RecomputeCheckability()
Public Sub RecomputeCheckability
public:
void RecomputeCheckability()
member RecomputeCheckability : unit -> unit
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.SetAttrEdited

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorSetAttrEdited

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetAttrEdited(
    DedDataPart attrEdited,
    bool evaluateSameStructInfo = true
)
Public Sub SetAttrEdited (
    attrEdited As DedDataPart,
    Optional evaluateSameStructInfo As Boolean = true
)
public:
void SetAttrEdited(
    DedDataPart^ attrEdited,
    bool evaluateSameStructInfo = true
)
member SetAttrEdited :
        attrEdited : DedDataPart *
        ?evaluateSameStructInfo : bool
(* Defaults:
        let _evaluateSameStructInfo = defaultArg evaluateSameStructInfo true
*)
-> unit

Parametri

attrEdited DedDataPart
evaluateSameStructInfo Boolean (Optional)
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.SetCheckedStatus

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorSetCheckedStatus

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckedStatus(
    bool value
)
Public Sub SetCheckedStatus (
    value As Boolean
)
public:
void SetCheckedStatus(
    bool value
)
member SetCheckedStatus :
        value : bool -> unit

Parametri

value Boolean
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.SetDocumentOperation

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorSetDocumentOperation

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetDocumentOperation(
    bool copy,
    bool evaluateSameStructInfo = true
)
Public Sub SetDocumentOperation (
    copy As Boolean,
    Optional evaluateSameStructInfo As Boolean = true
)
public:
void SetDocumentOperation(
    bool copy,
    bool evaluateSameStructInfo = true
)
member SetDocumentOperation :
        copy : bool *
        ?evaluateSameStructInfo : bool
(* Defaults:
        let _evaluateSameStructInfo = defaultArg evaluateSameStructInfo true
*)
-> unit

Parametri

copy Boolean
evaluateSameStructInfo Boolean (Optional)
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.SetOverridedDbType

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorSetOverridedDbType

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetOverridedDbType(
    DedType dbType,
    bool evaluateSameStructInfo = true
)
Public Sub SetOverridedDbType (
    dbType As DedType,
    Optional evaluateSameStructInfo As Boolean = true
)
public:
void SetOverridedDbType(
    DedType^ dbType,
    bool evaluateSameStructInfo = true
)
member SetOverridedDbType :
        dbType : DedType *
        ?evaluateSameStructInfo : bool
(* Defaults:
        let _evaluateSameStructInfo = defaultArg evaluateSameStructInfo true
*)
-> unit

Parametri

dbType DedType
evaluateSameStructInfo Boolean (Optional)
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptor.UpdateElaborationStatus

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorUpdateElaborationStatus

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void UpdateElaborationStatus(
    string msg,
    bool elaborationIsGood = true
)
Public Sub UpdateElaborationStatus (
    msg As String,
    Optional elaborationIsGood As Boolean = true
)
public:
void UpdateElaborationStatus(
    String^ msg,
    bool elaborationIsGood = true
)
member UpdateElaborationStatus :
        msg : string *
        ?elaborationIsGood : bool
(* Defaults:
        let _elaborationIsGood = defaultArg elaborationIsGood true
*)
-> unit

Parametri

msg String
elaborationIsGood Boolean (Optional)
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Eventi di MultiSaverNodeDescriptor

Il tipo DedSwSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Eventi
Nome | Descrizione
UserUncheckedChanged |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Evento DedSwSaveMulipleForm.MultiSaverNodeDescriptor.UserUncheckedChanged

Evento DedSwSaveMulipleFormMultiSaverNodeDescriptorUserUncheckedChanged

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler UserUncheckedChanged
Public Shared Event UserUncheckedChanged As EventHandler
public:
static  event EventHandler^ UserUncheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member UserUncheckedChanged : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetSw.Forms


Classe DedSwSaveMulipleForm.MultiSaverNodeDescriptors

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptors
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedSwSaveMulipleFormMultiSaverNodeDescriptor
DedNetSw.FormsDedSwSaveMulipleFormMultiSaverNodeDescriptors

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverNodeDescriptors : List<DedSwSaveMulipleFormMultiSaverNodeDescriptor>
Public Class MultiSaverNodeDescriptors
    Inherits List(Of DedSwSaveMulipleFormMultiSaverNodeDescriptor)
public ref class MultiSaverNodeDescriptors : public List<DedSwSaveMulipleFormMultiSaverNodeDescriptor^>
type MultiSaverNodeDescriptors =
    class
        inherit List<DedSwSaveMulipleFormMultiSaverNodeDescriptor>
    end

Il tipo DedSwSaveMulipleFormMultiSaverNodeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSwSaveMulipleFormMultiSaverNodeDescriptors |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Sort |
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore DedSwSaveMulipleForm.MultiSaverNodeDescriptors

Costruttore DedSwSaveMulipleFormMultiSaverNodeDescriptors

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverNodeDescriptors()
Public Sub New
public:
MultiSaverNodeDescriptors()
new : unit -> MultiSaverNodeDescriptors
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptors
Namespace DedNetSw.Forms


Metodi di MultiSaverNodeDescriptors

Il tipo DedSwSaveMulipleFormMultiSaverNodeDescriptors espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Sort |
Torna su
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptors
Namespace DedNetSw.Forms


Metodo DedSwSaveMulipleForm.MultiSaverNodeDescriptors.Sort

Metodo DedSwSaveMulipleFormMultiSaverNodeDescriptorsSort

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Sort()
Public Sub Sort
public:
void Sort()
member Sort : unit -> unit
Vedi anche

Documentazione

Classe DedSwSaveMulipleFormMultiSaverNodeDescriptors
Namespace DedNetSw.Forms


Classe ModifyingDocumentsForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSw.FormsModifyingDocumentsForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentsForm : BaseForm
Public Class ModifyingDocumentsForm
    Inherits BaseForm
public ref class ModifyingDocumentsForm : public BaseForm
type ModifyingDocumentsForm =
    class
        inherit BaseForm
    end

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentsForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | Ask |
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | Editable |
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | Label |
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | ModList |
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ReloadDocMode |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo pubblico | CanSelectRow |
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | ClearSelection |
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawCheckBox |
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo pubblico | SelectAll |
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore ModifyingDocumentsForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentsForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
ModifyingDocumentsForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> ModifyingDocumentsForm

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Proprietà di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | Ask |
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | Editable |
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | Label |
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | ModList |
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ReloadDocMode |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Proprietà ModifyingDocumentsForm.Ask

Proprietà ModifyingDocumentsFormAsk

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Ask { get; set; }
Public Property Ask As Boolean
    Get
    Set
public:
property bool Ask {
    bool get ();
    void set (bool value);
}
member Ask : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Proprietà ModifyingDocumentsForm.Editable

Proprietà ModifyingDocumentsFormEditable

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Proprietà ModifyingDocumentsForm.Label

Proprietà ModifyingDocumentsFormLabel

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Proprietà ModifyingDocumentsForm.ModList

Proprietà ModifyingDocumentsFormModList

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList ModList { get; set; }
Public Property ModList As ModifyingDocumentInfoList
    Get
    Set
public:
property ModifyingDocumentInfoList^ ModList {
    ModifyingDocumentInfoList^ get ();
    void set (ModifyingDocumentInfoList^ value);
}
member ModList : ModifyingDocumentInfoList with get, set

Valore della proprietà

ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Proprietà ModifyingDocumentsForm.ReloadDocMode

Proprietà ModifyingDocumentsFormReloadDocMode

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReloadDocMode { get; set; }
Public Property ReloadDocMode As Boolean
    Get
    Set
public:
property bool ReloadDocMode {
    bool get ();
    void set (bool value);
}
member ReloadDocMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Metodi di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo pubblico | CanSelectRow |
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | ClearSelection |
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawCheckBox |
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo pubblico | SelectAll |
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Metodo ModifyingDocumentsForm.CanSelectRow

Metodo ModifyingDocumentsFormCanSelectRow

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CanSelectRow(
    int rowHandle
)
Public Function CanSelectRow (
    rowHandle As Integer
) As Boolean
public:
bool CanSelectRow(
    int rowHandle
)
member CanSelectRow :
        rowHandle : int -> bool

Parametri

rowHandle Int32

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Metodo ModifyingDocumentsForm.ClearSelection

Metodo ModifyingDocumentsFormClearSelection

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ClearSelection()
Public Sub ClearSelection
public:
void ClearSelection()
member ClearSelection : unit -> unit
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Metodo ModifyingDocumentsForm.Dispose

Metodo ModifyingDocumentsFormDispose

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Metodo ModifyingDocumentsForm.DrawCheckBox

Metodo ModifyingDocumentsFormDrawCheckBox

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void DrawCheckBox(
    Graphics g,
    Rectangle r,
    bool Checked
)
Protected Sub DrawCheckBox (
    g As Graphics,
    r As Rectangle,
    Checked As Boolean
)
protected:
void DrawCheckBox(
    Graphics^ g,
    Rectangle r,
    bool Checked
)
member DrawCheckBox :
        g : Graphics *
        r : Rectangle *
        Checked : bool -> unit

Parametri

g Graphics
r Rectangle
Checked Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Metodo ModifyingDocumentsForm.SelectAll

Metodo ModifyingDocumentsFormSelectAll

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Eventi di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Campi di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetSw.Forms


Classe MultipleStateOperation
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSw.FormsMultipleStateOperation

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultipleStateOperation : BaseForm
Public Class MultipleStateOperation
    Inherits BaseForm
public ref class MultipleStateOperation : public BaseForm
type MultipleStateOperation =
    class
        inherit BaseForm
    end

Il tipo MultipleStateOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateOperation |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | ChangeStateNote |
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OperationDelegate |
Proprietà pubblica | Res |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySettings |
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings |
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
 | _stateIndex |
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore MultipleStateOperation

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperation(
    DedNetApplication app,
    DedState operation,
    SwDocStructInfo ds,
    Icon cmdIcon
)
Public Sub New (
    app As DedNetApplication,
    operation As DedState,
    ds As SwDocStructInfo,
    cmdIcon As Icon
)
public:
MultipleStateOperation(
    DedNetApplication^ app,
    DedState^ operation,
    SwDocStructInfo^ ds,
    Icon^ cmdIcon
)
new :
        app : DedNetApplication *
        operation : DedState *
        ds : SwDocStructInfo *
        cmdIcon : Icon -> MultipleStateOperation

Parametri

app DedNetApplication
operation DedState
ds SwDocStructInfo
cmdIcon Icon
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Proprietà di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | ChangeStateNote |
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OperationDelegate |
Proprietà pubblica | Res |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Proprietà MultipleStateOperation.ChangeStateNote

Proprietà MultipleStateOperationChangeStateNote

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ChangeStateNote { get; set; }
Public Property ChangeStateNote As String
    Get
    Set
public:
property String^ ChangeStateNote {
    String^ get ();
    void set (String^ value);
}
member ChangeStateNote : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Proprietà MultipleStateOperation.OperationDelegate

Proprietà MultipleStateOperationOperationDelegate

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperationOperationDelagateHandler OperationDelegate { get; set; }
Public Property OperationDelegate As MultipleStateOperationOperationDelagateHandler
    Get
    Set
public:
property MultipleStateOperationOperationDelagateHandler^ OperationDelegate {
    MultipleStateOperationOperationDelagateHandler^ get ();
    void set (MultipleStateOperationOperationDelagateHandler^ value);
}
member OperationDelegate : MultipleStateOperationOperationDelagateHandler with get, set

Valore della proprietà

MultipleStateOperationOperationDelagateHandler
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Proprietà MultipleStateOperation.Res

Proprietà MultipleStateOperationRes

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult Res { get; }
Public ReadOnly Property Res As DedCmdResult
    Get
public:
property DedCmdResult Res {
    DedCmdResult get ();
}
member Res : DedCmdResult with get

Valore della proprietà

DedCmdResult
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Metodi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySettings |
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings |
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Metodo MultipleStateOperation.Dispose

Metodo MultipleStateOperationDispose

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Metodo MultipleStateOperation.LoadRegistrySettings

Metodo MultipleStateOperationLoadRegistrySettings

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings()
Public Sub LoadRegistrySettings
public:
void LoadRegistrySettings()
member LoadRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Metodo MultipleStateOperation.SaveRegistrySettings

Metodo MultipleStateOperationSaveRegistrySettings

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Eventi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Campi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Campi
 | Nome | Descrizione
 | _stateIndex |
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Campo MultipleStateOperation._stateIndex

Campo MultipleStateOperation_stateIndex

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, int> _stateIndex
Public Shared _stateIndex As Dictionary(Of String, Integer)
public:
static Dictionary<String^, int>^ _stateIndex
static val mutable _stateIndex: Dictionary<string, int>

Valore del campo

Dictionary String, Int32
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetSw.Forms


Delegate MultipleStateOperation.OperationDelagateHandler

Delegate MultipleStateOperationOperationDelagateHandler

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate DedCmdResult OperationDelagateHandler(
    DedState targetState,
    string changeNote,
    SwDocStructInfo swMainDsInfo,
    SwDocStructInfo swDsInfo,
    bool isChildOperation,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Delegate Function OperationDelagateHandler (
    targetState As DedState,
    changeNote As String,
    swMainDsInfo As SwDocStructInfo,
    swDsInfo As SwDocStructInfo,
    isChildOperation As Boolean,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public delegate DedCmdResult OperationDelagateHandler(
    DedState^ targetState,
    String^ changeNote,
    SwDocStructInfo^ swMainDsInfo,
    SwDocStructInfo^ swDsInfo,
    bool isChildOperation,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
type OperationDelagateHandler =
    delegate of
        targetState : DedState *
        changeNote : string *
        swMainDsInfo : SwDocStructInfo *
        swDsInfo : SwDocStructInfo *
        isChildOperation : bool *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState DedState
changeNote String
swMainDsInfo SwDocStructInfo
swDsInfo SwDocStructInfo
isChildOperation Boolean
multiplo Boolean
message String
pubExtList List Exception

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Classe OpenOptionsForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetSw.FormsOpenOptionsForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OpenOptionsForm : BaseForm
Public Class OpenOptionsForm
    Inherits BaseForm
public ref class OpenOptionsForm : public BaseForm
type OpenOptionsForm =
    class
        inherit BaseForm
    end

Il tipo OpenOptionsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OpenOptionsForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OpenDocParams |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNetSw.Forms


Costruttore OpenOptionsForm

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OpenOptionsForm(
    string filename,
    DedNetApplication app
)
Public Sub New (
    filename As String,
    app As DedNetApplication
)
public:
OpenOptionsForm(
    String^ filename,
    DedNetApplication^ app
)
new :
        filename : string *
        app : DedNetApplication -> OpenOptionsForm

Parametri

filename String
app DedNetApplication
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms


Proprietà di OpenOptionsForm

Il tipo OpenOptionsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OpenDocParams |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms


Proprietà OpenOptionsForm.OpenDocParams

Proprietà OpenOptionsFormOpenDocParams

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentSpecification OpenDocParams { get; }
Public ReadOnly Property OpenDocParams As DocumentSpecification
    Get
public:
property DocumentSpecification^ OpenDocParams {
    DocumentSpecification^ get ();
}
member OpenDocParams : DocumentSpecification with get

Valore della proprietà

DocumentSpecification
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms


Metodi di OpenOptionsForm

Il tipo OpenOptionsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | (Sovrascrive BaseForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms


Metodo OpenOptionsForm.Dispose

Metodo OpenOptionsFormDispose

Namespace: DedNetSw.Forms
Assembly: DedNetSw (in DedNetSw.dll) Versione: 26.4.0.0 (26.4.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms


Eventi di OpenOptionsForm

Il tipo OpenOptionsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms


Campi di OpenOptionsForm

Il tipo OpenOptionsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OpenOptionsForm
Namespace DedNetSw.Forms