DedNetConnector Namespace
Classes
 | Class | Description
Public class | DedCustomItemBom | Classe usata per creare gli oggetti di distinta personalizzati.
Public class | DedDataLight | Oggetto rappresentante un'anagrafica del DataAndDrawings.
Public class | DedDocLight | Oggetto rappresentante un documento del DataAndDrawings.
Public class | DedNetConnectorCommands | Classe che espone all'esterno i vari comandi per interoperare con il software DataAndDrawings.
Public class | Utility | Classe contenente metodi di uso generale.
Enumerations
 | Enumeration | Description
Public enumeration | DedBomContext | Tipo di contesto del legame di distinta
Public enumeration | DedDataDocContext | Enum dei possibili contesti di associazione documento/anagrafica

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


DedBomContext Enumeration
Tipo di contesto del legame di distinta

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DedBomContext
Public Enumeration DedBomContext
public enum class DedBomContext
type DedBomContext
Members
Member name | Value | Description
Cad | 0 |
Manual | 1 |
See Also

Reference

DedNetConnector Namespace


DedCustomItemBom Class
Classe usata per creare gli oggetti di distinta personalizzati.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Object
DedNetConnectorDedCustomItemBom

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DedCustomItemBom : Dictionary<string, Object>
Public Class DedCustomItemBom
    Inherits Dictionary(Of String, Object)
public ref class DedCustomItemBom : public Dictionary<String^, Object^>
type DedCustomItemBom =
    class
        inherit Dictionary<string, Object>
    end

The DedCustomItemBom type exposes the following members.

Constructors
 | Name | Description
Public method | DedCustomItemBom(String) | Costruttore dedicato all'inizializzazione del campo 'Code'. I campi 'Rev' e 'QTA' vengono inizializzati con i valori di default ("" e 1).
Public method | DedCustomItemBom(String, Double) | Costruttore dedicato all'inizializzazione dei campo 'Code' e 'QTA'. Il campo 'Rev' viene inizializzato con il valore di default ("").
Public method | DedCustomItemBom(String, String) | Costruttore dedicato all'inizializzazione dei campo 'Code' e 'Rev'. Il campo 'QTA' viene inizializzato con il valore di default (1).
Public method | DedCustomItemBom(String, String, Double) | Costruttore dedicato all'inizializzazione dei campi 'Code', 'Rev' e 'QTA'.
Top
Properties
 | Name | Description
Public property | Code | Codice dell'elemento da riportare in distinta.
Public property | Qta | Quantità dell'elemento da riportare in distinta.
Public property | Rev | Revisione dell'elemento da riportare in distinta.
Top
Methods
 | Name | Description
Public method | Add | Metodo che aggiunge, al dizionario interno, l'accoppiata Attributo/Valore. Se l'attributo passato in ingresso è 'QTA', anzichè creare un apposita accopiata viene settata la relativa proprietà.
Top
See Also

Reference

DedNetConnector Namespace

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


DedCustomItemBom Constructor
Overload List
 | Name | Description
Public method | DedCustomItemBom(String) | Costruttore dedicato all'inizializzazione del campo 'Code'. I campi 'Rev' e 'QTA' vengono inizializzati con i valori di default ("" e 1).
Public method | DedCustomItemBom(String, Double) | Costruttore dedicato all'inizializzazione dei campo 'Code' e 'QTA'. Il campo 'Rev' viene inizializzato con il valore di default ("").
Public method | DedCustomItemBom(String, String) | Costruttore dedicato all'inizializzazione dei campo 'Code' e 'Rev'. Il campo 'QTA' viene inizializzato con il valore di default (1).
Public method | DedCustomItemBom(String, String, Double) | Costruttore dedicato all'inizializzazione dei campi 'Code', 'Rev' e 'QTA'.
Top
See Also

Reference

DedCustomItemBom Class


DedCustomItemBom(String) Constructor
Costruttore dedicato all'inizializzazione del campo 'Code'. I campi 'Rev' e 'QTA' vengono inizializzati con i valori di default ("" e 1).

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedCustomItemBom(
    string code
)
Public Sub New (
    code As String
)
public:
DedCustomItemBom(
    String^ code
)
new :
        code : string -> DedCustomItemBom

Parameters

code String
Codice del sotto elemento da riportare in distinta (non può essere null altrimenti verrà generata un'eccezione).
See Also

Reference

DedCustomItemBom Class
DedCustomItemBom Overload


DedCustomItemBom(String, Double) Constructor
Costruttore dedicato all'inizializzazione dei campo 'Code' e 'QTA'. Il campo 'Rev' viene inizializzato con il valore di default ("").

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedCustomItemBom(
    string code,
    double qta
)
Public Sub New (
    code As String,
    qta As Double
)
public:
DedCustomItemBom(
    String^ code,
    double qta
)
new :
        code : string *
        qta : float -> DedCustomItemBom

Parameters

code String
Codice del sotto elemento da riportare in distinta (non può essere null altrimenti verrà generata un'eccezione).
qta Double
Quantità del sotto elemento da riportare in distinta (non può essere minore di 1 altrimenti verrà generata un'eccezione).
See Also

Reference

DedCustomItemBom Class
DedCustomItemBom Overload


DedCustomItemBom(String, String) Constructor
Costruttore dedicato all'inizializzazione dei campo 'Code' e 'Rev'. Il campo 'QTA' viene inizializzato con il valore di default (1).

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedCustomItemBom(
    string code,
    string rev
)
Public Sub New (
    code As String,
    rev As String
)
public:
DedCustomItemBom(
    String^ code,
    String^ rev
)
new :
        code : string *
        rev : string -> DedCustomItemBom

Parameters

code String
Codice del sotto elemento da riportare in distinta (non può essere null altrimenti verrà generata un'eccezione).
rev String
Revisione del sotto elemento da riportare in distinta (non può essere null altrimenti verrà generata un'eccezione).
See Also

Reference

DedCustomItemBom Class
DedCustomItemBom Overload


DedCustomItemBom(String, String, Double) Constructor
Costruttore dedicato all'inizializzazione dei campi 'Code', 'Rev' e 'QTA'.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedCustomItemBom(
    string code,
    string rev,
    double qta
)
Public Sub New (
    code As String,
    rev As String,
    qta As Double
)
public:
DedCustomItemBom(
    String^ code,
    String^ rev,
    double qta
)
new :
        code : string *
        rev : string *
        qta : float -> DedCustomItemBom

Parameters

code String
Codice del sotto elemento da riportare in distinta (non può essere null altrimenti verrà generata un'eccezione).
rev String
Revisione del sotto elemento da riportare in distinta (non può essere null altrimenti verrà generata un'eccezione).
qta Double
Quantità del sotto elemento da riportare in distinta (non può essere minore di 1 altrimenti verrà generata un'eccezione).
See Also

Reference

DedCustomItemBom Class
DedCustomItemBom Overload


DedCustomItemBom Properties

The DedCustomItemBom type exposes the following members.

Properties
 | Name | Description
Public property | Code | Codice dell'elemento da riportare in distinta.
Public property | Qta | Quantità dell'elemento da riportare in distinta.
Public property | Rev | Revisione dell'elemento da riportare in distinta.
Top
See Also

Reference

DedCustomItemBom Class


DedCustomItemBom.Code Property

Libreria DedNetConnector

DedCustomItemBomCode Property
Codice dell'elemento da riportare in distinta.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get
public:
property String^ Code {
    String^ get ();
}
member Code : string with get

Property Value

String
See Also

Reference

DedCustomItemBom Class


DedCustomItemBom.Qta Property

DedCustomItemBomQta Property
Quantità dell'elemento da riportare in distinta.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Property Value

Double
See Also

Reference

DedCustomItemBom Class


DedCustomItemBom.Rev Property

DedCustomItemBomRev Property
Revisione dell'elemento da riportare in distinta.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Rev { get; }
Public ReadOnly Property Rev As String
    Get
public:
property String^ Rev {
    String^ get ();
}
member Rev : string with get

Property Value

String
See Also

Reference

DedCustomItemBom Class


DedCustomItemBom Methods

The DedCustomItemBom type exposes the following members.

Methods
 | Name | Description
Public method | Add | Metodo che aggiunge, al dizionario interno, l'accoppiata Attributo/Valore. Se l'attributo passato in ingresso è 'QTA', anzichè creare un apposita accopiata viene settata la relativa proprietà.
Top
See Also

Reference

DedCustomItemBom Class


DedCustomItemBom.Add Method

DedCustomItemBomAdd Method
Metodo che aggiunge, al dizionario interno, l'accoppiata Attributo/Valore. Se l'attributo passato in ingresso è 'QTA', anzichè creare un apposita accopiata viene settata la relativa proprietà.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string attr,
    Object value
)
Public Sub Add (
    attr As String,
    value As Object
)
public:
void Add(
    String^ attr,
    Object^ value
)
member Add :
        attr : string *
        value : Object -> unit

Parameters

attr String
Attributo da aggiungere.
value Object
Valore da aggiungere.
See Also

Reference

DedCustomItemBom Class


DedDataDocContext Enumeration
Enum dei possibili contesti di associazione documento/anagrafica

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DedDataDocContext
Public Enumeration DedDataDocContext
public enum class DedDataDocContext
type DedDataDocContext
Members
Member name | Value | Description
Allegato | 0 |
Modello | 1 |
Pubblicazione | 2 |
See Also

Reference

DedNetConnector Namespace

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


DedDataLight Class
Oggetto rappresentante un'anagrafica del DataAndDrawings.
Inheritance Hierarchy
SystemObject
DedNetConnectorDedDataLight

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DedDataLight
Public Class DedDataLight
public ref class DedDataLight
type DedDataLight = class end

The DedDataLight type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultFullFileName | Ritorna il filename di default di un file associata all'anagrafica. Il file ha una estensione neutra esemplificativa.
Public method | GetValueAttr | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.
Public method | GetValueAttrByPrompt | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome visualizzato dell'attributo.
Top
See Also

Reference

DedNetConnector Namespace

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


DedDataLight Methods

The DedDataLight type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultFullFileName | Ritorna il filename di default di un file associata all'anagrafica. Il file ha una estensione neutra esemplificativa.
Public method | GetValueAttr | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.
Public method | GetValueAttrByPrompt | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome visualizzato dell'attributo.
Top
See Also

Reference

DedDataLight Class


DedDataLight.GetDefaultFullFileName Method

DedDataLightGetDefaultFullFileName Method
Ritorna il filename di default di un file associata all'anagrafica. Il file ha una estensione neutra esemplificativa.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDefaultFullFileName(
    bool isPrimary = true
)
Public Function GetDefaultFullFileName (
    Optional isPrimary As Boolean = true
) As String
public:
String^ GetDefaultFullFileName(
    bool isPrimary = true
)
member GetDefaultFullFileName :
        ?isPrimary : bool
(* Defaults:
        let _isPrimary = defaultArg isPrimary true
*)
-> string

Parameters

isPrimary Boolean (Optional)
Determina se il contesto è primario o allegato

Return Value

String
See Also

Reference

DedDataLight Class


DedDataLight.GetValueAttr Method

DedDataLightGetValueAttr Method
Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object GetValueAttr(
    string attr
)
Public Function GetValueAttr (
    attr As String
) As Object
public:
Object^ GetValueAttr(
    String^ attr
)
member GetValueAttr :
        attr : string -> Object

Parameters

attr String
Nome dell'atributo da cui prelevare il valore. Deve essere il nome effettivo e non quello visualizzato.

Return Value

Object
Tipo: 'System.Object'; Valore dell'attributo.
See Also

Reference

DedDataLight Class


DedDataLight.GetValueAttrByPrompt Method

DedDataLightGetValueAttrByPrompt Method
Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome visualizzato dell'attributo.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object GetValueAttrByPrompt(
    string prompt
)
Public Function GetValueAttrByPrompt (
    prompt As String
) As Object
public:
Object^ GetValueAttrByPrompt(
    String^ prompt
)
member GetValueAttrByPrompt :
        prompt : string -> Object

Parameters

prompt String
Nome visualizzato dell'atributo da cui prelevare il valore. Deve essere il nome visualizzato e non quello effettivo.

Return Value

Object
Tipo: 'System.Object'; Valore dell'attributo.
See Also

Reference

DedDataLight Class


DedDocLight Class
Oggetto rappresentante un documento del DataAndDrawings.
Inheritance Hierarchy
SystemObject
DedNetConnectorDedDocLight

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DedDocLight
Public Class DedDocLight
public ref class DedDocLight
type DedDocLight = class end

The DedDocLight type exposes the following members.

Properties
 | Name | Description
Public property | IsCheckedIn | Restituisce se il documento è in Checkin
Public property | IsCheckedOutByMe | Restituisce se il documento è in Checkout da me
Public property | IsCheckedOutByMeOnOtherHost | Restituisce se il documento è in Checkout da me su un'altra postazione
Public property | IsCheckedOutByOther | Restituisce se il documento è in Checkout da altri
Public property | PwsFullPath | Restituisce il percorso in area locale del documento Se non è presente area locale restituisce il percorso di Vault
Top
Methods
 | Name | Description
Public method | GetValueAttr(StandardDocFields) | Ottiene il valore dell'attributo specificato in ingresso.
Public method | GetValueAttr(String) | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.
Public method | GetValueAttrByPrompt | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome visualizzato dell'attributo.
Top
See Also

Reference

DedNetConnector Namespace

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


DedDocLight Properties

The DedDocLight type exposes the following members.

Properties
 | Name | Description
Public property | IsCheckedIn | Restituisce se il documento è in Checkin
Public property | IsCheckedOutByMe | Restituisce se il documento è in Checkout da me
Public property | IsCheckedOutByMeOnOtherHost | Restituisce se il documento è in Checkout da me su un'altra postazione
Public property | IsCheckedOutByOther | Restituisce se il documento è in Checkout da altri
Public property | PwsFullPath | Restituisce il percorso in area locale del documento Se non è presente area locale restituisce il percorso di Vault
Top
See Also

Reference

DedDocLight Class


DedDocLight.IsCheckedIn Property

DedDocLightIsCheckedIn Property
Restituisce se il documento è in Checkin

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCheckedIn { get; }
Public ReadOnly Property IsCheckedIn As Boolean
    Get
public:
property bool IsCheckedIn {
    bool get ();
}
member IsCheckedIn : bool with get

Property Value

Boolean
See Also

Reference

DedDocLight Class


DedDocLight.IsCheckedOutByMe Property

DedDocLightIsCheckedOutByMe Property
Restituisce se il documento è in Checkout da me

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCheckedOutByMe { get; }
Public ReadOnly Property IsCheckedOutByMe As Boolean
    Get
public:
property bool IsCheckedOutByMe {
    bool get ();
}
member IsCheckedOutByMe : bool with get

Property Value

Boolean
See Also

Reference

DedDocLight Class


DedDocLight.IsCheckedOutByMeOnOtherHost Property

DedDocLightIsCheckedOutByMeOnOtherHost Property
Restituisce se il documento è in Checkout da me su un'altra postazione

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCheckedOutByMeOnOtherHost { get; }
Public ReadOnly Property IsCheckedOutByMeOnOtherHost As Boolean
    Get
public:
property bool IsCheckedOutByMeOnOtherHost {
    bool get ();
}
member IsCheckedOutByMeOnOtherHost : bool with get

Property Value

Boolean
See Also

Reference

DedDocLight Class


DedDocLight.IsCheckedOutByOther Property

DedDocLightIsCheckedOutByOther Property
Restituisce se il documento è in Checkout da altri

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCheckedOutByOther { get; }
Public ReadOnly Property IsCheckedOutByOther As Boolean
    Get
public:
property bool IsCheckedOutByOther {
    bool get ();
}
member IsCheckedOutByOther : bool with get

Property Value

Boolean
See Also

Reference

DedDocLight Class


DedDocLight.PwsFullPath Property

DedDocLightPwsFullPath Property
Restituisce il percorso in area locale del documento Se non è presente area locale restituisce il percorso di Vault

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PwsFullPath { get; }
Public ReadOnly Property PwsFullPath As String
    Get
public:
property String^ PwsFullPath {
    String^ get ();
}
member PwsFullPath : string with get

Property Value

String
See Also

Reference

DedDocLight Class


DedDocLight Methods

The DedDocLight type exposes the following members.

Methods
 | Name | Description
Public method | GetValueAttr(StandardDocFields) | Ottiene il valore dell'attributo specificato in ingresso.
Public method | GetValueAttr(String) | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.
Public method | GetValueAttrByPrompt | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome visualizzato dell'attributo.
Top
See Also

Reference

DedDocLight Class


DedDocLight.GetValueAttr Method

DedDocLightGetValueAttr Method
Overload List
 | Name | Description
Public method | GetValueAttr(StandardDocFields) | Ottiene il valore dell'attributo specificato in ingresso.
Public method | GetValueAttr(String) | Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.
Top
See Also

Reference

DedDocLight Class


DedDocLight.GetValueAttr(DedDoc.StandardDocFields) Method

DedDocLightGetValueAttr(DedDocStandardDocFields) Method
Ottiene il valore dell'attributo specificato in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object GetValueAttr(
    StandardDocFields attr
)
Public Function GetValueAttr (
    attr As StandardDocFields
) As Object
public:
Object^ GetValueAttr(
    StandardDocFields attr
)
member GetValueAttr :
        attr : StandardDocFields -> Object

Parameters

attr StandardDocFields
Nome dell'atributo da cui prelevare il valore.

Return Value

Object
Tipo: 'System.Object'; Valore dell'attributo.
See Also

Reference

DedDocLight Class
GetValueAttr Overload


DedDocLight.GetValueAttr(String) Method

DedDocLightGetValueAttr(String) Method
Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome interno dell'attributo.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object GetValueAttr(
    string attr
)
Public Function GetValueAttr (
    attr As String
) As Object
public:
Object^ GetValueAttr(
    String^ attr
)
member GetValueAttr :
        attr : string -> Object

Parameters

attr String
Nome dell'atributo da cui prelevare il valore. Deve essere il nome effettivo e non quello visualizzato.

Return Value

Object
Tipo: 'System.Object'; Valore dell'attributo.
See Also

Reference

DedDocLight Class
GetValueAttr Overload


DedDocLight.GetValueAttrByPrompt Method

DedDocLightGetValueAttrByPrompt Method
Ritorna il valore dell'attributo specificato in ingresso. In ingresso deve essere specificato il nome visualizzato dell'attributo.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object GetValueAttrByPrompt(
    string prompt
)
Public Function GetValueAttrByPrompt (
    prompt As String
) As Object
public:
Object^ GetValueAttrByPrompt(
    String^ prompt
)
member GetValueAttrByPrompt :
        prompt : string -> Object

Parameters

prompt String
Nome visualizzato dell'atributo da cui prelevare il valore. Deve essere il nome visualizzato e non quello effettivo.

Return Value

Object
Tipo: 'System.Object'; Valore dell'attributo.
See Also

Reference

DedDocLight Class


DedNetConnectorCommands Class
Classe che espone all'esterno i vari comandi per interoperare con il software DataAndDrawings.
Inheritance Hierarchy
SystemObject
DedNetConnectorDedNetConnectorCommands

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DedNetConnectorCommands
Public Class DedNetConnectorCommands
public ref class DedNetConnectorCommands
type DedNetConnectorCommands = class end

The DedNetConnectorCommands type exposes the following members.

Constructors
 | Name | Description
Public method | DedNetConnectorCommands | Costruttore unico senza parametri.
Top
Properties
 | Name | Description
Public property | CurrentUser | Restituisce il nome dell'utente corrente
Public property | CurrentUserNameVis | REstituisce il nome visualizzato dell'utente corrente
Public property | CurrentWorkArea | Restituisce il percorso dell'area locale dell'utente corrente
Top
Methods
 | Name | Description
Public method | AnnullaCheckOut | Esegue un Annulla CheckOut sul documento specificato in ingresso.
Public method | AssociateDocumentToData | Associa un documento ad una anagrafica. In base al filename e al contesto (file primario / file allegato) del documento, individua il nome del documento e, nel caso sia già presente, lo elimina. Infine viene eseguita una nuova importazione del documento individuato dal file passato.
Public method | ChangeDataState(DedDataLight) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Verrà mostrata un' apposita interfaccia grafica dove poter scegliere lo stato di destinazione.
Public method | ChangeDataState(DedDataLight, Boolean) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Se attiva la configurazione AVANZATA degli stati, verrà mostrata un'apposita interfaccia grafica dove poter scegliere lo stato di destinazione.
Public method | ChangeDataState(DedDataLight, String) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Nel caso lo stato di destinazione specificato in ingresso non venga trovato, verrà generata una eccezione.
Public method | CheckInDocument | Esegue un CheckIn sul documento specificato in ingresso.
Public method | CheckOutDocument | Esegue un CheckOut sul documento specificato in ingresso.
Public method | CreateData | Crea una nuova anagrafica nella famiglia selezionata.
Public method | CreateDocument | Registra un documento nel database
Public method | CreateRevData | Crea una nuova revisione dell'anagrafica specificata. Se quest'ultima non è specificata, apparirà un apposito dialogo per selezionarla.
Public method | Deactivate | Metodo dedicato al rilascio delle risorse.
Public method | DisconnectDocument | Disconnette il documento dall'anagrafica.
Public method | DocumentIsCheckedIn | Controlla se il documento è in checkin. Solleva eccezione se il documento non esiste.
Public method | EnsureLocalDocument | Esegue il comando di ensureLocal del file passato
Public method | ExplodedBom | Visualizza la distinta esplosa dell'anagrafica specificata.
Public method | FindDoc | Permette di ottenere un documento dal file specificato in ingresso. Non mostra alcuna interfaccia grafica.
Public method | GetDataByDocument | Ritorna l'elenco delle anagrafiche associate al documento.
Public method | GetDocumentsByData | Ritorna l'elenco dei documenti associati all'anagrafica specificata in ingresso. I percorsi dei documenti sono relativi all'area locale.
Public method | ImplodedBom | Visualizza la distinta implosa dell'anagrafica specificata.
Public method | PublishDocument | Esegue un Publish sul documento specificato in ingresso.
Public method | RemoveDocument | Elimina il documento dal database nel caso in cui non sia utilizzato in nessuna anagrafica. Se il documento è utilizzato in 1 o più anagrafiche verrà generata una eccezione.
Public method | SaveBom(DedDataLight, DedCustomItemBom) | Salva la distinta relativa all'anagrafica specificata in ingresso.
Public method | SaveBom(DedDataLight, DedCustomItemBom, DedBomContext) | Salva la distinta relativa all'anagrafica specificata in ingresso.
Public method | SelectData | Permette, attravero un'apposita interfaccia grafica, di selezionare e ritornare una lista di anagrafiche.
Public method | SelectData(String, String) | Permette di ottenere un'anagrafica in base ai campi 'ID' e 'REV' specificati in ingresso. Non mostra alcuna interfaccia grafica.
Public method | SelectDataByField |
Public method | ShowFindForm | Visualizza il form della ricerca
Top
See Also

Reference

DedNetConnector Namespace

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


DedNetConnectorCommands Constructor
Costruttore unico senza parametri.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedNetConnectorCommands()
Public Sub New
public:
DedNetConnectorCommands()
new : unit -> DedNetConnectorCommands
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands Properties

The DedNetConnectorCommands type exposes the following members.

Properties
 | Name | Description
Public property | CurrentUser | Restituisce il nome dell'utente corrente
Public property | CurrentUserNameVis | REstituisce il nome visualizzato dell'utente corrente
Public property | CurrentWorkArea | Restituisce il percorso dell'area locale dell'utente corrente
Top
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CurrentUser Property

DedNetConnectorCommandsCurrentUser Property
Restituisce il nome dell'utente corrente

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUser { get; }
Public ReadOnly Property CurrentUser As String
    Get
public:
property String^ CurrentUser {
    String^ get ();
}
member CurrentUser : string with get

Property Value

String
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CurrentUserNameVis Property

DedNetConnectorCommandsCurrentUserNameVis Property
REstituisce il nome visualizzato dell'utente corrente

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUserNameVis { get; }
Public ReadOnly Property CurrentUserNameVis As String
    Get
public:
property String^ CurrentUserNameVis {
    String^ get ();
}
member CurrentUserNameVis : string with get

Property Value

String
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CurrentWorkArea Property

DedNetConnectorCommandsCurrentWorkArea Property
Restituisce il percorso dell'area locale dell'utente corrente

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentWorkArea { get; }
Public ReadOnly Property CurrentWorkArea As String
    Get
public:
property String^ CurrentWorkArea {
    String^ get ();
}
member CurrentWorkArea : string with get

Property Value

String
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands Methods

The DedNetConnectorCommands type exposes the following members.

Methods
 | Name | Description
Public method | AnnullaCheckOut | Esegue un Annulla CheckOut sul documento specificato in ingresso.
Public method | AssociateDocumentToData | Associa un documento ad una anagrafica. In base al filename e al contesto (file primario / file allegato) del documento, individua il nome del documento e, nel caso sia già presente, lo elimina. Infine viene eseguita una nuova importazione del documento individuato dal file passato.
Public method | ChangeDataState(DedDataLight) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Verrà mostrata un' apposita interfaccia grafica dove poter scegliere lo stato di destinazione.
Public method | ChangeDataState(DedDataLight, Boolean) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Se attiva la configurazione AVANZATA degli stati, verrà mostrata un'apposita interfaccia grafica dove poter scegliere lo stato di destinazione.
Public method | ChangeDataState(DedDataLight, String) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Nel caso lo stato di destinazione specificato in ingresso non venga trovato, verrà generata una eccezione.
Public method | CheckInDocument | Esegue un CheckIn sul documento specificato in ingresso.
Public method | CheckOutDocument | Esegue un CheckOut sul documento specificato in ingresso.
Public method | CreateData | Crea una nuova anagrafica nella famiglia selezionata.
Public method | CreateDocument | Registra un documento nel database
Public method | CreateRevData | Crea una nuova revisione dell'anagrafica specificata. Se quest'ultima non è specificata, apparirà un apposito dialogo per selezionarla.
Public method | Deactivate | Metodo dedicato al rilascio delle risorse.
Public method | DisconnectDocument | Disconnette il documento dall'anagrafica.
Public method | DocumentIsCheckedIn | Controlla se il documento è in checkin. Solleva eccezione se il documento non esiste.
Public method | EnsureLocalDocument | Esegue il comando di ensureLocal del file passato
Public method | ExplodedBom | Visualizza la distinta esplosa dell'anagrafica specificata.
Public method | FindDoc | Permette di ottenere un documento dal file specificato in ingresso. Non mostra alcuna interfaccia grafica.
Public method | GetDataByDocument | Ritorna l'elenco delle anagrafiche associate al documento.
Public method | GetDocumentsByData | Ritorna l'elenco dei documenti associati all'anagrafica specificata in ingresso. I percorsi dei documenti sono relativi all'area locale.
Public method | ImplodedBom | Visualizza la distinta implosa dell'anagrafica specificata.
Public method | PublishDocument | Esegue un Publish sul documento specificato in ingresso.
Public method | RemoveDocument | Elimina il documento dal database nel caso in cui non sia utilizzato in nessuna anagrafica. Se il documento è utilizzato in 1 o più anagrafiche verrà generata una eccezione.
Public method | SaveBom(DedDataLight, DedCustomItemBom) | Salva la distinta relativa all'anagrafica specificata in ingresso.
Public method | SaveBom(DedDataLight, DedCustomItemBom, DedBomContext) | Salva la distinta relativa all'anagrafica specificata in ingresso.
Public method | SelectData | Permette, attravero un'apposita interfaccia grafica, di selezionare e ritornare una lista di anagrafiche.
Public method | SelectData(String, String) | Permette di ottenere un'anagrafica in base ai campi 'ID' e 'REV' specificati in ingresso. Non mostra alcuna interfaccia grafica.
Public method | SelectDataByField |
Public method | ShowFindForm | Visualizza il form della ricerca
Top
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.AnnullaCheckOut Method

DedNetConnectorCommandsAnnullaCheckOut Method
Esegue un Annulla CheckOut sul documento specificato in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AnnullaCheckOut(
    string file
)
Public Function AnnullaCheckOut (
    file As String
) As Boolean
public:
bool AnnullaCheckOut(
    String^ file
)
member AnnullaCheckOut :
        file : string -> bool

Parameters

file String
Percorso del documento su cui eseguire l'operazione.

Return Value

Boolean
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.AssociateDocumentToData Method

DedNetConnectorCommandsAssociateDocumentToData Method
Associa un documento ad una anagrafica. In base al filename e al contesto (file primario / file allegato) del documento, individua il nome del documento e, nel caso sia già presente, lo elimina. Infine viene eseguita una nuova importazione del documento individuato dal file passato.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssociateDocumentToData(
    string file,
    DedDataLight data,
    bool ignoreState = false,
    bool isRecognize = false,
    DedDataDocContext context = DedDataDocContext.Allegato,
    bool noDelNoMoved = false,
    bool docHasToBeCheckedIn = false
)
Public Function AssociateDocumentToData (
    file As String,
    data As DedDataLight,
    Optional ignoreState As Boolean = false,
    Optional isRecognize As Boolean = false,
    Optional context As DedDataDocContext = DedDataDocContext.Allegato,
    Optional noDelNoMoved As Boolean = false,
    Optional docHasToBeCheckedIn As Boolean = false
) As String
public:
String^ AssociateDocumentToData(
    String^ file,
    DedDataLight^ data,
    bool ignoreState = false,
    bool isRecognize = false,
    DedDataDocContext context = DedDataDocContext::Allegato,
    bool noDelNoMoved = false,
    bool docHasToBeCheckedIn = false
)
member AssociateDocumentToData :
        file : string *
        data : DedDataLight *
        ?ignoreState : bool *
        ?isRecognize : bool *
        ?context : DedDataDocContext *
        ?noDelNoMoved : bool *
        ?docHasToBeCheckedIn : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _isRecognize = defaultArg isRecognize false
        let _context = defaultArg context DedDataDocContext.Allegato
        let _noDelNoMoved = defaultArg noDelNoMoved false
        let _docHasToBeCheckedIn = defaultArg docHasToBeCheckedIn false
*)
-> string

Parameters

file String
Percorso del documento da associare all'anagrafica.
data DedDataLight
Anagrafica a cui associare il documento.
ignoreState Boolean (Optional)
Indica se ignorare lo stato dell'anagrafica alla quale associare il documento; Default: False.
isRecognize Boolean (Optional)
Indica se il documento è già nel posto giusto e con il nome giusto, in tal caso verrà effettuata un'operazione di 'Riconoscimento'; Default: False.
context DedDataDocContext (Optional)
Indica com deve essere associato il documento all'anagrafica; Default: Allegatp.
noDelNoMoved Boolean (Optional)
Indica se creare (False) o non creare (True) il .del o .moved del documento dopo l'esecuzione del comando; Default: False.
docHasToBeCheckedIn Boolean (Optional)
Indica se il documento deve essere posto in CheckIn dopo l'esecuzione del comando: Default False.

Return Value

String
Tipo: 'System.String'; Ritorna il nuovo percorso del documento se l'operazione è andata a buon fine, null altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.ChangeDataState Method

DedNetConnectorCommandsChangeDataState Method
Overload List
 | Name | Description
Public method | ChangeDataState(DedDataLight) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Verrà mostrata un' apposita interfaccia grafica dove poter scegliere lo stato di destinazione.
Public method | ChangeDataState(DedDataLight, Boolean) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Se attiva la configurazione AVANZATA degli stati, verrà mostrata un'apposita interfaccia grafica dove poter scegliere lo stato di destinazione.
Public method | ChangeDataState(DedDataLight, String) | Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Nel caso lo stato di destinazione specificato in ingresso non venga trovato, verrà generata una eccezione.
Top
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.ChangeDataState(DedDataLight[]) Method

DedNetConnectorCommandsChangeDataState(DedDataLight) Method
Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Verrà mostrata un' apposita interfaccia grafica dove poter scegliere lo stato di destinazione.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ChangeDataState(
    DedDataLight[] dataList
)
Public Function ChangeDataState (
    dataList As DedDataLight()
) As Boolean
public:
bool ChangeDataState(
    array<DedDataLight^>^ dataList
)
member ChangeDataState :
        dataList : DedDataLight[] -> bool

Parameters

dataList DedDataLight
Elenco di anagrafiche alle quali cambiare stato.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class
ChangeDataState Overload


DedNetConnectorCommands.ChangeDataState(DedDataLight[], Boolean) Method

DedNetConnectorCommandsChangeDataState(DedDataLight, Boolean) Method
Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Se attiva la configurazione AVANZATA degli stati, verrà mostrata un'apposita interfaccia grafica dove poter scegliere lo stato di destinazione.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ChangeDataState(
    DedDataLight[] dataList,
    bool isLav
)
Public Function ChangeDataState (
    dataList As DedDataLight(),
    isLav As Boolean
) As Boolean
public:
bool ChangeDataState(
    array<DedDataLight^>^ dataList,
    bool isLav
)
member ChangeDataState :
        dataList : DedDataLight[] *
        isLav : bool -> bool

Parameters

dataList DedDataLight
Elenco di anagrafiche alle quale cambiare stato.
isLav Boolean
Indica se impostare le anagrafiche in Lavorazione (True) o in Rilasciate (False).

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class
ChangeDataState Overload


DedNetConnectorCommands.ChangeDataState(DedDataLight[], String) Method

DedNetConnectorCommandsChangeDataState(DedDataLight, String) Method
Cambia lo stato delle anagrafiche specificate in ingresso. Le anagrafiche devono avere tutte lo stesso stato di partenza altrimenti non sarà possibile eseguire il comando. Nel caso lo stato di destinazione specificato in ingresso non venga trovato, verrà generata una eccezione.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ChangeDataState(
    DedDataLight[] dataList,
    string targetStateName
)
Public Function ChangeDataState (
    dataList As DedDataLight(),
    targetStateName As String
) As Boolean
public:
bool ChangeDataState(
    array<DedDataLight^>^ dataList,
    String^ targetStateName
)
member ChangeDataState :
        dataList : DedDataLight[] *
        targetStateName : string -> bool

Parameters

dataList DedDataLight
Elenco di anagrafiche alle quale cambiare stato.
targetStateName String
Nome dello stato in cui le anagrafiche devono essere cambiate.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class
ChangeDataState Overload


DedNetConnectorCommands.CheckInDocument Method

DedNetConnectorCommandsCheckInDocument Method
Esegue un CheckIn sul documento specificato in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckInDocument(
    string file,
    bool structure = false,
    bool eraseFromPws = false
)
Public Function CheckInDocument (
    file As String,
    Optional structure As Boolean = false,
    Optional eraseFromPws As Boolean = false
) As Boolean
public:
bool CheckInDocument(
    String^ file,
    bool structure = false,
    bool eraseFromPws = false
)
member CheckInDocument :
        file : string *
        ?structure : bool *
        ?eraseFromPws : bool
(* Defaults:
        let _structure = defaultArg structure false
        let _eraseFromPws = defaultArg eraseFromPws false
*)
-> bool

Parameters

file String
Percorso del documento su cui eseguire l'operazione.
structure Boolean (Optional)
Specifica se eseguire un CheckIn su tutta la struttura del documento; Default: False.
eraseFromPws Boolean (Optional)
Specifica se cancellare il documento dall'area locale dopo l'esecuzione del comando; Default: False.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CheckOutDocument Method

DedNetConnectorCommandsCheckOutDocument Method
Esegue un CheckOut sul documento specificato in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CheckOutDocument(
    string file,
    bool structure = false
)
Public Function CheckOutDocument (
    file As String,
    Optional structure As Boolean = false
) As String
public:
String^ CheckOutDocument(
    String^ file,
    bool structure = false
)
member CheckOutDocument :
        file : string *
        ?structure : bool
(* Defaults:
        let _structure = defaultArg structure false
*)
-> string

Parameters

file String
Percorso del documento su cui eseguire l'operazione.
structure Boolean (Optional)
Specifica se eseguire un CheckOut su tutta la struttura del documento; Default: False.

Return Value

String
Tipo: 'System.String'; Ritorna il percorso del doumento in locale se l'operazione è andata a buon fine, 'null' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CreateData Method

DedNetConnectorCommandsCreateData Method
Crea una nuova anagrafica nella famiglia selezionata.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDataLight CreateData(
    string dbPath,
    Dictionary<string, Object> attr,
    bool useUI
)
Public Function CreateData (
    dbPath As String,
    attr As Dictionary(Of String, Object),
    useUI As Boolean
) As DedDataLight
public:
DedDataLight^ CreateData(
    String^ dbPath,
    Dictionary<String^, Object^>^ attr,
    bool useUI
)
member CreateData :
        dbPath : string *
        attr : Dictionary<string, Object> *
        useUI : bool -> DedDataLight

Parameters

dbPath String
Indica la famiglia in cui creare l'anagrafica. Può essere 'null' se non si dispone di questa informazione.
attr Dictionary String, Object
Dizionario di tipo string/object dove 'string' rappresenta il nome VISUALIZZATO dell'attributo e 'object' il relativo valore da assegnarli. Imposta solamente gli attributi che vengono trovati, gli altri vengono ignorati. Può essere 'null' se non si dispone di questa informazione.
useUI Boolean
Indica se visualizzare o meno eventuali interfacce grafiche.

Return Value

DedDataLight
Tipo: 'DedNetConnector.DedDataLight'; Ritorna l'anagrafica appena creata se l'operazione è andata a buon fine, 'null' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CreateDocument Method

DedNetConnectorCommandsCreateDocument Method
Registra un documento nel database

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CreateDocument(
    string file
)
Public Function CreateDocument (
    file As String
) As Boolean
public:
bool CreateDocument(
    String^ file
)
member CreateDocument :
        file : string -> bool

Parameters

file String
Percorso del documento su cui eseguire l'operazione.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.CreateRevData Method

DedNetConnectorCommandsCreateRevData Method
Crea una nuova revisione dell'anagrafica specificata. Se quest'ultima non è specificata, apparirà un apposito dialogo per selezionarla.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDataLight CreateRevData(
    DedDataLight data = null,
    Dictionary<string, Object> attr = null
)
Public Function CreateRevData (
    Optional data As DedDataLight = Nothing,
    Optional attr As Dictionary(Of String, Object) = Nothing
) As DedDataLight
public:
DedDataLight^ CreateRevData(
    DedDataLight^ data = nullptr,
    Dictionary<String^, Object^>^ attr = nullptr
)
member CreateRevData :
        ?data : DedDataLight *
        ?attr : Dictionary<string, Object>
(* Defaults:
        let _data = defaultArg data null
        let _attr = defaultArg attr null
*)
-> DedDataLight

Parameters

data DedDataLight (Optional)
Anagrafica di partenza da cui creare la revisione.
attr Dictionary String, Object (Optional)
Dizionario di tipo string/object dove 'string' rappresenta il nome VISUALIZZATO dell'attributo e 'object' il relativo valore da assegnarli. Imposta solamente gli attributi che vengono trovati, gli altri vengono ignorati.

Return Value

DedDataLight
Tipo: 'DedNetConnector.DedDataLight'; Ritorna l'anagrafica appena revisionata se l'operazione è andata a buon fine, 'null' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.Deactivate Method

DedNetConnectorCommandsDeactivate Method
Metodo dedicato al rilascio delle risorse.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Deactivate()
Public Sub Deactivate
public:
void Deactivate()
member Deactivate : unit -> unit
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.DisconnectDocument Method

DedNetConnectorCommandsDisconnectDocument Method
Disconnette il documento dall'anagrafica.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DisconnectDocument(
    DedDataLight data,
    string file
)
Public Function DisconnectDocument (
    data As DedDataLight,
    file As String
) As Boolean
public:
bool DisconnectDocument(
    DedDataLight^ data,
    String^ file
)
member DisconnectDocument :
        data : DedDataLight *
        file : string -> bool

Parameters

data DedDataLight
Anagrafica dalla quale disconnettere il documento.
file String
Percorso del documento su cui eseguire l'operazione.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.DocumentIsCheckedIn Method

DedNetConnectorCommandsDocumentIsCheckedIn Method
Controlla se il documento è in checkin. Solleva eccezione se il documento non esiste.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DocumentIsCheckedIn(
    string file
)
Public Function DocumentIsCheckedIn (
    file As String
) As Boolean
public:
bool DocumentIsCheckedIn(
    String^ file
)
member DocumentIsCheckedIn :
        file : string -> bool

Parameters

file String
Percorso del documento su cui eseguire il controllo.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se il documento è in checkin, 'False' in tutti gli altri casi.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.EnsureLocalDocument Method

DedNetConnectorCommandsEnsureLocalDocument Method
Esegue il comando di ensureLocal del file passato

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnsureLocalDocument(
    string file
)
Public Function EnsureLocalDocument (
    file As String
) As Boolean
public:
bool EnsureLocalDocument(
    String^ file
)
member EnsureLocalDocument :
        file : string -> bool

Parameters

file String
File di riferimente

Return Value

Boolean
Esito dell'operazione come booleano.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.ExplodedBom Method

DedNetConnectorCommandsExplodedBom Method
Visualizza la distinta esplosa dell'anagrafica specificata.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExplodedBom(
    DedDataLight data
)
Public Function ExplodedBom (
    data As DedDataLight
) As Boolean
public:
bool ExplodedBom(
    DedDataLight^ data
)
member ExplodedBom :
        data : DedDataLight -> bool

Parameters

data DedDataLight
Anagrafica di cui visualizzare la distinta esplosa.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.FindDoc Method

DedNetConnectorCommandsFindDoc Method
Permette di ottenere un documento dal file specificato in ingresso. Non mostra alcuna interfaccia grafica.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDocLight FindDoc(
    string file
)
Public Function FindDoc (
    file As String
) As DedDocLight
public:
DedDocLight^ FindDoc(
    String^ file
)
member FindDoc :
        file : string -> DedDocLight

Parameters

file String
Rappresenta l'ID dell'anagrafica (genera una eccezione se impostato con una stringa vuota o null).

Return Value

DedDocLight
Tipo: 'DedNetConnector.DedDocLight'; Ritorna il documento se è stato trovato, altrimenti null.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.GetDataByDocument Method

DedNetConnectorCommandsGetDataByDocument Method
Ritorna l'elenco delle anagrafiche associate al documento.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDataLight[] GetDataByDocument(
    string file,
    bool isAttachContext = false
)
Public Function GetDataByDocument (
    file As String,
    Optional isAttachContext As Boolean = false
) As DedDataLight()
public:
array<DedDataLight^>^ GetDataByDocument(
    String^ file,
    bool isAttachContext = false
)
member GetDataByDocument :
        file : string *
        ?isAttachContext : bool
(* Defaults:
        let _isAttachContext = defaultArg isAttachContext false
*)
-> DedDataLight[]

Parameters

file String
Percorso del documento.
isAttachContext Boolean (Optional)
Specifica se ritornare le anagrafiche in cui il documento è usato come file allegato (True) o come file primario (False); Default: False.

Return Value

DedDataLight
Tipo: 'DedNetConnector.DedDataLight[]'; Ritorna un array con le anagrafiche trovate, nel caso non ve ne siano ritorna un array con 0 elementi.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.GetDocumentsByData Method

DedNetConnectorCommandsGetDocumentsByData Method
Ritorna l'elenco dei documenti associati all'anagrafica specificata in ingresso. I percorsi dei documenti sono relativi all'area locale.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetDocumentsByData(
    DedDataLight data,
    bool isAttachContext = false
)
Public Function GetDocumentsByData (
    data As DedDataLight,
    Optional isAttachContext As Boolean = false
) As String()
public:
array<String^>^ GetDocumentsByData(
    DedDataLight^ data,
    bool isAttachContext = false
)
member GetDocumentsByData :
        data : DedDataLight *
        ?isAttachContext : bool
(* Defaults:
        let _isAttachContext = defaultArg isAttachContext false
*)
-> string[]

Parameters

data DedDataLight
Anagrafica di partenza.
isAttachContext Boolean (Optional)
Specifica se ritornare solamente i documenti che sono utilizzati come file allegati (True) o come file primari (False); Default: False.

Return Value

String
Tipo: 'System.string[]'; Ritorna un array con i percorsi dei documenti trovati, nel caso non ve ne siano ritorna un array con 0 elementi.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.ImplodedBom Method

DedNetConnectorCommandsImplodedBom Method
Visualizza la distinta implosa dell'anagrafica specificata.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ImplodedBom(
    DedDataLight data
)
Public Function ImplodedBom (
    data As DedDataLight
) As Boolean
public:
bool ImplodedBom(
    DedDataLight^ data
)
member ImplodedBom :
        data : DedDataLight -> bool

Parameters

data DedDataLight
Anagrafica di cui visualizzare la distinta implosa.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.PublishDocument Method

DedNetConnectorCommandsPublishDocument Method
Esegue un Publish sul documento specificato in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PublishDocument(
    string file
)
Public Function PublishDocument (
    file As String
) As Boolean
public:
bool PublishDocument(
    String^ file
)
member PublishDocument :
        file : string -> bool

Parameters

file String
Percorso del documento su cui eseguire l'operazione.

Return Value

Boolean
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.RemoveDocument Method

DedNetConnectorCommandsRemoveDocument Method
Elimina il documento dal database nel caso in cui non sia utilizzato in nessuna anagrafica. Se il documento è utilizzato in 1 o più anagrafiche verrà generata una eccezione.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveDocument(
    string file
)
Public Function RemoveDocument (
    file As String
) As Boolean
public:
bool RemoveDocument(
    String^ file
)
member RemoveDocument :
        file : string -> bool

Parameters

file String
Percorso del documento su cui eseguire l'operazione.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.SaveBom Method

DedNetConnectorCommandsSaveBom Method
Overload List
 | Name | Description
Public method | SaveBom(DedDataLight, DedCustomItemBom) | Salva la distinta relativa all'anagrafica specificata in ingresso.
Public method | SaveBom(DedDataLight, DedCustomItemBom, DedBomContext) | Salva la distinta relativa all'anagrafica specificata in ingresso.
Top
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.SaveBom(DedDataLight, DedCustomItemBom[]) Method

DedNetConnectorCommandsSaveBom(DedDataLight, DedCustomItemBom) Method
Salva la distinta relativa all'anagrafica specificata in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveBom(
    DedDataLight data,
    DedCustomItemBom[] subItem
)
Public Function SaveBom (
    data As DedDataLight,
    subItem As DedCustomItemBom()
) As Boolean
public:
bool SaveBom(
    DedDataLight^ data,
    array<DedCustomItemBom^>^ subItem
)
member SaveBom :
        data : DedDataLight *
        subItem : DedCustomItemBom[] -> bool

Parameters

data DedDataLight
Anagrafica di partenza da cui salvare la distinta.
subItem DedCustomItemBom
Sotto elementi da inserire nella distinta.

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class
SaveBom Overload


DedNetConnectorCommands.SaveBom(DedDataLight, DedCustomItemBom[], DedBomContext) Method

DedNetConnectorCommandsSaveBom(DedDataLight, DedCustomItemBom, DedBomContext) Method
Salva la distinta relativa all'anagrafica specificata in ingresso.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveBom(
    DedDataLight data,
    DedCustomItemBom[] subItem,
    DedBomContext bomContext
)
Public Function SaveBom (
    data As DedDataLight,
    subItem As DedCustomItemBom(),
    bomContext As DedBomContext
) As Boolean
public:
bool SaveBom(
    DedDataLight^ data,
    array<DedCustomItemBom^>^ subItem,
    DedBomContext bomContext
)
member SaveBom :
        data : DedDataLight *
        subItem : DedCustomItemBom[] *
        bomContext : DedBomContext -> bool

Parameters

data DedDataLight
Anagrafica di partenza da cui salvare la distinta.
subItem DedCustomItemBom
Sotto elementi da inserire nella distinta.
bomContext DedBomContext
Indica il tipo di salvataggio degli elementi di distinta. Di Default sono comunque elementi CAD

Return Value

Boolean
Tipo: 'System.Boolean'; Ritorna 'True' se l'operazione è andata a buon fine, 'False' altrimenti.
See Also

Reference

DedNetConnectorCommands Class
SaveBom Overload


DedNetConnectorCommands.SelectData Method

DedNetConnectorCommandsSelectData Method
Overload List
 | Name | Description
Public method | SelectData | Permette, attravero un'apposita interfaccia grafica, di selezionare e ritornare una lista di anagrafiche.
Public method | SelectData(String, String) | Permette di ottenere un'anagrafica in base ai campi 'ID' e 'REV' specificati in ingresso. Non mostra alcuna interfaccia grafica.
Top
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.SelectData Method

DedNetConnectorCommandsSelectData Method
Permette, attravero un'apposita interfaccia grafica, di selezionare e ritornare una lista di anagrafiche.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDataLight[] SelectData()
Public Function SelectData As DedDataLight()
public:
array<DedDataLight^>^ SelectData()
member SelectData : unit -> DedDataLight[]

Return Value

DedDataLight
Tipo: 'DedNetConnector.DedDataLight[]'; Ritorna un array con le anagrafiche selezionate. Se l'utente ha annullato il comando, ritorna un array con 0 elementi.
See Also

Reference

DedNetConnectorCommands Class
SelectData Overload


DedNetConnectorCommands.SelectData(String, String) Method

DedNetConnectorCommandsSelectData(String, String) Method
Permette di ottenere un'anagrafica in base ai campi 'ID' e 'REV' specificati in ingresso. Non mostra alcuna interfaccia grafica.

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDataLight SelectData(
    string id,
    string rev
)
Public Function SelectData (
    id As String,
    rev As String
) As DedDataLight
public:
DedDataLight^ SelectData(
    String^ id,
    String^ rev
)
member SelectData :
        id : string *
        rev : string -> DedDataLight

Parameters

id String
Rappresenta l'ID dell'anagrafica (genera una eccezione se impostato con una stringa vuota o null).
rev String
Rappresenta la Revisione dell'anagrafica (genera una eccezione se impostato con una stringa vuota o null).

Return Value

DedDataLight
Tipo: 'DedNetConnector.DedDataLight'; Ritorna l'anagrafica se è stata trovata, altrimenti null.
See Also

Reference

DedNetConnectorCommands Class
SelectData Overload


DedNetConnectorCommands.SelectDataByField Method

DedNetConnectorCommandsSelectDataByField Method

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DedDataLight[] SelectDataByField(
    string field,
    Object value,
    Dictionary<string, Object> subFields
)
Public Function SelectDataByField (
    field As String,
    value As Object,
    subFields As Dictionary(Of String, Object)
) As DedDataLight()
public:
array<DedDataLight^>^ SelectDataByField(
    String^ field,
    Object^ value,
    Dictionary<String^, Object^>^ subFields
)
member SelectDataByField :
        field : string *
        value : Object *
        subFields : Dictionary<string, Object> -> DedDataLight[]

Parameters

field String
value Object
subFields Dictionary String, Object

Return Value

DedDataLight
See Also

Reference

DedNetConnectorCommands Class


DedNetConnectorCommands.ShowFindForm Method

DedNetConnectorCommandsShowFindForm Method
Visualizza il form della ricerca

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowFindForm()
Public Sub ShowFindForm
public:
void ShowFindForm()
member ShowFindForm : unit -> unit
See Also

Reference

DedNetConnectorCommands Class


Utility Class
Classe contenente metodi di uso generale.
Inheritance Hierarchy
SystemObject
DedNetConnectorUtility

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Utility
Public NotInheritable Class Utility
public ref class Utility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utility = class end

The Utility type exposes the following members.

Methods
Name | Description
GetAttrNameByPrompt | Data una famiglia ed un prompt attributo, ritorna il nome
GetAttrPromptByName | Data una famiglia ed un nome attributo, ritorna il prompt
GetNativeException | Ritorna l'eccezione nativa
VisMsg | Visualizza la finestra di dialogo per le eccezioni
Top
See Also

Reference

DedNetConnector Namespace

QS Informatica Srl

Send comments on this topic to info@qsinformatica.it


Utility Methods

The Utility type exposes the following members.

Methods
Name | Description
GetAttrNameByPrompt | Data una famiglia ed un prompt attributo, ritorna il nome
GetAttrPromptByName | Data una famiglia ed un nome attributo, ritorna il prompt
GetNativeException | Ritorna l'eccezione nativa
VisMsg | Visualizza la finestra di dialogo per le eccezioni
Top
See Also

Reference

Utility Class


Utility.GetAttrNameByPrompt Method

UtilityGetAttrNameByPrompt Method
Data una famiglia ed un prompt attributo, ritorna il nome

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetAttrNameByPrompt(
    string dbpath,
    string prompt
)
Public Shared Function GetAttrNameByPrompt (
    dbpath As String,
    prompt As String
) As String
public:
static String^ GetAttrNameByPrompt(
    String^ dbpath,
    String^ prompt
)
static member GetAttrNameByPrompt :
        dbpath : string *
        prompt : string -> string

Parameters

dbpath String
Percorso famiglia di riferimento
prompt String
Prompt dell'attributo da cercare

Return Value

String
See Also

Reference

Utility Class


Utility.GetAttrPromptByName Method

UtilityGetAttrPromptByName Method
Data una famiglia ed un nome attributo, ritorna il prompt

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetAttrPromptByName(
    string dbpath,
    string name
)
Public Shared Function GetAttrPromptByName (
    dbpath As String,
    name As String
) As String
public:
static String^ GetAttrPromptByName(
    String^ dbpath,
    String^ name
)
static member GetAttrPromptByName :
        dbpath : string *
        name : string -> string

Parameters

dbpath String
Percorso famiglia di riferimento
name String
Nome dell'attroibuto da cercare

Return Value

String
See Also

Reference

Utility Class


Utility.GetNativeException Method

UtilityGetNativeException Method
Ritorna l'eccezione nativa

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Exception GetNativeException(
    Exception ex
)
Public Shared Function GetNativeException (
    ex As Exception
) As Exception
public:
static Exception^ GetNativeException(
    Exception^ ex
)
static member GetNativeException :
        ex : Exception -> Exception

Parameters

ex Exception
Eccezione da elaborare

Return Value

Exception
Eccezione nativa.
See Also

Reference

Utility Class


Utility.VisMsg Method

UtilityVisMsg Method
Visualizza la finestra di dialogo per le eccezioni

Namespace: DedNetConnector
Assembly: DedNetConnector (in DedNetConnector.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void VisMsg(
    Exception ex
)
Public Shared Sub VisMsg (
    ex As Exception
)
public:
static void VisMsg(
    Exception^ ex
)
static member VisMsg :
        ex : Exception -> unit

Parameters

ex Exception
Eccezione da visualizzare.
See Also

Reference

Utility Class