QsGemBox Namespace

[Missing <summary> documentation for "N:QsGemBox"]

Classes
 | Class | Description
Public class | Document | Class Word.
Public class | Utils | Class Utils.
Public class | UtilsImage | Class UtilsImage.
Enumerations
 | Enumeration | Description
Public enumeration | TextChunkFormat | Enum TextChunkFormat


Document Class

Class Word.
Inheritance Hierarchy
SystemObject
QsGemBoxDocument

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Document
Public NotInheritable Class Document
public ref class Document abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Document = class end

The Document type exposes the following members.

Methods
Name | Description
Create(String) | Crea di un documento vuoto
Create(String, String) | Creazione di un documento vuoto partendo da un documento word (non deve essere un vero template). Viene usato per ereditare stili e impostazioni
Load | Carica un documento
ValidateLicense | Validates the license.
Top
See Also

Reference

QsGemBox Namespace


Document Methods

The Document type exposes the following members.

Methods
Name | Description
Create(String) | Crea di un documento vuoto
Create(String, String) | Creazione di un documento vuoto partendo da un documento word (non deve essere un vero template). Viene usato per ereditare stili e impostazioni
Load | Carica un documento
ValidateLicense | Validates the license.
Top
See Also

Reference

Document Class
QsGemBox Namespace


Document.Create Method

A Sandcastle Documented Class Library

DocumentCreate Method

Overload List
Name | Description
Create(String) | Crea di un documento vuoto
Create(String, String) | Creazione di un documento vuoto partendo da un documento word (non deve essere un vero template). Viene usato per ereditare stili e impostazioni
Top
See Also

Reference

Document Class
QsGemBox Namespace


Document.Create(String) Method

DocumentCreate(String) Method

Crea di un documento vuoto

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocxDocument Create(
    string docxfile
)
Public Shared Function Create (
    docxfile As String
) As DocxDocument
public:
static DocxDocument^ Create(
    String^ docxfile
)
static member Create :
        docxfile : string -> DocxDocument

Parameters

docxfile String
The docxfile.

Return Value

DocxDocument
DocxDocument.
See Also

Reference

Document Class
Create Overload
QsGemBox Namespace


Document.Create(String, String) Method

DocumentCreate(String, String) Method

Creazione di un documento vuoto partendo da un documento word (non deve essere un vero template). Viene usato per ereditare stili e impostazioni

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocxDocument Create(
    string docxfile,
    string template
)
Public Shared Function Create (
    docxfile As String,
    template As String
) As DocxDocument
public:
static DocxDocument^ Create(
    String^ docxfile,
    String^ template
)
static member Create :
        docxfile : string *
        template : string -> DocxDocument

Parameters

docxfile String
The docxfile.
template String
The template.

Return Value

DocxDocument
DocxDocument.
See Also

Reference

Document Class
Create Overload
QsGemBox Namespace


Document.Load Method

DocumentLoad Method

Carica un documento

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocxDocument Load(
    string docxfile
)
Public Shared Function Load (
    docxfile As String
) As DocxDocument
public:
static DocxDocument^ Load(
    String^ docxfile
)
static member Load :
        docxfile : string -> DocxDocument

Parameters

docxfile String
The docxfile.

Return Value

DocxDocument
DocxDocument.
See Also

Reference

Document Class
QsGemBox Namespace


Document.ValidateLicense Method

DocumentValidateLicense Method

Validates the license.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateLicense()
Public Shared Function ValidateLicense As Boolean
public:
static bool ValidateLicense()
static member ValidateLicense : unit -> bool

Return Value

Boolean
true if XXXX, false otherwise.
See Also

Reference

Document Class
QsGemBox Namespace


TextChunkFormat Enumeration

Enum TextChunkFormat

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextChunkFormat
Public Enumeration TextChunkFormat
public enum class TextChunkFormat
type TextChunkFormat
Members
Member name | Value | Description
None | 0 | The none
NewLine | 1 | The new line
Tab | 2 | The tab
See Also

Reference

QsGemBox Namespace


Utils Class

Class Utils.
Inheritance Hierarchy
SystemObject
QsGemBoxUtils

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Utils
Public NotInheritable Class Utils
public ref class Utils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utils = class end

The Utils type exposes the following members.

Methods
Name | Description
ComposeParagraph | Composes the paragraph.
EnsureStyle | Ensures the style existence.
FindParagraphStyleByName | Finds the paragraph style providing the name.
FindStyleByName | Finds thestyle providing the name.
FixText | Fixes the text.
GemboxColorToSystemColor | Convert from gembox color to system color
GetSection | Gets the section.
GetStyleNames | Gets the style names.
InsertPageBreakAfter(DocxParagraph) | Inserisce un'interruzione di pagina dopo del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakAfter(DocxTable) | Inserisce un'interruzione di pagina dopo il parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakBefore(DocxParagraph) | Inserisce un'interruzione di pagina prima del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakBefore(DocxTable) | Inserisce un'interruzione di pagina prima del parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertParagraphAfter | Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertParagraphBefore | Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableAfter | Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableAfterParagraph | Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableBefore | Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableBeforeParagraph | Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
ParseEnumT | Parses the enum.
RemoveField | Rimuove il campo dal documento.
ReplaceFieldWithDocument | Sostituisce il campo inserendo al suo posto tutte le sezioni presenti nel documento specificato come parametro. Attenzione! Questo metodo esegue una vera e propria sostituzione, NON imposta il valore del campo.
ReplaceFieldWithString | Sostituisce il campo inserendo al suo posto la stringa specificata in ingresso (ritorna poi il relativo oggetto DocxRun). Nota bene: Il seguente metodo riporta nella nuova stringa anche le impostazioni di formato (font, spazi, ecc..) del vecchio campo. Attenzione! Questo metodo esegue una vera e propria sostituzione, NON imposta il valore del campo.
SystemColorToGemboxColor | Convert from system color to gembox color
Top
See Also

Reference

QsGemBox Namespace


Utils Methods

The Utils type exposes the following members.

Methods
Name | Description
ComposeParagraph | Composes the paragraph.
EnsureStyle | Ensures the style existence.
FindParagraphStyleByName | Finds the paragraph style providing the name.
FindStyleByName | Finds thestyle providing the name.
FixText | Fixes the text.
GemboxColorToSystemColor | Convert from gembox color to system color
GetSection | Gets the section.
GetStyleNames | Gets the style names.
InsertPageBreakAfter(DocxParagraph) | Inserisce un'interruzione di pagina dopo del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakAfter(DocxTable) | Inserisce un'interruzione di pagina dopo il parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakBefore(DocxParagraph) | Inserisce un'interruzione di pagina prima del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakBefore(DocxTable) | Inserisce un'interruzione di pagina prima del parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertParagraphAfter | Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertParagraphBefore | Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableAfter | Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableAfterParagraph | Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableBefore | Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertTableBeforeParagraph | Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
ParseEnumT | Parses the enum.
RemoveField | Rimuove il campo dal documento.
ReplaceFieldWithDocument | Sostituisce il campo inserendo al suo posto tutte le sezioni presenti nel documento specificato come parametro. Attenzione! Questo metodo esegue una vera e propria sostituzione, NON imposta il valore del campo.
ReplaceFieldWithString | Sostituisce il campo inserendo al suo posto la stringa specificata in ingresso (ritorna poi il relativo oggetto DocxRun). Nota bene: Il seguente metodo riporta nella nuova stringa anche le impostazioni di formato (font, spazi, ecc..) del vecchio campo. Attenzione! Questo metodo esegue una vera e propria sostituzione, NON imposta il valore del campo.
SystemColorToGemboxColor | Convert from system color to gembox color
Top
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.ComposeParagraph Method

UtilsComposeParagraph Method

Composes the paragraph.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Paragraph ComposeParagraph(
    string s,
    DocumentModel doc
)
Public Shared Function ComposeParagraph (
    s As String,
    doc As DocumentModel
) As Paragraph
public:
static Paragraph^ ComposeParagraph(
    String^ s,
    DocumentModel^ doc
)
static member ComposeParagraph :
        s : string *
        doc : DocumentModel -> Paragraph

Parameters

s String
The s.
doc DocumentModel
The document.

Return Value

Paragraph
Paragraph.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.EnsureStyle Method

UtilsEnsureStyle Method

Ensures the style existence.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Style EnsureStyle(
    DocumentModel doc,
    string styleName,
    bool createIfMissing
)
Public Shared Function EnsureStyle (
    doc As DocumentModel,
    styleName As String,
    createIfMissing As Boolean
) As Style
public:
static Style^ EnsureStyle(
    DocumentModel^ doc,
    String^ styleName,
    bool createIfMissing
)
static member EnsureStyle :
        doc : DocumentModel *
        styleName : string *
        createIfMissing : bool -> Style

Parameters

doc DocumentModel
The document.
styleName String
Name of the style.
createIfMissing Boolean
if set to true [create if missing].

Return Value

Style
Style.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.FindParagraphStyleByName Method

UtilsFindParagraphStyleByName Method

Finds the paragraph style providing the name.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocxParagraphStyle FindParagraphStyleByName(
    DocxDocument doc,
    string stylename
)
Public Shared Function FindParagraphStyleByName (
    doc As DocxDocument,
    stylename As String
) As DocxParagraphStyle
public:
static DocxParagraphStyle^ FindParagraphStyleByName(
    DocxDocument^ doc,
    String^ stylename
)
static member FindParagraphStyleByName :
        doc : DocxDocument *
        stylename : string -> DocxParagraphStyle

Parameters

doc DocxDocument
The document.
stylename String
The styleName.

Return Value

DocxParagraphStyle
Style.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.FindStyleByName Method

UtilsFindStyleByName Method

Finds thestyle providing the name.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Style FindStyleByName(
    DocumentModel doc,
    string stylename
)
Public Shared Function FindStyleByName (
    doc As DocumentModel,
    stylename As String
) As Style
public:
static Style^ FindStyleByName(
    DocumentModel^ doc,
    String^ stylename
)
static member FindStyleByName :
        doc : DocumentModel *
        stylename : string -> Style

Parameters

doc DocumentModel
The document.
stylename String
The styleName.

Return Value

Style
Style.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.FixText Method

UtilsFixText Method

Fixes the text.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FixText(
    string s
)
Public Shared Function FixText (
    s As String
) As String
public:
static String^ FixText(
    String^ s
)
static member FixText :
        s : string -> string

Parameters

s String
The s.

Return Value

String
System.String.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.GemboxColorToSystemColor Method

UtilsGemboxColorToSystemColor Method

Convert from gembox color to system color

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color GemboxColorToSystemColor(
    Color color
)
Public Shared Function GemboxColorToSystemColor (
    color As Color
) As Color
public:
static Color GemboxColorToSystemColor(
    Color color
)
static member GemboxColorToSystemColor :
        color : Color -> Color

Parameters

color Color
The color.

Return Value

Color
System.Drawing.Color.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.GetSection Method

UtilsGetSection Method

Gets the section.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Section GetSection(
    Element ele
)
Public Shared Function GetSection (
    ele As Element
) As Section
public:
static Section^ GetSection(
    Element^ ele
)
static member GetSection :
        ele : Element -> Section

Parameters

ele Element
The ele.

Return Value

Section
Section.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.GetStyleNames Method

UtilsGetStyleNames Method

Gets the style names.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] GetStyleNames(
    DocumentModel doc
)
Public Shared Function GetStyleNames (
    doc As DocumentModel
) As String()
public:
static array<String^>^ GetStyleNames(
    DocumentModel^ doc
)
static member GetStyleNames :
        doc : DocumentModel -> string[]

Parameters

doc DocumentModel
The document.

Return Value

String
System.String[].
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertPageBreakAfter Method

UtilsInsertPageBreakAfter Method

Overload List
Name | Description
InsertPageBreakAfter(DocxParagraph) | Inserisce un'interruzione di pagina dopo del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakAfter(DocxTable) | Inserisce un'interruzione di pagina dopo il parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
Top
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertPageBreakAfter(DocxParagraph) Method

UtilsInsertPageBreakAfter(DocxParagraph) Method

Inserisce un'interruzione di pagina dopo del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertPageBreakAfter(
    DocxParagraph item
)
Public Shared Function InsertPageBreakAfter (
    item As DocxParagraph
) As Boolean
public:
static bool InsertPageBreakAfter(
    DocxParagraph^ item
)
static member InsertPageBreakAfter :
        item : DocxParagraph -> bool

Parameters

item DocxParagraph
Paragrafo da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertPageBreakAfter(QsGemBox.Docx.DocxParagraph)"]

See Also

Reference

Utils Class
InsertPageBreakAfter Overload
QsGemBox Namespace


Utils.InsertPageBreakAfter(DocxTable) Method

UtilsInsertPageBreakAfter(DocxTable) Method

Inserisce un'interruzione di pagina dopo il parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertPageBreakAfter(
    DocxTable item
)
Public Shared Function InsertPageBreakAfter (
    item As DocxTable
) As Boolean
public:
static bool InsertPageBreakAfter(
    DocxTable^ item
)
static member InsertPageBreakAfter :
        item : DocxTable -> bool

Parameters

item DocxTable
Elemento da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertPageBreakAfter(QsGemBox.Docx.DocxTable)"]

See Also

Reference

Utils Class
InsertPageBreakAfter Overload
QsGemBox Namespace


Utils.InsertPageBreakBefore Method

UtilsInsertPageBreakBefore Method

Overload List
Name | Description
InsertPageBreakBefore(DocxParagraph) | Inserisce un'interruzione di pagina prima del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
InsertPageBreakBefore(DocxTable) | Inserisce un'interruzione di pagina prima del parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.
Top
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertPageBreakBefore(DocxParagraph) Method

UtilsInsertPageBreakBefore(DocxParagraph) Method

Inserisce un'interruzione di pagina prima del paragrafo specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertPageBreakBefore(
    DocxParagraph item
)
Public Shared Function InsertPageBreakBefore (
    item As DocxParagraph
) As Boolean
public:
static bool InsertPageBreakBefore(
    DocxParagraph^ item
)
static member InsertPageBreakBefore :
        item : DocxParagraph -> bool

Parameters

item DocxParagraph
Paragrafo da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertPageBreakBefore(QsGemBox.Docx.DocxParagraph)"]

See Also

Reference

Utils Class
InsertPageBreakBefore Overload
QsGemBox Namespace


Utils.InsertPageBreakBefore(DocxTable) Method

UtilsInsertPageBreakBefore(DocxTable) Method

Inserisce un'interruzione di pagina prima del parametro specificato in ingresso. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertPageBreakBefore(
    DocxTable item
)
Public Shared Function InsertPageBreakBefore (
    item As DocxTable
) As Boolean
public:
static bool InsertPageBreakBefore(
    DocxTable^ item
)
static member InsertPageBreakBefore :
        item : DocxTable -> bool

Parameters

item DocxTable
Elemento da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertPageBreakBefore(QsGemBox.Docx.DocxTable)"]

See Also

Reference

Utils Class
InsertPageBreakBefore Overload
QsGemBox Namespace


Utils.InsertParagraphAfter Method

UtilsInsertParagraphAfter Method

Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertParagraphAfter(
    DocxParagraph p,
    DocxTable item
)
Public Shared Function InsertParagraphAfter (
    p As DocxParagraph,
    item As DocxTable
) As Boolean
public:
static bool InsertParagraphAfter(
    DocxParagraph^ p,
    DocxTable^ item
)
static member InsertParagraphAfter :
        p : DocxParagraph *
        item : DocxTable -> bool

Parameters

p DocxParagraph
Paragrafo da aggiungere.
item DocxTable
Elemento da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertParagraphAfter(QsGemBox.Docx.DocxParagraph,QsGemBox.Docx.DocxTable)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertParagraphBefore Method

UtilsInsertParagraphBefore Method

Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertParagraphBefore(
    DocxParagraph p,
    DocxTable item
)
Public Shared Function InsertParagraphBefore (
    p As DocxParagraph,
    item As DocxTable
) As Boolean
public:
static bool InsertParagraphBefore(
    DocxParagraph^ p,
    DocxTable^ item
)
static member InsertParagraphBefore :
        p : DocxParagraph *
        item : DocxTable -> bool

Parameters

p DocxParagraph
Paragrafo da aggiungere.
item DocxTable
Elemento da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertParagraphBefore(QsGemBox.Docx.DocxParagraph,QsGemBox.Docx.DocxTable)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertTableAfter Method

UtilsInsertTableAfter Method

Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertTableAfter(
    DocxTable table,
    DocxTable item
)
Public Shared Function InsertTableAfter (
    table As DocxTable,
    item As DocxTable
) As Boolean
public:
static bool InsertTableAfter(
    DocxTable^ table,
    DocxTable^ item
)
static member InsertTableAfter :
        table : DocxTable *
        item : DocxTable -> bool

Parameters

table DocxTable
Tabella da aggiungere.
item DocxTable
Elemento da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertTableAfter(QsGemBox.Docx.DocxTable,QsGemBox.Docx.DocxTable)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertTableAfterParagraph Method

UtilsInsertTableAfterParagraph Method

Inserisce il primo parametro specificato in ingresso immediatamente dopo il secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertTableAfterParagraph(
    DocxTable table,
    DocxParagraph item
)
Public Shared Function InsertTableAfterParagraph (
    table As DocxTable,
    item As DocxParagraph
) As Boolean
public:
static bool InsertTableAfterParagraph(
    DocxTable^ table,
    DocxParagraph^ item
)
static member InsertTableAfterParagraph :
        table : DocxTable *
        item : DocxParagraph -> bool

Parameters

table DocxTable
Tabella da aggiungere.
item DocxParagraph
Paragrafo da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertTableAfterParagraph(QsGemBox.Docx.DocxTable,QsGemBox.Docx.DocxParagraph)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertTableBefore Method

UtilsInsertTableBefore Method

Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertTableBefore(
    DocxTable table,
    DocxTable item
)
Public Shared Function InsertTableBefore (
    table As DocxTable,
    item As DocxTable
) As Boolean
public:
static bool InsertTableBefore(
    DocxTable^ table,
    DocxTable^ item
)
static member InsertTableBefore :
        table : DocxTable *
        item : DocxTable -> bool

Parameters

table DocxTable
Tabella da aggiungere.
item DocxTable
Elemento da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertTableBefore(QsGemBox.Docx.DocxTable,QsGemBox.Docx.DocxTable)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.InsertTableBeforeParagraph Method

UtilsInsertTableBeforeParagraph Method

Inserisce il primo parametro specificato in ingresso immediatamente prima del secondo parametro. Ritorna True se l'elemento è stato aggiunto, False altrimenti.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsertTableBeforeParagraph(
    DocxTable table,
    DocxParagraph item
)
Public Shared Function InsertTableBeforeParagraph (
    table As DocxTable,
    item As DocxParagraph
) As Boolean
public:
static bool InsertTableBeforeParagraph(
    DocxTable^ table,
    DocxParagraph^ item
)
static member InsertTableBeforeParagraph :
        table : DocxTable *
        item : DocxParagraph -> bool

Parameters

table DocxTable
Tabella da aggiungere.
item DocxParagraph
Paragrafo da usare come riferimento.

Return Value

Boolean

[Missing <returns> documentation for "M:QsGemBox.Utils.InsertTableBeforeParagraph(QsGemBox.Docx.DocxTable,QsGemBox.Docx.DocxParagraph)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.ParseEnum<T> Method

UtilsParseEnumT Method

Parses the enum.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T ParseEnum<T>(
    string value
)

Public Shared Function ParseEnum(Of T) (
    value As String
) As T
public:
generic<typename T>
static T ParseEnum(
    String^ value
)
static member ParseEnum :
        value : string -> 'T

Parameters

value String
The value.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:QsGemBox.Utils.ParseEnum``1(System.String)"]

Return Value

T
T.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.RemoveField Method

UtilsRemoveField Method

Rimuove il campo dal documento.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveField(
    DocxField field
)
Public Shared Sub RemoveField (
    field As DocxField
)
public:
static void RemoveField(
    DocxField^ field
)
static member RemoveField :
        field : DocxField -> unit

Parameters

field DocxField
Campo da rimuovere.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.ReplaceFieldWithDocument Method

UtilsReplaceFieldWithDocument Method

Sostituisce il campo inserendo al suo posto tutte le sezioni presenti nel documento specificato come parametro. Attenzione! Questo metodo esegue una vera e propria sostituzione, NON imposta il valore del campo.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ReplaceFieldWithDocument(
    DocxField field,
    DocxDocument document,
    bool useDestinationStyles
)
Public Shared Sub ReplaceFieldWithDocument (
    field As DocxField,
    document As DocxDocument,
    useDestinationStyles As Boolean
)
public:
static void ReplaceFieldWithDocument(
    DocxField^ field,
    DocxDocument^ document,
    bool useDestinationStyles
)
static member ReplaceFieldWithDocument :
        field : DocxField *
        document : DocxDocument *
        useDestinationStyles : bool -> unit

Parameters

field DocxField
Campo da sostituire.
document DocxDocument
Documento da cui prelevare le sezioni da importare.
useDestinationStyles Boolean
Indica se utilizzare gli stili presenti nel documento di destinazione.
See Also

Reference

Utils Class
QsGemBox Namespace


Utils.ReplaceFieldWithString Method

UtilsReplaceFieldWithString Method

Sostituisce il campo inserendo al suo posto la stringa specificata in ingresso (ritorna poi il relativo oggetto DocxRun). Nota bene: Il seguente metodo riporta nella nuova stringa anche le impostazioni di formato (font, spazi, ecc..) del vecchio campo. Attenzione! Questo metodo esegue una vera e propria sostituzione, NON imposta il valore del campo.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<DocxRun> ReplaceFieldWithString(
    DocxField field,
    string val
)
Public Shared Function ReplaceFieldWithString (
    field As DocxField,
    val As String
) As List(Of DocxRun)
public:
static List<DocxRun^>^ ReplaceFieldWithString(
    DocxField^ field,
    String^ val
)
static member ReplaceFieldWithString :
        field : DocxField *
        val : string -> List<DocxRun>

Parameters

field DocxField
Campo da sostituire.
val String
String da inserire nel documento.

Return Value

List DocxRun

[Missing <returns> documentation for "M:QsGemBox.Utils.ReplaceFieldWithString(QsGemBox.Docx.DocxField,System.String)"]

See Also

Reference

Utils Class
QsGemBox Namespace


Utils.SystemColorToGemboxColor Method

UtilsSystemColorToGemboxColor Method

Convert from system color to gembox color

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color SystemColorToGemboxColor(
    Color color
)
Public Shared Function SystemColorToGemboxColor (
    color As Color
) As Color
public:
static Color SystemColorToGemboxColor(
    Color color
)
static member SystemColorToGemboxColor :
        color : Color -> Color

Parameters

color Color
The color.

Return Value

Color
Color.
See Also

Reference

Utils Class
QsGemBox Namespace


UtilsImage Class

Class UtilsImage.
Inheritance Hierarchy
SystemObject
QsGemBoxUtilsImage

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class UtilsImage
Public NotInheritable Class UtilsImage
public ref class UtilsImage abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UtilsImage = class end

The UtilsImage type exposes the following members.

Methods
Name | Description
Base64ToImage | Base64s to image.
FixPictureSize | Adatta la dimensione non definita mantenendo la proporzione.
ImageToBase64(Image) | Images to base64.
ImageToBase64(String) | Convert a picture to a base64 string
ImageToStream | Images to stream.
Top
See Also

Reference

QsGemBox Namespace


UtilsImage Methods

The UtilsImage type exposes the following members.

Methods
Name | Description
Base64ToImage | Base64s to image.
FixPictureSize | Adatta la dimensione non definita mantenendo la proporzione.
ImageToBase64(Image) | Images to base64.
ImageToBase64(String) | Convert a picture to a base64 string
ImageToStream | Images to stream.
Top
See Also

Reference

UtilsImage Class
QsGemBox Namespace


UtilsImage.Base64ToImage Method

UtilsImageBase64ToImage Method

Base64s to image.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Image Base64ToImage(
    string base64String
)
Public Shared Function Base64ToImage (
    base64String As String
) As Image
public:
static Image^ Base64ToImage(
    String^ base64String
)
static member Base64ToImage :
        base64String : string -> Image

Parameters

base64String String
The base64 string.

Return Value

Image
Image.
See Also

Reference

UtilsImage Class
QsGemBox Namespace


UtilsImage.FixPictureSize Method

UtilsImageFixPictureSize Method

Adatta la dimensione non definita mantenendo la proporzione.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void FixPictureSize(
    Image img,
    ref int width,
    ref int height
)
Public Shared Sub FixPictureSize (
    img As Image,
    ByRef width As Integer,
    ByRef height As Integer
)
public:
static void FixPictureSize(
    Image^ img,
    int% width,
    int% height
)
static member FixPictureSize :
        img : Image *
        width : int byref *
        height : int byref -> unit

Parameters

img Image

[Missing <param name="img"/> documentation for "M:QsGemBox.UtilsImage.FixPictureSize(System.Drawing.Image,System.Int32@,System.Int32@)"]

width Int32

[Missing <param name="width"/> documentation for "M:QsGemBox.UtilsImage.FixPictureSize(System.Drawing.Image,System.Int32@,System.Int32@)"]

height Int32

[Missing <param name="height"/> documentation for "M:QsGemBox.UtilsImage.FixPictureSize(System.Drawing.Image,System.Int32@,System.Int32@)"]

See Also

Reference

UtilsImage Class
QsGemBox Namespace


UtilsImage.ImageToBase64 Method

UtilsImageImageToBase64 Method

Overload List
Name | Description
ImageToBase64(Image) | Images to base64.
ImageToBase64(String) | Convert a picture to a base64 string
Top
See Also

Reference

UtilsImage Class
QsGemBox Namespace


UtilsImage.ImageToBase64(Image) Method

UtilsImageImageToBase64(Image) Method

Images to base64.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ImageToBase64(
    Image image
)
Public Shared Function ImageToBase64 (
    image As Image
) As String
public:
static String^ ImageToBase64(
    Image^ image
)
static member ImageToBase64 :
        image : Image -> string

Parameters

image Image
The image.

Return Value

String
System.String.
See Also

Reference

UtilsImage Class
ImageToBase64 Overload
QsGemBox Namespace


UtilsImage.ImageToBase64(String) Method

UtilsImageImageToBase64(String) Method

Convert a picture to a base64 string

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ImageToBase64(
    string filePath
)
Public Shared Function ImageToBase64 (
    filePath As String
) As String
public:
static String^ ImageToBase64(
    String^ filePath
)
static member ImageToBase64 :
        filePath : string -> string

Parameters

filePath String
The file path.

Return Value

String
System.String.
See Also

Reference

UtilsImage Class
ImageToBase64 Overload
QsGemBox Namespace


UtilsImage.ImageToStream Method

UtilsImageImageToStream Method

Images to stream.

Namespace: QsGemBox
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Stream ImageToStream(
    Image image,
    ImageFormat format
)
Public Shared Function ImageToStream (
    image As Image,
    format As ImageFormat
) As Stream
public:
static Stream^ ImageToStream(
    Image^ image,
    ImageFormat^ format
)
static member ImageToStream :
        image : Image *
        format : ImageFormat -> Stream

Parameters

image Image
The image.
format ImageFormat
The format.

Return Value

Stream
Stream.
See Also

Reference

UtilsImage Class
QsGemBox Namespace


QsGemBox.Docx Namespace

[Missing <summary> documentation for "N:QsGemBox.Docx"]

Classes
 | Class | Description
Public class | DocxCell | La cella di una tabella Word
Public class | DocxCellIterator | Class DocxCellIterator.
Public class | DocxCharacterFormat |
Public class | DocxCharacterStyle | CharacterStyle wrapper
Public class | DocxDocument | Class DocxDocument.
Public class | DocxElement | Elemento generico di un documento word.
Public class | DocxField | Campo di un documento word.
Public class | DocxHyperlink | Class DocxHyperlink.
Public class | DocxImageProxy | Class DocxImageProxy.
Public class | DocxImaging | Class DocxImaging.
Public class | DocxPaginator | Gestore delle pagine del documento.
Public class | DocxParagraph | Class DocxParagraph.
Public class | DocxParagraphStyle | Class DocxParagraphStyle.
Public class | DocxRun | Class DocxRun.
Public class | DocxSection | Class DocxSection.
Public class | DocxTable | L'ogetto tabella
Public class | DocxTableColumn | Class DocxTableColumn.
Public class | DocxTableRow | Class DocxTableRow.
Public class | DocxTableRowsIterator | Class DocxTableRowsIterator.
Public class | DocxTableStyle | Class DocxTableStyle.
Public class | DocxTextBox | Class DocxTextBox.
Enumerations
 | Enumeration | Description
Public enumeration | DocxDocumentSummaryOrientationEnum | Specifica l'orientamento che deve avere la pagina contenente il sommario.


DocxCell Class

La cella di una tabella Word
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxCell

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxCell
Public Class DocxCell
public ref class DocxCell
type DocxCell = class end

The DocxCell type exposes the following members.

Constructors
 | Name | Description
Public method | DocxCell | Costruttore standard
Public method | DocxCell(TableCell) | Costruttore wrapper
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the color of the background.
Public property | Bold | Sets a value indicating whether this DocxCell is bold.
Public property | Height | Altezza della cella.
Public property | InnerObject | L'oggetto interno
Public property | Italic | Sets a value indicating whether this DocxCell is italic.
Public property | Section | Ritorna la sezione di appartenenza
Public property | Text | Get cell text.
Public property | Width | Larghezza della cella.
Top
Methods
 | Name | Description
Public method | AddBookmarkText | Adds the bookmark text.
Public method | AddField | Adds the field. Warning: not complete!
Public method | AddHyperlink | Aggiunge un hyperlink
Public method | AddImage(Image, Int32, Int32) | Aggiunge un'immagine. L'immagine deve essere in formato PNG.
Public method | AddImage(String, Int32, Int32) | Aggiunge un'immagine
Public method | AddNewLine | Aggiunge una linea vuota.
Public method | AddParagraph | Aggiunge un paragrafo
Public method | AddTab | Aggiunge una tabulazione
Public method | AddTable | Aggiunge una tabella
Public method | AddText | Aggiunge un testo al paragrafo corrente di una cella
Public method | CloneFormat | Copia il formato della cella leggendo le informazioni dalla cella specificata in ingresso.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetColumnIndex | Ritorna l'indice della colonna a cui la cella appartiene.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRowIndex | Ritorna l'indice della riga a cui la cella appartiene.
Public method | GetTable | Ritorna la tabella in cui è contenuta la cella.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetAlignmentHorizontal | Sets the alignement.
Public method | SetAlignmentVertical | Sets the alignment vertical.
Public method | SetBackgroundColor(Color) | Sets the color of the background.
Public method | SetBackgroundColor(Int32, Int32, Int32) | Sets the color of the background.
Public method | SetBottomPadding | Sets the bottom padding of the cell.
Public method | SetFontBold | Sets the font bold.
Public method | SetFontItalic | Imposta il font come italic
Public method | SetFontName | Imposta il font di tutta la cella
Public method | SetFontSize | Imposta l'altezza del font di tutta la cella
Public method | SetLeftPadding | Sets the left padding of the cell.
Public method | SetLineSpacing | Sets the line spacing.
Public method | SetRightPadding | Sets the right padding of the cell.
Public method | SetTopPadding | Sets the top padding of the cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxCell Constructor

Overload List
 | Name | Description
Public method | DocxCell | Costruttore standard
Public method | DocxCell(TableCell) | Costruttore wrapper
Top
See Also

Reference

DocxCell Class


DocxCell Constructor

Costruttore standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell()
Public Sub New
public:
DocxCell()
new : unit -> DocxCell
See Also

Reference

DocxCell Class
DocxCell Overload


DocxCell(TableCell) Constructor

Costruttore wrapper

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell(
    TableCell innerObject
)
Public Sub New (
    innerObject As TableCell
)
public:
DocxCell(
    TableCell^ innerObject
)
new :
        innerObject : TableCell -> DocxCell

Parameters

innerObject TableCell
The inner object.
See Also

Reference

DocxCell Class
DocxCell Overload


DocxCell Properties

The DocxCell type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the color of the background.
Public property | Bold | Sets a value indicating whether this DocxCell is bold.
Public property | Height | Altezza della cella.
Public property | InnerObject | L'oggetto interno
Public property | Italic | Sets a value indicating whether this DocxCell is italic.
Public property | Section | Ritorna la sezione di appartenenza
Public property | Text | Get cell text.
Public property | Width | Larghezza della cella.
Top
See Also

Reference

DocxCell Class


DocxCell.BackgroundColor Property

DocxCellBackgroundColor Property

Gets or sets the color of the background.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
member BackgroundColor : Color with get, set

Property Value

Color
The color of the back ground.
See Also

Reference

DocxCell Class


DocxCell.Bold Property

DocxCellBold Property

Sets a value indicating whether this DocxCell is bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bold { set; }
Public WriteOnly Property Bold As Boolean
    Set
public:
property bool Bold {
    void set (bool value);
}
member Bold : bool with set

Property Value

Boolean
true if bold; otherwise, false.
See Also

Reference

DocxCell Class


DocxCell.Height Property

DocxCellHeight Property

Altezza della cella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
See Also

Reference

DocxCell Class


DocxCell.InnerObject Property

DocxCellInnerObject Property

L'oggetto interno

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCell InnerObject { get; set; }
Public Property InnerObject As TableCell
    Get
    Set
public:
property TableCell^ InnerObject {
    TableCell^ get ();
    void set (TableCell^ value);
}
member InnerObject : TableCell with get, set

Property Value

TableCell
The inner object.
See Also

Reference

DocxCell Class


DocxCell.Italic Property

DocxCellItalic Property

Sets a value indicating whether this DocxCell is italic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Italic { set; }
Public WriteOnly Property Italic As Boolean
    Set
public:
property bool Italic {
    void set (bool value);
}
member Italic : bool with set

Property Value

Boolean
true if italic; otherwise, false.
See Also

Reference

DocxCell Class


DocxCell.Section Property

DocxCellSection Property

Ritorna la sezione di appartenenza

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection Section { get; }
Public ReadOnly Property Section As DocxSection
    Get
public:
property DocxSection^ Section {
    DocxSection^ get ();
}
member Section : DocxSection with get

Property Value

DocxSection
The section.
See Also

Reference

DocxCell Class


DocxCell.Text Property

DocxCellText Property

Get cell text.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

String
See Also

Reference

DocxCell Class


DocxCell.Width Property

DocxCellWidth Property

Larghezza della cella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
See Also

Reference

DocxCell Class


DocxCell Methods

The DocxCell type exposes the following members.

Methods
 | Name | Description
Public method | AddBookmarkText | Adds the bookmark text.
Public method | AddField | Adds the field. Warning: not complete!
Public method | AddHyperlink | Aggiunge un hyperlink
Public method | AddImage(Image, Int32, Int32) | Aggiunge un'immagine. L'immagine deve essere in formato PNG.
Public method | AddImage(String, Int32, Int32) | Aggiunge un'immagine
Public method | AddNewLine | Aggiunge una linea vuota.
Public method | AddParagraph | Aggiunge un paragrafo
Public method | AddTab | Aggiunge una tabulazione
Public method | AddTable | Aggiunge una tabella
Public method | AddText | Aggiunge un testo al paragrafo corrente di una cella
Public method | CloneFormat | Copia il formato della cella leggendo le informazioni dalla cella specificata in ingresso.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetColumnIndex | Ritorna l'indice della colonna a cui la cella appartiene.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRowIndex | Ritorna l'indice della riga a cui la cella appartiene.
Public method | GetTable | Ritorna la tabella in cui è contenuta la cella.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetAlignmentHorizontal | Sets the alignement.
Public method | SetAlignmentVertical | Sets the alignment vertical.
Public method | SetBackgroundColor(Color) | Sets the color of the background.
Public method | SetBackgroundColor(Int32, Int32, Int32) | Sets the color of the background.
Public method | SetBottomPadding | Sets the bottom padding of the cell.
Public method | SetFontBold | Sets the font bold.
Public method | SetFontItalic | Imposta il font come italic
Public method | SetFontName | Imposta il font di tutta la cella
Public method | SetFontSize | Imposta l'altezza del font di tutta la cella
Public method | SetLeftPadding | Sets the left padding of the cell.
Public method | SetLineSpacing | Sets the line spacing.
Public method | SetRightPadding | Sets the right padding of the cell.
Public method | SetTopPadding | Sets the top padding of the cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxCell Class


DocxCell.AddBookmarkText Method

DocxCellAddBookmarkText Method

Adds the bookmark text.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun AddBookmarkText(
    string bookmarkName,
    string txt
)
Public Function AddBookmarkText (
    bookmarkName As String,
    txt As String
) As DocxRun
public:
DocxRun^ AddBookmarkText(
    String^ bookmarkName,
    String^ txt
)
member AddBookmarkText :
        bookmarkName : string *
        txt : string -> DocxRun

Parameters

bookmarkName String
Name of the bookmark.
txt String
The text.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxCell Class


DocxCell.AddField Method

DocxCellAddField Method

Adds the field. Warning: not complete!

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddField(
    string formula
)
Public Sub AddField (
    formula As String
)
public:
void AddField(
    String^ formula
)
member AddField :
        formula : string -> unit

Parameters

formula String
The formula.
See Also

Reference

DocxCell Class


DocxCell.AddHyperlink Method

DocxCellAddHyperlink Method

Aggiunge un hyperlink

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxHyperlink AddHyperlink(
    string bookmarkName,
    string txt,
    bool internalLink
)
Public Function AddHyperlink (
    bookmarkName As String,
    txt As String,
    internalLink As Boolean
) As DocxHyperlink
public:
DocxHyperlink^ AddHyperlink(
    String^ bookmarkName,
    String^ txt,
    bool internalLink
)
member AddHyperlink :
        bookmarkName : string *
        txt : string *
        internalLink : bool -> DocxHyperlink

Parameters

bookmarkName String
Name of the bookmark.
txt String
The text.
internalLink Boolean
if set to true [internal link].

Return Value

DocxHyperlink
DocxHyperlink.
See Also

Reference

DocxCell Class


DocxCell.AddImage Method

DocxCellAddImage Method

Overload List
 | Name | Description
Public method | AddImage(Image, Int32, Int32) | Aggiunge un'immagine. L'immagine deve essere in formato PNG.
Public method | AddImage(String, Int32, Int32) | Aggiunge un'immagine
Top
See Also

Reference

DocxCell Class


DocxCell.AddImage(Image, Int32, Int32) Method

DocxCellAddImage(Image, Int32, Int32) Method

Aggiunge un'immagine. L'immagine deve essere in formato PNG.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddImage(
    Image img,
    int width,
    int height
)
Public Sub AddImage (
    img As Image,
    width As Integer,
    height As Integer
)
public:
void AddImage(
    Image^ img,
    int width,
    int height
)
member AddImage :
        img : Image *
        width : int *
        height : int -> unit

Parameters

img Image
The picture.
width Int32
The width.
height Int32
The height.
See Also

Reference

DocxCell Class
AddImage Overload


DocxCell.AddImage(String, Int32, Int32) Method

DocxCellAddImage(String, Int32, Int32) Method

Aggiunge un'immagine

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddImage(
    string pictpath,
    int width,
    int height
)
Public Sub AddImage (
    pictpath As String,
    width As Integer,
    height As Integer
)
public:
void AddImage(
    String^ pictpath,
    int width,
    int height
)
member AddImage :
        pictpath : string *
        width : int *
        height : int -> unit

Parameters

pictpath String
The pictpath.
width Int32
The width.
height Int32
The height.
See Also

Reference

DocxCell Class
AddImage Overload


DocxCell.AddNewLine Method

DocxCellAddNewLine Method

Aggiunge una linea vuota.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell AddNewLine()
Public Function AddNewLine As DocxCell
public:
DocxCell^ AddNewLine()
member AddNewLine : unit -> DocxCell

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.AddParagraph Method

DocxCellAddParagraph Method

Aggiunge un paragrafo

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun AddParagraph(
    string txt
)
Public Function AddParagraph (
    txt As String
) As DocxRun
public:
DocxRun^ AddParagraph(
    String^ txt
)
member AddParagraph :
        txt : string -> DocxRun

Parameters

txt String
The text.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxCell Class


DocxCell.AddTab Method

DocxCellAddTab Method

Aggiunge una tabulazione

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell AddTab()
Public Function AddTab As DocxCell
public:
DocxCell^ AddTab()
member AddTab : unit -> DocxCell

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.AddTable Method

DocxCellAddTable Method

Aggiunge una tabella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddTable(
    int rows,
    int columns
)
Public Function AddTable (
    rows As Integer,
    columns As Integer
) As DocxTable
public:
DocxTable^ AddTable(
    int rows,
    int columns
)
member AddTable :
        rows : int *
        columns : int -> DocxTable

Parameters

rows Int32
The rows.
columns Int32
The columns.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxCell Class


DocxCell.AddText Method

DocxCellAddText Method

Aggiunge un testo al paragrafo corrente di una cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun AddText(
    string txt
)
Public Function AddText (
    txt As String
) As DocxRun
public:
DocxRun^ AddText(
    String^ txt
)
member AddText :
        txt : string -> DocxRun

Parameters

txt String
The text.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxCell Class


DocxCell.CloneFormat Method

DocxCellCloneFormat Method

Copia il formato della cella leggendo le informazioni dalla cella specificata in ingresso.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CloneFormat(
    DocxCell cell
)
Public Sub CloneFormat (
    cell As DocxCell
)
public:
void CloneFormat(
    DocxCell^ cell
)
member CloneFormat :
        cell : DocxCell -> unit

Parameters

cell DocxCell

[Missing <param name="cell"/> documentation for "M:QsGemBox.Docx.DocxCell.CloneFormat(QsGemBox.Docx.DocxCell)"]

See Also

Reference

DocxCell Class


DocxCell.GetColumnIndex Method

DocxCellGetColumnIndex Method

Ritorna l'indice della colonna a cui la cella appartiene.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetColumnIndex()
Public Function GetColumnIndex As Integer
public:
int GetColumnIndex()
member GetColumnIndex : unit -> int

Return Value

Int32

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxCell.GetColumnIndex"]

See Also

Reference

DocxCell Class


DocxCell.GetRowIndex Method

DocxCellGetRowIndex Method

Ritorna l'indice della riga a cui la cella appartiene.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetRowIndex()
Public Function GetRowIndex As Integer
public:
int GetRowIndex()
member GetRowIndex : unit -> int

Return Value

Int32

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxCell.GetRowIndex"]

See Also

Reference

DocxCell Class


DocxCell.GetTable Method

DocxCellGetTable Method

Ritorna la tabella in cui è contenuta la cella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable GetTable()
Public Function GetTable As DocxTable
public:
DocxTable^ GetTable()
member GetTable : unit -> DocxTable

Return Value

DocxTable

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxCell.GetTable"]

See Also

Reference

DocxCell Class


DocxCell.SetAlignmentHorizontal Method

DocxCellSetAlignmentHorizontal Method

Sets the alignement.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetAlignmentHorizontal(
    string alignement
)
Public Function SetAlignmentHorizontal (
    alignement As String
) As DocxCell
public:
DocxCell^ SetAlignmentHorizontal(
    String^ alignement
)
member SetAlignmentHorizontal :
        alignement : string -> DocxCell

Parameters

alignement String
The alignement.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetAlignmentVertical Method

DocxCellSetAlignmentVertical Method

Sets the alignment vertical.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetAlignmentVertical(
    string alignement
)
Public Function SetAlignmentVertical (
    alignement As String
) As DocxCell
public:
DocxCell^ SetAlignmentVertical(
    String^ alignement
)
member SetAlignmentVertical :
        alignement : string -> DocxCell

Parameters

alignement String
The alignement.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetBackgroundColor Method

DocxCellSetBackgroundColor Method

Overload List
 | Name | Description
Public method | SetBackgroundColor(Color) | Sets the color of the background.
Public method | SetBackgroundColor(Int32, Int32, Int32) | Sets the color of the background.
Top
See Also

Reference

DocxCell Class


DocxCell.SetBackgroundColor(Color) Method

DocxCellSetBackgroundColor(Color) Method

Sets the color of the background.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetBackgroundColor(
    Color color
)
Public Function SetBackgroundColor (
    color As Color
) As DocxCell
public:
DocxCell^ SetBackgroundColor(
    Color color
)
member SetBackgroundColor :
        color : Color -> DocxCell

Parameters

color Color
The color.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class
SetBackgroundColor Overload


DocxCell.SetBackgroundColor(Int32, Int32, Int32) Method

DocxCellSetBackgroundColor(Int32, Int32, Int32) Method

Sets the color of the background.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetBackgroundColor(
    int r,
    int g,
    int b
)
Public Function SetBackgroundColor (
    r As Integer,
    g As Integer,
    b As Integer
) As DocxCell
public:
DocxCell^ SetBackgroundColor(
    int r,
    int g,
    int b
)
member SetBackgroundColor :
        r : int *
        g : int *
        b : int -> DocxCell

Parameters

r Int32
The r.
g Int32
The g.
b Int32
The b.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class
SetBackgroundColor Overload


DocxCell.SetBottomPadding Method

DocxCellSetBottomPadding Method

Sets the bottom padding of the cell.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetBottomPadding(
    double bottom
)
Public Function SetBottomPadding (
    bottom As Double
) As DocxCell
public:
DocxCell^ SetBottomPadding(
    double bottom
)
member SetBottomPadding :
        bottom : float -> DocxCell

Parameters

bottom Double
Value of the bottom padding.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetFontBold Method

DocxCellSetFontBold Method

Sets the font bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetFontBold(
    bool bold
)
Public Function SetFontBold (
    bold As Boolean
) As DocxCell
public:
DocxCell^ SetFontBold(
    bool bold
)
member SetFontBold :
        bold : bool -> DocxCell

Parameters

bold Boolean
if set to true [bold].

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetFontItalic Method

DocxCellSetFontItalic Method

Imposta il font come italic

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetFontItalic(
    bool italic
)
Public Function SetFontItalic (
    italic As Boolean
) As DocxCell
public:
DocxCell^ SetFontItalic(
    bool italic
)
member SetFontItalic :
        italic : bool -> DocxCell

Parameters

italic Boolean
if set to true [italic].

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetFontName Method

DocxCellSetFontName Method

Imposta il font di tutta la cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetFontName(
    string fontName
)
Public Function SetFontName (
    fontName As String
) As DocxCell
public:
DocxCell^ SetFontName(
    String^ fontName
)
member SetFontName :
        fontName : string -> DocxCell

Parameters

fontName String
Name of the font.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetFontSize Method

DocxCellSetFontSize Method

Imposta l'altezza del font di tutta la cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetFontSize(
    double fontSize
)
Public Function SetFontSize (
    fontSize As Double
) As DocxCell
public:
DocxCell^ SetFontSize(
    double fontSize
)
member SetFontSize :
        fontSize : float -> DocxCell

Parameters

fontSize Double
Size of the font.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetLeftPadding Method

DocxCellSetLeftPadding Method

Sets the left padding of the cell.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetLeftPadding(
    double left
)
Public Function SetLeftPadding (
    left As Double
) As DocxCell
public:
DocxCell^ SetLeftPadding(
    double left
)
member SetLeftPadding :
        left : float -> DocxCell

Parameters

left Double
Value of the left padding.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetLineSpacing Method

DocxCellSetLineSpacing Method

Sets the line spacing.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetLineSpacing(
    double lineSpacing
)
Public Function SetLineSpacing (
    lineSpacing As Double
) As DocxCell
public:
DocxCell^ SetLineSpacing(
    double lineSpacing
)
member SetLineSpacing :
        lineSpacing : float -> DocxCell

Parameters

lineSpacing Double
The line spacing.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetRightPadding Method

DocxCellSetRightPadding Method

Sets the right padding of the cell.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetRightPadding(
    double right
)
Public Function SetRightPadding (
    right As Double
) As DocxCell
public:
DocxCell^ SetRightPadding(
    double right
)
member SetRightPadding :
        right : float -> DocxCell

Parameters

right Double
Value of the right padding.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCell.SetTopPadding Method

DocxCellSetTopPadding Method

Sets the top padding of the cell.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell SetTopPadding(
    double top
)
Public Function SetTopPadding (
    top As Double
) As DocxCell
public:
DocxCell^ SetTopPadding(
    double top
)
member SetTopPadding :
        top : float -> DocxCell

Parameters

top Double
Value of the top padding.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxCell Class


DocxCellIterator Class

Class DocxCellIterator.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxCellIterator

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxCellIterator : IEnumerable<DocxCell>,
    IEnumerable
Public Class DocxCellIterator
    Implements IEnumerable(Of DocxCell), IEnumerable
public ref class DocxCellIterator : IEnumerable<DocxCell^>,
    IEnumerable
type DocxCellIterator =
    class
        interface IEnumerable<DocxCell>
        interface IEnumerable
    end

The DocxCellIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DocxCellIterator | Initializes a new instance of the DocxCellIterator class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace
DocxCell
DocxCell


DocxCellIterator Constructor

Initializes a new instance of the DocxCellIterator class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCellIterator(
    Table innerObject
)
Public Sub New (
    innerObject As Table
)
public:
DocxCellIterator(
    Table^ innerObject
)
new :
        innerObject : Table -> DocxCellIterator

Parameters

innerObject Table
The inner object.
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

DocxCellIterator Class


DocxCellIterator Methods

The DocxCellIterator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxCellIterator Class


DocxCellIterator.GetEnumerator Method

DocxCellIteratorGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<DocxCell> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DocxCell)
public:
virtual IEnumerator<DocxCell^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<DocxCell>
override GetEnumerator : unit -> IEnumerator<DocxCell>

Return Value

IEnumerator DocxCell
An enumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DocxCellIterator Class


DocxCharacterFormat Class

[Missing <summary> documentation for "T:QsGemBox.Docx.DocxCharacterFormat"]

Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxCharacterFormat

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxCharacterFormat
Public Class DocxCharacterFormat
public ref class DocxCharacterFormat
type DocxCharacterFormat = class end

The DocxCharacterFormat type exposes the following members.

Constructors
 | Name | Description
Public method | DocxCharacterFormat | Initializes a new instance of the DocxCharacterFormat class.
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | Size | Gets or sets the font size (in points) which shall be applied to the text of the run when displayed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxCharacterFormat Constructor

Initializes a new instance of the DocxCharacterFormat class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCharacterFormat(
    CharacterFormat innerObject
)
Public Sub New (
    innerObject As CharacterFormat
)
public:
DocxCharacterFormat(
    CharacterFormat^ innerObject
)
new :
        innerObject : CharacterFormat -> DocxCharacterFormat

Parameters

innerObject CharacterFormat
The inner object.
See Also

Reference

DocxCharacterFormat Class


DocxCharacterFormat Properties

The DocxCharacterFormat type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | Size | Gets or sets the font size (in points) which shall be applied to the text of the run when displayed.
Top
See Also

Reference

DocxCharacterFormat Class


DocxCharacterFormat.InnerObject Property

DocxCharacterFormatInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public CharacterFormat InnerObject { get; set; }
Public Property InnerObject As CharacterFormat
    Get
    Set
public:
property CharacterFormat^ InnerObject {
    CharacterFormat^ get ();
    void set (CharacterFormat^ value);
}
member InnerObject : CharacterFormat with get, set

Property Value

CharacterFormat
The inner object.
See Also

Reference

DocxCharacterFormat Class


DocxCharacterFormat.Size Property

DocxCharacterFormatSize Property

Gets or sets the font size (in points) which shall be applied to the text of the run when displayed.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Size { get; set; }
Public Property Size As Double
    Get
    Set
public:
property double Size {
    double get ();
    void set (double value);
}
member Size : float with get, set

Property Value

Double
See Also

Reference

DocxCharacterFormat Class


DocxCharacterFormat Methods

The DocxCharacterFormat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxCharacterFormat Class


DocxCharacterStyle Class

CharacterStyle wrapper
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxCharacterStyle

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxCharacterStyle
Public Class DocxCharacterStyle
public ref class DocxCharacterStyle
type DocxCharacterStyle = class end

The DocxCharacterStyle type exposes the following members.

Constructors
 | Name | Description
Public method | DocxCharacterStyle | Initializes a new instance of the DocxCharacterStyle class.
Public method | DocxCharacterStyle(CharacterStyle) | Initializes a new instance of the DocxCharacterStyle class.
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetColor | Sets the color.
Public method | SetProperty | Sets the property. Used for generic (not so common) properties
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxCharacterStyle Constructor

Overload List
 | Name | Description
Public method | DocxCharacterStyle | Initializes a new instance of the DocxCharacterStyle class.
Public method | DocxCharacterStyle(CharacterStyle) | Initializes a new instance of the DocxCharacterStyle class.
Top
See Also

Reference

DocxCharacterStyle Class


DocxCharacterStyle Constructor

Initializes a new instance of the DocxCharacterStyle class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCharacterStyle()
Public Sub New
public:
DocxCharacterStyle()
new : unit -> DocxCharacterStyle
See Also

Reference

DocxCharacterStyle Class
DocxCharacterStyle Overload


DocxCharacterStyle(CharacterStyle) Constructor

Initializes a new instance of the DocxCharacterStyle class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCharacterStyle(
    CharacterStyle innerObject
)
Public Sub New (
    innerObject As CharacterStyle
)
public:
DocxCharacterStyle(
    CharacterStyle^ innerObject
)
new :
        innerObject : CharacterStyle -> DocxCharacterStyle

Parameters

innerObject CharacterStyle
The inner object.
See Also

Reference

DocxCharacterStyle Class
DocxCharacterStyle Overload


DocxCharacterStyle Properties

The DocxCharacterStyle type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Top
See Also

Reference

DocxCharacterStyle Class


DocxCharacterStyle.InnerObject Property

DocxCharacterStyleInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public CharacterStyle InnerObject { get; set; }
Public Property InnerObject As CharacterStyle
    Get
    Set
public:
property CharacterStyle^ InnerObject {
    CharacterStyle^ get ();
    void set (CharacterStyle^ value);
}
member InnerObject : CharacterStyle with get, set

Property Value

CharacterStyle
The inner object.
See Also

Reference

DocxCharacterStyle Class


DocxCharacterStyle Methods

The DocxCharacterStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetColor | Sets the color.
Public method | SetProperty | Sets the property. Used for generic (not so common) properties
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxCharacterStyle Class


DocxCharacterStyle.SetColor Method

DocxCharacterStyleSetColor Method

Sets the color.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColor(
    int r,
    int g,
    int b
)
Public Sub SetColor (
    r As Integer,
    g As Integer,
    b As Integer
)
public:
void SetColor(
    int r,
    int g,
    int b
)
member SetColor :
        r : int *
        g : int *
        b : int -> unit

Parameters

r Int32
The r.
g Int32
The g.
b Int32
The b.
See Also

Reference

DocxCharacterStyle Class


DocxCharacterStyle.SetProperty Method

DocxCharacterStyleSetProperty Method

Sets the property. Used for generic (not so common) properties

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetProperty(
    string propname,
    Object propvalue
)
Public Function SetProperty (
    propname As String,
    propvalue As Object
) As Boolean
public:
bool SetProperty(
    String^ propname,
    Object^ propvalue
)
member SetProperty :
        propname : string *
        propvalue : Object -> bool

Parameters

propname String
The propname.
propvalue Object
The propvalue.

Return Value

Boolean
true if XXXX, false otherwise.
Exceptions
Exception | Condition
Exception |
Exception |
See Also

Reference

DocxCharacterStyle Class


DocxDocument Class

Class DocxDocument.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxDocument

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxDocument
Public Class DocxDocument
public ref class DocxDocument
type DocxDocument = class end

The DocxDocument type exposes the following members.

Constructors
 | Name | Description
Public method | DocxDocument | Initializes a new instance of the DocxDocument class.
Top
Properties
 | Name | Description
Public property | DocumentPath | Gets or sets the document path.
Public property | InnerObject | Gets or sets the inner object.
Top
Methods
 | Name | Description
Public method | ActivateAdvancedMerging | Activates the advanced merging. Using fields prefixes we can decide what kind of data insert into the field
Public method | AddBookmarkText | Adds the bookmark text.
Public method | AddCharacterStyle | Aggiunge un nuovo stile di carattere
Public method | AddFooterPage | Aggiunge il footer standard con il numero di pagina
Public method | AddHyperlink | Aggiunge un hyperlink al documento.
Public method | AddImage(Image, Int32, Int32) | Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.
Public method | AddImage(String, Int32, Int32) | Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.
Public method | AddNewLine | Aggiunge una nuova linea (a capo).
Public method | AddPageBreak | Inserisce una interruzione di pagina
Public method | AddParagraph | Adds the text as new paragraph.
Public method | AddParagraphStyle | Aggiunge uno stile di paragrafo
Public method | AddStyle | Crea un nuovo stile e lo salva nel documento
Public method | AddTab | Inserisce una tabulazione
Public method | AddTable(DataTable) | Adds the table.
Public method | AddTable(Int32, Int32) | Aggiunge una tabella di r righe e c colonne
Public method | AddTableOfContents(String, Int32) | Adds the summary.
Public method | AddTableOfContents(String, String, Int32, DocxDocumentSummaryOrientationEnum, Boolean, Boolean) | Adds the summary.
Public method | AddTableStyle | Aggiunge un nuovo stile di tabella.
Public method | AddText | Adds the text inline (current paragraph)
Public method | AddTextBox | Aggiunge una textbox TODO: completare passando le informazioni corrette per il posizionamento. Una volta creata non si può modificare.
Public method | AppendDocument(DocxDocument, Boolean) | Append a document at the end of the current one
Public method | AppendDocument(String, Boolean) | Append a document at the end of the current one
Public method | AppendDocumentToSection | Append a document after the section.
 | CreateImageProxy | Crea un proxy immagine. E' una funzione di servizio per non dover importare il tipo in Lua
Public method | EnsureSection | Ensures the section.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | FindTextByRegex | Finds the text by regex.
Public method | GetAllFields | Gets all fields contained into the document.
Public method | GetAllSections | Ritorna tutte le sezioni presenti nel documento.
Public method | GetAllTables | Gets all tables contained into the document.
Public method | GetAvailableListStyles | Ritorna una lista con gli stili di lista standard
Public method | GetBookmarkText | Ritorna il testo di un bookmark
Public method | GetBuiltInProperties | Ritorna le proprietà standard del documento
Public method | GetCustomProperties | Ritorna le proprietà custom del documento
Public method | GetFieldNames | Gets the field names.
Public method | GetFirstRun | Ritorna il primo run del documento.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPaginator | Gets the document paginator. Object to manage the documents page. Create a new object every time (like Gembox).
Public method | GetSection | Ritorna la sezione all'indice passato
Public method | GetStyleNames | Ritorna i nomi degli stili
Public method | GetTableStyle | Ritorna lo stile di tabella in base al nome specificato in ingresso. Ritorna 'null' se il nome specificato è vuoto
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MailMerge | Esegue il mailmerge a partire dalla tabella lua.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadForm | Legge un form Word
Public method | RemoveParagraph | Eliminata dalla lista dei blocks il paragrafo
Public method | ReplaceText(String, String) | Search and replace NO regex
Public method | ReplaceText(String, String, Boolean) | Replace text into the document, regex allowed
Public method | ReplaceTextWithImage | Replace a placehloder with the given image
Public method | Save | Just Save
Public method | SaveAs | Save the document as...
Public method | SetBookmark | Imposta il bookmark con il valore passato
Public method | SetBookmarks | Imposta i bookmarks dalla tabella lua passata
Public method | SetField | Imposta un campo nel documento
Public method | SetProperties | Imposta le proprietà del documento leggendo una tabella nome-valore in lua. Da priorità alle proprietà standard del documento e poi a quelle custom.
Public method | SetSectionOrientation | Imposta l'orientamento della sezione
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateTableOfContent | Updates the table of content making dirty the document.
Public method | UpdateTableOfContent(Boolean) | Updates the table of content making dirty the document.
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxDocument Constructor

Initializes a new instance of the DocxDocument class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument(
    DocumentModel innerObject,
    string documentpath
)
Public Sub New (
    innerObject As DocumentModel,
    documentpath As String
)
public:
DocxDocument(
    DocumentModel^ innerObject,
    String^ documentpath
)
new :
        innerObject : DocumentModel *
        documentpath : string -> DocxDocument

Parameters

innerObject DocumentModel
The inner object.
documentpath String
The documentpath.
See Also

Reference

DocxDocument Class


DocxDocument Properties

The DocxDocument type exposes the following members.

Properties
 | Name | Description
Public property | DocumentPath | Gets or sets the document path.
Public property | InnerObject | Gets or sets the inner object.
Top
See Also

Reference

DocxDocument Class


DocxDocument.DocumentPath Property

DocxDocumentDocumentPath Property

Gets or sets the document path.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DocumentPath { get; set; }
Public Property DocumentPath As String
    Get
    Set
public:
property String^ DocumentPath {
    String^ get ();
    void set (String^ value);
}
member DocumentPath : string with get, set

Property Value

String
The document path.
See Also

Reference

DocxDocument Class


DocxDocument.InnerObject Property

DocxDocumentInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentModel InnerObject { get; set; }
Public Property InnerObject As DocumentModel
    Get
    Set
public:
property DocumentModel^ InnerObject {
    DocumentModel^ get ();
    void set (DocumentModel^ value);
}
member InnerObject : DocumentModel with get, set

Property Value

DocumentModel
The inner object.
See Also

Reference

DocxDocument Class


DocxDocument Methods

The DocxDocument type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAdvancedMerging | Activates the advanced merging. Using fields prefixes we can decide what kind of data insert into the field
Public method | AddBookmarkText | Adds the bookmark text.
Public method | AddCharacterStyle | Aggiunge un nuovo stile di carattere
Public method | AddFooterPage | Aggiunge il footer standard con il numero di pagina
Public method | AddHyperlink | Aggiunge un hyperlink al documento.
Public method | AddImage(Image, Int32, Int32) | Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.
Public method | AddImage(String, Int32, Int32) | Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.
Public method | AddNewLine | Aggiunge una nuova linea (a capo).
Public method | AddPageBreak | Inserisce una interruzione di pagina
Public method | AddParagraph | Adds the text as new paragraph.
Public method | AddParagraphStyle | Aggiunge uno stile di paragrafo
Public method | AddStyle | Crea un nuovo stile e lo salva nel documento
Public method | AddTab | Inserisce una tabulazione
Public method | AddTable(DataTable) | Adds the table.
Public method | AddTable(Int32, Int32) | Aggiunge una tabella di r righe e c colonne
Public method | AddTableOfContents(String, Int32) | Adds the summary.
Public method | AddTableOfContents(String, String, Int32, DocxDocumentSummaryOrientationEnum, Boolean, Boolean) | Adds the summary.
Public method | AddTableStyle | Aggiunge un nuovo stile di tabella.
Public method | AddText | Adds the text inline (current paragraph)
Public method | AddTextBox | Aggiunge una textbox TODO: completare passando le informazioni corrette per il posizionamento. Una volta creata non si può modificare.
Public method | AppendDocument(DocxDocument, Boolean) | Append a document at the end of the current one
Public method | AppendDocument(String, Boolean) | Append a document at the end of the current one
Public method | AppendDocumentToSection | Append a document after the section.
 | CreateImageProxy | Crea un proxy immagine. E' una funzione di servizio per non dover importare il tipo in Lua
Public method | EnsureSection | Ensures the section.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | FindTextByRegex | Finds the text by regex.
Public method | GetAllFields | Gets all fields contained into the document.
Public method | GetAllSections | Ritorna tutte le sezioni presenti nel documento.
Public method | GetAllTables | Gets all tables contained into the document.
Public method | GetAvailableListStyles | Ritorna una lista con gli stili di lista standard
Public method | GetBookmarkText | Ritorna il testo di un bookmark
Public method | GetBuiltInProperties | Ritorna le proprietà standard del documento
Public method | GetCustomProperties | Ritorna le proprietà custom del documento
Public method | GetFieldNames | Gets the field names.
Public method | GetFirstRun | Ritorna il primo run del documento.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPaginator | Gets the document paginator. Object to manage the documents page. Create a new object every time (like Gembox).
Public method | GetSection | Ritorna la sezione all'indice passato
Public method | GetStyleNames | Ritorna i nomi degli stili
Public method | GetTableStyle | Ritorna lo stile di tabella in base al nome specificato in ingresso. Ritorna 'null' se il nome specificato è vuoto
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MailMerge | Esegue il mailmerge a partire dalla tabella lua.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadForm | Legge un form Word
Public method | RemoveParagraph | Eliminata dalla lista dei blocks il paragrafo
Public method | ReplaceText(String, String) | Search and replace NO regex
Public method | ReplaceText(String, String, Boolean) | Replace text into the document, regex allowed
Public method | ReplaceTextWithImage | Replace a placehloder with the given image
Public method | Save | Just Save
Public method | SaveAs | Save the document as...
Public method | SetBookmark | Imposta il bookmark con il valore passato
Public method | SetBookmarks | Imposta i bookmarks dalla tabella lua passata
Public method | SetField | Imposta un campo nel documento
Public method | SetProperties | Imposta le proprietà del documento leggendo una tabella nome-valore in lua. Da priorità alle proprietà standard del documento e poi a quelle custom.
Public method | SetSectionOrientation | Imposta l'orientamento della sezione
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateTableOfContent | Updates the table of content making dirty the document.
Public method | UpdateTableOfContent(Boolean) | Updates the table of content making dirty the document.
Top
See Also

Reference

DocxDocument Class


DocxDocument.ActivateAdvancedMerging Method

DocxDocumentActivateAdvancedMerging Method

Activates the advanced merging. Using fields prefixes we can decide what kind of data insert into the field

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateAdvancedMerging()
Public Sub ActivateAdvancedMerging
public:
void ActivateAdvancedMerging()
member ActivateAdvancedMerging : unit -> unit
See Also

Reference

DocxDocument Class


DocxDocument.AddBookmarkText Method

DocxDocumentAddBookmarkText Method

Adds the bookmark text.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun AddBookmarkText(
    string bookmarkName,
    string txt
)
Public Function AddBookmarkText (
    bookmarkName As String,
    txt As String
) As DocxRun
public:
DocxRun^ AddBookmarkText(
    String^ bookmarkName,
    String^ txt
)
member AddBookmarkText :
        bookmarkName : string *
        txt : string -> DocxRun

Parameters

bookmarkName String
Name of the bookmark.
txt String
The text.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxDocument Class


DocxDocument.AddCharacterStyle Method

DocxDocumentAddCharacterStyle Method

Aggiunge un nuovo stile di carattere

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCharacterStyle AddCharacterStyle(
    string name
)
Public Function AddCharacterStyle (
    name As String
) As DocxCharacterStyle
public:
DocxCharacterStyle^ AddCharacterStyle(
    String^ name
)
member AddCharacterStyle :
        name : string -> DocxCharacterStyle

Parameters

name String
Il nome dello stile

Return Value

DocxCharacterStyle
L'oggetto stile
See Also

Reference

DocxDocument Class


DocxDocument.AddFooterPage Method

DocxDocumentAddFooterPage Method

Aggiunge il footer standard con il numero di pagina

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddFooterPage(
    string headertxt
)
Public Sub AddFooterPage (
    headertxt As String
)
public:
void AddFooterPage(
    String^ headertxt
)
member AddFooterPage :
        headertxt : string -> unit

Parameters

headertxt String
The headertxt.
See Also

Reference

DocxDocument Class


DocxDocument.AddHyperlink Method

DocxDocumentAddHyperlink Method

Aggiunge un hyperlink al documento.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxHyperlink AddHyperlink(
    string bookmarkName,
    string txt,
    bool internalLink
)
Public Function AddHyperlink (
    bookmarkName As String,
    txt As String,
    internalLink As Boolean
) As DocxHyperlink
public:
DocxHyperlink^ AddHyperlink(
    String^ bookmarkName,
    String^ txt,
    bool internalLink
)
member AddHyperlink :
        bookmarkName : string *
        txt : string *
        internalLink : bool -> DocxHyperlink

Parameters

bookmarkName String
Nome del bookmark.
txt String
The text.
internalLink Boolean
if set to true [internal link].

Return Value

DocxHyperlink
DocxHyperlink.
See Also

Reference

DocxDocument Class


DocxDocument.AddImage Method

DocxDocumentAddImage Method

Overload List
 | Name | Description
Public method | AddImage(Image, Int32, Int32) | Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.
Public method | AddImage(String, Int32, Int32) | Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.
Top
See Also

Reference

DocxDocument Class


DocxDocument.AddImage(Image, Int32, Int32) Method

DocxDocumentAddImage(Image, Int32, Int32) Method

Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddImage(
    Image pict,
    int width,
    int height
)
Public Sub AddImage (
    pict As Image,
    width As Integer,
    height As Integer
)
public:
void AddImage(
    Image^ pict,
    int width,
    int height
)
member AddImage :
        pict : Image *
        width : int *
        height : int -> unit

Parameters

pict Image
The pictpath.
width Int32
The width.
height Int32
The height.
See Also

Reference

DocxDocument Class
AddImage Overload


DocxDocument.AddImage(String, Int32, Int32) Method

DocxDocumentAddImage(String, Int32, Int32) Method

Aggiunge un'immagine al documento. Passare le dimensioni dell'immagine. Passare 0 e 0 per lasciare i valori predefiniti di immagine.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddImage(
    string pictpath,
    int width,
    int height
)
Public Sub AddImage (
    pictpath As String,
    width As Integer,
    height As Integer
)
public:
void AddImage(
    String^ pictpath,
    int width,
    int height
)
member AddImage :
        pictpath : string *
        width : int *
        height : int -> unit

Parameters

pictpath String
Il percorso all'immagine.
width Int32
Larghezza dell'immagine.
height Int32
Altezza dell'immagine.
See Also

Reference

DocxDocument Class
AddImage Overload


DocxDocument.AddNewLine Method

DocxDocumentAddNewLine Method

Aggiunge una nuova linea (a capo).

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument AddNewLine()
Public Function AddNewLine As DocxDocument
public:
DocxDocument^ AddNewLine()
member AddNewLine : unit -> DocxDocument

Return Value

DocxDocument
DocxDocument.
See Also

Reference

DocxDocument Class


DocxDocument.AddPageBreak Method

DocxDocumentAddPageBreak Method

Inserisce una interruzione di pagina

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument AddPageBreak()
Public Function AddPageBreak As DocxDocument
public:
DocxDocument^ AddPageBreak()
member AddPageBreak : unit -> DocxDocument

Return Value

DocxDocument
DocxDocument.
See Also

Reference

DocxDocument Class


DocxDocument.AddParagraph Method

DocxDocumentAddParagraph Method

Adds the text as new paragraph.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph AddParagraph(
    string txt
)
Public Function AddParagraph (
    txt As String
) As DocxParagraph
public:
DocxParagraph^ AddParagraph(
    String^ txt
)
member AddParagraph :
        txt : string -> DocxParagraph

Parameters

txt String
The text.

Return Value

DocxParagraph
DocxParagraph.
See Also

Reference

DocxDocument Class


DocxDocument.AddParagraphStyle Method

DocxDocumentAddParagraphStyle Method

Aggiunge uno stile di paragrafo

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraphStyle AddParagraphStyle(
    string name
)
Public Function AddParagraphStyle (
    name As String
) As DocxParagraphStyle
public:
DocxParagraphStyle^ AddParagraphStyle(
    String^ name
)
member AddParagraphStyle :
        name : string -> DocxParagraphStyle

Parameters

name String
Il nome dello stile

Return Value

DocxParagraphStyle
L'oggetto stile
See Also

Reference

DocxDocument Class


DocxDocument.AddStyle Method

DocxDocumentAddStyle Method

Crea un nuovo stile e lo salva nel documento

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Style AddStyle(
    StyleTemplateType stt
)
Public Function AddStyle (
    stt As StyleTemplateType
) As Style
public:
Style^ AddStyle(
    StyleTemplateType stt
)
member AddStyle :
        stt : StyleTemplateType -> Style

Parameters

stt StyleTemplateType
The STT.

Return Value

Style
L'oggetto stile
See Also

Reference

DocxDocument Class


DocxDocument.AddTab Method

DocxDocumentAddTab Method

Inserisce una tabulazione

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument AddTab()
Public Function AddTab As DocxDocument
public:
DocxDocument^ AddTab()
member AddTab : unit -> DocxDocument

Return Value

DocxDocument
DocxDocument.
See Also

Reference

DocxDocument Class


DocxDocument.AddTable Method

DocxDocumentAddTable Method

Overload List
 | Name | Description
Public method | AddTable(DataTable) | Adds the table.
Public method | AddTable(Int32, Int32) | Aggiunge una tabella di r righe e c colonne
Top
See Also

Reference

DocxDocument Class


DocxDocument.AddTable(DataTable) Method

DocxDocumentAddTable(DataTable) Method

Adds the table.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddTable(
    DataTable dt
)
Public Function AddTable (
    dt As DataTable
) As DocxTable
public:
DocxTable^ AddTable(
    DataTable^ dt
)
member AddTable :
        dt : DataTable -> DocxTable

Parameters

dt DataTable
The datatable.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxDocument Class
AddTable Overload


DocxDocument.AddTable(Int32, Int32) Method

DocxDocumentAddTable(Int32, Int32) Method

Aggiunge una tabella di r righe e c colonne

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddTable(
    int rows,
    int columns
)
Public Function AddTable (
    rows As Integer,
    columns As Integer
) As DocxTable
public:
DocxTable^ AddTable(
    int rows,
    int columns
)
member AddTable :
        rows : int *
        columns : int -> DocxTable

Parameters

rows Int32
Numero di righe
columns Int32
Numero di colonne

Return Value

DocxTable
L'oggetto tabella
See Also

Reference

DocxDocument Class
AddTable Overload


DocxDocument.AddTableOfContents Method

DocxDocumentAddTableOfContents Method

Overload List
 | Name | Description
Public method | AddTableOfContents(String, Int32) | Adds the summary.
Public method | AddTableOfContents(String, String, Int32, DocxDocumentSummaryOrientationEnum, Boolean, Boolean) | Adds the summary.
Top
See Also

Reference

DocxDocument Class


DocxDocument.AddTableOfContents(String, Int32) Method

DocxDocumentAddTableOfContents(String, Int32) Method

Adds the summary.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddTableOfContents(
    string title,
    int position
)
Public Sub AddTableOfContents (
    title As String,
    position As Integer
)
public:
void AddTableOfContents(
    String^ title,
    int position
)
member AddTableOfContents :
        title : string *
        position : int -> unit

Parameters

title String
The title.
position Int32
The position. -1 at the end of the document
See Also

Reference

DocxDocument Class
AddTableOfContents Overload


DocxDocument.AddTableOfContents(String, String, Int32, DocxDocument.SummaryOrientationEnum, Boolean, Boolean) Method

DocxDocumentAddTableOfContents(String, String, Int32, DocxDocumentSummaryOrientationEnum, Boolean, Boolean) Method

Adds the summary.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddTableOfContents(
    string title,
    string styleName,
    int position,
    DocxDocumentSummaryOrientationEnum orientation,
    bool addPageBreak,
    bool updateTocOnOpening
)
Public Sub AddTableOfContents (
    title As String,
    styleName As String,
    position As Integer,
    orientation As DocxDocumentSummaryOrientationEnum,
    addPageBreak As Boolean,
    updateTocOnOpening As Boolean
)
public:
void AddTableOfContents(
    String^ title,
    String^ styleName,
    int position,
    DocxDocumentSummaryOrientationEnum orientation,
    bool addPageBreak,
    bool updateTocOnOpening
)
member AddTableOfContents :
        title : string *
        styleName : string *
        position : int *
        orientation : DocxDocumentSummaryOrientationEnum *
        addPageBreak : bool *
        updateTocOnOpening : bool -> unit

Parameters

title String
The title.
styleName String
Style name to apply to title. If doesn't exists will be used the 'Heading 1' style.
position Int32
The position. -1 at the end of the document.
orientation DocxDocumentSummaryOrientationEnum
Indicates the summary page orientation.
addPageBreak Boolean
Indicates if add an empty page after the summary.
updateTocOnOpening Boolean
Indicate if update TOC during opening document or now.
See Also

Reference

DocxDocument Class
AddTableOfContents Overload


DocxDocument.AddTableStyle Method

DocxDocumentAddTableStyle Method

Aggiunge un nuovo stile di tabella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableStyle AddTableStyle(
    string name
)
Public Function AddTableStyle (
    name As String
) As DocxTableStyle
public:
DocxTableStyle^ AddTableStyle(
    String^ name
)
member AddTableStyle :
        name : string -> DocxTableStyle

Parameters

name String
Il nome dello stile

Return Value

DocxTableStyle
L'oggetto stile
See Also

Reference

DocxDocument Class


DocxDocument.AddText Method

DocxDocumentAddText Method

Adds the text inline (current paragraph)

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun AddText(
    string txt
)
Public Function AddText (
    txt As String
) As DocxRun
public:
DocxRun^ AddText(
    String^ txt
)
member AddText :
        txt : string -> DocxRun

Parameters

txt String
The text.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxDocument Class


DocxDocument.AddTextBox Method

DocxDocumentAddTextBox Method

Aggiunge una textbox TODO: completare passando le informazioni corrette per il posizionamento. Una volta creata non si può modificare.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTextBox AddTextBox(
    string text
)
Public Function AddTextBox (
    text As String
) As DocxTextBox
public:
DocxTextBox^ AddTextBox(
    String^ text
)
member AddTextBox :
        text : string -> DocxTextBox

Parameters

text String
The text.

Return Value

DocxTextBox
DocxTextBox.
See Also

Reference

DocxDocument Class


DocxDocument.AppendDocument Method

DocxDocumentAppendDocument Method

Overload List
 | Name | Description
Public method | AppendDocument(DocxDocument, Boolean) | Append a document at the end of the current one
Public method | AppendDocument(String, Boolean) | Append a document at the end of the current one
Top
See Also

Reference

DocxDocument Class


DocxDocument.AppendDocument(DocxDocument, Boolean) Method

DocxDocumentAppendDocument(DocxDocument, Boolean) Method

Append a document at the end of the current one

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument AppendDocument(
    DocxDocument doc,
    bool useDestinationStyles
)
Public Function AppendDocument (
    doc As DocxDocument,
    useDestinationStyles As Boolean
) As DocxDocument
public:
DocxDocument^ AppendDocument(
    DocxDocument^ doc,
    bool useDestinationStyles
)
member AppendDocument :
        doc : DocxDocument *
        useDestinationStyles : bool -> DocxDocument

Parameters

doc DocxDocument
The document.
useDestinationStyles Boolean
if set to true [use destination styles].

Return Value

DocxDocument
DocxDocument.
Exceptions
Exception | Condition
ArgumentNullException | doc
ArgumentNullException | doc
See Also

Reference

DocxDocument Class
AppendDocument Overload


DocxDocument.AppendDocument(String, Boolean) Method

DocxDocumentAppendDocument(String, Boolean) Method

Append a document at the end of the current one

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument AppendDocument(
    string docpath,
    bool useDestinationStyles
)
Public Function AppendDocument (
    docpath As String,
    useDestinationStyles As Boolean
) As DocxDocument
public:
DocxDocument^ AppendDocument(
    String^ docpath,
    bool useDestinationStyles
)
member AppendDocument :
        docpath : string *
        useDestinationStyles : bool -> DocxDocument

Parameters

docpath String
The docpath.
useDestinationStyles Boolean
if set to true [use destination styles].

Return Value

DocxDocument
DocxDocument.
Exceptions
Exception | Condition
ArgumentNullException | docpath
ArgumentNullException | docpath
See Also

Reference

DocxDocument Class
AppendDocument Overload


DocxDocument.AppendDocumentToSection Method

DocxDocumentAppendDocumentToSection Method

Append a document after the section.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxDocument AppendDocumentToSection(
    DocxDocument doc,
    DocxSection section,
    bool useDestinationStyles,
    bool addPageBreak
)
Public Function AppendDocumentToSection (
    doc As DocxDocument,
    section As DocxSection,
    useDestinationStyles As Boolean,
    addPageBreak As Boolean
) As DocxDocument
public:
DocxDocument^ AppendDocumentToSection(
    DocxDocument^ doc,
    DocxSection^ section,
    bool useDestinationStyles,
    bool addPageBreak
)
member AppendDocumentToSection :
        doc : DocxDocument *
        section : DocxSection *
        useDestinationStyles : bool *
        addPageBreak : bool -> DocxDocument

Parameters

doc DocxDocument
The document.
section DocxSection
Index section.
useDestinationStyles Boolean
if set to true [use destination styles].
addPageBreak Boolean
if set to true add a page break before append document.

Return Value

DocxDocument
DocxDocument.
Exceptions
Exception | Condition
ArgumentNullException | doc
ArgumentNullException | doc
See Also

Reference

DocxDocument Class


DocxDocument.CreateImageProxy Method

DocxDocumentCreateImageProxy Method

Crea un proxy immagine. E' una funzione di servizio per non dover importare il tipo in Lua

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocxImageProxy CreateImageProxy(
    string imagepath
)
Public Shared Function CreateImageProxy (
    imagepath As String
) As DocxImageProxy
public:
static DocxImageProxy^ CreateImageProxy(
    String^ imagepath
)
static member CreateImageProxy :
        imagepath : string -> DocxImageProxy

Parameters

imagepath String
The imagepath.

Return Value

DocxImageProxy
Ritorna un proxy immagine
See Also

Reference

DocxDocument Class


DocxDocument.EnsureSection Method

DocxDocumentEnsureSection Method

Ensures the section.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnsureSection()
Public Sub EnsureSection
public:
void EnsureSection()
member EnsureSection : unit -> unit
See Also

Reference

DocxDocument Class


DocxDocument.FindTextByRegex Method

DocxDocumentFindTextByRegex Method

Finds the text by regex.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] FindTextByRegex(
    string regex
)
Public Function FindTextByRegex (
    regex As String
) As String()
public:
array<String^>^ FindTextByRegex(
    String^ regex
)
member FindTextByRegex :
        regex : string -> string[]

Parameters

regex String
The regex.

Return Value

String
System.String[].
See Also

Reference

DocxDocument Class


DocxDocument.GetAllFields Method

DocxDocumentGetAllFields Method

Gets all fields contained into the document.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<DocxField> GetAllFields()
Public Function GetAllFields As ICollection(Of DocxField)
public:
ICollection<DocxField^>^ GetAllFields()
member GetAllFields : unit -> ICollection<DocxField>

Return Value

ICollection DocxField
ICollection<DocxField>.
See Also

Reference

DocxDocument Class


DocxDocument.GetAllSections Method

DocxDocumentGetAllSections Method

Ritorna tutte le sezioni presenti nel documento.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<DocxSection> GetAllSections()
Public Function GetAllSections As List(Of DocxSection)
public:
List<DocxSection^>^ GetAllSections()
member GetAllSections : unit -> List<DocxSection>

Return Value

List DocxSection

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxDocument.GetAllSections"]

See Also

Reference

DocxDocument Class


DocxDocument.GetAllTables Method

DocxDocumentGetAllTables Method

Gets all tables contained into the document.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<DocxTable> GetAllTables()
Public Function GetAllTables As ICollection(Of DocxTable)
public:
ICollection<DocxTable^>^ GetAllTables()
member GetAllTables : unit -> ICollection<DocxTable>

Return Value

ICollection DocxTable
ICollection<DocxTable>.
See Also

Reference

DocxDocument Class


DocxDocument.GetAvailableListStyles Method

DocxDocumentGetAvailableListStyles Method

Ritorna una lista con gli stili di lista standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> GetAvailableListStyles()
Public Function GetAvailableListStyles As ICollection(Of String)
public:
ICollection<String^>^ GetAvailableListStyles()
member GetAvailableListStyles : unit -> ICollection<string>

Return Value

ICollection String
Lista degli stili di lista standard
See Also

Reference

DocxDocument Class


DocxDocument.GetBookmarkText Method

DocxDocumentGetBookmarkText Method

Ritorna il testo di un bookmark

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetBookmarkText(
    string fieldname
)
Public Function GetBookmarkText (
    fieldname As String
) As String
public:
String^ GetBookmarkText(
    String^ fieldname
)
member GetBookmarkText :
        fieldname : string -> string

Parameters

fieldname String
Il nome del campo

Return Value

String
Il testo
See Also

Reference

DocxDocument Class


DocxDocument.GetBuiltInProperties Method

DocxDocumentGetBuiltInProperties Method

Ritorna le proprietà standard del documento

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetBuiltInProperties()
Public Function GetBuiltInProperties As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetBuiltInProperties()
member GetBuiltInProperties : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
IDictionary<System.String, System.String>.
See Also

Reference

DocxDocument Class


DocxDocument.GetCustomProperties Method

DocxDocumentGetCustomProperties Method

Ritorna le proprietà custom del documento

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetCustomProperties()
Public Function GetCustomProperties As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetCustomProperties()
member GetCustomProperties : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
IDictionary<System.String, System.String>.
See Also

Reference

DocxDocument Class


DocxDocument.GetFieldNames Method

DocxDocumentGetFieldNames Method

Gets the field names.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> GetFieldNames()
Public Function GetFieldNames As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetFieldNames()
member GetFieldNames : unit -> IEnumerable<string>

Return Value

IEnumerable String
IList<System.String>.
See Also

Reference

DocxDocument Class


DocxDocument.GetFirstRun Method

DocxDocumentGetFirstRun Method

Ritorna il primo run del documento.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun GetFirstRun()
Public Function GetFirstRun As DocxRun
public:
DocxRun^ GetFirstRun()
member GetFirstRun : unit -> DocxRun

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxDocument Class


DocxDocument.GetPaginator Method

DocxDocumentGetPaginator Method

Gets the document paginator. Object to manage the documents page. Create a new object every time (like Gembox).

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxPaginator GetPaginator()
Public Function GetPaginator As DocxPaginator
public:
DocxPaginator^ GetPaginator()
member GetPaginator : unit -> DocxPaginator

Return Value

DocxPaginator

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxDocument.GetPaginator"]

See Also

Reference

DocxDocument Class


DocxDocument.GetSection Method

DocxDocumentGetSection Method

Ritorna la sezione all'indice passato

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection GetSection(
    int idx
)
Public Function GetSection (
    idx As Integer
) As DocxSection
public:
DocxSection^ GetSection(
    int idx
)
member GetSection :
        idx : int -> DocxSection

Parameters

idx Int32
L'indice di sezione

Return Value

DocxSection
La sezione all'indice richiesto
See Also

Reference

DocxDocument Class


DocxDocument.GetStyleNames Method

DocxDocumentGetStyleNames Method

Ritorna i nomi degli stili

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetStyleNames()
Public Function GetStyleNames As String()
public:
array<String^>^ GetStyleNames()
member GetStyleNames : unit -> string[]

Return Value

String
La lista degli stili
See Also

Reference

DocxDocument Class


DocxDocument.GetTableStyle Method

DocxDocumentGetTableStyle Method

Ritorna lo stile di tabella in base al nome specificato in ingresso. Ritorna 'null' se il nome specificato è vuoto

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableStyle GetTableStyle(
    string name
)
Public Function GetTableStyle (
    name As String
) As DocxTableStyle
public:
DocxTableStyle^ GetTableStyle(
    String^ name
)
member GetTableStyle :
        name : string -> DocxTableStyle

Parameters

name String
Nome dello stile.

Return Value

DocxTableStyle

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxDocument.GetTableStyle(System.String)"]

See Also

Reference

DocxDocument Class


DocxDocument.MailMerge Method

DocxDocumentMailMerge Method

Esegue il mailmerge a partire dalla tabella lua.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MailMerge(
    IDictionary<string, Object> data
)
Public Sub MailMerge (
    data As IDictionary(Of String, Object)
)
public:
void MailMerge(
    IDictionary<String^, Object^>^ data
)
member MailMerge :
        data : IDictionary<string, Object> -> unit

Parameters

data IDictionary String, Object
The data.
See Also

Reference

DocxDocument Class


DocxDocument.ReadForm Method

DocxDocumentReadForm Method

Legge un form Word

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> ReadForm()
Public Function ReadForm As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ ReadForm()
member ReadForm : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
Una tabella lua contenente i dati del form
See Also

Reference

DocxDocument Class


DocxDocument.RemoveParagraph Method

DocxDocumentRemoveParagraph Method

Eliminata dalla lista dei blocks il paragrafo

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveParagraph(
    int index
)
Public Sub RemoveParagraph (
    index As Integer
)
public:
void RemoveParagraph(
    int index
)
member RemoveParagraph :
        index : int -> unit

Parameters

index Int32
Indica quale paragrafo deve essere eliminato. Esempio: se inserisco 1 viene eliminato il primo paragrafo trovato nei blocks
See Also

Reference

DocxDocument Class


DocxDocument.ReplaceText Method

DocxDocumentReplaceText Method

Overload List
 | Name | Description
Public method | ReplaceText(String, String) | Search and replace NO regex
Public method | ReplaceText(String, String, Boolean) | Replace text into the document, regex allowed
Top
See Also

Reference

DocxDocument Class


DocxDocument.ReplaceText(String, String) Method

DocxDocumentReplaceText(String, String) Method

Search and replace NO regex

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReplaceText(
    string textFind,
    string textReplace
)
Public Function ReplaceText (
    textFind As String,
    textReplace As String
) As Integer
public:
int ReplaceText(
    String^ textFind,
    String^ textReplace
)
member ReplaceText :
        textFind : string *
        textReplace : string -> int

Parameters

textFind String
The text find.
textReplace String
The text replace.

Return Value

Int32
System.Int32.
See Also

Reference

DocxDocument Class
ReplaceText Overload


DocxDocument.ReplaceText(String, String, Boolean) Method

DocxDocumentReplaceText(String, String, Boolean) Method

Replace text into the document, regex allowed

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReplaceText(
    string textFind,
    string textReplace,
    bool regex
)
Public Function ReplaceText (
    textFind As String,
    textReplace As String,
    regex As Boolean
) As Integer
public:
int ReplaceText(
    String^ textFind,
    String^ textReplace,
    bool regex
)
member ReplaceText :
        textFind : string *
        textReplace : string *
        regex : bool -> int

Parameters

textFind String
The text find.
textReplace String
The text replace.
regex Boolean
if set to true [regex].

Return Value

Int32
System.Int32.
See Also

Reference

DocxDocument Class
ReplaceText Overload


DocxDocument.ReplaceTextWithImage Method

DocxDocumentReplaceTextWithImage Method

Replace a placehloder with the given image

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReplaceTextWithImage(
    string textFind,
    string imgReplace,
    bool regex
)
Public Function ReplaceTextWithImage (
    textFind As String,
    imgReplace As String,
    regex As Boolean
) As Integer
public:
int ReplaceTextWithImage(
    String^ textFind,
    String^ imgReplace,
    bool regex
)
member ReplaceTextWithImage :
        textFind : string *
        imgReplace : string *
        regex : bool -> int

Parameters

textFind String
The text find.
imgReplace String
The img replace.
regex Boolean
if set to true [regex].

Return Value

Int32
System.Int32.
See Also

Reference

DocxDocument Class


DocxDocument.Save Method

DocxDocumentSave Method

Just Save

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
See Also

Reference

DocxDocument Class


DocxDocument.SaveAs Method

DocxDocumentSaveAs Method

Save the document as...

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    string docxfilepath
)
Public Sub SaveAs (
    docxfilepath As String
)
public:
void SaveAs(
    String^ docxfilepath
)
member SaveAs :
        docxfilepath : string -> unit

Parameters

docxfilepath String
The docxfilepath.
Exceptions
Exception | Condition
Exception |
Exception | Unable to save file
See Also

Reference

DocxDocument Class


DocxDocument.SetBookmark Method

DocxDocumentSetBookmark Method

Imposta il bookmark con il valore passato

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetBookmark(
    string fieldname,
    string val
)
Public Function SetBookmark (
    fieldname As String,
    val As String
) As Boolean
public:
bool SetBookmark(
    String^ fieldname,
    String^ val
)
member SetBookmark :
        fieldname : string *
        val : string -> bool

Parameters

fieldname String
nome del field del bookmark
val String
Il valore. Se prefissato con 'picture://' carica l'immagine.

Return Value

Boolean
true if XXXX, false otherwise.
See Also

Reference

DocxDocument Class


DocxDocument.SetBookmarks Method

DocxDocumentSetBookmarks Method

Imposta i bookmarks dalla tabella lua passata

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBookmarks(
    IDictionary<string, Object> data
)
Public Sub SetBookmarks (
    data As IDictionary(Of String, Object)
)
public:
void SetBookmarks(
    IDictionary<String^, Object^>^ data
)
member SetBookmarks :
        data : IDictionary<string, Object> -> unit

Parameters

data IDictionary String, Object
La tabella lua contenente le info dei bookmark
See Also

Reference

DocxDocument Class


DocxDocument.SetField Method

DocxDocumentSetField Method

Imposta un campo nel documento

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetField(
    string fieldName,
    Object fieldValue
)
Public Sub SetField (
    fieldName As String,
    fieldValue As Object
)
public:
void SetField(
    String^ fieldName,
    Object^ fieldValue
)
member SetField :
        fieldName : string *
        fieldValue : Object -> unit

Parameters

fieldName String
Name of the field.
fieldValue Object
The field value.
See Also

Reference

DocxDocument Class


DocxDocument.SetProperties Method

DocxDocumentSetProperties Method

Imposta le proprietà del documento leggendo una tabella nome-valore in lua. Da priorità alle proprietà standard del documento e poi a quelle custom.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetProperties(
    IDictionary<string, string> props
)
Public Sub SetProperties (
    props As IDictionary(Of String, String)
)
public:
void SetProperties(
    IDictionary<String^, String^>^ props
)
member SetProperties :
        props : IDictionary<string, string> -> unit

Parameters

props IDictionary String, String
The props.
See Also

Reference

DocxDocument Class


DocxDocument.SetSectionOrientation Method

DocxDocumentSetSectionOrientation Method

Imposta l'orientamento della sezione

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSectionOrientation(
    int idx,
    bool landscape
)
Public Sub SetSectionOrientation (
    idx As Integer,
    landscape As Boolean
)
public:
void SetSectionOrientation(
    int idx,
    bool landscape
)
member SetSectionOrientation :
        idx : int *
        landscape : bool -> unit

Parameters

idx Int32
L'indice della sezione
landscape Boolean
1 (true) per Landscape, nil (false) per Portrait
See Also

Reference

DocxDocument Class


DocxDocument.UpdateTableOfContent Method

DocxDocumentUpdateTableOfContent Method

Overload List
 | Name | Description
Public method | UpdateTableOfContent | Updates the table of content making dirty the document.
Public method | UpdateTableOfContent(Boolean) | Updates the table of content making dirty the document.
Top
See Also

Reference

DocxDocument Class


DocxDocument.UpdateTableOfContent Method

DocxDocumentUpdateTableOfContent Method

Updates the table of content making dirty the document.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateTableOfContent()
Public Sub UpdateTableOfContent
public:
void UpdateTableOfContent()
member UpdateTableOfContent : unit -> unit
See Also

Reference

DocxDocument Class
UpdateTableOfContent Overload


DocxDocument.UpdateTableOfContent(Boolean) Method

DocxDocumentUpdateTableOfContent(Boolean) Method

Updates the table of content making dirty the document.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateTableOfContent(
    bool updateTocOnOpening
)
Public Sub UpdateTableOfContent (
    updateTocOnOpening As Boolean
)
public:
void UpdateTableOfContent(
    bool updateTocOnOpening
)
member UpdateTableOfContent :
        updateTocOnOpening : bool -> unit

Parameters

updateTocOnOpening Boolean
Indicate if update TOC during opening document or now.
See Also

Reference

DocxDocument Class
UpdateTableOfContent Overload


DocxDocument.SummaryOrientationEnum Enumeration

DocxDocumentSummaryOrientationEnum Enumeration

Specifica l'orientamento che deve avere la pagina contenente il sommario.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SummaryOrientationEnum
Public Enumeration SummaryOrientationEnum
public enum class SummaryOrientationEnum
type SummaryOrientationEnum
Members
Member name | Value | Description
None | 0 | Viene utilizzato il valore di default della sezione.
LandScape | 1 | La pagina viene impostata orizzontalmente.
Portrait | 2 | La pagina viene impostata verticalmente.
See Also

Reference

QsGemBox.Docx Namespace


DocxElement Class

Elemento generico di un documento word.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxElement

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxElement
Public Class DocxElement
public ref class DocxElement
type DocxElement = class end

The DocxElement type exposes the following members.

Constructors
 | Name | Description
Public method | DocxElement | Costruttore wrapper
Top
Properties
 | Name | Description
Public property | InnerObject | L'oggetto interno
Top
Methods
 | Name | Description
Public method | ConvertToCell | Ritorna l'oggetto 'DocxCell' se l'oggetto corrente è una cella di una tabella, altrimenti null.
Public method | ConvertToSection | Ritorna l'oggetto 'DocxSection' se l'oggetto corrente è una sezione di documento, altrimenti null.
Public method | ConvertToTable | Ritorna l'oggetto 'DocxTable' se l'oggetto corrente è una tabella, altrimenti null.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParent | L'oggetto padre.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxElement Constructor

Costruttore wrapper

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxElement(
    Element innerObject
)
Public Sub New (
    innerObject As Element
)
public:
DocxElement(
    Element^ innerObject
)
new :
        innerObject : Element -> DocxElement

Parameters

innerObject Element
The inner object.
See Also

Reference

DocxElement Class


DocxElement Properties

The DocxElement type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | L'oggetto interno
Top
See Also

Reference

DocxElement Class


DocxElement.InnerObject Property

DocxElementInnerObject Property

L'oggetto interno

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element InnerObject { get; set; }
Public Property InnerObject As Element
    Get
    Set
public:
property Element^ InnerObject {
    Element^ get ();
    void set (Element^ value);
}
member InnerObject : Element with get, set

Property Value

Element
The inner object.
See Also

Reference

DocxElement Class


DocxElement Methods

The DocxElement type exposes the following members.

Methods
 | Name | Description
Public method | ConvertToCell | Ritorna l'oggetto 'DocxCell' se l'oggetto corrente è una cella di una tabella, altrimenti null.
Public method | ConvertToSection | Ritorna l'oggetto 'DocxSection' se l'oggetto corrente è una sezione di documento, altrimenti null.
Public method | ConvertToTable | Ritorna l'oggetto 'DocxTable' se l'oggetto corrente è una tabella, altrimenti null.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParent | L'oggetto padre.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxElement Class


DocxElement.ConvertToCell Method

DocxElementConvertToCell Method

Ritorna l'oggetto 'DocxCell' se l'oggetto corrente è una cella di una tabella, altrimenti null.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell ConvertToCell()
Public Function ConvertToCell As DocxCell
public:
DocxCell^ ConvertToCell()
member ConvertToCell : unit -> DocxCell

Return Value

DocxCell

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxElement.ConvertToCell"]

See Also

Reference

DocxElement Class


DocxElement.ConvertToSection Method

DocxElementConvertToSection Method

Ritorna l'oggetto 'DocxSection' se l'oggetto corrente è una sezione di documento, altrimenti null.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection ConvertToSection()
Public Function ConvertToSection As DocxSection
public:
DocxSection^ ConvertToSection()
member ConvertToSection : unit -> DocxSection

Return Value

DocxSection

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxElement.ConvertToSection"]

See Also

Reference

DocxElement Class


DocxElement.ConvertToTable Method

DocxElementConvertToTable Method

Ritorna l'oggetto 'DocxTable' se l'oggetto corrente è una tabella, altrimenti null.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable ConvertToTable()
Public Function ConvertToTable As DocxTable
public:
DocxTable^ ConvertToTable()
member ConvertToTable : unit -> DocxTable

Return Value

DocxTable

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxElement.ConvertToTable"]

See Also

Reference

DocxElement Class


DocxElement.GetParent Method

DocxElementGetParent Method

L'oggetto padre.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxElement GetParent()
Public Function GetParent As DocxElement
public:
DocxElement^ GetParent()
member GetParent : unit -> DocxElement

Field Value

DocxElement
The inner object.

Return Value

DocxElement

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxElement.GetParent"]

See Also

Reference

DocxElement Class


DocxField Class

Campo di un documento word.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxField

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxField
Public Class DocxField
public ref class DocxField
type DocxField = class end

The DocxField type exposes the following members.

Constructors
 | Name | Description
Public method | DocxField | Costruttore wrapper
Top
Properties
 | Name | Description
Public property | InnerObject | L'oggetto interno
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Ritorna il nome del campo.
Public method | GetParent | L'oggetto padre.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxField Constructor

Costruttore wrapper

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxField(
    Field innerObject
)
Public Sub New (
    innerObject As Field
)
public:
DocxField(
    Field^ innerObject
)
new :
        innerObject : Field -> DocxField

Parameters

innerObject Field
The inner object.
See Also

Reference

DocxField Class


DocxField Properties

The DocxField type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | L'oggetto interno
Top
See Also

Reference

DocxField Class


DocxField.InnerObject Property

DocxFieldInnerObject Property

L'oggetto interno

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Field InnerObject { get; set; }
Public Property InnerObject As Field
    Get
    Set
public:
property Field^ InnerObject {
    Field^ get ();
    void set (Field^ value);
}
member InnerObject : Field with get, set

Property Value

Field
The inner object.
See Also

Reference

DocxField Class


DocxField Methods

The DocxField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Ritorna il nome del campo.
Public method | GetParent | L'oggetto padre.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxField Class


DocxField.GetName Method

DocxFieldGetName Method

Ritorna il nome del campo.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetName()
Public Function GetName As String
public:
String^ GetName()
member GetName : unit -> string

Return Value

String

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxField.GetName"]

See Also

Reference

DocxField Class


DocxField.GetParent Method

DocxFieldGetParent Method

L'oggetto padre.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxElement GetParent()
Public Function GetParent As DocxElement
public:
DocxElement^ GetParent()
member GetParent : unit -> DocxElement

Field Value

DocxElement
The inner object.

Return Value

DocxElement

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxField.GetParent"]

See Also

Reference

DocxField Class


DocxHyperlink Class

Class DocxHyperlink.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxHyperlink

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxHyperlink
Public Class DocxHyperlink
public ref class DocxHyperlink
type DocxHyperlink = class end

The DocxHyperlink type exposes the following members.

Constructors
 | Name | Description
Public method | DocxHyperlink | Initializes a new instance of the DocxHyperlink class.
Public method | DocxHyperlink(Hyperlink) | Initializes a new instance of the DocxHyperlink class.
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | Paragraph | Gets the parent.
Public property | Section | Ritorna la sezione di appartenenza
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxHyperlink Constructor

Overload List
 | Name | Description
Public method | DocxHyperlink | Initializes a new instance of the DocxHyperlink class.
Public method | DocxHyperlink(Hyperlink) | Initializes a new instance of the DocxHyperlink class.
Top
See Also

Reference

DocxHyperlink Class


DocxHyperlink Constructor

Initializes a new instance of the DocxHyperlink class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxHyperlink()
Public Sub New
public:
DocxHyperlink()
new : unit -> DocxHyperlink
See Also

Reference

DocxHyperlink Class
DocxHyperlink Overload


DocxHyperlink(Hyperlink) Constructor

Initializes a new instance of the DocxHyperlink class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxHyperlink(
    Hyperlink innerObject
)
Public Sub New (
    innerObject As Hyperlink
)
public:
DocxHyperlink(
    Hyperlink^ innerObject
)
new :
        innerObject : Hyperlink -> DocxHyperlink

Parameters

innerObject Hyperlink
The inner object.
See Also

Reference

DocxHyperlink Class
DocxHyperlink Overload


DocxHyperlink Properties

The DocxHyperlink type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | Paragraph | Gets the parent.
Public property | Section | Ritorna la sezione di appartenenza
Top
See Also

Reference

DocxHyperlink Class


DocxHyperlink.InnerObject Property

DocxHyperlinkInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hyperlink InnerObject { get; set; }
Public Property InnerObject As Hyperlink
    Get
    Set
public:
property Hyperlink^ InnerObject {
    Hyperlink^ get ();
    void set (Hyperlink^ value);
}
member InnerObject : Hyperlink with get, set

Property Value

Hyperlink
The inner object.
See Also

Reference

DocxHyperlink Class


DocxHyperlink.Paragraph Property

DocxHyperlinkParagraph Property

Gets the parent.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph Paragraph { get; }
Public ReadOnly Property Paragraph As DocxParagraph
    Get
public:
property DocxParagraph^ Paragraph {
    DocxParagraph^ get ();
}
member Paragraph : DocxParagraph with get

Property Value

DocxParagraph
The parent.
See Also

Reference

DocxHyperlink Class


DocxHyperlink.Section Property

DocxHyperlinkSection Property

Ritorna la sezione di appartenenza

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection Section { get; }
Public ReadOnly Property Section As DocxSection
    Get
public:
property DocxSection^ Section {
    DocxSection^ get ();
}
member Section : DocxSection with get

Property Value

DocxSection
The section.
See Also

Reference

DocxHyperlink Class


DocxHyperlink Methods

The DocxHyperlink type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxHyperlink Class


DocxImageProxy Class

Class DocxImageProxy.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxImageProxy

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxImageProxy
Public Class DocxImageProxy
public ref class DocxImageProxy
type DocxImageProxy = class end

The DocxImageProxy type exposes the following members.

Constructors
 | Name | Description
Public method | DocxImageProxy | Initializes a new instance of the DocxImageProxy class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSize | Gets the size. WARNING: v1 returned LuaTable
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxImageProxy Constructor

Initializes a new instance of the DocxImageProxy class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxImageProxy(
    string imagepath
)
Public Sub New (
    imagepath As String
)
public:
DocxImageProxy(
    String^ imagepath
)
new :
        imagepath : string -> DocxImageProxy

Parameters

imagepath String
The imagepath.
See Also

Reference

DocxImageProxy Class


DocxImageProxy Methods

The DocxImageProxy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSize | Gets the size. WARNING: v1 returned LuaTable
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxImageProxy Class


DocxImageProxy.GetSize Method

DocxImageProxyGetSize Method

Gets the size. WARNING: v1 returned LuaTable

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size GetSize()
Public Function GetSize As Size
public:
Size GetSize()
member GetSize : unit -> Size

Return Value

Size
Size.
See Also

Reference

DocxImageProxy Class


DocxImaging Class

Class DocxImaging.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxImaging

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DocxImaging
Public NotInheritable Class DocxImaging
public ref class DocxImaging abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DocxImaging = class end

The DocxImaging type exposes the following members.

Methods
Name | Description
GetImageFormat | Gets the image format.
GetPicture(Byte, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato.
GetPicture(String, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato.
GetPicture(Byte, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPicture(Image, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'oggetto Image specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPicture(String, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPictureSize | Gets the size of the picture.
ResizeImage | Resizes the image.
RotateImage | Rotates the image.
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxImaging Methods

The DocxImaging type exposes the following members.

Methods
Name | Description
GetImageFormat | Gets the image format.
GetPicture(Byte, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato.
GetPicture(String, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato.
GetPicture(Byte, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPicture(Image, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'oggetto Image specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPicture(String, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPictureSize | Gets the size of the picture.
ResizeImage | Resizes the image.
RotateImage | Rotates the image.
Top
See Also

Reference

DocxImaging Class


DocxImaging.GetImageFormat Method

DocxImagingGetImageFormat Method

Gets the image format.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageFormat GetImageFormat(
    Image img
)
Public Shared Function GetImageFormat (
    img As Image
) As ImageFormat
public:
static ImageFormat^ GetImageFormat(
    Image^ img
)
static member GetImageFormat :
        img : Image -> ImageFormat

Parameters

img Image
The img.

Return Value

ImageFormat
System.Drawing.Imaging.ImageFormat.
See Also

Reference

DocxImaging Class


DocxImaging.GetPicture Method

DocxImagingGetPicture Method

Overload List
Name | Description
GetPicture(Byte, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato.
GetPicture(String, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato.
GetPicture(Byte, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPicture(Image, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base all'oggetto Image specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
GetPicture(String, Int32, Int32, DocumentModel) | Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.
Top
See Also

Reference

DocxImaging Class


DocxImaging.GetPicture(Byte[], DocumentModel) Method

DocxImagingGetPicture(Byte, DocumentModel) Method

Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Picture GetPicture(
    byte[] imageBytes,
    DocumentModel doc
)
Public Shared Function GetPicture (
    imageBytes As Byte(),
    doc As DocumentModel
) As Picture
public:
static Picture^ GetPicture(
    array<unsigned char>^ imageBytes,
    DocumentModel^ doc
)
static member GetPicture :
        imageBytes : byte[] *
        doc : DocumentModel -> Picture

Parameters

imageBytes Byte

[Missing <param name="imageBytes"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],GemBox.Document.DocumentModel)"]

doc DocumentModel

[Missing <param name="doc"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],GemBox.Document.DocumentModel)"]

Return Value

Picture

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],GemBox.Document.DocumentModel)"]

See Also

Reference

DocxImaging Class
GetPicture Overload


DocxImaging.GetPicture(String, DocumentModel) Method

DocxImagingGetPicture(String, DocumentModel) Method

Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Picture GetPicture(
    string path,
    DocumentModel doc
)
Public Shared Function GetPicture (
    path As String,
    doc As DocumentModel
) As Picture
public:
static Picture^ GetPicture(
    String^ path,
    DocumentModel^ doc
)
static member GetPicture :
        path : string *
        doc : DocumentModel -> Picture

Parameters

path String

[Missing <param name="path"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,GemBox.Document.DocumentModel)"]

doc DocumentModel

[Missing <param name="doc"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,GemBox.Document.DocumentModel)"]

Return Value

Picture

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,GemBox.Document.DocumentModel)"]

See Also

Reference

DocxImaging Class
GetPicture Overload


DocxImaging.GetPicture(Byte[], Int32, Int32, DocumentModel) Method

DocxImagingGetPicture(Byte, Int32, Int32, DocumentModel) Method

Ritorna un oggetto "GemBox.Document.Picture" in base all'array di byte specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Picture GetPicture(
    byte[] imageBytes,
    int width,
    int height,
    DocumentModel doc
)
Public Shared Function GetPicture (
    imageBytes As Byte(),
    width As Integer,
    height As Integer,
    doc As DocumentModel
) As Picture
public:
static Picture^ GetPicture(
    array<unsigned char>^ imageBytes,
    int width,
    int height,
    DocumentModel^ doc
)
static member GetPicture :
        imageBytes : byte[] *
        width : int *
        height : int *
        doc : DocumentModel -> Picture

Parameters

imageBytes Byte

[Missing <param name="imageBytes"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

width Int32

[Missing <param name="width"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

height Int32

[Missing <param name="height"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

doc DocumentModel

[Missing <param name="doc"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

Return Value

Picture

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Byte[],System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

See Also

Reference

DocxImaging Class
GetPicture Overload


DocxImaging.GetPicture(Image, Int32, Int32, DocumentModel) Method

DocxImagingGetPicture(Image, Int32, Int32, DocumentModel) Method

Ritorna un oggetto "GemBox.Document.Picture" in base all'oggetto Image specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Picture GetPicture(
    Image img,
    int width,
    int height,
    DocumentModel doc
)
Public Shared Function GetPicture (
    img As Image,
    width As Integer,
    height As Integer,
    doc As DocumentModel
) As Picture
public:
static Picture^ GetPicture(
    Image^ img,
    int width,
    int height,
    DocumentModel^ doc
)
static member GetPicture :
        img : Image *
        width : int *
        height : int *
        doc : DocumentModel -> Picture

Parameters

img Image

[Missing <param name="img"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Drawing.Image,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

width Int32

[Missing <param name="width"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Drawing.Image,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

height Int32

[Missing <param name="height"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Drawing.Image,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

doc DocumentModel

[Missing <param name="doc"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Drawing.Image,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

Return Value

Picture

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.Drawing.Image,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

See Also

Reference

DocxImaging Class
GetPicture Overload


DocxImaging.GetPicture(String, Int32, Int32, DocumentModel) Method

DocxImagingGetPicture(String, Int32, Int32, DocumentModel) Method

Ritorna un oggetto "GemBox.Document.Picture" in base al path dell'immagine specificato utilizzando una larghezza e/o altezza custom. Se uno dei due valori di dimensione è minore di 0 viene calcolato a partire dall'altro mantenendo le proporzioni. Se, invece, entrambi i valori sono minori di 0 mantiene le dimensioni originali.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Picture GetPicture(
    string path,
    int width,
    int height,
    DocumentModel doc
)
Public Shared Function GetPicture (
    path As String,
    width As Integer,
    height As Integer,
    doc As DocumentModel
) As Picture
public:
static Picture^ GetPicture(
    String^ path,
    int width,
    int height,
    DocumentModel^ doc
)
static member GetPicture :
        path : string *
        width : int *
        height : int *
        doc : DocumentModel -> Picture

Parameters

path String

[Missing <param name="path"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

width Int32

[Missing <param name="width"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

height Int32

[Missing <param name="height"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

doc DocumentModel

[Missing <param name="doc"/> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

Return Value

Picture

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxImaging.GetPicture(System.String,System.Int32,System.Int32,GemBox.Document.DocumentModel)"]

See Also

Reference

DocxImaging Class
GetPicture Overload


DocxImaging.GetPictureSize Method

DocxImagingGetPictureSize Method

Gets the size of the picture.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetPictureSize(
    string imagepath,
    out int width,
    out int height
)
Public Shared Function GetPictureSize (
    imagepath As String,
    <OutAttribute> ByRef width As Integer,
    <OutAttribute> ByRef height As Integer
) As Boolean
public:
static bool GetPictureSize(
    String^ imagepath,
    [OutAttribute] int% width,
    [OutAttribute] int% height
)
static member GetPictureSize :
        imagepath : string *
        width : int byref *
        height : int byref -> bool

Parameters

imagepath String
The imagepath.
width Int32
The width.
height Int32
The height.

Return Value

Boolean
true if XXXX, false otherwise.
See Also

Reference

DocxImaging Class


DocxImaging.ResizeImage Method

DocxImagingResizeImage Method

Resizes the image.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ResizeImage(
    string imagepath,
    string outpath,
    int width,
    int height
)
Public Shared Function ResizeImage (
    imagepath As String,
    outpath As String,
    width As Integer,
    height As Integer
) As String
public:
static String^ ResizeImage(
    String^ imagepath,
    String^ outpath,
    int width,
    int height
)
static member ResizeImage :
        imagepath : string *
        outpath : string *
        width : int *
        height : int -> string

Parameters

imagepath String
The imagepath.
outpath String
The outpath.
width Int32
The width.
height Int32
The height.

Return Value

String
System.String.
See Also

Reference

DocxImaging Class


DocxImaging.RotateImage Method

DocxImagingRotateImage Method

Rotates the image.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string RotateImage(
    string imagepath,
    string outpath,
    int ang
)
Public Shared Function RotateImage (
    imagepath As String,
    outpath As String,
    ang As Integer
) As String
public:
static String^ RotateImage(
    String^ imagepath,
    String^ outpath,
    int ang
)
static member RotateImage :
        imagepath : string *
        outpath : string *
        ang : int -> string

Parameters

imagepath String
The imagepath.
outpath String
The outpath.
ang Int32
The ang.

Return Value

String
System.String.
See Also

Reference

DocxImaging Class


DocxPaginator Class

Gestore delle pagine del documento.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxPaginator

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxPaginator
Public Class DocxPaginator
public ref class DocxPaginator
type DocxPaginator = class end

The DocxPaginator type exposes the following members.

Constructors
 | Name | Description
Public method | DocxPaginator | Costruttore wrapper
Top
Properties
 | Name | Description
Public property | InnerObject | L'oggetto interno
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPageNumber | Ritorna il numero delle pagine che compongono il documento.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxPaginator Constructor

Costruttore wrapper

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxPaginator(
    DocumentModelPaginator innerObject
)
Public Sub New (
    innerObject As DocumentModelPaginator
)
public:
DocxPaginator(
    DocumentModelPaginator^ innerObject
)
new :
        innerObject : DocumentModelPaginator -> DocxPaginator

Parameters

innerObject DocumentModelPaginator
The inner object.
See Also

Reference

DocxPaginator Class


DocxPaginator Properties

The DocxPaginator type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | L'oggetto interno
Top
See Also

Reference

DocxPaginator Class


DocxPaginator.InnerObject Property

DocxPaginatorInnerObject Property

L'oggetto interno

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentModelPaginator InnerObject { get; set; }
Public Property InnerObject As DocumentModelPaginator
    Get
    Set
public:
property DocumentModelPaginator^ InnerObject {
    DocumentModelPaginator^ get ();
    void set (DocumentModelPaginator^ value);
}
member InnerObject : DocumentModelPaginator with get, set

Property Value

DocumentModelPaginator
The inner object.
See Also

Reference

DocxPaginator Class


DocxPaginator Methods

The DocxPaginator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPageNumber | Ritorna il numero delle pagine che compongono il documento.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxPaginator Class


DocxPaginator.GetPageNumber Method

DocxPaginatorGetPageNumber Method

Ritorna il numero delle pagine che compongono il documento.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPageNumber()
Public Function GetPageNumber As Integer
public:
int GetPageNumber()
member GetPageNumber : unit -> int

Return Value

Int32

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxPaginator.GetPageNumber"]

See Also

Reference

DocxPaginator Class


DocxParagraph Class

Class DocxParagraph.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxParagraph

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxParagraph
Public Class DocxParagraph
public ref class DocxParagraph
type DocxParagraph = class end

The DocxParagraph type exposes the following members.

Constructors
 | Name | Description
Public method | DocxParagraph | Initializes a new instance of the DocxParagraph class.
Public method | DocxParagraph(Paragraph) | Initializes a new instance of the DocxParagraph class.
Top
Properties
 | Name | Description
Public property | AlignmentHorizontal | Gets or sets the alignment.
Public property | Bold | Sets a value indicating whether this DocxParagraph is bold.
Public property | InnerObject | Gets or sets the inner object.
Public property | Italic | Sets a value indicating whether this DocxParagraph is italic.
Public property | LineSpacing | Gets or sets the line spacing.
Public property | Section | Gets the section.
Public property | SpaceAfter | Gets or sets the amount of spacing after the paragraph (in points).
Public property | SpaceBefore | Gets or sets the amount of spacing before the paragraph (in points).
Public property | Style | Sets the style provided as string
Top
Methods
 | Name | Description
Public method | Clone | Clones this DocxTable instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetCharacterFormatForParagraphMarkSize | Get the size of character format for paragraph mark.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRun | Gets the run.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | LastRun | Get the last run.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetFontName | Setta il font di tutto il paragrafo
Public method | SetFontSize | Setta l'altezza del font di tutto il paragrafo
Public method | SetLineSpacing | Imposta l'interlinea
Public method | SetListStyle | Sets the list style. convert the string to enum
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxParagraph Constructor

Overload List
 | Name | Description
Public method | DocxParagraph | Initializes a new instance of the DocxParagraph class.
Public method | DocxParagraph(Paragraph) | Initializes a new instance of the DocxParagraph class.
Top
See Also

Reference

DocxParagraph Class


DocxParagraph Constructor

Initializes a new instance of the DocxParagraph class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph()
Public Sub New
public:
DocxParagraph()
new : unit -> DocxParagraph
See Also

Reference

DocxParagraph Class
DocxParagraph Overload


DocxParagraph(Paragraph) Constructor

Initializes a new instance of the DocxParagraph class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph(
    Paragraph innerObject
)
Public Sub New (
    innerObject As Paragraph
)
public:
DocxParagraph(
    Paragraph^ innerObject
)
new :
        innerObject : Paragraph -> DocxParagraph

Parameters

innerObject Paragraph
The inner object.
See Also

Reference

DocxParagraph Class
DocxParagraph Overload


DocxParagraph Properties

The DocxParagraph type exposes the following members.

Properties
 | Name | Description
Public property | AlignmentHorizontal | Gets or sets the alignment.
Public property | Bold | Sets a value indicating whether this DocxParagraph is bold.
Public property | InnerObject | Gets or sets the inner object.
Public property | Italic | Sets a value indicating whether this DocxParagraph is italic.
Public property | LineSpacing | Gets or sets the line spacing.
Public property | Section | Gets the section.
Public property | SpaceAfter | Gets or sets the amount of spacing after the paragraph (in points).
Public property | SpaceBefore | Gets or sets the amount of spacing before the paragraph (in points).
Public property | Style | Sets the style provided as string
Top
See Also

Reference

DocxParagraph Class


DocxParagraph.AlignmentHorizontal Property

DocxParagraphAlignmentHorizontal Property

Gets or sets the alignment.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AlignmentHorizontal { get; set; }
Public Property AlignmentHorizontal As String
    Get
    Set
public:
property String^ AlignmentHorizontal {
    String^ get ();
    void set (String^ value);
}
member AlignmentHorizontal : string with get, set

Property Value

String
The alignment.
See Also

Reference

DocxParagraph Class


DocxParagraph.Bold Property

DocxParagraphBold Property

Sets a value indicating whether this DocxParagraph is bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bold { set; }
Public WriteOnly Property Bold As Boolean
    Set
public:
property bool Bold {
    void set (bool value);
}
member Bold : bool with set

Property Value

Boolean
true if bold; otherwise, false.
See Also

Reference

DocxParagraph Class


DocxParagraph.InnerObject Property

DocxParagraphInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Paragraph InnerObject { get; set; }
Public Property InnerObject As Paragraph
    Get
    Set
public:
property Paragraph^ InnerObject {
    Paragraph^ get ();
    void set (Paragraph^ value);
}
member InnerObject : Paragraph with get, set

Property Value

Paragraph
The inner object.
See Also

Reference

DocxParagraph Class


DocxParagraph.Italic Property

DocxParagraphItalic Property

Sets a value indicating whether this DocxParagraph is italic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Italic { set; }
Public WriteOnly Property Italic As Boolean
    Set
public:
property bool Italic {
    void set (bool value);
}
member Italic : bool with set

Property Value

Boolean
true if italic; otherwise, false.
See Also

Reference

DocxParagraph Class


DocxParagraph.LineSpacing Property

DocxParagraphLineSpacing Property

Gets or sets the line spacing.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LineSpacing { get; set; }
Public Property LineSpacing As Double
    Get
    Set
public:
property double LineSpacing {
    double get ();
    void set (double value);
}
member LineSpacing : float with get, set

Property Value

Double
See Also

Reference

DocxParagraph Class


DocxParagraph.Section Property

DocxParagraphSection Property

Gets the section.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection Section { get; }
Public ReadOnly Property Section As DocxSection
    Get
public:
property DocxSection^ Section {
    DocxSection^ get ();
}
member Section : DocxSection with get

Property Value

DocxSection
The section.
See Also

Reference

DocxParagraph Class


DocxParagraph.SpaceAfter Property

DocxParagraphSpaceAfter Property

Gets or sets the amount of spacing after the paragraph (in points).

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpaceAfter { get; set; }
Public Property SpaceAfter As Double
    Get
    Set
public:
property double SpaceAfter {
    double get ();
    void set (double value);
}
member SpaceAfter : float with get, set

Property Value

Double
See Also

Reference

DocxParagraph Class


DocxParagraph.SpaceBefore Property

DocxParagraphSpaceBefore Property

Gets or sets the amount of spacing before the paragraph (in points).

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpaceBefore { get; set; }
Public Property SpaceBefore As Double
    Get
    Set
public:
property double SpaceBefore {
    double get ();
    void set (double value);
}
member SpaceBefore : float with get, set

Property Value

Double
See Also

Reference

DocxParagraph Class


DocxParagraph.Style Property

DocxParagraphStyle Property

Sets the style provided as string

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Style { set; }
Public WriteOnly Property Style As String
    Set
public:
property String^ Style {
    void set (String^ value);
}
member Style : string with set

Property Value

String
The style.
See Also

Reference

DocxParagraph Class


DocxParagraph Methods

The DocxParagraph type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clones this DocxTable instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetCharacterFormatForParagraphMarkSize | Get the size of character format for paragraph mark.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRun | Gets the run.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | LastRun | Get the last run.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetFontName | Setta il font di tutto il paragrafo
Public method | SetFontSize | Setta l'altezza del font di tutto il paragrafo
Public method | SetLineSpacing | Imposta l'interlinea
Public method | SetListStyle | Sets the list style. convert the string to enum
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxParagraph Class


DocxParagraph.Clone Method

DocxParagraphClone Method

Clones this DocxTable instance.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph Clone(
    bool cloneDescendants
)
Public Function Clone (
    cloneDescendants As Boolean
) As DocxParagraph
public:
DocxParagraph^ Clone(
    bool cloneDescendants
)
member Clone :
        cloneDescendants : bool -> DocxParagraph

Parameters

cloneDescendants Boolean
If set to true clone all descendants recursively; otherwise clone only current Table.

Return Value

DocxParagraph

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxParagraph.Clone(System.Boolean)"]

See Also

Reference

DocxParagraph Class


DocxParagraph.GetCharacterFormatForParagraphMarkSize Method

DocxParagraphGetCharacterFormatForParagraphMarkSize Method

Get the size of character format for paragraph mark.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetCharacterFormatForParagraphMarkSize()
Public Function GetCharacterFormatForParagraphMarkSize As Double
public:
double GetCharacterFormatForParagraphMarkSize()
member GetCharacterFormatForParagraphMarkSize : unit -> float

Return Value

Double

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxParagraph.GetCharacterFormatForParagraphMarkSize"]

See Also

Reference

DocxParagraph Class


DocxParagraph.GetRun Method

DocxParagraphGetRun Method

Gets the run.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun GetRun(
    int idx
)
Public Function GetRun (
    idx As Integer
) As DocxRun
public:
DocxRun^ GetRun(
    int idx
)
member GetRun :
        idx : int -> DocxRun

Parameters

idx Int32
The index.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxParagraph Class


DocxParagraph.LastRun Method

DocxParagraphLastRun Method

Get the last run.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun LastRun()
Public Function LastRun As DocxRun
public:
DocxRun^ LastRun()
member LastRun : unit -> DocxRun

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxParagraph Class


DocxParagraph.SetFontName Method

DocxParagraphSetFontName Method

Setta il font di tutto il paragrafo

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph SetFontName(
    string fontName
)
Public Function SetFontName (
    fontName As String
) As DocxParagraph
public:
DocxParagraph^ SetFontName(
    String^ fontName
)
member SetFontName :
        fontName : string -> DocxParagraph

Parameters

fontName String
Name of the font.

Return Value

DocxParagraph
DocxParagraph.
See Also

Reference

DocxParagraph Class


DocxParagraph.SetFontSize Method

DocxParagraphSetFontSize Method

Setta l'altezza del font di tutto il paragrafo

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph SetFontSize(
    double fontSize
)
Public Function SetFontSize (
    fontSize As Double
) As DocxParagraph
public:
DocxParagraph^ SetFontSize(
    double fontSize
)
member SetFontSize :
        fontSize : float -> DocxParagraph

Parameters

fontSize Double
Size of the font.

Return Value

DocxParagraph
DocxParagraph.
See Also

Reference

DocxParagraph Class


DocxParagraph.SetLineSpacing Method

DocxParagraphSetLineSpacing Method

Imposta l'interlinea

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph SetLineSpacing(
    double lineSpacing
)
Public Function SetLineSpacing (
    lineSpacing As Double
) As DocxParagraph
public:
DocxParagraph^ SetLineSpacing(
    double lineSpacing
)
member SetLineSpacing :
        lineSpacing : float -> DocxParagraph

Parameters

lineSpacing Double
The line spacing.

Return Value

DocxParagraph
DocxParagraph.
See Also

Reference

DocxParagraph Class


DocxParagraph.SetListStyle Method

DocxParagraphSetListStyle Method

Sets the list style. convert the string to enum

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph SetListStyle(
    string listStyle,
    int level
)
Public Function SetListStyle (
    listStyle As String,
    level As Integer
) As DocxParagraph
public:
DocxParagraph^ SetListStyle(
    String^ listStyle,
    int level
)
member SetListStyle :
        listStyle : string *
        level : int -> DocxParagraph

Parameters

listStyle String
The list style.
level Int32
The level.

Return Value

DocxParagraph
DocxParagraph.
See Also

Reference

DocxParagraph Class


DocxParagraphStyle Class

Class DocxParagraphStyle.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxParagraphStyle

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxParagraphStyle
Public Class DocxParagraphStyle
public ref class DocxParagraphStyle
type DocxParagraphStyle = class end

The DocxParagraphStyle type exposes the following members.

Constructors
 | Name | Description
Public method | DocxParagraphStyle | Initializes a new instance of the DocxParagraphStyle class.
Public method | DocxParagraphStyle(ParagraphStyle) | Initializes a new instance of the DocxParagraphStyle class.
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | LineSpacing | Gets or sets the line spacing.
Public property | SpaceAfter | Gets or sets the amount of spacing after the paragraph (in points).
Public property | SpaceBefore | Gets or sets the amount of spacing before the paragraph (in points).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetCharacterFormat | Gets formatting properties which shall be applied to a document text.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetColor | Sets the color.
Public method | SetProperty | Sets the property. Used for generic (not so common) properties
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxParagraphStyle Constructor

Overload List
 | Name | Description
Public method | DocxParagraphStyle | Initializes a new instance of the DocxParagraphStyle class.
Public method | DocxParagraphStyle(ParagraphStyle) | Initializes a new instance of the DocxParagraphStyle class.
Top
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle Constructor

Initializes a new instance of the DocxParagraphStyle class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraphStyle()
Public Sub New
public:
DocxParagraphStyle()
new : unit -> DocxParagraphStyle
See Also

Reference

DocxParagraphStyle Class
DocxParagraphStyle Overload


DocxParagraphStyle(ParagraphStyle) Constructor

Initializes a new instance of the DocxParagraphStyle class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraphStyle(
    ParagraphStyle innerObject
)
Public Sub New (
    innerObject As ParagraphStyle
)
public:
DocxParagraphStyle(
    ParagraphStyle^ innerObject
)
new :
        innerObject : ParagraphStyle -> DocxParagraphStyle

Parameters

innerObject ParagraphStyle
The inner object.
See Also

Reference

DocxParagraphStyle Class
DocxParagraphStyle Overload


DocxParagraphStyle Properties

The DocxParagraphStyle type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | LineSpacing | Gets or sets the line spacing.
Public property | SpaceAfter | Gets or sets the amount of spacing after the paragraph (in points).
Public property | SpaceBefore | Gets or sets the amount of spacing before the paragraph (in points).
Top
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.InnerObject Property

DocxParagraphStyleInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParagraphStyle InnerObject { get; set; }
Public Property InnerObject As ParagraphStyle
    Get
    Set
public:
property ParagraphStyle^ InnerObject {
    ParagraphStyle^ get ();
    void set (ParagraphStyle^ value);
}
member InnerObject : ParagraphStyle with get, set

Property Value

ParagraphStyle
The inner object.
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.LineSpacing Property

DocxParagraphStyleLineSpacing Property

Gets or sets the line spacing.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LineSpacing { get; set; }
Public Property LineSpacing As Double
    Get
    Set
public:
property double LineSpacing {
    double get ();
    void set (double value);
}
member LineSpacing : float with get, set

Property Value

Double
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.SpaceAfter Property

DocxParagraphStyleSpaceAfter Property

Gets or sets the amount of spacing after the paragraph (in points).

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpaceAfter { get; set; }
Public Property SpaceAfter As Double
    Get
    Set
public:
property double SpaceAfter {
    double get ();
    void set (double value);
}
member SpaceAfter : float with get, set

Property Value

Double
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.SpaceBefore Property

DocxParagraphStyleSpaceBefore Property

Gets or sets the amount of spacing before the paragraph (in points).

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpaceBefore { get; set; }
Public Property SpaceBefore As Double
    Get
    Set
public:
property double SpaceBefore {
    double get ();
    void set (double value);
}
member SpaceBefore : float with get, set

Property Value

Double
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle Methods

The DocxParagraphStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetCharacterFormat | Gets formatting properties which shall be applied to a document text.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetColor | Sets the color.
Public method | SetProperty | Sets the property. Used for generic (not so common) properties
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.GetCharacterFormat Method

DocxParagraphStyleGetCharacterFormat Method

Gets formatting properties which shall be applied to a document text.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCharacterFormat GetCharacterFormat()
Public Function GetCharacterFormat As DocxCharacterFormat
public:
DocxCharacterFormat^ GetCharacterFormat()
member GetCharacterFormat : unit -> DocxCharacterFormat

Return Value

DocxCharacterFormat

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxParagraphStyle.GetCharacterFormat"]

See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.SetColor Method

DocxParagraphStyleSetColor Method

Sets the color.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColor(
    int r,
    int g,
    int b
)
Public Sub SetColor (
    r As Integer,
    g As Integer,
    b As Integer
)
public:
void SetColor(
    int r,
    int g,
    int b
)
member SetColor :
        r : int *
        g : int *
        b : int -> unit

Parameters

r Int32
The r.
g Int32
The g.
b Int32
The b.
See Also

Reference

DocxParagraphStyle Class


DocxParagraphStyle.SetProperty Method

DocxParagraphStyleSetProperty Method

Sets the property. Used for generic (not so common) properties

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetProperty(
    string propname,
    Object propvalue
)
Public Function SetProperty (
    propname As String,
    propvalue As Object
) As Boolean
public:
bool SetProperty(
    String^ propname,
    Object^ propvalue
)
member SetProperty :
        propname : string *
        propvalue : Object -> bool

Parameters

propname String
The propname.
propvalue Object
The propvalue.

Return Value

Boolean
true if XXXX, false otherwise.
Exceptions
Exception | Condition
Exception |
Exception |
See Also

Reference

DocxParagraphStyle Class


DocxRun Class

Class DocxRun.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxRun

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxRun
Public Class DocxRun
public ref class DocxRun
type DocxRun = class end

The DocxRun type exposes the following members.

Constructors
 | Name | Description
Public method | DocxRun | Initializes a new instance of the DocxRun class.
Public method | DocxRun(Run) | Initializes a new instance of the DocxRun class.
Top
Properties
 | Name | Description
Public property | Bold | Gets or sets a value indicating whether this DocxRun is bold.
Public property | FontColor | Gets or sets the color of the font.
Public property | FontName | Gets or sets the font.
Public property | InnerObject | Gets or sets the inner object.
Public property | Italic | Gets or sets a value indicating whether this DocxRun is italic.
Public property | Paragraph | Gets the paragraph.
Public property | Section | Gets the section.
Public property | Size | Gets or sets the size of the font.
Public property | Style | Sets the style.
Public property | Text | Gets or sets the text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetBold | Sets the bold.
Public method | SetBookmark | Sets the bookmark.
Public method | SetFontColor(Color) | Sets the color of the font.
Public method | SetFontColor(Int32, Int32, Int32) | Sets the color.
Public method | SetFontName | Sets the name of the font.
Public method | SetItalic | Sets the italic.
Public method | SetProperty | Sets the property. Used for generic (not so common) properties
Public method | SetSize | Sets the size.
Public method | SetStyle | Sets the style.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxRun Constructor

Overload List
 | Name | Description
Public method | DocxRun | Initializes a new instance of the DocxRun class.
Public method | DocxRun(Run) | Initializes a new instance of the DocxRun class.
Top
See Also

Reference

DocxRun Class


DocxRun Constructor

Initializes a new instance of the DocxRun class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun()
Public Sub New
public:
DocxRun()
new : unit -> DocxRun
See Also

Reference

DocxRun Class
DocxRun Overload


DocxRun(Run) Constructor

Initializes a new instance of the DocxRun class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun(
    Run innerObject
)
Public Sub New (
    innerObject As Run
)
public:
DocxRun(
    Run^ innerObject
)
new :
        innerObject : Run -> DocxRun

Parameters

innerObject Run
The inner object.
See Also

Reference

DocxRun Class
DocxRun Overload


DocxRun Properties

The DocxRun type exposes the following members.

Properties
 | Name | Description
Public property | Bold | Gets or sets a value indicating whether this DocxRun is bold.
Public property | FontColor | Gets or sets the color of the font.
Public property | FontName | Gets or sets the font.
Public property | InnerObject | Gets or sets the inner object.
Public property | Italic | Gets or sets a value indicating whether this DocxRun is italic.
Public property | Paragraph | Gets the paragraph.
Public property | Section | Gets the section.
Public property | Size | Gets or sets the size of the font.
Public property | Style | Sets the style.
Public property | Text | Gets or sets the text.
Top
See Also

Reference

DocxRun Class


DocxRun.Bold Property

DocxRunBold Property

Gets or sets a value indicating whether this DocxRun is bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bold { get; set; }
Public Property Bold As Boolean
    Get
    Set
public:
property bool Bold {
    bool get ();
    void set (bool value);
}
member Bold : bool with get, set

Property Value

Boolean
true if bold; otherwise, false.
See Also

Reference

DocxRun Class


DocxRun.FontColor Property

DocxRunFontColor Property

Gets or sets the color of the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color FontColor { get; set; }
Public Property FontColor As Color
    Get
    Set
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}
member FontColor : Color with get, set

Property Value

Color
The color of the font.
See Also

Reference

DocxRun Class


DocxRun.FontName Property

DocxRunFontName Property

Gets or sets the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}
member FontName : string with get, set

Property Value

String
The color of the font.
See Also

Reference

DocxRun Class


DocxRun.InnerObject Property

DocxRunInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Run InnerObject { get; set; }
Public Property InnerObject As Run
    Get
    Set
public:
property Run^ InnerObject {
    Run^ get ();
    void set (Run^ value);
}
member InnerObject : Run with get, set

Property Value

Run
The inner object.
See Also

Reference

DocxRun Class


DocxRun.Italic Property

DocxRunItalic Property

Gets or sets a value indicating whether this DocxRun is italic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Italic { get; set; }
Public Property Italic As Boolean
    Get
    Set
public:
property bool Italic {
    bool get ();
    void set (bool value);
}
member Italic : bool with get, set

Property Value

Boolean
true if italic; otherwise, false.
See Also

Reference

DocxRun Class


DocxRun.Paragraph Property

DocxRunParagraph Property

Gets the paragraph.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxParagraph Paragraph { get; }
Public ReadOnly Property Paragraph As DocxParagraph
    Get
public:
property DocxParagraph^ Paragraph {
    DocxParagraph^ get ();
}
member Paragraph : DocxParagraph with get

Property Value

DocxParagraph
The paragraph.
See Also

Reference

DocxRun Class


DocxRun.Section Property

DocxRunSection Property

Gets the section.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection Section { get; }
Public ReadOnly Property Section As DocxSection
    Get
public:
property DocxSection^ Section {
    DocxSection^ get ();
}
member Section : DocxSection with get

Property Value

DocxSection
The section.
See Also

Reference

DocxRun Class


DocxRun.Size Property

DocxRunSize Property

Gets or sets the size of the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Size { get; set; }
Public Property Size As Double
    Get
    Set
public:
property double Size {
    double get ();
    void set (double value);
}
member Size : float with get, set

Property Value

Double
The size of the font.
See Also

Reference

DocxRun Class


DocxRun.Style Property

DocxRunStyle Property

Sets the style.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Style { set; }
Public WriteOnly Property Style As String
    Set
public:
property String^ Style {
    void set (String^ value);
}
member Style : string with set

Property Value

String
Name of the style.
See Also

Reference

DocxRun Class


DocxRun.Text Property

DocxRunText Property

Gets or sets the text.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

String
The text.
See Also

Reference

DocxRun Class


DocxRun Methods

The DocxRun type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetBold | Sets the bold.
Public method | SetBookmark | Sets the bookmark.
Public method | SetFontColor(Color) | Sets the color of the font.
Public method | SetFontColor(Int32, Int32, Int32) | Sets the color.
Public method | SetFontName | Sets the name of the font.
Public method | SetItalic | Sets the italic.
Public method | SetProperty | Sets the property. Used for generic (not so common) properties
Public method | SetSize | Sets the size.
Public method | SetStyle | Sets the style.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxRun Class


DocxRun.SetBold Method

DocxRunSetBold Method

Sets the bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetBold(
    bool bold
)
Public Function SetBold (
    bold As Boolean
) As DocxRun
public:
DocxRun^ SetBold(
    bool bold
)
member SetBold :
        bold : bool -> DocxRun

Parameters

bold Boolean
if set to true [bold].

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxRun Class


DocxRun.SetBookmark Method

DocxRunSetBookmark Method

Sets the bookmark.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetBookmark(
    string bookmarkName
)
Public Function SetBookmark (
    bookmarkName As String
) As Boolean
public:
bool SetBookmark(
    String^ bookmarkName
)
member SetBookmark :
        bookmarkName : string -> bool

Parameters

bookmarkName String
Name of the bookmark.

Return Value

Boolean
true if XXXX, false otherwise.
See Also

Reference

DocxRun Class


DocxRun.SetFontColor Method

DocxRunSetFontColor Method

Overload List
 | Name | Description
Public method | SetFontColor(Color) | Sets the color of the font.
Public method | SetFontColor(Int32, Int32, Int32) | Sets the color.
Top
See Also

Reference

DocxRun Class


DocxRun.SetFontColor(Color) Method

DocxRunSetFontColor(Color) Method

Sets the color of the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetFontColor(
    Color color
)
Public Function SetFontColor (
    color As Color
) As DocxRun
public:
DocxRun^ SetFontColor(
    Color color
)
member SetFontColor :
        color : Color -> DocxRun

Parameters

color Color
The color.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxRun Class
SetFontColor Overload


DocxRun.SetFontColor(Int32, Int32, Int32) Method

DocxRunSetFontColor(Int32, Int32, Int32) Method

Sets the color.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetFontColor(
    int r,
    int g,
    int b
)
Public Function SetFontColor (
    r As Integer,
    g As Integer,
    b As Integer
) As DocxRun
public:
DocxRun^ SetFontColor(
    int r,
    int g,
    int b
)
member SetFontColor :
        r : int *
        g : int *
        b : int -> DocxRun

Parameters

r Int32
The r.
g Int32
The g.
b Int32
The b.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxRun Class
SetFontColor Overload


DocxRun.SetFontName Method

DocxRunSetFontName Method

Sets the name of the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetFontName(
    string fontName
)
Public Function SetFontName (
    fontName As String
) As DocxRun
public:
DocxRun^ SetFontName(
    String^ fontName
)
member SetFontName :
        fontName : string -> DocxRun

Parameters

fontName String
Name of the font.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxRun Class


DocxRun.SetItalic Method

DocxRunSetItalic Method

Sets the italic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetItalic(
    bool italic
)
Public Function SetItalic (
    italic As Boolean
) As DocxRun
public:
DocxRun^ SetItalic(
    bool italic
)
member SetItalic :
        italic : bool -> DocxRun

Parameters

italic Boolean
if set to true [italic].

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxRun Class


DocxRun.SetProperty Method

DocxRunSetProperty Method

Sets the property. Used for generic (not so common) properties

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetProperty(
    string propname,
    Object propvalue
)
Public Function SetProperty (
    propname As String,
    propvalue As Object
) As Boolean
public:
bool SetProperty(
    String^ propname,
    Object^ propvalue
)
member SetProperty :
        propname : string *
        propvalue : Object -> bool

Parameters

propname String
The propname.
propvalue Object
The propvalue.

Return Value

Boolean
true if XXXX, false otherwise.
Exceptions
Exception | Condition
Exception |
Exception |
See Also

Reference

DocxRun Class


DocxRun.SetSize Method

DocxRunSetSize Method

Sets the size.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetSize(
    double size
)
Public Function SetSize (
    size As Double
) As DocxRun
public:
DocxRun^ SetSize(
    double size
)
member SetSize :
        size : float -> DocxRun

Parameters

size Double
The size.

Return Value

DocxRun
DocxRun.
See Also

Reference

DocxRun Class


DocxRun.SetStyle Method

DocxRunSetStyle Method

Sets the style.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxRun SetStyle(
    string styleName
)
Public Function SetStyle (
    styleName As String
) As DocxRun
public:
DocxRun^ SetStyle(
    String^ styleName
)
member SetStyle :
        styleName : string -> DocxRun

Parameters

styleName String
Name of the style.

Return Value

DocxRun

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxRun.SetStyle(System.String)"]

See Also

Reference

DocxRun Class


DocxSection Class

Class DocxSection.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxSection

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxSection
Public Class DocxSection
public ref class DocxSection
type DocxSection = class end

The DocxSection type exposes the following members.

Constructors
 | Name | Description
Public method | DocxSection | Initializes a new instance of the DocxSection class.
Public method | DocxSection(Section) | Initializes a new instance of the DocxSection class.
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | Orientation | Legge o scrive l'orientamento della pagina
Public property | PageHeight | Gets the page height.
Public property | PageMarginsBottom | Gets or set the bottom page margins.
Public property | PageMarginsFooter | Gets or set the footer page margins.
Public property | PageMarginsHeader | Gets or set the header page margins.
Public property | PageMarginsLeft | Gets or set the left page margins.
Public property | PageMarginsRight | Gets or set the right page margins.
Public property | PageMarginsTop | Gets or set the top page margins.
Public property | PageWidth | Gets the page width.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxSection Constructor

Overload List
 | Name | Description
Public method | DocxSection | Initializes a new instance of the DocxSection class.
Public method | DocxSection(Section) | Initializes a new instance of the DocxSection class.
Top
See Also

Reference

DocxSection Class


DocxSection Constructor

Initializes a new instance of the DocxSection class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection()
Public Sub New
public:
DocxSection()
new : unit -> DocxSection
See Also

Reference

DocxSection Class
DocxSection Overload


DocxSection(Section) Constructor

Initializes a new instance of the DocxSection class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection(
    Section innerObject
)
Public Sub New (
    innerObject As Section
)
public:
DocxSection(
    Section^ innerObject
)
new :
        innerObject : Section -> DocxSection

Parameters

innerObject Section
The inner object.
See Also

Reference

DocxSection Class
DocxSection Overload


DocxSection Properties

The DocxSection type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Public property | Orientation | Legge o scrive l'orientamento della pagina
Public property | PageHeight | Gets the page height.
Public property | PageMarginsBottom | Gets or set the bottom page margins.
Public property | PageMarginsFooter | Gets or set the footer page margins.
Public property | PageMarginsHeader | Gets or set the header page margins.
Public property | PageMarginsLeft | Gets or set the left page margins.
Public property | PageMarginsRight | Gets or set the right page margins.
Public property | PageMarginsTop | Gets or set the top page margins.
Public property | PageWidth | Gets the page width.
Top
See Also

Reference

DocxSection Class


DocxSection.InnerObject Property

DocxSectionInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Section InnerObject { get; set; }
Public Property InnerObject As Section
    Get
    Set
public:
property Section^ InnerObject {
    Section^ get ();
    void set (Section^ value);
}
member InnerObject : Section with get, set

Property Value

Section
The inner object.
See Also

Reference

DocxSection Class


DocxSection.Orientation Property

DocxSectionOrientation Property

Legge o scrive l'orientamento della pagina

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Orientation { get; set; }
Public Property Orientation As String
    Get
    Set
public:
property String^ Orientation {
    String^ get ();
    void set (String^ value);
}
member Orientation : string with get, set

Property Value

String
L'orientamento
See Also

Reference

DocxSection Class


DocxSection.PageHeight Property

DocxSectionPageHeight Property

Gets the page height.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageHeight { get; }
Public ReadOnly Property PageHeight As Double
    Get
public:
property double PageHeight {
    double get ();
}
member PageHeight : float with get

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageMarginsBottom Property

DocxSectionPageMarginsBottom Property

Gets or set the bottom page margins.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageMarginsBottom { get; set; }
Public Property PageMarginsBottom As Double
    Get
    Set
public:
property double PageMarginsBottom {
    double get ();
    void set (double value);
}
member PageMarginsBottom : float with get, set

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageMarginsFooter Property

DocxSectionPageMarginsFooter Property

Gets or set the footer page margins.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageMarginsFooter { get; set; }
Public Property PageMarginsFooter As Double
    Get
    Set
public:
property double PageMarginsFooter {
    double get ();
    void set (double value);
}
member PageMarginsFooter : float with get, set

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageMarginsHeader Property

DocxSectionPageMarginsHeader Property

Gets or set the header page margins.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageMarginsHeader { get; set; }
Public Property PageMarginsHeader As Double
    Get
    Set
public:
property double PageMarginsHeader {
    double get ();
    void set (double value);
}
member PageMarginsHeader : float with get, set

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageMarginsLeft Property

DocxSectionPageMarginsLeft Property

Gets or set the left page margins.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageMarginsLeft { get; set; }
Public Property PageMarginsLeft As Double
    Get
    Set
public:
property double PageMarginsLeft {
    double get ();
    void set (double value);
}
member PageMarginsLeft : float with get, set

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageMarginsRight Property

DocxSectionPageMarginsRight Property

Gets or set the right page margins.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageMarginsRight { get; set; }
Public Property PageMarginsRight As Double
    Get
    Set
public:
property double PageMarginsRight {
    double get ();
    void set (double value);
}
member PageMarginsRight : float with get, set

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageMarginsTop Property

DocxSectionPageMarginsTop Property

Gets or set the top page margins.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageMarginsTop { get; set; }
Public Property PageMarginsTop As Double
    Get
    Set
public:
property double PageMarginsTop {
    double get ();
    void set (double value);
}
member PageMarginsTop : float with get, set

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection.PageWidth Property

DocxSectionPageWidth Property

Gets the page width.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PageWidth { get; }
Public ReadOnly Property PageWidth As Double
    Get
public:
property double PageWidth {
    double get ();
}
member PageWidth : float with get

Property Value

Double
See Also

Reference

DocxSection Class


DocxSection Methods

The DocxSection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxSection Class


DocxTable Class

L'ogetto tabella
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxTable

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxTable
Public Class DocxTable
public ref class DocxTable
type DocxTable = class end

The DocxTable type exposes the following members.

Constructors
 | Name | Description
Public method | DocxTable | Costruttore standard
Public method | DocxTable(Table) | Costruttore wrapper standard
Top
Properties
 | Name | Description
Public property | AutoResize | Decide se la tabella deve ridimensionare le colonne automaticamente
Public property | Cells | Gets the cells.
Public property | ColumnsCount | Ritorna il numero di colonne della tabella.
Public property | InnerObject | Gets or sets the inner object.
Public property | Rows | Returns an enumerator that iterates through the collection.
Public property | RowsCount | Ritorna il numero di righe della tabella.
Public property | Section | Prende la sezione
Top
Methods
 | Name | Description
Public method | AddRow | Aggiunge una riga vuota
Public method | AddRow(ICollectionString) | Aggiunge una riga riempiendo le celle con il contenuto della tabella lua
Public method | AddRow(IListString) | Adds the row. To make it easy from Python...
Public method | AddRow(Int32) | Adds the row.
Public method | Clone | Clones this DocxTable instance.
Public method | DeleteRow | Deletes the row.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetCell | Prende la cella alle coordinate passate
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTableColumn | Gets the table column.
Public method | GetTableRow | Ritorna la riga di tabella
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HideBorders | Nasconde i bordi della tabella. Si usa per le tabelle di allinemanto.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | MergeCells | Esegue il merging delle celle.
Public method | MergeColumnsAuto(IListInt32) | Merges the columns automatic.
Public method | MergeColumnsAuto(Int32) | Merges the columns automatic.
Public method | ReadCell | Legge il testo della cella
Public method | SetAlignmentHorizontal | Sets the alignement.
Public method | SetAlignmentVertical | Sets the alignment vertical.
Public method | SetBorders | Set the table borders
Public method | SetColumnPreferredWidth | Imposta la preferenza sulla larghezza di colonna (non garantita)
Public method | SetColumnsPreferredWidth | Imposta le larghezze di colonna
Public method | SetFontBold | Sets the font bold.
Public method | SetFontItalic | Sets the font italic.
Public method | SetFontName | Imposta il font di tutta la cella
Public method | SetFontSize | Sets the size of the font.
Public method | SetLineSpacing | Sets the line spacing.
Public method | SetRowHeight | Sets the height.
Public method | SetStyle | Imposta lo stile della tabella.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteCell | Scrive il testo della cella
Public method | WriteRow | Scrive l'intera riga della tabella
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxTable Constructor

Overload List
 | Name | Description
Public method | DocxTable | Costruttore standard
Public method | DocxTable(Table) | Costruttore wrapper standard
Top
See Also

Reference

DocxTable Class


DocxTable Constructor

Costruttore standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable()
Public Sub New
public:
DocxTable()
new : unit -> DocxTable
See Also

Reference

DocxTable Class
DocxTable Overload


DocxTable(Table) Constructor

Costruttore wrapper standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable(
    Table innerObject
)
Public Sub New (
    innerObject As Table
)
public:
DocxTable(
    Table^ innerObject
)
new :
        innerObject : Table -> DocxTable

Parameters

innerObject Table
L'oggetto interno.
See Also

Reference

DocxTable Class
DocxTable Overload


DocxTable Properties

The DocxTable type exposes the following members.

Properties
 | Name | Description
Public property | AutoResize | Decide se la tabella deve ridimensionare le colonne automaticamente
Public property | Cells | Gets the cells.
Public property | ColumnsCount | Ritorna il numero di colonne della tabella.
Public property | InnerObject | Gets or sets the inner object.
Public property | Rows | Returns an enumerator that iterates through the collection.
Public property | RowsCount | Ritorna il numero di righe della tabella.
Public property | Section | Prende la sezione
Top
See Also

Reference

DocxTable Class


DocxTable.AutoResize Property

DocxTableAutoResize Property

Decide se la tabella deve ridimensionare le colonne automaticamente

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoResize { set; }
Public WriteOnly Property AutoResize As Boolean
    Set
public:
property bool AutoResize {
    void set (bool value);
}
member AutoResize : bool with set

Property Value

Boolean
true if [automatic resize]; otherwise, false.
See Also

Reference

DocxTable Class


DocxTable.Cells Property

DocxTableCells Property

Gets the cells.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DocxCell> Cells { get; }
Public ReadOnly Property Cells As IEnumerable(Of DocxCell)
    Get
public:
property IEnumerable<DocxCell^>^ Cells {
    IEnumerable<DocxCell^>^ get ();
}
member Cells : IEnumerable<DocxCell> with get

Property Value

IEnumerable DocxCell
The cells.
See Also

Reference

DocxTable Class


DocxTable.ColumnsCount Property

DocxTableColumnsCount Property

Ritorna il numero di colonne della tabella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ColumnsCount { get; }
Public ReadOnly Property ColumnsCount As Integer
    Get
public:
property int ColumnsCount {
    int get ();
}
member ColumnsCount : int with get

Property Value

Int32
The columns count.
See Also

Reference

DocxTable Class


DocxTable.InnerObject Property

DocxTableInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public Table InnerObject { get; set; }
Public Property InnerObject As Table
    Get
    Set
public:
property Table^ InnerObject {
    Table^ get ();
    void set (Table^ value);
}
member InnerObject : Table with get, set

Property Value

Table
The inner object.
See Also

Reference

DocxTable Class


DocxTable.Rows Property

DocxTableRows Property

Returns an enumerator that iterates through the collection.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DocxTableRow> Rows { get; }
Public ReadOnly Property Rows As IEnumerable(Of DocxTableRow)
    Get
public:
property IEnumerable<DocxTableRow^>^ Rows {
    IEnumerable<DocxTableRow^>^ get ();
}
member Rows : IEnumerable<DocxTableRow> with get

Property Value

IEnumerable DocxTableRow
The rows.
See Also

Reference

DocxTable Class


DocxTable.RowsCount Property

DocxTableRowsCount Property

Ritorna il numero di righe della tabella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RowsCount { get; }
Public ReadOnly Property RowsCount As Integer
    Get
public:
property int RowsCount {
    int get ();
}
member RowsCount : int with get

Property Value

Int32
The rows count.
See Also

Reference

DocxTable Class


DocxTable.Section Property

DocxTableSection Property

Prende la sezione

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxSection Section { get; }
Public ReadOnly Property Section As DocxSection
    Get
public:
property DocxSection^ Section {
    DocxSection^ get ();
}
member Section : DocxSection with get

Property Value

DocxSection
La sezione di appartenenza
See Also

Reference

DocxTable Class


DocxTable Methods

The DocxTable type exposes the following members.

Methods
 | Name | Description
Public method | AddRow | Aggiunge una riga vuota
Public method | AddRow(ICollectionString) | Aggiunge una riga riempiendo le celle con il contenuto della tabella lua
Public method | AddRow(IListString) | Adds the row. To make it easy from Python...
Public method | AddRow(Int32) | Adds the row.
Public method | Clone | Clones this DocxTable instance.
Public method | DeleteRow | Deletes the row.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetCell | Prende la cella alle coordinate passate
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTableColumn | Gets the table column.
Public method | GetTableRow | Ritorna la riga di tabella
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HideBorders | Nasconde i bordi della tabella. Si usa per le tabelle di allinemanto.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | MergeCells | Esegue il merging delle celle.
Public method | MergeColumnsAuto(IListInt32) | Merges the columns automatic.
Public method | MergeColumnsAuto(Int32) | Merges the columns automatic.
Public method | ReadCell | Legge il testo della cella
Public method | SetAlignmentHorizontal | Sets the alignement.
Public method | SetAlignmentVertical | Sets the alignment vertical.
Public method | SetBorders | Set the table borders
Public method | SetColumnPreferredWidth | Imposta la preferenza sulla larghezza di colonna (non garantita)
Public method | SetColumnsPreferredWidth | Imposta le larghezze di colonna
Public method | SetFontBold | Sets the font bold.
Public method | SetFontItalic | Sets the font italic.
Public method | SetFontName | Imposta il font di tutta la cella
Public method | SetFontSize | Sets the size of the font.
Public method | SetLineSpacing | Sets the line spacing.
Public method | SetRowHeight | Sets the height.
Public method | SetStyle | Imposta lo stile della tabella.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteCell | Scrive il testo della cella
Public method | WriteRow | Scrive l'intera riga della tabella
Top
See Also

Reference

DocxTable Class


DocxTable.AddRow Method

DocxTableAddRow Method

Overload List
 | Name | Description
Public method | AddRow | Aggiunge una riga vuota
Public method | AddRow(ICollectionString) | Aggiunge una riga riempiendo le celle con il contenuto della tabella lua
Public method | AddRow(IListString) | Adds the row. To make it easy from Python...
Public method | AddRow(Int32) | Adds the row.
Top
See Also

Reference

DocxTable Class


DocxTable.AddRow Method

DocxTableAddRow Method

Aggiunge una riga vuota

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddRow()
Public Function AddRow As DocxTable
public:
DocxTable^ AddRow()
member AddRow : unit -> DocxTable

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class
AddRow Overload


DocxTable.AddRow(ICollection<String>) Method

DocxTableAddRow(ICollectionString) Method

Aggiunge una riga riempiendo le celle con il contenuto della tabella lua

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddRow(
    ICollection<string> rowdata
)
Public Function AddRow (
    rowdata As ICollection(Of String)
) As DocxTable
public:
DocxTable^ AddRow(
    ICollection<String^>^ rowdata
)
member AddRow :
        rowdata : ICollection<string> -> DocxTable

Parameters

rowdata ICollection String
The rowdata.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class
AddRow Overload


DocxTable.AddRow(IList<String>) Method

DocxTableAddRow(IListString) Method

Adds the row. To make it easy from Python...

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddRow(
    IList<string> rowdata
)
Public Function AddRow (
    rowdata As IList(Of String)
) As DocxTable
public:
DocxTable^ AddRow(
    IList<String^>^ rowdata
)
member AddRow :
        rowdata : IList<string> -> DocxTable

Parameters

rowdata IList String
The rowdata.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class
AddRow Overload


DocxTable.AddRow(Int32) Method

DocxTableAddRow(Int32) Method

Adds the row.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable AddRow(
    int idx
)
Public Function AddRow (
    idx As Integer
) As DocxTable
public:
DocxTable^ AddRow(
    int idx
)
member AddRow :
        idx : int -> DocxTable

Parameters

idx Int32
The index.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class
AddRow Overload


DocxTable.Clone Method

DocxTableClone Method

Clones this DocxTable instance.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable Clone(
    bool cloneDescendants
)
Public Function Clone (
    cloneDescendants As Boolean
) As DocxTable
public:
DocxTable^ Clone(
    bool cloneDescendants
)
member Clone :
        cloneDescendants : bool -> DocxTable

Parameters

cloneDescendants Boolean
If set to true clone all descendants recursively; otherwise clone only current Table.

Return Value

DocxTable

[Missing <returns> documentation for "M:QsGemBox.Docx.DocxTable.Clone(System.Boolean)"]

See Also

Reference

DocxTable Class


DocxTable.DeleteRow Method

DocxTableDeleteRow Method

Deletes the row.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable DeleteRow(
    int index
)
Public Function DeleteRow (
    index As Integer
) As DocxTable
public:
DocxTable^ DeleteRow(
    int index
)
member DeleteRow :
        index : int -> DocxTable

Parameters

index Int32
The index.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.GetCell Method

DocxTableGetCell Method

Prende la cella alle coordinate passate

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxCell GetCell(
    int row,
    int column
)
Public Function GetCell (
    row As Integer,
    column As Integer
) As DocxCell
public:
DocxCell^ GetCell(
    int row,
    int column
)
member GetCell :
        row : int *
        column : int -> DocxCell

Parameters

row Int32
The row.
column Int32
The column.

Return Value

DocxCell
DocxCell.
See Also

Reference

DocxTable Class


DocxTable.GetTableColumn Method

DocxTableGetTableColumn Method

Gets the table column.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableColumn GetTableColumn(
    int col
)
Public Function GetTableColumn (
    col As Integer
) As DocxTableColumn
public:
DocxTableColumn^ GetTableColumn(
    int col
)
member GetTableColumn :
        col : int -> DocxTableColumn

Parameters

col Int32
The col.

Return Value

DocxTableColumn
DocxTableColumn.
See Also

Reference

DocxTable Class


DocxTable.GetTableRow Method

DocxTableGetTableRow Method

Ritorna la riga di tabella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow GetTableRow(
    int row
)
Public Function GetTableRow (
    row As Integer
) As DocxTableRow
public:
DocxTableRow^ GetTableRow(
    int row
)
member GetTableRow :
        row : int -> DocxTableRow

Parameters

row Int32
The row.

Return Value

DocxTableRow
TableRow.
See Also

Reference

DocxTable Class


DocxTable.HideBorders Method

DocxTableHideBorders Method

Nasconde i bordi della tabella. Si usa per le tabelle di allinemanto.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable HideBorders()
Public Function HideBorders As DocxTable
public:
DocxTable^ HideBorders()
member HideBorders : unit -> DocxTable

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.MergeCells Method

DocxTableMergeCells Method

Esegue il merging delle celle.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable MergeCells(
    int row,
    int column,
    int hspan,
    int vspan
)
Public Function MergeCells (
    row As Integer,
    column As Integer,
    hspan As Integer,
    vspan As Integer
) As DocxTable
public:
DocxTable^ MergeCells(
    int row,
    int column,
    int hspan,
    int vspan
)
member MergeCells :
        row : int *
        column : int *
        hspan : int *
        vspan : int -> DocxTable

Parameters

row Int32
L'indice di riga (0 based) della cella radice
column Int32
L'indice di colonna (0 based) della cella radice
hspan Int32
Numero di celle da fondere in orizzontale (a destra)
vspan Int32
Numero di celle da fondere in verticale (in basso)

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.MergeColumnsAuto Method

DocxTableMergeColumnsAuto Method

Overload List
 | Name | Description
Public method | MergeColumnsAuto(IListInt32) | Merges the columns automatic.
Public method | MergeColumnsAuto(Int32) | Merges the columns automatic.
Top
See Also

Reference

DocxTable Class


DocxTable.MergeColumnsAuto(IList<Int32>) Method

DocxTableMergeColumnsAuto(IListInt32) Method

Merges the columns automatic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MergeColumnsAuto(
    IList<int> columnIndexes
)
Public Sub MergeColumnsAuto (
    columnIndexes As IList(Of Integer)
)
public:
void MergeColumnsAuto(
    IList<int>^ columnIndexes
)
member MergeColumnsAuto :
        columnIndexes : IList<int> -> unit

Parameters

columnIndexes IList Int32
The column indexes.
See Also

Reference

DocxTable Class
MergeColumnsAuto Overload


DocxTable.MergeColumnsAuto(Int32) Method

DocxTableMergeColumnsAuto(Int32) Method

Merges the columns automatic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MergeColumnsAuto(
    int columnIndex
)
Public Sub MergeColumnsAuto (
    columnIndex As Integer
)
public:
void MergeColumnsAuto(
    int columnIndex
)
member MergeColumnsAuto :
        columnIndex : int -> unit

Parameters

columnIndex Int32
The column indexes.
See Also

Reference

DocxTable Class
MergeColumnsAuto Overload


DocxTable.ReadCell Method

DocxTableReadCell Method

Legge il testo della cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReadCell(
    int row,
    int column
)
Public Function ReadCell (
    row As Integer,
    column As Integer
) As String
public:
String^ ReadCell(
    int row,
    int column
)
member ReadCell :
        row : int *
        column : int -> string

Parameters

row Int32
L'indice di riga
column Int32
L'indice di colonna

Return Value

String
System.String.
See Also

Reference

DocxTable Class


DocxTable.SetAlignmentHorizontal Method

DocxTableSetAlignmentHorizontal Method

Sets the alignement.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetAlignmentHorizontal(
    string alignement
)
Public Function SetAlignmentHorizontal (
    alignement As String
) As DocxTable
public:
DocxTable^ SetAlignmentHorizontal(
    String^ alignement
)
member SetAlignmentHorizontal :
        alignement : string -> DocxTable

Parameters

alignement String
The alignement.

Return Value

DocxTable
DocxCell.
See Also

Reference

DocxTable Class


DocxTable.SetAlignmentVertical Method

DocxTableSetAlignmentVertical Method

Sets the alignment vertical.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetAlignmentVertical(
    string alignement
)
Public Function SetAlignmentVertical (
    alignement As String
) As DocxTable
public:
DocxTable^ SetAlignmentVertical(
    String^ alignement
)
member SetAlignmentVertical :
        alignement : string -> DocxTable

Parameters

alignement String
The alignement.

Return Value

DocxTable
DocxCell.
See Also

Reference

DocxTable Class


DocxTable.SetBorders Method

DocxTableSetBorders Method

Set the table borders

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetBorders(
    int borderType,
    int borderStyle,
    Color color,
    double width
)
Public Function SetBorders (
    borderType As Integer,
    borderStyle As Integer,
    color As Color,
    width As Double
) As DocxTable
public:
DocxTable^ SetBorders(
    int borderType,
    int borderStyle,
    Color color,
    double width
)
member SetBorders :
        borderType : int *
        borderStyle : int *
        color : Color *
        width : float -> DocxTable

Parameters

borderType Int32
None = 0, Left = 1, Top = 2, Right = 4, Bottom = 8, Outside = 15, InsideHorizontal = 16, InsideVertical = 32, Inside = 48, DiagonalDown = 64, DiagonalUp = 128, Diagonal = 192, All = 255
borderStyle Int32
None = 0, Single = 1, Double = 2, Triple = 3, Dotted = 4, Dashed = 5, DotDash = 6, DotDotDash = 7, Wave = 8, DoubleWave = 9,
color Color
The color.
width Double
The width.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.SetColumnPreferredWidth Method

DocxTableSetColumnPreferredWidth Method

Imposta la preferenza sulla larghezza di colonna (non garantita)

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetColumnPreferredWidth(
    int col,
    double preferredWidth
)
Public Function SetColumnPreferredWidth (
    col As Integer,
    preferredWidth As Double
) As DocxTable
public:
DocxTable^ SetColumnPreferredWidth(
    int col,
    double preferredWidth
)
member SetColumnPreferredWidth :
        col : int *
        preferredWidth : float -> DocxTable

Parameters

col Int32
The col.
preferredWidth Double
Width of the preferred.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.SetColumnsPreferredWidth Method

DocxTableSetColumnsPreferredWidth Method

Imposta le larghezze di colonna

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetColumnsPreferredWidth(
    IList<int> widths
)
Public Function SetColumnsPreferredWidth (
    widths As IList(Of Integer)
) As DocxTable
public:
DocxTable^ SetColumnsPreferredWidth(
    IList<int>^ widths
)
member SetColumnsPreferredWidth :
        widths : IList<int> -> DocxTable

Parameters

widths IList Int32
The widths.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.SetFontBold Method

DocxTableSetFontBold Method

Sets the font bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetFontBold(
    bool bold
)
Public Function SetFontBold (
    bold As Boolean
) As DocxTable
public:
DocxTable^ SetFontBold(
    bool bold
)
member SetFontBold :
        bold : bool -> DocxTable

Parameters

bold Boolean
if set to true [bold].

Return Value

DocxTable
DocxTableRow.
See Also

Reference

DocxTable Class


DocxTable.SetFontItalic Method

DocxTableSetFontItalic Method

Sets the font italic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetFontItalic(
    bool italic
)
Public Function SetFontItalic (
    italic As Boolean
) As DocxTable
public:
DocxTable^ SetFontItalic(
    bool italic
)
member SetFontItalic :
        italic : bool -> DocxTable

Parameters

italic Boolean
if set to true [italic].

Return Value

DocxTable
DocxTableRow.
See Also

Reference

DocxTable Class


DocxTable.SetFontName Method

DocxTableSetFontName Method

Imposta il font di tutta la cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetFontName(
    string fontName
)
Public Function SetFontName (
    fontName As String
) As DocxTable
public:
DocxTable^ SetFontName(
    String^ fontName
)
member SetFontName :
        fontName : string -> DocxTable

Parameters

fontName String
Name of the font.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.SetFontSize Method

DocxTableSetFontSize Method

Sets the size of the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetFontSize(
    double fontSize
)
Public Function SetFontSize (
    fontSize As Double
) As DocxTable
public:
DocxTable^ SetFontSize(
    double fontSize
)
member SetFontSize :
        fontSize : float -> DocxTable

Parameters

fontSize Double
Size of the font.

Return Value

DocxTable
DocxTableRow.
See Also

Reference

DocxTable Class


DocxTable.SetLineSpacing Method

DocxTableSetLineSpacing Method

Sets the line spacing.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetLineSpacing(
    double lineSpacing
)
Public Function SetLineSpacing (
    lineSpacing As Double
) As DocxTable
public:
DocxTable^ SetLineSpacing(
    double lineSpacing
)
member SetLineSpacing :
        lineSpacing : float -> DocxTable

Parameters

lineSpacing Double
The line spacing.

Return Value

DocxTable
DocxCell.
See Also

Reference

DocxTable Class


DocxTable.SetRowHeight Method

DocxTableSetRowHeight Method

Sets the height.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetRowHeight(
    double height,
    TableRowHeightRule rule
)
Public Function SetRowHeight (
    height As Double,
    rule As TableRowHeightRule
) As DocxTable
public:
DocxTable^ SetRowHeight(
    double height,
    TableRowHeightRule rule
)
member SetRowHeight :
        height : float *
        rule : TableRowHeightRule -> DocxTable

Parameters

height Double
The height.
rule TableRowHeightRule
The rule.

Return Value

DocxTable
DocxTableRow.
See Also

Reference

DocxTable Class


DocxTable.SetStyle Method

DocxTableSetStyle Method

Imposta lo stile della tabella.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable SetStyle(
    DocxTableStyle style
)
Public Function SetStyle (
    style As DocxTableStyle
) As DocxTable
public:
DocxTable^ SetStyle(
    DocxTableStyle^ style
)
member SetStyle :
        style : DocxTableStyle -> DocxTable

Parameters

style DocxTableStyle
Stile da utilizzare.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.WriteCell Method

DocxTableWriteCell Method

Scrive il testo della cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable WriteCell(
    string val,
    int row,
    int column
)
Public Function WriteCell (
    val As String,
    row As Integer,
    column As Integer
) As DocxTable
public:
DocxTable^ WriteCell(
    String^ val,
    int row,
    int column
)
member WriteCell :
        val : string *
        row : int *
        column : int -> DocxTable

Parameters

val String
Il testo da scrivere
row Int32
L'indice di riga
column Int32
L'indice di colonna

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTable.WriteRow Method

DocxTableWriteRow Method

Scrive l'intera riga della tabella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTable WriteRow(
    IEnumerable<string> values,
    int row
)
Public Function WriteRow (
    values As IEnumerable(Of String),
    row As Integer
) As DocxTable
public:
DocxTable^ WriteRow(
    IEnumerable<String^>^ values,
    int row
)
member WriteRow :
        values : IEnumerable<string> *
        row : int -> DocxTable

Parameters

values IEnumerable String
The values.
row Int32
The row.

Return Value

DocxTable
DocxTable.
See Also

Reference

DocxTable Class


DocxTableColumn Class

Class DocxTableColumn.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxTableColumn

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxTableColumn
Public Class DocxTableColumn
public ref class DocxTableColumn
type DocxTableColumn = class end

The DocxTableColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DocxTableColumn | Costruttore standard
Public method | DocxTableColumn(TableColumn, Table) | Costruttore wrapper standard
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetPreferredWidth | Sets the width of the preferred.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxTableColumn Constructor

Overload List
 | Name | Description
Public method | DocxTableColumn | Costruttore standard
Public method | DocxTableColumn(TableColumn, Table) | Costruttore wrapper standard
Top
See Also

Reference

DocxTableColumn Class


DocxTableColumn Constructor

Costruttore standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableColumn()
Public Sub New
public:
DocxTableColumn()
new : unit -> DocxTableColumn
See Also

Reference

DocxTableColumn Class
DocxTableColumn Overload


DocxTableColumn(TableColumn, Table) Constructor

Costruttore wrapper standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableColumn(
    TableColumn innerObject,
    Table table
)
Public Sub New (
    innerObject As TableColumn,
    table As Table
)
public:
DocxTableColumn(
    TableColumn^ innerObject,
    Table^ table
)
new :
        innerObject : TableColumn *
        table : Table -> DocxTableColumn

Parameters

innerObject TableColumn
L'oggetto interno.
table Table
The table.
See Also

Reference

DocxTableColumn Class
DocxTableColumn Overload


DocxTableColumn Properties

The DocxTableColumn type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Top
See Also

Reference

DocxTableColumn Class


DocxTableColumn.InnerObject Property

DocxTableColumnInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableColumn InnerObject { get; set; }
Public Property InnerObject As TableColumn
    Get
    Set
public:
property TableColumn^ InnerObject {
    TableColumn^ get ();
    void set (TableColumn^ value);
}
member InnerObject : TableColumn with get, set

Property Value

TableColumn
The inner object.
See Also

Reference

DocxTableColumn Class


DocxTableColumn Methods

The DocxTableColumn type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetPreferredWidth | Sets the width of the preferred.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxTableColumn Class


DocxTableColumn.SetPreferredWidth Method

DocxTableColumnSetPreferredWidth Method

Sets the width of the preferred.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableColumn SetPreferredWidth(
    double width
)
Public Function SetPreferredWidth (
    width As Double
) As DocxTableColumn
public:
DocxTableColumn^ SetPreferredWidth(
    double width
)
member SetPreferredWidth :
        width : float -> DocxTableColumn

Parameters

width Double
The width.

Return Value

DocxTableColumn
GemBox.DocxTableColumn.
See Also

Reference

DocxTableColumn Class


DocxTableRow Class

Class DocxTableRow.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxTableRow

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxTableRow
Public Class DocxTableRow
public ref class DocxTableRow
type DocxTableRow = class end

The DocxTableRow type exposes the following members.

Constructors
 | Name | Description
Public method | DocxTableRow | Costruttore standard
Public method | DocxTableRow(TableRow) | Costruttore wrapper standard
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetAlignmentHorizontal | Sets the alignement.
Public method | SetAlignmentVertical | Sets the alignment vertical.
Public method | SetBackgroundColor(Color) | Sets the color of the background.
Public method | SetBackgroundColor(Int32, Int32, Int32) | Sets the color of the background.
Public method | SetFontBold | Sets the font bold.
Public method | SetFontItalic | Sets the font italic.
Public method | SetFontName | Imposta il font di tutta la cella
Public method | SetFontSize | Sets the size of the font.
Public method | SetLineSpacing | Sets the line spacing.
Public method | SetRowHeight | Sets the height.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxTableRow Constructor

Overload List
 | Name | Description
Public method | DocxTableRow | Costruttore standard
Public method | DocxTableRow(TableRow) | Costruttore wrapper standard
Top
See Also

Reference

DocxTableRow Class


DocxTableRow Constructor

Costruttore standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow()
Public Sub New
public:
DocxTableRow()
new : unit -> DocxTableRow
See Also

Reference

DocxTableRow Class
DocxTableRow Overload


DocxTableRow(TableRow) Constructor

Costruttore wrapper standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow(
    TableRow innerObject
)
Public Sub New (
    innerObject As TableRow
)
public:
DocxTableRow(
    TableRow^ innerObject
)
new :
        innerObject : TableRow -> DocxTableRow

Parameters

innerObject TableRow
L'oggetto interno.
See Also

Reference

DocxTableRow Class
DocxTableRow Overload


DocxTableRow Properties

The DocxTableRow type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the inner object.
Top
See Also

Reference

DocxTableRow Class


DocxTableRow.InnerObject Property

DocxTableRowInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableRow InnerObject { get; set; }
Public Property InnerObject As TableRow
    Get
    Set
public:
property TableRow^ InnerObject {
    TableRow^ get ();
    void set (TableRow^ value);
}
member InnerObject : TableRow with get, set

Property Value

TableRow
The inner object.
See Also

Reference

DocxTableRow Class


DocxTableRow Methods

The DocxTableRow type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetAlignmentHorizontal | Sets the alignement.
Public method | SetAlignmentVertical | Sets the alignment vertical.
Public method | SetBackgroundColor(Color) | Sets the color of the background.
Public method | SetBackgroundColor(Int32, Int32, Int32) | Sets the color of the background.
Public method | SetFontBold | Sets the font bold.
Public method | SetFontItalic | Sets the font italic.
Public method | SetFontName | Imposta il font di tutta la cella
Public method | SetFontSize | Sets the size of the font.
Public method | SetLineSpacing | Sets the line spacing.
Public method | SetRowHeight | Sets the height.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxTableRow Class


DocxTableRow.SetAlignmentHorizontal Method

DocxTableRowSetAlignmentHorizontal Method

Sets the alignement.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetAlignmentHorizontal(
    string alignement
)
Public Function SetAlignmentHorizontal (
    alignement As String
) As DocxTableRow
public:
DocxTableRow^ SetAlignmentHorizontal(
    String^ alignement
)
member SetAlignmentHorizontal :
        alignement : string -> DocxTableRow

Parameters

alignement String
The alignement.

Return Value

DocxTableRow
DocxCell.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetAlignmentVertical Method

DocxTableRowSetAlignmentVertical Method

Sets the alignment vertical.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetAlignmentVertical(
    string alignement
)
Public Function SetAlignmentVertical (
    alignement As String
) As DocxTableRow
public:
DocxTableRow^ SetAlignmentVertical(
    String^ alignement
)
member SetAlignmentVertical :
        alignement : string -> DocxTableRow

Parameters

alignement String
The alignement.

Return Value

DocxTableRow
DocxCell.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetBackgroundColor Method

DocxTableRowSetBackgroundColor Method

Overload List
 | Name | Description
Public method | SetBackgroundColor(Color) | Sets the color of the background.
Public method | SetBackgroundColor(Int32, Int32, Int32) | Sets the color of the background.
Top
See Also

Reference

DocxTableRow Class


DocxTableRow.SetBackgroundColor(Color) Method

DocxTableRowSetBackgroundColor(Color) Method

Sets the color of the background.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetBackgroundColor(
    Color color
)
Public Function SetBackgroundColor (
    color As Color
) As DocxTableRow
public:
DocxTableRow^ SetBackgroundColor(
    Color color
)
member SetBackgroundColor :
        color : Color -> DocxTableRow

Parameters

color Color
The color.

Return Value

DocxTableRow
DocxCell.
See Also

Reference

DocxTableRow Class
SetBackgroundColor Overload


DocxTableRow.SetBackgroundColor(Int32, Int32, Int32) Method

DocxTableRowSetBackgroundColor(Int32, Int32, Int32) Method

Sets the color of the background.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetBackgroundColor(
    int r,
    int g,
    int b
)
Public Function SetBackgroundColor (
    r As Integer,
    g As Integer,
    b As Integer
) As DocxTableRow
public:
DocxTableRow^ SetBackgroundColor(
    int r,
    int g,
    int b
)
member SetBackgroundColor :
        r : int *
        g : int *
        b : int -> DocxTableRow

Parameters

r Int32
The r.
g Int32
The g.
b Int32
The b.

Return Value

DocxTableRow
DocxTableRow.
See Also

Reference

DocxTableRow Class
SetBackgroundColor Overload


DocxTableRow.SetFontBold Method

DocxTableRowSetFontBold Method

Sets the font bold.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetFontBold(
    bool bold
)
Public Function SetFontBold (
    bold As Boolean
) As DocxTableRow
public:
DocxTableRow^ SetFontBold(
    bool bold
)
member SetFontBold :
        bold : bool -> DocxTableRow

Parameters

bold Boolean
if set to true [bold].

Return Value

DocxTableRow
DocxTableRow.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetFontItalic Method

DocxTableRowSetFontItalic Method

Sets the font italic.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetFontItalic(
    bool italic
)
Public Function SetFontItalic (
    italic As Boolean
) As DocxTableRow
public:
DocxTableRow^ SetFontItalic(
    bool italic
)
member SetFontItalic :
        italic : bool -> DocxTableRow

Parameters

italic Boolean
if set to true [italic].

Return Value

DocxTableRow
DocxTableRow.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetFontName Method

DocxTableRowSetFontName Method

Imposta il font di tutta la cella

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetFontName(
    string fontName
)
Public Function SetFontName (
    fontName As String
) As DocxTableRow
public:
DocxTableRow^ SetFontName(
    String^ fontName
)
member SetFontName :
        fontName : string -> DocxTableRow

Parameters

fontName String
Name of the font.

Return Value

DocxTableRow
DocxTableRow.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetFontSize Method

DocxTableRowSetFontSize Method

Sets the size of the font.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetFontSize(
    double fontSize
)
Public Function SetFontSize (
    fontSize As Double
) As DocxTableRow
public:
DocxTableRow^ SetFontSize(
    double fontSize
)
member SetFontSize :
        fontSize : float -> DocxTableRow

Parameters

fontSize Double
Size of the font.

Return Value

DocxTableRow
DocxTableRow.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetLineSpacing Method

DocxTableRowSetLineSpacing Method

Sets the line spacing.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetLineSpacing(
    double lineSpacing
)
Public Function SetLineSpacing (
    lineSpacing As Double
) As DocxTableRow
public:
DocxTableRow^ SetLineSpacing(
    double lineSpacing
)
member SetLineSpacing :
        lineSpacing : float -> DocxTableRow

Parameters

lineSpacing Double
The line spacing.

Return Value

DocxTableRow
DocxCell.
See Also

Reference

DocxTableRow Class


DocxTableRow.SetRowHeight Method

DocxTableRowSetRowHeight Method

Sets the height.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRow SetRowHeight(
    double height,
    TableRowHeightRule rule
)
Public Function SetRowHeight (
    height As Double,
    rule As TableRowHeightRule
) As DocxTableRow
public:
DocxTableRow^ SetRowHeight(
    double height,
    TableRowHeightRule rule
)
member SetRowHeight :
        height : float *
        rule : TableRowHeightRule -> DocxTableRow

Parameters

height Double
The height.
rule TableRowHeightRule
The rule.

Return Value

DocxTableRow
DocxTableRow.
See Also

Reference

DocxTableRow Class


DocxTableRowsIterator Class

Class DocxTableRowsIterator.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxTableRowsIterator

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxTableRowsIterator : IEnumerable<DocxTableRow>,
    IEnumerable
Public Class DocxTableRowsIterator
    Implements IEnumerable(Of DocxTableRow), IEnumerable
public ref class DocxTableRowsIterator : IEnumerable<DocxTableRow^>,
    IEnumerable
type DocxTableRowsIterator =
    class
        interface IEnumerable<DocxTableRow>
        interface IEnumerable
    end

The DocxTableRowsIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DocxTableRowsIterator | Initializes a new instance of the DocxTableRowsIterator class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace
DocxTableRow
DocxTableRow


DocxTableRowsIterator Constructor

Initializes a new instance of the DocxTableRowsIterator class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableRowsIterator(
    Table table
)
Public Sub New (
    table As Table
)
public:
DocxTableRowsIterator(
    Table^ table
)
new :
        table : Table -> DocxTableRowsIterator

Parameters

table Table
The table.
See Also

Reference

DocxTableRowsIterator Class


DocxTableRowsIterator Methods

The DocxTableRowsIterator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxTableRowsIterator Class


DocxTableRowsIterator.GetEnumerator Method

DocxTableRowsIteratorGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<DocxTableRow> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DocxTableRow)
public:
virtual IEnumerator<DocxTableRow^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<DocxTableRow>
override GetEnumerator : unit -> IEnumerator<DocxTableRow>

Return Value

IEnumerator DocxTableRow
An enumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DocxTableRowsIterator Class


DocxTableStyle Class

Class DocxTableStyle.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxTableStyle

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxTableStyle
Public Class DocxTableStyle
public ref class DocxTableStyle
type DocxTableStyle = class end

The DocxTableStyle type exposes the following members.

Constructors
 | Name | Description
Public method | DocxTableStyle | Costruttore standard
Top
Properties
 | Name | Description
Public property | InnerObject | Gets or sets the table style.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxTableStyle Constructor

Costruttore standard

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTableStyle(
    TableStyle innerObject
)
Public Sub New (
    innerObject As TableStyle
)
public:
DocxTableStyle(
    TableStyle^ innerObject
)
new :
        innerObject : TableStyle -> DocxTableStyle

Parameters

innerObject TableStyle

[Missing <param name="innerObject"/> documentation for "M:QsGemBox.Docx.DocxTableStyle.#ctor(GemBox.Document.Tables.TableStyle)"]

See Also

Reference

DocxTableStyle Class


DocxTableStyle Properties

The DocxTableStyle type exposes the following members.

Properties
 | Name | Description
Public property | InnerObject | Gets or sets the table style.
Top
See Also

Reference

DocxTableStyle Class


DocxTableStyle.InnerObject Property

DocxTableStyleInnerObject Property

Gets or sets the table style.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableStyle InnerObject { get; set; }
Public Property InnerObject As TableStyle
    Get
    Set
public:
property TableStyle^ InnerObject {
    TableStyle^ get ();
    void set (TableStyle^ value);
}
member InnerObject : TableStyle with get, set

Property Value

TableStyle
The inner object.
See Also

Reference

DocxTableStyle Class


DocxTableStyle Methods

The DocxTableStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxTableStyle Class


DocxTextBox Class

Class DocxTextBox.
Inheritance Hierarchy
SystemObject
QsGemBox.DocxDocxTextBox

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocxTextBox
Public Class DocxTextBox
public ref class DocxTextBox
type DocxTextBox = class end

The DocxTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | DocxTextBox | Initializes a new instance of the DocxTextBox class.
Public method | DocxTextBox(TextBox) | Initializes a new instance of the DocxTextBox class.
Top
Properties
 | Name | Description
Public property | Height | Gets the height.
Public property | InnerObject | Gets or sets the inner object.
Public property | Width | Gets the width.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetSize | Sets the size of the textbox
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QsGemBox.Docx Namespace


DocxTextBox Constructor

Overload List
 | Name | Description
Public method | DocxTextBox | Initializes a new instance of the DocxTextBox class.
Public method | DocxTextBox(TextBox) | Initializes a new instance of the DocxTextBox class.
Top
See Also

Reference

DocxTextBox Class


DocxTextBox Constructor

Initializes a new instance of the DocxTextBox class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTextBox()
Public Sub New
public:
DocxTextBox()
new : unit -> DocxTextBox
See Also

Reference

DocxTextBox Class
DocxTextBox Overload


DocxTextBox(TextBox) Constructor

Initializes a new instance of the DocxTextBox class.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocxTextBox(
    TextBox innerObject
)
Public Sub New (
    innerObject As TextBox
)
public:
DocxTextBox(
    TextBox^ innerObject
)
new :
        innerObject : TextBox -> DocxTextBox

Parameters

innerObject TextBox
The inner object.
See Also

Reference

DocxTextBox Class
DocxTextBox Overload


DocxTextBox Properties

The DocxTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height.
Public property | InnerObject | Gets or sets the inner object.
Public property | Width | Gets the width.
Top
See Also

Reference

DocxTextBox Class


DocxTextBox.Height Property

DocxTextBoxHeight Property

Gets the height.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
The height.
See Also

Reference

DocxTextBox Class


DocxTextBox.InnerObject Property

DocxTextBoxInnerObject Property

Gets or sets the inner object.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextBox InnerObject { get; set; }
Public Property InnerObject As TextBox
    Get
    Set
public:
property TextBox^ InnerObject {
    TextBox^ get ();
    void set (TextBox^ value);
}
member InnerObject : TextBox with get, set

Property Value

TextBox
The inner object.
See Also

Reference

DocxTextBox Class


DocxTextBox.Width Property

DocxTextBoxWidth Property

Gets the width.

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
The width.
See Also

Reference

DocxTextBox Class


DocxTextBox Methods

The DocxTextBox type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetSize | Sets the size of the textbox
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocxTextBox Class


DocxTextBox.SetSize Method

DocxTextBoxSetSize Method

Sets the size of the textbox

Namespace: QsGemBox.Docx
Assembly: QsGemBox (in QsGemBox.dll) Version: 26.4.0.0 (26.4.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSize(
    double width,
    double height
)
Public Sub SetSize (
    width As Double,
    height As Double
)
public:
void SetSize(
    double width,
    double height
)
member SetSize :
        width : float *
        height : float -> unit

Parameters

width Double
The width.
height Double
The height.
See Also

Reference

DocxTextBox Class


QsGemBox

QsGembox mette a disposizione dell'utente una serie di API atte ad operare con i file di Word.