InitPrtFast Namespace

[image]

Libreria query DedNet
InitPrtFast Namespace
Send Feedback

Classes

 | Class | Description
Public class | InitPrtFast | Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.
Public class | InitPrtFast..::..Element | Classe che rappreseneta l'oggetto cella.
Public class | InitPrtFast..::..InitPrtFastCtxMenuCommand | Classe per gestire i comandi personalizzati sul tasto dx.
Public class | InitPrtFast..::..InitPrtFastCtxMenuCommandList | Lista di oggetti InitPrtFastCtxMenuCommand.
Public class | InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs | Argomento utilizzato durante il click su un menu constestuale personalizzato.
Public class | InitPrtFast..::..PrtInitSelectionEventArgs | Classe contenente le informazioni per l'evento SelectionChanged.
Public class | InitPrtFast..::..Row |
Public class | InitPrtFast..::..Rows |
Public class | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'

Enumerations

 | Enumeration | Description
Public enumeration | InitPrtFast..::..SelectionVisibility | Definizione possibili azioni su oggetti importazione

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it

QS Informatica Srl


InitPrtFast Class

[image]

Libreria query DedNet
InitPrtFast Class
Members See Also Send Feedback
Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InitPrtFast : XtraUserControl
Visual Basic
Public Class InitPrtFast _
    Inherits XtraUserControl
Visual C++
public ref class InitPrtFast : public XtraUserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
XtraUserControl
InitPrtFast..::..InitPrtFast

See Also

InitPrtFast Members
InitPrtFast Namespace


InitPrtFast Members

[image] [image]

Libreria query DedNet
InitPrtFast Members
InitPrtFast Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The InitPrtFast type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast | Costruttore unico.

Methods

 | Name | Description
Public method | AllowDragAndDrop |
Protected method | CreateDefaultAppearance | (Inherited from XtraUserControl.)
Protected method | CreatePainter | (Inherited from XtraUserControl.)
Protected method | Dispose | Liberare le risorse in uso. (Overrides XtraUserControlDispose(Boolean).)
Protected method | GetBackColor | (Inherited from XtraUserControl.)
Protected method | GetInnerIXtraResizableControl | (Inherited from XtraUserControl.)
Protected method | GetService | (Inherited from XtraUserControl.)
Public method | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
 | Log | Utilità di logging delle Eccezionii
Protected method | OnAppearance_Changed | (Inherited from XtraUserControl.)
Protected method | OnBackColorChanged | (Inherited from XtraUserControl.)
Protected method | OnControlAdded | (Inherited from XtraUserControl.)
Protected method | OnControlRemoved | (Inherited from XtraUserControl.)
Protected method | OnFirstLoad | (Inherited from XtraUserControl.)
Protected method | OnForeColorChanged | (Inherited from XtraUserControl.)
Protected method | OnInitPrtFastCtxMenuItemClick | Lancia l'evento InitPrtFastCtxMenuItemClick.
Protected method | OnInitPrtFastSelectionChanged |
Protected method | OnInitPrtFastSelectionConfirmed |
Protected method | OnLoad | (Inherited from XtraUserControl.)
Protected method | OnPaint | (Inherited from XtraUserControl.)
Protected method | OnParentChanged | (Inherited from XtraUserControl.)
Public method | ResetBackColor | (Inherited from XtraUserControl.)
Public method | ResetForeColor | (Inherited from XtraUserControl.)
Public method | SaveRegistrySettings | Salva nel registro le impostazioni della griglia.
Public method | SetDataSources | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
 | SetValuesInSubKeyUpdatingPosition | Aggiunge l'elemento specificato alla lista presente nella chiave di registro. Se l'elemento è già presente, viene spostato in ultima posizione (la più recente).
Public method | StopThread | Funzione per bloccate l'esecuzione del thread.
Protected method | WndProc | (Inherited from XtraUserControl.)

Properties

 | Name | Description
Public property | Appearance | (Inherited from XtraUserControl.)
Public property | BackColor | (Inherited from XtraUserControl.)
Protected property | DefaultAppearance | (Inherited from XtraUserControl.)
Public property | DefaultDataSource |
Public property | EnableIXtraResizeableControlInterfaceProxy | (Inherited from XtraUserControl.)
Public property | Font | (Inherited from XtraUserControl.)
Public property | ForeColor | (Inherited from XtraUserControl.)
Protected property | Helper | (Inherited from XtraUserControl.)
Public property | InitPrtFastMenuCommandList | Lista dei comandi custom del menu constestuale.
Public property | LookAndFeel | (Inherited from XtraUserControl.)
Protected property | Painter | (Inherited from XtraUserControl.)
Public property | SelectedConnection |
Public property | SelectedRows |
Public property | Site | (Inherited from XtraUserControl.)

Events

 | Name | Description
Public event | InitPrtFastCtxMenuItemClick | Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.
Public event | SelectionChanged | Evento su modifica della selezione.
Public event | SelectionConfirmed |

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#Changed | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#Control | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#IsCaptionVisible | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#MaxSize | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#MinSize | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Inherited from XtraUserControl.)

See Also

InitPrtFast Class
InitPrtFast Namespace


InitPrtFast Constructor

[image]

Libreria query DedNet
InitPrtFast Constructor
InitPrtFast Class See Also Send Feedback
Costruttore unico.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast()
Visual Basic
Public Sub New
Visual C++
public:
InitPrtFast()

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


InitPrtFast Methods

[image] [image]

Libreria query DedNet
InitPrtFast Methods
InitPrtFast Class See Also Send Feedback

The InitPrtFast type exposes the following members.

Methods

 | Name | Description
Public method | AllowDragAndDrop |
Protected method | CreateDefaultAppearance | (Inherited from XtraUserControl.)
Protected method | CreatePainter | (Inherited from XtraUserControl.)
Protected method | Dispose | Liberare le risorse in uso. (Overrides XtraUserControlDispose(Boolean).)
Protected method | GetBackColor | (Inherited from XtraUserControl.)
Protected method | GetInnerIXtraResizableControl | (Inherited from XtraUserControl.)
Protected method | GetService | (Inherited from XtraUserControl.)
Public method | InizializeInitPrtFast | Chiama la funzione InizializeInitPrt definita nei lua comuni.
 | Log | Utilità di logging delle Eccezionii
Protected method | OnAppearance_Changed | (Inherited from XtraUserControl.)
Protected method | OnBackColorChanged | (Inherited from XtraUserControl.)
Protected method | OnControlAdded | (Inherited from XtraUserControl.)
Protected method | OnControlRemoved | (Inherited from XtraUserControl.)
Protected method | OnFirstLoad | (Inherited from XtraUserControl.)
Protected method | OnForeColorChanged | (Inherited from XtraUserControl.)
Protected method | OnInitPrtFastCtxMenuItemClick | Lancia l'evento InitPrtFastCtxMenuItemClick.
Protected method | OnInitPrtFastSelectionChanged |
Protected method | OnInitPrtFastSelectionConfirmed |
Protected method | OnLoad | (Inherited from XtraUserControl.)
Protected method | OnPaint | (Inherited from XtraUserControl.)
Protected method | OnParentChanged | (Inherited from XtraUserControl.)
Public method | ResetBackColor | (Inherited from XtraUserControl.)
Public method | ResetForeColor | (Inherited from XtraUserControl.)
Public method | SaveRegistrySettings | Salva nel registro le impostazioni della griglia.
Public method | SetDataSources | Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.
 | SetValuesInSubKeyUpdatingPosition | Aggiunge l'elemento specificato alla lista presente nella chiave di registro. Se l'elemento è già presente, viene spostato in ultima posizione (la più recente).
Public method | StopThread | Funzione per bloccate l'esecuzione del thread.
Protected method | WndProc | (Inherited from XtraUserControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Inherited from XtraUserControl.)

See Also

InitPrtFast Class
InitPrtFast Namespace


AllowDragAndDrop Method

[image]

Libreria query DedNet
InitPrtFast..::..AllowDragAndDrop Method
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "M:InitPrtFast.InitPrtFast.AllowDragAndDrop(System.Boolean)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AllowDragAndDrop(
    bool allowDrop
)
Visual Basic
Public Sub AllowDragAndDrop ( _
    allowDrop As Boolean _
)
Visual C++
public:
void AllowDragAndDrop(
    bool allowDrop
)

Parameters

allowDrop
Type: System..::..Boolean

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


Dispose Method

[image]

Libreria query DedNet
InitPrtFast..::..Dispose Method
InitPrtFast Class See Also Send Feedback
Liberare le risorse in uso.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


InizializeInitPrtFast Method

[image]

Libreria query DedNet
InitPrtFast..::..InizializeInitPrtFast Method
InitPrtFast Class See Also Send Feedback
Chiama la funzione InizializeInitPrt definita nei lua comuni.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InizializeInitPrtFast(
    string caller
)
Visual Basic
Public Sub InizializeInitPrtFast ( _
    caller As String _
)
Visual C++
public:
void InizializeInitPrtFast(
    String^ caller
)

Parameters

caller
Type: System..::..String

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


Log Method

[image]

Libreria query DedNet
InitPrtFast..::..Log Method
InitPrtFast Class See Also Send Feedback
Utilità di logging delle Eccezionii

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Log(
    Exception ex
)
Visual Basic
Public Shared Sub Log ( _
    ex As Exception _
)
Visual C++
public:
static void Log(
    Exception^ ex
)

Parameters

ex
Type: System..::..Exception

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


OnInitPrtFastCtxMenuItemClick Method

[image]

Libreria query DedNet
InitPrtFast..::..OnInitPrtFastCtxMenuItemClick Method
InitPrtFast Class See Also Send Feedback
Lancia l'evento InitPrtFastCtxMenuItemClick.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal void OnInitPrtFastCtxMenuItemClick(
    Object sender,
    InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs e
)
Visual Basic
Protected Friend Sub OnInitPrtFastCtxMenuItemClick ( _
    sender As Object, _
    e As InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs _
)
Visual C++
protected public:
void OnInitPrtFastCtxMenuItemClick(
    Object^ sender,
    InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: InitPrtFast..::..InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


OnInitPrtFastSelectionChanged Method

[image]

Libreria query DedNet
InitPrtFast..::..OnInitPrtFastSelectionChanged Method
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "M:InitPrtFast.InitPrtFast.OnInitPrtFastSelectionChanged(System.Object,InitPrtFast.InitPrtFast.PrtInitSelectionEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnInitPrtFastSelectionChanged(
    Object sender,
    InitPrtFast..::..PrtInitSelectionEventArgs ev
)
Visual Basic
Protected Sub OnInitPrtFastSelectionChanged ( _
    sender As Object, _
    ev As InitPrtFast..::..PrtInitSelectionEventArgs _
)
Visual C++
protected:
void OnInitPrtFastSelectionChanged(
    Object^ sender,
    InitPrtFast..::..PrtInitSelectionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
ev
Type: InitPrtFast..::..InitPrtFast..::..PrtInitSelectionEventArgs

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


OnInitPrtFastSelectionConfirmed Method

[image]

Libreria query DedNet
InitPrtFast..::..OnInitPrtFastSelectionConfirmed Method
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "M:InitPrtFast.InitPrtFast.OnInitPrtFastSelectionConfirmed(System.Object,InitPrtFast.InitPrtFast.PrtInitSelectionEventArgs)"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnInitPrtFastSelectionConfirmed(
    Object sender,
    InitPrtFast..::..PrtInitSelectionEventArgs ev
)
Visual Basic
Protected Sub OnInitPrtFastSelectionConfirmed ( _
    sender As Object, _
    ev As InitPrtFast..::..PrtInitSelectionEventArgs _
)
Visual C++
protected:
void OnInitPrtFastSelectionConfirmed(
    Object^ sender,
    InitPrtFast..::..PrtInitSelectionEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
ev
Type: InitPrtFast..::..InitPrtFast..::..PrtInitSelectionEventArgs

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SaveRegistrySettings Method

[image]

Libreria query DedNet
InitPrtFast..::..SaveRegistrySettings Method
InitPrtFast Class See Also Send Feedback
Salva nel registro le impostazioni della griglia.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveRegistrySettings()
Visual Basic
Public Sub SaveRegistrySettings
Visual C++
public:
void SaveRegistrySettings()

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SetDataSources Method

[image]

Libreria query DedNet
InitPrtFast..::..SetDataSources Method
InitPrtFast Class See Also Send Feedback
Permette di impostare le sorgenti dati ed eventualmente seleziona la connessione di defualt.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDataSources(
    List<ConnBase> sources
)
Visual Basic
Public Sub SetDataSources ( _
    sources As List(Of ConnBase) _
)
Visual C++
public:
void SetDataSources(
    List<ConnBase^>^ sources
)

Parameters

sources
Type: System.Collections.Generic..::..List <(Of <(<' ConnBase >)>)>

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SetValuesInSubKeyUpdatingPosition Method

[image]

Libreria query DedNet
InitPrtFast..::..SetValuesInSubKeyUpdatingPosition Method
InitPrtFast Class See Also Send Feedback
Aggiunge l'elemento specificato alla lista presente nella chiave di registro. Se l'elemento è già presente, viene spostato in ultima posizione (la più recente).

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetValuesInSubKeyUpdatingPosition(
    string regKey,
    string nameRegKey,
    string valToAdd,
    char separator,
    int max
)
Visual Basic
Public Shared Sub SetValuesInSubKeyUpdatingPosition ( _
    regKey As String, _
    nameRegKey As String, _
    valToAdd As String, _
    separator As Char, _
    max As Integer _
)
Visual C++
public:
static void SetValuesInSubKeyUpdatingPosition(
    String^ regKey,
    String^ nameRegKey,
    String^ valToAdd,
    wchar_t separator,
    int max
)

Parameters

regKey
Type: System..::..String
Path della chaive di registro.
nameRegKey
Type: System..::..String
Nome della chiave di registro.
valToAdd
Type: System..::..String
Valore da aggiungere.
separator
Type: System..::..Char
Separatore.
max
Type: System..::..Int32
Numero massimo di elementi.

Return Value

True: operazione terminata senza errori; False: Operazione terminata con errori.

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


StopThread Method

[image]

Libreria query DedNet
InitPrtFast..::..StopThread Method
InitPrtFast Class See Also Send Feedback
Funzione per bloccate l'esecuzione del thread.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void StopThread()
Visual Basic
Public Sub StopThread
Visual C++
public:
void StopThread()

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


InitPrtFast Properties

[image] [image]

Libreria query DedNet
InitPrtFast Properties
InitPrtFast Class See Also Send Feedback

The InitPrtFast type exposes the following members.

Properties

 | Name | Description
Public property | Appearance | (Inherited from XtraUserControl.)
Public property | BackColor | (Inherited from XtraUserControl.)
Protected property | DefaultAppearance | (Inherited from XtraUserControl.)
Public property | DefaultDataSource |
Public property | EnableIXtraResizeableControlInterfaceProxy | (Inherited from XtraUserControl.)
Public property | Font | (Inherited from XtraUserControl.)
Public property | ForeColor | (Inherited from XtraUserControl.)
Protected property | Helper | (Inherited from XtraUserControl.)
Public property | InitPrtFastMenuCommandList | Lista dei comandi custom del menu constestuale.
Public property | LookAndFeel | (Inherited from XtraUserControl.)
Protected property | Painter | (Inherited from XtraUserControl.)
Public property | SelectedConnection |
Public property | SelectedRows |
Public property | Site | (Inherited from XtraUserControl.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#Control | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#IsCaptionVisible | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#MaxSize | (Inherited from XtraUserControl.)
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#MinSize | (Inherited from XtraUserControl.)

See Also

InitPrtFast Class
InitPrtFast Namespace


DefaultDataSource Property

[image]

Libreria query DedNet
InitPrtFast..::..DefaultDataSource Property
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.DefaultDataSource"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DefaultDataSource { get; set; }
Visual Basic
Public Property DefaultDataSource As String
    Get
    Set
Visual C++
public:
property String^ DefaultDataSource {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


InitPrtFastMenuCommandList Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastMenuCommandList Property
InitPrtFast Class See Also Send Feedback
Lista dei comandi custom del menu constestuale.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast..::..InitPrtFastCtxMenuCommandList InitPrtFastMenuCommandList { get; }
Visual Basic
Public ReadOnly Property InitPrtFastMenuCommandList As InitPrtFast..::..InitPrtFastCtxMenuCommandList
    Get
Visual C++
public:
property InitPrtFast..::..InitPrtFastCtxMenuCommandList^ InitPrtFastMenuCommandList {
    InitPrtFast..::..InitPrtFastCtxMenuCommandList^ get ();
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SelectedConnection Property

[image]

Libreria query DedNet
InitPrtFast..::..SelectedConnection Property
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.SelectedConnection"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnBase SelectedConnection { get; }
Visual Basic
Public ReadOnly Property SelectedConnection As ConnBase
    Get
Visual C++
public:
property ConnBase^ SelectedConnection {
    ConnBase^ get ();
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SelectedRows Property

[image]

Libreria query DedNet
InitPrtFast..::..SelectedRows Property
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.SelectedRows"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast..::..Rows SelectedRows { get; set; }
Visual Basic
Public Property SelectedRows As InitPrtFast..::..Rows
    Get
    Set
Visual C++
public:
property InitPrtFast..::..Rows^ SelectedRows {
    InitPrtFast..::..Rows^ get ();
    void set (InitPrtFast..::..Rows^ value);
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


InitPrtFast Events

[image] [image]

Libreria query DedNet
InitPrtFast Events
InitPrtFast Class See Also Send Feedback

The InitPrtFast type exposes the following members.

Events

 | Name | Description
Public event | InitPrtFastCtxMenuItemClick | Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.
Public event | SelectionChanged | Evento su modifica della selezione.
Public event | SelectionConfirmed |

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#Utils#Controls#IXtraResizableControl#Changed | (Inherited from XtraUserControl.)

See Also

InitPrtFast Class
InitPrtFast Namespace


InitPrtFastCtxMenuItemClick Event

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClick Event
InitPrtFast Class See Also Send Feedback
Evento chiamato alla pressione dei pulsanti personalizzati sul menu contestuale.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs> InitPrtFastCtxMenuItemClick
Visual Basic
Public Event InitPrtFastCtxMenuItemClick As EventHandler(Of InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs)
Visual C++
public:
 event EventHandler<InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs^>^ InitPrtFastCtxMenuItemClick {
    void add (EventHandler<InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs^>^ value);
    void remove (EventHandler<InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs^>^ value);
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SelectionChanged Event

[image]

Libreria query DedNet
InitPrtFast..::..SelectionChanged Event
InitPrtFast Class See Also Send Feedback
Evento su modifica della selezione.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs> SelectionChanged
Visual Basic
Public Event SelectionChanged As EventHandler(Of InitPrtFast..::..PrtInitSelectionEventArgs)
Visual C++
public:
 event EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs^>^ SelectionChanged {
    void add (EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs^>^ value);
    void remove (EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs^>^ value);
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


SelectionConfirmed Event

[image]

Libreria query DedNet
InitPrtFast..::..SelectionConfirmed Event
InitPrtFast Class See Also Send Feedback

[Missing <summary> documentation for "E:InitPrtFast.InitPrtFast.SelectionConfirmed"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs> SelectionConfirmed
Visual Basic
Public Event SelectionConfirmed As EventHandler(Of InitPrtFast..::..PrtInitSelectionEventArgs)
Visual C++
public:
 event EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs^>^ SelectionConfirmed {
    void add (EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs^>^ value);
    void remove (EventHandler<InitPrtFast..::..PrtInitSelectionEventArgs^>^ value);
}

See Also

InitPrtFast Class
InitPrtFast Members
InitPrtFast Namespace


InitPrtFast.Element Class

[image]

Libreria query DedNet
InitPrtFast..::..Element Class
InitPrtFast Class Members See Also Send Feedback
Classe che rappreseneta l'oggetto cella.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Element
Visual Basic
Public Class Element
Visual C++
public ref class Element

Inheritance Hierarchy

System..::..Object
InitPrtFast..::..InitPrtFast..::..Element

See Also

InitPrtFast..::..Element Members
InitPrtFast Namespace


InitPrtFast.Element Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..Element Members
InitPrtFast..::..Element Class Constructors Properties See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..Element type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..Element | Initializes a new instance of the InitPrtFast..::..Element class

Properties

 | Name | Description
Public property | DedLink |
Public property | Field |
Public property | Value |

See Also

InitPrtFast..::..Element Class
InitPrtFast Namespace


InitPrtFast.Element Constructor

[image]

Libreria query DedNet
InitPrtFast..::..Element Constructor
InitPrtFast..::..Element Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..Element class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Element(
    string field,
    string dedlink,
    Object value
)
Visual Basic
Public Sub New ( _
    field As String, _
    dedlink As String, _
    value As Object _
)
Visual C++
public:
Element(
    String^ field,
    String^ dedlink,
    Object^ value
)

Parameters

field
Type: System..::..String
dedlink
Type: System..::..String
value
Type: System..::..Object

See Also

InitPrtFast..::..Element Class
InitPrtFast..::..Element Members
InitPrtFast Namespace


InitPrtFast.Element Properties

[image] [image]

Libreria query DedNet
InitPrtFast..::..Element Properties
InitPrtFast..::..Element Class See Also Send Feedback

The InitPrtFast..::..Element type exposes the following members.

Properties

 | Name | Description
Public property | DedLink |
Public property | Field |
Public property | Value |

See Also

InitPrtFast..::..Element Class
InitPrtFast Namespace


DedLink Property

[image]

Libreria query DedNet
InitPrtFast..::..Element..::..DedLink Property
InitPrtFast..::..Element Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.Element.DedLink"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DedLink { get; set; }
Visual Basic
Public Property DedLink As String
    Get
    Set
Visual C++
public:
property String^ DedLink {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast..::..Element Class
InitPrtFast..::..Element Members
InitPrtFast Namespace


Field Property

[image]

Libreria query DedNet
InitPrtFast..::..Element..::..Field Property
InitPrtFast..::..Element Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.Element.Field"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Field { get; set; }
Visual Basic
Public Property Field As String
    Get
    Set
Visual C++
public:
property String^ Field {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast..::..Element Class
InitPrtFast..::..Element Members
InitPrtFast Namespace


Value Property

[image]

Libreria query DedNet
InitPrtFast..::..Element..::..Value Property
InitPrtFast..::..Element Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.Element.Value"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

InitPrtFast..::..Element Class
InitPrtFast..::..Element Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommand Class

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast Class Members See Also Send Feedback
Classe per gestire i comandi personalizzati sul tasto dx.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InitPrtFastCtxMenuCommand
Visual Basic
Public Class InitPrtFastCtxMenuCommand
Visual C++
public ref class InitPrtFastCtxMenuCommand

Inheritance Hierarchy

System..::..Object
InitPrtFast..::..InitPrtFast..::..InitPrtFastCtxMenuCommand

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommand Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast..::..InitPrtFastCtxMenuCommand Class Constructors Properties See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..InitPrtFastCtxMenuCommand type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..InitPrtFastCtxMenuCommand | Initializes a new instance of the InitPrtFast..::..InitPrtFastCtxMenuCommand class

Properties

 | Name | Description
Public property | BeginGroup |
Public property | ImagePath |
Public property | Name |
Public property | Prompt |
Public property | SelectionVisibility |
Public property | ToolStripItem |
Public property | Tooltip |

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommand Constructor

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand Constructor
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..InitPrtFastCtxMenuCommand class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFastCtxMenuCommand(
    string name,
    string prompt,
    string tooltip,
    string imagePath,
    bool beginGroup,
    InitPrtFast..::..SelectionVisibility selectionVisibility
)
Visual Basic
Public Sub New ( _
    name As String, _
    prompt As String, _
    tooltip As String, _
    imagePath As String, _
    beginGroup As Boolean, _
    selectionVisibility As InitPrtFast..::..SelectionVisibility _
)
Visual C++
public:
InitPrtFastCtxMenuCommand(
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath,
    bool beginGroup,
    InitPrtFast..::..SelectionVisibility selectionVisibility
)

Parameters

name
Type: System..::..String
prompt
Type: System..::..String
tooltip
Type: System..::..String
imagePath
Type: System..::..String
beginGroup
Type: System..::..Boolean
selectionVisibility
Type: InitPrtFast..::..InitPrtFast..::..SelectionVisibility

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommand Properties

[image] [image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand Properties
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

The InitPrtFast..::..InitPrtFastCtxMenuCommand type exposes the following members.

Properties

 | Name | Description
Public property | BeginGroup |
Public property | ImagePath |
Public property | Name |
Public property | Prompt |
Public property | SelectionVisibility |
Public property | ToolStripItem |
Public property | Tooltip |

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast Namespace


BeginGroup Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..BeginGroup Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.BeginGroup"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BeginGroup { get; set; }
Visual Basic
Public Property BeginGroup As Boolean
    Get
    Set
Visual C++
public:
property bool BeginGroup {
    bool get ();
    void set (bool value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


ImagePath Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..ImagePath Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.ImagePath"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ImagePath { get; set; }
Visual Basic
Public Property ImagePath As String
    Get
    Set
Visual C++
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


Name Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..Name Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Name"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


Prompt Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..Prompt Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Prompt"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Prompt { get; set; }
Visual Basic
Public Property Prompt As String
    Get
    Set
Visual C++
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


SelectionVisibility Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..SelectionVisibility Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.SelectionVisibility"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast..::..SelectionVisibility SelectionVisibility { get; set; }
Visual Basic
Public Property SelectionVisibility As InitPrtFast..::..SelectionVisibility
    Get
    Set
Visual C++
public:
property InitPrtFast..::..SelectionVisibility SelectionVisibility {
    InitPrtFast..::..SelectionVisibility get ();
    void set (InitPrtFast..::..SelectionVisibility value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


ToolStripItem Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..ToolStripItem Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.ToolStripItem"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BarItem ToolStripItem { get; }
Visual Basic
Public ReadOnly Property ToolStripItem As BarItem
    Get
Visual C++
public:
property BarItem^ ToolStripItem {
    BarItem^ get ();
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


Tooltip Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommand..::..Tooltip Property
InitPrtFast..::..InitPrtFastCtxMenuCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.InitPrtFast.InitPrtFastCtxMenuCommand.Tooltip"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Tooltip { get; set; }
Visual Basic
Public Property Tooltip As String
    Get
    Set
Visual C++
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommand Class
InitPrtFast..::..InitPrtFastCtxMenuCommand Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommandList Class

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommandList Class
InitPrtFast Class Members See Also Send Feedback
Lista di oggetti InitPrtFastCtxMenuCommand.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InitPrtFastCtxMenuCommandList : List<InitPrtFast..::..InitPrtFastCtxMenuCommand>
Visual Basic
Public Class InitPrtFastCtxMenuCommandList _
    Inherits List(Of InitPrtFast..::..InitPrtFastCtxMenuCommand)
Visual C++
public ref class InitPrtFastCtxMenuCommandList : public List<InitPrtFast..::..InitPrtFastCtxMenuCommand^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' InitPrtFast..::..InitPrtFastCtxMenuCommand >)>)>
InitPrtFast..::..InitPrtFast..::..InitPrtFastCtxMenuCommandList

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommandList Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommandList Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommandList Members
InitPrtFast..::..InitPrtFastCtxMenuCommandList Class Constructors See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..InitPrtFastCtxMenuCommandList type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..InitPrtFastCtxMenuCommandList | Initializes a new instance of the InitPrtFast..::..InitPrtFastCtxMenuCommandList class

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommandList Class
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuCommandList Constructor

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuCommandList Constructor
InitPrtFast..::..InitPrtFastCtxMenuCommandList Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..InitPrtFastCtxMenuCommandList class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFastCtxMenuCommandList()
Visual Basic
Public Sub New
Visual C++
public:
InitPrtFastCtxMenuCommandList()

See Also

InitPrtFast..::..InitPrtFastCtxMenuCommandList Class
InitPrtFast..::..InitPrtFastCtxMenuCommandList Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs Class

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast Class Members See Also Send Feedback
Argomento utilizzato durante il click su un menu constestuale personalizzato.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InitPrtFastCtxMenuItemClickEventArgs : EventArgs
Visual Basic
Public Class InitPrtFastCtxMenuItemClickEventArgs _
    Inherits EventArgs
Visual C++
public ref class InitPrtFastCtxMenuItemClickEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
InitPrtFast..::..InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class Constructors Properties See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs | Initializes a new instance of the InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs class

Properties

 | Name | Description
Public property | CtrlGrid | Restituisce il controllo griglia.
Public property | CtrlInitPrtFast | Restituisce il controllo InitPrtFast
Public property | ItemClicked | Restuisce l'elemento cliccato.
Public property | MainForm | Form che contiente il controllo.
Public property | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Public property | SelectedConnection | Restiruisce la connessione selezionata
Public property | SelectedRows | Restituisce le righe selezionate.

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs Constructor

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Constructor
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFastCtxMenuItemClickEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
InitPrtFastCtxMenuItemClickEventArgs()

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


InitPrtFast.InitPrtFastCtxMenuItemClickEventArgs Properties

[image] [image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Properties
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback

The InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CtrlGrid | Restituisce il controllo griglia.
Public property | CtrlInitPrtFast | Restituisce il controllo InitPrtFast
Public property | ItemClicked | Restuisce l'elemento cliccato.
Public property | MainForm | Form che contiente il controllo.
Public property | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Public property | SelectedConnection | Restiruisce la connessione selezionata
Public property | SelectedRows | Restituisce le righe selezionate.

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast Namespace


CtrlGrid Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..CtrlGrid Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Restituisce il controllo griglia.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridControl CtrlGrid { get; internal set; }
Visual Basic
Public Property CtrlGrid As GridControl
    Get
    Friend Set
Visual C++
public:
property GridControl^ CtrlGrid {
    GridControl^ get ();
    internal: void set (GridControl^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


CtrlInitPrtFast Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..CtrlInitPrtFast Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Restituisce il controllo InitPrtFast

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast CtrlInitPrtFast { get; set; }
Visual Basic
Public Property CtrlInitPrtFast As InitPrtFast
    Get
    Set
Visual C++
public:
property InitPrtFast^ CtrlInitPrtFast {
    InitPrtFast^ get ();
    void set (InitPrtFast^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


ItemClicked Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..ItemClicked Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Restuisce l'elemento cliccato.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BarButtonItem ItemClicked { get; internal set; }
Visual Basic
Public Property ItemClicked As BarButtonItem
    Get
    Friend Set
Visual C++
public:
property BarButtonItem^ ItemClicked {
    BarButtonItem^ get ();
    internal: void set (BarButtonItem^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


MainForm Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..MainForm Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Form che contiente il controllo.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Form MainForm { get; set; }
Visual Basic
Public Property MainForm As Form
    Get
    Set
Visual C++
public:
property Form^ MainForm {
    Form^ get ();
    void set (Form^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


NeedRefresh Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..NeedRefresh Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Indica se è necessario un refresh dopo il comando.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool NeedRefresh { get; set; }
Visual Basic
Public Property NeedRefresh As Boolean
    Get
    Set
Visual C++
public:
property bool NeedRefresh {
    bool get ();
    void set (bool value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


SelectedConnection Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..SelectedConnection Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Restiruisce la connessione selezionata

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnBase SelectedConnection { get; internal set; }
Visual Basic
Public Property SelectedConnection As ConnBase
    Get
    Friend Set
Visual C++
public:
property ConnBase^ SelectedConnection {
    ConnBase^ get ();
    internal: void set (ConnBase^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


SelectedRows Property

[image]

Libreria query DedNet
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs..::..SelectedRows Property
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class See Also Send Feedback
Restituisce le righe selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast..::..Rows SelectedRows { get; internal set; }
Visual Basic
Public Property SelectedRows As InitPrtFast..::..Rows
    Get
    Friend Set
Visual C++
public:
property InitPrtFast..::..Rows^ SelectedRows {
    InitPrtFast..::..Rows^ get ();
    internal: void set (InitPrtFast..::..Rows^ value);
}

See Also

InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Class
InitPrtFast..::..InitPrtFastCtxMenuItemClickEventArgs Members
InitPrtFast Namespace


InitPrtFast.PrtInitSelectionEventArgs Class

[image]

Libreria query DedNet
InitPrtFast..::..PrtInitSelectionEventArgs Class
InitPrtFast Class Members See Also Send Feedback
Classe contenente le informazioni per l'evento SelectionChanged.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PrtInitSelectionEventArgs : EventArgs
Visual Basic
Public Class PrtInitSelectionEventArgs _
    Inherits EventArgs
Visual C++
public ref class PrtInitSelectionEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
InitPrtFast..::..InitPrtFast..::..PrtInitSelectionEventArgs

See Also

InitPrtFast..::..PrtInitSelectionEventArgs Members
InitPrtFast Namespace


InitPrtFast.PrtInitSelectionEventArgs Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..PrtInitSelectionEventArgs Members
InitPrtFast..::..PrtInitSelectionEventArgs Class Constructors Properties See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..PrtInitSelectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..PrtInitSelectionEventArgs | Initializes a new instance of the InitPrtFast..::..PrtInitSelectionEventArgs class

Properties

 | Name | Description
Public property | Rows | Lista delle righe selezionate.

See Also

InitPrtFast..::..PrtInitSelectionEventArgs Class
InitPrtFast Namespace


InitPrtFast.PrtInitSelectionEventArgs Constructor

[image]

Libreria query DedNet
InitPrtFast..::..PrtInitSelectionEventArgs Constructor
InitPrtFast..::..PrtInitSelectionEventArgs Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..PrtInitSelectionEventArgs class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PrtInitSelectionEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
PrtInitSelectionEventArgs()

See Also

InitPrtFast..::..PrtInitSelectionEventArgs Class
InitPrtFast..::..PrtInitSelectionEventArgs Members
InitPrtFast Namespace


InitPrtFast.PrtInitSelectionEventArgs Properties

[image] [image]

Libreria query DedNet
InitPrtFast..::..PrtInitSelectionEventArgs Properties
InitPrtFast..::..PrtInitSelectionEventArgs Class See Also Send Feedback

The InitPrtFast..::..PrtInitSelectionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Rows | Lista delle righe selezionate.

See Also

InitPrtFast..::..PrtInitSelectionEventArgs Class
InitPrtFast Namespace


Rows Property

[image]

Libreria query DedNet
InitPrtFast..::..PrtInitSelectionEventArgs..::..Rows Property
InitPrtFast..::..PrtInitSelectionEventArgs Class See Also Send Feedback
Lista delle righe selezionate.

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast..::..Rows Rows { get; internal set; }
Visual Basic
Public Property Rows As InitPrtFast..::..Rows
    Get
    Friend Set
Visual C++
public:
property InitPrtFast..::..Rows^ Rows {
    InitPrtFast..::..Rows^ get ();
    internal: void set (InitPrtFast..::..Rows^ value);
}

See Also

InitPrtFast..::..PrtInitSelectionEventArgs Class
InitPrtFast..::..PrtInitSelectionEventArgs Members
InitPrtFast Namespace


InitPrtFast.Row Class

[image]

Libreria query DedNet
InitPrtFast..::..Row Class
InitPrtFast Class Members See Also Send Feedback

[Missing <summary> documentation for "T:InitPrtFast.InitPrtFast.Row"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Row : List<InitPrtFast..::..Element>
Visual Basic
Public Class Row _
    Inherits List(Of InitPrtFast..::..Element)
Visual C++
public ref class Row : public List<InitPrtFast..::..Element^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' InitPrtFast..::..Element >)>)>
InitPrtFast..::..InitPrtFast..::..Row

See Also

InitPrtFast..::..Row Members
InitPrtFast Namespace


InitPrtFast.Row Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..Row Members
InitPrtFast..::..Row Class Constructors See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..Row type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..Row | Initializes a new instance of the InitPrtFast..::..Row class

See Also

InitPrtFast..::..Row Class
InitPrtFast Namespace


InitPrtFast.Row Constructor

[image]

Libreria query DedNet
InitPrtFast..::..Row Constructor
InitPrtFast..::..Row Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..Row class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Row()
Visual Basic
Public Sub New
Visual C++
public:
Row()

See Also

InitPrtFast..::..Row Class
InitPrtFast..::..Row Members
InitPrtFast Namespace


InitPrtFast.Rows Class

[image]

Libreria query DedNet
InitPrtFast..::..Rows Class
InitPrtFast Class Members See Also Send Feedback

[Missing <summary> documentation for "T:InitPrtFast.InitPrtFast.Rows"]

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Rows : List<InitPrtFast..::..Row>
Visual Basic
Public Class Rows _
    Inherits List(Of InitPrtFast..::..Row)
Visual C++
public ref class Rows : public List<InitPrtFast..::..Row^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' InitPrtFast..::..Row >)>)>
InitPrtFast..::..InitPrtFast..::..Rows

See Also

InitPrtFast..::..Rows Members
InitPrtFast Namespace


InitPrtFast.Rows Members

[image] [image]

Libreria query DedNet
InitPrtFast..::..Rows Members
InitPrtFast..::..Rows Class Constructors See Also Send Feedback

Classe che permette di ricercare all'interno di una qualsiasi fonte dati : DB o FILE. Impostare le fonte dati tramite il metodo SetDataSources.

The InitPrtFast..::..Rows type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFast..::..Rows | Initializes a new instance of the InitPrtFast..::..Rows class

See Also

InitPrtFast..::..Rows Class
InitPrtFast Namespace


InitPrtFast.Rows Constructor

[image]

Libreria query DedNet
InitPrtFast..::..Rows Constructor
InitPrtFast..::..Rows Class See Also Send Feedback
Initializes a new instance of the InitPrtFast..::..Rows class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Rows()
Visual Basic
Public Sub New
Visual C++
public:
Rows()

See Also

InitPrtFast..::..Rows Class
InitPrtFast..::..Rows Members
InitPrtFast Namespace


InitPrtFast.SelectionVisibility Enumeration

[image]

Libreria query DedNet
InitPrtFast..::..SelectionVisibility Enumeration
InitPrtFast Class See Also Send Feedback
Definizione possibili azioni su oggetti importazione

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum SelectionVisibility
Visual Basic
Public Enumeration SelectionVisibility
Visual C++
public enum class SelectionVisibility

Members

Member name | Description
Single |
Multiple |
SingleAndMultiple |
None |
Always |

See Also

InitPrtFast Namespace


QsResources Class

[image]

Libreria query DedNet
QsResources Class
Members See Also Send Feedback
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class QsResources : ResourceManager
Visual Basic
Public Class QsResources _
    Inherits ResourceManager
Visual C++
public ref class QsResources : public ResourceManager

Inheritance Hierarchy

System..::..Object
System.Resources..::..ResourceManager
InitPrtFast..::..QsResources

See Also

QsResources Members
InitPrtFast Namespace


QsResources Members

[image] [image]

Libreria query DedNet
QsResources Members
QsResources Class Constructors Methods See Also Send Feedback

The QsResources type exposes the following members.

Constructors

 | Name | Description
Public method | QsResources | Initializes a new instance of the QsResources class

Methods

 | Name | Description
Public method | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Overrides ResourceManager..::..GetString(String).)
Public method | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Overrides ResourceManager..::..GetString(String, CultureInfo).)

See Also

QsResources Class
InitPrtFast Namespace


QsResources Constructor

[image]

Libreria query DedNet
QsResources Constructor
QsResources Class See Also Send Feedback
Initializes a new instance of the QsResources class

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public QsResources(
    string s,
    Assembly a
)
Visual Basic
Public Sub New ( _
    s As String, _
    a As Assembly _
)
Visual C++
public:
QsResources(
    String^ s,
    Assembly^ a
)

Parameters

s
Type: System..::..String
a
Type: System.Reflection..::..Assembly

See Also

QsResources Class
QsResources Members
InitPrtFast Namespace


QsResources Methods

[image] [image]

Libreria query DedNet
QsResources Methods
QsResources Class See Also Send Feedback

Methods

 | Name | Description
Public method | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Overrides ResourceManager..::..GetString(String).)
Public method | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Overrides ResourceManager..::..GetString(String, CultureInfo).)

See Also

QsResources Class
InitPrtFast Namespace


GetString Method

[image] [image]

Libreria query DedNet
QsResources..::..GetString Method
QsResources Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Overrides ResourceManager..::..GetString(String).)
Public method | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Overrides ResourceManager..::..GetString(String, CultureInfo).)

See Also

QsResources Class
QsResources Members
InitPrtFast Namespace


GetString Method (String)

[image]

Libreria query DedNet
QsResources..::..GetString Method (String)
QsResources Class See Also Send Feedback
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string GetString(
    string name
)
Visual Basic
Public Overrides Function GetString ( _
    name As String _
) As String
Visual C++
public:
virtual String^ GetString(
    String^ name
) override

Parameters

name
Type: System..::..String

See Also

QsResources Class
QsResources Members
GetString Overload
InitPrtFast Namespace


GetString Method (String, CultureInfo)

[image]

Libreria query DedNet
QsResources..::..GetString Method (String, CultureInfo)
QsResources Class See Also Send Feedback
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: InitPrtFast
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string GetString(
    string name,
    CultureInfo culture
)
Visual Basic
Public Overrides Function GetString ( _
    name As String, _
    culture As CultureInfo _
) As String
Visual C++
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override

Parameters

name
Type: System..::..String
culture
Type: System.Globalization..::..CultureInfo

See Also

QsResources Class
QsResources Members
GetString Overload
InitPrtFast Namespace


InitPrtFast.ConnType Namespace

[image]

Libreria query DedNet
InitPrtFast.ConnType Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConnBase | Definisce i metodi di accesso all'oggetto della connessione. Impostare i campi su cui effettuare la query tramite la proprietà FieldList.
Public class | ConnDB | Classe che rappresenta la connessione a un DB.
Public class | ConnFileFixedLenght | Classe che rappresenta la connessione a un file con elementi a spaziatura fissa.
Public class | ConnFileSeparator | Classe che rappresenta la connessione a un file con elementi separati con separatore.
Public class | Field | Classe che rappresenta un campo generico.
Public class | FieldFileFixedLenght | Classe che rappresenta un campo a lunghezza fissa.
Public class | FieldFileSeparator | Classe che rappresenta un campo con separatore.
Public class | FieldList |
Public class | SearchRule | Classe che rappresenta un singolo criterio di ricerca
Public class | SearchRules | Insieme di criteri di ricerca


ConnBase Class

[image]

Libreria query DedNet
ConnBase Class
Members See Also Send Feedback
Definisce i metodi di accesso all'oggetto della connessione. Impostare i campi su cui effettuare la query tramite la proprietà FieldList.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ConnBase
Visual Basic
Public MustInherit Class ConnBase
Visual C++
public ref class ConnBase abstract

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..ConnBase
InitPrtFast.ConnType..::..ConnDB
InitPrtFast.ConnType..::..ConnFileFixedLenght

See Also

ConnBase Members
InitPrtFast.ConnType Namespace


ConnBase Members

[image] [image]

Libreria query DedNet
ConnBase Members
ConnBase Class Constructors Methods Fields Properties See Also Send Feedback

The ConnBase type exposes the following members.

Constructors

 | Name | Description
Public method | ConnBase | Costruttore della classe base.

Methods

 | Name | Description
Public method | Run | Metodo per effettuare la query.

Fields

 | Name | Description
Protected field | _ds | Data source
Protected field | _fields | Lista dei campi.
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte
Protected field | _prompt | Prompt della connessione.

Properties

 | Name | Description
Public property | AutoComplete |
Public property | Ds |
Public property | Fields |
Public property | Posname |
Public property | Prompt |
Public property | RegistryBaseDir |
Public property | SearchOnEnter |

See Also

ConnBase Class
InitPrtFast.ConnType Namespace


ConnBase Constructor

[image]

Libreria query DedNet
ConnBase Constructor
ConnBase Class See Also Send Feedback
Costruttore della classe base.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnBase(
    string prompt
)
Visual Basic
Public Sub New ( _
    prompt As String _
)
Visual C++
public:
ConnBase(
    String^ prompt
)

Parameters

prompt
Type: System..::..String
Prompt della connessione.

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


ConnBase Fields

[image] [image]

Libreria query DedNet
ConnBase Fields
ConnBase Class See Also Send Feedback

The ConnBase type exposes the following members.

Fields

 | Name | Description
Protected field | _ds | Data source
Protected field | _fields | Lista dei campi.
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte
Protected field | _prompt | Prompt della connessione.

See Also

ConnBase Class
InitPrtFast.ConnType Namespace


_ds Field

[image]

Libreria query DedNet
ConnBase..::.._ds Field
ConnBase Class See Also Send Feedback
Data source

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Object _ds
Visual Basic
Protected _ds As Object
Visual C++
protected:
Object^ _ds

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


_fields Field

[image]

Libreria query DedNet
ConnBase..::.._fields Field
ConnBase Class See Also Send Feedback
Lista dei campi.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected FieldList _fields
Visual Basic
Protected _fields As FieldList
Visual C++
protected:
FieldList^ _fields

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


_posname Field

[image]

Libreria query DedNet
ConnBase..::.._posname Field
ConnBase Class See Also Send Feedback
Imposta/Restituice l'indice del campo che da il nome alla parte

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int _posname
Visual Basic
Protected _posname As Integer
Visual C++
protected:
int _posname

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


_prompt Field

[image]

Libreria query DedNet
ConnBase..::.._prompt Field
ConnBase Class See Also Send Feedback
Prompt della connessione.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected string _prompt
Visual Basic
Protected _prompt As String
Visual C++
protected:
String^ _prompt

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


ConnBase Methods

[image] [image]

Libreria query DedNet
ConnBase Methods
ConnBase Class See Also Send Feedback

The ConnBase type exposes the following members.

Methods

 | Name | Description
Public method | Run | Metodo per effettuare la query.

See Also

ConnBase Class
InitPrtFast.ConnType Namespace


Run Method

[image]

Libreria query DedNet
ConnBase..::..Run Method
ConnBase Class See Also Send Feedback
Metodo per effettuare la query.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void Run(
    SearchRules search
)
Visual Basic
Public MustOverride Sub Run ( _
    search As SearchRules _
)
Visual C++
public:
virtual void Run(
    SearchRules^ search
) abstract

Parameters

search
Type: InitPrtFast.ConnType..::..SearchRules
Criteri di ricerca scelti.

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


ConnBase Properties

[image] [image]

Libreria query DedNet
ConnBase Properties
ConnBase Class See Also Send Feedback

The ConnBase type exposes the following members.

Properties

 | Name | Description
Public property | AutoComplete |
Public property | Ds |
Public property | Fields |
Public property | Posname |
Public property | Prompt |
Public property | RegistryBaseDir |
Public property | SearchOnEnter |

See Also

ConnBase Class
InitPrtFast.ConnType Namespace


AutoComplete Property

[image]

Libreria query DedNet
ConnBase..::..AutoComplete Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.AutoComplete"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AutoComplete { get; set; }
Visual Basic
Public Property AutoComplete As Boolean
    Get
    Set
Visual C++
public:
property bool AutoComplete {
    bool get ();
    void set (bool value);
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


Ds Property

[image]

Libreria query DedNet
ConnBase..::..Ds Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.Ds"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Ds { get; set; }
Visual Basic
Public Property Ds As Object
    Get
    Set
Visual C++
public:
property Object^ Ds {
    Object^ get ();
    void set (Object^ value);
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


Fields Property

[image]

Libreria query DedNet
ConnBase..::..Fields Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.Fields"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FieldList Fields { get; }
Visual Basic
Public ReadOnly Property Fields As FieldList
    Get
Visual C++
public:
property FieldList^ Fields {
    FieldList^ get ();
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


Posname Property

[image]

Libreria query DedNet
ConnBase..::..Posname Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.Posname"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Posname { get; set; }
Visual Basic
Public Property Posname As Integer
    Get
    Set
Visual C++
public:
property int Posname {
    int get ();
    void set (int value);
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


Prompt Property

[image]

Libreria query DedNet
ConnBase..::..Prompt Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.Prompt"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Prompt { get; }
Visual Basic
Public ReadOnly Property Prompt As String
    Get
Visual C++
public:
property String^ Prompt {
    String^ get ();
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


RegistryBaseDir Property

[image]

Libreria query DedNet
ConnBase..::..RegistryBaseDir Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.RegistryBaseDir"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string RegistryBaseDir { get; }
Visual Basic
Public ReadOnly Property RegistryBaseDir As String
    Get
Visual C++
public:
property String^ RegistryBaseDir {
    String^ get ();
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


SearchOnEnter Property

[image]

Libreria query DedNet
ConnBase..::..SearchOnEnter Property
ConnBase Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnBase.SearchOnEnter"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SearchOnEnter { get; set; }
Visual Basic
Public Property SearchOnEnter As Boolean
    Get
    Set
Visual C++
public:
property bool SearchOnEnter {
    bool get ();
    void set (bool value);
}

See Also

ConnBase Class
ConnBase Members
InitPrtFast.ConnType Namespace


ConnDB Class

[image]

Libreria query DedNet
ConnDB Class
Members See Also Send Feedback
Classe che rappresenta la connessione a un DB.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConnDB : ConnBase
Visual Basic
Public Class ConnDB _
    Inherits ConnBase
Visual C++
public ref class ConnDB : public ConnBase

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..ConnBase
InitPrtFast.ConnType..::..ConnDB

See Also

ConnDB Members
InitPrtFast.ConnType Namespace


ConnDB Members

[image] [image]

Libreria query DedNet
ConnDB Members
ConnDB Class Constructors Methods Fields Properties See Also Send Feedback

The ConnDB type exposes the following members.

Constructors

 | Name | Description
Public method | ConnDB | Construttore.

Methods

 | Name | Description
Public method | AddWhere |
Public method | Run | Metodo per effettuare la query e riempire la DataTable. (Overrides ConnBase..::..Run(SearchRules).)

Fields

 | Name | Description
Protected field | _ds | Data source (Inherited from ConnBase.)
Protected field | _fields | Lista dei campi. (Inherited from ConnBase.)
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Inherited from ConnBase.)
Protected field | _prompt | Prompt della connessione. (Inherited from ConnBase.)

Properties

 | Name | Description
Public property | AutoComplete | (Inherited from ConnBase.)
Public property | Connection |
Public property | Ds | (Inherited from ConnBase.)
Public property | Fields | (Inherited from ConnBase.)
Public property | Posname | (Inherited from ConnBase.)
Public property | Prompt | (Inherited from ConnBase.)
Public property | RegistryBaseDir | (Inherited from ConnBase.)
Public property | SearchOnEnter | (Inherited from ConnBase.)
Public property | Table |

See Also

ConnDB Class
InitPrtFast.ConnType Namespace


ConnDB Constructor

[image]

Libreria query DedNet
ConnDB Constructor
ConnDB Class See Also Send Feedback
Construttore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnDB(
    string prompt
)
Visual Basic
Public Sub New ( _
    prompt As String _
)
Visual C++
public:
ConnDB(
    String^ prompt
)

Parameters

prompt
Type: System..::..String
Nome della connessione.

See Also

ConnDB Class
ConnDB Members
InitPrtFast.ConnType Namespace


ConnDB Fields

[image] [image]

Libreria query DedNet
ConnDB Fields
ConnDB Class See Also Send Feedback

The ConnDB type exposes the following members.

Fields

 | Name | Description
Protected field | _ds | Data source (Inherited from ConnBase.)
Protected field | _fields | Lista dei campi. (Inherited from ConnBase.)
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Inherited from ConnBase.)
Protected field | _prompt | Prompt della connessione. (Inherited from ConnBase.)

See Also

ConnDB Class
InitPrtFast.ConnType Namespace


ConnDB Methods

[image] [image]

Libreria query DedNet
ConnDB Methods
ConnDB Class See Also Send Feedback

The ConnDB type exposes the following members.

Methods

 | Name | Description
Public method | AddWhere |
Public method | Run | Metodo per effettuare la query e riempire la DataTable. (Overrides ConnBase..::..Run(SearchRules).)

See Also

ConnDB Class
InitPrtFast.ConnType Namespace


AddWhere Method

[image]

Libreria query DedNet
ConnDB..::..AddWhere Method
ConnDB Class See Also Send Feedback

[Missing <summary> documentation for "M:InitPrtFast.ConnType.ConnDB.AddWhere(System.String)"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddWhere(
    string wstr
)
Visual Basic
Public Sub AddWhere ( _
    wstr As String _
)
Visual C++
public:
void AddWhere(
    String^ wstr
)

Parameters

wstr
Type: System..::..String

See Also

ConnDB Class
ConnDB Members
InitPrtFast.ConnType Namespace


Run Method

[image]

Libreria query DedNet
ConnDB..::..Run Method
ConnDB Class See Also Send Feedback
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Run(
    SearchRules searchRules
)
Visual Basic
Public Overrides Sub Run ( _
    searchRules As SearchRules _
)
Visual C++
public:
virtual void Run(
    SearchRules^ searchRules
) override

Parameters

searchRules
Type: InitPrtFast.ConnType..::..SearchRules
Regole per eseguire la ricerca

Return Value

See Also

ConnDB Class
ConnDB Members
InitPrtFast.ConnType Namespace


ConnDB Properties

[image] [image]

Libreria query DedNet
ConnDB Properties
ConnDB Class See Also Send Feedback

The ConnDB type exposes the following members.

Properties

 | Name | Description
Public property | AutoComplete | (Inherited from ConnBase.)
Public property | Connection |
Public property | Ds | (Inherited from ConnBase.)
Public property | Fields | (Inherited from ConnBase.)
Public property | Posname | (Inherited from ConnBase.)
Public property | Prompt | (Inherited from ConnBase.)
Public property | RegistryBaseDir | (Inherited from ConnBase.)
Public property | SearchOnEnter | (Inherited from ConnBase.)
Public property | Table |

See Also

ConnDB Class
InitPrtFast.ConnType Namespace


Connection Property

[image]

Libreria query DedNet
ConnDB..::..Connection Property
ConnDB Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnDB.Connection"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public QSConnection Connection { get; set; }
Visual Basic
Public Property Connection As QSConnection
    Get
    Set
Visual C++
public:
property QSConnection^ Connection {
    QSConnection^ get ();
    void set (QSConnection^ value);
}

See Also

ConnDB Class
ConnDB Members
InitPrtFast.ConnType Namespace


Table Property

[image]

Libreria query DedNet
ConnDB..::..Table Property
ConnDB Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnDB.Table"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Table { get; set; }
Visual Basic
Public Property Table As String
    Get
    Set
Visual C++
public:
property String^ Table {
    String^ get ();
    void set (String^ value);
}

See Also

ConnDB Class
ConnDB Members
InitPrtFast.ConnType Namespace


ConnFileFixedLenght Class

[image]

Libreria query DedNet
ConnFileFixedLenght Class
Members See Also Send Feedback
Classe che rappresenta la connessione a un file con elementi a spaziatura fissa.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConnFileFixedLenght : ConnBase
Visual Basic
Public Class ConnFileFixedLenght _
    Inherits ConnBase
Visual C++
public ref class ConnFileFixedLenght : public ConnBase

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..ConnBase
InitPrtFast.ConnType..::..ConnFileFixedLenght
InitPrtFast.ConnType..::..ConnFileSeparator

See Also

ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


ConnFileFixedLenght Members

[image] [image]

Libreria query DedNet
ConnFileFixedLenght Members
ConnFileFixedLenght Class Constructors Methods Fields Properties See Also Send Feedback

The ConnFileFixedLenght type exposes the following members.

Constructors

 | Name | Description
Public method | ConnFileFixedLenght | Costruttore.

Methods

 | Name | Description
Protected method | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file.
Protected method | readLine | Legge la linea del file.
Public method | Run | Metodo per effettuare la query e riempire la DataTable. (Overrides ConnBase..::..Run(SearchRules).)

Fields

 | Name | Description
Protected field | _ds | Data source (Inherited from ConnBase.)
Protected field | _encoding | Indica il tipo di codifica del file.
Protected field | _fields | Lista dei campi. (Inherited from ConnBase.)
Protected field | _fileData | Percorso del file contenente le anagrafiche.
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Inherited from ConnBase.)
Protected field | _prompt | Prompt della connessione. (Inherited from ConnBase.)

Properties

 | Name | Description
Public property | AutoComplete | (Inherited from ConnBase.)
Public property | Ds | (Inherited from ConnBase.)
Public property | Encoding |
Public property | Fields | (Inherited from ConnBase.)
Public property | FileData |
Public property | Posname | (Inherited from ConnBase.)
Public property | Prompt | (Inherited from ConnBase.)
Public property | RegistryBaseDir | (Inherited from ConnBase.)
Public property | SearchOnEnter | (Inherited from ConnBase.)

See Also

ConnFileFixedLenght Class
InitPrtFast.ConnType Namespace


ConnFileFixedLenght Constructor

[image]

Libreria query DedNet
ConnFileFixedLenght Constructor
ConnFileFixedLenght Class See Also Send Feedback
Costruttore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnFileFixedLenght(
    string prompt
)
Visual Basic
Public Sub New ( _
    prompt As String _
)
Visual C++
public:
ConnFileFixedLenght(
    String^ prompt
)

Parameters

prompt
Type: System..::..String

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


ConnFileFixedLenght Fields

[image] [image]

Libreria query DedNet
ConnFileFixedLenght Fields
ConnFileFixedLenght Class See Also Send Feedback

The ConnFileFixedLenght type exposes the following members.

Fields

 | Name | Description
Protected field | _ds | Data source (Inherited from ConnBase.)
Protected field | _encoding | Indica il tipo di codifica del file.
Protected field | _fields | Lista dei campi. (Inherited from ConnBase.)
Protected field | _fileData | Percorso del file contenente le anagrafiche.
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Inherited from ConnBase.)
Protected field | _prompt | Prompt della connessione. (Inherited from ConnBase.)

See Also

ConnFileFixedLenght Class
InitPrtFast.ConnType Namespace


_encoding Field

[image]

Libreria query DedNet
ConnFileFixedLenght..::.._encoding Field
ConnFileFixedLenght Class See Also Send Feedback
Indica il tipo di codifica del file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Encoding _encoding
Visual Basic
Protected _encoding As Encoding
Visual C++
protected:
Encoding^ _encoding

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


_fileData Field

[image]

Libreria query DedNet
ConnFileFixedLenght..::.._fileData Field
ConnFileFixedLenght Class See Also Send Feedback
Percorso del file contenente le anagrafiche.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected string _fileData
Visual Basic
Protected _fileData As String
Visual C++
protected:
String^ _fileData

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


ConnFileFixedLenght Methods

[image] [image]

Libreria query DedNet
ConnFileFixedLenght Methods
ConnFileFixedLenght Class See Also Send Feedback

The ConnFileFixedLenght type exposes the following members.

Methods

 | Name | Description
Protected method | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file.
Protected method | readLine | Legge la linea del file.
Public method | Run | Metodo per effettuare la query e riempire la DataTable. (Overrides ConnBase..::..Run(SearchRules).)

See Also

ConnFileFixedLenght Class
InitPrtFast.ConnType Namespace


CreateFilterExpression Method

[image]

Libreria query DedNet
ConnFileFixedLenght..::..CreateFilterExpression Method
ConnFileFixedLenght Class See Also Send Feedback
Metodo usato per creare i filtri per la ricerca all'interno del DataView file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected string CreateFilterExpression(
    SearchRules searchRules
)
Visual Basic
Protected Function CreateFilterExpression ( _
    searchRules As SearchRules _
) As String
Visual C++
protected:
String^ CreateFilterExpression(
    SearchRules^ searchRules
)

Parameters

searchRules
Type: InitPrtFast.ConnType..::..SearchRules

Return Value

Stringa per il filtraggio del DataView

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


readLine Method

[image]

Libreria query DedNet
ConnFileFixedLenght..::..readLine Method
ConnFileFixedLenght Class See Also Send Feedback
Legge la linea del file.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void readLine(
    DataTable t,
    string line
)
Visual Basic
Protected Overridable Sub readLine ( _
    t As DataTable, _
    line As String _
)
Visual C++
protected:
virtual void readLine(
    DataTable^ t,
    String^ line
)

Parameters

t
Type: System.Data..::..DataTable
Data table da riempire con i valori della linea.
line
Type: System..::..String
Linea da valutare.

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


Run Method

[image]

Libreria query DedNet
ConnFileFixedLenght..::..Run Method
ConnFileFixedLenght Class See Also Send Feedback
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Run(
    SearchRules search
)
Visual Basic
Public Overrides Sub Run ( _
    search As SearchRules _
)
Visual C++
public:
virtual void Run(
    SearchRules^ search
) override

Parameters

search
Type: InitPrtFast.ConnType..::..SearchRules
Dizionario contenente le coppie colonna - valore da cercare

Return Value

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


ConnFileFixedLenght Properties

[image] [image]

Libreria query DedNet
ConnFileFixedLenght Properties
ConnFileFixedLenght Class See Also Send Feedback

The ConnFileFixedLenght type exposes the following members.

Properties

 | Name | Description
Public property | AutoComplete | (Inherited from ConnBase.)
Public property | Ds | (Inherited from ConnBase.)
Public property | Encoding |
Public property | Fields | (Inherited from ConnBase.)
Public property | FileData |
Public property | Posname | (Inherited from ConnBase.)
Public property | Prompt | (Inherited from ConnBase.)
Public property | RegistryBaseDir | (Inherited from ConnBase.)
Public property | SearchOnEnter | (Inherited from ConnBase.)

See Also

ConnFileFixedLenght Class
InitPrtFast.ConnType Namespace


Encoding Property

[image]

Libreria query DedNet
ConnFileFixedLenght..::..Encoding Property
ConnFileFixedLenght Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnFileFixedLenght.Encoding"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic
Public Property Encoding As Encoding
    Get
    Set
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


FileData Property

[image]

Libreria query DedNet
ConnFileFixedLenght..::..FileData Property
ConnFileFixedLenght Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnFileFixedLenght.FileData"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FileData { get; set; }
Visual Basic
Public Property FileData As String
    Get
    Set
Visual C++
public:
property String^ FileData {
    String^ get ();
    void set (String^ value);
}

See Also

ConnFileFixedLenght Class
ConnFileFixedLenght Members
InitPrtFast.ConnType Namespace


ConnFileSeparator Class

[image]

Libreria query DedNet
ConnFileSeparator Class
Members See Also Send Feedback
Classe che rappresenta la connessione a un file con elementi separati con separatore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConnFileSeparator : ConnFileFixedLenght
Visual Basic
Public Class ConnFileSeparator _
    Inherits ConnFileFixedLenght
Visual C++
public ref class ConnFileSeparator : public ConnFileFixedLenght

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..ConnBase
InitPrtFast.ConnType..::..ConnFileFixedLenght
InitPrtFast.ConnType..::..ConnFileSeparator

See Also

ConnFileSeparator Members
InitPrtFast.ConnType Namespace


ConnFileSeparator Members

[image] [image]

Libreria query DedNet
ConnFileSeparator Members
ConnFileSeparator Class Constructors Methods Fields Properties See Also Send Feedback

The ConnFileSeparator type exposes the following members.

Constructors

 | Name | Description
Public method | ConnFileSeparator | Initializes a new instance of the ConnFileSeparator class

Methods

 | Name | Description
Protected method | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file. (Inherited from ConnFileFixedLenght.)
Protected method | readLine | Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable. (Overrides ConnFileFixedLenght..::..readLine(DataTable, String).)
Public method | Run | Metodo per effettuare la query e riempire la DataTable. (Overrides ConnFileFixedLenght..::..Run(SearchRules).)

Fields

 | Name | Description
Protected field | _ds | Data source (Inherited from ConnBase.)
Protected field | _encoding | Indica il tipo di codifica del file. (Inherited from ConnFileFixedLenght.)
Protected field | _fields | Lista dei campi. (Inherited from ConnBase.)
Protected field | _fileData | Percorso del file contenente le anagrafiche. (Inherited from ConnFileFixedLenght.)
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Inherited from ConnBase.)
Protected field | _prompt | Prompt della connessione. (Inherited from ConnBase.)

Properties

 | Name | Description
Public property | AutoComplete | (Inherited from ConnBase.)
Public property | Ds | (Inherited from ConnBase.)
Public property | Encoding | (Inherited from ConnFileFixedLenght.)
Public property | Fields | (Inherited from ConnBase.)
Public property | FileData | (Inherited from ConnFileFixedLenght.)
Public property | Posname | (Inherited from ConnBase.)
Public property | Prompt | (Inherited from ConnBase.)
Public property | RegistryBaseDir | (Inherited from ConnBase.)
Public property | SearchOnEnter | (Inherited from ConnBase.)
Public property | Separator |

See Also

ConnFileSeparator Class
InitPrtFast.ConnType Namespace


ConnFileSeparator Constructor

[image]

Libreria query DedNet
ConnFileSeparator Constructor
ConnFileSeparator Class See Also Send Feedback
Initializes a new instance of the ConnFileSeparator class

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnFileSeparator(
    string prompt
)
Visual Basic
Public Sub New ( _
    prompt As String _
)
Visual C++
public:
ConnFileSeparator(
    String^ prompt
)

Parameters

prompt
Type: System..::..String

See Also

ConnFileSeparator Class
ConnFileSeparator Members
InitPrtFast.ConnType Namespace


ConnFileSeparator Fields

[image] [image]

Libreria query DedNet
ConnFileSeparator Fields
ConnFileSeparator Class See Also Send Feedback

The ConnFileSeparator type exposes the following members.

Fields

 | Name | Description
Protected field | _ds | Data source (Inherited from ConnBase.)
Protected field | _encoding | Indica il tipo di codifica del file. (Inherited from ConnFileFixedLenght.)
Protected field | _fields | Lista dei campi. (Inherited from ConnBase.)
Protected field | _fileData | Percorso del file contenente le anagrafiche. (Inherited from ConnFileFixedLenght.)
Protected field | _posname | Imposta/Restituice l'indice del campo che da il nome alla parte (Inherited from ConnBase.)
Protected field | _prompt | Prompt della connessione. (Inherited from ConnBase.)

See Also

ConnFileSeparator Class
InitPrtFast.ConnType Namespace


ConnFileSeparator Methods

[image] [image]

Libreria query DedNet
ConnFileSeparator Methods
ConnFileSeparator Class See Also Send Feedback

The ConnFileSeparator type exposes the following members.

Methods

 | Name | Description
Protected method | CreateFilterExpression | Metodo usato per creare i filtri per la ricerca all'interno del DataView file. (Inherited from ConnFileFixedLenght.)
Protected method | readLine | Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable. (Overrides ConnFileFixedLenght..::..readLine(DataTable, String).)
Public method | Run | Metodo per effettuare la query e riempire la DataTable. (Overrides ConnFileFixedLenght..::..Run(SearchRules).)

See Also

ConnFileSeparator Class
InitPrtFast.ConnType Namespace


readLine Method

[image]

Libreria query DedNet
ConnFileSeparator..::..readLine Method
ConnFileSeparator Class See Also Send Feedback
Metodo per leggere le varie linee la singola linea del file e aggiungerla al DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void readLine(
    DataTable t,
    string line
)
Visual Basic
Protected Overrides Sub readLine ( _
    t As DataTable, _
    line As String _
)
Visual C++
protected:
virtual void readLine(
    DataTable^ t,
    String^ line
) override

Parameters

t
Type: System.Data..::..DataTable
DataTable
line
Type: System..::..String
Linea da analizzare.

See Also

ConnFileSeparator Class
ConnFileSeparator Members
InitPrtFast.ConnType Namespace


Run Method

[image]

Libreria query DedNet
ConnFileSeparator..::..Run Method
ConnFileSeparator Class See Also Send Feedback
Metodo per effettuare la query e riempire la DataTable.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Run(
    SearchRules search
)
Visual Basic
Public Overrides Sub Run ( _
    search As SearchRules _
)
Visual C++
public:
virtual void Run(
    SearchRules^ search
) override

Parameters

search
Type: InitPrtFast.ConnType..::..SearchRules

Return Value

See Also

ConnFileSeparator Class
ConnFileSeparator Members
InitPrtFast.ConnType Namespace


ConnFileSeparator Properties

[image] [image]

Libreria query DedNet
ConnFileSeparator Properties
ConnFileSeparator Class See Also Send Feedback

The ConnFileSeparator type exposes the following members.

Properties

 | Name | Description
Public property | AutoComplete | (Inherited from ConnBase.)
Public property | Ds | (Inherited from ConnBase.)
Public property | Encoding | (Inherited from ConnFileFixedLenght.)
Public property | Fields | (Inherited from ConnBase.)
Public property | FileData | (Inherited from ConnFileFixedLenght.)
Public property | Posname | (Inherited from ConnBase.)
Public property | Prompt | (Inherited from ConnBase.)
Public property | RegistryBaseDir | (Inherited from ConnBase.)
Public property | SearchOnEnter | (Inherited from ConnBase.)
Public property | Separator |

See Also

ConnFileSeparator Class
InitPrtFast.ConnType Namespace


Separator Property

[image]

Libreria query DedNet
ConnFileSeparator..::..Separator Property
ConnFileSeparator Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.ConnFileSeparator.Separator"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public char Separator { get; set; }
Visual Basic
Public Property Separator As Char
    Get
    Set
Visual C++
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}

See Also

ConnFileSeparator Class
ConnFileSeparator Members
InitPrtFast.ConnType Namespace


Field Class

[image]

Libreria query DedNet
Field Class
Members See Also Send Feedback
Classe che rappresenta un campo generico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Field
Visual Basic
Public Class Field
Visual C++
public ref class Field

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..Field
InitPrtFast.ConnType..::..FieldFileFixedLenght
InitPrtFast.ConnType..::..FieldFileSeparator

See Also

Field Members
InitPrtFast.ConnType Namespace


Field Members

[image] [image]

Libreria query DedNet
Field Members
Field Class Constructors Properties See Also Send Feedback

The Field type exposes the following members.

Constructors

 | Name | Description
Public method | Field | Costruttore unico.

Properties

 | Name | Description
Public property | DedLink |
Public property | IsResult |
Public property | IsReturn |
Public property | IsSearch |
Public property | List |
Public property | Name |
Public property | Prompt |

See Also

Field Class
InitPrtFast.ConnType Namespace


Field Constructor

[image]

Libreria query DedNet
Field Constructor
Field Class See Also Send Feedback
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Field(
    string prompt,
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList
)
Visual Basic
Public Sub New ( _
    prompt As String, _
    name As String, _
    dedlink As String, _
    isSearch As Boolean, _
    isResult As Boolean, _
    isReturn As Boolean, _
    attList As String() _
)
Visual C++
public:
Field(
    String^ prompt,
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList
)

Parameters

prompt
Type: System..::..String
Prompt del campo.
name
Type: System..::..String
Nome del campo.
dedlink
Type: System..::..String
Nome del campo ded collegato.
isSearch
Type: System..::..Boolean
Indica se è un campo di ricerca
isResult
Type: System..::..Boolean
Indica se è un campo presente nel risultato
isReturn
Type: System..::..Boolean
Indica se è un campo di cui fare tornare il valore
attList
Type: array< System..::..String >[]()[][]
Valori da mostrare nel menù a tendina

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


Field Properties

[image] [image]

Libreria query DedNet
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | DedLink |
Public property | IsResult |
Public property | IsReturn |
Public property | IsSearch |
Public property | List |
Public property | Name |
Public property | Prompt |

See Also

Field Class
InitPrtFast.ConnType Namespace


DedLink Property

[image]

Libreria query DedNet
Field..::..DedLink Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.DedLink"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DedLink { get; }
Visual Basic
Public ReadOnly Property DedLink As String
    Get
Visual C++
public:
property String^ DedLink {
    String^ get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


IsResult Property

[image]

Libreria query DedNet
Field..::..IsResult Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.IsResult"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsResult { get; }
Visual Basic
Public ReadOnly Property IsResult As Boolean
    Get
Visual C++
public:
property bool IsResult {
    bool get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


IsReturn Property

[image]

Libreria query DedNet
Field..::..IsReturn Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.IsReturn"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsReturn { get; }
Visual Basic
Public ReadOnly Property IsReturn As Boolean
    Get
Visual C++
public:
property bool IsReturn {
    bool get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


IsSearch Property

[image]

Libreria query DedNet
Field..::..IsSearch Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.IsSearch"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSearch { get; }
Visual Basic
Public ReadOnly Property IsSearch As Boolean
    Get
Visual C++
public:
property bool IsSearch {
    bool get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


List Property

[image]

Libreria query DedNet
Field..::..List Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.List"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] List { get; }
Visual Basic
Public ReadOnly Property List As String()
    Get
Visual C++
public:
property array<String^>^ List {
    array<String^>^ get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


Name Property

[image]

Libreria query DedNet
Field..::..Name Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


Prompt Property

[image]

Libreria query DedNet
Field..::..Prompt Property
Field Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.Field.Prompt"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Prompt { get; }
Visual Basic
Public ReadOnly Property Prompt As String
    Get
Visual C++
public:
property String^ Prompt {
    String^ get ();
}

See Also

Field Class
Field Members
InitPrtFast.ConnType Namespace


FieldFileFixedLenght Class

[image]

Libreria query DedNet
FieldFileFixedLenght Class
Members See Also Send Feedback
Classe che rappresenta un campo a lunghezza fissa.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FieldFileFixedLenght : Field
Visual Basic
Public Class FieldFileFixedLenght _
    Inherits Field
Visual C++
public ref class FieldFileFixedLenght : public Field

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..Field
InitPrtFast.ConnType..::..FieldFileFixedLenght

See Also

FieldFileFixedLenght Members
InitPrtFast.ConnType Namespace


FieldFileFixedLenght Members

[image] [image]

Libreria query DedNet
FieldFileFixedLenght Members
FieldFileFixedLenght Class Constructors Properties See Also Send Feedback

The FieldFileFixedLenght type exposes the following members.

Constructors

 | Name | Description
Public method | FieldFileFixedLenght | Costruttore unico.

Properties

 | Name | Description
Public property | DedLink | (Inherited from Field.)
Public property | IsResult | (Inherited from Field.)
Public property | IsReturn | (Inherited from Field.)
Public property | IsSearch | (Inherited from Field.)
Public property | Lenght |
Public property | List | (Inherited from Field.)
Public property | Name | (Inherited from Field.)
Public property | Prompt | (Inherited from Field.)
Public property | StartIndex |

See Also

FieldFileFixedLenght Class
InitPrtFast.ConnType Namespace


FieldFileFixedLenght Constructor

[image]

Libreria query DedNet
FieldFileFixedLenght Constructor
FieldFileFixedLenght Class See Also Send Feedback
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FieldFileFixedLenght(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int startIndex,
    int lenght
)
Visual Basic
Public Sub New ( _
    name As String, _
    dedlink As String, _
    isSearch As Boolean, _
    isResult As Boolean, _
    isReturn As Boolean, _
    attList As String(), _
    startIndex As Integer, _
    lenght As Integer _
)
Visual C++
public:
FieldFileFixedLenght(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int startIndex,
    int lenght
)

Parameters

name
Type: System..::..String
Nome del campo.
dedlink
Type: System..::..String
Nome del campo ded collegato.
isSearch
Type: System..::..Boolean
Indica se è un campo di ricerca
isResult
Type: System..::..Boolean
Indica se è un campo presente nel risultato
isReturn
Type: System..::..Boolean
Indica se è un campo di cui fare tornare il valore
attList
Type: array< System..::..String >[]()[][]
Valori da mostrare nel menù a tendina
startIndex
Type: System..::..Int32
Indica l'indice del carattere di partenza del campo.
lenght
Type: System..::..Int32
Indica la lunghezza del campo ( in caratteri )

See Also

FieldFileFixedLenght Class
FieldFileFixedLenght Members
InitPrtFast.ConnType Namespace


FieldFileFixedLenght Properties

[image] [image]

Libreria query DedNet
FieldFileFixedLenght Properties
FieldFileFixedLenght Class See Also Send Feedback

The FieldFileFixedLenght type exposes the following members.

Properties

 | Name | Description
Public property | DedLink | (Inherited from Field.)
Public property | IsResult | (Inherited from Field.)
Public property | IsReturn | (Inherited from Field.)
Public property | IsSearch | (Inherited from Field.)
Public property | Lenght |
Public property | List | (Inherited from Field.)
Public property | Name | (Inherited from Field.)
Public property | Prompt | (Inherited from Field.)
Public property | StartIndex |

See Also

FieldFileFixedLenght Class
InitPrtFast.ConnType Namespace


Lenght Property

[image]

Libreria query DedNet
FieldFileFixedLenght..::..Lenght Property
FieldFileFixedLenght Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.FieldFileFixedLenght.Lenght"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Lenght { get; set; }
Visual Basic
Public Property Lenght As Integer
    Get
    Set
Visual C++
public:
property int Lenght {
    int get ();
    void set (int value);
}

See Also

FieldFileFixedLenght Class
FieldFileFixedLenght Members
InitPrtFast.ConnType Namespace


StartIndex Property

[image]

Libreria query DedNet
FieldFileFixedLenght..::..StartIndex Property
FieldFileFixedLenght Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.FieldFileFixedLenght.StartIndex"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int StartIndex { get; set; }
Visual Basic
Public Property StartIndex As Integer
    Get
    Set
Visual C++
public:
property int StartIndex {
    int get ();
    void set (int value);
}

See Also

FieldFileFixedLenght Class
FieldFileFixedLenght Members
InitPrtFast.ConnType Namespace


FieldFileSeparator Class

[image]

Libreria query DedNet
FieldFileSeparator Class
Members See Also Send Feedback
Classe che rappresenta un campo con separatore.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FieldFileSeparator : Field
Visual Basic
Public Class FieldFileSeparator _
    Inherits Field
Visual C++
public ref class FieldFileSeparator : public Field

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..Field
InitPrtFast.ConnType..::..FieldFileSeparator

See Also

FieldFileSeparator Members
InitPrtFast.ConnType Namespace


FieldFileSeparator Members

[image] [image]

Libreria query DedNet
FieldFileSeparator Members
FieldFileSeparator Class Constructors Properties See Also Send Feedback

The FieldFileSeparator type exposes the following members.

Constructors

 | Name | Description
Public method | FieldFileSeparator | Costruttore unico.

Properties

 | Name | Description
Public property | DedLink | (Inherited from Field.)
Public property | Index |
Public property | IsResult | (Inherited from Field.)
Public property | IsReturn | (Inherited from Field.)
Public property | IsSearch | (Inherited from Field.)
Public property | Lenght |
Public property | List | (Inherited from Field.)
Public property | Name | (Inherited from Field.)
Public property | Prompt | (Inherited from Field.)

See Also

FieldFileSeparator Class
InitPrtFast.ConnType Namespace


FieldFileSeparator Constructor

[image]

Libreria query DedNet
FieldFileSeparator Constructor
FieldFileSeparator Class See Also Send Feedback
Costruttore unico.

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FieldFileSeparator(
    string name,
    string dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    string[] attList,
    int index
)
Visual Basic
Public Sub New ( _
    name As String, _
    dedlink As String, _
    isSearch As Boolean, _
    isResult As Boolean, _
    isReturn As Boolean, _
    attList As String(), _
    index As Integer _
)
Visual C++
public:
FieldFileSeparator(
    String^ name,
    String^ dedlink,
    bool isSearch,
    bool isResult,
    bool isReturn,
    array<String^>^ attList,
    int index
)

Parameters

name
Type: System..::..String
Nome del campo.
dedlink
Type: System..::..String
Nome del campo ded collegato.
isSearch
Type: System..::..Boolean
Indica se è un campo di ricerca
isResult
Type: System..::..Boolean
Indica se è un campo presente nel risultato
isReturn
Type: System..::..Boolean
Indica se è un campo di cui fare tornare il valore
attList
Type: array< System..::..String >[]()[][]
Valori da mostrare nel menù a tendina
index
Type: System..::..Int32
Indica la posizione del campo ( zero-based )

See Also

FieldFileSeparator Class
FieldFileSeparator Members
InitPrtFast.ConnType Namespace


FieldFileSeparator Properties

[image] [image]

Libreria query DedNet
FieldFileSeparator Properties
FieldFileSeparator Class See Also Send Feedback

The FieldFileSeparator type exposes the following members.

Properties

 | Name | Description
Public property | DedLink | (Inherited from Field.)
Public property | Index |
Public property | IsResult | (Inherited from Field.)
Public property | IsReturn | (Inherited from Field.)
Public property | IsSearch | (Inherited from Field.)
Public property | Lenght |
Public property | List | (Inherited from Field.)
Public property | Name | (Inherited from Field.)
Public property | Prompt | (Inherited from Field.)

See Also

FieldFileSeparator Class
InitPrtFast.ConnType Namespace


Index Property

[image]

Libreria query DedNet
FieldFileSeparator..::..Index Property
FieldFileSeparator Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.FieldFileSeparator.Index"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

FieldFileSeparator Class
FieldFileSeparator Members
InitPrtFast.ConnType Namespace


Lenght Property

[image]

Libreria query DedNet
FieldFileSeparator..::..Lenght Property
FieldFileSeparator Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.FieldFileSeparator.Lenght"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Lenght { get; set; }
Visual Basic
Public Property Lenght As Integer
    Get
    Set
Visual C++
public:
property int Lenght {
    int get ();
    void set (int value);
}

See Also

FieldFileSeparator Class
FieldFileSeparator Members
InitPrtFast.ConnType Namespace


FieldList Class

[image]

Libreria query DedNet
FieldList Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:InitPrtFast.ConnType.FieldList"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FieldList : List<Field>
Visual Basic
Public Class FieldList _
    Inherits List(Of Field)
Visual C++
public ref class FieldList : public List<Field^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Field >)>)>
InitPrtFast.ConnType..::..FieldList

See Also

FieldList Members
InitPrtFast.ConnType Namespace


FieldList Members

[image] [image]

Libreria query DedNet
FieldList Members
FieldList Class Constructors See Also Send Feedback

The FieldList type exposes the following members.

Constructors

 | Name | Description
Public method | FieldList | Initializes a new instance of the FieldList class

See Also

FieldList Class
InitPrtFast.ConnType Namespace


FieldList Constructor

[image]

Libreria query DedNet
FieldList Constructor
FieldList Class See Also Send Feedback
Initializes a new instance of the FieldList class

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FieldList()
Visual Basic
Public Sub New
Visual C++
public:
FieldList()

See Also

FieldList Class
FieldList Members
InitPrtFast.ConnType Namespace


SearchRule Class

[image]

Libreria query DedNet
SearchRule Class
Members See Also Send Feedback
Classe che rappresenta un singolo criterio di ricerca

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SearchRule
Visual Basic
Public Class SearchRule
Visual C++
public ref class SearchRule

Inheritance Hierarchy

System..::..Object
InitPrtFast.ConnType..::..SearchRule

See Also

SearchRule Members
InitPrtFast.ConnType Namespace


SearchRule Members

[image] [image]

Libreria query DedNet
SearchRule Members
SearchRule Class Constructors Properties See Also Send Feedback

The SearchRule type exposes the following members.

Constructors

 | Name | Description
Public method | SearchRule | Initializes a new instance of the SearchRule class

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

SearchRule Class
InitPrtFast.ConnType Namespace


SearchRule Constructor

[image]

Libreria query DedNet
SearchRule Constructor
SearchRule Class See Also Send Feedback
Initializes a new instance of the SearchRule class

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchRule()
Visual Basic
Public Sub New
Visual C++
public:
SearchRule()

See Also

SearchRule Class
SearchRule Members
InitPrtFast.ConnType Namespace


SearchRule Properties

[image] [image]

Libreria query DedNet
SearchRule Properties
SearchRule Class See Also Send Feedback

The SearchRule type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

SearchRule Class
InitPrtFast.ConnType Namespace


Name Property

[image]

Libreria query DedNet
SearchRule..::..Name Property
SearchRule Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.SearchRule.Name"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SearchRule Class
SearchRule Members
InitPrtFast.ConnType Namespace


Value Property

[image]

Libreria query DedNet
SearchRule..::..Value Property
SearchRule Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFast.ConnType.SearchRule.Value"]

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

SearchRule Class
SearchRule Members
InitPrtFast.ConnType Namespace


SearchRules Class

[image]

Libreria query DedNet
SearchRules Class
Members See Also Send Feedback
Insieme di criteri di ricerca

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SearchRules : Dictionary<string, SearchRule>
Visual Basic
Public Class SearchRules _
    Inherits Dictionary(Of String, SearchRule)
Visual C++
public ref class SearchRules : public Dictionary<String^, SearchRule^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, SearchRule >)>)>
InitPrtFast.ConnType..::..SearchRules

See Also

SearchRules Members
InitPrtFast.ConnType Namespace


SearchRules Members

[image] [image]

Libreria query DedNet
SearchRules Members
SearchRules Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | SearchRules()()()() | Initializes a new instance of the SearchRules class
Public method | SearchRules(SearchRules) | Initializes a new instance of the SearchRules class

See Also

SearchRules Class
InitPrtFast.ConnType Namespace


SearchRules Constructor

[image] [image]

Libreria query DedNet
SearchRules Constructor
SearchRules Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SearchRules()()()() | Initializes a new instance of the SearchRules class
Public method | SearchRules(SearchRules) | Initializes a new instance of the SearchRules class

See Also

SearchRules Class
SearchRules Members
InitPrtFast.ConnType Namespace


SearchRules Constructor

[image]

Libreria query DedNet
SearchRules Constructor
SearchRules Class See Also Send Feedback
Initializes a new instance of the SearchRules class

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchRules()
Visual Basic
Public Sub New
Visual C++
public:
SearchRules()

See Also

SearchRules Class
SearchRules Members
SearchRules Overload
InitPrtFast.ConnType Namespace


SearchRules Constructor (SearchRules)

[image]

Libreria query DedNet
SearchRules Constructor (SearchRules)
SearchRules Class See Also Send Feedback
Initializes a new instance of the SearchRules class

Namespace: InitPrtFast.ConnType
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchRules(
    SearchRules from
)
Visual Basic
Public Sub New ( _
    from As SearchRules _
)
Visual C++
public:
SearchRules(
    SearchRules^ from
)

Parameters

from
Type: InitPrtFast.ConnType..::..SearchRules

See Also

SearchRules Class
SearchRules Members
SearchRules Overload
InitPrtFast.ConnType Namespace


InitPrtFastForm Namespace

[image]

Libreria query DedNet
InitPrtFastForm Namespace
Send Feedback

Classes

 | Class | Description
Public class | InitPrtFastForm |
Public class | InitPrtFastForm..::..BtnClickEventArgs | Classe contenente le informazioni per l'evento BtnClick.


InitPrtFastForm Class

[image]

Libreria query DedNet
InitPrtFastForm Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:InitPrtFastForm.InitPrtFastForm"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InitPrtFastForm : XtraForm
Visual Basic
Public Class InitPrtFastForm _
    Inherits XtraForm
Visual C++
public ref class InitPrtFastForm : public XtraForm

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
MouseWheelContainerForm
XtraForm
InitPrtFastForm..::..InitPrtFastForm

See Also

InitPrtFastForm Members
InitPrtFastForm Namespace


InitPrtFastForm Members

[image] [image]

Libreria query DedNet
InitPrtFastForm Members
InitPrtFastForm Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The InitPrtFastForm type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFastForm | Costruttore unico.

Methods

 | Name | Description
Protected method | ActivateWindow | (Inherited from XtraForm.)
Public method | AddButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Protected method | CalcClippedRegion | (Inherited from XtraForm.)
Protected method | CalcFormBounds | (Inherited from XtraForm.)
Protected method | CalcPreferredSizeCore | (Inherited from XtraForm.)
Protected method | CheckCustomDrawNonClientArea | (Inherited from XtraForm.)
Protected method | CheckFormAppearanceAsMdiTabPage | (Inherited from XtraForm.)
Protected method | CheckGlassForm | (Inherited from XtraForm.)
Protected method | CheckRightToLeft | (Inherited from XtraForm.)
Protected method | CheckUpdateSkinPainter | (Inherited from XtraForm.)
Protected method | ClientSizeFromSize | (Inherited from XtraForm.)
Protected method | ConstrainMinimumClientSize | (Inherited from XtraForm.)
Protected method | CreateControlsInstance | (Inherited from XtraForm.)
Protected method | CreateDefaultAppearance | (Inherited from XtraForm.)
Protected method | CreateFormBorderPainter | (Inherited from XtraForm.)
Protected method | CreateFormShadow | (Inherited from XtraForm.)
Protected method | CreateHandle | (Inherited from XtraForm.)
Protected method | CreateHelper | (Inherited from XtraForm.)
Protected method | CreateShowingStrategy | (Inherited from XtraForm.)
Protected method | Dispose | Liberare le risorse in uso. (Overrides XtraFormDispose(Boolean).)
Protected method | DrawClientBackground | (Inherited from XtraForm.)
Protected method | DrawClientBackgroundCore | (Inherited from XtraForm.)
Protected method | ForceActivateWindow | (Inherited from XtraForm.)
Protected method | ForceRefresh | (Inherited from XtraForm.)
Protected method | GetAllowMdiFormSkins | (Inherited from XtraForm.)
Protected method | GetAllowSkin | (Inherited from XtraForm.)
Protected method | GetConstrainSize | (Inherited from XtraForm.)
Protected method | GetCreateParams | (Inherited from XtraForm.)
Protected method | GetFormBorderEffect | (Inherited from XtraForm.)
Protected method | GetScaledBounds | (Inherited from XtraForm.)
Protected method | GetScaleFactor | (Inherited from XtraForm.)
Protected method | GetSkinBackgroundImage | (Inherited from XtraForm.)
Protected method | GetSkinBackgroundImageStretch | (Inherited from XtraForm.)
Protected method | GetSkinPainterType | (Inherited from XtraForm.)
Protected method | IsMdiTab | (Inherited from XtraForm.)
Protected method | IsMinimizedState | (Inherited from XtraForm.)
Protected method | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Protected method | OnActiveGlowColorChanged | (Inherited from XtraForm.)
Protected method | OnAppearance_Changed | (Inherited from XtraForm.)
Protected method | OnBtnClick |
Protected method | OnClientSizeChanged | (Inherited from XtraForm.)
Protected method | OnFontChanged | (Inherited from XtraForm.)
Protected method | OnHandleCreated | (Inherited from XtraForm.)
Protected method | OnInactiveGlowColorChanged | (Inherited from XtraForm.)
Protected method | OnLayout | (Inherited from XtraForm.)
Protected method | OnLoad | (Inherited from XtraForm.)
Protected method | OnMaximumClientSizeChanged | (Inherited from XtraForm.)
Protected method | OnMaximumSizeChanged | (Inherited from XtraForm.)
Protected method | OnMdiChildActivate | (Inherited from XtraForm.)
Protected method | OnMdiChildTextChanged | (Inherited from XtraForm.)
Protected method | OnMinimumClientSizeChanged | (Inherited from XtraForm.)
Protected method | OnMinimumSizeChanged | (Inherited from XtraForm.)
Protected method | OnMouseHWheel | (Inherited from MouseWheelContainerForm.)
Protected method | OnMouseWheel | (Inherited from MouseWheelContainerForm.)
Protected method | OnPaint | (Inherited from XtraForm.)
Protected method | OnPaintBackground | (Inherited from XtraForm.)
Protected method | OnParentChanged | (Inherited from XtraForm.)
Protected method | OnShowMdiChildCaptionInParentTitle | (Inherited from XtraForm.)
Protected method | OnShown | (Inherited from XtraForm.)
Protected method | OnSizeChanged | (Inherited from XtraForm.)
Protected method | OnSkinPainterChanged | (Inherited from XtraForm.)
Protected method | OnStyleChanged | (Inherited from XtraForm.)
Protected method | OnTextChanged | (Inherited from XtraForm.)
Protected method | OnTextMdiTabChanged | (Inherited from XtraForm.)
Protected method | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Inherited from XtraForm.)
Protected method | RaiseFormLayoutChanged | (Inherited from XtraForm.)
Public method | ResetBackColor | (Inherited from XtraForm.)
Public method | ResetForeColor | (Inherited from XtraForm.)
Public method | ResumeLayout | (Inherited from XtraForm.)
Public method | ResumeLayout | (Inherited from XtraForm.)
Public method | ResumeRedraw | (Inherited from XtraForm.)
Protected method | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Protected method | ScaleControl | (Inherited from XtraForm.)
Protected method | ScaleCore | (Inherited from XtraForm.)
Protected method | SetBoundsCore | (Inherited from XtraForm.)
Protected method | SetClientSizeCore | (Inherited from XtraForm.)
Public method | SetDataSources | Imposta le sorgenti dati da visualizzare.
Public method | SetDefaultDataSource | Imposta la sorgente dati da pre-selezionare di default.
Protected method | SetLayoutDeferred | (Inherited from XtraForm.)
Protected method | SetVisibleCore | (Inherited from XtraForm.)
Protected method | ShouldDrawClientBackground | (Inherited from XtraForm.)
Protected method | ShouldSerializeBackgroundImageLayoutStore | (Inherited from XtraForm.)
Protected method | ShouldSerializeBackgroundImageStore | (Inherited from XtraForm.)
Protected method | ShouldUpdateFrame | (Inherited from XtraForm.)
Public method | ShowDialog | (Inherited from XtraForm.)
Protected method | SizeFromClientSize | (Inherited from XtraForm.)
Public method | SuspendLayout | (Inherited from XtraForm.)
Public method | SuspendRedraw | (Inherited from XtraForm.)
Protected method | UpdateClientBackgroundBounds | (Inherited from XtraForm.)
Protected method | UpdateSkinPainter | (Inherited from XtraForm.)
Protected method | UpdateSkinPainter | (Inherited from XtraForm.)
Protected method | UpdateWindowThemeCore | (Inherited from XtraForm.)
Protected method | WndProc | (Inherited from XtraForm.)

Fields

 | Name | Description
Protected field | boundsUpdated | (Inherited from XtraForm.)
Protected field | formBounds | (Inherited from XtraForm.)
Protected field | isFormPainted | (Inherited from XtraForm.)
Protected field | lockDrawingClientBackground | (Inherited from XtraForm.)
Protected field | prevFormBounds | (Inherited from XtraForm.)

Properties

 | Name | Description
Public property | ActiveGlowColor | (Inherited from XtraForm.)
Public property | AllowFormSkin | (Inherited from XtraForm.)
Public property | AllowMdiBar | (Inherited from XtraForm.)
Protected property | AllowSkinForEmptyText | (Inherited from XtraForm.)
Public property | Appearance | (Inherited from XtraForm.)
Public property | BackColor | (Inherited from XtraForm.)
Public property | BackgroundImage | (Inherited from XtraForm.)
Public property | BackgroundImageLayout | (Inherited from XtraForm.)
Public property | BackgroundImageLayoutStore | (Inherited from XtraForm.)
Public property | BackgroundImageStore | (Inherited from XtraForm.)
Protected property | CanDrawClientBackground | (Inherited from XtraForm.)
Protected property | ClientBackgroundTop | (Inherited from XtraForm.)
Public property | CloseBox | (Inherited from XtraForm.)
Protected property | CreateParams | (Inherited from XtraForm.)
Public property | ctrInitPrtFast | Restituisce il controllo dell'inizia parte veloce.
Protected property | DefaultAppearance | (Inherited from XtraForm.)
Protected property | DesignModeCore | (Inherited from XtraForm.)
Public property | Font | (Inherited from XtraForm.)
Public property | ForeColor | (Inherited from XtraForm.)
Public property | FormBorderEffect | (Inherited from XtraForm.)
Protected property | FormPainter | (Inherited from XtraForm.)
Protected property | FormShadow | (Inherited from XtraForm.)
Public property | FormTitle | Imposta il titolo della finestra.
Protected property | Helper | (Inherited from XtraForm.)
Public property | HtmlImages | (Inherited from XtraForm.)
Public property | HtmlText | (Inherited from XtraForm.)
Public property | InactiveGlowColor | (Inherited from XtraForm.)
Public property | InizializeInitPrtFast | Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.
Protected property | InvisibleDueShowingStrategy | (Inherited from XtraForm.)
Protected property | IsActive | (Inherited from XtraForm.)
Protected property | IsApplyingLocalizableResourcesInDesignTime | (Inherited from XtraForm.)
Protected property | IsCustomPainter | (Inherited from XtraForm.)
Protected property | IsInitializing | (Inherited from XtraForm.)
Protected property | IsRegionPainted | (Inherited from XtraForm.)
Protected property | IsRibbonForm | (Inherited from XtraForm.)
Protected property | IsRightToLeftCaption | (Inherited from XtraForm.)
Protected property | IsSizableWindow | (Inherited from XtraForm.)
Public property | IsSuspendRedraw | (Inherited from XtraForm.)
Protected property | LayoutSuspendCountCore | (Inherited from XtraForm.)
Public property | LookAndFeel | (Inherited from XtraForm.)
Public property | MaximumClientSize | (Inherited from XtraForm.)
Public property | MaximumSize | (Inherited from XtraForm.)
Public property | MdiChildCaptionFormatString | (Inherited from XtraForm.)
Public property | MinimumClientSize | (Inherited from XtraForm.)
Public property | MinimumSize | (Inherited from XtraForm.)
Protected property | NeedActivateForm | (Inherited from XtraForm.)
Public property | SelectedRow | Restituisce l'insieme delle righe attualmente selezionate.
Protected property | ShouldShowMdiBar | (Inherited from XtraForm.)
Protected property | ShowingStrategy | (Inherited from XtraForm.)
Public property | ShowMdiChildCaptionInParentTitle | (Inherited from XtraForm.)
Protected property | ShowMode | (Inherited from XtraForm.)
Public property | Site | (Inherited from XtraForm.)
Protected property | SupportAdvancedTitlePainting | (Inherited from XtraForm.)
Public property | Text | (Inherited from XtraForm.)
Public property | TextMdiTab | (Inherited from XtraForm.)

Events

 | Name | Description
Public event | BtnClick | Evento sul click del bottone.
Public event | FormLayoutChanged | (Inherited from XtraForm.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Inherited from MouseWheelContainerForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#Control | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Inherited from MouseWheelContainerForm.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Inherited from XtraForm.)

See Also

InitPrtFastForm Class
InitPrtFastForm Namespace


InitPrtFastForm Constructor

[image]

Libreria query DedNet
InitPrtFastForm Constructor
InitPrtFastForm Class See Also Send Feedback
Costruttore unico.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFastForm()
Visual Basic
Public Sub New
Visual C++
public:
InitPrtFastForm()

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


InitPrtFastForm Fields

[image] [image]

Libreria query DedNet
InitPrtFastForm Fields
InitPrtFastForm Class See Also Send Feedback

The InitPrtFastForm type exposes the following members.

Fields

 | Name | Description
Protected field | boundsUpdated | (Inherited from XtraForm.)
Protected field | formBounds | (Inherited from XtraForm.)
Protected field | isFormPainted | (Inherited from XtraForm.)
Protected field | lockDrawingClientBackground | (Inherited from XtraForm.)
Protected field | prevFormBounds | (Inherited from XtraForm.)

See Also

InitPrtFastForm Class
InitPrtFastForm Namespace


InitPrtFastForm Methods

[image] [image]

Libreria query DedNet
InitPrtFastForm Methods
InitPrtFastForm Class See Also Send Feedback

The InitPrtFastForm type exposes the following members.

Methods

 | Name | Description
Protected method | ActivateWindow | (Inherited from XtraForm.)
Public method | AddButton | Metodo che permette di aggiungere un bottone ( da destra a sinistra ).
Protected method | CalcClippedRegion | (Inherited from XtraForm.)
Protected method | CalcFormBounds | (Inherited from XtraForm.)
Protected method | CalcPreferredSizeCore | (Inherited from XtraForm.)
Protected method | CheckCustomDrawNonClientArea | (Inherited from XtraForm.)
Protected method | CheckFormAppearanceAsMdiTabPage | (Inherited from XtraForm.)
Protected method | CheckGlassForm | (Inherited from XtraForm.)
Protected method | CheckRightToLeft | (Inherited from XtraForm.)
Protected method | CheckUpdateSkinPainter | (Inherited from XtraForm.)
Protected method | ClientSizeFromSize | (Inherited from XtraForm.)
Protected method | ConstrainMinimumClientSize | (Inherited from XtraForm.)
Protected method | CreateControlsInstance | (Inherited from XtraForm.)
Protected method | CreateDefaultAppearance | (Inherited from XtraForm.)
Protected method | CreateFormBorderPainter | (Inherited from XtraForm.)
Protected method | CreateFormShadow | (Inherited from XtraForm.)
Protected method | CreateHandle | (Inherited from XtraForm.)
Protected method | CreateHelper | (Inherited from XtraForm.)
Protected method | CreateShowingStrategy | (Inherited from XtraForm.)
Protected method | Dispose | Liberare le risorse in uso. (Overrides XtraFormDispose(Boolean).)
Protected method | DrawClientBackground | (Inherited from XtraForm.)
Protected method | DrawClientBackgroundCore | (Inherited from XtraForm.)
Protected method | ForceActivateWindow | (Inherited from XtraForm.)
Protected method | ForceRefresh | (Inherited from XtraForm.)
Protected method | GetAllowMdiFormSkins | (Inherited from XtraForm.)
Protected method | GetAllowSkin | (Inherited from XtraForm.)
Protected method | GetConstrainSize | (Inherited from XtraForm.)
Protected method | GetCreateParams | (Inherited from XtraForm.)
Protected method | GetFormBorderEffect | (Inherited from XtraForm.)
Protected method | GetScaledBounds | (Inherited from XtraForm.)
Protected method | GetScaleFactor | (Inherited from XtraForm.)
Protected method | GetSkinBackgroundImage | (Inherited from XtraForm.)
Protected method | GetSkinBackgroundImageStretch | (Inherited from XtraForm.)
Protected method | GetSkinPainterType | (Inherited from XtraForm.)
Protected method | IsMdiTab | (Inherited from XtraForm.)
Protected method | IsMinimizedState | (Inherited from XtraForm.)
Protected method | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Protected method | OnActiveGlowColorChanged | (Inherited from XtraForm.)
Protected method | OnAppearance_Changed | (Inherited from XtraForm.)
Protected method | OnBtnClick |
Protected method | OnClientSizeChanged | (Inherited from XtraForm.)
Protected method | OnFontChanged | (Inherited from XtraForm.)
Protected method | OnHandleCreated | (Inherited from XtraForm.)
Protected method | OnInactiveGlowColorChanged | (Inherited from XtraForm.)
Protected method | OnLayout | (Inherited from XtraForm.)
Protected method | OnLoad | (Inherited from XtraForm.)
Protected method | OnMaximumClientSizeChanged | (Inherited from XtraForm.)
Protected method | OnMaximumSizeChanged | (Inherited from XtraForm.)
Protected method | OnMdiChildActivate | (Inherited from XtraForm.)
Protected method | OnMdiChildTextChanged | (Inherited from XtraForm.)
Protected method | OnMinimumClientSizeChanged | (Inherited from XtraForm.)
Protected method | OnMinimumSizeChanged | (Inherited from XtraForm.)
Protected method | OnMouseHWheel | (Inherited from MouseWheelContainerForm.)
Protected method | OnMouseWheel | (Inherited from MouseWheelContainerForm.)
Protected method | OnPaint | (Inherited from XtraForm.)
Protected method | OnPaintBackground | (Inherited from XtraForm.)
Protected method | OnParentChanged | (Inherited from XtraForm.)
Protected method | OnShowMdiChildCaptionInParentTitle | (Inherited from XtraForm.)
Protected method | OnShown | (Inherited from XtraForm.)
Protected method | OnSizeChanged | (Inherited from XtraForm.)
Protected method | OnSkinPainterChanged | (Inherited from XtraForm.)
Protected method | OnStyleChanged | (Inherited from XtraForm.)
Protected method | OnTextChanged | (Inherited from XtraForm.)
Protected method | OnTextMdiTabChanged | (Inherited from XtraForm.)
Protected method | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Inherited from XtraForm.)
Protected method | RaiseFormLayoutChanged | (Inherited from XtraForm.)
Public method | ResetBackColor | (Inherited from XtraForm.)
Public method | ResetForeColor | (Inherited from XtraForm.)
Public method | ResumeLayout | (Inherited from XtraForm.)
Public method | ResumeLayout | (Inherited from XtraForm.)
Public method | ResumeRedraw | (Inherited from XtraForm.)
Protected method | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Protected method | ScaleControl | (Inherited from XtraForm.)
Protected method | ScaleCore | (Inherited from XtraForm.)
Protected method | SetBoundsCore | (Inherited from XtraForm.)
Protected method | SetClientSizeCore | (Inherited from XtraForm.)
Public method | SetDataSources | Imposta le sorgenti dati da visualizzare.
Public method | SetDefaultDataSource | Imposta la sorgente dati da pre-selezionare di default.
Protected method | SetLayoutDeferred | (Inherited from XtraForm.)
Protected method | SetVisibleCore | (Inherited from XtraForm.)
Protected method | ShouldDrawClientBackground | (Inherited from XtraForm.)
Protected method | ShouldSerializeBackgroundImageLayoutStore | (Inherited from XtraForm.)
Protected method | ShouldSerializeBackgroundImageStore | (Inherited from XtraForm.)
Protected method | ShouldUpdateFrame | (Inherited from XtraForm.)
Public method | ShowDialog | (Inherited from XtraForm.)
Protected method | SizeFromClientSize | (Inherited from XtraForm.)
Public method | SuspendLayout | (Inherited from XtraForm.)
Public method | SuspendRedraw | (Inherited from XtraForm.)
Protected method | UpdateClientBackgroundBounds | (Inherited from XtraForm.)
Protected method | UpdateSkinPainter | (Inherited from XtraForm.)
Protected method | UpdateSkinPainter | (Inherited from XtraForm.)
Protected method | UpdateWindowThemeCore | (Inherited from XtraForm.)
Protected method | WndProc | (Inherited from XtraForm.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Inherited from MouseWheelContainerForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Inherited from XtraForm.)

See Also

InitPrtFastForm Class
InitPrtFastForm Namespace


AddButton Method

[image]

Libreria query DedNet
InitPrtFastForm..::..AddButton Method
InitPrtFastForm Class See Also Send Feedback
Metodo che permette di aggiungere un bottone ( da destra a sinistra ).

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddButton(
    string text,
    string tagText
)
Visual Basic
Public Sub AddButton ( _
    text As String, _
    tagText As String _
)
Visual C++
public:
void AddButton(
    String^ text,
    String^ tagText
)

Parameters

text
Type: System..::..String
Testo da visuelaizzare sul bottone.
tagText
Type: System..::..String
Testo usato come tag del bottone.

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


Dispose Method

[image]

Libreria query DedNet
InitPrtFastForm..::..Dispose Method
InitPrtFastForm Class See Also Send Feedback
Liberare le risorse in uso.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


LoadSizeAndPosition Method

[image]

Libreria query DedNet
InitPrtFastForm..::..LoadSizeAndPosition Method
InitPrtFastForm Class See Also Send Feedback
Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void LoadSizeAndPosition()
Visual Basic
Protected Sub LoadSizeAndPosition
Visual C++
protected:
void LoadSizeAndPosition()

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


OnBtnClick Method

[image]

Libreria query DedNet
InitPrtFastForm..::..OnBtnClick Method
InitPrtFastForm Class See Also Send Feedback

[Missing <summary> documentation for "M:InitPrtFastForm.InitPrtFastForm.OnBtnClick(System.Object,InitPrtFastForm.InitPrtFastForm.BtnClickEventArgs)"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnBtnClick(
    Object sender,
    InitPrtFastForm..::..BtnClickEventArgs ev
)
Visual Basic
Protected Sub OnBtnClick ( _
    sender As Object, _
    ev As InitPrtFastForm..::..BtnClickEventArgs _
)
Visual C++
protected:
void OnBtnClick(
    Object^ sender,
    InitPrtFastForm..::..BtnClickEventArgs^ ev
)

Parameters

sender
Type: System..::..Object
ev
Type: InitPrtFastForm..::..InitPrtFastForm..::..BtnClickEventArgs

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


SaveSizeAndPosition Method

[image]

Libreria query DedNet
InitPrtFastForm..::..SaveSizeAndPosition Method
InitPrtFastForm Class See Also Send Feedback
Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void SaveSizeAndPosition()
Visual Basic
Protected Sub SaveSizeAndPosition
Visual C++
protected:
void SaveSizeAndPosition()

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


SetDataSources Method

[image]

Libreria query DedNet
InitPrtFastForm..::..SetDataSources Method
InitPrtFastForm Class See Also Send Feedback
Imposta le sorgenti dati da visualizzare.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDataSources(
    List<ConnBase> sources
)
Visual Basic
Public Sub SetDataSources ( _
    sources As List(Of ConnBase) _
)
Visual C++
public:
void SetDataSources(
    List<ConnBase^>^ sources
)

Parameters

sources
Type: System.Collections.Generic..::..List <(Of <(<' ConnBase >)>)>
Lista di sorgenti dati.

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


SetDefaultDataSource Method

[image]

Libreria query DedNet
InitPrtFastForm..::..SetDefaultDataSource Method
InitPrtFastForm Class See Also Send Feedback
Imposta la sorgente dati da pre-selezionare di default.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDefaultDataSource(
    string sourceName
)
Visual Basic
Public Sub SetDefaultDataSource ( _
    sourceName As String _
)
Visual C++
public:
void SetDefaultDataSource(
    String^ sourceName
)

Parameters

sourceName
Type: System..::..String
Nome della sorgente dati da pre-selezionare.

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


InitPrtFastForm Properties

[image] [image]

Libreria query DedNet
InitPrtFastForm Properties
InitPrtFastForm Class See Also Send Feedback

The InitPrtFastForm type exposes the following members.

Properties

 | Name | Description
Public property | ActiveGlowColor | (Inherited from XtraForm.)
Public property | AllowFormSkin | (Inherited from XtraForm.)
Public property | AllowMdiBar | (Inherited from XtraForm.)
Protected property | AllowSkinForEmptyText | (Inherited from XtraForm.)
Public property | Appearance | (Inherited from XtraForm.)
Public property | BackColor | (Inherited from XtraForm.)
Public property | BackgroundImage | (Inherited from XtraForm.)
Public property | BackgroundImageLayout | (Inherited from XtraForm.)
Public property | BackgroundImageLayoutStore | (Inherited from XtraForm.)
Public property | BackgroundImageStore | (Inherited from XtraForm.)
Protected property | CanDrawClientBackground | (Inherited from XtraForm.)
Protected property | ClientBackgroundTop | (Inherited from XtraForm.)
Public property | CloseBox | (Inherited from XtraForm.)
Protected property | CreateParams | (Inherited from XtraForm.)
Public property | ctrInitPrtFast | Restituisce il controllo dell'inizia parte veloce.
Protected property | DefaultAppearance | (Inherited from XtraForm.)
Protected property | DesignModeCore | (Inherited from XtraForm.)
Public property | Font | (Inherited from XtraForm.)
Public property | ForeColor | (Inherited from XtraForm.)
Public property | FormBorderEffect | (Inherited from XtraForm.)
Protected property | FormPainter | (Inherited from XtraForm.)
Protected property | FormShadow | (Inherited from XtraForm.)
Public property | FormTitle | Imposta il titolo della finestra.
Protected property | Helper | (Inherited from XtraForm.)
Public property | HtmlImages | (Inherited from XtraForm.)
Public property | HtmlText | (Inherited from XtraForm.)
Public property | InactiveGlowColor | (Inherited from XtraForm.)
Public property | InizializeInitPrtFast | Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.
Protected property | InvisibleDueShowingStrategy | (Inherited from XtraForm.)
Protected property | IsActive | (Inherited from XtraForm.)
Protected property | IsApplyingLocalizableResourcesInDesignTime | (Inherited from XtraForm.)
Protected property | IsCustomPainter | (Inherited from XtraForm.)
Protected property | IsInitializing | (Inherited from XtraForm.)
Protected property | IsRegionPainted | (Inherited from XtraForm.)
Protected property | IsRibbonForm | (Inherited from XtraForm.)
Protected property | IsRightToLeftCaption | (Inherited from XtraForm.)
Protected property | IsSizableWindow | (Inherited from XtraForm.)
Public property | IsSuspendRedraw | (Inherited from XtraForm.)
Protected property | LayoutSuspendCountCore | (Inherited from XtraForm.)
Public property | LookAndFeel | (Inherited from XtraForm.)
Public property | MaximumClientSize | (Inherited from XtraForm.)
Public property | MaximumSize | (Inherited from XtraForm.)
Public property | MdiChildCaptionFormatString | (Inherited from XtraForm.)
Public property | MinimumClientSize | (Inherited from XtraForm.)
Public property | MinimumSize | (Inherited from XtraForm.)
Protected property | NeedActivateForm | (Inherited from XtraForm.)
Public property | SelectedRow | Restituisce l'insieme delle righe attualmente selezionate.
Protected property | ShouldShowMdiBar | (Inherited from XtraForm.)
Protected property | ShowingStrategy | (Inherited from XtraForm.)
Public property | ShowMdiChildCaptionInParentTitle | (Inherited from XtraForm.)
Protected property | ShowMode | (Inherited from XtraForm.)
Public property | Site | (Inherited from XtraForm.)
Protected property | SupportAdvancedTitlePainting | (Inherited from XtraForm.)
Public property | Text | (Inherited from XtraForm.)
Public property | TextMdiTab | (Inherited from XtraForm.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | DevExpress#XtraEditors#IDXControl#Control | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Inherited from MouseWheelContainerForm.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Inherited from XtraForm.)
Explicit interface implemetation | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Inherited from XtraForm.)

See Also

InitPrtFastForm Class
InitPrtFastForm Namespace


ctrInitPrtFast Property

[image]

Libreria query DedNet
InitPrtFastForm..::..ctrInitPrtFast Property
InitPrtFastForm Class See Also Send Feedback
Restituisce il controllo dell'inizia parte veloce.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast ctrInitPrtFast { get; }
Visual Basic
Public ReadOnly Property ctrInitPrtFast As InitPrtFast
    Get
Visual C++
public:
property InitPrtFast^ ctrInitPrtFast {
    InitPrtFast^ get ();
}

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


FormTitle Property

[image]

Libreria query DedNet
InitPrtFastForm..::..FormTitle Property
InitPrtFastForm Class See Also Send Feedback
Imposta il titolo della finestra.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FormTitle { set; }
Visual Basic
Public WriteOnly Property FormTitle As String
    Set
Visual C++
public:
property String^ FormTitle {
    void set (String^ value);
}

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


InizializeInitPrtFast Property

[image]

Libreria query DedNet
InitPrtFastForm..::..InizializeInitPrtFast Property
InitPrtFastForm Class See Also Send Feedback
Inizializza il controllo dell'inizia parte veloce chiamando la funzione lua InizializeInitPrtFast con parametro caller uguale al valore passato.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string InizializeInitPrtFast { set; }
Visual Basic
Public WriteOnly Property InizializeInitPrtFast As String
    Set
Visual C++
public:
property String^ InizializeInitPrtFast {
    void set (String^ value);
}

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


SelectedRow Property

[image]

Libreria query DedNet
InitPrtFastForm..::..SelectedRow Property
InitPrtFastForm Class See Also Send Feedback
Restituisce l'insieme delle righe attualmente selezionate.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InitPrtFast..::..Rows SelectedRow { get; }
Visual Basic
Public ReadOnly Property SelectedRow As InitPrtFast..::..Rows
    Get
Visual C++
public:
property InitPrtFast..::..Rows^ SelectedRow {
    InitPrtFast..::..Rows^ get ();
}

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


InitPrtFastForm Events

[image] [image]

Libreria query DedNet
InitPrtFastForm Events
InitPrtFastForm Class See Also Send Feedback

The InitPrtFastForm type exposes the following members.

Events

 | Name | Description
Public event | BtnClick | Evento sul click del bottone.
Public event | FormLayoutChanged | (Inherited from XtraForm.)

See Also

InitPrtFastForm Class
InitPrtFastForm Namespace


BtnClick Event

[image]

Libreria query DedNet
InitPrtFastForm..::..BtnClick Event
InitPrtFastForm Class See Also Send Feedback
Evento sul click del bottone.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<InitPrtFastForm..::..BtnClickEventArgs> BtnClick
Visual Basic
Public Event BtnClick As EventHandler(Of InitPrtFastForm..::..BtnClickEventArgs)
Visual C++
public:
 event EventHandler<InitPrtFastForm..::..BtnClickEventArgs^>^ BtnClick {
    void add (EventHandler<InitPrtFastForm..::..BtnClickEventArgs^>^ value);
    void remove (EventHandler<InitPrtFastForm..::..BtnClickEventArgs^>^ value);
}

See Also

InitPrtFastForm Class
InitPrtFastForm Members
InitPrtFastForm Namespace


InitPrtFastForm.BtnClickEventArgs Class

[image]

Libreria query DedNet
InitPrtFastForm..::..BtnClickEventArgs Class
InitPrtFastForm Class Members See Also Send Feedback
Classe contenente le informazioni per l'evento BtnClick.

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BtnClickEventArgs : EventArgs
Visual Basic
Public Class BtnClickEventArgs _
    Inherits EventArgs
Visual C++
public ref class BtnClickEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
InitPrtFastForm..::..InitPrtFastForm..::..BtnClickEventArgs

See Also

InitPrtFastForm..::..BtnClickEventArgs Members
InitPrtFastForm Namespace


InitPrtFastForm.BtnClickEventArgs Members

[image] [image]

Libreria query DedNet
InitPrtFastForm..::..BtnClickEventArgs Members
InitPrtFastForm..::..BtnClickEventArgs Class Constructors Properties See Also Send Feedback

The InitPrtFastForm..::..BtnClickEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InitPrtFastForm..::..BtnClickEventArgs | Initializes a new instance of the InitPrtFastForm..::..BtnClickEventArgs class

Properties

 | Name | Description
Public property | BtnTag |

See Also

InitPrtFastForm..::..BtnClickEventArgs Class
InitPrtFastForm Namespace


InitPrtFastForm.BtnClickEventArgs Constructor

[image]

Libreria query DedNet
InitPrtFastForm..::..BtnClickEventArgs Constructor
InitPrtFastForm..::..BtnClickEventArgs Class See Also Send Feedback
Initializes a new instance of the InitPrtFastForm..::..BtnClickEventArgs class

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BtnClickEventArgs(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)
Visual C++
public:
BtnClickEventArgs(
    String^ text
)

Parameters

text
Type: System..::..String

See Also

InitPrtFastForm..::..BtnClickEventArgs Class
InitPrtFastForm..::..BtnClickEventArgs Members
InitPrtFastForm Namespace


InitPrtFastForm.BtnClickEventArgs Properties

[image] [image]

Libreria query DedNet
InitPrtFastForm..::..BtnClickEventArgs Properties
InitPrtFastForm..::..BtnClickEventArgs Class See Also Send Feedback

The InitPrtFastForm..::..BtnClickEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | BtnTag |

See Also

InitPrtFastForm..::..BtnClickEventArgs Class
InitPrtFastForm Namespace


BtnTag Property

[image]

Libreria query DedNet
InitPrtFastForm..::..BtnClickEventArgs..::..BtnTag Property
InitPrtFastForm..::..BtnClickEventArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:InitPrtFastForm.InitPrtFastForm.BtnClickEventArgs.BtnTag"]

Namespace: InitPrtFastForm
Assembly: InitPrtFast (in InitPrtFast.dll) Versione: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string BtnTag { get; internal set; }
Visual Basic
Public Property BtnTag As String
    Get
    Friend Set
Visual C++
public:
property String^ BtnTag {
    String^ get ();
    internal: void set (String^ value);
}

See Also

InitPrtFastForm..::..BtnClickEventArgs Class
InitPrtFastForm..::..BtnClickEventArgs Members
InitPrtFastForm Namespace